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Using the Image Print Server
(IPS) Software with the

KODAK PROFESSIONAL LED II
Printers 20P/20R

This document describes how to use the Kodak Professional Image Print Server 
(IPS) application for Windows NT Workstation 4.0 Systems with the Kodak 
Professional LED II Printers 20P and 20R.

The IPS application enables printing of TIFF images and provides easy, intuitive 
methods for performing simple print management operations that include:

• applying a tone scale correction to images

• inserting new images into the print queue

• stopping or suspending and resuming the processing

• deleting images from the queue

In addition, the IPS application allows you to monitor a specified folder for TIFF 
images to add to the print queue.

Communication Channels

Your computer can print to the LED Printer through a SCSI connection only.
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Definitions of Terms
The following terms are used in this document and are defined here for your 
convenience.

Source Directory Folder or directory that is designated for holding TIFF 
images to be printed.

Hot Folder Another term for Source Directory.

Attended Mode The mode in which all errors are displayed through a 
dialog box. When the application is in Attended Mode, it 
stops until you exit the dialog box.

Unattended Mode The mode in which the only errors that are displayed in 
dialog boxes are the errors that require user intervention. 
Errors that do not require user intervention, such as 
invalid file format, are logged in the log file.

Enqueue Insert a new image into the print queue.

Dequeue Remove one image from the print queue. Only the top 
entry in the queue is removed.

Flush Remove all images from the print queue.

Suspend Prevent the application from sending another image to 
the printer until the application resumes. When you select 
Suspend, if an image is processing or going to the 
printer, this image will complete before the application 
suspends. When the application is suspended, it will not 
scan for images in the hot folder.

Resume Return the application to normal operation.

Order Punch An indicator on a print to specify that it is the end of an 
order.

Tiff Downloader Another term for the Image Print Server (IPS) application.
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Installing the IPS Application
Before you perform the installation, make certain you are familiar with the 
Windows NT operating system.

Hardware Requirements
The following is the minimum hardware required for the IPS application:

• 64 MB Main System Memory

• 100 MHz PENTIUM Processor

• VGA Monitor (640 x 480 spatial resolution)

Software Requirements
The following must be installed on your computer:

• Windows NT Workstation 4.0

• An ASPI-compliant SCSI interface driver (recommended: Adaptec 2940 SCSI 
card)

Installing the Software

Downloading the Installation Application

1. Place the IPS application CD in your CD-ROM drive.

2. When the Internet Browser appears, select LED Printer.

3. Scroll to Image Print Server and click KPROImagePrintServer.

4. If a dialog box appears asking if you want to “save this program to disk” 
accept the dialog box (do not launch the program from the browser).

The Save As... dialog box appears.

5. Either accept the path shown or click Browse to select another path for the 
KProImagePrintServer.exe file.

6. Click Save.
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Installing the Application

1. From your Windows Explorer program, double-click the Image Print Server 
application (from the location designated in step 5 under “Downloading the 
Installation Application” on page 3).
The splash screen and setup messages appear.
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The Welcome screen appears.

2. Click Next>.
The License Agreement screen appears.
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3. Read the License Agreement.
• To accept the license agreement, click Yes.
• Or, to cancel the installation, click No.
The Readme information appears.

4. Click Next>.
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The Choose Destination Location dialog box appears, showing the 
destination folder and file name for the IPS application.

The default installation location for both the application and the tone scale 
correction Lookup Table (LUT) that can be used by the IPS application is 
“C:\Eastman Kodak\KPro Applications\Image Print Server.”

5. Either:

a. Leave the destination as is and click Next> or 

b. Click Browse, change the destination, and then click Next>.
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The Setup Complete screen appears.

6. Click Finish to complete the installation.
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Using the Image Print Server 

Before You Begin

When you begin using this application, you need to set Source Directory 
Preferences (see page 14). To do this you need to: 

• know whether printer calibration was performed using Density aims or 
Lightness aims; this will determine whether you apply tone scale correction

• set up a log file on your host computer so the application can log errors

• designate a Source Directory (or hot folder) on your host computer, even if 
you do not send images from the Source Directory and you only enqueue 
(see “Definitions of Terms” on page 2) images one at a time

IMPORTANT:Set up the Source Directory for one use only—as a temporary 
source of images. Do not specify a directory that contains images 
that you want to keep. Once the images are processed from the 
Source Directory, they are deleted from that directory.

Do not specify as a Source Directory any directory that is on a 
read-only volume.

If you will be adding any print devices, you need to know the number of the SCSI 
Host Adapter and the SCSI ID for the devices.

Starting the IPS Application
• From the Start menu of the host computer, select Programs>Eastman 

Kodak>KPro Applications>KODAK PROFESSIONAL Image Print Server.
The display shows the IPS Launcher window.

Add a device if no device icon is in the window or if there is no icon for the 
device from which you want to print. You can also update or delete the device 
information.

If you do not need to add, update, or delete a device, go to page 13.
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Adding, Updating, or Deleting a Printer Device

Adding a Device

1. Click the New icon on the IPS Launcher window or select File>New.

The display shows the Create a New Device screen.

2. Enter a unique identifier as the device name. The device name must be 
alphanumeric with no spaces or special characters. It can contain as many as 
10 characters.

3. Enter the correct SCSI ID information.
The factory default is 5 for LED.

NOTE: The value for SCSI Host Adapter is typically 1. Select another value 
only if necessary.

4. Select the correct Device Type from the menu to correspond to either the 
Digital LED Printer, the Kodak Professional Digital Multiprinter, or the Kodak 
Professional Digital Multiprinter II.
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5. Click OK to accept the information (or click Cancel to go to the IPS Launcher 
window without adding a device).
A new device icon appears on the IPS Launcher window.

Updating the Device Name, SCSI Host Adapter, or SCSI ID

1. On the IPS Launcher window, select the icon for the device to update and 
click the Edit icon or select File>Edit.

The display shows:

2. Edit the Device Name, SCSI Host Adapter, or SCSI ID.

Device is 
selected
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3. Click OK to save the changes (or click Cancel to ignore the changes and go 
to the IPS Launcher window).

Deleting a Device

To delete a device and all files associated with the device:

1. On the IPS Launcher window, select the icon for the device you want to delete 
and click the Cut icon or select Edit>Cut.

The display shows:

2. Select Yes to delete the device and associated files (select No to go to the 
IPS Launcher window).
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Printing Images

To print images, you:

• select the device from which to print

• start the IPS application for the selected device

• set the Source Directory preferences for the selected device, if not already 
done

• place images in the print queue

• wait for the images to print

1. Select the device from which to print.

2. Click the Start IPS icon (or double-click the icon for the selected device).

The following main menu appears.

Selected 
device icon
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Description of Icons on the Main Menu

The icons and their associated menu items allow you to choose the following 
options:

Setting the Source Directory Preferences for a Device

1. Select Server>Defaults from the IPS main menu.

Menu 
Access

Menu 
Item

Icon Description/Function

File Enqueue Displays the Enqueue dialog box and allows you to insert a new 
image into the print queue.

Dequeue Allows you to remove the top entry from the print queue.

Server Suspend Stops the operation of the application. If an image is processing or 
going to the printer, the operation on this image will complete before 
the application suspends.

Resume Resumes the operation of the application; Resume is active only 
when the system is suspended and can only be used if the server 
defaults were initialized (Source Directory preferences were set).

Flush Allows you to delete all entries from the print queue.

Help About Displays the About box that includes version information about the 
Kodak Professional Image Print Server.
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The Source Directory Preferences dialog box appears.

2. Type the Source Directory name or click Browse to select the Source 
Directory where the TIFF images will be placed.

3. Type the Log File name or click Browse to select the Log File where printer 
error information is to be stored. The log file applies to all devices for the 
application. To edit the log file information, go to “Editing Log File Information” 
on page 16.

4. Enter the number of copies to print of each image in the Source Directory. 
Valid numbers are from 1 through 9999. The default value is 1.

5. Select the Printer Resolution:
• The default value is 250 ppi; when you select 250 ppi, each image is 

printed pixel for pixel.
• When you select 125 ppi, the printer’s hardware pixel replication capability 

is enabled.

6. Select the Print Production:
• To print immediately, click the button next to Immediate.
• To print later, click the button next to Deferred.

7. Select the Roll to Roll Options:
• If each image is the end of an order, click the box next to Order Punch.
• If you want a punch .25 in. inside each image area to mark a gutter for host 

image information, click the box next to ID Punch.
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8. To center each image on the paper, leave the Center image box checked. If 
you do not want to center images, click to “uncheck” the box.

To ensure that the complete image file is exposed on the paper, Kodak 
recommends that you always check “Center image.”

9. If the LED Printer was calibrated using Density, you can apply Tone Scale 
Correction with the g22_fullrange.txt file in the LUTs folder supplied with the 
IPS application.
To apply tone scale correction:

a. Type the path and name of the Correction File or click Browse to select 
the Correction File to be applied to each image.

b. Click the box next to Apply to apply the designated Correction File to each 
image.

10. When the dialog box is complete, click OK to close the dialog box and save 
the specified values (or click Cancel to close the dialog box without saving the 
values).

Editing Log File Information

Do this only when you need to edit information about the error log file.

1. With no device selected, select File>Edit from the IPS Launcher window.

The Edit Configuration dialog box appears.

2. Make changes as needed to either the Log Type, number of days to keep log, 
or the Log File Name.

3. Click OK to accept changes (or click Cancel to cancel changes).
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Placing Images in the Print Queue

You can submit images by:

• placing images in the “hot folder” (the Source Directory in the Source 
Directory Preferences dialog box)

• using the enqueue function on the application menu bar

Using Source Directory Insertion

When you place images in the Source Directory, they are automatically placed in 
the print queue. The images are sorted by the date and time they were placed in 
the Source Directory and printed in that order.

IMPORTANT: After the image goes to the printer, the file is removed from the 
Source Directory.

NOTE: The properties of the images placed in the Source Directory are taken 
from the Source Directory Preferences dialog box.

Using the Enqueue Function

To enqueue a single image from the menu bar:

1. Click the Enqueue icon or select File>Enqueue.
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The Enqueue dialog box appears.

NOTE: The Enqueue and the Source Directory Preferences dialog boxes look 
almost identical, but they affect different image files. The information 
in each dialog is independent of the other.

2. Type the Image File path and name or click Browse to select the TIFF Image 
File to be printed.

3. Enter the number of copies of the image to print. Valid numbers are from 1 
through 9999. The default value is 1.

4. Select the Printer Resolution: 
• The default value is 250 ppi; when you select 250 ppi, the image is printed 

pixel for pixel.
• When you select 125 ppi, the printer’s hardware pixel replication capability 

is enabled.

5. Select the Print Production:
• To print immediately, click the button next to Immediate.
• To print later, click the button next to Deferred.

6. Select the Roll to Roll Options:
• If the image is the end of an order, click the box next to Order Punch.
• If you want a punch .25 in. inside the image area to mark a gutter for host 

image information, click the box next to ID Punch.

7. To center the image on the paper, leave the Center image box checked. If 
you do not want to center the image, click to “uncheck” the box.

To ensure that the complete image file is exposed on the paper, Kodak 
recommends that you always check “Center image.”
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8. If the LED Printer was calibrated using Density, you may apply Tone Scale 
Correction with the g22_fullrange.txt file in the LUTs folder supplied with the 
IPS application.
To apply tone scale correction:

a. Type the path and file name of the Correction File or click Browse to 
select the Correction File to be applied to each image.

b. Click the box next to Apply to apply the designated Correction File to each 
image.

9. When the dialog box is complete, click OK to close the dialog box and save 
the specified values (or click Cancel to close the dialog box without saving the 
values).

NOTES: You cannot enqueue a file that is in process. Wait until the file is 
completely processed before you access the file again.

Images placed in the queue by using the Enqueue function are not 
removed from their original directory after they are sent to the printer.

Removing Images from the Print Queue

Removing the Top Image from the Queue

1. Click the Dequeue icon or select File>Dequeue.
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A dialog box appears.

2. Click OK to delete the first job (or click Cancel to cancel the deletion).
The job at the top of the list is deleted from the print queue.

NOTE: Before you can delete an image from the print queue, the application 
must be suspended and all jobs in progress must be complete

Removing All Images from the Print Queue

1. Click the Flush icon or select Server>Flush.

A dialog box appears.

2. Click OK to delete all jobs (or click Cancel to cancel the deletion).
All jobs are deleted from the print queue.

NOTE: Before you can delete an image from the print queue, the application 
must be suspended and all jobs in progress must be complete.
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Suspending and Resuming the IPS Application
When the IPS application starts, it looks for Source Directory Preferences.

If these preferences are initialized, the application will start in the “running” state—
as if the Resume icon was selected.

If the preferences are not initialized, the application is in the “suspended” state—
as if the Suspend icon was selected.

Suspending the IPS Application

To suspend the IPS application, select the Suspend icon or select 
Server>Suspend.

Resuming the IPS Application after a Suspension

To resume the IPS application, select the Resume icon or select Server>Resume.
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If the preferences were not initialized, the dialog box below appears.

After you select OK, the Source Directory Preferences dialog box appears and the 
application remains suspended until the preferences are initialized. See “Setting 
the Source Directory Preferences for a Device” on page 14.

Failed Jobs
When an image fails to go to the printer for any reason, an appropriate error 
message is appended to the log. The log file is specified in the Source Directory 
Preferences dialog box.

Images in the Source Directory (hot folder) are moved to the FailedJobs 
Directory. The FailedJobs Directory is created as a subdirectory within the 
Source Directory when the first failure occurs.

Images that fail and were not inserted through the Source Directory (that is, they 
were inserted with the Enqueue icon or menu item) are not moved to the 
FailedJobs Directory.

Attended and Unattended Modes
The IPS application allows you to operate in the Attended or Unattended mode.

In Attended mode, all errors are displayed in dialog boxes. The IPS application is 
halted until you respond to the message.

In Unattended mode, only errors that require user intervention are displayed in 
dialog boxes. Errors that do not require user intervention, such as an invalid file 
format, are logged in the log file.

In both Attended and Unattended modes, all errors are written to the log file.

NOTE: If a communication error occurs while the file is going to the printer, the 
image may not be printed. In addition, jobs that fail to print from the Source 
Directory (hot folder) are copied to the failed jobs directory.
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To determine if the IPS application is running in Attended mode, pull down the 
Server menu.

If the bullet appears next to Attended, the application is running in attended mode.

• To disable attended mode, select the Server>Attended menu item.

If no bullet appears next to Attended, the application is not running in attended 
mode.

• To enable attended mode, select the Server>Attended menu item.

 Application is in 
Attended mode

 Application is not in 
Attended mode
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File Format Details
The data portion of the TIFF file must contain RGB byte interleaved data.

Supported Tags
The Image Print Server supports the TIFF tags listed below. The range of valid 
values for TIFF tags 256, 257, 258, 273, 278 and 279 are image dependent and 
are indicated by a “*” in the Valid Range column. If these values are incorrect, an 
error will occur when the application is reading the image data and an appropriate 
error message will be placed in the log file.

*indicates an image-dependent value

LZW Compression
The IPS application does not support LZW compression.

TIFF Tag ID Name Valid Range

256 Image Width *
257 Image Length *
258 Bits per Sample *
259 Compression 1
262 Photometric Interpretation 2
273 Strip Offset *
277 Samples per Pixel 3
278 Rows per Strip *
279 Strip Byte Count *
284 Planar Configuration 1
24 December 2000



Index

A
adding a print device 10 to 11
attended mode of IPS application 22 to 23

defined 2

C
centering image on the paper 16, 18
communication channels, SCSI 1
copies to print, number of 15, 18

D
Defaults menu item (Server menu) 14
deferred printing option 15, 18
deleting a print device 12
dequeue function 2, 14

using 19 to 20
description of icons on the LED IPS main menu 14
devices, print 10 to 12

adding 10 to 11
deleting 12
updating 11 to 12

E
end of order, specifying 15, 18
enqueue function 2, 14

using 17 to 19

F
failed jobs directory 22
file formats, image files 24
flushing images from the print queue 20

defined 2
icon and menu item defined 14

H
hardware requirements 3
hot folder. see also source directory 2

I
icons on LED IPS main menu 14
ID punch to mark a gutter 15, 18
image file in Enqueue dialog box 18
immediate printing option 15, 18
installing the IPS application 3 to 8

L
log file for printer error information 9, 15

editing configuration of 16
LZW compression (not supported) 24

M
main menu

Image Print Server (IPS) launcher 9
LED Image Print Server 13

O
order punch to specify end of order 15, 18

defined 2

P
preferences, source directory, setting 14 to 16
print production options 15, 18
print queue

placing images in 17 to 19
removing images from 19 to 20

printer resolution options 15, 18
printing images 13 to 19

R
requirements, system 3
resuming a suspended application 21 to 22

defined 2
roll to roll options 15, 18

S
SCSI ID 10, 11
SCSI interface driver (ASPI-compliant) 3
software requirements 3
source directory 15

defined 2
insertion of images 17
setting preferences 14 to 16

suspending and resuming the IPS 
application 21 to 22

resuming 21 to 22
suspending 21

defined 2
icon and menu item defined 14

T
terms, defined 2
TIFF downloader 2
TIFF tags 24
tone scale correction, applying 9, 16, 19
December 2000 I-1



U
unattended mode of IPS application 22 to 23

defined 2
updating a print device 11 to 12
using the Image Print Server (IPS) 

application 9 to 23
adding, updating, and 

deleting print devices 10 to 12
attended and unattended modes 22 to 23
failed jobs directory, using 22
printing images 13 to 19
removing images from the print queue 19 to 20
starting the application 9
suspending and resuming the IPS application 

21 to 22
I-2 December 2000





EASTMAN KODAK COMPANY
Rochester, New York 14653
U.S.A.

Kodak and Kodak Professional are 
trademarks of 
Eastman Kodak Company.

© Eastman Kodak Company, 2000 Printed in U.S.A.


	Contents
	Using the Image Print Server (IPS) Software with the KODAK PROFESSIONAL LED II Printers 20P/20R
	Definitions of Terms
	Installing the IPS Application
	Hardware Requirements
	Software Requirements
	Installing the Software
	Downloading the Installation Application
	Installing the Application


	Using the Image Print Server
	Before You Begin
	Starting the IPS Application
	Adding, Updating, or Deleting a Printer Device
	Adding a Device
	Updating the Device Name, SCSI Host Adapter, or SCSI ID
	Deleting a Device

	Printing Images
	Description of Icons on the Main Menu
	Setting the Source Directory Preferences for a Device
	Placing Images in the Print Queue

	Removing Images from the Print Queue
	Removing the Top Image from the Queue
	Removing All Images from the Print Queue

	Suspending and Resuming the IPS Application
	Suspending the IPS Application
	Resuming the IPS Application after a Suspension

	Failed Jobs
	Attended and Unattended Modes

	File Format Details
	Supported Tags
	LZW Compression



