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Chapter 1

Getting Started with
Bluetooth Manager

This manual describes Bluetooth® Manager (BTManager) 2.0 used
on the Topcon field controller FC-200 with the CE.Net operating
system.

The BTManager utility controls the FC-200 Bluetooth module.

Starting Bluetooth Manager

To start the BTManager:
1. Turn on the FC-200.

2. Tap the Bluetooth icon in the system tray, and select Bluetooth
Manager from the pop-up menu.

Turn Transmitter OFF

] EBluetooth Manager
About. .,

Exit

Hid |4§ 11:39AM|@|%

Figure 1-1. Starting Bluetooth Manager

1-1



Getting Started with Bluetooth Manager

3. If the Bluetooth transmitter is switched off (the menu item is
gray), select Turn Transmitter On to turn on Bluetooth.

Getting Acquainted

Table 1-1 summarizes the screens and settings in BTManager,

Table 1-1. BTManager Screens

Description Screen

Type of devices to detect

Type of devices to detect E] E]

This screen dlsplays types of The Discovery Wizard is ready to search for

devices to pair with. Once a device Bluetooth devices, Select the type of
Bluetooth devices that you would like ko

type is selected, the DiSCOVeI’y discover and tap Mext to begin the search,
Wizard searches for those devices ®

when you tap Next. (O computer
O Phone

O LAR Metwark Access Point
O Peripheral

O Irnaging

O Miscellaneous
O Uniclassified

’ < Back ” Next > ]

Device List
This screen displays all discovered P nddress [
devices of a selected type. From v|E3 Pr-n1ss 00:03:7a:2b:42:08
this list, you can choose a device to vIQROVER 166 0003:Tai2bi42iT2
pair with and add it to your List of
Favorite Devices by tapping Next.

Check the checkboxes next to the device that
wou would like to save,

< Back ” Next >
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Table 1-1. BTManager Screens (Continued)

Getting Acquainted

Description

Screen

List of Favorite Devices

This screen displays your preferred
Bluetooth-enabled devices to pair
with. Selecting a device and
tapping View » Details displays
detailed information about that
device.

|Devi|:e View Tools Help

X

0 ©

ROVER 166 PP-0168

My Bluetooth Device

This screen displays the internal
FC-200 Bluetooth module
information. Enabling
Discoverable allows other devices
to detect your FC-200. Enabling
Authentication confirms the
identity of other devices trying to
pair with your FC-200.

My Bluetooth Device

TOPCON

g Class {Major): Computer

Diewvice Mame:  WindowsCE

Address: 00:03:72:30:d0:02

Class {Minor): Unclassified

o] )]

I:‘ Authentication

My

Bluetooth Device
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Getting Started with Bluetooth Manager

Table 1-1. BTManager Screens (Continued)

Description Screen

Bluetooth Device Pairing

. . Bluetooth Device Pairing *
This screen prompts the Wizard to ]
search for the device you have Bl oo
L. TOPCON Pairin
selected to pair with when you tap g
Next. - !
Tap Mext ko begin pairing Bluetooth devices.,
Pairing creates a bond between the computer
and your Bluetooth device, This process is
only required once per Bluetooth device,
< Back
About BTManager

About. BtManager, E]

This screen displays version and Bluetooth Manager

copyright information for the TOPCON About
BTManager.

BtManager Version 2.0 RC, 10 July, 2007

Copyright € 2006-2007

Topcon Positioning Systems
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Chapter 2

Using Bluetooth
Manager

Before the FC-200 can pair with another Bluetooth-enabled device, it
must discover which devices are available within your coverage area.
You can then add these devices to the List of Favorite Devices. Upon
first opening the BTManager, the List is empty.

|Devi|:e View Tools Help| *

Figure 2-1. List of Favorite Devices

Discovering Devices

To discover other Bluetooth-enabled devices within your coverage
area:

1. Tap Tools » Device Discovery.
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Using Bluetooth Manager

Device View Help

9 Device Disc

ROVER 166 PP-0162

Figure 2-2. Tools menu - Device Discovery

The Discovery Wizard appears (Figure 2-1).
Welcome! E]

Bluetooth Device

TOPCON Discovery

Tap Mext to discover new Bluetooth devices,
Make sure the new devices are on and in
Discoverable mode.

< Back

Figure 2-3. Discovery Wizard
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Discovering Devices

2. Tap Next to display a list of device types.

Type of devices to detect E] E]

The Discovery Wizard is ready to search for
Bluetooth devices, Select the type of
Bluetooth devices that yvou would like to
discover and tap Mext to begin the search,

OF:

O Computer
O Phone
O LAk MNetwork Access Point
O Peripheral

O Irnaging

O Miscellaneous

O Uniclassified

’ < Back ” Next > ]

Figure 2-4. Device Types

3. Choose a type of devices to discover, and tap Next.

The Discovery Wizard searches for Bluetooth-enabled devices in
your coverage area and displays the icons of the devices it
discovers on the Device List.

As device names and addresses are retrieved, the Device List
updates with detailed information.

Device Mame I Address I
3 PP-0165 00:03:7a:2bi42:08
aROVER 166 00:03:7a:2bi42:72

Check the checkboxes next to the device that
wou would like to save,

’ < Back ” Next > ]

Figure 2-5. Discovered Devices

Once the Device List is populated, you can add any device from this
list to the List of Favorite Devices.
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Using Bluetooth Manager

Adding to the List of

Favorite Devices

The Devices List displays all discovered Bluetooth-enabled devices in
your coverage area.

To add a device from the Devices List to the List of Favorite Devices:

1. Select a device, and tap Next. You can choose more than one
device.

Device Mame I Address I
v| &4 PP-0165 00:03:7a:2bi42:08
v 9 ROYER. 166 00:03:7a:2bi42:72

Check the checkboxes next to the device that
wou would like to save,

< Back ” Next > ]

Figure 2-6. Select Device(s)
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Adding to the List of Favorite Devices

A confirmation message appears when the devices are
successfully added to the List of Favorite Devices.

Success!

‘fou have added 2 new deviceis), Tap Finish
to exit.

’ < Back ” Finish ]

Figure 2-7. Devices Added

2. Tap Finish to exit the Wizard and display the List of Favorite
Devices.

The List of Favorite Devices shows all devices your FC-200 is
currently paired with. You can view devices by icon and name or by
name and address.

|Devi|:e View Tools Help| *

B ©

ROVER 166 PP-0162

Figure 2-8. Bluetooth Devices Folder - Name and Icon View
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Using Bluetooth Manager

To display the list of devices by name and address, tap

View » Details.

|Devi|:e View Tools Help| *

Device Mame

Address

I ROVER 166
£ Pr-016e

<

00:03:7a:2hi42:72
00:03:7a:2b:42:08

>

Figure 2-9. Bluetooth Devices Folder - Name and Address View

Viewing Device Properties

To view the properties of a device, select the device in the List of
Favorite Devices, and tap Device » Properties.

The Bluetooth Device Properties screen displays major and minor
class identifiers, the name, and address of the selected device. The
screen also shows the services supported by the device. Depending on
the device type, the supported services can include Limited,

2-6
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Deleting a Device from the List

Positioning, Networking, Rendering, Capturing, Object XFER,
Audio, Telephony, and Information.

Properties E]

Bluetooth Device

TOPCON Properties

Class {Major): Unclassified
9 Class (Minor):

Device Mame: ROYER 166
Address: 00:03:7a2hi42:72

Supported Services:
FPositioning

Figure 2-10. Bluetooth Device Properties

Deleting a Device from the List

To delete a device from the List of Favorite Devices:
1. Select the device, and tap Device » Delete.

A confirmation message appears.
2. Tap Yes to delete the device.

| Device View Tools Help *
Device Marme Address

4 ROVER 166 00:03:7a:2h42:72
aF‘P-DlﬁEI 00:03:7a:2h:42:08

Bluetooth Manager,

Confirm deletion of
the device "ROVER
166"7

Figure 2-11. Deleting a Device
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Using Bluetooth Manager

Choosing Device Accessibility

To select accessibility settings for the internal FC-200 Bluetooth
Module, tap Device » My Bluetooth Device.

The My Bluetooth Device screen displays information about the
internal FC-200 Bluetooth module and if external devices can
discover/pair with it.

My Bluetooth Device E] E]

My

Bluetooth Device

TOPCON

T Class (Major): Computer
Class {Minor): Unclassified

Device Mame:  WindawsCE

Address: 00:03:72:30:d0:02

I:‘ Authentication

Figure 2-12. My Bluetooth Device
My Bluetooth Device always displays the following information:
* Class (major and minor)
* Name (Other devices use this name to identify the FC-200.)
* Address

This screen also allows you to enable the following accessibility
options:

* Discoverable: allows other devices to find the FC-200
* Authentication: authenticates the identity of other devices

BTManager allows the FC-200 to connect with other Bluetooth-
enabled devices using serial port or dial-up services:

» SPP (Serial Port Profile): provides serial port connection with
peripheral Bluetooth-enabled devices, including GPS
receivers which normally do not require authentication.
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Pairing Bluetooth Devices

* DUN (Dial-up Networking Profile): provides a standard to
access dial-up services over Bluetooth. The most common
scenario is connecting to a phone.

Pairing Bluetooth Devices

Pairing establishes communication between devices by exchanging
PINs and addresses. Once communication is established and
authentication occurs, these devices become “trusted” devices and
will no longer have to authenticate for future connections. The List of
Favorite Devices displays all of the discovered Bluetooth-enabled
devices your FC-200 can pair with.

To pair with a Bluetooth-enabled device from the List of Favorite
Devices:

1. Select the device, and tap Device » Pair.

Pair
Properties
Delete

My Bluetooth Device...

Exit

< 4

Figure 2-13. Device Menu - Pair

The Pairing Wizard appears to guide you through the pairing
process.

2. Tap Next to continue.

2-9



Using Bluetooth Manager

The Wizard searches for the other device.

Bluetnoth Device Pairing E]

Bluetooth Device

Bluetnoth Device Pairing

Pairing will be attempted with the Following

TOPCON Palring device:

9 Device Mame:  ROVER 166
Device Address: 00:03:7a:2bi42:72

Tap Mext ko begin pairing Bluetooth devices.,
Pairing creates a bond between the computer
and your Bluetooth device, This process is
only required once per Bluetooth device,

Please make sure the Elustooth on the device
is enabled and will accept: pairing.

Tap Mext ko continue. ..

< Back

Figure 2-14. Pairing with Remote device

When the Wizard discovers the other Bluetooth-enabled device,
you are prompted to enter a passkey (PIN) for authentication. The
same passkey must be entered on both devices to establish
authentication and pairing. Authentication is only required the
first time the two devices pair.

The following device requires a passkey: The following device requires a passkey:
ROYER 166 ROYER 166

The same Bluetooth passkey is required on The same Bluetooth passkey is required on
each device, Please enter the passkey below each device, Please enter the passkey below
and tap Mext, or close the Wizard to deny and tap Mext, or close the Wizard to deny
the request, the request,

Flease enter the passkey below: Flease enter the passkey below:

| |1 111

CAPla|s|d|f[a|h[j|k[I];]" CAPla|s|d|f[a|h[j|k[I];]"
Shift/ z [2[c[¥[b[n[m Bri Shiftfz [2[c[¥[b[n[m[.[.]/
af " | I ai]~ [\ ] Lt]<]>

Next = ’ < Back ” Next >

Figure 2-15. Enter Passkey (PIN)

3. Enter a passkey, and then tap Next.
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Pairing Bluetooth Devices

4. If the passkey on the remote device is changed or revoked, an
error message appears. Tap OK to change the current passkey.

The following device requires a passkey:
ROYER 166

The same Bluetooth passkey is required on
elow

i

The operation being
requested was not
performed because
the user has not
been authenticated.

< Back ” Next > ]

Figure 2-16. Change Current Passkey

A congratulation message appears when the pairing is successful.

Success!

‘fou are now paired to the Following device:

ROVER 166

Tap the Finish button ko exit the Wizard.,

Figure 2-17. Successful Pairing

5. Tap Finish to exit the Wizard.
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