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1 Getting Started

Topics in this chapter:

• Installing generator

• Connector pin-outs

• Using Video Generator Manager
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Installing generator

To install the generator:

1. Turn off your computer and monitor to protect the generator from possible electrical 
damage. Leave the power cord connected with the computer, until step 4.

2. Remove the cover from the computer.

3. Touch the metal part of the power supply case inside the computer to discharge any 
static electricity that you might have.

4. Disconnect the power cord from the computer, even though the computer is turned off.

5. Hold the generator by its edges, and insert it into a PCI slot.

6. Secure the backplate attached to the card.

7. Replace the computer cover, and plug in the computer.

8. Connect a display with the generator.

9. Turn on the computer.

The generator displays the SMPTE133 image, using the DMT0660 format, the first time 
it is started, or initialized.
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Connector pin-outs

VGA connector

EGA connector

Pin Description Pin Description

1 Analog red video 9 DDC/EDID +5 VDC out

2 Analog green video 10 Digital ground

3 Analog blue video 11 No connection

4 No connection 12 DDC/EDID serial data

5 Digital ground 13 Horizontal sync

6 Red analog video ground 14 Vertical sync

7 Green analog video ground 15 DDC/EDID data clock

8 Blue analog video ground

Pin Description

1 Ground

2 Red intensity

3 Red

4 Green

5 Blue

6 Green intensity

7 Blue intensity

8 Horizontal sync

9 Vertical sync
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Using Video Generator Manager

Video Generator Manager (VGM) is a Microsoft Windows-based program used to operate 
the generator. The 802R-PCI generator requires VGM 3.0.4 or later.

VGM is available on the Resource CD included with the generator, and from 
http://www.quantumdata.com/support/downloads/.

Installing VGM

To install VGM:

1. Log onto Windows with Administrator privileges.

2. Locate setup.exe from the Resource CD or Quantum Data website.

3. Follow the on-screen instructions.

Quick tour of VGM

This section demonstrates basic VGM features.

To tour VGM:

1. Connect the generator with a display.

2. Select Start > Programs > Quantum Data > VGM to start VGM.

3. In VGM, select Generator > Connect.
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4. In the Select Port dialog box, choose PCI Card, and then click OK.

VGM adds the generator to the connections pane. VGM may be connected with 
multiple generators, but can control only one generator at the same time.

5. In the connections pane, double-click the generator name to open the generator view 
window.

6. Click the  icon, if it is not already selected, to list the available video formats.

The left pane displays basic properties of the format currently being used by the 
generator. For detailed format information, click the  icon. Use this detailed view to 
sort formats by different properties.

7. Double-click the format you want to use.

Connections pane
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8. Click the  icon to list available images, and then double-click the image you want to 
use.

9. In the toolbar, click the video gate buttons  to gate R, G, and B output.

10. Click the  icon, and then double-click the NewSeq sequence to open the default test 
sequence in the Sequence Player.

11. Click the play button to begin playing the test sequence.

For more information about creating test sequences, see Chapter 3, “Creating Test 
Sequences.”

12. Click the Unload the Sequence button to exit the Sequence Player.

13. Select File > Close View to close the generator window.

14. Choose Generator > Disconnect to disconnect VGM from the generator.
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2 Operating Procedures

Topics in this chapter:

• Viewing system information

• Installing firmware and gateware upgrades

• Initializing the generator

• Calibrating the generator

• Downloading bitmap images

• Advanced tasks
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Viewing system information

Use the GenStats image to view information about your generator, including versions of 
installed software, and memory usage.

To view system information:

1. Connect the generator with VGM.

2. Display the GenStats image.
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Installing firmware and gateware upgrades

This section describes how to install firmware and gateware upgrades, which are available 
at http://www.quantumdata.com/support/downloads/. Firmware is an executable program, 
which controls the user inteface, defines built-in formats and images, and other functions. 
Gateware code is used to program the FPGA in the generator.

VGM 3.0.4 or later is required to install install firmware and gateware updates.

Important: Always check the release notes for release-specific installation instructions.

Installing firmware updates removes any objects you created and stored on the generator, 
such as formats or images. Backup any custom objects before installing a firmware 
update. Updating gateware does not remove custom objects.

To backup custom objects:

1. Connect the generator with VGM.

2. Open the generator view window for the generator.

3. Open any custom objects in VGM, and then save them to your computer.

To install a firmware update:

1. Connect the generator with VGM.

2. Select Tools > Archiver > Update Firmware.

3. Click Browse, and then specify the firmware.bin file you want to install.

4. In the Generator Selection box, select the target generator, and click Flash.

After the firmware is installed, the generator calibrates itself, which takes about one 
minute, restarts, and then displays the SMPTE133 image.

To install a gateware update:

1. Connect the generator with VGM.
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2. Select Tools > Archiver > Gateware Upgrade.

3. Click Browse, and then specify the gateware file (*.xsvf) you want to install.

4. In the Generator Selection box, select the target generator, and then click Program.

VGM displays this message when the update is complete.

After VGM copies the gateware file to the generator, VGM will disconnect from the 
generator.

5. Read the release notes provided with the gateware update before proceeding.

If the gateware update does not require a firmware update, restart the computer, which 
restarts the generator, and activates the new gateware.

If the gateware update requires a firmware update, do not restart the computer, or you 
may be unable to install the firmware update. Refer to the release notes for special 
instructions.

6. Reconnect the generator with VGM.
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Initializing the generator

Initializing the generator restores it to factory settings, and erases all user-created objects.

To initialize generator:

1. Start VGM.

Connecting VGM with the generator is not necessary.

2. Select Generator > Special > Forced Init.

3. Choose the PCI Card option, specify the port used by the generator you want to 
initialize, and then click OK.

4. Confirm that you want to initialize the generator, and delete any user-defined objects 
from the generator.

5. Wait for one minute while the generator initializes and calibrates itself before 
connecting the generator with VGM.
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Calibrating the generator

About self-calibration

The generator can calibrate itself. Once calibrated, the generator does not require periodic 
calibration. There are no physical controls to adjust. All calibration is electronic.

Self-calibrating generators output very accurate analog video swings; more accurate then 
can be measured with most oscilloscopes. By comparing the output of these products with 
a chopped precision DC voltage source, swing accuracys better than ±5mv and 
component matches better than ±3mv have been routinely measured.

Given that the calibration circuit has a swing measurement accuracy of ±5mv, calibration 
of a nominally 700mV video signal should yield an actual video swing of between 695mV 
to 705mV. In the worst case, this would represent an error of ±0.7%.

The generator output consists of a buffer amplifier (with near 0-ohm output Z) and a 
75-ohm source resistor. The resistor is inserted between a buffer amplifier output and the 
output terminal of the generator. The calibration circuit measures voltage at the output of 
the buffer amplifier – not at the output terminal, therefore any errors in the internal source 
or external load resistors will not be calibrated and will remain.

This could potentially add an additional 1% error to the mix. So a nominally 700mV video 
signal should yield an actual video swing of 688mV to 712mV at the output terminal into a 
1% 75-ohm load. In the worst case, this would represent an error of ±1.7%.

Our current swing spec is ±14mV (or ±2%).

Using the Tektronix VM700T, which has a measurement uncertainty of 0.5% (or ±3.5mV at 
700mV), we would expect readings between 684.5mV to 715.5mV video, when the 
generator output is within 1.7% of 0.7Vp-p (in the absolute worst case). Using a typical 
oscilloscope, which might have a swing measurement accuracy of ±14mV. In this case, we 
should expect readings between 674mV to 726mV under the same conditions.

How to calibrate generator

To calibrate the generator:

1. Connect the generator with VGM.

2. Connect a display to the generator, and display any static image.

3. In the VGM connections pane, select the generator, and then choose Tools > CMD 
Terminal.

4. In the CMD box, enter SCAL.

The generator displays the image you selected in step 2 after the calibration process is 
completed.
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Calibrating frequency

All frequencies associated with the generator are derived from a common frequency 
reference, which can be calibrated using the rate calibration command RATC.

To reduce all frequency errors to zero:

1. Measure any convenient frequency from the generator using a very accurate frequency 
counter.

For example, measure the horizontal TTL separate sync frequency with the DMT0660 
format loaded and the horizontal rate temporarily set to 100KHz. Do this by typing

FMTL DMT0660;HRAT 100E3;ALLU

on the command line and measuring the TTL horizontal sync frequency.

2. Divide the frequency that you expect by the frequency that you measure and enter that 
ratio using the RATC command.

For example, if you measure 99.9955782499875 kHz, when you expect 
100.000000000KHz, then divide 100.000000000KHz by 99.9950002499875kHz and 
type

RATC 1.0000442194553987

This will raise all rates output by the generator and make them exact.
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Downloading bitmap images

Use VGM to download 8-bit or 24-bit bitmap (.bmp) images to the generator. Images 
cannot be stored on the generator.

To download a bitmap image:

1. Connect generator with VGM.

2. Load the Raster (flat black) image, which clears the display.

3. If the image uses 24-bit color, send the PELD 32; FMTU commands to set the 
generator into 24-bit mode. Otherwise, no commands are necessary.

The PELD command temporally changes the color depth of the current format.

After sending these commands, you can enter PELD? to confirm that the generator is 
in 24-bit (32) color mode.

4. Select Tools > Image Download.

5. Select your generator from the Select a Generator list.

The Screen Dimensions group displays the size and color depth of the current video 
format.

6. Click Browse, and specify the image you want to download.

7. In the X and Y boxes, specify the coordinates, in pixels, of the top left corner of the 
image in pixels, relative to the top left corner of the display (0,0).

8. Click the Download button.
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Advanced tasks

Creating video formats and images

Use VGM to create or modify video formats, and to create images. The images provided 
with the generator cannot be modified.

For information about creating formats and images, see VGM help.

Automating generator

The Quantum Data SDK provides an Application Programming Interface (API) that you 
can use to create Windows-based applications that control the generator automatically.

For more information, see the SDK, which is on the Quantum Data Resource CD included 
with the generator, and at http://www.quantumdata.com/support/downloads/.
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3 Creating Test Sequences

Topics in this chapter:

• Overview

• Using VGM to create a test sequence
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Overview 

In a production environment, where you might need to test several combinations of format 
and images, a test sequence can be used to automate the process of selecting formats 
and images.

A test sequence consists of steps. Each step specifies the format and image to display, 
and the duration of the step.

You can create multiple test sequences, and store them in the non-volatile memory of the 
generator. About 1500 steps, from all sequence files, can be stored.
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Using VGM to create a test sequence

You can use VGM to create and run test sequences.

To create a sequence using VGM:

1. Connect VGM with the generator.

2. Double-click the generator name to open the generator window.

3. In the generator window, right-click the NewSeq object, and then choose Edit.

4. In the Recall Data dialog box, click Yes.

5. ]In the Sequence Editor, select your generator from the Generator list.

6. The NewSeq file, which is a template for creating new sequences, contains default 
steps. Modify these steps, and values, as needed.
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7. Select the field you want to change, then double-click a new value from the list on the 
left.

8. Select Edit > Edit Sequence Name, and then specify a name for the sequence. This 
name is displayed as the sequence name on the generator.

9. Select File > Save to save the sequence (.seq) file to your computer. This name is used 
only as the name of the file stored on your computer, and may be different than the 
name of the sequence.

10. Select File > Close to close the Sequence Editor.

11. In the buffer pane, select the new sequence object, and then select Generator > Send 
Data.
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12. In the Data Transfer dialog box, select the generator on which you want to install the 
sequence (in case multiple generators are connected with VGM), and then click OK.

The sequence file is now stored on the generator.

To play a sequence:

1. Connect VGM with your generator.

2. Double-click the generator name.

3. In the generator window, right-click the sequence you want to run, and then choose 
Open.

4. Use the Sequence Player to run the sequence.

5. Click Unload the Sequence to stop running the sequence, and to return the generator 
to normal operating mode.
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