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FCC and IC RFI Statements/NOM Statement

FEDERAL COMMUNICATIONS COMMISSION AND 
INDUSTRY CANADA RADIO FREQUENCY INTERFERENCE STATEMENTS

This equipment generates, uses, and can radiate radio-frequency energy,  
and if not installed and used properly, that is, in strict accordance with the  
manufacturer’s instructions, may cause inter ference to radio communication.  
It has been tested and found to comply with the limits for a Class A computing 
device in accordance with the specifications in Subpart B of Part 15 of FCC rules, 
which are designed to provide reasonable protection against such interference 
when the equipment is operated in a commercial environment. Operation of  
this equipment in a residential area is likely to cause interference, in which case 
the user at his own expense will be required to take whatever measures may be 
necessary to correct the interference.

Changes or modifications not expressly approved by the party responsible  
for compliance could void the user’s authority to operate the equipment.

This digital apparatus does not exceed the Class A limits for radio noise  
emis sion from digital apparatus set out in the Radio Interference Regulation  
of Industry Canada.

Le présent appareil numérique n’émet pas de bruits radioélectriques dépassant les 
limites applicables aux appareils numériques de la classe A prescrites dans le 
Règlement sur le brouillage radioélectrique publié par Industrie Canada.

Normas Oficiales Mexicanas (NOM) 
Electrical Safety Statement

INSTRUCCIONES DE SEGURIDAD

1.  Todas las instrucciones de seguridad y operación deberán ser leídas antes   
de que el aparato eléctrico sea operado.

2.   Las instrucciones de seguridad y operación deberán ser guardadas para  
referencia futura.

3.  Todas las advertencias en el aparato eléctrico y en sus instrucciones de   
operación deben ser respetadas.
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 4. Todas las instrucciones de operación y uso deben ser seguidas.

 5. El aparato eléctrico no deberá ser usado cerca del agua—por ejemplo,  
  cerca de la tina de baño, lavabo, sótano mojado o cerca de una alberca,   
  etc.

 6. El aparato eléctrico debe ser usado únicamente con carritos o pedestales   
  que sean recomendados por el fabricante. 

 7. El aparato eléctrico debe ser montado a la pared o al techo sólo como sea  
  recomendado por el fabricante.

 8. Servicio—El usuario no debe intentar dar servicio al equipo eléctrico más allá  
  lo descrito en las instrucciones de operación. Todo otro servicio deberá ser  
  referido a personal de servicio calificado. 

 9. El aparato eléctrico debe ser situado de tal manera que su posición no   
  interfiera su uso. La colocación del aparato eléctrico sobre una cama, sofá,  
  alfombra o superficie similar puede bloquea la ventilación, no se debe   
  colocar en libreros o gabinetes que impidan el flujo de aire por los orificios  
  de ventilación.

 10. El equipo eléctrico deber ser situado fuera del alcance de fuentes de calor  
  como radiadores, registros de calor, estufas u otros aparatos (incluyendo   
  amplificadores) que producen calor.

 11. El aparato eléctrico deberá ser connectado a una fuente de poder sólo del  
  tipo descrito en el instructivo de operación, o como se indique en el   
  aparato.

 12. Precaución debe ser tomada de tal manera que la tierra fisica y la   
  polarización del equipo no sea eliminada.

 13. Los cables de la fuente de poder deben ser guiados de tal manera que no  
  sean pisados ni pellizcados por objetos colocados sobre o contra ellos,   
  poniendo particular atención a los contactos y receptáculos donde salen  
  del aparato.

 14. El equipo eléctrico debe ser limpiado únicamente de acuerdo a las   
  recomendaciones del fabricante.

 15. En caso de existir, una antena externa deberá ser localizada lejos de las   
  lineas de energia.

 16. El cable de corriente deberá ser desconectado del cuando el equipo no sea  
  usado por un largo periodo de tiempo.
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 17. Cuidado debe ser tomado de tal manera que objectos liquidos no sean   
  derramados sobre la cubierta u orificios de ventilación.

 18. Servicio por personal calificado deberá ser provisto cuando:

  A: El cable de poder o el contacto ha sido dañado; u

  B: Objectos han caído o líquido ha sido derramado dentro del aparato; o

  C: El aparato ha sido expuesto a la lluvia; o

  D:  El aparato parece no operar normalmente o muestra un cambio en su   
desempeño; o

  E: El aparato ha sido tirado o su cubierta ha sido dañada.



Page 6 724-746-5500   |   blackbox.com 

Safety Instructions

Safety Instructions
For reliable and safe long-term operation of your ServSwitch DKM FX, follow these 
guidelines:

Installation
• Only use in dry, indoor environments.

•  The ServSwitch DKM FX and the power supply units can get warm. Don’t put them 
in an enclosed space without any airflow.

• Do not obscure ventilation holes.

•  Only use power supplies originally supplied with the product or manufacturer-
approved replacements. Do not use a power supply if it appears to be defective or 
has a damaged case.

•  Connect all power supplies to grounded outlets. In each case, make sure that the 
ground connection is maintained from the outlet socket to the power supply’s AC 
power input.

•  Do not connect the link interface to any other equipment, particularly network or 
telecommunications equipment.

• Take any required ESD precautions.

Repair
• Do not attempt to open or repair a power supply unit.

•  Do not attempt to open or repair the ServSwitch DKM FX. There are no  
user-serviceable parts inside.

•  Contact Black Box Technical Support at 724-746-5500 or info@blackbox.com  
if there is a fault.
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Chapter 1: Specifications

1. Specifications

1.1 Interfaces

1.1.1 DVI-D Single Link
The video interface supports the DVI-D protocol. All signals that comply with 
DVI-D single-link standard can be transmitted. This includes, for example, monitor 
resolutions such as 1920 x 1200 @ 60 Hz, Full HD (1080p), or 2K HD (up to 2048 
x 1152). Data rate is limited to 165 MPixel/s.

1.1.2 USB HID
Devices with USB HID interface support a maximum of two devices with  
USB HID protocol. Each USB HID port provides a maximum current of 100 mA.

Keyboard

Compatible with most USB keyboards. Certain keyboards with additional  
functions may require custom firmware to operate. Keyboards with an integral 
USB Hub (Mac® keyboards, for example) are also supported.

Mouse

Compatible with most 2-button, 3-button, and scroll mice.

Other USB HID devices

The proprietary USB emulation also supports certain other USB HID devices, such 
as specific touchscreens, graphics tablets, bar-code scanners, or special keyboards. 
Support cannot be guaranteed, however, for every USB HID device.

NOTE:  Only two USB HID devices are supported concurrently, such as keyboard 
and mouse or keyboard and touchscreen. A hub is allowed, but it does not 
increase the number of HID devices allowed.

To support other USB “non-HID” devices, such as scanners, Web cams or memory 
devices, choose our devices with transparent USB support.

1.1.3 RJ-45 (Network)
CATx device communication requires a 1000BASE-T connection. Pin the cable 
according to EIA/TIA-568-B (1000BASE-T) standard with RJ-45 connectors at both 
ends. All four wire pairs are used in both directions. The cabling is suitable for  
full-duplex operation. For the cable connection to a source (computer, CPU), use a 
cross-pinned network cable.
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1.1.4 RS-232 (Serial)
The communication takes place with a transmission speed of up to 115.2 kbps, 
regardless of the file format. The transmission takes place with eight data bits and 
a stop bit, but without a parity bit. Limited hardware handshake (DSR) is possible.

1.1.5 RJ-45 (Interconnect)
CATx device communication requires a 1000BASE-T connection.

Connector wiring must comply with EIA/TIA-568-B (1000BASE-T), with RJ-45 
connectors at both ends. All four wire pairs are used.

1.1.6 Fiber SFP Type LC (Interconnect)
Fiber device communication is performed via Gigabit SFPs connected to suitable 
fibers fitted with LC connectors (see Section 1.2.2).

NOTE:  The correct function of the device can only be guaranteed with SFPs  
provided by Black Box.

CAUTION:  SFP modules can be damaged by electrostatic discharge (ESD). Follow 
ESD handling precautions.

1.1.7 SDI (Interconnect)
SDI device communication requires a mini coax connection with mini BNC  
connectors or 3G SFPs with transmission speeds of 0.360 Gbps (SD-SDI, SMPTE 
259M), 1.485 Gbps (HD-SDI, SMPTE 292M), and 2.70 Gbps (3G SDI).

1.2 Interconnect Cable
1.2.1 CATx
NOTE:  A point-to-point connection is required. Operation with several patch fields 

is possible. Routing over an active network component, such as an Ethernet 
hub, router, or ServSwitch DKM FX, is not allowed. 
• Avoid routing CATx cables along power cables. 
•  If the site has three-phase AC power, make sure that the CPU Unit and 

CON Unit are on the same phase.

NOTE:  To maintain regulatory EMC compliance, use correctly installed shielded 
CATx cable throughout the interconnection link.

NOTE:  To maintain regulatory EMC compliance, all CATx cables need to carry  
ferrites on both cable ends close to the device.

Type of Interconnect Cable

The ServSwitch DKM FX requires interconnect cabling specified for Gigabit 
Ethernet (1000BASE-T). Use solid-core (24 AWG), shielded, CAT5e (or better) 
cable.
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Table 1-1. CATx interconnect cable.

Cable Type Description

CATx solid-core 24 AWG cable
This S/UTP (CAT5e) cable confoms to EIA/TIA-568-B.  
Uses four pairs of 24 AWG wires. Connects according  
to EIA/TIA-568-B (1000BASE-T).

CATx solid-core 26/8 AWG cable
This S/UTP (CAT5e) cable confoms to EIA/TIA-568-B.  
Uses four pairs of 26/8 AWG wires. Connects according  
to EIA/TIA-568-B (1000BASE-T).

NOTE:  You can use use type 26/8 AWG flexible cables (patch cables), but the 
maximum possible extension distance is cut in half.

Table 1-2. Maximum acceptable cable length.

Cable Type Distance

CATx 24 AWG installation cable 400 ft. (140 m)

CATx 26/8 AWG patch cable 200 ft. (70 m)

1.2.2 Fiber

NOTE:   A point-to-point connection is necessary. Operation with multiple patch 
panels is allowed. Routing over active network components, such as 
Ethernet hubs, ServSwitch DKM FXes, or routers, is not allowed.

Type of Interconnect Cable

Table 1-3. Fiber interconnect cable.

Cable Type Description

Single-mode, 9-µm
• Two fibers, 9-µm 
• In-house patch cable (EFN092)

Multimode 50-µm
• Two fibers, 50-µm 
• In-house patch cable (EFN6020)

Multimode 62.5-µm
• Two fibers, 62.5-µm 
• In-house patch cable (EFN116-LCLC)

NOTE:  Only use single-mode cables for fiber connections that are based on 3G 
SFPs.
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Table 1-4. Maximum acceptable fiber cable length.

Cable Type Distance

Single-mode 9-µm 32,800 ft. (10,000 m)

Multimode 50-µm (OM3) 3280 ft. (1000 m)

Multimode 50-µm 1300 ft. (400 m)

Multimode 62.5µm 650 ft. (200 m)

NOTE:   If you use single-mode SFPs with multimode fiber optic cable, you can 
double the maximum acceptable cable length.

Type of Connector

The fiber cable uses LC connectors.

1.2.3 Coaxial
NOTE: A point-to-point connection is necessary.

Table 1-5. Coaxial interconnect cable.
Cable Type Description

Mini coaxial cable, 18 AWG
RG-6 
Impedance: 75 ohms

Table 1-6. Maximum acceptable coaxial cable length.

Bandwidth Distance

0.270 Gbps 1312 ft. (400 m)

1.485 Gbps 459 ft. (140 m)

2.970 Gbps 394 ft. (120 m)

Type of Connector

The coaxial cable uses mini BNC connectors.
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1.3 Supported Peripherals

You can use the KVM extenders described in Tables 1-7 and 1-8 with the 
ServSwitch DKM FX:

Table 1-7. KVM extender with CATx connection.

Product Code Description

ACX1T-11-C KVM CPU unit, single-head, 2x USB HID

ACX1R-11-C KVM CON unit, single-head, 2x USB HID

ACX1T-11V-C KVM CPU unit, single-head, DVI-I input (VGA), 2x USB HID

ACX1R-11V-C KVM CON unit, single-head, IR receiver, 2x USB HID

Table 1-8. KVM extender with fiber (single-mode) connection.

Product Code Description

ACX1T-11-SM KVM CPU unit, single-head, 2x USB HID

ACX1R-11-SM KVM CON unit, single-head, 2x USB HID

ACX1T-11V-SM KVM CPU unit, single-head, DVI-I input (VGA), 2x USB HID

ACX1R-11V-SM KVM CON unit, single-head, IR receiver, 2x USB HID

1.4 Connector Pinouts
1.4.1 CPU Board

Figure 1-1. DVI-D single-link connector.
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Table 1-9. DVI-D single-link connector pinout. 

Pin Signal Pin Signal Pin Signal

1 T.M.D.S. data 2- 9 T.M.D.S. data 1- 17 T.M.D.S. data 0-

2 T.M.D.S. data 2+ 10 T.M.D.S. data 1+ 18 T.M.D.S. data 0+

3 T.M.D.S. data 2 GND 11 T.M.D.S. data 1 GND 19 T.M.D.S. data 0 GND

4 Not connnected 12 Not connected 20 Not connected

5 Not connected 13 Not connected 21 Not connected

6 DDC input (SCL) 14 +5 VDC high impedance 22 T.M.D.S. GND

7 DDC output (SDA) 15 GND 23 T.M.D.S. clock+

8 Internal use 16 Hot plug recognition 24 T.M.D.S. clock-

C1 Internal use — — C3 Internal use

C2 Not connected C5 GND C4 Internal use

Table 1-10. USB Type A connector.

Picture Pin Signal Color

1 VCC (+5 VDC) Red

2 Data - White

3 Data + Green

4 GND Black

Table 1-11. DB9 connector.

Picture Pin Signal Color Signal

1 Not connected 6 DTR

2 CTS 7 TxD

3 RTS 8 RxD

4 DSR 9 Not connected

5 GND — —
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Table 1-12. RJ-45 connector.

Picture Pin Signal Color Signal

1 D1+ 5 Not connected

2 D1- 6 D2-

3 D2+ 7 Not connected

4 Not connected 8 Not connected

1.4.2 I/O Board CATx

Table 1-13. RJ-45 CATx connector.

Picture Pin Signal Color Signal

1 D1+ 5 D3-

2 D1- 6 D2-

3 D2+ 7 D4+

4 D3+ 8 D4-

1.4.3 I/O Board SFP
Table 1-14. RJ-45 connector.

Picture Diode Signal

1 Data OUT

2 Data IN

1.4.4 I/O Board SDI

Table 1-15. RJ-45 connector.

Picture Pin Signal

1 Data In

2 GND
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1.5 Power Supply

Power — All models: Voltage: 100–240 VAC, 50–60 Hz; 
 ACX288, ACX288-PS: 202 W max. without I/O boards; 
 ACX160, ACX160-PS: 188 W max. without I/O boards; 
 ACX080, ACX080-PS: 99 W max. without I/O boards; 
 ACX048: 94 W max. without I/O boards; 
 I/O boards (ACXI08-C, ACXI08-SM, ACXI08-SPF): 13 W max.

1.6 Environmental Conditions
Temperature Tolerance — +41 to +113° F (+5 to +45° C)

Storage Temperature — -13 to +140° F (-25 to +60° C)

Relative Humidity — Max. 80%, non-condensing

1.7 Size
Size — ACX288: 19"H x 22.8"W x 12"D (48.3 x 57.8 x 33 cm), 
  Shipping box: 25.6"H x 26.8"W x 29.9"D (65 x 68 x 76 cm); 
 ACX160: 19"H x 15.8"W x 12"D (48.3 x 40 x 33 cm), 
  Shipping box: 25.6"H x 26.8"W x 12"D (65 x 68 x 54 cm); 
 ACX080: 19"H x 7"W x 9.1"D (64 x 57 x 36 cm), 
  Shipping box: 25.2"H x 22.4"W x 21.3"D (64 x 57 x 36 cm); 
 ACX048: 19"H x 5.3"W x 9.1"D, 
  Shipping box: 25.2" x 22.4"W x 12.4"D (64 x 57 x 23.1 cm)

1.8 Shipping Weight
Weight — ACX288: 76.2 lb (34.6 kg) fully equipped,  
  Shipping box: 90.6 lb. (41.1 kg); 
 ACX160: 60 lb. (26.3 kg) fully equipped, 
  Shipping box: 69.9 lb. (31.7 kg); 
 ACX080: 24.5 lb. (11.1 kg) fully equipped, 
  Shipping box: 34.4 lb. (15.6 kg); 
 ACX048: 19.6 lb. (8.9 kg), 
  Shipping box: 26.7 lb. (12.1 kg)
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2. Overview

2.1 Description
2.1.1 Application
The ServSwitch DKM FX is used to establish connections from consoles (monitor, 
keyboard, mouse, and other peripheral devices) to various sources (computer, 
CPU).

In a maximum configuration, up to 288 independent ports can be defined and 
switched either as a console or a CPU.

The ServSwitch DKM FX is mainly specified for the use with extenders that are 
able to transmit video, KVM, and USB 2.0 signals. You can also use it as a video 
matrix.

For the connection between the ServSwitch DKM FX and the peripheral devices, 
such as KVM extenders or video sources, you can use CATx, fiber, or coaxial 
cables.

The ServSwitch DKM FX serves as a repeater. You can place it up to 6.2 miles  
(10 km) from the consoles and 6.2 miles (10 km) from the sources.

2.1.2 Access Options
You have the following options to access the ServSwitch DKM FX for  
configuration and operation:

Table 2-1. Access options.

Access option Symbol

OSD

Java tool

Serial interface
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2.2 System Overview
A ServSwitch DKM FX system consists of a ServSwitch DKM FX and, for KVM 
applications, one or more CPU units/CON units. The ServSwitch DKM FX is  
connected to the CPU units/CON units by interconnect cables or is connected 
directly to the video devices when used as a video matrix.

The CPU units connect directly to the sources (computer, CPU), using the included 
cables.

Monitor(s), keyboard, and mouse connect to the CON units.

The ServSwitch DKM FX and the CPU units/CON units communicate over CATx, 
fiber, or coaxial interconnect cables.

Figure 2-1 shows the system overview. Table 2-2 describes its components.

1  2      3         4   3     5      6

Figure 2-1. System overview.

Table 2-2. System components.

Number Component

1 Source (computer, CPU)

2 CPU units

3 Interconnect cable

4 ServSwitch DKM FX

5 CON units

6 Console (monitor, keyboard, mouse)
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See Section 3.2 for installation examples.

2.3 Available Products

Table 2-3. Available products.

Number Description

ServSwitch DKM FX

ACX048 ServSwitch DKM FX 48-port with control card and power supply

ACX080 ServSwitch DKM FX 80-port with control card and power supply

ACX160 ServSwitch DKM FX 160-port with control card and power supply

ACX288 ServSwitch DKM FX 288-port with control card and power supply

Accessories

ACXIO8-C 8-port CATx input/output (I/O) module

ACXIO8-SM 8-port single-mode fiber input/output (I/O) module

ACXIO8-SFP 8-port single-mode fiber SFP input/output (I/O) module

ACX288-CTL ServSwitch DKM FX controller card

ACXSFPC CATx SFP module

ACXSFPS Single-mode fiber SFP module

ACX080-PS Power supply for ACX048 and ACX080

ACX160-PS Power supply for ACX160

ACX288-PS Power supply for ACX288

ACX080-FAN Tray for 48/80 port console

ACX288-FAN Tray for 160/288 port console

2.4 What’s Included

Your package should contain the following items. If anything is missing  
or damaged, contact Black Box Technical Support at 724-746-5500  
or info@blackbox.com.

• (1) ServSwitch DKM FX (ACX048, ACX080, ACX160, or ACX288)

• (1) power cord per built-in power supply unit

• (1) DKM FX controller card

• (1) serial control cable

• (1) set of mounting accessories

• This users’ manual in PDF format and Java tool on CD-ROM
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• (1) cross-wired CATx network cable

2.5 Device Views
In Sections 2.5.1 through 2.5.5, Figures 2-2 through 2-5 illustrate the ServSwitch 
DKM FX chassis models. Tables 2-4 through 2-8 describe their components.

2.5.1 ServSwitch DKM FX 288-Port

1   2              3         4       5  6    7  8

Figure 2-2. Front view, ACX288.
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Table 2-4. ACX288 components.

Number Component

1 Slot for Power Supply Unit 1

2 Slot for Fan Tray 1

3 Slot for Power Supply Unit 2

4 Slot for Fan Tray 2

5 Slot for I/O Boards 1–36

6 Slot for Power Supply Unit 3

7 Slot for CPU board

8 Grounding

2.5.2 ServSwitch DKM FX 160-Port

1   2              3         4       5  6    7   8

Figure 2-3. Front view, ACX160.
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Table 2-5. ACX160 components.

Number Component

1 Slot for Power Supply Unit 1

2 Slot for Fan Tray 1

3 Slot for Power Supply Unit 2

4 Slot for Fan Tray 2

5 Slot for I/O Boards 1–20

6 Slot for Power Supply Unit 3

7 Slot for CPU board

8 Grounding

2.5.3 ServSwitch DKM FX 80-Port

1                 2       3     4      5       6   7

Figure 2-4. Front view, ACX080.

Table 2-6. ACX080 components.

Number Component

1 Slot for fan tray

2 Slot for Power Supply Unit 1

3 Slot for I/O Boards 1–10

4 Slot for Power Supply Unit 2

5 Slot for CPU board

6 Slot for air filter

7 Slot for Fan Tray 2
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2.5.4 ServSwitch DKM FX 48-Port

1        2       3  4      5       6  7

Figure 2-5. Front view, ACX048.

Table 2-7. ACX048 components.

Number Component

1 Slot for fan tray

2 Slot for Power Supply Unit 1

3 Slot for I/O Boards 1–10

4 Slot for Power Supply Unit 2

5 Slot for CPU board

6 Slot for air filter

7 Slot for Fan Tray 2

2.6 Diagnostics and Status

2.6.1 Status LEDs
The ServSwitch DKM FX components LED indicators are shown in Figures 2-6 
through 2-11, and described in Tables 2-8 through 2-13.
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1

2

Figure 2-6. CPU board, front view.



Page 26 724-746-5500   |   blackbox.com 

Chapter 2: Overview

Table 2-8. Status LEDs on the CPU board.

Number LED Status Description

1 Status 1

White CPU board is in registration process

Blue flashing Registration at the matrix is started

Red flashing Registration is in progess

Green flashing Operating condition

Green CPU board de-registered

2 Status 2

White CPU board is in registration process

Red flashing Registration at the matrix is started

Off Operating condition

NOTE:  Because of variations in the LED type, “white” may also appear as light  
purple or light blue.
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1

2

11

22

CATx  SFP fiber  SFP coax

Figure 2-7. LEDs on the I/O boards. 
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Table 2-9. Status LEDs on the I/O boards.

Number LED Status Description

1 Status 1

Light blue I/O board in boot process

Red flashing I/O board in registration process

Green flashing Operating condition, I/O board registered at the matrix

Green I/O board de-registered (locking pin pulled out)

2 Status 2

White I/O board in boot process

Blue I/O board in registration process

Blue flashing
Operating condition, communication active with CPU board 
active

Red flashing I/O board de-registered (locking pin pulled out)

CATx    SFP fiber     SFP coax

1

2
11
22

Figure 2-8. Ports status LEDs on the I/O boards.

Table 2-10. Port status LEDs on the I/O boards.

Number LED Status Description

1 Link status (green)

Off Port not activated

Flashing Port activated, no connection via interconnect cable

On Connection via interconnect cable OK, data traffic active

2 Link status (orange)

Off Port not activated

Flashing Port activated, no connection via interconnect cable

On Connection via interconnect cable OK, data traffic active
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1     2   3

Figure 2-9. Status LEDs on the fan tray.

Table 2-11. Status LEDs on the fan tray.

Number LED Status Description

1 Status 1 (green) On Operating condition

2 Status 2 (blue)
Off Operating condition

On Error indication

3 Hot swap (blue)
Off Hot swap option deactivated

On Hot swap option activated

   1  2 3

Figure 2-10. Status LEDs on the power supply unit (ACX288-PS or ACX160-PS).
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Table 2-12. Status LEDs on the power supply unit  
(ACX288-PS or ACX160-PS).

Number LED Status Description

1 AC input OK (green) On Operating condition

2 DC output OK (green) On Operating condition

3 O/T (yellow)
Off Normal temperature

On High temperature

1

Figure 2-11. Status LEDs on the power supply unit (ACX080-PS).

Table 2-13. Status LEDs on the power supply unit  
(ACX080-PS).

Number LED Status Description

1
DC input OK (green) On Operating condition

DC output OK (green) Off No power supply

2.6.2 Port Status
The connections and the switching status between the various consoles and CPUs 
are shown in this menu.

You have the following possibilities to access the menu:

Figure 2-12. OSD and Java icons.
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OSD

An on-screen display (abbreviated OSD) is an image superimposed on a screen 
picture, commonly used by modern television sets, VCRs, and DVD players to  
display information such as volume, channel, and time.

Java® Tool

The current port configuration of the ServSwitch DKM FX is illustrated in this 
menu.

Select Status > Matrix View in the task area in on-line mode.

Figure 2-13. Menu Status—Matrix View screen.

Table 2-14. Connection status.

Color Description

Black Port not connected

Yelllow Video connection

Green KVM connection
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The symbol in Table 2-15 indicates the extender that is recognized and defined at 
a certain port:

Table 2-15. Extender recognized.

Symbol Description

Port connected to a CPU unit

Port connected to a CON unit

Port connected to a USB 2.0 CPU unit

Port connected t a USB 2.0 CON unit

• Red framed ports are defined as “fixed” (for example, for USB 2.0 connections).

• The port with a static blue frame is currently selected.

• The ports with a flashing blue frame show the currently assigned connections.

NOTE:  To show the extender information of the currently selected port in the right 
part of the working area, press the left mouse button.

The information in Table 2-16 is available:

Table 2-16. Extender information.

Symbol Description

Extender name Name of the selected extenders

Extender type Type of the selected extender

Port ID Number of the selected port

Device name Name of the connected console or CPU

Connections Listing of assigned connections to the marked port (full access or video access)

NOTE:  To open the context menu for the currently selected port with further 
functions, press the right mouse button.
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The context functions in Table 2-17 are available:

Table 2-17. Context functions.

Function Description

Open extender The menu for definition of the currently selected extender is opened

Open device The menu for definition of the currently selected console  or CPU is opened

Switch The menu for execution of switching applications is opened

To reload the Matrix View, you have the following possibilities:

• Press the key <F5> of a connected keyboard

• Execute Edit > Reload in the menu bar

• Press the Button Reload in the tool bar

2.6.3 Network Status
The current network configuration is shown in this menu.

You have the following possibilities to access the menu:

Figure 2-14. OSD and Java icons.

OSD

Select Status > Network in the main menu.
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Figure 2-15. Status—Network screen.

The following information is shown in the Network Status menu:

Table 2-17. Network status.

Field Description

DHCP Information if the network settings are applied dynamically. Display Y (Yes) or N (No)

IP address Information about the IP address as provided manually or via DHCP

Subnet mask Information about the subnet mask as provided manually or via DHCP

Gateway Information about the gateway address as provided manually or via DHCP

MAC ID Information about the MAC address in the matrix
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Java Tool

1. Select Status > Matrix View in the task area.

Figure 2-16. Menu status—matrix view.

2.  Use the left mouse button to click on the network port of the CPU board.  
The corresponding network status will be shown in the right part of the  
working area.

2.6.4 Firmware Status
The current firmware status of the installed boards is shown in this menu.

You have the following possibilities to access the menu:

Figure 2-17. OSD and Java icons.
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Figure 2-18. Menu status—firmware.

Table 2-18. Menu status—firmware.

Field Description

Name Description of the modules

Type Type number

Ports Number of ports

Version Complete description of the firmware version

Date Date of the firmware version

Status Module status
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Java Tool

1. Select Status > Slot Table in the task area.

Figure 2-19. Menu Status—Slot Table.

2.  To read out the firmware status and store it locally (file extension .dtf), select 
Switch > Save Firmware Status to File....

3.  To read out the overall status of the ServSwitch DKM FX and store it locally (file 
extension .zip), select Switch > Save Status to File....

The various modules can expanded and retracted in the column Name by clicking 
with the left mouse button on the plus or minus symbols to get a better overview.

By clicking on the plus resp. minus symbol in the upper right corner of the  
working area, you can expand and retract all module information with one click  
at the left mouse button.

2.7 Trace Function
All events—for example, activities and switching operations of the ServSwitch 
DKM FX—are logged and displayed in this menu.

This function is used for diagnostic purposes.
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You can request various trace views in the menu:

Figure 2-20. OSD icon.

The following information is shown in this menu:

Table 2-20. Trace menu function.

Field Description

Time Timestamp

Message Detailed description of the event

Trace possibilities

•  Select Status > Trace IO Board in the main menu to check the events on your 
current I/O boards.

• Select Status > Trace Matrix to check the ServSwitch DKM FX events.
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3. Installation

3.1 System Setup

NOTE:  If you are a first-time user, we recommend that you set up the system  
in the same room as a test setup. This will allow you to identify and solve 
any cabling problems, and experiment with your system more conveniently.

Setup of the ServSwitch DKM FX

1. Install the CPU and I/O boards.

2.  Connect the keyboard, mouse, and monitor to the CPU board of the 
ServSwitch DKM FX.

3. Connect the ServSwitch DKM FX to the power supply.

4.  Open OSD via hotkey and log in with administrator rights in the main menu 
under configuration (see Section 4.2.1).

5. Configure initially as requested.

NOTE:  After configuring the system, we recommend that you save the  
configuration by selecting Configuration > Save and restart the ServSwitch 
DKM FX by selecting Restart Matrix.

6.  Optional: Establish a network connection between the ServSwitch DKM FX and 
the Java tool to set an extended configuration (see Section 4.2.2).

Setup of Extender

1.  Connect the CON units to the ServSwitch DKM FX by using the interconnect 
cables (CATx or fiber).

2.  Connect the CON units to the input devices to be used (for example, keyboard 
and mouse).

3. Connect the 5-VDC power supply units to the CON units.

4. Check the basic function of the CON unit by opening the OSD via hotkey.

5.  Connect the source (computer, CPU) to the CPU unit of the extender by using 
the provided connection cables.

6.  Connect the CPU unit to the ServSwitch DKM FX by using the provided  
interconnect cables (CATx or fiber).
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7.  If you have a video matrix, connect the video source directly to the ServSwitch 
DKM FX by using the interconnect cables (coax, fiber).

8. Connect the 5-VDC power supply units to the CPU units.

9. Start the system.

3.2 Example Applications
The ServSwitch DKM FX supports a flexible configuration of your system  
environment:

For example, part of the ServSwitch DKM FX can be configured as a single-head 
workstation, part as dual-head, or quad-head, or even as a video ServSwitch DKM 
FX. You can also configure KVM and USB 2.0.

In addition to the access via OSD by the keyboard connected to the CPU board or 
an extender CON unit, you have the following access options:

• via Java Tool

• via serial interface

A connection to common media controls is possible, too.

Sections 3.2.1 through 3.2.5 describe typical installations of the ServSwitch DKM 
FX.

3.2.1 KVM Matrix
In single-head mode, up to 288 ports can be used either as an input or as an  
output port, depending on components and equipment. At the same time, all 
users have non-blocking access (user access is not limited by the activities of 
another user).
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1 2      3         4         3   5     6

Figure 3-1. KVM using ServSwitch DKM FX application.

Table 3-1. Single-head KVM matrix components.

Number Description

1 Source (computers, CPU)

2 CPU units

3 Interconnect cable

4 ServSwitch DKM FX

5 CON units

6 Consoles (monitor, keyboard, mouse)

If you have a single-head console, you can also access a dual-head or quad-head 
console. However, you can control the system only at Monitor 1.

Any signal source can be switched to any number of monitors that will show the 
video signal at the same time. Even (optional) audio can be switched.

3.2.2 Video Matrix
If you use the ServSwitch DKM FX as a video matrix, it can switch up to 288 input 
ports to up to 288 output ports, depending on components and equipment.
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1 2                 3               2            4 

Figure 3-2. Video using ServSwitch DKM FX application.

Table 3-2. Video matrix components.

Number Description

1 Video sources, for example, an SDI camera

2 Interconnect cable

3 ServSwitch DKM FX

4 Video sinks, for example, a monitor

3.2.3 Parallel Operation (Stacking)
If you have special configurations, especially at installations with several monitors 
per workstation, or you need additional support for USB 2.0 transmission paths, 
you can increase the number of CPUs and consoles connected using a parallel 
operation (stacking) of several ServSwitch DKM FX devices.

One of the ServSwitch DKM FX matrices has to be defined as the master 
ServSwitch DKM FX, and all the others have to be configured as slaves (see 
Section 4.4.1) and must be connected to the master ServSwitch DKM FX via a 
network.

If you send a switching command via the OSD, the slave matrices will also switch.

NOTE: Switching of stacked devices might be delayed by several seconds.
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1 2      3         4     6       3   7     8

Figure 3-3. Parallel operation (stacking) application.

Table 3-3. Parallel operation  
(stacking) components.

Number Description

1 Dual-head source computer, CPU

2 CPU units

3 Interconnect cable

4 ServSwitch DKM FX (master)

5 ServSwitch DKM FX (slave)

6 Network connection master/slave(s)

7 CON units

8 Console (two monitors, keyboards, and mice

3.2.4 Cascading
For applications that exceed the number of available ports, you can extend the 
system by cascading.

In this case, the ServSwitch DKM FX devices are connected by so-called “tie lines.” 
The tie lines are dynamically configured to support connections in both directions.

5
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1 2    3           4         3         5           3  6     7

Figure 3-4. Cascading application.

Table 3-4. Cascading components.

Number Description

1 Source (computer, CPU)

2 CPU units

3 Interconnect cable

4 ServSwitch DKM FX (slave)

5 ServSwitch DKM FX (master)

6 CON unit

7 Console (monitor, keyboard, mouse)
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4. Configuration

4.1 Command Mode
The ServSwitch DKM FX has a Command Mode that enables several functions via 
keyboard command during normal use.

To enter Command Mode, use a hotkey sequence and to exit Command Mode, 
press <Esc>. While in Command Mode, the Shift and Scroll LEDs on the console 
keyboard will flash.

NOTE:  In Command Mode, normal keyboard and mouse operation will cease.  
Only selected keyboard commands are available.

The following table lists the keyboard commands to enter and to exit Command 
Mode and to change the hotkey sequence:

Table 4-1. Command mode components.

Function Keyboard command

Enter Command Mode (default) 2x <Right-Shift> (or hotkey)

Exit Command Mode <Esc>

Change hotkey sequence
<Left-Ctrl> + <Left-Shift> + <c>, <hotkey code>, <Enter> 
Since 8/10/2011: 
<current hotkey> + <c>, <new hotkey code>, <Enter>

NOTE:  <Key> + <Key> = Press keys simultaneously; <Key>, <Key> = Press keys 
successively, 2x <Key> = Press key quickly, twice in a row (similar to a 
mouse double-click).

You can change the hotkey sequence to enter Command Mode. The following 
table lists the hotkey codes for the available key sequences:
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Table 4-2. Command mode components.

Hotkey code Hotkey

1 <Left-Ctrl> + <Left-Shift> + <i>

2 2x <Scroll>

3 2x <Left-Shift>

4 2x <Left-Ctrl>

5 2x <Left-Alt>

6 2x <Right-Shift>

7 2x <Right-Ctrl>

8 2x <Right-Alt>

NOTE:  In a combined KVM matrix/U-Switch configuration, choose different  
hotkeys for the KVM matrix and the U-Switch.

4.2 Control Options
The ServSwitch DKM FX contains an internal CPU that enables you to control all 
functions from any console without the need for an external CPU or media  
control.

You have the following possibilities to access the ServSwitch DKM FX for  
configuration and operation:

• via OSD

• via Java Tool

• via serial interface

4.2.1 Control via OSD

Figure 4-1. OSD icon.

Via OSD (on-screen display), you set the configuration of the ServSwitch DKM FX 
operating system. The settings of the Configuration menu are described in this 
chapter. All other menus are described in later chapters.
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You can enter the OSD of the ServSwitch DKM FX:

• via keyboard connected to the CPU board

• via keyboard connected to a CON unit of an extender

Entering OSD

1. Start Command Mode with the hotkey (see Section 5.1).

2. Press <o> to open OSD. You will see a list of all available CPUs as a start menu.

3. Press <Esc> to enter the main menu.

Leaving OSD

•  Press <Shift> + <Esc> simultaneously. The OSD will close without any further 
changes and the currently active CPU connection will display.

Menu Structure

Figure 4-2. Menu structure.

The general layout of the OSD is structured into three areas:

• Upper status area (top-most two text lines)

• Working area
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• Lower status area (lowest two text lines)

Keyboard control

You can select between the following keyboard commands:

Table 4-3. Keyboard commands.

Function
Keyboard 
command

Left cursor—only within an input field or a switching screen <Cursor-Left>

Right cursor—only within an input field or a switching screen <Cursor-Right>

• In input fields: Line up (with wrap-around)

• In menus: Line up (without wrap-around)
<Cursor-Up>

• In input fields: Line down (with wrap-around)

• In menus: Line down (without wrap-around)
<Cursor-Down>

Previous page in menus with more than one page <Page-Up>

Next page in menus with more than one page <Page-Down>

Next input field <Tab>

Previous input field <Left-Shift> + <Tab>

Next option in selection fields <+>

Previous option in selection fields <->

Switching in selection fields between two conditions,  
for example, between ON/OFF or Y(Yes)/N(No)

<Space>

• In menus with input fields: Save data

• In menus: Select menu item
<Enter>

• In menus with input fields: Cancel data

• In menus with selection fields: Go back to the superior menu
<Esc>

Sorting Function

You can sort lists and tables in the Java Tool.
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Table 4-4. Sorting functions.

Function
Keyboard 
command

Sort ID numbers in a descending order or in an ascending order by  
pressing the keyboard command twice (ID)

<F1>

Sort ID names in a descending order or in an ascending order by pressing 
the keyboard command twice (Name)

<F2>

Go to the next result in the list of results for the search field (Next) <F3>

Go to the previous result in the list of results for the search field (Previous) <F3>

Refresh the currently shown list (Previous) <F4>

Refresh the currently shown field (Refresh) <F5>

Jump between the search field and the list of results (Find) <F6>

Password request

You have to log in with administrator rights to be able to set configurations.

Figure 4-3. Login Menu screen.

Access to the configuration menu requires administrator rights. User login is  
mandatory.
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Table 4-5. Menu login parameters.

Field Input

User admin

Password admin

NOTE:  For security reasons, change the administrator password as soon as  
possible.

4.2.2 Control via Java Tool

Figure 4-4. Java icon.

Requirements

If you want to use the Java tool, you need these items:

•  Computer with an executable Java tool and an installed Java Runtime 
Environment (JRE, version 1.6 or higher)

• Java Tool software

•  Available network connection between the Java tool and the ServSwitch DKM 
FX

NOTE:  Contact your system administrator concerning JRE and network  
connection.

Installation of the Java Tool

The Java tool is available as a single executable program file that does not require 
a separate installation.

Copy the tool after receiving the file to a directory on your computer.

NOTE:  If you do not have a Java tool, contact Black Box Technical Support  
at 724-746-5500 or info@blackbox.com. 

Computer Connection to the ServSwitch DKM FX

NOTE:  For a direct connection between the computer and ServSwitch DKM FX, 
use a cross-wired network cable.

           For a connection between the computer and ServSwitch DKM FX via 
switch or hub, use a straight-pinned network cable.
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Connect the network cable to the RJ-45 ports of the computer and CPU board of 
the ServSwitch DKM FX.

Start of the Java Tool

Open the Java tool by a double click on the program icon or use the <Enter> key 
on the keyboard.

Connection to the ServSwitch DKM FX

NOTE: Administrator rights are required.

1. Open the Java tool.

2. Select Switch > Connect in the menu bar.

3.  Enter the IP address in the popup input field according to the network  
configuration of the ServSwitch DKM FX (see Section 4.2.3).

4.  Enter the user name and password for the ServSwitch DKM FX (see Section 
4.4.1).

5. Confirm your inputs with the button “OK” or reject with “Cancel.”

Figure 4-5. Menu Connection screen.
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Menu structure

Figure 4-6. Example menu view (system-switch).

The menu structure of the Java tools is subdivided into various sections:

• Menu bar (top line)

• Toolbar (second line)

• Tab bar (third line)

• Task area (left menu section)

• Working area (right menu section)

• Status bar (bottom line section)

Operating Instructions

The operation of the Java tool is intuitive and corresponds to the user interface of 
common operating systems.

The Java tool contains its own support function.

This ServSwitch DKM FX manual only describes how to find and open the  
appropriate menus in the Java tool. For further operation, use the support  
function of the tool.
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You can activate or deactivate the integrated help texts in the working area of the 
Java tool by checking the box in the upper right corner.

Mouse Control

You can select between the following mouse commands:

Table 4-6. Mouse commands.

Function Mouse command

Menu selection, marking Left mouse button

Open function-specific selection menus Double-click the left mouse button

Open content-specific selection menus Right mouse button

Keyboard Control

You can select between the following keyboard commands:

Table 4-7. Keyboard commands.

Function Keyboard command

Cursor to the left <Cursor Left>

Cursor to the right <Cursor Right>

Line up <Cursor Up>

Line down <Cursor Down>

Previous page in input or status menus with more than one page <Page Up>

Next page in input or status menus with more than one page <Page Down>

Next field in input menus <Tab>

Previous field in input menus <Left-Shift> + <Tab>

•  Switching in selection fields between two conditions (checkmark or not)

•  Open already marked fields with editing or selecting capablility
<Space>

•  In menus: data saving

• Menu item selection
<Enter>

•  Leave tables

• Jump from tables into the next field
<Ctrl> + <Tab>
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Table 4-7 (Continued). Keyboard commands.

Function Keyboard command

• Leave tables

• Jump from tables into the previous filed

<Ctrl> + <Left-Shift> + 
<Tab>

Open content-specific selection menus Right mouse button

NOTE:  Various functions within the menus in the menu bar can be executed with 
the provided keyboard commands (for example, press <Ctrl> + <S> to exe-
cute Save) that are listed to the right of the respective menu item.

Reload Options

The information shown in the Java tool can be reloaded in different ways.

• Via <F5> key on the used keyboard

• Via Edit > Reload in the menu bar

• Via “Reload” Symbol in the symbol bar

Context Function

The Java tool offers several context functions that support a user friendly and 
effective operation of the tool. The context functions are described in the  
respective chapters.

To execute a context function, use the right mouse button on the corresponding 
field and select the desired function.

Sorting Function

Lists and tables in the Java tool offer a sorting function for fast and smooth 
search.

1.  For ascending sort status, use the left mouse button once to click into the 
header of the column you want to sort.

    The sort status is indicated by an arrow that points upwards.

2.  For descending sort, use the left mouse button twice to click on the header of 
the column that you want to sort. The sort is displayed by an arrow that points 
downwards.

3.  To cancel the sort, use the left mouse button once or twice to click on the 
header of the column that is sorted until the displayed arrow disappears.
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Filter Function

Lists and tables in the Java tool offer a filter function that enables a fast and 
smooth search.

1.  To activate a filter, use the right mouse button to click on the header of the  
column you want to filter and select Set Filter.

2. Write the word or part of a word you want to filter directly into the header.

    The filter results are shown immediately.

3.  To delete a filter, use the right mouse button to click on the header of the  
column you want to filter and select Clear Filter.

NOTE:   An asterix in the header indicates an active filter. 

         The filter function is based on the functional principle of common Web 
search engines.

Configuration in the Java Tool

You can only change configuration and system settings via Java tool in off-line 
mode without a direct connection between ServSwitch DKM FX and Java tool.

To activate a configuration in the ServSwitch DKM FX:

1. Select “File > Upload to” in the menu bar.

2.  Enter the IP address of the ServSwitch DKM FX (see Section 4.2.3) and the 
name and password of the user authorization and select the storage location  
of the new configuration (default or config01-08) in the menu “Select 
Configuration.”

3.  Select “Switch > Connect” in the menu bar and enter the IP address of the 
matrix and the name and password for user authorization.

4.  Select “Administration > Activate Configuration” in the task area and select the 
storage location that you selected above.

5. Use the “Activate” button to open the selected configuration within the matrix.

    The connection and the open tab will close, and the matrix will restart.

NOTE:  During the activation of a configuration, the matrix is temporarily not  
available.
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4.2.3 Control via Serial Interface

Figure 4-7. RS-232 icon.

The ServSwitch DKM FX operating system offers various functions for operation 
via serial interface. There are telegrams for switching single or all connections 
available, both unidirectional and bidirectional. There are also  
telegrams for an overall definition of the total switching status and for saving and 
loading such switching states.

The ServSwitch DKM FX has an option that provides an echo of all affected 
switching operations via serial interface or network interface. It enables you to 
track the current configurations of the matrix at any time so you can update your 
own applications.

You can also switch ServSwitch DKM FX clones as slaves (stacking) in parallel via a 
serial network interface.

4.3 Assignment
The ServSwitch DKM FX enables you to create a console-specific or a CPU-specific 
assignment.

• You can assign virtual CPUs to real CPUs.

• You can assign real consoles to virtual consoles.

4.3.1 Virtual CPU to real CPU
Switch several consoles to the same CPU. If there are several consoles connected 
to a virtual CPU that is assigned to a real CPU, you will only have to change the 
real CPU once and all the consoles will receive the video signal of the new CPU.

You can access the menu via OSD or Java.

Figure 4-8. OSD and Java icons.
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Java Tool

Select “Assignment > Virtual to Real CPU” in the task area.

Figure 4-9. Menu assignment—Virtual to Real CPU screen.

For an assignment, proceed as follows:

1. Select a virtual CPU in the “Virtual CPU” list.

2. Double-click in the “Real CPU” column to get a list of all available real CPUs.

3. Select a real CPU.

You can select between the following buttons:

Table 4-8. Selection buttons.

Button Function

Send Send assignments to the matrix

Reload Reload changes

NOTE:  By activating the Auto Send function in the left lower corner of the  
working area, switching operations will occur immediately without  
pressing the Send button to confirm.
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The selection boxes in the Real CPU column contain a filter function for an easy 
selection of single consoles from a larger pool of consoles (see Section 4.2.2).

The Java tool additionally offers the possibility to go directly from the Assignment  
menu to the Definition menu to check specific settings for the respective console 
or CPU.

Use the right mouse button to select the respective console or CPU and select 
“Open CON Device” or “Open CPU Device.”

4.3.2 Real Console to Virtual Console
You can assign real consoles to virtual consoles in this menu.

Using this function, you can change access permissions of the virtual console and 
apply them to all assigned real consoles, too.

You can access the menu via OSD or Java.

Figure 4-10. OSD and Java icons.

Java Tool

Select “Assignment > Real to Virtual Console” in the task area.

Figure 4-11. Menu Assignment—Real to Virtual Console screen.
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To place an assignment, proceed as follows:

1. Select the required real console in the table Real Console.

2.  Double-click in the Virtual Console column to get a list of all available virtual 
consoles.

3. Select the required virtual console.

You can select between the following buttons:

Table 4-9. Send and Cancel  
selection buttons.

Button Function

Send Send assignments to the matrix

Cancel Reject changes

NOTE:  If you activate the Auto Send function in the left lower corner of the  
working area, switching operations will occur automatically without  
pressing the Send button to confirm. 

The selection boxes in the Virtual Console column contain a filter function so you 
can easily select a single CPU from a larger pool of CPUs (see Section 4.2.2).

4.4 System Settings
You can configure the following system settings at the ServSwitch DKM FX.

NOTE: Only users with administrator rights can configure the system settings.

4.4.1 System Data
The system configuration is set in this menu.

You can access the menu via OSD and Java:

Figure 4-12. OSD and Java icons.

Select from the following settings:
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Table 4-10. System data settings.

Field Selection Description

Device Text Enter the device name of the matrix (default: SWITCH 01)

Name Text
Enter the name of the configuration that is used to save the current 
settings (default: Standard)

Info Text
Additional text field to describe the configuration (default: Factory  
settings)

Slave

Activated

If the matrix is defined as a slave in the OSD, the user will lose control 
automatically. Use the keyboard command <Shift><Shift><s><o>to 
recover control. The OSD will open again in the matrix defined as 
slave.

Deactivated Function not active (default)

Auto Save
Activated

Save the current configuration of the matrix in the flash memory 
periodically.

Deactivated Function not active (default)

Enable COM 
echo

Activated

Send all performed switching commands in the matrix as an echo via 
serial interface.

NOTE:  Enable this function when using media control via the serial 
interface.

Deactivated Function not active (default)

Enable LAN 
echo

Activated

Send all performed switching commands in the matrix as an echo via 
LAN connection.

NOTE:  Enable this function when using media control via the serial 
interface.

Deactivated Function not active (default)

Synchronize
Activated

Synchronize the slave matrix according to the switch status of the  
master matrix.

Deactivated Function not active (default)

Master IP 
address

Numerical value
Set the network address of the master matrix (default value: 
000.000.000.000)
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OSD

Select Configuration > System in the main menu.

Figure 4-13. Menu Configuration—System screen.

Table 4-11. Cancel and Save 
selection buttons.

Button Function

Cancel Reject changes

Save Save changes
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Java Tool

Figure 4-14. Menu System—System Data.

4.4.2 Automatic ID
From this menu, you can automatically create CPU and CON devices‘ settings by 
connecting a new extender unit.

You can access the menu via OSD or Java:

Figure 4-15. OSD and Java icons.
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You can select between the following settings:

Table 4-12. Automatic ID settings.

Field Selection Description

Enable Auto 
Config

Activated
Automatically creates a new CPU or CON device if new extender units 
are connected (default)

Deactivated Function not active

ID Real CPU 
Device

Numerical value Initial value of the automatic ID for real CPUs (default value: 1000)

ID Virtual 
CPU Device

Numerical value Initial value of the automatic ID for virtual CPUs (default value: 2000)

ID Real CON 
Device

Numerical value Initial value of the automatic ID for real CONs (default value: 3000)

ID Virtual 
CON Device

Numerical value Initial value of the automatic ID for virtual CONs (default value: 4000)

OSD

Select Configuration > System in the main menu.

Figure 4-16. Menu Configuration—System screen.



Page 64 724-746-5500   |   blackbox.com 

Chapter 4: Configuration

Table 4-13. Cancel and Save 
selection buttons.

Button Function

Cancel Reject changes

Save Save changes

Java Tool

Select “System > Automatic ID” in the task area.

Figure 4-17. Menu System—Automatic ID screen.

4.4.3 Access
The access configuration is set in this menu.

You have the following possibilities to access the menu:

Figure 4-18. OSD and Java icons.
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Table 4-14. Access settings.

Field Selection Description

Enable User 
Login

Activated
The user has to log in with a user name and a password code to enter 
OSD. Thereafter, the user remains logged in until he explicitly logs out 
or an auto logout is effected.

Deactivated Function not active (default)

Enable User 
ACL

Activated

CPU access is restricted according to the permissions in the ACL 
(Access Control List). 

• User login is required.

• Switching by keyboard hotkeys requires a prior login.

Deactivated Function not active (default)

Auto 
Disconnect

Activated
Upon opening the OSD, the console will automatically disconnect from 
the current CPU.

Deactivated Function not active (default)

OSD 
Timeout

0–999 seconds
Period of inactivity after which OSD will close automatically.

• Select 0 seconds, for no timeout (default: 0 seconds)

Auto Logout 0–999 minutes

Period of inactivity after which a user is automatically logged out from 
the OSD at this console.

• The timer is not active as long as the OSD is open.

• Select 0 minutes, for no timeout (default: 0 minutes)
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OSD

Select Configuration > Access in the main menu.

Figure 4-19. Menu Configuration Access screen.

You can select between the following buttons:

Table 4-15. Cancel and Save 
selection buttons.

Button Function

Cancel Reject changes

Save Save changes
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Java Tool

Select System > Access in the task area.

Figure 4-20. Menu System—Access screen.

4.4.4 Switch
The configuration of the switching parameters is set in this menu.

You have the following possibilities to access the menu:

Figure 4-21. OSD and Java icons.
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You can select between the following settings:

Table 4-16. Switch settings.

Field Selection Description

Video 
Sharing

Activated

The user can switch to any CPU as an observer, even to ones that are 
already assigned to another user (observer without keyboard/mouse 
access).

• NOTE: Switch with the <Space> key , not the <Enter> key.

•  The operator will not be informed if further users connect as an 
observer to the CPU that is connected to his console.

Deactivated Function not active (default)

Force 
Connect

Activated

The user can connect to every single CPU as an operator, even to ones 
that are related to another user.

• NOTE: The previous user is set to video-only status.

• To share K/M control, Force Connect must be activated.

Deactivated Function not active (default)

Force 
Disconnect

Activated

Extension of Force Connect: If the user connects to a CPU as an  
operator that is already related to another user, the connection to the 
previous user will be completely disconnected.

NOTE: To share K/M control, Force Connect must be deactivated.

Deactivated Function not active (default)

CPU Auto 
Connect

Activated
If a console is not connected to a CPU, you can establish an automatic 
connection to the next available CPU by pressing any key or mouse 
button.

Deactivated Function not active (default)

CPU 
Timeout

0–999  
minutes

Period of inactivity after which a console will automatically disconnect 
from its current CPU. (default value = 0 minutes)

Keyboard 
Connect

Activated Activate request of K/M control by keyboard event (key will be lost)

Deactivated Function not active (default)

Mouse 
Connect

Activated Activate request of K/M control by mouse event

Deactivated Function not active (default)
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Table 4-16 (continued). Switch settings.

Field Selection Description

Release Time
0–999  
seconds

Period of inactivity of a connected console after which K/M control 
can be requested by other consoles connected to the CPU.

• NOTE: Set “0” for an immediate transfer in real time.

•  Only one console can have keyboard and mouse control at the same 
time. The other consoles that are connected to the same CPU have a 
video-only status (default value: 10 seconds)

NOTE:  If the options Keyboard Connect and/or Mouse Connect are activated, the 
Release Time condition must be met until a new user gains control.

OSD

Select Configuration > Switch in the main menu.

Figure 4-22. Menu configuration–System.
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Table 4-17. Cancel and Save 
selection buttons.

Button Function

Cancel Reject changes

Save Save changes

Java Tool

Select “System > Switch” in the task area.

Figure 4-23. Menu system—switch.

4.4.5 Network
The network configuration is set in this menu.

You have the following possibilities to access the menu:

Figure 4-24. OSD and Java icons.
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Table 4-18. Network settings.

Field Selection Description

DHCP
Activated

The network settings are automatically supplied by a DNS server 
(default)

Deactivated Function not active

IP address Byte Input of the IP address in the form “192.168.1.1,” if DHCP is not active

Subnet 
Mask

Byte
Input of the subnet mask in the form “255.255.255.0,” if DHCP is not 
active (default 255.255.255.0)

Gateway Byte
Input of the subnet mask in the form “192.168.1.1,” if DHCP is not 
active

NOTE: To activate the modified network parameters, restart the ServSwitch DKM.

CAUTION:  Consult your system administrator before modifying the network 
parameters. Otherwise, unexpected results and failures can occur in 
combination with the network.

OSD

Select “Configuration > Network” in the main menu.

Figure 4-25. Menu Configuration—Network screen.
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Table 4-19. Cancel and Save 
selection buttons.

Button Function

Cancel Reject changes

Save Save changes

Java Tool

Select System > Network in the task area.

Figure 4-26. Menu system—network.

4.4.6 Date and Time
Date and Time are set in this menu.

You can access the menu via OSD:

Figure 4-27. OSD icon.
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Table 4-20. Date and time settings.

Field Selection Description

Month 1–12 Enter month

Date 1–31 Enter date

Year 1–99 Enter year

Day of the 
week

1–7 Enter week

Hours 0–23 Enter hour

Minutes 0–59 Enter minute

Seconds 0–59 Enter second

OSD

Select “Configuration > Date+Time” in the main menu.

Figure 4-28. Menu Configuration—Date and Time screen.
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You can select between the following buttons:

Table 4-21. Cancel and Save 
selection buttons.

Button Function

Cancel Reject changes

Save Save changes

4.5 User Settings
You have the possibility to configure the following user settings:

User Data

New users and their user settings and permissions are set in this menu.

You have the following possibilities to access the menu:

Figure 4-29. OSD and Java icons.

You can select between the following settings:

Table 4-22. User data settings.

Field Selection Description

Name Text User name (case-sensitive)

Password Text User password (case-sensitive)

Repeat 
Password

Text Repeat user password (case-sensitive)

HTTP
Activated Access permission via HTTP

Deactivated Function not active (default)

FTP

Activated
Access permission via FTP. This setting is necessary for file access from 
the Java tool or any Web browser.

Deactivated Function not active (default)
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Table 4-22 (continued). User data settings.

Field Selection Description

TEL

activated Access permission via Telnet

deactivated Function not active (default)

POW
activated

• User has rights

• Permission for crosspoint operations

deactivated Function not active (default)

ADM

activated

• Permission for system configuration and all switching operations

• User has administrator rights

• This setting is required for an online connection with the Java tool

deactivated Function not active (default)

OSD

Select “Configuration > User” in the main menu.

Figure 4-30. Menu Configuration—User screen.
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Table 4-23. OSD settings.

Button Function

New Create a new user

Edit Edit an existing user

Delete Delete an existing user

Cancel Reject changes

Save Save changes

Java Tool

Select “User > User Data” in the task area.

Figure 4-31. Menu User—User Data screen.

Table 4-24. OSD settings.

Button Function

New Create a new user

Delete Delete an existing user

Apply Create a new user account

Cancel Reject changes
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To configure user access rights for CPUs, proceed as follows:

1. Select a user in the User Data list.

2.  By using the right mouse button once on a CPU in one of the respective access 
lists (Full Access, Video Access, and No Access), two lists for selection will 
appear in which the respective CPU can be moved and the access rights can be 
changed.

3. Confirm the configuration by pressing the “Apply” button.

To create a new user, proceed as follows:

1. Press the “New” button.

2. Select a template of an existing user if applicable (choose template).

3. Press the “OK” button.

4. Set password.

5. Set general access permissions.

6. Set user permissions for CPU access (paste function).

7. Set user favorites for OSD access.

8. Press the “Apply” button to save the new user settings.

You can select between the following keyboard commands:

Table 4-25. Keyboard commands.

Function Keyboard Command

Add CPU to Full Access list <F>

Add CPU to Video Access list <V>

Add CPU to No Access list <N>

4.6 Extender Settings
All extender units are managed in this menu. This also contains the creation of 
new extender units and the deletion of existing extender units.

The extender unit describes the connection of a physical extender to the matrix. 
Every extender board with a direct cable connection to the matrix is recognized  
as an extender unit. Dual-head KVM extenders will be recognized as two  
independent extender units.

NOTE: KVM extenders automatically create extender units inside the matrix.
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To access the menu, use OSD or Java:

Figure 4-32. OSD and Java icons.

Table 4-26. OSD settings.

Field Selection Description

ID Text
Numerical value of the extender ID (KVM extenders: ID is  
provided by extender unit [serial no.] and cannot be changed)

Name Text Name of the extender unit

Fixed
Activated Create an extender unit with a fixed port assignment (default)

Deactivated Function not active (default)

Port
1–288 (depending 
on the matrix)

Port number of the extender unit
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OSD

Select “Configuration > EXT Units” in the main menu.

Figure 4-33. Menu Configuration—EXT Units screen.

You can select between the following buttons:

Table 4-27. Extender (EXT) units settings.

Button Function

New Create an extender unit

Edit Edit an existing extender unit

Delete Delete an existing extender unit

Cancel Reject changes

Save Save changes
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The settings for the tab OSD Data are described in Section 4.8.2.

Java Tool

Select “Definition > EXT Units” in the task area.

Figure 4-34. Menu Definition—EXT Units screen.

You can select between the following buttons:

Table 4-28. OSD settings.

Button Function

New Create a new extender unit

Delete Delete an existing unit

Apply Confirm changes of an extender unit

Cancel Reject changes
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1. To create a new extender unit press the button “New.”

2.  Select whether a template of an existing extender unit (“Choose extender as 
template”), a template of an predefined extender type (“Choose extender 
type”) or no template (“None”) should be used.

3. Press the “OK” button.

4. Set all relevant parameters for the extender unit.

5. Press the “Apply” button to save the new extender unit.

CAUTION:  Created extender units are always set as fixed port extenders. These 
configurations are necessary, if you want to switch, for example, USB 
2.0 connections via the matrix.

4.7 CPU Settings
New CPU devices are configured in this menu including their assignment to 
extenders.

The assignment helps to describe and switch more complex computer  
configurations (for example, Quad-Head with USB 2.0) in the matrix.

You can access the menu via the OSD or Java icon:

Figure 4-35. OSD and Java icons.

You can select between the following settings:

Table 4-29. CPU settings.

Field Selection Description

ID Text ID of the CPU unit (see Section 4.4.2)

Name Text Name of the CPU device

Fixed
Activated Create new CPU device as a virtual one

Deactivated Function not active (default)
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OSD

Select “Configuration > CPU Units” in the main menu.

Figure 4-36. Menu Configuration—CPU Devices screen.

You can select between the following buttons:

Table 4-30. CPU unit buttons.

Button Function

New R. Create a new real CPU unit

New V. Create a new virtual CPU unit

Edit Edit an existing CPU device

Delete Delete an existing CPU device

Cancel Reject changes

Save Save changes

Java Tool

Select “Definition > CPU Devices” in the task area.
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Figure 4-37. Menu Definition—CPU Devices screen.

You can select between the following buttons:

Table 4-31. CPU devices buttons.

Button Function

New Create a new CPU device

Delete Delete a new CPU device

Apply Confirm a created CPU device

Cancel Reject changes

> Assign selected extender units

>> Assign all available extender units

< Remove the selected extender units

<< Remove all extender units

You can select between the following keyboard commands:

Table 4-32. Keyboard commands.

Function Keyboard Command

Change assignment number of the extender unit upwards <+>

Change assignment number of the extender unit downwards <->
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To create a new CPU device, proceed as follows:

1. Press the “New” button.

2.  Select whether a real CPU (“Create a real CPU”) or a virtual CPU (“Create a  
virtual CPU”) should be created or a template of an existing CPU should be 
used (“Choose template”).

NOTE: A template can be used only if there is at least one existing CPU device.

3. Press the “OK” button.

4. Determine all parameters that are relevant for the CPU.

5. To confirm the new CPU, press the “Apply” button.

To access a new CPU via matrix, an assignment of one or more CPU type  
extender units is required. Proceed as follows:

1. Select the new CPU in the CPU devices list.

2. Select one or more extenders in the Extender available list.

3.  Perform the assignment by pressing the “>”button. To assign all available  
extenders to the CPU, press the “>>” button.

    The assignments are displayed in the Extender assigned list.

4. Confirm the assignment by pressing the “Apply” button.

To remove an extender assignment, proceed as follows:

1. Select a CPU in the CPU Devices list.

2. Select one or more extenders in the Extender assigned list.

3.  Remove the assignment with the button <. To remove all existing assignments, 
press the button <<.

4. Confirm the removal with the “Apply” button.

4.8 Console Settings
You can perform the following console settings:

4.8.1 CON Devices
New CON devices are created in this menu including access rights and assignment 
to extenders.
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You can access the menu via OSD or Java:

Figure 4-38. OSD and Java icons.

You can select between the following settings:

Table 4-39. CON devices settings.

Field Selection Description

ID Text ID of the CON unit (see Section 4.4.2)

Name Text Name of the CON device

Virtual 
device

Activated Create new CON devicd as a virtual one

Deactivated Function not active (default)

Allow login
Activated Allow user login at this CON device

Deactivated Function not active

Force login
Activated Force user login at this CON device

Deactivated Function not active

OSD

Select “Configuration > CON Devices” in the main menu.

Figure 4-39. Menu Configuration—CON Devices screen.
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You can select between the following buttons:

Table 4-34. CON devices buttons.

Button Function

New R. Create a real console

New V. Create a virtual console

Edit Edit an existing console

Delete Delete an existing console

Cancel Reject changes

Save Save changes

Java Tool

Select “Definition > CON Devices” in the task area.

Figure 4-40. Menu Configuration—CON Devices screen.
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Table 4-35. Menu configuration— 
CON devices buttons.

Button Function

New Open a new CON device

Delete Delete a new CON device

Apply Confirm a created CON device

Cancel Reject changes

> Assign selected extender units

>> Assign all available extender units

< Remove the selected extender units

<< Remove all extender units

You can select between the following keyboard commands:

Table 4-36. Keyboard commands.
Function Keyboard Command

Decrease assignment number of the extender unit <+>

Increase assignment number of the extender unit <->

To create a new console, proceed as follows:

1. Press the “New” button.

2.  Select “Create a real Console” to create a real console or a select “Create a  
virtual Console” to create a virtual console, or select “Choose template” to use 
the template of an existing console.

3. Press the “OK” button.

4. Determine all parameters that are relevant for the console.

5. To confirm a created console, press the “Apply” button.

To run a created CPU via matrix, you need to assign one or more CON units 
(extenders). To place an assignment, proceed as follows:

1. Select the console in the CON devices list to be assigned to an extender.

2. Select the extender in the Extender available list to be assigned to the CON.

3.  Perform the assignment by pressing the “>” button. To assign all available  
extenders to the console, press the “>>” button. The assignments are displayed 
in the Extender assigned list.
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4. Confirm the assignment by pressing the “Apply” button.

To remove an extender assignment, proceed as follows:

1. Select the console in the CON devices to be modified list.

2. Select the extender(s) in the Extender assigned to be removed list.

3.  Remove the assignment with the “<” button. To remove all existing  
assignments, press the “<<” button.

4. Confirm the changes by pressing the “Apply” button.

To configure the access rights of consoles to CPUs, proceed as follows:

1. Select a console in the CON devices list.

2. Open the “CPU Access Control” tab.

3.  Assign new access rights by using the right mouse button or the respective  
keyboard commands (see below).

4. Confirm the configuration by pressing the “Apply” button.

NOTE:  Once created, a new user automatically receives full access to all available 
CPUs.

You can select between the following keyboard commands:

Table 4-37. Keyboard commands.
Function Keyboard Command

Add CPU to Full Access list <F>

Add CPU to Video Access list <V>

Add CPU to No Access list <N>

4.8.2 Mouse and Keyboard
From this menu, you can set the OSD configuration for mouse and keyboard. You 
can access the menu via OSD or Java.

Figure 4-41. OSD and Java icons.
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Table 4-38. Mouse and keyboard settings.

Field Selection Description

Horizontal speed 1/x 1–9
Adjusts the horizontal mouse speed:  
1= slow, 9 = fast (default value = 4)

Vertical speed 1/x 1–9
Adjusts the vertical mouse speed:  
1= slow, 9 = fast (default value = 5)

Double-click 100–800
Adjusts the time slot for a double-click 
(default value = 200 ms)

Keyboard layout Region
Set the OSD keyboard layout according 
to the keyboard you are using (default: 
German [DE])

Video mode
Variable or specific 
resolution

Resolution that is used when opening 
OSD

NOTE:  The mouse and keyboard settings are console specific. You can set them  
separately for every console.

OSD

Select “Configuration > EXT Units” in the main menu.

Figure 4-42. Menu Configuration—EXT Units screen.
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You can select between the following buttons:

Table 4-39. Buttons.

Button Function

Cancel Reject changes

Save Save changes

Java Tool

Select “Definition > EXT Units” in the task area.

NOTE: Set mouse and keyboard settings using the OSD Data tab.

Figure 4-43. Menu Definition—EXT Units screen.

4.9 Saving and Loading Configurations
You can set the following configurations:

4.9.1 Active Configuration
Use the OSD button to access the menu:

Figure 4-44. OSD button.
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Select “Configuration > Save” in the main menu.

By selecting this menu item, the active configuration of the matrix is saved to the 
permanent matrix memory. By default, the last configuration that has been saved 
in this way will be restored after the matrix restarts.

NOTE:  Changing or saving configurations blocks the matrix memory and freezes 
all OSD menus for a few seconds. The switching connections are not 
affected by this freeze.

If you select “Auto Save” within the system settings, it will automatically save the 
configuration periodically.

4.9.2 Saving Configurations (Internal)
In this menu, the current matrix configuration to predefined storage locations is 
saved. However, it does not replace configuration buffering.

You can access the menu via OSD or Java:

Figure 4-45. OSD and Java icons.

In Active, the name and detailed information of the current configuration are 
shown. This configuration can be saved now.

In Default and File #1 to File #8, the name and the detailed information of the 
respective saved configuration are shown. You can overwrite these storage  
locations.

The storage location to be overwritten by the current configuration must be 
selected explicitly.

Afterwards, the current configuration will be saved to this storage location and 
will be immediately shown in the menu. The previously saved configuration that 
was saved to this storage location is deleted.

OSD

You can save the created configuration within eight storage locations in the matrix 
(File #1–File #8). You can also save a configuration as the default configuration.

1. Select “Configuration > Save As…” in the main menu.

2. Select the required storage location “(File #1–File #8)” or “Default.”
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Figure 4-46. Menu Configuration—Save As screen.

Java Tool

To save the configuration into the internal matrix memory, proceed as follows:

1. Select “File > Upload to…” in the menu bar.

2.  Enter the IP address of the matrix, your user name, and your password, and 
select the storage location where the configuration will be saved (default or  
config01–config08).

3. Press the “OK” button to confirm.
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Figure 4-47. Menu File—Upload to screen.

4.9.3 Loading of Configurations (Internal)
Previously saved configurations are loaded in this menu.

You have the following possibilities to load configurations from files:

Figure 4-48. OSD and Java icons.

In Active, the currently loaded configuration is displayed.

In addition to the default configuration, you can load up to eight further  
configurations.

Select the configuration to be loaded from eight personalizable configurations and 
the default settings.

The selected configuration will be immediately loaded and displayed in the menu 
as “Active.” The previously active configuration is deleted.
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OSD

1. Select “Configuration > Open” in the main menu.

2. Select the desired configuration.

3. Load the configuration by pressing the <Enter> key.

Figure 4-49. Menu Configuration—Open screen.

Java Tool

1.  Select “Administration > Activate Configuration” during on-line mode in the 
task area.

2. Select the required configuration.

3. Load the configuration by pressing the “Activate” button.
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Figure 4-50. Menu Administration—Activate Configuration on Switch screen.

4.9.4 Saving Configurations (External)
You can save created configurations as a file, so that they will be independent of 
the matrix and transportable.

You have the following possibility to access the menu:

Figure 4-51. Java icon.

1. Select “File > Save As” in the menu bar.

2.  Select the directory of the configuration on your storage medium where it will 
be saved.

NOTE: Configurations are always saved in a file with the ending “dtc.”



Page 96 724-746-5500   |   blackbox.com 

Chapter 4: Configuration

Figure 4-52. Menu File—Save As screen.

4.9.5 Loading Configurations (External)
Externally saved configurations are opened and activated in this menu.

You have the following possibilities to load configurations from files:

1.  Select “File > Open…” during off-line mode and select the storage location of 
the configuration file that has to be opened.

2. Open the configuration by pressing the “Open” button.

3.  Select “File > Upload to…” in the menu bar to transfer the opened  
configuration to the matrix. Enter the necessary parameters.

4.  Select “Switch > Connect” in the menu bar to make a connection between the 
matrix and the Java tool. Enter the necessary parameters.

5.  Select “Administration > Activate Configuration” and select the configuration 
to be activated.

6. Confirm the process with the “Activate” button.

The opened configuration is activated now and can be used.
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Figure 4-53. Menu File–Open screen.

4.10 Export and Import Options
The ServSwitch DKM FX offers the possibility to read out available configuration 
lists (extender, CPUs, consoles and users) for exporting and importing again via 
Java tool. You have the following possibilities to handle configuration lists.

Exported configuration lists are always saved in “.csv” format that allows off-line 
editing with common spreadsheet applications.

You have the following possibilities to export or import configuration lists:

Figure 4-54. Java icon.

4.10.1 Export Options
Configuration lists are exported in this menu. To export, proceed as follows:

1. Select “File > Export” in the menu bar.

2.  After opening the menu, select the list to export (Extender, CPU, Console or 
User).
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3. Select the storage location for the export file.

4. Confirm the export with the “Finish” button.

Figure 4-55. Menu File–Export screen.

4.10.2 Import Options
Configuration lists are imported in this menu. To import, proceed as follows:

1. Select “File > Import” in the menu bar.

2.  After opening the menu, select the list to import (Extender, CPU, Console or 
User).

3. Select the directory of the list to import.

4. Confirm the import with the “Finish” button.
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Figure 4-56. Menu File–Import screen.

4.11 Firmware Update
The firmware of the matrix can be updated in this menu.

To access the menu, use the Java icon:

Figure 4-57. Java icon.

1. Select “Administration > Update Firmware” in the task area.
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Figure 4-58. Menu Administration–Update Firmware screen.

2.  Select the directory in the lower part of the working area in which the update 
files can be found.

3.  Select those modules in the list that have to be updated and enable the  
respective checkbox in the Update column.

4.  Start the update by pressing the “Update” button in the lower part of the  
working area.

5.  Restart the matrix by pressing the “Restart matrix” button in the lower part of 
the working area.
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5. Operation
You can operate the ServSwitch DKM FX in three different ways:

1. Direct Switching

•  via a keyboard connected to a CON port and the hotkeys

•  by a macro keyboard connected to a console port

2. OSD

•  via keyboard/mouse directly connected to the CPU board of the matrix

•  via keyboard/mouse connected to a CON Unit and the OSD

3. External Switching Commands:

•  via an external computer via Java tool (network connection required)

•  via a media control (network or serial connection required)

5.1 Operation via Hotkeys
5.1.1 Direct Switching
The direct switching by hotkeys on a keyboard is the fastest way for a user to 
switch at his console between different CPUs. He can switch video, keyboard and 
mouse, or only video.

Direct Switching of Video, Keyboard, and Mouse

1.  Start Command Mode with the hotkey. For control, the LEDs Shift and Scroll 
flash at the keyboard, if Command Mode is activated.

2.  Enter the index number of the new CPU from the list of favorites and confirm 
with <Enter>. At the same time, the Command Mode is closed and the console 
is connected to the new CPU with complete control.

NOTE:  For best switching time, use identical mice, keyboards, and monitors.  
This contributes to a smooth and delayless direct switching of the matrix.

Direct Switching of Video

1.  Start Command Mode with the hotkey. For control, the LEDs Shift and Scroll 
flashes at the keyboard, if command mode is activated.

2.  Enter the index number of the new CPU from the list of favorites and confirm 
with <Space>.

At the same time, the Command Mode is closed and the console is connected to 
the new CPU with video only.
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NOTE:  You can only use the hotkeys to switch to unused and allowed CPUs. 
Hotkeys are only supported if neither “Enable User Login” nor “Enable User 
ACL” is selected and the user is logged in the OSD.

5.1.2 Scan Mode
The Scan Mode can show video signals of the different CPUs fast and without 
delay and switch continuously using the hotkey. Switching between two video  
signals can even take place within one frame.

1.  Start command mode with the hotkey. For control, the “Shift” and “Scroll” 
LEDs flash at the keyboard if command mode is activated.

2.  Press the “<Left Shift>” key and hold it down. You can now enter the index 
numbers of the various CPUs from the list of favorites with the keyboard and 
immediately switch to the video signal of the respective CPU after entering the 
index number.

3. Leave Scan Mode by pressing “<Left Shift> + <Esc>.”

NOTE:  For optimal results, use identical resolutions. This contributes to a smooth 
and delay-free scan mode function.

5.1.3 Addressing Master and Slave
The ServSwitch DKM FX can be cascaded in two steps. You can optionally send 
the commands (including opening the OSD) to the master or the slave matrix.

Whenever command mode is activated, you can select by a <m> or a <s>, if all 
the following commands should be handled in the master or in the slave matrix.

OSD Access

• OSD access to the master matrix:

   <Left Shift>, <Left Shift>, <m> (optional), <o>

• OSD access to the slave matrix:

   <Left Shift>, <Left Shift>, <s>, <o>

Example: Switching to the CPU Port 23 of the slave matrix.

1.  Switching to the CPU port (e.g. 12) of the master matrix that has the  
connection to the slave matrix:

   <Left Shift>, <Left Shift>, <m> (optional), <1>, <2>, <Enter>
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2. Switching to the CPU Port 23 of the slave matrix:

   <Left Shift>, <Left Shift>, <s>, <2>, <3>, <Enter>

NOTE:  The selected master/slave mode is permanently activated until another 
mode is manually activated. This means that if you select <s> for example, 
all prospective commands will be sent to the slave, but not if the Command 
Mode is left in the meantime.

5.1.4 Function Keys <F1>–<F12>
In Command Mode you can retrieve the Macros 1–12 with the function keys 
<F1>–<F12> of the connected standard keyboard instead of the special macro 
keyboard.

The deposited command sequence for the appropriate function key is executed 
and Command Mode is left immediately.

By using <s> or <S> and <m> or <M> before you key in other commands, you 
can select whether the command sequence should be executed for the master or 
the slave.

NOTE:  The chosen control level remains selected only if the switch remains in 
Command Mode.

5.2 KVM Switching
To switch using the ServSwitch DKM FX, use OSD or Java:

Figure 5-1. OSD and Java icons.
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OSD

Select “Switch” in the main menu.

Figure 5-2. Menu Switch screen.

The following information is shown in this menu:

Table 5-1 Menu switch.
Field Description

CON device Assigned physical extender unit (CON unit)

CON assigned Virtual CON device that is assigned to the real CON device

CPU connected Currently connected CPU device

CON status Current connection status (CON device)

EXT list LIst of all available physical extender units (CON units)

CPU device Assigned physical extender unit (CPU unit)

CPU assigned Real CPU device that is assigned to a virtual CPU device

CON connected Currenlty connected CON device

CPU status Current connection status (CPU device)

EXT list List of all available extender units (CPU units)
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You can select from the following switching functions:

Table 5-2. Switching functions.
Function Keyboard Command

Set a video-only connection <Space>

Set a KVM connection <Enter>

Set a KVM connection in private mode (video sharing disabled) <Shift>+<Enter>

Disconnect own CON device from CPU device <Backspace>

Java Tool

Select “Switch > Switch Console to CPU” in the task area.

Figure 5-3. Menu Switch—Switch Console to CPU.

All connected consoles and the associated CPU connections are shown in columns 
in the working area in this menu.

NOTE:  Switching operations can only be performed in on-line mode, that means 
an active network connection between the matrix and the Java tool is 
needed.



Page 106 724-746-5500   |   blackbox.com 

Chapter 5: Operation

To set a KVM connection between a console and a CPU, double-click on the  
corresponding selection box within the CPU column and select the requested CPU 
(green).

To set a video connection between a console and a CPU, double-click on the  
corresponding selection box within the CPU column and select the requested CPU 
(orange).

NOTE:  CPUs whose respective console does not have access rights will not appear 
in the list.

You can use the following button to perform a switching operation:

Table 5-3. Switching button.
Button Function

Send Send effected switching operations to the matrix

NOTE:  By activating the function Auto Send in the left lower corner of the  
working area, switching operations will be done immediately without  
confirmation by pressing the Send button.

Additionally, the menu offers the possibility to get from any console or CPU into 
the associated configuration menu in the task area.

1.  To get directly to Definition > CON Devices, use the right mouse button to click 
on the respective console in the list and select “Open CON Device.”

2.  To get directly to Definition > CPU Devices, use the right mouse button to click 
on the respective console in the list and select “Open CPU Device.”

5.3 Serial Interface

Figure 5-4. OSD icon.

The ServSwitch DKM FX enables you to switch via a serial interface (RS-232).

Detailed information for the serial interface and the corresponding switching  
commands can be found in Chapter 6.
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5.4 Power On and Power Down Functions
The ServSwitch DKM FX has the following power on and power down functions: 
restart and reset.

5.4.1 Restart
To perform a restart, use OSD.

Figure 5-5. OSD icon.

OSD

1.  Select “Configuration > Restart Matrix” or “Restart IO Board” in the main 
menu to restart either the matrix or the I/O boards.

2. To confirm the selection, press the “Yes” button.

The ServSwitch DKM FX will be restarted with the current settings.

5.4.2 Reset
Use the OSD to reset the extender:

Figure 5-6. OSD icon.

NOTE:  If a firmware update has been done since the delivery, the matrix will be 
set to the state defined there.

OSD

1. Select “Configuration > Reset Matrix” in the main menu.

2. To confirm the selection, press the “Yes” button.

The ServSwitch DKM FX will be reset to the factory settings.

5.4.3 Power Down
Slide the on and off switch at the main sockets of the power supply units to start 
or switch off the matrix.
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6. Serial Control
Use the following parameters to control the ServSwitch DKM FX via its serial  
interface.

115.2K, 8, 1, NO

(115.2 kbps, 8 data bits, 1 stop bit, no parity)

Command

<STX>, <command byte (CMD)>, [data bytes (D0…DN)], <ETX>

[ ] = Optional elements

Response

<ACK> , [<ECHO>]

[ ] = Optional elements

<ECHO> reports the ServSwitch DKM FX sequences enabled by a command that 
shows the new switching status of the ServSwitch DKM FX. The echo can be 
used to update user applications and to operate several matrices in parallel.

Parameter Description

Command byte: In the range 0x40 to 0x6F (see the list of allowed commands 
below).

Data bytes: a) To prevent transferring control statements of control commands 
while transferring binary data, the data are divided into low-nibble and high- 
nibble. The data are distributed to the low nibbles of two bytes and provided  
with an offset by 0x60, for example, 0x1F.

=> 0x61 + 0x6F

b) 7-bit data: (0x0 to 0x7F) are provided with an offset by 0x80,  
    e.g. 0000011 => 0x83

c) ASCII data => 0x20 to 0x7E are transmitted unencrypted.
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(Special) characters: 

 ACK  0x06 
 NAK  0x15 
 STX  0x02 
 ETX  0x03 
 CR  0x0D 
 ESC  0x1B 
 HTAB  0x09 
 LF  0x0A

Sequence of a Data Communication

Table 6-1. Data communication sequence.

ServSwitch KVM DKM FX Control CPU

— 1. Send a command

2.  Acquire a command, process a  
command, block further commands.

—

3. a) Errors occurred: <NAK> 
    b) No errors: <ACK><ECHO> 
    c) Optional: Reply telegram with data

—

—
4. a) Repeat telegram 
    b) Next command 
    c) Receive and process the repeat telegram

NOTE: The serial interface can be blocked while OSD is open.

Switching Functions Telegrams

Table 6-2. Input port’s request for output port.

Bytes Description Coding

1 Control character 0x1B

1 Server indentification 0x5B

1 Command 0x42

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Requested output port (binary, 1…max. ports)
0x01 0x00 (for port 1) to 0x120 0x00 (for port 
288)
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Example:
Input port’s request for output Port 160
0x1B 0x5B 0x42 0x07 0x00 0xA0 0x00

Table 6-3. Return of input port for output port.

Bytes Description Coding

1 Control character 0x1B

1 Server indentification 0x5B

1 Command 0x42

2 Requested output port (binary, 1…max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)

2 Assigned input port (binary, 1…max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)

Example:
Input Port 17’s return for output Port 160
0x1B 0x5B 0x42 0x09 0x00 0xA0 0x00 0x11x00

Table 6-4. Connection of input port with output port.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x43

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested output port (binary, 1…max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)

2 Assigned input port (binary, 1…max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)

Example:
Connection of input Port 17 with output Port 160
0x1B 0x5B 0x43 0x09 0x00 0xA0 0x00 0x11 0x00
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Table 6-5. Request of input port for output port with a fixed total port number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x44

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2
Number of output ports  (binary, 1…max. 
ports)

0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 287)

2 Requested output port (binary, 1…max. ports) 0x01 0x00 (for Port 1) to 0x120 0x00 (for Port 288)

Example:

Request of input port for output Port 25 with a total port number of 160

0x1B 0x5B 0x44 0x09 0x00 0xA0 0x00 0x19 0x00

Table 6-6. Return of input port for output port with a fixed port number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x44

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Number of output ports  (binary, 1…max. 288 
ports)

0x01 0x00 (for Port 1) to 0x120 0x00 (for 287 
ports)

Example:

Return of input Port 17 for output Port 25 with a total port number of 160.

0x1B 0x5D 0x44 0x09 0x00 0xA0 0x00 0x19 0x00 0x11 0x00
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Table 6-7. Connection of input port with output port  
with a fixed total port number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x45

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Number of output ports  (binary, 1…max. 
2887ports)

0x01 0x00 (for Port 1) to 0x120 0x00 (for 287 
ports)

Example:

Connection of input Port 17 with output Port 25 with a total port number of 160

0x1B 0x5B 0x45 0x07 0x00 0xA0 0x00 0x19 0x00 0x11 0x00

Table 6-8. Request of switching matrix.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x46

Table 6-9. Return of the switching matrix (input port for all output ports).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x46

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Input port whose signal is sent to output port 
OutPort (n)

0x01 0x00 (for Port 1) to 0x120 0x00 (for 288 
ports)
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Example:

Return input Port 17 for all output ports

0x1B 0x5D 0x46 0x07 0x00 0x11 0x00

Table 6-10. Request of CPU (input) for CON (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x46

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Requested output console
0x01 0x00 (for Console 1) to 0x11F 0x00  
(for Console 287)

Example:

Request of CPU (input) for Console 23

0x1B 0x5B 0x47 0x07 0x00 0x17 0x00

Table 6-11. Return of CPU (input) for CON (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x47

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested output console
0x01 0x00 (for Console 1) to 0x11F 0x00 (Console 
287)

2 Requested input CPU 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU 287)

Example:

Return of CPU 34 for Console 23

0x1B 0x5D 0x47 0x09 0x00 0x17 0x00 0x22 0x00
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Table 6-12. Connection of CPU (input) with CON (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x48

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested console
0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
Console 287)

2 Requested CPU
0x01 0x00 (for CPU 1) to 0x11F 0x00 (for  
CPU 287)

Example:

Connection of CPU 43 with Console 23

0x1B 0x5B 0x48 0x09 0x00 0x17 0x00 0x2B 0x00

Table 6-13. Request of CPU (input) for CON (output)  
with a fixed console number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x49

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2
Total number of consoles (binary, 1…max. 
CONs)

0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
287 Consoles)

2 Requested consoles
0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
Console 287)

Example:

Request of CPU (input) for Console 23 with 50 consoles in total

0x1B 0x5B 0x49 0x09 0x00 0x32 0x00 0x17 0x00
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Table 6-14. Return of CPU (input) for CON (output)  
with a fixed console number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5D

1 Command 0x49

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Total number of consoles (binary, 1…max. 
CONs)

0x01 0x00 (for console 1) to 0x11F 0x00 (for  
287 consoles)

Example:

Return of CPU 43 for Console 23 with 50 consoles in total

0x1B 0x5D 0x49 0x07 0x00 0x32 0x00 0x17 0x00 0x2B 0x00

Table 6-15. Connection of CPU (input) for CON (output)  
with a fixed console number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x50

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Total number of consoles (binary, 1…max. 
CONs)

0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
287 consoles)

Example:

Connection of 43 with Console 23 with 50 consoles total

0x1B -x5B 0x50 0x07 0x00 0x32 0x00 0x17 0x00 0x2B 0x00
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Table 6-16. Request of CON (input) for CPU (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x51

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2
Total number of consoles (binary, 1…max. 
CONs)

0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU 
287)

Example:

Request of CON (input) for CPU 23

0x1B 0x5B 0x51 0x07 0x00 0x17 0x00

Table 6-17. Return of CON (input) for CPU (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5D

1 Command 0x51

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested output CPU 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU 287)

2 Requested input console
0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
console 287)

Example:

Request of Console 23 for CPU 23

0x1B 0x5D 0x09 0x00 0x2B 0x00 0x17 0x00
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Table 6-18. Connection of CON (input) with CPU (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x52

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Requested output CPU 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for CPU 287)

2 Requested input console
0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
Console 287)

Example: 
Connection of Console 23 with CPU 43

0x1B 0x5B 0x52 0x09 0x00 0x2B 0x00 0x17 0x00

Table 6-19.  Request CON (input) for CPU (output) with a fixed CPU number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x52

2 Total length of telegram (9 bytes, binary) 0x09 0x00

2 Total number of CPUs 0x01 0x00 (for CPU 1) to 0x11F 0x00 (for 159 CPUs)

2
Requested output for CPU (binary, 1…max. 
CPUs)

0x01 0x00 (for Console 1) to 0x11F 0x00 (for  
Console 287)

Example:

Request for CPU 43 with 50 CPUs in total

0x1B 0x5B 0x53 0x09 0x00 0x32 0x00 0x2B 0x00
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Table 6-20.  Return of CON (Input) for CPU (Output) with a fixed CPU number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5D

1 Command 0x53

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Total number of CPUs 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)

Example:

Return of Console 23 for CPU 43 with 50 CPUs in total

0x1B 0x5D 0x53 0x07 0x00 0x32 0x00 0x2B 0x00 0x17 0x00

Table 6-21. Connection of CON (input) with CPU (output)  
with a fixed total CPU number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x54

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Total number of CPUs 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)

Example:

Connection of Console 23 with CPU 43 with 50 CPUs in total

0x1B 0x5B 0x54 0x07 0x00 0x32 0x00 0x2B 0x00 0x17 0x00
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Table 6-22. Connection of CON (input) with CPU (output)  
and CPU (input) with CON (output).

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x55

2
Total length of telegram  
(9 bytes, binary)

0x09 0x00

2 Requested CPU 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)

2 Requested console 0x01 0x00 (for Console 1to 0x11F 0x00 (for Console 287)

Example:

Connection of Console 23 (input) with CPU 43 (output)

0x1B 0x5B 0x55 0x09 0x00 0x2B 0x00 0x17 0x00

Table 6-23. Connection of CON (input) with CPU (output)  
and CPU (input) with CON (output) with a fixed CPU number.

Bytes Description Coding

1 Control character 0x1B

1 Server identification 0x5B

1 Command 0x56

2 Total length of telegram (7 bytes, binary) 0x07 0x00

2 Total number of CPUs 0x01 0x00 (for 1 CPU) to 0x11F 0x00 (for 287 CPUs)

Example:

Connection of Console 23 with CPU 43 and Console 24 with CPU 44 with 50 
existing CPUs

0x1B 0x5B 0x56 0x07 0x00 0x32 0x00 0x2B 0x00 0x17 0x00 0x2C 0x00

0x18 0x00
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7. Troubleshooting
Tables 7-1 through 7-7 in Sections 7.1 through 7.7 provide support for problems 
with the ServSwitch DKM FX matrix. This help assumes a functional extender 
route. Before running, make sure your extenders’ matrixes work over a peer-to-
peer connection. This can be supported by the use of a CATx or fiber coupler.

7.1 External Failure

Table 7-1. External failure.

Problem Possible Cause Solution

ServSwitch DKM FX cannot be started Fuse at the standard appliance outlet is out Check fuse

7.2 Video Interference

Table 7-2. Video interference.

Problem Possible Cause Solution

Opening the OSD is not possible No OSD jumper set Set Jumper 11 on the CON unit

Incorrect video display Cable connection disturbed
Check the connection, length, 
and quality of the interconnection 
cable to the units

7.3 Fans Malfunction

Table 7-3. Fans malfunction.

Problem Possible Cause Solution

Fans only run under full load
Communication to fan 
tray is disturbed

Remove and reinstall the fan tray

Fans do not run; LED OK is on Fans are defective
Contact Black Box Technical Support at 
724-746-5500 or info@blackbox.com
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7.4 Power Supply Units Malfunction

Table 7-4. Power supply units malfunction.

Problem Possible Cause Solution

ServSwitch DKM FX  
cannot be started

Power supply units not locked 
correctly

Check the power supply unit’s lock and 
plug-in

No power supply is available
Check that cables for the power supply 
are connected correctly

Power supply units are not 
switched on

Check the slide to switch on the power 
supply units

7.5 Network Error

Table 7-5. Network error.

Problem Possible Cause Solution

Network settings are not resumed after 
editing

ServSwitch DKM FX restart is not 
yet completed

Restart the unit

7.6 ServSwitch DKM FX Failure

Table 7-6. ServSwitch DKM FX failure.

Problem Possible Cause Solution

Serial control is impossible  
or restricted

CPU and ServSwitch DKM FX 
are running at a different baud 
rate

Adapt the baud rate in the 
ServSwitch DKM FX and in the 
CPU

Serial control via the RJ-45 
port is not possible

Wrong network cable Use a cross-pinned network cable

Port definitions as USB 2.0 
invalid

ServSwitch DKM FX restart not 
yet completed

Restart the ServSwitch DKM FX
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7.7 Blank Screen

1   2         3

1  2         3 3

Figure 7-1. LEDs on the ServSwitch DKM FX.

Table 7-7. LED indications.

Problem Possible Cause Solution

Monitor remains dark after 
switching operation

Switching to a CPU port 
without active source 
(computer, CPU)

Connect the computer or CPU

Connection of a console 
with a CON port or  
connection of a CPU to a 
CPU port not established 
correctly

Check CON and CPU port connections at the 
ServSwitch DKM FX

LED 1 on or LED 2 off
Connections of the CON 
unit, ServSwitch DKM FX, 
and the CPU unit

Check the cables and connectors (no cable, 
cable break, CPU/CON unit off-line, CPU/CON 
unit connected to the wrong port

LED 3 off Power supply
Check the power supply units and connection 
to the power network

7.8 Contacting Black Box
If you determine that your ServSwitch DKM FX is malfunctioning, do not attempt 
to alter or repair the unit. It contains no user-serviceable parts. Contact Black Box 
Technical Support at 724-746-5500 or info@blackbox.com.
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Before you do, make a record of the history of the problem. We will be able to 
provide more efficient and accurate assistance if you have a complete description, 
including:

• the nature and duration of the problem.

• when the problem occurs.

• the components involved in the problem.

•  any particular application that, when used, appears to create the problem or 
make it worse.

7.9 Shipping and Packaging
If you need to transport or ship your ServSwitch DKM FX:

• Package it carefully. We recommend that you use the original container.

•  If you are returning the unit, make sure you include everything you received 
with it. Before you ship for return or repair, contact Black Box to get a Return 
Authorization (RA) number.
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Appendix. Glossary

The following terms are commonly used in this guide or in video and KVM  
technology:

AES/EBU — Digital audio standard officially known as AES3, used for carrying 
digital audio signals between devices.

CATx — Any CAT5e (CAT6, CAT7) cable.

CGA — The Color Graphics Adapter (CGA) is an old analog graphics standard  
with up to 16 displayable colors and a maximum resolution of 640 x 400 pixels.

Component Video — The Component Video (YPbPr) is a high-quality video  
standard that consists of three independently and separately transmittable video 
signals, the luminance signal, and two color difference signals.

Composite Video — The Composite Video is also called FBAS and it is part of 
the PAL TV standard.

CON Unit — Component of a ServSwitch DKM FX or media extender that  
connects to the console (monitor[s], keyboard and mouse; optionally also with 
USB 2.0 devices).

CPU Unit — Component of a ServSwitch DKM FX or media extender that  
connects to a source (computer, CPU).

DDC — The Display Data Channel (DDC) is a serial communication interface 
between a monitor and a source (computer, CPU). It enables data exchange via  
monitor cable and automatic installation and configuration of a monitor driver  
by the operating system.

Dual Access — A system that operates a source (computer, CPU) from two  
consoles.

Dual-Head — A system with two video connections.

Dual Link — A DVI-D interface for resolutions up to 2560 x 2048 by signal  
transmission of up to 330 MPixel/s (24-bit).

DVI — Digital video standard, introduced by the Digital Display Working Group 
(http://www.ddwg.org). See also Single Link and Dual Link. The signals have 
TMDS level.

DVI-I — A combined signal (digital and analog) that allows running a VGA  
monitor at a DVI-I port—in contrast to DVI-D (see DVI).
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Fiber — Single-mode or multimode fiber cables.

EGA — The Enhanced Graphics Adapter (EGA) is an old analog graphics  
standard, introduced by IBM® in 1984. It uses a DB9 connector.

FBAS — The analog color video baseband signal (FBAS) is also called Composite 
Video and it is part of the PAL TV standard.

Console — Keyboard, mouse, and monitor.

KVM — Keyboard, video, and mouse.

Mini-XLR — Industrial standard for electrical plug connections (3-pole) for the 
transmission of digital audio and control signals.

Multimode — 62.5-µ or 50-µ fiber cable.

OSD — An OSD (on-screen display) is used to display information or to operate a 
device.

Quad-Head — A system with four video connections.

RCA (Cinch) — A non-standardized plug connection that transmits electrical 
audio and video signals, especially with coaxial cables.

SFP — SFPs (Small Form Factor Pluggables) are pluggable interface modules for 
Gigabit connections. SFP modules are available for CATx and fiber interconnect 
cables.

S/PDIF — A digital audio interconnect used in consumer audio equipment over 
relatively short distances.

Single-Head — A system with one video connection.

Single Link — A DVI-D interface for resolutions up to 1920 x 1200 by signal 
transmission of up to 165 MPixel/s (24-bit). Alternative frequencies are Full HD 
(1080p), 2K HD (2048 x 1080), and 2048 x 1152.

Single-Mode — 9µ fiber cable.

S-Video (Y/C) — The S-Video (Y/C) is a video format that transmits luminance 
and chrominance signals separately. It has a higher-quality standard than FBAS.

TOSLINK® — Standardized fiber connection system for digital transmission of 
audio signals (F05 plug connection).

Triple-Head — A system with three video connections.
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USB HID — USB HID devices (human interface devices) allow for data input. You 
don’t need a special driver during installation; “New USB-HID device found” is 
reported. Typical HID devices include keyboards, mice, graphics tablets, and  
touchscreens. Storage, video, and audio devices are not HID.

VGA — Video Graphics Array (VGA) is a computer graphics standard with a  
typical resolution of 640 x 480 pixels and up to 262,144 colors. Its is preceded by 
the graphics standards MDA, CGA and EGA.

A.1 Matrix-Specific Glossary
Auto Disconnect — Matrix function that allows an automatic disconnect 
between a console and a CPU, if the OSD is opened via this console.

Auto Logout — Matrix function that describes the duration of inactivity after the 
user has been logged out from the OSD at this console.

CON Device — Logical term that summarizes several physical extenders to switch 
more complex console systems via matrix.

CON Timeout — Matrix function that allows an automatic disconnect of the 
console from the connected CPU after a predefined time.

Console ACL — Console ACL (Access Control List) is a list that shows the respec-
tive switching rights for the various consoles.

CPU Auto Connect — Matrix function that allows an automatic connection  
establishment between the own console and a random available CPU.

CPU Device — Logical term that summarizes several physical extenders to switch 
more complex CPU systems via matrix.

CPU Timeout — Matrix function that allows the user to disconnect after a  
predefined period of time of inactivity from the respective CPU.

EXT Unit — Part or extender board of a CON or CPU unit with a connection to 
the matrix. A CON or CPU unit can consist of several EXT devices.

Force Connect — Matrix function that allows a user to switch with his own  
console to a CPU that is already used. This enables the user to take keyboard and 
mouse control. The connected console loses K/M control but keeps video.

Force Disconnect — Matrix function that allows to switch with the console to a 
CPU that is already used. This enables the user to take KVM control. The  
connected console loses complete KVM control.

Java Tool — Java based control and configuration tool for the ServSwitch DKM 
FX matrix.
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Keyboard Connect — Matrix function that allows taking over the keyboard  
control of an inactive console.

Macro Keys — Programmable keys that string together commands to the matrix.

Mouse Connect — Matrix function that enables a user to control an inactive 
console’s mouse.

Non-Blocking-Access — Matrix configuration in which no user can be disturbed  
by an activity of another user.

OSD Timeout — Matrix function that closes the OSD automatically after a  
predefined period of time of inactivity.

Release Time — Matrix function that enables a console connected to the same 
CPU to release the K/M control after a predefined time.

Tie-Line — Communication connection to and between extension modules in a 
network environment.

User ACL — User ACL (Access Control List) is a list that shows the respective 
switching rights for the various users.

Video Sharing — Matrix function that enables switching from a user’s own  
console to any CPU with video.
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