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Zebra warrants the ZebraNet PrintServer II against defects in material or workmanship 
for a period of three years from either (i) the date of shipment to you by Zebra, or (ii) 
the date of any resale by you to an end user, whichever is later. Proof of shipment date 
may be required to validate the warranty period. This warranty does not cover normal 
wear and tear, and shall be null and void if the equipment is modified, improperly 
installed or used, damaged by accident or neglect, or improperly installed or replaced 
by the user. To qualify for this warranty, the ZebraNet PrintServer II must be returned 
to the factory or other authorized service center.

ZEBRA’S SOLE OBLIGATION UNDER THIS WARRANTY SHALL BE TO 
FURNISH PARTS AND LABOR FOR THE REPAIR OR REPLACEMENT OF 
PRODUCTS FOUND TO BE DEFECTIVE IN MATERIAL OR WORKMANSHIP 
DURING THE WARRANTY PERIOD, OR ZEBRA MAY, AT ITS DISCRETION, 
ISSUE A CREDIT FOR ANY SUCH DEFECTIVE PRODUCTS IN SUCH 
AMOUNT AS IT DEEMS REASONABLE.

As a condition of this warranty, the user must: (a) obtain a Zebra Return Materials 
Authorization (RMA), which will include an RMA number that must be prominently 
displayed on the outside of the shipping container (returns without an RMA number 
will be rejected by Zebra and immediately returned to you, freight collect); (b) ship the 
Product being returned freight prepaid, to the authorized service location; and (c) 
include with the Product a written description of the claimed defect. Products returned 
PrintServer II User and Reference Guide i



Warranty Information
should be packaged in the original packing and shipping container or comparable 
container. In the event the Product is not so packaged or if shipping damage is evident, 
it will not be accepted for service under warranty. Surface transportation charges for 
the return of the Product to the customer shall be paid by Zebra within the 48 
contiguous states and the District of Columbia. The customer shall pay shipping costs, 
customs clearance, and other related charges outside the designated area. If Zebra 
determines that the Product returned to it for warranty service or replacement is not 
defective as herein defined, the customer shall pay all costs of handling and 
transportation.
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The above warranty is in lieu of all other warranties, expressed or implied, oral or 
written, statutory or otherwise, including any implied warranty of merchantability or 
fitness for a particular purpose. Zebra shall not be responsible for the specific 
application to which any Products are applied, including but not limited to 
compatibility with other equipment. All statements, technical information, and 
recommendations relating to Zebra Products are based on tests believed to be reliable 
but do not constitute a guarantee or warranty.

ZEBRA SHALL NOT, UNDER ANY CIRCUMSTANCES WHATSOEVER, BE 
LIABLE TO THE BUYER OR ANY OTHER PARTY FOR LOST PROFITS, 
DIMINUTION OF GOOD WILL, OR ANY OTHER SPECIAL OR 
CONSEQUENTIAL DAMAGES WHATSOEVER WITH RESPECT TO ANY 
CLAIM HEREUNDER. IN ADDITION, ZEBRA’S LIABILITY FOR WARRANTY 
CLAIMS SHALL NOT, IN ANY EVENT, EXCEED THE INVOICE PRICE OF THE 
PRODUCT CLAIMED DEFECTIVE, NOR SHALL ZEBRA BE LIABLE FOR 
DELAYS IN REPLACEMENT OR REPAIR OF PRODUCTS.

No salesperson, representative, or agent of Zebra is authorized to make any guarantee, 
warranty, or representation in addition to the foregoing warranty.

NO WAIVER, ALTERATION, ADDITION, OR MODIFICATION OF THE 
FOREGOING WARRANTY SHALL BE VALID UNLESS MADE IN WRITING 
AND SIGNED BY AN EXECUTIVE OFFICER OF ZEBRA.

'���"	���(���
���) �����
�

Software and documentation provided by Zebra are protected by the United States 
copyright law and international treaty, and therefore you must treat them like a book, 
ii  PrintServer II User and Reference Guide



Warranty Information
with the exception that you may make copies of the software to protect yourself 
against loss of the original.

Your right to use the software and documentation as described below is non-exclusive 
and non-transferable. Zebra retains ownership of the software and documentation and 
all other rights, title, and interest. The software and documentation may be used by any 
number of people and may be freely moved from one computer to another as long as 
there is no possibility of their being used by more than one person on more than one 
computer at the same time.

Machine readable files representing graphics or fonts that you have created 
independently may be converted to ZPL format files using the software, and such files 
may be used, copied onto diskettes or font cards, given away, or sold without paying 
license fees to Zebra. Pictorial or graphic images and any machine readable files 
representing them may be protected by United States copyright law and international 
treaty provisions, which prohibit you from transcribing or scanning such images or 
using, copying, or converting such files without permission of the copyright owner. 
You may not use this software in violation of U.S. copyright law or international 
treaty. By using this software, you agree to be bound by these terms.

Zebra warrants the software diskettes to be free of defects in material and 
workmanship for a period of 60 days from the date of purchase. In the event of 
notification within the warranty period of defects in material and workmanship, Zebra 
will replace the defective diskette or documentation. Zebra specifically disclaims all 
other warranties, expressed or implied, including but not limited to implied warranties 
of merchantability and fitness for a particular purpose. IN NO EVENT WILL ZEBRA 
BE LIABLE FOR LOST PROFITS, LOST DATA, OR ANY OTHER INCIDENTAL 
OR CONSEQUENTIAL DAMAGES CAUSED BY ABUSE OR MISAPPLICATION 
OF THE SOFTWARE OR BY ITS USE IN VIOLATION OF THE U.S. 
COPYRIGHT LAW OR INTERNATIONAL TREATY.

This product document refers to hardware and software products by their trade names. 

ZebraNet® is a trademark of Zebra. The PrintServer II is a product of Zebra. All other 
designations are trademarks or registered trademarks of their respective companies.
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You can contact Zebra, USA at any of the following: 

Visit us at:   http://www.zebra.com

Our Mailing Address:   

������������������������������
333 Corporate Woods Parkway
Vernon Hills, Illinois 60061.3109 U.S.A
Telephone +1 847.634.6700
Facsimile +1 847.913.8766

��������������������
������������
Zebra House
The Valley Centre, Gordon Road
High Wycombe
Buckinghamshire HP13 6EQ, UK
Telephone +44 (0)1494 472872
Facsimile +44 (0) 1494 450103

'������

You can contact Zebra support with any questions or problems with your ZebraNet 
PrintServer II (PSII):

Support email:  http://support.zebra.com 

Telephone:  +1.847.913.2259

�����	��

Be sure to complete the feedback form located at the beginning of this guide. For 
details see, Your Feedback Is Important on page 3.
x  PrintServer II User and Reference Guide
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The ZebraNet PrintServer II User and Reference Guide consists of these chapters:
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��
������������


Introduction This chapter provides a high-level overview of 
the ZebraNet PrintServer II (PSII), installation 
instructions, standard network configurations, 
and how to work with PSII. 

Installation This chapter provides information on how to 
install PSII (external and internal) and the 
ZebraNet Utilities.

Getting Started This chapter provides you with information on 
how to work with the most frequently used 
PSII features. 

NetWare Print Configuration This chapter provides you with instructions on 
how to configure Novell’s NetWare for printing 
to PSII.

Printing Configurations This chapter provides information and 
instructions on configuring your printer for 
remote BSD-style LPD printing on the UNIX 
operating system.

Using Printing Protocols This chapter provides information and steps to 
set up your PSII to support Internet Printing 
Protocol (IPP).

PrintServer II This appendix provides you with details on the 
most commonly used PSII features.

ZebraLink

For ZebraLink-enabled 
printers.

This appendix provides you with detailed 
information that allows you to use the 
enhanced functionality of your ZebraLink-
enabled printer with the PSII.

ZebraNet Utilities This appendix provides you with details on 
ZebraNet Utilities, the software suite of printer 
administration tools that complements and 
enhances both ZebraLink and the ZebraNet 
family of connectivity products.
PrintServer II User and Reference Guide xi
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Hardware Troubleshooting This section provides you with solutions to 
known issues.

Frequently Asked Questions This section is a compiled group of frequently 
asked questions (FAQs) about PSII.

Glossary This section is a glossary of terms that are 
specific to the PSII.
xii  PrintServer II User and Reference Guide



Preface
Document Conventions
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The following conventions are used throughout this document to convey certain 
information: 

About this Chapter Sections  These sections list and describe each main section 
of the chapter, including the initial page numbers of those sections. These sections 
primarily serve as hyperlink components for the Adobe Acrobat .pdf version of this 
guide.

Alternate Color  (online only) Cross-references contain hot links to other sections in 
this guide. If you are viewing this guide online in .pdf format, you can click the 
cross-reference (royal blue text) to jump directly to its location. 

Command Line Examples  All command line examples appear in Courier font. 
For example, you would type the following to get to the Post-Install scripts in the bin 
directory:�
�
Ztools

Files and Directories  All file names and directories appear in Courier font. For 
example, the Zebra<version number>.tar file and the /root directory.

Caution, Caution, Important, Note, Tools, and Example  These topics are 
defined in the following example:        

Caution • Advises you that failure to take or avoid a specified action could result in 
loss of data. 

Caution • Turn OFF (O) the printer and disconnect it from the power source before 
performing the following maintenance.  

Caution • Advises you that failure to take or avoid a specified action could result in 
personal injury. 

 ! Important • Provides information that is essential to the completion of a task. 
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Preface
Document Conventions
Illustration Callout Instruction  Illustration callout instructions are used when an 
illustration contains either information about a dialog box or step(s) to accomplish in a 
dialog box. 

This illustration callout instruction identifies a section of the dialog box, and the other 
callout shows steps to follow:

Note •  Indicates neutral or positive information that emphasizes or supplements 
important points of the main text.  

Tools •  Identifies the tools you need to accomplish a task.  

Example • Provides an example, often a scenario, to better clarify a section of text. 
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Preface
Related Documents
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In addition to the ZebraNet PrintServer User and Reference Guide, the following 
documents might be helpful references while using PSII:

� Wireless Card Socket Option (WCSO) Install and Users Guide 

� The ZebraLink Solution Application White-paper

� ZPL II® Programming Guide Volume One: Command Reference

� ZPL II® Programming Guide Volume Two: The X.10 Environment

� EPL2 Programmer’s Manual

� Line Mode Programmer’s Manual

Note • Most of these documents are available on our Web site.
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CHAPTER 1
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This chapter provides a high-level overview of the PSII device, installation 
instructions, standard network configurations, and how to work with PSII. 

Contents
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Requirements  . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Compatibility  . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
Installation Types. . . . . . . . . . . . . . . . . . . . . . . . 8
PSII Specifications. . . . . . . . . . . . . . . . . . . . . . . 9
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Introduction
Overview
+!��!��"

The PSII is an optional factory- or field-installed device that connects the network and 
your Zebra printer is ZebraLink-enabled, PSII provides you with a browser user-
interface for printer and PSII settings. If your printer also has ZebraNet Utilities, you 
have even more functionality. For details, see ZebraNet Utilities on page 4.

 ! Important • You can download the most recent version of ZebraNet Utilities from 
our Web site: www.zebra.com.
2  PrintServer II User and Reference Guide
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This illustration shows the flow of all the components that work with PSII. The table 
that follows identifies the components and how they enhance each respective device:

1

2

�����������
��*!!�����

-�	�
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	�����������"����
��*!!

-�	�
 ���/��������

3

PAUSE
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Printer with PSII only PSII gives your printer these features:

��allows the remote monitoring and configuration 
capability of the PSII using a browser. 

��allows you to send unsolicited printer status mes-
sages via email-enabled devices.

ZebraLink-enabled 
printer with PSII

A ZebraLink-enabled printer with PSII gives you all 
the above-mentioned features (WebView and Alert).

NOTE • PSII can be either field- or factory-installed 
for additional features. For details, see Installation 
Types on page 8.

ZebraNet Utilities ZebraNet® Utilities is a suite of software programs 
that work with PSII and enhance the features of 
ZebraLink resident within ZPL-based printers. The 
features include

��ZebraNet Alert lets you configure multiple event 
alerts per device with different alerts going to dif-
ferent people. You are notified of alerts from 
either visual or audio cues. You can also generate 
advanced alert reports.

��ZebraNet Connect IP lets you, with Windows, 
enable simple printer selection of an IP address-
able printer.

��ZebraNet View allows you to locate printers auto-
matically. ZebraNet View searches on parameters 
such as IP address, subnet, printer model, printer 
status, and many other user-defined characteris-
tics. It also offers powerful device management 
capabilities.

��ZebraNet View Java Applet is a Java-based ver-
sion of the popular ZebraNet View. It gives you 
ZebraNet View capabilities in a non-Windows 
environment. 

1

2

3
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Requirements
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This section lists the minimum requirements for PSII, which include software, browser 
support, and hardware.

'���"	��

These are the platforms supported by ZebraNet Utilities:

The ZebraNet View Java Applet is supported by any Java-enabled browser:

-��"����'������

Windows™ NT®, 95, 98, 2000, Me

Novell® versions 3 and 4 Netware®

UNIX®

Linux

Internet Explorer 4.0+

Netscape Navigator 4.08+

Any browser that is HTML 1.1 
compliant
PrintServer II User and Reference Guide 5
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Requirements
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These are the minimum hardware requirements:

* future releases

���
���� �����
	
 �
���
	

���
���� �	��

�
���
	

�	�����

Xi Series (XiII and XiIII) • • •
R140 • • •
PAX Series (excluding PAX4) • • •
Z-Series® •
Stripe® Series •
Z4Mplus™ • • •
Z6Mplus™ • • •
105SL • • •
105 Se/160S •
2746 •
2746e • •
2684 •
DA402, T402 •
2844 (EPL) • •
2844 (ZPL) • •*

Ht-146 • •*

2824 • •
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Compatibility
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This section identifies the various components that are compatible with PSII.

ZebraNet Wireless Card Socket Option (WCSO)  PSII is fully compatible with 
WCSO.

Software  HP JetAdmin, HP Web JetAdmin™, and HP OpenView™ all work with 
PSII. 
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Installation Types
�
��	

	���
������

PSII can be factory- or field-installed, as follows:

Factory  Factory-installations are for new Zebra printers that are built with the 
internal PSII option.

Field  Field-installations are for Zebra printers already in the field that do not have the 
PSII device installed. The PSII option can be installed on existing printers, as follows:

• External PSII — attaches to the printer parallel port

• Internal PSII — for the appropriate Zebra printers, this option connects 
directly to the main logic board

 ! Important • This installation must be performed by a qualified service technician.
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PSII Specifications
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Network Connection  10BASE-T UTP RJ45 connection. Auto senses IEEE- 802.3, 
Ethernet II, IEEE- 802.2, and IEEE 802.2/SNAP frame formats 

Printer Connection  Bi-directional, IEEE- 1284 Centronics parallel port 

User Interface  Activity indicator: bi-color display of operational status; test button: 
diagnostic test and configuration printing 

Size (external ZebraNet PrintServer II)  Length: 3.6" / 91.4 mm, Width: 2.5" / 
63.5 mm, Height: 0.8"/ 20.3 mm

Weight (external ZebraNet PrintServer II)  .5 oz / 71 g 

Power  Maximum 250mA at 5.25VDC; power provided by the printer (Centronics 
pin 18, 5VDC at 200mA)

Environment   Operating Temperature: 0° to 104°F (0° to 40°C); Storage 
Temperature: –4° to 140°F (–20° to 60°C); Operating Humidity: 25 to 85% non-
condensing

Agency Approvals   FCC Class B, Canadian ICES-003 “Class B”, EN55022 Class 
B, EN55024, AS/NZS3548

Warranty  Three years
PrintServer II User and Reference Guide 9
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CHAPTER 2
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This chapter provides information on how to install PSII (external and internal) and 
the ZebraNet Utilities.

Contents
External PSII . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Internal PSII. . . . . . . . . . . . . . . . . . . . . . . . . . . 16
ZebraNet Utilities. . . . . . . . . . . . . . . . . . . . . . . 26
ZebraNet View Java Applet . . . . . . . . . . . . . . . 30

�
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Installation
External PSII
�����
	
��'��

This section provides you with an illustration of the external PSII and the steps 
required for its installation.

�

����	���
��

This illustration shows a visual of an external PSII. The callouts identify the important 
components: 

����
��	

�	
������
	
��'���/�����
���������������0�

1 Turn off (O) the printer. 

2 On the back of the printer, insert the PSII device into the parallel port.

Note • When necessary, refer back to this illustration during the installation steps.

�
�
�����
&��������
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����
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Installation
External PSII
This illustration calls out the location of the parallel port and provides an enlarged 
illustration of the parallel port:

  

3 Secure the wire locks.

4 On the back of the PSII, insert a live 10BASE-T cable into the Ethernet connector.

5 Turn on the printer. 

A red status indicator blinks during the Power On Self Test (POST) and changes to 
green when the initialization is finished.

The Test button is a small hole on the PSII device. To press it, you need to insert 
something small into the hole, like a paperclip.

6 Press the Test button located on the side of the PSII. This prints out a PSII 
configuration label. 

 ! Important • DPI and your firmware version:

��For printers with firmware version 7.01 and higher, regardless of the dpi, a �
2-inch (5 cm) label prints 

��For printers with firmware version 7 and lower, see the table that follows.

�
�
�����
&��������
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Installation
External PSII
This table shows you how to determine the minimum label width needed to print a 
PSII configuration label for printers with firmware version 7 or lower:

This is an example of a PSII configuration label. The callouts identify the settings you 
need to know. The table following the illustration callout provides a description of 
each callout.

  

 

��� �
����

600 1.25

300 2.50

200 3.69

150 5.0

2

3

4

2
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External PSII
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This shows the IP address, subnet mask, and 
default gateway of the PSII device. If the IP 
address is set at 0.0.0.0, you need the serial 
number (in callout 3) to set the IP address.

This shows all the Novell settings. 

This shows the serial number, hardware 
address (MAC address), and firmware version 
of the PSII device.

2

3

4
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Installation
Internal PSII
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This section provides you with an illustration of the internal PSII and installation steps. 
The printer model you have determines the instruction you need to go to:

� If you have an XiII, XiIII, 105SL, and PAX-Series printers, see XiII, XiIII, 105SL, 
and PAX-Series on page 16.

� If you have an Z4Mplus or Z6Mplus printer, see Z4Mplus/Z6Mplus on page 20.

�
��	



This section provides you with instructions on how to install a PSII into the supported 
Zebra printers.

����/������/�123��/�	
���)45'�����

This illustration shows you the internal PSII that can be installed into XiII, XiIII, 105SL, 
and PAX-Series printers. The callouts identify the important components: 
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Internal PSII
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1 Turn off (O)the printer and disconnect the AC power cord.

2 On the back of the printer, remove the two screws and the blank cover plate 
positioned next to the main RS-232 and parallel interface connectors.

3 To remove the side panel:

• For the XiII-, XiIII-Series, and 105SL, remove the screws and remove the left 
side panel.  

Caution • This installation must be performed by a qualified service technician.

Caution • Turn Off (O) the printer and disconnect it from the power source before 
performating these procedures.

Caution • Observe proper electrostatic safety precautions when handling any static-
sensitive components such as circuit boards and printheads.

Tools • These are the tools you need for the installation:

��#1 Phillips screwdriver

��3/32 in. Allen wrench
PrintServer II User and Reference Guide 17



Installation
Internal PSII
• For the PAX-Series, access the electronics by removing the mounting screws 
from the printer’s PCB access panel and sliding the panel out.  

 

.

4 Through the mounting slot, insert the ribbon cable and PSII.

Note • The parallel port on the back of the printer is not operational when the internal 
PSII is installed. The hardware of the PSII mounting bracket covers the parallel port.
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Installation
Internal PSII
5 Fold the cable and the ferrite bead back over the mounting bracket, and connect the 
ribbon cable connector into the keyed Interface Data Cable Connector (J4) on the 
main logic board. Secure the PSII interface board in place with the cover plate 
screws that you removed early in this step sequence.

6 Confirm that all small cable connectors are tight.

7 Reinstall the PAX-Series PCB access panel or the left side-panel of the XiII and 
XiIII-Series printers that you removed earlier in this step sequence.

8 This kit includes a label printed with the Ethernet MAC hardware address for the 
PSII. Remove the backing from the label and affix it to the back of the printer.

9 Reconnect the AC power cord and turn the printer on.

10 Consult your System Administrator before configuring the PSII for your network! 
To establish the network connection, refer to the section applicable to your 
network type.
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Installation
Internal PSII
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This illustration shows you the internal PSII that can be installed into Z4Mplus and 
Z6Mplus printers. The callouts identify the components you need to be familiar with:  
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Installation
Internal PSII
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1 Turn off (O) the printer and disconnect the AC power cord.

2 Lift the media door and find the screw in the upper-middle area of the printer 
frame. 

3 As shown in this illustration, remove the screw and the lock washer:

Caution • This installation must be performed by a qualified service technician.

Caution • Turn Off (O) the printer and disconnect it from the power source before 
performating these procedures.

Caution • Observe proper electrostatic safety precautions when handling any static-
sensitive components such as circuit boards and printheads.

Tools • These are the tools you need for the installation:

��7 mm nutdriver

��Flat blade screwdriver
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Installation
Internal PSII
4 Close the media door. 

5 As shown in this illustration to remove the electronics cover, push in and pull up.

6 On the back of the printer, use the flat blade screwdriver to remove the screws and 
the cover plate.

This opens the mounting slot on the back of the printer.
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Installation
Internal PSII
7 Take the PSII and disconnect it as noted in this illustration:

8 As shown in this illustration, insert the short ends of each standoff into the holes on 
the main logic board until you hear a click. 

Note • This illustration identfies the components you will be working with in the 
upcoming steps:
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Installation
Internal PSII
9 With the PSII device, take the cable and PSII board, go to the electronics side of 
the printer and plug the parallel port socket of the PSII board into the parallel port 
plug on the main logic board. 

10 Snap the standoffs through the holes on the PSII board. 

 Be sure the PSII is in securely.

11 With the PSII board connected onto the main logic board, feed the connector 
through the mounting slot on the back of the printer.

12 As shown in this illustration, put the I/O board and plate together, then connect the 
cable into the plug on the I/O board: 

.

13 Use the screws from step 6 to screw the plate onto the back of the printer.

14 Reinstall the electronics cover.

15 Reconnect the AC power cord and turn the printer on.

If the green status indicator is solid (not blinking), you have power to the PSII.

Note • Does your printer have a PCMCIA card installed? If so, step 11 requires 
you to feed the connector over the PCMCIA card, then through the mounting slot on 
the back of the printer. 

Note • The parallel port on the back of the printer cannot be used when the internal 
PSII is installed. The hardware of the PSII mounting bracket covers the parallel port.
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Installation
Internal PSII
16 Consult your System Administrator before configuring the PSII for your network. 
To establish the network connection, refer to the section applicable to your 
network type.
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Installation
ZebraNet Utilities
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The ZebraNet Utilities is a software suite consisting of tools to assist you with the 
configuration of the PSII device, which gives you the flexibility to make changes to 
settings, track errors, and more.

If you want to be certain you have the most recent version of the ZebraNet Utilities, 
you can visit our Web site and download the most recent version.

For more details, see Overview on page 2 or ZebraNet Utilities on page 117.  
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��	

�����%���	&������
�����/�����
���������������0

The steps that follow reflect the steps and dialogs for a typical installation. If you plan 
to conduct a custom installation, the dialogs you encounter or see will differ from 
those in this step sequence.   

1 Insert the CD-ROM into the drive.

2 Click Next>.

Note • Contact your System Administrator before installing this software. You must 
have Administrator rights on your network to install most of these utilities. 

 !
Important • Is AutoPlay enabled on your computer?

��Yes. Your computer automatically launches the installation.

��No. You need to navigate to the Software>ZebraNet Util>setup.exe 
on the CD-ROM and manually launch the installation.
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Installation
ZebraNet Utilities
This illustration shows the dialog box that lets you select the utilities that you want 
to install:

3 In the ZebraNet Utilities dialog, select the features you want to install and click 
Next>. 

 ! Important • If you installed ZebraNet View Java Applet, you must complete the 
installation steps for ZebraNet View Java Applet on page 30.
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Installation
ZebraNet Utilities
This illustration gives you the chance to reset your installation settings:

4 In the ZebraNet Utilities dialog, you have the option to review and make any 
changes to your installation settings. When you are satisfied with your installation 
settings, click Install. 
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ZebraNet Utilities
When the installation is complete, this dialog opens:

5 Click Finish.

 ! Important • When the installation is complete, you need to restart your system for 
the changes to take place.
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Installation
ZebraNet View Java Applet
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If you selected ZebraNet View Java Applet when you were installing the ZebraNet 
Utilities, you need to complete a few installation steps to work with this utility.
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1 From the task bar, select Programs>ZebraNet Utilities>ZebraNet View Java Applet 
1.0.

This Security Warning dialog opens:

2 To begin the installation, click Yes.
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Installation
ZebraNet View Java Applet
The Select Java Plugin Installation dialog opens:

3 Make the selections that apply to your environment, and click Install.
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Installation
ZebraNet View Java Applet
The Software License Agreement opens.

4 Read the License Agreement. 

5 To continue with the installation, click Yes. 

6 When the installation is complete, click OK. 
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Installation
ZebraNet View Java Applet
The Java page opens:

7 You have these options:

• To work with this utility, see ZebraNet View Java Applet on page 130.

• To close the utility, click the X.
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CHAPTER 3
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This chapter provides you with information and procedures for working with the most 
frequently used PSII features.

Contents
Before you begin  . . . . . . . . . . . . . . . . . . . . . . 36
Assigning an IP Address  . . . . . . . . . . . . . . . . 38
Setting Alerts  . . . . . . . . . . . . . . . . . . . . . . . . . 45
Checking PSII Configuration Settings . . . . . . . 53
Setting up a ZebraNet Connect IP . . . . . . . . . 58
Enabling Protocols  . . . . . . . . . . . . . . . . . . . . . 62
Defaulting the PSII  . . . . . . . . . . . . . . . . . . . . . 68
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Getting Started
Before you begin
-������������ �
�

PSII offers many features, but how you access and work with them is dependent on 
your environment. Before you begin, you need to get information from the PSII 
configuration label. 
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1 Turn on the printer and let it complete its power-up cycle.

2 Let the PSII complete its POST cycle. 

3 When the above steps are complete, press the Test button and hold it in for a few 
seconds before you release it. 

 ! Important • Make sure the printer is turned off (O).

Note • Running the POST cycle requires you to access the PSII Test button on the 
PSII device. On the:

��Z4Mplus and Z6Mplus, the Test button on the PSII device is a little 
white button. For more details, see the illustration under the heading 
XiII, XiIII, 105SL, and PAX-Series on page 16.

��On any other printer, the Test button on the PSII device is a small hole. 
For more details, see the illustration under the heading �
Z4Mplus/Z6Mplus on page 20.
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Getting Started
Before you begin
A PSII configuration label prints. Your configuration label looks similar to this: 

4 From the configuration label, you need to get these numbers:

For details on getting these numbers, see page 15. 

• ADDRESS (IP address)  

• SUBNET MASK  

• DEFAULT GATEWAY  

• SERIAL NUMBER  

• HARDWARE ADDRESS (MAC address)     

5 On the configuration label that prints out for your PSII device, circle the above-
mentioned settings. You can now proceed to Assigning an IP Address on page 38.
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Getting Started
Assigning an IP Address
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Before you can begin working with PSII, you must get or assign an IP address for the 
PSII device.
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If your network uses DHCP, your PSII device is assigned a temporary IP address. This 
is important to know, because you have the option to make the temporary IP address 
the permanent IP address.

 

$��������.���

If your network does not use a dynamic IP addressing system (such as DHCP), you 
need to set a permanent IP address of the PSII device. 

%���	&���:��"

ZebraNet View is the Windows-based print server management and configuration 
utility that came with your PSII. 

 ! Important • Throughout the step sequence in this chapter, there are some features 
that require the default User ID and/or default password. If you are prompted, these 
are the defaults:

��User ID: admin

��Password: 1234

Note • Check with your Network Administrator to see whether your network uses 
DHCP. 

 ! Important • The remaining sections are dependent on the successful installation of 
ZebraNet Utilities, which you should have completed on page 26. 
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1 From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.

The ZebraNet View dialog opens:

2 Compare the H/W Address or Serial Number on the PSII configuration 
label with the H/W Address column on the screen to find the PSII you are 
working with. 

3 When you locate your PSII, select it. 

4 From the menu bar, select PrintServer>Configuration.

 ! Important • On the illustration that follows, take note of the H/W address 
column and Serial # column. Compare what you see in ZebraNet View with the 
configuration label you printed out.

 ! Important • If the PSII does not have an IP address, it shows in the main screen 
with an IP of  0.0.0.0. If, after 2 minutes, you do not assign an IP Address, the PSII 
defaults to IP Address 192.168.254.254 or 198.102.102.254 (this depends on your 
firmware version).
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5 If your PSII does not have an IP address, complete these steps:

• Find your PSII and right-click it.

• In the small dialog that opens, enter an IP Address, click OK.

• The ZebraNet View dialog opens. 
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���������������0�

6 From the ZebraNet View menu bar, select PrintServer>Configuration.

7 Click the TCP/IP tab.

8 From the Print Server Configuration>TCP/IP tab, in the Subnet Mask text-box, 
type in your subnet mask.

9 Confirm it is accurate, and click OK.

The Print Server Configuration dialog opens:

10 To set a permanent IP address, enable the Set Permanent radio button.

11 In the Set Permanent text-box, type a new IP address and click OK.
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These steps are Optional.

1 From the ZebraNet View menu bar, select PrintServer>Configuration.

2 Click the TCP/IP tab.

3 From the Print Server Configuration>TCP/IP tab, in the Default GateWay text-
box, type in your default gateway.

4 Confirm it is accurate, and click OK.
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These steps can be used with all printers. However, the liquid crystal display (LCD) 
instructions are for printers with an LCD. 
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1 Turn on the printer and allow 2 minutes for all systems to complete the self test. If 
you do not have a network cable in the port, the PSII prints the configuration label 
when it is ready.

2 On the printer front panel, press SETUP/EXIT.

3 On the printer front panel, press PREVIOUS twice until you reach the network 
settings menu item. 

4 You can edit any of the following network settings in order to communicate with 
any PSII in your network environment.

• ip resolution (dynamic, permanent) The printer menu item IP 
RESOLUTION must be set to PERMANENT if attempting to assign the IP 
address from the front panel.

• default gateway (default setting of 000.000.000.000) 

 ! Important • Your PSII must have firmware 6.3 and higher and your Zebra printer 
must have firmware x.10 or higher with an LCD. 

 ! Important • To change any of these settings, you need to use the default password: 
1234.
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• subnet mask (default setting 255.0.0.0) 

• ip address (if initial default setting is 0.0.0.0, after 2 minutes this 
defaults to 198.102.102.254 or 192.168.254.254 — depends on firmware 
version) 

• ip protocol (gleaning only, rarp bootp, dhcp, dhcp and bootp, all) 
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If your environment is not Windows-based, this section is for you. However, this 
method can be used in a Windows environment, too.

The methods used for assigning an IP address with a Telnet session are Static Route 
and Gleaning.

 

Before you can Telnet to the PSII and configure it, you must first assign the PSII a 
temporary IP address. 
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1 Turn on the printer and wait for 2 minutes to allow for the device self test. 

During this time, the PSII performs an address broadcast. If no address is assigned 
to the unit (via DHCP or Bootp), it uses a default address. The default address used 
varies with the version of firmware the PSII is using. Print the PSII configuration 
label to confirm the address; for details see page 36.

2 You can use the route add command to place the default IP address into the 
workstation's network routing table.

 

3 At the workstation/host command prompt (in Windows, go the DOS prompt), 
type:

route add **** "IP address of the workstation" 0

 ! Important • This applies to any TCP/IP capable workstation/ host networked with 
the Zebra printer. Both the workstation/host and the PSII must be on the same 
network segment.

Example • In the next step, **** is the IP address on the PSII configuration label.
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4 Telnet to the PSII by typing:

"Telnet xxx.xxx.xxx.xxx" 

The password is 1234. 

5 When finished, you can alter the appropriate settings. When complete, do a reset 
and allow the PSII self test to complete before proceeding with any 
communications activity. 
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A method by which the PSII uses the IP address of the first ping packet that is sent to 
its Hardware address. 

1 Add an entry to the ARP table that assigns an IP address to an Ethernet (Hardware) 
address. 

The syntax for this command is: arp -s "temporary ipaddress of 
print server" "MAC Address (print server hardware 
address)" arp -s <temporary ip address> <MAC Address>

2 Power cycle the printer. 

3 As the printer reboots, begin a continuous ping to the address assigned previously. 

Note • The zero (0) placed at the end of the "route add" command is optional on 
some systems. 

Note • Gleaning works only on local subnets at routers. It does not pass Address 
Resolution Protocol (ARP) broadcasts.

Example • You would type: arp -s 10.3.50.59 00-40-68-1D-B9-86

Note • Most UNIX systems use a continuous ping. 

To use a continuous ping from a Windows host, you must issue the 
command: ping -t "ipaddress". 
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4 When the PSII begins to respond, stop the ping activity.

 In Windows, Ctrl + C halts the pinging.

5 Telnet to the PSII and assign the appropriate IP address, subnet mask, and gateway 
if applicable. 

6 Once this is complete, reset the PSII. 

For details on resetting the PSII, see Reset on page 96.
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It is important to understand the relationship between the PSII and the printer when 
you are establishing alerts. Here are the relationships you need to be aware of:

• Non-ZebraLink-enabled printers — can send alerts on only a specific set of 
printer errors that are reported in the IEEE 1284 protocol.

• ZebraLink-enabled printers — ZebraLink allows for the printer to send alerts 
not in the IEEE 1284 protocol.

%���	&���:��"���

In this section are step-by-steps instructions on how to set up an alert using ZebraNet 
View. For information on setting up alerts using ZebraLink, see ZebraLink on page 47.
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1 In the ZebraNet View dialog, from the menu bar select Print Server>Configuration.

2 Click the SNMP Traps tab.
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The Printer Traps check boxes are the alerts you can set from ZebraNet View.

3 Enable the alerts (printer traps) you want to set here and click OK.

4 To monitor the alerts you established, from the task bar select Start>ZebraNet 
Utilities>ZebraNet Alert.
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The ZebraNet Alert dialog opens:

In this dialog you can view the log of errors and monitor the activity of your 
printer(s).
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In this section are step-by-step instructions on how to set up an alert using ZebraLink. 
For information on setting up alerts using ZebraNet View, see ZebraNet View on page 
53.  

 ! Important • If you do not have a ZebraLink-enabled printer, these steps will not 
work. 
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1 Open a Web browser.

2 In the Address text-box, type your printer’s IP address, and press Enter.

3 From the Printer Home Page, click Alert Setup.

The Alert Messaging System dialog opens:

To add an alert, you need the default user ID and password.

4 To add an alert, click Add Alert Message.

5 Select accordingly.

6 You can use ZebraNet Alert to monitor alerts set through a ZebraLink-enabled 
printer.

From this Web page you can add alert messages to notify you when a printer is out of 
paper, needs a ribbon, and so on.
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ZebraNet Alert supports email notification of printer errors sent directly to any valid 
email address. You can have multiple email addresses set up for routing different error 
messages, or split notifications between email and other network management tools. 
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1 From the browser view, in the Address text-box type in the printer’s IP address. 

The Printer Home Page opens.

2 From the Printer Home Page, click Alert Setup.

The Alert Setup page shows a list of message notifications and their respective 
destinations (if no notifications are listed). 
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3 To set up email notification, go to the Alert Setup page and click Add Alert 
Message.

The Add Alert Message page opens:

.

4 Specify the condition to send over email, such as HEAD ELEMENT BAD or 
PAPER OUT.

5 Set destination to Email.

6 Enter a valid email address for the messages to be sent to. 

 ! Important • The printer accepts only the last configuration made.

Example • admin@yourcompany.net (The Port field can be ignored for 
email setup.)
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7 Click Add Alert Message. 

To receive email alert you must give PSII the IP address of your mail server that is 
running SMTP.

8 To save current settings, click Save Printer Setting. 

9 Enter the password and click Save Current Configuration.

10 You can continue to add more settings or, if finished:

• From the Printer Home Page, select PrintServer Settings>Network 
Communications Setup. 

• Click SMTP Email Alerts.   

• Specify your SMTP server address. 

When these steps are done, you can begin receiving email notification messages.
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1 From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet Alert.

Warning • A password is required. If you forget to enter the password, the alerts 
you just set are deleted.

Note • The SMTP Server address might be referred to as Mail Server address.
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The Active Log dialog opens, displaying a list of all the logged alerts:   
 

2 From this dialog, you can track the printer(s) activity and status. 

3 From the menu bar, you can explore all the other features, such as Reports.
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This section provides steps on how to check PSII’s configuration settings using 
ZebraNet View and a browser.
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1 From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.

The ZebraNet View dialog opens: 

2 From the menu bar, select Print Server>Configuration.
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The Print Server Configuration dialog opens: 

This dialog offers multiple tabs to choose from. Each tab contains various 
configuration settings that you can change.

For details on the configurations, see page 118.
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This section provides steps on how to check PSII’s configuration settings using its 
Web pages.
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1 Open a Web browser.

2 In the Address text-box, type your printer’s IP address, then press Enter.
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Your browser page looks similar to this:

3 From the Printer Home Page, click Print Server Settings.

The default User ID and password are required.

Note • Your printer firmware determines how this page looks. This page is from a 
printer with firmware x.10 and above.

 ! Important • The illustration of the Printer Server Settings page is based on a ZPL 
printer. If you have an EPL printer, the menu options on the Print Server page are 
slightly different.
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The Print Server Configuration Page opens:   

Note • Your printer firmware determines how this page looks. This page is from a 
printer with firmware x.10 and below.
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1 From the Print Server page, click Print Server.

The Print Server Configuration page opens:

2 For details on the configuration choices, see To check configuration settings, 
complete these steps: on page 53.
PrintServer II User and Reference Guide 57



Getting Started
Setting up a ZebraNet Connect IP
'����
 ����	�%���	&�����

�������

ZebraNet Connect IP allows you to send jobs to PrintServers that use Dynamic IP 
addresses (DHCP). It also notifies you of printer errors, such as paper out or head 
open. When print jobs are printed through ZebraNet Connect IP, they are sent directly 
to PSII and are not routed through a network server, resulting in a reduction of network 
traffic. 

If you have printing problems while using the ZebraNet Connect IP printing port, you 
may check the status of the port or change its settings through the printer Properties 
dialog.

� For Windows 95/98, select Port Settings under the Details tab.

� For Windows NT 4.0 or Windows 2000, select Configure Port under the Ports tab.
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If you are using the Windows NT 4.0 or Windows 2000 operating system, use the 
following procedure to set up a printer port for the PSII.

1 From the task bar, select Start>Settings>Printers.

2 Select the Windows printer to use when printing with the PSII.

3 From the menu bar, select File>Properties.

4 To add a ZebraNet Connect IP port, in the Ports tab select Add Port.

5 From the list of Available Printer Ports, select ZebraNet Connect Monitor as the 
type of port to add, and click New Port.

Note • The DHCP feature of ZebraNet Connect IP can rediscover a PSII on the local 
subnet, even when its IP address might be changing (e.g., when using DHCP for IP 
address resolution). The PSII is relocated by its port name as configured through 
ZebraNet View (the default name is Serial Number-Port Number). This feature is 
enabled on the local subnet only. A non-local PSII device is not rediscovered if the 
IP address changes.

Note • If ZebraNet Connect IP monitor is not listed, verify that the ZebraNet 
Connect IP software has been properly installed. To do this, you need to reinstall the 
software and choose Modify.
58  PrintServer II User and Reference Guide



Getting Started
Setting up a ZebraNet Connect IP
You enter into the Add ZebraNet Connect Port screen, where there is a list of all 
PSII devices available on the local subnet.

• The TCP/IP monitor searches only the local subnet.

• The IPX/SPX monitor retrieves all devices found in the NetWare bindery.

6 If the port you want to add is listed in the Ports Available on Local Subnet window, 
select the port name. If the port you want to use is not listed, you can: 

• Select Cancel and repeat step 5 to rediscover the print servers. 

• In ZebraNet Connect for IPX/SPX, click Search and enter the PrintServer’s 
Network Number and Hardware Address.

• In ZebraNet Connect, click the Locate Non-local Device button and enter the 
static TCP/IP Address used for the PSII.

7 Click Add.

8 To close the Printer Ports dialog, click Cancel.

9 To save the configuration, click OK.

Now you can use ZebraNet Connect. Whenever you print to the Windows printer 
configured with ZebraNet Connect, your print job will go directly to the ZebraNet PSII 
port.
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1 From the task bar, select Start>Settings>Printers.

2 Select the Windows printer that you want to print with ZebraNet Connect IP.

3 From the file menu, select File>Properties.

Note • The ZebraNet Connect for TCP/IP DHCP discovery feature relocates a PSII 
device on the local subnet by its port name, even if the IP address changes. This 
feature is enabled on the local subnet only. A non-local PSII device is not 
rediscovered if the IP address changes.

Note • Under Windows 95, you have to set up the printer for a local port first, then 
open Properties from the File menu and continue with the configurations.
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4 To add a ZebraNet Connect IP port, in the Details tab select Add Port.

5 From the Add Port dialog, select Other, then select the ZebraNet Connect Monitor 
as the type of port to add. 

6 Click OK.

The Add ZebraNet Connect Port screen opens. There is a list of all PSII devices 
discovered on the network.

• The TCP/IP monitor searches only the local subnet.

• The IPX/SPX monitor retrieves all devices found in the NetWare bindery.

7 If the port you want to add is listed in the Ports Available on Local Subnet window, 
select the port name. If the port you want to use is not listed, you can:

• Select Cancel and repeat step 5 to rediscover the PSII devices. 

• In ZebraNet Connect IP for IPX/SPX, click Search and enter the PSII’s 
network number and hardware address.

• In ZebraNet Connect IP, click the Locate Non-local Device button and enter 
the static TCP/IP address used for the PSII.

8 Click Add.

9 To save the configuration, click OK.

Now you can use ZebraNet Connect IP. Whenever you print to the Windows printer 
configured with ZebraNet Connect IP, your print job will go directly to the PSII port.
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ZebraNet Connect for IPX/SPX is a utility that allows simple, direct, IPX/SPX 
printing from your computer to a printer attached to a ZebraNet PSII. Print jobs printed 
through the ZebraNet Connect utility are sent directly to the PSII and do not require a 
NetWare server, resulting in a reduction of network traffic.

If you have printing problems while using the PSII Connect printing port, you can 
check the status of the port or change its settings under the printer Properties window.

� For Windows 95/98, select Port Settings under the Details tab.

� For Windows NT 4.0 or Windows 2000, select Configure Port under the Ports tab.

Note • If ZebraNet Connect IP is not listed, verify that the software has been 
properly installed.
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Notify on Printer Error — This feature checks the printer status prior to printing 
the job. If a printer error is detected (e.g., printer off-line), the error description is 
given.

Notify When Printed — This feature provides an alert when your job is active on 
the printer. This is useful if the printer is unusually busy.

Description — An optional field in which you can list any useful information 
about the printer port, such as location.
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You can enable protocols with WebView or ZebraNet View. This section provides you 
with directions for accessing and enabling protocols using both WebView and 
ZebraNet View.
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This section contains directions for accessing protocols using WebView. The browser 
illustrations were captured from a ZebraLink-enabled printer.
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1 Open a Web browser.

2 In the Address text-box, type your printer’s IP address, then press Enter.
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Your browser page looks similar to this: 

3 From the Printer Home Page, click Print Server Settings.

The default User ID and password are required.

4 From the Print Server page, click Print Server.
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The Print Server Configuration page opens: 

5 From the Print Server Configuration page, click Enabled Protocols.
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The Protocol Configuration page opens:

6 Select the protocols you want to enable, then click Submit Changes.

You get a confirmation to reset the unit for changes to take place.
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This section contains directions for accessing protocols using ZebraNet View.
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1 From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.
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The ZebraNet View dialog opens:

2 From the menu bar, select Print Server>Configuration.

3 Click the Protocols tab.

The Protocols tab opens:
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4 Select the protocols you want to enable, then click OK.

A confirmation message opens. 

5 To accept changes, click OK.
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This section provides you with instructions for defaulting the PSII to factory settings 
using WebView, ZebraNet View, and the Test button.

$��:��"����

������	�
�������'�������	�����������
 �����
 �$��:��"/�
����
���������������0

1 From the ZebraNet PrintServer view, click Factory Print Server Settings.

The Restore to Factory Defaults page opens:
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2 Enable the check box of the settings you want to reset, and click Submit 
Changes.
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1 From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.

The ZebraNet View dialog opens:

2 From the menu bar, select Print Server>Reset. 

 ! Important • With the reset command on its way to the PSII, the HTTP connection 
is unavailable while the PSII re-initializes. You need to wait a few seconds before 
trying to reestablish a connection.
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The Reset Print Server dialog opens: 

3 Select the settings you want to reset, then click Restore.
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1 The printer is turned off (O).

The Test button is a small hole on the PSII device. To press the Test button, you 
need to insert something small into the hole, like a paperclip.

2 With the printer turned off, press and hold the Test button on the PSII device and 
turn on the printer.

3 The status indicator tells you when PSII has been reset to factory defaults, as 
follows:

• If an active network cable is connected to the PSII, the status indicator turns 
solid green. When this happens, you can release the Test button.

• If there is not an active network cable connected to the PSII, the status 
indicator flashes green. When this happens, you can release the Test button.

• For more details on status indicators, see Status Indicator on page 134.
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This chapter provides you with instructions for configuring Novell’s NetWare for 
printing to PSII.
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You must have Zebra’s snap-in for Novell installed to complete these steps.

�����
�� �����
�&�!�

A��&��$	����������
��
 ���������'��/�
����
���������������0

1 From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.

2 Create a ZebraNet object by completing the following steps:

• From Novell’s NetWare Administrator, select the container in which you want 
the object created. 

• From the menu bar, select Object>Create.

If the Create option is gray, you do not have sufficient rights, or you selected a 
leaf object. 

• Find Zebra Print Server, select it, and click OK.
If the class of the object you want to create is not listed, you cannot create it in 
the container you selected.

• Define filter and sort devices for displaying a list of PSII devices to choose 
from, and click OK.

• Type in a name for the new PSII object, and click Create.
Wait for the print server to reset.

• (optional) To rename one of the PSII devices, select the one you want to 
rename, and click Create.

3 In the Directory Tree, find your object, and double-click.

4 Select Assignments>Assign>New.

5 Next to the Context text-box, click the Directory Tree icon, then double-click the 
browse arrow.

 ! Important • Some important items to keep in mind before you proceed with these 
steps:

� You must have PSII installed before you proceed with these steps. 

� Snap-in for Novell only works with Windows 9X operating systems. 

Example •  To create an object that is subordinate to sales, choose SALES.
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6 Find the Contexts container you want, and double-click.

It auto-fills into the Context text-box.

7 Enter the printer name you want, and click Create.

8 Next to the Print Queues section, click New.

9 Next to the Context text-box, click the Directory Tree, and double-click the 
Browse arrow.

10 Select the Context you want.

It auto-fills the text-box.

11 In the Print Queue Name text-box, type in the name you want.

12 Next to the Print Queue Volume text-box, click the Directory Tree icon.

13 Double-click the Volume you want, and click Create.

Your Print Queue Name is listed with the name of your Context as the extension.

14 Click OK, and then click OK again.

Wait for the print server to reset.

15 To refresh your Directory Tree, double-click on your context twice.

You now see the Object, Printer Name, and Print Queue that you created.
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1 On Add Printer double-click, and click Next.

2 Select Network Printer, and click Next.

3 Click Browse and click on the context.

You can see the queue and printer that you created.

4 Select the queue, and click OK.

The Network path (queue name) auto-fills.

5 Click Next.

6 Select Generic for Manufacturer of printer, and click Next.

7 Select Keep Existing Driver, and click Next.

8 Enter the printer name you want and click Next.

9 Select No for printing a Test Page, and click Finish.
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10 From the Printers dialog, double-click on your new printer and set it as the default 
printer.

11 Open a text editor, create ZPL (Zebra Programming Language) file, and print.
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This chapter provides information and instructions on configuring your printer.

Content
BSD (Berkeley Software Distribution)-Style Print 

Queue . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76
System V Queue Installation . . . . . . . . . . . . . . 78

�

PrintServer II User and Reference Guide 75



Printing Configurations
BSD (Berkeley Software Distribution)-Style Print Queue
-'��<-����
���'���"	��������������
=5
'��
�����
��B����

BSD is a version of the UNIX OS that distributes software that includes TCP/IP.
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For remote BSD-style LPD printing, add the PSII as a remote printer in the /etc/
printcap database to each host printing to the PSII. You can add printcap options as 
needed. If you are unfamiliar with these options, consult the printer documentation. 

The entry looks similar to this:

local_print_queue_name|[printer_model_and_manufacturer]
:\

:lp=:mx#0:rm=ZebraNet_name:\

:rp=remote_print_queue_name:\

:sd=path_to_spool_directory:lf=just log_file_name

local_print_queue_name — This defines the name of the printcap entry. It is 
used by the LPR/LPD utilities to specify which printcap entry is being referenced. 
Additional printcap entries can be added as needed for different queue types. Each 
entry must have a unique local_print_queue_name and a different spool directory to 
work properly. When you are ready to print, use the local_print_queue_name that 
matches the data type of the file to be printed.

ZebraNet_name — This is the name (alias) of the ZebraNet PSII. This must be the 
same name as entered in the /etc/ hosts file or your NIS or DNS system. An IP 
address may also be used here.

remote_print_queue_name — This entry determines the ZebraNet port where 
the print job will be printed and optionally specifies ASCII printing that must end for 
LF1.

 ! Important • You must be logged in as root.
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path_to_spool_directory — This is the path to a directory where the print 
jobs will be spooled for this queue. You must create a unique spool directory for each 
printcap entry.

log_file_name — This is the path to a file where error information from the LPD 
will be logged.  

Example • Your printcap entries might look similar to this:

Ascii_files|form.feed.Queue_on_Port_1:\

:lp=:mx#0:rm=pserver1:rp=MYQUEUELF1:\

:sd=/usr/spool/myqueuelf1:\

:lf=/usr/spool/myqueuelf1/queue.log

 ! Important • Each printcap entry must have a different spool directory to work 
properly.
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This section describes the configuration of the printing system on the UNIX operating 
system. For clarity and brevity, the following specific names are used to represent 
general devices or concepts. 

lj4 — The local queue name on the UNIX system to which you want PSII print jobs 
directed.

ZEBRAPRINTER — The host name or IP address of the remote system that is the PSII 
device. For example, to Telnet to the PSII and invoke the PSII configuration utility, 
you would enter: 

Telnet ZEBRAPRINTER

A host name is not required for the PSII — the IP address can be used. 

yourqueuename — This is the name of the queue on the ZebraNet and must end 
with LF1.
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Before you proceed, the following prerequisites must be met: 

� The name ZEBRAPRINTER and the IP address assigned to the PSII are in the /etc/
hosts file on the UNIX system.

� The LPD must be running on the UNIX system.
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1 Log in to the UNIX machine as root. 

2 Type:

lpsystem -t bsd ZEBRAPRINTER
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3 Type:

lpadmin -p lj4 -s ZEBRAPRINTER!yourqueuename - I any

4 Type:

accept lj4

5 Type:

enable lj4

6 Try printing by typing the command:

lp -d lj4 [filename]
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In this chapter you are given steps to set up your PSII to support Internet Printing 
Protocol (IPP). Also, an exercise is provided to experiment with File Transfer 
Protocol (FTP) support.
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Using Printing Protocols
IPP
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IPP is an application-level protocol used for distributed printing over the Internet. 
Using IPP from any standard IPP client, you can transfer jobs to a printer that is 
connected to your ZebraNet PSII device and the Internet. 
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1 Open a browser.

2 Enter the PSII IPP URL as follows:

http://xxx.xxx.xxx.xxx:631/ipp/port1

xxx.xxx.xxx.xxx = the IP address of the PrintServer II 
device

:631 = a fixed value

/ipp = a fixed string designating IPP

/port1 = a fixed value

 ! Important • You must have IPP support on your system.

 ! Important • IPP support is not available on all PSII printers. To be certain you are 
running the latest version of firmware, visit our Web site:

www.zebra.com

Example • Your address might look like this:

http:198.60.248.120:631/ipp/port1

Note • Because IPP does not have an official standard, usage depends entirely on 
the quality of the IPP client and server.
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FTP
����

Embedded within the PSII is an FTP server application that processes file transfers 
from a host computer to the printer.

If the printer is on a network, label formats can be generated and data can be 
transferred without setting up a print queue.
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1 In a text editor, generate the following ZPL II code:

^XA

^FO100,100

^CF0,55^FDZebra Technologies^FS

^XZ

2 Save the file and name it test.txt.

3 Open the MS-DOS Command Prompt and type:

ftp <IP of PrintServer II>

This opens a session with the FTP server. 

4 Type your user name and press Enter.

5 Type:

put test.txt

This transfers test.txt to the printer, and the printer generates a label.

Example • If the IP address of your PSII device is 12.3.4.123, you would type:

ftp 12.3.4.123

Note • The default user name is blank.
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6 To terminate the FTP session, type:

quit
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This appendix provides you with details on the PSII features that were not covered in 
the chapter Getting Started on page 35.
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This section covers features available for the PSII only, not the printer’s features. Some 
of the features you access in this section prompt you to enter the default user ID and 
password, as follows:     

• User ID: admin

• Password: 1234 

The options on the Print Server page vary. ZPL and EPL printers print server settings 
vary slightly.
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The steps that follow are based on the navigation of a ZPL printer using firmware X.10 
or higher.

���	�������������
�����!��������
 �/�����
���������������0

1 Open a Web browser.

2 In the Address text-box, type your printer’s IP address, and press Enter.

Note • The difference between ZPL and EPL is this:

��ZPL — If you have a ZPL printer, you are initially prompted to the Printer 
Home page, and from there, you select Print Server Settings.

��EPL — If you have an EPL printer, you are immediately prompted to the Print 
Server page. 

 ! Important • You can upgrade your firmware by visiting our Web site: 

http://www.zebra.com
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PSII Features
The Printer Home Page opens:

3 From the Printer Home Page, click Print Server Settings.

 ! Important • The illustration of the Printer Server Settings page is based on a ZPL 
printer. If you have an EPL printer, the menu options on the Print Server page are 
slightly different.
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The PrintServer page opens:

4 From the PrintServer page, click Print Server.
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The Print Server Configuration page opens:

5 In the Print Server Configuration page, you have a menu to choose from. The table 
that follows identifies what each menu option page looks like:
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Enabled Protocols

Modifies the protocols to be used. 
NetWare, HP JetAdmin, or both.

Enabling HP JetAdmin Support allows 
status from the Zebra device to display in 
Hewlett-Packard’s HP JetAdmin utility.

Netware

Preferred Tree — Enter the tree that the 
printer is in.

Print Server Name — Enter the name of 
the printer.

Disable NetWare SAP — Enables or 
disables the broadcast SAP (Service 
Advertising Protocol) messages. Typically, 
SAP is enabled. If SAPs are disabled, the 
print server does not appear in the bindery 
and is not discovered by ZebraNet View. 
Disabling SAPs reduces network traffic, 
however, SAPs should be disabled, only on 
networks using NDPS exclusively or 
NetWare 5 over the IP protocol.

NetWare Frame Format — You can select 
how the frames for the data packets are 
assembled. The default is Automatic 
Sensing.

For details, see Help. 
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TCP/IP Configuration

You can change the TCP/IP Configuration 
of the PSII.

For details, see Help.
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TCP/IP Logical Printing Ports

Logical printers allow you to set up 
multiple pre- and post-processing 
configurations for each output port. Each 
logical port configuration can do the 
following:

��Add user-configured strings before and 
after the print data.

��Remove unwanted characters from the 
beginning of the print data.

��Four logical printer configurations are 
supported for each output port on the 
printer. The configurations can be 
assigned to any port, and all of these con-
figurations can be assigned to a single 
output port.

System (SNMP)

This feature gives you the ability to 
manage multiple devices on a network, be 
it printers, computers, or other network-
attached devices.

On this page you can define the SNMP 
system name, system location (PSII 
description), and other SNMP settings for 
your PSII.
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IPX Alerts (Traps)

Internetwork Packet Exchange (IPX) is 
Netware’s network-layer protocol that 
handles networking addressing, routing, 
and packets. 

This feature has you enter the IPX Network 
Address and IPX Node Address to which 
traps will be sent.

��To broadcast traps to all addresses on all 
networks, enter FFFFFFFF in the IPX 
Network address field and 
FFFFFFFFFFFF in the IPX Node 
Address field. 

��To broadcast traps to all addresses on a 
specific local network, enter the network 
number in the IPX Network Address 
field and then FFFFFFFFFFFF in the 
IPX Node Address field.

��To disable traps, set all destination 
addresses to 0.

SMTP Email Alert Configuration

This feature allows you to enter data 
regarding System Information on the 
network that is being used. Typically, a 
Network Administrator would use this.
PrintServer II User and Reference Guide 93



PrintServer II
PSII Features
���
��'��!���'�	���

From the Print Server page, in the Print Server Status section you can access PSII’s 
configuration sheet and port status.

Web Admin

This page allows you to configure the 
Admin name and password. Links to 
upgrades and support information can also 
be altered. 

POP3 Email Printing

This feature helps you set up the print 
server to receive email messages 
containing formats that can be printed. The 
POP3 settings must be set to retrieve 
emails from the email server. 

Warning • Setting the POP3 polling 
interval (seconds) below 30 can cause 
communication problems with the POP3 
server.
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1 From the PrintServer page, click View Configuration Sheet.

This page opens:
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1 From the Print Server page, click View Port Status.

The port status page opens:

*����

From the Print Server page, in the Reset section you can reset PSII’s configuration 
settings to what they were before you made the most recent changes.
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1 From the Print Server page, click Reset Print Server.

 ! Important • The default user ID and password is required to access this page.
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The Reset Device page opens:

2 To reset PSII, click Yes.
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From the Print Server page, in the Restore section you can restore PSII’s to the default 
factory settings:
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1 From the Print Server page, click Factory Print Server Settings.
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The Restore To Factory Defaults page opens:

2 Make the selections you want, and click Submit Changes.
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The appendix provides you with detailed information that allows you to use the 
enhanced functionality of your ZebraLink-enabled printer with the PSII.
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WebView gives the System Administrator or user who needs complete, easy, one-step 
control over the printing environment exactly what is needed. It provides real-time 
configuration, control, and monitoring capabilities with the convenient graphic 
interface of a Web browser. 

The Web pages returned by Zebra printers are not static. They contain real-time 
information about the printer’s present state of operation, including on-line status, 
error conditions, and all printing parameters. 
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The Home Page is the first Web page that opens. It is a page with a menu of 
hyperlinks. Each hyperlink allows you to make modifications to the printer, PSII, and 
network settings; the other changeable settings through the Home Page include:

� Network Status, Error, and Warning reports

� ZebraNet PSII configuration

� Printer settings

� Directories of objects stored in Flash memory and RAM devices

� Objects, stored fonts, images, programs, and ZPL II formats

� Zebra Technologies support and home pages

������
�����$��:��"������������
���/�����
���������������0

1 Open a Web browser.

2 In the Address text-box, type your printer’s IP address, and press Enter.

Note • To access the printer’s Web page, you need the IP address. For instructions 
on getting the IP address, see Assigning an IP Address on page 38.
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The Printer Home Page opens:
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The View Printer Configuration menu option provides accurate, up-to-the-minute 
information on the printer’s current state. An administrator can conveniently find any 
information on the Virtual Configuration Label and also check on the status of printer 
ports.
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1 From the Printer Home Page, click View Printer Configuration.
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The WebView displays the configuration settings:

2 To update the printer information from this view:

• For Netscape, select Reload and the printer sends current information to the 
Web browser.

• For IE, click Refresh and the printer sends current information to the Web 
browser.

3 When you are finished reviewing:

• To return to the Home page, click the Home link.

• To print the label, scroll to the bottom of this page and click Print Label. 
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This section provides you with steps for accessing and modifying printer settings with 
a ZebraLink-enabled printer. It also provides illustrations of the various pages you can 
access.
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1 From the Printer Home Page, click View and Modify Printer Settings.

 ! Important • To apply changes made in this section, you need to use the default user 
ID and password:

User ID: admin 
Password: 1234
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The View and Modify Printer Settings page opens:

2 In the View and Modify Printer Settings page, you have a menu to choose from. 
The section that follows identifies what each menu option page looks like:
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General Setup

Serial Communications 
Setup
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Network Communications 
Setup

Print Listings on Label
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Media Setup

Calibration
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WebView
ZPL Control

Advanced Setup
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The directory page provides a listing of all file system devices (B:, E:, R:, Z:). The 
size, name, and location of each stored object appears.

Buttons are available to perform file management operations on the objects. The file 
management operations include:

• Delete object — Not available for objects in read-only memory (Z:).

• Copy object to a new name and/or device — Not available for objects that 
have the “protected” attribute set.
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1 From the Printer Home Page, click Directory Listing.
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This page opens:

2 There are several links to select in this view. 

3 To create a script, click Create New Script.

)
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To configure the printer’s interaction with ZebraNet Alert to be completely functional, 
SNMP settings must be established in these areas:

� The printer, via the WebView interface.

� The Alert Printer Management Utility for logging SNMP traps.
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The ZebraLink messaging system provides for more than SNMP notification. Alert 
can be routed to various destinations:

• TCP

• UDP

• email

• serial port

• parallel port destinations
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1 From the Printer Home Page, click Alert Setup.

The Alert Messaging System page opens:

2 To add an alert, click Add Alert Message.

3 Select accordingly.
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ZebraNet Alert supports email notification of printer errors sent directly to any valid 
email address. You can have multiple email addresses set up for routing different error 
messages, or split notifications between email and other network management tools. 
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1 From the browser, in the address text-box type in the printer’s address. 

The printer’s home page opens.

2  From the Printer Home Page, click Alert Setup.

The Alert Setup page shows a list of message notifications and their respective 
destinations. 

3 From the Alert Setup page, email notification can be set up. Click �
Add Alert Message.
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The Add Alert Message page opens:

.

4 Specify the condition to send over email, such as HEAD ELEMENT BAD or 
PAPER OUT.

5 Enter a valid email address for the messages to be sent.
 

 ! Important • The printer accepts only the last configuration made.

Example • admin@yourcompany.net (The Port field can be ignored for 
email setup.)
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6 Click Add Alert Message. Here you can continue to add more settings or, if 
finished, save the current settings.

7 From the Printer Home Page, select PrintServer Settings>Network 
Communications Setup. 

8 Click SMTP Email Alerts.

9 Specify your SMTP server address. 

When these steps are done, you can begin receiving email notification messages.
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This page offers control over basic printer functions. 

Other functions are also accessible from this page. These include:

• Feed — causes printer to feed one label.

• Cancel One Format — cancels the currently printing format.

• Cancel All Formats — cancels all formats.

• Reset Printer — causes printer to perform its standard reset without 
cycling power. 
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1 From the Printer Home Page, click Printer Controls.

Warning • You must type in a password. If you forget to enter the default 
password, the alerts you just set are deleted.
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This Printer Controls page opens:
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This section provides you with instructions for viewing the current printer settings.
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� From the Printer Home Page, click Print Server Settings.

 ! Important • In this view, you must have administrative rights to make changes to 
the printer controls. 
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WebView
 The PrintServer page opens:   

For more details on PSII, see PrintServer II on page 85.
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The appendix provides you with details on ZebraNet Utilities, the software suite of 
printer administration tools that complements and enhances both ZebraLink and the 
ZebraNet family of connectivity products. 
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ZebraNet View
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ZebraNet View allows you to locate printers automatically. It can search on parameters 
such as IP address, subnet, printer model, printer status, and many other user-defined 
characteristics. It also offers powerful device management capabilities.

������
�%���	&���:��"����
�����/�����
���������������0�

1 From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.

The ZebraNet View dialog opens:

2 Select your printer.

3 From the menu bar, select PrintServer>Configuration.
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ZebraNet View
The Print Server Configuration dialog opens:

There are multiple tabs that you can access to make changes to current settings. 
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4 From the Print Server Configuration dialog, click the SNMP Traps tab.
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ZebraNet View
The SNMP Traps tab shows the alerts you can set.

5 To monitor the set alerts (printer traps), see ZebraNet Alert on page 121.
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ZebraNet Alert gives you the ability to manage your Zebra printers by immediately 
notifying System Administrators of printer error or warning conditions. Using Web- 
based configuration tools, selected errors or warning conditions can be routed to a 
variety of services such as email messages, wireless pagers, or the ZebraNet Alert.

The following tables show the conditions that can trigger alerts:
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� On-line (condition clear)

� Off-line

� Paper out

� Printer error

� Media out

� Ribbon out

� Printhead over-temp warning

� Printhead under-temp warning

� Head open

� Power supply over-temp

� Ribbon warning (in direct-thermal mode)

� Rewind full

� Cut error

� Printer paused

� PQ job completed
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Unsolicited Alert messages can be directed to the following destinations:

� Email (PSII-specific)

� Serial (ZebraLink-specific)

� Parallel (ZebraLink-specific)

� TCP (PSII-specific)

� UDP (ZebraLink-specific)

� SNMP (PSII-specific)
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You can send notifications over SNMP only, for use with ZebraNet Alert or a similar 
network management utility. 
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1 From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View.

2 Select the printer you want.

• If a DHCP server is present, the PSII will already have an IP address.

• If no DHCP server is present, you might need to assign the printer an IP 
address.

3 To assign your printer an IP address, from the menu bar, select Print 
Server>Configuration.

4 For PrintServer SNMP Traps, select the SNMP Traps tab.

5 Enter the trap destination and options.

� Label taken

� Head element out

� Power on

Important • If you did not install ZebraNet Alert during the ZebraNet Utilities 
installation, see ZebraNet Utilities on page 26.
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This tells the PSII what TCP/IP address to send the alerts to, and under what 
circumstances to send error and log reports. Entering 255.255.255.255 broadcasts 
the message to every host on the network with an SNMP program running.

6 For ZebraNet Alert to get and display the messages, you need to open ZebraNet 
Alert. To do this, follow these steps:

• From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet Alert.

� In the ZebraNet Alert dialog, from menu bar, select View>Filter Settings. 

� From the View Filter - Devices tab, choose your settings accordingly. 

� The View Filter - Events tab allows you to select individual events you want the 
program to be aware of.
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To easily transfer instructions and data to your printer from a remote location, PSII 
allows you to send email to the printer. This is set up under the link POP3 Email 
Printing. You need to provide the address of the network POP3 server, a user name, 
and a password.

With this option, you can create a text-based email containing ZPL II code and transfer 
it to the printer.

By using the proper ZPL II commands, files can be saved, loaded, printed, copied, and 
deleted, just as if the data were transferred from a serial or parallel port.

Important • The SNMP trap settings must be established to communicate with PSII 
if messages are sent to the ZebraNet Alert.

Note • If you select No device filtering, messages from every printer are caught; 
Device Address allows you to specify which IP address data will come from.

Important • Now PSII’s SNMP Alert messages can be set up in WebView. From 
the printer’s home page, activate the link to Alert Setup. You can add messages that 
are sent to the ZebraNet Alert for Windows by choosing SNMP as a destination.

Note • Email attachments sent to the printer are not supported.
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1 From the Printer Home page, click Print Server Settings.
124  PrintServer II User and Reference Guide



ZebraNet Utilities
ZebraNet Alert
The PrintServer page opens:

2 From the PrintServer page, click Print Server.
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ZebraNet Alert
The Print Server Configuration page opens:

3 From the Print Server Configuration page, click POP3 E-mail Printing.
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ZebraNet Alert
The POP3 Printing Configuration page opens:

4 Make the necessary changes, and click Submit Changes.

ZebraNet Alert monitors status and activity of all Zebra printers on the network. It 
alerts the administrator when there is an error condition, which reduces printer 
downtime and increases application efficiency.
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1 From the task bar, select Start>ZebraNet Utilities>ZebraNet Alert.

2 In the ZebraNet Alert dialog, from the menu bar select Report>. The report menu 
option has multiple report selections.

3 Select the type of report you want to generate.
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ZebraNet Alert
This is an example of the Event Summary report. Notice it generates a .log file:
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For details, see Setting up a ZebraNet Connect IP on page 58.
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ZebraNet View Java Applet is a Java-based version of ZebraNet View. This can run on 
any enabled platform that can run a Java virtual machine, such as Windows, UNIX, 
Linux, and many others.   
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1 From the task bar, select Start>Programs>ZebraNet Utilities>ZebraNet View Java 
Applet 1.0.

Important • To use this, you must have installed it with ZebraNet Utilities and then 
installed this application. For installation instructions for ZebraNet Utilities, see 
ZebraNet View Java Applet on page 30.
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ZebraNet View Java Applet
This view opens:

2 In the Search Method drop-down list box, select the search method you want.

3 Click Begin Search.

It searches your network for all networked Zebra printers, discovers them, and lists 
them.

4 When you select a device from the list that is discovered, the selected device’s 
Home Page displays in the lower portion of the view (it replaces the ZebraNet 
View Web Configuration Utility content).
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ZebraNet View Java Applet
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This provides you with solutions to known issues.
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Hardware Troubleshooting
Troubleshooting the PSII
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To reset the PSII configuration parameters to the factory defaults, press the Test button 
and hold it in while turning the printer power on. Keep the test button pressed until the 
Status Indicator light turns green, then release the test button. After approximately 20 
seconds, a configuration label prints automatically.

'�	�����
���	������

A bi-color Status Indicator displays the operational status of the PSII. The following 
conditions might occur:

� During normal operation, the LED is solid green for more than 30 seconds. This 
indicates all the hardware is functioning properly and it has detected the presence 
of the network. It does not mean the PSII has an IP address or is attached to a 
printer queue.

� If the LED is rapidly flashing green (9 times/sec), the PSII has not detected the 
presence of a network cable. To solve the problem:

• Turn the printer power off. Remove the network cable from the PSII. Plug the 
network cable back in until you hear a positive click. Check the other end of 
the cable in the same manner. Turn the printer power on. If the PSII still does 
not detect a cable, continue.

• Verify that the network cable is 10BASE-T and has an RJ-45 connector. 

• Connect the PSII to a network drop that is a known good network connection. 
If the PSII is still unable to detect the network cable, contact Technical 
Support for assistance.

� If the LED is slowly flashing green (1 time/sec), the PSII is trying to print a job. If 
the job does not print, check the following:

• Verify that the printer has media and ribbon (if in thermal transfer mode). If 
the printer is showing any errors, it is unlikely that the PSII can send data to 
the printer. The LED continues to blink until the printer malfunction is 
resolved or until the printer is turned off.

 ! Important • Cables with a rating higher than CAT-5 have not been tested.
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• Flashing red indicates the Power On Self Test (POST) is in progress.

� If the LED is solid red for more than 30 seconds, the PSII has failed the POST. If 
the failure is not severe, the PSII attempts to print a configuration label on the 
printer. A failed POST can be caused by any of the following:

• The printer attached to the PSII device is malfunctioning. Turn the printer 
power off, wait 10 seconds, then turn the printer back on. 

• If the PSII still fails the POST, continue below. The PSII has a hardware 
problem that can be fixed only by replacing or returning the unit. Contact 
Technical Support for repair or replacement information.

� If the LED is alternately flashing red and green for longer than 2 minutes, the PSII 
is in firmware-download mode. This means it is waiting for new firmware data to 
be sent before it continues normal functioning. Perform the following:

• If the PSII was purposely put into firmware-download mode, finish the 
download with the proper update utility. Contact the Zebra Web site at        
http://www.zebra.com to download this utility.

• Contact Technical Support for help recovering this unit.
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If you are having problems using the ZebraNet View utility to discover or configure 
the unit, check the following:

� Verify there is not a router between the workstation running ZebraNet View and 
the PSII. Because the PSII does not have an IP address, TCP/IP communication 
cannot be started across a router. Run ZebraNet View on the same subnet as the 
PSII. This is not a limitation when using ZebraNet View for HP JetAdmin in IPX/
SPX Discovery Mode.

� Verify the PSII has a solid green light. If the LED shows a rapidly flashing green 
light, check the network cable that is attached.
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� If you are having problems printing, verify that there is communication between 
the PSII and the printer. Check the following:

• Print a configuration label by pressing the test button on the PSII. If a 
configuration label does not print, verify the printer has media and ribbon (if 
used) and is not paused. 

• If problems persist, contact Technical Support.
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Troubleshooting the PSII
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To assign an IP address to a ZebraNet PSII using ZebraNet View, you must be on the 
same subnet. If ZebraNet View has Multicast enabled, you might be able to view the 
ZebraNet PSII on another subnet, but you will not be able to configure the device.
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The ZebraNet PSII might be set up and managed using HP JetAdmin or HP Web 
JetAdmin products.
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This is a group of frequently asked questions (FAQs) about PSII.
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Frequently Asked Questions
FAQs
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This table provides frequently asked questions (FAQs) on PSII:
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Are there any differences in 
functionality between a ZebraNet 
PSII with an EPL-based printer 
and with a ZebraLink-enabled 
ZPL printer?

Yes.

��In a ZebraLink environment, with either a 
Web browser or with the ZebraNet View 
Utilities, there are a variety of Web pages 
that display a wealth of status information 
regarding both the ZebraLink printer and 
its ZebraNet PSII. However, when used 
with an EPL printer, such as the LP/TLP 
2844, the Web pages for printer status are 
not available at this time, only the Web 
pages showing status of the PSII are dis-
played. The PSII can be easily configured. 
However, printer configuration information 
regarding the EPL printer is not available 
via the ZebraNet Utilities. 

��Error conditions: Using ZebraNet Alert, an 
EPL printer can be configured to use differ-
ent IP addresses to report the following 
Alert status conditions: on-line, off-line, 
paper out.

��For EPL: only two destinations can be con-
figured to report error messages (online, 
offline, and paper out) using SMTP email 
alert – serial and parallel port destinations 
are not supported.

Can the internal ZebraNet PSII 
option work on a computer 
network that is running both 
TCP/IP and IPX protocols 
simultaneously?

Yes. 

The ZebraNet PSII runs all of its available 
protocols simultaneously. This means that the 
ZebraNet PSII can run on mixed networks 
such as a network using Microsoft, UNIX, 
and Novell NetWare operating systems.
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Will the ZebraNet PSII allow 
connectivity to anything other 
than a PC network?

Yes. 

The ZebraNet PSII allows connectivity to 
systems such as IBM’s AS400, provided that 
it is configured using TCP/IP. Other network 
protocols can be used with third-party 
adapters that are converted to 10BASE-T.

Will the ZebraNet PSII option 
work on a 10BASE-T per second 
network?

No. 

The ZebraNet PSII option is a 10BASE-T 
print server. This means that the data cannot 
travel any faster than 10 megabits per second. 
The ZebraNet PSII can be deployed on a 
network that is utilizing 10/100 hubs, but the 
ZebraNet PSII operates at only 10 megabits 
per second. 

What if a print job makes it to 
the queue, but never leaves the 
queue? The label does not print. 

These are the things to check:

��Confirm that the printer is turned on and 
receiving power. 

��Confirm that the network cable is plugged 
in and that you can ping the printer.   

If the above bullets do not change the 
outcome, it is likely that there was a 
misconfiguration while creating the queue. 
The queue must be recreated verifying the 
following:

��Confirm that you use the print server’s 
valid IP address. 

��If you are using a UNIX or AS/400 
host, there is an option for the remote 
queue name. There is only one valid 
response to use: PORTLF1.

��If Windows does not have LPR 
installed, the above required option 
should be left blank.

��See the documentation for other oper-
ating system specific queue creation.   

B������
 )
�"��
PrintServer II User and Reference Guide 139



Frequently Asked Questions
FAQs
What are the minimum 
requirements to network a 
printer?

��Cat-5 network cable with 10BASE-T con-
nectors

��PSII

��Hub or Switch

��If a hub or switch is NOT used, you need a 
cross-over cable.

��Workstation running a TCP stack with print 
services installed

What do the activity lights on the 
PSII mean?

��Fast blinking (9 times/second) — no link 
status

��Slow blinking (1 time/second) — no IP 
address, or the unit is sending data to the 
parallel port

��Blinking red — unit is still in POST

��red-green-red-green — unit is in Netware 
firmware update mode

��red-red-green-green — unit is in IP firm-
ware update mode

��Solid red — unit has failed POST. Remove 
network cable and restart printer

What is the default User ID and 
password for the print server?

��The User ID is admin and the password is 
1234.
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What ports are open on PSII and 
related software?

TCP Ports:

��21 FTP

��23 Telnet

��80 HTTP Server

��515 Printer port

��631 IPP port

��9100 Raw socket connection

UDP Ports:

��161 SNMP broadcast from PSII

��162 SNMP trap on ZebraNet Alert

��4201 discovery destination on PSII

��(dynamic) SNMP get request from Zebra-
Net View

��(dynamic) discovery broadcast from Zebra-
Net view

��(dynamic) discovery broadcast from Zebra-
Net view Java
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What are my network 
connectivity options based on 
when using a PSII? 

It depends on your environment, but the print 
server accepts print jobs in any of the 
following ways:

��FTP — ZPL/EPL files can be sent to the 
printer via a FTP client as standard ASCII 
files

��HTTP — (ZebraLink-enabled printers only) 
Using the script option of the print server’s 
homepage, you can type ZPL into a speci-
fied location of the Web browser and send 
it to the printer 

��IPP — Using third-party IPP clients, print 
jobs can be sent via the internet

��LPR/LPD — Sometimes referred to as 
queue based printing. LPR/LPD is the stan-
dard in network printing. Most TCP/IP 
operating systems are compatible with this 
option

��Raw socket connection — You can connect 
to the printer directly via the network, 
bypassing everything in-between. This 
option is commonly used to integrate ZPL/
EPL into existing programs, such as VB 
scripts

��POP3 — With proper configuration, you 
can place ZPL/EPL files into the body of 
an email, and it will print. The print server 
periodically checks this email box at the 
specified intervals and prints the body of 
the message. IMPORTANT: attachments 
and subject line are not supported
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10BASE-T   A type of Ethernet that uses unshielded twisted pair cable.

arp   The standard TCP/IP method for determining the actual network address of a 
device based on its IP address. 

ASCII   A standard for the binary representation of characters. 

BOOTP  BOOTP (Bootstrap Protocol) is a protocol that lets a network client 
configure automatically. It can automatically configure any of the following 
information: IP address, gateway, subnet, system name, name server, and more. It 
automatically assigns the necessary settings from a pool of pre-determined addresses 
for a certain duration of time. BOOTP is the basis for a more advanced network 
manager protocol, the DHCP (Dynamic Host Configuration Protocol). 

broadcast  In a network, a situation when all destinations on the network receive a 
given packet. 

client   A workstation or PC in a client/server environment. 

community  For SNMP, a relationship between an agent and a set of SNMP 
managers that defines security characteristics. The community concept is a local one, 
defined at the agent. Each community is given a unique community name. 

�

PrintServer II User and Reference Guide 143



Glossary
DHCP (Dynamic Host Configuration Protocol)   DHCP is an alternative to 
another network IP management protocol, Bootstrap Protocol (BOOTP). Like 
BOOTP, DHCP can configure an IP address, gateway, subnet, system name, and name 
server. When speaking about the PSII, BOOTP, and DHCP configure the same 
options.

delete bytes  This number is used to remove characters from the beginning of every 
job sent to the logical printer. The value for delete bytes can range from 0 to 255. 

dynamic  A dynamic configuration, as the name implies, means that it changes. 
BOOTP and DHCP offer time-based leases for the configurations they assign. Their 
changes depend on the time-based lease, and how often the printer itself is offline and 
online again. A dynamic configuration includes BOOTP or DHCP. 

EPL  Eltron Programming Language.

Ethernet  A widely used local area network system based on the IEEE 802.3 
standard. 

firmware  Software routines that are stored in ROM (Read Only Memory). This is 
typically part of a device, such as a printer or PSII. 

FTP  File Transfer Protocol, a TCP/IP-related protocol for transferring files between 
devices on a network. 

Flash memory  A type of memory that allows read-and-write operations, but 
permanently stores data when the power is turned off. Useful for storing firmware 
because it can be easily updated by downloading new code. 

gateway  A device that converts one higher-level network protocol to a different 
higher level protocol. 

gleaning  A temporary, local configuration option. Gleaning lets you add the address 
of the device you want to configure to your local workstation’s arp table. This 
configuration is not permanent and is valid only from the workstation from which you 
entered the arp information. After the information is entered into the workstation’s arp 
table, the user follows up with a Telnet session to enter the information permanently. 
This configuration option is used mostly by non-Windows workstations that cannot 
run the ZebraNet View configuration utility. 

IP  Internet Protocol, one of the main protocols of the TCP/IP protocol suite. 
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IP address  A network address used by the TCP/IP protocol.

IPP  Internet Printing Protocol. Allows you to associate a printer with a URL address 
that is used for printing over the Internet.

IPX   Internetwork Packet Exchange, one of the NetWare protocols.

JetAdmin  A Hewlett-Packard printer management program available for NetWare 
and TCP/IP. 

logical  Refers to conceptual rather than physical. For example, a computer might 
have a single physical connection to the network (an Ethernet adapter card), but could 
have logical connections to several other devices on the network. 

MAC Address  Media Access Control. Ethernet address that corresponds to the 
assigned IP address. 

name server  A workstation on a TCP/IP network that provides a list of all 
workstations on the network. 

NetWare  A network operating system developed by Novell. 

node  A device connected to a network, such as a computer or print server.

parallel port   A port on a device that sends information in groups of bits over 
multiple wires, one wire for each bit in a group. 

ping  A TCP/IP command that determines whether a device is accessible on the 
network. 

POP3  Post Office Protocol, the protocol used to retrieve email from the server. 

port  A physical connector, such as the parallel port, or a logical connection to a 
device.

post string  A string that is sent at the end of every job going to the logical printer. 
Maximum 64 characters long.

pre string  A string that is sent at the beginning of each job that goes to the logical 
printer. Max 64 characters long. 
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print server  A device in a network that changes a network protocol into a printer 
protocol. 

protocol  A method of sending and receiving data between two or more workstations 
on a network, and insuring that the data is received without errors.  

rarp  Reverse Arp, a standard TCP/IP method of determining a device’s IP address 
based on its Ethernet address. 

raw TCP port  A type of TCP port in which data is passed unmodified to the 
receiving node. 

RJ45  A type of modular jack connector similar to a telephone connector with up to 
eight wires. Used for 10BASE-T Ethernet connections and for serial port connections. 

serial port  On a printer or print server, a port that transfers data one bit at a time. 
Serial ports usually have either a 25-pin, 9-pin "D", or RJ45 connector. 

server  A device on a local area network that provides services to client computers on 
the network. 

SMTP  Simple Mail Transfer Protocol, a protocol used to send email messages over 
the Internet. 

SNMP  Simple Network Management Protocol, a protocol for monitoring and 
controlling devices on a network. 

spooling  In printing applications, spooling is the transfer of data to a temporary 
storage area on disk (the print queue) prior to printing. Spooling allows many jobs to 
be queued to a single printer. 

static  Refers to a static IP address. All information is provided by the network 
administrator. 

subnet mask  A TCP/IP method of dividing a network into several smaller 
subnetworks. 

TCP/IP  Transmission Control Protocol/Internet Protocol, the de facto standard for 
Internet communications that is widely used on local area networks.

TCP Port  A method of accessing a TCP/IP service, where a device with a single IP 
address can have multiple TCP ports. 
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Telnet  A TCP/IP protocol that allows two devices to communicate over a LAN. 

trap  An unsolicited message sent by an SNMP agent to an SNMP management 
station. It notifies the management station of some unusual event. 

UNIX  A general-purpose computer operating system used on many different kinds of 
computers.

WCSO  Wireless Card Socket Option. Zebra’s wireless Ethernet option. 

Windows 95 and Windows 98  Microsoft’s PC operating systems that feature 
built-in peer-to-peer networking.  

Windows NT  Microsoft’s multitasking operating system that can be used either as a 
client or as a server. 

Windows 2000  Microsoft’s multitasking operating system that replaces Windows 
NT; can be used as either as a client or as a server. 

ZebraNet PrintServer II  An Ethernet connectivity solution. 

ZebraLink  Allows you to connect and control your bar code printers anywhere and 
anytime. 

ZPL II  Zebra Programming Language II is a powerful label-definition and printer-
control language.  
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