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At a high level, the process of making existing PDF files accessible consists of a few basic steps:

1. Take a moment to examine and evaluate the PDF document before you begin (See “Step 1: Exam-

ine the PDF File” on page 3).

2. Determine if the PDF file originated from a scan. If so, perform Optical Character Recognition 

(OCR) using the OCR Text Recognition command in Adobe Acrobat 9 (See “Step 2: Determine if 

the PDF is a Scanned Document” on page 3).

3. Add fillable form fields and buttons with short descriptions if the PDF file is intended to work as an 

interactive document. Set the tab order for the form field (See “Step 3: Add Interactive Features: 

Form Fields and Buttons” on page 6).

4. Add other accessibility features to the PDF such as bookmarks and security that does not interfere 

with assistive technology (See “Step 4: Add Other Accessibility Features” on page 14).

5. Add tags to the PDF if it has not been tagged (See “Step 5: Determine if the PDF File is a Tagged 

PDF File” on page 18).

6. Determine if the PDF file has been properly tagged (See “Step 6: Determine if the PDF File is 

Properly Tagged” on page 21).

7. Check your results with the Acrobat Accessibility Checke. Refer to the document. (See “Step 7: Use 

the Accessibility Checker to Evaluate the PDF File” on page 42).

Though these stages are presented in an order that suits most needs, you may perform tasks in these stages in 

a different order or iterate between some of the stages. In all cases, you should first examine the document, 

determine its intended purpose, and use that analysis to determine the workflow that you should apply.

Step 1: Examine the PDF File

When you open the PDF file, take a moment to analyze the document before you. Take a moment to note its 

characteristics. 

• Is it a short document with a small number of pages or a long document consisting of many pages? 

• Is the document mostly text or a mixture of text and graphics?

• Does the document appear to have form fields?

• Another item to note is the complexity of the document’s layout. In some instances, documents of 

shorter length may be more challenging from an accessibility perspective than longer docments 

because their layout and read order are more complex.  Is the layout simple, a single column with a 

limited number of graphics, or is it complex with multiple columns, mixed layouts, tables and many 

graphics?  Complex layouts are an indicator that you may be spending more time with the 

document doing more detailed accessibility enhancements with the Touch Up Read Order Tool.

Step 2: Determine if the PDF is a Scanned Document

A common method for making PDF documents is to place a paper copy of a document into a scanner and 

then opening the resulting electronic version using Adobe Acrobat to view the newly scanned document as a 

PDF file. Unfortunately, this process results in creating an image of text and not the actual text itself. This 

means the content is not accessible to users who rely on assistive technology to hear the contents of the page. 

Additional work must take place to make the document accesible.

Note: If you are certain that the PDF document is not a scanned document or it has previously 

undergone optical character recognition, you can skip this discussion and proceed to 
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“Step 3: Add Interactive Features: Form Fields and Buttons” on page 6.

How to Tell if a PDF File is a Scanned Document

There are a number of indications that a PDF file originated from a scanned page. Onscreen, the document 

appears to contain text, but the page is actually an image. Choose the method that suits you best for 

determining if the PDF is from a scan and is an “image only” PDF.

• Note if the page appears to be skewed.  Sometimes sheets are not properly fed into the 

scanner with the effect being the page appears to be crooked, or skewed on the screen . 

Lines of text will not be straight but will appear to slant up or down (See “Figure 1 Skewed 

Text Indicates a Scanned PDF” on page 4) 

Figure  1 Skewed Text Indicates a Scanned PDF

• Search for characters that appear on the page. Use the find command in Acrobat to 

search for text that appears on the page. Select Edit > Find (Ctrl + F on Windows or 

Option + F on Mac OS) and type a term that appears on the page in the search field.

If the document was scanned, Acrobat will not find the search but will display a message 

indicating “Acrobat has finished searching the document. No matches were found”.

• Zoom in and check for jagged edges on smooth characters. Scanned images are bitmaps 

(See “Figure 2 Bitmap text (top) and text that has undergone OCR (bottom)” on 

page 5)The edges of curves on bit maps will not appear to be smooth or rounded but will 

be jagged as shown in the top sample illustrating the word “Ozone” in Figure 2 on page 5  

Use the marquee zoom tool in Acrobat to define the area and magnify the edges of curved 

letters such as “c”, “s”, and “o”. Text that has undergone the OCR process using the 
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ClearScan option will display smoother edges as shown in the bottom illustration of the 

word “Ozone” in Figure 2 on page 5 

Figure  2 Bitmap text (top) and text that has undergone OCR (bottom)

• Use assistive technology or the Read Out Loud feature. Acrobat 9 Pro can detect the 

presence of assistive technology and if it encounters a scanned document will announce an 

audible empty page warning and display the Scanned Page Alert dialog (See “Figure 3 

Scanned Page Alert Dialog” on page 5)

Figure  3 Scanned Page Alert Dialog

What to Do if the PDF is a Scanned Document

Perform Optical Character Recognition (OCR) to convert the bitmap image of text to actual characters. In 

Acrobat 9 Pro. You can do this by selecting “OK” from the Scanned Page Alert dialog (See “Figure 3 

Scanned Page Alert Dialog” on page 5) You can also run the “Recognize Text Using OCR” command in 

Acrobat 9. 

• Document > OCR Text Recognition > Recognize Text Using OCR...

• or use the keyboard accelerator: ALT + D + C + R 

All three of these methods will result in the display of the Recognize Text dialog (See “Figure 4 Recognize 

Text Dialog and Recognize Text Settings” on page 6) Use the Edit button in the scanned page dialog to set 

the desired characteristics for the resulting file.

• Primary OCR Language (user should select the applicable document language)

• PDF Output Style should be ClearScan. ClearScan will allow the resulting PDF to “reflow”. The 

other two options, “Searchable Image” and “Searchable Image Exact” will work with assistive 

technology but will result in a PDF file that cannot be reflowed.

• Downsample should be set to the lowest downsampling which results in the highest resolution as 

measured in dots per inch (dpi). This should be 600 dpi.
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Figure  4 Recognize Text Dialog and Recognize Text Settings

For additional information on performing optical character recognition using Adobe Acrobat, refer to the 

Acrobat 9 Help.

What to Do if the PDF is Not a Scanned Document

Proceed to “Step 3: Add Interactive Features: Form Fields and Buttons” on page 6.

Step 3: Add Interactive Features: Form Fields and Buttons

Determining if a PDF file is meant to be an interactive form is a matter of visually examining the file and 

looking for the presence of form fields, or areas in the document where some kind of information is being 

asked for such as name, address, social security number. Boxes or fields drawn on the page are also typical 

indications that the document is meant to function as a form. If you want users to be able to complete the 

form online, rather than resort to printing a paper copy in order to complete the form, then the form is 

meant to be an interactive form. 

Note: If you are certain the PDF document is not intended to have fillable form fields or buttons, 

you can skip this discussion and proceed to “Step 4: Add Other Accessibility Features” on 

page 14.

You can make form fields accessible to vision impaired users and users with mobility challenges by adding 

fillable fields to the PDF and by properly structuring it. In addition, you can use the Tooltip field property to 

provide the user with information about the field or to provide instructions. For example, using the Tooltip 

property value, the screen reader user would hear “Check this box if you will be attending the luncheon.”  

Without the tool tip property, a screen reader simply provides the name of  the form field (Check Box 1), its 

type (Check Box), and its state (Unchecked). It would not be clear to someone listening to the form that they 

are indicating their desire to attend a luncheon.

You can have Acrobat Pro detect and create the form fields automatically or you can manually create the 

necessary fields using Acrobat Pro’s form tools.
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This discussion limits itself to the accessibility issues involved with PDF forms. For a more detailed 

discussion of forms, refer to the Adobe Acrobat 9 Online Help.

PDF Form Fields

A PDF form created with Acrobat can contain the following types of fields:

• Text field.  Lets the user type in text, such as name, address, or phone number. 

• Check box.  Presents yes-or-no choices for individual items. If the form contains multiple 

check boxes, the user can typically select as many or few of these as needed.

• Radio button. Presents a group of choices from which the user can select only one item. 

All radio buttons with the same name work together as a group.

• List box. Displays a list of options the user can select. You can set a form field property 

that enables the user to Shift-click or Control-click to select multiple items on the list.

• Combo box.  Lets the user either choose and item from a pop-up menu or type in a value.

• Button.  Initiates a change on the user’s computer, such as opening a file, playing a sound, 

or submitting data to a web server. These buttons can be customized with images, text, and 

visual changes triggered by mouse actions.  Action buttons have a different purpose than 

radio buttons, which represent data choices made by the user.

• Digital signature field.  Lets the user electronically sign a PDF document with a digital 

signature.

• Barcode.  Encodes the input form selected fields and diplays it as a visual pattern that can 

be interpreted by decoding software or hardware (available separately). 

Use Acrobat to Detect and Create Interactive Form Fields

You can convert an existing electronic document (for example a Word, Excel, or PDF document) or scan a 

paper document to a PDF form, and then add interactive form fields to the form. 

When you convert a document to an Acrobat form, Acrobat can detect the form fields in the document. In 

many instances, Acrobat will use the form field labels to name the field and provide a Tooltip. While the 

results are often acceptable, this is not a foolproof process. You will need to examine the document carefully 

to verify that Acrobat accurately detected the fields and labelled them appropriately.

Acrobat Form Wizard

You can use the Form Wizard in Adobe Acrobat 9 Pro or Adobe Acrobat 9 Pro Extended to create 

interactive forms from an existing electronic document (for example a Word, PDF, or Excel document) or 

scan a paper form into a PDF form. 

• Choose Forms > Start Form Wizard.  

This displays the Create or Edit Form Dialog. From the Create or Edit Form Dialog, do one of the following, 

and then follow the on-screen instructions. 

• To convert an existing electronic document (for example Word or PDF) to a PDF form, select An 

Existing Electronic Document. This places the document in Form Editing Mode.

• To scan a paper form and convert it to a PDF form, select A Paper Form. The form will be scanned 

and placed in Form Editing Mode.

• To use LiveCycle Designer to create a form from scratch or from one of the available templates, 

select No Existing Form.  

Note: Using the Adobe LiveCycle Designer, included in Adobe Acrobat Pro and Adobe Acrobat 

Pro Extended for Windows, to create accessible PDF forms is beyond the scope of this Best 
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Practices Guide.

The Form Wizard completes its analysis of the document, adds any form fields it may detect and places the 

PDF form in Forms Editing Mode where you can edit the automatically created fields or add additional form 

fields (See “Forms Editing Mode” on page 9).

During form field detection, Acrobat may have missed some fields or created unneeded fields. It may have 

also created fields of the wrong type. Please verify the fields and field names on your form. You can select 

Add New Field on the Forms Editing toolbar to add more fields or right click on the form to edit or delete 

fields.

Enter Forms Editing Mode Directly

If you don’t want to use the Form Wizard, you can open the file, and  place the document in Form Editing 

Mode directly.

• From the Acrobat Menu, select Forms > Add Or Edit Fields  (Keyboard shortcut is Shift + Ctrl 7).  

This displays the Add or Edit Form Fields dialog (See “Figure 5 Add or Edit Form Fields Dialog” on 

page 8)

Answering “Yes” to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect form fields 

for you?”  results in the automatic detection of form fields prior to placing the document in Form Editing 

Mode. This is the same as if you had proceeded using the Form Wizard on the current PDF.  

Acrobat completes its analysis of the document, adds any form fields it may detect and places the PDF form 

in Forms Editing Mode where you can edit the automatically created fields or add additional form fields (See 

“Forms Editing Mode” on page 9).

During form field detection, Acrobat may have missed some fields or created unneeded fields. It may have 

also created fields of the wrong type. Please verify the fields and field names on your form. You can select 

Add New Field on the Forms Editing toolbar to add more fields or right click on the form to edit or delete 

fields.

Answering “No” to the Add or Edit Form Fields dialog question “Do you want Acrobat to detect form fields 

for you?” also places the document in Form Editing mode, but does not create form fields automatically. You 

will have to add the form fields manually.  Proceed to the next section, “Create Form Fields Manually” on 

page 8 for futher information.

Create Form Fields Manually

To add form fields manually you first select Forms > Add or Edit Fields (Keyboard shortcut is Shift + Ctrl 7) 

and answer “No” to the question “Do you want Acrobat to detect the Form Fields for you?” in the resulting 

dialog (See “Figure 5 Add or Edit Form Fields Dialog” on page 8) This places the document in Forms 

Editing Mode without automatically creating any fields. You can now add new form fields to the PDF form. 

Proceed to the next section “Forms Editing Mode” on page 9 for further instruction.

Figure  5 Add or Edit Form Fields Dialog
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Forms Editing Mode

With the PDF form in Forms Editing Mode, you can add new fields and buttons to the form and edit or 

delete any existing field or button (See “Figure 6 Adobe Acrobat 9 Forms Editing Mode” on page 9) The 

Forms Editing Mode changes the Acrobat user interface slightly. 

• A Forms Editing Toolbar provides access to the Select Object tool, the Add New Field button,  and 

the Form Preview button.  You can configure the Add New Field button to display the Forms tools 

on the toolbar instead of the Add New Field button if you prefer.

• On the right hand side of the Forms Editing Toolbar, are the Distribute Form button and the Close 

Form editing button.

• A fields panel  appears on the left side of the document. 

• There is a forms menu bar which offers users choices that are mostly restricted to forms editing 

functions. 

Figure  6 Adobe Acrobat 9 Forms Editing Mode

Creating a New Form Field

In Acrobat, you create a form field by choosing one of the form tools. For each field type, you can set a 

variety of options through the form field Properties dialog box. 

You can access the forms tools one of three ways.

• You can select “Add New Field” on the Forms Editing Toolbar to add more fields

• From the Forms Editing menu you can select Forms > Form Tools (Keyboard accelerator ALT + R 

+ O). This will provide access to the Acrobat form tools.
PDF Accessible Repair with Adobe Acrobat 9 Pro
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• You can right click over the form to present options that allow you to add, edit, or delete fields.

The cursor becomes a cross hair.

• On the page, click where you want to add the field to create a field with the default size. To create a 

field using a custom size, drag a rectangle to define the size of the field. 

• In the Field Name box, type the name of the field and specify if you want the field to be a required 

field.  Acrobat provides a default name based upon the field type and the number of fields drawn on 

the page. You should choose a name that is relevant and descriptive to make organizing and 

collecting the data easier (See “Figure 7 Field Name Box” on page 10)

• To display the Properties dialog box and modify any other field properties, click Show All 

Properties (See “Figure 7 Field Name Box” on page 10)

Note: If you have selected the Keep Tool Selected option in the forms toolbar, the Field Name 

box doesn’t appear after adding a field. Each time you click the page, a new field is added 

to the form. To exit this mode, press the Esc key or click the Select Object Tool button. To 

modify the properties of the field, double-click the field. 

 

Figure  7 Field Name Box

To test your form, click the Preview button. Previewing a form allows you to view the form the same way the 

form recipients will and gives you a chance to verify the form. If you are previewing a form, you can click the 

Edit Layout button to go back to the Forms Editing mode.  

Form Field Properties

How a form field behaves is determined by settings in the Properties dialog box for that individual field. You 

can set properties that apply formatting, determine how the form field information relates to other form 

fields, impose limitations on what the user can enter in the form field, trigger custom scripts, and so forth.

You can set a variety of properties for an Acrobat form field, depending on the form field type. The 

properties for each type of form field are selected on a series of tabs. When you change a property, it is 

applied as soon as you select another property or press Enter.

All the form field types have a General tab, Appearance tab, and an Actions tab. Other tabs appear only in 

specific types of form fields. The Options tab appears for most form field types but the options available are 

unique to each type of form field.

If you are changing the properties of multiple fields, you can leave the Properties dialog box open. Click on 

each field to change its properties.

Tooltips for Form Fields

For accessibility, the Tooltip option on the General tab is important for entering text that will be announced 

by screen readers. 

You can make form fields accessible to people with disabilities by adding tags to the PDF and by properly 

structuring it. In addition, you can use the tool tip form field property to provide the user with information 
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about the field or to provide instructions. For example, using the tool tip property value, the screen reader 

could say “Your first name.” Without the tool tip property, a screen reader announces the type and name of 

the form field (See “Figure 8 Adding a Tooltip for Form Fields” on page 11)

• If necessary, choose Forms > Add or Edit Fields, and make sure that the Select Object tool is 

selected. 

• Double-click a selected form field to open the Properties window. 

• In the General tab, type a description into the tool tip box. 

The Tooltip also displays text that users may find helpful in filling in the form field. Tooltips appear when 

the pointer hovers briefly over the form field. 

Figure  8 Adding a Tooltip for Form Fields

Tooltips for Radio Buttons

To create a set of mutually exclusive Radio Buttons, where only one field can be selected at a time, give each 

field the same name but different Button values. The Button value is a field in the options tab of the Radio 

Button Properties dialog 

To make a radio button accessible, in addition to entering  unique text in the Button Value field for each 

choice, you would enter identical text in the Tooltip field of the General properties tab for each radio button 

in the group (See “Figure 9 Tooltips and Button Values for Radio Button Short Descriptions” on 

page 12)

For example, you may have a radio button group that asks the question, “Are You a Citizen?”. 

• You would create two radio buttons. For each button, you would enter the text “Are You a 

Citizen?” in the Tooltip field. 

• For one button you would enter “Yes” in the Button Value field under the options tab, for the other 

“No” should be entered in the Button Value field.
PDF Accessible Repair with Adobe Acrobat 9 Pro
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Figure  9 Tooltips and Button Values for Radio Button Short Descriptions

Editing or Modifying an Existing Form Field

You can access Acrobat form field properties only when you are in editing mode (by choosing Forms > Add 

Or Edit Fields). You can change the properties for multiple form fields at a time. 

Open the Properties dialog box using one of the following methods: 

• To edit a single form field, double-click it or right-click/Control-click it and choose Properties. 

• To edit multiple form fields, select the fields that you want to edit, right-click/Control-click one of 

the selected fields, and choose Properties. 

Change the properties on each of the available tabs, as needed. The property is changed as soon as you select 

another property or press Enter.

• Click Close to close the Properties dialog box. 

If you select form fields that have different property values, some options in the Properties dialog box are not 

available. Otherwise, changes to the available options are applied to all selected form fields. 

To avoid accidental changes to the form field, select Locked in the lower left corner of the Properties dialog 

box before you close it. To unlock, click the check box again.

Deleting a Form Field

With the document in Forms Editing mode, click on the field you would like to delete and do any of the 

following.

• Right mouse click and select delete

• Press the delete key.

• From the menu, select Edit > Delete (ALT + ED)
PDF Accessible Repair with Adobe Acrobat 9 Pro
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Note: You can select multiple fields by holding the Control key as you click on each one.

Buttons

Buttons are most commonly associated with forms, but you can add them to any document. Buttons can 

open a file, play a sound or movie clip, submit data to a web server, and much more. When deciding on how 

to initiate an action, remember that buttons offer the following capabilities that links and bookmarks do not:

• A button can activate a single action or a series of actions.

• A button can change appearance in response to mouse actions.

• A button can be easily copied across many pages.

• Mouse actions can activate different button actions. For example, Mouse Down (a click), Mouse Up 

(releasing after a click), Mouse Enter (moving the pointer over the button), and Mouse Exit 

(moving the pointer away from the button) can all start a different action for the same button.

Buttons are an easy, intuitive way to let users initiate an action in PDF documents. Buttons are added the 

same way as form fields while in Forms Editing mode. They also should be given a name and a Tooltip and 

their behavior is determined by the actions the user assigns the button on the actions tab of the Button 

Properties dialog. They also appear in the Tab order tree. See the Adobe Acrobat Help for a complete 

discussion of PDF fields and buttons.

Set the Tab Order

If a PDF document doesn’t have a specified tab order, the default tabbing order is based on the document 

structure unless the user has deselected the Tab Order option in the Accessibility preferences.

You can change the tabbing order after you create the fields. 

• If you are in Forms Editing mode, you can order the tabs by document structure (default), row, or 

column. 

• You can also choose the order manually by dragging and dropping fields in the Fields panel. 

• If you are not in Forms Editing mode, you can change the page properties to order the tabs by row 

or column. However, you can’t customize the tab order manually.

To change the tab order, first select “Order Tabs Manually” from the Tab Order button on the Fields panel. 

Then you can drag and drop fields where you want them within the Fields panel to modify the tab order (See 

“Figure 10 Rearranging Tab Order with the Fields Panel” on page 14)

To assist in determining tab order, you can select “Show Tab Numbers” from the Tab Order button of the 

Fields panel (See “Figure 10 Rearranging Tab Order with the Fields Panel” on page 14)

In the example shown in Figure 10 on page 14 , the check box labelled “operating system” is in the fifth 

position. Selecting the entry for operating system in the Forms panel highlights the corresponding field in 
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the document view. To move it to the second position, drag it up and drop it below the check box for “office 

suite”

Figure  10 Rearranging Tab Order with the Fields Panel

Step 4: Add Other Accessibility Features

This stage includes setting the document language, making sure that security settings do not interfere with 

screen readers, creating accessible links, and adding bookmarks.

Document Language

Setting the document language in a PDF enables some screen readers to switch to the appropriate language. 

You can set the document language for an entire document with Acrobat Pro, Acrobat Pro Extended, or 

Acrobat Standard. You can set the document language for specific portions of a multilanguage document 

with Acrobat Pro or Acrobat Pro Extended (See “Figure 11 Setting the document language” on page 15)

To set the language for an entire document:

• Choose File > Properties, (Cntrl + D for Windows, Cmnd + D Mac OS) and select a language from 

the Language menu in the Reading Options area of the Advanced tab. 

To set the language for an entire document to a language not in the Language menu: 

• choose File > Properties (Cntrl + D for Windows, Cmnd + D Mac OS), and enter the ISO 639 code 

for the language in the Language field in the Reading Options area of the Advanced tab. For more 

information, see the ISO Language Codes on http://www.loc.gov/standards. 

You can also set the language for individual sections or words: 

• Select the desired text element in the Tags tab and right click (See “ Tags Panel” on page 36)

• Choose Properties from the Options menu. In the TouchUp Properties dialog box, select the Tag 

tab. Select a language from the Language menu, and click Close. 

Note: The language that you specify for an element also applies to all elements nested under it 

in the logical structure tree.
PDF Accessible Repair with Adobe Acrobat 9 Pro
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Figure  11 Setting the document language

Set Security That Permits Accessibility

You should ensure the Acrobat 9 security settings permit access to the document by assistive technology. 

You can verify the Acrobat 9 or Adobe Reader 9 security settings do not prohibit access to assistive 

technology by checking the security preferences tab of the document properties dialog.

• Select File > Properties (Cntrl + D for Windows, Cmnd + D Mac OS)

• Select the Security Tab of the Document Properties dialog (See “Figure 12 Security Tab Location 

in Document Properties Dialog” on page 16)
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Figure  12 Security Tab Location in Document Properties Dialog

• Select “Password Security” as the security method from the drop-down list. In the Permissions 

section of the Password Security Settings dialog, verify the box labelled “Enable text access for 

screen reader devices for the visually impaired” is checked. This is the default setting for Adobe 

Acrobat 9 and Adobe Reader 9 (See “Figure 13 Password Security Settings” on page 16)

Figure  13 Password Security Settings

Certain applications allow you to set the security settings for PDF files you plan to generate from within the 

application (See “Creating Accessible PDF Files Using Authoring Applications” on page 53).
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Create Accessible Links

With thoughtfully provided links, users can quickly move from one part of a document to another, to related 

information in a different document, or to a website that is relevant to the content.

For URLs to be accessible to screen readers, you must convert them to active links and make sure that they 

are correctly tagged in the PDF. 

Note: If you tagged the Adobe PDF during conversion from an authoring application, the links 

and URLs in the document are probably already active and included in the tag tree so that 

they are accessible to screen readers. You probably don’t have to do this task unless you 

want to add more links. 

Acrobat provides several ways to create active links for text, objects, and URLs in a PDF. However, the 

methods differ in how they affect the tag tree. The best way to create accessible links is with the Create Link 

command.

Unlike the other methods for creating links in a tagged PDF (by using the Links tool or the Create From 

URLs In Document command), the Create Link command adds all three tags that screen readers require in 

order to recognize a link. The other methods create only one of the three tags, meaning that you must 

manually edit the tag tree to add the remaining two tags for each link and place these tags in the proper 

reading order in the tree. Although you must activate links one by one, using the Create Link command 

provides the fastest results and the least amount of follow-up work to make the links accessible to screen 

readers. All that is left to do is optional editing of the tag tree to add alternate text to the new links.

Note: Automatically detected URLs in PDF documents are not accessible. Avoid using the Create 

Links from URLs command (Advanced > Document Processing > Create Links from URLs... 

or ALT + A D C) . Also, ensure that the Basic Tools General Preference, “Create Links from 

URLs” is unchecked (Edit > Preferences > General). While these are a convenient way to 

detect text that is possibly a URL which allows users to click and go to the URL, the result is 

not an accessible link.  

Creating links with Acrobat Standard doesn’t generate any tags for the links. 

Do the following to make links active and add them to the tag tree:

• Select the text or object for which you want to create a link. 

• Right-click the selection, and choose Create Link from the context menu. 

• In the Create Link dialog box, select the appropriate options, and then follow the on-screen 

instructions to specify a URL, page view, or file as the link target. 

By default, the selected text for each link becomes the link text. After you add all the links, you can edit the 

tag tree to add alternate text to the links, further improving the accessibility of the PDF.

Add Bookmarks

A bookmark is a type of link with representative text in the Bookmarks panel in the navigation pane. Each 

bookmark goes to a different view or page in the document. Bookmarks are generated automatically during 

PDF creation from the table-of-contents entries of documents created by most desktop publishing 

programs. These bookmarks are often tagged and can be used to make edits in the PDF. 

Initially, a bookmark displays the page that was in view when the bookmark was created, which is the 

bookmark’s destination. In Acrobat, you can set bookmark destinations as you create each bookmark. 

However, it is sometimes easier to create a group of bookmarks, and then set the destinations later. 
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In Acrobat, you can use bookmarks to mark a place in the PDF to which you want to return, or to jump to a 

destination in the PDF, another document, or a web page. Bookmarks can also perform actions, such as 

executing a menu item or submitting a form. 

Note: An Acrobat user can add bookmarks to a document only if the security settings allow it.

Step 5: Determine if the PDF File is a Tagged PDF File

Tagging is essential for PDF accessibility, it is used to establish logical read order and to provide hooks for 

adding alternative text descriptions to non-text elements that are in the PDF document. 

If you have been following the workflow up to this point,  you will have a PDF file that is searchable because 

you performed optical character recognition on a scanned document, or it was searchable to begin with. You 

have also added any desired interactivity in the form of navigational controls or interactive form fields. At 

this point it may or may not be a tagged PDF file.

Note: If you are certain the PDF document has been tagged, you can skip this discussion and 

proceed to “Step 6: Determine if the PDF File is Properly Tagged” on page 21.

How to Tell if a PDF File is Tagged

There are several ways to determine if a PDF file has been tagged. 

• View Document Properties. File > Document Properties (Ctrl +D) - In the lower left 

hand corner of the Description tab, is an indication as to whether or not the document is 

tagged (See “Figure 14 Tagged PDF File Property” on page 19)
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Figure  14 Tagged PDF File Property

• Reveal the Tags Panel. View > Navigation Panels > Tags. An untagged document will 

display the words "No Tags Available" as its root. A tagged document will show structure.  

To expand the entire tree fully, Cntrl + click on the root node labelled “Tags”.

Note: In certain instances, a document may not be considered tagged by Acrobat even though a 

structure is visible in the Tags panel.  Select the tags options icon and ensure a check mark 

appears before the entry “Document is Tagged PDF.” If it does not, simply select this entry 

to add the missing check mark (See “Figure 15 Document is Tagged PDF Indicator in a 

Structured Document” on page 20)
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Figure  15 Document is Tagged PDF Indicator in a Structured Document

• Run the Accessibility Quick Check . Advanced > Accessibility > Quick Check (Shift + 

Ctrl + 6). If the document is not tagged, the Accessibility Quick Check will indicate the 

document is not structured.

• Run the Accessibility Full Check. Advanced > Accessibility > Full Check. If the 

document is not tagged, the Accessibility Full Check will indicate the document is not 

tagged.

• Use the Touch Up Read Order Tool. Advanced > Accessibility > TouchUp Reading 

Order - An untagged document will not appear to have undergone a change. A tagged 

document will display shaded areas on the page that are numbered. An untagged 

document will not display these numbered rectangles (See “ TouchUp Reading Order 

Tool (TURO)” on page 21)

What to do if the PDF File is Not Tagged

Add tags to the document using Adobe Acrobat 9 Pro. 

• From the menu, select Advanced > Accessibility > Add Tags to Document (Keyboard Accelerator is 

ALT + AAA)

About the Add Tags Report

If Acrobat encounters potential problems while running the Add Tags To Document command, the Add 

Tags Report opens in the navigation pane. The report lists potential problems by page, provides a 

navigational link to each problem, and offers suggestions for fixing them. 
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You could choose to repair the problems at this time by following the suggestions in the Add Tags report or 

now that the file is tagged proceed to the next step “Step 6: Determine if the PDF File is Properly Tagged” 

on page 21. 

If you choose to repair the document at this stage, remember to assess the context of any error before 

following a particular suggestion for fixing it. For example, the report might state that an element that has 

been tagged as a figure and requires alternate text to make it accessible. When you examine the figure in its 

context on the page, you may decide that the figure is a background design element, not an illustration that 

conveys valuable meaning to the user. In the case of a nonessential image, and you would change the Figure 

tag to a Background tag; in the case of an image intended to convey meaning to the reader, you would add 

the missing alternate text (See “ Step 6: Determine if the PDF File is Properly Tagged” on page 21) 

Note: The Add Tags Report highlights tagging-related problems only, and it is a temporary file 

that you cannot save. You can assess other tagging, reading order, and accessibility 

problems by using Full Check.

If adding tags to a PDF in Adobe Acrobat results in a tagging structure that is overly complicated or too 

problematic to fix, you can use the TouchUp Reading Order tool to remove or replace the current structure. 

If the document contains mostly text, you can select a page and then remove headings, tables, and other 

elements to create a cleaner, simpler tagging structure (See “TouchUp Reading Order Tool (TURO)” on 

page 21).

What to do if the PDF File is Tagged

Proceed to the next step, “Step 6: Determine if the PDF File is Properly Tagged” on page 21.

Step 6: Determine if the PDF File is Properly Tagged

The easiest way to determine if the PDF file has been properly tagged is to use the TouchUp Reading Order 

Tool (See “ TouchUp Reading Order Tool (TURO)” on page 21)

• From the menu, select Advanced > Accessibility > Touchup Reading Order.... (Keyboard 

Accelerator is ALT + AAT)

The Touch Up Reading Order Tool divides a tagged page into shaded segments. Each segment is numbered 

indicating the read order of the item on the page. You can also verify the read order of items on the page by 

displaying the order panel from the Touch Up Read Order Tool.

Note: If you are certain the PDF document is properly tagged, you can skip this discussion and 

proceed to “Step 7: Use the Accessibility Checker to Evaluate the PDF File” on page 42.

TouchUp Reading Order Tool (TURO)

The TouchUp Reading Order tool provides the easiest and quickest way to fix reading order and basic 

tagging problems. When you select the TouchUp Reading Order tool, a dialog box opens that lets you see 

overlay highlights that show the order of page content. Each highlighted region is numbered and highlighted 

with gray or colored blocks; the number indicates the region’s placement in the page’s reading order. After 

you check the reading order of the page, you can correct other, more subtle tagging issues as needed.

The TouchUp Reading Order tool is intended for repairing PDFs that were tagged using Acrobat, not for 

repairing PDFs that were tagged during conversion from an authoring application. Whenever possible, you 

should return to the source file and add accessibility features in the authoring application. Repairing the 

original file ensures that you don’t have to repeatedly touch up future iterations of the PDF in Acrobat.

You use the TouchUp Reading Order tool to perform the following accessibility tasks:

• Visually check, and then repair, the reading order of page content
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• Tag fillable form fields and their labels

• Add alternative text to figures and descriptions to form fields

• Fix the tagging of simple tables, and prepare complex tables for more advanced manipulation in the 

logical structure tree

• Remove nonessential content, such as ornamental page borders, from the logical structure tree

Figure  16 TouchUp Reading Order Dialog

Selecting the TouchUp Reading Order Tool

To select the TouchUp Reading Order Tool, do one of the following: 

• Choose Advanced > Accessibility > TouchUp Reading Order (ALT + AAT)

• Choose Tools > Advanced Editing > TouchUp Reading Order Tool (ALT + TAG).

• Click the TouchUp Reading Order tool button in the Advanced Editing toolbar.

When you select TouchUp Reading Order, a dialog box opens that lets you see overlay highlights that show 

the order of page content (See “Figure 17 Result of Selecting the TouchUp Reading Order Tool” on 

page 23)
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Each highlighted region is numbered and highlighted with gray or colored blocks; the number indicates the 

region’s placement in the page’s reading order.l

Figure  17 Result of Selecting the TouchUp Reading Order Tool

TouchUp Reading Order Tool Options

You can select TouchUp Reading Order options from the dialog box, from the pop-up menu that appears 

when you right-click a highlighted region, or from the Options menu in the Order tab. The TouchUp 

Reading Order tool includes the following options:

• Text . Tags the selection as text. 

• Figure . Tags the selection as a figure. Text contained within a figure tag is defined as part 

of the image and is not read by screen readers. 

• Form Field . Tags the selection as a form field. 

• Figure/Caption . Tags a selected figure and caption as a single tag. Any text contained in 

the tag is defined as a caption. Useful for tagging photos and captions and preventing 

caption text from being incorrectly added to adjacent text blocks. Figures may require 

alternate text. 

• Heading 1, Heading 2, Heading 3 . Tags the selection as a first, second, or third level 

heading tag. You can convert heading tags to bookmarks to help users navigate the 

document. 

• Table . Tags the selection as a table after the selection is analyzed to determine the location 

of headings, columns, and rows. 

• Cell . Tags the selection as a table or header cell. Use this option to merge cells that are 

incorrectly split. 
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• Formula . Tags the selection as a formula. Because speech software may handle formula 

tags differently from normal text, you may want to add a description using alternate text. 

• Background . Tags the selection as a background element, or artifact, removing the item 

from the tag tree so that it doesn’t appear in the reflowed document and isn’t read by 

screen readers. 

• Table Editor . Automatically analyzes the selected table into cells and applies the 

appropriate tags. The table must be tagged as a table before you can use the Table Editor 

command on it. 

• Show Page Content Order . Shows content elements as highlighted areas that contain 

numbers to indicate the reading order. The rectangle next to this entry is a color swatch. 

Specify the desired highlight color for page content order by clicking the color swatch. 

• Show Table Cells . Highlights the content of individual table cells. The rectangle next to 

this entry is a color swatch. Specify the highlight color for Table Cells by clicking the color 

swatch. 

• Show Tables And Figures . Outlines each table and figure with a crossed-out box. The 

box also indicates whether the element includes alternate text. The rectangle next to this 

entry is a color swatch. Specify the highlight color for Tables and Figures by clicking the 

color swatch. 

• Clear Page Structure . Removes the tagging structure from the page. Use this option to 

start over and create a new structure if the existing structure contains too many problems. 

• Show Order Panel . Opens the Order tab to allow you to reorder highlighted content. 

• Edit Alternate Text . Available in the menu that appears when you right-click a 

highlighted figure. Allows the user to add or edit a text description about the figure 

properties that is read by a screen reader or other assistive technology. 

• Edit Form Field Text . Available in the menu that appears when you right-click a form 

field. Allows the user to add or edit a form field text description that is read by a screen 

reader or other assistive technology. 

• Edit Table Summary . Available in the menu that appears when you right-click a 

highlighted table. Allows the user to add or edit a text description about the table 

properties that is read by a screen reader or other assistive technology.

Tips for using the TouchUp Reading Order tool

When using the TouchUp Reading Order tool, you should be mindful of the following tips for use:

• Save the document (or a copy of it) before you use the TouchUp Reading Order tool. You can’t use 

Undo to reverse changes made with this tool, so reverting to a saved document is the only way to 

undo such a change. 

• Choose View > Page Display > Single Page, when using the TouchUp Reading Order tool. When 

you click the Clear Structure button, Acrobat clears tags from all visible pages—even pages that are 

only partially visible. 

Checking Read Order with the Touch Up Read Order Tool

You can quickly check the reading order of tagged PDFs by using the TouchUp Reading Order tool. You can 

also use this tool to add alternate text to images and correct many types of tagging problems that are outlined 

in the report that Acrobat generates when you add tags to a PDF. 

Reading-order problems are readily apparent when you use the TouchUp Reading Order tool. Each section 

of contiguous page content appears as a separate highlighted region and is numbered according to its 

placement in the reading order. 
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Within each region, text is ordered left to right and top to bottom. (You can change this order in the 

TouchUp preferences.) If a single highlighted region contains two columns of text or text that won’t flow 

normally, divide the region into parts that can be reordered. Because highlighted regions are rectangular, 

they may overlap somewhat, especially if their page content is irregularly shaped. Unless page content 

overlaps or is contained within two highlighted regions, no reading order problem is indicated. Page content 

should belong to no more than one highlighted region. 

You can change the reading order of the highlighted regions by moving an item in the Order Panel or by 

dragging it on the page in the document pane. By reordering highlighted regions on the page, you can make 

a figure and caption read at the specific point that they are referenced in the text. By changing the order of a 

highlighted region, you effectively change the reading order of that item without changing the actual 

appearance of the PDF.

Check reading order with the TouchUp Reading Order tool

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, select Show Page Content Order. 

Note: If highlighted regions don’t appear in the document pane, the document doesn’t contain 

tags.  You will need to tag the document (See “ What to do if the PDF File is Not Tagged” 

on page 20)

Optionally, do any of the following: 

• To specify a highlight color, click the color swatch, and then click the color you want.

• To highlight tables and figures, and to view alternate text for figures, select Show Tables And 

Figures.

• Check the reading order of text within each highlighted region. Zooming in can make this step 

easier. 

• Check the numbered order of all highlighted regions. If consecutive, numbered regions don’t 

follow one another, reorder them in the Order tab. 

• Click Show Order Panel, and then select each content entry (in square brackets [ ]) in the Order tab 

to highlight that content region in the document pane. Use this method to find numbered regions 

that you can’t see or locate on the page.

Change the reading order by dragging on the page

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, select Show Page Content Order. 

• In the document pane, place the pointer over the number for the highlighted region you want to 

move, and drag it to where you want it to be read. The text-insertion pointer shows target locations 

within the text. 

When you release the highlighted region, the location of the text-insertion pointer becomes the 

dividing line as the underlying highlighted region is split into two new highlighted regions. All 

highlighted regions are renumbered to show the new reading order. 

Change the reading order using the Order panel

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, click Show Order Panel. 

• In the Order tab, navigate to view a list of highlighted regions that appear in the document pane. 

In the Order tab, drag the tag for a highlighted region to the location you want. As you drag, a line 

appears to show potential locations. After you drag an item to a new location, the highlighted 
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regions are renumbered to show the new reading order. You can select and move multiple, adjacent 

regions (See “Figure 25 Acrobat 9 Pro Order Panel” on page 36).

Editing Tags with the TouchUp Reading Order Tool

You can use the TouchUp Reading Order tool to create tags in untagged PDFs or to add new tags to an 

existing structure. However, this manual tagging doesn’t provide the same level of detail to the tagging 

structure as the Add Tags To Document command, such as paragraphs, bulleted and numbered lists, line 

breaks, and hyphens. Before you clear the existing structure, make sure that manual tagging is your only 

recourse.

Tag a region

• Using the TouchUp Reading Order tool, drag within the document pane to select a region of the 

page that contains one type of content (for example, a text block). 

Do one of the following: 

• To add more page content to the current selection, Shift-drag.

• To remove page content from the current selection, Ctrl-drag/Command-drag.

Click the appropriate button in the TouchUp Reading Order dialog box to specify the tag type.

Change the tag for a region

If Acrobat tags a page element incorrectly, you can change the tag type for the highlighted region. 

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, select Show Page Content Order. 

To select a highlighted region, do one of the following: 

• Drag to select it.

• Click the number of a highlighted region.

• Click the button for the tag type that you want for the highlighted region. 

Add or remove content from a tagged region

The TouchUp Reading Order tool always displays as few highlighted regions as possible. If content within a 

highlighted region doesn’t flow properly, you may need to split a region to reorder it. Highlighted regions 

may also contain adjacent page content that is unrelated or that requires a different tag type. Page content 

may become orphaned from related elements, particularly if the content doesn’t fit within a rectangular 

shape. Use the TouchUp Reading Order tool to add or remove content from a region, or to split a region to 

reorder the content.

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, select Show Page Content Order. 

• In the document pane, select a highlighted region. 

Do one of the following: 

• To add content to the current selection, Shift-click the content you want to add. The pointer 

changes to include a plus sign (+).

• To remove content from the current selection, Ctrl-click/Command-click the content you want to 

remove. The pointer changes to include a minus sign (-).

Click the button for the tag type that you want for the highlighted region. 

Split a region into two regions

• Select the TouchUp Reading Order tool. 
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• In the TouchUp Reading Order dialog box, select Show Page Content Order. 

• In the document pane, drag to select a small portion of content near the boundary of the first region 

that you want to create. 

• Click the Background button in the dialog box. The highlighted region splits into two regions, 

numbered from right to left. 

• If you need to correct the reading order, click Show Order Panel, and drag the new highlighted 

region to the correct location in the Order tab. 

Drag to select the first content region you created, including the region you defined as Background, and then 

set the tag by clicking a button in the TouchUp Reading Order dialog box.

Apply a heading tag

To help readers navigate a document and find the information they need, make sure that headings are tagged 

with the appropriate level to indicate their hierarchy in the content. 

• Select the TouchUp Reading Order tool, and then select the heading text in the PDF. 

• In the TouchUp Reading Order dialog box, click the button corresponding to the appropriate 

heading tag (for example, Heading 1, Heading 2). 

Remove page elements from the tag structure

When tagging a PDF, Acrobat can’t always distinguish between instructive figures and decorative page 

elements. Items that visually enhance page layout, such as decorative borders, lines, or background elements, 

can add clutter to the structure layout and should be removed. Therefore, Acrobat may incorrectly tag 

artifacts or page elements as figure tags. You can remove artifacts and irrelevant page elements from the tag 

structure by redefining them with the Background tag or by deleting their tags. If a tagged image in the 

document doesn’t contain useful or illustrative information for the user, you can remove the element from 

the tagging structure so that it isn’t read out loud or reflowed.

• Select the TouchUp Reading Order tool. 

• In the TouchUp Reading Order dialog box, select Show Page Content Order and Show Tables And 

Figures. 

• Remove the page element by doing one of the following: 

• In the document pane, select the page element, and then click Background in the dialog box.

In the Order tab, select the page element, and then press Delete.

Apply a figure tag

You can select an element and define it as a figure by using the TouchUp Reading Order tool. Once you 

define it as a figure, you can add alternate text to describe the figure.

• Using the TouchUp Reading Order tool, select the figure. 

• In the TouchUp Reading Order dialog box, click Figure. 

• In the document pane, right-click the region and choose Edit Alternate Text. 

Enter alternate text, and click OK. 

Using TouchUp Reading Order to Check and Correct Figure Tags

You can use the TouchUp Reading Order tool to identify and correct tagging results for figures. Determine 

whether figures include or require alternate text in order to be read correctly with assistive technologies. 

Ideally, figure tags should identify image content that is meaningful to the document as a whole, such as 

graphs or illustrative photographs. If background elements that shouldn’t be read are tagged as figures, 

redefine them as background.

• Select the TouchUp Reading Order tool, and then click Show Tables And Figures in the dialog box. 
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Do any of the following: 

• If a figure isn’t tagged as a figure, select the content region you want, and then click Figure or 

Figure/Caption in the dialog box.

• To remove text that was incorrectly combined with a figure, drag to select the text, and click the 

Text button in the dialog box.

To include a caption that is grouped with the figure, select the figure and caption, and click the Figure/

Caption button in the dialog box.

Adding Alternate Text with the TouchUp Reading Order Tool

If you want screen readers to describe graphical elements that illustrate important concepts in a document, 

you must provide the description using alternate text. Figures aren’t recognized or read by a screen reader 

unless you add alternate text to the tag properties. If you apply alternate text to text elements, only the 

description, not the actual text, is read. 

• Select the TouchUp Reading Order tool. 

• Select Show Tables And Figures in the dialog box. Figures that are missing Alternate Text will have 

a flag indicating “Figure - No alternate text exists” (See “Figure 18 Add / Edit Alternate Text with 

TouchUp Reading Order” on page 28).

• Right-click the figure, and choose Edit Alternate Text from the pop-up menu. (See “Figure 18 Add 

/ Edit Alternate Text with TouchUp Reading Order” on page 28)

In the Edit Alternate Text dialog box, type a new (or edit an existing) description for the figure, and then 

click OK (See “Figure 19 TouchUp Reading Order Alternate Text Dialog” on page 29) 

Figure  18 Add / Edit Alternate Text with TouchUp Reading Order
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Figure  19 TouchUp Reading Order Alternate Text Dialog

Using the TouchUp Reading Order Tool Table Editor

Tables pose a special challenge for screen readers because they present textual or numerical data to be easily 

referenced visually. Content within table cells can be complex and might contain lists, paragraphs, form 

fields, or another table.

The TouchUp Reading Order Table Editor automatically analyzes the selected table into cells and applies the 

appropriate tags. The table must be tagged as a table before you can use the Table Editor command on it. 

For best results when tagging tables, use the application that you created the document with to add tags 

when you create the PDF. If a PDF isn’t tagged, you can add tags by using the Add Tags To Document 

command. Most tables are properly recognized using this command; however, the command may not 

recognize a table that lacks clear borders, headings, columns, and rows. Use the TouchUp Reading Order 

tool to determine if the table has been properly recognized and to correct recognition problems. To add 

specialized formatting to tables and table cells, use the Tags tab.

You can use the Table Editor to automatically analyze a table into its components and apply the appropriate 

tags, but you may still need to check and correct some of these tags manually. By viewing table tags, you can 

determine whether columns, rows, and cells have been correctly identified. Tables that lack well-defined 

borders and rules are often tagged incorrectly or contain adjacent page elements. You can correct poorly 

tagged tables by selecting and redefining them; you can split combined cells by creating a tag for each cell. 

• Select the TouchUp Reading Order tool, and then click Show Tables And Figures. 

• If the table isn’t clearly labeled in the document pane, drag to select the entire table, and then click 

Table in the dialog box. 

• Click Show Table Cells to make sure that all cells in the table are defined as individual elements.

If cells don’t appear as separate elements, do one of the following: 

• If one or more cells are merged, use the TouchUp Reading Order tool to select the area within a 

single cell, and then click Cell in the dialog box. Repeat for each merged cell.

• If cells aren’t highlighted, the table might not use standard table formatting. Re-create the table in 

the authoring application.

Add a Table Summary

• With the cursor over the table, right click to add a Table Summary. The Edit Table Summary option 

is available in the menu that appears when you right-click a highlighted table. This allows the user 

to add or edit a text description about the table properties that is read by a screen reader or other 

assistive technology.

Place the Table in Editing Mode

There are two ways to place Tables in Table Editing Mode with the TouchUp Reading Order Tool:
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• With the cursor over the table, right click to select Table Editor from the drop down list to place the 

table in Table Editing mode.

• You can also click the Show Order Panel in the TouchUp Reading Order dialog and select the table 

from the Order Panel. One technique is to highlight the snippets of text in the Order Panel that 

match the headings of  the first row in the table. This often activates the Table Editor when it cannot 

otherwise be activated. You then select the Table Editor button on the TouchUp Reading Order 

dialog  to place the table in Table Editing Mode (See “Figure 20 Using the Order Panel to Activate 

the Table Editor” on page 30)

Figure  20 Using the Order Panel to Activate the Table Editor

Once in Table Editing Mode, the borders of the table cells are highlighted. You can change the color of the 

border to suit your needs (See “Figure 21 Table Editing Mode” on page 31). You can select individual cells 

by clicking within the borders with the mouse. You can select multiple table cells by holding down Shift and 

clicking. This is an effecient method for selecting the first row of data cells in a table which need to be 

changed to header cells.
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Figure  21 Table Editing Mode

Once in Table Editing Mode, you can right click to display the Table Cell Properties dialog or the Table 

Editor Options dialog. 

The Table Cell Properties dialog (See “Figure 22 Table Cell Properties” on page 32) allows you to: 

• Specify the type of cell the selected cell should be, whether a Header cell or Data cell

• Set the cells attibutes for row span and column span. Assign a unique header ID for Table Headers 

or associate Data cells with Header IDs that have been created for the table
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Figure  22 Table Cell Properties

The Table Editor Options dialog allows users to control how table cells and table headers are displayed by 

Acrobat when using the TouchUp Reading Order Table Editor (See “Figure 23 Table Editor Options” on 

page 32).

Figure  23 Table Editor Options

Note: To correct complex tagging problems for tables, you often must use the Tags Panel. 
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Remove or Replace Document Structure Tags

If the tags in a PDF file in Acrobat appear to be overly complicated you can try retagging an already tagged 

document.  To do this,  you must first remove all existing tags from the tree. 

If adding tags to a PDF in Adobe Acrobat results in a tagging structure that is overly complicated or too 

problematic to fix, you can use the TouchUp Reading Order tool to remove or replace the current structure. 

If the document contains mostly text, you can select a page and then remove headings, tables, and other 

elements to create a cleaner, simpler tagging structure. 

Acrobat can retag an already tagged document after you first remove all existing tags from the tree. 

Replace the Existing Tag Structure

This procedure works best in pages that contain a single column of text. If the page contains multiple 

columns, each column must be selected and tagged individually.

• Select the TouchUp Reading Order tool. 

• In the document pane, drag to select the entire page. The selection includes both text and nontext 

elements. 

• Ctrl-drag/Command-drag around nontext page elements—such as figures and captions—to 

deselect them, until only text is selected on the page. Click Text in the TouchUp Reading Order 

dialog box. 

In the document pane, select a nontext page element, such as a figure and caption, and click the appropriate 

button in the dialog box to tag it. Repeat until all page content is tagged. 

Remove All Tags from a PDF

• Open the Tags tab (View > Navigation Panels > Tags) and select the root (topmost) tag, Tags. 

• In the Tags tab, choose Options > Delete tag. 

Note: The Clear Page Structure command in the TouchUp Reading Order dialog box removes all 
tags from the currently visible pages.

Complex Structures

While you can use the TouchUp Reading Order tool to create tags in untagged PDFs or to add new tags to an 

existing structure, this manual tagging doesn’t provide the same level of detail to the tagging structure as the 

Add Tags To Document command, such as paragraphs, bulleted and numbered lists, line breaks, and 

hyphens. Before you clear the existing structure, make sure that manual tagging is your only recourse.

To perform more advanced reading order and tagging tasks—such as fixing complex tables, removing 

obsolete tags after you delete pages, and adding alternative text to links—you may need to use the Content 

Panel and the Tags panel, which provide an alternate set of tools and features for manipulating PDF tags. 

Content Panel

Use the Content Panel to correct reflow problems in a PDF that can’t be corrected by using the TouchUp 

Reading Order tool. Because you can damage a PDF by editing content objects, make sure that you’re 

familiar with PDF structure before you change anything. For comprehensive information about PDF 

structure, see the PDF Reference Sixth Edition: Adobe Portable Document Format Version 1.7, on the PDF 

reference page (English only) of the Adobe website.

The Content Panel provides a hierarchical view of the objects that make up a PDF, including the PDF object 

itself. Each document includes one or more pages, a set of annotations (such as comments and links), and 

the content objects for the page, consisting of containers, text, paths, and images. Objects are listed in the 
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order in which they appear on the page, similar to tags in the logical structure tree. However, PDFs don’t 

require tags for you to view or change the object structure. 

• Choose View > Navigation Panels > Content.

The Content Panel may open in the document viewing area. It may be part of a panel group that also 

includes the Order Panel and the Tags Panel. You can drag the individual panel and dock it in the 

Navigation pane. You can also a the menu command to dock all panels in the Navigation Pane:

•  View > Navigation Panels > Dock All Panels (ALT + VNK) 

Click the plus sign (+) (Windows) or the triangle (Mac OS) next to the document name to view pages and 

objects.

Note: You may find it helpful to have Acrobat highlight items in the document view when the 

associated item in the Content Panel is selected. From the Content Panel Options Menu, 

select “Highlight Content” (See “Figure 24 Set Highlighting On for the Content Panel” on 

page 34). 

Move a container or object by selecting it and doing one of the following: 

• Drag it to the location you want. 

• Choose Cut from the Options menu, select the tag above the location you want to paste the cut tag, 

and choose Paste from the Options menu

.

Figure  24 Set Highlighting On for the Content Panel

Note: Container elements can’t be pasted directly to page elements. To move a container to 

another page, cut the container you want to move, select a container on the page you 

want to move the container to, and choose Paste from the Options menu. Then, drag the 

container out one level to the location that you want. 
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Content Tab Options

In the Content tab, use the Options menu or right-click an object to choose from the following options:

• New Container . Adds a new container object at the end of the selected page or container. 

• Edit Container Dictionary . Specifies the dictionary for the container. Errors in this 

dialog box may damage the PDF. Available only for containers that include dictionaries. 

• Cut . Cuts and copies the selected object (not the related page content). 

• Paste . Pastes content directly below the selected object at the same hierarchical level. 

• Paste Child . Pastes content into the selected object as a child content item. 

• Delete . Removes the object (not the related page content) from the document. 

• Find Content From Selection . Searches for the object in the Content tab that contains 

the object selected in the document pane. 

• Find . Searches for unmarked (untagged) artifacts, content, comments, and links. Options 

allow you to search the page or document, and to add tags to found items. 

• Create Artifact . Defines selected objects as artifacts. Artifacts are not read by a screen 

reader or by the Read Out Loud feature. Page numbers, headers, and footers are often best 

tagged as artifacts. 

• Remove Artifact . Removes the artifact definition from the selected object. 

• Highlight Content . When selected, highlights appear in the document pane around 

content that relates to a selected object in the Content tab. 

• Show Metadata . Allows viewing and editing of image or object metadata. 

• Properties . Opens the TouchUp Properties dialog box. 

Order Panel

You can change the reading order of the highlighted regions by moving an item in the Order tab or by 

dragging it on the page in the document pane. By reordering highlighted regions on the page, you can make 

a figure and caption read at the specific point that they are referenced in the text. By changing the order of a 

highlighted region, you effectively change the reading order of that item without changing the actual 

appearance of the PDF.

To select the Order Panel, do one of the following:

• Select the TouchUp Reading Order tool. In the TouchUp Reading Order dialog box, click Show 

Order Panel. 

• From the Acrobat menu select View > Navigation Panels > Order (ALT + VNO)

The Order Panel may open in the document viewing area. It may be part of a panel group that also includes 

the Content Panel and the Tags Panel. You can drag the individual panel and dock it in the Navigation pane. 

You can also use a menu command to dock all panels in the Navigation Pane:

•  View > Navigation Panels > Dock All Panels (ALT + VNK) 

To change the order of content using the Order Panel:

• In the Order panel, navigate to view a list of highlighted regions that appear in the document pane. 

In the Order tab, drag the tag for a highlighted region to the location you want. As you drag, a line 

appears to show potential locations. After you drag an item to a new location, the highlighted 

regions are renumbered to show the new reading order. You can select and move multiple, adjacent 

regions. 
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Figure  25 Acrobat 9 Pro Order Panel

Tags Panel

The Tags Panel allows you to view and edit tags in the logical structure tree, or tags tree, of a PDF. In the 

Tags Panel, tags appear in a hierarchical order that indicates the reading sequence of the document. The first 

item in this structure is the Tags root. All other items are tags and are children of the Tags root. Tags use 

coded element types that appear in angle brackets (< >). Each element, including structural elements such as 

sections and articles, appears in the logical structure order by type, followed by a title and the element’s 

content or a description of the content. Structural elements are typically listed as container—or parent—tags 

and include several smaller elements—or child tags—within them.

Though you can correct most tagging issues by using the TouchUp Reading Order tool, you must use the 

Tags Panel to address detailed tagging of tables and substructure items—such as paragraphs, lists, and 

sections that require multiple languages. Add tags manually to a document using the Tags tab only as a last 

resort. First consider using the Add Tags To Document feature.

Note: Important: Operations performed in the Tags tab cannot be undone with the Undo 

command.  Save a backup copy of a document before you begin work on it in the Tags tab.

To select the Tags Panel:

• Choose View > Navigation Panels > Tags. 

Then do one of the following: 

• Expand the tag for the section you want.

• Ctrl-click the plus sign (Windows) or Option-click the triangle (Mac OS) next to the Tags root to 

show all tags in the logical structure tree.

Note: You may find it helpful to have Acrobat highlight items in the document view when the 

associated item in the Tags Panel is selected. From the Content Panel Options menu, 

select “Highlight Content” (See “Figure 26 Set Content Highlighting On for the Tags 

Panel” on page 37). 
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Figure  26 Set Content Highlighting On for the Tags Panel

Edit tags with the Tags Panel

You can edit a tag title, change a tag location, or change the tag type for an element. All page content must be 

tagged, marked as an artifact, or removed from the logical structure tree.

To reveal the TouchUp Properties for any tag select the desired tag in the Tags panel and do one of the 

following:

• Right click and select Properties from the context menu

• Select Properties from the Tags Panel Option Menu
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Figure  27 Revealing TouchUp Properties for Tags 

Edit a tag title

• In the Tags tab, expand the section of the logical structure that you want to edit. 

• To edit the title, Select the tag, choose Properties from the Options menu, enter text in the Title box, 

and click Close. 

Move a tag

• In the Tags tab, expand the Tags root to view all tags. 

• Select the Tag icon of the element that you want to move. 

Do one of the following: 

• Drag the tag to the location you want. As you drag, a line appears at viable locations. 

• Choose Cut from the Options menu, and select the tag that appears above the location you want to 

paste the cut tag. From the Options menu, choose Paste to move the tag to the same level as the 

selected tag, or choose Paste Child to move the tag within the selected tag.

Change the element type

• In the Tags tab, expand the section of the logical structure that you want to change. 

• Select an element and choose Properties from the Options menu. 

• Choose a new element type from the Type menu, and then click Close. 

Tags tab options

In the Tags tab, use the Options menu or right-click a tag in the logical structure tree to choose from the 

following options:
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• New Tag . Creates a new tag in the logical structure tree after the currently selected item. 

Specify type and title of the new tag. 

• Cut . Removes the selected tag from its current location and puts it on the clipboard. 

• Paste . Places the tag that’s on the clipboard into the location specified, replacing the 

selected tag. 

• Paste Child . Places the tag that’s on the clipboard into the location specified, as a child of 

the selected tag. 

• Delete Tag . Removes the selected tag. 

• Find Tag From Selection . Searches for the tag in the Tags tab that contains the text or 

object selected in the document pane. 

• Create Tag From Selection . Creates a new tag in the logical structure tree after the item 

selected in the document pane. Specify type and title of the new tag. 

• Find . Searches for artifacts, OCR suspects, and unmarked (untagged) content, comments, 

links, and annotations. Options allow you to search the page or document and add tags to 

found items. 

• Change Tag To Artifact . Changes selected tags to artifacts and removes the tagged 

content from the structure tree. 

• Copy Contents To Clipboard . Copies all content contained within the selected tags. 

• Edit Class Map . Allows you to add, change, and delete the class map, or style dictionary, 

for the document. Class maps store attributes that are associated with each element. 

• Edit Role Map . Allows you to add, change, and delete role maps for the document. Role 

maps allow each document to contain a uniquely defined tag set. By mapping these 

custom tags to predefined tags in Acrobat, custom tags are easier to identify and edit. 

• Tag Annotations . When selected, all new comments and form fields are added to the tag 

tree after the selected tag element; existing comments and form fields aren’t added to the 

tag tree. Highlight and Underline comments are automatically associated and tagged with 

the text that they annotate and don’t require this option. 

• Document Is Tagged PDF . Flags the PDF as a tagged document. Deselect to remove the 

flag. 

Important: This option doesn’t necessarily indicate that the PDF conforms to PDF guidelines and 

should be used judiciously. 

• Highlight Content . When selected, causes highlights to appear around content in the 

document pane when you select the related tag in the Tags tab. 

• Show Metadata . Opens a read-only dialog box that contains reference information about 

the selected tag. 

• Properties . Opens the TouchUp Properties dialog box.

Add alternate text and supplementary information to tags

Some tagged PDFs might not contain all the information necessary to make the document contents fully 

accessible. For example, if you want to make a document available to a screen reader, the PDF should 

contain alternate text for figures, language properties for portions of the text that use a different language 

than the default language for the document, and expansion text for abbreviations. Designating the 

appropriate language for different text elements ensures that the correct characters are used when you 

repurpose the document and that it is spell-checked with the correct dictionary. 
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You can add alternate text and multiple languages to a tag from the Tags tab. (If only one language is 

required, choose the language with File > Properties instead.) You can also add alternate text by using the 

TouchUp Reading Order tool.

Note: Keep alternate text descriptions as concise as possible. 

Add alternate text to links

Screen readers can read the URLs of web links out loud, but adding meaningful alternate text to links can 

help users immensely. For example, by adding alternate text you can have a screen reader tell a user to “go to 

the Acrobat accessibility page of adobe.com” rather than “go to http://www.adobe.com/products/acrobat/

solutionsacc.html.” 

You add alternate text to the <Link> tag of a link.

Note: Note: You must add alternate text only to tags that don’t have child tags. Adding 

alternate text to a parent tag prevents a screen reader from reading any of that tag’s child 

tags. 

• In the tag tree, select the <Link> tag for the link and choose Options > Properties. 

• In the TouchUp Properties dialog box, select the Tag tab. 

• Type alternate text for the link, and click Close. 

Add alternate text for a figure

• Choose View > Navigation Panels > Tags. 

• Expand the logical structure tree to find and select the <Figure> tag element for the image. 

To find a tag more easily, use the TouchUp Reading Order tool to select the figure—or text near the 

figure—in the document pane, and then choose Find Tag From Selection from the Options menu 

in the Tags tab. 

• Choose Highlight Content from the Options menu in the Tags tab to see a highlighted area in the 

document that corresponds to the tag. 

• Choose Properties from the Options menu in the Tags tab. 

• In the TouchUp Properties dialog box, click the Tag tab. 

• For Alternate Text, type text that describes the figure. 

Add alternate text for an abbreviated term

In the Tags panel, locate the abbreviated term by doing one of the following: 

• Expand the tag tree as needed to see the elements that contain the abbreviation.

• Use the TouchUp Text tool or the Select tool to select the abbreviation in the document, and then 

choose Find Tag From Selection from the Options menu to locate the text in the tag tree.

• Select the tag for that element, and choose Properties from the Options menu. 

Note: Note: If the abbreviation includes additional text, cut the additional text and place it in a 

new <Span> child tag within the same <Span> parent tag. 

• In the TouchUp Properties dialog box, select the Tag tab. 

• For Alternate Text, type the unabbreviated version of the term. 

Click Close. 
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Create a new child tag

• In the Tags tab, select the parent node (the icon located at the same level at which you want to 

create a child tag) in the Tags tree for which you want to create a child tag. 

• Choose New Tag from the Options menu. 

Select the appropriate tag type from the Type pop-up menu, or type a custom tag type, name the tag 

(optional), and then click OK. 

Add tags to comments

When you tag a PDF that includes comments, the comments are tagged as well. However, if you add 

comments to a PDF that’s already tagged, your comments are untagged unless you enable comment tagging 

first. 

Note: To Enable comment tagging in a PDF, in the Tags tab, choose Tag Annotations from the 

Options menu. Comments or markups that you add to the PDF are tagged automatically. 

If a document contains untagged comments, you can locate them in the logical structure tree and tag them 

by using the Find command in the Tags tab.

• In the Tags tab, choose Find from the Options menu. 

• In the Find Element dialog box, choose Unmarked Comments from the Find pop-up menu, and 

click Find. 

• When the comment type appears in the Type field (for example, Text), click Tag Element, choose 

Annotation from the Type pop-up menu in the New Tag dialog box, and then click OK. 

In the Find Element dialog box, click Find Next to locate and tag all comments, and then click Close. 

Correct Table Tags with the Tags Tab

Use the TouchUp Reading Order tool to make sure that tables are tagged correctly. If you need to structure 

figures and text within the cells of your table, you may prefer to re-create the table in the authoring 

application before you convert it as an accessible PDF. Adding tags on a cell level in Acrobat is a labor-

intensive procedure.

Before you make any changes to table elements, use the TouchUp Reading Order tool to determine that the 

table is tagged correctly.

Check table elements

• In the Tags tab, expand the tags root to view a table tag. 

• Select the table tag <Table> and verify that it contains one of the following elements: 

Table Rows, each of which contains Table Header <TH> or Table Data <TD> cells.

<THead>, <TBody>, and <TFoot> sections, each of which contains Table Rows. (The Table Rows 

contain <TH> cells, <TD> cells, or both.)

Do one or more of the following: 

• If the tag for the table doesn’t contain these elements, but rows, columns, and cells appear in the 

table in the document pane, use the TouchUp Reading Order tool to select and define the table or 

individual cells.

• If the table contains rows that span two or more columns, set ColSpan and RowSpan attributes for 

these rows in the tag structure.

• Re-create the table in the authoring application, and then convert it to a tagged PDF.
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Set ColSpan and RowSpan attributes

• In the Tags tab, select a <TD> or <TH> element. 

• Choose Properties from the Options menu. 

• In the TouchUp Properties dialog box, click the Tag tab, and then click Edit Attribute Objects. 

• Select Attribute Objects, and then click New Item to create a new Attribute Object Dictionary. 

• Expand the new dictionary, select the Layout attribute, and then click Change Item. 

• Change the Layout value to Table. 

• Select the Attribute Object Dictionary, and click New Item. 

In the Add Key And Value dialog box, type ColSpan or RowSpan in the Key box, enter the number of 

columns or rows spanned in the Value box, choose Integer from the Value Type pop-up menu, and click 

OK. 

Step 7: Use the Accessibility Checker to Evaluate the PDF File

Once you have performed the previous steps. Check the PDF file using the Adobe Acrobat 9 Pro accessibility 

checker. See the document Adobe® Acrobat® 9 Pro Accessibility Guide: Using the Accessibility Checker  for 

complete instructions.

Note: The accessibility checker tools (Quick Check and Full Check) can help to identify areas of 

documents that may be in conflict with Adobe's interpretations of the accessibility 

guidelines referenced in the application and its documentation. However, these tools 

don’t check documents against all accessibility criteria, including those in such referenced 

guidelines, and Adobe does not warrant that documents comply with any specific 

guidelines or regulations.
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