
In this lesson, you learn about the
Dreamweaver 8 interface while setting
up and preparing to develop the site
you will use throughout this book.

Dreamweaver 8
Basics

Macromedia Dreamweaver 8 is the tool of choice for many Web developers—it provides

the means for both visual design and code editing, combined in an environment that

enables you to work with a wide variety of current and evolving technology solutions

while addressing the need for accessible and standards-compliant sites. Dreamweaver

helps speed production time and provides tools for site management and maintenance.

As the industry leader in Web development software, Dreamweaver gives you the tools

you need to meet the challenges of creating and maintaining Websites, including

constantly changing standards, new technologies, and the ability to meet user needs.

In this lesson, you’ll get started by learning the basics of site planning and preparation—

vital steps in the development of any Website, whether it is a completely new Web

presence or a redesign of an existing site. In the process, you’ll become familiar with the

site that is used throughout the lessons in this book. The project is a real-world example:

a redesign of the Website for Yoga Sangha—a yoga studio located in San Francisco. 

You’ll then move on to learning the basics of Dreamweaver 8 and become familiar with

the program’s interface and tools. You’ll start to use the basic site-management features
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by establishing a local site on your machine that will contain the pages that you create

while developing portions of the Yoga Sangha site.

This lesson teaches you how to work with document settings to create a simple Web

page and to open an existing page, as well as how to test your work in different browsers—

an essential part of creating functional, accessible Websites. You’ll also begin to learn

how to customize Dreamweaver to your own workflow and discover how to extend

Dreamweaver’s functionality.

In the final exercise of this lesson, you’ll begin the process of applying the skills and

techniques that you learn in this lesson to your own Web projects.

You can find an example of the completed Lesson 1 in the Completed folder inside the

Lesson_01_Basics folder on the CD-ROM.

What You Will Learn

In this lesson, you will:

• Become familiar with the Dreamweaver interface

• Customize the Dreamweaver environment

• Explore the planning process

• Set up a new site

• Create and save a new document

• Identify the tools

• Give your page a title

• Specify preview browsers and test your page

• Apply what you’ve learned to your own site(s)

Approximate Time

This lesson should take approximately one hour to complete.

Lesson Files

Starting Files:

Lesson_01_Basics/resources/client-questionnaire.doc

Completed Project:

Lesson_01_Basics/Completed/yoga.html
Lesson_01_Basics/Completed/yoga-sangha-responses.pdf

2 LESSON 1
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Exploring the Workspace

To get started using Dreamweaver, you need to become familiar with the interface and the
initial options that are available for your workspace. Windows and Macintosh versions
differ slightly.

Windows Users: If this is your first time opening Dreamweaver 8 on a Windows computer,
you will be presented with the option to select one of two workspaces: Designer or Coder.
For this exercise, you should select the Designer workspace because it will be used through-
out this book. The Designer workspace integrates all Dreamweaver-related windows and
panels into an environment that is optimized for visually based Website creation—this
option is ideal for designers. The Coder workspace is tailored for programmers—those
who want to work primarily with HTML and other Web and programming languages.
You can access all Dreamweaver features and tools from either workspace. The workspaces
simply organize the tools into optimized setups.

You can switch from the Designer workspace to the Coder workspace at any time by
choosing Window > Workspace Layout and then selecting your desired workspace.

Macintosh Users: The Designer and Coder workspace options described previously are
not available on the Macintosh. The Macintosh uses a floating panel system that you can
arrange to achieve the same optimized environment as needed.

You’ll learn more about customizing the Dreamweaver workspace later in this lesson and
throughout the book.

DREAMWEAVER 8 BASICS 3
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Start Page

Upon opening Dreamweaver 8, you should see the Start page that provides the following:

• Quick links to recent documents

• Options to create a new document from a variety of file types

• Page design samples that can give you a starting point for developing your own sites

• Program resources including a Dreamweaver tour and a tutorial

• A link to the Dreamweaver Exchange that contains resources you can use to extend
the program’s tools

By default, the Start page appears every time you open Dreamweaver unless you click the
Don’t show again checkbox.

If the Start page does not appear on startup and you want to view it, you

can adjust the display of the Start page in the Dreamweaver Preferences. To do

so, choose Dreamweaver > Preferences (Macintosh) or Edit > Preferences (Windows),

select General from the Category list, and click the Show Start Page checkbox in

the Document options section. A checkmark indicates that the Start page will be

displayed when the program is opened; no checkmark indicates that the Start

page will not appear.

When you begin to create new pages or explore other options on the Start page, it will
close on its own. Macintosh users can also close this window using the Close button in 
the upper-left corner of the window.

4 LESSON 1

Dreamweaver 8
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Preparing to Develop Your Site

Spending the time to thoroughly address the research and planning stages that are necessary
for the creation of a Website is essential. Developing a strategic method with which you
can approach development will help you be more efficient, better and more thoroughly
develop your ideas, obtain a more comprehensive understanding of the scope of your project,
and save time and resources down the road. A good Website should be intuitive and create
a positive, unique user experience. The creation of an effective Website starts with tasks
that include defining and summarizing the reason and need for the site and analyzing the
competition, creating an outline or flowchart, documenting how site features will function
and designing the look and feel. In larger companies, these tasks can be delegated to multiple
people or departments and the timeframes in which they are completed can overlap
significantly. The specific breakdown of this process can vary widely—the core components
of Website creation are presented in this book as stages that occur through five phases of
development. For the most effective site, all these components should be covered—regardless
of whether you are creating your own site, working for a client, or working as part of a
team. As you’ll learn while working through the lessons, Dreamweaver can help you with
many of these tasks—not just those in the production and post-production stages.

Phase 1: Research

Before you start work on any pages, ask yourself or your client questions like the ones
presented here. A full version of the Client Questionnaire that was used in the development
of the Website you’ll be working on, Yoga Sangha, is included on the CD-ROM in the
Lesson_01_Basics/resources folder. Throughout this section, you’ll find Yoga Sangha’s
responses to key questions from the questionnaire. Exploring these responses can give you
insight into how the Yoga Sangha site was developed and help you to understand how the
process described here was the backbone of the site’s development. Understanding how
this entire process works will help you when creating your own Websites.

• Who is the audience, why is the site needed, and what do you want the visitors

of your site to come away with? Knowing your audience is vital. Defining a general
user profile helps you to effectively reach your target audience. You may have multiple
kinds of users; if so, develop a profile for each of them.

After you know who your audience is, you need to consider which technologies those
users are likely to have. What kinds of plug-ins, browsers, and operating systems do
the majority of your visitors use? The type of equipment used by your visitors is
important to consider when you create a Website that is accessible to your intended
audience. For example, you wouldn’t want to create a site that uses elements supported
by only the most recent and up-to-date browsers if most of your audience uses older
machines that can’t even run those browsers.

DREAMWEAVER 8 BASICS 5
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Consider the purpose your site will serve and how each potential user will make use of
the site. What does the site need to contain to serve its purpose? Use the visitor profile(s)
you created to determine possible scenarios for what visitors would do at your site.

• What content will be needed for the site? Identifying and collecting your site
assets is an important part of the preparation to design and produce a Website. You
need to gather all the content, such as text, graphics, and multimedia elements that
will be used on the site. Organizing these assets enables you to create a complete and
thorough Website. You can then determine which types of content need to be developed.

Project Site: Yoga Sanhga’s Content

List the sections, features, and content that you want to see included on the site.
Of this content, what already exists and what will need to be developed?

“We want to see included a studio tour, quarterly news, a quarterly letter from Katchie and
Jayne [the studio owners], a map, and directions. These would all need to be developed.
We also want to include a quarterly or monthly highlight of a certain nonprofit doing great
work in the world, highlights of certain teachers, and whatever other topical information we
need to be conveyed, based on future needs. These would also need to be developed.”

Project Site: Yoga Sangha’s Audience

Who is your audience? What are the age ranges and interests of potential stu-
dents and site visitors?

“We seek to attract students from age 20–60 who are interested in taking yoga or who
are trying to improve their health through physical activity.”

How will they use the Website and services provided by your company?

“We want them to use the information to choose a class to attend and to discern which
workshops they would like to take. We want them to get a first impression of the studio
and its offerings that shows our quality, depth, connection, and personable service.”

How does Yoga Sangha help students and fit into their lives?

“By offering yoga classes at varying levels of ability all day and during the evening, and
by offering workshops on the weekends, which allow students to find a class or work-
shop that will fit their fitness level and personal schedule.”

What are the key reasons students may have for choosing Yoga Sangha?

“Because we’re close to where they live, because we offer Anusara yoga, or because
their favorite teacher teaches at Yoga Sangha. Plus, at Yoga Sangha they’ll learn how
to actually practice yoga versus just moving through the poses.”

6 LESSON 1
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• What should the site communicate? It is essential to know exactly what you want
to express to your visitors. If you don’t know what you’re trying to say, chances are
your users won’t know, either. Clarify the message of your site. Communication with
your visitors is an integral part of maintaining an effective site.

The final part of researching a new Website is to check out the competition. This step is
critical, even if the Website you are developing isn’t going to be for the public. Because the
Web is such a large place, almost any conceivable type of Website has already been created.
Understanding who your competition is and how they built their Websites can make all
the difference in the world. You may find that your competition’s Website is poorly designed,
or lacking in features. This can offer you the ability to design a site that stands out, giving
you the edge. Or you may discover that the competition’s Website is well designed, giving
you the incentive to create a better site. Whichever the case, ignoring your competition
puts you and the Website you are designing at a disadvantage.

Phase 2: Planning and Structure

The connection between your Website and the audience is dependent in part upon the
structure of your site. Clarity and ease-of-use are vital components of a good Website.
This important phase of development is the one you’ll begin with in this book.

• Creating the site structure: Websites rely on structure. A Website with a poor
structure can be confusing to navigate, hard to use, and difficult to maintain. To create
a site that is clear, communicative, and easy for visitors to use, you need to plan out
the structure of the site as well as the hierarchy of files and folders within the site
completely—before you begin to build any HTML documents.

Project Site: Yoga Sangha’s 

Communication Goals

What are the primary objectives for your site?

“Our studio is very community-oriented, ecologically minded, and personal. We would
love to more fully convey the Anusara Yoga philosophy, the community focus, and the
personal feel and experience of our studio on our Website. We are also part of a new
program in which we expect to be a fully Green studio by next year; that is, fully ecolog-
ically responsible and sustainable. We want to show how yoga relates with day-to-day
life through guest lectures by prominent people in activism, ecological awareness, nutri-
tion, community relations, philosophy, and meditation.”

DREAMWEAVER 8 BASICS 7
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Creating a thorough outline of the site as well as a detailed flowchart or storyboard is
an important step of the planning process.

More detailed individual page-level flowcharts are often developed at this stage as well
to organize the content prior to the design stage in the Phase 3. You’ll work on this type
of page-level content organization in Lesson 2.

• Setting up file and folder structure: It is important to set up a strategy for file
management at the beginning of the development process. Keeping different types of
media together in individual folders for each file type is a good way of doing this. You
might have an HTML folder, an images folder, a Cascading Style Sheets (CSS) folder
and a multimedia folder. Using a folder called html_docs to contain only HTML or
XHTML files, for instance, will help keep those files organized and easy to find. If the
site is very large, you might want to break it down into more manageable portions
with a folder for each section and possibly subsections—in which case, there may be
folders for the same file types in each section and subsection folder. If you have elements
such as graphics that are used site-wide, you might want to create a common folder(s)
in the main folder for such files to avoid duplicating the same files in various locations
throughout the site. Creating a visual flowchart of the different folder levels can help
you in the process of defining the folder hierarchy. A clean, well-structured Website is
much easier and more efficient to develop and maintain than one that is disorganized.
You’ll learn more about site structure and folder hierarchy as they relate to links in
Lesson 3. In this book, the file organization is arranged by lesson.

In the next exercise, you’ll be able to see the structure of the Yoga Sangha

project site by looking at the folders and files within the DW8_YogaSangha/

Completed_YogaSangha_SampleSite folder.

Phase 3: Development—Designing the Site

When designing a Website, you can start by creating thumbnails that show general designs—
a quick brainstorming method of getting visual representations of your ideas on paper.
Throughout this process, you should continue to take into account the responses to the
questions asked in Phase 1 and the results of your research. The second step of developing
your design is to fill out more detailed sketches from the best of your initial ideas. Finally,
full mockup(s) of how the pages will look can be created for the chosen design. During
this design process, there is usually a great deal of communication with the client—you
don’t want to complete a full mockup for design ideas that are nothing like what your
client is expecting. This is the stage at which many of the graphical elements for the site
are created—you’ll be working on creating page layouts in Lesson 4 and incorporating
graphics in your pages in Lesson 5.

8 LESSON 1
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Additionally, the process of testing the visual design components to verify that what you’re
envisioning will work technically in a Web page should be done throughout this stage.
Effective Web design relies on creating visual concepts that can be translated to the fully
functional technical aspects of a site. The more you learn about what is possible in a
Website, the better equipped you’ll be to design efficiently for the online medium. You’ll
learn throughout this book about many technical Web features that Dreamweaver can
help you create.

A style guide containing specific details on the look and feel, appearance, colors, and styles
to be used throughout the site is usually created at this stage as well.

During the creation of a Website, there is often a considerable amount of overlap of the
development phases—work in each of the phases often occurs concurrently. Although you’ll
address some of the concepts from Phase 2 in the next several lessons, the production stage
of Phase 3 is the one in which you’ll be working primarily throughout this book’s lessons.

Now that you understand what is involved in the preproduction stages of Phases 1 and 2—
all of which has already been done for the project site—you’re ready to begin working on
re-creating portions of the “Yoga Sangha” project site with Dreamweaver. As you work 
on the project site throughout the book, you’ll learn how to implement the site through
Dreamweaver by creating the HTML that brings all the research, content, and design
together within a successful Website.

Phase 4: Testing

Once you have finished designing your Website, it is important to test it, before you
release it to the intended audience. Even the simplest of Websites should be tested in every
conceivable way. For example, you should test your Website with as many popular browsers
as possible. Although Microsoft Internet Explorer for Windows is the most common
browser today, Mozilla Firefox, Opera, and Safari maintain a large enough share of the
market to be considered. Even with a browser such as Internet Explorer, there are major
differences between versions 5, 5.5, and 6; never mind the differences between the Windows
and Macintosh versions. Besides the way that different browsers render your pages, you
should also make sure to test every page and link. Dreamweaver 8 can help with these
postproduction tasks, as you will see later in Lesson 14.

Phase 5: Maintenance

Many Website developers find that a Website is never done. Adding pages, updating links,
modifying content and replacing images are all normal parts of maintaining a Website.
Dreamweaver 8 offers a number of features to help make the process of maintaining a
Website painless with Library items, templates and other tools. You will learn more about
these features in Lessons 13 through 16.

DREAMWEAVER 8 BASICS 9
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Defining a Local Site

The first step of creating a Website—before you begin to create any individual pages—is
to designate or create the folder on your computer that will contain everything within your
site. This process is called defining a local site. The designated folder, known as the local
root folder, sets the boundaries of the local site that resides on your hard disk and mirrors
the remote site, which is the actual site on the Web server that your visitors will access.
Defining a local site enables you to maintain the same folder hierarchy between the local
and remote versions, which is crucial to creating and maintaining a functional site.

The creation of a local site, composed of the local root folder within which you set up the
structure of the site’s files and folders, prevents your site from storing any site files outside
of the local root folder. The files on your hard disk that are outside of the local root folder
cannot be transferred to the remote server. This restriction ensures that as you develop
your site, you won’t access files that aren’t available when the site is made available online.
Many Dreamweaver features, such as the potential to update all references to a file that
may have been moved to a different location in the site, require the definition of a local
site to fully function. You should make a practice of always creating and working within
local sites. If you don’t, you might have problems with links, paths, and file management
(Dreamweaver’s tools for these features are covered in later lessons of this book).

The development of your site occurs in the local site on your hard disk, in which you
build and initially test your pages.

Setting up a site is not required, although it is recommended. Dreamweaver

will allow you to quickly edit, connect, and transfer files without setting up a site.

You’ll learn more about managing your site in Lesson 14.

1. Copy the DW8_YogaSangha folder from the CD-ROM to your hard disk.

The DW8_YogaSangha folder will become the local root folder of your site. This folder
contains all the files and folders for the Yoga Sangha project site that you will re-create
portions of as you work through the lessons in this book. When you begin work on your
own sites, you will need to create an individual local root folder for each site.

The name of a local root folder can be the name of the respective site or any name you
choose. If you develop multiple sites, it is helpful to use names that are descriptive and can
be distinguished easily from one another. The name of the local root folder is simply for
file management purposes and is not visible to the visitors of the site.

Save your local root folder in a location on your hard disk that is outside the Dreamweaver 8
application folder. If you ever need to reinstall Dreamweaver, your work will be lost if it is
located inside the Dreamweaver 8 application folder.

10 LESSON 1
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Suggestions for common locations to store local root folders:

Macintosh: Macintosh HD/User Name/Sites/local root folder

Windows: MyDocuments\local root folder

2. On the Dreamweaver Start page, select Dreamweaver Site from the Create
New section.

You can also create a new site by choosing Site > New Site or Site > Manage

Sites, clicking the New button, and selecting Site from the pop-up menu. The Site

Definition dialog box appears.

The Site Definition dialog box opens with two tabs: Basic and Advanced. These tabs allow
you to choose how you will go through the process of defining a site. The Basic version,
which is shown by default when you open the dialog box, walks you step-by-step through
the process. The Advanced version gives you a number of additional options and settings to
configure, and it does not include the explanatory text descriptions available in Basic view.

For this exercise, click the Basic tab if it is not already selected.

DREAMWEAVER 8 BASICS 11
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3. In the Basic tab of the Site Definition dialog box, Dreamweaver poses the
question, “What would you like to name your site?” Type Yoga Sangha in the Site
name text field and then click Next.

Yoga Sangha is the name of the project site you are creating. When you create your own
sites, the names that you assign should let you easily identify them. Clear and specific site
names allow you to immediately distinguish sites by name, making it easier to manage
multiple sites. Like the local root folder, the site name is for your reference only in
Dreamweaver’s list of defined sites and is not visible to users of your site.

You should leave the HTTP Address text field on this screen blank. The HTTP Address—
the URL of the online site—is used to define site-root relative links, which are covered in
Lesson 3. This item is optional and not necessary for the exercises in this book.

This section of the Basic site setup corresponds to the Site name text field

of the Local Info category in the Advanced view. Throughout the course of defining

your site, you can switch back and forth between the Basic and Advanced views if

you want to see how the Advanced view appears. You’ll work with the Advanced

view in Lesson 14.

4. Dreamweaver asks, “Do you want to work with a server technology such as
ColdFusion, ASP.NET, ASP, JSP, or PHP?” Click the radio button for the option “No,
I do not want to use a server technology.” Click Next to advance to the next section.

At this time you are not creating pages that will incorporate databases or other server
technologies, so you should select the No option. You can always add this functionality 
at a later point—any time you need to make changes to your site setup, you can choose
Site > Manage Sites, select your site in the list, and click the Edit button.

12 LESSON 1

Specifying the
server

technology in
the Site

Definition
dialog box

01_DW8 tfs(1-38).qxd  03/06/2006  12:20 PM  Page 12

IS
B

N
: 0-558-13856-X

Macromedia Dreamweaver 8: Training from the Source, by Khristine Annwn Page. Copyright © 2006 by Adobe Systems, Inc.
Published by Peachpit Press, a Pearson Company.



This section of the Basic setup corresponds to the Testing Server category in

the Advanced View, which gives you additional options that are involved with creating

dynamic sites, such as choosing the server model that is used on your remote server.

5. At the top of this section, Dreamweaver asks, “How do you want to work with
your files during development?” Click the option “Edit local copies on my
machine, then upload to server when ready (recommended).”

At this time, you will be working with files that are located on your machine—you don’t
need to have access to a remote server. Editing files that exist on your computer is the
most common selection. If you have a remote server, this option means that there are two
copies of the files—one copy on your local hard drive and a second copy on your server.
This gives you the option to retrieve the original files from the server if necessary—
provided that you haven’t replaced them by uploading files that were changed locally.
Doing production and testing work on your local hard drive prevents unfinished pages
from being publicly displayed.

If you were working directly on a server, any changes you might make would be
immediately applied to the original files.

DREAMWEAVER 8 BASICS 13
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6. Also in this section, Dreamweaver asks, “Where on your computer do you
want to store your files?” Click the folder icon to the right of the text field and
browse to find the DW8_YogaSangha folder.

This text field allows you to select the folder on your hard disk within which all the files
for the site are stored. This folder is the equivalent of the root folder on the remote site.
Dreamweaver needs to define this local root folder to determine the paths for documents,
images, and links in your site. You will learn about paths and links in Lesson 3.

The DW8_YogaSangha folder is the folder that you copied from the CD-ROM to your
hard disk in Step 1 of this exercise. By default, the text field initially contained the path to
a folder called Yoga Sangha. Using that default would create a new folder on your hard
disk called Yoga Sangha, which would become your local root folder. Because you need 
to use the DW8_YogaSangha folder that contains the files, you must locate that folder.

Macintosh Users: Find the DW8_YogaSangha folder on your hard disk, select it, and
click Choose.

Windows Users: Find the DW8_YogaSangha folder on your hard disk, select it, and click
Open; then click Select to choose the DW8_YogaSangha folder as your local root folder.
The text “Select:DW8_YogaSangha” appears in the lower-left corner of the Choose Local
Root Folder For Site Yoga Sangha dialog box to indicate that the DW8_YogaSangha folder
will be selected.

Be sure to select the DW8_YogaSangha folder that you copied to your hard

disk—not the one residing on the CD-ROM. In some versions of Windows, files

copied from a CD are marked read-only; to fix this, select all of the files (Ctrl-A), after

copying them, go to Properties (Alt-Enter or right-click on the selected files and

click Properties), and uncheck the Read-Only checkbox. Then click Apply, or OK.

14 LESSON 1
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The path to the local root folder, DW8_YogaSangha, is now displayed in the text field and
its location is shown in relation to your hard disk.

In this case, however, you need to choose the DW8_YogaSangha folder that already exists
(and contains the many files that you need to work with in this book’s lessons) as your
local root folder.

When you create your own sites, if you do not already have a folder, you might find it
useful to allow Dreamweaver to automatically create one for you based on the name you
chose for your site.

Understanding the Advanced 

Site Definition Options

This section of the Basic site setup—in which you are specifying the local root folder—
corresponds to the Local root folder text field of the Local Info category in the
Advanced view. The Advanced site definition options also allow you to select Refresh
Local File List automatically, Enable Cache, specify a Default Images folder, and define
the HTTP Address for the site.

The Refresh Local File List option is checked by default, causing Dreamweaver to
update the site list whenever you add a new file to the site folder. If you uncheck this
option, you need to refresh the local files manually whenever you make changes such as
adding or deleting files.

The Enable Cache option is checked by default. Enabling the cache allocates memory
to store frequently used site data, improving the speed of linking and site-management
tasks. The site cache stores information in your computer’s RAM memory making
access to features that use the cache quicker. When this option is active, Dreamweaver
will continuously update the information stored in the cache as you work. Although it is
usually best to leave the cache option on, keep in mind that re-creating the cache can
slow operations on extremely large sites.

The Default Images folder allows you to specify the location of images in your site and
can reduce the amount of time that it takes to browse for images when inserting them.
The use of images is covered in Lesson 5.

The HTTP address, another optional feature, is used to define the URL of your Website.
This address is used to verify absolute links. More information on links is covered in
Lesson 3.
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7. Click Next to advance to the next section. Below the question “How do you
connect to your remote server?” choose None from the menu.

At this time, you are working on a local site; you do not need access to a remote server.
More information about connecting to a remote server can be found in Lesson 14.

This section of the Basic setup corresponds to the Remote Info category 

in the Advanced view, which gives you additional options that are involved in

transferring files to a remote server, such as specifying the folder to store files 

in on the server.
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8. Click Next to advance to the next section. Review the information about the site
you just defined and then click the Done button at the bottom of the dialog box.

Because you chose the No options for the Remote Info and Testing Server sections,
Dreamweaver displays “Access: I’ll set this up later.” for both.

When you click Done, Dreamweaver scans the files in the DW8_YogaSangha folder to create
the site cache. You may see a dialog box appear briefly as Dreamweaver completes the process
of creating the cache for the first time. Creating the cache will take longer on very large sites.
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The Files panel now displays the DW8_YogaSangha folder. By default, the Files panel is
displayed at the bottom of the panel groups that you’ll explore later in this lesson. You’ll
also learn more about the Files panel in Lesson 14.

If you have never defined a site in Dreamweaver, the Files panel displays a

hierarchy of folders on your computer and a link to open the Manage Sites dialog

box. For Macintosh users, the default selection in the Site panel pop-up menu is

Computer, which initially contains Macintosh HD, Network, FTP & RDS Servers,

and Desktop folder. For Windows users, the default selection is Desktop, which

initially contains My Computer, My Network Places, FTP & RDS Servers, and

Desktop items. After you create a site, that site becomes the default selection. If

you have more than one site, Dreamweaver displays the most recently used site 

in the Files panel. The Files panel is located in the Files panel group.

Creating and Saving a New Page

After your local site is defined, you are ready to start working with and creating Web pages.
Whenever you create a new page, the first thing you should do is save the document.

1. Choose File > New. The New Document dialog box appears.
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You can use the keyboard commands Cmd+N (Macintosh) or Ctrl+N (Windows)

to open the New Document dialog box. If you want to bypass the New Document

dialog box and create a new document immediately whenever using these keyboard

commands, choose Dreamweaver > Preferences (Macintosh) or Edit > Preferences

(Windows), select New Document from the Category list, and uncheck the Show

New Document Dialog on Command+N (Macintosh) or the Show New Document

Dialog on Ctrl+N (Windows). This section also provides you with the option to

change the default document type as well as the extension and encoding. The

lessons in this book assume that you are using the defaults. Clicking the Preferences

button at the bottom of the New Document dialog box is another way to open the

Preferences dialog box.

The New Document dialog box opens with two tabs: General and Templates. In this exercise,
you are creating a new HTML (Hypertext Markup Language) page. The option to create a
new HTML page is located in the Basic category of the General tab. These selections are
the defaults and might already be selected for you.

The New Document dialog box also gives you additional options for creating a variety of
page types. The Basic Page category offers a number of options in addition to HTML,
including CSS (Cascading Style Sheets), JavaScript, and XML. Other available page type
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categories include Dynamic Pages (that use languages such as ASP, ColdFusion, and PHP)
and Page Designs (that you can use as a starting point when creating your own site). You
can access specific page types by choosing from the list of categories in the left column of
the dialog box that includes Dynamic, Templates, CSS Style Sheets, Framesets, and Page
Designs. You won’t use any of these additional page types in this exercise, but you should be
aware of them. The contents of the middle column of the dialog box change depending
upon the category selected in the left column.

Understanding XHTML, XML and 

Document Type Definitions

Behind the visual appearance of a Web page is code, called a markup language, that is
used to produce what a visitor sees in their browser—the markup describes the struc-
ture and appearance of a page by labeling elements such as text and images with
instructions, in the form of tags and their attributes, as to how those elements should be
displayed. Hypertext Markup Language (HTML) is currently one of the most well-
known markup languages; however, HTML is limited in nature, particularly in that new
features are generally not backward-compatible, and there are a wide number of com-
patibility issues with HTML for cross-browser use. HTML is an older markup language
that is being phased out of use because it doesn’t meet current Web standards, nor
does it have the potential to evolve to match those standards.

Extensible Hypertext Markup Language (XHTML) replaces and extends the capabilities of
HTML by reforming HTML as an Extensible Markup Language (XML) language. XML
markup emphasizes and facilitates the separation of structure, content, and presentation by
specifying the content and structure of a page, but not the appearance or presentation—
the definition of all presentation is handled separately through other means, such as CSS. 

The advantages of using XHTML include both backward- and forward-compatibility,
operability on alternate Web access devices such as cell phones or handheld comput-
ers, and the potential for extensibility. XHTML 1.0 Transitional is a version of XHTML
that allows the use of some HTML elements that are deprecated—marked as obsolete
by the World Wide Web Consortium (W3C), which develops Web standards to ensure
compatibility throughout the industry—and therefore not available in stricter versions of
XHTML. Because allowing these deprecated elements enables backward-compatibility
through the conversion from HTML to XHTML, XHTML 1.0 Transitional is currently the
recommended markup language for Web development.

The use of these languages is defined through the Document Type Definition (DTD).
Although invisible to the visitor, the DTD is located at the beginning of the code that com-
prises the Web page. The DTD declares the syntax of the markup language for the page—
that is, it defines how the browser or other Web access device should interpret the page.

20 LESSON 1

01_DW8 tfs(1-38).qxd  03/06/2006  12:20 PM  Page 20

IS
B

N
: 0-558-13856-X

Macromedia Dreamweaver 8: Training from the Source, by Khristine Annwn Page. Copyright © 2006 by Adobe Systems, Inc.
Published by Peachpit Press, a Pearson Company.



By default, Dreamweaver uses XHTML 1.0 Transitional as the Document

Type Definition in all new HTML documents unless you select a different type.

You can change the DTD of a new document in the New Document dialog box by

choosing the desired type from the DTD menu at the bottom of the dialog box.

Throughout this book, you should use the default XHTML 1.0 Transitional DTD—

do not change the DTD. You can convert between HTML and XHTML by

choosing File > Convert and selecting the type to which you want to convert.

After you click the Create button, a new untitled XHTML document appears, and the
Start page closes automatically.

You can also create a new document directly from the Start page by selecting

the file type (such as HTML, as you did in this exercise) from the Create New column.

A new document of the type you selected appears, and the Start page closes.

2. Click the General tab in the New Document dialog box and choose Basic Page in
the category list. Choose HTML in the Basic Page list and click the Create button.

3. Choose File > Save and locate the folder html_docs in Lesson_01_Basics, in
which you will save this file. Type yoga.html in the Save As (Macintosh) or File
Name (Windows) field and then click Save.
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Don’t wait until you have text or graphics on the page to save—save your pages as soon as
you open new documents. Provided that your file is saved first, when you import graphics
or other media, all the paths that reference where those elements are located in your site will
be made properly. If you don’t save your document, a path name beginning with file:// is
used that describes the location of the element you are inserting relative to your hard disk.
If you try to insert an object without first saving the document, Dreamweaver warns you
that it needs to use a file:// path name for the element. These file:// paths do not work on
remote servers because they describe the location of files specific to your computer.

You can use the keyboard commands Cmd+S (Macintosh) or Ctrl+S (Windows)

to save your document. Always remember to save often so you won’t lose a lot of

work if your computer crashes for any reason.

Macintosh Users: Dreamweaver automatically adds the extension .html to the filename
of HTML documents in the File Name text field—you must leave this extension or specify
a different one for the document to be saved with an extension.

Windows Users: Dreamweaver automatically adds the extension .html to the filename,
of HTML documents, when you save if the extension isn’t specified in the File Name text
field. You can also specify the extension yourself.

Dreamweaver adds the default extension of any file you create. For example,

if you create a Cascading Style Sheet file, Dreamweaver will add .css to the filename.

You should always save your documents with the extension .html. If Dreamweaver is
giving you a default of .htm, you can change the default by choosing Dreamweaver >
Preferences (Macintosh) or Edit > Preferences (Windows) and selecting the New Document
category. The default extension is displayed in a text box. Throughout this book, the
extension .html is used in the examples and materials included on the CD-ROM, and the
exercises assume that you will be using the default extension.

The .htm extension is a remnant from the bad old days when Windows could

only handle 3 character file extensions. Unless you think that someone with

Windows 3.1 is going to be working on this site, there’s no reason to ever use the

.htm extension as it’s generally considered to be unprofessional.
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New documents are given a default name of Untitled-1.html in the Save As text field, with
the numbers increasing sequentially for every new document that is created.

The New Document and Save options are also available on the Standard

toolbar, which you can open by choosing View > Toolbars > Standard. Toolbars

other than the default document toolbar appear as you add or move them only 

on the active document; changes are not reflected in other documents.

Exploring the Tools

Before jumping into further development of any Web pages, you need to become familiar
with the variety of tools and panels that make up the Dreamweaver 8 interface and enable
you to effectively produce a Website.

1. Move the pointer over the Document window and the document toolbar. Rest
the pointer over a button to see its name.

The majority of your design and coding work is done within the Document window. This
area is known as the body of the page, in which you can insert, modify, and delete the wide

File-Naming Conventions

Keep in mind that naming your files for use on a Web server is a little different from naming
your files for use on your hard disk. It is helpful to know what operating system the server
will be using—the most common systems are Unix, Linux, Windows NT, and Mac OS X.
The naming structure is different on Windows from the other *NIX-based operating sys-
tems. Unix, for example, is case-sensitive, which means that myfile.html does not equal
MYFILE.HTML. Using all lowercase names for your files makes naming files simpler and
helps you maintain consistency. You should use only alpha characters (A–Z) and numbers
(0–9) to name your files. Here are other important conventions to follow for both filenames
and folder names:

• Spaces. Don’t ever use spaces in filenames. Use the underscore or hyphen charac-
ters to simulate a space if you need to separate words. Problems can arise because
browsers substitute %20 for spaces.

• Special characters. Don’t use any special characters, such as ?, %, *, >, or /. Don’t
use commas.

• Numbers. Avoid beginning your filenames with numbers.

• Length. Keep folder names and filenames as short as possible. Remember that the
folder name becomes part of the URL you type to get to the page.
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variety of elements that make up a Web page. As you work, the Document window displays
an approximation of the way your page should appear in a browser. It is an approximation
because there are differences in the ways that browsers interpret Web pages.

The filename yoga.html (as you saved this page in the previous exercise) is shown on the
title bar (On Windows, the filename is shown in a tab at the top of the document window;
see the illustration on page 31). By default, this page is initially titled Untitled Document,
as shown in the Title text field on the document toolbar. The document toolbar, which can
be shown or hidden through View > Toolbars, contains buttons and pop-up menus to provide
quick access to common operations. By default, the toolbar is part of the document
window. Windows users can double-click or drag the gripper area on the left edge of the
toolbar to separate it from the document window, making it become an individual panel.

There are three view modes in Dreamweaver: Design view, Code view, and Split view, which
shows both Design view and Code view. The buttons for these modes are located on the
left side of the document toolbar. You can see the view mode names by pausing the pointer
over the buttons. At this point, the view mode you are using should be Design view. The
active button is highlighted, indicating that Dreamweaver is displaying the page in that
view mode. You will work with Code view and Split view in Lesson 16. If the Document
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window is shown split into two panes with code in one pane or a single pane with code,
you need to select the Design View icon located on the document toolbar.

In the lower-left corner of the document window is the tag selector. The tag selector always
starts from the <body> tag and hierarchically displays HTML tags that apply to the currently
selected element. Using the HTML tags that correspond with those elements, the tag selector
allows you to move quickly through the hierarchy of code to see what element you are
working with and to easily select other elements. Getting used to working with the tag
selector will be particularly helpful when you begin using tables in Lesson 6.

If you can’t see the tag selector, try reducing the size of your document

window. The tag selector can become hidden beneath the Property inspector.

You’ll become familiar with the many buttons and customizable options in the Document
window as you work through the lessons in this book.

2. Make sure that Common is chosen from the pop-up menu at the left end of the
Insert bar, then move the pointer over the bar, whose default position is at the top of
your screen. Rest the pointer over a button to see its name.

The Insert bar contains many of the objects or elements that you can add to your page,
including images, tables, special characters, forms, and HTML. The elements are arranged
in eight groups, according to their type: Common, Layout, Forms, Text, HTML, Application,
Flash Elements, and Favorites. The name of the active group is displayed on the menu.
The Common group is active by default. You can use the pop-up menu to switch to a
different group of objects. Many of the individual objects in these groups have their own
pop-up menus, indicated by a small black arrow, with additional tools, options and other
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closely related objects; click the black arrow once to open the pop-up menu. The last
option in the Insert bar category pop-up menu is Show As Tabs, which will convert the
Insert bar to show tabs at the top of the bar for each category. To switch back to the menu
format, choose Show As Menu from the Options menu in the upper-right corner of the
Insert bar. Use whichever viewing method—tabs or the menu—that you prefer.

Throughout this book, the words “objects” and “elements” are used

interchangeably. Where possible, “object” is used when referring to the button,

and “element” is used for the item after it appears within the Document window.

To insert an element, you can drag the object’s icon from the Insert bar to the location
where you want it to appear in the Document window. You can also place the insertion
point in your document where the element should appear and then click the object’s icon
in the panel. When you click the icon, the element appears in the document at the
insertion point.

You can move many of the objects that you use regularly into the Favorites

group of the Insert bar by right-clicking (Macintosh users with single-button mice

can use Control+click to access the same options) on the bar and choosing

Customize Favorites. Select the desired item from the Available Objects menu

that appears and click the double arrow button between the Available Objects 

and Favorite Objects lists. You can use the Up and Down Arrow keys above the

Favorite objects list to adjust the order of objects. The dialog box also allows you

to remove objects from the Favorites group and add separators between the

objects to further organize them.

3. Move the pointer over the Property inspector, normally at the bottom of your
screen. Rest the pointer over a button to see its name.

The Property inspector is used to view and modify the attributes of selected text, images,
tables and other elements in a document. The Property inspector is contextual—the
attributes that it makes available change depending on what is selected in the document
window. To expand or collapse the Property inspector, click the expander arrow in the
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lower-right corner of the panel. If the Property inspector is collapsed, there can be additional
properties that are not visible until you expand the panel.

Windows users can also reduce the inspector so that only the name of the panel shows to
gain a larger viewing area.

Windows users can also resize the entire area for the Property inspector (and

additional panels that later appear in that area) by dragging the arrow button on

the horizontal border between the document window and the Property inspector.

Clicking the arrow button collapses the entire area; simply click the button again

to reopen it. The horizontal border is not part of the Macintosh interface.

Working with Panels and Documents

The majority of Dreamweaver’s panels are docked—combined in tabbed windows—
within panel groups according to their functions. The default panel groups are CSS,
Application, Tag Inspector, and Files. You can access panels from within these groups as
well as from the Window menu. Panel groups let you quickly hide or access your most
frequently used panels. Docking maximizes your screen area while giving you quick access
to the panels you need. Each panel group can be expanded to display the active panel plus
tabs for the rest of the panels it contains or reduced to show only the name of the group.

If you opened Dreamweaver before beginning this lesson, the panels are placed exactly
where they were the last time you quit the program. In the Window menu, a checkmark
next to an item indicates that the panel or toolbar is selected and active (visible) in the
panel groups.
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1. Click the arrow on the CSS panel group title bar to expand the group if it is not
already open.

The CSS panel group is located (by default) at the top of the panel groups. When the CSS
panel group is expanded, you will see the CSS Styles panel, which you will work with in
Lesson 4. In the upper-right corner of the panel you see the Options menu button, which
is not visible when the panel group is reduced.

In the Window menu, a hidden panel does not have a checkmark next to the panel name.
To display a hidden panel, choose the desired panel from the Window menu. If the panel
you choose is in a panel group that is not currently available, both the panel and the panel
group containing that chosen panel appear. If the group containing the desired panel is
visible but reduced, choosing the panel from the Window menu expands the group and
displays the selected panel.

There may be instances in which a panel is hidden beneath another panel or

the Document window. Changes in screen resolution can be one cause of this

problem. If you are missing a panel and can’t bring it up by choosing it from the

Window menu, you might need to choose Window > Arrange Panels (Macintosh

Only) to reset all open panels to the default positions. Both Macintosh and

Windows users can also choose Window > Workspace Layout > Default to restore

all tools and panels to their original positions. The Insert bar moves to the upper-

left corner of the screen, the Property inspector moves to the bottom of the

screen, and all other open panels move to the right of the screen.
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2. Rest the pointer over the bottom of a line that separates two panel groups. When
the pointer changes to a vertical two-arrow pointer, click and drag upward or
downward to adjust the size of the panels.

As you work, you might need to resize panels to show more information or provide more
room for other panels and the Document window.

Windows users can also resize the width of the entire area for all docked panel

groups by dragging the arrow button on the vertical border. Clicking the arrow button

collapses the entire docking area; simply click the button again to reopen it.

The vertical border is not part of the Macintosh interface. Macintosh users can

resize the width of docked panel groups by clicking and dragging the resize

button at the lower-right corner of the panel groups.
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After you become familiar with the Dreamweaver panels and tools, you can customize the
interface by rearranging panels and reordering panel groups to make the program work
with your specific needs. You can save any custom workspace that you create by choosing
Window > Workspace Layout > Save Current. The Workspace Layout submenu also offers
a workspace for developers who work with two monitors—Dual Screen—as well as the
ability to rename or delete saved workspaces through the Manage option.

You can undock any panel group and separate it from the docking area. To

undock a panel group, rest the pointer over the panel gripper designated by the

dots on the left of the panel group title bar. When the pointer turns to a hand

(Macintosh) or a cross-hair with arrows (Windows), click and drag the panel group

out of the window and release it. As you drag it outside of the docked panels, you

will see a ghost image of the panel group until you release it. You can rename this

new window or panel group by clicking the Options menu button and choosing

Rename Panel Group from the Options menu. As you drag a panel group back

into the docking area with other groups, you see the ghost image of the panel

before you release it as well as a thick dark line at the point where the panel group

appears. You can also rearrange the order of panel groups by using the grab area

to move any of the groups above or below the other groups. If you want to change

the organization of panel tabs by moving them into different groups, select a panel

by clicking its tab and choose Group (panel name) with from the Options menu.

The lessons in this book assume that you are using the default configuration of panels in
Dreamweaver 8, with no changes to the order or names of panels and panel groups. If you
have rearranged any of the tools, you can revert to the default configuration by choosing
Window > Workspace Layout > Default (Macintosh) or Window > Workspace and
selecting Designer (Windows).

3. Choose File > New and select HTML from the Basic page category of the
General tab.

A new XHTML document opens with a new tab in the current Document window.
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Windows Users: Cascade, Tile Horizontally, and Tile Vertically are three options for
viewing documents. If you have more than one Document window open at a time, the
Cascade option causes those windows to float, stacked one on top of the other, within 
the Document window portion of the workspace. The Tile Horizontally option causes the
Document windows to appear stacked horizontally. The Tile Vertically option causes the
Document windows to appear side by side vertically. These options can be accessed from
the Window menu. You can also switch to the Tile view by clicking the maximize button
in the upper-right corner of the Document window—not the maximize button for the
entire program. Click the Maximize button on a Document window again to switch back
to tabs.

Macintosh Users: Cascade, Tile, and Combine As Tabs are the three options for viewing
documents. The Cascade option will cause the documents to appear in individual windows
that float, stacked one on top of the other. The Tile option will cause the documents to
display in individual windows that appear side by side. Combine As Tabs is the default
arrangement—new documents will appear in the same window as current documents
with tabs for each one. You can open any tabbed document by right-clicking (Windows)
or Control+clicking (Macintosh) the corresponding tab and choosing the Move To New
Window option.
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Giving Your Page a Title

Every HTML document you create needs to have a title. The title is used primarily for
document identification. It is displayed in a browser’s title bar, indicates the content of a
page, and appears as the bookmark name in Favorites lists. You should choose a short
informative phrase, beginning with the site name, which is descriptive of the document’s
purpose. Get into the habit of adding a title to each page you create before you add text or
graphics to the page. If you forget, Dreamweaver titles the file Untitled Document by default.

To give a title to your page, click the tab for the yoga.html document and type Yoga Sangha
Project into the Title text field on the document toolbar. Press Return (Macintosh) or
Enter (Windows), or click in the yoga.html document.

If you don’t see the document toolbar with the Title text field, choose View >

Toolbars > Document.

The Title text field initially displays Untitled Document—you are now replacing that
placeholder title with a title for a page in the project site.

You can also specify the title of your document in the Title text field located

in the Title/Encoding category of the Page Properties dialog box. To access the

Page Properties dialog box, choose Modify > Page Properties.
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Specifying Preview Browsers

As you develop Web pages, you’ll need to continually test how your work appears in different
browsers, such as Internet Explorer and Safari. What you see in the Dreamweaver Document
window is only an approximation of how the pages will look. Every browser has differences
in the way it displays Web pages, and although some of these discrepancies are slight, the
differences can sometimes be significant. You might notice differences, even between different
versions of the same browser. The more you test your site in multiple browsers and on
different operating systems—and make changes to your pages accordingly—the more
certain you can be that visitors to the site see your pages as you intended them to appear.

The Preferences in Dreamweaver enable you to specify which browsers you want to use to
preview the pages in your site. To speed up the process, you can define a primary and a
secondary browser, with a keyboard shortcut for each.

1. Choose File > Preview in Browser > Edit Browser List.

Alternatively, you can choose Dreamweaver > Preferences (Macintosh) or

Edit > Preferences (Windows) and select Preview In Browser in the Category list,

located on the left side of the dialog box, to open the same Preview In Browser

Preferences dialog box. You can also use the keyboard command Command+U

(Macintosh) or Ctrl+U (Windows) to open the Preferences dialog box.

The Preferences dialog box opens to display the Preview In Browser preferences.
Dreamweaver can automatically list one of more of the browsers that are on your computer.

On Windows, Internet Explorer may appear as iexplore or iexplore.exe in 

the list.
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When you click a browser name in the browser list, the checkboxes below the list show
whether that browser is the primary or secondary browser. If you have more than two
browsers, it leaves both boxes unchecked to show if it is neither.

The Preview Using Temporary File option is unchecked by default for any browsers in the
list. Checking this option will cause Dreamweaver to create temporary files when previewing
pages in a browser.

2. Click OK to close the dialog box when you are done reviewing the preferences.

You can add, modify, or remove browsers from the list if needed.

• Adding a Browser: To add a browser to the list, click the plus (+) button. When the
dialog box appears, browse your hard disk to find and choose a browser application.
Check the Primary Browser checkbox if you want to launch this browser by pressing
Option+F12 (Macintosh) or F12 (Windows) when you preview your pages. Check the
Secondary Browser checkbox if you want to preview your documents in this browser
by pressing Command+F12 (Macintosh) or Ctrl+F12 (Windows). (You’ll be
previewing the pages you develop while completing the lessons in this book often, so
using these shortcuts can save you time.)

Your function keys must be enabled for the Preview In Browser keyboard

shortcuts to work. Function keys are usually enabled by default; if they are not

working, check your operating system preferences. If your function keys are

performing system functions, you might have to press the Fn key to use the

function keys for Dreamweaver—or adjust your system preferences.

• Removing a Browser: To remove a browser from the list, select the browser name in
the list and then click the minus (–) button.

To change a browser choice, select the browser name in the list. Then click

Edit and locate a different browser.

3. Click the yoga.html document tab and press F12 to preview the page in your
primary browser.

You can also choose File > Preview in Browser and select the browser 

you want to use from the submenu. The document toolbar also contains a

Preview/Debug In Browser button; click it to open the pop-up menu and 

select the browser in which you want to preview your page.
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The browser defined as the Primary Browser in the Preview In Browser preferences
becomes active and displays the yoga.html file in a browser window. Notice the title Yoga
Sangha on the title bar of the browser.

At this point, your browser shows a blank page. You are ready to begin inserting content.
You’ll add text to this file in the next lesson.

Unless you clicked the Don’t Show Again checkbox on the Start page

earlier in this lesson, the Start page will reappear if you close all open documents.

4. Save the yoga.html document. Close and do not save the untitled document.

You can leave the yoga.html document open for the next lesson.

Exploring the Basics On Your Own

Now that you learned how to plan a Website, set up a site in Dreamweaver, and worked
with both new and existing pages, you’re ready to apply these skills and techniques to your
own Website(s).

1. Use planning phases and questions to complete the research and develop a
Creative Brief for your own site.

As you work through the process, remember to be detailed. Start the process of developing
your site by:

• Considering the purpose, goals, and market for your site

• Exploring who the audience is and what their needs are

• Taking stock of content and assets that are already available

• Determining what elements will need to be created

• Developing the site structure

• Setting up the file structure

The Creative Brief is a document in which you organize all the research and work that was
done on the site in Phase 1. This can help you coordinate the efforts in later stages while
making it easier to stay on track in the development of the site you are creating.

2. Use the Site Definition dialog box to set up your site in Dreamweaver.

Site setup will include the creation of the local root folder in which all your site files will
be stored.
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3. Use the starter pages and page designs available from the New Document
dialog box to create several placeholder pages within your new site.

You can save these pages inside your local root folder as placeholders for future content.

You can also access these resources by selecting a category from the Create

From Samples section on the Start page.

As you continue to complete the lessons, you’ll learn how to work with the various
elements that can be seen in these starter pages, including links, images, and CSS.

Recommended Resources

Book: Web ReDesign 2.0: Workflow that Works
by Kelly Goto and Emily Cotler
Published by New Riders. © 2004
ISBN 0-7357-1433-9

This book is a great source of information that can aid you in the process of developing a
Website—whether you are creating a new site from scratch or redesigning an existing
site. The development process is clearly presented and offers a number of tools and
techniques for developing the workflow that will best serve your project—including case
studies, forms, checklists and worksheets.

Web: www.macromedia.com/resources/techniques

A Web resource created jointly by Macromedia and Kelly Goto, co-author of Web
ReDesign: Workflow that Works, this site presents a wide range of articles on each phase
of Web development. Additional resources are included in the forums hosted on the site,
such as the Production Management Online Forum.

Book: Don’t Make Me Think: A Common Sense Approach to Web Usability 
(2nd Edition)
by Steve Krug
Published by New Riders. © 2005
ISBN 0-3213-4475-8

Usability is a key factor in creating successful Websites—it includes attention to ease of
use and clarity. Exploring the common-sense aspect of usability concepts for the Web,
this book offers methods for examining your site and determining if all portions of that
site—navigation, layout, content, and more—are usable for the intended audience.
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What You Have Learned

In this lesson, you have:

• Opened Dreamweaver (pages 4–5)

• Learned about the phases of Website development (pages 5–9)

• Prepared to create a Website, set up a local site, and defined the local root folder
(pages 10–18)

• Created a new page and saved the document using the proper naming conventions
(pages 18–23)

• Familiarized yourself with Dreamweaver’s Insert panel; Property inspector;
Document window; and other tools, windows, and panels (pages 23–31)

• Given your page a title (page 32)

• Specified preview browsers and used the keyboard shortcut to test your page 
(pages 33–35)
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