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Introduction
Tap into your inner Mozart!  GarageBand is an application that allows you to create your own
music (pros and novices alike) and turns your Macintosh into a digital recording studio.  You
don’t have to play the piano, you don’t have to read music, you don’t even have to have rhythm!
Tired of messing with issues of copyright when using music for your PowerPoints, videos,
digital photo albums or other presentations?  Make your OWN music by learning how to
manipulate infinite combinations of the over 1,000 loops that Apple provides in this powerful
software tool. These professionally-recorded riffs by world-class musicians are royalty-free
interludes, played in a variety of moods and genres. GarageBand does not require that you use
a synthesizer keyboard or other MIDI instrument but if you have one and are musically-inclined,
you can even make BETTER music by recording your own tracks and using GarageBand to lay
down additional background tracks. Just like the pro’s, you can tweak your own loops and/or
recordings with processed effects such as reverb or grand chorus.  When your masterpiece is
finished, export it to iTunes 4 for use in your iMovie, iPhoto, or PowerPoint/Keynote
presentation, or even transfer it to your iPod for your own personal enjoyment!

GarageBand’s Musical Components
GarageBand consists of three musical components:  1) Loops:  These are pre-recorded audio
loops of both sampled or synthesized instruments; 2) Software Instruments:  These are MIDI
tracks created either with software synthesizers controlled via a MIDI keyboard or with
GarageBand’s on-screen keyboard; and 3) Real Instruments:  These are digital audio tracks live
performance recordings of real instruments or vocals through the Mac’s audio port or an audio
interface.
All three of these components display as separate tracks within the GarageBand Timeline.  You
can add as many tracks as you need in order to complete your composition and use any
mixture of the above three components.  You are only limited by the amount of RAM on your
computer.
Actually, you can get around that problem by combining multiple tracks into one track (a
process the pro’s called bouncing).  Create as many tracks as your Mac allows, mix them to
your satisfaction (i.e., balancing volume etc. so they can still be heard when you add other
tracks later), then export them into iTunes as one .AIF file.  Import the .AIF file back into
GarageBand as one merged track by dragging it from iTunes into the Finder and then drag the
exported file from the Finder into GarageBand’s Timeline.  Continue to record additional tracks
and repeat this process as necessary until you have completed your project.  Basically, this
method allows you to create a virtually unlimited number of tracks!

Let’s not waste any time… let’s create a song file and get started!

Note:  A great deal of this tutorial was extracted from Apple’s GarageBand Tutorials but
placed in somewhat different order for better understanding.
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Creating a New Project File
To start working in GarageBand, you will need to create a new project. Projects or songs are the
documents that hold your music and all the changes you make. If it is your first time to open
the GarageBand application, it will ask you if you wish to “Create a new song” or “Open an
Existing Song.”

To create a new project within GarageBand:

1. Choose File > New.
2. In the New Project dialog box, browse to the location where you want to store the

project, then type a name for the project in the name field.
3. Set the song’s tempo, time signature, and key as described in the following section.

Figure 1:  New Project Dialog Box

Setting the Tempo, Time Signature, and Key
Each song has a tempo, a time signature, and a key, which last for the entire length of the song.

Music Theory Tip - About the Tempo:
Each song has a speed, or tempo, which defines the rate that the beat (i.e., the basic rhythmic
pulse), occurs in the song. The tempo is measured in beats per minute, or bpm.  You can set
the tempo to any speed between 60 and 240 bpm. The default tempo is 120 bpm, which is a
common tempo used in pop music.
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To set the tempo for your song:
1. In the New Project dialog box, drag the Tempo slider left to slow down the tempo,

or right to speed up the tempo.  If you need to, you can change the tempo later in
the Track Info > Master Track window.

Music Theory Tip - About the Time Signature:
Each song also has a time signature, which controls the relationship between beats and
measures. A song's time signature consists of two numbers separated by a forward slash, which
look similar to a fraction. The number on the left refers to the number of beats in each
measure, and the number on the right refers to the beat value (the length of the note that gets
one beat). You can use any of the following time signatures in a GarageBand song: 2/2, 2/4,
3/4, 4/4, 5/4, 7/4, 6/8, 7/8, 9/8, or 12/8. The default is 4/4, the most commonly used time
signature.

To set the time signature:
In the New Song dialog, choose a time signature from the Time pop-up menu. If you need to,
you can change the time signature later in the Track Info > Master Track window.

Music Theory Tip – About the Key
Each song has a key, which defines the central note to which the other notes in the music
relate.  You can set the song to use any musical key. (Note: Obviously, the Apple programmers
don’t know that much about music theory and key signatures since they have offered such key
choices as D#, instead of Eb.  The note of D# exists but the key of D# does NOT!  They also
have only offered the key of C# but not Db, which both exist in the real musical world!  I guess
it is time to give Apple programmers a lesson on key signatures and enharmonic equivalents.)

To set the key:
1. In the New Song dialog, choose a key from the Key pop-up menu. If you change the

key of a song after recording instruments or adding loops, all Software Instrument
recordings and loops are transposed to the new key. Real Instrument recordings are
not transposed.

2. If you need to, you can change the key later in the Track Info > Master Track
window.

3. Note:  If you are using Apple Loops to create your song, the loop will automatically
be transposed as you drag it into the main GarageBand window according to the key
you selected when setting up your composition.  If you are going to use Real
Instruments for your composition, you should set the appropriate key here before
you begin recording.

GarageBand Main Window Overview
Here’s an overview of the main GarageBand window:
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Figure 2:  GarageBand Main Window

A  Track Headers:  The instrument icon and name are shown on the left of each track’s header.
Click the Mute button (with the speaker icon) to silence the track. Click the Solo button (with
the headphone icon) to hear the track by itself.

B  Track Mixer:  Drag the pan wheel to adjust the pan position of the track (the left-to-right
placement in the stereo field). Drag the volume slider to adjust the track’s volume. Watch
the level meters to see the track’s volume level as you record and play.

C  Timeline:  Contains the tracks where you record Real and Software Instruments, add loops,
and arrange regions. Also includes the beat ruler, which you use to move the playhead and
align items in the timeline with beats and measures.

D  Zoom Slider:  Drag the zoom slider to zoom in for a closer view of part of the timeline, or to
zoom out to see more of the timeline.

E  New Track Button:  Click to add a track below the existing tracks in the timeline.

F  Track Info, Loop Browser, and Track Editor Buttons:  Click to open the Track Info window,
Loop Browser, or Track Editor.
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G  Transport Controls:  Click the Record button to start recording. Click the Play button to
start or stop the song playing. Click the Go to Beginning, Rewind, or Fast Forward buttons
to move the playhead to different parts of the song. Click the Cycle button to turn on the
cycle region.

H  Time Display:  Shows the playhead’s position in either musical time (measures, beats, ticks)
or absolute time (hours, minutes, seconds, fractions). Also shows the song’s tempo.
Includes buttons for changing the format of the time display.

I  Master Volume Slider and Level Meters:  Drag the volume slider to adjust the output
volume level of the song. Watch the level meters to see if clipping is occurring before you
export a song.

Adding Loops for Drum and Rhythm Tracks
You can quickly define the feel of a song by adding Apple Loops. Apple Loops are prerecorded
music files designed to seamlessly repeat a rhythmic pattern. When you add a loop to the
timeline, you can extend it to fill any amount of time, making it easy to create drum parts and
other rhythm parts.
When you add a loop to a song, GarageBand matches the loop’s tempo and key to the tempo
and key of the song. This lets you use loops that were originally recorded at different speeds,
and in different keys, and have them sound as though they were made to be played together.
GarageBand includes a loop browser that lets you find loops by musical instrument, genre, or
mood. You can also perform text searches, and refine your searches for loops in several other
ways. No matter how large your collection of loops becomes, you can quickly find loops with
the sound you want using the loop browser.  A common way to work with loops is to start with
your rhythm tracks (drums, bass, rhythm guitar) and add more loops from there.

To show the loop browser:

1. Click the Loop Browser button (the button with the open eye). The loop browser has two
views: button view and column view. In button view, you click keyword buttons to show
loops that match the keywords. In column view, you choose from different keyword types,
categories, and keywords to show matching loops. In the lower-left corner of the loop
browser are two view buttons you use to select button or column view.

To choose button view or column view:

1. Click the column button to show column view, or click the grid button to show button
view.

Button View of the Loop Browser
In button view, the loop browser contains a set of keyword buttons. Click a button to show
matching loops in the results list. Clicking multiple buttons narrows the results to those loops
that match all of the selected keywords.
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Figure 3:  Button View of the Loop Browser

A  Keyword Buttons:  Click a keyword button to display matching loops in the results list. You
can click multiple keyword buttons to narrow your results.

B  View Buttons:  Click the column button to show column view, or click the grid button to
show button view.

C  Scale Type Pop-Up Menu:  Choose a scale type to see only loops using that musical scale.

D  Search Text Field:  Type text in the field to see loops with the text in their file name or path.

E  Preview Volume Slider:  Drag the slider to adjust the volume of the loop being previewed.

F  Results List:  Shows loops that match the selected keywords. Also displays the tempo, key,
and number of beats for each loop. Click a loop in the results list to preview it. Click the
Favs checkbox for a loop to add it to your favorites.

Column View of the Loop Browser
In column view, the loop browser features columns for keyword type, categories, and keywords.
Click a keyword type to show categories for that type, click a category to show keywords, then
click a keyword to show matching loops in the results list. Clicking multiple keywords expands
the results to those loops matching any of the selected keywords.

Figure 4:  Column View of Loop Browser
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A  Keyword Type Column:  Click a keyword type to show the categories for that keyword type
in the middle column.

B  Category Column:  Click a category to show keywords for that category in the right column.

C  Keyword Column:  Click a keyword to show matching loops in the results list. You can click
multiple keywords to expand your results.

D  View Buttons:  Click the column button to show column view, or click the grid button to
show button view.

E  Scale Type Pop-Up Menu:  Choose a scale type to see only loops using that scale.

F  Search Text Field: Type text in the field to see loops with the text in their file name or path.

G  Preview Volume Slider:  Drag the slider to adjust the volume of the loop being previewed.

H  Results List:  Shows the loops that match the selected keywords. Also displays the tempo,
key, and number of beats for each loop. Click a loop in the results list to preview it. Click
the Favs checkbox for a loop to add it to your favorites.

Timeline Overview
The timeline contains the tracks where you record Real and Software Instruments, add loops,
and arrange regions.  Here’s an overview of the controls in the Timeline (See Figure 5):

A  Beat Ruler:  Shows beats and measures, the units of musical time in the timeline. You can
click the beat ruler to move the playhead to a precise beat or measure.

B  Tracks:  You record Real and Software Instruments in tracks, and drag loops to tracks to add
them to a song. You arrange the song by working with loops and regions in tracks in the
timeline.

C  Playhead:  Shows the point in the song currently playing, or the point where playback starts
when you click the Play button. Also shows where cut and copied items are pasted in the
timeline. You can move the playhead to change what part of the song is playing.

D  Timeline Grid Button:  Choose a note value for the timeline grid, or choose Automatic to
have the value change when you zoom in or out.

E  Regions:  When you record a Real Instrument or Software Instrument, or add a loop, you
create a region in the timeline. You can cut, copy, and paste regions, resize and move them,
transpose them, and make other changes to build the arrangement of the song.
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Figure 5:  Timeline Overview

F  Volume Curves:  Add a volume curve to a track, then add and adjust control points on the
volume curve to add dynamic changes to different parts of a song.

G  Master Track:  You can change the sound of the overall song by adding effects or a volume
curve to the master track.

H  Playhead Lock Button:  Click to unlock the playheads in the timeline and the track editor, so
that you can see a different part of the song in the track editor than in the timeline.

I  Scroll Bars:  Drag the horizontal scroll bar to move to a different part of a song.  Drag the
vertical scroll bar to see tracks not currently visible.

C E D F B
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Software Instruments Track Editor
When you select a Software Instrument track, the track editor shows a graphic display of the
notes in the track or selected region. You can edit individual notes in Software Instrument
regions, fix the timing of notes, and transpose and rename regions. You can also show and edit
controller data, such as pitch bend, modulation wheel, and sustain data, recorded when you
play your music keyboard.

Figure 6:  Software Track Editor

A  Name Field:   When a track is selected, type a new name for the track in the field. When a
region is selected in the timeline, type a new name for the region in the field.

B  Fix Timing Button:  Click to fix the timing of the selected region so that notes move to the
nearest grid position.

C  Zoom Slider:  Drag to zoom in for a closer view or to zoom out to see more of the track.

D  Display Pop-Up Menu:  Choose whether to show notes or controller data in the track editor.

E  Velocity Slider and Field:  Drag the slider to change the velocity of selected notes. You can
also type the velocity value in the field. A note’s velocity reflects how hard the key is
pressed when you play the note.

F  Transpose Slider and Field:  Drag the slider to transpose the selected Software Instrument
region up or down by up to 36 semitones (3 octaves). You can also type the number of
semitones in the field.

G  Beat Ruler:  Shows beats and measures for the area visible in the track editor.

H  Notes/Controller Data Display:  Shows the individual notes of Software Instrument regions
in a graphic format. You can move and resize notes to adjust their pitch, where they start
playing, and how long they play. Shows controller data when chosen in Display pop-up
menu.
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I  Playhead:  Shows the point in the song currently playing.

J  Scroll Bar:  Drag the scroll bar to move to a different part of a track.

Real Instruments Track Editor
When you select a Real Instrument track, the track editor shows the waveform of the regions in
the track. You can rename regions and transpose loop regions (but not recorded Real
Instrument regions) in the track editor.

Figure 7:  Real Instruments Track Editor

A  Name Field:  When a track is selected, type a new name for the track in the field. When a
region is selected in the timeline, type a new name for the region in the field.

B  Zoom Slider:  Drag to zoom in for a closer view or to zoom out to see more of the track or
selected region. Zooming in the track editor is independent of the timeline.

C Transpose Slider and Field:  Drag the slider to transpose the selected Real Instrument region
up or down by up to 12 semitones (1 octave). You can also type the number of semitones in the
field. Only Real Instrument regions created from loops can be transposed.

D  Beat Ruler:  Shows beats and measures for the area visible in the track editor.

E  Playhead:  Shows the point in the song currently playing.

F  Waveform Display:  Shows the waveform of the regions in the track.

G  Scroll Bar:  Drag the scroll bar to move to a different part of the track.
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Using the GarageBand Onscreen Music Keyboard
You can use the GarageBand onscreen music keyboard to play and record Software Instruments.
When you show the onscreen music keyboard, by default it displays a four-octave range of
keys. You can resize the keyboard to display up to 10 octaves.

To play the onscreen music keyboard:

1. Choose Window > Keyboard.
2. Click the notes on the keyboard. You can click when the song is playing, when it is

stopped, or when recording. Clicking a note lower on the key plays the note with a higher
velocity (equivalent to pressing the key harder), and clicking a note higher on the key plays
the note with a lower velocity (equivalent to pressing the key more softly).

To move the keyboard:

1. Place the pointer anywhere in the space above the keys and drag.

To resize the keyboard:

1. Drag the expansion triangle on the lower-right edge of the keyboard window.

To change the range of notes you can play:

1. Click the small triangles to the left or right of the keys. Clicking the triangle to the left
lowers the keys by an octave, and clicking the triangle on the right raises the keys by an
octave.

Connecting a Music Keyboard to your Computer
If you play a keyboard instrument, you can connect a MIDI-compatible music keyboard to your
computer.

To connect a music keyboard to record Software Instruments:

1. If the keyboard is a USB MIDI keyboard, connect the USB cable to the keyboard and to your
computer.

2. If the keyboard is a standard MIDI keyboard, connect the keyboard to a MIDI interface using
standard MIDI cables, and connect the interface to your computer. Be sure to follow the
instructions that came with the keyboard, which may include installing the correct driver on
your computer.
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Adding a Software Instrument Track
To record a Software Instrument, such as a MIDI keyboard, you can add a new Software
Instrument track or record on an existing Software Instrument track.

To add a Software Instrument track:

1. Click the Add Track button, or choose Track > New Track.
2. In the New Track dialog, click the Software Instrument tab.
3. Select an instrument category from the Category list, then select the instrument you want

to use from the Instrument list.

Getting Ready to Record
Once you have connected your music keyboard, there are a few things to check before you start
recording:

1. Make sure your music keyboard is connected to your computer and is working.
2. Select a Software Instrument track and try playing your music keyboard, or clicking notes

on the onscreen music keyboard. You should hear the Software Instrument as you play.

Recording a Software Instrument
Now you’re ready to record a Software Instrument. You can record one Software Instrument
track at a time.

To record a Software Instrument:

1. Click the header of the Software Instrument track you want to record in to select the track.
2. Move the playhead to the point in the timeline you want to start recording.
3. Choose Control > Count In to have the metronome play a one-measure count-in before

recording starts. You can also set the playhead a few beats before the point where you
want the music to come in to make it easier to start on the beat.

4. Click the Record button to start recording.
5. Start playing your music keyboard, or clicking notes on the onscreen music keyboard

(Command-K).  As you record, a new region appears in the selected Software Instrument
track.

6. When you are finished, click the Record button again to stop recording. Click the Play
button to stop the song playing.

7. After you record, you can listen to your new recorded part to see how you like it.
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To hear the new recording:

1. Move the playhead to the point in the timeline where the new region starts (align it with the
left edge of the region). You can also move the playhead to an earlier point in the song, or
to the beginning of the song, to hear the new recording in the context of the song.

2. Click the Play button, or press the Space bar.

Recording a Software Instrument With the Cycle Region
GarageBand lets you record over a specific part of a song. Musicians sometimes call this
“punching in” and “punching out”, and call the points where you start and stop recording
“punch points”. You can record a Software or a Real Instrument using a cycle region.  When you
record with a cycle region, you can keep recording for as many times as the cycle region
repeats. Each new cycle is merged with the region created the first time through the cycle
region.  To record over a specific part of a song, you set the cycle region in the timeline.

To set the cycle region:

1. Click the Cycle button. The cycle region appears as a yellow strip just below the beat ruler.
2. Move the cycle region to the point in the timeline you want to start recording, then drag the

end of the cycle region to the point in the timeline you want to end recording. You can drag
in the cycle region ruler (below the beat ruler) to move the cycle region to a new part of the
timeline.

3. You may want to have the cycle region start a few extra beats before the point where you
want to start recording, to make it easier to start playing on the beat, and end a few beats
after you want to stop recording, in case your last note extends past the end of the cycle
region.

To record using a cycle region:

1. Select the track you want to record in.
2. Click the Record button, then click the Play button to start recording.
3. Play your musical instrument or sing into your microphone. As you record, a new region

appears in the selected track.
4. Real Instruments only record the first time through the cycle region. When the cycle region

repeats, you hear the newly recorded region.
5. When you are finished, click the Record button again to stop the cycle region.
6. When you have finished using the cycle region, click the Cycle button again to turn it off.
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MIDI Overdubbing
When you record instruments in a looped GarageBand track, you can continue to add to your
recording as the track loops (this technique is called overdubbing ).  To build a drum track one
drum at a time, for example, first lay down the beats for the bass drum.  On the next pass,
press the key assigned to the snare drum to overdub the bass-drum sound.  On subsequent
passes, add the hi-hat, tom-tom, and cymbal sounds.  GarageBand can also overdub some
controller data, such as Pitch Bend and Modulation wheels on a MIDI keyboard.

Changing Software Instrument Settings
When you create a Software Instrument track, you select an instrument for the track in the New
Track dialog. You can change the instrument in the Track Info window and also add and adjust
the instrument’s effects.

To change the instrument for Software Instrument track:

1. Select the track, then click the Track Info button to open the Track Info window.
2. Select an instrument category from the list on the left, then select a track instrument from

the list on the right.
3. The output of a Software Instrument is always stereo.

Editing Software Instrument Regions
You can edit individual notes in Software Instrument regions, and can edit “controller”
information recorded when you move the pitch bend wheel or modulation wheel on your music
keyboard (most music keyboards include these two controls), or use a sustain pedal.

Editing Individual Notes in a Software Instrument Region:

You can edit individual notes of a Software Instrument region. When you view the region in the
track editor, individual notes in the region are displayed in a graphic format:

1. The left edge of the note shows the point in the timeline it starts playing.
2. The width of the note shows how long it plays.
3. The vertical position of the note shows its pitch, in relation to the piano keyboard displayed

vertically along the left edge of the track editor.
4. You can drag notes to a new starting point, resize notes to shorten or lengthen how long

they play, and drag notes up or down to a different pitch. You can also select multiple
notes and edit them at the same time.
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5. Note: To edit notes in the track editor, you may need to zoom in so that the notes are large
enough to select and edit.

To edit notes in a Software Instrument region:

1. Drag the note left or right to a new starting point. You can use the beat ruler in the track
editor to align the note with a specific beat or measure.

2. Drag the lower-right corner of the note to resize it.
3. Drag the note up or down to raise or lower its pitch. Use the piano keyboard along the left

edge of the editor to see the pitches.
4. You can also select multiple notes in the track editor, and edit them at the same time.
5. To select multiple notes: Shift-click or Command-click the notes you want to select.
6. You can also select multiple notes by dragging from a point before the first note to a point

after the last note, enclosing the notes you want to select.
7. When you edit multiple notes, each note is changed by the same amount. For example, if

you select several notes and drag them to a new starting point, each note is moved by the
same number of beats. If you resize several notes at the same time, each note is shortened
or lengthened by the same amount. If you drag several notes up or down to a different
pitch, each note is changed by the same number of semitones.

Connecting Real Musical Instruments to Your Computer
Some microphones can be connected to your computer using the audio in port, if your
computer has one. You can also connect microphones and instruments using an audio
interface.  Some audio interfaces let you connect multiple microphones or instruments to your
computer and record them on different channels. Audio interfaces are available in a variety of
formats, including USB, FireWire, PC card, and PCI formats. If you plan to use an audio interface,
be sure your computer supports the format of the interface.
You may also want to connect speakers or monitors to your computer to hear your songs play
back with greater audio quality than possible from your computer’s speaker. A variety of
monitors and speakers are available, including speakers you can connect directly to your
computer's audio out port, through a USB port, or using an audio interface.

If you connect an audio interface to your computer, you set the audio interface as the audio
input device for GarageBand. Before setting the audio input device, be sure to install any
necessary driver software for the audio interface.

To set an audio interface as the audio input device:

1. Choose GarageBand > Preferences, then click the Audio/MIDI Interfaces tab.
2. In the Audio/MIDI Interfaces pane, choose the audio interface from the Audio Input pop-

up menu.
3. If you connect a microphone, an instrument, or other audio device directly to your

computer’s audio-in port, you set may need to configure input settings for it in the Sound
pane of your computer’s System Preferences.
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To configure input settings in System Preferences:

1. Choose System Preferences from the Apple menu, then click the button for Sound
Preferences.

2. In the Sound Preferences pane, click the Input tab.
3. Select Line In from the sound input devices list, then drag the Input volume slider to set

the input level.

Adding a Real Instrument Track
To record a Real Instrument (such as a guitar or vocal), you can add a new Real Instrument track
or record on an existing Real Instrument track.  To connect an electric guitar or a professional
microphone, you’ll need additional hardware.  Apple sells the $19 Monster Instrument Adaptor,
which converts a guitar’s 1/4 inch jack plug to a standard 1/8 inch minijack plug that you
connect to your Mac’s analog audio-in port; however, you can pick up a similar adaptor at your
local Radio Shack for less than $5.  Although this is all you need to get your guitar sound into a
Mac, for optimal sound levels and quality, you may want to invest in a preamplifier such as M-
Audio’s $180 MoblePre USB.

To add a Real Instrument track:

1. Click the Add Track button, or choose Track > New Track.
2. In the New Track dialog, click the Real Instrument tab.
3. Select an instrument category from the Category list, then select an instrument from the

Instrument list.
4. Select the input format by clicking either the Mono or Stereo format button, then choose

the input channel from the Input pop-up menu. If the instrument you are recording has a
single input, choose the Mono format. If the instrument has left and right inputs, choose
the Stereo format.

Getting Ready to Record
Once you have connected your instrument and added a track to record in, there are a few things
to check before you start recording:

1. Make sure the microphone or instrument is connected properly and is working.
2. Make sure the correct audio drivers are selected in the Audio/MIDI Interfaces pane of

GarageBand Preferences.
3. Open the Track Info window to make sure the instrument has the instrument and effects

settings you want, and is using the correct input channel (or pair of channels).
4. Sing or play a few notes and watch the track's level meters in the track mixer to make sure

the track is receiving input, and isn't clipping. If the red dots at the right of the level meters
(called clipping indicators) light up, try dragging the volume slider to the left a little to
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lower the input volume.  Click on the red dots to turn them off and try again.
5. You may want to set the song tempo and key before recording a Real Instrument.  Note:

Real Instrument recordings are fixed in tempo and key, unlike loops and Software
Instrument recordings, and cannot be changed after they are recorded.

Monitoring Real Instrument Input
Hearing your instrument while you play and record is called monitoring.  When you create a
Real Instrument track, you can turn on monitoring for the track in the New Track dialog. You
can turn monitoring on or off in the Track Info window.

To turn on monitoring for a Real Instrument track:

1. Select a Real Instrument track, then click the Track Info button to open the Track Info
window.

2. Click the Monitor On button to turn on monitoring, or click the Monitor Off button to turn
off monitoring.

3. Turning on monitoring can produce feedback (loud, sharp noise) if the audio input picks up
the sound being output through your speakers. This is the reason monitoring is off by
default. You may want to turn off monitoring for a Real Instrument track when you are not
singing into the microphone or playing the instrument connected to the track.

Changing Real Instrument Settings
When you create a Real Instrument track, you select an instrument for the track in the New
Track dialog. You can change the instrument in the Track Info window, and also change the
effects and input settings.

To change the instrument for a Real Instrument track:

1. Select the track, then click the Track Info button to open the Track Info window.
2. Select an instrument category from the list on the left, then select a track instrument from

the list on the right.

Track Info Window Overview
The Track Info window shows the current instrument and effects settings for the selected track.
You can change these settings in the Track Info window. Some controls in the Track Info
window are different for Real Instrument tracks than for Software Instrument tracks (as noted
below).
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Figure 8:  Track Info Window
J

D G H I

 A  Instrument Category List:  Click an instrument category to see the instruments for that
category in the instrument list.

B  Instrument List:  Click an instrument from the list.

C  Instrument Icon Pop-Up Menu:  Click to choose an instrument icon from the icon menu.

D  Details Triangle:  Click to show the instrument, effects, and channel settings.

E  Effect Checkboxes, Sliders, and Pop-Up Menus:  Click an effect checkbox to turn the effect
on or off.  Drag the sliders to adjust the level of the effects, or choose an item from the
pop-up menus. The Track Info window includes the following effects for Real and Software
Instruments:
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Noise Gate Slider (Real Instrument tracks only):  Drag the slider to adjust the amount
of gating.
Module and Module Setting Pop-Up Menus (Software Instrument tracks only-not
pictured):  Choose an instrument module (preset) from the menu.
Compression Slider:  Drag the slider to adjust the amount of compression.
Equalizer Pop-Up Menu:  Choose an EQ setting from the pop-up menu.
Effect and Effect Setting Pop-Up Menus:  Click a checkbox to turn additional effects
on or off. Choose an effect from a pop-up menu on the left, then choose an effect
preset from the pop-up menu on the right.
Echo Slider:  Drag the slider to adjust the amount of echo.
Reverb Slider:  Drag the slider to adjust the amount of reverb.

F  Input Channel Pop-Up Menu and Buttons (Real Instrument tracks only):  Choose the
input channel or channels for the instrument from the pop-up menu. Click the Mono button
for an instrument with mono (single) output, or click the Stereo button for an instrument
with stereo outputs. Click the Monitor On button to turn on monitoring for the track, or
click the Monitor Off button to turn off monitoring.

G  Save Instrument and Delete Instrument Buttons:  Click the Save Instrument button to
save an instrument. Click the Delete Instrument button to delete a saved instrument.

Mix Down
After you have all the tracks you want, you can tweak both volume and panning (left to right)
settings by track, add and change effects, and more.  In all, you can layer 64 instrument tracks,
and even more for digital audio.  Be sure to check for clipping and lower the volume of the
tracks if necessary to avoid distortion.

Saving Your File
GarageBand will save your file with a .band extension.  To save your file, select File > Save As
and type a name for your song.  The default save location is Home > Music > Garage Band.

Exporting to iTunes
You can export a song to an iTunes playlist, then play your exported songs in iTunes, download
them to an iPod, or burn the playlist to a CD.  GarageBand will mix all your tracks down to a 2-
track (stereo), 16-bit, 44.1 kHz AIFF file – a full CD-quality song. Although the default is AIFF
format, you can convert the exported file to another format, such as AAC or MP3, from within
iTunes or keep it as full quality to burn to a CD.
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To export your GarageBand File:

1. Choose File > Export to iTunes. The entire song, from the beginning (measure 1) to the
end of the last region, is exported.

2. If the cycle region is turned on when you export the song, the part of the timeline from the
start to the end of the cycle region is exported.

3. You can set the name of the iTunes playlist to which files will be exported, and also set the
name of the album and composer, in the Export pane of GarageBand Preferences.

Some Great URLs to Know About
Here are just some of the hundreds of URLs associated with GarageBand.  Check them out:

http://www.apple.com/ilife/garageband/   

http://www.apple.com/support/garageband/   

http://discussions.info.apple.com/webx/garageband/   

http://www.apple.com/ilife/garageband/hottips/   

http://www.macjams.com/   

http://www.samples4.com/   

http://www.musiconthemac.com/   

http://www.macjukebox.com/   

http://www.icompositions.com/   

http://www.macband.com/   

http://www.musicmakingtools.com/   

http://www.garageband.com/   

http://thegaragedoor.com/   


