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Preface
This workbook is a beginner’s tutorial for web content authors. It describes how 
to use Macromedia Contribute to maintain the content of your website by editing 
existing pages and adding new ones.

Arthur Wilson 
Shona Matchett

February 2009

Copyright © IS 2009

Permission is granted to any individual or institution to use, copy or redistribute this 
document whole or in part, so long as it is not sold for profit and provided that the 
above copyright notice and this permission notice appear in all copies.

Where any part of this document is included in another document, due 
acknowledgement is required.
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This course will show you how to create new and edit existing web pages using 
Macromedia Contribute 3.

Who should attend this course
This course is intended for staff and postgraduates at Edinburgh University who 
wish to create and edit basic web pages. 

Course prerequisites
Attendees should be able to use a Windows or Macintosh operating system and 
should have keyboard skills.

Course structure 
Each section in the course will introduce a topic or activity and will include a 
demonstration. Once you have read each section and followed the presentations, 
you can go on to the practical exercises where you will use Contribute to complete 
an editing task. 

Course format 
This workbook contains notes on using Contribute as well as practical exercises that 
you will work through under the supervision of the course tutor.

The course tutor will talk you though each section of the course and demonstrate 
the various tasks you will be expected to carry out when creating content using 
Contribute. 
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About Contribute
Contribute is an application that runs on your desktop computer that you can use to 
browse the web, edit existing pages and create new ones. 

When you browse to a page that you have permission to edit you can Connect to 
that web page. When you connect to a web page using Contribute you GET the web 
page from the website. That is, a web page file is copied from the web server to your 
desktop computer.

Once you have got the web page with Contribute, you can choose to EDIT the page 
with your changes and then PUBLISH the page back onto the server.

Different types of Contribute users
The website administrator can set up different roles for different Contribute users.

A Contribute administrator is usually the owner of the website, and will create the 
folders and files that go to make up the site. The administrator will decide who can 
edit content on the website and which pages they are allowed to change.

If you are unsure who your website administrator is, contact the person who gives 
you computing support, such as your User Support Team.

A Contribute content editor will update pages and add new pages to the website. 
There are two categories of editor: the Publisher who can create, edit and also 
publish pages, and the Writer who can create and edit pages, but cannot publish. 
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You will normally start Contribute by choosing All Programs > WWW > 
Macromedia > Macromedia Contribute 3 from the start menu. You may also find 
that a Contribute icon similar to the one below is available on your desktop. 

If you cannot find Contribute in any of these locations then contact the person who 
gives you technical support.

Set a security password and encryption 
The first time you use Contribute you will need to set a security password and also 
set all your connections to be encrypted. This will prevent an unauthorized person 
from getting access to your Contribute application and your websites.  

Keep your password safe. Choose a password that people are unlikely to guess. 
See http://www.ucs.ed.ac.uk/passwords.html for further guidance.

Note: Please note that if you forget your password, you will need to delete your 
connections and re-establish them as detailed in exercise 2, Connect to a 
website. Contact your website administrator or user support team for assistance 
with this.

To set up your security, you would:

Choose •	 Edit > Preferences.

This will present you with the Preferences dialog box:

Choose •	 Security from the panel on the left.
At the •	 Security dialog, check the Encrypt connection information for all 
websites and Require password at startup boxes.
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Enter and confirm your password.•	
Click on the •	 OK button.
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Before you can edit web content using Contribute, you need to connect to a website. 
You do this by either:

Using a connection key given to you by your website administrator, or •	
Creating a connection manually between Contribute and your web space.•	

Using a connection key
To connect to a website using a connection key, all you need to do is click on the 
file sent to you by the website administrator. Contribute will make the connection for 
you.

You only need to use the key once. From then on the website will be listed under 
Begin editing my websites on the Contribute Start Page.

Creating a connection manually
If you don't have a connection key you can create a connection manually.  To do this 
you will need details of the host name where your web space is located, the user 
account that owns the website, the account password and the path where your web 
content is held.

Note: We recommend that you consult with your website owner/administrator 
before attempting to create a manual connection.

List of 
websites
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Exercise 1:  Secure your copy of Contribute

What you will do
Secure your copy of Contribute with a password so that only you can update your 
website. 

Ensure that communications between Contribute and the web server are secure.

How you will do it
You will start Contribute, access the security dialog box, and set a start-up 
password. Through the same dialog box, you will choose to encrypt your connection 
information.

Now you do it
Choose ÂÂ Start > All Programs > WWW > Contribute > Macromedia 
Contribute 3. (Note that this may not reflect where Contribute has been installed 
on your own machine.)

Choose ÂÂ Edit > Preferences and the Preferences dialog box will appear as 
shown below:

Choose the ÂÂ Security option from the panel on the left.

The Security dialog will appear:


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Click the ÂÂ Encrypt connection information for all websites and the Require 
password at startup boxes.

The password fields become enabled.

Enter your password in the ÂÂ Password and Confirm password text entry boxes.

Click on the ÂÂ OK button.

You will get a message warning you that if you lose your password you will need 
to re-establish your connections.

Click on the ÂÂ OK button.

You will then be told that your password and connection information has been 
successfully encrypted.

Click on the ÂÂ OK button.

You will now be prompted for this password whenever you start Contribute. 

Note: Unless you supply the correct password, your connections will be 
unavailable. Note also that if you have to reset your password (for example, 
because you have forgotten it), you will need to delete your connections then 
re-establish them as detailed in exercise 2, Connect to a website. If you 
have problems with re-establishing your connections, contact your website 
administrator or your User Support Team.
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Exercise 2:  Connect to a website 

What you will do 
Using the key given to you by the course website administrator, you will connect to a 
website with Contribute.  

How you will do it
You will browse to the My Documents\ContributeKeys folder and open the key 
named ContributeCourse.

Now you do it
Open your connection 

Click on ÂÂ start, select My Documents and browse to the folder ContributeKeys.

Double-click on the file ÂÂ ContributeCourse. You will be presented with the 
Import Connection Key dialog box. (You may have to click on the Macromedia 
Contribute icon on the taskbar to see the dialog box.)

Replace the entry in ÂÂ What is your name with your own name and enter your 
e‑mail address.

Enter the password.ÂÂ

This is a specific password for this particular connection key. For this course, it 
has been set to "admin".

Click on the ÂÂ OK button.

You will be presented with the home page for the website you have connected to. 
For the purposes of this course, we have created a website for you. This website 
will contain all the files needed to complete the practical exercises.


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Once you have made your connection to a website, its home page will be displayed. 
You can navigate through the site as you would in a normal web browser using links 
and the buttons on the toolbar.

To edit a particular page, browse to it and click on the Edit Page button on the 
toolbar. 

The page layout will change. You will be able to edit certain areas while others will 
be locked. Editable areas display within blue boxes with the name of the area at the 

top left. The cursor will display as the normal insert type  when you move over 

editable areas, but will change into a black circle with a diagonal line through it  
when you move over locked areas.

The toolbar also changes to display a range of editing tools.

When you have finished editing the page you can put it back on the server by 

clicking on the Publish button .

Locked area 
marker

Editable areas



Editing web pages with Contribute

13

C
reating content
Creating a new page
To create a new page using Contribute, click on File on the menu bar and choose 

New Page, or click on the New Page button . You will be presented with 
the New Page dialog box. 

You can create a new blank page, or one based on an existing page, a pre-designed 
web page template or a sample (starter) web page. 

Note: If your website administrator has restricted the types of new pages that you 
can create you won’t see all of these options.

Once you have selected the type of page, enter a page title and click on the OK 
button. 

Your new page is displayed and the page editing tools become available.

Click Publish to save your new page. The Publish New Page dialog box displays.

Contribute will enter the page title in the Filename box. You can change this if you 
wish. The file extension (htm or html) will be added automatically. 

Note: The page title appears in the application bar of the web browser when the 
page is opened. Contribute also lists pages by title, not by filename, when you 
use the Pages panel or carry out actions such as creating links. See the section 
Page titles: good practice on page 14 for guidance on composing titles.
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Note the web address shown below the Filename box. By default, Contribute will 
save the new page to the same location as the page you were viewing when you 
clicked New Page. You can save your new page to a different folder by clicking on 

the Choose Folder button. To create a new folder, click on the New Folder icon  
enter a name and click OK. Then click on the Select "foldername" button and on 
Publish to finish. 

Contribute warns you if you have not created a link to the new page. After you have 
published it, remember to link to it from an existing page so that your readers can 
see it.

Note: It is important to consider how you are going to organise the pages in your 
website. You should group related information together in separate folders rather 
than simply saving all your pages to the same location. For example, the website 
used for this course contains a meetings folder with the sub-folders jcmb and 
library. 

If you are not sure how to organise your pages, contact your website 
administrator. He or she will be able to advise, and may already have defined a 
structure for your site. 

Page titles: good practice
How page titles are used

The text you supply for a page title doesn't appear in the browser window itself, but it 
will display in the bar at the top, as in the example below.

The title is also used when readers add your page to their bookmarks or favourites. 
For example, if you added this page to your Favourites in Internet Explorer, it would 
appear like this: 

Search engines such as Google assume that the page title reflects the page content 
and so will extract keywords from it. When a page is found by a search engine, it is 
the title that is displayed in the list of pages that match the submitted keywords. For 
example:

Note: See the section File names: good practice on page 15 for advice on 
choosing a file name.
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Page titles are also very important for people who need to use assistive 
technologies such as talking browsers. The page title is announced whenever a 
talking browser user moves between pages. If the title doesn't describe the content 
of the page, or it is meaningless (for example, "home page" or "untitled"), or if the 
same title is used for every page, the site will be unusable. If you do not use the title 
element properly your pages may fail the W3C WAI accessibility guidelines.

Guidance on composing suitable page titles

Think about:

How you would like your page to appear in search engine results •	
How you would like your page to be recorded in a user's browser bookmarks/•	
favourites 
If the page title was to be read out by a screen reader, what you would like it to •	
say 

You need to provide as much information as possible, but not too much otherwise 
search engines may choose to ignore it. Try to limit your page titles to 64 characters.

It is also good practice to include primary and secondary information, for example 
"Page title composition – Web publishing good practice guide" or "Middle East 
Report – World Affairs – CNN News".

Editing a page title

You can change the title of your page after you have created it. With the page in edit 
mode, click on Format on the menu and choose Page Properties. The dialog box 
opens at the Title/Encoding category. 

Make your changes and click OK.

File names: good practice
When choosing a name for your file, you should follow the University's standard 
conventions. You will find full details at http://www.recordsmanagement.
ed.ac.uk/InfoStaff/RMstaff/RMprojects/PP/FileNameRules/
FileNameRules.htm
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Keep file names short but meaningful, and do not use invalid characters such •	
as * ?. Long file names mean long file paths and long URLs which increase the 
likelihood of error, and are more difficult to remember and recognise.

Use capital letters to delimit words, not spaces or underscores. This is because •	
some software has difficulty recognising file names with spaces, and using 
spaces or underscores increases the length of the name.

When entering a date, use the order: year, month, day. Use four-digit years and •	
two-digit months and days, e.g. 20070405.

Pages relating to recurring events such as meetings should include the date and •	
a description of the event. 

Adding keywords and descriptions
Keywords

You can add keywords to your page so that search engines can find it. If you include 
keywords it improves the chances of your page matching a search query. Make 
sure they are directly related to the material on the page and remember to include 
synonyms.

To add keywords, click on Format and choose Keywords and Description. The 
Page Keywords and Description dialog box displays.

Enter your keywords, separated by a space and click OK.

Description

The "description" is a summary of your page that appears in a list of search results. 

Search engines may generate this automatically from the first paragraph of the 
page. It is better, however, to enter your own summary in the Page Keywords and 
Description dialog box to help readers decide if your page is what they are looking 
for. 

Page description
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Inserting a Word document
You can use Contribute to convert Microsoft Word documents into web pages by 
inserting the text. You may find that once you have inserted the Word document you 
will need to use the Contribute editing tools to tidy up the layout. 

To insert a Word document you would:

Create a new page.•	
At the •	 Insert menu, choose Microsoft Office Document.
Browse to the Word document you wish to insert.•	
Click •	 Open.

You will be presented with a dialog box asking how you would like to insert this 
document:

 

Choose to insert the contents of the document into the existing page. This option •	
is recommended rather than creating a link, which requires your readers to have 
the appropriate software installed.
Click on the •	 OK button.

Note: The option to insert Word documents should only be used if the document 
has a simple layout. Ideally, it should also have Word's Heading styles applied to 
the text. If the document is complex, using Insert > Microsoft Office Document 
may produce erratic formatting. If this is the case, copy the text from the 
document and paste it into your page using the option Edit > Paste as text only. 
Use Contribute's editing tools to apply formatting.  
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You can insert images into your page from your computer or from a folder on your 
website.

To insert an image:

Edit the page.•	
Place your cursor where you want the image to appear.•	
At the •	 Insert menu, choose Image.
Choose •	 From My Computer or From Website.
Browse to the image you wish to insert.•	
Click •	 Select.

Contribute displays an image editing toolbar.

.
Note: To resize an image, you must first click on the Resize icon , then drag a 
selection handle.

About images
Type and size

Images for the web are normally in GIF (Graphics Interchange Format), JPEG (Joint 
Photographic Experts Group) or PNG (Portable Network Graphics) format. These 
are "compressed" formats, i.e. the number of colours is restricted to keep the file 
size low. You should avoid using uncompressed image files wherever possible. 
Remember that if a page takes a long time to load your readers will lose interest and 
go elsewhere. 

Your administrator may also have set limitations on the size of images that you can 
insert. Even if there is no restriction, you should ensure that your image is not so big 
that your viewers have to scroll to see it in full. 

Tip: If you have a large image you think your readers should see in full, create a 
small version (called a thumbnail) using an image editing package, and link this to a 
page containing the full size image. Your readers can then choose whether to load 
the page or not.

Note that some file types, for example, TIFF, are not supported by all web browsers 
and should not be used.

Accessibility

To make your pages more accessible, enter a description for your image that can be 
read by tools for people with visual disabilities.

To enter a description:

Select the image.•	
At the •	 Format menu, choose Image Properties. 
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•	 Type the text in the Description (ALT text) box.
Click •	 OK.

Copyright

Bear in mind that although an image appears on the internet, it may not be freely 
available. If you use an image without permission you may be breaching copyright. 
Check before copying, and if in doubt, do not use it. 
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What you will do 
Add details of a new Health and Safety Committee meeting to be held in the Main 
Library building.

How you will do it 
Insert a new row into a table, and in each cell add details about a forthcoming Health 
and Safety meeting.

Now you do it 
From the Computing Services - Health and Safety home page, click on the link to ÂÂ
Main Library (under EUCS Health and Safety Committee Meetings).

Click on the ÂÂ Edit Page button at the top left of the application window.

Contribute will change into editing mode, the editing tools will become available, 
and the editable areas will be highlighted.

Move the cursor to the last cell of the "Agenda, minutes and papers" table and ÂÂ
click just after the word “papers”.

Press the TAB key.ÂÂ

A new row will be added to the bottom of the table.

Enter the date of the forthcoming meeting (“29 July 2008”) in the first cell and the ÂÂ
words “agenda” in the second, “minutes” in the third and “papers” in the fourth.

Click ÂÂ Publish to put the updated file back on to the website.

You will be told that you have successfully published your page.

Click on the ÂÂ OK button.

Contribute will change back to browse mode, and the amended page will be 
displayed.


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Exercise 4:  Add a new page

What you will do
Create a new agenda for a forthcoming Health and Safety meeting. 

How you will do it
You will create a new web page, insert a Microsoft Word document then tidy up and 
publish the new page. 

Now you do it
From the ÂÂ Main Library Health and Safety Committee meetings page, click on 
File and choose New Page, or click the New Page button.

Choose ÂÂ Default from the list of templates in the Contribute course website.

In the ÂÂ Page title box, enter “EUCS Main Library Health and Safety Meeting 
Agenda - 29/07/2008”.

Click on the ÂÂ OK button.

The new page will be created and opened for editing.

Select the text ÂÂ Put the main content of the page here.

From the ÂÂ Insert menu, choose Microsoft Office Document. 

Browse to the file ÂÂ Agenda 29072008.doc in the My Documents\Word and 
Excel documents folder.

Choose this file and click ÂÂ Open.

You will be presented with the Insert Microsoft Office Document dialog box.

Select the ÂÂ Insert the contents of this document into this page option.

Check the ÂÂ Remember this setting and don’t ask again box. This sets the 
option as the default setting. If you want to change the default at a later date, 
Select Edit > Preferences and choose Microsoft Documents.  

Click on the ÂÂ OK button.

The MS Word document text is converted to HTML.

Use the Contribute formatting tools to tidy up the layout, for example, apply ÂÂ
heading styles.


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button.

You will be given a warning saying that there is no link from any other page on 
the website to this new file.

Click on the ÂÂ Yes button.

You will be asked to give the file a name:

Call the file ÂÂ 20080729agenda.html. Note the web address – Contribute will 
save the new page to the same folder as the Main Library Health and Safety 
Committee meetings page.

Click on the ÂÂ Publish button.

You will be told that the page has been published successfully.

Click on the ÂÂ OK button.

Note: In this exercise you inserted a very simple Word document. See the course 
notes on page 17 for advice on including text from more complex documents.   
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Exercise 5:  Create links between the pages 
you have created

What you will do
Create a link to a web page. 

How you will do it
You will select the word “Agenda” in the Health and Safety meetings table and set 
up a link to the new agenda that you created in the previous practical exercise. 

Now you do it
If you are not already at the ÂÂ Main Library Health and Safety Committee 
meetings page, click on the Back button until you reach it.

Click on the ÂÂ Edit Page button.

Select the word “agenda” in the second cell of the third row (for the meeting of 29 ÂÂ
July 2008).

From the ÂÂ Insert menu, choose Link, and from the pop-out sub-menu, choose 
Drafts and Recent Pages.

Choose the page entitled ÂÂ EUCS Main Library Health and Safety Meeting 
Agenda - 29/07/2008.

Remember that Contribute displays page titles when listing drafts and pages, not 
file names.  

Click on the ÂÂ OK button.

Click on the ÂÂ Publish button.

You will be presented with the You have successfully published your page 
dialog box.

Click on the ÂÂ OK button.

Browse through the information and check the link you created to the new ÂÂ
agenda.


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What you will do
Add more content to the Health and Safety website. 

How you will do it
You will use Contribute to: 

Create a new page.•	
Insert Microsoft Office documents.•	
Add a table and enter data.•	
Insert images, edit their alignment and add alternative text.•	
Insert a list.•	
Save and publish the page.•	
Create a link to the new page you have just created.•	

Now you do it
Create a new page 

Choose ÂÂ File > New Page or click on the New Page button.

Create a page based on the ÂÂ Default template.

Replace ÂÂ <Enter Title> with “EUCS Health and Safety Committee Information”.

Click on the ÂÂ OK button.

Insert a document

You will insert the data from a Word and an Excel document.

Delete the default text and insert the Microsoft Office Word document called ÂÂ
Health and Safety Policy_styles from the folder My Documents > Word and 
Excel Documents. (if you can't see the document, change the Files of type to 
"Microsoft Word document".)

Click in the paragraph after the heading "Actions" and insert the Microsoft Office ÂÂ
Excel document called HSActions from the folder My Documents > Word and 
Excel Documents. (Change Files of type to "Microsoft Excel document".)

Set all the borders to 1 pixel (choose ÂÂ Table > Select Table, then Table > Table 
Properties).

Insert a table

You will insert a table with 5 rows and 3 columns. This table will contain the date of 
the meeting, location and the name of the person who will take the minutes.

Create a new paragraph after the Excel data table.ÂÂ

Type the text "Meetings". Format this with the style Heading 2.  ÂÂ

In the next paragraph, choose ÂÂ Table > Insert > Table.

Create a table with 5 rows and 3 columns.ÂÂ


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Set the specific width of the table to be 100% (ÂÂ Hint: you are setting the width as 
a percentage of the page rather than a fixed pixel width). 

Choose the top row to be the header (click on the ÂÂ Top icon in the Header section  

).

Click on the ÂÂ OK button.

An empty table will be created with 4 rows and 3 columns.ÂÂ

Enter “Date”, “Location” and “Minute recorder” into the 3 cells of the top row.ÂÂ

Complete the table. Here is some sample data:ÂÂ

14th June 2008, Main Library, John Smith
15th July 2008, Kings Buildings, Fred Bloggs
3rd August 2008, Holyrood, Harry Jones
23rd December 2008, Main Library, Jack Jones

Create a link from the name of the person taking the minutes to their email ÂÂ
address (choose Insert > Link > Email Address). 

Adjust the width of the columns.ÂÂ

Centre the text in the ÂÂ Date column.

Add images

You will insert two images and adjust them.

Click in the paragraph after the heading "What we do".ÂÂ

With the cursor in the blank line, choose ÂÂ Insert > Image > From My Computer.

Navigate to ÂÂ My Documents > Contribute > Images and select the file 
studentguidance.

In the next line, insert the image called ÂÂ resourceguidance. 

Make the images bigger (use the ÂÂ Resize button on the toolbar ). How would 
you resize the images proportionally?

Centre the images on the page (use the alignment buttons on the toolbar).ÂÂ

Give the images some alternative text (double-click on the images and enter a ÂÂ
text description in the Description (ALT text) box).

Create a list

Turn the entries under the heading "On Discovering a Fire" into a bulleted list.ÂÂ

Add another bullet point with the text " Leave the building and proceed to the ÂÂ
relevant assembly point". 

Publish the page

Click on the ÂÂ Publish button.

You will be told that the page is not linked to from any other page on the website. ÂÂ
Click Yes.
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Create a new folder called "Information" and click the ÂÂ Select "Information" 
button at the bottom of the window.

Give the page the filename ÂÂ policyinformation.html and publish it.

Create a link to the page from the Health and Safety home page 

Go back to the Computing Services – Health and Safety home page and click ÂÂ
Edit Page.

Add an entry to the bulleted list with the text "Policy information", and create ÂÂ
a link from the entry to your new EUCS Health and Safety Committee 
Information page.

Re-publish the home page.ÂÂ
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Exercise 7:  More about links

What you will do
Create a table of contents for the EUCS Health and Safety policy document.

How you will do it
You will create a bulleted list at the top of the page containing a list of the main 
section headings. You will then create section “anchors” and links to these anchors.

Now you do it
Browse to the ÂÂ EUCS Health and Safety Policy page.

Choose to edit the page.ÂÂ

Select and copy the first section heading “1. Statement by Director of Computing ÂÂ
Services”.

Paste this text on a line on its own just after the “EUCS Health and Safety Policy” ÂÂ
main heading.

Note: If the copied text retains the same formatting as the section heading, 
highlight the text, click on the Style drop down (below the Publish button), and 
select Normal.   

Make this a bulleted list and remove the number from the text.ÂÂ

Repeat this for every section of the document.ÂÂ

This will create a list of items that can be use as a table of contents for the 
document.

Select the first section heading again and choose ÂÂ Insert > Section Anchor.

When prompted for a name for this anchor, give it a name that relates to the ÂÂ
section heading, e.g. “Statement” for section 1, "Organisation" for section 2 etc. 
Note that anchor names cannot begin with a number or contain spaces.

A flag  is inserted before the heading to indicate the anchor.

Select the line in the table of contents that relates to the section now containing ÂÂ
the anchor.

Choose ÂÂ Insert > Link > Drafts and Recent Pages. 

From the ÂÂ Insert Link dialog box, choose the “Computing Services Health and 
Safety Policy” page.

Click on the ÂÂ Advanced button. More link options become available.

From the ÂÂ Section Anchor drop down menu, choose, “Statement”.

Click on the ÂÂ OK button.



Note: See the section Page titles: good practice on page 14 for guidance on 
composing titles.
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Publish the page and check that all the links work.ÂÂ
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Exercise 8:  Editing page titles, adding 
keywords and descriptions

What you will do
Edit the pages you created in the previous practical exercises to create more 
suitable titles. Add descriptions and keywords to assist searchers.

How you will do it
You will edit the Page Properties and Page Keywords and Description for each 
page.

Now you do it
Edit the page title

Browse to the Health and Safety – Computing Services home page and click on ÂÂ
the Edit Page button.

On the ÂÂ Format menu, choose Page Properties or click on the Page Properties 

button on the toolbar .  

The Page Properties dialog box appears.

Change the title to "Health and Safety home page – Computing Services". ÂÂ

Click ÂÂ OK. 

Re-publish the page.ÂÂ

Click on the link "EUCS Health and Safety Policy" on the home page and change ÂÂ
the page title to something more appropriate. 

Add keywords and descriptions

At the "Health and Safety home page – Computing Services" page, click on the ÂÂ
Edit Page button.

On the ÂÂ Format menu, choose Keywords and Description.

Enter keywords separated by a space, for example: ÂÂ
eucs safety health policy procedures meetings committee

In ÂÂ Description, enter a short summary of the page – use any text you like.


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Navigate to other pages in the site and add appropriate keywords and ÂÂ
descriptions. 
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If you make an error when editing a page you have the option of restoring a previous 
copy using the Roll Back feature. Your website administrator can set up your 
website to keep previous copies for roll back.

To restore a previous copy, select File > Actions > Roll Back to Previous Version 
and select the version.

Note: Roll Back is not set by default in Contribute. If you wish to make use of this 
feature, check with your administrator that it has been activated.  
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Saving a page for later
If you are not ready to publish the page you are editing, you can save it to deal with 
later by clicking on the Save for Later button on the toolbar.

When you choose to save the file for later, it will be saved as a draft document and 

you will see the message  at the top of the 
page. 

Drafts are displayed in the Pages panel on the left. (If the panel is not visible, select 

View – Sidebar or click .)

Clicking on the page name opens the page ready for editing.

Note: Draft pages are saved on your C: drive, not your web server. If you are 
closing down Contribute and your computer, make sure you do this correctly – if 
you switch off before close down is complete, you may lose your drafts. 

Deleting a draft page
If you want to delete a draft, click on the Cancel button on the toolbar and on Yes to 
confirm.
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Contribute includes a facility to send a draft page to someone else to review. You will 
need to do this if you have been set up with the role of Writer and cannot publish to 
the website yourself. You can also use this feature if you would like someone else to 
check the page before you publish it. 

Note: Your website administrator may have an established process for page 
review and publishing. Consult with him or her before using this option.

To send a draft, edit your page, then click the Send for Review button or select File 
> Actions > Send for Review.

There are two options:

Send e-mail with a link to a 
preview of the draft

Enables you to send an e-mail containing a link to 
your page to users who do not have Contribute. 
This option creates a temporary copy of the page 
on the web server. You cannot use this if you are 
unable to publish pages yourself.

Send the draft to another 
Contribute user

Enables you to send a draft page to other 
Contribute users for feedback. You will have to 
use this option if you have the role of Writer and 
cannot publish yourself.

Select the option you want to use and click Send.

Sending an e-mail
If you select the e-mail option, Contribute creates an e-mail message in your default 
e-mail application. Enter the reviewer's address, type a message and send the 
e‑mail. The e-mail includes a link to the page on the web server.

When you receive feedback from the reviewer, click the page title in the Pages 
panel to open the draft.
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Sending a draft
If you want to send a draft to another Contribute user, Contribute displays a list of 
the users who have a connection to your website. You can send the draft to multiple 
users by holding down Ctrl and clicking the names. 

You can enter a note of the changes you have made or provide other instructions for 
the reviewer in the Description of changes box.

To see the page, reviewers will have to open Contribute and check their Pages 
panel. To notify them that a page is awaiting their feedback, click Notify recipients 
through e-mail and send the message. The reviewer can then check and publish 
the page, or send it back to you to publish yourself. 

Note: Once the option to notify recipients is ticked, Contribute will in future 
automatically open your e-mail application as soon as you select Send for 
Review.  

Using the Draft Console
You can use the Draft Console to track pages you have sent for review.

Select View > Draft Console, or click on Draft Console in the Pages panel. 

You can see the drafts you are currently editing, those you have sent for review and 
the ones you have previously published. Clicking on the Title will open the page in 
edit mode. 

When you are finished with the console, click the Back button, or click on Home 
Pages on the toolbar and select the home page of your website.

Note: If there is no Contribute administrator assigned to your website, the Draft 
Console option is unavailable.  
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version of your page

What you will do
Undo an error by rolling back a page to a previously saved version. 

How you will do it
You will make a mistake when you are editing your page and you will undo the error 
by restoring a previously saved copy of the page. 

Now you do it
Edit the Health and Safety meetings page 

Browse to the Health and Safety home page and click on the ÂÂ Edit Page button.

Select all the content on the page and replace it with “Oops, I made a mistake!”ÂÂ

Click ÂÂ Publish to put the edited web page back on the server. 

Roll back to a previously saved version

From the ÂÂ File menu, choose Actions > Roll Back to Previous Version. 

You will be presented with a list of pages with the dates they were last edited. 

Choose the most recent version of the page and click on the ÂÂ Roll Back button.

The version will be restored.


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Exercise 10:  Saving your page for later

What you will do
Save pages for later, reopen the pages and either complete your changes and 
publish, or cancel the draft.

How you will do it
You will use the Save for Later option to create a draft page, the Pages panel to 
re-open the draft, the Publish option to publish the changes or the Cancel option to 
remove the draft.

Now you do it
Browse to the Health and Safety home page.ÂÂ

Edit the page.ÂÂ

Change the ÂÂ Publisher details in the editable region at the bottom of the page to 
your own name.

Save the page to edit later by choosing the ÂÂ Save for Later button.

From the Health and Safety home page, click on the link to the ÂÂ Main Library.

Edit the page.ÂÂ

Add a new row to the bottom of the table and enter some information in it.ÂÂ

Click the ÂÂ Save for Later button. 

In the ÂÂ Pages panel, click on "Health and Safety home page – Computing 
Services" to open the draft of the Health and Safety home page. (If the panel is 
not visible, select View - Sidebar or click on the arrow on the left of your screen 

 .)

Remember that Contribute displays page titles in the panel, not filenames.

Change the ÂÂ Publisher details back to "the Safety Officer". 

Click on the ÂÂ Publish button.

In the ÂÂ Pages panel, click on "Main Library Health and Safety Committee 
meetings ..." to open the draft of the page.

Click ÂÂ Cancel to remove the draft and Yes to confirm.


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... Exercise 11:  Use Contribute to update a 
University website

What you will do
Connect to a School of Virtual Existence website, update it and create new pages. 

How you will do it
You will use Contribute to browse to pages and update them. You will also create 
new pages based on a School template. 

Now you do it
Create a table of contents in the School home page

In Contribute, type in the address ÂÂ http://homepages.ed.ac.uk/wamsweb/
trn-0xx/school/ (trn-0xx is the name of your website for this course. You will 
find a card on your desk with the full number – check with your course tutor if you 
are not sure). 

Edit the page. ÂÂ

Make some of the site contents into a bulleted list (news and events, location ÂÂ
etc.). 

Create links from the list items to the pages:ÂÂ

Select the text "News and events".yy

Choose yy Insert > Link > Browse to web page and you will be presented 
with the Insert Link dialog box. 

Click on the yy Choose button to browse through the school files. 

Double-click the website URL.yy

Double-click the folder "School".yy

Choose the file "news" and click on the yy OK button. 

You will return to the Insert Link dialog box. 

Click on the yy OK button again. 

Repeat these steps for all the items in the list, choosing the appropriate files.ÂÂ

Publish the page. ÂÂ

Apply layout to the other pages in the school web site

Browse through the other pages in the site improving the layout and appearance. ÂÂ
For example, use the Style drop-down list to add section and subsection 
headings where required, and create bulleted and numbered lists.

Put the timetable into an HTML table 

Use the menu on the left to browse to the "Timetable" page. ÂÂ

Edit the page. ÂÂ


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Click after the introductory paragraph and insert a new table with 6 rows and 8 ÂÂ
columns. 

Make the top row and left column into headers (click ÂÂ Both). 

Insert the timetable details shown in the table below:ÂÂ

9 - 10 10 - 11 11 - 12 12 - 1 1 - 2 2 - 3 3 - 4
Mon CC3 M2y Lunch A14
Tue M1z Tut Lunch A14
Wed CC3 M2y Lunch SM SM
Thu CC3 M1z Tut Lunch A14
Fri M2y Tut Lunch AM AM

Adjust the format of the table: ÂÂ

Remove the border.yy

Adjust the width.yy

Centre the data.yy

Add a map to the location page 

Browse to the "Location" page. ÂÂ

Click the ÂÂ Edit button. 

Click at the very top of the page. ÂÂ

Choose ÂÂ Insert > Image > From Website. 

Double-click on the website, then on the "school" and "images" folders.ÂÂ

Select the file "campus_map.gif" and click on the ÂÂ OK button. 

The image will be inserted into your web page. ÂÂ

Double-click on the image and you will be presented with the ÂÂ Image Properties 
dialog box. 

Enter a description of the image in the ÂÂ Description (ALT text) box. 

Click on the ÂÂ OK button. 

Publish the page.ÂÂ

Add suitable titles to all the School pages 

Browse to and edit each page. ÂÂ

Add suitable titles, following the guidance in the section ÂÂ Page titles: good practice 
on page 14.
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... Exercise 12:  Create a website for the 
School of Metahypology

What you will do
Create a new website for an imaginary university school.

How you will do it
The pages you will need have all been created for you. You will use Contribute to 
format these pages, link them together, insert tables, images etc.

Now you do it
In Contribute, type in the addressÂÂ  www.homepages.ed.ac.uk/wamsweb/
trn-0??/project/ (trn-0?? is the name of your website for this course. You will 
find a card on your desk with the number – check with your course tutor).

Edit the page. ÂÂ

Create a table with one row and two columns. ÂÂ

You will add the university crest (the crest is in the "graphics" folder on the ÂÂ
Project website – use Insert > Image > From Website). Put the crest in the cell 
to the left and the name of the department in the right. Make the crest flush left in 
the cell.

Make the table 100% wide.ÂÂ

Choose 0 for the border thickness.ÂÂ

Create links from the home page to the other pages in the site. For example, ÂÂ
create a link from the paragraph “News and events” to the file “news.html”. (Note: 
in the Insert Link dialog box, use the Choose button to search on your website 
for the file you want to link to.) 

Work your way through the pages marking them up using Contribute and giving ÂÂ
them suitable titles. 

Note: Include icons and images from the graphics folder. Use tables and the 
other formatting tools. 





Chapter 5

Learning more 



Editing web pages with Contribute

44

Le
ar

ni
ng

 m
or

e More about Contribute
The Contribute application has a tutorial available through the Help menu. Choose 
Help > Contribute Tutorial.

Full documentation is available through the Macromedia website at: 

http://www.macromedia.com/contribute/
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More about web page design
Writing for the web

Editorial style and good practice guides:

http://www.cam.ed.ac.uk/documents/University-of-Edinburgh-Editorial-Style-
Guide.pdf

http://www.cam.ed.ac.uk/documents/Writing_for_the_Web.pdf

http://webhelp.ucs.ed.ac.uk/docs/goodpractice.html

Courses:

Writing for the Web – see the MyEd (https://www.myed.ed.ac.uk) Event 
Booking channel for dates.

File naming conventions

Records Management Section website:

http://www.recordsmanagement.ed.ac.uk/InfoStaff/RMstaff/
RMprojects/PP/FileNameRules/FileNameRules.htm


