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Alesis D4/DM5

 

This 

 

Galaxy Plus Editors

 

 module adds support for the Alesis D4 and 
DM5 drum modules. The D4 and DM5 each contain over 500 sam-
pled drum and percussion sounds, which can be triggered by MIDI 
or with built-in trigger inputs (placed on acoustic drums or percus-
sion instruments, or drum sounds recorded on tape). These Alesis 
drum modules can also convert external triggers to MIDI notes. 

The Macintosh user interface allows many parameters to be dis-
played simultaneously and grouped into windows that make it easy 
to understand and access the D4/DM5’s capabilities.

This editor manual describes only features specific to the D4/DM5 
Editor. See your Galaxy Plus Editors manual for information on:

• Installing Editor and Librarian modules;
• Loading/sending Bundles, Banks, and Patches;
• Using common editing features such as graphic envelopes, pop-up 

menus, and numericals.

You should also read the “device specific” online Help, which is 
available from the Apple 

 

Help

 

 menu when an Edit or Librarian 
Window is active.

This manual does not attempt to teach D4/DM5 programming and it 
does not discuss each parameter in detail. Often, the effect of one 
parameter depends on the settings of other parameters. If you alter a 
parameter and don’t hear any change in sound, examine how other 
parameters may affect the desired outcome. Refer to your Alesis 
manual to learn how various parameters interact and affect the over-
all sound.
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CH 1: INSTRUMENT SETUP

 

D4 CONFIGURATION

 

Before using the Alesis D4 with Galaxy or Galaxy Plus Editors make 
sure:

• The instrument’s MIDI input and output are connected to your MIDI 
interface; if using a multiport interface, connect both MIDI cables to 
the same port number.

• The MIDI channel matches the Device ID setting in your OMS Studio 
Setup.

• The unit’s THRU setting is off.

To set the MIDI 

 

channel

 

 and 

 

thru

 

 parameters from the D4’s front 
panel:

 

a

 

Press the MIDI button until “CHANNEL” and “THRU” are displayed.

 

b

 

Use the cursor keys to select the 

 

channel

 

 parameter; then set the channel to 
match the Device ID number in your OMS Studio Setup.

 

c

 

Use the cursor keys to select the 

 

thru

 

 parameter; then set it to “OFF.”

 

ROM V

 

ERSIONS

 

 E

 

ARLIER

 

 T

 

HAN

 

 1.02

 

Early versions of the D4 ROMs contained some problems that affect 
the use of your D4 Editor. To find out which ROM version your D4 
has, press the Drum Set button and then press and hold the left and 
right cursor buttons simultaneously.

ROM versions 1.0 and 1.01 had limitations on how fast MIDI System 
Exclusive (sysex) messages could be accepted. The 

 

Has 1.01 or Older 
ROMs

 

 command, available in the 

 

Load/Send

 

 menu when a Drum 
Set Bank or Edit Window is open, adjusts the rate at which sysex is 
transmitted to the D4. If your D4 contains a ROM version earlier 
than 1.02, enable (check) this menu item.

ROM versions earlier than 1.02 also use a different format for Trigger 
Setup data. Although the Editor is capable of dealing with all ver-
sions, the Librarian must handle them differently. If you are using a 
version earlier than 1.02, set up your Bundle as follows:
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a

 

Click the D4 device name in an open Bundle and choose 

 

Bundle>Banks in 
Device

 

.

The following dialog appears.

Figure 1: Banks in Device Dialog 

 

b

 

Check the option for 

 

Trigger Setup (<1.02)

 

.

 

c

 

Uncheck the option for 

 

Trigger Setup (>=1.02)

 

.

 

d

 

Click 

 

OK

 

 to confirm your selections and close the dialog box.

 

?

 

IMPORTANT: Make sure that only one Trigger Setup item is 
selected. If both check boxes are selected, Galaxy will put both Bank 
types into the Bundle, which could cause problems when loading or 
sending the Bundle.

 

DM5 CONFIGURATION

 

Before using the Alesis DM5 with Galaxy or Galaxy Plus Editors 
make sure:

• The instrument’s MIDI input and output are connected to your MIDI 
interface; if using a multiport interface, connect both MIDI cables to 
the same port number.

• The MIDI channel matches the Device ID setting in your OMS Studio 
Setup.

• The unit’s THRU setting is off.

To set the MIDI 

 

channel

 

 and 

 

thru

 

 parameters from the DM5’s front 
panel:

 

a

 

Press the MIDI button until “CHANNEL” and “THRU” are displayed.

 

b

 

Use the parameter keys to select the 

 

channel

 

 parameter; then set the channel to 
match the Device ID number in your OMS Studio Setup.

 

c

 

Use the parameter keys to select the 

 

thru

 

 parameter; then set it to “OFF.”
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CH 2: D4/DM5 BANK TYPES

 

To open a new Bundle for the Alesis D4 or DM5:

 

a

 

Make sure your 

 

Current

 

 OMS Studio Setup contains either an Alesis D4 or DM5, 
then launch Galaxy Plus Editors.

When launching Galaxy for the first time, Librarian modules for devices contained 
in your OMS Studio Setup are automatically installed.

 

b

 

Choose 

 

File>New Bundle

 

.

A dialog box listing all installed Librarian modules appears.

 

c

 

Select the D4 or DM5 by clicking the device name.

Its name will become highlighted to illustrate that it’s selected.

 

d

 

Click the 

 

OK

 

 button to place all D4/DM5 Bank types in a new “Untitled” Bundle.

When opening or a creating a Bundle, a Bundle menu becomes available; to 
retrieve all Banks from your instrument, choose 

 

Bundle>Get All Banks in 
Bundle

 

.

 

B

 

ANK

 

 T

 

YPES

 

Below is a brief description of each D4/DM5 Bank type:

 

Figure 2: Bundle Listing DM5 and D4 Bank Types

 

A

 

Drum Set

 

: Bank of 21 drum sets—each specifying a keyboard layout 
of drum sounds with settings for volume, tuning, pan, and routing.

 

B

 

Trigger Setup

 

: Stores settings for triggering parameters for each of 
the 12 external trigger inputs.
D4 users, must choose 

 

Bundle>Banks in Device

 

 to specify your 
ROM version (see ROM Versions Earlier Than 1.02, pg. 1).

 

C

 

Prog Tbl

 

: Determines how the D4/DM5 responds to MIDI program 
changes.

 

D

 

System Info

 

: Defines global MIDI settings, configures footswitch 
mode, and enables “note chase.”
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CH 3: EDITING DRUM SETS

 

To edit a Drum Set:

 

a

 

Open a Bank of D4/DM5 Drum Sets.

Figure 3: Drum Set Bank

 

b

 

Highlight a patch from the Drum Set Bank and click the 

 

Edit

 

 button.

You can also double-click a Drum Set to edit it.

 

DRUM SET EDIT WINDOW

 

The Drum Set Edit Window assigns drum and percussion sounds to 
keys, along with settings for volume, tuning, pan, and routing. This 
window also assigns MIDI notes to each of the 12 external trigger 
inputs.

 

Figure 4: Drum Set Edit Window

 

The Drum Set Edit Window consists of three main edit blocks: 

 

Drum 
Set

 

, 

 

Trigger Notes

 

, and 

 

Root Note/Footswitch

 

.
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D

 

RUM

 

 S

 

ET

 

The 

 

Drum Set

 

 edit block is the heart of the D4/DM5 editor, where 
sounds are selected, mapped to notes, tuned, and routed.

 

Figure 5: Drum Set Edit Block

 

A

 

Note

 

: Indicates the MIDI note being assigned, starting at the 

 

Drum 
Set Root Note

 

 (see Root Note and Footswitch, pg. 7) and covering a 
61-note range. Clicking a note name selects the entire line for copy-
ing or pasting.

 

B

 

Keyboard

 

: The column to the right of the note names is a scrollable 
keyboard for auditioning sounds. Clicking any note on the keyboard 
triggers the corresponding sound. 
Clicking the up/down arrows, scrolls the display an octave at a time. 
Option-clicking an arrow, scrolls one note at a time. The velocity of 
the MIDI note played is set with the Mac KV setting in the 
MouseKeys Window.

 

C

 

Bank

 

: Specifies a Drum Bank from which the Drum Sound for that 
note is chosen.

 

D

 

Drum

 

: Assigns a Drum Sound, from the indicated Drum Bank, for 
that note.

 

E

 

Volume

 

: Sets the Drum Sound’s volume.

 

F

 

Coarse

 

: Tunes the Drum Sound in semitone steps within a range of 
+3/-4 steps.

 

G

 

Fine

 

: Tunes the Drum Sound in cents within a range of +99/-99 
cents.

 

H

 

Panning

 

: Pans the Drum Sound to any of seven possible stereo loca-
tions. The Output setting determines between which two outputs the 
sound is panned.

 

I

 

Output

 

: Routes the Drum Sound to either the Main or Aux outputs.

 

J

 

Assign Group

 

: Specifies a trigger mode for the Drum Sound.

1
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C

 

OPYING NOTE
SETTINGS

Settings for a note can be copied to another note, or even to another 
Drum Set.

a Click the note name in the left column to select the source note and its parameters.

Figure 6: Source Note Selected

b Choose Edit>Copy.

c Click the destination note name to select it.

If you are pasting to a different Drum Set, first open the Edit Window for the 
desired Drum Set.

Figure 7: Destination Note Selected

d Choose Edit>Paste.
The new note’s parameters are then updated.

Figure 8: Note Pasted into Destination

COPYING PARAMETERS

Individual parameters can be copied to other notes, or Drum Sets, in 
similar fashion. Do this by clicking the individual source and desti-
nation fields instead of the note names. Additionally, multiple 
parameters can be copied by shift-clicking on source and destination 
fields.

Of course, these copy/pasting techniques may also be used in other 
Edit Windows.
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TRIGGER NOTES In the Trigger Notes edit block, each of the D4/DM5’s external trig-
ger inputs is mapped to a MIDI note. This mapping determines both 
which sound is triggered and which MIDI note is output.

Figure 9: Trigger Notes Edit Block

The left column shows the external trigger input numbers, to which 
the Trigger Notes column assigns MIDI notes.

ROOT NOTE AND
FOOTSWITCH

The third edit block of the Drum Set Editor, edits Root Note and 
Footswitch settings.

Figure 10: Drum Set General Edit Block

• Drum Set Root Note: Sets the lowest MIDI note to be used for that 
Drum Set’s 61-note range. Changing this parameter transposes all 
note settings in the Drum Set Edit Window.

• Footswitch Closing: Selects the MIDI note generated when a foot-
switch, plugged into the D4/DM5’s footswitch input, is pressed.

• Footswitch Held: Selects the MIDI note generated when a trigger is 
received at External Trigger Input 1 while the footswitch is held 
down.
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SPECIAL MENU COMMANDS IN THE DRUM SET EDIT WINDOW

The following Edit menu commands are available when the Drum 
Set Edit Window is active:

• Note Chase: Enables a sound in the D4/DM5 to be selected for edit-
ing simply by striking the associated pad or other trigger device. 

• 1 Oct (small screens): Sets the display in the Drum Set Edit Window 
to one octave.

• 2 Oct (large screens): Sets the display in the Drum Set Edit Window 
to two octaves.

The following Load/Send menu commands are available when a D4 
Drum Set Bank or Drum Set Edit Window is active:

• Store Drum Set in D4: Stores an edited Drum Set in the D4, as 
opposed to remaining only in the unit’s edit buffer. This saves the 
trouble of having to send the entire Bank to the D4 simply to store a 
single edited Drum Set. 
This command is disabled when Load/Send>Has Old ROMs is 
checked.

• Has Old ROMs: Compensates for problems caused by older D4 
ROM versions. See ROM Versions Earlier Than 1.02, pg. 1
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CH 4: EDITING TRIGGER SETUPS

To edit a Trigger Setup:

a Open a Trigger Setup Bank.

Figure 11: Trigger Setup Bank Window

b Click the Edit button to open the Trigger Setup Edit Window.

TRIGGER SETUP EDIT WINDOW

The Trigger Setup Edit Window is where triggering parameters are 
set for each of the D4/DM5’s 12 external trigger inputs. Although 
each of the 21 Drum Sets has its own set of trigger note assignments, 
the following Trigger Setup parameters are global and therefore 
affect all Drum Sets. 

Figure 12: Trigger Setup Edit Window

A Gain: Sets the amount of amplification applied to the trigger input.
B Velocity Curve: Sets the sensitivity of a trigger input with any of 

eight velocity response curves.

1 2 43 5

7 86



Ch 4: Editing Trigger Setups - 10 - D4/DM5 Editor

C Cross-Talk: A threshold parameter that enables a trigger input to 
avoid false triggering from a nearby pad or drum being struck.

D Noise Floor: A threshold parameter that enables the D4/DM5 to 
avoid false triggering by distinguishing between genuine triggers 
and ambient noise.

E Decay: Sets a delay time during which the D4/DM5 will not accept 
another trigger for that input.

F Set Select: Auditions any of the D4/DM5’s 21 Drum Sets during 
Trigger Setup configuration. The D4/DM5 can hold only one Trigger 
Setup at a time, so this feature is provided to audition how well the 
Trigger Setup works with different Drum Sets.

? NOTE: Option-clicking on the Drum Set pop-up opens the Edit 
Window for that Drum Set, enabling editing of Trigger Notes or 
sound assignments.

G Destination: Displays the sounds, assigned to the corresponding 
MIDI notes, for the selected Drum Set.

H Note: Displays the MIDI notes, assigned to the external trigger 
inputs, for the selected Drum Set.

Destination and Note columns cannot be edited from the Trigger 
Setup Window. These edits must be made from the Drum Set Edit 
Window.
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CH 5: EDITING PROGRAM TABLE 
AND SYSTEM INFO

To edit a Program Table:

a Open a Program Table Bank.

Figure 13: Program Table Bank Window

b Click the Edit button to open the Program Table Edit Window.

PROGRAM TABLE EDIT WINDOW

The Program Table Edit Window specifies which Drum Set is 
selected when receiving a particular MIDI program change number.

Figure 14: Program Table Edit Window

The left column shows the program numbers with their correspond-
ing Drum Set (chosen from a pop-up menu) in the right column.
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When the Program Table Edit Window is open, the following com-
mands are available from the Edit menu:

• 0-127, 1-128, or A11-B88: Sets the numbering scheme for how 
patches appear when published to Name Manager compatible appli-
cations—like Opcode’s Vision.

• Sequential Assign: Opens the following dialog which sequentially 
assigns Drum Sets to the indicated range of program change 
numbers.

EDITING SYSTEM INFORMATION

To edit the System Information:

a Open a D4/DM5 System Info Bank.

Figure 15: System Information Bank Window

b Click Edit button to open the System Information Edit Window.
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SYSTEM
INFORMATION EDIT

WINDOW

The System Information Edit Window defines global MIDI settings, 
configures the footswitch mode, and enables “note chase.”

Figure 16: System Information Edit Window

A Footswitch Mode: Configures the external footswitch jack for 
“Hi Hat” triggers or program advance (“Advance”).

B Note Chase Enable: Enables or disables Note Chase, which allows 
selection of a sound for editing by striking the appropriate trigger or 
by sending the assigned MIDI note to the D4/DM5.

C Channel: Sets the D4/DM5’s MIDI channel. This parameter is only 
enabled when Omni is set to “Off.”

D Omni: Enables or disables MIDI Omni mode, determining whether 
the D4/DM5 responds to MIDI data on all channels or only to the 
one set by Channel.

E Thru Enabled: Configures the D4/DM5’s MIDI Out jack as a MIDI 
Thru jack. If this is inadvertently checked, MIDI feedback problems 
may occur.

F Programs Enabled: Allows the D4/DM5 to respond to MIDI pro-
gram changes, based on its Program Change Table. If this box is not 
checked, the unit will not respond to program changes.

G Controllers Enabled: Enables reception of MIDI continuous control-
ler messages, as described in the D4/DM5 manual.

1
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