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1      About ZCO
This chapter includes information about prerequisites for installing Zimbra 

Connector for Microsoft® Outlook® (ZCO) and how to download the ZCO 
installation file. 

With ZCO, users can use Microsoft Outlook and synchronize data such as 
email messages, folders, tags, contacts, personal calendars, appointment 
reminders, and tasks with the Outlook client. The ZCS server-side 
configuration for accounts is enforced for Outlook users.

Topics in this chapter include:

Use ZCO with the Correct Version of ZCS

Supported Versions of Microsoft Operating System

ZCO supports Microsoft Operating Systems: Windows XP with required 
updates, Vista, Windows 7, and Windows 8.

ZCO Configuration Files

Downloading ZCO Installation and Customization Files

Use ZCO with the Correct Version of ZCS

The versions you are running for ZCO and ZCS must be from the same major 
release. For example ZCO 8.x and ZCS 8.x are used together. Never use 
versions that do not align together, such as ZCO 7.x with ZCS 8.x. 

From the Tools and Migration>Client Upload page on the ZCS administration 
console, you can upload the latest version of ZCO to the ZCS server. 

Supported Versions of Microsoft Operating System 

ZCO supports Microsoft Operating Systems: Windows XP with required 
updates, Vista, Windows 7, and Windows 8.

Supported Versions of Microsoft Outlook

ZCO supports the following versions of Microsoft Outlook:

Important:  ZCO installations working with older versions of Outlook require 
updating or reinstalling if Outlook is upgraded to Outlook 2013.
Zimbra Collaboration Server  ZCO 8.0   5
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 Outlook 2013: 32-bit and 64-bit editions of Microsoft Office are supported.

 Outlook 2010: 32-bit and 64-bit editions of Microsoft Office are supported. 

Note:   “Click to run” versions of Outlook 2010 are not supported.

 Outlook 2007: Client computers must have Microsoft Office Outlook 2007 
SP2 or later installed. 

 Outlook 2003: Client computers must have Microsoft Office Outlook 2003 
SP3 or later installed.

ZCO Configuration Files 

There are three different download files, including the installation and 
customization files, that can be configured to make the user’s deployment of 
ZCO quick and easy. 

 Zimbra Connector for Outlook: The ZCO .msi file (either 32bits or 64bits) 
users download and deploy on their computer to install ZCO. 

 Zimbra Connector for Outlook MSI Customizer: Used to customize the ZCO 
.msi file to add basic server information the user needs to install ZCO on 
their computer. Other variables such as setting up single sign-on and 
password rules can also be configured.

 Zimbra Connector for Outlook Branding MSI: Used to customize the ZCO 
.msi file to replace all instances of the Zimbra product name and logo.

Downloading ZCO Installation and Customization Files

The ZCO installation and customization files are accessible from the ZCS 
administration console. 

1. From the ZCS administration console, click the Tools and 
Migration>Downloads link.

2.  Select the Zimbra Connector for Outlook download file appropriate for your 
version of Outlook (32bit or 64bit).

3.  Download the .msi file and user instructions so that you can easily deploy 
these files to your users.

4.  You can copy the .msi file to a directory or URL that users can access and 
then instruct users how to download the file, or you can use group 
deployment software.

Note:   Users must have temporary administrator privileges on their computer 
to install ZCO.
 6    ZCO 8.0 Zimbra Collaboration Server



2      Preconfiguring and Customizing the Installer
When ZCO is installed, the information needed to complete the installation is 
the ZCS server name and whether to use a secure connection. Users enter 
server information when they install ZCO and create their default profile. This 
chapter includes information about how to preconfigure and customize the 
ZCO .msi installation file. 

To customize the installer with your specific configuration details, you modify 
the ZmCustomizeMsi.js file which is located in the Zimbra download directory 
on the administration console. 

Areas that can be customized include:

 Configuring the ZCS server name and secure connection options. When 
users install ZCO they only need to enter their account name and 
password.

 Single Sign-on options when SPNEGO is configured for ZCS.

 Password rules.

 GAL sync mode.

 Default profile name.

 Disabling automatic upgrading to the latest ZCO version.

Note:   To see a complete list of customization options, type ZmCustomizeMsi 
at the command line prompt and press Enter.

You can also change the Zimbra branding to your own company name or 
brand using the rebranding tool.

Adding ZCO Server Credentials

When you add the server domain name, port, and secure connection details, 
users only need to add their name and password when they install ZCO.

1. From the administration console, copy the ZmCustomizeMsi.js file and the 
ZCO .msi file to a computer running the Windows platform.

2.  Open the Windows command prompt. 

3.  Change to the directory where the ZmCustomizeMsi.js file is located.
Zimbra Collaboration Server  ZCO 8.0   7
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4.  Type the server configuration command all on one line:

cscript ZmCustomizeMsi.js <path/msi-filename> -sn <servername.com> -sp 
<port> -ssl <1 | 0> //nologo

Command Description

5.  Press Enter. The ZCO .msi file is modified. 

6.  To verify that the modification is correct, run the .msi installer and create a 
dummy profile. The Zimbra Server Configuration Settings dialog should 
include the server name, server port, and the check box marked/unmarked 
for whether to use a secure connection. 

You can now deploy the customized ZCO .msi file to users. To install ZCO, 
users must have administrator privileges on their computer.

Optional Customization of ZCO 

You can make other changes to the .msi file to add or modify the following 
functionality:

Set the Password Rule

1. To set the password rule, enter as -pw <1|0>

Setting the password rule to 0 prevents the ZCO password from being 
saved. This option should be used when using single sign-on (SSO) 
authentication.

When the password rule is set to 1, the ZCO encrypted password is saved 
in the user’s ZCO profile (default). 

Modify the GAL Sync Mode

1. To set GAL sync mode, enter as -gsm <2|1|0>

2.  Enter 2 to disable GAL sync; 1 to make GAL sync a manual option only, 0 
for GAL syncs to occur automatically every x days. 

ZmCustomizeMsi.js Name of the js file

path/msi-filename Directory path and the ZCO .msi filename. 

servername.com Zimbra server domain name (DNS) to be configured.

port Port number to be configured. For non-secured 
connections, the default is 80. For a secured 
connection, the default is 443. Your configuration 
can be different. 

1 | 0 Enter 1 for a secure connection using HTTPS, or 
enter 0 to use a HTTP connection. 
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Create Sync Failure Message

1. To create sync failure message in the sync folder and/or the Inbox folder, 
enter as -ifo <1|0>

Use 1 to create sync failure messages only in the Sync Issues folders. Use 
0 to create the sync failure messages in the Sync Issues folders and in the 
user’s Inbox.

Setting Up the Single Sign-On Option (SSO)

Note:   To use SSO, SPNEGO must be configured on ZCS. 

SSO works with a specific server. The server name used in the ZCO profile 
must match that in the SPNEGO configuration. Make sure that the server 
name is incorporated into the .msi file prior to installation of ZCO.

1. Set the server name to be the server name configured for SPNEGO, enter 
-sn <spnegoserver.example.com>

2.  Set the password rule, enter -pw 0

Example:

cscript ZmCustomizeMsi.js <path/msi-filename> -sn 
<spnegoserver.example.com> -pw 0

For more information, see Appendix B, Configuring SPNEGO Single Sign-On 
for ZCS in the Zimbra Collaboration Server Administrator’s Guide.

Disabling the Auto-Upgrade Feature

When a user launches Outlook, ZCO checks ZCS for a newer version of ZCO. 
If a newer version is available, the user is prompted with the option to 
upgrade. 

You can disable the auto-upgrade feature. Modify the ZmCustomizeMsi.js file 
before installation and select the --disable-autoupgrade option. 
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Hiding GAL Aliases

An email alias is an email address that redirects all mail to a specified mail 
account. If an address has an alias, by default the alias is shown as a 
separate entry when the GAL contents are displayed in Outlook.

If you do not want aliases to appear in the GAL, you can disable this option. 
Modify the ZmCustomizeMsi.js file before installation and select the 
--galsync-disablealiases 1 option.

When this is disabled, users cannot search for aliases when addressing mail.

If profile aliases are being displayed by Outlook, and you have disabled this 
feature, the GAL must be reset. 

 For Outlook 2007, go to Sync Global Address List>Reset Global Address 
List.

 For Outlook 2010, go to the Zimbra ribbon>Sync Global Address List>Reset 
Global Address List.

Rebranding ZCO

You can change the Zimbra branding in ZCO to your own company name or 
brand.

1. From the administration console, click Downloads link.

2.  Open the Zimbra Connector for Outlook Branding MSI.vbs (Visual Basic) 
file. 

3.  At the start of the script, replace “Foobar” with your company name or 
value:

Value Description

Brand Substitutes all occurrences of “Zimbra” in the product, 
except the Zimbra copyright statement in the ZCO About 
window. (maximum 30 characters)

Company Appears only in the .msi file's summary information 
(right-click and select Properties) and in the Control 
Panel entry for the installed program under 
Publisher. (no character limit)

DefaultProfileName Provides a name for the default Outlook profile to be 
created as part of the installation if none already exists. 
(maximum of 64 characters)

AboutLink The URL that appears in the Control Panel entry for the 
installed program under Support Link. (no character limit)
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4.  Run this script on the ZCO .msi file that users will use to install ZCO: 

  cscript ZimbraBrandMsi.vbs ZimbraOlkConnector.msi

If ZCO has been previously installed on the target machine, uninstall ZCO 
before running the newly branded installation.

Your company name or value now replaces the Zimbra brand, and the Zimbra 
icon is replaced with a generic icon.

Note:   Existing Outlook profiles created using the unbranded package should 
remain usable but will show the old "Zimbra - ..." store name.

DocumentLink The Click here for documentation link on the ZCO 
About dialog. This normally links to a Zimbra PDF 
document but can be redirected to your own web 
documents. (maximum of 260 characters)
Zimbra Collaboration Server ZCO 8.0     11
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3      Installing ZCO
This chapter provides information about what server configuration information 
the user needs to install ZCO, what takes place when ZCO is installed on 
individual computers, and what happens during the initial synchronization of 
ZCO and Outlook.

Note:   Examples in this guide refer to Outlook 2007. In Outlook 2010, 
equivalent ZCO features are accessed from the Zimbra ribbon. 

Topics in this chapter include:

Installation Prerequisites

Installing ZCO on Individual Computers

Synchronizing ZCO with Outlook

Migrate ZDB Profiles

Installation Prerequisites

If you did not modify the .msi file, the user needs the following server 
configuration information during the installation process. Be sure to provide 
this information to your user before they install ZCO so they can complete 
their installation of ZCO:

 ZCS DNS name.

 Whether to select Use Secure Connection (SSL). This feature is used to 
establish a secure connection to that port.

 The user’s complete email address and email password.

Installing ZCO on Individual Computers

It only takes a few minutes for users to install ZCO on their computers and 
configure the connection to ZCS. You must provide the user with temporary 
administrative privileges and the server configuration information.

Installing ZCO creates a mail profile named Zimbra and designates it as the 
user’s default profile in Outlook. 

The installation does not remove any previous Outlook profiles or accounts. 
The user can view previous profiles by navigating to Start>Settings>Control 
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Panel>Mail>Show Profiles. Mail profiles can combine a Zimbra account with an 
IMAP, Exchange, or POP account. 

To add a new profile, users select Add on the Show Profiles dialog and follow 
the prompts. 

Note:   Users cannot add more than one Zimbra account to a profile. Users 
can customize the name of the profile created during the installation 
using the “profile name” customization option available from the 
installation file.

For more information about the ZCO installation process, see the Zimbra 
Connector for Microsoft Outlook User Guide.

Synchronizing ZCO with Outlook

The first time a user opens Outlook after ZCO is installed, the user’s Outlook 
mailbox must synchronize with ZCS. If users have been using the Zimbra Web 
Client and have email messages, folders, tags, signatures, contacts, personal 
calendars, appointment reminders, and tasks on ZCS, this information is 
synchronized with their Zimbra profile in Outlook. The initial synchronization 
can take a few minutes or longer, depending on the size of the mailbox.

If users use the default Zimbra profile, their synchronized data is saved in the 
zimbra.zdb file located in the user’s Local Settings\Application 
Data\Microsoft\Outlook folder.

Important:  When ZCS is restored from a Zimbra backup session, users must 
perform an initial synchronization with the Outlook client when they log in. 

Manually Synchronizing ZCO with Outlook

You can initiate a manual synchronization of ZCO with Outlook, or perform a 
delta synchronization to update your account with changes made since the 
last synchronization. Click Send/Receive located on the toolbar or press the F9 
key.

Resyncing the GAL for Contact Group Support

To obtain full support for contact groups for profiles that were created with 
older versions of ZCO, it is necessary to perform a full GAL reset on your ZCO 
client to ensure contact groups and their members are synced correctly with 
ZCS.

 For Outlook 2007, go to Sync Global Address List>Reset Global Address 
List.

 For Outlook 2010, go to the Zimbra ribbon>Sync Global Address List>Reset 
Global Address List.
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Installing ZCO
For more information about ZCO synchronization, see the Zimbra Connector 
for Microsoft Outlook User Guide.

Migrate ZDB Profiles

ZCO supports relocating a ZDB file, ZDB file compaction, and migration of 
ZDB profiles. You can migrate ZDB profiles, including user files and settings, 
from one machine to another. To compact roaming profiles and ZDB files, you 
must be logged in to the user’s account to configure the ZDB settings. For 
more information, see the Zimbra Connector for Microsoft Outlook User 
Guide.

1. Install ZCO on machine A and on machine B.

2.  On machine A, create a profile and synchronize it. 

3.  Shut down Outlook on machine A.

4.  On machine A, save the profile settings from the registry to a file. The 
registry key is located in 
HKEY_CURRENT_USER\Software\Microsoft\Windows 
NT\CurrentVersion\Windows Messaging Subsystem\Profiles.

5.  Copy the ZDB file to machine B.

6.  Import the registry settings to machine B.

7.  On machine B, make sure Outlook is set to prompt which profile to use.

8.  Open Outlook on machine B and select the copied profile. Your profiles are 
migrated.
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4      Zimbra Features in Outlook
Zimbra features have been incorporated into Outlook menus. The ZCO User 
Guide, which is available from the ZCO About page describes these features, 
which include

Personal Email Certificates (S/MIME)

Personal Email Certificates (S/MIME) synchronize in the GAL from ZCS, 
which allows users to send and receive signed and encrypted email 
messages. Certificates are stored in two places, including the GAL 
(synchronized to ZCO during GAL sync), and in Personal Contacts 
(synchronized bi-directionally with ZCS).

Advanced Settings

Users can modify the following advanced settings. The Advanced button, 
available from View>Toolbars>Zimbra Support, is used to set the following:

Note:   Any changes made in the Advanced Settings dialog are made to the 
registry.

Feature Location in Outlook

Zimbra Personas Available in Outlook under Tools > Options > Personas.

Zimbra Mail Filters Available in Outlook under Tools > Zimbra Server 
Rules.

Out-of-Office Reply Available in Outlook under Tools > Zimbra Out of Office 
Assistant. 

Zimbra Tags Synchronized with Outlook Categories. 

Zimbra mailbox quota Can be checked using Tools >Mailbox Quota.

Enable/disable and 
update the GAL

Enable or disable using Tools > Send/Receive > Global 
Address List.

Select/Deselect Error 
Messages

Select or deselect error messages to the Inbox. Go to 
View>Errors to Inbox.

Sharing Users can access Zimbra mail folders, calendars, 
contacts, and tasks shared by another Zimbra user. 
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Feature Description

• When “Use Secure Connection” is selected in the 
ZCO profile configuration page, ZCO validates the 
server certificate.

• If there is a problem with the certificate, for example 
the certificate has expired or the certificate is self-
signed, the user is warned and the connection with the 
server is denied.

• To allow connection even when there is a problem with 
the server certificate.

Zimbra Feature Differences for Outlook Users

ZCS offers account configuration by Class of Service and by account. When 
you use Outlook, many of the features and options configured for the Zimbra 
account are not enforced in Outlook. Only restrictions that are controlled by 
the server are enforced. 

Connection 
Timeouts.

Configure HTTP connection settings. The default settings 
for connect, send, receive and option/receive are 900000 
milliseconds, or 15 minutes. These settings are 
configurable.

GAL Sync 
Optimizations

Set GAL sync time, including sleep time, and sleep after. 
If the user’s system is slow due to the sync, they can 
configure their system to go to sleep after a specified 
number of contacts have been synced.

LDAP The LDAP default is disable. Users can enable LDAP and 
enter the server name.

Delegate Calendar 
Sync

Select to sync all calendar content, or select to sync 
partial calendar content by selecting a specified number 
of days to sync.

Enable local rules Check this box to allow users to enable local Outlook 
rules. By default, local Outlook rules are disabled.

Store password in the 
profile

Check this box for users to store their passwords in their 
profiles. Uncheck this box if you do not want user 
passwords stored in their profile. They enter their 
password at each login.

Allow Invalid 
Certificates

Check this box:

Synchronize 
Signatures

Check this box to sync email signatures from Outlook’s 
“Signatures and Stationary” dialog with the server.

Synchronize 
Preferences

Check this box to allow preferences, such as Read 
Receipt options in Outlook’s Options dialog, to sync with 
the server. 

Synchronize on 
Change

Synchronizations are typically carried out at the interval 
specified in Outlook Send/Receive Groups dialog. If this 
option is selected, ZCO bypasses the interval and syncs 
within 60 seconds if it detects a change made by Outlook 
or a change made by the server.
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Zimbra Features in Outlook
Users can configure their own Outlook preferences. These are not 
synchronized with the Zimbra server. 

Free/Busy Lookup in ZCO

If the ZCS server CA certificate is self-signed, free/busy lookup in Outlook fails 
with the error "An error occurred reading Internet free/busy data. General 
failure." To fix this issue, add the CA certificate to Internet Explorer's Trusted 
Root Certification Authorities.

Outlook AutoArchive Disabled for Zimbra Profiles and Folders

The Outlook AutoArchive function is disabled for Zimbra profiles and folders. 
This feature should not be enabled. Auto-archiving removes files from the 
server, including items shared with others. This can cause data loss or 
problems with recurring appointments, shared items, and historical calendar 
data.

Note:   Outlook’s global AutoArchive function remains enabled for Outlook 
features that are not Zimbra specific. 

Forwarding Invitations

If you forward a meeting invitation to another user, a notification is sent to the 
original meeting organizer because you have now extended their invitation to 
a new invitee.
Zimbra Collaboration Server ZCO 8.0    19
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5      Troubleshooting ZCO
Note:   Disable logging when not being used for troubleshooting. If logging is 
on continuously, performance might be affected.

Topics in this chapter include:

Common Troubleshooting Issues

Repairing ZCO

Restoring ZCO

Removing ZCO

Resolving Mailbox Sync Problems

Resyncing GAL for Contact Group Support

Enable Logging for Troubleshooting

Zimbra Support Toolbar

Zimbra Support and Additional Resources

Common Troubleshooting Issues

This section contains information about common troubleshooting issues, 
including:

 Received a Local/Server Failure Notice

 Outlook Crashed

 My Zimbra Calendar will not Sync

 Unable to Access a Shared Item

 The .zdb File is Corrupt

Received a Local/Server Failure Notice

If errors occur when Outlook syncs with ZCS (for example, a MIME error), 
Local/Server Failure messages are automatically sent to the user’s Outlook 
account. 

Review the Failure messages. The problem might be apparent and simple to 
resolve, such as an “out of quota” message. If you cannot resolve the error 
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based on the message, submit the messages with a support case to Zimbra 
Support.

When ZCO is installed, a Sync Issues folder with subfolders are created in the 
user’s Outlook Folder List. Copies of the Local/Server Failure messages is 
saved to the Sync Issues folder. 

 Users can tell when new messages are in a folder when the folder is bold 
and the number of unread messages is displayed beside the folder name.

 To disable failure notifications to the user’s Inbox in the user’s Outlook, 
deselect View > Errors to Inbox.

Outlook Crashed

If Outlook closes unexpectedly (for example, with the warning 
“Outlook...needs to close”), look in the Windows %TEMP% directory to see if 
there is a subfolder called zco-cores. You can also generate core dumps for 
Outlook. See http://wiki.zimbra.com/wiki/Generating_Core_Dumps for 
directions. 

The core dump shows what Outlook was doing at the time of the crash. 
Submit a case with this file to Zimbra support.

My Zimbra Calendar will not Sync

1. Verify that the user’s account has synced.

2.  Check Local/Server Failure messages in the Sync Issues folders.

3.  Submit a case with the logging information to Zimbra Support.

Unable to Access a Shared Item

1. Verify that the user has accessed the calendar correctly: 

a. Open>File> Other User’s Mailbox. The GAL is displayed. 

b. Select the sharing user from the list. The shared item should sync 
automatically.

2.  Submit a case with the logging information to Zimbra Support.

The .zdb File is Corrupt

A user receives a Local Failure message stating that the .zdb file is corrupt. To 
fix this issue, you must repair the .zdb file. The .zdb file includes all Outlook 
data from ZCS in .pst format: messages, contacts, appointments, tasks, etc. 

Use the scanpst.exe tool to:

 Repair any .zdb file that Outlook/ZCO has trouble opening.

 Repair user’s PST files before importing them using the Zimbra PST Import 
Wizard.
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a. Locate the scanpst.exe tool in Windows (Start>Search>For files or 
folders).

b. Type the path and the filename of the personal folders (PST or ZDB) 
file, or click Browse to locate the file by using the Windows file system.

c. Click Start.

Repairing ZCO

1. Locate the ZCO .msi used to install ZCO and download the file to your 
computer.

2.  Click the file to open.

Note:   To find out which version of ZCO is installed, open Outlook and go to 
Help>About Zimbra Connector for Outlook.

When the .msi file is opened after ZCO is installed, it opens with the 
options to repair the connector.

3.  Click repair. ZCO is reinstalled.

Restoring ZCO

When ZCS is restored from a Zimbra backup session, users must resync 
Outlook with ZCS.

Removing ZCO

To remove ZCO, including removing all components except the Zimbra 
profiles, on your computer go to Add or Remove Programs and select to 
remove Zimbra Connector for Microsoft Outlook.

Resolving Mailbox Sync Problems

If a user’s mailbox cannot receive new mail, becomes out-of-sync, or the .zdb 
file becomes corrupted, you can:

 Force an initial sync of the user’s mailbox. To do this, have the user create 
another profile, open Outlook, and select Tools>Send/Receive>Send/
Receive All to sync with ZCS.

 Set the Sync Token to an earlier number and resync the user’s mailbox. For 
more information, see Set Sync Token on page 25.

 Have the user exit Outlook and then delete the existing .zdb file. This 
deletes all data on the user’s computer and recreates the mailbox from the 
data that is on ZCS, but keeps the same profile. Restart Outlook after the 
.zdb file is deleted. 
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In some cases, it might be necessary to uninstall the .msi file, delete the profile 
and .zdb, and start over. 

Reviewing Sync Issues folders

When ZCO is installed, a Sync Issues folder with subfolders is created in the 
user’s Outlook Folder List. If errors are found when Outlook syncs with the 
server, a sync failure notification is sent to both the user’s Inbox and the Sync 
Issues folder. To turn off local failure notifications to the user’s Inbox, deselect 
Errors to Inbox under the View menu.

To view the Sync Issues folder, click the Folder List icon in the Outlook 
Navigation Pane. The Sync Issues folder is displayed in the Folder List. Users 
can tell when new messages are in these folders when the folder is bold and 
the number of unread messages is displayed.

If users are having problems using Outlook and continuously receiving errors, 
the messages in these folders should be submitted with a support case to 
Zimbra Support. These messages are created to help Zimbra technical 
support and engineering debug and fix errors.

Resyncing GAL for Contact Group Support

For contact group support, perform a full GAL reset on your ZCO client to 
ensure contact groups and their members are synced correctly with ZCS.

 For Outlook 2007, go to Sync Global Address List>Reset Global Address 
List.

 For Outlook 2010, go to the Zimbra ribbon>Sync Global Address List>Reset 
Global Address List.

Enable Logging for Troubleshooting 

If users encounter problems when accessing their Zimbra accounts using 
ZCO, you can enable logging to monitor the errors and events that occur. After 
you have enabled logging and have recreated the issue, you can send this log 
to Zimbra Support for analysis.

To enable logging:

1. Select the Logging button on the Zimbra Support Toolbar and select 
Enabled, or

Go to \Program files\Common Files\System\MSMAPI\<LCID> where LCID 
refers to the local ID of the user. For USA English, this ID is 1033, and run 
ZCOLogCtl.exe and select Enable Logging.

After logging is enabled, reproduce the problem and click Open Log Folder to 
locate the log file.
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To resolve some problems, it might be necessary to configure the types of 
event logged by clicking Advanced Log Settings. Zimbra Support will advise if 
this is necessary.

Zimbra Support Toolbar

When ZCO is installed, the Zimbra Support Toolbar is added to the Outlook 
Views list. If users are having issues with specific emails or folders, you can 
use this toolbar to collect information to help debug the issue.

To display the Zimbra Support Toolbar, select View>Toolbars>Zimbra Support. 

The Zimbra Support Toolbar buttons are explained below.

View MAPI Properties

The Show Properties button shows a subset of the MAPI properties of an item. 
Select either Message or Folder in the bottom left of the MAPI properties dialog 
to view MAPI properties of a message and of the folder. You can click Save to 
File to save the MAPI properties of an item to a file.

Open Original Source

The Show Original button opens the source of the original item in the default 
Internet browser. The browser prompts you for the account login information 
before you can view the item. The source text includes the Zimbra Item ID, 
Folder ID, and any other information contained in the original item (such as 
tags, flags, header information, etc.).

View IDs of Zimbra Activities

The Open By Zimbra Id button allows you to view an email, appointment, task 
or other item in Outlook by its Zimbra Id. You can find the Zimbra Id of an item 
by using the Show Original button in the Zimbra Support Toolbar, or by the 
number listed in a Local Failure Notice.

Note:   Meeting requests cannot be opened by Zimbra Id. Drafts can be 
opened, but sometimes generate errors when opened by Zimbra Id.

Set Sync Token

The Set Sync Token button allows you to set the Zimbra sync token. Sync 
tokens track the syncs between an Outlook client and ZCS. Sync tokens 
increase in numerical value between one sync and the next. Setting a sync 
token to an earlier number allows you to resync any items that failed to sync 
between the sync token you set and the current sync token.

For example, if an appointment fails to sync to a user’s Outlook client they 
receive a Local Failure Notice in their Inbox and Sync Issues>Local Failures 
folders.
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To resync an item and update the user’s Outlook client with the most 
information, the Sync Token must be set to before the request that failed.

Note:   In some cases, sync failures might not be resolved unless the Sync 
Token number is set back several tokens before the failed sync. 

To set the sync token and attempt to resync an item that failed to sync, click 
Set Sync Token in the Zimbra Support Toolbar. The Update Sync Token dialog 
opens.

Enter the sync token to set. Click OK. To attempt to resync the item, click 
Send/Receive.

Zimbra Support and Additional Resources

If your issue is not a known or common issue, or is persisting despite 
troubleshooting, you can use the following additional resources to search for 
information about your issue or contact Zimbra Support for help.

Additional Resources

 Zimbra Forums. The Zimbra Forums, http://www.zimbra.com/forums, are 
a great place to find answers to problems and issues you may be 
experiencing. 

 Zimbra Wiki. The Zimbra Wiki has many articles and reference material 
about ZCO. Go to http://wiki.zimbra.com/wiki/Category:ZCO.

 Web Search. If you cannot find a solution to your issue through the Zimbra 
Forums, you might be able to find other resources or information using a 
Web search. 

Contact Zimbra Support

You can contact Zimbra Support at support@zimbra.com. To provide the 
highest level of service, gather the following information before contacting 
support.

 Steps for reproducing the problem. 

 Zimbra Support Toolbar output. You need to include any relevant Zimbra 
Support Toolbar output, described in Zimbra Support Toolbar on page 25.

Beyond the above information, include the following information if it is relevant 
to your problem. 

 Install logs. If users are experiencing issues with installing ZCO, include 
the install logs. You can create install logs by running the following 
command.

msiexec /i <zco-installer.msi> /lv <zco-install.log>

For example, the following command creates a ZCO install log named 
case00012345-zco-install.log.
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msiexec /i  ZimbraOlkConnector-5.0.6_GA_2314_5.0.2635.6.msi /lv 
case00012345-zco-install.log

 Sync error messages. If users are experiencing issues with syncing, 
include any relevant error messages. You can find sync error messages in 
the Local Failures and Server Failures folders, located in the Sync Issues 
mail folder. For more information about the Sync Issues folder, see 
Reviewing Sync Issues folders on page 24.

 Core files. If users are experiencing issues with ZCO crashing, include the 
automatically generated core files located in %temp%\zco-cores. If these 
core files have not been automatically generated, you can manually create 
a core dump using the instructions available at the Zimbra Wiki, located at 
http://wiki.zimbra.com/
index.php?title=Creating_a_Core_Dump_from_a_Running_Process_using
_WinDbg.
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