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ESG Family Signal Generators
Option 200
1 The Fully Coded W-CDMA Personality

This guide provides information specific to the Option 200 Fully Coded W-CDMA 
personality. This chapter contains an overview of Option 200.

NOTE This option requires the installation of Option UN8 (hardware Revision C or 
greater), Real-Time Baseband Generator. Refer to the Option UN8 user’s and 
programming guide for information.
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Overview
The Option 200 personality provides fully coded signals for W-CDMA, compliant to the 
following 3GPP Technical Specifications:

• downlink (base station simulation) 3G TS 25.101 V3.5 (2000-12)1

• uplink (user equipment simulation) 3G TS 25.141 V3.4 (2000-12)

This option supports pre-configured reference measurement channels for conformance 
testing, special channels (UDI 64k, multiple-block UDI ISDN, and AMR speech) for service 
verification, physical channels with user-configurable fields, and editing capability of 
transport channels.

Downlink Channels

The signal generator in the downlink mode supports the following channels:

NOTE The synchronization channel (SCH) is a downlink signal used for cell search. 
The SCH consists of two sub channels, the primary synchronization channel 
(P-SCH) and the secondary synchronization channel (S-SCH). The 10 ms 
radio frames of the P-SCH and S-SCH are divided into 15 slots, each 
2560-chips long.

P-SCH  The P-SCH consists of a modulated code, 256-chips long, transmitted once 
every slot. The primary synchronization code is the same for every cell in 
the system.

S-SCH  The S-SCH consists of a repeating synchronization code sequence 
transmitted in parallel with the P-SCH. The sequence is 15 slots in length, 
consisting of modulated codes, each 256-chips long and indicating to which 
of the code groups the cell’s downlink scrambling code belongs.

CPICH  The common pilot channel is a fixed rate physical channel that carries a 
pre-defined bit/symbol sequence.

P-CCPCH  The primary common control physical channel is a fixed rate physical 
channel used to carry the broadcast transport channel (BCH) and the 
incrementing system frame number (SFN).

PICH  The paging indicator channel is a fixed rate physical channel used to carry 
the paging indicators (PI). 

OCNS  The orthogonal coded noise source is required so that the total power 
spectral density of the base station (BS) is 0 dB.

1. The 3GPP W-CDMA user equipment performance tests described in this manual conform to
3G TS 25.101 v3.3 (2000-06). For information on the additional equipment required to perform 
receiver tests conforming to 3G TS 25.101 v3.5 (2000-12), call your nearest Agilent Technologies 
Sales and Service office.
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DPCH  The dedicated physical channel contains a time multiplex of a dedicated 
physical data channel (DPDCH) and a dedicated physical control channel 
(DPCCH). Refer to Figure 1-1.

This downlink mode supports slot formats 0–16 for DPDCH channels with editing 
capability.

Within the DPCCH channel, the transmit power control (TPC) field enables the user to 
select a pattern of commands to vary the power level and also has trigger output capability. 
In addition, user arbitrary pattern files are supported. The transport format combination 
indicator (TFCI) accepts 10 bit user inputs (default value 0000000000). 

The user can configure up to four QPSK W-CDMA channels simultaneously or the required 
synchronization channels (PSCH, SSCH, CPICH, PCCPCH) on a single ESG. The actual 
number of channels supported on a single ESG depends upon the selected channel types 
and their associated power levels.

The two-ESG configuration combines the baseband outputs to support both data and 
synchronization channels. See “Two ESG Downlink Measurement Setup” on page 2-6. 
Using two ESGs, a stimulus can be provided to perform bit error rate analysis of user 
equipment (UE) designs based on the requirements outlined in the 3GPP specification. 
Baseband signals are combined to provide the required 3GPP conformance test channels. 
The amplitude and carrier frequency of each ESG are independent to allow for adjacent 
channel selectivity, intermodulation response rejection, and blocking tests. With the same 
configuration, two phones can be tested simultaneously for increased throughput.

Figure 1-1 Example Downlink DPCH Coding
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Uplink Channel

The signal generator in the uplink mode supports the following channels:

DPCCH  The dedicated physical control channel carries the layer 1 control 
information. This channel is code multiplexed onto the I and Q channels 
using BPSK modulation. A typical configuration for the associated 
DPCCH runs at 15 ksps with 10 bits in each timeslot.

This mode supports slot formats 0 to 5 for DPCCH channel with editing 
capability. Refer to Table 4-10.

Within the DPCCH channel, the transmit power control (TPC) field 
enables the user to select a pattern of commands to vary the power level 
and also has trigger output capability. In addition, user arbitrary pattern 
files are supported. The transport format combination indicator (TFCI) 
accepts a 10 bit user pattern (default value 0000000000). The feedback 
information (FBI) bit is used for closed loop transmit diversity or to select 
the base station when in soft handoff conditions. Given its 15 kbps rate, 
the DPCCH has 10 bits available in each slot which are allocated for the 
pilot bits, TFCI bits, FBI bits, and TPC bits, according to the slot format 
selection. In the case of slot format 2, 5 bits are allocated for the embedded 
Pilot channel, 2 bits for TPC, 1 bit for FBI, and 2 bits for optional TFCI.

DPDCH  The dedicated physical data channel carries whatever transport channel 
data is mapped to it. The data rates on the DPDCH are multiples of the 
base rate of 15 kbps. These data rates are after error coding, rate 
matching, and multiplexing of transport channels. Each data rate 
configuration is identified by a slot format number. This channel is code 
multiplexed onto the I and Q channels using the BPSK modulation. A 
typical DPDCH running at 60 ksps has 40 data bits in each 667 
microsecond timeslot.

This mode supports slot formats 0 to 6 for DPDCH channel with editing 
capability. Refer to Table 4-11.

When compared with the downlink DPCCH and DPDCH coding, the uplink DPCCH and 
DPDCH coding are individually made as shown in Figure 1-2.
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Figure 1-2 Uplink DPCCH and DPDCH Coding
Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide 1-5



The Fully Coded W-CDMA Personality ESG Family Signal Generators
Overview Option 200
1-6 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators
Option 200
2 Using Functions

This chapter provides information on how to use functions that are unique to Option 200 
ESG Family signal generators. The chapter is divided into the following sections:

• “Single ESG Downlink Measurement Setup” on page 2-2

• “Two ESG Downlink Measurement Setup” on page 2-6

• “3GPP W-CDMA User Equipment Performance Tests” on page 2-18

• “Uplink Measurement Setup” on page 2-76

• “3GPP W-CDMA Base Station Performance Testing” on page 2-79

• “Troubleshooting” on page 2-115

You can configure Option 200 using either one or two signal generators.

A setup using a single ESG to test a subset of receiver parameters is provided on 
page 2-2.

A dual-output setup using two ESGs to test W-CDMA receiver designs is provided on 
page 2-6.

For 3GPP performance testing configurations, see “Two ESG Downlink Measurement 
Setup” on page 2-6.

The material in this chapter is presented with the assumption that you have a working 
knowledge of the ESG. For basic operating information, refer to the quick start guide and 
user’s guide.

For information on the operational theory of Option 200, refer to chapter 4.

NOTE References to preset refer to normal, factory preset conditions (Utility > 
Power On/Preset > Normal), not user preset.

Hardkeys and softkeys are denoted by Bold text; data fields within a setup 
editor are denoted by Courier Font.

Examples:

I/Q > I/Q Source (Ext I/Q) > Int I/Q

Mode > CDMA > W-CDMA > BS Setup > Filter

Hardkey Softkey Data Field
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Single ESG Downlink Measurement Setup

This setup provides four 3GPP channels with fully coded signal generation capability, 
which can be used to test a subset of 3GPP receiver parameters (such as receiver control or 
data transmission and code domain power adjustment).

Required Equipment

• one ESG-D/DP Family Signal Generator with Option 200

• one E4406A VSA Series Transmitter Tester with Option BAF

• BNC cables as needed 

Refer to Figure 2-1 and make the necessary connections between the ESG and the E4406A.

Figure 2-1 ESG Downlink Equipment Setup

Configuring the ESG 

NOTE The following signal generator settings are used for example purposes. 
Change them as needed for your device under test (DUT). 

1. Press Preset.

2. Press Frequency > 2.14 > GHz then press Amplitude > –30 > dBm .

3. Press Mode  > Real-time I/Q BaseBand  (if it appears) > CDMA > W-CDMA.
2-2 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators Using Functions
Option 200 Single ESG Downlink Measurement Setup
4. Press BS Setup.

This opens the base station (BS) setup editor. The highlight bar can be moved by 
rotating the front panel knob or pressing the arrow keys.

The following default values are displayed.

Filter   RNYQ (root Nyquist)

Chip Rate  3.840000 Mcps

Scrambling Code  0

5. Press Return to reopen the W-CDMA menu.

6. Press the Link Control softkey. 

This opens the Link Control setup editor and a predefined configuration is enabled. 
Refer to the following table.

7. Press Adjust Code Domain Power > Scale To 0dB. 

Notice that the power levels have changed on each channel. This has scaled the channel 
power levels to the proper amplitudes for transmission (the sum of the new power levels 
equals zero). The power ratios between the channels remain unchanged.

NOTE Adjusting the code domain power applies to active channels only.

Table 2-1 Predefined Downlink W-CDMA Physical Layer Configuration

Channel Parameter Setting

1 PhyCH Type PSCH

Power −8.30 dB

2 PhyCH Type SSCH

Power −8.30 dB

Secondary Scramble Code 
Group

0

3 PhyCH Type P-CCPCH

Power −5.30 dB

Channel Code 1

BCH Data 0000

4 PhyCH Type CPICH 

Power −3.30 dB

 Channel Code 0
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8. Press W-CDMA Off On. On is now highlighted and the WCDMA and I/Q annunciators are 
displayed.

9. Activate the RF output power by pressing RF On/Off until the RF ON annunciator is 
displayed.

Configuring the E4406A Option BAF VSA Series Transmitter Tester

This section explains how to set up the E4406A Option BAF VSA to display the downlink 
stimulus configured in the previous section.

Perform the following steps to view the code domain display:

1. Press Preset.

2. Set the VSA to use an external reference and ensure that it is set to 10 MHz.

Press: System > Reference > Freq Ref Int Ext > 10 > MHz 

Ext is now underscored.

3. Choose the W-CDMA option.

Press: Mode > More (1 of 2) > W-CDMA (3GPP)

4. Set the VSA to receive a base station signal.

Press: Mode Setup > Radio (ensure that BTS is underscored)

5. Set the center frequency to 2.14 GHz.

Press: FREQUENCY > Center Freq > 2.14 > GHz
Press: SPAN > 10 > MHz

6. Select code domain measurement.

Press: MEASURE > More (1 of 2) > Code Domain

7. Adjust the code domain spread code range.

Press: SPAN > Scale/Div > 64

NOTE Ensure that the center frequency is set appropriately for your DUT.
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The following figure shows the VSA code domain display.
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Two ESG Downlink Measurement Setup
This setup provides the capability to test 3GPP receiver designs for capability to test 
adjacent channel selectivity, blocking, intermodulation, maximum input, receiver 
sensitivity, and spurious response.

The following example configures a 3GPP receiver test stimulus.

Required Equipment

• two ESG-D Family Signal Generators with Option 200 and UN8

• one E4406A VSA Series Transmitter Tester with Option BAF

• one function generator (with an external frequency reference input or a 10 MHz 
frequency reference output) capable of providing an external ESG data clock input with 
the following characteristics:

— wave type: square 

— amplitude: 2.5 Vrms

— frequency: 3.84 MHz

— DC offset: +1.25 V

• 13 BNC cables (long, equal lengths)

• 6 BNC cables (short, equal lengths)

• 6 BNC tee splitters

• 3 BNC to BNC connectors

• 3 Type-N to BNC adapters (for ESG and VSA RF Output)

System Configuration Process

The two-ESG system configuration process is divided into the following subsections:

“Connect the Equipment” on page 2-7

“The W-CDMA Configuration” on page 2-8

“Configure ESG 1” on page 2-10

“Configure ESG 2” on page 2-11

“Adjust the Relative Power Mapping” on page 2-14

“Generate the Signal at the RF Output” on page 2-16

“Configure the E4406A Option BAF VSA Series Transmitter Tester” on page 2-16
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Connect the Equipment

1. Refer to Figure 2-2 and connect the two ESGs as shown:

NOTE This denotes a short cable.

This denotes a long cable.

Figure 2-2 ESG Downlink Equipment Setup

2. Turn on the function generator and set the following characteristics:

wave type:  square wave

amplitude:  2.5 Vrms

frequency:  3.84 MHz

DC offset:  +1.25 V

3. Turn on the signal generators and the transmitter tester.
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The W-CDMA Configuration

The following tables summarize the signal generator’s parameter settings for the 
W-CDMA configuration. This predefined configuration is later modified to provide the 
stimuli for several W-CDMA performance tests described in the section entitled, “3GPP 
W-CDMA User Equipment Performance Tests” on page 2-18.

Table 2-2 Predefined W-CDMA Physical Layer Configuration

ESG # Channel # Parameter Setting

ESG 1 Channel 1 PhyCH Type PSCH

Power −8.30 dB

ESG 1 Channel 2 PhyCH Type SSCH

Power −8.30 dB

Secondary Scramble Code Grp 0

ESG 1 Channel 3 PhyCH Type P-CCPCH

Power −5.30 dB

Channel Code 1 (Fixed Value)

BCH Data 0000

ESG 1 Channel 4 PhyCH Type CPICH

Power −3.30 dB

Channel Code 0 (Fixed Value)

ESG 2 Channel 1 PhyCH Type DPCH

Power −10.30 dB

Channel Code 6 (Arbitrary Value)

SecScr Code OS 0

TPC Pat Steps 1

Data Transport CH (See Table 4-12.)

Symbol Rate 7.500 ksps

TFCI Pattern 0000000000 (Arbitrary Value)

TPC Pattern Up/Down

Slot Format 11

Time Offset 0 (Arbitrary Value)

ESG 2 Channel 2 Channel State Off 

ESG 2 Channel 3 PhyCH Type PICH 

Power −8.30 dB

Channel Code 3 (Arbitrary Value)

Data PN9

PI Bits 288

Paging Indicator 144

ESG 2 Channel 4 Channel State Off 
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Table 2-3 Predefined W-CDMA Transport Layer Configuration

Parameter Setting

Reference Measurement Setup 
(For details, see Table 4-12.)

12.20 kbps

Table 2-4 Predefined W-CDMA Baseband Signal Configuration

Parameter Setting(s)

BTS Setup
(both ESGs)

Filter: RNYQ
Chip Rate: 3.840000 Mcps
Scramble Code: 0

BBG Data Clock (both ESGs) Ext 

Phase Polarity ESG 1: Normal
ESG 2: Normal

Two ESG Setup (Relative Power Mapping) ESG 1: enter values as required (See page 2-14.)
ESG 2: enter values as required

W-CDMA Off/On (both ESGs) On

Table 2-5 Predefined W-CDMA RF Carrier Configuration

Parameter Setting

Frequency 2140.00 MHz (ESG 1) (Arbitrary Value)

2140.00 MHz (ESG 2) (Arbitrary Value)

Amplitude −80.00 dBm (ESG 1)

−52.00 dBm (ESG2)

RF Off/On On (ESG 1)

Off (ESG 2)

Mod Off/On (both ESGs) On 

I Q Int/Ext Ext
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Configure ESG 1

1. Press Preset.

2. Press Frequency > 2.14 > GHz then press Amplitude > –80 > dBm .

3. Press Mode  > Real-time I/Q BaseBand  (if it appears) > CDMA > W-CDMA > 
BBG Data Clock Ext Int .

4. Press BS Setup .

This opens the base station (BS) setup editor. The highlight bar can be moved by 
rotating the front panel knob or pressing the arrow keys.

The following default values are displayed.

Filter   RNYQ (root Nyquist)

Chip Rate  3.840000 Mcps

Scrambling Code  0

NOTE Both ESGs must have the same parameter settings.

5. Press Return  to reopen the W-CDMA menu.

6. Press the Link Control softkey. 

This opens the Link Control setup editor and a predefined configuration is enabled. 
Refer to the following table.

7. Press Return  to reopen the W-CDMA menu.

Table 2-6 Predefined Downlink W-CDMA Physical Layer Configuration

Channel Parameter Setting

1 PhyCH Type PSCH

Power −8.30 dB

2 PhyCH Type SSCH

Power −8.30 dB

Secondary Scramble Code Group 0

3 PhyCH Type P-CCPCH

Power −5.30 dB

Channel Code 1

BCH Data 0000

4 PhyCH Type CPICH 

Power −3.30 dB

 Channel Code 0
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Configure ESG 2

1. Press Preset.

2. Press Frequency > 2.14 > GHz and then Amplitude > –52 > dBm .

3. Press Mode  > Real-time I/Q BaseBand  (if it appears) > CDMA > W-CDMA > 
BBG Data Clock Ext Int .

4. Press BS Setup .

This opens the base station (BS) setup editor. The highlight bar can be moved by 
rotating the front panel knob or pressing the arrow keys.

The following default values are displayed.

Filter   RNYQ (root Nyquist)

Chip Rate  3.840000 Mcps

Scrambling Code  0

NOTE Both ESGs must have the same parameter settings.

5. Press Return  to reopen the W-CDMA menu.
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6. Press the Link Control softkey. 

This opens the Link Control setup editor and a predefined configuration is enabled. 
Refer to the following table.

Table 2-7 Predefined Downlink W-CDMA Physical Layer Configuration

Channel Parameter Setting

1 PhyCH Type PSCH

Power −8.30 dB

2 PhyCH Type SSCH

Power −8.30 dB

Secondary Scramble Code Group 0

3 PhyCH Type P-CCPCH

Power −5.30 dB

Channel Code 1

BCH Data 0000

4 PhyCH Type CPICH 

Power −3.30 dB

 Channel Code 0
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7.  Press the following key sequences to configure the individual channels:

a. 2 > Enter > Channel State Off On (Off is now highlighted)

b. 4 > Enter > Channel State Off On (Off is now highlighted)

c. 1 > Enter > PhyCH Type > DPCH > PhyCH Setup > Power > –10.3 > dB  > Data > 
Edit Item  > Transport CH > Slot Format > 11 > Enter  > Apply Channel Setup  

The following figure displays the channel setup.

d. 3 > Enter > PhyCH Type  > PICH > PhyCH Setup  > Power > –8.3 > dB  > 
Apply Channel Setup

The following figure displays the channel setup.

8. Press Return  to reopen the W-CDMA menu.
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Adjust the Relative Power Mapping

Once the signal generators are configured as described in the previous steps, follow the 
steps in this section to perform the relative power mapping procedure. Relative power 
mapping assures proper channel power levels between the two ESGs and an overall code 
domain power of 0 dB. For more information, see “Understanding Relative Power 
Mapping” on page 4 -24.
1. To adjust the relative power mapping, return to the W-CDMA menu. 

Press More (1 of 2) > 2 Box Setup on both ESGs.

2. The percent power adjustment sets the parameters that will allow the scale to 0 dB 
function to scale all channels to 0 dB. This aligns the displayed power of both ESGs to 
match the code domain measurement values on the transmitter tester. To adjust 
percent power:

a. On ESG 1, highlight the % Power Other ESG: data field and enter the % Power 
This ESG value from ESG 2. Press Enter to terminate the entry. 

b. On ESG 2, highlight the % Power Other ESG: data field and enter the % Power 
This ESG value from ESG 1. Press Enter to terminate the entry. 

a. Enter this value here. b. Enter this value here.

ESG 2

ESG 1
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3. The individual ESG voltage adjustments are made to align the channel voltages 
between the signal generators by making adjustments to the I/Q voltage scale. While 
this scales the channels relative to each other, the total sum may be greater or less than 
0 dB. To adjust total voltage:

a. On ESG 1, highlight the Voltage Other ESG: data field and enter the Voltage 
This ESG value from ESG 2. Press Enter to terminate the entry. 

b. On ESG 2, highlight the Voltage Other ESG: data field and enter the Voltage 
This ESG value from ESG 1 into the Voltage Other ESG: data field on ESG 2. 
Press Enter to terminate the entry. The resulting I/Q voltage scale is displayed on the 
ESGs.

4. To scale the overall code domain power to 0 dB, press Scale to 0dB on both ESGs. The 
voltage and power values may change to reflect the power scaling. Press Return on both 
ESGs to open the W-CDMA menu.

NOTE Pressing Scale To 0 dB on both ESGs scales the individual channel power 
levels so that the sum of the code domain power generated by both ESGs 
equals 0 dB.This does not change the total, as set by the amplitude key.

a. Enter this value here. b. Enter this value here.

Resulting I/Q Voltage Scale

ESG 2

ESG 1
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Generate the Signal at the RF Output

Perform the following steps on both ESGs to generate a signal at the RF outputs.

1. Press W-CDMA Off On. On is now highlighted and the WCDMA and I/Q annunciators are 
displayed.

2. Press I/Q > I/Q Source > Ext I/Q. This sets the I/Q source to external.

3. Press RF On/Off. The RF ON annunciator is now displayed.

4. Connect the RF OUTPUT of ESG 2 to the RF INPUT of the VSA.

Configure the E4406A Option BAF VSA Series Transmitter Tester

This section explains how to set up the E4406A Option BAF VSA to display the downlink 
ESG parameters that were configured in the previous section.

Perform the following steps to show the code domain display:

1. Connect the RF OUTPUT from one of the signal generators to the RF INPUT of the 
transmitter tester.

2.  Press Preset.

3. Set the VSA to use an external reference and ensure that it is set to 10 MHz.

Press: System > Reference > Freq Ref Int Ext > 10 > MHz 

Ext is now underscored.

4. Choose the W-CDMA option.

Press: Mode > More (1 of 2) > W-CDMA (3GPP)

5. Set the VSA to receive a base station signal.

Press: Mode Setup > Radio (ensure that BTS is underscored)

6. Set the center frequency to 2.14 GHz and the span to 10 MHz.

Press: FREQUENCY > Center Freq > 2.14 > GHz
Press: SPAN > 10 > MHz

7. Select code domain measurement.

Press: MEASURE > More (1 of 2) > Code Domain

8. Adjust the code domain spread code range.

Press: SPAN > Scale/Div > 64

NOTE Ensure that the center frequency is set appropriately for your DUT.
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The following figure shows the VSA code domain display.
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3GPP W-CDMA User Equipment Performance Tests
This section includes signal generator configurations that will provide a stimulus for 
bit-error-ratio analysis of user equipment (UE) designs based on the requirements 
outlined in the 3GPP W-CDMA specification.1 

This section includes performance test summaries, test-specific signal generator settings, 
test system configurations, step-by-step instructions in the form of example test 
procedures, and example performance test records for testing the following performance 
specifications: 

• “Reference Sensitivity Level (3G TS 25.101.7.3)” on page 2-21

• “Maximum Input Level (3G TS 25.101.7.4)” on page 2-28

• “Adjacent Channel Selectivity (3G TS 25.101.7.5)” on page 2-35

• “Blocking Characteristics (3G TS 25.101.7.6)” on page 2-42

• “Spurious Response (3G TS 25.101.7.7)” on page 2-57

• “Intermodulation Characteristics (3G TS 25.101.7.8)” on page 2-65

• “Spurious Emissions (3G TS 25.101.7.9)” on page 2-742

NOTE Most 3GPP specification performance tests require a dual-output, two-ESG 
system configuration. Before continuing, you must connect and configure the 
dual-output, two-ESG system. Follow the instructions detailed in “Two ESG 
Downlink Measurement Setup” on page 2-6. 

After the system has been connected and configured, proceed to the desired 
performance test.

The performance test procedures based on these specifications can be performed in any 
order. Each test contains the required signal generator settings, test setups, and test 
procedures.

1. 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; UE 
Radio transmission and Reception (FDD) Technical Specification 3G TS 25.101 V3.3 (2000-06).

2. Performance test summary and test station setup only. Detailed VSA configuration and test 
procedures can be found in “Chapter 3. Making W-CDMA (3GPP) Measurements” of the 
Agilent Technologies E4406A VSA Series Transmitter Tester W-CDMA Measurement Guide.
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Required Equipment

The following equipment must be calibrated and must perform within the limits of its 
published specifications.

• two ESG signal generators configured as a dual-output, two-ESG W-CDMA mobile test 
solution

• E4406A VSA Series W-CDMA transmitter tester

• function generator (with an external frequency reference input) capable of providing an 
external ESG data clock input with the following characteristics:

— wave type: square

— amplitude: 2.5 Vrms

— frequency: 3.84 MHz

— DC offset: +1.25 V

• 83712B synthesized CW generator (or another signal source capable of providing CW at 
an amplitude range of −46 dBm to −15 dBm with an RF output frequency range of 
2.11 GHz to 12.75 GHz)

• a UE test mode designed to allow the controller to assign the UE a dedicated physical 
channel on which to receive and demodulate the transmitted data1 

• A system controller and software capable of providing control data to the UE 

• software and/or hardware (a BER test platform) capable of measuring, calculating and 
storing the UE’s bit error ratio (BER) while exposed to the test stimulus

• microwave frequency combiner

• BNC cables, tee splitters and adapters

• adapters and antennae as required by the UE

NOTE All ESG signal parameters are specified at the front panel RF OUTPUT 
connector. Losses due to cabling and signal combining must be considered 
when performing the tests.

1. The signal generator does not receive nor act upon uplink data from the UE.
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ESG Physical Layer and Transport Layer Configuration

The physical layer and transport layer channelizations are configured separately. Physical 
layer configurations change as required for each individual performance test. The specified 
channel types and power levels are modified to provide the required stimulus for 
performing the individual performance specification tests.

The ESG provides a single-softkey solution for configuring factory-defined transport layer 
channelization. This predefined reference measurement channel is used as the transport 
layer configuration throughout the specification performance tests. For specific 
information regarding transport layer channelization based on this factory-defined setting, 
see “Understanding the Reference Measurement Channel” on page 4-18.
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Reference Sensitivity Level (3G TS 25.101.7.3)

This section explains how to complete a reference sensitivity level performance test on 
your user equipment (UE). It includes a process definition, signal generator 
configurations, test system connections, abbreviations, an example test procedure and 
performance test record.

Specification Definition

Reference sensitivity level is a measure of the minimum receiver input power at the 
antenna port at which the bit error ratio does not exceed a specified value.1

Performance Test Objective

The objective of this performance test is to determine the Reference Sensitivity Level 
(RSL) performance of your UE against limitations described in the 3GPP W-CDMA RF 
specification (3G TS 25.101 V3.3).

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring Bit Error Ratio (BER) at a 
specified minimum power level measured at the UE antenna port.

Abbreviations

Definitions of abbreviations used throughout 3G TS 25.101 V3.3 and the following example 
performance test procedure:

Îor the received power spectral density2 of the downlink as measured at the 
UE antenna connector

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
UE Radio transmission and Reception (FDD) Technical Specification 3G TS 25.101 V3.3 (2000-06).

2. Defined as the ratio dBm/3.84 Mcps.
Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide 2-21



Using Functions ESG Family Signal Generators
3GPP W-CDMA User Equipment Performance Tests Option 200
Process

ESG Configuration

For a connection diagram, see “Two ESG Downlink Measurement Setup” on page 2-6.

Configure the signal generators by using the front panel hardkeys and softkeys (or the 
appropriate SCPI commands) to enter the values listed in Table 2-8, Table 2-9, Table 2-10, 
and Table 2-11. 

NOTE Enter values on both signal generators, unless otherwise noted. Channel State 
Off On is set to On for all channels, unless otherwise noted.

Measure BER
Performance

Does BER 
Meet Spec?

START

END

Decrease Îor Measure BER
Performance

Does BER 
Meet Spec?

Repair

Troubleshoot

Y

N

Y

N

Amplitude

KEY

UE BER 

Verification
Performance

RSL
BER Test
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Table 2-8 RSL Physical Layer Configuration

ESG # Channel # Parameter Setting

ESG 1 Channel 1 PhyCH Type PSCH

Power −8.3 dB

ESG 1 Channel 2 PhyCH Type SSCH

Power −8.3 dB

Secondary Scramble Code Grp 0

ESG 1 Channel 3 PhyCH Type P-CCPCH

Power −5.3 dB

Channel Code 1 (Fixed Value)

BCH Data 0000

ESG 1 Channel 4 PhyCH Type CPICH

Power −3.3 dB

Channel Code 0 (Fixed Value)

ESG 2 Channel 1 PhyCH Type DPCH

Power −10.3 dB

Channel Code 6 (Arbitrary Value)

SecScr Code OS 0

TPC Pat Steps 1

Data Ref 12 (See Table 4-12.)

Symbol Rate 30.00 ksps

TFCI Pattern 0000000000

TPC Pattern Up/Down

Slot Format 11

Time Offset 0

ESG 2 Channel 2 Channel State Off/On Off 

ESG 2 Channel 3 PhyCH Type PICH 

Power −8.3 dB

Channel Code 3 (Arbitrary Value)

Data PN9

PI Bits 288

Paging Indicator 144

ESG 2 Channel 4 Channel State Off/On Off 
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Table 2-9 RSL Transport Layer Configuration

Parameter Setting

Reference Measurement Setup1 12.2 kbps (ESG 2)

1 For details, see Table 4-12.

Table 2-10 RSL W-CDMA Baseband Signal Configuration

Parameter Setting(s)

BS Setup Filter: RNYQ
Chip Rate: 3.840000 Mcps
Scramble Code: 0

BBG Data Clock Ext

Phase Polarity Normal 

Two Box Setup (Relative Power Mapping) Enter values as required.1 

W-CDMA Off/On On

1 For detailed information, see “Adjust the Relative Power Mapping” on page 2-14.

Table 2-11 RSL W-CDMA RF Carrier Configuration

Parameter Setting

Frequency 2140.0 MHz (ESG 1)

Amplitude1 −80.0 dBm (ESG 1)

RF Off/On2 On (ESG 1)
Off (ESG 2)

Mod Off/On On (ESG 1)

1 The amplitude of the RF output of ESG 1 is initially set to an arbitrary value (−80.0 dBm), 
in order to perform a BER verification measurement. After BER verification, the 
amplitude will be modified to the required value (−106.7 dBm) in accordance with the 
3GPP specification for this performance test.

2 No RF output is required from ESG 2 for this performance test.
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Example Test Procedure

Follow this example procedure to perform a 3GPP W-CDMA reference level sensitivity test 
on your UE. Complete the subsections of this procedure sequentially, in the order in which 
they appear in this document.

Subsection 1. Equipment Setup and Preliminary BER Verification  

Complete the following steps to connect the equipment and perform a BER verification test 
on your UE. 

Figure 2-3 Reference Level Sensitivity Equipment Setup

1. Connect the UE to the test system as shown in Figure 2-3.

a. Using the appropriate cables, adapters, and antennae, connect the output of ESG 1 
to the RF input of the UE.

b. Connect the system controller (and the BER test platform) to the UE.

2. Perform call acquisition functions for the UE.

From the system controller, perform all of the call acquisition functions required to 
enable the UE to demodulate transmitted data, in order to perform bit error ratio 
measurements. 

These call acquisition functions include:

a. acquiring the primary synchronization channel (P-SCH),

b. acquiring the secondary synchronization channel (S-SCH) and determining the 
secondary scramble code group,

c. acquiring and synchronizing to the common pilot channel (CPICH),

d. acquiring the primary common control physical channel (PCCPCH) and determining 
system frame number.
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At this point, the controller must configure the UE into a test mode. With the UE 
operating in test mode, the controller assigns the UE a dedicated physical channel on 
which to receive and demodulate the transmitted data. 

3. Measure the Bit Error Ratio (BER) of the data received by the UE on RMC 12.2 kbps 
(25.101 V3.3).

The controller (or BER test platform) is measuring the bit error ratio of the UE exposed 
to Îor (the RF output of ESG 1) at an arbitrary amplitude. This process verifies that the 
BER of the UE is within specification prior to decreasing the amplitude of Îor.

4. In Table 2-12, record the measured BER value in the column titled, “Verification BER 
Value.”

5. Compare the measured BER value in the column titled, “Verification BER Value” with 
the limits from the column titled, “Specification Limitations.”

• If the measured value is within the limits, continue to subsection 2.

• If the measured value is outside the limits, determine the cause of failure and repair 
the UE. After repair, return to Step 1 of this subsection.

Subsection 2. Reference Sensitivity Level Measurement  

Complete the following steps to perform a reference sensitivity level measurement on your 
UE. 

1. Decrease the amplitude level of Îor.

In accordance with the 3GPP W-CDMA RF specification, decrease the amplitude of Îor 
to −106.7 dBm.

On ESG 1: Press Amplitude > −106.7 > dBm.

2. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) at the 
decreased amplitude.

The controller (or BER test platform) is measuring the bit error ratio of the UE with an 
Îor amplitude of −106.7 dBm.

3. In Table 2-12, record the measured BER value in the column titled, “Minimum 
Amplitude BER Value.”

4. Compare the recorded BER value in the column titled, “Minimum Amplitude BER 
Value” to the allowable values in the column titled, “Specification Limitations” and 
record the status of the UE as PASS or FAIL in the column titled, “PASS/FAIL Status.”
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Example Test Record

Use the following table to record the data from the RSL performance test.

Table 2-12 RSL Performance Test Record

Verification BER 
Value

Minimum 
Amplitude 
BER Value

Specification 
Limitations

PASS/FAIL Status

BER ≤ 0.001
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Maximum Input Level (3G TS 25.101.7.4)

This section explains how to complete a maximum input level performance test on your 
user equipment (UE). It includes a process definition, signal generator configurations, test 
system connections, abbreviations, an example test procedure and performance test 
record.

Specification Definition

Maximum input level is a measure of the maximum receiver input power at the antenna 
port, which does not degrade the specified BER performance.1

Performance Test Objective

The objective of this performance test is to determine the Maximum Input Level (MIL) 
performance of your UE against limitations described in the 3GPP W-CDMA RF 
specification (3G TS 25.101 V3.3). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring Bit Error Ratio (BER) at a 
specified maximum power level measured at the UE antenna port.

Abbreviations

Definitions of abbreviations used throughout 3G TS 25.101 V3.3 and the following example 
performance test procedure:

Îor the received power spectral density2 of the downlink as measured at the 
UE antenna connector

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
UE Radio transmission and Reception (FDD) Technical Specification 3G TS 25.101 V3.3 (2000-06).

2. Defined as the ratio dBm/3.84 Mcps.
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ESG Configuration

For a connection diagram, see “Two ESG Downlink Measurement Setup” on page 2-6.

Configure the signal generators by using the front panel hardkeys and softkeys (or the 
appropriate SCPI commands) to enter the values listed in Table 2-13, Table 2-14, 
Table 2-15, and Table 2-16. 

NOTE Enter values on both signal generators, unless otherwise noted. Channel State 
Off On is set to On for all channels, unless otherwise noted.

Measure BER
Performance

Does BER 
Meet Spec?

START

END

Increase Îor Measure BER
Performance

Does BER 
Meet Spec?

Repair

Troubleshoot

Y

N

Y

N

Amplitude

KEY

UE BER 

Verification
Performance

MIL
BER Test
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Table 2-13 MIL Physical Layer Configuration

ESG # Channel # Parameter Setting

ESG 1 Channel 1 PhyCH Type PSCH

Power −15.0 dB

ESG 1 Channel 2 PhyCH Type SSCH

Power −15.0 dB

Secondary Scramble Code Grp 0

ESG 1 Channel 3 PhyCH Type P-CCPCH

Power −12.0 dB

Channel Code 1 (Fixed Value)

BCH Data 0000

ESG 1 Channel 4 PhyCH Type CPICH

Power −10.0 dB

Channel Code 0 (Fixed Value)

ESG 2 Channel 1 PhyCH Type DPCH

Power −19.0 dB

Channel Code 6 (Arbitrary value)

SecScr Code OS 0

TPC Pat Steps 1

Data Ref 12 (See Table 4-12)

Symbol Rate 30.00 ksps

TFCI Pattern 0000000000

TPC Pattern Up/Down

Slot Format 11

Time Offset 0

ESG 2 Channel 2 PhyCH Type OCNS 

Power −1.37 dB

Data PN9

Symbol Rate 30.00 kHz

Channel Code 6

SecSrc Code OS 0

ESG 2 Channel 3 PhyCH Type PICH 

Power −15.0 dB

Channel Code 3 (Arbitrary value)

Data PN9

PI Bits 288

Paging Indicator 144

ESG 2 Channel 4 Channel State Off/On Off 
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Table 2-14 MIL Transport Layer Configuration

Parameter Setting

Reference Measurement Setup1 12.2 kbps

1 For details, see Table 4-12.

Table 2-15 MIL W-CDMA Baseband Signal Configuration

Parameter Setting(s)

BS Setup Filter: RNYQ
Chip Rate: 3.840000 Mcps
Scramble Code: 0

BBG Data Clock Ext

Phase Polarity Normal

Two Box Setup (Relative Power Mapping) Enter values as required.1

W-CDMA Off/On On

1 For detailed information, see “Adjust the Relative Power Mapping” on page 2-14.

Table 2-16 MIL W-CDMA RF Carrier Configuration

Parameter Setting

Frequency 2140.0 MHz (ESG 1)

Amplitude1 −80.0 dBm (ESG 1)

RF Off/On2 On (ESG 1)
Off (ESG 2)

Mod Off/On On (ESG 1)

1 The amplitude of the RF output of ESG 1 is initially set to an arbitrary value (−80.0 dBm), 
in order to perform a BER verification measurement. After BER verification, the 
amplitude will be modified to the required value (−25.0 dBm) in accordance with the 
3GPP specification for this performance test.

2 No RF output is required from ESG 2 for this performance test.
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Example Test Procedure

Follow this example procedure to perform a 3GPP W-CDMA maximum input level test on 
your UE. Complete the subsections of this procedure sequentially, in the order in which 
they appear in this document.

Subsection 1. Equipment Setup and Preliminary BER Verification  

Complete the following steps to connect the equipment and perform a BER verification test 
on your UE. 

Figure 2-4 Maximum Input Level Equipment Setup

1. Connect the UE to the test system as shown in Figure 2-4.

a. Using the appropriate cables, adapters, and antennae, connect the output of ESG 1 
to the RF input of the UE.

b. Connect the system controller (and the BER test platform) to the UE.

2. Perform call acquisition functions for the UE.

From the system controller, perform all of the call acquisition functions required to 
enable the UE to demodulate transmitted data, in order to perform bit error ratio 
measurements. 

These call acquisition functions include:

a. acquiring the primary synchronization channel (P-SCH),

b. acquiring the secondary synchronization channel (S-SCH) and determining the 
secondary scramble code group,

c. acquiring and synchronizing to the common pilot channel (CPICH),

d. acquiring the primary common control physical channel (PCCPCH) and determining 
system frame number.
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At this point, the controller must configure the UE into a test mode. With the UE 
operating in test mode, the controller assigns the UE a dedicated physical channel on 
which to receive and demodulate the transmitted data. 

3. Measure the Bit Error Ratio (BER) of the data received by the UE on RMC 12.2 kbps 
(25.101 V3.3).

The controller (or BER test platform) is measuring the bit error ratio of the UE exposed 
to Îor (the RF output of ESG 1) at an arbitrary amplitude. This process verifies that the 
BER of the UE is within specification prior to increasing the amplitude of Îor.

4. In Table 2-17, record the measured BER value in the column titled, “Verification BER 
Value.”

5. Compare the measured BER value in the column titled, “Verification BER Value” with 
the limits from the column titled, “Specification Limitations.”

• If the measured value is within the limits, continue to subsection 2.

• If the measured value is outside the limits, determine the cause of failure and repair 
the UE. After repair, return to Step 1 of this subsection.

Subsection 2. Maximum Input Level Measurement  

Complete the following steps to perform a maximum input level measurement on your UE. 

1. Increase the amplitude of Îor to the required value.

In accordance with the 3GPP W-CDMA RF specification, increase the amplitude of Îor 
to −25.0 dBm.

On ESG 1:

Press Amplitude > −25 > dBm. 

2. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) at the 
increased amplitude.

The controller (or BER test platform) is measuring the bit error ratio of the UE with an 
Îor amplitude of −25.0 dBm.

3. In Table 2-17, record the measured BER value in the column titled, “Maximum 
Amplitude BER Value.”

4. Compare the recorded BER value in the column titled, “Maximum Amplitude BER 
Value” to the allowable values in the column titled, “Specification Limitations” and 
record the status of the UE as PASS or FAIL in the column titled, “PASS/FAIL Status.”
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Example Test Record

Use the following table to record the data from the MIL performance test.

Table 2-17 MIL Performance Test Record

Verification BER 
Value

Maximum 
Amplitude 
BER Value

Specification 
Limitations

PASS/FAIL Status

BER ≤ 0.001
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Adjacent Channel Selectivity (3G TS 25.101.7.5)

This section explains how to complete an adjacent channel selectivity performance test on 
your user equipment (UE). It includes a process definition, signal generator configuration, 
test system connections, abbreviations, an example test procedure and performance test 
record.

Specification Definition

Adjacent Channel Selectivity (ACS) is a measure of a receiver’s ability to receive a 
W-CDMA signal at its assigned frequency in the presence of an adjacent channel signal at 
a given frequency offset from the center frequency of the assigned channel.1

Performance Test Objective

The objective of this performance test is to determine the ACS performance of your UE 
against limitations described in the 3GPP W-CDMA RF specification (3G TS 25.101 V3.3). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring Bit Error Ratio (BER) in 
the presence of a specified adjacent channel interferer.

Abbreviations

Definitions of abbreviations used throughout 3G TS 25.101 V3.3 and the following example 
performance test procedure:

Îor the received power spectral density2 of the downlink as measured at the 
UE antenna connector

Ioac the received power spectral density of the adjacent channel interferer as 

measured at the UE antenna connector3

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
UE Radio transmission and Reception (FDD) Technical Specification 3G TS 25.101 V3.3 (2000-06).

2. Defined as the ratio dBm/3.84 Mcps.
3. Undefined in 3G TS 25.101 V3.3.
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Process

ESG Configuration

For a connection diagram, see “Two ESG Downlink Measurement Setup” on page 2-6. 

Configure the signal generators by using the front panel hardkeys and softkeys (or the 
appropriate SCPI commands) to enter the values listed in Table 2-18, Table 2-19, Table 
2-20, and Table 2-21. 

NOTE Enter values on both signal generators, unless otherwise noted. Channel State 
Off On is set to On for all channels, unless otherwise noted.

Measure BER
Performance

Does BER 
Meet Spec?

START

END

Introduce ACS
Interferer

Measure BER
Performance

Does BER 
Meet Spec?

Repair

Troubleshoot

Y

N

Y

N KEY

UE BER 

Verification
Performance

ACS
BER Test
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Table 2-18 ACS Physical Layer Configuration

ESG # Channel # Parameter Setting

ESG 1 Channel 1 PhyCH Type PSCH

Power −8.3 dB

ESG 1 Channel 2 PhyCH Type SSCH

Power −8.3 dB

Secondary Scramble Code Grp 0

ESG 1 Channel 3 PhyCH Type P-CCPCH

Power −5.3 dB

Channel Code 1 (Fixed Value)

BCH Data 0000

ESG 1 Channel 4 PhyCH Type CPICH

Power −3.3 dB

Channel Code 0 (Fixed Value)

ESG 2 Channel 1 PhyCH Type DPCH

Power −10.3 dB

Channel Code 6 (Arbitrary Value)

SecScr Code OS 0

TPC Pat Steps 1

Data Ref 12 (See Table 4-12.)

Symbol Rate 30.00 ksps

TFCI Pattern 0000000000

TPC Pattern Up/Down

Slot Format 11

Time Offset 0

ESG 2 Channel 2 Channel State Off/On Off 

ESG 2 Channel 3 PhyCH Type PICH 

Power −8.3 dB

Channel Code 3 (Arbitrary Value)

Data PN9

PI Bits 288

Paging Indicator 144

ESG 2 Channel 4 Channel State Off/On Off 
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Table 2-19 ACS Transport Layer Configuration

Parameter Setting

Reference Measurement Setup1 12.2 kbps (ESG 2)

1 For details, see Table 4-12.

Table 2-20 ACS W-CDMA Baseband Signal Configuration

Parameter Setting(s)

BS Setup Filter: RNYQ
Chip Rate: 3.840000 Mcps
Scramble Code: 0

BBG Data Clock Ext

Phase Polarity Normal

Two Box Setup (Relative Power Mapping) Enter values as required.1

W-CDMA Off/On On

1 For detailed information, see “Adjust the Relative Power Mapping” on page 2-14.

Table 2-21 ACS W-CDMA RF Carrier Configuration

Parameter Setting

Frequency1 2140.0 MHz (ESG 1) (Arbitrary Value)
2145.0 MHz or 2135.0 MHz (ESG 2)

Amplitude2 −80.0 dBm (ESG 1) (Arbitrary Value)
−52.0 dBm (ESG 2)

RF Off/On3 On (ESG 1)
Off (ESG 2)

Mod Off/On On

1 The frequency of the unwanted signal generated at the output of ESG 2 must be ±5 MHz 
from the fundamental waveform generated at the output of ESG 1.

2 The amplitude of the RF output of ESG 1 is initially set to an arbitrary value (−80.0 dBm), 
in order to perform a BER verification measurement. After BER verification, the 
amplitude will be modified to the required value (−92.7 dBm) in accordance with the 
3GPP specification for this performance test.

3 The RF output of ESG 2 remains off until the initial BER verification measurement has 
been performed. After BER verification, the RF output of ESG 2 (the interferer) will be 
applied to the UE in accordance with the 3GPP specification for this performance test.
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Example Test Procedure

Follow this example procedure to perform a 3GPP W-CDMA adjacent channel selectivity 
test on your UE. Complete the subsections of this procedure sequentially, in the order in 
which they appear in this document.

Subsection 1. Equipment Setup and Preliminary BER Verification  

Complete the following steps to connect the equipment and perform a BER verification test 
on your UE. 

Figure 2-5 BER Verification Equipment Setup

1. Connect the UE to the test system as shown in Figure 2-5.

a. Using the appropriate cables, adapters, and antennae, connect the output of ESG 1 
to the RF input of the UE.

b. Connect the system controller (and the BER test platform) to the UE.

2. Perform call acquisition functions for the UE.

From the system controller, perform all of the call acquisition functions required to 
enable the UE to demodulate transmitted data, in order to perform bit error ratio 
measurements. 

These call acquisition functions include:

a. acquiring the primary synchronization channel (P-SCH),

b. acquiring the secondary synchronization channel (S-SCH) and determining the 
secondary scramble code group,

c. acquiring and synchronizing to the common pilot channel (CPICH),

d. acquiring the primary common control physical channel (PCCPCH) and determining 
system frame number.
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At this point, the controller must configure the UE into a test mode. With the UE 
operating in test mode, the controller assigns the UE a dedicated physical channel on 
which to receive and demodulate the transmitted data. 

3. Measure the Bit Error Ratio (BER) of the data received by the UE on RMC 12.2 kbps 
(25.101 V3.3).

The controller (or BER test platform) is measuring the bit error ratio of the UE exposed 
to Îor (the RF output of ESG 1) only. This process verifies that the BER of the UE is 
within specification prior to the introduction of the adjacent channel interferer.

4. In Table 2-22, record the measured BER value in the column titled, “Verification BER 
Value.”

5. Compare the measured BER value in the column titled, “Verification BER Value” with 
the limits from the column titled, “Specification Limitations.”

• If the measured value is within the limits, continue to subsection 2.

• If the measured value is outside the limits, determine the cause of failure and repair 
the UE. After repair, return to Step 1 of this subsection.

Subsection 2. ACS Measurements  

Complete the following steps to perform adjacent channel selectivity measurements on 
your UE. 

Figure 2-6 ACS Measurement Equipment Setup

1. Connect the additional equipment to the test system as shown in Figure 2-6.

a. Connect the RF output of ESG 1 to one input of the signal combiner.

b. Connect the RF output of ESG 2 to one input of the signal combiner.

c. Connect the signal combiner output to the RF input of the UE.
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2. Adjust the amplitude of Îor to the required value.

 In accordance with the 3GPP specification, adjust the amplitude of Îor to −92.7 dBm.

On ESG 1: Press Amplitude > −92.7 > dBm. 

3. Introduce the adjacent channel (Ioac) waveform.

The adjacent channel stimulus is made available at the RF output of ESG 2. In 
accordance with the 3GPP W-CDMA RF specification, the center frequency of Ioac can 
be ±5 MHz from the center frequency of Îor. The amplitude of Ioac is −52.0 dBm.

On ESG 2:

Press RF On/Off (or execute the appropriate SCPI command) until the RF ON 
annunciator is displayed.

4. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the adjacent channel interferer.

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of both RF output waveforms, Îor (from ESG 1) and the adjacent channel 
interferer Ioac (from ESG 2).

5. In Table 2-22, record the measured BER value in the column titled, “Adjacent Channel 
BER Value.”

6. Compare the recorded BER value in the column titled, “Adjacent Channel BER Value” 
to the allowable values in the column titled, “Specification Limitations” and record the 
status of the UE as PASS or FAIL in the column titled, “PASS/FAIL Status.”

Example Test Record

Use the following table to record the data from the ACS performance test.

Table 2-22 ACS Performance Test Record

Verification BER 
Value

Adjacent Channel 
BER Value

Specification 
Limitations

PASS/FAIL Status

BER ≤ 0.001
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Blocking Characteristics (3G TS 25.101.7.6)

This section explains how to complete a blocking characteristics performance test on your 
user equipment (UE). It includes a process definition, signal generator configurations, test 
system connections, abbreviations, an example test procedure and performance test 
record.

NOTE An external source capable of providing CW at an amplitude of −15 dBm 
across a frequency range of 4 to 12.750 GHz is required for band 3 out-of-band 
performance testing above 4 GHz (or the maximum RF output frequency of 
your ESG).

Specification Definition

The blocking characteristic is a measure of the receiver’s ability to receive a desired signal 
at its assigned channel frequency in the presence of an undesired interferer on frequencies 
other than those of the spurious response or the adjacent channels, without this undesired 
input signal causing receiver performance degradation beyond a specified limit.1

Performance Test Objective

The objective of this performance test is to determine the in-band and out-of-band blocking 
characteristic performance of your UE against limitations described in the 3GPP W-CDMA 
RF specification (3G TS 25.101 V3.3). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring Bit Error Ratio (BER) in 
the presence of specified interferers at in-band and out-of-band frequencies (other than 
spurious response or adjacent channel frequencies).

Abbreviations

Definitions of abbreviations used throughout 3G TS 25.101 V3.3 and the following example 
performance test procedure:

Îor the received power spectral density2 of the downlink as measured at the 
UE antenna connector

Iblocking the received power spectral density of the modulated or CW blocking 

interferer as measured at the UE antenna connector3

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
UE Radio transmission and Reception (FDD) Technical Specification 3G TS 25.101 V3.3 (2000-06).

2. Defined as the ratio dBm/3.84 Mcps.
3. Undefined in 3G TS 25.101 V3.3.
2-42 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators Using Functions
Option 200 3GPP W-CDMA User Equipment Performance Tests
Process
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ESG Configuration

For a connection diagram, see “Two ESG Downlink Measurement Setup” on page 2-6.

Configure the signal generators by using the front panel hardkeys and softkeys (or the 
appropriate SCPI commands) to enter the values listed in Table 2-23, Table 2-24, 
Table 2-25, and Table 2-26. 

NOTE Enter values on both signal generators, unless otherwise noted. Channel State 
Off On is set to On for all channels, unless otherwise noted.
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Table 2-23 Blocking Characteristics Physical Layer Configuration

ESG # Channel # Parameter Setting

ESG 1 Channel 1 PhyCH Type PSCH

Power −8.3 dB

ESG 1 Channel 2 PhyCH Type SSCH

Power −8.3 dB

Secondary Scramble Code Grp 0

ESG 1 Channel 3 PhyCH Type P-CCPCH

Power −5.3 dB

Channel Code 1 (Fixed Value)

BCH Data 0000

ESG 1 Channel 4 PhyCH Type CPICH

Power −3.3 dB

Channel Code 0 (Fixed Value)

ESG 2 Channel 1 PhyCH Type DPCH

Power −10.3 dB

Channel Code 6 (Arbitrary Value)

SecScr Code OS 0

TPC Pat Steps 1

Data Ref 12 (See Table 4-12.)

Symbol Rate 30.00 ksps

TFCI Pattern 0000000000

TPC Pattern Up/Down

Slot Format 11

Time Offset 0

ESG 2 Channel 2 Channel State Off/On Off 

ESG 2 Channel 3 PhyCH Type PICH 

Power −8.3 dB

Channel Code 3 (Arbitrary Value)

Data PN9

PI Bits 288

Paging Indicator 144

ESG 2 Channel 4 Channel State Off/On Off 
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Table 2-24 Blocking Characteristics Transport Layer Configuration

Parameter Setting

Reference Measurement Setup1 12.2 kbps (ESG 2)

1 For details, see Table 4-12.

Table 2-25 Blocking Characteristics W-CDMA Baseband Signal Configuration

Parameter Setting(s)

BS Setup Filter: RNYQ
Chip Rate: 3.840000 Mcps
Scramble Code: 0

BBG Data Clock Ext

Phase Polarity Normal

Two Box Setup (Relative Power Mapping) Enter values as required.1

W-CDMA Off/On On

1 For detailed information, see “Adjust the Relative Power Mapping” on page 2-14.

Table 2-26 Blocking Characteristics W-CDMA RF Carrier Configuration

Parameter Setting

Frequency1 2140.0 MHz (ESG 1) (Arbitrary Value)
2150.0 MHz or 2130.0 MHz (ESG 2)

Amplitude2 −80.0 dBm (ESG 1) (Arbitrary Value)
−52.0 dBm (ESG 2)

RF Off/On3 On (ESG 1)
Off (ESG 2)

Mod Off/On On

1 The frequency of the unwanted signal generated at the output of ESG 2 must be ±10 MHz 
from the fundamental waveform generated at the output of ESG 1.

2 The amplitude of the RF output of ESG 1 is initially set to an arbitrary value (−80.0 dBm), 
in order to perform a BER verification measurement. After BER verification, the 
amplitude will be modified to the required value (−92.7 dBm) in accordance with the 
3GPP specification for this performance test.

3 The RF output of ESG 2 remains off until the initial BER verification measurement has 
been performed. After BER verification, the RF output of ESG 2 (the interferer) will be 
applied to the UE in accordance with the 3GPP specification for this performance test.
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Example Test Procedure

Follow this example procedure to perform a 3GPP W-CDMA blocking characteristics test 
on your UE. Complete the subsections of this procedure sequentially, in the order in which 
they appear in this document.

Subsection 1. Equipment Setup and Preliminary BER Verification  

Complete the following steps to connect the equipment and perform a BER verification test 
on your UE. 

Figure 2-7 BER Verification Equipment Setup

1. Connect the UE to the test system as shown in Figure 2-7.

a. Using the appropriate cables, adapters, and antennae, connect the output of ESG 1 
to the RF input of the UE.

b. Connect the system controller (and the BER test platform) to the UE.

2. Perform call acquisition functions for the UE.

From the system controller, perform all of the call acquisition functions required to 
enable the UE to demodulate transmitted data, in order to perform bit error ratio 
measurements. 

These call acquisition functions include:

a. acquiring the primary synchronization channel (P-SCH),

b. acquiring the secondary synchronization channel (S-SCH) and determining the 
secondary scramble code group,

c. acquiring and synchronizing to the common pilot channel (CPICH),

d. acquiring the primary common control physical channel (PCCPCH) and determining 
system frame number.
2-48 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators Using Functions
Option 200 3GPP W-CDMA User Equipment Performance Tests
At this point, the controller must configure the UE into a test mode. With the UE 
operating in test mode, the controller assigns the UE a dedicated physical channel on 
which to receive and demodulate the transmitted data. 

3. Measure the Bit Error Ratio (BER) of the data received by the UE on RMC 12.2 kbps 
(25.101 V3.3).

The controller or (BER test platform) is measuring the bit error ratio of the UE exposed 
to Îor (the RF output of ESG 1) only. This process verifies that the BER of the UE is 
within specification prior to the introduction of the Iblocking interferer.

4. In Table 2-27, record the measured BER value in the column titled, “Verification BER 
Value.”

5. Compare the measured BER value in the column titled, “Verification BER Value” with 
the limits from the column titled, “Specification Limitations.”

• If the measured value is within the limits, continue to subsection 2.

• If the measured value is outside the limits, determine the cause of failure and repair 
the UE. After repair, return to Step 1 of this subsection.

Subsection 2. In-Band Blocking Characteristics Measurements  

Complete the following steps to make in-band blocking characteristics measurements on 
your UE. 

Figure 2-8 Blocking Characteristics Measurements Equipment Setup 1

1. Connect the additional equipment to the test system as shown in Figure 2-8.

a. Connect the RF output of ESG 1 to one input of the signal combiner.

b. Connect the RF output of ESG 2 to one input of the signal combiner.

c. Connect the signal combiner output to the RF input of the UE.
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2. Adjust the amplitude of Îor to the required value.

In accordance with the 3GPP specification, adjust the amplitude of Îor to −92.7 dBm.

On ESG 1: Press Amplitude > −92.7 > dBm. 

3. Introduce the 10 MHz offset in-band interferer (Iblocking).

The first in-band interfering stimulus is made available at the RF output of ESG 2. In 
accordance with the 3GPP W-CDMA RF specification, the center frequency of this 
unwanted interferer (Iblocking) can be ±10 MHz from the center frequency of Îor. The 
amplitude of Iblocking is −52.0 dBm.

On ESG 2:

Press RF On/Off (or execute the appropriate SCPI command) until the RF ON 
annunciator is displayed.

4. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the 10 MHz offset in-band interferer.

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of both RF output waveforms, Îor (from ESG 1) and the 10 MHz offset in-band 
interferer Iblocking (from ESG 2).

5. In Table 2-27, record the measured BER value in the column titled, “10 MHz Offset 
Interferer BER Value.”

6. Introduce the 15 MHz offset in-band interferer.

The second in-band interfering stimulus is made available at the RF output of ESG 2. 
In accordance with the 3GPP W-CDMA RF specification, the center frequency of this 
unwanted interferer (Iblocking) can be ±15 MHz from the center frequency of Îor. The 
amplitude of Iblocking is −44 dBm.

On ESG 2:

a. Press Frequency and enter a frequency value ±15 MHz from the center frequency of 
Îor to change the Iblocking carrier frequency. 

b. Press Amplitude > −44 > dBm to change the Iblocking amplitude. 

c. Press RF On/Off until the RF ON annunciator is displayed on ESG 2 to activate the 
RF output.

7. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the 15 MHz offset in-band interferer.

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of both RF output waveforms, Îor (from ESG 1) and the 15 MHz offset in-band 
interferer Iblocking (from ESG 2).

8. In Table 2-27, record the measured BER value in the column titled, “15 MHz Offset 
Interferer BER Value.”
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9. In Table 2-27, compare both the BER values recorded in columns “10 MHz Offset 
Interferer BER Value” and “15 MHz Offset Interferer BER Value” to the allowable 
values in the column titled, “Specification Limitations” (both values must be within the 
allowable specification for a PASS status). Record the status of the UE as PASS or FAIL 
in the column titled, “PASS/FAIL Status.”

Subsection 3. Out-of-Band Blocking Characteristics Measurements  

Complete the following subsections to measure out-of-band blocking characteristics on 
your UE. 

Part A. Band 1 Out-of-Band Blocking Characteristics Measurements  

1. Introduce the negative frequency offset CW interferer for band 1.

The band 1 negative frequency offset interferer is made available at the RF output of 
ESG 2. In accordance with the 3GPP W-CDMA RF specification, the center frequency of 
this band 1 interferer (Iblocking) must be between 2050 MHz and 2095 MHz. The 
amplitude of Iblocking is −44 dBm.

On ESG 2:

a. Press Mod On/Off until the MOD OFF annunciator is displayed on ESG 2 to create an 
unmodulated CW signal.

b. Press Frequency and enter a value between 2050 MHz and 2095 MHz to set the 
carrier frequency of the band 1 negative frequency offset CW interferer (Iblocking).

c. Press Amplitude > −44 > dBm to set the amplitude of the band 1 negative frequency 
offset CW interferer.

d. Press RF On/Off until the RF ON annunciator is displayed on ESG 2 to activate the RF 
output.

2. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the negative frequency offset interferer for band 1.

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of both RF output waveforms, Îor (from ESG 1) and the band 1 negative 
frequency offset interferer Iblocking (from ESG 2).

3. In Table 2-28, record the measured BER value in the column titled, “Negative 
Frequency Offset Interferer BER Value.”

4. Introduce the positive frequency offset CW interferer for band 1.

The band 1 positive frequency offset interfering stimulus is made available at the RF 
output of ESG 2. In accordance with the 3GPP W-CDMA RF specification, the center 
frequency of this band 1 interferer (Iblocking) must be between 2185 MHz and 
2230 MHz. The amplitude of Iblocking is −44 dBm.
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On ESG 2:

a. Press Frequency and enter a value between 2185 MHz and 2230 MHz to set the 
carrier frequency of the band 1 positive frequency offset CW interferer.

b. Press Amplitude > −44 > dBm to set the amplitude of the band 1 positive frequency 
offset CW interferer.

c. Press RF On/Off until the RF ON annunciator is displayed on ESG 2 to activate the RF 
output.

5. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the positive frequency offset interferer for band 1.

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of both RF output waveforms, Îor (from ESG 1) and the positive frequency 
offset interferer Iblocking (from ESG 2).

6. In Table 2-28, record the measured BER value in the column titled, “Positive Frequency 
Offset Interferer BER Value.”

7. Compare both the BER values recorded in columns “Negative Frequency Offset 
Interferer BER Value” and “Positive Frequency Offset Interferer BER Value” to the 
allowable values in the column titled, “Specification Limitations” (both values must be 
within the allowable specification for a PASS status). Record the status of the UE as 
PASS or FAIL in the column titled, “PASS/FAIL Status.”

Part B. Band 2 Out-of-Band Blocking Characteristics Measurements  

1. Introduce the negative frequency offset CW interferer for band 2.

The band 2 negative frequency offset interfering stimulus is made available at the RF 
output of ESG 2. In accordance with the 3GPP W-CDMA RF specification, the center 
frequency of this band 2 interferer (Iblocking) must be between 2025 MHz and 
2050 MHz. The amplitude of Iblocking is −30.0 dBm.

On ESG 2:

a. Press Frequency and enter a value between 2025 MHz and 2050 MHz to set the 
carrier frequency of the band 2 negative frequency offset CW interferer.

b. Press Amplitude > −30 > dBm to set the amplitude of the band 2 negative frequency 
offset CW interferer.

c. Press RF On/Off until the RF ON annunciator is displayed on ESG 2 to activate the RF 
output.

2. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the negative frequency offset interferer for band 2.

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of both RF output waveforms, Îor (from ESG 1) and the negative frequency 
offset interferer Iblocking (from ESG 2).
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3. In Table 2-29, record the measured BER value in the column titled, “Negative 
Frequency Offset Interferer BER Value.”

4. Introduce the positive frequency offset CW interferer for band 2.

The band 2 positive frequency offset interfering stimulus is made available at the RF 
output of ESG 2. In accordance with the 3GPP W-CDMA RF specification, the center 
frequency of this band 2 interferer (Iblocking) must be between 2230 MHz and 
2255 MHz. The amplitude of Iblocking is −30.0 dBm.

On ESG 2:

a. Press Frequency and enter a value between 2230 MHz and 2255 MHz to set the 
carrier frequency of the band 2 positive frequency offset CW interferer.

b. Press Amplitude > −30 > dBm to set the amplitude of the band 2 positive frequency 
offset CW interferer.

c. Press RF On/Off until the RF ON annunciator is displayed on ESG 2 to activate the RF 
output.

5. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the positive frequency offset interferer for band 2.

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of both RF output waveforms, Îor (from ESG 1) and the positive frequency 
offset interferer Iblocking (from ESG 2).

6. In Table 2-29, record the measured BER value in the column titled, “Positive Frequency 
Offset Interferer BER Value.”

7. Compare both the BER values recorded in columns “Negative Frequency Offset 
Interferer BER Value” and “Positive Frequency Offset Interferer BER Value” to the 
allowable values in the column titled, “Specification Limitations” (both values must be 
within the allowable specification for a PASS status). Record the status of the UE as 
PASS or FAIL in the column titled, “PASS/FAIL Status.”

Part C. Band 3 Out-of-Band Blocking Characteristics Measurements  

NOTE Additional equipment is required for band 3 out-of-band performance testing 
beyond the upper frequency limit of ESG 2:

• a signal combiner with three input ports and one output port

• an external source capable of providing CW at an amplitude of −15 dBm 
across a frequency range of x GHz (x = the upper RF output frequency 
limitations of ESG 2) to 12.750 GHz.

1. Introduce the negative frequency offset CW interferer for band 3.

The band 3 negative frequency offset interfering stimulus is made available at the RF 
output of ESG 2. In accordance with the 3GPP W-CDMA RF specification, the center 
frequency of this band 3 interferer (Iblocking) must be between 1 MHz and 2025 MHz. 
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The amplitude of Iblocking is −15 dBm.

On ESG 2:

a. Press Frequency and enter a value between 1 MHz and 2025 MHz to set the carrier 
frequency of the band 3 negative frequency offset CW interferer.

b. Press Amplitude > −15 > dBm to set the amplitude of the band 3 negative frequency 
offset CW interferer.

c. Press RF On/Off until the RF ON annunciator is displayed on ESG 2 to activate the RF 
output.

2. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the negative frequency offset interferer for band 3.

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of both RF output waveforms, Îor (from ESG 1) and the band 3 negative 
frequency offset interferer Iblocking (from ESG 2).

3. In Table 2-30, record the measured BER value in the column titled, “Negative 
Frequency Offset Interferer BER Value.”

4. Introduce the positive frequency offset CW interferer for band 3.

The band 3 positive frequency offset interfering stimulus is made available at the RF 
output of ESG 2. In accordance with the 3GPP W-CDMA RF specification, the center 
frequency of this band 3 interferer (Iblocking) must be between 2255 MHz and 
12750 MHz (see note at beginning of Part C). The amplitude of Iblocking is −15 dBm.

On ESG 2:

a. Press Frequency and enter a value between 2255 MHz and the maximum RF output 
frequency of your ESG to set the carrier frequency of the band 3 positive frequency 
offset CW interferer.

b. Press Amplitude > −15 > dBm to set the amplitude of the band 3 positive frequency 
offset CW interferer.

c. Press RF On/Off until the RF ON annunciator is displayed on ESG 2 to activate the RF 
output.

To measure blocking characteristics at frequencies beyond the RF output limitations of 
ESG 2, connect the additional equipment, as shown in Figure 2-9.. 

Set the external source to:

a. signal type: CW 

b. amplitude: −15 dBm

c. frequency: desired frequency up to 12.75 GHz

d. RF output: on
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Figure 2-9. Out-of-Band Band 3 Blocking Characteristics Measurements 
Equipment Setup 2

5. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the positive frequency offset interferer for band 3.

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of both RF output waveforms, Îor (from ESG 1) and the band 3 positive 
frequency offset interferer Iblocking (from ESG 2).

6. In Table 2-30, record the measured BER value in the column titled, “Positive Frequency 
Offset Interferer BER Value.”

7. Compare both the BER values recorded in columns “Negative Frequency Offset 
Interferer BER Value” and “Positive Frequency Offset Interferer BER Value” to the 
allowable values in the column titled, “Specification Limitations” (both values must be 
within the allowable specification for a PASS status). Record the status of the UE as 
PASS or FAIL in the column titled, “PASS/FAIL Status.”
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Example Test Record

Use the following tables to record the data from the blocking characteristics performance 
test.

Table 2-27 In-Band Blocking Characteristics Performance Test Record

Verification 
BER 
Value

10 MHz Offset 
Interferer 

BER 
Value

15 MHz Offset 
Interferer 

BER 
Value

Specification 
Limitations

PASS/FAIL 
Status

BER ≤ 0.001

Table 2-28 Band 1 Out-of-Band Blocking Characteristics Measurements 
Performance Test Record

Negative 
Frequency Offset 
Interferer BER 

Value

Positive 
Frequency Offset 
Interferer BER 

Value

Specification 
Limitations

PASS/FAIL 
Status

BER ≤ 0.001

Table 2-29 Band 2 Out-of-Band Blocking Characteristics Measurements 
Performance Test Record

Negative 
Frequency Offset 
Interferer BER 

Value

Positive 
Frequency Offset 
Interferer BER 

Value

Specification 
Limitations

PASS/FAIL 
Status

BER ≤ 0.001

Table 2-30 Band 3 Out-of-Band Blocking Characteristics Measurements 
Performance Test Record

Negative 
Frequency Offset 
Interferer BER 

Value

Positive 
Frequency Offset 
Interferer BER 

Value

Specification 
Limitations

PASS/FAIL 
Status

BER ≤ 0.001
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Spurious Response (3G TS 25.101.7.7)

This section explains how to complete a spurious response performance test on your user 
equipment (UE). It includes a process definition, signal generator configurations, test 
system connections, abbreviations, an example test procedure and performance test 
record.

Specification Definition

Spurious response is a measure of the receiver’s ability to receive a desired signal on its 
assigned channel frequency without exceeding a given degradation due to the presence of 
an undesired CW interfering signal at any other frequency at which a response is obtained 
(i.e. for which the blocking limit is not met).1

Performance Test Objective

The objective of this performance test is to determine the spurious response performance of 
your UE against limitations described in the 3GPP W-CDMA RF specification (3G TS 
25.101 V3.3). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring Bit Error Ratio (BER) in 
the presence of specified spurious response interferers.

Abbreviations

Definitions of abbreviations used throughout 3G TS 25.101 V3.3 and the following example 
performance test procedure:

Îor the received power spectral density2 of the downlink as measured at the 
UE antenna connector

Iblocking the received power of the CW blocking interferer as measured at the UE 

antenna connector3

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
UE Radio transmission and Reception (FDD) Technical Specification 3G TS 25.101 V3.3 (2000-06).

2. Defined as the ratio dBm/3.84 Mcps.
3. Undefined in 3G TS 25.101 V3.3.
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Process

ESG Configuration

For a connection diagram, see “Two ESG Downlink Measurement Setup” on page 2-6.

Configure the signal generators by using the front panel hardkeys and softkeys (or the 
appropriate SCPI commands) to enter the values listed in Table 2-31, Table 2-32, 
Table 2-33, and Table 2-34. 

NOTE Enter values on both signal generators, unless otherwise noted. Channel State 
Off On is set to On for all channels, unless otherwise noted.

Measure & Record
BER Performance

Does BER 
Meet Spec?

START

END

Repair

Troubleshoot

N

IntroduceY
First Spurious

Interferer
Measure & Record
BER Performance

Measure & Record
BER Performance

Measure & Record
BER Performance

Do BERs 
Meet Spec?

Y

N

Introduce
Second Spurious

Interferer

Introduce
Third Spurious

Interferer

KEY

UE BER 

Verification
Performance

Spurious

BER Test
Interferers
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Table 2-31 Spurious Response Physical Layer Configuration

ESG # Channel # Parameter Setting

ESG 1 Channel 1 PhyCH Type PSCH

Power −8.3 dB

ESG 1 Channel 2 PhyCH Type SSCH

Power −8.3 dB

Secondary Scramble Code Grp 0

ESG 1 Channel 3 PhyCH Type P-CCPCH

Power −5.3 dB

Channel Code 1 (Fixed Value)

BCH Data 0000

ESG 1 Channel 4 PhyCH Type CPICH

Power −3.3 dB

Channel Code 0 (Fixed Value)

ESG 2 Channel 1 PhyCH Type DPCH

Power −10.3 dB

Channel Code 6 (Arbitrary Value)

SecScr Code OS 0

TPC Pat Steps 1

Data Ref 12 (See Table 4-12.)

Symbol Rate 30.00 ksps

TFCI Pattern 0000000000

TPC Pattern Up/Down

Slot Format 11

Time Offset 0

ESG 2 Channel 2 Channel State Off/On Off 

ESG 2 Channel 3 PhyCH Type PICH 

Power −8.3 dB

Channel Code 3 (Arbitrary Value)

Data PN9

PI Bits 288

Paging Indicator 144

ESG 2 Channel 4 Channel State Off/On Off 
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Table 2-32 Spurious Response Transport Layer Configuration

Parameter Setting

Reference Measurement Setup1 12.2 kbps (ESG 2)

1 For details, see Table 4-12.

Table 2-33 Spurious Response W-CDMA Baseband Signal Configuration

Parameter Setting(s)

BS Setup Filter: RNYQ
Chip Rate: 3.840000 Mcps
Scramble Code: 0

BBG Data Clock Ext

Phase Polarity Normal

Two Box Setup (Relative Power Mapping) Enter values as required.1 

W-CDMA Off/On On

1 For detailed information, see “Adjust the Relative Power Mapping” on page 2-14.

Table 2-34 Spurious Response W-CDMA RF Carrier Configuration

Parameter Setting

Frequency 2140.0 MHz (ESG 1) (Arbitrary Value)
Set to first spurious response frequency (ESG 2)

Amplitude1 −80.0 dBm (ESG 1) (Arbitrary Value)
−44.0 dBm (ESG 2)

RF Off/On2 On (ESG 1)
Off (ESG 2)

Mod Off/On3 On (ESG 1)
Off (ESG 2)

1 The amplitude of the RF output of ESG 1 is initially set to an arbitrary value (−80.0 dBm), 
in order to perform a BER verification measurement. After BER verification, the 
amplitude will be modified to the required value (−103.7 dBm) in accordance with the 
3GPP specification for this performance test.

2 The RF output of ESG 2 remains off until the initial BER verification measurement has 
been performed. After BER verification, the RF output of ESG 2 (the interferer) will be 
applied to the UE in accordance with the 3GPP specification for this performance test.

3 ESG 2’s modulation is switched off, in order to provide a spurious CW interferer.
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Example Test Procedure

Follow this example procedure to perform a 3GPP W-CDMA spurious response test on 
your UE. Complete the subsections of this procedure sequentially, in the order in which 
they appear in this document.

Subsection 1. Equipment Setup and Preliminary BER Verification  

Complete the following steps to connect the equipment and perform a BER verification test 
on your UE. 

Figure 2-10 BER Verification Equipment Setup

1. Connect the UE to the test system as shown in Figure 2-10.

a. Using the appropriate cables, adapters, and antennae, connect the output of ESG 1 
to the RF input of the UE.

b. Connect the system controller (and the BER test platform) to the UE.

2. Perform call acquisition functions for the UE.

From the system controller, perform all of the call acquisition functions required to 
enable the UE to demodulate transmitted data, in order to perform bit error ratio 
measurements. 

These call acquisition functions include:

a. acquiring the primary synchronization channel (P-SCH),

b. acquiring the secondary synchronization channel (S-SCH) and determining the 
secondary scramble code group,

c. acquiring and synchronizing to the common pilot channel (CPICH),

d. acquiring the primary common control physical channel (PCCPCH) and determining 
system frame number.
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At this point, the controller must configure the UE into a test mode. With the UE 
operating in test mode, the controller assigns the UE a dedicated physical channel on 
which to receive and demodulate the transmitted data. 

3. Measure the Bit Error Ratio (BER) of the data received by the UE on RMC 12.2 kbps 
(25.101 V3.3).

The controller (or BER test platform) is measuring the bit error ratio of the UE exposed 
to Îor (the RF output of ESG 1) only. This process verifies that the BER of the UE is 
within specification prior to the introduction of the spurious response stimulus.

4. In Table 2-35, record the measured BER value in the column titled, “Verification BER 
Value.”

5. Compare the measured BER value in the column titled, “Verification BER Value” with 
the limits from the column titled, “Specification Limitations.”

• If the measured value is within the limits, continue to subsection 2.

• If the measured value is outside the limits, determine the cause of failure and repair 
the UE. After repair, return to Step 1 of this subsection.

Subsection 2. Spurious Response Measurements  

Complete the following steps to make spurious response measurements on your UE. 

Figure 2-11 Spurious Response Measurements Equipment Setup

1. Connect the additional equipment to the test system as shown in Figure 2-11.

a. Connect the RF output of ESG 1 to one input of the signal combiner.

b. Connect the RF output of ESG 2 to one input of the signal combiner.

c. Connect the signal combiner output to the RF input of the UE.
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2. Adjust the amplitude of Îor to the required value.

In accordance with the 3GPP specification, adjust the amplitude of Îor to −103.7 dBm.

On ESG 1:

Press Amplitude > −103.7 > dBm. 

3. Introduce the first spurious response (Iblocking) stimulus.

Iblocking is made available at the RF output of ESG 2. In accordance with the 3GPP 
W-CDMA RF specification, the amplitude of Iblocking is −44 dBm.

On ESG 2:

Activate the RF output on ESG 2 by pressing RF On/Off (or executing the appropriate 
SCPI command) until the RF ON annunciator is displayed on ESG 2.

4. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the first spurious response stimulus.

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of both RF output waveforms, Îor (from ESG 1) and the spurious response 
interferer Iblocking (from ESG 2).

5. In Table 2-35, record the measured BER value in the column titled, “1st Spurious BER 
Value.”

6. Introduce the next spurious response (Iblocking) stimulus.

The next spurious response stimulus is made available at the RF output of ESG 2. In 
accordance with the 3GPP W-CDMA RF specification, the amplitude of Iblocking is 
−44 dBm.

On ESG 2:

a. Press Frequency and enter the value of your second spurious response frequency.

b. Activate the RF output on ESG 2 by pressing RF On/Off (or executing the appropriate 
SCPI command) until the RF ON annunciator is displayed on ESG 2.

7. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the second spurious response stimulus.

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of both RF output waveforms, Îor (from ESG 1) and the second spurious 
response interferer Iblocking (from ESG 2).

8. In Table 2-35, record the measured BER value in the column titled, “2nd Spurious BER 
Value.”

9. Repeat Steps 6 and 7 for a third spurious response interferer.

10. In Table 2-35, record the measured BER value in the column titled, “3rd Spurious BER 
Value.”
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11. Compare all three recorded BER values (the 1st, 2nd, and 3rd spurious BER values 
must be within the allowable specification for a PASS status) to the allowable values in 
the column titled, “Specification Limitations” and record the status of the UE as PASS 
or FAIL in the column titled, “PASS/FAIL Status.”

Example Test Record

Use the following table to record the data from the spurious response performance test.

Table 2-35 Spurious Response Performance Test Record

Verification 
BER 
Value

1st 
Spurious 

BER 
Value

2nd 
Spurious 

BER 
Value

3rd 
Spurious 

BER 
Value

Specification 
Limitations

PASS/FAIL 
Status

BER ≤ 0.001
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Intermodulation Characteristics (3G TS 25.101.7.8)

This section explains how to complete an intermodulation response rejection performance 
test on your user equipment (UE). It includes a process definition, signal generator 
configurations, test system connections, abbreviations, an example test procedure and 
performance test record.

NOTE An external source capable of providing CW at an amplitude of −46 dBm 
across a frequency range of 2100 MHz to 2180 MHz is required for IRR 
performance testing.

Specification Definition

Intermodulation response rejection is a measure of the receiver’s ability to receive a 
desired signal at its assigned channel frequency in the presence of two or more undesired 
interferers which have a specific frequency relationship (i.e. third- or higher-order mixing 
products within the frequency band of the desired channel) to the desired signal.1

Performance Test Objective

The objective of this performance test is to determine the Intermodulation Response 
Rejection (IRR) performance of your UE against limitations described in the 3GPP 
W-CDMA RF specification (3G TS 25.101 V3.3). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring Bit Error Ratio (BER) in 
the presence of two specified, frequency-related interferers.

Abbreviations

Definitions of abbreviations used throughout 3G TS 25.101 V3.3 and the following example 
performance test procedure:

Îor the received power spectral density2 of the downlink as measured at the 
UE antenna connector

Iouw1 the received power of the unwanted CW interferer as measured at the UE 

antenna connector3

Iouw2 the received power spectral density of the unwanted modulated interferer 

as measured at the UE antenna connector4

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
UE Radio transmission and Reception (FDD) Technical Specification 3G TS 25.101 V3.3 (2000-06).

2. Defined as the ratio dBm/3.84 Mcps.
3. Undefined in 3G TS 25.101 V3.3.
4. Undefined in 3G TS 25.101 V3.3.
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Process

ESG Configuration

For a connection diagram, see “Two ESG Downlink Measurement Setup” on page 2-6.

Configure the signal generators by using the front panel hardkeys and softkeys (or the 
appropriate SCPI commands) to enter the values listed in Table 2-36, Table 2-37, 
Table 2-38, and Table 2-39. 

NOTE Enter values on both signal generators, unless otherwise noted. Channel State 
Off On is set to On for all channels, unless otherwise noted.

Measure & Record
BER Performance

Does BER 
Meet Spec?

START

END

Does BER 
Meet Spec?

Repair

Troubleshoot

N

Y

N

IntroduceY
Negative Offset
IRR Interferers

Introduce
Positive Offset

Measure & Record
BER Performance

Measure & Record
BER Performance

Meet Spec?
Y

N

IRR Interferers

Does BER KEY

UE BER 

Verification
Performance

Negative

BER Test
Interferers

Positive

BER Test
Interferers
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Table 2-36 IRR Physical Layer Configuration

ESG # Channel # Parameter Setting

ESG 1 Channel 1 PhyCH Type PSCH

Power −8.3 dB

ESG 1 Channel 2 PhyCH Type SSCH

Power −8.3 dB

Secondary Scramble Code Grp 0

ESG 1 Channel 3 PhyCH Type P-CCPCH

Power −5.3 dB

Channel Code 1 (Fixed Value)

BCH Data 0000

ESG 1 Channel 4 PhyCH Type CPICH

Power −3.3 dB

Channel Code 0 (Fixed Value)

ESG 2 Channel 1 PhyCH Type DPCH

Power −10.3 dB

Channel Code 6 (Arbitrary Value)

SecScr Code OS 0

TPC Pat Steps 1

Data Transport CH (See Table 4-12.)

Symbol Rate 30.00 ksps

TFCI Pattern 0000000000

TPC Pattern Up/Down

Slot Format 11

Time Offset 0

ESG 2 Channel 2 Channel State Off/On Off 

ESG 2 Channel 3 PhyCH Type PICH 

Power −8.3 dB

Channel Code 3 (Arbitrary Value)

Data PN9

PI Bits 288

Paging Indicator 144

ESG 2 Channel 4 Channel State Off/On Off 
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Table 2-37 IRR Transport Layer Configuration

Parameter Setting

Reference Measurement Setup1 12.2 kbps (ESG 2)

1 For details, see Table 4-12.

Table 2-38 IRR W-CDMA Baseband Signal Configuration

Parameter Setting(s)

BS Setup Filter: RNYQ
Chip Rate: 3.840000 Mcps
Scramble Code: 0

BBG Data Clock Ext

Phase Polarity Normal

Two Box Setup (Relative Power Mapping) Enter values as required.1

W-CDMA Off/On On

1 For detailed information, see “Adjust the Relative Power Mapping” on page 2-14.

Table 2-39 IRR W-CDMA RF Carrier Configuration

Parameter Setting

Frequency1 2140.0 MHz (ESG 1) (Arbitrary Value)
2120.0 MHz (ESG 2)

Amplitude2 −80.0 dBm (ESG 1) (Arbitrary Value)
−46.0 dBm (ESG 2)

RF Off/On3 On (ESG 1)
Off (ESG 2)

Mod Off/On On

1 The frequency of the unwanted signal generated at the output of ESG 2 must be ±20 MHz 
from the center frequency of the fundamental waveform generated at the output of 
ESG 1. If a negative offset frequency is selected, the output frequency of the CW source 
must be set 10 MHz below the center frequency of the fundamental waveform. If a 
positive offset frequency is selected, the output frequency of the CW source must be set 
10 MHz above the center frequency of the fundamental waveform.

2 The amplitude of the RF output of ESG 1 is initially set to an arbitrary value (−80.0 dBm), 
in order to perform a BER verification measurement. After BER verification, the 
amplitude will be modified to the required value (−92.7 dBm) in accordance with the 
3GPP specification for this performance test.

3 The RF output of ESG 2 remains off until the initial BER verification measurement has 
been performed. After BER verification, the RF output of ESG 2 (the interferer) will be 
applied to the UE in accordance with the 3GPP specification for this performance test.
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Example Test Procedure

Follow this example procedure to perform a 3GPP W-CDMA intermodulation response 
rejection test on your UE. Perform the procedures in the subsections sequentially, in the 
order in which they appear in this document. 

Subsection 1. Equipment Setup and Preliminary BER Verification  

Complete the following steps to connect the equipment and perform a BER verification test 
on your UE. 

Figure 2-12 BER Verification Equipment Setup

1. Connect the UE to the test system as shown in Figure 2-12.

a. Using the appropriate cables, adapters, and antennae, connect the output of ESG 1 
to the RF input of the UE.

b. Connect the system controller (and the BER test platform) to the UE.

2. Perform call acquisition functions for the UE.

From the system controller, perform all of the call acquisition functions required to 
enable the UE to demodulate transmitted data, in order to perform bit error ratio 
measurements. 

These call acquisition functions include:

a. acquiring the primary synchronization channel (P-SCH),

b. acquiring the secondary synchronization channel (S-SCH) and determining the 
secondary scramble code group,

c. acquiring and synchronizing to the common pilot channel (CPICH),

d. acquiring the primary common control physical channel (PCCPCH) and determining 
system frame number.
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At this point, the controller must configure the UE into a test mode. With the UE 
operating in test mode, the controller assigns the UE a dedicated physical channel on 
which to receive and demodulate the transmitted data. 

3. Measure the Bit Error Ratio (BER) of the data received by the UE on RMC 12.2 kbps 
(25.101 V3.3).

The controller (or BER test platform) is measuring the bit error ratio of the UE exposed 
to Îor (the RF output of ESG 1) only. This process verifies that the BER of the UE is 
within specification prior to the introduction of the frequency-related interferers.

4. In Table 2-40, record the measured BER value in the column titled, “Verification BER 
Value.”

5. Compare the measured BER value in the column titled, “Verification BER Value” with 
the limits from the column titled, “Specification Limitations.”

• If the measured value is within the limits, continue to subsection 2.

• If the measured value is outside the limits, determine the cause of failure and repair 
the UE. After repair, return to Step 1 of this subsection.

Subsection 2. Negative Frequency Offset Interferers IRR Measurements  

Complete the following steps to make negative frequency offset measurements on your UE. 

Figure 2-13 IRR Measurements Equipment Setup
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1. Connect the additional equipment to the test system as shown in Figure 2-13.

a. Connect the RF output of ESG 1 to one input of the signal combiner.

b. Connect the RF output of ESG 2 to one input of the signal combiner.

c. Connect the RF output of the CW source to one input of the signal combiner.

d. Connect the signal combiner output to the RF input of the UE.

2. Adjust the amplitude of Îor to the required value.

In accordance with the 3GPP specification, adjust the amplitude of Îor to −92.7 dBm.

On ESG 1:

Press Amplitude > −92.7 > dBm. 

3. Introduce the negative frequency offset CW interferer (Iouw1).

Iouw1 is made available at the RF output of the CW source. In accordance with the 3GPP 
W-CDMA RF specification, the center frequency of Iouw1 is set 10 MHz below the center 
frequency of Îor. The amplitude of Iouw1 is −46 dBm.

On the CW source:

Set the RF output frequency to 2130 MHz (or 10 MHz below the center frequency of Îor).

Set the RF output amplitude to −46 dBm.

Activate the RF output.

4. Introduce the negative frequency offset modulated interferer (Iouw2).

Iouw2 is made available at the RF output of ESG 2. In accordance with the 3GPP 
W-CDMA RF specification, the center frequency of Iouw2 is set 20 MHz below the center 
frequency of Îor. The amplitude of Iouw2 is −46 dBm.

On ESG 2:

Press RF On/Off until the RF ON annunciator is displayed on ESG 2 to activate the RF 
output.

5. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the CW and modulated interferers (Iouw1 and Iouw2).

6. The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of all three RF output waveforms, Îor (from ESG 1) and the negative frequency 
offset interferers Iouw1 and Iouw2 (from the CW source and ESG 2, respectively).

7. In Table 2-40, record the measured BER value in the column titled, “Negative 
Frequency Offset Interferers BER Value.”

8. Compare the recorded BER value in the column titled, “Negative Frequency Offset 
Interferers BER Value” to the allowable values in the column titled, “Specification 
Limitations” and record the status of the UE as PASS or FAIL in the column titled, 
“PASS/FAIL Status.”
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Subsection 3. Positive Frequency Offset Interferers IRR Measurements  

Complete the following steps to make positive frequency offset measurements on your UE. 

1. Introduce the positive frequency offset CW interferer (Iouw1).

Iouw1 is made available at the RF output of the CW source. In accordance with the 3GPP 
W-CDMA RF specification, the center frequency of Iouw1 is set 10 MHz above the center 
frequency of Îor. The amplitude of Iouw1 is −46 dBm.

On the CW source:

Set the RF output frequency to 2150 MHz (or 10 MHz above the center frequency of Îor).

Set the RF output amplitude to −46 dBm.

Activate the RF output.

2. Introduce the positive frequency offset modulated interferer (Iouw2).

Iouw2 is made available at the RF output of ESG 2. In accordance with the 3GPP 
W-CDMA RF specification, the center frequency of Iouw2 is set 20 MHz above the center 
frequency of Îor. The amplitude of Iouw2 is −46 dBm.

On ESG 2:

a. Press Frequency > 2160 > MHz (or a frequency 20 MHz above the center frequency of 
Îor) to set the carrier frequency of positive frequency offset modulated interferer 
(Iouw2).

b. Press RF On/Off until the RF ON annunciator is displayed on ESG 2 to activate the RF 
output.

3. Measure the BER of the data received by the UE on RMC 12.2 kbps (25.101 V3.3) in the 
presence of the positive frequency offset CW and modulated interferers (Iouw1 and 
Iouw2).

The controller (or BER test platform) is measuring the bit error ratio of the UE in the 
presence of all three RF output waveforms, Îor (from ESG 1) and the positive frequency 
offset interferers Iouw1 and Iouw2 (from the CW source and ESG 2, respectively).

4. In Table 2-41, record the measured BER value in the column titled, “Positive Frequency 
Offset Interferers BER Value.”

5. Compare the recorded BER value in the column titled, “Positive Frequency Offset 
Interferers BER Value” to the allowable values in the column titled, “Specification 
Limitations” and record the status of the UE as PASS or FAIL in the column titled, 
“PASS/FAIL Status.”
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Example Test Record

Use the following tables to record the data from the IRR performance test.

Table 2-40 Negative Frequency Offset Interferers IRR Measurement 
Performance Test Record

Verification BER 
Value

Negative 
Frequency Offset 
Interferers BER 

Value

Specification 
Limitations

PASS/FAIL Status

BER ≤ 0.001

Table 2-41 Positive Frequency Offset Interferers IRR Measurement Performance 
Test Record

Positive 
Frequency Offset 

Interferers BER Value

Specification Limitations PASS/FAIL Status

BER ≤ 0.001
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Spurious Emissions (3G TS 25.101.7.9)

This section contains a performance test summary and explains how to configure your test 
system in order to complete a spurious emissions performance test on your user equipment 
(UE).

NOTE Spurious emissions measurements are only available within the specified 
input frequency limitations of the vector signal analyzer.

Specification Definition

Spurious emissions is a measure of the power of emissions generated or amplified in a 
receiver that appear at the UE antenna connector.1

Performance Test Objective

The objective of this performance test is to determine the spurious emissions performance 
of your UE against limitations described in the 3GPP W-CDMA RF specification (3G TS 
25.101 V3.3). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring power level and occupied 
bandwidth of the spurious emissions generated by the UE.

Process

Using the VSA, measure the power level and occupied bandwidth of spurious emissions at 
the antenna port of the UE. 

The recorded results are compared against the limits listed in the 3GPP W-CDMA RF 
specification and a PASS or FAIL status is assigned to the UE.

System Configuration

To configure the system to conduct the spurious emissions performance test:

1. Connect the equipment as shown in Figure 2-14.

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
UE Radio transmission and Reception (FDD) Technical Specification 3G TS 25.101 V3.3 (2000-06).
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Figure 2-14 Spurious Emissions Equipment Setup

2. Configure the vector signal analyzer and complete the spurious emissions performance 
test. 

See the section titled, “Making the Spectrum Emission Mask Measurement” in 
“Chapter 3. Making W-CDMA (3GPP) Measurements” of the Agilent Technologies 
E4406A VSA Series Transmitter Tester W-CDMA Measurement Guide for VSA 
configurations and performance test procedure.
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Uplink Measurement Setup
This section will guide you through setting up the ESG and measuring the output using 
the E4406A VSA Transmitter Tester.

This setup provides two 3GPP channels with real-time signal generation capability, which 
are used to test 3GPP base station (BS) receiver designs.

Required Equipment

• one ESG-D Series Signal Generator with Option 200

• one E4406A VSA Series Transmitter Tester with Option BAF

• BNC cables as needed (see the following figure)

Refer to Figure 2-15 and make the necessary connections between the ESG and the 
E4406A.

Figure 2-15 ESG Uplink Measurement Setup

Configuring the ESG

NOTE The following signal generator settings are used for example purposes. 
Change them as needed for your device under test (DUT). 

1. Press Preset.

2. Press Frequency > 1.950 > GHz and then Amplitude > –10 > dBm .

3. Press Mode  > Real Time I/Q BaseBand  > CDMA > W-CDMA.

4. Press Link Down Up  until Up is highlighted.

5. Press UE Setup .

This opens the user equipment (UE) setup editor. The highlight bar can be moved by 
rotating the front panel knob or pressing the arrow keys.
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The following default values are displayed:

Filter   RNYQ (α = 0.220) EVM

Chip Rate  3.840000 Mcps

Scrambling Code  0

6. Press Return to reopen the W-CDMA menu.

7. Press the Link Control softkey. 

This opens the Link Control setup editor and a predefined configuration is enabled.

8. Press Adjust Code Domain Power > Scale To 0dB. 

Notice that the power levels have changed on each channel. This process has scaled the 
channel power levels to the proper amplitudes for transmission (the sum log value of 
the new power levels equals zero). The power ratios between the channels remain 
unchanged.

NOTE Adjusting the code domain power applies to active channels only.

9. Toggle the W-CDMA Off On softkey to highlight On. Ensure that the WCDMA and I/Q 
annunciators are displayed.

10. Activate the RF output power by toggling the RF On/Off key until the RF ON 
annunciator is displayed on the ESG.

Configuring the E4406A VSA Series Transmitter Tester

This section explains how to configure the E4406A VSA, in order to measure the output 
signal from the ESG that was configured in the previous section.

Perform the following steps to view the code domain display:

1.  Press Preset.

2. Set the VSA to use a 10 MHz external frequency reference.
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Press: System > Reference > Freq Ref Int Ext > 10 > MHz > Freq Ref Int Ext

Ext is now underscored.

3. Choose the W-CDMA option.

Press: Mode > More (1 of 2) > W-CDMA (3GPP)

4. Set the VSA to receive a mobile station signal.

Press: Mode Setup > Radio (ensure that MS is underscored)

5. Set the center frequency to 1.950 GHz.

Press: FREQUENCY > 1.950 > GHz

6. Select the code domain measurement.

Press: MEASURE > More (1 of 2) > Code Domain

7. Activate the marker function and use the front panel knob to place marker #1 at the 
highest I or Q channel with the RPG knob.

8. In the upper right corner of the screen, ensure the marker readout data is shown as 
follows:

IMkr #1: C6 (16) 60 ksps
−1.87 dB

or

QMkr #2: C8 (0) 15 ksps
−4.56 dB

NOTE Be sure that the center frequency is set appropriately for your DUT.

The following figure shows the VSA code domain display.

Marker
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3GPP W-CDMA Base Station Performance Testing
This section includes signal generator configurations that will provide a stimulus for 
bit-error-ratio analysis of base station (BS) designs based on the requirements outlined in 
the 3GPP W-CDMA specification.1 

This includes performance test summaries, test-specific signal generator settings, test 
system configurations, step-by-step instructions in the form of example test procedures, 
and example performance test records for testing the following performance specifications: 

• “Reference Sensitivity Level (3G TS 25.141.7.2)” on page 2-81

• “Dynamic Range (3G TS 25.141.7.3)” on page 2-86

• “Adjacent Channel Selectivity (3G TS 25.141.7.4)” on page 2-91

• “Blocking Characteristics (3G TS 25.141.7.5)” on page 2-96

• “Intermodulation Response Rejection (3G TS 25.141.7.6)” on page 2-105

• “Spurious Emissions (3G TS 25.141.7.7)” on page 2-112

Required Equipment

• two ESG signal generators configured as a single ESG W-CDMA base station test 
solution

• one E4440A performance spectrum analyzer

• one signal source capable of providing CW at an amplitude range of −50 dBm to
−15 dBm with an RF frequency range of 1.000 MHz to 12.750 GHz

• a system controller and software capable of providing control data to the base station 
under test

• software and/or hardware capable of measuring, calculating and storing the base 
station’s bit error ratio (BER) while exposed to the test stimulus

• BNC cables, tee splitters, signal combiners, and adapters

• adapters and antennae as required by the BS

1. 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; Base 
station conformance testing (FDD) Technical Specification 3G TS 25.141 V3.4 (2000-12).
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ESG Physical Layer and Transport Layer Configuration

The physical layer and transport layer are configured separately. Physical layer 
configurations change as required by each individual performance test. The specified 
channel types and power levels are modified to provide the required stimulus for 
performing the individual performance specification tests.

The ESG provides a single-softkey solution for configuring factory-defined transport layer 
channelization. This predefined reference measurement channel is used as the transport 
layer configuration throughout the specification performance tests. For specific 
information regarding transport layer channelization based on this factory-defined setting, 
see the following section, “Understanding the Reference Measurement Channel” on 
page 4-18.

Performance Test Preparation

Prior to initiating the performance tests, ensure that:

• the base station’s transmitter port(s) are terminated (to avoid the RF leakage power),

• the base station’s TPC function is disabled, and

• the appropriate external attenuators are being used (for higher accuracy and less 
mismatch losses). 

NOTE All ESG signal parameters are specified at the front panel RF OUTPUT 
connector. Losses due to cabling and signal combining must be considered 
when performing the tests.
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Reference Sensitivity Level (3G TS 25.141.7.2)

This section explains how to configure your test system, including signal generator 
settings and test system connections, in order to complete a reference sensitivity level 
performance test on your base station (BS). It includes an example performance test 
procedure and performance test record.

Specification Definition

Reference sensitivity level is a measure of the minimum receiver input power at the 
antenna connector at which the bit error ratio does not exceed a specific value.1

Performance Test Objective

The objective of this performance test is to determine the Reference Sensitivity Level 
(RSL) performance of your BS against limitations described in the 3GPP W-CDMA RF 
specification (3G TS 25.141 V3.4). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring Bit Error Ratio (BER) at a 
specified minimum power level measured at the BS antenna port.

Process

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
Base station conformance testing (FDD) Technical Specification 3G TS 25.141 V3.4 (2000-12).
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ESG Configuration

This test can be performed using the default uplink W-CDMA parameter settings with the 
exceptions of setting Frequency, Amplitude, Channel State, RF On/Off, and 
Mod On/Off. Configure the signal generators by using the front panel hardkeys and 
softkeys (or the appropriate SCPI commands) to enter the values listed in Table 2-42 and 
Table 2-43.

Table 2-42 RSL Physical Layer Configuration

Channel # Parameter Setting

Channel 1 Channel State On

PhyCH Type DPCCH 

Power −2.69 dB 

Beta 11

TFCI Pattern 0000

Slot Format 0

Symbol Rate 15.0 ksps

FBI Pattern 00000000

Channel Code 0

TPC Pattern Up/Down

TPC Pat Steps 1

Channel 2 Channel State On

PhyCH Type DPDCH

Power 0.00 dB 

Beta 15

Data Transport CH

Symbol Rate 60.000 ksps

Slot Format 2

Channel Code 16
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Table 2-43 RSL Transport Layer, Baseband, and RF Carrier Configuration

Transport Layer Parameter Setting

Ref Measure Setup 12.2 kbps

Data PN9

W-CDMA Baseband Signal Parameter Setting

UE Setup Filter: RNYQ (α=0.220)EVM
Chip Rate: 3.840000 Mcps
Scrambling Code: 0

BBG Data Clock Int1

Phase Polarity Normal

W-CDMA Off/On On

W-CDMA RF Carrier Parameter Setting

Frequency 1950 MHz

Amplitude −111.00 dBm2

RF Off/On On

Mod Off/On On

1 Set to external if using the optional base station chip clock output as the ESG’s data clock 
source.

2 The amplitude of the RF output is initially set to an arbitrary value (−111.0 dBm), in order 
to perform a BER verification measurement. After BER verification, the amplitude will 
be modified to the required value (−121.0 dBm) in accordance with the 3GPP specification 
for this performance test.
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Example Test Procedure

Follow this example procedure to perform a 3GPP W-CDMA reference sensitivity level test 
on your BS. Perform the procedures in the subsections sequentially, in the order in which 
they appear in this document.

Subsection 1. Equipment Setup and Preliminary BER Verification  

Complete the following steps to connect the equipment and perform a BER verification test 
on your BS. 

Figure 2-16 Reference Sensitivity Level Equipment Setup

1. Connect the BS to the test system as shown in Figure 2-16.

a. Using the appropriate cables, adapters, and antennae, connect the output of the ESG 
to the RF input of the BS. 

b. If the BS has multiple input ports, terminate the unused ports.

c. Connect the system controller and the BER test platform to the BS.

2. Measure the Bit Error Ratio (BER) of the BS.

The controller or BER test platform measures the bit error ratio of the BS exposed to 
the RF output power specified by TS 25.141.7.8 V3.4. This process verifies that the BER 
of the BS is within specification before decreasing the amplitude of the RF output 
power.

3. Record the first BER measurement result in the column titled, “Verification BER Value” 
in Table 2-44.

4. Compare the measured BER value in the column titled, “Verification BER Value” with 
the limits from the column titled, “Specification Limitations.”

• If the measured value is within the limits, continue to subsection 2.
2-84 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators Using Functions
Option 200 3GPP W-CDMA Base Station Performance Testing
• If the measured value is outside the limits, determine the cause of failure and repair 
the BS. After repair, return to Step 1 of this subsection.

Subsection 2. Reference Sensitivity Level Measurement  

Complete the following steps to make a reference sensitivity level measurement on your 
BS. 

1. Decrease the amplitude of the W-CDMA stimulus.

In accordance with the 3GPP W-CDMA RF specification, decrease the amplitude of the 
RF output power to −121.00 dBm.

On the ESG,

Press Amplitude > −121 > dBm.

2. Measure the BER of the BS at the decreased amplitude.

The controller or BER test platform measures the bit error ratio of the BS with a 
W-CDMA stimulus amplitude of −121.00 dBm.

3. Record the BER result in the column titled, “Reference Sensitivity Level BER Value” in 
Table 2-44.

4. Compare the recorded value of the BER result with the allowable values and record the 
PASS/FAIL status for the BS.

Example Test Record

Use the following table to record the data from the RSL performance test.

Table 2-44 RSL Performance Test Record

Verification
BER Value

Reference 
Sensitivity Level 

BER Value

Specification 
Limitation PASS/FAIL Status

BER ≤ 0.001
Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide 2-85



Using Functions ESG Family Signal Generators
3GPP W-CDMA Base Station Performance Testing Option 200
Dynamic Range (3G TS 25.141.7.3)

This section explains how to configure your test system, including signal generator 
settings and test system connections, in order to complete a dynamic range performance 
test on your base station (BS). It includes an example performance test procedure and 
performance test record.

Specification Definition

Dynamic range is a measure of a receiver’s ability to handle a rise of interference in the 
reception frequency channel. The receiver shall fulfill a specified BER requirement for a 
specified sensitivity degradation of the wanted signal in the presence of an interfering 
AWGN signal in the same reception frequency channel.1

Performance Test Objective

The objective of this performance test is to determine the dynamic range performance of 
your BS against limitations described in the 3GPP W-CDMA RF specification (3G TS 
25.141 V3.4). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring Bit Error Ratio (BER) in 
the presence of a specified interfering AWGN signal occupying the same reception channel.

Process

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
Base station conformance testing (FDD) Technical Specification 3G TS 25.141 V3.4 (2000-12).
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ESG Configuration

This test can be performed using the default uplink W-CDMA parameter settings with the 
exceptions of setting Frequency, Amplitude, Channel State, RF On/Off, and 
Mod On/Off. Configure the signal generators by using the front panel hardkeys and 
softkeys (or the appropriate SCPI commands) to enter the values listed in Table 2-45 and 
Table 2-46.

Table 2-45 Dynamic Range Physical Layer Configuration

Channel # Parameter Setting

Channel 1 Channel State On

PhyCH Type DPCCH 

Power −2.69 dB 

Beta 11

TFCI Pattern 0000

Slot Format 0

Symbol Rate 15.0 ksps

FBI Pattern 00000000

Channel Code 0

TPC Pattern Up/Down

TPC Pat Steps 1

Channel 2 Channel State On

PhyCH Type DPDCH

Power 0.00 dB 

Beta 15

Data Transport CH

Symbol Rate 60.000 ksps

Slot Format 2

Channel Code 16
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Table 2-46 Dynamic Range Transport Layer, Baseband, and RF Carrier 
Configuration

Transport Layer Parameter Setting

Ref Measure Setup 12.2 kbps

Data PN9

W-CDMA Baseband Signal Parameter Setting

UE Setup Filter: RNYQ(α=0.220)EVM
Chip Rate: 3.840000 Mcps
Scrambling Code: 0

BBG Data Clock Int1

Phase Polarity Normal

W-CDMA Off/On On

W-CDMA RF Carrier Parameter Setting

Frequency 1950.0 MHz

Amplitude −111.00 dBm2

RF Off/On On

Mod Off/On On

1 Set to external if using the optional base station chip clock output as the ESG’s data clock 
source.

2 The amplitude of the RF output is initially set to an arbitrary value (−111.0 dBm), in order 
to perform a BER verification measurement. After BER verification, the amplitude will 
be modified to the required value (−91.0 dBm) in accordance with the 3GPP specification 
for this performance test.
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Example Test Procedure

Follow this example procedure to perform a 3GPP W-CDMA dynamic range test on your 
BS. Perform the procedures in the subsections sequentially, in the order in which they 
appear in this document.

Subsection 1. Equipment Setup and Preliminary BER Verification  

Complete the following steps to connect the equipment and perform a BER verification test 
on your BS. 

Figure 2-17 Dynamic Range Equipment Setup

1. Connect the BS to the test system as shown in Figure 2-17.

a. Using the appropriate cables, adapters, and antennae, connect the combined outputs 
of the ESG system and AWGN signal generator to the RF input of the BS.

b. If the BS has multiple input ports, unused ports need to be terminated.

c. Connect the system controller and the BER test platform to the BS.

2. Measure the Bit Error Ratio (BER) of the BS.

The controller or BER test platform measures the bit error ratio of the BS exposed to 
the RF output power at a typical amplitude. This process verifies that the BER of the 
BS is within specification before introducing the AWGN interferer.

3. Record the first BER measurement result in the column titled, “Verification BER Value” 
in Table 2-47.
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4. Compare the measured BER value in the column titled, “Verification BER Value” with 
the limits from the column titled, “Specification Limitations.”

• If the measured value is within the limits, continue to subsection 2.

• If the measured value is outside the limits, determine the cause of failure and repair 
the BS. After repair, return to Step 1 of this subsection.

Subsection 2. Dynamic Range Measurement  

Complete the following steps to make a dynamic range measurement on your BS. 

1. Modify the amplitude level the W-CDMA stimulus.

In accordance with the 3GPP W-CDMA RF specification, increase the amplitude of the 
RF output power to −91.00 dBm.

On the ESG:

Press Amplitude > −91 > dBm.

2. Introduce the AWGN interferer. This signal acts as an interferer to degrade the BER of 
the BS.

On the AWGN signal source:

a. Set the RF output frequency to the same RF output frequency as the ESG.

b. Set the amplitude to −73.00 dBm.

c. Set the bandwidth to 3.840 MHz (3.84 Mcps data clock rate).

d. Activate the modulation.

e. Activate the RF output.

3. Measure the BER of the W-CDMA signal in the presence of the AWGN interferer.

The controller or BER test platform measures the BER of the BS in the presence of the 
AWGN interferer.

4. Record the BER result in the column titled, “Dynamic Range BER Value” in Table 2-47.

5. Compare the recorded value of the BER result with the allowable values and record the 
PASS/FAIL status for the BS.

Example Test Record

Use the following table to record the data from the dynamic range performance test.

Table 2-47 Dynamic Range Performance Test Record

Verification BER 
Value

Dynamic Range 
BER Value

Specification 
Limitations PASS/FAIL Status

BER ≤0.001
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Adjacent Channel Selectivity (3G TS 25.141.7.4)

This section explains how to configure your test system, including signal generator 
settings and test system connections, in order to complete an adjacent channel selectivity 
performance test on your base station (BS). It includes an example performance test 
procedure and performance test record.

Specification Definition

Adjacent Channel Selectivity (ACS) is a measure of a receiver’s ability to receive a wanted 
signal at its assigned frequency in the presence of an adjacent channel signal at a given 
frequency offset from the center frequency of the assigned channel.1

Performance Test Objective

The objective of this performance test is to determine the ACS performance of your base 
station against limitations described in the 3GPP W-CDMA RF specification (3G TS 25.141 
V3.4). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring Bit Error Ratio (BER) in 
the presence of a specified adjacent channel interferer.

Process

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
Base station conformance testing (FDD) Technical Specification 3G TS 25.141 V3.4 (2000-12).
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ESG Configuration

This test can be performed using the default uplink W-CDMA parameter settings with the 
exceptions of setting Frequency, Amplitude, Channel State, RF On/Off, and 
Mod On/Off. Configure the signal generators by using the front panel hardkeys and 
softkeys (or the appropriate SCPI commands) to enter the values listed in Table 2-48 and 
Table 2-49.

Unless otherwise noted, values are to be entered on both signal generators.

Table 2-48 ACS Physical Layer Configuration

ESG # Channel # Parameter Setting

ESG 1 Channel 1

ESG 2 Channel 2

Channel State On

PhyCH Type DPCCH 

Power −2.69 dB 

Beta 11

TFCI Pattern 0000

Slot Format 0

Symbol Rate 15.0 ksps

FBI Pattern 00000000

Channel Code 0

TPC Pattern Up/Down

TPC Pat Steps 1

ESG 1 Channel 1

ESG 2 Channel 2

Channel State On

PhyCH Type DPDCH

Power 0.00 dB 

Beta 15

Data Transport CH

Symbol Rate 60.000 ksps

Slot Format 2
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NOTE For this performance test, ESG 2 must be provided with Option H99 
Improved ACP performance for W-CDMA, CDMA, and TETRA systems.

Table 2-49 ACS Transport Layer, Baseband, and RF Carrier Configuration

Transport Layer Parameter Setting

Ref Measure Setup 12.2 kbps

Data PN9

W-CDMA Baseband Signal Parameter Setting

UE Setup Filter: RNYQ(α=0.220)EVM
Chip Rate: 3.840000 Mcps
Scrambling Code: 0

BBG Data Clock Int1

Phase Polarity Normal

W-CDMA Off/On On

W-CDMA RF Carrier Parameter Setting

Frequency 1950 MHz (ESG 1)
1945 MHz or 1955 MHz (ESG 2)2

Amplitude −111.00 dBm (ESG 1)3

−52.00 dBm (ESG 2)

RF Off/On On (ESG 1)
Off (ESG 2)

Mod Off/On On

1 Set to external if using the optional base station chip clock output as the ESG’s data clock 
source.

2 The frequency of the unwanted signal generated at the output of ESG 2 must be ±5 MHz 
from the fundamental waveform generated at the output of ESG 1.

3 The amplitude of the W-CDMA stimulus is initially set to an arbitrary value (−111.0 dBm), 
in order to perform a BER verification measurement. After BER verification, the 
amplitude will be modified to the required value (−115.0 dBm) in accordance with the 
3GPP specification for this performance test.
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Example Test Procedure

Follow this example procedure to perform a 3GPP W-CDMA adjacent channel selectivity 
test on your BS. Perform the procedures in the subsections sequentially, in the order in 
which they appear in this document.

Subsection 1. Equipment Setup and Preliminary BER Verification  

Complete the following steps to connect the equipment and perform a BER verification test 
on your BS. 

Figure 2-18 Adjacent Channel Selectivity Equipment Setup

1. Connect the BS to the test system as shown in Figure 2-18.

a. Using the appropriate cables, adapters, and antennae, connect the output of the two 
ESGs to the RF input ports of the signal combiner.

b. Connect the RF output port of the signal combiner to the RF input of the BS.

c. Connect the system controller and the BER test platform to the BS.

2. Measure the Bit Error Ratio (BER) of the BS.

The controller or BER test platform is measuring the bit error ratio of the BS exposed to 
the RF output of ESG 1 only. This process verifies that the BER of the BS is within 
specification without the adjacent channel interferer.

3. Record the first BER measurement result in the column titled, “Verification BER Value” 
in Table 2-50.
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4. Compare the measured BER value in the column titled, “Verification BER Value” with 
the limits from the column titled, “Specification Limitations.”

• If the measured value is within the limits, continue to subsection 2.

• If the measured value is outside the limits, determine the cause of failure and repair 
the BS. After repair, return to Step 1 of this subsection.

Subsection 2. ACS Measurement  

Complete the following steps to make an ACS measurement on your BS. 

1. Modify the amplitude of the W-CDMA stimulus to −115.00 dBm.

On ESG 1:

Press Amplitude > −115 > dBm.

2. Introduce the adjacent channel interferer.

The adjacent channel stimulus is made available at the RF output of ESG 2. In 
accordance with the 3GPP W-CDMA RF specification, the center frequency of this 
adjacent channel interferer can be offset ±5 MHz from the center frequency of 
fundamental waveform. The amplitude of the adjacent interferer is −52.00 dBm.

On ESG 2:

Press RF On/Off (or executing the appropriate SCPI command) until the RF ON 
annunciator is displayed on ESG 2.

3. Measure the BER of the BS in the presence of the adjacent channel stimulus.

The controller or BER test platform is measuring the bit error ratio of the BS in the 
presence of both the W-CDMA stimulus from ESG 1 and the adjacent channel interferer 
from ESG 2.

4. Record the BER measurement result in the column titled, “Adjacent Channel BER 
Value” in Table 2-50.

5. Compare the recorded value of the BER measurement with the allowable values and 
record the PASS/FAIL status for the BS.

Example Test Record

Use the following table to record the data from the ACS performance test.

Table 2-50 ACS Performance Test Record

Verification BER 
Value

Adjacent Channel 
BER Value

Specification 
Limitations PASS/FAIL Status

BER ≤0.001
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Blocking Characteristics (3G TS 25.141.7.5)

This section explains how to configure your test system, including signal generator 
settings and test system connections, in order to complete a blocking characteristics 
performance test on your base station (BS). It includes an example performance test 
procedure and performance test record.

NOTE An external source capable of providing CW at an amplitude of −15 dBm 
across a frequency range of 4 to 12.750 GHz is required for testing above 
4 GHz (or the maximum RF output frequency of your ESG).

Specification Definition

Blocking characteristic is a measure of the receiver’s ability to receive a wanted signal at 
its assigned channel frequency in the presence of an unwanted interferer on frequencies 
other than those of the adjacent channels.1

Performance Test Objective

The objective of this performance test is to determine the in-band and out-of-band blocking 
characteristics performance of your BS against limitations described in the 3GPP 
W-CDMA RF specification (3G TS 25.141 V3.4). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring Bit Error Ratio (BER) in 
the presence of specified interferers at in-band and out-of-band frequencies (other than 
adjacent channel frequencies).

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
Base station conformance testing (FDD) Technical Specification 3G TS 25.141 V3.4 (2000-12).
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ESG Configuration

Performance tests can be done with the default settings with the exceptions of setting 
Frequency, Amplitude, Channel State, RF On/Off, and Mod On/Off. Configure the signal 
generators by using the front panel hardkeys and softkeys (or the appropriate SCPI 
commands) to enter the values listed in Table 2-51 and Table 2-52.

Unless otherwise noted, values are to be entered on both signal generators.

Table 2-51 Blocking Characteristics Physical Layer Configuration

ESG # Channel # Parameter Setting

ESG 1 Channel 1

ESG 2 Channel 1

Channel State On

PhyCH Type DPCCH 

Power −2.69 dB 

Beta 11

TFCI Pattern 0000

Slot Format 0

Symbol Rate 15.0 ksps

FBI Pattern 00000000

Channel Code 0

TPC Pattern Up/Down

TPC Pat Steps 1

ESG 1 Channel 2

ESG 2 Channel 2

Channel State Off
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Table 2-52 Blocking Characteristics Transport Layer, Baseband, and RF Carrier 
Configuration

Transport Layer Parameter Setting

Ref Measure Setup 12.2 kbps

Data PN9

W-CDMA Baseband Signal Parameter Setting

UE Setup Filter: RNYQ(α=0.220)EVM
Chip Rate: 3.840000 Mcps
Scrambling Code: 0

BBG Data Clock Int1

Phase Polarity Normal

W-CDMA Off/On On

W-CDMA RF Carrier Parameter Setting

Frequency 1950 MHz (ESG 1)
1940 MHz or 1960 MHz (ESG 2)2

Amplitude −111.00 dBm (ESG 1)3

−40.00 dBm (ESG 2)

RF Off/On On (ESG 1)
Off (ESG 2)

Mod Off/On On

1 Set to external if using the optional base station chip clock output as the ESG’s data clock 
source.

2 The frequency of the unwanted signal generated at the output of ESG 2 must be ±10 MHz 
from the fundamental W-CDMA signal generated at the output of 
ESG 1.

3 The amplitude of the W-CDMA stimulus is initially set to an arbitrary value (−111.0 dBm), 
in order to perform a BER verification measurement. After BER verification, the 
amplitude will be modified to the required value (−115.0 dBm) in accordance with the 
3GPP specification for this performance test.
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Example Test Procedure

Follow this example procedure to perform a 3GPP W-CDMA blocking characteristics test 
on your BS. Perform the subsections in this procedure sequentially, in the order in which 
they appear in this document.

Subsection 1. Equipment Setup and Preliminary BER Verification  

Complete the following steps to connect the equipment and perform a BER verification test 
on your BS. 

Figure 2-19 Blocking Characteristics Equipment Setup

1. Connect the BS to the test system as shown in Figure 2-19.

a. Using the appropriate cables, adapters, and antennae, connect the outputs of the two 
ESGs, or of one ESG and RF signal generator, to the RF input ports of the signal 
combiner. 

b. Connect the RF output port of the signal combiner to the RF input of the BS. 

c. Connect the system controller and the BER test platform to the BS.
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2. Measure the Bit Error Ratio (BER) of the BS.

The controller or BER test platform is measuring the bit error ratio of the BS exposed to 
the RF output of ESG 1 only. This process verifies that the BER of the BS is within 
specification without the presence of the interfering signal.

3. Record the first BER measurement result in the column titled, “Verification BER 
Value” in Table 2-53.

4. Compare the measured BER value in the column titled, “Verification BER Value” with 
the limits from the column titled, “Specification Limitations.”

• If the measured value is within the limits, continue to subsection 2.

• If the measured value is outside the limits, determine the cause of failure and repair 
the BS. After repair, return to Step 1 of this subsection.

Subsection 2. In-Band Measurements  

Complete the following steps to make an in-band blocking characteristics measurement on 
your BS. 

1. Adjust the amplitude of the fundamental W-CDMA signal to the required value.

Modify the amplitude of the W-CDMA stimulus to −115.0 dBm.

On ESG 1:

Press Amplitude > −115 > dBm. 

2. Introduce the in-band 10 MHz offset interferer.

The first in-band interfering stimulus is made available at the RF output of ESG 2. In 
accordance with the 3GPP W-CDMA RF specification, the center frequency of this 
interferer must be offset ±10 MHz from the center frequency of fundamental W-CDMA 
signal. The amplitude of this interfering signal is −40.00 dBm.

On ESG 2:

Activate the RF output by pressing RF On/Off (or executing the appropriate SCPI 
command) until the RF ON annunciator is displayed.

3. Measure the BER of the BS in the presence of the 10 MHz offset in-band interferer.

The controller or BER test platform is measuring the bit error ratio of the BS in the 
presence of both the RF output waveform from ESG 1 and the 10 MHz offset in-band 
interferer from ESG 2.

4. Record the BER measurement result for the 10 MHz offset in-band interferer in the 
column titled, “10 MHz Offset Interferer BER Value” in Table 2-53.

Subsection 3. Out-of-Band Measurements  

Complete the following steps to make out-of-band blocking characteristics measurements 
on your BS. 

Perform the following parts of this subsection sequentially, in the order they appear in this 
document.
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Part A. Modulated Interferer Measurements  

1. Introduce the modulated negative frequency offset out-of-band interferer.

The out-of-band interfering stimulus is also made available at the RF output of ESG 2. 
In accordance with the 3GPP W-CDMA RF specification, the center frequency of this 
interferer must be offset a minimum of 10 MHz below the center frequency of 
fundamental W-CDMA signal. The amplitude of this interferer is −40.00 dBm.

On ESG 2:

Press Frequency and enter a value between 1900 MHz and 1920 MHz. This value must 
be at least 10 MHz below the center frequency of the fundamental W-CDMA signal.

2. Measure the BER of the BS in the presence of the modulated negative frequency offset 
out-of-band interferer.

The controller or BER test platform is measuring the bit error ratio of the BS in the 
presence of both the fundamental W-CDMA signal from ESG 1 and the modulated 
negative frequency offset out-of-band interferer from ESG 2.

3. Record the BER measurement results for the modulated negative frequency offset 
out-of-band interferer in the column titled, “Negative Frequency Offset Interferer BER 
Value” in Table 2-54.

4. Introduce the modulated positive frequency offset out-of-band interferer.

The out-of-band interfering stimulus is also made available at the RF output of ESG 2. 
In accordance with the 3GPP W-CDMA RF specification, the center frequency of this 
interferer must be offset a minimum of 10 MHz above the center frequency of 
fundamental W-CDMA signal. The amplitude of this interferer is −40.00 dBm.

On ESG 2:

Press Frequency and enter a value between 1980 MHz and 2000 MHz. This value must 
be at least 10 MHz above the center frequency of the fundamental W-CDMA signal.

5. Measure the BER of the BS in the presence of the modulated positive frequency offset 
out-of-band interferer.

The controller or BER test platform is measuring the bit error ratio of the BS in the 
presence of both the fundamental W-CDMA signal from ESG 1 and the modulated 
positive frequency offset out-of-band interferer from ESG 2.

6. Record the BER measurement results for the modulated positive frequency offset 
out-of-band interferer in the column titled, “Positive Frequency Offset Interferer BER 
Value” in Table 2-54.

Part B. CW Interferer Measurements  

NOTE An external signal source capable of providing CW at an amplitude of 
−15 dBm across a frequency range of 1.000 MHz to 12.750 GHz is required for 
out-of-band performance testing.
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1. Introduce the negative offset CW out-of-band interferer.

The negative offset CW out-of-band interferer is made available at the RF output of the 
external signal source. The amplitude of this interferer is −15.00 dBm.

On the external signal source:

a. Set the waveform type to CW.

b. Set the RF output frequency to a value between 1 MHz and 1900 MHz.

c. Set the RF output amplitude to −15 dBm.

d. Activate the RF output.

2. Measure the BER of the BS in the presence of the negative offset CW out-of-band 
interferer.

The controller or BER test platform is measuring the bit error ratio of the BS in the 
presence of both the RF output waveform from ESG 1 and the negative offset CW 
out-of-band interferer from the external signal source.

3. Record the BER measurement results for the negative offset CW out-of-band interferer 
in the column titled, “Negative Frequency Offset Interferer BER Value” in Table 2-55.

4. Introduce the positive offset CW out-of-band interferer.

The positive offset CW out-of-band interferer is made available at the RF output of the 
external signal source. The amplitude of this interferer is −15.00 dBm.

On the external signal source:

a. Set the waveform type to CW.

b. Set the RF output frequency to a value between 2000 MHz and 12750 MHz.

c. Set the RF output amplitude to −15 dBm.

d. Activate the RF output.

5. Measure the BER of the BS in the presence of the positive offset CW out-of-band 
interferer.

The controller or BER test platform is measuring the bit error ratio of the BS in the 
presence of both the RF output waveform from ESG 1 and the positive offset CW 
out-of-band interferer from the external signal source.

6. Record the BER measurement results for the positive offset CW out-of-band interferer 
in the column titled, “Positive Frequency Offset Interferer BER Value” in Table 2-55.

7. Compare all of the values with the specification limitations and assign a PASS/FAIL 
status to the BS.
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Example Test Record

Use the following tables to record the data from the blocking characteristics performance 
tests.

Table 2-53 In-Band Measurement Blocking Characteristics Performance Test 
Record

Verification BER 
Value

10 MHz Offset 
Interferer BER 

Value

Specification 
Limitations

PASS/FAIL 
Status

BER ≤ 0.001

Table 2-54 Out-of-Band Modulated Interferer Measurements Blocking 
Characteristics Performance Test Record

Negative 
Frequency Offset 
Interferer BER 

Value

Positive 
Frequency Offset 
Interferer BER 

Value

Specification 
Limitations

PASS/FAIL 
Status

BER ≤ 0.001

Table 2-55 Out-of-Band CW Interferer Measurements Blocking Characteristics 
Performance Test Record

Negative 
Frequency Offset 
Interferer BER 

Value

Positive 
Frequency Offset 
Interferer BER 

Value

Specification 
Limitations

PASS/FAIL 
Status

BER ≤ 0.001
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Intermodulation Response Rejection (3G TS 25.141.7.6)

This section explains how to configure your test system, including signal generator 
settings and test system connections, in order to complete an intermodulation response 
rejection performance test on your base station (BS). It includes an example performance 
test procedure and performance test record.

NOTE An external source capable of providing CW at an amplitude of −48 dBm 
across a frequency range of 1920.0 to 1980.0 MHz is required for IRR 
performance testing.

Specification Definition

Intermodulation response rejection is a measure of the capability of a receiver to receive a 
wanted signal on its assigned channel frequency in the presence of two or more interfering 
signals which have a specific frequency relationship to the wanted signal.1

Performance Test Objective

The objective of this performance test is to determine the Intermodulation Response 
Rejection (IRR) performance of your BS against limitations described in the 3GPP 
W-CDMA RF specification (3G TS 25.141 V3.4). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring Bit Error Ratio (BER) in 
the presence of two specified, frequency-related interferers.

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
Base station conformance testing (FDD) Technical Specification 3G TS 25.141 V3.4 (2000-12).
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ESG Configuration

This test can be performed using the default uplink W-CDMA parameter settings with the 
exceptions of setting Frequency, Amplitude, Channel State, RF On/Off, and Mod On/Off. To 
configure the signal generators, use the front panel hardkeys and softkeys (or the 
appropriate SCPI commands) to enter the values listed in Table 2-56 and Table 2-57.

Unless otherwise noted, values are to be entered on both ESGs.

Table 2-56 IRR Physical Layer Configuration

ESG # Channel # Parameter Setting

ESG 1 Channel 1

ESG 2 Channel 1

Channel State On

PhyCH Type DPCCH 

Power −2.69 dB 

Beta 11

TFCI Pattern 0000

Slot Format 0

Symbol Rate 15.0 ksps

FBI Pattern 00000000

Channel Code 0

TPC Pattern Up/Down

TPC Pat Steps 1

ESG 1 Channel 2

ESG 2 Channel 2

Channel State Off
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Table 2-57 IRR Transport Layer, Baseband, and RF Carrier Configuration

Transport Layer Parameter Setting

Ref Measure Setup 12.2 kbps

Data PN9

W-CDMA Signal Parameter Setting

UE Setup Filter: RNYQ(α=0.220)EVM
Chip Rate: 3.840000 Mcps
Scrambling Code: 0

BBG Data Clock Int1

Phase Polarity Normal

W-CDMA Off/On On

W-CDMA RF Carrier Parameter Setting

Frequency 1950 MHz (ESG 1)
1930 MHz (ESG 2)2

Amplitude −111.00 dBm (ESG 1)3

−48.0 dBm (ESG 2)

RF Off/On On (ESG 1)
Off (ESG 2)

Mod Off/On On

1 Set to external if using the optional base station chip clock output as the ESG’s data clock 
source.

2 The frequency of the modulated interferer generated at the output of ESG 2 must be 
±20 MHz from the fundamental W-CDMA signal generated at the output of 
ESG 1.

3 The amplitude of the W-CDMA stimulus is initially set to an arbitrary value (−111.0 dBm), 
in order to perform a BER verification measurement. After BER verification, the 
amplitude will be modified to the required value (−115.0 dBm) in accordance with the 
3GPP specification for this performance test.
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Example Test Procedure

Follow this example procedure to perform a 3GPP W-CDMA intermodulation response 
rejection test on your BS. Perform the subsections in this procedure sequentially, in the 
order they appear in this document.

Subsection 1. Equipment Setup and Preliminary BER Verification  

Complete the following steps to connect the equipment and perform a BER verification test 
on your BS. 

Figure 2-20 Intermodulation Response Rejection Equipment Setup

1. Connect the BS to the test system as shown in Figure 2-20.

a. Using the appropriate cables, adapters, and antennae, connect the outputs of the two 
ESGs and one RF signal generator to the RF input ports of the signal combiner.

b. Connect the RF output port of the signal combiner to the RF input of the BS.

c. Connect the system controller and the BER test platform to the BS.
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2. Measure the Bit Error Ratio (BER) of the BS.

The controller or BER test platform is measuring the bit error ratio of the BS exposed to 
the RF output of ESG 1 only. This process verifies that the BER of the BS is within 
specification without the intermodulation products generated by the CW and 
modulated interferers.

3. Record the first BER measurement result in the column titled, “Verification BER Value” 
in Table 2-58.

4. Compare the measured BER value in the column titled, “Verification BER Value” with 
the limits from the column titled, “Specification Limitations.”

• If the measured value is within the limits, continue to subsection 2.

• If the measured value is outside the limits, determine the cause of failure and repair 
the BS. After repair, return to Step 1 of this subsection.

Subsection 2. Negative Frequency Offset Interferers Measurement  

Complete the following steps to make negative frequency offset interferer IRR 
measurements on your BS. 

1. Adjust the amplitude of the fundamental W-CDMA signal to the required value.

Modify the amplitude of the W-CDMA stimulus to −115.0 dBm.

On ESG 1:

Press Amplitude > −115 > dBm. 

2. Introduce the negative 10 MHz offset interferer from the RF signal generator and 
negative 20 MHz offset interferer from the ESG 2 (relative to the center frequency of 
the W-CDMA signal) in the frequency range 1920.0 to 1980.0 MHz. The amplitudes of 
these interferers are −48 dBm.

On ESG 2:

Activate the RF output by pressing RF On/Off (or executing the appropriate SCPI 
command) until the RF ON annunciator is displayed. 

On the external signal source:

a. Set the waveform type to CW.

b. Set the RF output frequency to 1940 MHz.

c. Set the RF amplitude to −48 dBm.

d. Activate the RF output.

3. Measure the BER of the BS.

The controller or BER test platform is measuring the bit error ratio of the BS in the 
presence of the negative frequency offset interferers. 
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4. Record the BER measurement results for the negative frequency offset interferers 
measurement in the column titled, “Negative Frequency Offset Interferers BER Value” 
in Table 2-58.

Subsection 3. Positive Frequency Offset Interferers Measurements  

Complete the following steps to make positive frequency offset interferer IRR 
measurements on your BS. 

1. Introduce the positive 10 MHz offset interferer from the RF signal generator and 
positive 20 MHz offset interferer from the ESG 2 (relative to the center frequency of the 
W-CDMA signal) in the frequency range 1920.0 to 1980.0 MHz. The amplitudes of these 
interferers are −48 dBm.

On ESG 2:

Press Frequency > 1970 > MHz. 

On the external signal source:

Set the RF output frequency to 1960 MHz.

2. Measure the BER of the BS.

The controller or BER test platform is measuring the bit error ratio of the BS in the 
presence of the positive frequency offset interferers. 

3. Record the BER measurement results for the positive frequency offset interferers 
measurement in the column titled, “Positive Frequency Offset Interferers BER Value” 
in Table 2-58.

4. Compare all of the values with the specification limitations and assign a PASS/FAIL 
status to the BS.

Example Test Record

Use the following table to record the data from the IRR performance test.

Table 2-58 IRR Performance Test Record

Verification 
BER Value

Negative 
Frequency 

Offset 
Interferers
BER Value

Positive 
Frequency 

Offset 
Interferers
BER Value

Specification 
Limitations

PASS/FAIL 
Status

BER ≤ 0.001
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Spurious Emissions (3G TS 25.141.7.7)

This section contains a performance test summary and explains how to configure your test 
system in order to complete an spurious emissions performance test on your base station 
(BS).

NOTE Spurious emissions measurements are only available within the specified 
input frequency limitations of the microwave spectrum analyzer.

Specification Definition

Spurious emissions is a measure of the power of emissions generated or amplified in a 
receiver that appear at the BS antenna connector.1

Performance Test Objective

The objective of this performance test is to determine the spurious emissions performance 
of your BS against limitations described in the 3GPP W-CDMA RF specification (3G TS 
25.141 V3.4). 

Defining Measurement

The PASS/FAIL status of the DUT is determined by measuring the power level and 
occupied bandwidth of the spurious emissions generated by the BS.

Process

1. From 3rd Generation Partnership Project; Technical Specification Group Radio Access Networks; 
Base station conformance testing (FDD) Technical Specification 3G TS 25.141 V3.4 (2000-12).
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Example Test Procedure

Follow this example procedure to perform 3GPP W-CDMA spurious emissions performance 
test on your BS.

Figure 2-21. Spurious Emissions Equipment Setup

1. Connect the equipment as shown in Figure 2-21.

2. Configure the E4440A performance spectrum analyzer. (For additional information, 
refer to the E4440A performance spectrum analyzer measurement guide.)

3. Terminate the transmitter (TX) port(s) of the BS appropriately.

4. Set the frequency span of the spectrum analyzer from 1920 MHz to 1980 MHz. Measure 
the power levels and occupied bandwidths of the spurious emissions from the BS. 
Record the results in the column titled, “Measurement Value” in Table 2-59.

5. Set the frequency span of the spectrum analyzer from 9 kHz to 1 GHz. Measure the 
power levels and occupied bandwidths of the spurious emissions from the BS. Record 
the results in the column titled, “Measurement Value” in Table 2-59.

6. Set the frequency span of the spectrum analyzer from 1 GHz to 12.75 GHz. Measure the 
power levels and occupied bandwidths of the spurious emissions from the BS. Record 
the results in the column titled, “Measurement Value” in Table 2-59.

7. Compare the values with the specification limitations and assign a PASS/FAIL status to 
the BS.
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Example Test Record  

Use the following table to record the data from the spurious emissions performance test.

Table 2-59 Spurious Emissions Performance Test Record

Frequency Range Measurement
Value

Specification 
Limitations

PASS/FAIL 
Status

1920 to 1980 MHz −78 dBm/3.840 MHz

9 kHz to 1 GHz −57 dBm/100 kHz

1 GHz to 12.75 GHz1

1With the exception of frequencies lower than 12.5 MHz from the first carrier frequency 
used, or higher than 12.5 MHz from the last carrier frequency used.

−47 dBm/1 MHz
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Troubleshooting
Use the following checklists to help troubleshoot problems with Option 200.

NOTE In some cases, the ESG may allow invalid channel coding settings without 
reporting an error. If you experience problems, ensure that the setting of the 
ESG(s) conform to the 3GPP Technical Specification.

Tips and Tricks

There is a Tips and Tricks section located on the Agilent Technologies ESG support web 
site that may provide you assistance in the operation of the Option 200 firmware. Perform 
the following steps to reach the appropriate web site:

1. Enter and go to www.agilent.com/find/esg.

2. Select your model of ESG under the Products list. 

3. Select Software Patches and Drivers, in the next window, under the Additional 
Information list.

4. Select the firmware version currently loaded on your ESG, shown under the Software 
Updates section.

The firmware version is displayed when the ESG is powered on or it can be viewed by 
pressing the following keys and viewing the listed field:

Utility > Instrument Info/Help Mode > Diagnostic Info > Firmware Revision

5. Locate the Tips and Tricks section and follow any instructions that may be appropriate 
to your situation.

Can’t Turn on W-CDMA

❏ At least one W-CDMA channel must be on.

Can’t See Channels Displayed on Transmitter Tester

Ensure that the following are true:

❏ W-CDMA channels are on.

❏ W-CDMA is on (W-CDMA and I/Q annunciators are displayed). I/Q must be toggled on to 
modulate the RF output.

❏ ESG RF output is on (RF ON annunciator is displayed).

❏ ESG RF is modulated (MOD ON annunciator is displayed).

❏ Scrambling Code (BS Setup) of ESG matches primary scramble code of VSA.

❏ For two-ESG system configurations, the I/Q Source is set to Ext I/Q and BBG Data 
Clock set to Ext.
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❏ ESG RF power may need to be increased (for example, –30 dBm).

❏ Power of other coded channels may need to be decreased.

❏ ESG carrier signal power is higher than the receiver’s noise floor. (Increase the ESG 
carrier signal power level if the signal cannot be seen on the transmitter tester.)

❏ ESG OCNS channel power level is sufficient to increase the code domain power to the 
appropriate level without interfering with the other channels. (OCNS channel power 
may need to be reduced.)

When Programming Two ESGs, Both Signal Generators Display the Same Values

❏ Each ESG must have a unique GPIB address:
Utility > GPIB/RS2-32 > GPIB Address
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3 Softkey Reference

This chapter lists, in alphanumeric order, the softkeys and associated data fields available 
with Option 200.

Navigate among the data field entries using the front panel knob or the arrow keys.

For the SCPI commands that duplicate some of these softkeys remotely, see
Chapter 5 , “Remote Programming and Examples.”

To access the Option 200 softkeys 
use the front panel Mode key.

If your signal generator has 
multiple options, the softkeys in 
the first menu enable you to 
access the various options. 
Press Real Time I/Q Baseband to 
display the CDMA softkey.

NOTE

• The key paths provided in this chapter do not include the 
Real Time I/Q Baseband softkey.

• If you do not see a softkey in the indicated menu, it may be on the 
next page of that menu; to display the next page, press the More 
softkey. Hardkeys and softkeys are denoted by Bold text; data fields 
by Courier font. 
For example:

Location: Mode > CDMA > BS Setup > Filter

• All softkey and Data Field Location pathways assume a factory 
preset condition.

Data FieldSoftkeysHardkey
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Symbols

# of Blocks

This field sets the number of blocks transmitted by the active transport 
(DCH) channel.

Range: 1 to 8

Default: 1

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > PhyCH Type > DPCH > Ref Measure Setup > (select any 
reference measurement channel type) > Config Transport > # of Blocks

% Power Other ESG

After setting the channel powers of both ESGs, edit this field by 
entering the percent power value of the ESG that is paired with this 
one. Once the value has been entered, Scale to 0 dB will scale the 
channel powers so that the sum of the powers is 0 dB taking into 
account the total power of both ESGs. See “Adjust the Relative Power 
Mapping” on page 2-14. 

NOTE For the single-ESG setup, set this field to 0.0 percent.

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
2 Box Setup > % Power Other ESG

% Power This ESG

This field displays the percentage of total power that this ESG is 
contributing. Enter a value in the % Power Other ESG data field of the 
ESG that is paired with this one. See “Adjust the Relative Power 
Mapping” on page 2-14.

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
2 Box Setup > % Power This ESG
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Numerics

1/2 Conv

This key sets a one-half rate convolutional encoder, used for coding each 
transport channel selected for uplink physical channel #2.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Coding > Edit Item > 1/2 Conv

1/3 Conv

This key sets a one-third rate convolutional encoder, used for coding 
each transport channel selected for uplink physical channel #2.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Coding > Edit Item > 1/3 Conv

2 Box Setup

This key accesses a table editor from which you can select and modify 
the parameters of the IQ voltage scale and scale the code domain power 
to 0 dB for the two-ESG configuration. See “I/Q Voltage Scale” 
on page 3-39. This is valid for the two-ESG configuration in downlink 
only.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > 2 Box Setup

10 msec

This key sets the frame clock interval to 10 milliseconds for the uplink 
synchronization signal setup.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Uplink Sync Setup > Signal Setup > Frame Clock Interval > 10 msec

12.2 kbps (25.101 v3.5)

This key sets the downlink DPCH channel to 12.2 kbps for the reference 
measurement test setup.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > Ref Measure Setup > 12.2 kbps (25.101 v3.5)
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20 msec

This key sets the frame clock interval to 20 milliseconds for the uplink 
synchronization signal setup.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Uplink Sync Setup > Signal Setup > Frame Clock Interval > 20 msec

40 msec

This key sets the frame clock interval to 40 milliseconds for the uplink 
synchronization signal setup.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Uplink Sync Setup > Signal Setup > Frame Clock Interval > 40 msec

64 kbps (25.101 v3.5)

This key sets the downlink DPCH channel to 64 kbps for the reference 
measurement test setup.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > Ref Measure Setup > 64 kbps (25.101 v3.5)

80 msec

This key sets the frame clock interval to 80 milliseconds for the uplink 
synchronization signal setup.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Uplink Sync Setup > Signal Setup > Frame Clock Interval > 80 msec

144 kbps (25.101 v3.5)

This key sets the downlink DPCH channel to 144 kbps for the reference 
measurement test setup.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > Ref Measure Setup > 144 kbps (25.101 v3.5)

384 kbps (25.101 v3.5)

This key sets the downlink DPCH channel to 384 kbps for the reference 
measurement test setup.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > Ref Measure Setup > 384 kbps (25.101 v3.5)
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A

Abort Channel Setup

This key immediately stops the channel-coding generation process that 
was initiated after pressing the Apply Channel Setup softkey. This key is 
valid for uplink only.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 1 or 2 > PhyCH Setup > Apply Channel Setup > 
Abort Channel Setup

Or: Mode > CDMA > W-CDMA > Link Up > Link Control > 2 > 
Config Transport > Transport Channel # 1 to 6 > TrCH Setup > 
Apply Channel Setup > Abort Channel Setup

Actual BER

This field displays the actual bit error rate (BER) value being 
generated. This value may be different from the desired BER value as 
set in the BER field. It is calculated after the Apply Channel Setup key is 
pressed and the error bits are inserted into the data of the transport 
channel. To insert the error bits, the Err Insert field must be set to 
BER. This data field is on the second page of the table editor.

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Actual BER

Actual BLER

This field displays the actual block error rate (BLER) value being 
generated. This value may be different from the desired BLER value as 
set in the BLER field. It is calculated after the Apply Channel Setup key is 
pressed and the error blocks are inserted into the data of the transport 
channel. To insert the error blocks, the Err Insert field must be set to 
BLER. This data field is on the second page of the table editor.

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Actual BLER
Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide 3-5



Softkey Reference ESG Family Signal Generators
A Option 200
Adjust Code Domain Power

This key accesses a menu in which you can adjust the code domain 
power. Select the Equal Powers or Scale to 0 dB softkey from the list 
displayed to set the code domain power level. This key is valid only for a 
one-box configuration.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
Adjust Code Domain Power

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > Adjust Code Domain Power

All Down

This key sets the transport power control (TPC) pattern to send 
consecutive down commands. The power will decrease by 1 dB on a 
slot-by-slot basis.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, 4 > PhyCH Type > DPCH > PhyCH Setup > TPC Pattern > 
Edit Item > All Down

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > TPC Pattern > 
Edit Item > Select Pattern > All Down

All Up

This key sets the transport power control (TPC) pattern to send 
consecutive up commands. The power will increase by 1 dB on a 
slot-by-slot basis.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, 4 > PhyCH Type > DPCH > PhyCH Setup > TPC Pattern > 
Edit Item > All Up

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > TPC Pattern > 
Edit Item > Select Pattern > All Up
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AMR 12.2 (25.944 v3.3)

This key selects the adaptive multirate (AMR) 12.2 kbps reference 
measurement test setup.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > PhyCH Type > DPCH > Ref Measure Setup > 
AMR 12.2 (25.944 v3.3)

AMR 12.2 kbps

This key selects the adaptive multirate (AMR) 12.2 kbps reference 
measurement test setup.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Ref Measure Setup > AMR 12.2 kbps

APCO 25 C4FM

This key selects an Association of Public-safety Communications 
Officials (APCO) 25 specified C4FM filter in the Select (filter) menu. 
This is a Nyquist filter with an alpha of 0.2 that is combined with a 
shaping filter.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > APCO 25 C4FM

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > APCO 25 C4FM

Apply Bit Errors

This key appears in two places.

Create File/Edit File Menu

This key displays a menu in which you can enter bit errors and a 
percentage of bit errors in the file displayed in the Bit File Editor.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > PhyCH Type > DPCH or PICH > PhyCH Setup > Data > 
Edit Item > User File > Create File or Edit File > Apply Bit Errors

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > TPC Pattern > Edit Item > User File > 
Create File or Edit File > Apply Bit Errors

Or: Mode > CDMA > W-CDMA > Link Up > Link Control > 2 > 
PhyCH Setup > Data > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors
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Bit Errors Menu

This key applies the adjusted values of bit errors to the current file. 
From this menu you can enter bit errors as a numeric value or as a 
percentage or the total bit count and apply these to the selected file.

Range: 0 to 511

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > PhyCH Type > DPCH or PICH >PhyCH Setup > Data > 
Edit Item > User File > Create File or Edit File > Apply Bit Errors > 
Apply Bit Errors

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > TFCI Pattern, TPC Pattern, or 
FBI Pattern > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors > Apply Bit Errors

Or: Mode > CDMA > W-CDMA > Link Up > Link Control > 2 > 
PhyCH Setup > Data > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors > Apply Bit Errors
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Apply Channel Setup

This key initiates the data coding process for the physical and transport 
channel’s user-defined parameters. Upon pressing this key, the 
required calculations are made and data is generated. The time taken is 
dependent on the physical and transport channel configurations. This 
key appears in several locations.

PhyCH Setup menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > PhyCH Type > (type) > PhyCH Setup > Apply Channel Setup

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > Apply Channel Setup

Or: Mode > CDMA > W-CDMA > Link Up > Link Control > 2 > 
PhyCH Setup > Apply Channel Setup

TrCH Setup Menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > 
Transport CH > Return > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Apply Channel Setup

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Apply Channel Setup
Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide 3-9



Softkey Reference ESG Family Signal Generators
B Option 200
B

BBG Data Clock Setup

This key displays a menu from which you can select the baseband 
generator (BBG) data clock source and a multiplier for the external 
clock.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
BBG Data Clock Setup

BBG Data Clock Ext Int

This key selects the baseband generator (BBG) data clock source. The 
choices are external (Ext) or internal (Int). In external mode, the 
baseband generator uses the signal applied to the external data clock 
input as the data clock. When internal is selected, it uses the internal 
data clock.

Default: Internal

Softkey Location (Downlink): Mode > CDMA > W-CDMA > 
BBG Data Clock Ext Int

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
BBG Data Clock Setup > BBG Data Clock Ext Int

BCH Data

This field displays the data type used for the broadcast channel (BCH). 
The data type can be PN9, PN15, FIX4 or a user file. The BCH is 
carried on the P-CCPCH channel.

Default: 0000 

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > 3 > PhyCH Type > BCH Data

BER

This key sets the insertion mode to Bit Error Rate (BER) for each 
transport channel. An incorrect bit sequence is inserted in the data.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Err Insert > Edit Item > BER
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BER

This field displays the bit error rate (BER) to be inserted into the 
selected transport channel data. The value entered into this field is 
valid only when the Err Insert field is set to BER. The errors are 
applied to transport channel data when the Apply Channel Setup softkey 
is pressed. The actual numbers of the Error Bit, the Total Bit, and 
the Actual BER are displayed below this field after the errors are 
applied to the transport channel data. This data field is on the second 
page of the table editor.

Range: 0.0000 to 1.0000

Default: 0.0000 

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > BER

Beta

This key is activated automatically when you select the Kaiser 
windowing function. The default Beta factor provides a good 
compromise for optimizing out-of-band performance (ACP) without 
seriously compromising passband performance (EVM).

Changing the Beta factor adjusts the trade-off between ACP and EVM:

• decreasing the value improves EVM

• increasing the value improves ACP

Range: 1.000 to 10.000

Default: 4.000

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
BS Setup > Filter > Edit Item > Define User FIR > Load Default FIR > 
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window > Kaiser > Beta

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window > Kaiser > Beta
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Beta

This field displays the signaling value for the amplitude ratio. The 
value of the Power field is re-calculated when the value is set in this 
field. If the value of the Power field is directly set, the value of this field 
becomes invalid and “-” is displayed.

Range: 0 to 15

Default: 15

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 or 2 > PhyCH Setup > Beta

Bit Errors (numeric value)

This key allows you to enter bit errors into a selected file. The number 
of bit errors is displayed in the active entry area of the Bit File 
Editor display. These errors are applied to the selected file when the 
Apply Bit Errors softkey is pressed. The Bit Errors percent softkey will 
update automatically to reflect the number of bit errors selected. This 
key appears in several locations.

PhyCH Setup menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > PhyCH Type > DPCH or PICH > PhyCH Setup > Data > 
Edit Item > User File > or Edit File > Apply Bit Errors > 
Bit Errors <numeric value>

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > TPC Pattern > Edit Item > User File > 
Create File or Edit File > Apply Bit Errors > Bit Errors <numeric value> 

Or: Mode > CDMA > W-CDMA > Link Up > Link Control > 2 > 
PhyCH Setup > Data > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors > Bit Errors <numeric value>

TrCH Setup menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > 
Transport CH > Return > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Data > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors > Bit Errors <numeric value>

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport >Transport Channel # 1 to 6 > 
TrCH Setup > Data > Edit Item > User File > Create File or Edit File >
Apply Bit Errors > Bit Errors <numeric value>
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Bit Errors (percent value)

This key allows you to enter bit errors into the selected file as a 
percentage of the total bit count. The percentage of bit errors is 
displayed in the active entry area of the Bit File Editor display. 
These errors are applied to the selected file when the Apply Bit Errors 
softkey is pressed. When the percent value changes, the bit error 
numeric value is automatically adjusted to reflect the number of bit 
errors. This key appears in several locations.

PhyCH Setup menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > PhyCH Type > DPCH or PICH > PhyCH Setup > Data > 
Edit Item > User File > Create File or Edit File > Apply Bit Errors > 
Bit Errors <% value>

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > TPC Pattern >Edit Item > User File > 
Create File or Edit File > Apply Bit Errors > Bit Errors <% value>

Or: Mode > CDMA > W-CDMA > Link Up > Link Control > 2 > 
PhyCH Setup > Data > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors > Bit Errors <% value>

TrCH Setup menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or   > PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > 
Transport CH > Return > Config Transport >Transport Channel # 1 to 6 > 
TrCH Setup > Data > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors > Bit Errors <% value>

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Data > Edit Item > User File > Create File or Edit File > 
Apply Bit Errors > Bit Errors <% value> 
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Bits/Frame

This field is not user-defined. The value cannot be changed and the field 
is grayed-out. The field displays the bits per frame for the fully coded 
transport channel and is automatically updated from calculated 
transport channel parameters and the Ref Measurement Setup test 
rate selection.

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > 1, 2, 3, or 4 > PhyCH Type > DPCH > PhyCH Setup > Data > 
Edit Item > Transport CH > Return > Config Transport > Bits/Frame

Default (Uplink): 490 for transport channel #1, 110 for transport 
channel #2, 60 for transport channels #3, #4, #5, and #6

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 2 > Config Transport > Bits/Frame

Bits Rate

This field is not user-defined. The value cannot be changed and the field 
is grayed-out. The bits rate value is automatically updated from 
calculated transport channel parameters and the Ref Measurement 
Setup test rate selection.

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > 1, 2, 3, or 4 > PhyCH Type > DPCH > PhyCH Setup > Data > 
Edit Item > Transport CH > Return > Config Transport > Bits Rate

Default (Uplink): 12.2 kbps for transport channel #1, 2.40 kbps for 
transport channel #2, 2.00 kbps for transport channels #3, #4, #5,
and #6

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 2 > Config Transport > Bits Rate

BLER

This key sets the insertion mode to Block Error Rate (BLER) for each 
transport channel. An incorrect CRC bit sequence is inserted in the 
data.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Err Insert > Edit Item > BLER
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BLER

This field displays the block error rate (BLER) in bits, selected for the 
transport channel data. The value entered into this field is valid only 
when the Err Insert field is set to BLER. The errors are applied to the 
transport channel data when the Apply Channel Setup softkey is 
pressed. The numbers of the Error Block, the Total Block, and the 
Actual BLER fields are displayed below this field after the errors are 
applied to the transport channel data. This data field is on the second 
page of the table editor. See “Num of Blk” on page 3-46 for more 
information.

Range: 0.000 to 1.000

Default: 0.000 for all Transport Channels

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > BLER

Blk Size

This field displays the coding block size of the selected transport 
channel. The total input data in one transport channel is the block size 
multiplied by the number of blocks.

Range: 0 to 5000

Default (Downlink): 20 for all the transport channels

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > 
Transport CH > Return > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Blk Size

Default (Uplink): 244 for transport channel #1, 96 for transport channel 
#2, 20 for transport channels #3, #4, #5, and #6.

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport >Transport Channel # 1 to 6 > 
TrCH Setup > Blk Size

BS Setup

This key accesses a table editor from which you can select and modify 
the parameters for the base station (BS). Highlight the data field you 
want to change and press the Edit Item softkey. Press a softkey, use the 
numeric keypad or front panel knob to change values contained in the 
table and press the appropriate softkey to terminate the entry.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup
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Channel Code

This field displays the value of the channel code. This code is an 
orthogonal variable spreading factor code (OVSF). The range of code 
numbers is dependent on and coupled to the slot format and symbol 
rate.

Range (Downlink): 0 to 511

Default (Downlink): 6 for channel 1, 7 for channel 2, 8 for channel 3, 
and 9 for channel 4

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > 1, 2, 3, or 4 > PhyCH Type > DPCH or OCNS > 
Channel Code

Range (DPCCH of Uplink): Always 0 to 255, not depending on the slot 
format and symbol rate

Range (DPDCH of Uplink): 0 to 255

Default (Uplink): 0 for DPCCH, 16 for DPDCH

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > Channel Code

Or: Mode > CDMA > W-CDMA > Link Up > Link Control > 2 > 
PhyCH Setup > Channel Code

Slot 
Format

0-1 2-7 8-11 12 13 14 15 16

Symbol 
Rate

7.5 
ksps

15 
ksps

30 
ksps

60 
ksps

120 
ksps

240 
ksps

480 
ksps

960 
ksps

Max Ch 
Code

511 255 127 63 31 15 7 3

Slot 
Format

0 1 2 3 4 5 6

Symbol 
Rate

15 
ksps

30 
ksps

60 
ksps

120 
ksps

240 
ksps

480 
ksps

960 
ksps

Max Ch 
Code

255 127 63 31 15 7 3
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Channel State Off On

This key turns the selected physical channel on or off.

Default: On

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > Channel State Off On

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 or 2 > Channel State Off On

Chip Rate

This field displays the chip rate set in the BS Setup or UE Setup table 
editor. Press the Edit Item key to set the chip rate. The default value is 
3.84 Mcps and is in accordance with the 3GPP W-CDMA specification.

Range: 1000 cps to 4.250 Mcps.

Default: 3.840000 Mcps

Data Field Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Chip Rate

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Chip Rate

Coding

This field displays the encoder type used for the transport/physical 
channel selected. For uplink, this key is active only with physical 
channel #2. Choices for the encoder type include 1/2 Conv, 1/3 Conv, 
Turbo, and None.

Default: 1/3 Conv for transport channels #1 and #2, 1/2 Conv for all 
other transport channels

Data Field Location (Downlink): Mode > CDMA > W-CDMA >
Link Control > 1, 2, 3, or 4 > Config Transport > 
Transport Channel # 1 to 6 > TrCH Setup > Coding

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control >2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Coding
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Config Transport

This key accesses a menu from which a transport channel can be 
selected and transport channel data entered. For uplink, this key is 
active only for physical channel #2. For downlink, this key is active only 
with physical channel type DPCH and after selection of a reference 
measurement setup rate or data type TrCH. For downlink, press the 
following sequence of keys to activate the Config Transport softkey:

Mode > CDMA > W-CDMA > Link Control > PhyCH Type > DPCH > 
PhyCH Setup > Data > Edit Item > Transport CH > Return > 
Config Transport

Or: Mode > CDMA > W-CDMA > Link Control > PhyCH Type > DPCH > 
Ref Measurement Setup > (rate) > Config Transport

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
Config Transport

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport

Copy File 

This key copies the current file. You can then edit and rename the file.

Copy File is located in table editor menus and in catalogs of files.

CPICH

This key selects the common pilot channel (CPICH) as the physical 
channel type. CPICH is a fixed rate (30 kbps, SF=256) downlink 
channel.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control >
4 > PhyCH Type > CPICH

CRC Size

This field displays the number of cyclic redundancy code (CRC) bits to 
be added to the transport channel data. For downlink, this field is 
displayed after the Config Transport softkey is active. For uplink, this 
field is displayed only with physical channel #2. The CRC choices are 0, 
8, 12, 16, and 24.

Default (Downlink): 16 for transport channel 1, 12 for transport 
channel 2 and for other transport channels the default is 8.

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item >
Transport CH > Return > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > CRC Size
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Default (Uplink): 16 for transport channels 1 and 2 and for other 
transport channels the default is 8.

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > CRC Size

Create File

This key creates a new user file. The file, named Untitled, can be 
opened for editing in the Bit File Editor.

Create File is located in table editor menus and in catalogs of files.
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Data

This field displays the data type for a transport and/or physical 
channel. Press the Edit Item key to choose from a list of data types. Data 
types available include PN sequences, fixed data, transport channel 
data, or user-defined data files. This field appears in several locations.

PhyCH Setup menu

Default (Downlink): PN9

Default (Uplink): Transport CH

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > PhyCH Type > DPCH > PhyCH Setup > Data

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > PhyCH Setup > Data

TrCH Setup menu

Default: PN9

Data Field Location (Downlink): Mode > CDMA > W-CDMA >
Link Control > PhyCH Type > DPCH > PhyCH Setup > Data > 
Transport CH > Return > Config Transport > Transport Channel # 1 to 6 > 
TrCH setup > Data

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport >Transport Channel # 1 to 6 > 
TrCH Setup > Data

Define User FIR

This key accesses the FIR Values table editor. You can add or modify 
coefficients for a finite impulse response (FIR) filter. The FIR Values 
table editor allows a maximum of 1024 coefficients in a file, however, 
the signal generator hardware is limited to 256 coefficients, 32 symbols, 
and an oversample ratio between 4 and 16. 

NOTE If you enter more than 32 symbols, the instrument cannot use the filter.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR
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Delete

This key displays the Bit File Editor and a menu from which you can 
select different ways of removing bits from a file.

Delete is located in table editor menus and in catalogs of files.

Delete All Rows

This key deletes all rows in the file displayed in the Bit File Editor. You 
are asked to confirm the deletion.

Delete All Rows is located in table editor menus and in catalogs of files.

Delete Bits

This key deletes the specified number of bits from the selected file.

Delete Bits is located in table editor menus and in catalogs of files.

Delete File

This key deletes the highlighted file from the Catalog of FIR files. You 
are prompted for confirmation.

Delete File is located in table editor menus and in catalogs of files.

Delete To Beginning

This key deletes all bits from the highlighted bit to the beginning bit of 
the file displayed in the Bit File Editor.

Delete To Beginning is located in table editor menus and in catalogs of 
files.

Delete To End

This key deletes all bits from the highlighted bit to the end of the file 
displayed in the Bit File Editor. The key appears in several locations.

Delete To End is located in table editor menus and in catalogs of files.

Delete Row

This key deletes the highlighted row of the file displayed in the 
FIR Values table editor.

Delete Row is located in table editor menus and in catalogs of files.
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Display FFT

This key displays a graphical representation of the filter frequency 
response for a filter loaded into the FIR values table editor (calculated 
using a fast Fourier Transform function). The following is an example of 
the frequency response for a root Nyquist filter with an oversample 
ratio of 4.

To return to the FIR table editor and menu keys, press Return.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Display FFT

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Display FFT
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Display Impulse Response

This key displays a graphical representation of the finite impulse 
response (FIR) over time for the filter loaded into the FIR Values table 
editor. The following is an example of the impulse response of a root 
Nyquist filter with an oversample ratio of 4.

To return to the FIR table editor and menu keys, press Return.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Display Impulse Response

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR >
Display Impulse Response

Down/Up

This key sets the transport power control (TPC) pattern to repeatedly 
send down followed by n up commands. The number of n down and up 
commands is defined in the TPC Pat Steps field of the PhyCH Setup 
menu.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > PhyCH Setup > TPC Pattern > Edit Item > Down/Up

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > TPC Pattern > 
Edit Item > Select Pattern > Down/Up
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DPCCH

This key selects the dedicated physical control channel (DPCCH) for 
uplink physical channel #1. The uplink DPCCH is used to carry control 
information. For example, TFCI and TPC bits.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH

DPCH

This key selects the dedicated downlink physical channel (DPCH). This 
softkey is available for all four physical downlink channels.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH

DPDCH

This key selects the dedicated physical data channel (DPDCH) for 
uplink physical channel #2. The uplink DPDCH is used to carry the 
DCH transport channel.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > PhyCH Type > DPDCH
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E

Edit File

This key allows editing of the file selected from the Catalog of 
Binary/Bit Files. When necessary, you are asked to confirm 
converting binary files to bit files for editing. This key appears in 
several locations.

NOTE There is no undo capability; bit files are saved after each modification.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > 
User File > Edit File

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > FBI Pattern, TFCI Pattern, or 
TPC Pattern > Edit Item > User File > Edit File

Or: Mode > CDMA > W-CDMA > Link Up > Link Control > 2 > 
PhyCH Setup > Data > Edit Item > User File > Edit File

Edit Item

This key selects the highlighted field in the displayed table for editing.

Edit Item is located in table editor menus and in catalogs of files.

Equal Powers

This key adjusts all channel powers to equal power levels. The sum of 
all channel powers is 0 dB. 

NOTE This softkey is valid only for a single-ESG configuration.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
Adjust Code Domain Power > Equal Powers

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 or 2 > Adjust Code Domain Power > Equal Powers
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Err Insert

This field allows you to select an error insertion mode to be applied to 
the data for the transport channel. This field is on the second page of 
the table editor. The selections are BLER (block error rate), BER (bit 
error rate), and NONE.

Default: NONE

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Err Insert

Error Bits

This field displays the number of actual bit errors being generated. It is 
calculated from the desired BER value as set in the BER field after the 
Apply Channel Setup key is pressed and the error bits are inserted into 
the data for the transport channel. To insert the error bits, the Err 
Insert field must be set to BER. This data field is on the second page of 
the table editor.

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Error Bit

Error Blocks

This field displays the number of the actual error blocks being 
generated. It is calculated from the desired BLER value as set in the 
BLER field after the Apply Channel Setup key is pressed and the error 
blocks are inserted into the data of the transport channel. To insert the 
error blocks, the Err Insert field must be set to BLER. This data field is 
on the second page of the table editor.

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Error Block

Ext Clock Polarity Neg Pos

This key selects the external clock polarity to either the positive (Pos) 
edge or negative (Neg) edge. This is valid only when BBG Data Clock is 
set to Ext.

Default: Positive

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
BBG Data Clock Setup > Ext Clock Polarity Neg Pos
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Ext Clock Rate X1 X2 X4

This key selects the external clock rate. The key is valid for uplink and 
only when BBG Data Clock is set to Ext.

X1  3.84 MHz external clock

X2  7.68 MHz external clock

X4  15.36 MHz external clock

Default: X1

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
BBG Data Clock Setup > Ext Clock Rate X1 X2 X4
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FBI Pattern

This field displays the 30-bit data pattern of the feedback information 
(FBI) bits set in the PhyCH Setup menu for uplink physical channel #1. 
Press the Edit Item key to specify the desired pattern and terminate 
with the Return key.

Range: 0 to 3FFFFFFF

Default: 00000000

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > FBI Pattern

FBI State

This field indicates whether or not the feedback information (FBI) bits 
are included in the uplink dedicated physical control channel
(DPCCH) #1. The FBI state is dependent on the slot format number. 

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > FBI State

Filter

This field displays the selected filter type. Press the Edit Item softkey to 
display a menu from which you can select a filter type or user FIR, 
change a filter alpha, optimize FIR for EVM or ACP, or restore the 
default filter.

Data Field Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter
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Filter Alpha

This key allows you to enter a filter alpha value for a Nyquist filter or 
root Nyquist filter. The entered value appears in the active entry area 
of the display. This key appears in several locations.

NOTE The Filter Alpha softkey appears only after you choose a root Nyquist or 
Nyquist filter. If a Gaussian filter is used, you will see Filter BbT. If any 
other filter is selected, you will see a Filter Factor N/A softkey 
(grayed-out).

The filter alpha value is set to 0.220 at the factory. This value can be 
user-defined. The value is not affected by an instrument preset or by a 
power cycle.

Range: 0.000 to 1.000

Select Menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > Nyquist or Root Nyquist > Filter Alpha

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > Root Nyquist or Nyquist >
Filter Alpha

Load Default FIR Menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > 
Nyquist or Root Nyquist > Filter Alpha

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist or Nyquist > Filter Alpha
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Filter BbT

This key allows you to change the bandwidth-multiplied-by-bit-time 
product value. The entered BbT filter value for the Gaussian filter 
appears in the active entry area of the display. The Filter BbT key 
appears in several locations.

The BbT value is set to 0.300 at the factory. This value can be 
user-defined. The value is not affected by an instrument preset or 
power cycle.

Range: 0.000 to 1.000

NOTE The Filter BbT softkey appears only after you choose a Gaussian filter. If 
a root Nyquist or Nyquist filter is in use, you will see Filter Alpha. If any 
other filter is selected, you will see a Filter Factor N/A softkey 
(grayed-out).

Select Menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > Gaussian > Filter BbT

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > Gaussian > Filter BbT

Load Default FIR Menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Gaussian >
Filter BbT

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR > 
Gaussian > Filter BbT
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Filter Symbols

This key enables you to select the number of filter symbols for the filter 
displayed in the FIR Values table editor. The entered value appears in 
the active entry area of the display. Although the FIR table editor 
allows a maximum of 32 symbols, with a maximum oversample ratio of 
32, the selected FIR filter cannot have more than 256 coefficients. 
Select the number of symbols and the oversample ratio accordingly. A 
FIR filter with more than 16 symbols will cause the symbol rate to be 
halved.

The filter symbol number is set to 8 at the factory. This value can be 
user-defined. The filter symbol number is not affected by an instrument 
preset or by a power cycle.

Range: 1 to 32 symbols

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Up >
BS Setup > Filter > Edit Item > Define User FIR > Load Default FIR > 
Root Nyquist, Nyquist, Gaussian, or Rectangle > Filter Symbols

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist, Nyquist, Gaussian, or Rectangle > Filter Symbols

FIX

This key allows you to enter in a fixed data pattern for uplink physical 
channel #1. The key appears in several locations. For the TFCI Pattern, 
a fixed hexadecimal data pattern can be selected and encoded into the 
transport format combination indicator (TFCI). For the FBI Pattern, a 
fixed hexadecimal data pattern can be selected for the feedback 
information (FBI) bits.

Range (TFCI Patt): 0000 to 03FF

Default (TFCI Patt): 0000

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > 
TFCI Pattern > Edit Item > FIX

Range (FBI Patt): 00000000 to 3FFFFFFF

Default (FBI Patt): 00000000

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > FBI Pattern > 
Edit Item > FIX
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FIX4

This key allows you to enter in a downlink or uplink fixed 4-bit data 
pattern. The entered value appears in the active display area. The FIX4 
pattern will be repeated as necessary to fill the data slot for the 
downlink physical channel (DPCH) or uplink physical channel #1 or #2. 
The front panel arrow keys, keypad, or front panel knob can be used to 
set the 4-bit data pattern. This key appears in several locations. 

Range: 0000 to 1111

Default: 0000

PhyCH Setup 

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH or PICH > PhyCH Setup > Data > Edit Item > FIX4

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 2 > PhyCH Setup > Data > Edit Item > FIX4

TrCH Setup 

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > DPCH > PhyCH Setup > Data > Edit Item > Transport CH > 
Return > Config Transport > Transport Channel # 1 to 6 > TrCH Setup > 
Data> Edit Item > FIX4

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > PhyCH Setup > Data > Edit Item > Transport CH > 
Return > Config Transport > Transport Channel # 1 to 6 > TrCH Setup > 
Data > Edit Item > FIX4

Frame Clock Interval

This key displays a menu from which you can select a frame clock 
interval for the uplink synchronization signal. Choices are 10, 20, 40, 
and 80 msec.

Default: 80 msec

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Uplink Sync Setup > Signal Setup > Frame Clock Interval
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Frame Clock Polarity Neg Pos

This key sets the polarity of the frame clock signal to either positive 
(Pos) or negative (Neg).

Default: Positive

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Uplink Sync Setup > Signal Setup > Frame Clock Polarity Neg Pos
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Gaussian

This key selects a Gaussian filter for use in the filter setup. Use the 
Filter BbT softkey to change the filter bandwidth-multiplied-by-bit-time 
product value. The Gaussian softkey appears in several locations.

Pressing the Gaussian softkey followed by Generate loads the 
FIR Values table editor with the coefficient values for the Gaussian 
filter. The filter BbT and number of filter symbols are defined with the 
softkeys in this menu. If you change either parameter after loading the 
filter coefficients, press the Generate softkey again.

The Display Impulse Response and Display FFT softkeys in this menu 
graphically display the filter response as it is defined in the FIR Values 
table editor.

Select Menu

Softkey Location (Downlink): Mode > CDMA >W-CDMA > BS Setup > 
Filter > Edit Item > Select > Gaussian

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > Gaussian

Load Default FIR Menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Gaussian

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR > 
Gaussian
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Generate

This key creates coefficients for a filter using the filter alpha value or 
filter BbT value and the filter symbols.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > 
Root Nyquist, Nyquist, Gaussian, or Rectangle > Generate

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist, Nyquist, Gaussian, or Rectangle > Generate

Goto Bottom Row 

This key moves the highlighted selection to the bottom row of the file 
displayed by the Bit File Editor or current list of items.

Goto Bottom Row is located in table editor menus and in catalogs of files.

Goto Middle Row

This key moves the highlighted selection to the middle row of the file 
displayed by the Bit File Editor or current list of items.

Goto Middle Row is located in table editor menus and in catalogs of files.

Goto Row

This key displays a menu from which you can select a row or page in a 
table editor or current list of items to edit.

Goto Row is located in table editor menus and in catalogs of files.

Goto Top Row

This key moves the highlighted selection to the top row of the file 
displayed by the Bit File Editor or current list of items.

Goto Top Row is located in table editor menus and in catalogs of files.
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H

Hamming

This key applies the Hamming windowing function to the selected 
filter. Windowing improves out-of-band performance (ACP) by 
smoothing the filter’s transition to zero, but simultaneously degrades 
passband performance (EVM).

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > 
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window > Hamming

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window > Hamming

Hann

This key applies the Hann windowing function to the selected filter. 
Windowing improves out-of-band performance (ACP) by smoothing the 
filter’s transition to zero, but simultaneously degrades passband 
performance (EVM).

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > 
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window > Hann

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window > Hann
3-36 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators Softkey Reference
Option 200 I
I

Insert

This key displays a menu from which you can select different ways of 
inserting bits into a user file. This key appears in several locations.

Insert is located in table editor menus and in catalogs of files.

Insert 0’s

This key inserts the desired number of 0’s at the current position in the 
user file. This key appears in several locations.

Insert 0’s  is located in table editor menus.

Insert 1’s

This key inserts the desired number of 1’s at the current position in the 
user file. This key appears in several locations.

Insert 1’s  is located in table editor menus.

Insert PN9

This key accesses a menu from which a PN9 seed value can be entered. 
The generated 9-bit pseudo-random bit sequence can then be inserted 
into the user file. This key appears in several locations.

Range: 001 to 1FF

Default: 1FF

Insert PN9  is located in table editor menus under the Edit File  or 
Create File  softkeys. An example of this key’s location is given as follows:

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > User File > 
Edit File or Create File > Insert > Insert PN9 > Insert PN9

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > FBI Pattern > 
Edit Item > User File > Edit File or Create File > Insert > Insert PN9 > 
Insert PN9
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Insert PN15

This key accesses a menu from which a PN15 seed value can be entered. 
The generated 15-bit pseudo-random bit sequence can then be inserted 
into the user file. This key appears in several locations.

Range: 0000 to 7FFE

Default: 0000

Insert PN15 is located in table editor menus under the Edit File or
Create File softkeys. An example of this key’s location is given as follows:

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > User File > 
Edit File or Create File > Insert > Insert PN15 > Insert PN15

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > FBI Pattern > 
Edit Item > User File >Edit File or Create File > Insert > Insert PN15 >
Insert PN15

Insert Row

This key inserts a row into the file displayed in the table editor.

Insert Row is located in table editor menus.

Interleaver

The field displays the interleaving operating state. This field is not 
user-defined. The value cannot be changed and the field is grayed-out.

Default: On 

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > 1, 2, 3, or 4 > PhyCH Type > DPCH > PhyCH Setup > Data > 
Edit Item > Transport CH > Return > Config Transport > Interleaver

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 2 > Config Transport > Interleaver
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I/Q Voltage Scale

This field displays the power output value at the IQ ports. Press the 
Edit Item key to select the power level at the IQ ports. Since changing 
this value affects the total power, you will also see individual channel 
power adjustments. This value is assigned by performing the relative 
power mapping procedure. See “Adjust the Relative Power Mapping” 
on page 2-14. This field is not valid for uplink configuration.

NOTE IQ Voltage Scale is used in the two-ESG configuration to adjust the 
relative power values of the channels between the two signal 
generators. See “Voltage Other ESG” on page 3-74.

Range: –40.00 dB to 0.00 dB

Default: 0.00 dB

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
2 Box Setup > IQ Voltage Scale

IS-95

This key selects a standard IS-95 filter.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Up >
BS Setup > Filter > Edit Item > Select > IS-95 and IS-2000 > IS-95

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > IS-95 and IS-2000 > IS-95

IS-95 and IS-2000

This key accesses a menu of filter types for IS-95 and IS-2000 filters. 
The choices are IS-95, IS-95 w/EQ, IS-95 Mod, and IS-95 Mod w/EQ.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > IS-95 and IS-2000

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > IS-95 and IS-2000
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IS-95 Mod

This key selects a modified version of the standard IS-95 filter. This 
filter has improved adjacent channel power performance. The 
modification meets the IS-95 error function criterion.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > IS-95 and IS-2000 > IS-95 Mod

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > IS-95 and IS-2000 > IS-95 Mod

IS-95 Mod w/EQ

This key selects a modified version of the standard IS-95 filter. This 
filter has improved adjacent channel power performance, and includes 
equalization for phase compensation required by a base station. The 
filter modification meets the IS-95 error function criterion.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > IS-95 and IS-2000 > IS-95 w/EQ Mod

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > IS-95 and IS-2000 >
IS-95 w/EQ Mod

IS-95 w/EQ

This key selects a standard IS-95 filter with equalization for phase 
compensation required by a base station.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > IS-95 and IS-2000 > IS-95 w/EQ

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > IS-95 and IS-2000 > IS-95 w/EQ
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Option 200 K
K

Kaiser

This key applies the Kaiser windowing function to the selected filter. 
Windowing improves out of band performance (ACP) by smoothing the 
filter’s transition to zero, but simultaneously degrades passband 
performance (EVM). 

Selecting the Kaiser softkey activates the Beta factor that can be 
adjusted for trade-off between optimized ACP and EVM. Decreasing the 
Beta factor value improves EVM; increasing the value improves ACP.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window > Kaiser

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window > Kaiser
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L

Link Control

This key displays a menu from which you can select a physical channel, 
modify parameters and/or configure selected transport channels.

Softkey Location: Mode > CDMA > W-CDMA > Link Control

Link Down Up

This key toggles the link down/up selection. Down sets the downlink 
base station (BS) setup parameters while Up sets the uplink user 
equipment (UE) setup parameters.

Default: Down

Softkey Location: Mode > CDMA > W-CDMA > Link Down Up

Load Default FIR

This key presents a selection of default filter types with standard filter 
parameters. The choices are Root Nyquist, Nyquist, Gaussian, and 
Rectangle. A selection will automatically fill the FIR Values table editor 
with the pre-defined filter coefficients. Depending on the filter selected, 
a menu will be presented listing filter alpha, filter BbT, filter symbols 
and windowing. These can be edited where appropriate. If any default 
parameters, for example, filter alpha, filter BbT, or filter symbols are 
changed then press the Generate softkey to create the filter.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR
3-42 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators Softkey Reference
Option 200 L
Load From Selected File

This key replaces the current filter information displayed in the 
Catalog of FIR Files with the information stored in the highlighted 
file.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load/Store >
Load From Selected File

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load/Store >
Load From Selected File

Load/Store

This key accesses a file management menu from which you can load the 
table editor with filter values from files stored in the signal generator’s 
memory. The file management menu also allows you to store data to a 
file, or delete a file.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load/Store

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load/Store
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M

Max Puncture

This field is not used in the current version of the firmware.

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 2 > Config Transport > Max Puncture

Mirror Table

Pressing this key generates a mirrored copy of FIR table entries. The 
mirror function takes the values in the FIR table and duplicates them. 
The duplicate values occupy the bottom half of the table and are in 
reverse order.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Mirror Table

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Mirror Table
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N

NONE

This key sets the insertion mode to NONE for each transport channel. 
No error bit is inserted in the data. 

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Err Insert > Edit Item > NONE

None

This key selects no coding in the TrCH Setup menu or no windowing 
function in the Window menu.

TrCH Menu

No encoder is used for coding transport channels.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
Config Transport > Transport Channel # 1 to 6 > TrCH Setup > Coding > 
Edit Item > None

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > 1 to 6 > TrCH Setup > Coding >
Edit Item > None

Window Menu

No windowing function is used for the selected filter. The filter is 
optimized for maximum passband performance (EVM).

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window > None

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window > None
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Number of Bits

This key allows deletion of bits from the user file displayed in the 
Bit File Editor. The number of bits to delete is displayed in the 
active entry field of the display. 

Number of Bits is located in table editor menus under the Edit File or 
Create File softkeys. An example of this key’s location is given as follows:

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type> DPCCH > PhyCH Setup > FBI Pattern, 
TFCI Pattern, or TPC Pattern > Edit Item > User File > Edit File or 
Create File > Delete > Number of Bits

Num of Blk

This field displays the number of coded blocks set for each transport 
channel selected for uplink physical channel #2. The total input data in 
one transport channel is the number of blocks multiplied by the block 
size.

Range: 0 to 4095

Default: 1 for all transport channels

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Num of Blk
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Nyquist

This key selects a Nyquist (raised cosine) filter in either the Select 
menu or the Load Default FIR menu.

Select Menu

This key selects a Nyquist filter and returns to the Select (Filter) menu.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > Nyquist

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > Nyquist

Load Default FIR Menu

This key followed by Generate loads the FIR table editor with the 
coefficient values for a Nyquist filter. The filter alpha and number of 
filter symbols are defined with the softkeys in this menu. If you change 
either parameter after loading the filter coefficients, press the Generate 
softkey again. The Display Impulse Response and Display FFT softkeys in 
this menu graphically display the filter responses as it is currently 
defined in the FIR table editor.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Nyquist

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR > 
Nyquist
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O

Offset

This field displays the timing offset for the DPCH channel. Press the 
Edit Item key to select a timing offset for the DPCH channel. The offset 
is in chips.

Range: 0 to 149

Default: 0

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > PhyCH Type > DPCH > PhyCH Setup > Offset

Optimize FIR For EVM ACP

This key selects either error vector magnitude (EVM), for best passband 
filter response, or adjacent channel power (ACP), for best stopband 
filter rejection.

Default: EVM

NOTE This key is grayed-out if a filter other than a root Nyquist or Nyquist 
filter is selected.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > Root Nyquist or Nyquist >
Optimize FIR For EVM ACP

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > Root Nyquist or Nyquist > 
Optimize FIR For EVM ACP
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Oversample Ratio

This key sets the oversampling ratio to be applied to the FIR filter 
design in the Define User FIR menu. Although the FIR Values table 
editor allows a maximum of 32 symbols, with a maximum oversample 
ratio of 32, the selected FIR filter cannot have more than 256 
coefficients. Select the number of symbols and the oversample ratio 
accordingly.

The oversample ratio value is set at the factory. This value can be 
user-defined. The value is not affected by an instrument preset or by a 
power cycle.

Range: 1 to 32

Default: 1

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Oversample Ratio

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Oversample Ratio
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P

Page Down

This key displays the next page of entries in the table editor menu and 
in catalogs of files.

Page Down is located in table editor menus and in catalogs of files.

Page Up

This key displays the previous page of entries in the table editor menu 
and in catalogs of files.

Page Up is located in table editor menus and in catalog of files.

P-CCPCH

This key selects the primary common control physical channel 
(P-CCPCH) as the physical channel type. The P-CCPCH is a fixed rate 
(30 kbps, Spread Factor=256) common downlink physical channel.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control >
3 > PhyCH Type > P-CCPCH

Paging Indicator

This filed displays the number of paging indicators per frame. This field 
is not user-defined. The value cannot be changed and the field is 
grayed-out.

Default: 144

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > 3 > PhyCH Type > PICH > Paging Indicator

Phase Polarity Normal Invert

This key selects either normal or inverted phase polarity. The inverted 
mode shifts the internal Q signal 90 degrees so that it lags the in-phase 
I signal. This is useful for lower sideband mixing applications and is 
required by some radio standards.

Default: Normal

Softkey Location: Mode > CDMA > W-CDMA > Phase Polarity Normal Invert
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Physical Channel #

This key is always active unless the Frequency or Amplitude key is 
activated. For downlink, press the up/down arrow keys or rotate the 
front panel knob to select physical channel #1, #2, #3, or #4. For uplink, 
press the up/down arrow keys or rotate the front panel knob to select 
physical channel #1 or #2.

Default: Physical channel #1

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
Physical Channel #

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > Physical Channel #

PhyCH Setup

This key displays a menu in which you can edit parameter fields and 
apply those parameters to the physical channel selected. The fields 
shown depend on the PhyCH Type selected.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Setup

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > PhyCH Setup

PhyCH Type

This key accesses a menu from which you can select a physical channel 
type. The default and available channels are different for downlink and 
uplink configurations.

Default (Downlink):
  PSCH for Physical Channel # 1

SSCH for Physical Channel # 2

P-CCPCH for Physical Channel # 3

CPICH for Physical Channel # 4

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type

Default (Uplink):
  DPCCH for Physical Channel # 1

DPDCH for Physical Channel # 2

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 or 2 > PhyCH Type
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PI Bits

This field displays the number of bits in the paging indicator. The field 
is grayed-out and you cannot change the value.

Default: 288

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > 3 > PhyCH Type > PICH > PI Bits

PICH

This key selects the paging indicator channel. The paging indicator 
channel (PICH) is a fixed rate (Spread Factor=256) physical channel 
used to carry the paging indicators. Selecting the PICH for channel #3 
will disable channel #4.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control >
3 > PhyCH Type > PICH

PN9

This key selects an internally generated 9-bit pseudo-random sequence 
pattern as output data. The PN9 code can be applied to physical and /or 
transport channels. This key appears in several locations.

PhyCH Setup menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
Physical Channel > PhyCH Type > DPCH, PICH or OCNS > PhyCH Setup > 
Data > Edit Item > PN Sequence > PN9

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > PhyCH Setup > Data > Edit Item > PN Sequence > PN9

TrCH Setup Menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > 
Transport CH > Return > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Data > Edit Item > PN9

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Data > Edit Item > PN9

FBI, TFCI, or TPC Pattern Selection

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > FBI, TFCI, or TPC Pattern > Edit Item > 
PN Sequence > PN9
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Option 200 P
PN15

This key selects an internally generated 15-bit pseudo-random 
sequence pattern as output data. For uplink, physical channel #1 can 
use PN15 in the following formats: FBI Pattern, TFCI Patt or
TPC Pattern. For downlink, PN15 is available for the following 
physical channels types: DPCH, OCNS and PICH. The downlink and 
uplink transport channels do not support PN15.

Softkey location (Downlink): Mode > CDMA > W-CDMA > Link Control >
1, 2, 3, or 4 > PhyCH Type > DPCH, PICH, or OCNS > PhyCH Setup > 
Data > Edit Item > PN Sequence > PN15

Softkey location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > FBI, TFCI, or TPC Pattern > 
Edit Item > PN Sequence > PN15

Or: Mode > CDMA > W-CDMA > Link Up > Link Control > 
2 > PhyCH Setup > Data > Edit Item > PN Sequence > PN15

Power

This field displays the power level for the selected physical channel. 
Press the PhyCH Setup softkey to edit the power field.

Range (Downlink): –40.00 dB to 0.00 dB

Default (Downlink): –8.30 dB for physical channel #1, –8.30 for physical 
channel #2, –5.30 for physical channel #3, –3.30 for physical channel #4

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > Power

Range (Uplink): –40.00 dB to 0.00 dB

Default (Uplink): −2.69 dB for physical channel #1, 0.00 dB for physical 
channel #2

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 or 2 > Power

PSCH

This key selects the primary synchronization channel.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > PSCH
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Puncture

This field is not user-defined. The value cannot be changed and the field 
is grayed-out. The field displays the puncture rate percentage for the 
dedicated physical channel (DPCH). Data can be removed from or 
added to the fully coded channel. The number of bits removed or 
inserted is displayed as a percentage of the total number of bits. This is 
a calculated value. The negative value indicates that bits are to be 
added to the frame.

Range: –25400 to 100%

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > 1, 2, 3, or 4 > PhyCH Type > DPCH > PhyCH Setup > Data > 
Edit Item > Transport CH > Return > Config Transport > TrCH Setup > 
Puncture

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 2 > Config Transport > Puncture
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Option 200 R
R
Rate Match Attr

This field displays the rate matching attribute value for the selected 
transport channel. Press Edit Item to enter a value and terminate with 
the Enter softkey to set the value. A higher RMatch attribute number 
indicates more data for the channel and allows for a higher puncture 
percentage.

Range: 1 to 256

Default: 1 for all Transport Channels

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCh Type > DPCH > PhyCH Setup > Data > Edit Item > Transport CH > 
Return > Config Transport > Transport Channel # 1 to 6 > TrCH Setup > 
Rate Match Attr

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport >Transport Channel # 1 to 6 > 
TrCH Setup > Rate Match Attr

Rectangle

This key selects a one-symbol-wide rectangle filter in either the Select 
(Filter) menu or the Load Default FIR menu.

Select Menu

This key selects a rectangle FIR filter for use in the filter setup.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > Rectangle

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > Rectangle

Load Default FIR Menu

This key followed by Generate loads the FIR table editor with coefficient 
values for a rectangle filter. The Display Impulse Response and
Display FFT softkeys in this menu graphically display the filter response 
as defined in the FIR table editor.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Rectangle

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR > 
Rectangle
Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide 3-55



Softkey Reference ESG Family Signal Generators
R Option 200
Ref Measure Setup

This key accesses a menu from which you can select a reference 
measurement test setup for a physical channel. For downlink, this key 
is only available for the dedicated physical channels (DPCH). For 
uplink, this key is valid only for physical channel #2 (DPDCH).

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > Ref Measure Setup

Default (Uplink): RMC 12.2 kbps 

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Ref Measure Setup

Rename

This key accesses a menu from which you can rename the selected file.

Rename is located in table editor menus under the Edit File or 
Create File softkeys.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > FBI Pattern > 
Edit Item > User File > Edit File or Create File > Rename

Restore Default Filter

This key replaces the current FIR filter with the default filter.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Restore Default Filter

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Restore Default Filter

RMC 12.2 kbps (25.141 v3.4)

This key sets the uplink reference measurement channel (RMC) test 
setup rate to 12.2 kbps as described in the 3GPP Technical 
Specification (TS 25.141 V3.4).

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Ref Measure Setup > RMC 12.2 kbps (25.141 v3.4)
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RMC 64 kbps (25.141 v3.4)

This key sets the uplink reference measurement channel (RMC) test 
setup rate to 64 kbps as described in the 3GPP Technical Specification 
(TS 25.141 V3.4).

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Ref Measure Setup > RMC 64 kbps (25.141 v3.4)

RMC 144 kbps (25.141 v3.4)

This key sets the uplink reference measurement channel (RMC) test 
setup rate to 144 kbps as described in the 3GPP Technical Specification 
(TS 25.141 V3.4).

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Ref Measure Setup > RMC 144 kbps (25.141 v3.4)

RMC 384 kbps (25.141 v3.4)

This key sets the uplink reference measurement channel (RMC) test 
setup rate to 384 kbps as described in the 3GPP Technical Specification 
(TS 25.141 V3.4).

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Ref Measure Setup > RMC 384 kbps (25.141 v3.4)
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Root Nyquist

This key selects a root Nyquist (root-raised cosine) filter in either the 
Select (Filter) menu or the Load Default FIR menu.

Select (Filter) Menu

This key selects a root Nyquist FIR filter. After the selection is made, 
the Select (Filter) menu will be returned.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > Root Nyquist

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > Root Nyquist

Load Default FIR Menu

This key followed by the Generate softkey loads the FIR table editor 
with the coefficient values for a root Nyquist filter. The filter alpha and 
number of filter symbols are defined with the softkeys in this menu. If 
you change either parameter after loading the filter coefficients, press 
the Generate softkey again.

The Display Impulse Response and Display FFT softkeys in this menu 
graphically display the filter response as it is currently defined in the 
FIR table editor.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > Root Nyquist

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist
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Scale To 0dB

This key adjusts the displayed power so that the sum of the power of all 
channels is 0 dB. The ratios between individual channel power values 
are maintained.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
Adjust Code Domain Power > Scale To 0dB

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > Adjust Code Domain Power > Scale To 0dB

Scrambling Code

This field displays the scrambling code in use. Press Edit Item to change 
the scrambling code number.

Range (Downlink): 0 to 511

Default: 0

Data Field Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Scrambling Code

Range (Uplink): 0 to 16777215

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Scrambling Code

SecScr Code OS

This field displays the secondary scrambling code offset. Press Edit Item 
to change the scrambling code offset number. This field is displayed for 
the downlink DPCH and OCNS physical channel types.

Range: 0 to 15

Default: 0

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > 1, 2, 3, or 4 > DPCH or OCNS > PhyCH Setup > 
SecScr Code OS
Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide 3-59



Softkey Reference ESG Family Signal Generators
S Option 200
Select 

This key accesses a menu from which you can select a filter type. You 
can select from standard filter types, such as Root Nyquist, Nyquist, 
Gaussian, several IS-95 filters, User FIR, Rectangle, APCO 25 C4FM, 
and UN3/4 GSM Gaussian.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select

Select File

This key displays a menu from which you can select a file in the 
Catalog of Binary/Bit Files or Catalog of FIR Files. This key 
appears in several locations.

Select Menu

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > User FIR > Select File

Or: Mode > CDMA > W-CDMA > Link Up > UE Setup > Filter > Edit Item > 
Select > User FIR > Select File

User File Menu

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > FBI, TFCI, or TPC Pattern > Edit Item > 
User File > Select File

Or: Mode > CDMA > W-CDMA > Link Up > Link Control >
2 > PhyCH Setup > Data > Edit Item > User File > Select File

Select Pattern

This key accesses a menu from which you can select a transmit power 
control (TPC) pattern for uplink physical channel #1. The choices are: 
All Up, All Down, Up/Down and Down/Up.

Default: Up/Down

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > TPC Pattern > Edit Item > 
Select Pattern
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SFN RST Polarity Neg Pos

This key changes the polarity of the system frame number (SFN) reset 
(RST) signal for uplink synchronization from negative (Neg) to 
positive (Pos).

Default: Positive

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Uplink Sync Setup > Signal Setup > SFN RST Polarity Neg Pos

Signal Setup

This key displays a menu from which you can select the following 
softkeys: Sync Source, Frame Clock Interval, Frame Clock Polarity, and 
SRN RST Polarity.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Uplink Sync Setup > Signal Setup

Slot Delay (numeric value)

This key enables you to specify the number of slots to be delayed 
between the downlink frame clock and uplink frame timing signals. The 
actual delay time is the sum of 1024 chips, the slot delay, and the 
timing offset. See “System Triggering and Synchronization” 
on page 4-28 for more information.

Range: 0 to 119 slots

Default: 0 slots

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Uplink Sync Setup > Slot Delay (numeric value)
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Slot Format

This field displays the slot format used for the dedicated physical 
channel. Press the Edit Item key to change the slot format. Slot formats 
are coupled with the channel code and symbol rate. For downlink, the 
17 slot formats are described in the 3GPP Technical Specification (TS 
25.141 V3.3). For uplink, the 6 slot formats for DPCCH and the 7 slot 
formats for DPDCH are described in the 3GPP Technical Specification 
(TS 25.211 V3.4).

Range (Downlink): 0 to 16

Default (Downlink): 0

Data Field Location (Downlink): Mode > CDMA > W-CDMA >
Link Control > PhyCH Type > DPCH > PhyCH Setup >
Slot Format

Range (DPCCH of Uplink): 0 to 5

Default (DPCCH of Uplink): 0

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 1 > Slot Format

Slot 
Format

0-1 2-7 8-11 12 13 14 15 16

Symbol 
Rate

7.5 
ksps

15 
ksps

30 
ksps

60 
ksps

120 
ksps

240 
ksps

480 
ksps

960 
ksps

Max Ch 
Code

511 255 127 63 31 15 7 3

Slot 
Format

0 1 2 3 4 5

Symbol 
Rate

15 ksps 15 ksps 15 ksps 15 ksps 15 ksps 15 ksps

Max Ch 
Code

255 255 255 255 255 255

Pilot 
Bits/Slot

6 8 5 7 6 5

TFCI 
Bits/Slot

2 0 2 0 0 2

FBI 
Bits/Slot

0 0 1 1 2 2

TPC 
Bits/Slot

2 2 2 2 2 1
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Range (DPDCH of Uplink): 0 to 6

Default (DPDCH of Uplink): 2

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 2 > Slot Format

SSCH

Press this key to select the secondary synchronization channel.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control >
2 > PhyCH Type > SSCH

Store To File

This key accesses a menu from which you can select a name for a file to 
be stored in the catalog of FIR files.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load/Store > Store To File

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load/Store >
Store To File

Slot 
Format

0 1 2 3 4 5 6

Symbol 
Rate

15 
ksps

30 
ksps

60 
ksps

120 
ksps

240 
ksps

480 
ksps

960 
ksps

Max Ch 
Code

255 127 63 31 15 7 3
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Symbol Rate

This field displays the symbol rate as set in the PhyCH Setup menu. 
Highlight the Symbol Rate then press the Edit Item key to set the 
symbol rate. The symbol rate is shown in the active entry area of the 
display. For uplink, this field is active only for physical channel #2.

Range: 7.5 to 960 ksps

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > PhyCH Type > DPCH > PhyCH Setup > Symbol Rate

Slot Format, Symbol Rate and Maximum Channel Code for downlink 
are determined from the table below:

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > PhyCH Setup > Symbol Rate

Slot Format, Symbol Rate and Maximum Channel Code for uplink are 
determined from the table below:

Sync Source FClk SFN

This key sets the uplink synchronization source to either frame clock 
(FClk) or system frame number (SFN).

Default: FClk

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Uplink Sync Setup > Signal Setup > Sync Source FClk SFN

Slot 
Format

0-1 2-7 8-11 12 13 14 15 16

Symbol 
Rate

7.5 
ksps

15 
ksps

30 
ksps

60 
ksps

120 
ksps

240 
ksps

480 
ksps

960 
ksps

Max Ch 
Code

511 255 127 63 31 15 7 3

Slot 
Format

0 1 2 3 4 5 6

Symbol 
Rate

15 
ksps

30 
ksps

60 
ksps

120 
ksps

240 
ksps

480 
ksps

960 
ksps

Max Ch 
Code

255 127 63 31 15 7 3
3-64 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators Softkey Reference
Option 200 S
Sync Trigger Mode Single Cont

This key selects either a single or a continuous synchronization trigger 
mode.

Default: Single

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Uplink Sync Setup > Sync Trigger Mode Single Cont
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T

TFCI Pattern

This field displays the transport format combination indicator (TFCI) 
pattern set in the PhyCH Setup menu for a physical channel. Press the 
Edit Item key to enter in a desired bit pattern. See “Slot Format” 
on page 3-62 for more information.

The TFCI is an optional field describing what services are in use for 
example, data and video. Fixed rate service does not include TFCI.

Range (Downlink): 0x0 to 0x3FF

Default (Downlink): 0x0

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > PhyCH Type > DPCH > TFCI Pattern

Range (Uplink): 0000 to 1111

Default (Uplink): 0000

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > TFCI Pattern

TFCI State

This field displays whether or not the transport format combination 
indicator (TFCI) bits are included in the dedicated physical control 
channel (DPCCH). The TFCI is coupled to the Slot Format field.

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > TFCI State

Time Offset

This field displays the timing offset for the DPCH channel. The timing 
offset is in chips and is used to sync the base station (BS) and the user 
equipment (UE). Press the PhyCH Setup softkey, highlight the field and 
press the Edit Item key to enter the offset. Each number in the range 
represents 256 bits and 1/10 of a time slot.

Range: 0 to 149

Default: 0

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > PhyCH Type > DPCH > PhyCH Setup > Time Offset
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Timing Offset (numeric value) chip

This key enables you to specify the number of chips to be delayed in 
addition to the slot delay between the downlink frame clock and uplink 
frame timing signals. The actual delay time is the sum of 1024 chips, 
the slot delay, and the timing offset.

Range: −512 to 2560 chips 

Default: 0

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Uplink Sync Setup > Timing Offset (numeric value) chip

Total Bits

This field displays the actual number of total bits after the error bits 
are inserted into the current data of each transport channel. This data 
field is on the second page of the table editor.

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Total Bit

Total Blocks

This field displays the actual number of total blocks after the error 
blocks are inserted into the current data of each transport channel. 
This data field is on the second page of the table editor.

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > Total Block

TPC Pat Steps

This field displays the number of successive down and up commands for 
the transport power control (TPC) pattern, when the TPC Pattern field 
is set to Up/Down or Down/Up. The power of the user equipment (UE) or 
the base station (BS) will decrease or increase by 1 dB on a slot-by-slot 
basis for every down or up command. For uplink, the TPC pattern has a 
number of different formats. For downlink, the pattern is limited to 
four formats. Press the Edit Item key to select the TPC pattern steps.

Range: 1 to 80

Default: 1

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > PhyCH Type > DPCH > PhyCH Setup > TPC Pat Steps

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > TPC Pat Steps
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TPC Pat Trig Off On

This key sets the pattern trigger state of the transmit power control 
(TPC) for the uplink dedicated physical control channel (DPCCH).

Default: Off

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > TPC Pat Trig Off On

TPC Pat Trig Polarity Neg Pos

This key sets the pattern trigger polarity of the transmit power control 
(TPC) for the uplink dedicated physical control channel (DPCCH). The 
choices are: Positive (Pos) edge or Negative (Neg) edge.

Default: Positive

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Setup > TPC Pat Trig Polarity Neg Pos

TPC Pattern

This field displays the power control command format in use. The 
TPC Pattern is used to change the user equipment (UE) or the base 
station (BS) power level. Press the Edit Item key to select the power 
format for the transmit power control (TPC). For uplink, the TPC 
pattern has a number of different formats (see “Select Pattern” 
on page 3-60 for more information). For downlink, the pattern is limited 
to four formats.

Default: Up/Down

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > PhyCH Type > DPCH > PhyCH Setup > TPC Pattern

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > TPC Pattern

Transport CH

This key selects the transport channel to be configured as data for the 
selected dedicated physical channel. In uplink mode this key is active 
only with physical channel #2.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > Transport CH

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > PhyCH Setup > Data > Edit Item > Transport CH
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Transport Channel #

This key selects a transport channel. The Transport Channel # 1 softkey 
is always active unless the Frequency or Amplitude key is activated. 
Press the up/down arrow keys or rotate the front panel knob to select 
transport channels #2, #3, #4, #5, and #6.

Default: Transport channel #1

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
1, 2, 3, or 4 > Config Transport > Transport Channel # 1 to 6

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6

TrCH Setup

This key accesses a menu in which you can edit transport channel 
(TrCH) data. This key is active with physical channel type DPCH for 
downlink and physical channel type DPDCH for uplink configurations.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > PhyCH Setup > Data > Transport CH > Return > 
Config Transport > Transport Channel # 1 to 6 > TrCH Setup

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup

TrCH State Off On

This key turns the selected transport channel off or on. Transport 
channel #1 is always in the active state; the user has no control over 
this state and the key is grayed-out. Select transport channel #2, #3, 
#4, #5, or #6 to active this key. These transport channels can be turned 
on or off with this softkey.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > Transport CH > 
Return > Config Transport > Transport Channel # 1 to 6 > TrCH State Off On

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > Transport Channel # 1 to 6 > 
TrCH State Off On
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Tr Position

This field displays the transport channel (Tr) position on the physical 
channel. This field is an indicator only and not a user-defined function.

Default: Flexible

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > 1, 2, 3, or 4 > PhyCH Type > DPCH > PhyCH Setup > Data > 
Transport CH > Return > Config Transport > Transport Channel # 1 to 6 > 
TrCh Setup > Tr Position

TTI

This field displays the transmission time interval set for the transport 
channel. The time interval is the time allowed for the transport channel 
to transmit. Press Edit Item to set a value for the time interval. The 
choices are 10, 20, 40, or 80 msecs.

Default: 20.0 msec

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
Link Control > PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item >
Transport CH > Return > Config Transport > Transport Channel # 1 to 6 > 
TrCH Setup > TTI

Data Field Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport > TrCH Setup > TTI

Turbo

This key selects a turbo code to be used for transport channel coding. 
Turbo coding has better error rate performance than convolutional 
encoding.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > Transport CH > 
Return > Config Transport > Transport Channel # 1 to 6 > TrCH Setup > 
Coding > Edit Item > Turbo

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Config Transport >Transport Channel # 1 to 6 > 
TrCH Setup > Coding > Edit Item > Turbo
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U

UDI 64 (25.944 v3.0)

This key selects the unrestricted digital information (UDI) 64 kbps 
reference measurement test setup for the downlink DPCH channel or 
the uplink DPDCH channel.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > Ref Measure Setup > UDI 64 (25.944 v3.0)

UDI 64 kbps

This key selects the unrestricted digital information (UDI) 64 kbps 
reference measurement test setup for the downlink DPCH channel or 
the uplink DPDCH channel.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 2 > Ref Measure Setup > UDI 64 kbps

UDI ISDN (25.944 v3.3)

This key sets the downlink DPCH channel to UDI (unrestricted digital 
information) ISDN for the reference measurement test setup. Transport 
channel 1 is configured to carry four blocks of 640 and transport 
channel 2 is configured to carry one block of 148.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > Ref Measure Setup > UDI ISDN (25.944 v3.3)

UE Setup

This key accesses the uplink table editor from which you can select and 
modify user equipment (UE) parameters. Highlight the data field you 
want to change and press the Edit Item key. Press a softkey, use the 
numeric keypad, or front panel knob to change values displayed in the 
table. Press the appropriate softkey to terminate the entry.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup
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UN3/4 GSM Gaussian

This key selects an Option UN3/4 delay-compatible, GSM, Gaussian 
filter with a fixed (non-adjustable) BbT of 0.300.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > UN3/4 GSM Gaussian

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up > 
UE Setup > Filter > Edit Item > Select > UN3/4 GSM Gaussian

Up/Down

This key sets the transport power control (TPC) pattern to repeatedly 
send consecutive up and consecutive down commands. The number of 
successive down and up commands is defined in the TPC Pat Steps 
field of the PhyCH Setup menu.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH > DPCH > PhyCH Setup > TPC Pattern > Edit Item > Up/Down

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > TPC Pattern > 
Edit Item > Select Pattern > Up/Down

Uplink Sync Setup

This key displays a menu from which you can configure the uplink 
synchronization signal.

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Uplink Sync Setup

User File

This key displays a file management menu from which you can create, 
edit, or select a user-defined file to be used as a data pattern.

The maximum size of each user-defined file is as follows:

PhyCh Data  Up to 32768 bits

TrCH Data  Up to 1024 bits for both downlink and uplink,

Up to 32768 bits and a multiple of Blk Size for 
downlink, or

Up to 32768 bits and a common multiple of Blk Size 
and Number of Blk for uplink

FBI Pattern  Up to 2048 bits

TFCI Pattern  Up to 2048 bits
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TPC Pattern  Up to 2048 bits

Softkey Location (Downlink): Mode > CDMA > W-CDMA > Link Control > 
PhyCH Type > DPCH > PhyCH Setup > Data > Edit Item > User File

Or: Mode > CDMA > W-CDMA > Link Control > PhyCH Type > PCCPCH > 
PhyCH Setup > Data > Edit Item > User File

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
Link Control > 1 > PhyCH Type > DPCCH > PhyCH Setup > Data > 
Edit Item > User File

Or: Mode > CDMA > W-CDMA > Link Up > Link Control > 2 > 
PhyCH Setup > FBI Pattern, TFCI Pattern, or TPC Pattern >
Edit Item > User File

User FIR

This key displays a menu and the Catalog of FIR Files from which 
you can make a selection.

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Select > User FIR

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Select > User FIR
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V

Voltage Other ESG

Press the Edit Item key to select the total voltage value of the paired 
ESG after setting the channel powers of both the current ESG and the 
paired ESG. After setting this value, the IQ voltage scale will be 
automatically generated. See “Adjust the Relative Power Mapping” 
on page 2-14. This field is not valid for downlink configurations.

NOTE For the single-ESG setup, this field should be set to 0.0 V.

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
2 Box Setup > Voltage Other ESG

Voltage This ESG

Press the Edit Item key to select the voltage level for the ESG. This key 
displays the total voltage for the ESG. Enter a value in the Voltage 
Other ESG data field of the ESG that is paired with this ESG. See 
“Adjust the Relative Power Mapping” on page 2-14. This field is not 
valid for downlink configurations.

Data Field Location (Downlink): Mode > CDMA > W-CDMA > 
2 Box Setup > Voltage This ESG
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W

W-CDMA Off On

This key turns W-CDMA modulation off or on. At least one physical 
channel must be turned on before W–CDMA can be activated. To turn 
on a physical channel use the Channel State Off On softkey.

Default: Off

Softkey Location: Mode > CDMA > W-CDMA > W-CDMA Off On

Window

This key displays a menu from which you can apply a windowing 
function to the selected filter. The default is to use no windowing which 
optimizes the passband response (EVM). Several windowing selections 
are provided in this menu. The windowing will smooth the filter’s 
transition to zero. Windowing improves adjacent channel power 
performance (ACP) but degrades passband response (EVM). The 
choices available are: None, Hamming, Hann, and Kaiser.

Default: None

Softkey Location (Downlink): Mode > CDMA > W-CDMA > BS Setup > 
Filter > Edit Item > Define User FIR > Load Default FIR > 
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window

Softkey Location (Uplink): Mode > CDMA > W-CDMA > Link Up >
UE Setup > Filter > Edit Item > Define User FIR > Load Default FIR >
Root Nyquist, Nyquist, Gaussian, or Rectangle > Window
Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide 3-75



Softkey Reference ESG Family Signal Generators
W Option 200
3-76 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators
Option 200
4 Operation

This chapter contains detailed information that will help you understand the operation of 
your Option 200 signal generator. 

The chapter is divided into the following sections:

• “W-CDMA Frame Structures” on page 4-2

• “Understanding W-CDMA Data Generation” on page 4-7

• “Understanding the Reference Measurement Channel” on page 4-18

• “Understanding the Single-ESG Downlink Configuration” on page 4-20

• “Understanding the Two-ESG Downlink Configuration” on page 4-21

• “Understanding Relative Power Mapping” on page 4-24

• “Calculating Downlink Scramble Codes” on page 4-25

• “Understanding the Uplink Configuration” on page 4-27
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W-CDMA Frame Structures
This section contains graphical representations of W-CDMA frame structures, with 
associated tables, for both downlink and uplink channels.

Downlink PICH Frame Structure

Figure 4-1. PICH Frame Structure
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Downlink PCCPCH + SCH Frame Structure

Figure 4-2. PCCPCH + SCH Frame Structure 

Table 4-1 Lengths of PCCPCH + SCH Fields

Parameter Symbols Per Slot

Ndata 9

NSCH
a

a. SCH is comprised of PSCH 
and SSCH

1
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Downlink DPDCH/DPCCH Frame Structure

Figure 4-3. DPDCH/DPCCH Frame Structure

Table 4-2 DPDCH and DPCCH Fields
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Bits/Frame Bits/
Slot

DPDCH Bits/Slot DPCCH Bits/Slot

DPDCH DPCCH TOTAL Ndata1 Ndata2 NTPC NTFCI Npilot

0 15 7.5 512 60 90 150 10 0 4 2 0 4

1 15 7.5 512 30 120 150 10 0 2 2 2 4

2 30 15 256 240 60 300 20 2 14 2 0 2

3 30 15 256 210 90 300 20 2 12 2 2 2a

a. The number of pilot bits can vary with channel symbol rates of 15 and 30 ksps.

4 30 15 256 210 90 300 20 2 12 2 0 4a

5 30 15 256 180 120 300 20 2 10 2 2 4a

6 30 15 256 150 150 300 20 2 8 2 0 8a

7 30 15 256 120 180 300 20 2 6 2 2 8a

8 30 60 128 510 90 600 40 6 28 2 0 4a

9 60 30 128 480 120 600 40 6 26 2 2 4a

10 60 30 128 450 150 600 40 6 24 2 0 8a

11 60 30 128 420 180 600 40 6 22 2 2 8a

12 120 60 64 900 300 1200 80 12 48 4 8 8a

13 240 120 32 2100 300 2400 160 28 112 4 8 8

14 480 240 16 4320 480 4800 320 56 232 8 8 16

15 960 480 8 9120 480 9600 640 120 488 8 8 16

16 1920 960 4 18720 480 19200 1280 248 1000 8 8 16
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Uplink DPDCH/DPCCH Frame Structure

There are two types of uplink dedicated physical channels, the uplink Dedicated Physical 
Data Channel (uplink DPDCH) and the uplink Dedicated Physical Control Channel 
(uplink DPCCH). The DPDCH and the DPCCH are I/Q multiplexed within each radio 
frame.

The uplink DPCCH is used to carry control information generated at Layer 1. The Layer 1 
control information consists of known pilot bits (Pilot) to support channel estimation for 
coherent detection, transmit power control (TPC) commands, feedback information (FBI), 
and an optional transport format combination indicator (TFCI) as shown in Figure 4-4. 
The TFCI informs the receiver regarding the instantaneous transport format combination 
of the transport channels mapped to the simultaneously transmitted uplink DPDCH radio 
frame.

Figure 4-4 Uplink DPDCH/DPCCH Frame Structure

The exact number of uplink DPDCH bits is shown in Table 4-3.

Table 4-3  Uplink DPDCH Fields

Slot 
Format

Bit Rate 
(kbps)

Symbol 
Rate (ksps)

Spread
Factor

Bits per 
Frame

Bits per 
Slot

NData

0 15 15 256 150 10 10
1 30 30 128 300 20 20
2 60 60 64 600 40 40
3 120 120 32 1200 80 80
4 240 240 16 2400 160 160
5 480 480 8 4800 320 320
6 960 960 4 9600 640 640
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The exact number of uplink DPCCH bits is shown in Table 4-4.

DPCCH Pattern Coding

Depending on the selected pattern and pattern type (user file, PN9 or PN15, or FIX4), 
coding effects differ as shown in Table 4-5.

Limitation for User File Size

Depending on the selected data or pattern types, user file size limitations differ as shown 
in Table 4-5.

Table 4-4  Uplink DPCCH Fields

Slot 
Format

Bit 
Rate 

(ksps)

Symbol 
Rate 

(ksps)

Spread
Factor

Bits 
per 

Frame

Bits 
per 
Slot

NPilot NTFCI NFBI NTPC

0 15 15 256 150 10 6 2 0 2
1 15 15 256 150 10 8 0 0 2
2 15 15 256 150 10 5 2 1 2
3 15 15 256 150 10 7 0 1 2
4 15 15 256 150 10 6 0 2 2
5 15 15 256 150 10 5 2 2 1

Table 4-5  DPCCH Pattern Coding Effect

Pattern User File, PN9, or PN15 FIX4

TFCI <no coding done>
10 bits/frame to 30 bits/frame by the 
second order Reed Muller coding
(puncturing 2 bits/frame)

FBI <no coding done> <no coding done>

TPC 
1 bit becomes,

1 TPC bit if 1 bit/frame,
2 TPC bits if 2 bits/frame

Table 4-6  DPCCH Pattern Coding Effect

Data or Pattern User File Size Limitation

Data (TrCH)
1024 bits maximum, or 
4096 bytes maximum: multiple of “information bit/TTI
(= “block size” * “number of blocks”)”

Data (DPDCH) 4096 bytes maximum

TFCI 256 bytes maximum

FBI 256 bytes maximum

TPC 256 bytes maximum
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Understanding W-CDMA Data Generation
This section will familiarize you with the types of signals that can be generated, including 
information on valid channel combinations, parameter couplings, and value restrictions by 
channel type. It is divided into separate subsections for downlink and uplink. 

Downlink Data Generation

Valid Channel-Type-to-Channel-Number Assignments

Valid Channel Combinations per ESG

Channel # Available Channel Types

1 OCNS, DPCHa, or PSCH

a. Up to six dedicated channels (DCH) may be activated within the transport 
channel carried by a DPCH.

2 OCNS, DPCH, or SSCH

3 OCNS, DPCH, PCCPCH, or PICHb

b. When selected and active, PICH occupies both Channel #3 and Channel #4 due 
to DTX bits.

4 OCNS, DPCH, or CPICH

Configuration Available Channel Types

Receiver Control PSCH + SSCH + CPICH + PCCPCHa

a. Any combination of these four channel types disallows DPCH and OCNS. 

Information Data 
Transmission, 
Code Domain 

Power 
Adjustment

(DPCH × m) + (OCNS × n) + PICH

Where:

m + n ≤ 4 for configurations without PICH
m + n ≤ 2 for configurations with PICH
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Parameter Couplings

Changing the value of certain W-CDMA waveform parameters will cause value changes in 
other W-CDMA waveform parameters. In the following table, a bullet indicates coupling 
between two parameters. Value changes in one parameter necessitate value changes in 
coupled parameters. These coupled value changes occur automatically.

Table 4-7 Parameter Couplings

12.2 RMCa

a. Reference Measurement Channel

64 RMC 144 RMC 384 RMC Block 
Size

# of 
Blocks 

Coding Rate Match 
Attribute

CRC Size

Slot 
Format

• • • • •

Channel 
Code

• • • •

Symbol 
Rate

• • • •

Bits Rate • • • • • •

12.2 RMC − • • • • •

64 RMC − • • • • •

144 RMC − • • • • •

384 RMC − • • • • •

UDI 64 • • • • •

AMR 12.2 • • • • •

UDI 
ISDN

• • • • •
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Table 4-8 DPCH Slot Format and OCNS, Symbol Rate, Channel Code, OVSF 
Couplings and Values

Slot Format Channel Code Symbol Rate (ksps) Spread Factor 
(OVSF)

0 0 to 511 7.5 512

1 0 to 511 7.5 512

2 0 to 255 15 256

3 0 to 255 15 256

4 0 to 255 15 256

5 0 to 255 15 256

6 0 to 255 15 256

7 0 to 255 15 256

8 0 to 127 30 128

9 0 to 127 30 128

10 0 to 127 30 128

11 0 to 127 30 128

12 0 to 63 60 64

13 0 to 31 120 32

14 0 to 15 240 16

15 0 to 7 480 8

16 0 to 3 960 4
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Parameter Value Restrictions and Couplings by Channel Type

This section contains information on parameter value restrictions, changes requiring data 
precomputation and regeneration, and parameter couplings.

CPICH  

DPCH  

General restriction: in order for the ESG to precompute data for baseband generation, you 
must press the Apply Channel Setup after any one of following actions:

• Changing any DPCH parameter value (except for power)

• Changing from any other channel type to DPCH

• Changing from DPCH to any other channel type

Parameter Restrictions Notes

Power None

Channel Code Not 
user-selectable. 

0 only, by 3GPP specification.

Parameter Restrictions Notes

Power None No Apply Channel Setup key press necessary.

Channel Code None Coupled to Slot Format, Spread Factor, and Symbol Rate. For 
valid values, see Table 4-8.

SecScr Code 
OS

None Coupled to BS primary scramble code.

TPC Pat Steps Must be same for 
all DPCH.

Entering a value in one DPCH will enter the same value in all 
other DPCHs.

Data Must be same for 
all DPCH.

Entering a value in one DPCH will enter the same value in all 
other DPCHs.

Symbol Rate Not user selectable. Assigned based on Slot Format. Also coupled to Channel Code 
and Spread Factor. For valid values, see Table 4-8.

TFCI Pattern Must be same for 
all DPCH.

Entering a value in one DPCH will enter the same value in all 
other DPCHs.

TPC Pattern Must be same for 
all DPCH.

Entering a value in one DPCH will enter the same value in all 
other DPCHs.

Slot Format Must be same for 
all DPCH.

Coupled to Channel Code, Symbol Rate and Spread Factor. For 
valid values, see Table 4-8.

Time Offset Must be same for 
all DPCH.

Entering a value in one DPCH will enter the same value in all 
other DPCHs.
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OCNS  

PCCPCH  No restrictions. Contains incrementing system frame number.

PICH  General restriction: due to DTX (discontinuous transmission), PICH is only 
available on Channel #3 and occupies the state reserved for Channel #4 when active.

PSCH  No restrictions

SSCH  No restrictions

Transport Channel Layer  

General restrictions: 

• In order for the ESG to precompute data for baseband generation, you must press the 
Apply Channel Setup after changing any parameter value.

• The TrCH assigned on the ESG’s user interface becomes the TrCH referred to in the 
3GPP RF specification.

• DCHs must be turned on sequentially (DCH 1 and 2 must be ON before DCH 3 is 
activated).

• DTCH data is transmitted on DCH channels 1, 3, 4, 5, and 6. 

DCCH data is transmitted on DCH 2.

Parameter Restrictions Notes

Power None

Data PN9 and PN15 only

Symbol Rate None Coupled to Channel Code, Slot Format and Spread Factor. For 
valid values, see Table 4-8.

Channel Code None Coupled to Symbol Rate, Slot Format and Spread Factor. For 
valid values, see Table 4-8.

SecScr Code 
OS

None

Parameter Restrictions Notes

Block Size Max size = 
5000 bits

Coupled to Bits Rate, Puncture, and Bits/Frame values.

Number of Blocks None Coupled to Bits Rate, Puncture, and Bits/Frame values.

Coding None Coupled to Puncture and Bits/Frame values.

TTI None Coupled to Puncture and Bits Rate values.
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Interleaver Not user 
selectable. 

Data field for value display only, to provide TTI period.

Data Max user file size 
= 1024 bits

Transmission of user files > than 1024 bits will be truncated to a 
multiple of the block size.

Rate Match Attr None Coupled to Puncture and Bits/Frame values.

CRC Size None

Bits/Frame Not user 
selectable. 

Data field for value display only, to provide total 
information data bits-per-radio frame. Value based on 
Block Size, TTI, Coding and Rate Match Attribute values.

Puncture Not user 
selectable. 

Data field for value display only, to provide puncture 
percentage. Value based on Block Size, TTI, Coding and 
Rate Match Attribute values.

Bits Rate Not user 
selectable. 

Data field for value display only, to provide DCH bits rate, 
controlled by DPCH data rate.

Tr Position Not user 
selectable. 

Data field for value display only, to provide position of 
TRCH in radio frame. Rate matching algorithm depends 
on TrCH assignment. TrCH 1 should be assigned to 
DTCH and TrCH 2 should be assigned to DCCH for 
reference measurement channel.

Parameter Restrictions Notes
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Uplink Data Generation

Channel Type Assignment

Parameter Couplings

Changing the value of certain W-CDMA waveform parameters will cause value changes in 
other W-CDMA waveform parameters. In Table 4-9, a bullet indicates coupling between 
two parameters. Value changes in one parameter necessitate value changes in coupled 
parameters. These coupled value changes occur automatically.

Channel # Available Channel Types

1 DPCCH

2 DPDCHa

a. Up to six dedicated channels (DCH) may be activated within the transport layer 
reference measurement channel carried by a DPDCH.

Table 4-9  Parameter Couplings

RMC 
12.2 kbps

RMC
64 kbps

RMC
144 kbps

RMC
384 kbps

Block Size Coding 
Rate

RM 
Parameter

CRC Size TFCI State

Slot Format • • • • • •

Channel 
Code

• • • •

Symbol Rate • • • •

Bit Rate • • • • •

TFCI On/Off • • • •

RMC 
12.2 kbps

− • • • •

RMC 
64 kbps

− • • • •

RMC 
144 kbps

− • • • •

RMC 
384 kbps

− • • • •
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Table 4-10  DPCCH and Slot Format, Channel Code, Couplings and Values

Slot 
Format

DPCCH 
Bits/Slot

Pilot 
Bits/Slot

TFCI 
Bits/Slot

FBI 
Bits/Slot

TPC 
Bits/Slot

Max Channel 
Code

0 10 6 2 0 2 255

1 10 8 0 0 2 255

2 10 5 2 1 2 255

3 10 7 0 1 2 255

4 10 6 0 2 2 255

5 10 5 2 2 1 255

Table 4-11  DPDCH and Slot Format, Symbol Rate, Channel Code, Couplings and 
Values

Slot 
Format

DPDCH 
Bits/Slot

DPDCH 
Bits/Frame

DPDCH
Bit Rate

Max Channel 
Code

0 10 150 15 kbps 255

1 20 300 30 kbps 127

2 40 600 60 kbps 63

3 80 1200 120 kbps 31

4 160 2400 240 kbps 15

5 320 4800 480 kbps 7

6 640 9600 960 kbps 3
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Parameter Value Restrictions and Couplings by Channel Type

This section contains information on parameter value restrictions, changes requiring data 
pre-computation and regeneration, and parameter couplings.

DPCCH  

General restriction: In order for the ESG to precompute data for baseband generation, you 
must press the Apply Channel Setup after any one of following actions:

• Changing any DPCCH parameter value (except for power)

• Changing from any other channel type to DPCCH

• Changing from DPCCH to any other channel type

Parameter Restrictions Notes

Power None No Apply Channel Setup key press necessary.

Channel Code None See Table 4-4.

TPC Pat Steps None

Symbol Rate None Always assigned to 15.0 ksps, see Table 4-4.

FBI Pattern None Maximum 256 bytes for user file size.

FBI State Not user selectable. Coupled to Slot Format.

TFCI Pattern None Maximum 256 bytes for user file size.

TFCI State Not user selectable. Coupled to Slot Format.

TPC Pattern None Maximum 256 bytes for user file size.

Slot Format None For valid values, see Table 4-4.
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DPDCH  

General restriction: In order for the ESG to precompute data for baseband generation, you 
must press the Apply Channel Setup after any one of following actions:

• Changing any DPDCH parameter value (except for power)

• Changing from any other channel type to DPDCH

• Changing from DPDCH to any other channel type

Transport Channel Layer  

General restriction: In order for the ESG to precompute data for baseband generation, you 
must press the Apply Channel Setup after changing any parameter value.

• DCHs must be turned on sequentially (DCH 1 and 2 must be ON before DCH 3 is 
activated).

Parameter Restrictions Notes

Power None

Data Max user file size = 
4096 bytes

PN9, PN15, FIX4, user file, TRCH

Symbol Rate None Coupled to Channel Code and Slot Format. For valid values, see 
Table 4-3.

Channel Code None Coupled to Symbol Rate and Slot Format. For valid values, see 
Table 4-3.

Slot Format None Coupled to Channel Code and Symbol Rate. For valid values, see 
Table 4-3.

Parameter Restrictions Notes

Blk Size Max user file size = 
4096 bytes

Coupled to Bits Rate, Bits/Frame, and other values.
“information bits”/TTI = “block size” * “num of blocks”

Num of Blks Max 4095 blocks

Coding None Coupled to Bits Rate, Bits/Frame, and other values.

TTI None Coupled to Bits Rate, Bits Rate, and other values.

Data Max user file size = 
1024 bits

Transmission of user files larger than 1024 bits will be 
truncated to a multiple of the block size.

Rate Match 
Attr

None Coupled to Bits Rate, Bits/Frame, and other values.

CRC Size None

Bits/Frame Not user selectable. Data field for value display only, to provide total information 
data bits-per-radio frame. Value based on Blk Size, TTI, Coding 
and Rate Match Attr values.
4-16 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators Operation
Option 200 Understanding W-CDMA Data Generation
Max Puncture Not used. Data field for value display only, to provide maximum power 
puncture percentage. Value based on Blk Size, TTI, Coding and 
Rate Match Attr values.

Puncture Not user selectable. Data field for value display only, to provide power puncture 
percentage. Value based on Blk Size, TTI, Coding and Rate 
Match Attr values.

Bits Rate Not user selectable. Data field for value display only, to provide DCH bits rate.

Interleaver Not user selectable. Data field for value display only, to provide interleaver 
operating state information.

Err Insert None 

BLER None Resolution 0.001%

Err Blocks Not user selectable. Data field for value display only, to provide the number of error 
blocks inserted.

Total Blocks Not user selectable. Data field for value display only, to provide the number of total 
blocks.

Actual BLER Not user selectable. Data field for value display only, to provide the actual block 
error ratio.

BER None Resolution 0.0001

Err Bits Not user selectable. Data field for value display only, to provide the number of error 
bits inserted.

Total Bits Not user selectable. Data field for value display only, to provide the number of total 
bits.

Actual BER Not user selectable. Data field for value display only, to provide the actual bit error 
ratio.

Parameter Restrictions Notes
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Understanding the Reference Measurement Channel

The signal generator provides one-button setup capabilities for transport channel 
configuration. The dedicated physical channel DCH (downlink) or DPDCH (uplink) is 
predefined by pressing the Ref Measure Setup softkey (or sending the appropriate SCPI 
commands). For downlink, at least one physical channel needs to be set to DPCH to 
activate the Ref Measure Setup softkey. Also, to activate the Config Transport softkey, one of 
the reference measurement rates must be selected or the DPCH Data field value must be 
set to Transport CH. For uplink, DPDCH and RMC 12.2 kbps are the default selections, 
respectively.

Table 4-12 and Table 4-13 describe the downlink and uplink reference measurement 
channel (RMC) configurations generated by pressing the Ref Measure Setup softkey after 
signal generator preset. Transport channel parameters can be modified in a table editor by 
pressing the Config Transport softkey, then moving the cursor to the desired data field and 
pressing Edit Item. DPCH and DPDCH parameters can be individually modified in a table 
editor by pressing PhyCH Setup, then moving the cursor to the desired data field and 
pressing Edit Item. 

Table 4-12 The Downlink RMC Predefined DPCH Configuration

Parameter DPCH Values at Specified Reference Measurement Channel

12.2 kbps 64 kbps 144 kbps 384 kbps UDI 64 AMR 12.2 UDI 
ISDN

Power 0.00 dB 0.00 dB 0.00 dB 0.00 dB 0.00 dB 0.00 dB 0.00 dB

Channel 
Codea

a. ESG Channel # 1 default shown. Default channel code for Channels 2 through 4 are based on the 
equation: Default Channel Code = (Channel #) + 5.

6 6 6 6 6 6 6

SecSrc Code 
OS

0 0 0 0 0 0 0

TPC Pat 
Steps

1 1 1 1 1 1 1

Datab

b. If a transport configuration parameter is changed using the Config Transport 
softkey and the table editor, the Data field reverts to Transport CH, showing that it no longer con-
tains a specified reference measurement channel.

Ref 12 Ref 64 Ref 144 Ref 384 ISDN64 AMR 12 ISDN

Symbol 
Ratec

c. Symbol rate is not user-selectable. It is coupled to slot format. To change symbol rate, use the 
appropriate slot format.

30.00 
ksps

120.0 
ksps

240.0 
ksps

480.0 
ksps

120.0 
ksps

30.0 ksps 120.0 
ksps

TFCI 
Pattern

00000000 00000000 00000000 00000000 00000000 00000000 00000000

TPC Pattern Up/Down Up/Down Up/Down Up/Down Up/Down Up/Down Up/Down

Slot Format 11 13 14 15 13 8 13

Time Offset 0 0 0 0 0 0 0
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Table 4-13 The Uplink RMC Predefined DPDCH Configuration

DPCH Values at Specified Reference Measurement Channel

Parameter 12.2 kbps 64 kbps 144 kbps 384 kbps UDI 
64 kbps

AMR 
12.2 kbps

Power 0.00 dB 0.00 dB 0.00 dB 0.00 dB 0.00 dB 0.00 dB

Beta 15 15 15 15 15 15

Data TransportCH TransportCH TransportCH TransportCH TransportCH TransportCH

Symbol Ratea

a. The user-selectable symbol rate and slot format parameters are coupled together.

60.000 ksps 240.000 ksps 480.000 ksps 960.000 ksps 240.000 ksps 60.000 ksps

Slot Formata 2 4 5 6 4 2

Channel Code 16 4 2 1 4 16
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Understanding the Single-ESG Downlink Configuration

Capabilities 

The Option 200 single-ESG setup provides four fully coded 3GPP channels for use in 
testing 3GPP mobile receiver designs. 

Channel Types

The single-ESG setup can provide up to four of the following downlink channel types: 

• primary synchronization channel (PSCH)

• secondary synchronization channel (SSCH)

• primary common control physical channel (PCCPCH)

• common pilot channel (CPICH)

• dedicated physical channel (DPCH)

• paging indicator channel (PICH)

• orthogonal channel noise simulator (OCNS)

A single ESG can provide a control configuration (PSCH, SSCH, PCCPCH, and CPICH) or 
an information data transmission configuration (DPCH and PICH, with optional OCNS).

For valid channel type/channel number, see “Valid Channel-Type-to-Channel-Number 
Assignments” on page 4-7. For valid channel combinations, see “Valid Channel 
Combinations per ESG” on page 4-7.

Reference Measurement Channels

Option 200 provides reference measurement channels at 12.2, 64, 144, and 384 kbits per 
second. This option also provides transport layer channelization for AMR 12.2 (adaptive 
multi-rate) and UDI 64 (unrestricted digital information) protocols.

System Triggering and Synchronization

This configuration utilizes internal I/Q triggering. The rear panel EVENT 2 BNC 
connector provides a system synchronization signal in the form of a chip-wide pulse that 
resets the system every time a parameter change that requires system re-synchronization 
is made. For increased measurement accuracy, the signal generator’s rear panel 10 MHZ 
OUT frequency reference can be utilized by other instruments in the test system.
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Understanding the Two-ESG Downlink Configuration

Capabilities

The two-ESG downlink configuration provides a 3GPP solution in situations where more 
than four fully coded W-CDMA channels are required. Using two ESG signal generators, 
Option 200 utilizes the combination of both baseband generators to build the W-CDMA 
waveforms required to test 3GPP user equipment designs. 

The Option 200 3GPP setup provides the following downlink channel types: 

• primary synchronization channel (PSCH)

• secondary synchronization channel (SSCH)

• primary common control physical channel (PCCPCH)

• common pilot channel (CPICH)

• dedicated physical channel (DPCH)

• paging indicator channel (PICH)

• orthogonal channel noise simulator (OCNS)

In a typical two-ESG setup, the baseband generator from one ESG provides a control 
configuration (PSCH, SSCH, PCCPCH, and CPICH) while the other provides an 
information data transmission configuration (DPCH and PICH, with optional OCNS). 
Fully coded and channelized W-CDMA signals are available at the RF outputs of both 
ESGs.

For valid channel type/channel number, see “Valid Channel-Type-to-Channel-Number 
Assignments” on page 4-7. For valid channel combinations, see “Valid Channel 
Combinations per ESG” on page 4-7.

System Functionality

Separate sections of the 3GPP frame are generated by separate baseband generators, one 
within ESG 1 and another within ESG 2. The two sections of the frame are then combined 
at the I/Q inputs of both ESGs and modulated to the carrier by the RF section within each 
ESG. After carrier frequency and amplitude are introduced, the fully coded and 
channelized 3GPP signals are output to the DUT(s) through the RF output of both ESGs. 
An external function generator is used to supply the chip clock. See Figure 4-5.
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Figure 4-5. The Two-ESG 3GPP Downlink System Block Diagram
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Downlink I/O Signal Descriptions and Timing Relationships

The following sections describe the functionality of various input and output signals 
available at the BNC connectors on the Option 200 signal generator. Option 200 changes 
some of the standard characteristics of these signals for use with 3GPP applications. 

Connector descriptions are divided into two subsections: front panel BNC inputs and rear 
panel BNC inputs and outputs.

Front Panel BNC Input Connectors

DATA  This connector is not used for Option 200. 

DATA CLOCK  This BNC connector is used for chip clock input. 

For use with external data clock sources. To use an external signal source as the data clock 
input, press BBG Data Clock Ext Int until Ext is highlighted or execute the appropriate SCPI 
command.

SYMBOL SYNC  This connector is not used for Option 200. 

Rear Panel BNC Input/Output Connectors

PATTERN TRIG IN  This BNC connector is used for system sync input. 

This connector uses the signal from the EVENT 2 system synchronization output to keep 
the two baseband generators synchronized.

EVENT 1 OUT  This BNC connector is used for an 80 ms synchronization clock output.

This connector outputs an 80 ms synchronization clock aligned with the RF, 40 ms high 
and 40 ms low.

EVENT 2 OUT  This BNC connector is used for system synchronization output.

The system synchronization signal is a chip-wide pulse that resets the system every time a 
parameter change that requires system synchronization is made.

DATA OUT  This BNC connector is used to output the TPC bit. 

This signal indicates the state of the transmit power control bit (CMOS high to increase 
power, CMOS low to decrease power). The signal leads the RF by 24 chips and is active for 
the entire timeslot. 

SYMBOL SYNC OUT  This BNC connector is used for symbol synchronization output. 

The synchronization output signal is a one-chip wide pulse every 80 ms.
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Understanding Relative Power Mapping

The Option 200 3GPP two-ESG downlink system configuration requires power 
adjustments for each active channel, in order to achieve the required 3GPP code domain 
power output. 

Once the test system has been properly connected and configured, a relative power 
mapping procedure must be performed after entering channel power values into the signal 
generators. ESG 1 and ESG 2 cannot communicate channel power level information 
between the two signal generators. The relative power mapping procedure solves this 
problem. This procedure ensures that the channel power levels generated on ESG 1 are 
aligned with the channel power levels produced by ESG 2 to achieve the required 3GPP 
code domain power levels.

By making adjustments to percent power paired and total voltage paired, the power output 
of the second baseband generator is matched to the first, resulting in a 0 dB overall system 
code domain output power value. 

The OCNS channel generates orthogonal noise in the code domain. If specific downlink 
channel power levels are required, adding and/or adjusting the power level of the 
orthogonal channel noise simulator is an easy way to add fill-in power while keeping the 
original channel power values intact.

Voltage Other ESG values and % Power Other ESG values must be input to ESG 1 and 
ESG 2 via the front panel user interface or by executing SCPI commands via remote 
interface. See “Adjust the Relative Power Mapping” on page 2-14.

NOTE To ensure accuracy, the relative power mapping procedure must be repeated 
every time a channel power level setting is modified on either ESG.
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Calculating Downlink Scramble Codes
The Option 200 signal generator implements scrambling codes for downlink OCNS and 
DPCH channels in compliance with the 3G TS 25.101 V3.3 specification. This is done 
through the use of the Scrambling Code (primary scramble code) field, located in the BS 
setup menu, and the SecScr Code OS (secondary scramble code offset) fields located in the 
OCNS and DPCH Physical Channel Setup menus. These fields are linked so that an entry 
to any field affects the actual scramble code. To better understand the relationship, refer to 
the following formula:

The primary and secondary sets are determined by the SecScr Code OS field values. If the 
SecScr Code OS field value is zero, then the scramble code is in the primary set. Any 
non-zero entry enables the secondary set. The SecScr Code OS field value has a range of 
0 through 15.

A primary scramble code is the product of the Scrambling Code field value and 16. 
Therefore, the primary scramble code set contains all the multiples of 16, from 0 through 
8176.

A secondary scramble code is the sum of the non-zero SecScr Code OS field value and the 
primary scramble code. The secondary scramble code set uses the numbers in between the 
multiples of 16.

Thus, all numbers from 0 through 8191 are available for scramble codes. 

Refer to the following for examples of scramble codes generated with the primary and 
secondary sets:

Where n = scramble code Range: 0 to 8191

i = Scrambling Code field input Range 0 to 511

k = SecScr Code OS field input Range: 0 to 15

Where n = scramble code

i = Scrambling Code field input

k = SecScr Code OS field input

A: Primary set B: Secondary set
i = 6 i = 8
k = 0 k = 7
n = 96 n = 135

n 16 i×( ) k+=

n 16 i×( ) k+=
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Understanding the Uplink Configuration

Uplink Capabilities 

The Option 200 single-ESG setup provides two 3GPP channels with real-time generation 
capability for use in testing 3GPP base station receiver designs.

Channel Types

The single-ESG setup provides the following uplink channel types: 

• dedicated physical control channel (DPCCH)

• dedicated physical data channel (DPDCH)

Uplink Data Channel Air Interface

The spreading and scrambling used on the uplink DPCCH and DPDCH channels differ 
from the downlink in two key areas: I/Q multiplexing of the DPCCH and DPDCH, and the 
use of the scrambling codes as the channelization.

Figure 4-6 W-CDMA Uplink Data Channel Air Interface Block Diagram
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Reference Measurement Channels

Option 200 provides reference measurement channels at 12.2, 64, 144, and 384 kbits per 
second. This option also provides transport layer channelization for AMR 12.2 (adaptive 
multi-rate) and UDI 64 (unrestricted digital information) protocols.

System Triggering and Synchronization

Either of the system frame number reset signal or the frame clock which is applied to the 
PATTERN TRIG IN port can be set as a system trigger signal. After a delay time defined 
by the sum of 1024 chips (T0 = the standard timing offset between downlink and uplink), 
Timing Offset, and Slot Delay (plus 10 ms when the SFN reset signal is used), a sync 
signal is generated to time align all other signals. The RF output signal is generated after 
the fixed delay of the processing time by the hardware.

For increased measurement accuracy, the signal generator’s rear panel 10 MHZ OUT 
frequency reference can be utilized by other instruments in the test system.

Uplink I/O Signal Descriptions and Timing Relationships

The following sections describe the functionality and timing relationships of various input 
and output signals available at the BNC connectors on the Option 200 signal generator. 
Option 200 changes some of the standard characteristics of these signals for use with 
3GPP applications. 

Front Panel BNC Input Connectors

Other input connectors are used for configuring the downlink tests.

DATA CLOCK  This BNC connector is used for chip clock input. 

For use with external data clock sources. To use an external signal source as the data clock 
input, press BBG Data Clock Ext Int until Ext is highlighted or execute the appropriate SCPI 
command. This clock rate can be multiplied by setting the Ext Clock Rate softkey to x2 or 
x4. Also, the polarity of this signal can be selected by the Ext Clock Polarity softkey to either 
Pos (positive) or Neg (negative).

Rear Panel BNC Input/Output Connectors

PATTERN TRIG IN  This BNC connector is used for system reset trigger input. 

The input signal can be set to either the frame clock or the system frame number reset 
signal by toggling the Sync Source FClk SFN softkey. The frame clock is selectable from 10, 
20, 40, and 80 ms.

EVENT 1 OUT  This BNC connector is used for raw data output of the DPDCH channel.

The DPDCH raw data is aligned with the clock signal (EVENT 2) for the DPDCH raw 
data. The length of this raw data is dependent on the slot format currently selected for the 
DPDCH channel.
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EVENT 2 OUT  This BNC connector is used for clock signal output for DPDCH raw data.

This clock signal is aligned with the DPDCH raw data. The one-cycle length is dependent 
on the slot format currently set to the DPDCH channel.

DATA OUT  This BNC connector is used for DPCCH raw data output. 

The value aligned with the 15 ksps symbol rate may change every 256 chips. The output is 
aligned with data generation timing and leads the RF output by typically 33 chips.

SYMBOL SYNC OUT  This BNC connector is used for system sync output. 

The sync output signal is triggered by the system frame number reset signal or by the 
frame clock which is applied to the PATTERN TRIG IN connector. With this sync signal, 
the time alignment of the earliest frame timing for baseband data generation is made. A 
number of frames are generated until the next sync signal is introduced for time 
alignment. The delay time from the trigger input is the sum of 1024 chips (T0), Timing 
Offset, and Slot Delay (also add 10 ms if the SFN reset signal is used).

This output can be used to synchronize receiver measurements of the base station.

Uplink I/O Signal Timing Diagram

The following figure illustrates the timing relationships between the signals from the rear 
panel BNC input and output connectors. Signal states are referenced to the chip clock 
provided at the DATA CLK OUT connector.
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ESG Family Signal Generators
Option 200
5 Remote Programming and Examples

This chapter describes Option 200 SCPI commands and provides programming examples. 
The descriptions of commands include syntax requirements, ranges, restrictions, queries, 
and *RST.
Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide 5-1



Remote Programming and Examples ESG Family Signal Generators
W-CDMA Subsystem SCPI Command Reference Option 200
W-CDMA Subsystem SCPI Command Reference
Use the SCPI commands described in this chapter to remotely set the controls and 
parameters associated with the W-CDMA communications standard. The commands are 
grouped under general headings and listed in alphabetical order by subject. The general 
headings are common SCPI commands for downlink and uplink, downlink SCPI 
commands and uplink SCPI commands. Commands are further organized by their 
association with the physical channel types.

Common SCPI Commands for Downlink and Uplink

Baseband Generator Data Clock Selection

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock INT[1]|EXT[1]
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock?

This command selects the baseband generator data clock source for the radio channel. The 
choices are Internal (INT[1]) or External (EXT[1]).

*RST: Internal

External Clock Polarity Selection

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock:EXT:POLarity POSitive|NEGative
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock:EXT:POLarity?

This command sets the external clock polarity to either the positive edge or negative edge 
for the baseband generator. The choices are positive or negative.

*RST: Positive

IQ Percent Power Query

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:PPOWer?

This command query returns the IQ percent power of the ESG. The IQ percent power is 
that value displayed in the ESG % Power This ESG field.

*RST: 0

IQ Percent Power Paired

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:PPPaired <0 - 40>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:PPPaired?

This command sets the percent power of the paired ESG. The IQ percent power for the 
paired ESG. The IQ percent power is that value displayed in the ESG % Power Other ESG 
field.

*RST: 0
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IQ Voltage Scale

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:SCALe <−40.00 to 0.00dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:SCALe?

This command adjusts the total IQ output power in the 2 box setup. Changing this value 
affects the total power and channel power levels will be internally scaled. The output 
power is automatically calculated when the Voltage Other ESG field changes.

Range: 0 to −40 dB

*RST: 0.00 

IQ Total Voltage Query

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:TVOLtage?

This command query returns the total voltage level value from the ESG. This value will 
displayed in the Voltage This ESG data field.

*RST: 0.00

IQ Total Voltage Paired

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:TVPaired <0 to 4V>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:TVPaired?

This command adjusts the total IQ output power of the paired ESG. The IQ Voltage Other 
ESG value is for a 2-ESG setup. Entering a value in the IQ Voltage Other ESG field 
forces a calculation of the IQ voltage scale.

*RST: 0 

Link Down Up

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:LINK DOWN|UP
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:LINK?

This command sets the ESG for uplink or downlink parameters.

*RST: Down

Phase Polarity

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:POLarity[:ALL] NORMal|INVerted 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:POLarity[:ALL]?

This command selects the polarity for the Q channel.

*RST: Normal
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W-CDMA State

[:SOURce]:RADio:WCDMa:TGPP[:BBG][:STATe] ON|OFF|1|0 
[:SOURce]:RADio:WCDMa:TGPP[:BBG][:STATe]?

This command turns W-CDMA functionality on or off.

*RST: Off (0)

Downlink SCPI Commands

Apply Channel Setup

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:APPLy
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:APPLy?

This command immediately starts the channel coding generation process according to the 
channel setup and data entered for the downlink physical and transport channels. If 
pre-computing is required, then a progress bar will appear on the signal generator’s 
display. You may query for operation complete with the command “*OPC?”. If the apply 
query command is sent and a “1” is returned, then immediately outputting the command 
“*OPC?” will force an execution of the “APPLy” command and the channel generation 
process.

Chip Rate

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CRATe <1kcps to 4.25Mcps>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CRATe?

This command adjusts the chip rate. The default value (3.84 Mcps) is in accordance with 
the 3GPP v3.3 specification.

Range: 1.000 kcps to 4.250000 Mcps

*RST: 3.84 Mcps
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Reference Measurement Channel

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup REF122|REF64|REF144| 
REF384|AMR122|UDI64|ISDN
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup?

This command configures the downlink reference measurement setup. The following 
choices are available:

REF122  Reference Measurement Channel 12.2 kbps (25.101 V3.3)

REF64  Reference Measurement Channel 64.0 kbps (25.101 V3.3)

REF144  Reference Measurement Channel 144.0 kbps (25.101 V3.3)

REF384  Reference Measurement Channel 384.0 kbps (25.101 V3.3)

AMR122  Adaptive Multiple Rate 12.2 kbps (25.944 V3.0)

UDI64  Unrestricted Digital Information 1B 64.0 kbps (25.944 V3.0)

ISDN  ISDN Unrestricted Digital Information. Configures transport channel 
1 to carry four blocks of 640 and transport channel 2 to carry one block 
of 148.

*RST: REF122 

Scramble Code

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SCRamblecode <0 to 511>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SCRamblecode?

This command selects the scramble code number to be used.

Range: 0 to 511

*RST: 0

CPICH Setup

Power Level  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CPICh:POWer <−40.00 to 0.00dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CPICh:POWer?

This command sets the power level for this channel.

*RST: 0.00 dB 

State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CPICh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CPICh[:STATe]?

This command turns the CPICH channel on or off. The CPICH channel type will be 
activated on channel 4 with the ON[1] command.

*RST: Off (0)
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DCH Transport Channel Setup

Block Size  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
BLKSize <0 to 5000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:BLKSize?

This command sets the block size for the selected DCH transport channel.

Range: 0 to 5000

*RST: 20

BP Frame Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:BPFRame?

This command query returns the bits per frame for the DCH transport channel.

Range: 16 to 380

*RST: 343

Bits Rate Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:BRATe?

This command query returns the bit rate of the selected DCH transport channel.

*RST:12.2 kbps

Coding Type  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:CODE 
HCONv|TCONv|TURBo|NONE
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:CODE?

This command selects the encoder type. The choices are turbo, none, 1/2 convolutional 
(HCONv), 1/3 convolutional (TCONv).

*RST: HCONv

CRC  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:CRC 0|8|16|24
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:CRC?

This command sets the number of CRC (cyclic redundancy check) bits for the DCH 
transport channel.

*RST: 8
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Data  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:DATA PN9|FIX4|
"<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:DATA?

This command configures the data for the downlink dedicated channel (DCH) selected. The 
following choices are available:

PN9  9-bit ITU pseudorandom sequence bit data pattern

FIX4  4-bit repeating sequence data pattern

"<file name>"  A file name in the catalog of binary files

*RST: PN9

FIX4  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:DATA:
FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:DATA:FIX4?

This command sets a fixed data type to be transmitted on the selected DCH transport 
channel.

Range: 0 to 15

*RST: 0

Number of Blocks  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:NBLocks <1 to 8>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:NBLocks?

This command sets the number of blocks transmitted by the active transport (DCH) 
channel.

*RST: 1

Puncture Percentage Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:PPERcentage?

This command query returns the percentage of the total bits removed from or added to the 
fully coded channel.

*RST: 1

Rate Match Attribute  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:RMATch <1 to 256>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:RMATch?

This command sets the rate matching attribute.

*RST: 1
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State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6[:STATe]?

This command turns the selected DCH transport channel on or off. The channels must be 
turned on sequentially. If one channel is turned off then all higher numbered channels will 
automatically be turned off. Channels #2 to 6 are off at reset while channel #1 is always on.

*RST: On (DCH 1)

TTI  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:TTI 10|20|40|80
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:TTI?

This command sets the transmission time interval (in milliseconds) allowed for the 
transport channel to transmit. Choices are 10, 20, 40, or 80 milliseconds.

*RST: 10

DPCH Setup

Channel Code  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:CCODe <0 to 511>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:CCODe?

This command sets the channel code number. The channel code is coupled with the slot 
format and symbol rate.

Range: 0 to 511

*RST: 6

Slot 
Format

0-1 2-7 8-11 12 13 14 15 16

Symbol 
Rate

7.5 
ksps

15 
ksps

30 
ksps

60 
ksps

120 
ksps

240 
ksps

480 
ksps

960 
ksps

Max Ch 
Code

511 255 127 63 31 15 7 3
5-8 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators Remote Programming and Examples
Option 200 W-CDMA Subsystem SCPI Command Reference
Data  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
DATA PN9|PN15|TRANspch|FIX4|"<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:DATA?

This command configures the data pattern for the downlink DPCH channel. The following 
choices are available:

PN9  9-bit ITU pseudorandom sequence bit pattern

PN15  15-bit ITU pseudorandom sequence bit pattern

FIX4  4-bit repeating sequence bit pattern

TRANspch  DCH transport channel data pattern

"<file name>"  A file name in the catalog of binary files

*RST: PN9

FIX4  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:DATA:FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:DATA:FIX4?

This command sets the data type to a FIX4 pattern. 

Range: 0 to 15

*RST: 0

Power  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:POWer <−40.00 to 
0.00dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:POWer?

This command sets the power level for the DPCH physical channel.

*RST: 0.00 dB
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Slot Format  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:SLOTformat <0 to 16>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:SLOTformat?

This command configures the DPCH physical channel for a slot format. Slot format is 
coupled with the channel code and symbol rate. TPC, TFCI and Pilot bits are also set as 
per specification and not displayed. For a description of slot formats, see the 3GPP 
Technical Specifications (TS 25.211 v3.3).

Range: 0 to 16

*RST: 0

Secondary Scrambling Code Offset  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:SSCodeos <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:SSCodeos?

This command sets the secondary scrambling code offset for the DPCH channel.

Range: 0 to 15

*RST: 0

State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4[:STATe]?

This command turns the DPCH channel on or off. The DPCH channel type will be 
activated on the selected channel with the ON[1] command.

*RST: Off (0)

Symbol Rate  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH:SRATe <7.5 to 960 kbps>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH:SRATe?

This command selects a symbol rate. The choices are 7.5, 30, 60, 120, 240, 480 or 960 kbps. 
The symbol rate is dependent on the slot format.

Range: 7.5 to 960 kbps

*RST: 7.5 kbps

Slot 
Format

0-1 2-7 8-11 12 13 14 15 16

Symbol 
Rate

7.5 
ksps

15 
ksps

30 
ksps

60 
ksps

120 
ksps

240 
ksps

480 
ksps

960 
ksps

Max Ch 
Code

511 255 127 63 31 15 7 3
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TFCI Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TFCI:PATTern <0 to 
0x3FF>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TFCI:PATTern?

This command sets a 10-bit pattern for the transport format combination indicator (TFCI). 
The TFCI is optional and describes the services in use (for example, voice and data).

Range: 0 to 0x3FF

*RST: 0

Timing Offset  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TOFFset <0 to 149>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TOFFset?

This command adjusts the timing offset for the DPCH physical channel. The offset is in 
chips.

Range: 0 to 149

*RST: 0

TPC Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TPC:
PATTern UDOWn|DUP|UALL|DALL
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TPC:PATTern?

This command controls the power of the users equipment (UE). The increase/decrease 
direction for UE power level changes is determined by the TPC Pattern. The power can be 
stepped all up, stepped all down, alternately step up then down, or step down then up. 

*RST: Up/Down

TPC Pattern Steps  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TPC:NUMSteps <1 - 80>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TPC:NUMSteps?

This command sets the number of 1 dB steps for increasing/decreasing the UE power. The 
command is used with the TPC Patterns Up/Down (UDOWn) or Down/Up (DUP) and is the 
number of 1 db steps taken before the increasing/decreasing power direction changes. The 
command causes the UE power level to continually increase and decrease by the number of 
1 dB steps assigned.

Range: 1 to 80

*RST: 1
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Filter Setup

Filter  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer RNYQuist|NYQuist|GAUSsian|
RECTangle|IS95|IS95_EQ|IS95_MOD|IS95_MOD_EQ|AC4Fm|UGGaussian|"<User FIR>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?

This command selects one of the following filter types:

RNYQuist  Root Nyquist

NYQuist  Nyquist

GAUSsian  Gaussian

RECTangle  Rectangle

IS95  IS-95

IS95_EQ  IS-95 with equalizer

IS95_MOD  IS-95 modified

IS95_MOD_EQ  IS-95 modified with equalizer

AC4Fm  APCO 25 C4FM

UGGaussian  UN3/4 delay compatible, 0.300 fixed BbT, GSM Gaussian

"<User FIR>"  User defined FIR

Filter Alpha (for Nyquist or Root Nyquist)  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:ALPHa <0.000 to 1.000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:ALPHa?

Execute this command to change the alpha value for a Nyquist or root Nyquist filter. The 
pre-defined alpha value is 0.220. This command is effective only after selection of a root 
Nyquist or Nyquist filter; it does not affect other types of filters.

Range: 0.000 to 1.000

Once set, this value is not affected by an instrument preset or by a power cycle.

Filter BbT (for Gaussian)  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:BBT <0.000 to 1.000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:BBT?

Execute this command to change the bandwidth-multiplied-by-bit-time filter parameter 
value. The pre-defined BbT value is 0.500, This command is effective only after selection of 
a Gaussian filter; it does not affect other types of filters.

Range: 0.000 to 1.000

Once set, this value is not affected by an instrument preset or by a power cycle.
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Filter EVM/ACP Optimization (for Nyquist or Root Nyquist)  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:CHANnel EVM|ACP
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:CHANnel?

Execute this command to optimize a filter for minimized error vector magnitude (EVM) or 
for minimized adjacent channel power (ACP).

*RST: EVM

OCNS Setup 

Channel Code  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:CCode <0 to 511>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:CCode?

This command sets the channel code number. The channel code is coupled with the slot 
format and symbol rate.

Range: 0 to 511

*RST: 6

Data  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:DATA PN9|PN15
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:DATA?

This command configures the data pattern for the downlink OCNS channel. The following 
choices are available:

PN9  9-bit ITU pseudorandom sequence bit pattern

PN15  15-bit ITU pseudorandom sequence bit pattern

*RST: PN9

Power   

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:POWer <−40.00 to 
0.00dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:POWer?

This command sets the power level for the OCNS channel.

*RST: 0.00 dB

Slot 
Format

0-1 2-7 8-11 12 13 14 15 16

Symbol 
Rate

7.5 
ksps

15 
ksps

30 
ksps

60 
ksps

120 
ksps

240 
ksps

480 
ksps

960 
ksps

Max Ch 
Code

511 255 127 63 31 15 7 3
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Secondary Scrambling Code Offset  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:SSCodeos <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:SSCodeos?

This command sets the secondary scrambling code offset for the OCNS channel.

Range: 0 to 15

*RST: 0

State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[:STATe]?

This command turns the OCNS channel on or off. The OCNS channel type will be 
activated on the selected channel with the ON[1] command.

*RST: Off (0)

Symbol Rate

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS:SRATe <7.5 to 960 kbps>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS:SRATe?

This command selects the symbol rate.

Range: 7.5 to 960 kbps

*RST: 7.5 kbps

P–CCPCH Setup

BCH Data  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:BCHData PN9|PN15|FIX4|
"<file name>"|TRANspch
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:BCHData?

This command sets the data type to one of the formats available. The BCH data will be 
transmitted on the PCCPCH channel. The following choices are available:

PN9  9-bit ITU pseudorandom sequence bit pattern

PN15  15-bit ITU pseudorandom sequence bit pattern

FIX4  4-bit repeating sequence bit pattern

"<file name>"  A file name in the catalog of binary files

TRANspch  DCH transport channel data pattern

*RST: FIX4 0000
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Channel Code  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:CCODe <0 to 255>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:CCODe?

This command sets the channel code to the desired code number.

Range: 0 to 255

*RST: 1

FIX4  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:BCHData:FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:BCHData:FIX4?

This command sets a fixed 4-bit data pattern.

Range: 0 to 15

*RST: 0

Power  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:POWer <−40.00 to 0.00dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:POWer?

This command sets the power level for the channel.

*RST: 0.00 dB

State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch[:STATe]?

This command turns the PCCPCH channel on or off. The PCCPCH channel type will be 
activated on channel 3 with the ON[1] command.

*RST: Off (0)

PICH Setup 

Channel Code  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:CCode <0 to 255>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:CCode?

This command sets the channel code to the desired code number.

Range: 0 to 255

*RST: 3
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Data  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:DATA PN9|PN15|FIX4|
"<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:DATA?

This command configures the data pattern for the downlink PICH channel. The following 
choices are available:

PN9  9-bit ITU pseudorandom sequence bit pattern

PN15  15-bit ITU pseudorandom sequence bit pattern

FIX4  4-bit repeating sequence bit pattern

"<file name>"  A file name in the catalog of binary files

*RST: PN9 

FIX4   

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:DATA:FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:DATA:FIX4?

This command sets a fixed 4-bit data pattern to be transmitted on a transport channel.

Range: 0 to 15

*RST: 0000

Paging Indicator Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:PINDincator?

This command query returns the number of paging indicator fields per frame.

Paging Indicator Bits Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:PIBits?

This command query returns the number of bits in the paging indicator field.

Power  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:POWer <−40.00 to 0.00dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:POWer?

This command sets the power level for the PICH channel.

*RST: 0.00 dB 

State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PIPH[:STATe]?

This command turns the PICH channel on or off. The PICH channel type will be activated 
on the selected channel with the ON[1] command.

*RST: Off (0)
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PSCH Setup

Power  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PSCH:POWer <−40.00 to 0.00dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PSCH:POWer?

This command sets the power level for the PSCH physical channel.

*RST: 0.00 dB

State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PSCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PSCH[:STATe]?

This command turns the PSCH channel on or off. The PSCH channel type will be activated 
on channel 1 with the ON[1] command.

*RST: On

SSCH State

Power  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SSCH:POWer <−40.00 to 0.00dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SSCH:POWer?

This command sets the power level for the channel.

*RST: 0.00 dB

Secondary Scramble Code Group Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SSCH:SSGRoup?

This query returns the secondary scramble code group for the SSCH channel.

*RST: 0

State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SSCH[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SSCH[:STATe]?

This command turns the SSCH channel on or off. The SSCH channel type will be activated 
on channel 2 with the ON[1] command.

*RST: On 
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Uplink SCPI Commands

External Clock Rate Multiplier

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock:EXT:RATE X1|X2|X4
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock:EXT:RATE?

This command sets the external clock rate for the baseband generator. The choices are ×1, 
×2, or ×4.

X1  3.84 MHz external clock

X2  7.68 MHz external clock

X4  15.36 MHz external clock

*RST: ×1

DPCCH Setup

Channel Code  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:CCODe <0 to 255>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:CCODe?

This command sets the channel code for the uplink dedicated physical control channel. The 
maximum value is dependent on the symbol rate.

Range: 0 to 255

*RST: 0

Channel Power Control  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:POWer <−40.00 to 0.00dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:POWer?

This command sets the power level for the uplink dedicated physical control channel 
(DPCCH).

*RST: −2.69 dB

Channel State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh[:STATe]?

This command sets the operating state for the uplink dedicated physical control channel 
(DPCCH). The choice is on (1) or off (0).

*RST: On (1)
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FBI Fixed-Bit Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern:FIX <0 to 
1073741823>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern:FIX?

This command sets the 30-bit feedback information (FBI) pattern for the uplink dedicated 
physical control channel (DPCCH).

Range: 0 to 1073741823 (0x3FFFFFFF)

*RST: 0

FBI Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern PN9|PN15|FIX|
"<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern?

This command configures the pattern of the feedback information (FBI) for the uplink 
dedicated physical control channel (DPCCH). The following choices are available:

PN9  9-bit ITU pseudorandom sequence bit pattern

PN15  15-bit ITU pseudorandom sequence bit pattern

FIX  Fixed 30-bit repeating sequence data pattern

"<file name>"  A file name in the catalog of binary files

*RST: FIX

FBI State Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI[:STATe]?

This query returns whether or not the feedback information (FBI) bits are included in the 
uplink dedicated physical control channel (DPCCH).

*RST: Off (0)

Signaling Value  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:BETA <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:BETA?

This command sets the number of the signaling value for the amplitude ratio. After this 
command is sent, the channel power level for the uplink dedicated physical control channel 
(DPCCH) is re-calculated. If the channel power is set directly, the value of this command 
becomes invalid and is set to −1.

Range: 0 to 15

*RST: 11
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Slot Format  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:SLOTformat <0 to 5>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:SLOTformat?

This command sets the slot format for the uplink dedicated physical control channel 
(DPCCH).

Range: 0 to 5

*RST: 0

Symbol Rate Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:RATE?

This query returns the symbol rate for the uplink dedicated physical control channel 
(DPCCH).

*RST: 15000 bps

TFCI Fixed-Bit Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:PATTern:FIX <0 to 1023>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:PATTern:FIX?

This command sets the 10-bit data pattern of the transport format combination indicator 
for the uplink dedicated physical control channel (DPCCH).

Range: 0 to 1023 (0x03FF)

*RST: 0

TFCI Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:PATTern PN9|PN15|FIX|
"<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:PATTern?

This command configures the bit pattern of the transport format combination indicator for 
the uplink dedicated physical control channel (DPCCH). The following choices are 
available:

PN9  9-bit ITU pseudorandom sequence bit pattern

PN15  15-bit ITU pseudorandom sequence bit pattern

FIX  Fixed-bit repeating sequence data pattern

"<file name>"  A file name in the catalog of binary files

*RST: PN9
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TFCI State Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI[:STATe]?

This query returns the status of the transport format combination indicator (TFCI) for the 
uplink dedicated physical control channel (DPCCH).

*RST: On (1)

TPC Fixed 4-Bit Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern:FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern:FIX4?

This command sets the 4-bit data pattern of the transmit power control (TPC) for the 
uplink dedicated physical control channel (DPCCH).

Range: 0 to 15

*RST: 0

TPC Number of Steps  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:NSTeps <1 to 80>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:NSTeps?

This command sets the number of steps to increase or decrease the transmit power control 
(TPC) for the uplink dedicated physical control channel (DPCCH).

*RST: 1

TPC Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern PN9|PN15|FIX4|
"<file name>"|UDOWn|DUP|UALL|DALL
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern?

This command configures the pattern of the transmit power control (TPC) for the uplink 
dedicated physical control channel (DPCCH). The following choices are available:

PN9  Pseudorandom bit pattern with 9 steps

PN15  Pseudorandom bit pattern with 15 steps

FIX4  4-bit repeating sequence data pattern

"<file name>"  A file name in the catalog of binary files

UDOWn  Repetitively stepping up and down pattern

DUP  Repetitively stepping down and up pattern

UALL  Consecutively stepping up pattern

DALL  Consecutively stepping down pattern

*RST: PN9
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TPC Pattern Trigger Polarity  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern:TRIGger:
POLarity POSitive|NEGative
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern:TRIGger:POLarity?

This command sets the pattern trigger polarity of the transmit power control (TPC) for the 
uplink dedicated physical control channel (DPCCH). The choices are either positive edge or 
negative edge.

*RST: Positive

TPC Pattern Trigger State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern:TRIGger
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern:TRIGger[:STATe]?

This command sets the pattern trigger state of the transmit power control (TPC) for the 
uplink dedicated physical control channel (DPCCH). The choices are either (1) or off (0).

*RST: Off (0)

DPDCH Channel Setup

Channel Power Control  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:POWer <−40.00 to 0.00dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:POWer?

This command sets the power level for the uplink dedicated physical data channel 
(DPDCH).

*RST: 0.00 dB

Channel State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh[:STATe]?

This command sets the operating state for the uplink dedicated physical data channel 
(DPDCH). The choices are either on (1) or off (0).

*RST: On (1)

Channel Code  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:CCODe <0 to 255>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:CCODe?

This command sets the channel code for the uplink dedicated physical data channel 
(DPDCH). The maximum value is dependent on the slot format value.

Range: 0 to 255

*RST: 16
5-22 Fully Coded 3GPP W-CDMA Personality User’s and Programming Guide



ESG Family Signal Generators Remote Programming and Examples
Option 200 W-CDMA Subsystem SCPI Command Reference
Data Fixed 4-Bit Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA:FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA:FIX4?

This command sets the fixed 4-bit binary data for the uplink dedicated physical data 
channel (DPDCH).

Range: 0 to 15

*RST: 0

Data Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA PN9|PN15|FIX4|
"<file name>"|TRANspch
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA?

This command configures the data pattern for the uplink dedicated physical data channel 
(DPDCH). The following choices are available:

PN9  9-bit ITU pseudorandom sequence bit pattern

PN15  15-bit ITU pseudorandom sequence bit pattern

FIX4  4-bit repeating sequence bit pattern

"<file name>"  A file name in the catalog of binary files

TRANspch  Transport channel data pattern

*RST: TRANspch

Signaling Value  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:BETA <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:BETA?

This command sets the number of the signaling value for the amplitude ratio. After this 
command is sent, the value of the channel power level of the uplink dedicated physical 
data channel (DPDCH) is re-calculated. If the channel power is set directly, the value of 
this command becomes invalid and is set to −1.

Range: 0 to 15

*RST: 15
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Slot Format  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:SLOTformat <0 to 6>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:SLOTformat?

This command sets the slot format for the uplink dedicated physical data channel 
(DPDCH). This value primarily decides the symbol rate value and the maximum channel 
code value as shown in the following table.

Range: 0 to 6

*RST: 2

Symbol Rate  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:
RATE 15000|30000|60000|120000|240000|480000|960000
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:RATE?

This command sets the symbol rate for the uplink dedicated physical data channel 
(DPDCH). The choices range from 15 ksps to 960 ksps. The symbol rate is dependent on 
the slot format.

*RST: 60 ksps

UE Setup

Chip Rate  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:CRATe <1000 to 4250000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:CRATe?

This command sets the chip rate for the uplink configuration.

Range: 1.000 kcps to 4.250000 Mcps

*RST: 3.840 Mcps

Slot Format 0 1 2 3 4 5 6

Symbol Rate 15 ksps 30 ksps 60 ksps 120 ksps 240 ksps 480 ksps 960 ksps

Max Ch Code 255 127 63 31 15 7 3
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Filter  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer RNYQuist|NYQuist|GAUSsian|
RECTangle|IS95|IS95_EQ|IS95_MOD|IS95_MOD_EQ|AC4Fm|UGGaussian|"<User FIR>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?

This command selects one of the following filter types for the uplink configuration:

RNYQuist  Root Nyquist

NYQuist  Nyquist

GAUSsian  Gaussian

RECTangle  Rectangle

IS95  IS-95

IS95  IS-95 with equalizer

IS95_MOD  IS-95 modified

IS95_MOD_EQ  IS-95 modified with equalizer

AC4Fm  APCO 25 C4FM

UGGausian  UN3/4 delay compatible, 0.300 fixed BbT, GSM Gaussian

"<User FIR>"  User defined FIR

*RST: RNYQuist 

Filter Alpha (for Nyquist or Root Nyquist)  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:ALPHa <0.000 to 1.000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:ALPHa?

This command changes the alpha value for the Nyquist or root Nyquist filter. The 
pre-defined alpha value is 0.220. This command is effective only after a root Nyquist or 
Nyquist filter is selected; it does not effect other types of filters.

Range: 0.000 to 1.000

Once set, this value is not affected by an instrument preset or by a power cycle.

Filter BbT (for Gaussian)  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:BBT <0.000 to 1.000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:BBT?

This command changes the bandwidth-multiplied-by-bit-time filter parameter value for 
the Gaussian filter. The pre-defined BbT is 0.500. This command is effective only after a 
Gaussian filter is selected; it does not affect other types of filters.

Range: 0.000 to 1.000

Once set, this value is not affected by an instrument preset or by a power cycle.
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Filter EVM/ACP Optimization (for Nyquist or Root Nyquist)  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:CHANnel EVM|ACP
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:CHANnel?

This command optimizes a filter for the minimized error vector magnitude (EVM) or for 
the minimized adjacent channel power (ACP). This command is effective only after 
choosing a root Nyquist or Nyquist filter; it does not effect other types of filters.

*RST: EVM

Scramble Code  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SCRamblecode <0 to 16777215>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SCRamblecode?

This command sets the scramble code.

Range: 0 to 16777215

*RST: 0

DCH Transport Channel Setup

Bit Error Rate  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:BER
[:VALue] <0.0000 to 1.0000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:BER[:VALue]?

This command specifies the bit error rate to be applied for the uplink dedicated channel 
(DCH) selected.

Range: 0.000 to 1.000

*RST: 0.000

Bit Error Rate Actual Value Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:BER:ACTual?

This query returns the actual bit error rate value applied to the data for the uplink 
dedicated channel (DCH) selected. The actual bit error rate can be different from the 
specified bit error rate due to the internal bit generation.

Range: 0.000 to 1.000

*RST: 0.000
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Bit Error Rate Error Bits Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:BER:ERRor:
BIT?

This query returns the total number of bit errors for the selected bit error rate applied to 
the data for the uplink dedicated channel (DCH).

Range: 0 to 4294967295

*RST: 0

Bit Error Rate Total Bits Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:BER:TOTal:
BIT?

This query returns the total number of bits for the bit error rate applied to the data for the 
uplink dedicated channel (DCH) selected.

Range: 0 to 4294967295

*RST: 0 

Block Error Rate  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:BLER
[:VALue] <0.000 to 1.000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:BLER[:VALue]?

This command specifies the block error rate to be applied for the uplink dedicated channel 
(DCH) selected.

Range: 0.000 to 1.000

*RST: 0.000

Block Error Rate Actual Value Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:BLER:ACTual?

This query returns the actual block error rate value applied to the data for the uplink 
dedicated channel (DCH) selected. The actual block error rate can be different from the 
specified block error rate due to the internal bit generation.

Range: 0.000 to 1.000

*RST: 0.000
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Block Error Rate Error Blocks Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:BLER:ERRor:
BLOCk?

This query returns the total number of block errors for the selected block error rate applied 
to the data for the uplink dedicated channel (DCH).

Range: 0 to 4294967295

*RST: 0 

Block Error Rate Total Blocks Query  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:BLER:TOTal:
BLOCk?

This query returns the total number of blocks for the block error rate applied to the data 
for the uplink dedicated channel (DCH) selected.

Range: 0 to 4294967295

*RST: 0

Block Size  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:BLKSize <0 to 
5000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:BLKSize?

This command sets the block size for the uplink dedicated channel (DCH) selected.

Range: 0 to 5000

*RST:  244 for DCH1

96 for DCH2

20 for DCH3 to DCH6

Channel State  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6[:STATe]?

This command sets the operating state of the uplink dedicated channel (DCH) selected. 
The choices are either on (1) or off (0).

*RST:  Always on (1) for DCH1

On (1) for DCH2

Off (0) for DCH3 to DCH6
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Cyclic Redundancy Code  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:CRC 0|8|12|16|24
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:CRC?

This command specifies the number of cyclic redundancy code (CRC) bits to be added to 
each transport channel block. The choices are 0, 8, 12, 16, and 24.

*RST:  16 bits for DCH1 and DCH2

8 bits for DCH3 to DCH6

Data Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA PN9|FIX4|
"<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA?

This command configures the data for the selected uplink dedicated channel (DCH). The 
following choices are available:

PN9  9-bit ITU pseudorandom sequence bit data pattern

FIX4  4-bit repeating sequence data pattern

"<file name>"  A file name in the catalog of binary files

*RST: PN9

Data Fixed 4-Bit Pattern  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:FIX4 <0 - 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:FIX4?

This command sets the 4-bit data pattern for the uplink dedicated channel (DCH) selected.

Range: 0 to 15

*RST: 0

Encoder Type  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:CODE HCONv|TCONv| 
TURBo|NONE
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:CODE?

This command sets the encoder type for the uplink dedicated channel (DCH) selected. The 
following choices are available:

HCONv  Coding with the 1/2 rate convolutional encoder

TCONv  Coding with the 1/3 rate convolutional encoder

TURBo  Coding with the turbo coder

NONE  No coding

*RST:  TCONv for DCH1 and DCH2

HCONv for DCH3 to DCH6
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Error Insertion Mode  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:
EINSert BLER|BER|NONE
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:EINSert?

This command toggles the error insertion mode between BLER (block error rate) and BER 
(bit error rate) for the uplink dedicated channel (DCH) selected. The following choices are 
available:

BLER:  An incorrect CRC bit sequence is inserted in the data.

BER:  An incorrect bit sequence is inserted in the data.

NONE:  No error bit is inserted in the data.

*RST: None

Number of Blocks  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:NBLock <0 to 4095>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:NBLock?

This command sets the 4-bit data pattern for the uplink dedicated channel (DCH) selected.

*RST: 1

Rate Matching Attribute  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:RMATch <1 to 256>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:RMATch?

This command sets the rate matching attribute for the uplink dedicated channel (DCH) 
selected.

*RST: 1

Transmission Time Interval  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
TTI 10000|20000|40000|80000
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:TTI?

This command sets the transmission time interval for the uplink dedicated channel (DCH) 
selected. The choice is 10000, 20000, 40000, or 80000 microseconds.

*RST:  20000 microseconds for DCH1

40000 microseconds for DCH2

10000 microseconds for DCH3 to DCH6
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Adjust Code Domain Power Level  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:PADJust EQUal|SCALe

This command adjusts the code domain power levels of all uplink channels. The following 
choices are available:

EQUal  Adjusts all channel powers to equal power settings that sum to 0 dB.

SCALe  Scales the channel power levels so that the sum of the powers is 0 dB 
and the power ratios for the individual channels are the same.

*RST: Scale

Apply Channel Setup  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:APPLy
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:APPLy?

This command immediately starts the channel coding generation process according to the 
channel setup and data for the uplink physical and transport channels. If pre-computing is 
required then a progress bar will appear on the signal generator display. You may query 
for operation complete with the command “*OPC?”. If the apply query command returns a 
“1”, the execution of the apply command is needed. If the apply query command returns a 
“0”, the execution of the apply command is completed and is not needed.

Reference Measurement Channel  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel RMC122|RMC64|RMC144| 
RMC384|AMR122|UDI64
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel?

This command configures the uplink reference measurement channel. The following 
choices are available:

RMC122  Reference Measurement Channel 12.2 kbps (25.141 V3.4)

RMC64  Reference Measurement Channel 64.0 kbps (25.141 V3.4)

RMC144  Reference Measurement Channel 144.0 kbps (25.141 V3.4)

RMC384  Reference Measurement Channel 384.0 kbps (25.141 V3.4)

AMR122  Adaptive Multiple Rate 12.2 kbps

UDI64  ISDN Unrestricted Digital Information 1B 64.0 kbps

*RST: RMC122 
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Uplink Synchronization Setup

Frame Clock Interval  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval 
FCL10|FCL20|FCL40|FCL80
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval?

This command sets the frame clock interval for the uplink synchronization source.

FCL10  10 milliseconds

FCL20  20 milliseconds

FCL40  40 milliseconds

FCL80  80 milliseconds

*RST: FCL80 

Frame Clock Polarity  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:POLarity POSitive|NEGative
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:POLarity?

This command sets the operating state of the frame clock for the uplink synchronization 
source. The choices are either positive edge or negative edge.

*RST: Positive

SFN Reset Polarity  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SFNRst:POLarity POSitive|NEGative
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SFNRst:POLarity?

This command sets the operating state of the system frame number (SFN) reset signal for 
the uplink synchronization. The choices are positive edge or negative edge.

*RST: Positive

Slot Delay Control  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SDELay <0 to 119>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SDELay?

This command sets the number of slots to be delayed from the synchronization source. The 
actual timing offset is (T0) + (Timeslot Delay) + (Timing Offset) where T0 (= 1024 chips) is 
the standard timing offset between downlink and uplink.

Range: 0 to 119 slots

*RST: 0
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Synchronization Triggering Mode  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SYNC:MODE SINGle|CONTinuous
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SYNC:MODE?

This command selects the synchronization triggering mode. The following choices are 
available:

SINGle  Once triggered, the ESG generates one set of frames based on the 
reference clock.

CONTinuous  The sync signal and frame timing are continuously aligned.

*RST: Single

Sync Source  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SYNC[:SOURce] SFN_RST|FCLock
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SYNC[:SOURce]?

This command selects the uplink synchronization source type. The following choices are 
available:

SFN_RST  System frame number reset signal

FCLock  Frame clock signal

*RST: FCLock

Timing Offset Control  

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:TOFFset <−512 to 2560>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:TOFFset?

This command sets the timing offset in chips between the downlink signal and the uplink 
signal. A minus value means a negative delay. The actual timing offset is (T0) + (Timeslot 
Delay) + (Timing Offset) where T0 (= 1024 chips) is the standard timing offset between 
downlink and uplink.

Range: −512 to 2560 chips

*RST: 0
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Programming Example
This section provides the following programming example:

• uplink reference sensitivity
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Use this example to configure the reference sensitivity setup for uplink.

10 !**************************************************************
20 ! 
30 ! PROGRAM DESCRIPTION: In this example, the instrument is configured for
40 ! uplink (BS test). The carrier frequency is 1950 MHz at −121 dBm.
50 ! 
60 ! Text within ‘[]’ is optional. Lower case is also optional.
70 ! 
80 ! If this example is used with HP Basic, every line must start with
90 ! ‘OUTPUT < GPIB Address >;’.
100 ! 
110 !**************************************************************
120 *RST 
130 [:SOURce]:FREQuency[:CW] 1950.0 MHZ
140 [:SOURce]:POWer[:LEVel][:AMPLitude] −121 DBM
150 :OUTPut:MODulation[:STATe] ON
160 !**********************************************
170 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:LINK UP
180 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:POLarity[:ALL] NORmal
190 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBClock INT[1]
200 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:FILTer RNYQuist
210 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:FILTer:ALPHa 0.220
220 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:FILTer:SCRamblecode 0
230 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:CRATe 3840000
240 ! *********************************************
250 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SYNC[:SOURce] SFN_RST
260 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SYNC:MODE CONTinuous
270 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:TOFFset 0
280 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval FCL80
290 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel RMC122
300 ! *********************************************
310 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh[:STATe] ON
320 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:POWer −2.69 DB
330 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:SLOTformat 0
340 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:CCODe 0
350 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:PATTern:FIX 0
360 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern:FIX 0
370 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern UDOWn
380 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:NSTep 1
390 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern:TRIGger OFF
400 ! *********************************************
410 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh[:STATe] ON
420 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:POWer 0.00 DB
430 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA PN9
440 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:SLOTformat 2
450 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:CCODe 16
460 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:RATE 60000
470 ! *********************************************
480 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1][:STATe] ON
490 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]:BLKSize 244
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500 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]:DATA PN9
510 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]:NBLock 1
520 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]:RMATch 1
530 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]:CODE TCONv
540 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]:CRC 16
550 [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]:TTI 80000
560 !**********************************************
570 [:SOURce]:RADio:WCDMa:TGPP[:BBG][:STATe] ON
580 :OUTPut[:STATe] ON
590 END
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Program Comments

10 to 110: Program description

120: Reset the signal generator.

130: Set the signal generator’s carrier frequency to 1950.000 MHz.

140: Set the signal generator’s carrier power to −121 dBm.

150: Turn on the modulation function.

160: Program border

170: Set the ESG for uplink parameters. 

180: Set the phase polarity to normal. 

190: Set the data clock source of the baseband generator to internal. 

200: Set the filter type to root Nyquist.

210: Set the alpha value of the root Nyquist filter to 0.220.

220: Set the scrambling code to 0.

230: Set the chip rate to 3.840 Mcps.

240: Program border

250: Set the synchronization source to SFN reset signal.

260: Set the synchronization triggering mode to continuous.

270 Set the timing offset to 0 chip.

280: Set the frame clock interval to 80 milliseconds.

290: Set the reference measurement channel rate to 12.2 kbps.

300: Program border

310: Turn on the uplink dedicated physical control channel (DPCCH) operating state.

320: Set the power of the uplink DPCCH to −2.69 dB.

330: Set the slot format of the uplink DPCCH to 0.

340: Set the channel code of the uplink DPCCH to 0.

350: Set the TFCI fixed-bit pattern of the uplink DPCCH to 0000.

360: Set the FBI fixed-bit pattern of the uplink DPCCH to 00000000.

370: Set the TPC pattern of the uplink DPCCH to up and down pattern.

380: Set the number of steps for TPC of the uplink DPCCH to 1.

390: Set the pattern trigger for TPC of the uplink DPCCH to off.

400: Program border

410: Turn on the uplink dedicated physical data channel (DPDCH) operating state.

420: Set the power of the uplink DPDCH to 0.00 dB.

430: Set the data pattern of the uplink DPCCH to PN9.

440: Set the slot format of the uplink DPCCH to 2.

450: Set the channel code of the uplink DPDCH to 16.

460: Set the symbol rate of the uplink DPCCH to 60 ksps.
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470: Program border

480 Turn on the uplink dedicated channel (DCH) #1.

490 Set the block size of the uplink DCH #1 to 244.

500 Set the data pattern of the transport channel #1 to PN9.

510 Set the number of blocks of the uplink DCH #1 to 1.

520 Set the rate matching parameter of the transport channel #1 to 1.

530 Set the encoder type of the uplink DCH to 1/3 convolutional encoder.

540 Set the cyclic redundancy code of the transport channel #1 to 16.

550 Set the transmission time interval (TTI) of the uplink DCH #1 to 80 milliseconds.

560 Program border

570 Turn on the W-CDMA functionality.

580 Turn on the signal generator output.

590 End of program
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6 Programming Command 
Cross-Reference

This chapter lists the W-CDMA softkeys and data fields along with their corresponding 
SCPI commands. For a complete list of the signal generator hardkeys and softkeys and 
their corresponding SCPI commands, please refer to the programming guide.
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Table 6-1. Mode – WCDMA Softkeys  

Key or Data Field SCPI Command

# of Blocks [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
NBLocks <1 to 8>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
NBLocks?

% Power Other 
ESG

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:PPPaired <0 to 40>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:PPPaired?

% Power This ESG [:SOURce]:RADio:WCDMa:TGPP[:BBG]:PPOWer?

1/2 Conv
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
CODE HCONv
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:CODE? 

1/2 Conv
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
CODE HCONv
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:CODE?

1/3 Conv
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
CODE TCONv
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:CODE? 

1/3 Conv
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
CODE TCONv
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:CODE?

10 msec [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval FCL10
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval?

12.2 kbps 
(25.101 v3.5)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup REF122
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup?

20 msec [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval FCL20
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval?

40 msec [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval FCL40
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval?

64 kbps 
(25.101 v3.5)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup REF64
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup?

80 msec [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval FCL80
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval?

144 kbps 
(25.101 v3.5)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup REF144
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup?

384 kbps 
(25.101 v3.5)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup REF384
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup?
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Actual BER [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:
BER:ACTual?

Actual BLER [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:
BLER:ACTual?

Adjust Code Domain 
Power (Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PADJust EQUal|SCALe

Adjust Code Domain 
Power (Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:PADJust EQUal|SCALe

All Down
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
TPC:PATTern DALL 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
TPC:PATTern?

All Down
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern DALL
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern?

All Up
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
TPC:PATTern UALL 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
TPC:PATTern?

All Up
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern UALL
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern?

AMR 12.2 kbps [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel AMR122
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel?

AMR 12.2 
(25.944 v3.3)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup AMR122
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup?

APCO 25 C4FM
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer AFC4Fm
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?

APCO 25 C4FM
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer AC4Fm 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?

Apply Channel 
Setup (Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:APPLy
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:APPLy?

Apply Channel 
Setup (Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:APPLy
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:APPLy?

BBG Data Clock
Ext Int

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock INT[1]|EXT[1]
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock?

BCH Data 
(P-CCPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:BCHData 
PN9|PN15|FIX4|"<file name>"|TRANspch
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:BCHData?

Table 6-1. Mode – WCDMA Softkeys (Continued) 

Key or Data Field SCPI Command
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BER [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:
BER[:VALue] <0.0000 to 1.0000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:
BER[:VALue]?

Beta
(DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:BETA <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:BETA?

Beta
(DPDCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:BETA <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:BETA?

Bits/Frame [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
BPFRame?

Bits Rate [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
BRATe?

BLER [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:
BLER[:VALue] <0.000 to 1.000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:
BLER[:VALue]?

Blk Size 
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
BLKSize < 0 to 5000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
BLKSize? 

Blk Size 
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
BLKSize <0 to 5000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
BLKSize?

Channel Code 
(CPICH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CPICh:CCODe?

Channel Code
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
CCODe <0 to 511> 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:CCODe?

Channel Code 
(DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:CCODe <0 to 255>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:CCODe?

Channel Code 
(DPDCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:CCODe <0 to 255>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:CCODe?

Channel Code 
(OCNS)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:
CCODe <0 to 511>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:CCODe?

Channel Code
(P-CCPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:CCODe <0 to 511>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:CCODe?

Table 6-1. Mode – WCDMA Softkeys (Continued) 

Key or Data Field SCPI Command
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Channel Code
(PICH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:CCODe <0 to 511>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:CCODe?

Channel State 
Off On
(CPICH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CPICh
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CPICh[:STATe]?

Channel State 
Off On 
(DCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6
[:STATe]?

Channel State 
Off On
(DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh[:STATe]?

Channel State
Off On 

(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4 
[:STATe]?

Channel State
Off On
(DPDCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh[:STATe]?

Channel State
Off On

(OCNS)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[:STATe]?

Channel State
Off On
(P- CCPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch[:STATe]?

Channel State
Off On
(PICH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH[:STATe]?

Channel State 
Off On 
(PSCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PSCH
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PSCH[:STATe]?

Channel State 
Off On 
(SSCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SSCH
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SSCH[:STATe]?

Chip Rate
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:
CRATe <1 kcps to 4.25 Mcps>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CRATe?

Chip Rate
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:
CRATe <1000 to 4250000 cps>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:CRATe?

Table 6-1. Mode – WCDMA Softkeys (Continued) 

Key or Data Field SCPI Command
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Coding
(Downlink DCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
CODE HCONv|TCONv|TURBo|NONE
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:CODE? 

Coding
(Uplink DCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
CODE HCONv|TCONv|TURBo|NONE
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:CODE?

CRC Size
(Downlink DCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
CRC 0|8|12|16|24
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:CRC? 

CRC Size
(Uplink DCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
CRC 0|8|12|16|24
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:CRC?

Data 
(DCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
DATA PN9|FIX4|"<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:DATA?

Data 
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
DATA PN9|PN15|FIX4|"<file name>"|TRANspch
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:DATA?

Data
(DPDCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA PN9|PN15 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA?

Data
(OCNS)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS:DATA PN9|PN15 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS:DATA?

Data 
(PICH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:
DATA PN9|PN15|FIX4|"<file name>" 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:DATA?

Data
(Uplink DCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
DATA PN9|FIX4|"<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA?

Down/Up
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
TPC:PATTern DUP 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
TPC:PATTern?

Down/Up
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern DUP
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern?

Equal Powers 
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PADJust EQUal

Equal Powers 
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:PADJust EQUal
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ESG Family Signal Generators Programming Command Cross-Reference
Option 200
Err Insert [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
DATA:EINSert BLER|BER|NONE
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
DATA:EINSert?

Error Bits [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
DATA:BER:ERRor:Bit?

Error Blocks [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
DATA:BLER:ERRor:BLOCk?

Ext Clock Polarity 
Neg Pos 
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock:EXT:
POLarity POSitive|NEGative
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock:EXT:POLarity?

Ext Clock Rate
 x1 x2 x4 
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock:EXT:RATE x1|x2|x4
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:BBCLock:EXT:RATE?

FBI Pattern [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:
PATTern PN9|PN15|FIX|"<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern?

FBI State [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI[:STATe]?

Filter
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:
FILTer RNYQuist|NYQuist|GAUSsian|RECTangle|IS95|IS95_EQ|
IS95_MOD|IS95_MOD_EQ|AFC4Fm|UGGaussian|"<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?

Filter
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:
FILTer RNYQuist|NYQuist|GAUSsian|RECTangle|IS95|IS95_EQ|
IS95_MOD|IS95_MOD_EQ|AC4Fm|UGGaussian|"<file name>" 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?

Filter Alpha
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:
ALPHa <0.000 to 1.000> 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:ALPHa?

Filter Alpha
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:
ALPHa <0.000 to 1.000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:ALPHa?

Filter BbT
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:
BBT <0.000 to 1.000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:BBT?

Filter BbT
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:
BBT <0.000 to 1.000>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:BBT?

Table 6-1. Mode – WCDMA Softkeys (Continued) 
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Programming Command Cross-Reference ESG Family Signal Generators
Option 200
FIX 
(FBI for DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern:
FIX <0 to 1073741823>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern:FIX?

FIX 
(TFCI for DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:PATTern:
FIX <0 to 1023>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:PATTern:
FIX?

FIX4 
(DPDCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA:
FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA:FIX4?

FIX4 
(Uplink DCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
DATA:FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
DATA:FIX4?

FIX4 
(Downlink DCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
DATA:FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
DATA:FIX4?

FIX4 (DPCH) [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
DATA:FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
DATA:FIX4?

FIX4 (P-CCPCH) [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:
BCHData:FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:BCHData:FIX4?

FIX4 
(PICH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:
DATA:FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DATA:FIX4?

FIX4
(TPC for DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:
PATTern:FIX4 <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:
PATTern:FIX4?

Frame Clock Interval [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:
INTerval FCL10|FCL20|FCL40|FCL80
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:INTerval?

Frame Clock Polarity
Neg Pos

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:
POLarity POSitive|NEGative
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FCLock:POLarity?

Gaussian
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer GAUSsian
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?

Table 6-1. Mode – WCDMA Softkeys (Continued) 
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ESG Family Signal Generators Programming Command Cross-Reference
Option 200
Gaussian
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer GAUSsian 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?

IS-95
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer IS95
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?

IS-95
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer IS95 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?

IS-95 Mod
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer IS95_MOD
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?

IS-95 Mod
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer IS95_MOD 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?

IS-95 Mod w/EQ 
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer IS95_MOD_EQ
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?

IS-95 Mod w/EQ
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer IS95_MOD_EQ 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?

IS-95 w/EQ 
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer IS95_EQ
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?

IS-95 w/EQ
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer IS95_EQ 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?

IQ Voltage Scale [:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:SCALe <-40 to 0dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:SCALe?

Link Down Up [:SOURce]:RADio:WCDMa:TGPP[:BBG]:LINK DOWN|UP
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:LINK?

None 
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
CODE NONE
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:CODE? 

None
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
CODE NONE
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:CODE?

Num of Blk [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
NBLock <0 to 4095>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
NBLock?

Nyquist
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer NYQuist
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?

Nyquist
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer NYQuist 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?
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Programming Command Cross-Reference ESG Family Signal Generators
Option 200
Offset [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
TOFFset <0 - 149> 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TOFFset?

Optimize FIR For
EVM ACP
(BS Setup)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:CHANnel EVM|ACP
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer:CHANnel?

Optimize FIR For
EVM ACP
(UE Setup)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:CHANnel EVM|ACP 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer:CHANnel?

Paging 
Indicator

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:PI?

Phase Polarity
Normal Invert

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:
POLarity[:ALL] NORMal|INVerted
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:POLarity[:ALL]?

PI Bits [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:PIBits?

PN9
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH:DATA PN9
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH:DATA?

PN9
(DPDCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA PN9
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA?

PN9
(FBI for DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern PN9
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern?

PN9
(TFCI for DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:PATTern PN9
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:PATTern?

PN9
(TPC for DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern PN9
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern?

PN9
(Transport 
Channel)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA 
PN9
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA?

PN15
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH:DATA PN15
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH:DATA?

PN15
(DPDCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA PN15
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA?

PN15
(FBI for DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern PN15
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern?

PN15
(TFCI for DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:
PATTern PN15
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:PATTern?
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ESG Family Signal Generators Programming Command Cross-Reference
Option 200
PN15
(TPC for DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern PN15
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern?

Power (CPICH) [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CPICh:
POWer <-40 to 0dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:CPICh:POWer?

Power
(DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:
POWer <−40 to 0dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:POWer?

Power 
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
POWer <-40 to 0dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:POWer?

Power
(DPDCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:
POWer <−40 to 0dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:POWer?

Power 
(OCNS)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS:POWer <-40 to 0dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS:POWer?

Power 
(P-CCPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:
POWer <-40 to 0dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:POWer?

Power 
(PICH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:POWer <-40 to 0dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PICH:POWer?

Power 
(PSCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PSCH:POWer <-40 to 0dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PSCH:POWer?

Power 
(SSCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SSCH:POWer <-40 to 0dB>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SSCH:POWer?

Puncture 
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
PPERcentage?

Puncture 
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
PPERcentage?

Rate Match Attr 
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
RMATch <1 to 256>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH:DCH[1]|2|3|4|5|6:
RMATch?

Rate Match Attr 
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
RMATch <1 to 256>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
RMATch?

Rectangle
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer RECTangle
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?
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Programming Command Cross-Reference ESG Family Signal Generators
Option 200
Rectangle
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer RECTangle 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?

Ref Measure Setup 
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:
RCSetup REF122|REF64|REF144|REF384|AMR122|UDI64|ISDN
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup?

Ref Measure Setup 
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:
RMCHannel RMC122|RMC64|RMC144|RMC384|AMR122|UDI64
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel?

RMC 12.2 kbps 
(25.141 v3.4)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel RMC122
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel?

RMC 64 kbps 
(25.141 v3.4)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel RMC64
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel?

RMC 144 kbps 
(25.141 v3.4)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel RMC144
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel?

RMC 384 kbps 
(25.141 v3.4)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel RMC384
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel?

Root Nyquist
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer RNYQuist
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?

Root Nyquist
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer RNYQuist 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?

Scale to 0dB 
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PADJust SCALe

Scale to 0dB 
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:PADJust SCALe

Scrambling Code:
(BS Setup)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SCRamblecode <0 to 511>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SCRamblecode?

Scrambling Code
(UE Setup)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:
SCRamblecode <0 to 16777215> 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SCRamblecode?

Secondary 
Scramble Code 
Group 

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:SSCH:SSGRoup?

SecScr Code OS 
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
SSCodeos <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
SSCodeos?
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ESG Family Signal Generators Programming Command Cross-Reference
Option 200
SecScr Code OS 
(OCNS)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:
SSCodeos <0 to 15>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS[1]|2|3|4:
SSCodeos?

Select Pattern [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:
PATTern PN9|PN15|FIX4|"<file name>"|UDOW|DUP|UALL|DALL 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern?

SFN RST Polarity
Neg Pos

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SFNRst:
POLarity POSitive|NEGative
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SFNRst:POLarity?

Slot Delay [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SDELay <0 to 119>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SDELay?

Slot Format 
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
SLOTformat <0 to 16>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
SLOTformat?

Slot Format
(DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:
SLOTformat <0 to 5>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:SLOTformat?

Slot Format
(DPDCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:
SLOTformat <0 to 6>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:SLOTformat?

Symbol Rate
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH:SRATe?

Symbol Rate
(DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:RATE?

Symbol Rate
(DPDCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:
RATE 15000|30000|60000|120000|240000|480000|960000
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:RATE?

Symbol Rate
(OCNS)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS:
SRATe 7.5|15|30|60|120|240|480 ksps
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:OCNS:SRATe?

Sync Source
FClk SFN

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:
SYNC[:SOURce] SFN_RST|FCLock
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SYNC[:SOURce]?

Sync Trigger Mode
Single Cont

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SYNC:
MODE SINGle|CONTinuous
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:SYNC:MODE?

Table 6-1. Mode – WCDMA Softkeys (Continued) 
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Programming Command Cross-Reference ESG Family Signal Generators
Option 200
TFCI Pattern 
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TFCI: 
PATTern <0 to 0x3FF> 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TFCI: 
PATTern?

TFCI Pattern
(DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:
PATTern PN9|PN15|FIX|"<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:PATTern?

TFCI State [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI[:STATe]?

Time Offset [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
TOFFset <0 to 149> 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TOFFset?

Timing Offset [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:TOFFset <−512 to 2560>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:TOFFset?

Total Bits [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA: 
BER:TOTal:Bit?

Total Blocks [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:DATA:
BLER:TOTal:BLOCk?

TPC Pat Steps 
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TPC:
NUMSteps <1 to 80> 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TPC:
NUMSteps?

TPC Pat Steps 
(DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:
NSTeps <1 to 80>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:NSTeps?

TPC Pat Trig 
Off On

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern:
TRIGger[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern:
TRIGger[:STATe]?

TPC Pat Trig Polarity 
Neg Pos

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern:
TRIGger:POLarity POSitive|NEGative
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern:
TRIGger:POLarity?

TPC Pattern  
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TPC:
PATTern <UDOWn|DUP|UALL|DALL> 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TPC:
PATTern?

TPC Pattern
(DPCCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:
PATTern PN9|PN15|FIX4|"<file name>"|UDOWn|DUP|UALL|DALL
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern?

Table 6-1. Mode – WCDMA Softkeys (Continued) 
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ESG Family Signal Generators Programming Command Cross-Reference
Option 200
Transport Channel [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
DATA TRANspch 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
DATA?

TrCH State Off On [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6
[:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6 
[:STATe]?

TTI
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
TTI 10|20|40|80 mSec 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
TTI?

TTI
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
TTI 10000|20000|40000|80000
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:TTI?

Turbo [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
CODE TURBo 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6:
CODE?

UDI 64 (25.944 v3.0) [:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup UDI64
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RCSetup?

UDI 64 kbps [:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel UDI64
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:RMCHannel?

UDI ISDN 
(12.944 v3.3)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup ISDN
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:RCSetup?

UN3/4 GSM 
Gaussian 
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer UGGaussian
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:FILTer?

UN3/4 GSM 
Gaussian (Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer UGGaussian
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:FILTer?

Up/Down
(Downlink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TPC:
PATTern UDOWn 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:TPC:
PATTern?

Up/Down
(Uplink)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:
PATTern UDOW
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern?

User File
(Downlink DCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6
:DATA "<file name>" 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DCH[1]|2|3|4|5|6
:DATA?

Table 6-1. Mode – WCDMA Softkeys (Continued) 
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Programming Command Cross-Reference ESG Family Signal Generators
Option 200
User File
(Uplink DCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
DATA "<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DCH[1]|2|3|4|5|6:
DATA?

User File
(DPCCH FBI 
Pattern)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:
PATTern "<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:FBI:PATTern?

User File
(DPCCH TFCI 
Pattern)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:
PATTern "<file name>" 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TFCI:
PATTern?

User File
(DPCCH TPC 
Pattern)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:
PATTern "<file name>" 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPCCh:TPC:PATTern?

User File
(DPCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
DATA "<file name>" 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:DPCH[1]|2|3|4:
DATA?

User File
(DPDCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:
DATA "<file name>"
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:ULINk:DPDCh:DATA?

User File
(PCCPCH BCH)

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:
BCHData "<file name>" 
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:DLINk:PCCPch:BCHData?

Voltage Other 
ESG

[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:TVPaired <4 to 0V>
[:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:TVPaired?

Voltage This ESG [:SOURce]:RADio:WCDMa:TGPP[:BBG]:IQ:TVoltage?

W-CDMA Off On [:SOURce]:RADio:WCDMa:TGPP[:BBG][:STATe] ON|OFF|1|0
[:SOURce]:RADio:WCDMa:TGPP[:BBG][:STATe]?

Table 6-1. Mode – WCDMA Softkeys (Continued) 
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Index
Symbols
# of Blocks data field, 3-2
% Power Other ESG data field, 3-2
% Power This ESG data field, 3-2

Numerics
1/2 Conv softkey, 3-3
1/3 Conv softkey, 3-3
10 msec softkey, 3-3
12 kbps (25.101 v3.5) softkey, 3-3
144 kbps (25.101 v3.5) softkey, 3-4
2 Box Setup softkey, 3-3
20 msec softkey, 3-4
3, 3-57
384 kbps (25.101 v3.5) softkey, 3-4
40 msec softkey, 3-4
64 kbps (25.101 v3.5) softkey, 3-4
80 msec softkey, 3-4

A
Actual BER data field, 3-5
Actual BLER data field, 3-5
adjacent channel selectivity

base station performance test, 2-91
user equipment performance test, 2-35

Adjust Code Domain Power softkey, 3-6
algorithm decoding tests, 2-115
All Down softkey, 3-6
All Up softkey, 3-6
AMR 12.2 (25.944 v3.3) softkey, 3-7
AMR 12.2 kbps softkey, 3-7
APCO 25 C4FM softkey, 3-7
Apply Bit Errors softkey, 3-7
Apply Channel Setup softkey, 3-5, 3-9
architecture, system, 4-21

B
BBG Data Clock Ext Int softkey, 3-10
BCH Data data field, 3-10
BER softkey, 3-10, 3-14
Beta data field, 3-12
Beta softkey, 3-11
Bit Error Rate data field, 3-11
Bit Errors (numeric) softkey, 3-12
Bit/Frame data field, 3-14
Bits Rate data field, 3-14

block diagrams
two-ESG 3GPP downlink system, 4-22
uplink data channel air interface, 4-27

Block Error Rate data field, 3-15
Block Size data field, 3-15
blocking characteristics

base station performance test, 2-96
user equipment performance test, 2-42

BNC connectors
front panel inputs

downlink, 4-23
uplink, 4-28

rear panel inputs
downlink, 4-23
uplink, 4-28

timing diagram, uplink, 4-29
BNC connectors, I/O signal descriptions

downlink, 4-23
DATA, 4-23
DATA CLOCK, 4-23
DATA OUT, 4-23
EVENT 1 OUT, 4-23
EVENT 2 OUT, 4-23
PATTERN TRIG IN, 4-23
SYMBOL SYNC, 4-23
SYMBOL SYNC OUT, 4-23

uplink, 4-28
DATA CLOCK, 4-28
DATA OUT, 4-29
EVENT 1 OUT, 4-28
EVENT 2 OUT, 4-29
PATTERN TRIG IN, 4-28
SYMBOL SYNC OUT, 4-29

BS Setup
softkey, 3-15

BTS setup editor, 2-3, 2-10

C
calculating downlink scramble codes, 4-25
capabilities

downlink
single-ESG setup, 4-20
two-ESG setup, 4-21

uplink
single-ESG setup, 4-27

cdma2000
requirements, 1-1

CH, 5-26
Channel Code data field, 3-16
channel combinations

downlink, 4-7
Channel State Off On softkey, 3-17
Index I-1



Index
channel types
downlink, 4-7
uplink, 4-13

Chip Rate data field, 3-17
Coding

1/2 Conv, 3-3
1/3 Conv, 3-3
None, 3-45
Turbo, 3-70

coding
downlink DPCH, 1-3
uplink DPCCH and DPDCH, 1-5

Coding data field, 3-17
Config Transport softkey, 3-18
configure ESG

downlink
single ESG, 2-2
two ESGs, 2-10

uplink, 2-76
configure VSA

downlink
single ESG, 2-4
two ESGs, 2-16

uplink, 2-77
Copy File softkey, 3-18
couplings

downlink, 4-10
CPICH, 4-10
DPCH, 4-10
OCNS, 4-11
PCCPCH, 4-11
PICH, 4-11
PSCH, 4-11
SSCH, 4-11
TrCH, 4-11

uplink, 4-15
DPCCH, 4-15
DPDCH, 4-16

couplings, parameter
downlink, 4-8
uplink, 4-13

CPICH Setup, 5-5
CPICH softkey, 3-18
CRC Size data filed, 3-18
Create File softkey, 3-19

D
DATA CLOCK signal description

downlink, 4-23
uplink, 4-28

Data field, 3-20
data fields

# of Blocks, 3-2

data fields (Continued)
% Power Other ESG, 3-2
% Power This ESG, 3-2
Actual BER, 3-5
Actual BLER, 3-5
BCH Data, 3-10
BER, 3-11
Beta, 3-12
Bits Rate, 3-14
Bits/Frame, 3-14
BLER, 3-15
Blk Size, 3-15
Channel Code, 3-16
Chip Rate, 3-17
Coding, 3-17
CRC Size, 3-18
Data, 3-20
Error Bit, 3-26
Error Blocks, 3-26
Error Insertion, 3-26
FBI Pattern, 3-28
FBI State, 3-28
Filter, 3-28
Interleaver, 3-38
IQ Voltage Scale, 3-39
Max Puncture, 3-44
Number of Blk, 3-46
Offset, 3-48
Paging Indicator, 3-50
PI Bits, 3-52
Power, 3-53
Puncture, 3-54
RMatch Attr, 3-55
Scrambling Code, 3-59
SecScr Code OS, 3-59
selecting, 2-76
Slot Format, 3-62
Symbol Rate, 3-64
TFCI Pattern, 3-66
TFCI State, 3-66
Time Offset, 3-66
Total Bits, 3-67
Total Blocks, 3-67
TPC Pat Steps, 3-67
TPC Pattern, 3-68
Tr Position, 3-70
TTI, 3-70
Voltage Other ESG, 3-74
Voltage This ESG, 3-74

data generation
downlink, 4-7
uplink, 4-13

DATA OUT signal description
downlink, 4-23
I-2 Index 



Index
DATA OUT signal description (Continued)
uplink, 4-29

DATA signal description
downlink, 4-23

Define User FIR softkey, 3-20
Delete All Rows softkey, 3-21
Delete Bits softkey, 3-21
Delete File softkey, 3-21
Delete Row softkey, 3-21
Delete softkey, 3-21
Delete To Beginning softkey, 3-21
Delete To End softkey, 3-21
Display FFT softkey, 3-22
Display Impulse Response softkey, 3-23
Display softkeys

Display FFT, 3-22
Down/Up softkey, 3-23
downlink

DPCCH frame structure, 4-4
DPDCH frame structure, 4-4
PCCPCH+SCH frame structure, 4-3
PICH frame structure, 4-2

downlink DPCH coding, 1-3
downlink measurement setup

single ESG, 2-2
two ESGs, 2-6

Downlink SCPI commands, 5-4
DPCCH

downlink frame structure, 4-4
uplink frame structure, 4-5

DPCCH pattern coding, 4-6
DPCCH Setup, 5-18
DPCCH softkey, 3-24
DPCH Setup, 5-8
DPCH softkey, 3-24
DPDCH

downlink frame structure, 4-4
uplink frame structure, 4-5

DPDCH Channel Setup, 5-22
DPDCH softkey, 3-24
dynamic range

base station performance test, 2-86

E
Edit File softkey, 3-25
Edit Item softkey, 3-25
Equal Powers softkey, 3-25
equipment setup

downlink
single ESG, 2-2

downlink (Continued)
two ESGs, 2-7

uplink, 2-76
Error Bits data field, 3-26
Error Blocks data field, 3-26
Error Insertion data field, 3-26
EVENT 1 OUT signal description

downlink, 4-23
uplink, 4-28

EVENT 2 OUT signal description
downlink, 4-23
uplink, 4-29

Ext Clock Polarity Neg Pos softkey, 3-26
Ext Clock Rate softkey, 3-27

F
FBI Pattern data field, 3-28
FBI State data field, 3-28
Filter Alpha softkey, 3-29
Filter BbT softkey, 3-30
Filter data field, 3-28
Filter Setup, 5-12
Filter Symbols softkey, 3-31
filters

Gaussian, 3-34
IS-95, 3-39
IS-95 and IS-2000, 3-39
IS-95 Mod, 3-40
IS-95 w/EQ, 3-40
IS-95 w/EQ Mod, 3-40
Nyquist, 3-47
Rectangle, 3-55
Root Nyquist, 3-58
UN3/4 GSM Gaussian, 3-72

FIX softkey, 3-31
FIX4 softkey, 3-32
Frame Clock Interval softkey, 3-32
Frame Clock Polarity Neg Pos softkey, 3-33
frame structure

downlink
DPCCH, 4-4
DPDCH, 4-4
PCCPCH+SCH, 4-3
PICH, 4-2

uplink
DPCCH, 4-5
DPDCH, 4-5

front panel BNC connectors
downlink, 4-23
uplink, 4-28

functional testing of mobile receiver, 2-115
Index I-3



Index
G
Gaussian softkey, 3-34
Generate softkey, 3-35
Goto Bottom Row softkey, 3-35
Goto Middle Row softkey, 3-35
Goto Row softkey, 3-35
Goto Top Row softkey, 3-35

H
Hamming softkey, 3-36
Hann softkey, 3-36

I
I/O functionality

downlink, 4-23
uplink, 4-28

I/O signal descriptions
downlink, 4-23
uplink, 4-28

I/O timing diagram, uplink, 4-29
Insert 0’s softkey, 3-37
Insert 1’s softkey, 3-37
Insert PN15 softkey, 3-38
Insert PN9 softkey, 3-37
Insert Row softkey, 3-38
Insert softkey, 3-37
Interleaver data field, 3-38
intermodulation characteristics

user equipment performance test, 2-65
intermodulation response rejection

base station performance test, 2-105
IQ Voltage Scale data field, 3-39
IS-95 and IS-2000 softkey, 3-39
IS-95 Mod softkey, 3-40
IS-95 softkey, 3-39
IS-95 w/EQ Mod softkey, 3-40
IS-95 w/EQ softkey, 3-40

K
Kaiser softkey, 3-41

L
limitations, user file, 4-6
link control setup editor, 2-77
Link Control softkey, 3-42
Link Down Up softkey, 3-42

Load Default FIR softkey, 3-42
Load From Selected File softkey, 3-43
Load/Store softkey, 3-43

M
mapping, relative power, 2-14, 4-24
Max Puncture data field, 3-44
maximum input level

user equipment performance test, 2-28
menus

CDMA2000, 2-2, 2-76
Mirror Table softkey, 3-44
mobile receiver, troubleshooting, 2-115

N
NONE softkey, 3-45
None softkey, 3-45
Number of Bits softkey, 3-46
Number of Block data field, 3-46
Nyquist softkey, 3-47

O
OCNS Setup, 5-13
Offset data field, 3-48
operation, theory of, 4-1
Optimize FIR For EVM ACP softkey, 3-48
Option 200 overview, 1-2
option 201

requirements, 1-1
Oversample Ratio softkey, 3-49
overview

downlink channel, 1-2
uplink channel, 1-4

P
Page Down softkey, 3-50
Page Up softkey, 3-50
Paging Indicator data field, 3-50
parameters

selecting, 2-76
PATTERN TRIG IN signal description

downlink, 4-23
uplink, 4-28

P-CCPCH Setup, 5-14
P-CCPCH softkey, 3-50
PCCPCH+SCH

frame structure, 4-3
I-4 Index 



Index
performance tests
adjacent channel selectivity

base station (3G TS 25.141.7.4), 2-91
user equipment (3G TS 25.101.7.5), 2-35

base station tests, 2-79
physical and transport layer configuration, 2-80
preparation, 2-80
required equipment, 2-79

blocking characteristics
base station (3G TS 25.141.7.5), 2-96
user equipment (3G TS 25.101.7.6), 2-42

dynamic range
base station (3G TS 25.141.7.3), 2-86

intermodulation characteristics
user equipment (3G TS 25.101.7.8), 2-65

intermodulation response rejection
base station (3G TS 25.141.7.6), 2-105

maximum input level
user equipment (3G TS 25.101.7.4), 2-28

reference sensitivity level
base station (3G TS 25.141.7.2), 2-81
user equipment (3G TS 25.101.7.3), 2-21

spurious emissions
base station (3G TS 25.141.7.7), 2-112
user equipment (3G TS 25.101.7.9), 2-74

spurious response
user equipment (3G TS 25.101.7.7), 2-57

user equipment tests, 2-18
physical and transport layer configuration, 2-20
required equipment, 2-19

Phase PICH softkey, 3-52
Phase Polarity Normal Invert softkey, 3-50
Phase PSCH softkey, 3-53
PhyCH Setup softkey, 3-51
PhyCH Type softkey, 3-51
Physical Channel # softkey, 3-51
PI Bits data field, 3-52
PICH

frame structure, 4-2
PICH Setup, 5-15
PN15 softkey, 3-53
PN9 softkey, 3-52
Power data field, 3-53
primary scramble codes, 4-25
programming command cross reference, 6-1
programming examples, 5-34

single-ESG setup, 5-35
Puncture data field, 3-54

R
rear panel BNC connectors

downlink, 4-23

rear panel BNC connectors (Continued)
uplink, 4-28

receiver tests
using one ESG, 2-76

Rectangle softkey, 3-55
Ref Measure Setup softkey, 3-56
reference sensitivity level

base station performance test, 2-81
user equipment performance test, 2-21

relative power mapping
procedure, 2-14

relative power mapping, understanding, 4-24
Remote Programming, 5-2
remote softkey commands, 6-1
Rename softkey, 3-56
Restore Default Filter softkey, 3-56
restrictions

downlink, 4-10
CPICH, 4-10
DPCH, 4-10
OCNS, 4-11
PCCPCH, 4-11
PICH, 4-11
PSCH, 4-11
SSCH, 4-11
TrCH, 4-11

uplink, 4-15
DPCCH, 4-15
DPDCH, 4-16

RMatch Attr data field, 3-55
RMC 12.2 kbps (25.141 v3.4) softkey, 3-56
RMC 144 kbps (25.141 v3.4) softkey, 3-57
RMC 384 kbps (25.141 v3.4) softkey, 3-57
RMC 64 kbps (25.141 v3.4) softkey, 3-57
Root Nyquist softkey, 3-58

S
Scale To 0dB softkey, 3-59
SCPI command cross reference, 6-1
SCPI command reference, 5-2
SCPI commands

ALPHa
downlink filter alpha, 5-12
uplink filter alpha, 5-25

APPLy
downlink apply channel setup, 5-4
uplink apply channel setup, 5-31

BBCLock EXT POLarity
baseband generator external clock polarity, 5-2

BBCLock EXT RATE
baseband generator external clock rate multiplier, 

5-18
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SCPI commands (Continued)
BBCLock INT EXT

baseband generation data clock source, 5-2
BBT

downlink filter BbT, 5-12
uplink filter BbT, 5-25

BCHData
PCCPch data type, 5-14

BER
bit error rate actual value, 5-26
bit error rate error bits, 5-27
bit error rate total bits, 5-27
bit error rate value, 5-26

BETA
DPCCH signaling value, 5-19
DPDCH signaling value, 5-23

BLER
block error rate actual value, 5-27
block error rate total value, 5-28
block error rate value, 5-28
block error rate value setup, 5-27

BLKSize
downlink block size value, 5-6
uplink block size value, 5-28

BPFRame
DCH bits per frame, 5-6, 5-16

BRATe
DCH bits rate, 5-6

CCODe
DPCCH Channel Code, 5-18
DPDCH Channel Code, 5-22

CCode
DPCH Channel Code, 5-8
OCNS Channel Code, 5-13
P-CCPCH Channel Code, 5-15
PICH Channel Code, 5-15

CHANnel
downlink filter optimization, 5-13
uplink filter optimization, 5-26

CODE
downlink DCH encoder type, 5-6
uplink DCH encoder type, 5-29

CRATe
downlink chip rate, 5-4
uplink chip rate, 5-24

CRC
downlink DCH cyclic redundancy check, 5-6
uplink DCH cyclic redundancy code, 5-29

DATA
downlink DCH data pattern, 5-7
DPCH data pattern, 5-9
DPDCH data pattern, 5-23
OCNS data pattern, 5-13
PICH data pattern, 5-16
uplink DCH data pattern, 5-29

EINSert
DCH error insertion mode, 5-30

SCPI commands (Continued)
FILTer

downlink filter type, 5-12
uplink filter type, 5-25

FIX
DPCCH 10-bit data pattern, 5-20
DPCCh 30-bit feedback information, 5-19

FIX4
downlink DCH 4-bit data pattern, 5-7
DPCCH 4-bit data pattern, 5-21
DPCH 4-bit data pattern, 5-9
DPDCH 4-bit data pattern, 5-23
P-CCPCH 4-bit data pattern, 5-15
PICH 4-bit data pattern, 5-16
uplink DCH 4-bit data pattern, 5-29

INTerval
uplink frame clock interval, 5-32

LINK
link down up, 5-3

NBLock
DCH number of blocks, 5-30

NBLocks
DCH number of blocks, 5-7

NSTeps
DPCCH TPC number of steps, 5-21

NUMSteps
DPCH TPC pattern steps, 5-11

PADJust
code domain power adjustment, 5-31

PATTern
DPCCH TFCI pattern, 5-20
DPCCH TPC pattern, 5-21
DPCH TPC pattern, 5-11
FBI pattern, 5-19

POLarity
phase polarity, 5-3
uplink frame clock polarity, 5-32
uplink system frame number reset polarity, 5-32
uplink TPC pattern trigger polarity, 5-22

POWer
CPICH power, 5-5
DPCCH power, 5-18
DPCH power, 5-9
DPDCH power, 5-22
OCNS power, 5-13
P-CCPCH power, 5-15
PICH power, 5-16
PSCH power, 5-17
SSCH power, 5-17

PPERcentage
DCH puncture percentage, 5-7

PPOWer
IQ percent power query, 5-2

PPPaired
IQ percent power paired, 5-2

PSCH Setup, 5-17
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SCPI commands (Continued)
RATE

DPCCH symbol rate, 5-20
DPDCH symbol rate, 5-24

RCSetup
downlink reference measurement channel, 5-5

RMATch
downlink DCH rate matching attribute, 5-7
uplink DCH rate matching attribute, 5-30

RMCHannel
uplink reference measurement channel, 5-31

SCALe
IQ voltage scale, 5-3

SCRamblecode
downlink scramble code, 5-5
uplink scramble code, 5-26

SDELay
slot delay, 5-32

SLOTformat
DPCCH slot format, 5-20
DPCH slot format, 5-10
DPDCH slot format, 5-24

SRATe
DPCH Symbol Rate, 5-10
OCNS Symbol Rate, 5-14

SSCH State, 5-17
SSCodeos

DPCH Secondary Scrambling Code Offset, 5-10
OCNS Secondary Scrambling Code Offset, 5-14

SSGRoup
SSCH Secondary Scramble Code Group, 5-17

STATe
CPICH state on off, 5-5
downlink DCH state on off, 5-8
DPCCH FBI query state, 5-19
DPCCH state on off, 5-18
DPCCH TPC pattern trigger state on off, 5-22
DPCH on off state, 5-10
DPDCH state on off, 5-22
OCNS state on off, 5-14
P-CCPCH state on off, 5-15
PICH state on off, 5-16
PSCH state on off, 5-17
SSCH state on off, 5-17
uplink DCH state on off, 5-28
W-CDMA state on off, 5-4

SYNC
synchronization channel, 5-33

TFCI
DPCCH TFCI query state, 5-21
DPCH transport format combination indicator 

pattern, 5-11
TOFFset

downlink timing offset, 5-11
uplink timing offset, 5-33

SCPI commands (Continued)
TTI

downlink DCH transmission time interval, 5-8
uplink DCH transmission time interval, 5-30

TVOLtage
IQ total voltage query, 5-3

TVPaired
IQ voltage paired, 5-3

scramble code
calculating, 4-25
primary, 4-25
scramble offset, 4-25
scramble type, 4-25
secondary, 4-25

scramble offset, 4-25
Scrambling Code data field, 3-59
secondary scramble code, 4-25
SecScr Code OS data field, 3-59
Select (Filter) softkey, 3-60
Select File softkey, 3-60
Select Pattern (Up/Down) softkey, 3-60
setup editors

link control, 2-77
selecting data field, 2-76

SFN Polarity Neg Pos softkey, 3-61
Signal Setup softkey, 3-61
single-ESG capability

downlink, 4-20
uplink, 4-27

single-ESG setup
downlink, 4-20
uplink, 4-27

Slot Delay softkey, 3-61
Slot Format data field, 3-62
Softkey Descriptions, 3-1
softkeys

1/2 Conv, 3-3
1/3 Conv, 3-3
10 msec, 3-3
12 kbps (25.101 v3.5), 3-3
144 kbps (25.101 v3.5), 3-4
2 Box Setup, 3-3
20 msec, 3-4
384 kbps (25.101 v3.5), 3-4
40 msec, 3-4
64 kbps (25.101 v3.5), 3-4
80 msec, 3-4
Adjust Code Domain Power, 3-6
All Down, 3-6
All Up, 3-6
AMR 12.2 (25.944 v3.3), 3-7
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softkeys (Continued)
AMR 12.2 kbps, 3-7
APCO 25 C4FM, 3-7
Apply Bit Errors, 3-7
Apply Channel Setup, 3-5, 3-9
BBG Data Clock Ext Int, 3-10
BER, 3-10, 3-14
Beta Int, 3-11
Bit Errors (numeric value), 3-12
BS Setup, 3-15
Channel State Off On, 3-17
Config Transport, 3-18
Copy File, 3-18
CPICH File, 3-18
Create File, 3-19
Define User FIR, 3-20
Delete, 3-21

File, 3-21
Row, 3-21

Delete All Rows, 3-21
Delete Bits, 3-21
Delete To Beginning, 3-21
Delete To End, 3-21
Display FFT, 3-22
Display Impulse Response, 3-23
Down/Up, 3-23
DPCCH, 3-24
DPCH, 3-24
DPDCH, 3-24
Edit File, 3-25
Edit Item, 3-25
Equal Powers, 3-25
Ext Clock Polarity Neg Pos, 3-26
Ext Clock Rate, 3-27
Filter Alpha, 3-29
Filter BbT, 3-30
Filter Symbols, 3-31
FIX, 3-31
FIX4, 3-32
Frame Clock Interval, 3-32
Frame Clock Polarity Neg Pos, 3-33
Gaussian, 3-34
Generate, 3-35
Goto

Bottom Row, 3-35
Middle Row, 3-35
Row, 3-35
Top Row, 3-35

Hamming, 3-36
Hann, 3-36
Insert, 3-37

0’s, 3-37
1’s, 3-37

Insert (Continued)
PN15, 3-38
PN9, 3-37

Insert Row, 3-38
IS-95, 3-39
IS-95 and IS-2000, 3-39
IS-95 Mod, 3-40
IS-95 w/EQ, 3-40
IS-95 w/EQ Mod, 3-40
Kaiser, 3-41
Link Control, 3-42
Link Down Up, 3-42
Load Default FIR, 3-42
Load From Selected File, 3-43
Load/Store, 3-43
Mirror Table, 3-44
NONE, 3-45
None, 3-45
Number of Bits, 3-46
Nyquist, 3-47
Optimize FIR For EVM ACP, 3-48
Oversample Ratio, 3-49
Page Down, 3-50
Page Up, 3-50
P-CCPCH, 3-50
Phase Polarity Normal Invert, 3-50
PhyCH Setup, 3-51
PhyCH Type, 3-51
Physical Channel #, 3-51
PICH, 3-52
PN15, 3-53
PN9, 3-52
PSCH, 3-53
Rectangle, 3-55
Ref Measure Setup, 3-56
Rename, 3-56
Restore Default Filter, 3-56
RMC 12.2 kbps (25.141 v3.4), 3-56
RMC 144 kbps (25.141 v3.4), 3-57
RMC 384 kbps (25.141 v3.4), 3-57
RMC 64 kbps (25.141 v3.4), 3-57
Root Nyquist, 3-58
Scale To 0dB, 3-59
SCPI equivalent commands, 6-1
Select (Filter), 3-60
Select File, 3-60
Select Pattern (Up/Down), 3-60
SFN RST Polarity Neg Pos, 3-61
Signal Setup, 3-61
Slot Delay, 3-61
SSCH, 3-63
Store To File, 3-63
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softkeys (Continued)
Sync Source FClk SFN, 3-64
Sync Trigger Mode Single Cont, 3-65
Timing Offset, 3-67
TPC Pat Trig Off On, 3-68
TPC Pat Trig Polarity Neg Pos, 3-68
Transport CH, 3-68
Transport Channel #, 3-69
TrCH Setup, 3-69
TrCH State Off On, 3-69
Turbo, 3-70
UDI 64 (25.944 v3.0), 3-71
UDI 64 kbps, 3-71
UDI ISDN (25.944 v3.3), 3-71
UN3/4 GSM Gaussian, 3-72
Up/Down, 3-72
Uplink Sync Setup, 3-72
US Setup, 3-71
User File, 3-72
User FIR, 3-73
W-CDMA Off On, 3-75
Window, 3-75

spurious emissions
base station performance test, 2-112
user equipment performance test, 2-74

spurious response
user equipment performance test, 2-57

SSCH softkey, 3-63
Store To File softkey, 3-63
Symbol Rate data field, 3-64
SYMBOL SYNC OUT signal description

downlink, 4-23
uplink, 4-29

SYMBOL SYNC signal description
downlink, 4-23

Sync Source FClk SFN softkey, 3-64
Sync Trigger Mode Single Cont softkey, 3-65
system functionality, 4-21

T
table editors

BTS, 2-3, 2-10
link control, 2-77
selecting data field, 2-76

tests
algorithm decoding, 2-115
receiver, using one ESG, 2-76

TFCI Pattern data field, 3-66
TFCI State data field, 3-66
theory of operation, 4-1

Time Offset data field, 3-66
timing diagram for uplink I/O connectors, 4-29
Timing Offset softkey, 3-67
Total Bits data field, 3-67
Total Blocks data field, 3-67
TPC Pat Steps data field, 3-67
TPC Pat Trig Off On softkey, 3-68
TPC Pattern data field, 3-68
TPC Trig Polarity Neg Pos softkey, 3-68
Tr Position data field, 3-70
Transport CH softkey, 3-68
Transport Channel # softkey, 3-69
TrCH Setup softkey, 3-69
TrCH State Off On softkey, 3-69
troubleshooting, 2-115
TTI data field, 3-70
Turbo softkey, 3-70
two-ESG capability, downlink, 4-21
two-ESG setup, 4-21

system functionality, 4-21

U
UDI 64 (25.944 v3.0) softkey, 3-71
UDI 64 kbps softkey, 3-71
UDI ISDN (25.944 v3.3) softkey, 3-71
UE Setup, 5-24
UN3/4 GSM Gaussian softkey, 3-72
Up/Down softkey, 3-72
uplink

DPCCH frame structure, 4-5
DPDCH frame structure, 4-5

uplink DPCCH and DPDCH coding, 1-5
Uplink SCPI commands, 5-18
Uplink Setup, 5-31
Uplink Sync Setup softkey, 3-72
Uplink Synchronization Setup, 5-32
US Setup

softkey, 3-71
user file limitations, 4-6
User File softkey, 3-72
User FIR softkey, 3-73

V
Voltage Other ESG data field, 3-74
Voltage This ESG data field, 3-74
Index I-9
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W
W-CDMA Off On softkey, 3-75
Window

Hamming, 3-36
Hann, 3-36
Kaiser, 3-41
None, 3-45

Window softkey, 3-75
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