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1 Scope and purpose 
User manual for VDR Explorer 
 
 

1.1 References 
 

1.2 Terms and Abbreviations  
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2 System overview 
The VDR Explorer is an application designed for W2000 or XP. The VDR Explorer is able to 
replay data recorded by a DM300 S-VDR and DM500 VDR. The VDR Explorer can read data from 
the following sources: 
 
 
Source  Hardware required 
Capsule Data from the capsule that has 

been removed from the VDR 
- A PC with Firewire port. 
- Firewire repeater with CAT 5 
interface 
-  A mains to 12V DC adapter 
for the repeater is needed if a 
portable PC with 4-pin i/f is 
used 

Backup disc Data from a backup disc that 
has been removed from the 
VDR (Note 1) or data created by 
the VDR explore backup 
application. 

- A stationary PC with a 6-pin 
Firewire port. 
- A Firewire repeater and a 
mains to 12V adapter is needed 
when a portable PC with a 4-pin 
Firewire port is used  

VDR Extraction A file with VDR data 
downloaded from the VDR, 
capsule or a backup disc. It may 
also be a selection of data from 
another extraction  

 

Live Data transferred live from the 
VDR while recording. 

PC with an Ethernet port 
(10/100baseT) 

Note 1) Data can be retrieved from a functional VDR with the backup disc in place by means of the 
web extractor facility and a PC with an Internet browser/Ethernet port. This is the simplest way of 
getting access to the VDR data. 
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2.1 Connecting the PC with a capsule or disc 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Stationary 
PC 

Crossed CAT5 
RJ45 – RJ45 
Note 2

Firewire 
cable 
6pin - 6pin FW repeater 

CAT5 
P/N 1001162 

Note 2) if the original cable is attached to the capsule, then use a straight CAT5 cable and a RJ45 coupler. 

Firewire 
cable 
4pin - 6pin 

FW repeater 
CAT5 
P/N 1001162 

12VDC 

Portable 
PC 

Crossed CAT5 
RJ45 – RJ45 
Note 2

Mains 
adaptor 
P/N 1001163

 110-240VAC 

Note 2) if the original cable is attached to the capsule, then use a straight CAT5 cable and a RJ45 coupler. 

Stationary 
PC 

Firewire 
cable 
6pin - 6pin Backup disc 

Note) if the PC is unable to power the disc then use a repeater with a mains adaptor, see below. 

Firewire 
cable 
4pin - 6pin 

FW repeater 
CAT5  
P/N 1001162 

12VDC 

Portable 
PC 

Firewire 
cable 
6pin - 6pin

Backup disc 

 110-240VAC 
Mains 
adaptor 
P/N 1001163
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3 GUI description 
 

3.1 After startup 
The VDR Explorer will upon startup use the default configuration (DefaultGuiConfig.xml) 
 
 
 
 
 

Player status bar 

VDR Explorer window, dropdown menus (MS windows style) 
Tool bar

Tab pages 

Player control area 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The “window title bar” complies with the general standard for Microsoft GUI. The window title bar 
will display the name (if defined) of the current GUI configuration. 
 
 
VDR Explorer window dropdown menus: 
 
File->New: Creates a new (empty) VDR Explorer configuration 
 
File->Open: Opens an existing VDR Explorer configuration 
 
File->Save: Saves the current VDR Explorer configuration using the same name 
 
File->Save as: Save the current VDR Explorer configuration using a new name 
 
File->Recent files: Short cuts to the 4 most recent configurations, which have been opened or 
saved on the disc. The configuration, which has been temporary downloaded e.g. from a VDR while 
playing live will not be included on the list. 
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File->Exit: Exits the VDR Explorer program 
 
Tools->Log: Displays the log for the VDR Explorer program. This is only used for troubleshooting. 
 
Tools->Audio: Opens the audio settings dialog box 
 
Tools->Connect: Opens the “connect” dialog box. The “connect” dialog box is used to select a data 
source for the VDR Explorer see section 7. 
 
Tools->Disconnect: Disconnects the VDR Explorer from the data source. 
 
Tools->VDR config management: The VDR Explorer is able to use some of the information 
stored in a VDR for object labels see section 6.1 
 
Tools->VDR Explorer config management: The VDR Explorer is able to store its configuration 
together with source data and later retrieve this information see section 6.2 
 
Tools->Decoder library: Opens the NMEA decoder library, see section 8. 
 
Tools->Extractor: Opens the Extractor dialog box, see section 9.  
 
Tools->Export audio as wave 
 
Tools->Options: Opens the options and settings dialog box. 
 
Mode->Configuration mode on: Sets the VDR Explorer in configuration mode. 
 
Mode->Configuration mode off: Exits the VDR Explorer from configuration mode. 
 
Monitor:  Queue monitor used for troubleshooting only. 

3.1.1 Tool bar 
The tool bar contains short cuts (presented as icons) to the most common tools and functions. 

3.1.2 VDR Explorer status bar 
The VDR Explorer status bar contains information regarding the current status of the VDR 
Explorer. Additional information regarding an object selected by the cursor (“on hover”) may be 
displayed to the left. 
 

3.1.3 VDR Explorer play control area 
The VDR Explorer play control area contains the main controls i.e. play, stop and pause. Some of 
the controls will be grayed out depending on the data source for the VDR Explorer. See also section 
4.1.1 
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4 Replay of data, short guide 
 
The VDR Explorer will automatically display the “Connect” dialog box when the program is 
started. This dialog is used for selecting a data source. 
 

 
 
To select a data source press “Connect”, consult section 7 for more details. 
 
 

 
 
It is highly recommended that a VDR explorer configuration that matches the VDR data is uploaded 
to the VDR when the VDR is installed, since this will enable any PC with the VDR Explorer 
installed to replay data without any configuration work. If this dialog box appears then answer, 
“Yes”. 
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4.1.1 Play control 
The play control area contains the functions needed for replaying data. Two views are available, 
simple and advanced. 
 

 
Click here to expand play control 

Simple play control 
 

 
Advanced play control 
 
A tool tip with helpful information will appear if the cursor hovers over a bottom for short period. 
Note) The tool tip is not available for disabled functions (buttons with symbols). 
 

4.1.2 Tracks 
A track is defined as an uninterrupted recording session. The VDR will create a new track if it is 
restarted. VDR data retrieved from a normally operating VDR will only contain one track.  
 

4.1.2.1 Goto button 
The “Goto” button will, if activated, set the slider to the position indicated in the input field below 
the button. A new value may be entered into the input field. The field will become red if the entered 
value is illegal or out of range. The icon left to the “Goto” button may be used to update the input 
field with the current position of the slider. This function may be used while the VDR Explorer is 
playing data. If you want to set a “mark” at an event you want to revert to, do the following. First 
click on the icon (left to the “Goto” button) to set the “mark”, later click on the Goto button and 
then “Play”. 
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5 Configuration 
The VDR Explorer must be in confirmation mode “Mode->Configuration Mode - 

On” before any change of configuration can be made. 

5.1 Creating a new configuration 
File->New 
Will create a new “empty” configuration. 
 
File->Open 
Is used to open an existing configuration e.g. a template. Use “File-Save as” to store the new 
configuration under another name. 
 

5.2 Adding new tab pages 
Right click on a tab for and existing page and then click on “Tab properties” and the “Tab page 
organizer will appear. 
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5.2.1 Tab page organizer 
 

 
The Tab page organizer 
 
The “Tab page organizer” is a tool for creating, deleting, hiding, naming and sorting of the tab 
pages. 
 
Click on “Add” and this menu will appear 
 

 
 
Type in the title for the new tab page and select a template from the list box. To start with add 
“VDR serial status tab” and a “VDR status tab”.  After that add the pre configured conning display. 
It matches the S-VDR recommended standard setup. “Appendix A S-VDR conning display default 
configuration” shows the configuration for this page. 
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5.3 Creating and moving graphical objects 
The graphical objects on a tab page are organized in panels (columns). A graphical object often 
contains many elements hereafter called gauges. 
 
A proper tab page must be created before any graphical object can be created. Templates with one 
to four panels and one example have been made. (Right click on any tab for a tab page and then 
select ”Tab properties” opens the ”Tab Page Organizer” see section 5.2.  
 
A new graphical object is created on a panel by right clicking on a panel and then “Insert Object”.  
More objects within a panel will from a column. 
 
The position of an object within a panel may be changed i.e. the object may be moved up and down. 
 
Right click on the object and then click on “Object…-> Move up” or “Object…->Move down” 
 
A graphical object cannot be moved to another panel i.e. to the left or to the right. However there is 
a way around this limitation. 
 

1. Create a new instance of the object that has to be moved on the desired location. 
2. Copy the configuration from the original object and paste it onto the new object (see section 

5.4.1). 
3. Delete the original object. 

5.3.1 Creating and moving panels 
Right clicking on an existing panel and then select ”Insert panel” will create additional panels. More 
features for manipulating panels are found by right clicking on an existing panel and then selecting 
“Panel Properties”  

5.4  Configuration of graphical objects 
A graphical object contains one or more gauges for displaying data. The only exceptions are the 
“Numeric data display”, which contains 3 “objects” for displaying data in numerical form or as text 
and the Paper strip object that is able to display serial data as text. 
 
The following graphical objects have been defined (consult section 15 regarding objects related to 
AIS data display): 

• Dial meter 
• Dual dial meter 
• Four Vertical bars 
• Two Horizontal bars 
• Compass dial 
• Horizontal ruler 
• Doppler log indicator 
• Dual Rudder indicator 
• Graph 
• Roll and Pitch indicator 
• Numeric data display 
• Small numeric data display 
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• Paper strip 
 
Right clicking on the object while the VDR Explorer is set into configuration mode opens the 
property dialog box for a graphical object. 
 
The first tap page called “General” contains the 
most common parameters for a graphical object. 
This page is slightly different for the “Numeric 
data display” see section 5.6. 
 
Title: Text that is common for the gauges 
displayed by the graphical object. 
 
Gauges: Checkboxes for enabling/disabling the 
display of gauges defined for that graphical object.  
 
Frame: The boundary of a graphical object is 
indicated (default) with four thin lines. A number 
of graphical objects may be grouped by removing 
the adjacent lines. This is purely a visual effect. A 
line may be disabled /enabled by double clinking 
on its position on the squared symbol located in 
this section. 
 
Source labels: (dial meter graphical object only):  
The label for the fields that displays the data in 
numeric form 
 
The remaining tab pages are used for configuring 
the gauges defined for the graphical object.  
 

5.4.1 Copy/past of graphical object configuration 
The configuration from a graphical object may be copied and pasted onto another identical 
graphical object. 
 
Copy configuration: 
Right click on the object with the desired configuration, and then click on “Copy Config”. 
 
Paste Configuration: 
Right click on the object that needs a new configuration, and then click on “Paste Configuration” 
The receiving graphical object must be identical to the original. 
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5.5 Configuration of Gauges 

5.5.1 Dial meter 
 

5.5.1.1 Labels 
Dial Title: Text located immediately over the dial 
meter. 
 
Unit: Text located inside the dial. 
 
Use peak indicator: 
The peak indicator will show the maximum 
reading for a specified time (peak timeout). This is 
useful e.g. when measuring wind speed. 

5.5.1.2 Scale  
This section contain the parameters for controlling 
the geometry and resolution of the dial 
Start value: The start value corresponds to the 
most counterclockwise point on the dial. 

 Page 18/73 
 

ost End value: The end value corresponds to the m
clockwise point on the dial. 
 
Format:  
Format is used to define the format of the figures 
on the dial, see section 5.8.3.2. 
 
Show mathematical sign: 
The parameter controls whether figures on the dial 
are displayed signed or unsigned. 
 
Angle: 
Defines the extent of the dial. 
 
Rotation: 
The dial will per default be oriented like a typical 
speedometer in a car i.e. the axis of symmetry is 
vertical. The operator may change the orientation 
by entering a value other than 0 in this field. 
 
Resolution: 
This parameters control the graduation of the dial. 
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5.5.1.3 Sources  
Primary: Input to the pointer for the dial meter.  
Secondary:  Input to the secondary indicator for the dial meter. The secondary indicator is shown 
as a small triangle. The secondary indicator is typical used for displaying the “commanded value” 
while the main indicator shows the actual value. 
 
The “setup” button will open a dial box where the source data can be defined, see section 5.8 

5.5.1.4 Colors 
Parameters in this section control the appearance of the dial meter. The “set default” may be used to 
reset all the colors to the default settings (see section 5.9) 
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5.5.2 Vertical bar 

5.5.2.1 Labels 
A vertical bar has two labels one at each end. One 
of them is typically used as description while the 
other indicates units. 
 

5.5.2.2 Scale 
Start value: 
The start value corresponds to the bottom of the 
bar. 
 
End value: 
The end value corresponds to the top of the bar. 
 
Mirror horizontally: 
Two adjacent bars are per default two symmetrical 
instances i.e. bar 1,2 and 3,4 form two pairs. The 
operator may change this by “horizontally mirror” 
bar objects with odd number. 
 
Format:  
Format is used to define the format of the figures 
for the bar object, see section 5.8.3.2. 
 
Show mathematical sign: 
The parameter controls whether figures related to 
the bar object are displayed signed or unsigned. 
 

5.5.2.3 Sources 
Primary: Input to the main indicator for the bar 
object.  
Secondary:  Input to the secondary indicator for 
the bar object. The secondary indicator is shown 
as a small triangle. The secondary indicator is 
typically used for displaying the “commanded value” while the bar shows the actual value 
 

5.5.2.4 Colors 
Parameters in this section control the appearance of the bar object. The “set default” may be used to 
reset all the colors to the default settings (see section 5.9) 
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5.5.3 Horizontal bar 
The parameters for the horizontal bar correspond t
the parameters for the vertical bar. An extra lab
(middle) has been added. 

o 
el 
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5.5.4 Compass dial 

5.5.4.1 Scale 
Format: 
Format is used to define the format of the figures 
on the compass dial, see section 5.8.3.2. 
 

5.5.4.2 Sources 
Primary: 
The primary data source controls the rotation of 
the compass dial, the typical input is “Heading”. 
 
Secondary: 
The secondary (optional) data source controls a 
small triangle circling the compass dial. The 
typical secondary input is “Commanded H
  

eading”. 

5.5.4.3 Colors 
this section control the 

efault” 
The parameters in 
appearance of the compass dial. The “set d
button can be used to reset all the colors to the 
fault settings (see section 5.9) 
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5.5.5 Horizontal ruler 

5.5.5.1 Labels 
A vertical bar has 6 labels.  

5.5.5.2 Scale 
Star value: 
The start value corresponds to the far left point of 
the ruler. 
 
End value: 
The end value corresponds to the far right point of 
the ruler. 
 
Format:  
Format is used to define the format of the figures 
on the ruler object, see section 5.8.3.2. 
 
Show mathematical sign: 
The parameter controls whether the figures related 
to the ruler object are displayed signed or 
unsigned. 
 

5.5.5.3 Sources 
Primary: 
Input to the primary indicator for the bar object. 
The main indicator is shown as a triangle above 
the ruler. 
 
Secondary:  
Input to the secondary indicator for the bar object. The secondary indicator is shown as a triangle 
below the ruler. The secondary indicator is typically used for displaying the “commanded value” 
while the primary indicator shows the actual value 
 

5.5.5.4 Colors 
Parameters in this section control the appearance of the ruler object. The “set default” can be used 
to reset all the colors to the default settings (see section 5.9) 
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5.5.6 Doppler log 

5.5.6.1 Numeric Output 
Unit: 
Text displayed after numeric outputs e.g. KNT. 
 
Format:  
Format is used to define the format of the numeric 
outputs, see section 5.8.3.2. 
 
Show mathematical sign: 
The parameter controls whether the numeric 
outputs are displayed signed or unsigned. 
 

5.5.6.2 Sources 
4 inputs may be applied to the Doppler log object. 
 
Longitudinal speed: 
Is shown as numeric data in the center of the 
object 
 
Stern transverse speed:  
Is shown as numeric data at top of the object. 
 
Aft transverse speed: 
Is shown as numeric data at bottom of the object. 
 
Relative wind direction: 
Is shown as a triangle circling the center of the 
object. 
 

5.5.6.3 Colors 
Parameters in this section control the appearance 
of the object. The “set default” can be used to r
all the colors to the default settings (see sectio
5.9) 

eset 
n 
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5.5.7 Rudder indicator 

5.5.7.1 Labels 
Title: 
Text shown beneath the rudder indicator. 
 

5.5.7.2 Scale 
Rudder Max Angle:  
This parameter controls the extent of the dial for 
the object.  It is recommended that a value equal 
to the maximum rudder angle for the vessel is 
used. 
 
Show Mathematical Sign: 
The parameter controls whether figures on the dial 
are displayed signed or unsigned. 
 

5.5.7.3 Sources 
Primary: 
The primary data source controls the pointer; the 
typical input is data from the rudder angle sensor. 
 
Secondary: 
The secondary (optional) data source controls a 
small triangle circling the dial. The typical 
secondary input is “Commanded rudder angle”. 
 

5.5.7.4 Colors 
Parameters in this section control the appearance of the object. The “set default” can be used to 
reset all the colors to the default settings (see section 5.9) 
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5.5.8 Graph 

5.5.8.1 Graph type 
This section is used for defining the input to the X-
coordinate for the graph object. 
 
Time/Y graphs: 
The primary and secondary will be used as Y-
coordinate for two independent graphs. The time 
will be used as X-coordinate for both graphs. 
 
X/Y graph: The primary input will be used for the 
X-coordinate and the secondary for the Y-
coordinate. 
 

5.5.8.2 Resolution 
This section is used for defining the resolution of 
the graph(s). Small values for “Time Span” and 
“Sample Interval” derive a graph with high 
resolution while high values derive a graph that 
covers a large time span. 

5.5.8.3 Labels 
Label: 
Labels for numeric output. 
 
Unit: 
Text displayed after numeric output and Y-axis, 
X-axis if X/Y graph is selected. 

5.5.8.4 Scale 
This section is used for defining resolution and 
format of figures for the Y-axis and the X-axis if 
X/Y graph is selected. 
  

5.5.8.5 Colors 
Parameters in this section control the colors of the 
graph. The “set default” can be used to reset all t
colors to the default settings (see section 5.9) 

he 
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5.5.9 Roll and pitch indicator 

5.5.9.1 Gauge 
Title: 
Text shown above the gauge. 
 
Type: 
Used to select the gauge type (roll or pitch). Roll is 
default for gauge 1 and pitch is default for gauge 2 

5.5.9.2 Scale 
Format:  
Format is used to define the format of the numeric 
outputs, see section 5.8.3.2. 
 
Show Mathematical Sign: 
The parameter controls whether the figures on the 
dial are displayed signed or unsigned. 
 

5.5.9.3 Source 
Primary: 
The data source controls the rotation of the ship 
shaped indicator in the middle of the gauge; the 
typical input is data from the roll and pith sensor 
respectively. 
 

5.5.9.4 Colors 
Parameters in this section control the appearance 
of the object. The “set default” can be used to r
all the colors to the default settings (see sectio
5.9) 

eset 
n 
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5.6 Numeric data display 

5.6.1 General 
The Numeric Data Display does not display any 
gauges. Three smaller “objects” for displaying 
numeric data or text are displayed instead. These 
smaller objects are called “Alphanumeric data 
fields. 

5.6.2 Colors 
The color of the label text for a “Graphical 
Standard Object” is determined by the default 
color definition (Text/Outline Color) see section 
5.9. The “Primary indicator color” is used as the 
default for the displayed data but may be changed 
by the operator. 

5.6.3 Concatenation 
A number of Numeric Data Displays may be 
concatenated by removing adjacent lines (see 
section 5.4). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

9200294 V1.2  Page 28/73 
 



User manual for VDR Explorer 
Danelec Electronics A/S 

 

5.7 Paper strip 
The Paper strip object is designed to display serial 
data as text e.g. data that is sent to a line printer. It 
can also be used to monitor NMEA data. 
 

5.7.1 Data format 
The object is able to display data using three 
different formats: 

• ASCII 
• NMEA 
• Binary. Binary is displayed as 

“hexadecimal” 
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5.8 Configuration of data sources for objects 
This dialog box is common for all gauges and for the alphanumeric data display with few 
exceptions. This dialog is opened by clicking on the “Setup” button located in the “Source” section 
on the property pages for an object. 
 

    
 

5.8.1 Source 
The source section is used to select the proper source for the gauge. A gauge/data field may be 
disabled by selecting “No Source” i.e. no other parameters will be forgotten if already configured. 
 

5.8.2 Use Factor (gauge only) 
The operator may apply a factor (multiplier) to the original data. E.g. knots may be converted to 
m/s. 
 

5.8.2.1 Add to log (alphanumeric data field only) 
The information displayed in the data field will also be added to the log if this box is checked (see 
section 12). 
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5.8.3 Settings for analog data (alphanumeric data field only) 
 

5.8.3.1 Heading and trailing text: 
Heading and trailing text may be configured to 
change according to the numbering value for 
data.  

5.8.3.2 Formatter string 
See section 5.10. 

5.8.3.3 Test data format 
A “test utility” is located beneath the 
configuration fields. 
 
 

 

5.8.4 Settings for digital data 
 

    

5.8.4.1 Use alternative values (gauge only) 
Used to define alternative numeric values for active and inactive state, default (if box is unchecked) 
is 1 and 0. 
 

5.8.4.2 Use text from VDR configuration 
These parameters are used to define what text is associated to active and inactive state e.g. “Open” 
and “Closed”. This information is normally available from the VDR configuration and can be used 
by the VDR Explorer as it is.  
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5.8.5 Setting for serial data 

5.8.5.1 Decoding section 
Contains information about the currently 
selected decoder script: 
 
Edit: will open the decoder script editor. 
The editor is used for creating a new 
decoder script or for editing the currently 
selected one. A “*” after the name denotes 
that the decoder has been edited but not 
stored in the library yet. But it is strongly 
recommended that an edited decoder 
always be given a new name and that 
modification is described! 
 
Edit: Will open the decoder editor, see 
section 8.3. 
 
Save in library:  
Used to save the decoder script in the library if it has been changed. Se section 5.8.6 
 
Library: 
Will open the decoder script library from where the most commonly used decoder scripts can be 
selected see section 8. 
 
Use checksum: 
NMEA strings not containing correct checksum information will be ignored if this box is checked. 
 
Use timeout: 
The appearance of gauge/data field will be affected when no new data is resolved within a specified 
time if this box is checked 
 
- For gauges 
The indicator will disappear. 
 
- For alphanumeric data field: 
An additional menu “Action” is displayed for an alphanumeric data field. 
The operator may chose between: 

• Delete data: The data field is blanked 
• Dimming: Dimming of the text in the data field 
• Timeout: “Timeout” will displayed in the data field 
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5.8.6 Relation between decoders stored in the library and the configuration 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Decoder Library 
Decoder #1 

Decoder #3 

Decoder #n 

Decoder #4 

Decoder #2 
Gauge #1: 

Copy of 
Decoder #3

Gauge #2: 
Copy of 
Decoder #2

Gauge #3: 3 

. 

. 

. 

. 

. 

. 
New decoder 

Edited copy of 
Decoder #4 

5a 

4 

2 

1 

VDR Explorer 
Configuration 

Step 1) Decoder #2 is selected for Gauge #1 
Step 2) Decoder #3 is selected for Gauge #2 
Step 3) Decoder #4 is selected for Gauge #3 
Step 4) the decoder for gauge #3 is modified for some reason.  
The operator now has two options: 
Step 5a) Store the new decoder under a new name in the library i.e. use the “Save library” function 
see section 5.8.5.1.  
Step 5b) leave at it is i.e. a new decoder is created but is not stored in the library.  
This message will appear if the operator tries to replace a decoder that is not stored in the library  
 

 
 

5.8.7 Alarm settings 
Parameters relevant for the alarm display see section 13 
 

 

9200294 V1.2  Page 33/73 
 



User manual for VDR Explorer 
Danelec Electronics A/S 

 

5.9  Default color definition 
 

 
 
The global colors define the over all color-scheme used for the graphical data display(s). 

• The background color is the color of the window used for a graphical data display. The 
background color will be visible because there is a small space between objects (unless they 
are merged). 

• The Object Frame Color indicates the border of an object. 
• Object background Color is background color used for objects. 
• “Text/outline color” is color for static text (e.g. labels) and for outline of most gauges. 

 
Changes to Global color take affect immediately after “OK” or “Apply” is selected even when the 
VDR Explorer is not in configuration mode. 
 
The default colors are the colors of dynamic elements in a graphical data display e.g. the indicator 
for a dial meter. Changes to default colors will only take affect for new objects. The colors for an 
existing object may be set to new default colors by right clicking on the object (in configurations 
mode) and select Object->Set to Default Colors. 
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5.10  Formatter syntax 
Figures displayed in an alphanumeric data field may be formatted, i.e. the number of digit after the 
decimal point and leading zeroes may be defined.  
 
The formatter syntax is identical to the syntax defined for formatting output from a NMEA decoder. 
 
E.g.: The figures 7.5 and 10 will be displayed like this depending on the formatter. 
 
Formatter 7.5 10 
0 7 10 
0.0 7.5 10.0 
000 007 010 
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6 VDR and VDR Explorer configuration management 
The VDR Explorer will use information from both the VDR configuration (if available) and a VDR 
Explorer configuration. The VDR configuration contains useful information about what is 
connected to the VDR. Information from the VDR configuration may enable the VDR Explorer to 
e.g. use the name “SI02 Input from GPS” for serial input port #2 rather than just the default name“ 
SI02”.  
These functions are normally not needed except for “Tools->VDR Explorer config management-> 
Save VDR Explorer-configuration to source”. This function is used for storing the final VDR 
Explorer configurations in the capsule. This will enable any PC with the VDR Explorer installed to 
replay data from that VDR correctly.   

6.1 VDR configuration management 
Tools->VDR config management->Load VDR configuration from file 
Facilitates load of a alternative VDR configuration from a file. 
 
Tools->VDR config management->Load VDR configuration from source 
Reloads the original VDR configuration from the source. 
 
Tools->VDR config management->Set VDR configuration to default 
Restores the VDR configuration to default i.e. all labels will hereafter correspond to what is printed 
on the data interface modules e.g. “SI02”. 
 
Tools->VDR config management->Save VDR configuration from source to file  
Saves VDR configuration present on the source to a file. 
 
Tools->VDR config management->Display VDR configuration from source 
Displays the VDR configuration found at the source to which to VDR Explorer is currently 
connected. 

6.2 VDR Explorer configuration management 
A few special commands related to VDR Explorer configuration management are included here. 
Commonly used commands like Open, Save etc. are included in the “File” dropdown menu. 
 
Tools->VDR Explorer config management-> Load VDR Explorer-configuration from source 
Tool for reloading of a VDR Explorer configuration from the data source 
1) VDR (live playing): The configuration stored in the capsule will be loaded. 
2) Capsule/backup disc: The configuration stored in the capsule/on the backup disc will be loaded. 
3) Extracted data: A dialog box will enable the user to load the original or the user defined 
configuration.  
 
Tools->VDR Explorer config management-> Save VDR Explorer-configuration to source 
Tool for saving the VDR Explorer configuration at the data source. 
1) VDR (live playing): The current VDR Explorer configuration is stored in the capsule and on the 
backup disc via the VDR. The VDR Explorer must be connected as “Master”. 
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2) Capsule/backup disc: The VDR Explorer is not able to write to a capsule/backup disc and is 
consequently not able to save the VDR Explorer configuration at the source if data source is a 
capsule/backup disc 
 
3) Extracted data: The operator may store a “user defined” configuration together with the extracted 
data. The original VDR Explorer configuration (if present) will not be overwritten.  
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7 Connect dialog box  
Tools->connect will open the connect dialog box. 
 

 
 
The connect dialog box is used for connecting the VDR Explorer to a data source. Five types of 
data sources are supported: 
 

• A capsule 
• A backup disc 
• VDR extraction 
• Live from a VDR  

 
The connect dialog box will change according to the selected type of data source.  
 

7.1 Capsule 
“Capsules online” window: 
The “Capsules online” window displays a small symbol for each capsule, physically connected to 
the VDR Explorer PC via the Firewire interface. A capsule is selected by left clicking on its 
symbol. (Note: It is unusual to connect more the one capsule, but up to three capsules may be 
connected simultaneous if needed) 
 
“Refresh” button: 
Forces the VDR Explorer to scan the Firewire for capsules and update the window.  
 
“Analyze” button and “track information” window: 
The selected capsule may be analyzed for its content. The result is displayed in the “track 
information window”. For more information about tracks consult section 9.1.1 
 
“Connect” button: 
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Establishes a connection from the VDR Explorer software to the selected capsule. This may take a 
few seconds.  
 
“Cancel” 
Closes the window. 

7.2 Backup  
Two kinds of backup discs are recognized: 
- A disc that has been removed from a VDR 
- Disc with data made by the VDR Remote backup utility (large backup) 
 
The dialog for connecting a Backup Disc corresponds to the dialog for connecting a capsule, 
described in section 7.1. 
 

7.3 VDR extraction 
“Browse” button: 
Will open a standard file browser dialog box, which is used to locate and open a file containing a 
VDR extraction (file extension is .vee). 
 
“Analyze” button and “track information” window: 
The selected file may be analyzed for its content. The result is displayed in the “track information 
window”. For more information about tracks consult section 9.1.1. 
 
“Connect” button: 
Connects the VDR Explorer to the selected database.  
 
“Cancel” button: 
Closes the “Connect dialog” window. 
 

7.4 Live 
“Connect to IP” field:  
The IP address of the VDR must be entered here. 
 
“Get information” button: 
Tests the connection to the VDR with the IP address displayed in the “Connect to IP” field. Status 
information from the VDR will (if the tested VDR is online) be displayed in the VDR “Information 
field”.  
 
“Connect” button: 
Connects the VDR Explorer to a VDR with the IP address displayed in the ”Connect to IP” field.  
 
“Cancel” button: 
Closes the “Connect dialog” window. 
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8 Decoder library 
The NMEA decoder library is used to organize the NMEA decoders. A NMEA decoder is a small 
script, which describes how information shall be decoded and retrieved from a specific NMEA 
sentence. The syntax for the script language is described in section 17. A short description is 
available under “Help->Help Topics” in the decoder editor.   
 
Tools->decoder library will open the decoder library. 

 

8.1 Properties for a NMEA decoders 
 
Sentence formatter: 
A NMEA decoder is only able to retrieve information from one specific NMEA sentence. 
A typical NMEA decoder is only able to retrieve information from one field in a NMEA sentence. 
Most NMEA sentences contain many fields, hence a number of decoders may be needed for 
retrieving all the information from one sentence.  
 
Decoder group: 
A NMEA decoder belongs to a group, all decoders in the same group are stored in the same folder.  
Groups have been defined corresponding to the data items to be recorded (IEC 61996 section 4.6) 
e.g. speed (4.6.3) or heading (4.6.4). The user may establish new groups. 
 
Decoder name: 
A decoder must be assigned a name. The name must be unique within the decoder group. 
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(Write) protected decoders: 
A number of standard decoders (protected decoders) have been defined. These decoders are write 
protected and cannot be changed or deleted by the user. However the operator may use one of these 
decoders as a template for a new decoder. 
 
Sub library file:  
The VDR Explorer will at startup “compile” the library from a number of library files each 
containing a number of decoders. The standard decoders are stored in one file and another file is 
used to store the user-defined decoders. More library files for specific purposes may be added. 
 
Decoder output: 
The output from a decoder may behave like analog data, digital data or a text string. This 
information may be described for a decoder. However this information is only informative and will 
not be used by the VDR Explorer.  
 

8.2 NMEA decoder library window 
 

8.2.1 Drop down menus  
File->import: 
Imports decoders from an external file. The imported decoders will be added to the user defined sub 
library file. 
 
File->export: 
Exports decoders to an external file. 
 
File->Save in library:  
Saves decoder in library. 
 
File->Close: 
Closes the window. Corresponds to cancel. 
 
Edit->New decoder: 
Adds a new decoder to the library. 
 
Edit->New folder: 
Adds a new folder to the library.  
 
Edit->Copy: 
Makes a copy of the selected decoder. 
 
Edit->Edit: 
Opens the decoder edit window. 
 
Edit->Rename: 
Renames the selected decoder or folder. 
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Edit->Delete: 
Deletes the selected decoder or folder. 
 
 

8.2.2 Decoder library tree 
The decoder library tree is shown to the left. The “radio buttons” at the top are used to define how 
the library is organized. 
 
A pop up menu will appear if the user right clicks on 
a folder or a decoder. This menu will enable the user 
to add, rename, copy and delete folders and decoders.  
For “Import to Folder” consult section 8.2.1 
Note: It is only possible to create a new “root folder” 
by right clicking on the empty space beneath the 
“library tree”. Pop up for folder Pop up for decoder 
 

8.2.3 Decoder description 
The properties for the selected decoder, are shown in decoder description located to the right in 
NMEA decoder library window consult section 8.1 for more details.. 
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8.3 NMEA Decoder Editor 
The NMEA decoder editor may either be opened from the decoder library or from the settings menu 
for a gauge/alphanumeric data field. 
 

 

8.3.1 Drop down menus 
 
File->Save as: 
Closes the editor window and opens the NMEA decoder library window where the new name and 
folder (group) may be defined. This item is only present if the editor is called from the NMEA 
decoder library. 
 
File->Close: 
Closes the editor window. The user will be prompted for unsaved changes. 
 
Edit->Undo 
Edit->Redo 
Edit->Cut 
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Edit->Copy 
Edit->Paste 
Edit->Delete 
Commands for the Editor 
 
Tools->Insert symbol  
A menu with symbols normally not found on a keyboard will be displayed. 
 
Help->Help topics:  
A description of the decoder script language will be displayed. 

8.3.2 Tool bar 
A tool bar is located below the drop down menus. The tool bar contains short cuts (icons) to the 
most commonly used items from the drop down menus. 
 

8.3.3 General buttons 
 
“OK” button: 
Changes made will be stored,  the editor window is hereafter closed. The previous version of the 
decoder is overwritten. It is not possible to overwrite the decoders that are supplied with the VDR 
Explorer. 
 
“Cancel” button: 
Closes the editor window, any changes made will be ignored and lost. 
 
“Save As” button: 
The editor window will close. Changes made may be saved if the “Save As” button is in the 
decoder library are activated. This will give the operator an opportunity to save the changes using a 
new name/folder while maintaining the previous version of the decoder. 
The save as button is only enabled if the editor is opened from the library (i.e. disabled when 
opened from the GUI configurator).  
 

8.3.4 Decoder information 
 
Decoder name: 
See section 8.1  
 
Decoder output: 
See section 8.1  
 
Decoder description: 
A description of the decoder may be included (recommended). 
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8.3.5 Editor window 
A script defining the decoder shall be entered in the NMEA decoder window. The “sentence 
formatter field” derives information from the “search for” statement in the decoder script. The full 
name for the NMEA sentence will be displayed if the sentence formatter is known. 
 
“Help->Help topics” shows a short description of the script language. Section 17 contains an 
extensive description of the script language. 

8.3.6 Decoder test 
A decoder may be tested against an NMEA sentence if the test decoder button is activated. Two 
things happen when the test button is activated: 

1. The script will be compiled i.e. the syntax is checked. The text in the “NMEA test sentence” 
field will not influence this. The test will only continue if the compilation is successful. 

2. The NMEA decoder will decode the NMEA sentence shown in “NMEA test sentence” field. 
This is of course only meaningful if the NMEA sentence formatter in the test sentence 
matches the NMEA sentence formatter in the decoders search for statement. The data output 
and the trend output will be displayed upon a successful test. 

 

8.3.6.1 “NMEA test sentence” field 
The user may enter a test sentence in this field. Copy/paste from e.g. the serial monitor may be 
used. The 10 most recent test sentences will be saved. 
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9 Extractor 
The Extractor is used to retrieve data from a data source to a database. The VDR Explorer must be 
connected to a date source (not live from a VDR) before the Extractor tool can be opened. 
 

 

9.1.1 Track information 
The track information for the currently selected capsule or backup disc is displayed in this window. 
A track is defined as an uninterrupted recording session. This typical corresponds to a time period 
where the VDR was not interrupted e.g. by a restart. However, other events may divide a recording 
into two tracks e.g. a bad record (checksum error) on the disc. There will only exist one track in the 
capsule or on the backup disc for a VDR system that has been running uninterrupted and faultless 
for more than 13 hours. 
 
One or more tracks must be selected before the extraction process can start. A track is selected by 
right clicking anywhere on the text line for that track (except on the checkbox).  The sliders on the 
blue bar may be used to reduce the amount of data used from the selected track.  
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The check boxes are used for indicating whether a track shall be included or excluded from the 
extraction. Only check marked tracks will be included. 
 
Extraction target: 
Displays the currently selected (if any) extraction target. 
 
“Extract” button: 
Starts the extraction process. 
 
“Close” button: 
Closes the window. 
 
 
Overview for the extraction process step by step: 
 

1. Connect to a capsule or backup disc using the connect tool. 
2. Open the extractor tool. 
3. Select, and optional trim the duration of tracks to be extracted. 
4. Start extraction process using the “Extract” button. 

 
Extracting all data from a capsule will take approximately 20 minutes and require 6G byte of disc 
space. 
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10 Audio Export Tool 
The operator may use the Audio Export Tool for generation of wave files, which for example may 
be analyzed or improved. 
 
The Audio Export Tool is almost identical to the Extractor Tool.  
 
Check boxes for selecting channels have been included. Individual wave files (mono) will be 
generated for each selected audio channel i.e. the audio will not be mixed. Further, tracks will not 
be merged. A naming convention has been defined for the files. 
 
<User selectable text> <Track #> <ch#>.wav 
 
Mapping of “input” to ch# 
VHF 1 ch1 
VHF 2 ch2 
MIC 1/2 ch3 
MIC 3/4 ch4 
MIC 5/6 ch5 
 
e.g.: 
Captains’ voice Track 2 ch2.wav 
Export of password-protected audio is only possible if the password is known. 
 

11 Audio settings tool 
The Audio settings tool contains check boxes for selecting and directing audio channels to the left 
or right speaker. 
 
A master volume is included. 
 
The compression effect is useful when listening to recordings with a high dynamic range 
 

11.1  Password protected audio 
Audio can be password protected and replay of audio disabled. The operator may enable audio 
replay by opening the Audio Settings Tool and enter the correct password. 
 

12 Data Log 
The data log function is able to log data from selected objects into a CSV file. The data log function 
is associated to a special tab page. The data log tab page is established like any other tab page 
 

• The VDR Explorer must be set in configuration mode. 
• Right click on a tab for a tab page and then select “tab properties”, this will open the “tab 

page organizer”. 
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• Click on “add” and select the “Data Logger Tab”. 
 

12.1  Configuration of data log 
Columns may be created by two methods. 
 

12.1.1 Direct creations of columns 
• The VDR Explorer must be in configuration mode. 
• Right click on the title bar for the columns next to “Timestamp”. 

 
 
 

 
 

• Click on “add column” and a list of relevant objects appear. 
 

Continue on next page … 

9200294 V1.2  Page 49/73 
 



User manual for VDR Explorer 
Danelec Electronics A/S 

 

 
 
 

 
• Select an object and click on OK  
 
 

 
• Enter the title press ok and a new column is created. 
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12.1.2 Indirect creations of columns 
 

• The VDR Explorer must be in configuration mode. 
• Open the properties dialog for an object that is able to input data to the data log (short 

standard object and standard object) 
 
 
 

 
 

• Check “Add to log” and a new column is created. 
 
 

 
 

• Change the title if needed. Right click on the title, select “Column Title” and enter a new 
title. 
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12.1.3 Organizing columns 
The VDR Explorer must be (with few exception) in configuration mode. 
 
Right clicking on the title for column will open a menu with miscellaneous commands. 
 
In general the width and order of the column can be changed in the same manner as for many other 
Windows programs e.g. using ”click, drag and drop” on the column title can be used to rearrange 
columns. 
 

12.1.4 Maximum number of columns 
The maximum number of columns that can be handled depends the PC. A PC that meets the general 
requirements for the VDR Explorer will be able to handle 25 columns without any noticeable 
performance degradation. 
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12.2  Saving log data to a file 
The program will store the data to a user defined output file. 
 

 
  
 
 
The library path for the log files is defined by the preferences for the VDR Explorer see section 
12.3 
 

12.2.1 Max file size 
Maximum file size is user defined. Data logging will stop when the file is full. The file may then be 
reset (or renamed/moved using Windows Explore). 
 

12.2.2 Sample interval 
The sample interval is user defined. Fast sampling (small intervals) requires lot of disc space. 
 
 

12.3  Preferences 

12.3.1 Directory path for log files 
The library path for the log files are defined by the preferences for the VDR Explorer (VDR 
Explorer main window, Options->Preferences->Directory settings). 
 

12.3.2 Disable data logging at connect 
Data logging without explicit acknowledge from the operator can be inhibited (VDR Explorer main 
window, Options->Preferences->Advanced). 
 
On: The operator must start data logging manually. 
Off:  Data logging will start automatically if configuration with “data logger enable” is 

loaded. 
Prompt:  (Default) The operator will be prompted before data logging will start.  
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13  Alarm panel 
 
Selecting “Tools->Alarm Panel” or clicking on the  icon on the Player window tool bar will 
activate the alarm window. 
 

 
 
 
Acknowledge all alarms: 
This function will acknowledge all alarms on the list. An alarm may be acknowledged individually 
by clicking on the  icon for that alarm. 
 
Delete all alarms: 
The function will delete all alarms from the list. An alarm may be deleted individually by clicking 
on the  icon for that alarm. 
 
Acknowledge audio: 
This function will mute the audio until a new alarm is generated. 
 
Options->Disable sound:  
This option will mute the audio related to the alarms panel completely. 
 
Options->Disable popup: 
This option will prevent the alarm window from popping up when a new alarm is generated. 
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13.1.1 Easy localization of alarms source 
Double clicking on the text for an alarm will bring the tab page from where the alarm is generated 
to the front. The object that has generated the alarm will flash red for a few seconds. 
 

13.2  Default setting for alarm panel 
The default settings for the alarm panel may be set from the Player’s main window by selecting 
“Option->Settings”. 
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13.3  Configuration of objects for alarms 
Most objects can generate an alarm to the alarm panel. 
 
The parameters for generating alarms is located together with the other parameter related to a data 
source see section 5.8. 

 

 
The examp
 
Active: 
The object
 
Alarm tex
The text th
 
Level Ala
An alarm w
For serial 
alarm syst
 
Alarm on
An alarm w
 
 
 

9200294 V
23
 

le above shows how an alarm will be generated if the wind speed is above 23knt. 

 will only generate alarms if this box is checked. 

t: 
at will be written in the alarm window. 

rm: 
ill be generated if the output above or alternatively under a specific level. 

communication, please note that the trend output from a NMEA decoder is used for the 
em. 

 new data: 
ill be generated every time data is received (only applicable for serial data).  
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14  Relay of serial output to other applications 
The VDR Explorer is able to relay serial data to other applications. 
 

14.1  Output port settings 
An output port on the PC for the serial data is needed and must be configured. These parameters are 
included in the VDR Explorer’s preferences (Options->Preference->Port Settings). 
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14.2  Configuration of serial output 
The VDR Explorer must be in configuration mode. 
A click on “Tools->Serial output” will open the tool for configuring the sources of the serial output. 
 

 
 
The operator may select a number of data sources and one output port. 
 

14.2.1 Merging of data 
The program is designed to handle NMEA sentences i.e. two sentences will not be interleaved but 
sent one at a time. The program may fail to relay ASCI or binary data depending of the properties of 
the data. 

14.3  Enable/Disable output 
An icon on the VDR Explorer tool bar can be used to enabled/disable the serial output. This can 
be done while the VDR Explorer is playing/replaying data. 
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14.4  Overflow on serial port 
The serial output port may overflow if the combined inputs exceed the capacity of the output port. 
The operator will be warned if this happens. The operator may suppress the message. This will be in 
force until output is disabled and then enabled. 
 

14.5  Serial output and step 
The VDR Explorer is able to generate serial output while stepping. However the output port may be 
congested and steps may take very long time to process.  
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15 AIS data display 
There are eight objects designed for displaying AIS data: 
 

• AIS display 
• AIS display (small) 
• AIS own ship info 
• AIS target info 
• AIS target list (.5x1) 
• AIS target list (.5x2) 
• AIS target list (1x1) 
• AIS target list (1x2) 

 
The figures following an ”AIS target list” refer to the size of the object where 1x1 is the typical size 
of a graphical object.  
 
Notice that AIS data display object may be mixed with other object on a tab page. 
 

15.1  AIS display tab 
A default AIS data display has been defined which contains a useful combination of AIS object. 
This tab page is created like any other tab page see section 5.2 
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The AIS tab page is composed of the following objects; 
• One AIS display 
• One AIS Own ship info 
• Four AIS target Info 
• One AIS target list (.5x2) 

 

15.2  Selecting data source 
 
“Tools->Setup AIS Data Input” will open the “AIS data settings” tool. 
 

 
 

 
AIS data settings tool 
 
Select the serial channel to which the AIS is connected. 
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15.3  Using a AIS display tab 

 
 
The most important feature of the AIS data display is the ability to assign a label to and get 
information about a target of interest. This is simply done by clicking either directly on the target on 
the AIS display or on the label field for the target in the AIS target list. An AIS target info object 
will be assigned to the target when this is done.  
 
E.g.: On the AIS display tab shown above targets “A” and “B” have been selected. 
 
A target may be deselected by clicking on the target again. The number of “AIS target objects” on 
an “AIS display tab” determines the number of targets that can be selected simultaneously. “First in 
first out” applies if the number of selected targets exceeds the number of “AIS target objects”. 

15.4  Symbols for Targets 
 

AIS Standard target:  
 

Base station:   
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Aids to navigation:  
 

Aircraft:   
 
 

15.5  Supported messages 
1 - Position report  
2 - Position report  
3 - Position report  
4 - Base station report  
5 - Static and voyage related data  
6 - Binary addressed message  
8 - Binary broadcast message  
9 - Standard SAR aircraft position report  
12 - Addressed safety related message  
14 - Safety related broadcast message  
18 - Standard Class B equipment position report  
19 - Extended Class B equipment position report  
21 - Aids-to-navigation report  
22 - Channel management 
24 - Class B "CS" static data report 
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16 Special features 

16.1  Floating windows 
Note: This new feature has been designed for experienced users. Using floating windows in 
configuration mode may be confusing. 
 
A tab page may be detached from the VDR Explorers main window.  This is either done by “click, 
drag and drop” or “double clicking” on the tab for a tab page. 
 
Right clicking on the top bar for a floating window will open a menu with items for manipulating 
the window e.g. making it full screen. 
 
Double clicking on the top bar for floating window will revert it to a tab page. A floating window 
will also revert to a tab page if the corner of the window is aligned with the corner first tab in the 
VDR Explorer’s main window.  

16.1.1 “Windows” drop down menu  
A drop down menu (Windows) has been added to the menu bar for the VDR Explorers main 
window. The window selected from this menu will be brought to the front. 
 

16.2  Support for PC’s with lower screen resolution 
The VDR Explorer Pro is designed for 1280x1024 and above, however a PC with lower screen 
resolution may be used with minor inconvenience. 
 

16.3  Vessel information 
Complete vessel information is normally not displayed. “View->Vessel information” may be used 
to open/close a window for displaying complete vessel information. 
One “data item” related to Vessel information (vessel name is default) is displayed next to the tool 
bar for the VDR Explorer’s main window. 
 

16.4  Play control 
“View->Play Control” may be used to hide/show the Play Control. The Play Control may also be 
moved around (click, drag and drop). 
 

16.5  Full screen radar image 
Full screen radar image is entered and exited by double clicking on the image. 

16.6  Full screen graph object 
A double click on a graph object will expand it to full screen. A full screen graph will return to 
normal size upon a double click. 
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17 NMEA sentence formatting script language V1.4 

17.1  Purpose 

The purpose of this language is to easily match a given NMEA sentence and format it to human 
readable text. This implies that both pattern matching ability and string formatting ability must be a 
part of the language. The resulting human readable text will have a value associated with it. This 
value is used for the trend indicator and is most likely taken from the NMEA sentence. 

17.2  Language introduction 

Matching and formatting a NMEA sentence consists of applying a small compiled program to a 
NMEA sentence. The output from this program will be the formatted string and an optional value. 
In this context a program is a compiled set of statements in the NMEA sentence formatting 
language. The source for a program in this language consists of a sequence of statements. Each 
statement will be executed in the order they are written; hence the language is a straight-line 
language. If a statement fails, the program will exit. 

17.3  Language example 

The syntax and semantics of the language is best shown by use of an example. For an exact 
description of the language see the Grammar chapter 3. 

The following NMEA sentence is to be formatted: 

Field no: |  1  |    2    |3|    4     |5|    6    | 7 
Sentence: $GPGLL,5536.1234,N,01244.1234,E,123456.78,A*1B 

into the following result: “N 55°36.123” and the associated trend value “5536.1234” . Running the 
following program does this: 

// This is a comment and have no effect on the program 
Search for “GLL” 
If #7 <> “A” 
   print “GPS failed” 
   Stop 
EndIf 
Print #3 
Print “ “ 
Print #2 1:2 
Print “°” 
Print #2 3:6 F00.000 
Trend #2 

The first line is a comment and has no effect on the program, but can be a useful aid when 
developing decoders in the formatting language. The second line “Search for “GLL”” identifies 
which NMEA id this program is valid for. The third line uses an “if“ construct to test if field 7 
contains the text “A”. If this is the case, the text “GPS failed” is printed and the program stops. If 
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not, the program continues onto line three. The next few lines consists of “print” statements on 
field identifiers and strings. The hash mark “#” indicates a field identifier: 

#field [range] [format] 

Where “field” indicates the field number, “range” the range of characters to use and “format” 
how the number should be formatted. 

Continuous “print” operations can be concatenated into one “print” sentence resulting in a more 
compact program: 

Search for “GLL” 
If #7 <> “A” 
  print “GPS failed” 
  Stop 
EndIf 
Print #3 “ “ #2 1:2 “°” #2 3:6 F00.000 
Trend #2 

The last line identifies the field which will be used as the trend value. 

17.4  Bit function examples 

The following fictive NMEA sentence is used: 

Field no: |  1  |    2     |3| 4 
Sentence: $XXYYY,DEADBEEF01,N,A*1B 
 
search for "YYY" 
 
if bit(#2,2) = 1 
    print "bit 2" 
    stop 
endif 
 
if bit(#2,1) = 1 
    print "bit 1" 
endif 

The output of this program applied to the above NMEA sentence is: “bit 1” since bit 2 is not set. Bit 
number is counted from the right hand side and begins at position 1. Hence bit 24-28 is the “B”. 

17.5  Operators and reserved words 

17.5.1 Operators 

The following operators are valid in “if” statements: 

Operator Meaning Valid types on the right side of operator 
= Equality Strings, integers and real numbers 
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<> Inequality Strings, integers and real numbers 
<= Greater or equal Integers and real numbers 
>= Less or equal Integers and real numbers 
< Less than Integers and real numbers 
> Greater than Integers and real numbers 

 
The left side of an operator must be a field. 

17.5.2 Reserved words 

The following words are reserved: 

Reserved word Meaning 
Print Prints a field or a string 
Search for Identifies the NMEA id the program is valid for 
If Beginning of an “if” statement. “if” statement 

cannot be nested. 
EndIf Identifies that the “if” statement ends here 
Stop Stop the program keeping result 
Break Break the program with no result 
Trend Set trend value 
Bit(Field, Bit no.) Returns 1 if a bit is set in Field, 0 if not. Field must be 

a hex string. If bit does not exist it returns –1. 
Mbit(Field, bit no.) Returns 1 if a bit is set in a modbus field, 0 if not. 

Field must be a modbus string. If bit does not exist it 
returns –1. 

Mreg(Field, reg no.) Returns modbus register if the register exists in the 
modbus field. Field must be a modbus string. If 
register does not exist it returns –1. 

MSreg(Field, reg no.) Returns a signed Modbus register if the register exists 
in the Modbus field. Field must be a Modbus string. 
If register does not exist it returns 0. Use Mreg to the 
register existance. 

Last(Field, count) Returns the last “count” characters of a field. 

Reserved words are not case sensitive. 

17.6  Field Identifier 

The hash mark “#” indicates a field identifier: 

#field [range] [format] 

Where “field” indicates the field number beginning from 1. 

The “range” is optional and identifies the range of characters to use. The syntax is “x:y” where “x” 
is the first character to use (unless “y” is negative) and “y” is the number of characters. If  “x” is out 
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of range then the program is terminated and an error is printed. If “y” is out of range then the 
program will print to the end of the field. 

If  “y” is negative then the characters are selected from left. First to be printed is “x-y+1” and last 
character to be printer is “x” 
Example: 
 
Field no: |  1  |    2     |3| 4 
Sentence: $XXYYY,123456,N,A*1B 
 
search for "YYY" 
 
print #2 3:-2 

 
The printed result will be “23”. 
 
If  “x” is negative then the first character to print is selected from the right. Example: 
 
Field no: |  1  |    2     |3| 4 
Sentence: $XXYYY,123456,N,A*1B 
 
search for "YYY" 
 
print #2 -4:3 

 
This printed result will be “345”. 
 
To print everything but the last two characters of field 2: 
 
Field no: |  1  |    2     |3| 4 
Sentence: $XXYYY,123456,N,A*1B 
 

search for "YYY" 
 
print #2 -3:-99 

 
Will print “1234” 

The “format” field is optional and similar to the one used in Visual Basic. The maximum length of 
a formatter will be limited to 10 characters, including the decimal point. 

E.g.: 
 
Formatter Data to display    
- 14.75 0.336 -17 278 
F0 14 0 -17 278 
F00.00 14.75 00.34 -17.00 278.00 
F0.000 14.750 0.336 -17.000 278.000 
F000.0 014.8 000.3 -017.0 278.0 
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A000.0 014.8 000.3 017.0 278.0 
N000.0 -014.8 -000.3 017.0 -278.0 

The will be no default formatting of fields. 

By replacing the “F” with an “A” the result will be formatted into an absolute value. The following 
syntax is not allowed: “F0.” and “F.0” 

17.7  ModBus functions 
These functions are only relevant in conjunction with ModBus to NMAE converter hardware. 
 
MBIT( #<field no.> , <bit no.> ) 
 
Field number:  Always equal to 2 with the current encoding 
Bit no.: 0x000 to 0xFFFF 
 
Purpose: Used for testing the value for a bit in a “write multiple/single coils” command PDU. 
Returns 1 if the bit is 1 
Returns 0 if the bit is 0 
Returns -1 if the bit is not addressed.   
 
Used as a function in IF and PRINT statements: 
 
SEARCH FOR “PMTMWRB” 
 
IF MBIT(#2,0x0021) < 0 
  // No bit so break without result 
  BREAK 
ENDIF 
 
IF MBIT(#2, 0x0021) = 0 
  PRINT “off” 
  TREND 0 
ENDIF 
 
IF MBIT(#2, 0x0021) = 1 
  PRINT “on” 
  TREND 1 
ENDIF 
 

 
Used on the following ModBus sentence: 
 
Multiple Coil (write) : $PMTMWRB,010F002000100255551A2F,A*70 
 
Gives the result “on” and trend “1”. 
  
Description:  
The specified field must contain a complete ModBus command coded as ASCII characters. 
- The function code must be checked and equal to “0F” or “05” (character 3:2). 
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Write single bit (0x05) 
The address for the bit must match the “output address”, character 5:4. 
 
Write multiple bits (0x0F): 
- The bit must be within the addressed range i.e. “starting address” to (“starting address” + 
“quantity of outputs” –1). “Starting address” is character 5:4 and  “quantity of outputs” is character 
9:4 
 
MREG(#<field no.>,<register no.>) 
 
Purpose: Used for reading a register from a write multiple/single register command PDU. 
Returns the value from the register if present PDU 
Returns –1 if the register value is not present 
 
Used as a function in PRINT and IF statements: 
  
SEARCH FOR “PMTMWRR” 
 
IF MREG(#2,0x9c42) < 0 
  // No register so break without result 
  BREAK 
ENDIF 
 
PRINT “Register : ” MREG(#2, 0x9c42) 
TREND MREG(#2, 0x9c42) 

 
Used on the following ModBus sentence: 
 
Multiple Reg (write) : $PMTMWRR,01109C410003061111222233337616,A*6E 
 
Gives the result “Register : 4369” and trend “4369”. ( 4369 = 0x1111). 
 
Description:  
The specified field must contain a complete ModBus command coded as ASCII HEX. 
- The function code must be checked and equal “06”,“10” or “17” (character 3:2). 
 
Write register (0x06) 
The address for the specified register must match the “register address”, character 5:4. 
 
Write multiple registers (0x10): 
- The specified register must be within the addressed range i.e. “starting address” to (“starting 
address” + “quantity of registers” –1). “Starting address” is character 5:4 and  “quantity of 
registers” is character 9:4 
 
Read/write multiple registers (0x17): 
- The specified register must be within the addressed range i.e. “starting address” to (“starting 
address” + “quantity of registers” –1). “Starting address” is character 13:4 and  “quantity of 
registers” is character 17:4 
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MSREG(#<field no.>,<register no.>) 
 
Purpose: Used for reading a register from a write multiple/single register command PDU. 
Returns the value from the register if present PDU 
Returns 0 if the register value is not present 
Use MREG to test for register existence 
 
Used as a function in PRINT and IF statements: 
  
SEARCH FOR “PMTMWRR” 
 
IF MREG(#2,0x9c42) < 0 
  // No register so break without result 
  BREAK 
ENDIF 
 
PRINT “Register : ” MSREG(#2, 0x9c42) 
TREND MSREG(#2, 0x9c42) 

 
Used on the following ModBus sentence: 
 
Multiple Reg (write) : $PMTMWRR,01109C41000306FFFF222233337616,A*6E 
 
Gives the result “Register : -1” and trend “-1”. ( -1 = 0xFFFF). 
 
Description:  
The specified field must contain a complete ModBus command coded as ASCII HEX. 
- The function code must be checked and equal to “06”,“10” or “17” (character 3:2). 
 
Write register (0x06) 
The address for the specified register must match the “register address”, character 5:4. 
 
Write multiple registers (0x10): 
- The specified register must be within the addressed range i.e. “starting address” to (“starting 
address” + “quantity of registers” –1). “Starting address” is character 5:4 and  “quantity of 
registers” is character 9:4 
 
Read/write multiple registers (0x17): 
- The specified register must be within the addressed range i.e. “starting address” to (“starting 
address” + “quantity of registers” –1). “Starting address” is character 13:4 and  “quantity of 
registers” is character 17:4 

17.8  Other functions 
 

17.8.1 Last function 
 
The last function returns the last characters of a field. 
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The following fictive NMEA sentence is used: 

Field no: |  1  |    2     |3| 4 
Sentence: $XXYYY,DEADBEEF01,N,A*1B 
 
search for "YYY" 
 
if last(#2,3) = “F01” 
    print last(#2,3) 
 trend last(#2,1) 
    stop 
endif 
 

 
The printed result will be “F01” and the trend value 1. 
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Appendix A S-VDR conning display default configuration 
 
Object Title and 

Indicator 
Input Enabled/ 

Disabled 
Pre-configured 
decoder script 

Alternative Decoder 
scripts 

UTC Time 
Object 1 

SI02 Enabled UTC time (ZDA) UTC time (GGA) 
UTC time (GLL) 
UTC time (GNS) 
UTC time (RMC) 

UTC Date 
Object 2 

SI02 Enabled UTC date (ZDA) Date (RMC) 

Numeric data 
display, left 

Quality ind. 
Object 3 

SI02 Enabled Quality Indicator 
(GGA) 

 

Latitude 
Object 1 

SI02 Enabled Latitude (GLL) Latitude (GGA) 
Latitude (GNS) 
Latitude (RMC) 

Longitude 
Object 2 

SI02 Enabled Longitude (GLL) Longitude (GGA) 
Longitude (GNS) 
Longitude (RMC) 

Numeric data 
display, right 

COG 
Object 3 

SI02 Enabled COG true (VTG) COG (RMC) 

n/a 
Longitudinal speed 

SI03 Enabled STW (VHW) STW Longitudinal 
(VBW) 

n/a 
Bow transverse speed 

SI03 Disabled STW transverse 
(VBW) 

 

n/a 
Stern transverse speed 

SI03 Disabled Stern transv STW 
(VBW) 

 

Doppler log 
indicator 

n/a 
Relative wind 

SI05 Enabled Wind direction rel 
(MWV) 

 

SOG 
Dial Meter 1 
Primary 

SI02 Enabled Speed (VTG) Speed (RMC) 
SOG Longitudinal 
(VBW) 

Dual dial meter 

STW 
Dial Meter 2 
Primary 

SI03 Enabled STW (VHW) STW Longitudinal 
(VBW) 

Horizontal ruler R.O.T. 
Primary 

SI04 Enabled Rate of turn (ROT)  

Compass dial Heading 
Primary 

SI04 Enabled Heading true (HDT)  

Wind speed r 
Primary 

SI05 Enabled Wind speed rel knt 
(MWV) note 1 

 Anemometer 
Graph 
 Wind dir r 

Secondary 
SI05 Enabled Wind direction rel 

(MWV) 
 

Depth 
Primary 

SI06 Enabled Depth (DPT)  Echo sounder 
Graph 

Range 
Secondary 

SI06 Disabled Range (DPT)  

Note 1) Decoders for other units are available in the library. 
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