
 
 

 
 

Dyno-Scan™ for Windows  

User Guide 



 

Warnings 
 
The exclamation point within the triangle is a warning sign alerting you of important 
instructions accompanying the product. Please observe all warnings.   
 

 

Do not operate the vehicle indoors. A running engine produces lethal carbon 
monoxide exhaust fumes that can seriously harm or kill you if inhaled. Only run the 
vehicle motor outdoors with proper ventilation. Many scan tool operations do not 
require a running motor. 

 

 

Do not attempt to operate or observe the scan tool while driving a vehicle. 
Driving requires the full attention of the driver. Operating or observing the scan tool 
will cause driver distraction and could cause a fatal accident.  

 

 

Ensure the PC, cable, and OBD II adapter do not interfere with the vehicle 
controls. A cable dangling in front of the foot pedals, gear shifter, or steering wheel 
can interfere with vehicle operation and cause a fatal accident. Always ensure the 
PC, cable, and OBD II adapter are securely fastened out of the way. If the scan tool 
and PC cannot be safely attached as to not interfere with the vehicle controls, then 
do not drive the vehicle with the OBD II adapter connected to the vehicle.  

 

 

Never race or exceed the posted speed limit while on public highways. The 
dynamometer operations require accelerating to high speeds. Always uses a closed 
course raceway when performing dynamometer and acceleration tests.  
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Terms of Use 
The Software contains proprietary and confidential information that is protected by applicable 
intellectual property and other laws. You may not modify or sell works based on the Software.  

The Software is for your personal use. We grant you a personal and non-exclusive license to 
use the object code version of the Software on a single Windows-based personal computer; 
provided that you do not (and do not allow any third party to) copy, modify, reverse engineer, 
create derivative works from, assign or otherwise transfer any right in the Software; and you 
will not modify the Software by any means. 

Disclaimer 
The “Product” is the complete Dyno-Scan for Windows product including hardware, software, 
user manual, and packaging.  

Auterra, LLC assumes no responsibility for any loss or claim by third parties which arise 
through the use of this Product. Auterra, LLC assumes no responsibility for any damage or loss 
caused by deletion of data as a result of a Product malfunction. Be sure to backup copies of all 
important data on other media to protect against data loss.  

The Software, and all accompanying files, data and materials, are provided "as is" without 
warranty of any kind, either expressed or implied, including, but not limited to, the implied 
warranties of merchantability and fitness for a particular purpose. The entire risk as to the 
quality and performance of the Software is with you. Should the Software prove defective, you 
assume the cost of all necessary servicing, repair or correction. 

AUTERRA, OR ITS PRINCIPALS, SHAREHOLDERS, OFFICERS, EMPLOYEES, AFFILIATES, 
CONTRACTORS, SUBSIDIARIES, OR PARENT ORGANIZATIONS, SHALL NOT BE LIABLE FOR ANY 
INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR OTHER DAMAGES INCLUDING BUT 
NOT LIMITED TO, LOSS OF PROFITS, LOSS OF REVENUE, LOSS OF DATA, LOSS OF USE OF THE 
PRODUCT OR ANY ASSOCIATED EQUIPMENT, DOWNTIME AND CONSUMER’S TIME OR FOR 
BREACH OF ANY EXPRESS OR IMPLIED WARRANTY OR CONDITION, DAMAGE TO THE VEHICLE, 
BREACH OF CONTRACT, NEGLIGENCE, STRICT LIABILITY OR ANY OTHER LEGAL THEORY 
RELATED TO THIS PRODUCT.  

Copyright 
1998-2010 Auterra, LLC. All rights reserved.  

Trademarks 
Windows® is a registered trademark of Microsoft Corporation. Palm, HotSync, Graffiti®, and 
Palm OS are registered trademarks of Palm, Inc. Google and Google Earth are trademarks of 
Google Inc. 
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CHAPTER 1 

Preface 

Congratulations on your purchase of an Auterra’s Dyno-Scan™ for Windows. Please take time 
to read through these operating instructions and become familiar with the operating 
procedure.  

The Auterra Dyno-Scan™ for Windows, in conjunction with your personal computer, enables 
access to your vehicle’s diagnostic information.  

The scan tool offers features such as read and clear trouble codes, turn off the “Check Engine” 
light, and display live sensor data from the vehicle. The Dyno software adds a performance-
measuring package that includes a dynamometer, acceleration tests, and fuel economy 
measurements.  

Key Features 
Dyno-Scan™ for Windows offers a multitude of diagnostic and performance-measuring 
features: 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

All 1996 and later vehicles supported, including American, Asian, and European 

Read and clear diagnostic trouble codes (DTCs) 

Integrated DTC description databases including enhanced and generic definitions   

Turn off the vehicle’s Check Engine or Service Engine Soon light 

Read and clear freeze frame data 

Monitor live sensor data with line graphs, bar graphs, and meters 

Graphically zoom in/out and pan within a virtual trace buffer 

View multiple sensors simultaneously with variable sample rates 

Record and playback live sensor data streams 

Export recording to a spreadsheet for further analysis 

Graphical oxygen sensor monitoring and on-board test results 

I/M readiness. Metric and English units of measure 

Horsepower and torque measurements 

0-60 time, 1/8 and 1/4 mile time and speed, MPG, and top speed 

Supports Windows 98 and higher  
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• 1-year warranty 

Minimum Platform and Software Requirements 
You must have one of the following operating systems with Microsoft Internet Explorer 5.01 or 
later installed on your computer: 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

Microsoft® Windows® 98  

Microsoft® Windows® 98 Second Edition  

Microsoft® Windows® Millennium Edition (Windows Me)  

Microsoft® Windows NT® 4 (Workstation or Server) with Service Pack 6a  

Microsoft® Windows® 2000 (Professional, Server, or Advanced Server) with the latest 
Windows service pack and critical updates available from the Microsoft Security Web 
site (www.microsoft.com/security).  

Microsoft® Windows® XP (Home or Professional, 32-bit and 64-bit)  

Microsoft® Windows® XP Media Center Edition  

Microsoft® Windows® XP Tablet PC Edition 

Microsoft® Windows® Server 2003 family 

Microsoft® Windows® Vista (all editions, 32-bit and 64-bit) 

Microsoft® Windows® 7 (all editions, 32-bit and 64-bit) 

Minimum hardware requirements: 

Pentium 166MHz or faster 

64MB of RAM or higher 

Auterra Dyno-Scan™ for Windows 
The Dyno-Scan™ for Windows is comprised of four components:  

OBD II Adapter and Software 

OBD II Cable 

USB or RS-232 null modem cable  

Windows laptop or desktop PC (purchased separately) 
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Figure 1: PC, RS-232 cable, OBD II Adapter, and OBD II Vehicle Connect Cable 

OBD II 
OBD II stands for On-Board Diagnostics second generation. OBD II was incorporated on some 
1994 and 1995 model-year vehicles and was required for all 1996-and-later vehicles. 

OBD II is a series of government regulations intended to reduce in-use vehicle emissions by 
continually monitoring for failure and/or deterioration of the powertrain and its emission-
control systems. A Malfunction Indicator Light (i.e. Check Engine light or Service Engine Soon 
light) visible to the vehicle operator will be illuminated and a Diagnostic Trouble Code set 
when either there is a failure of a monitored component/system or any of the sensed 
parameters deteriorates such that the vehicle's emissions would exceed the relevant standard 
by approximately 50 percent. 

The OBD II standard makes the Auterra Dyno-Scan™ for Windows universal to all automobiles, 
since all newer vehicles sold must conform to these government regulations.  

OBD II standardizes a vehicle communication protocol and the vehicle’s connector to an 
external diagnostic device called a Scan Tool. Auterra Dyno-Scan™ for Windows uses this 
connector located under the dash to communicate with the vehicle’s on-board computer 
systems.  

OBD II Connector 
OBD II compliant vehicles must have a 16-pin connector located in plain sight underneath the 
dash near the driver’s seat (see Figure 2). Alternatively, it may be behind ashtrays or concealed 
by an easily removed plastic cover, sometimes with the letters “OBD” stamped on the outside. 
Some 1994 and 1995 vehicles have this connector and are only OBD I compliant. These OBD I 
vehicles are not supported by the scan tool.  

 

Figure 2: Vehicle OBD II Connector (Front View) 
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Specifications 
The Dyno-Scan OBD II Adapter conforms to these specifications.  

Table 1: Hardware Specifications 

Vehicle Protocol Input: VPW, PWM, ISO, Keyword Protocol (KWP) 2000, and CAN bus. 
External Power: None. Draws power from vehicle. 
Weight: 4 oz 
Dimensions (H x W x D): 3.5" x 1.75" x .875"  
Temperature: 32° to 158° F (0° to 70° C) non-condensing 

Supported Vehicles 
Auterra Dyno-Scan™ for Windows supports all 1996 and newer vehicles, including American, 
European, and Asian models. Some 1994 and 1995 vehicles are also supported with a sticker 
under the hood indicating OBD II compliance. All vehicles sold in the US model year 1996 and 
newer are OBD II compliant and do not require the under hood sticker. 
The OBD II Adapter supports the following automotive standard interfaces: VPW, PWM, ISO, 
Keyword Protocol (KWP) 2000, and CAN bus.  

Abbreviations 
Some item descriptions are abbreviated within the software.  

BX – designates a bank number (e.g. B1 means bank 1) 

SX – designates a sensor number (e.g. S1 means sensor 1) 

BX-SX – designates a bank-sensor combination (e.g. B1-S2 means bank 1 – sensor 2) 

Abbreviations and Definitions 
A/F – Air Fuel 

A/T – Automatic Transmission 

Check Engine Light – also known as a MIL (Malfunction Indicator) light. 

CHT – Cylinder Head Temperature 

Closed Loop – In closed loop operation the oxygen sensors are used to adjust the fuel 
mixture. See open loop.  

DTC – Diagnostic Trouble Code 

Dyno - Dynamometer 

EBCM – Electronic Brake Control Module 

EBTCM – Electronic Brake Traction Control Module 

ECU – Emission Control Unit (i.e. the vehicle’s on-board computer) 

EGR – Exhaust Gas Recirculation 
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EFI – Electronic Fuel Injection 

EMR – Electronic Module Retard 

ESC – Electronic Spark Control 

EST – Electronic Spark Timing 

EVAP – Evaporative Emission 

Fuel Trim – engine computer function that keeps the air/fuel mixture close to ideal.  

HC – Hydrocarbons 

HEI – High Energy Ignition 

HO2S – Heated Oxygen Sensor 

Horsepower – a unit of measure to express the rate at which mechanical energy is expended. 

HP – Horsepower 

M/T – Manual Transmission 

MAF – Mass Air Flow 

MIL – Malfunction Indicator Light (i.e. “Check Engine” or “Service Engine Soon” light on the 
vehicle’s instrument panel). 

NOx – Oxides of Nitrogen 

O2 – Oxygen  

Open Loop – used to describe the fuel mixture when the oxygen sensors are not being used, 
usually when the engine is cold or if a malfunction preventing closed loop operation is 
detected. See closed loop.  

PCM – Power Control Module 

PID – Parameter ID is a number used to designate a particular vehicle sensor. 

PTO – Power Take-Off  

RPM – Revolutions per Minute 

SAE – Society of Automotive Engineers 

Scan Tool – a computer that reads out OBD II values from the vehicle.  

Service Engine Soon – also known as a MIL light. 

SFI – Sequential Fuel Injection 

TBI – Throttle Body Injection 

TCM – Transmission Control Module 

TCS – Traction Control Switch 

TFT – Transmission Fluid Temperature 
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Torque - Torque is a measure of the force acting on an object causing that object to rotate. 

TP – Throttle Position 

TPS – Throttle Position Sensor 

VAC – Vacuum 

VIN – Vehicle Identification Number 

VSS – Vehicle Speed Sensor 
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CHAPTER 2 

Installing Windows Software 

Loading the Auterra Windows software onto your personal computer is easy. This section 
shows you how.  

Uninstall Previous Dyno-Scan for Windows 
Auterra recommends uninstalling all previous versions of the Dyno-Scan for Windows 
software, if any, before proceeding.  

1 

2 

3 

4 

5 

6 

7 

From the Start menu, select Settings > Control Panel. 

Double-click on Add/Remove Programs. 

Click the Install/Uninstall tab, if your Windows version includes it. 

From the list of programs that you can remove, select Dyno-Scan for Windows. 

Click Add/Remove. 

At the prompt, click Yes to confirm that you want to remove the Dyno-Scan for Windows 
program. 

When the files are removed, the uninstall program indicates that the process is complete. 

Upgrade Internet Explorer  
The Dyno-Scan software relies upon Microsoft Internet Explorer version 5.01 or later. The 
version is located on the Help > About Internet Explorer menu option within Internet Explorer. 
If you do not have version 5.01 or later, you will need to upgrade using the instructions below. 
If necessary, update your Internet Explorer for free directly from Microsoft at: 

http://windowsupdate.microsoft.com 

Software Installation (All Windows Versions) 
1 

2 

3 

4 

5 

Close all other programs and windows. 

Insert the CD labeled Dyno-Scan for Windows into your CD-ROM drive. 

The installation should start automatically. If not, from the Start menu select Run. 

Type D:\setup (substitute the appropriate letter of your CD-ROM drive for D).  

Follow the instructions on the screen. 
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USB Driver Installation 
The A-302 Windows kit is equipped with a B-301 USB OBD II adapter. This adapter requires 
installing a USB driver. This section only applies to the USB version of the OBD II adapter, as 
shown in Figure 3: USB OBD II Adapter. 

 

Figure 3: USB OBD II Adapter 

Windows Vista/7 Installation 
1 

2 

3 

Do not plug in your Auterra USB OBD Adapter into your PC until after the Auterra Dyno-
Scan for Windows software is installed.  

During Dyno-Scan for Windows software installation, the USB driver is installed 
automatically. Just plug in the USB OBD II adapter and your device is ready for use.  

If you experience problems installing the USB driver, see the “USB Driver 
Installation.pdf” manual in the User Guide directory on the Auterra CD ROM.  

Windows 7: To locate the COM port number, go to the Windows Start button > Devices 
and Printers. In the Unspecified section, see the Dyno-Scan OBD II USB Adapter Port 
(COMX), where COMX is the COM port to select within the Dyno-Scan software on the 
Tools > Options menu dialog. 
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Windows Vista: To locate the COM port number, go to the Windows Start button > 
Control Panel > System and Maintenance and click Device Manager. Expand the Ports 
(COM & LPT) setting and see the Dyno-Scan OBD II USB Adapter Port (COMX) entry, where 
COMX is the COM port to select within the Dyno-Scan software on the Tools > Options 
menu dialog.   

 

9 Installing Windows Software   



 

 

Windows 2000/XP Installation 
1 

2 

3 

Do not plug in your Auterra USB OBD Adapter into your PC until after the driver is 
installed. 

Start AuterraVCPInstaller.exe within the USB Driver directory located on the Auterra CD 
ROM.  

On Windows XP it may display a warning message. Press the Continue Anyway button. 
With all other versions of Windows no warning dialog is displayed.  
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4 

5 

6 

Please wait a few minutes for the driver installation to complete. There will be no progress 
dialog during installation.  

Plug in the USB OBD II Adapter to your Windows PC. The Found New Hardware Wizard will 
display.  

On the Found New Hardware Wizard, select “Yes, this time only” and press Next. 
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7 On the next dialog, select “Install the software automatically (Recommended). 

The AuterraVCPInstaller.exe pre-installs the driver on your PC. Optionally, if you wanted 
to install the driver directly from the Auterra CD ROM, select “Install from a list or specific 
location (Advanced)” and then select a specific location on your computer (for instance 
d:\USB Driver). 
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8 On Windows XP, a warning dialog will appear. Press Continue Anyway. All other Windows 
versions will not display a warning message. 
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After the first driver installs, steps 7 though 9 will repeat again.  There are two parts to the 
driver and both must be installed. 

9 

10 

11 

The driver installation is complete.  

If you experience problems installing the USB driver, see the “USB Driver 
Installation.pdf” manual in the User Guide directory on the Auterra CD ROM. 

To locate the COM port number, go to the Windows Start button > Control Panel > System 
and Maintenance and click Device Manager. Expand the Ports (COM & LPT) setting and see 
the Dyno-Scan OBD II USB Adapter Port (COMX) entry, where COMX is the COM port to 
select within the Dyno-Scan software on the Tools > Options menu dialog.   

 

Figure 4: Correct Installation of USB Driver 

Windows 98/ME USB Driver Installation 
1 

2 

Plug in the USB OBD II adapter into any USB port on your Windows PC. 

The Welcome to the Found New Hardware Wizard dialog will display. Press Next.  
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3 The Found New Hardware Wizard dialog will display. Select the “Search for a suitable 

driver for my device (recommended)” option and press Next. 

 
4 Check the “Specify a location” option and press Next. 
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5 Press the Browse… button and select the “USB Driver (Win 98)” directory on the Auterra 

software CD ROM. Press OK. 

 

6 Windows will locate the driver on within the USB Driver directory on the Auterra the CD 
ROM. Press Next.  
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7 The wizard will now complete the installation. Press Finish. 

 

Once the first driver is installed, the Found New Hardware Wizard will repeat again the 
second driver. Repeat the above steps for the second driver installation. 

8 

9 

1 

After installing both drivers, your OBD II USB Adapter is ready for use. 

Virtual COM Port 
When the USB OBD II adapter is plugged into the PC, the driver will create a virtual COM port 
and assign it a number. The Windows Device Manager shows all assigned port numbers. Open 
Device Manager by doing the following: 

Click on “Start” and then “Control Panel”. 
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2 Switch to Classic View (if in Category View). 

3 

4 

5 

6 

7 

Double click on “System”. 

Select the Hardware tab. 

Press the “Device Manager” button. 

Click on the “+” next to Port. 

The entry labeled “Auterra USB OBD II Adapter” shows the virtual COM port for the USB 
OBD II adapter. Physical COM ports are also shown if you are using a serial OBD II adapter. 

 

 

Figure 5: Auterra USB OBD II Adapter COM Port 

Software Updates 
Check the Auterra website periodically to download software updates at 
www.auterraweb.com.  
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CHAPTER 3 

Connections 

Connecting your Auterra Dyno-Scan™ for Windows to the vehicle is easy. This section shows 
you how. 

Connect your Dyno-Scan™ to the Personal Computer 
A Plug the USB cable into the personal computer’s USB port. If the kit is equipped with a 

serial cable instead, plug the serial RS-232 cable into the computer’s COM port. 

B Connect the USB or RS-232 cable to the OBD II adapter. 

C Connect the OBD II cable to the OBD II adapter and tighten the two thumbscrews. 

 

 

Figure 6: Dyno-Scan™ Connections 

Connect the Dyno-Scan™ to your Vehicle 
Locate the OBD II connector on the vehicle. OBD II compliant vehicles have the 16-pin 
connector located in plain sight underneath the dash near the driver’s seat (see Figure 2). It 
may also be behind ashtrays.  

Connect the male OBD II Cable connector to the vehicle’s female OBD II connector. Ensure the 
connectors are fully engaged. 
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Select COM Port 
1 

2 

3 

4 

Start the Dyno-Scan application.  

Select the Tools > Options… menu selection.  

On the Options dialog, select the COM port that the scan tool is connected to. The COM 
port dropdown list only shows COM ports installed on your computer. Refer to section 
Virtual COM Port for information on displaying COM port numbers within Windows Device 
Manager. 

Press the OK button. 

Your Dyno-Scan for Windows scan tool is setup and ready for use. 
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CHAPTER 4 

Dyno-Scan Basics 

Getting started with your Dyno-Scan for Windows software is easy, and this section shows you 
how. 

To connect to your vehicle, press the Connect button on the toolbar. Then press the “Connect 
to Vehicle” button on the Connect dialog. After a few seconds the scan tool will be connected 
to the vehicle. If the scan tool fails to connect, see Troubleshooting on page 90. 

 

Figure 7: Connect Dialog 

The Navigation pane is vertically docked on the far left of the screen. The Navigation pane is 
used to switch between the main screens. Just click an icon, such as Live Data, to change 
screens.  

The Navigation pane sorts the main screens by category: Scan Tool, Dyno and Analyze. Mouse 
click a category on the Navigation pane and new category icons are displayed.  

A right mouse click brings up a shortcut menu on many screen elements. On the Live Data 
screen, right mouse click in the middle of a Graph or List pane and select “Edit Parameters” to 
monitor live sensor data. Alternatively, left mouse click the Options dropdown button located 
on the right side of the pane title bar.  
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Figure 8: Right Mouse Click Shortcut Menu 

If you close all of the Live Data Graph and List panes, the screen is blank. To add panes again, 
just right mouse click in the middle of the screen and select “Add List Pane” or “Add Graph 
Pane” and a new pane will be displayed.  

 

 

Figure 9: Live Data Screen Highlighted Features 

Not every screen is supported by every vehicle. For instance, some vehicles will not support 
the Oxygen Sensors screen. If a screen is blank or shows no data, then the vehicle doesn’t 
support that particular scan tool feature.  

The Analyze Live Data screen only displays data if you either record data or open a previously 
recorded live data file. For instance, select File > Open > Live Data File… and select a file to 
open. Data will then be displayed on the Analyze Live Data screen. 

Left mouse click the Options button on the Analyze Live Data pane title bar to display a 
shortcut menu of options. Right mouse click on any graphical element on this screen to 
display a shortcut menu of options. For instance, right mouse click an x or y axis for options.  
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Hold the left mouse button down and drag to move the axis data. Hold the Ctrl keyboard key 
and mouse drag an axis to zoom in and out.  

 

Figure 10: Analyze Live Data Screen 

If you close any of the docking windows such as Navigation or File Properties, you can display 
them again on the View menu (e.g. View > Navigation).  

Options Dialog 
The Reload last user parameters when starting program setting, when checked, restores all 
user parameters to their last known state. Otherwise, the program’s default parameters are 
used. 

The COM Port setting on the General tab selects the personal computer COM port to use.  
Make sure the selected COM port matches the one the OBDII’s adapter has been plugged into. 

The Default Units of Measure setting changes between English or Metric units. Not all 
sensors use English units of measure, in which case the Metric units are used.  

The Fast Sampling option on the General tab enables a faster than normal sampling 
frequency on some vehicles. If you notice on some vehicles that the live sensor monitoring 
doesn’t function or the sensor measurements update sporadically, disable this feature.  

The CAN 6x Communication options enables or disables the high-speed six-samples-per-
query communication mode. Normally, one sensor at a time is polled from the vehicle. If the 
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vehicle supports CAN bus, then the vehicle may support polling up to six parameters at once 
speeding the transfer of data. 

The MPG Correction applies a percent correction factor to all Instant Economy, Average 
Economy and Fuel Used parameters. This correction is used to fine-tune the fuel economy 
measurements.  

The Distance Correction applies a percent correction factor to the Distanced Traveled live 
data parameter.  

The Vehicle Speed Correction preference adjusts the vehicle speed sensor readings to 
accommodate a vehicle with an inaccurate speedometer. This is a global setting and adjusts 
the vehicle speed measurements on all screens displaying or using live data such as Live Data, 
Gear Ratio and Acceleration. The vehicle speed correction preference does not adjust the 
vehicle dashboard speedometer nor does it calibrate the vehicle speedometer. 

The Boost Calibration value is subtracted from all Boost Pressure readings in order to adjust 
the Boost Pressure measurements from absolute pressure to a gauge pressure. The Boost 
Calibration entered is the atmospheric pressure in psi (pounds per square inch). To get 
atmospheric pressure using your vehicle, enter a Boost Calibration value of 0.0% and view the 
Boost Pressure parameter on the Live Data screen with the engine off. The Boost Pressure 
reading with a 0.0% calibration is the value to enter into the Boost Calibration box.  

The Engine Size preference is used in the following parameters: Instant Economy 2, Average 
Economy 2, Fuel Used 2 and Air Flow Rate From MAP.  Ensure you enter an accurate engine 
size (in liters) if you use these parameters. 

The Fuel Type preference is used to adjust the fuel economy-related parameters. Ensure you 
enter the correct fuel type: gas or diesel. 

The Fuel Cost preference is used to enter the cost per gallon of fuel currently in the vehicle 
gas tank. This value is used to compute the Fuel Cost live data parameter. If the Units of 
Measure is Metric, the value is the cost per liter.  

The Reset Defaults button sets all settings back to their default state. 
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Figure 11: Options Dialog, General Tab 

The View tab allows customization of the Font, Font Style, Font Color, and Font Size settings 
used in all grid displays. 
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Figure 12: Options Dialog, View Tab 

Vehicle Speed Correction 
The vehicle speed correction preference adjusts the vehicle speed sensor readings to 
accommodate a vehicle with an inaccurate speedometer. This is a global setting and adjusts 
the vehicle speed measurements on all screens displaying of using live data. 

The vehicle speed correction preference does not adjust the vehicle dashboard speedometer 
nor does it calibrate the vehicle speedometer.  

If you vehicle is equipped with a stock tire size you leave this setting at 0.0%.  

Always compute and adjust the vehicle speed correction first before measuring and adjusting 
the distance correction or MPG correction. 

To compute and adjust the vehicle speed correction factor using is GPS: 

1 

2 

3 

4 

5 

6 

Set Vehicle Speed Correction to 0.  

Select the Live Data screen and monitor the Vehicle Speed parameter.  

Drive the vehicle and keep the vehicle speed stead (e.g. 30 MPH).  

Have a passenger note the Dyno-Scan Vehicle Speed and the GPS speed.  

Compute an error percentage: 

vehicle speed correction = ((GPS speed – Dyno-Scan vehicle speed ) / GPS speed) x 100 

Example: 

7.3% = ((30.0 MPH – 27.8 MPH) / 30.0 MPH) x 100 

Set the Vehicle Speed Correction to the computed correction factor.  
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Distance Correction 
The distance correction preference fine-tunes the accuracy of the Distance Traveled 
parameter, if necessary.  

The distance correction preference does not adjust the vehicle odometer nor does it calibrate 
the vehicle speedometer.  

The Distance Traveled parameter is used within the Instant MPG and Average MPG parameter 
computations. Therefore, an accurate Distance Traveled parameter ensures greatest accuracy 
of these parameters.  

To compute and adjust the distance correction preference using your vehicle odometer: 

1 

2 

3 

4 

5 

1 

2 

3 

4 

5 
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Set the Distance Correction to 0.  

Go to the Live Data screen and monitor the Distance Traveled parameter.  

Drive the vehicle for 25 to 50 miles.  

Compare the Dyno-Scan trip computer Distance Traveled value and the vehicle’s 
odometer mileage.  Compute an error percentage: 

distance correction = ((odometer distance – Dyno-Scan distance ) / odometer distance) x 100 

Example: 

3.3% = ((27.5 miles – 26.6 miles) / 27.5 miles) x 100 

Set the Distance Correction to the computed correction factor.  

Alternatively a GPS may be used in place of the odometer in the above procedure if the 
vehicle speedometer is not accurate.  

MPG Correction 
The MPG correction preference fine-tunes the accuracy of the Instant MPG, Average MPG and 
Fuel Used parameters due to different fuels or minor vehicle sensor variances.  

The MPG correction preference does not adjust the amount of fuel used by the vehicle. 

Always compute and adjust the distance correction first before measuring and adjusting MPG 
correction.  

To compute and adjust the MPG correction preference: 

Set the MPG Correction to 0.  

Fill up your vehicle gas tank.  

On the Tools > Options menu press the Reset Fuel Used button then press OK.  

Go to the Live Data screen and monitor the Fuel Used parameter.  

Drive the vehicle normally until the tank is near empty. Always have the Average Fuel 
Economy screen displayed when driving the vehicle. 

Fill up the vehicle and note the gallons used to fill up the vehicle. 
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7 Compute the error in the Dyno-Scan Fuel Used parameter and the gallons used to fill up 
the gas tank. 

MPG correction = ((Dyno-Scan fuel used - gas pump gallons) / gas pump gallons) x 100 

Example: 

-1.2% = ((25.3 gallons – 25.6 gallons) / 25.6 gallons) x 100 

8 

1 

2 

3 

4 

5 

6 

Set the MPG Correction to the computed correction factor.  

Boost Calibration 
Two different methods are used for expressing pressure: gauge pressure and absolute 
pressure. Gauge pressure is referenced to atmospheric pressure. The atmospheric pressure at 
sea level is about 14.7psi and changes slightly with atmospheric conditions. Absolute pressure 
is referenced to 0psi.  The relationship between the pressures can be expressed as follows: 

absolute pressure = gauge pressure + atmospheric pressure 

The Boost Pressure parameter measures the absolute pressure within the vehicle’s intake 
manifold. To measure gauge pressure, enter a Boost Calibration offset. Gauge pressure can be 
expressed as follows: 

gauge pressure = absolute pressure – atmospheric pressure 

The Boost Calibration allows entering the atmospheric pressure, in psi, such that a gauge 
pressure reading may be obtained.  

boost pressure = absolute pressure – Boost Calibration 

Two factors affect the Boost Calibration accuracy: weather conditions and elevation changes, 
the later being more significant. Enter a new Boost Calibration for the most accurate gauge 
pressure measurements.  

The boost calibration does not adjust the turbo boost pressure of the vehicle.  

To compute a Boost Calibration correction factor: 

Connect Dyno-Scan to your vehicle. 

Ensure your vehicle is not running.  

Select the Boost Calibration option to 0.   

Go to the Live Data screen and monitor the Boost Pressure parameter.  

The Boost Pressure parameter will display. This is your Boost Calibration correction factor. 
With the Boost Calibration preference at 0 and the vehicle off, the Boost Pressure value 
shown is atmospheric pressure. 

Set the Boost Calibration to the value measured above.  
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Engine Size  
The Engine Size preference is used in the following parameters: Instant Economy 2, Average 
Economy 2, Fuel Used 2 and Air Flow Rate From MAP.  Ensure you enter an accurate engine 
size (in liters) if you use these parameters. 

Fuel Type 
The Fuel Type preference is used to adjust the fuel economy-related parameters. Ensure you 
enter the correct fuel type: gas or diesel. 

Fuel Cost 
The Fuel Cost preference is used to enter the cost per gallon of the fuel currently in the vehicle 
gas tank. This value is used to correctly display the Fuel Cost live data parameter.  If the Units 
of Measure is set to Metric, the Fuel Cost is the cost per liter. 

Dyno-Scan File Types 
The software uses four data file types with four different file extensions. Each file type can be 
created using the File > New menu option.  

Table 2: File Types 

File Type File 
Extension 

Description 

Live Data File .ld Live data files store live parameter recordings. 
Power Torque File .pt Stores power torque run data. 
Acceleration File .ac Stores acceleration run data. 
Dyno Setup File .ds Stores vehicle and environmental setup information. 

Docking Windows 
The program contains four docking windows: Navigation, File Properties, Run Statistics, and 
Dyno Setup Properties. Each docking Windows may be resized, hidden, or slide-in or slide-out 
from a docked position on demand.   
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Figure 13: Floating Toolbars and Property Windows 

• 

• 

• 

• 

• 

• 

• 

To hide a docking window, click the red X close button in the upper right corner.  

To hide a docking window with slide-in, press the pushpin icon in the upper right 
corner. The window will slide in and hide itself. 

To show a hidden docking window, select the View menu option (e.g. View > 
Navigation).  

To show a docking window with slide-out, hover the mouse button over the docked 
window name or icon. The window will slide out showing itself. 

If a docking window is not visible, the View menu option will redisplay any of the four 
windows. 

To move a docking window from dock to float, either drag window title bar to a new 
location or double click the title bar. 

To move a docking window from float to dock, either drag the window title bar to one 
of the four window edges (top, bottom, left, right) or double click the title bar.  

Properties Windows 
Properties values are shown in certain docking windows, such as the Dyno Setup  Properties as 
shown below.  
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Figure 14: Dyno Setup Properties Docking Window 

All property windows share the same behavioral traits, such as: 

• 

• 

• 

Properties displayed in bold font may be modified. 

Properties display in grey font cannot be changed.  

Any property changes are immediately saved to disk. 

To change a property value, click the parameter and type in a new value. The change is 
immediately saved to disk.  

Navigation Docking Window 
The Navigation docking window is used to switch main screen.  
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Figure 15: Navigation Docking Window 

To switch screens, perform these steps: 

1 

2 

Click one of main group buttons.  

Click an item icon from within that group. 

For instance, to select the Acceleration screen, select the Dyno group then click the 
Acceleration icon. 

File Properties Docking Window 
Live Data, Power Torque, and Acceleration files properties are viewed and changed from the 
File Properties docking window.  
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Figure 16: File Properties Docking Window 

The File Properties docking window shows different properties depending on the active 
screen. 

Table 3: File Properties Displayed 

Active Screen File Properties Displayed 
Live Data Live Data file 
Power Torque Power Torque file 
Acceleration Acceleration file 
All other screens No properties are displayed 
 

For instance, to view Live Data file properties within the File Properties docking window, select 
the File > Open > Live Data File… menu option to open a file then switch to the Live Data 
screen. 

Dyno Setup Properties Docking Window 
The Dyno Setup file properties are viewed and changed from the Dyno Setup Properties 
docking window.  
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Figure 17: Dyno Setup Properties Docking Window 

To view Dyno Setup file within the Dyno Setup Properties docking window, select the File > 
Open > Dyno Setup File… menu option to open a file. 

Run Statistics Docking Window 
The Run Statistics docking window shows statistical values for Power Torque and Acceleration 
curves, such as maximum horsepower or top speed. 

 

Figure 18: Run Statistics Docking Window 

For instance, to view Power Torque statistics within the Run Statistics docking window, select 
the File > Open > Power Torque File… menu option to open the file then switch to the Power 
Torque screen. 
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Toolbars 
Toolbar locations, docking position, buttons shown, and sizes are completely user 
customizable. Each time you start the program; the toolbar settings and position is restored if 
the “Restore last user parameters when starting program” option is selected (see Options 
Dialog). 

• To move a docked toolbar, left mouse click and drag the vertical dashed line on a 
toolbar. Alternatively, double click the dashed line to move the toolbar into a floating 
position. 

 

• To move a floating toolbar, left mouse click the title bar and drag to its new location. 
Alternatively, double click the title bar to put the toolbar back into its docked position. 

 

• 

• 

To move toolbar to a new docked location, left mouse click and drag the toolbar to a 
new edge of the screen. The toolbar can be docked to any of the four application 
window edges (top, bottom, left, right).  

To customize the buttons shown on the toolbar, click the down arrow located on a 
docked toolbar to show a toolbar shortcut menu. Alternatively, right mouse click on 
any blank location within the toolbar area to show the shortcut menu. 

 

• To change to change various toolbar and menu options, such as enable/disable 
toolbars or change the icons from large to small, select the toolbar shortcut menu 
then select the Customize… option. 
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Figure 19: Customize Toolbars and Menus Dialog 

Status Bar 
The status bar is located at the bottom of the program screen. It displays the following 
information from left to right: 

Vehicle Connection Status – either Connected or Not Connected 

Connection Type – the vehicle hardware protocol connection type. For instance, 
PWM, VPW, CAN, ISO, or KWP. 

Data Mode – either Live or Play. Live mode means the data is originating from the 
vehicle. Play mode means the data is originating or recording to/from a file. 

Playback Percentage Bar Graph – the current playback file position as a percent. 

Open Live Data File – currently open Live Data file. 

Open Power Torque File – currently open Power Torque file. 

Open Acceleration File – currently open Acceleration file. 
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CHAPTER 5 

Scan Tool Operation 

The Dyno-Scan™ software is designed for easy operation. This section shows how to operate 
the software and describes the features on each screen.  

Not every vehicle is equipped with all sensor types supported by the scan tool. Therefore, the 
scan tool interrogates the vehicle and creates a custom list of sensors and options unique to 
the vehicle connected.  

 

Ensure the PC, cable, and OBD II adapter do not Interfere with the vehicle 
controls. A cable dangling in front of the foot pedals, gear shifter, or steering wheel 
can interferer with vehicle operation and cause a fatal accident. Always ensure the 
PC, cable, and OBD II adapter are securely fastened out of the way. If the scan tool 
and PC cannot be safely attached as to not interfere with the vehicle controls, then 
do not drive the vehicle with the OBD II adapter connected to the vehicle.  

Connect Scan Tool to Vehicle 
The scan tool must be connected to the vehicle’s diagnostic connector, except in 
demonstration mode where the vehicle data is simulated. See Demo Mode for more 
information about the demo mode.  

1 

2 

3 

Turn the vehicle ignition off.  

Connect the OBD II cable to the vehicle’s OBDII connector. Normally the vehicle connector 
is located under the dash on the driver’s side in plain sight.  

Turn the vehicle’s ignition on. Vehicle does not have to be running. For engine running 
tests, the vehicle can be started and idling. 

 

Do not operate the vehicle indoors. A running engine produces lethal carbon 
monoxide exhaust fumes that can seriously harm or kill you if inhaled. Only run the 
vehicle motor outdoors with proper ventilation.  

Start Dyno-Scan™ Software 
1 

2 

Start the Dyno-Scan™ software on the personal computer by double-clicking Dyno-Scan 
icon located your desktop. You can also start the software in different languages by 
selecting the Windows start button > Dyno-Scan > Español > Dyno-Scan. 

Once the software has started, select the File > Connect menu option.  
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3 On the Connect dialog, press the “Connect to Vehicle” button to connect to the vehicle. 
Selecting the Connect to Vehicle Demo checkbox to enable Demo mode see Demo Mode. 

 

Figure 20: Connect Dialog 

4 After a few seconds, the scan tool will detect the vehicle.  

Enhanced OBD II 
The scan tool supports optional enhanced OBD II upgrades. These upgrades can be purchased 
separately for certain makes of vehicle, like Ford, GM, Toyota and others. The enhanced 
features allow access to other vehicle systems like ABS, airbag (SRS), and others.  

A Product Key is purchased to unlock these features. Once the Product Key is obtained, it is 
entered into the Help > Product Registration Keys menu option. 

If you want to see what enhanced OBD II vehicles systems are supported before purchasing an 
enhanced upgrade, select a different make on the Vehicle Connection Type dropdown on the 
Connect dialog, and then press Connect to Vehicle. The software will detect the enhanced 
systems available on your vehicle such as ABS or airbag.  

Note the following when detecting enhanced OBD II vehicle systems: 

1. Upgrade to the latest Dyno-Scan for Windows software by download the upgrade 
from the Auterra web site (www.auterraweb.com).  

2. If you have an older OBD II adapter version, an adapter firmware update or new OBD II 
adapter may be required before all available vehicle systems are detected. Please 
contact Auterra for upgrade options available.  

General Information Screen 
The General Information screen contains two panes: Vehicle Monitor Test Status and Vehicle 
Information.  
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Figure 21: General Systems Screen 

The Vehicle Monitor Test Status pane shows the status of the vehicle’s built-in readiness 
monitor tests. Test statuses are either Complete or Incomplete. Other bit-encoded information 
is also displayed on this screen like fuel system status. Click on a column header to sort the 
parameters ascending alphabetically. Click the header again and it sorts descending.  

The software continually queries the vehicle to display current values on the Vehicle Monitor 
Test Status pane. 

The Vehicle Information pane shows vehicle specific information such as Vehicle Identification 
Number (VIN), Calibration IDs and Performance Tracking counters.   

Diagnostic Trouble Codes Screen 
The Diagnostic Trouble Codes screen has three panes: Stored Diagnostic Trouble Codes, 
Pending Diagnostic Trouble Codes, and Freeze Frame. 
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Figure 22: Trouble Codes Screen 

Stored and Pending Diagnostic Trouble Codes Pane 
The Stored and Pending Diagnostic Trouble Codes panes display the vehicle’s pending and 
stored Diagnostic Trouble Codes (DTC), if any. The Diagnostic Trouble Codes screen 
continually scans for new DTCs, even if some DTCs are already shown. 

All DTCs are displayed within 10 to 20 seconds. If the vehicle’s Check Engine or Service Engine 
Soon light on the instrument panel is illuminated, a stored DTC will be displayed. Pending 
DTCs do not necessarily indicate a faulty component/system. If the vehicle’s test results 
indicate a failure after additional driving, then the Check Engine light is illuminated and a DTC 
is set in the stored DTC pane.  

Two categories of trouble codes exist: generic and enhanced. Generic codes are standardized 
and common to all vehicle manufacturers. Enhanced codes are not uniquely defined and may 
overlap with another manufacture, or even the same manufacturer. For instance, multiple 
definitions may exist for code P1234. Ford may define it as “Engine Oil Pressure Too Low”, but 
Toyota’s definition could mean something different like “System Voltage Unstable”. The 
Diagnostic Trouble Codes screen reads and clears both generic and enhanced codes. 

There are four types of trouble codes: P (Powertrain), B (Body), C (Chassis), and U (Network 
Communication). The scan tool reads and clears all P-codes and, depending on the vehicle, B, 
C, and U-codes as well1. 

                                                               
1 Not all vehicles support retrieving and clearing B, C, and U-codes.  
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1. Switch to the Diagnostic Trouble Codes screen as described in the section Navigation 
Docking Window. 

2. If the vehicle has detected a Diagnostic Trouble Code(s) (DTC) they are listed in either 
the Stored or Pending Diagnostic Trouble Codes pane. Not all Diagnostic Trouble 
Codes cause the MIL light (i.e. Check Engine) to illuminate.  

3. If the MIL light is on (Check Engine), the Diagnostic Trouble Code that caused the light 
to illuminate is marked with a Yes in the “DTC Caused MIL” column. The Freeze Frame 
pane will contain a snapshot of a variety of sensor values at the time the error 
occurred (see Freeze Frame ).  Useful for diagnosing operating parameters of the 
vehicle at the time the MIL occured. 

4. If you wish to clear the MIL, select the Tools > Clear DTCs… menu option to clear all 
DTCs from the vehicle’s memory. Wait a few seconds after pressing Yes on the Clear 
Trouble Codes dialog for the scan tool to complete the clear command. 

5. Pressing Yes will clear the DTC from vehicle memory. Once cleared, the error codes 
cannot be recovered. Clearing also extinguishes the vehicle’s MIL (i.e. Check Engine) 
light and erases the vehicle’s freeze frame log. Sometimes the vehicle’s ignition must 
be turned off and on again before the Check Engine light turns off.  

 

Figure 23: Clear Trouble Codes 

6. Tapping the ‘+’ icon next a trouble code number will expand out the possible DTC 
textual descriptions. The software may not contain a description for every possible 
trouble code. If the software cannot find a description, please refer to your vehicle’s 
repair manual. See Diagnostic Trouble Codes for more information.  

Freeze Frame Pane 
The Freeze Frame pane displays the vehicle freeze frame log. Select the sensor units of 
measure, either English or Metric, using the Preferences screen (see Options Dialog). When a 
Diagnostic Trouble Code occurs that illuminates the Check Engine light, the vehicle’s 
computer saves the current values of the vehicle’s sensors at the instant the error occurred. If a 
freeze frame exists, it will display within a few seconds. Each vehicle supports a different 
complement of sensors. The Freeze Frame pane displays only sensors appropriate for the 
vehicle under test. This pane remains blank if no freeze frame information is available from the 
vehicle.  
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Record/Playback 
The Live Data screen can record and playback live sensor data. The recording and playback is 
controlled from the Playback menu option.  

The Record/Playback settings are: 

Live – display live data as it is occurring. 

Play – playback a previously recorded file.  

Stop – stop a playing file.  

Record – start recording live data. 

Pause – pause a file during playback.  

The Live Data panes have two modes of operation: Live and Play. When the Playback control is 
set to Live, all displayed parameters are live from the vehicle. If the Playback control is set to 
Play, Pause, Stop, or Record the scan tool is in the Play mode (see Status Bar).  

The recorded data is saved in a Live Data file. The Live Data files are open and created from the 
File > New and File > Open menu options.  

Once a file is open, selecting Record saves the data into the currently opened file. Similarly, 
Play plays back the currently opened file.  

New vehicle parameters are selected while in Live mode. Once the mode has switched to Play 
mode, new parameters cannot be added; always switch to Live mode to add/remove 
parameters via the Parameter Edit dialog.  

The playback speed does not use the same time-base as the original recording. Therefore, 
playback will be faster than when recorded. This makes it easier to review long recorded files.  

Playback position is controlled using the Playback > Set Playback Position control. 0% is the 
beginning of the file and 100% is the end.  

 

Figure 24: Set Playback Position Dialog 

A Live Data file saves a list of parameters recorded. The Parameter Edit dialog shows recorded 
parameters in the Parameter list box and the word “Play” is displayed as the Module. The 
Sample Speed control is hidden when in play mode. See Edit Parameters Dialog for more 
information.  

A typical Live Data record session proceeds as follows: 
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1. Switch to the Live Data screen as described in the section Navigation Docking 
Window. 

2. Ensure the Playback mode is set to Live by selecting the Playback > Live menu option.  

3. Create a new Live Data file by selecting File > New > Live Data File…  

4. Enter a file name, and press Open.  

5. Press the Options label in the upper right corner of the Graph pane. Alternatively, right 
mouse click anywhere in the Graph pane. Select the Edit Parameters menu option. 

6. Press the Add Parameter button.  

7. Select a sensor from the ECU Parameter box located on the right side of the dialog. 

8. Press OK.  

9. Set the Playback mode on the Playback > Record menu to start recording.  

10. Select the Playback > Stop menu option after a few seconds of recording.  

11. Select the Playback > Play menu option to playback the previously recorded file.  

Edit Parameters Dialog 
The Edit Parameters dialog selects a parameter to monitor, record, or playback. 

 

Figure 25: Parameter Edit Dialog 

Not every vehicle is equipped will all sensor types and not every vehicle supports every 
parameter type. Therefore, the software interrogates the vehicle and creates a custom, 
alphabetical listing of the parameters unique to the vehicle and module selected.  
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Sample Speed – selects the sampling speed for the sensor. High samples at up to 
40mS2, Med is about 3 seconds, and Low is about every 10 seconds per sample.  

Units of Measure – selects the units of measure for the sensor reading, either English 
or Metric.  

Parameters – selects the vehicle parameter to monitor. The list of sensors is 
dynamically created depending on the types of sensors supported by the vehicle.  

Add and Remove Parameters 
To add a Parameter, follow these steps: 

1 

2 

3 

4 

5 

6 

7 

8 

1 

2 

3 

4 

                                                              

Switch to the Live Data screen as described in the section Navigation Docking Window. 

Press the Options button in the upper right corner of the Graph pane. Alternatively, right 
mouse click anywhere in the Graph pane. Select the Edit Parameters menu option. 

Press Add Parameter. 

Select the Sampling Speed desired. 

Select the Units of Measure to display.  

Select the parameter to monitor within the ECU Parameters list box.  

Repeat the above process to add more parameters.  

Press OK.  

To remove a Parameter, follow these steps: 

Select the parameter to remove in the Parameter list. 

Press the Remove Parameter button. 

Repeat the above process to remove more parameters. 

Press OK. 

Supported Parameters 
The following is a list of all the live parameters supported by the software and a brief 
description of each parameter. Other non-live parameters, such as statuses or test results, are 
not listed here. 

Each parameter name ending with a number (e.g. “Average Economy 2”) provides the same 
data value as the non-numeric ending parameter. The distinction is the same parameter is 
obtained in different ways. 

Not every vehicle supports all parameters. A custom list of parameters is created unique to the 
vehicle connected. 

 
2 Actual sampling speed is vehicle dependant.  
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Parameter Parameter Parameter 

Average Economy 
Average Speed 
Battery Voltage 
Boost Pressure 
Digital In 1 
Distance Traveled 
Drive Time 
Fuel Cost 
Fuel Rate 
Fuel Used 
Idle Percent 
Idle Time 
Instant Economy 
Absolute Evap Vapor Pres 
Absolute Load Value 
Absolute Throttle Pos B 
Absolute Throttle Pos C 
Absolute Throttle Position 
Accelerator Pedal Pos D 
Accelerator Pedal Pos E 
Accelerator Pedal Pos F 
Actual EGR A Duty 
Actual EGR B Duty 
Actual Engine Torque 
Air Flow Rate From MAF 
Alcohol Fuel Percentage 
Ambient Air Temperature 
Avg Demanded 
Consumption 
Avg Reagent Consumption 
Barometric Pressure 
Boost Pressure A 
Boost Pressure B 
Calculated Load 
Catalyst Temp B1-S1 
Catalyst Temp B1-S2 
Catalyst Temp B2-S1 
Catalyst Temp B2-S2 
Chrg Air Cooler Temp B1S1 
Chrg Air Cooler Temp B1S2 
Chrg Air Cooler Temp B1S2 
Chrg Air Cooler Temp B2S1 
Cmd Boost Pressure A 
Cmd Boost Pressure B 

EGR Temperature B2-S2 
Engine Coolant Temp 
Engine Coolant Temp 1 
Engine Coolant Temp 2 
Engine Fuel Rate 
Engine Oil Temp 
Engine Reference Torque 
Engine RPM 
Engine Torque Idle Point 1 
Engine Torque Point 2 
Engine Torque Point 3 
Engine Torque Point 4 
Engine Torque Point 5 
Equivalence Ratio B1-S1 
Equivalence Ratio B1-S1 2 
Equivalence Ratio B1-S2 
Equivalence Ratio B1-S2 2 
Equivalence Ratio B1-S3 
Equivalence Ratio B1-S3 2 
Equivalence Ratio B1-S4 
Equivalence Ratio B1-S4 2 
Equivalence Ratio B2-S1 
Equivalence Ratio B2-S1 2 
Equivalence Ratio B2-S2 
Equivalence Ratio B2-S2 2 
Equivalence Ratio B2-S3 
Equivalence Ratio B2-S3 2 
Equivalence Ratio B2-S4 
Equivalence Ratio B2-S4 2 
Evap System Vapor Pres 
Evap System Vapor Press 
Exhaust Gas Temp B1-S1 
Exhaust Gas Temp B1-S2 
Exhaust Gas Temp B1-S3 
Exhaust Gas Temp B1-S4 
Exhaust Gas Temp B2-S1 
Exhaust Gas Temp B2-S2 
Exhaust Gas Temp B2-S3 
Exhaust Gas Temp B2-S4 
Exhaust Pressure B1 
Exhaust Pressure B2 
Fuel Injection Timing 
Fuel Level Input 
Fuel Rail Press Rel Manifold 

O2 B1-S2 Wide Range V 
O2 B1-S3 Wide Range mA 
O2 B1-S3 Wide Range V 
O2 B1-S4 Wide Range mA 
O2 B1-S4 Wide Range V 
O2 B2-S1 Wide Range mA 
O2 B2-S1 Wide Range V 
O2 B2-S2 Wide Range mA 
O2 B2-S2 Wide Range V 
O2 B2-S3 Wide Range mA 
O2 B2-S3 Wide Range V 
O2 B2-S4 Wide Range mA 
O2 B2-S4 Wide Range V 
O2 Sensor B1-S1 
O2 Sensor B1-S2 
O2 Sensor B1-S3 
O2 Sensor B1-S4 
O2 Sensor B2-S1 
O2 Sensor B2-S2 
O2 Sensor B2-S3 
O2 Sensor B2-S4 
PM Mass Concentrate B1-S1 
PM Mass Concentrate B2-S1 
Reagent Tank Level 
Rel Throttle A Position 
Rel Throttle B Position 
Relative Accel Pedal Pos 
Relative Intake Air A 
Relative Intake Air B 
Relative Throttle Position 
Run Time NOx Warn 
Short Fuel Trim B1-S1 
Short Fuel Trim B1-S2 
Short Fuel Trim B1-S3 
Short Fuel Trim B1-S4 
Short Fuel Trim B2-S1 
Short Fuel Trim B2-S2 
Short Fuel Trim B2-S3 
Short Fuel Trim B2-S4 
Short Term Fuel Trim B1 
Short Term Fuel Trim B2 
Short Term Fuel Trim B3 
Short Term Fuel Trim B4 
Shrt Term Sec Fuel Trim B1 
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Cmd Fuel Rail Pressure A 
Cmd Fuel Rail Pressure B 
Cmd Injection Pressure A 
Cmd Injection Pressure B 
Cmd Throttle Actuator A 
Cmd Throttle Actuator B 
Cmd Variable Turbo A 
Cmd Variable Turbo B 
Command Throttle Actuator 
Commanded EGR 
Commanded EGR A Duty 
Commanded EGR B Duty 
Commanded Equival Ratio 
Commanded Evap Purge 
Commanded Intake Air A 
Commanded Intake Air B 
Commanded Wastegate A 
Commanded Wastegate B 
Control Module Voltage 
Distance Since DTCs Clrd 
Distance Traveled MIL On 
DPF Delta Pressure B1 
DPF Delta Pressure B2 
DPF Inlet Pressure B1 
DPF Inlet Pressure B2 
DPF Inlet Temp B1 
DPF Inlet Temp B2 
DPF Outlet Pressure B1 
DPF Outlet Pressure B2 
DPF Outlet Temp B1 
DPF Outlet Temp B2 
Driver Demand Torque 
EGR A Error 
EGR B Error 
EGR Error 
EGR Temperature B1-S1 
EGR Temperature B1-S2 
EGR Temperature B2-S1 

Fuel Rail Pressure 
Fuel Rail Pressure (abs) 
Fuel Rail Pressure (gauge) 
Fuel Rail Pressure A 
Fuel Rail Pressure B 
Fuel Rail Temp A 
Fuel Rail Temp B 
Hybrid Battery Pack Life 
Ignition Timing Advance 
Injection Pressure A 
Injection Pressure B 
Intake Air Temp B1-S1 
Intake Air Temp B1-S2 
Intake Air Temp B1-S3 
Intake Air Temp B2-S1 
Intake Air Temp B2-S2 
Intake Air Temp B2-S3 
Intake Air Temperature 
Intake Manifold Abs PresA 
Intake Manifold Abs PresB 
Intake Manifold Pressure 
Long Term Fuel Trim B1 
Long Term Fuel Trim B2 
Long Term Fuel Trim B3 
Long Term Fuel Trim B4 
Long Term Sec Fuel Trim B1 
Long Term Sec Fuel TrimB2 
Long Term Sec Fuel TrimB3 
Long Term Sec Fuel TrimB4 
Manifold Surface Temp 
Mass Air Flow A 
Mass Air Flow B 
Minutes Run with MIL On 
NOx Concentration B1-S1 
NOx Concentration B2-S1 
O2 B1-S1 Wide Range mA 
O2 B1-S1 Wide Range V 
O2 B1-S2 Wide Range mA 

Shrt Term Sec Fuel TrimB2 
Shrt Term Sec Fuel TrimB3 
Shrt Term Sec Fuel TrimB4 
Time Since DTCs Cleared 
Time Since Engine Start 
Total Engine Idle Time 
Total Engine Run Time 
Total Engine Run w/PTO 
Total Run w/IE-ACED 1 
Total Run w/IE-ACED 10 
Total Run w/IE-ACED 2 
Total Run w/IE-ACED 3 
Total Run w/IE-ACED 4 
Total Run w/IE-ACED 5 
Total Run w/IE-ACED 6 
Total Run w/IE-ACED 7 
Total Run w/IE-ACED 8 
Total Run w/IE-ACED 9 
Turbo A In Compressor 
Turbo A In Turbine Temp 
Turbo A Inlet Pressure 
Turbo A Out Compressor 
Turbo A Out Turbine Temp 
Turbo A RPM 
Turbo B In Compressor 
Turbo B In Turbine Temp 
Turbo B Inlet Pressure 
Turbo B Out Compressor 
Turbo B Out Turbine Temp 
Turbo B RPM 
Variable Turbo A 
Variable Turbo B 
Vehicle Speed 
Warm-ups Since DTCs Clrd 
Wastegate A 
Wastegate B 

 

Air Fuel Ratio – overall air to fuel ratio of the vehicle being commanded by the vehicle ECU.  

Air Fuel Ratio BX-SX (up to 8) – air to fuel ratio of the vehicle computed for one bank (i.e. one 
oxygen sensor).  

Average Economy – the average fuel economy of the vehicle over time.  

Battery Voltage – the vehicle battery voltage. 
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Boost Pressure – the pressure measured within the intake manifold. 

Distance Traveled – distance traveled by the vehicle. This is not the odometer. 

Drive Time – the engine running time.  

Fuel Cost – the cost per gallon or liter of fuel.  

Fuel Used – amount of fuel used by the vehicle.  

Idle Percent – the ratio of Drive Time vs. Idle Time.  

Idle Time – the engine idling time defined as the motor running with the vehicle speed at 0.  

Instant Economy – is defined as the instantaneous fuel economy of the vehicle (e.g. MPG). 

Absolute Evap Vapor Pres – the evaporative system vapor pressure normally obtained from a 
sensor located in the fuel tank or a sensor in an evaporative system vapor line.  

Absolute Load Value – indicates a percentage of peak available torque. The normalized value 
of air mass per intake stroke displayed as a percent.  

Absolute Throttle Position (up to 3) – the absolute throttle position (not the relative or 
learned) throttle position. Usually above 0% at idle and less than 100% at full throttle. 

Accelerator Pedal Pos (up to 4) – the absolute pedal position (not the relative or learned) 
pedal position.  

Actual EGR A Duty (up to 2) – actual EGR displayed as a percent.  

Actual Engine Torque – the calculated output torque of the engine.  

Air Flow Rate From MAF – indicates the airflow rate as measured by the mass airflow sensor. 

Alcohol Fuel Percentage – percentage of alcohol fuel contained in ethanol or methanol fuels.  

Ambient Air Temperature – displays the ambient air temperature. 

Avg Demanded Consumption – average demanded reagent consumption by the engine 
system either over the previous complete 48 hour period of engine operation or the period 
needed for a demanded reagent consumption of at least 15 liters, whichever is longer.  

Avg Reagent Consumption – average reagent consumption by the engine system either over 
the previous complete 48 hour period of engine operation or the period needed for a 
demanded reagent consumption of at least 15 liters, whichever is longer. 

Barometric Pressure – barometric pressure normally obtained from a dedicated barometric 
sensor. Note some weather services report barometric pressure adjusted to sea level. In these 
cases, the reported value may not match the displayed value. 

Boost Pressure A (up to 2) –the actual turbocharger/supercharger pressure.  

Calculated Load Value – indicates a percentage of peak available torque. Reaches 100% at 
wide open throttle at any altitude or RPM for both naturally aspirated and boosted engines. 

Catalyst Temp Bank X – Sensor X (up to 4) –the catalyst substrate temperature. 

Chrg Air Cooler Temp BXSX – (up to 4) – the charge air cooler temperature.  
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Cmd Boost Pressure A (up to 2) – the ECU commanded turbocharger/supercharger pressure.  

Cmd Fuel Rail Pressure A (up to 2) – the commanded fuel rail pressure when the reading is 
referenced to atmosphere (gauge pressure). 

Cmd Injection Pressure A (up to 2) – the commanded injection control pressure.  

Cmd Throttle Actuator A (up to 2) – the commanded throttle actuator.  0% fully closed and 
100% fully open.  

Cmd Variable Turbo A (up to 2) – the variable geometry turbocharger commanded vane 
position as a percent.  

Commanded Throttle Actuator – displays 0% when the throttle is commanded closed and 
100% when the throttle commanded open. 

Commanded EGR (up to 3)  – display 0% when the EGR is commanded off, 100% when the 
EGR system is commanded on, and if the EGR is duty cycled somewhere between 0% and 
100%.  

Commanded Equival  Ratio – the commanded equivalence ratio (also known as lambda) 
while the fuel system. Fuel systems that use conventional oxygen sensors display the 
commanded open loop equivalence ratio while the system is in open loop. Should report 
100% when in closed loop fuel. Fuel systems that utilize wide-range/linear oxygen sensors 
shall display the commanded ratio in both open-loop and closed-loop operation.  

Commanded Evap Purge – displays 0% when no evaporative purge is commanded and 100% 
at the maximum commanded purge position/flow.  

Commanded Intake Air A (up to 2) – the commanded air intake displayed as a percent. Also 
known as EGR Throttle on compression ignition engineers.  

Commanded Wastegate A (up to 2) – the commanded wastegate position as a percent.  0% 
is fully closed (full boost) and 100% fully open (dump boost).  

Control Module Voltage – power input to the control module. Normally the battery voltage, 
less any voltage drop between the battery and the control module. 

Distance Since DTCs Cleared – distance accumulated since DTCs where cleared with a scan 
tool.  

Distance Traveled MIL On – accumulates the vehicle distance traveled while the MIL light is 
illuminated. 

DPF Delta Pressure BX (up to 2) – diesel particulate filter delta pressure.  

DPF Inlet Pressure BX (up to 2) – diesel particulate filter inlet pressure. 

DPF Inlet Temp BX (up to 2) – diesel particulate filter inlet temperature. 

DPF Outlet Pressure BX (up to 2) – diesel particulate filter outlet pressure. 

DPF Outlet Temp BX (up to 2) – diesel particulate filter outlet temperature. 

Driver Demand Torque – the requested torque output of the engine by the driver.  
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EGR Error (up to 3) – error as percent of actual commanded EGR. Negative percent is less than 
commanded and positive is more than commanded. 

EGR Temperature BX-SX (up to 4) – the EGR gas temperature.  

Engine Coolant Temp (up to 3) – engine coolant temperature derived from an engine 
coolant temperature sensor or a cylinder head temperature sensor. 

Engine Fuel Rate – amount of fuel consumed by the engine per unit of time in liters per hour.  

Engine Oil Temp – engine oil temperature.  

Engine Reference Torque – display the engine reference torque value. This value does not 
change.  

Engine RPM – displays the current engine revolutions per minute value. 

Engine Torque Idle Point – the torque limit that indicates the available engine torque that 
can be provided by the engine at idle speed.  

Engine Torque Point X (up to 4) – the torque limit that indicates the available engine torque 
that can be provided by the engine point X of the engine map.  

Equivalence Ratio BX-SX (up to 16) - is defined as the ratio of the fuel-to-oxidizer ratio to the 
stoichiometric fuel-to-oxidizer ratio. 

Evap System Vapor Press – evaporative system vapor pressure normally obtained from a 
sensor located in the fuel tank. 

Exhaust Gas Temp BX-SX – exhaust gas temperature.  

Exhaust Gas Pressure BX – exhaust gas pressure.  

Fuel Injection Timing – the start of the mail fuel injection relative to Top Dead Center (TDC). 
Positive degrees indicate before TDC. Negative degrees indicate after TDC.  

Fuel Level Input – indicates the nominal fuel tank liquid fill capacity as a percent of 
maximum. 

Fuel Rail Press Rel Manifold – displays the fuel rail pressure referenced to the manifold 
vacuum (relative pressure). 

Fuel Rail Pressure – indicates the fuel rail pressure at the engine referenced to atmosphere 
(gauge pressure). 

Fuel Rail Pressure (abs) – fuel rail pressure at the engine when the reading is absolute.  

Fuel Rail Pressure (gauge) – displays the fuel injection rail pressure at the engine when the 
reading is referenced to atmosphere (gauge pressure). 

Fuel Rail Pressure A (up to 2) – fuel rail pressure when the reading is referenced to 
atmosphere (gauge pressure). 

Fuel Rail Temp A (up to 2) – the fuel rail temperature.  

Fuel Rate – the rate at which fuel is consumed by the engine in gallons/hour or liters/hour.  
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Hybrid Battery Pack Life – the percent remaining life for the hybrid battery pack.  

Ignition Timing Advance – ignition timing advance for #1 cylinder (not including any 
mechanical advance). 

Injection Pressure A (up to 2) - the injection control pressure.  

Intake Air Temp BX-SX – displays the intake manifold air temperature.  

Intake Air Temperature – displays the intake manifold air temperature. 

Intake Manifold Abs PresA (up to 2) – intake manifold absolute pressure.  

Intake Manifold Pressure – indicates the manifold pressure derived from a Manifold 
Absolute Pressure sensor. 

Long Term Fuel Trim-BX (up to 4) – indicates the correction being used by the fuel control 
system in both open and closed loop modes of operation. 

Long Term Fuel Trim BX-SX (up to 8) - indicates the correction being used by the fuel control 
system in both open and closed loop modes of operation. 

Manifold Surface Temp – intake manifold surface temperature.  

Mass Air Flow A (up to 2) – airflow rate as measured by a vehicle MAF sensor or an equivalent 
source.  

Minutes Run with MIL On – accumulated minutes of engine run time while the MIL light is 
on. 

NOx Concentration BX-SX (up to 2) – NOx concentration.  

O2 Sensor BX-SX Wide Range mA (up to 8) – shows milliamps for linear or wide-ratio oxygen 
sensors.  

O2 Sensor BX-SX Wide Range V (up to 8) – shows voltage for linear or wide-ratio oxygen 
sensors. 

O2 Sensor BX-SX (up to 8) – indicates the voltage for conventional 0 to 1V oxygen sensors. 
O2 sensors with a different full-scale voltage shall be normalized to this range or, if a wide 
range sensor, may use the wide range parameters instead. 

PM Mass Concentration BX-SX (up to 2) – particulate matter mass concentration.  

Reagent Tank Level – nominal reagent tank liquid fill capacity as a percent of maximum.  

Rel Throttle A Position (up to 2) - relative or “learned” throttle position. 

Relative Throttle Position – relative or “learned” throttle position. 

Relative Accel Pedal Pos - relative or “learned” pedal position. 

Relative Intake Air A (up to 2) – actual intake airflow position displayed as a percent. Also 
knows as EGR Throttle Position on compression ignition engines.  

Run Time NOx Warn – run time of the engine while NOx warning mode is activated.  
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Short Term Fuel Trim-BX (up to 4) – indicates the correction being used by the closed loop 
fuel algorithm. If the fuel system is open loop, 0% correction should be reported. 

Short Term Fuel Trim BX-SX (up to 8) - indicates the correction being used by the closed 
loop fuel algorithm. If the fuel system is open loop, 0% correction should be reported. 

Short Term Sec Fuel Trim BX (up to 4) – short term secondary O2 sensor fuel trim shall 
indicate the correction being utilized by the closed-loop fuel algorithm. If the fuel system is 
open loop, 0% correction should be reported. 

Time Since DTCs Cleared – engine run time accumulated since DTCs were cleared.  

Time Since Engine Start – indicates the elapsed time since the engine was started while the 
engine is running. 

Total Engine Idle Time – total engine idle time for the life of vehicle.  

Total Engine Run Time – total engine run time for the life of vehicle. 

Total Engine Run w/PTO – total engine run time with PTO (power take off) engaged for the 
life of the vehicle.  

Total Run w/IE-ACED X (up to 10) – total engine run time with Emission Increasing Auxiliary 
Emission Control Device active for the life of the vehicle.  

Turbo A In Compressor (up to 2) – turbocharger compressor inlet temperature.  

Turbo A In Turbine Temp (up to 2) – turbocharger turbine inlet temperature.  

Turbo A Inlet Pressure (up to 2) – turbocharger inlet pressure.  

Turbo A Out Compressor (up to 2) – turbocharger compressor outlet temperature.  

Turbo A Out Turbine Temp (up to 2) – turbocharger turbine outlet temperature. 

Turbo A RPM (up to 2) – turbocharger revolutions per minute.  

Variable Turbo A (up to 2) – variable geometry turbocharger actual vane position as a 
percent. 0% when vanes are fully bypassed and 100% when the vanes are fully utilized.  

Vehicle Speed – displays the vehicle road speed. 

Warm-ups Since DTCs Cleared – number of warm-up cycles since all DTCs were cleared via a 
scan tool. A warm-up is defined as the coolant temperature rising by at least 22°C (40°F) and 
the engine temperature reaches at a minimum 70°C (160°F) (60°C (140°F) for diesels). 

Wastegate A (up to 2) – actual wastegate position as a percent. 0% wastegate is off (allow full 
boost) and 100% fully open (dump boost).  

Live Data Screen 
The Live Data screen has two panes: List and Graph.  
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Figure 26: Live Data Screen 

The Live Data screen supports recording and playback of live data. See Record/Playback for 
more information. 

The Options button in the upper right corner of each pane provides a menu of options. 
Alternatively, right mouse clicking inside any pane displays the Options menu.  

Panes are added or deleted using the Options menu items Add Graph Pane, Add List Pane, 
and Delete Pane. 

List Pane 
The List pane displays real-time sensor readings from the vehicle in a list format. Any number 
of sensors can be monitored simultaneously. Note the more sensors selected, the slower the 
update interval of each sensor.  

1 

2 

3 

4 

5 

6 

7 

Switch to the Live Data screen as described in the section Navigation Docking Window. 

Press the Options button in the upper right corner of the List pane. Alternatively, right 
mouse click anywhere in the List pane. Select the Edit Parameters menu option. 

Press the Add Parameter button.  

Select a sensor from the ECU Parameters list box located on the right side of the dialog. 

Press OK. 

Live data now displays in the List pane.  

Selecting Live Data > Hold temporarily suspends updating the Live data display. Selecting 
Hold again resumes sensor sampling. 

 

52 Scan Tool Operation   



 

The List pane shows these values: 

Parameter – the selected parameter. 

Value – the last measured parameter reading. 

Units – the units of measurement for the Value. 

Min – the minimum Value measured. 

Max – the maximum Value measured. 

Bar Graph – the current Value reading in relation to the absolute minimum and 
maximum parameter values. 

To reset the Min and Max values, select Options > Reset Min Max.  

Graph Pane 
The Graph pane displays real-time sensor readings from the vehicle in a line graph format. 
Two sensors at a time may be monitored simultaneously on one Graph pane. More panes are 
added using the Options > Add Graph Pane option.  

The Live Data menu options Zoom in X, Zoom in Y, Zoom out X, and Zoom out Y zoom the 
graph - vertically and horizontally. Each trace can be zoomed on the vertical axis independent 
of the other trace by using the zoom in/out buttons next to the scroll bars. The horizontal axis 
zooms both traces together.  

When changing vertical zoom levels, the minimum and maximum display value labels change 
to reflect the new range. The current sensor reading will always display the correct value 
irrespective of the zoom range or graphical clipping.  

Data values exceeding the vertical graph limits, either high or low, will be clipped at the 
vertical maximum/minimum graph value. 

The graph control has a virtual trace buffer that stores many pages of graph information. Scroll 
right and left using the control a the bottom of the graph pane to view all the data within the 
trace buffer.  

Exact measurement values for any data point along the trace can be shown using the marker. 
The marker is a vertical dashed line within the graphing area. A left mouse click within the 
graph boundaries sets the marker position. The data point under the marker for each axis will 
update as the marker is moved about the graphing area.  

Pressing zoom in will center the horizontal axis display around the marker. This facilitates 
selecting a point of interest with the marker, then zooming in the horizontal axis to examine 
the data point.  

The sensor Sample Speed (High, Medium, or Low) for each trace must be the same on the 
Graph screen. The software enforces identical sample speeds.  

1 

2 

Switch to the Live Data screen as described in the section Navigation Docking Window. 

Press the Options button in the upper right corner of the Graph pane. Alternatively, right 
mouse click anywhere in the List pane. Select the Edit Parameters menu option. 
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3 Press the Add Parameter button.  

4 

5 

6 

7 

Select a sensor from the ECU Parameters list box located on the right side of the dialog. 

Press OK. 

Live data now displays on the Graph pane.  

Selecting Live Data > Hold temporarily suspends the Live display. Selecting Hold again 
resumes sensor sampling. 

Oxygen Sensors 
The Oxygen Sensors screen has two panes: Oxygen Sensor Test Results and Oxygen Sensor 
Output Legend.  

 

Figure 27: Oxygen Sensors Screen 

Oxygen Sensors Test Results Pane 
The Oxygen Sensors Test Results pane displays the vehicle’s oxygen sensor test results. The 
results displayed here are computed/measured by the vehicle’s on-board computer (ECU) last 
successful test.  These tests are performed internally by the vehicle and are not initiated by the 
scan tool. These are not live values but instead the results of the ECU’s last O2 sensor test. For 
live O2 sensor readings, refer to any of the live sensor screens such as Graph Pane, selecting 
the desired O2 sensor parameters 

For these test results to accurate, the Oxygen Sensor test on the in the Vehicle Monitor Status 
section within the Vehicle Monitor Test Status pane should have a Test Status of Complete. 

 

54 Scan Tool Operation   



 

Not all test values are applicable to all vehicles. Therefore, the list generated will vary 
depending on the vehicle. In addition, not all vehicles support the Oxygen Sensors screen. If 
the vehicle or a particular sensor does not support this feature, the screen list will be blank.  

The test values measured by the ECU correspond to certain attributes of the O2 sensor voltage 
over time waveform as shown the Oxygen Sensor Output Legend Pane. 

1 

2 

Switch to the Oxygen Sensors screen as described in the section Navigation Docking 
Window. 

Press the “+” icon next to the Sensor Location to display the sensor results.  

The Oxygen Sensors Test Results displays these values: 

Parameter – an oxygen sensor parameter. 

Value – the ECU measured test result 

Min - the minimum test limit for which the measured test result is compared. 

Max - the maximum test limit for which the measured test result is compared. 

Units – the units of measure for the Value. 

Oxygen Sensor Output Legend Pane 
The Oxygen Sensor Output Legend Pane shows an oxygen sensor voltage over time waveform 
illustration. Each parameter with in the Oxygen Sensors Test Results pane is measured is 
shown on the illustration.  

Test Results Screen 
The Test Results screen shows the results for on-board diagnostic monitoring test of specific 
components / systems that are continuously monitored (e.g. mis-fire monitoring) and non-
continuously monitored (e.g. catalyst system).  

The Test Results pane displays the vehicle ECU’s test results. The results displayed here are 
computed/measured by the vehicle’s on-board computer (ECU) last successful test.  These 
tests are performed internally by the vehicle and are not initiated by the scan tool. These are 
not live values but instead the results of the ECU’s last test.  

Not all test values are applicable to all vehicles. Therefore, the list generated will vary 
depending on the vehicle. In addition, only vehicles using CAN communication protocol are 
supported on this screen. If the vehicle or a particular sensor does not support this feature, the 
screen list will be blank.  

The Test Results displays these values: 

Parameter – a test result parameter. 

Value – the ECU measured test result 

Min - the minimum test limit for which the measured test result is compared. 

Max - the maximum test limit for which the measured test result is compared. 
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Units – the units of measure for the Value. 

 

Figure 28: Test Results Screen 

On-Board Tests Screen 
The On-Board Tests screen shows the bi-directional controls supported by the vehicle. Bi-
directional on-board tests are commands sent by the scan tool to the vehicle to perform some 
action.  

The Bi-Directional Control pane shows the tests supported by the vehicle. If the vehicle does 
not support any bi-directional controls, the screen will remain blank. To run an on-board test, 
select the test to run then press the Run Selected On-Board Test. The vehicle will respond to 
the command with a status shown in the Status column.  

Table 4: Status Messages 

Status Meaning 
Complete Indicates the vehicle completed the requested action 

successfully. 
General Reject Indicates that the service requested was rejected but the 

vehicle ECU did not specify the reason of the rejection. 
Service Not Supported Indicates that the requested action will not be taken because 

the vehicle ECU does not support the requested service. 
Sub Function Not Supported Indicates that the requested action will not be taken because 
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– Invalid Format the vehicle ECU does not support the arguments of the 
requested message. 

Busy – Repeat Request Indicates the vehicle ECU is temporarily too busy to perform 
he requested operation. 

Conditions Not Correct Or 
Request Sequence Error 

Indicates that the requested action will not be taken because 
the vehicle ECU prerequisite conditions are not met. May also 
occur when sequence sensitive requests are issued in the 
wrong order. 

 

The Bi-Directional Test Description pane provides a description for the currently selected bi-
directional control within the Bi-Directional Control pane. 

 

Figure 29: On-Board Tests Screen 

Analyze Live Data Screen 
The Analyze Live Data screen provides a view of the entire live data recording. Whereas the 
Live Data screen plays back the recorded data, the Analyze Live Data screen shows the 
recorded data all at once.  

The Analyze Live Data screen is a data analysis tool. Numerous options are available for 
viewing the data, such as a stacked or side-by-side view, hiding traces, zoom in and out, and 
markers showing each data point.  
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Figure 30: Analyze Live Data Screen (Side-By-Side) 
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Figure 31: Analyze Live Data Screen (Stacked) 

A right mouse button click on these graph elements brings up a shortcut menu for additional 
options.  

• 
• 
• 

X-Axis 
Y-Axis 
Data-Cursor 

Viewing Recorded Live Data  
To open on the Analyze Live Data screen, select the File > Open > Live Data File… menu 
option.  

To create a file for analysis, select the File > New > Live Data File… menu option and then go 
to the Live Data screen to record data into the file. See Live Data Screen for more information.  

Analyze Tool Bar 
The toolbar provides quick and easy control over the function of the chart.  

Button Meaning 

 
Resume Button: Shows all data on all axes.  
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Pause Button: Pauses tracking for all axes. 

  
Axes Mode Buttons: Changes the mode that the axes are in when using the 
mouse. The first icon puts the axes in scroll mode. The second icon puts the 
axes in zoom mode. TIP: Press the Ctrl keyboard key to toggle between the two 
modes.  

  
Zoom In/Out Buttons: Zooms all axes in or out. 

 
Select Button: Used for selecting items in the data view area.  

 
Zoom Box Button: Allows the user to draw a "Zoom Box" to zoom ALL axes. 

 
Data Cursor Button: Show or hide all data cursors. Values for each channel are 
displayed in a hint window next to the cursor(s). 

 
Copy Button: Copies the current component image to the clipboard. 

 
Save Button: Save chart data to an image or data file.  

 
Print Button: Print image of chart to printer. 

Options Button 
The Options dropdown button on the upper right corner of the Analyze Live Data graph title 
bar provides a menu to graph features. 

Shortcut Menu Meaning 
Side-By-Side View Switches between Side-By-Side view and the Stacked view.  
Show Markers Shows a round dot on each data point. 
Show File Name Shows the file name at the top of the graph. 
Show Legend Shows a trace legend on the right side of the graph. 
Show All Parameters Shows every parameter on the screen. 
Hide All Parameters Hides all parameters on the screen. 
Parameters Shows/hides individual parameters on the graph.  

Axis Control 
The chart has two axes, one x-axis (horizontal) and one or more y-axis (vertical). Each axis 
shows the name of the parameter, units of measure, and numbers showing the axis scale.  

The chart has two main modes, Axis Scroll mode and Axis Zoom mode. The modes are 
switched using the Axis Scroll or Axis Zoom buttons on the toolbar. 

Many options require dragging, which means pressing and holding the left mouse button 
while moving the mouse is a direction.  

Zoom All Axes 
Toolbar Zoom: All axes can be zoomed together using the toolbar. 
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1 Left mouse click anywhere inside the line graphing area (a dotted box will surround the 
entire axes and line graphing area). 

2 

1 

2 

1 

2 

3 

1 

2 

3 

1 

2 

1 

1 

2 

Press the Zoom In or Zoom Out toolbar button.  

Zoom-Box Zoom: All axes can be zoomed using the Zoom-Box tool. 

Select the Zoom-Box button on the toolbar. 

Click inside the line graph area and drag a dotted line box around the area to zoom in. 

Mouse Zoom: The entire graph area can be dynamically zoomed using the mouse. 

Press the Axes Zoom toolbar button. 

Press the Select toolbar button. 

Drag the line graphing area to dynamically zoom both the x and y-axes. Drag left and right 
zooms the x-axis, and up and down zooms the y-axis. 

Zoom One Axis 
Toolbar Zoom: Each axis can be zoomed independent of the other using the toolbar zoom 
buttons.  

Press the Axis Zoom toolbar button. 

Select an axis to zoom with the left mouse button (a dotted box will surround the axis). 

Press the Zoom In or Zoom Out toolbar button.  

Mouse Zoom: Each axis can be dynamically zoomed using the mouse. 

Select the Axis Zoom button on the toolbar. 

Drag an axis to zoom in and out.  

Shortcut Menu Zoom: The software can also zoom a parameter to fit the entire graphing 
area. 

Right mouse click an axis and select from the shortcut menu Zoom To Fit > All or Zoom To 
Fit > In-View. The All option zooms the line based upon the data points in the entire 
recorded file. The In-View option only zooms the data points that are visible within the 
graphing area. 

Scroll One Axis 
Mouse Scroll: Once an axis is zoomed, it can be scrolled up and down.  

Press the Axis Scroll toolbar button. 

Drag an axis to scroll.  

Scroll All Axes 
Mouse Scroll: The entire graph area can be scrolled in any axis direction by mouse dragging. 
The chart must be zoomed on at least 1 axis before you can drag the chart.  
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1 Press the Axis Scroll toolbar button. 

2 

1 

2 

1 

2 

• 
• 
• 
• 
• 
• 

Drag the graph in any direction causes dynamic zooming in and out. 

Data-Cursor Control 
The Data-Cursor is a red crosshair within the graphing area. Dragging the crosshair vertical line 
moves the cursor. As the cursor is moved, the tooltip shows the current x/y value. If the 
Options > Show Markers is on, round markers will mark each individual data point. Tooltip 
values between actual marker data points are interpolated.  

The data cursor can be moved to a data point marker. 

Drag the cursor close to the marker you want to measure.  

Release the left mouse button. The cursor will snap to the closest marker providing an 
exact value of the data point.  

Moving the data-cursor between parameters uses the shortcut menu.  

Right mouse click anywhere on the cursor crosshair lines. 

Select Channel from the shortcut menu, then the parameter to monitor.  

The data-cursor has many different measurement modes selected from the Style shortcut 
menu: 

Value-XY 
Value-X 
Value-Y 
Period  
Peak-Peak 
Frequency 

Analyze Data Export 
The Analyze Live Data screen can export data into a data file or graphics file.  

Save Button 
The Save button on the graph toolbar can save the graph as a graphics image file or as a text 
data file (.dat). The text data file is saves a series of X and Y values for each parameter. The file 
can be opened with any text editor or with a spreadsheet such as Microsoft Excel.  

Copy Button 
The Copy button on the graph toolbar can copy the data into the Windows clipboard as either 
a graphics image file or as text data. Once copied, the data can be pasted into another 
application such as word processor.  

Playback 
Pressing the Play button on the Playback Control toolbar plays the data on the Analyze Live 
Data screen. The tooltip on the Data Cursor will continually update as the data plays back. The 
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Playback Pause or Stop button halts playback. Playback is particularly useful in conjunction 
with the Google Earth feature. See Google Earth on page 80 for more information.  

Code Search Screen 
The Code Search dialog provides an interactive search of diagnostic trouble code definitions 
(DTCs).  

 

Figure 32: Code Search Dialog 

Generic codes and enhanced codes have predefined numeric ranges as shown in Table 5: DTC 
Groupings.  

Table 5: DTC Groupings 

ISO/SAE Controlled (Generic) Manufacturer Controlled (Enhanced) 
P0000 to P0999 P1000 to P1999 
P2000 to P2999 P3000 to P3399 
P3400 to P3999  
 

1 

2 

3 

Select the Tools > Code Search… menu option.  

Type a code into the Code to Search field (e.g. P1234). The code must start with a P, B, C or 
U and end with a 4-digit number.  

Press the Search button. If a definition is found, it will display in the Search Results table.  

Import 
The Import feature allows users with the Dyno-Scan™ for Palm OS software product to import 
files recorded on a Palm OS device. Acceleration, Power Torque, and Scan Data files may be 
imported and viewed within the Dyno-Scan for Windows software. 

The Import feature is located on the File > Import > Palm PDB File… menu option.   

Export 
The Export feature allows files to be exported into a comma separated values (CSV) file format. 
Acceleration, Power Torque, and Scan Data files may be exported.  
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The Export feature is located on the File > Export > Comma Separated Values… menu option.
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CHAPTER 6 

Dyno Operation 

The Dyno software is designed for easy operation. This section shows how to operate the 
Dyno features and describes the features on each screen.  

Dyno operations require driving the vehicle while the software records performance data. For 
increased safety, the software does not require user intervention during the test runs. All data 
is recorded for later analysis and audible tones are used to convey instructions to the user 
while driving.  

 

Ensure the PC, cable, and OBD II adapter do not interfere with the vehicle 
controls. A cable dangling in front of the foot pedals, gear shifter, or steering wheel 
can interfere with vehicle operation and cause a fatal accident. Always ensure the 
PC, cable, and OBD II adapter are securely fastened out of the way. If the scan tool 
cannot be safely attached as to not interfere with the vehicle controls, then do not 
drive the vehicle with the OBD II adapter connected to the vehicle.  

 

 

Never race or exceed the posted speed limit while on public highways. The 
dynamometer operations require accelerating to high speeds. Always uses a closed 
course raceway when performing dynamometer and acceleration tests.  

 

 

Do not attempt to operate or observe the scan tool while driving a vehicle. 
Driving requires the full attention of the driver. Operating or observing the scan tool 
will cause driver distraction and could cause a fatal accident.  

Theory of Operation 
A dynamometer, or dyno for short, is used to measure the power produced by an engine. Until 
now, automotive dynos were either crankshaft dynamometers or chassis dynamometers.  

Crankshaft dynos require the motor to be removed from the vehicle. The power is measured 
directly at the crankshaft, or flywheel, and is not affected by transmission and axle powertrain 
losses. Vehicle manufacturers spec crankshaft power on new cars and trucks.  

Chassis dynos test the entire vehicle. The vehicle is tied down to a large machine and the drive 
wheels are placed over a rotating drum. The chassis dyno tests the entire powertrain system, 
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not just the crankshaft power. This is a more realistic test since it measures the power 
delivered to the wheels, not just the crankshaft. As such, the power figures measured are 
always less than with a crankshaft dyno since the powertrain robs some power from the 
vehicle.  

Clearly pulling the motor to use a crankshaft dyno is beyond most people, and chassis dynos 
can run $150 and hour or more to operate.  

Auterra Dyno-Scan™ for Windows 
The Auterra Dyno-Scan™ for Windows software is a newly developed device designed 
expressly for the automotive enthusiast. It uses the OBD II computer port located on all 1996 
and newer automobiles to compute engine power, acceleration times, fuel economy, and 
more.   

The Dyno-Scan™ for Windows is the only dyno to test the vehicle in a completely real world 
situation that includes powertrain losses, drag from disk brakes and wheel bearings, tire 
rolling resistance, etc. – everything a vehicle sees on the street.  

Aerodynamic drag is compensated for within the calculations. So, whether your vehicle has 
the aerodynamics of a Chevy Suburban or a Porsche 911, the power calculations can correct 
for losses due to wind drag.  

Weather conditions affect the output of an internal combustion motor. A correction factor is 
applied to compensate the measurements for weather conditions and elevation. The industry 
standard document for horsepower and torque corrections is SAE J1349. The Dyno-Scan™ for 
Windows software applies this correction factor to all horsepower and torque measurements.  

By applying these correction factors to the dyno results, a vehicle dyno'd in Denver on a hot 
day will give the same results as a chilly day in San Diego. Using the Dyno-Scan™ for Windows, 
measurements generated are comparable with one another the world over.  

The dyno runs are performed in a single gear. Any gear will work, however increased accuracy 
is obtained if the software has an increased measurement duration. For instance, the time to 
accelerate from 1000 RPM to 5000 RPM in 1st gear is a shorter duration than it would be in 3rd 
gear. Therefore, using 2nd or 3rd gear for dyno runs offers longer test durations for greater 
accuracy.  

Extensive comparison testing on a Dynojet chassis dynamometer has shown the Dyno-Scan™ 
for Windows to be extremely accurate.  

Automatic Transmissions 
All automatic transmissions are equipped with a torque converter. The torque converter is 
designed to slip under certain conditions, such as at low RPM and under heavy load. When the 
torque converter slips, the gear ratio is artificially lower and the RPM is higher than if the 
torque converter is locked up in direct drive. At cruising speeds and under low load 
requirements, the torque converter locks up for increased fuel economy.  

Under heavy acceleration, the slippage is greatest below 3000 RPM. Above 3000 RPM the 
slippage is still evident but to a lesser degree.  
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A slipping torque converter is perfectly normal. Automatic transmissions are designed to slip, 
which gives them some advantages when towing a heavy load. However, this causes an 
anomaly known to all chassis dynos and the Dyno-Scan™ for Windows.  

Since the RPM is higher than normal while the torque converter is slipping below 3000 RPM, 
the power vs. torque graphs may display an unnaturally large swell below 3000 RPM. This 
swell is the torque converter multiplying the engines available torque. The swell is normal and 
all dynos exhibit this behavior. The power torque figures above 3000 RPM are the real 
numbers generally used for evaluation. 

 

Figure 33: Power Torque Run Automatic Transmission 

Fast Sampling 
The Fast Sampling preference on the Options dialog must be enabled to achieve accurate 
dyno operation. Ensure this option is selected whenever using Dyno features.  

Dyno Files 
The Dyno feature use three storage file types: 

Power Torque – stores Power and Torque run data. 

Acceleration – stores Acceleration run data.  

Dyno Setup – stores Dyno setup variables such as vehicle weight, elevation, humidity, 
etc. 

Each of the files may be opened or created from the File > Open or File > New menu option.  
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The properties of each file may be viewed and modified in either the File Properties or Dyno 
Setup Properties docking window. See Properties Windows for more information. 

Dyno Setup File Properties 
The Dyno Setup file properties are changed on the Dyno Setup Properties Docking Window. 
The file attributes are: 

File – file name. 

File Full Path –file name and path.  

Weight – weight of the vehicle including passengers during the run.  

Gear Ratio – the overall gear ratio of the vehicle, which includes transmission and 
axle. 

Tire Diameter – the vehicle tire diameter. 

Temperature – current outside temperature. 

Elevation –elevation at the test track. 

Humidity – current outside humidity.  

Pressure – current outside altimeter pressure available from www.nws.noaa.gov. 
Altimeter pressure is different than barometric pressure.  

Drag Coef – drag coefficient of vehicle.  

Frontal Area – the frontal area of the vehicle. 

Note – an optional text note.  

Make – Vehicle make. 

VIN – vehicle identification number. 

Year – model year of vehicle. 

The software can measure the gear ratio and compute the tire diameter for you. See Compute 
Gear Ratio  for more information. 

Drag Coefficient and Frontal Area 
Common drag coefficients are usually in the range of 0.25 to 0.45 – the lower the number the 
less wind drag on the vehicle.  

Frontal areas are usually in the range of 17 to 28 sq. ft – the lower the number the less frontal 
area. Smaller vehicles have lower frontal areas.  

To get an understanding for these numbers, Table 6: Drag Coefficients and Frontal Areas list 
the values for different vehicle types.  
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Table 6: Drag Coefficients and Frontal Areas 

Vehicle Drag Coefficient Frontal Area (sq/ft) 
2005 BMW 325i 0.30 22.7 
2005 Chevrolet Corvette Z06 0.31 22.4 
2006 Porsche Cayman 0.29 21.3 
1999 Chevy Cavalier 0.36 21.5 
2000 Ford Taurus 0.32 23.7 
2000 Chevy Silverado 1500 2WD 0.45 28.0 
2000 Ford Explorer 0.45 25.8 
2002 Honda Insight 0.25 20.5 
2002 Honda Civic Hatchback 0.36 20.5 
2000 Acura Integra 0.32 20.1 
2000 Volvo S40 0.32 20.9 
2000 Mercedes E320 0.29 22.3 
2000 Chrysler LHS 0.31 23.1 

 
See the Auterra Vehicle Specifications document for more information on your specific vehicle 
make and model. 

An Internet search is another good source of drag coefficients, frontal areas and vehicle 
weights. The web site www.carfolio.com has specifications for thousands vehicles. 

Many frontal areas on the Internet are listed in metric square meter (m2). To convert to square 
feet (f2) multiply the metric frontal area by 10.76.  

2.11 m2 x 10.76 = 22.71 f2 

Calculation of Frontal Area 
Frontal area can be calculated for any car. The frontal area represents the front projection area 
of the vehicle. If one takes a straight-on picture of the front of a vehicle, it is the area included 
in the outline. Use the following to calculate:  

1. Calculate the area of a rectangle, which would encompass the front of the vehicle 
(multiply width by the height).  

2. Adjust the figure obtained above for areas not included, such as top rounded corners, 
etc. Typical adjusting values are 85 percent for cars, and 100 percent for trucks. 

Dyno Setup File Properties Usage 
The Dyno Setup file stores vehicle setup variables. When a power torque run is performed, the 
Dyno Setup file settings are copied into the Power Torque file. Similarly, the current Dyno 
Setup file is copied into the Acceleration file for acceleration runs.  

Once the settings are copied from the Dyno Setup file to the Power Torque or Acceleration file, 
there is no tie to the original Dyno Setup file. Meaning if you change a Dyno Setup file, it does 
not affect any stored Power Torque or Acceleration properties. 
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Compute Gear Ratio Dialog 
The Gear Ratio screen measures the overall gear ratio of the vehicle and computes a tire 
diameter given the tire size. The screen is located on the Tools > Compute Gear Ration menu 
option. 

 

Figure 34: Compute Gear Ratio Dialog 

Tire Diameter 
Computing a tire diameter requires entering the tire size. Most passenger car tire sizes are 
listed as width, ratio, and rim diameter (e.g. 205/65 R15).  

Enter the tire size using the Width, Ratio, and Rim Dia drop down lists. Once entered, press the 
Compute Tire Diameter to calculate the tire diameter in inches. 

Many large truck tire sizes are sized differently. These tires are listed as diameter, width, and 
rim diameter (e.g. 31x10.5 R16). In this case, the first number is used as the tire diameter, in 
inches (e.g. 31”), and entered directly into the Tire Diameter field.  

Manufacturers are usually off very slightly from the indicated tire size. Many manufactures list 
the exact tire diameter on their website. If available, use the tire diameter listed on the 
manufacturer’s datasheet.  

 

70 Dyno Operation   



 

Measuring Overall Gear Ratio 
Measuring the vehicle gear ratio involves keeping the vehicle speed steady while the software 
computes an overall gear ratio. The gear ratio changes with each transmission gear. Therefore, 
the software computes one overall gear ratio per gear ratio run (e.g. overall gear ratio for 2nd 
gear). The overall gear ratio is the combination of the transmission gear ratio and the final 
drive gear ratio.  

The Status field lists the status of the gear ratio run, either: 

Idle – no data is being gathered. 

Countdown to Start – shows the number of seconds until data collection begins.  

Collecting Data – vehicle data is being recorded.  

A tire diameter must be entered in the Tire Diameter field before performing a gear ratio run. 
Pressing Measure Gear Ratio will start a gear ratio run.  

Once a tire diameter is entered, pressing the Measure Gear Ratio button starts the 10-second 
countdown. During this time, get the vehicle moving in the gear the run is going to be 
performed in (e.g. 2nd gear). The vehicle RPM should be between 3000 and 4000 RPM for best 
results. Once the gear and RPM is achieved, keep the throttle steady and clutch out (if a 
manual transmission). 

At the end of the countdown, the software will beep. After the beep continue to keep the 
throttle steady until a second beep is heard (about 10 seconds). The second beep indicates the 
gear ratio run is over.  

Bring the vehicle to a complete stop. The measured overall gear ratio is displayed.  

Calculating Overall Gear Ratio 
The overall gear ratio can also be computed if the tire diameter and RPM at a speed is known. 
The following formula computes the overall vehicle gear ratio used by the dyno software: 

overall gear ratio = RPM x tire diameter / MPH x 336  

Example car: 

3.57 = 3000 RPM x 26” / 65 MPH x 336 

The preferred method is to use the Dyno-Scan™ to compute the overall gear ratio. If 
calculating, always confirm your ratio calculation is correct by performing the procedure in 
section Confirming Gear Ratio Result. 

Confirming Gear Ratio Result 
At the bottom of the Gear Ratio screen are three live values: 

RPM – current measured RPM. 

MPH (computed) – computed MPH using only RPM and the gear ratio. 

MPH (real) – real MPH measured via the vehicle’s on-board computer. 
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MPH (computed) will only display if values are entered into the Tire Diameter and Gear Ratio 
fields. If the computed MPH and real MPH values match throughout the RPM range then the 
gear ratio and tire diameter values are correct for this vehicle. If they do not match, adjust the 
Gear Ratio field up or down until the computed and real MPH match.  

A computed verses real MPH check in a single gear might be: 

1. Keep a steady speed at 2000 RPM. 

2. Confirm the computed and real MPH values match. 

3. Increase speed to a steady 4000 RPM. 

4. Confirm the computed and real MPH values match. 

 

 

Always have a passenger confirm the computed and real MPH readings match. 
Driving requires the full attention of the driver. Operating or observing the scan tool 
while driving will cause driver distraction and could cause a fatal accident.  

 
Computing a gear ratio requires an accurate speedometer. If the vehicle’s tire size is either 
smaller or larger than stock and the speedometer has not been recalibrated to the new wheel 
size, then the computed gear ratio will be incorrect. This will make the horsepower and torque 
figures higher or lower than expected. 

Using Tire Diameter and Gear Ratio 
After obtaining the tire diameter and gear ratio, the values are entered into the Gear Ratio and 
Tire Diameter fields within a Dyno Setup file. See Dyno Setup File  for more information.  

TIP: To have multiple gear ratio setups for the same car, create a Dyno Setup file for each gear 
with file names like Ford1stGear, Ford2ndGear, etc.  

Automatic Transmissions 
The software uses the gear ratio on the power torque run, which is performed under heavy 
acceleration. The gear ratio run, however, is performed under essentially a no-load condition 
where the torque converter slippage is negligible. Therefore, for automatic transmissions the 
measured gear ratio may have to be lowered by 5 to 15% to account for the torque converter 
slippage. Otherwise, the power and torque curves will show lower than expected results. 

Dynamometer Getting Started 
Using the dynamometer features requires a few one-time configurations. This section 
summarizes those steps. 

1 

2 

3 

Obtain the drag coefficient, frontal area and vehicle weight as described in Drag 
Coefficient and Frontal Area on page 68. 

Measure gear ratio of your vehicle as described in Compute Gear Ratio Dialog on page 70. 

Create a Dyno Setup file as described Dyno Setup File Properties on page 68. 
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4 Create a Power Torque file as described in Dyno Files on page 67. 

5 

6 

7 

8 

Connect the OBD II adapter to your vehicle. 

Turn the vehicle ignition ON. 

Select the File > Connect menu option.  

To measure power and torque, proceed to Dyno Run Dialog (Power Torque) on page 74. 

Power Torque Screen 
The Power. Torque screen analyzes power and torque data gathered from a vehicle run. 

 

Figure 35: Power Torque Screen 

The power torque graph shows the relationship between horsepower/torque and engine 
RPM. The vertical axis shows the power and torque. The horizontal axis shows the engine RPM.  

The value at any point along the curve is obtained by placing the mouse cursor (circle) over a 
data point.  

The File Properties displays the settings used to compute the power torque curve. When the 
File Properties are modified the graph dynamically updates to show the newly computed 
curve. See Dynamic Graph Update Using File Properties for more information. 

Dynamic Graph Update Using File Properties 
The File Properties docking window offers the ability to change parameters stored within the 
file (see File Properties Docking Window). When the Power Torque screen is displayed, 
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modifying these File Properties causes the Power Torque graph and Run Statistics to 
recompute based upon the new values.  

Similarly, the Acceleration screen offers file properties. However, only Weight within the File 
Properties docking window changes the computed Horsepower in the Run Statistics docking 
window. Unlike power and torque, the acceleration graph is not derived from mathematical 
computations and therefore the Acceleration File Properties are for informational purposes 
only.  

For instance, if the Power Torque file properties Elevation value is changed from 1000 feet to 
9000 feet, the graph will redraw using the new input parameter. 

See Properties Windows for more information about changing properties. 

Dyno Run Dialog (Power Torque) 
The Dyno Run dialog acquires the data from a power torque or acceleration run.  

 

Figure 36: Power Torque Run 

Two files are required to perform a power torque run: a Power Torque and a Dyno Setup file. 
The Power Torque file is the destination for the collected run data. The Dyno Setup file 
provides the operational parameters used by the software to compute horsepower and 
torque. Both files types are created from the File > New menu option.  

The Status field shows the status of the run, either: 

Idle – no data is being gathered. 

Countdown to Start – shows the number of seconds until data collection begins.  

Collecting Data – vehicle data is being recorded.  

Performing a Power Torque Run 
Before the run, ensure the laptop, cables and OBD II adapter are securely fastened out of the 
way and do not interfere with vehicle operation.  

Once the Power Torque file and Dyno Setup files are selected, pressing the Start Run button 
starts the 10-second countdown.  
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During the countdown, get the vehicle moving in the gear the run is going to be performed in 
(e.g. 2nd gear). The vehicle RPM during the countdown should be relatively low, under 2000 
RPM, the throttle steady, and clutch out (if a manual transmission). 

At the end of the countdown, the software will beep. At the beep, floor the accelerator to 
achieve maximum acceleration.  

Once maximum RPM is reached, either shift to the next higher gear or decelerate the vehicle 
by letting off the accelerator. Bring the vehicle to a complete stop and press Done to stop data 
collection.  

Power Torque Run Do’s and Don’ts 
For safety and the most accuracy from the Dyno software, please follow the guidelines below. 

Keep your attention on driving – the software is designed to require no user intervention 
when a run is performed. Start the power torque run while the vehicle is stopped. During the 
countdown, accelerate to the correct gear and starting RPM. Audible tones signal when to 
accelerate the vehicle.  

Consistent vehicle setup – use the same tire pressure, same number of passengers, no A/C, 
windows rolled up, low beams on, radio and other accessories off. 

Automatic transmission – most automatic transmissions will want to downshift under hard 
acceleration. Experiment with higher starting RPM or roll the throttle on slowly at first to 
prevent a downshift.  

Manual transmission – ensure the clutch is completely out when the data collection starts.  

Steady throttle – do not “blip” the throttle during the countdown period. Keep the throttle 
and RPM steady. 

Maximum throttle – keep the throttle fully floored until maximum RPM is achieved. A dip in 
the RPM will cause the power torque graphs to terminate early3.  

Dyno setup – try to obtain current temperature, humidity, elevation, and altimeter pressure 
before each day of runs. 

Head/Tail Wind – a windy day will skew the power/torque results higher or lower depending 
on the wind direction. A relatively calm day provides the best results.  

Level Ground – an uphill climb will make the power/torque lower and conversely a downhill 
run will have higher than expected values. Level ground provides the best results.  

Heat soak – repeated runs will cause the intake manifold temperature to increase. Hot air is 
less dense and causes a reduction in power/torque. Just note that the first run may have 
slightly higher values than subsequent runs if performed back-to-back.  

                                                               
3 Use common sense – let off the accelerator if something gets in the way of the vehicle.  
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Power Torque Run Statistics 
The Run Statistics docking window calculates the peak horsepower and torque at RPM values 
for the currently opened Power Torque file.  

Power – peak horsepower output during the run. 

Peak RPM – the RPM peak power was achieved.  

Torque – peak torque output during the run. 

Torque RPM – the RPM peak torque was achieved. 

Acceleration Screen 
The Acceleration screen analyzes acceleration data gathered from a vehicle run. 

 

Figure 37: Acceleration Screen 

The acceleration graph shows the relationship between vehicle speed over time. The vertical 
axis shows the vehicle speed in MPH. The horizontal axis shows the time in seconds.  

The value at any point along the curve is obtained by placing the mouse cursor over a data 
point. 

Dyno Run Dialog (Acceleration) 
The Dyno Run dialog acquires the data from an acceleration run.  
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Figure 38: Acceleration Run Dialog 

Two files are required to perform an acceleration run: an Acceleration file and a Dyno Setup 
file. The Acceleration file is the destination for the collected run data. The Dyno Setup file 
provides the operational parameters used by the software to compute a 1/4-mile horsepower 
figure. Both file types are created from the File > New menu option.  

The Status field shows the current status of the run, either: 

Idle – no data is being gathered. 

Waiting to Start – waiting for the vehicle to start moving.  

Collecting Data – vehicle data is being recorded.  

Performing an Acceleration Run 
Before the run, ensure the laptop, cables and OBD II adapter are securely fastened out of the 
way and do not interfere with vehicle operation.  

Once the Acceleration file and Dyno Setup files are selected, press the Start Run button.  

The acceleration run is performed from a standing start. Once the Status field says “Waiting to 
Start”, the software is waiting for the vehicle to start accelerating. The acceleration run does 
not use RPM like a power torque run does. Therefore, while waiting to accelerate you may rev 
the motor or do whatever else you think will achieve the quickest acceleration time.  

As you accelerate down the track, you may stop the acceleration run at different data points 
depending on the data you’re trying to collect.  

60 MPH – if acceleration stops after 60 MPH is reached, the 0-60 time will be 
computed. 

1/8 mile – if acceleration stops after 1/8 mile reached, the 1/8-mile time and speed is 
computed.  

1/4 mile – if acceleration stops after 1/4 mile reached, the 1/4-mile time and speed is 
computed. In addition, a 1/4-mile horsepower value is computed. 

Its best to accelerate slightly beyond a data point to ensure the software captures the vehicle 
passing through the data point at maximum acceleration. For instance, don’t let off the 
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accelerator at exactly 60 MPH. Accelerate just beyond 60for approximately ½ second to 
achieve the best results. 

Bring the vehicle to a complete stop and press the Done button to stop data collection.  

Acceleration Run Do’s and Don’ts 
For safety and the most accuracy from the Dyno software, please follow the guidelines below. 

Keep your attention on driving – the software is designed to require no user intervention 
when a run is performed.  

Consistent vehicle setup – use the same tire pressure, same number of passengers, no A/C, 
windows rolled up, low beams on, radio and other accessories off. 

Head/Tail Wind – a windy day will skew the acceleration results higher or lower depending 
on the wind direction. A relatively calm day provides the best results.  

Level Ground – an uphill climb will make the acceleration lower and conversely a downhill 
run will have higher than expected values. Level ground provides the best results.  

Heat soak – repeated runs will cause the intake manifold temperature to increase. Hot air is 
less dense and causes a reduction in power/torque. Just note that the first run may have 
slightly faster values than subsequent runs if performed back-to-back.  

Accelerate Just Past Data Point - accelerate slightly beyond a data point (e.g. 60 MPH, 1/8 
mile, or 1/4 mile) to ensure the software captures the vehicle passing through the data point 
at maximum acceleration 

If the vehicle’s tire size is either smaller or larger than stock and the speedometer has not been 
recalibrated to the new wheel size, then the computed acceleration figures will be incorrect. 
Acceleration runs require an accurate speedometer.  

Acceleration Run Statistics 
The Run Statistics screen computes times and horsepower values based upon how fast the 
vehicle accelerates.  

Top Speed – maximum speed achieved during the run. 

0 to 60 Time – how fast in seconds the vehicle traveled from 0 to 60 MPH. 

1/8 Mile Speed – how fast in MPH the vehicle was traveling at the 1/8-mile mark. 

1/8 Mile Time – time in seconds, the vehicle traveled a 1/8-mile. 

1/4 Mile Speed – how fast in MPH the vehicle was traveling at the 1/4-mile mark. 

1/4 Mile Time – time in seconds, the vehicle traveled a 1/4-mile. 

1/4 Mile HP – a rough calculation of horsepower based strictly on 1/4-mile time and 
vehicle weight.  
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N/A will be displayed in a column if the vehicle didn’t travel far enough to compute the 
statistic.  
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CHAPTER 7 

Google Earth 

Google Earth is a geographic information system (GIS) and provides a 3D software 
representation of Earth using satellite imagery. It provides you with the ability to move about 
the Earth and view any location on the planet from any altitude or viewing angle. Google Earth 
is a free application and may be downloaded from http://earth.google.com. Ensure you are 
running version 4.1 or higher. 

DashDyno and Dyno-Scan for Windows utilize Google Earth to correlate recorded vehicle 
sensor data with the vehicle’s georeferenced position on Earth. This is an extremely powerful 
tool in analyzing vehicle data whether on a racetrack, off road or around town.  

DashDyno records OBD II vehicle sensors data, analog voltages and GPS data onto the SD card. 
Dyno-Scan for Windows then opens the file and if it contains GPS data, Dyno-Scan for 
Windows interactively sends coordinate information to Google Earth. You do not need to 
interact with Google Earth –Dyno-Scan for Windows updates the camera position and viewing 
angles automatically.  

The Google Earth feature within the Dyno-Scan for Windows software may only be used in 
conjunction with an Auterra DashDyno SPD data logger. Dyno-Scan for Windows cannot 
connect to a GPS and will not record GPS data. The software reads GPS data recorded by an 
Auterra DashDyno. 
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When a DashDyno live data file containing GPS data is opened, Google Earth draws a yellow 
line showing the complete vehicle path and flies to that location. Moving the data cursor on 
the Analyze Live Data screen causes Google Earth to immediately fly to the new location on 
the yellow line. The Google Earth yellow pushpin shows the current GPS location within the 
data file. 

Two Google Earth view modes are supported: Stationary and Follow Vehicle. In stationary 
mode, the Google Earth view elevation and position does not move. This is useful if you want 
to see the entire vehicle path. In Follow Vehicle mode, Google Earth zooms to the vehicle 
georeferenced location. 

If the Play button on the Playback Control toolbar is pressed, the line graph data within the 
Analyze Live Data window starts to move and the Google Earth position continually updates 
during playback. If the Follow Vehicle option is selected, you will follow behind the vehicle 
position as it moves.  

To analyze a DashDyno live data file: 

1 Using your DashDyno and GPS receiver, record GPS and vehicle sensor data. See the 
DashDyno SPD User Guide for more information on recording data using DashDyno.  
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2 Eject the SD card from DashDyno and insert into your PC card reader connected to your 
computer.  

3 

4 

5 

6 

7 

8 

9 

10 

11 

12 

Start the Dyno-Scan for Windows software.  

Go to the Tools > Options dialog then select the Google Earth tab.  

Check the Enable Google Earth checkbox. Press OK.  

Select the File > Open > Live Data File menu option.  

Go to the PC card reader drive and open the DashDyno live data file. Live data files are 
stored on the SD card within the LIVE directory (e.g. f:\LIVE\MY_DATA.ld).  

Google Earth will start automatically when the file is opened. A yellow vehicle path line is 
drawn and the camera zooms over the entire vehicle path.  

Select the Analyze Live Data icon on the Navigation docking window.  

Press the Data Cursor button on the Analyze Tool Bar.  

Left mouse click the data cursor and drag it to a new location. Google Earth will reposition 
to the vehicle’s georeferenced location as recorded within your data file.   

Press the Play button on the Playback Control toolbar. The line graph will start to move 
and Google Earth will continually update its position during playback.  

See Analyze Live Data Screen on page 57 for more information on how to use Analyze Live 
Data screen.  

Google Earth Options 
Dyno-Scan for Windows has settings to control how GPS data is displayed within Google Earth. 
The user’s point of view within Google Earth is called a camera position. The camera position 
can be adjusted for altitude and viewing angle.  

The Google Earth settings with the Dyno-Scan for Windows Tools > Options dialog are: 

Enable Google Earth – when checked, Google Earth is used to display GPS position 
information from within a live data file. 

Playback Mode – the Stationary option holds the camera position and attitude steady 
during playback. The camera position when the Play button is pressed is used as the 
stationary position. The Follow Vehicle option zooms the camera behind the vehicle 
position. When the vehicle position is updated, the camera view will follow.  

GPS Heading Camera View – uses the heading (i.e. direction of travel) from the GPS 
to orient the camera view. During playback, the camera point of view always faces the 
vehicle’s direction of travel. Otherwise, the camera points north.  

Playback Speed – controls the playback speed.  

Refresh Rate – controls how often Google Earth is sent GPS positional data. 

Camera Tilt Angle – controls the tilt of the camera position. 0 degrees looks straight 
down and 80 degrees looks toward the horizon.  
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Camera Range – controls how far from the ground the camera is positioned.  

Enable Automatic Window Tiling – when checked, the software vertically tiles Dyno-
Scan and Google Earth so both application windows are visible.  

Tile Percentage – the horizontal percentage of screen width Google Earth will 
occupy. The Google Earth toolbar prevents Google Earth from sizing to a small 
horizontal screen width. To allow a small screen width, uncheck the menu View > 
Toolbar within Google Earth.  

 

 
 

Improving Playback Speed 
The Analyze Live Data screen Playback feature can be slow on an older computer. If this is the 
case, here are some tips:  
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1 On Dyno-Scan, slow the Refresh Rate and/or Playback Speed. For instance, setting a 
playback speed of 0.2 seconds and a refresh speed of 1.0 second’s means every 5th data 
point Google Earth will receive a new GPS coordinate.  

2 

3 

4 

5 

On Dyno-Scan, turn off the round markers by selecting the Options button pull down on 
the Analyze Live Data title bar and unchecking Show Markers.  

On Google Earth’s Tools > Options… dialog, set the Detail Area to Small and set the 
Terrain Quality to Lower. Its best to restart Google Earth after making changes.  

On Google Earth’s Layers sidebar, uncheck unused options such as Roads, Terrain, Dining, 
etc…  

On Google Earth, select the View > Sidebar menu option to hide the sidebar. This will 
prevent needless refreshing of the sidebar during playback.  

Working Without an Internet Connection 
Google Earth obtains satellite imagery from the Internet. If you want to use Google Earth away 
from the Internet (e.g. at track day), you’ll need to cache the images to your computer disk 
drive. 

To cache satellite imagery, while connected to the Internet move the Google Earth view 
around the location you want to view when not connected to the Internet. As you fly around, 
look at the area from different directions and attitudes. This will cause the satellite images to 
be stored within the Google Earth memory cache for use when offline.  

If necessary, the Google Earth cache can be increased by going to the Tools > Options menu 
then select the Cache tab. 
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CHAPTER 8 

Demo Mode 

Demonstration mode simulates all vehicle data. This mode facilitates learning about scan tool 
features without connecting to a live vehicle. 

Enable Demo Mode 
Demo mode is enabled from the File > Connect dialog.  

1 Select the “Connect to Vehicle Demo” checkbox on the Connect screen.  

       

Figure 39: Connect to Vehicle Demo 

2 Press the “Connect to Vehicle” button. With demo mode enabled, all vehicle data is 
simulated – even if the scan tool is connected to a vehicle.  
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CHAPTER 9 

Export File Format 

Four different export formats available within the software.  

1 

2 

3 

4 

Single-Point Row CSV File 

Multi-Point Row CSV File 

TrackVision File 

Analyze Live Data Save 

All file formats may be imported into a spreadsheet application such as Microsoft Excel. Once 
the data is imported into the spreadsheet, numerous data manipulations are possible such as 
graphing and analyzing the data.  

Single-Point Row CSV File Format 
This file format exports the data into a one-data point per row format. Each row within the 
spreadsheet corresponds to one data sample. The sample time on each row is the exact time 
the data sample was taken.  

The CSV file is a tabular format of data placed into rows and columns. The first row contains 
basic file information: 

File Name – the name of the PDB file. 

Make – make of the vehicle.  

Year – the year of the vehicle.  

VIN – the optional VIN number field.  

Note – the optional note field.  
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Figure 40: Single-Point Row CSV File in Excel 

The second row contains the column headings for the scan data. Metric values are always 
included in the CSV file, however if there is no corresponding English units of measure for a 
sensor then no conversion is shown.  

Sample – the sample number. 

Name– the parameter name.  

Sample Time – the time stamp when the data was sampled in seconds.  

Value Metric – the sensor value in Metric units. 

Units Metric – the Metric units of measure. 

Value English – the sensor value in English units. 

Units English – the English units of measure.  

Multi-Point Row CSV File 
This file format exports the data in a multiple data points per row format. Each row within the 
spreadsheet corresponds to one or more data samples.  
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The data arrives from the vehicle at different times. A single time stamp cannot accurately 
identify the exact moment when multiple vehicle samples arrive4. Therefore, the sample time 
used on each row is the time of the last sensor to be sampled on that row. The order of the 
columns is not important and does not indicate the order in which the sensors were sampled. 

All the sampled data within a certain time period is combined into a single row. If a new data 
sample is not available for a row within the time period, then the last known good data sample 
is inserted instead. 

The multi-point row CSV file format may be easier to use than the single-point row CSV format 
at the expense of loosing the exact time stamp for each data sample point.  

 

Figure 41: Multi-Point Row CSV File in Excel 

TrackVision CSV File 
TrackVision is a 3rd party software package that merges in-car video recorded with a camcorder 
and vehicle data recorded with DashDyno. The TrackVision software synchronizes the video 
and data and creates a virtual dashboard overlay within your video. Engine RPM, throttle 
position, vehicle speed, GPS position and more can be displayed. 

The resulting movie is exported to different video file formats or a DVD. TrackVision can be 
purchased at www.trackvision.net. 

                                                               
4 On CAN bus equipped vehicles with CAN 6x mode enabled up to 6 sensors can be 
simultaneously sampled from the vehicle. 
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To export a Live Data file into a format suitable for import within TrackVision, select the File > 
Export > TrackVision File… menu option.  

For more information on using TrackVision, refer to Auterra’s DashDyno SPD User Guide. 

Analyze Live Data Save 
The Save icon on the Analyze Live Data Screen toolbar exports a .dat file. This tab delimited file 
may be imported into a spreadsheet using a spreadsheet import data feature.  

See Save Button on page 62 for more information regarding the Analyze Live Data Save 
button. 
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CHAPTER 10 

Troubleshooting 

This section contains solutions for common problems encountered with the scan tool.  

Scan Tool Connects but No Sensor Data 
If no Live data is displayed in the Live Data screens, try the following remedies: 

1 

2 

3 

1 

2 

3 

1 

2 

3 

4 

5 

6 

Right mouse click in a Graph or List pane and select “Edit Parameters” from the shortcut 
menu and add the parameters you want to monitor. 

Disable the Fast Sampling option in the Tools > Options dialog.  

Disable the CAN 6x Communication option in the Tools > Options dialog. 

Can’t Open COM Port 
The COM port is either busy or does not exist, try the following remedies: 

Try selecting another COM port. 

If you use a Palm handheld computer with your computer, disable the Local Serial 
checkmark on the HotSync icon located on the Windows taskbar by right mouse clicking 
on the HotSync icon. Alternatively, right mouse click the HotSync icon and select Exit. 

If you have a PocketPC or Windows CE PDA, disable ActiveSync. 

No Communication (Scan Tool) 
If the No Communication (Scan Tool) dialog appears, this means the software cannot 
communicate with the vehicle. Try the following remedies: 

Ensure the vehicle ignition is turned on. Vehicle does not have to be running; however, it 
can be.  

Try pressing the “Connect to Vehicle” button again.  

Ensure the OBD II Adapter is securely plugged into the vehicle’s OBD II connector.  

Ensure the RS-232 cable is securely plugged into the PC. 

Ensure the vehicle is OBD II compliant (see Supported Vehicles).  

Ensure no vehicle fuses are blown. OBD II adapter power is derived from the vehicle and a 
blown fuse could prevent power from reaching the scan tool.  
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No Communication (Vehicle) 
If the No Communication (Vehicle) dialog appears, see No Communication (Scan Tool).  

Lost Communication 
If the Lost Communication dialog appears, this means the software initially established 
communication but subsequently lost it. Try the following remedies: 

1 

2 

Ensure the OBD II Adapter is securely plugged into the vehicle’s OBD II connector.  

Ensure the RS-232 cable is securely plugged into the PC.  

Live Data Screen Is Blank 
Right mouse click in the center of the screen and select “Add List Pane” or “Add Graph Pane” 
from the shortcut menu to add new panes. 

Oxygen Sensors Test Results Pane is Blank 
Not all vehicles support the features provided by the Oxygen Sensor screen. If the vehicle does 
not support this feature, the data for the screen will be blank.  

Freeze Frame Pane is Blank 
If the vehicle has not detected a failure that caused the Check Engine to illuminate, the data 
for the Freeze Frame pane will be blank.  

Clearing Codes Did Not Work or MIL Didn’t Turn Off 
There are a few possible causes for the check engine light not to extinguish or the DTCs to 
reappear on the scan tool. First, if the problem is not fixed the DTC may return immediately for 
problems such as misfires, open or shorted sensors, etc. Second, some vehicles can't be 
running when the memory is cleared. In these cases, ensure the key is on but the engine is off 
before attempting to clear the memory. Last, some vehicles require, after the codes are 
cleared, for the ignition key to be turned off and then on again before the MIL light actually 
turns off.  
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APPENDIX A 

Diagnostic Trouble Codes 

A Diagnostic Trouble Code (DTC) is a 5-digit value starting with a letter.  

The DTC’s codes listed here are generic to all manufacturers. These generic Diagnostic Trouble 
Codes are those codes where industry uniformity has been achieved. However, each vehicle 
manufacturer may optionally create new codes beyond the generic ones. The Auterra Dyno-
Scan™ for Windows can read these enhanced manufacturer specific codes.  

The DTC database files included with the software incorporates thousands of more codes, 
both generic and enhanced, than those listed here. The following listing simply provides an 
overview of the types of codes available. 

Diagnostic Trouble Code Format Structure 
The Diagnostic Trouble Code numbering follows a standardized structure. All Diagnostic 
Trouble Codes have a letter followed by a 4-digit number (e.g. P1234). The first letter indicates 
the type of code: 

P = Powertrain 
C = Chassis  
B = Body 
U = Network Communication 
 
The remaining 4-digit number specifies the problem within that system.  

P00XX Fuel and Air Metering and Auxiliary Emission Controls 
P0010  “A” Camshaft Position Actuator Circuit    (Bank 1) 
P0011 “A” Camshaft Position - Timing Over-Advanced or System Performance (Bank 1) 
P0012 “A” Camshaft Position - Timing Over-Retarded    (Bank 1) 
P0013 “B” Camshaft Position - Actuator Circuit    (Bank 1) 
P0014 “B” Camshaft Position - Timing Over-Advanced or System Performance (Bank 1) 
P0015 “B” Camshaft Position -Timing Over-Retarded    (Bank 1) 
 
P0020  “A” Camshaft Position Actuator Circuit    (Bank 2) 
P0021 “A” Camshaft Position - Timing Over-Advanced or System Performance (Bank 2) 
P0022 “A” Camshaft Position - Timing Over-Retarded    (Bank 2) 
P0023 “B” Camshaft Position - Actuator Circuit    (Bank 2) 
P0024 “B” Camshaft Position - Timing Over-Advanced or System Performance (Bank 2) 
P0025 “B” Camshaft Position - Timing Over-Retarded    (Bank 2) 
 
P0030 HO2S Heater Control Circuit      (Bank 1 Sensor 1) 
P0031 HO2S Heater Control Circuit Low     (Bank 1 Sensor 1) 
P0032 HO2S Heater Control Circuit High     (Bank 1 Sensor 1)  
P0033 Turbo Charger Bypass Valve Control Circuit 

 

92 Diagnostic Trouble Codes 



 

P0034 Turbo Charger Bypass Valve Control Circuit Low 
P0035 Turbo Charger Bypass Valve Control Circuit High 
P0036 HO2S Heater Control Circuit      (Bank 1 Sensor 2) 
P0037 HO2S Heater Control Circuit Low     (Bank 1 Sensor 2) 
P0038 HO2S Heater Control Circuit High     (Bank 1 Sensor 2) 
 
P0042 HO2S Heater Control Circuit      (Bank 1 Sensor 3) 
P0043 HO2S Heater Control Circuit Low     (Bank 1 Sensor 3) 
P0044  HO2S Heater Control Circuit High     (Bank 1 Sensor 3) 
 
P0050 HO2S Heater Control Circuit      (Bank 2 Sensor 1) 
P0051 HO2S Heater Control Circuit Low     (Bank 2 Sensor 1) 
P0052  HO2S Heater Control Circuit High     (Bank 2 Sensor 1) 
 
P0056 HO2S Heater Control Circuit      (Bank 2 Sensor 2) 
P0057 HO2S Heater Control Circuit Low     (Bank 2 Sensor 2) 
P0058  HO2S Heater Control Circuit High     (Bank 2 Sensor 2) 
 
P0062  HO2S Heater Control Circuit      (Bank 2 Sensor 3) 
P0063 HO2S Heater Control Circuit Low     (Bank 2 Sensor 3) 
P0064 HO2S Heater Control Circuit High     (Bank 2 Sensor 3) 
P0065 Air Assisted Injector Control Range/Performance 
P0066 Air Assisted Injector Control Circuit or Circuit Low 
P0067 Air Assisted Injector Control Circuit High 
 
P0070  Ambient Air Temperature Sensor Circuit 
P0071 Ambient Air Temperature Sensor Range/Performance 
P0072 Ambient Air Temperature Sensor Circuit Low Input 
P0073 Ambient Air Temperature Sensor Circuit High Input 
P0074 Ambient Air Temperature Sensor Circuit Intermittent 
P0075 Intake Valve Control Solenoid Circuit     (Bank 1) 
P0076 Intake Valve Control Solenoid Circuit Low    (Bank 1) 
P0077 Intake Valve Control Solenoid Circuit High    (Bank 1) 
P0078 Exhaust Valve Control Solenoid Circuit    (Bank 1) 
P0079 Exhaust Valve Control Solenoid Circuit Low    (Bank 1) 
P0080 Exhaust Valve Control Solenoid Circuit High    (Bank 1) 
P0081 Intake valve Control Solenoid Circuit     (Bank 2) 
P0082 Intake Valve Control Solenoid Circuit Low    (Bank 2) 
P0083 Intake Valve Control Solenoid Circuit High    (Bank 2) 
P0084 Exhaust Valve Control Solenoid Circuit    (Bank 2) 
P0085  Exhaust Valve Control Solenoid Circuit Low    (Bank 2) 
P0086  Exhaust Valve Control Solenoid Circuit High    (Bank 2) 

P01XX Fuel and Air Metering 
P0100  Mass or Volume Air Flow Circuit 
P0101 Mass or Volume Air Flow Circuit Range/Performance Problem 
P0102 Mass or Volume Air Flow Circuit Low Input 
P0103 Mass or Volume Air Flow Circuit High Input 
P0104 Mass or Volume Air Flow Circuit Intermittent 
P0105 Manifold Absolute Pressure/Barometric Pressure Circuit 
P0106 Manifold Absolute Pressure/Barometric Pressure Circuit Range/Performance Problem 
P0107 Manifold Absolute Pressure/Barometric Pressure Circuit Low Input 
P0108 Manifold Absolute Pressure/Barometric Pressure Circuit High Input 
P0109 Manifold Absolute Pressure/Barometric Pressure Circuit Intermittent 
P0110 Intake Air Temperature Circuit 
P0111 Intake Air Temperature Circuit Range/Performance Problem 
P0112 Intake Air Temperature Circuit Low Input 
P0113 Intake Air Temperature Circuit High Input 
P0114 Intake Air Temperature Circuit Intermittent 
P0115 Engine Coolant Temperature Circuit 
P0116 Engine Coolant Temperature Circuit Range/Performance Problem 
P0117 Engine Coolant Temperature Circuit Low Input 
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P0118 Engine Coolant Temperature Circuit High Input 
P0119 Engine Coolant Temperature Circuit Intermittent 
P0120 Throttle/Pedal Position Sensor/Switch A Circuit 
P0121 Throttle/Pedal Position Sensor/Switch A Circuit Range/Performance Problem 
P0122 Throttle/Pedal Position Sensor/Switch A Circuit Low Input 
P0123 Throttle/Pedal Position Sensor/Switch A Circuit High Input 
P0124 Throttle/Pedal Position Sensor/Switch A Circuit Intermittent 
P0125 Insufficient Coolant Temperature for Closed Loop Fuel Control 
P0126 Insufficient Coolant Temperature for Stable Operation 
P0127 Intake Air Temperature Too High 
P0128 Coolant Thermostat (Coolant Temperature Below Thermostat Regulating Temperature) 
 
P0130 O2 Sensor Circuit       (Bank 1 Sensor 1) 
P0131 O2 Sensor Circuit Low Voltage     (Bank 1 Sensor 1) 
P0132 O2 Sensor Circuit High Voltage     (Bank 1 Sensor 1) 
P0133 O2 Sensor Circuit Slow Response     (Bank 1 Sensor 1) 
P0134 O2 Sensor Circuit No Activity Detected    (Bank 1 Sensor 1) 
P0135 O2 Sensor Heater Circuit      (Bank 1 Sensor 1) 
P0136 O2 Sensor Circuit Malfunction     (Bank 1 Sensor 2) 
P0137 O2 Sensor Circuit Low Voltage     (Bank 1 Sensor 2) 
P0138 O2 Sensor Circuit High Voltage     (Bank 1 Sensor 2) 
P0139 O2 Sensor Circuit Slow Response     (Bank 1 Sensor 2) 
P0140 O2 Sensor Circuit No Activity Detected    (Bank 1 Sensor 2) 
P0141 O2 Sensor Heater Circuit      (Bank 1 Sensor 2) 
P0142 O2 Sensor Circuit Malfunction     (Bank 1 Sensor 3) 
P0143 O2 Sensor Circuit Low Voltage     (Bank 1 Sensor 3) 
P0144 O2 Sensor Circuit High Voltage     (Bank 1 Sensor 3) 
P0145 O2 Sensor Circuit Slow Response     (Bank 1 Sensor 3) 
P0146 O2 Sensor Circuit No Activity Detected    (Bank 1 Sensor 3) 
P0147 O2 Sensor Heater Circuit      (Bank 1 Sensor 3) 
P0148 Fuel Delivery Error 
P0149 Fuel Timing Error 
P0150 O2 Sensor Circuit       (Bank 2 Sensor 1) 
P0151 O2 Sensor Circuit Low Voltage     (Bank 2 Sensor 1) 
P0152 O2 Sensor Circuit High Voltage     (Bank 2 Sensor 1) 
P0153 O2 Sensor Circuit Slow Response     (Bank 2 Sensor 1) 
P0154 O2 Sensor Circuit No Activity Detected    (Bank 2 Sensor 1) 
P0155 O2 Sensor Heater Circuit      (Bank 2 Sensor 1) 
P0156 O2 Sensor Circuit Malfunction     (Bank 2 Sensor 2) 
P0157 O2 Sensor Circuit Low Voltage     (Bank 2 Sensor 2) 
P0158 O2 Sensor Circuit High Voltage     (Bank 2 Sensor 2) 
P0159 O2 Sensor Circuit Slow Response     (Bank 2 Sensor 2) 
P0160 O2 Sensor Circuit No Activity Detected    (Bank 2 Sensor 2) 
P0161 O2 Sensor Heater Circuit      (Bank 2 Sensor 2) 
P0162 O2 Sensor Circuit Malfunction     (Bank 2 Sensor 3) 
P0163 O2 Sensor Circuit Low Voltage     (Bank 2 Sensor 3) 
P0164 O2 Sensor Circuit High Voltage     (Bank 2 Sensor 3) 
P0165 O2 Sensor Circuit Slow Response     (Bank 2 Sensor 3) 
P0166 O2 Sensor Circuit No Activity Detected    (Bank 2 Sensor 3) 
P0167 O2 Sensor Heater Circuit      (Bank 2 Sensor 3) 
P0168 Fuel Temperature Too High 
P0169 Incorrect Fuel Composition 
P0170 Fuel Trim        (Bank 1) 
P0171 System too Lean       (Bank 1) 
P0172 System too Rich       (Bank 1) 
P0173 Fuel Trim Malfunction      (Bank 2) 
P0174 System too Lean       (Bank 2) 
P0175 System too Rich       (Bank 2) 
 
P0176  Fuel Composition Sensor Circuit 
P0177 Fuel Composition Sensor Circuit Range/Performance 
P0178 Fuel Composition Sensor Circuit Low Input 
P0179 Fuel Composition Sensor Circuit High Input 
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P0180 Fuel Temperature Sensor A Circuit 
P0181 Fuel Temperature Sensor A Circuit Range/Performance 
P0182 Fuel Temperature Sensor A Circuit Low Input 
P0183 Fuel Temperature Sensor A Circuit High Input 
P0184 Fuel Temperature Sensor A Circuit Intermittent 
P0185 Fuel Temperature Sensor B Circuit 
P0186 Fuel Temperature Sensor B Circuit Range/Performance 
P0187 Fuel Temperature Sensor B Circuit Low Input 
P0188 Fuel Temperature Sensor B Circuit High Input 
P0189 Fuel Temperature Sensor B Circuit Intermittent 
P0190 Fuel Rail Pressure Sensor Circuit 
P0191 Fuel Rail Pressure Sensor Circuit Range/Performance 
P0192 Fuel Rail Pressure Sensor Circuit Low In put 
P0193 Fuel Rail Pressure Sensor Circuit High Input 
P0194 Fuel Rail Pressure Sensor Circuit Intermittent 
P0195 Engine Oil Temperature Sensor 
P0196 Engine Oil Temperature Sensor Range/Performance 
P0197 Engine Oil Temperature Sensor Low 
P0198 Engine Oil Temperature Sensor High 
P0199 Engine Oil Temperature Sensor Intermittent 

P02XX Fuel and Air Metering 
P0200  Injector Circuit 
P0201 Injector Circuit - Cylinder 1 
P0202 Injector Circuit - Cylinder 2 
P0203 Injector Circuit - Cylinder 3 
P0204 Injector Circuit - Cylinder 4 
P0205 Injector Circuit - Cylinder 5 
P0206 Injector Circuit - Cylinder 6 
P0207 Injector Circuit - Cylinder 7 
P0208 Injector Circuit - Cylinder 8 
P0209 Injector Circuit - Cylinder 9 
P0210 Injector Circuit - Cylinder 10 
P0211 Injector Circuit - Cylinder 11 
P0212 Injector Circuit - Cylinder 12 
P0213 Cold Start Injector 1 
P0214 Cold Start Injector 2 
P0215 Engine Shutoff Solenoid 
P0216 Injector/Injection Timing Control Circuit 
P0217 Engine Coolant Over Temperature Condition 
P0218 Transmission Fluid Over Temperature Condition 
P0219 Engine Over Speed Condition 
P0220 Throttle/Pedal Position Sensor/Switch “B” Circuit 
P0221 Throttle/Pedal Position Sensor/Switch “B” Circuit Range/Performance Problem 
P0222 Throttle/Pedal Position Sensor/Switch “B” Circuit Low Input 
P0223 Throttle/Pedal Position Sensor/Switch “B” Circuit High Input 
P0224 Throttle/Pedal Position Sensor/Switch  “B” Circuit Intermittent 
P0225 Throttle/Pedal Position Sensor/Switch “C” Circuit 
P0226  Throttle/Pedal Position Sensor/Switch “C” Circuit Range/Performance Problem 
P0227 Throttle/Pedal Position Sensor/Switch “C” Circuit Low Input 
P0228 Throttle/Pedal Position Sensor/Switch “C” Circuit High Input 
P0229 Throttle/Pedal Position Sensor/Switch “C” Circuit Intermittent 
P0230 Fuel Pump Primary Circuit 
P0231 Fuel Pump Secondary Circuit Low 
P0232 Fuel Pump Secondary Circuit High 
P0233 Fuel Pump Secondary Circuit Intermittent 
P0234 Turbo/Super Charger Overboost Condition 
P0235 Turbo/Super Charger Boost Sensor “A” Circuit 
P0236 Turbo/Super Charger Boost Sensor “A” Circuit Range/Performance 
P0237 Turbo/Super Charger Boost Sensor “A” Circuit Low 
P0238 Turbo/Super Charger Boost Sensor “A” Circuit High 
P0239 Turbo/Super Charger Boost Sensor “B” Circuit 
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P0240 Turbo/Super Charger Boost Sensor “B” Circuit Range/Performance 
P0241 Turbo/Super Charger Boost Sensor “B” Circuit Low 
P0242 Turbo/Super Charger Boost Sensor “B” Circuit High 
P0243 Turbo/Super Charger Wastegate Solenoid “A” 
P0244 Turbo/Super Charger Wastegate Solenoid “A” Range/Performance 
P0245 Turbo/Super Charger Wastegate Solenoid “A” Low 
P0246 Turbo/Super Charger Wastegate Solenoid “A” High 
P0247 Turbo/Super Charger Wastegate Solenoid “B” 
P0248 Turbo/Super Charger Wastegate Solenoid “B” Range/Performance 
P0249 Turbo/Super Charger Wastegate Solenoid “B” Low 
P0250 Turbo/Super Charger Wastegate Solenoid “B” High 
P0251 Injection Pump Fuel Metering Control “A”  (Cam/rotor/Injector) 
P0252 Injection Pump Fuel Metering Control “A” Range/Performance (Cam/Rotor/Injector) 
P0253 Injection Pump Fuel Metering Control “A” Low (Cam/Rotor/Injector) 
P0254 Injection Pump Fuel Metering Control “A” High (Cam/Rotor/Injector) 
P0255 Injection Pump Fuel Metering Control “A” Intermittent (Cam/Rotor/Injector) 
P0256 Injection Pump Fuel Metering Control “B” (Cam/Rotor/Injector) 
P0257 Injection Pump Fuel Metering Control “B” Range/Performance (Cam/Rotor/Injector) 
P0258 Injection Pump Fuel Metering Control “B” Low (Cam/Rotor/Injector) 
P0259 Injection Pump Fuel Metering Control “B” High (Cam/Rotor/Injector) 
P0260 Injection Pump Fuel Metering Control “B” Intermittent (Cam/Rotor/Injector) 
P0261 Cylinder 1 Injector Circuit Low 
P0262 Cylinder 1 Injector Circuit High 
P0263 Cylinder 1 Contribution/Balance 
P0264 Cylinder 2 Injector Circuit Low 
P0265 Cylinder 2 Injector Circuit High 
P0266 Cylinder 2 Contribution/Balance 
P0267 Cylinder 3 Injector Circuit Low 
P0268 Cylinder 3 Injector Circuit High 
P0269 Cylinder 4 Contribution/Balance 
P0270 Cylinder 4 Injector Circuit Low 
P0271 Cylinder 4 Injector Circuit High 
P0272 Cylinder 4 Contribution/Balance 
P0273 Cylinder 5 Injector Circuit Low 
P0274 Cylinder 5 Injector Circuit High 
P0275 Cylinder 5 Contribution/Balance 
P0276 Cylinder 6Injector Circuit Low 
P0277 Cylinder 6 Injector Circuit High 
P0278 Cylinder 6 Contribution/Balance 
P0279 Cylinder 7 Injector Circuit Low 
P0280 Cylinder 7 Injector Circuit High 
P0281 Cylinder 7 Contribution/Balance 
P0282 Cylinder 8 Injector Circuit Low 
P0283 Cylinder 8 Injector Circuit High 
P0284 Cylinder 8 Contribution/Balance 
P0285 Cylinder 9 Injector Circuit Low 
P0286 Cylinder 9 Injector Circuit High 
P0287 Cylinder 9 Contribution/Balance 
P0288 Cylinder 10 Injector Circuit Low 
P0289 Cylinder 10 Injector Circuit High 
P0290 Cylinder 10 Contribution/Balance 
P0291 Cylinder 11 Injector Circuit Low 
P0292 Cylinder 11 Injector Circuit High 
P0293 Cylinder 11 Contribution/Balance 
P0294 Cylinder 12 Injector Circuit Low 
P0295 Cylinder 12 Injector Circuit High 
P0296 Cylinder 12 Contribution/Balance 
 
P0298 Engine Oil Over Temperature 

P03XX Ignition System or Misfire 
P0300  Random/Multiple Cylinder Misfire Detected 
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P0301 Cylinder 1 Misfire Detected 
P0302 Cylinder 2 Misfire Detected 
P0303 Cylinder 3 Misfire Detected 
P0304 Cylinder 4 Misfire Detected 
P0305 Cylinder 5 Misfire Detected 
P0306 Cylinder 6 Misfire Detected 
P0307 Cylinder 7 Misfire Detected 
P0308 Cylinder 8 Misfire Detected 
P0309 Cylinder 9 Misfire Detected 
P0310 Cylinder 10 Misfire Detected 
P0311 Cylinder 11 Misfire Detected 
P0312 Cylinder 12 Misfire Detected 
P0313 Misfire Detected with Low Fuel 
P0314 Single Cylinder Misfire (Cylinder not Specified) 
 
P0320  Ignition/Distributor Engine Speed Input Circuit 
P0321 Ignition/Distributor Engine Speed Input Circuit Range/Performance 
P0322 Ignition/Distributor Engine Speed Input Circuit No Signal 
P0323 Ignition/Distributor Engine Speed Input Circuit Intermittent 
P0324 Knock Control System Error 
P0325 Knock Sensor 1 Circuit      (Bank 1 or Single Sensor) 
P0326 Knock Sensor 1 Circuit Range/Performance    (Bank 1 or Single Sensor) 
P0327 Knock Sensor 1 Circuit Low Input     (Bank 1 or Single Sensor) 
P0328 Knock Sensor 1 Circuit High Input     (Bank 1 or Single Sensor) 
P0329 Knock Sensor 1 Circuit Input Intermittent    (Bank 1 or Single Sensor) 
P0330 Knock Sensor 2 Circuit      (Bank 2) 
P0331 Knock Sensor 2 Circuit Range/Performance    (Bank 2) 
P0332 Knock Sensor 2 Circuit Low Input     (Bank 2) 
P0333 Knock Sensor 2 Circuit High Input     (Bank 2) 
P0334 Knock Sensor 2 Circuit Input Intermittent    (Bank 2) 
P0335 Crankshaft Position Sensor A Circuit 
P0336 Crankshaft Position Sensor A Circuit Range/Performance  
P0337 Crankshaft Position Sensor A Circuit Low Input 
P0338 Crankshaft Position Sensor A Circuit High Input 
P0339 Crankshaft Position Sensor A Circuit Intermittent 
P0340 Camshaft Position Sensor “A” Circuit     (Bank 1 or Single Sensor) 
P0341 Camshaft Position Sensor “A” Circuit Range/Performance  (Bank 1 or Single Sensor) 
P0342 Camshaft Position Sensor “A” Circuit Low Input    (Bank 1 or Single Sensor) 
P0343 Camshaft Position Sensor “A” Circuit High Input   (Bank 1 or Single Sensor) 
P0344 Camshaft Position Sensor “A” Circuit Intermittent   (Bank 1 or Single Sensor) 
P0345 Camshaft Position Sensor “A” Circuit     (Bank 2) 
P0348 Camshaft Position Sensor “A” Circuit Range/Performance  (Bank 2) 
P0347 Camshaft Position Sensor “A” Circuit Low Input    (Bank 2) 
P0348 Camshaft Position Sensor “A” Circuit High Input   (Bank 2) 
P0349 Camshaft Position Sensor “A” Circuit Intermittent   (Bank 2) 
P0350 Ignition Coil Primary/Secondary Circuit 
P0351 Ignition Coil “A” Primary/Secondary Circuit 
P0352 Ignition Coil “B” Primary/Secondary Circuit 
P0353 Ignition Coil “C” Primary/Secondary Circuit 
P0354 Ignition Coil “D” Primary/Secondary Circuit 
P0355 Ignition Coil “F” Primary/Secondary Circuit 
P0356 Ignition Coil “F” Primary/Secondary Circuit 
P0357 Ignition Coil “G” Primary/Secondary Circuit 
P0358 Ignition Coil “H” Primary/Secondary Circuit 
P0359 Ignition Coil “I” Primary/Secondary Circuit 
P0360 Ignition Coil “J” Primary/Secondary Circuit 
P0361 Ignition Coil “K Primary/Secondary Circuit 
P0362 Ignition Coil “L’ Primary/Secondary Circuit 
 
P0365 Camshaft Position Sensor “B” Circuit     (Bank 1) 
P0366  Camshaft Position Sensor “B” Circuit Range/Performance  (Bank 1) 
P0367  Camshaft Position Sensor “B” Circuit Low Input    (Bank 1) 
P0368 Camshaft Position Sensor “B” Circuit High Input    (Bank 1) 
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P0369 Camshaft Position Sensor “B” Circuit Intermittent   (Bank 1) 
P0370 Timing Reference High Resolution Signal “A” 
P0371 Timing Reference High Resolution Signal “A” Too Many Pulses 
P0372 Timing Reference High Resolution Signal “A” Too Few Pulses 
P0373 Timing Reference High Resolution Signal “A” Intermittent/Erratic Pulses 
P0374 Timing Reference High Resolution Signal “A” No Pulse 
P0375 Timing Reference High Resolution Signal “B” 
P0376 Timing Reference High Resolution Signal “B” Too Many Pulses 
P0377 Timing Reference High Resolution Signal “B” Too Few Pulses 
P0378 Timing Reference High Resolution Signal “B” Intermittent/Erratic Pulses 
P0379 Timing Reference High Resolution Signal “B” No Pulses 
P0380 Glow Plug/Heater Circuit “A” 
P0381 Glow Plug/Heater Indicator Circuit 
P0382 Glow Plug/Heater Circuit “B” 
 
P0385  Crankshaft Position Sensor “B” Circuit 
P0386 Crankshaft Position Sensor “B” Circuit Range/Performance 
P0387 Crankshaft Position Sensor “B” Circuit Low Input 
P0388 Crankshaft Position Sensor “B” Circuit High Input 
P0389 Crankshaft Position Sensor “B” Circuit Intermittent 
P0390 camshaft Position Sensor “B” Circuit 
P0391 Camshaft Position Sensor “B” circuit Range/Performance  (Bank 2) 
P0392 Camshaft Position Sensor “B” Circuit Low Input    (Bank 2) 
P0393 Camshaft Position Sensor “B” Circuit High Input    (Bank 2) 
P0394 Camshaft Position Sensor “B” Circuit Intermittent   (Bank 2) 

P04XX Auxiliary Emission Controls 
P0400 Exhaust Gas Recirculation Flow 
P0401 Exhaust Gas Recirculation Flow Insufficient Detected 
P0402 Exhaust Gas Recirculation Flow Excessive Detected 
P0403 Exhaust Gas Recirculation Control Circuit 
P0404 Exhaust Gas Recirculation Control Circuit Range/Performance 
P0405 Exhaust Gas Recirculation Sensor “A” Circuit Low 
P0406 Exhaust Gas Recirculation Sensor “A” Circuit High 
P0407 Exhaust Gas Recirculation Sensor “B” Circuit Low 
P0408 Exhaust Gas Recirculation Sensor “B” Circuit High 
P0409 Exhaust Gas Recirculation Sensor “A” Circuit 
P0410 Secondary Air Injection System 
P0411 Secondary Air Injection System Incorrect Flow Detected 
P0412 Secondary Air Injection System Switching Valve “A” Circuit 
P0413 Secondary Air Injection System Switching Valve “A” Circuit Open 
P0414 Secondary Air Injection System Switching Valve “A” Circuit Shorted 
P0415 Secondary Air Injection System Switching Valve “B” Circuit 
P0416 secondary Air Injection System Switching Valve “B’ Circuit Open 
P0417 secondary Air Injection System Switching Valve “B” Circuit Shorted 
P0416 Secondary Air Injection System Relay “A” Circuit 
P0419 Secondary Air injection System Relay “B” Circuit 
P0420 Catalyst System Efficiency Below Threshold    (Bank 1) 
P0421 Warm Up Catalyst Efficiency Below Threshold    (Bank 1) 
P0422 Main Catalyst Efficiency Below Threshold    (Bank 1) 
P0423 Heated Catalyst Efficiency Below Threshold    (Bank 1) 
P0424 Heated Catalyst Temperature Below Threshold    (Bank 1) 
P0425 Catalyst Temperature Sensor     (Bank 1) 
P0426 Catalyst Temperature Sensor Range/Performance   (Bank 1) 
P0427 Catalyst Temperature Sensor Low Input    (Bank 1) 
P0428 Catalyst Temperature Sensor High Input    (Bank 1) 
P0429 Catalyst Heater Control Circuit     (Bank 1) 
P0430 Catalyst System Efficiency Below Threshold    (Bank 2) 
P0431 Warm Up Catalyst Efficiency Below Threshold    (Bank 2) 
P0432 Main Catalyst Efficiency Below Threshold    (Bank 2) 
P0433 Heated Catalyst Efficiency Below Threshold    (Bank 2) 
P0434 Heated Catalyst Temperature Below Threshold    (Bank 2) 
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P0435 Catalyst Temperature Sensor     (Bank 2) 
P0436 Catalyst Temperature Sensor Range/Performance   (Bank 2) 
P0437 Catalyst Temperature Sensor Low Input    (Bank 2) 
P0438 Catalyst Temperature Sensor High Input    (Bank 2) 
P0439 Catalyst Heater Control Circuit     (Bank 2) 
P0440 Evaporative Emission Control System 
P0441 Evaporative Emission Control System Incorrect Purge Flow 
P0442 Evaporative Emission Control System Leak Detected (small leak) 
P0443 Evaporative Emission Control System Purge Control Valve Circuit 
P0444 Evaporative Emission Control System Purge Control Valve Circuit Open 
P0445 Evaporative Emission Control System Purge Control Valve Circuit Shorted 
P0446 Evaporative Emission Control System Vent Control Circuit 
P0447 Evaporative Emission Control System Vent Control Circuit Open 
P0448 Evaporative Emission Control System Vent Control Circuit Shorted 
P0449 Evaporative Emission Control System Vent Valve/Solenoid Circuit 
P0450 Evaporative Emission Control System Pressure Sensor 
P0451 Evaporative Emission Control System Pressure Sensor Range/Performance 
P0452 Evaporative Emission Control System Pressure Sensor Low Input 
P0453 Evaporative Emission Control System Pressure Sensor High input 
P0454 Evaporative Emission Control System Pressure Sensor Intermittent 
P0455 Evaporative Emission Control System Leak Detected (gross leak) 
P0456 Evaporative Emission Control System Leak Detected (very small leak) 
P0457 Evaporative Emission Control System Leak Detected (fuel cap loose/off) 
P0460 Fuel Level Sensor Circuit 
P0461 Fuel Level Sensor Circuit Range/Performance 
P0462 Fuel Level Sensor Circuit Low Input 
P0463 Fuel Level Sensor Circuit High Input 
P0464 Fuel Level Sensor Circuit Intermittent 
P0465 EVAP Purge Flow Sensor Circuit 
P0466 EVAP Purge Flow Sensor Circuit Range/Performance 
P0467 EVAP Purge Flow Sensor Circuit Low Input 
P0468 EVAP Purge Flow Sensor Circuit High Input 
P0469 EVAP Purge Flow Sensor Circuit Intermittent 
P0470 Exhaust Pressure Sensor 
P0471 Exhaust Pressure Sensor Range/Performance 
P0472 Exhaust Pressure Sensor Low 
P0473 Exhaust Pressure Sensor High 
P0474 Exhaust Pressure Sensor Intermittent 
P0475 Exhaust Pressure Control Valve 
P0476 Exhaust Pressure Control Valve Range/Performance 
P0477 Exhaust Pressure Control Valve Low 
P0478 Exhaust Pressure Control Valve High 
P0479 Exhaust Pressure Control Valve Intermittent 
P0480 Cooling Fan 1 Control Circuit 
P0481 Cooling Fan 2 Control Circuit 
P0482 Cooling Fan 3 Control Circuit 
P0483 Cooling Fan Rationality Check 
P0484 Cooling Fan Circuit Over Current 
P0485 Cooling Fan Power/Ground Circuit 
P0486 Exhaust Gas Recirculation Sensor “B” Circuit 
P0487 Exhaust Gas Recirculation Throttle Position Control Circuit 
P0488 Exhaust Gas Recirculation Throttle Position Control Range/Performance 
 
P0491 Secondary Air Injection System     (Bank 1) 
P0492 Secondary Air Injection System     (Bank 2) 

P05XX Vehicle Speed, Idle Control, and Auxiliary Inputs 
P0500  Vehicle Speed Sensor 
P0501 Vehicle Speed Sensor Range/Performance 
P0502 Vehicle Speed Sensor Circuit Low Input 
P0503 Vehicle Speed Sensor Intermittent/Erratic/High 
P0505 Idle Control System 
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P0506 Idle Control System RPM Lower Than Expected 
P0507 Idle Control System RPM Higher Than Expected 
P0508 Idle Control System Circuit Low 
P0509 Idle Control System Circuit High 
P0510 Closed Throttle Position Switch 
P0512 Starter Request Circuit 
P0513 Incorrect Irnmobilizer Key (“Immobilizer pending SAE J1930 approval) 
 
P0515 Battery Temperature Sensor Circuit 
P0516 Battery Temperature Sensor Circuit Low 
P0517 Battery Temperature Sensor Circuit High 
 
P0520  Engine Oil Pressure Sensor/Switch Circuit 
P0521 Engine Oil Pressure Sensor/Switch Range/Performance 
P0522 Engine Oil Pressure Sensor/Switch Low Voltage 
P0523 Engine Oil Pressure Sensor/Switch High Voltage 
P0524 Engine Oil Pressure Too Low 
 
P0530 A/C Refrigerant Pressure Sensor Circuit 
P0531 A/C Refrigerant Pressure Sensor Circuit Range/Performance 
P0532 A/C Refrigerant Pressure Sensor Circuit Low Input 
P0533 A/C Refrigerant Pressure Sensor Circuit High Input 
P0534 Air Conditioner Refrigerant Charge Loss 
 
P0540 Intake Air Heater Circuit 
P0541 Intake Air Heater Circuit Low 
P0542 Intake Air Heater Circuit High 
 
P0544  Exhaust Gas Temperature Sensor Circuit    (Bank 1) 
P0545 Exhaust Gas Temperature Sensor Circuit Low    (Bank 1) 
P0546 Exhaust Gas Temperature Sensor Circuit High    (Bank 1) 
P0547 Exhaust Gas Temperature Sensor Circuit    (Bank 2) 
P0548 Exhaust Gas Temperature Sensor Circuit Low    (Bank 2) 
P0549 Exhaust Gas Temperature Sensor Circuit High    (Bank 2) 
P0550 Power Steering Pressure Sensor Circuit 
P0551 Power Steering Pressure Sensor Circuit Range/Performance 
P0552 Power Steering Pressure Sensor Circuit Low Input 
P0553 Power Steering Pressure Sensor Circuit High Input 
P0554 Power Steering Pressure Sensor Circuit Intermittent 
P0560 System Voltage 
P0561 System Voltage Unstable 
P0562 System Voltage Low 
P0563 System Voltage High 
P0564 Cruise Control Multi-Function Input Signal 
P0565 Cruise Control On Signal 
P0566 Cruise Control Off Signal 
P0567 Cruise Control Resume Signal 
P0568 Cruise Control Set Signal 
P0569 Cruise Control Coast Signal 
P0570 Cruise Control Accel Signal 
P0571 Cruise Control/Brake Switch A Circuit 
P0572  Cruise Control/Brake Switch A Circuit Low 
P0573 Cruise Control/Brake Switch A Circuit High 
P0574 Cruise Control System - Vehicle Speed Too High 
P0575 Cruise Control Input Circuit 
P0576 Cruise Control Input Circuit Low 
P0577 Cruise Control input Circuit High 
P0578 through P0580 Reserved for Cruise Control Codes 

P06XX Computer and Auxiliary Inputs 
P0600 Serial Communication Link 
P0601  Internal Control Module Memory Check Sum Error 
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P0602  Control Module Programming Error 
P0603  Internal Control Module Keep Alive Memory (KAM) Error 
P0604  Internal Control Module Random Access Memory (RAM) Error 
P0605 Internal Control Module Read Only Memory (ROM) Error (Module Identification Defined by SAE J1979) 
 
P0606 ECM/PCM Processor 
P0607 Control Module Performance 
P0608  Control Module VSS Output “A” 
P0609  Control Module VSS Output “B” 
P0610  Control Module Vehicle Options Error 
 
P0615 Starter Relay Circuit 
P0616  Starter Relay Circuit Low 
P0617  Starter Relay Circuit High 
P0618 Alternative Fuel Control Module KAM Error 
P0619 Alternative Fuel Control Module RAM/ROM Error 
P0620  Generator Control Circuit 
P0621 Generator Lamp “L” Terminal Control Circuit 
P0622 Generator Field “F” Terminal Control Circuit 
P0623  Generator Lamp Control Circuit 
P0624 Fuel Cap Lamp Control Circuit 
 
P0630  VIN Not Programmed or Mismatch - ECM/PCM  
P0631  VIN Not Programmed or Mismatch - TCM 
 
P0635 Power Steering Control Circuit 
P0836  Power Steering Control Circuit Low 
P0637  Power Steering Control Circuit High 
P0638  Throttle Actuator Control Range/Performance    (Bank 1) 
P0639  Throttle Actuator Control Range/Performance    (Bank 2) 
P0640 Intake Air Heater Control Circuit 
 
P0645  A/C Clutch Relay Control Circuit 
P0646  A/C Clutch Relay Control Circuit Low 
P0647  A/C Clutch Relay Control Circuit High 
P0648 Immobilizer Lamp Control Circuit (“Immobilizer” pending SAE J1930 approval) 
P0649 Speed Control Lamp Control Circuit 
P0650 Malfunction Indicator Lamp (ML) Control Circuit 
 
P0654 Engine RPM Output Circuit 
P0655 Engine Hot Lamp Output Control Circuit 
P0656 Fuel Level Output Circuit 
 
P0660 Intake Manifold Tuning Valve Control Circuit    (Bank 1) 
P0661 Intake Manifold Tuning Valve Control Circuit Low   (Bank 1) 
P0662 Intake Manifold Tuning Valve Control Circuit High   (Bank 1) 
P0663 Intake Manifold Tuning Valve Control Circuit    (Bank 2) 
P0664 Intake Manifold Tuning Valve Control Circuit Low   (Bank 2) 
P0665 Intake Manifold Tuning Valve Control Circuit High   (Bank 2) 

P07XX Transmission 
P0700 Transmission Control System (MIL Request) 
P0701 Transmission Control System Range/Performance 
P0702 Transmission Control System Electrical 
P0703 Torque Converter/Brake Switch B Circuit 
P0704 Clutch Switch In put Circuit Malfunction 
P0705 Transmission Range Sensor Circuit Malfunction (PRNDL Input) 
P0706 Transmission Range Sensor Circuit Range/Performance 
P0707 Transmission Range Sensor Circuit Low Input 
P0708 Transmission Range Sensor Circuit High Input 
P0709 Transmission Range Sensor Circuit intermittent 
P0710 Transmission Fluid Temperature Sensor Circuit 
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P0711 Transmission Fluid Temperature Sensor Circuit Range/Performance 
P0712 Transmission Fluid Temperature Sensor Circuit Low Input 
P0713 Transmission Fluid Temperature Sensor Circuit High Input 
P0714 Transmission Fluid Temperature Sensor Circuit Intermittent 
P0715 Input/Turbine Speed Sensor Circuit 
P0716 input/Turbine Speed Sensor Circuit Range/Performance 
P0717 Input/Turbine Speed Sensor Circuit No Signal 
P0718 Input/Turbine Speed Sensor Circuit Intermittent 
P0719 Torque Converter/Brake Switch B Circuit Low 
P0720 Output Speed Sensor Circuit 
P0721 Output Speed Sensor Circuit Range/Performance 
P0722 Output Speed Sensor Circuit No Signal 
P0723 Output Speed Sensor Circuit Intermittent 
P0724 Torque Converter/Brake Switch B Circuit High 
P0725 Engine Speed Input Circuit 
P0726 Engine Speed Input Circuit Range/Performance 
P0727 Engine Speed Input Circuit No Signal 
P0728 Engine Speed Input Circuit Intermittent 
P0730  Incorrect Gear Ratio 
P0731 Gear 1 Incorrect Ratio 
P0732 Gear 2 Incorrect Ratio 
P0733 Gear 3 Incorrect Ratio 
P0734 Gear 4 Incorrect Ratio 
P0735 Gear 5 Incorrect Ratio 
P0736 Reverse Incorrect Ratio 
P0737 TCM Engine Speed Output Circuit 
P0739 TCM Engine Speed Output Circuit Low 
P0739 TCM Engine Speed Output Circuit High 
P0740 Torque Converter Clutch Circuit 
P0741 Torque Converter Clutch Circuit Performance or Stuck Off 
P0742 Torque Converter Clutch Circuit Stuck On 
P0743 Torque Converter Clutch Circuit Electrical 
P0744 Torque Converter Clutch Circuit Intermittent 
P0745 Pressure Control Solenoid “A” 
P0746 Pressure Control Solenoid “A” Performance or Stuck Off 
P0747 Pressure Control Solenoid “A” Stuck On 
P0748 Pressure Control Solenoid “A” Electrical 
P0749 Pressure Control Solenoid “A” Intermittent 
P0750 Shift Solenoid “A” 
P0751 Shift Solenoid “A” Performance or Stuck Off 
P0752 Shift Solenoid “A” Stuck On 
P0753 Shift Solenoid “A” Electrical 
P0754 Shift Solenoid “A” Intermittent 
P0765 Shift Solenoid “B” 
P0756 Shift Solenoid “B” Performance or Stuck Off 
P0757 Shift Solenoid “B” Stuck On 
P0758 Shift Solenoid “B” Electrical 
P0759 Shift Solenoid “B” Intermittent 
P0760 Shift Solenoid “C” 
P0761 Shift Solenoid “C” Performance or Stuck Off 
P0762 Shift Solenoid “C” Stuck On 
P0763 Shift Solenoid “C” Electrical 
P0764 Shift Solenoid “C” Intermittent 
P0765 Shift Solenoid “C” 
P0766 Shift Solenoid “D” Performance or Stuck Off 
P0767 Shift Solenoid “D” Stuck On 
P0768 Shift Solenoid “D” Electrical 
P0769 Shift Solenoid “D” Intermittent 
P0770 Shift Solenoid “E” 
P0771 Shift Solenoid “E” Performance or Stuck Off 
P0772 Shift Solenoid “E” Stuck On 
P0773 Shift Solenoid “E” Electrical 
P0774 Shift Solenoid “E” Intermittent 
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P0775 Pressure Control Solenoid “B” 
P0776 Pressure Control Solenoid “B” Performance or Stuck Off 
P0777 Pressure Control Solenoid “B” Stuck On 
P0778 Pressure Control Solenoid “B” Electrical 
P0779 Pressure Control Solenoid “B” Intermittent 
P0780 Shift 
P0781 1-2 Shift 
P0782 2-3 Shift 
P0783 3-4 Shift 
P0784 4-5 Shift 
P0785 Shift/Timing Solenoid 
P0786 Shift/Timing Solenoid Range/Performance 
P0787 Shift/Timing Solenoid Low 
P0788 Shift/Timing Solenoid High 
P0789 Shift/Timing Solenoid Intermittent 
P0790 Normal/Performance Switch Circuit 
P0791 Intermediate Shaft Speed Sensor Circuit 
P0792 Intermediate Shaft Speed Sensor Circuit Range/Performance 
P0793 Intermediate Shaft Speed Sensor Circuit No Signal 
P0794 Intermediate Shaft Speed Sensor Circuit Intermittent 
P0795 Pressure Control Solenoid “C” 
P0796 Pressure Control Solenoid “C” Performance or Stuck off 
P0797 Pressure Control Solenoid “C” Stuck On 
P0798 Pressure Control Solenoid “C” Electrical 
P0799 Pressure Control Solenoid “C” Intermittent 

P08XX Transmission 
P0801 Reverse Inhibit Control Circuit 
 
P0803  1-4 Upshift (Skip Shift) Solenoid Control Circuit 
P0804 1-4 Upshift (Skip Shift) Lamp Control Circuit 
P0805 Clutch Position Sensor Circuit 
P0806 Clutch Position Sensor Circuit Range/Performance 
P0807 Clutch Position Sensor Circuit Low 
P0808 Clutch Position Sensor Circuit High 
P0809 Clutch Position Sensor Circuit Intermittent 
P0810 Clutch Position Control Error 
P0811 Excessive Clutch Slippage 
P0812 Reverse Input Circuit 
P0813 Reverse Output Circuit 
P0814 Transmission Range Display Circuit 
P0815 Upshift Switch Circuit 
P0816 Downshift Switch Circuit 
P0817 Starter Disable Circuit 
P0818 Driveline Disconnect Switch Input Circuit 
 
P0820 Gear Lever X-Y Position Sensor Circuit 
P0821 Gear Lever X Position Circuit 
P0822 Gear Lever Y Position Circuit 
P0823 Gear Lever X Position Circuit Intermittent 
P0824 Gear Lever Y Position Circuit Intermittent 
P0825 Gear Lever Push-Pull Switch (Shift Anticipate) 
 
P0830  Clutch Pedal Switch “A” Circuit 
P0831 Clutch Pedal Switch “A” Circuit Low 
P0832 Clutch Pedal Switch “A” Circuit High 
P0833 Clutch Pedal Switch “B” Circuit 
P0834 Clutch Pedal Switch “B” Circuit Low 
P0835 Clutch Pedal Switch “B” Circuit High 
P0836 Four Wheel Drive (4WD) Switch Circuit 
P0837 Four Wheel Drive (4WD) Switch Circuit Range/Performance 
P0838 Four Wheel Drive (4WD) Switch Circuit Low 
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P0839 Four Wheel Drive (4WD) Switch Circuit High 
P0840 Transmission Fluid Pressure Sensor/Switch “A” Circuit 
P0841 Transmission Fluid Pressure Sensor/Switch “A” Circuit Range/Performance 
P0842 Transmission Fluid Pressure Sensor/Switch “A” Circuit Low 
P0843 Transmission Fluid Pressure Sensor/Switch “A” Circuit High 
P0844 Transmission Fluid Pressure Sensor/Switch “A” Circuit Intermittent 
P0845 Transmission Fluid Pressure Sensor/Switch “B” Circuit 
P0846 Transmission Fluid Pressure Sensor/Switch “B” Circuit Range/Performance 
P0847 Transmission Fluid Pressure Sensor/Switch “B” Circuit Low 
P0848 Transmission Fluid Pressure Sensor/Switch “B” Circuit High 
P0849 Transmission Fluid Pressure Sensor/Switch “B” Circuit Intermittent 

Additional Diagnostic Trouble Code Ranges 
Other DTC ranges are defined for either manufacturer specific codes or under the control of 
SAE (Society of Automotive Engineers) and not yet defined. This section documents these 
additional ranges. Refer to your vehicle’s repair manual for manufacturer specific Diagnostic 
Trouble Codes.  

P09XX Transmission 

P1XXX Manufacturer Controlled 
P10XX Fuel and Air Metering and Auxiliary Emission Controls 

P11XX Fuel and Air Metering 

P12XX Fuel and Air Metering 

P13XX Ignition System or Misfire 

P14XX Auxiliary Emission Controls 

P15XX Vehicle Speed, Idle Control, and Auxiliary Inputs 

P16XX Computer and Auxiliary Outputs 

P17XX Transmission 

P18XX Transmission 

P19XX Transmission 

P2XXX SAE Controlled DTCs 
P20XX Fuel and Air Metering and Auxiliary Emission Controls 

P21XX Fuel and Air Metering and Auxiliary Emission Controls 

P22XX Fuel and Air Metering and Auxiliary Emission Controls 

P23XX Ignition System or Misfire 

P24XX SAE Reserved 

P25XX SAE Reserved 

P26XX SAE Reserved 

P27XX SAE Reserved 
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P28XX SAE Reserved 

P29XX SAE Reserved 

P3XX Manufacturer Controlled and SAE Reserved 
P30XX Fuel and Air Metering and Auxiliary Emission Controls 

P31XX Fuel and Air Metering and Auxiliary Emission Controls 

P32XX Fuel and Air Metering and Auxiliary Emission Controls 

P33XX Ignition System Misfire 

P34XX SAE Reserved 

P35XX SAE Reserved 

P36XX SAE Reserved 

P37XX SAE Reserved 

P38XX SAE Reserved 

P39XX SAE Reserved 
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APPENDIX B 

Support 

Technical support is offered on our products via email. Please note technical support cannot 
assist you in diagnosing and repairing your vehicle. Support is limited to operation of the scan 
tool only.  

When contacting technical support please provide the following information: 

• Year of Vehicle (e.g. 1997) 
• Make (e.g. Chevrolet) 
• Model (e.g. K1500 Pickup Extended Cab)  
• Problem encountered, be specific as possible. List any error messages displayed by the 

software.  
• Version of Auterra software located on the Help Options > About Dyno-Scan… menu.  
 

 

Figure 42: About Auterra Dyno-Scan Dialog 

 
Technical support is provided at: support@auterraweb.com. 
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APPENDIX C 

Warranty Information 

Auterra warranties the Dyno-Scan™ for Windows hardware for 1 year. Damage caused by 
misuse or modification is not covered.  

Auterra is not responsible for damage to vehicle caused by misuse or otherwise. Auterra's sole 
liability is limited to the repair or replacement of the scan tool while under warranty.  

When contacting Auterra for an RMA please provide the following information: 

• Year of Vehicle (e.g. 1997) 
• Make (e.g. Chevrolet) 
• Model (e.g. K1500 Pickup Extended Cab)  
• Problem encountered. Please be as specific as possible.  

Contact Auterra technical support via email at: support@auterraweb.com. 
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gear ratio, 66, 68, 70, 71, 72 CAN, 4, 36 
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Import, 63 COM port, 19, 20, 23, 90 

comma separated values, 63 ISO, 4, 36, 63 

correction factor, 66 KWP, 4, 36 

CSV, 63, 86, 87 Live Data, 29, 32, 33, 36, 42, 43, 44, 51, 52, 
53, 54, 59, 90 demo mode, 37, 85 

Lost Communication, 91 Demo mode, 38, 85 
MIL, 4, 5, 41, 48, 50, 91, 101 demonstration mode, 37 
No Communication, 90, 91 Demonstration mode, 85 
OBD II, 3 Diagnostic Trouble Code, 3, 4, 41, 92, 104 
OBD II adapter, ii, 19, 37, 65, 74, 77, 90 Diagnostic Trouble Codes, 39, 40, 41, 92, 

104 OBD II Cable, 2, 3, 19 

docking window, 30, 31, 32, 33, 34, 68, 73, 
74, 76 

OBD II compliant, 3, 4, 19, 90 

OBD II connector, 3, 19, 90, 91 
drag coefficients, 68, 69 Options, 20, 23, 25, 35, 41, 43, 44, 52, 53, 67, 

90, 101, 106 DTC, 1, 4, 40, 41, 63, 91, 92, 104 

dynamometers, 65 Parameter Edit, 42, 43 

Dynojet, 66 PWM, 4, 36 

ECU, 4, 43, 44, 52, 54, 55 RMA, 107 

ECU Parameters, 44, 52, 54 RS-232 cable, 3, 19, 74, 77, 90, 91 

enhanced, 92 Run Statistics, 29, 34, 74, 76, 78 

Export, 63 safety, 65, 75, 78 
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Sample Speed, 42, 44, 53 

Software Requirements, 2 

spreadsheet, 86 

status bar, 36 

support, 106 

Supported Vehicles, 4 

tire diameter, 68, 70, 71, 72 

torque converter, 66, 67, 72 

units of measure, 1, 23, 41, 44, 55, 56, 87 

Units of Measure, 23, 44 

Updates, 18 

VIN, 6, 68, 86, 101 

VPW, 4, 36 

Zoom, 53 
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