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Select Installation Folder

The installer will install Dependency Analyzer to the following folder.

Tainstall in this folder, click "Mext”. To install to a different folder, enter it below or click 'Browse".

FEolder:

C:\Program Filest\Dependency &nalyzer', Browse...
Disk Cost...

Install Dependency Analyzer for yourself, or for aryone who uses this computer:

() Everpone

@ Just me

[ Cancel ] [ < Back I I Mext » I

Figure 1: Dependency Analyzer installation wizard.
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Figure 2: Dependency Analyzer folder in Start Menu.
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Figure 3: SolidSX main screen.



1 Install Dependency Analyzer

In this part of the user manual the installation of the Dependency Analyzer,
SolidSX and a possible required hotfix is described.

1.1 Dependency Analyzer

Use the ”Install software” button in the autorun menu of the CD to start
the installation of Dependency Analyzer. The installation wizard is easy to
use, see figure 1 for a screenshot of the installation. When the installation
if finished a shortcut is created on the desktop and in the programs folder
of the start menu.

Note: When the autorun menu is not shown automatically, browse to the
CD and open DependencyAnalyserMenu.exe.

1.2  SolidSX

Dependency Analyzer uses SolidSX to visualize the dependencies, so make
sure the right version of SolidSX is installed correctly. SolidSX wersion
2.15.12 (and probably also newer versions) will be supported by the Depen-
dency Analyzer. To make it easy, the right version of SolidSX is included in
the Dependency Analyzer. To install this version go to Start Menu > Pro-
gram > Dependency Analyzer > Install SolidSX 2.15 (See figure 2).

It is recommended to install SolidSX on the default location. When the
installation is finished start SolidSX and add your license or select to re-
quest an evaluation version. When you see the same screen as displayed in
figure 3, the configuration is successfull and SolidSX can be closed.

1.3 Hotfix KB982927 (only when needed)

Install this hotifix only if you run Dependency Analyzer on Windows 7 and
you have problems using the SVN repository function, i.e. you receive an
error message that states the file system is broken or a file can not be moved.

To fix this problem there is a hotfix from Microsoft KB982927 which solves
this problem (the hotfix will also be part of the next Service pack for Win-
dows 7). The hotfix is included in the Dependency Analyzer and you can
find it here: Start Menu > Program >Dependency Analyzer > Install Hotfix
KB982927 186/164 (See figure 2). You have to select the version which is
suitable for your operating system, so x86 or x64.
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Figure 4: SolidSX is not found window.
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Figure 6: Project name and location.



2 Using Dependency Analyzer

2.1 Using the software for the first time

When you use Dependency Analyzer for the first time it will check if SolidSX
is found. When SolidSX is not installed, or it is installed, but not on the de-
fault location, the ”SolidSX nog found” window appears (see figure 4). Use
the ”Browse...” button to navigate to the location of SolidSX2.exe. When
the right location is selected click OK and Dependency Analyzer will be
started. The specified location is stored in the registry, so during the next
start the right location is selected automatically.

If you click Cancel when the ”SolidSX not found” window appears, the De-
pendency Analyzer will be closed, because it cannot run without SolidSX.

2.2 Creating a project

When Dependency Analyzer is started successfully, the main window is
shown (see figure 5). In Dependency Analyzer there are two project types:

e Local folder project:
A project using a local folder with source files to analyze. In this case
you can only see the dependencies of the local folder and you cannot
use the compare features of the software.

e Subversion project:
A project using a subversion repository. It is possible to select multiple
revisions and compare them with each other.

To create a new project go to File >New project and select the project type
you want to create. For both project types the first window it the same.
This window is used to give the project a name and select the location where
the project should be saved. With the checkbox there can be chosen if a
subfolder (with the projectname) for the project must be created or not (see
figure 6).

2.2.1 Local folder project

When there is chosen for a ” Local folder project”, in the next window select
the folder with the source code that should be analyzed. When the right
folder is selected, the code will be analyzed. The progress can be followed
in the Log box and with the progress bar at the bottom of the main window
(see figure 7). When this is done an item ”Local” is added to the Revision
list on the left side of the main window.



28-11-2010 16:12:43: Application started. -
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Figure 7: Log box and progress bar.
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Connect to Subversion
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Figure 9: Select revision using the log window.



2.2.2 Subversion project

When there is chosen for a ”Subversion project”, in the next window the
URI to the repository and the revision that should be analysed must be en-
tered. When there is chosen for a repository with an username or password
a login window appears when the process is started. A window where a SSL
certificate can be accepted will appear when there is an untrusted certificate
used (see figure 8).

In the revision box the revision that should be analysed must be entered.
This can be done by directly entering the revision number, enter the word
"HEAD” to use the HEAD revision or use the ”Select from log...” button.
When the ”Select from log” feature is used a window with the log with the
latest log entries will be shown. The range of the log items can be changed
using the DataPickers and the ” Update log” button. To use a revision, select
that one in the box and click the "Ok” button (see figure 9). The revision
number is now entered in the revision box. The next step is clicking the
”Ok” button and the revision will be checked out, the progress of the check-
out can be followed in the log window of the SVN window (see figure 10).
When the checkout is done, the revision will be analysed and the revision
number added to the revision list.

With the subversion project it is possible to add multiple revisions to the
project. To add a revision use the ” Add revision” button below the Revision
list. The same window used by creating the project appears, but this time
the Uri cannot be changed. It is only possible to select a revision.

To remove a revision from the project, just select a revision from the list and
use the ”Remove revision” button. At least one revision should be part of
the project, so removing is only possible if there are more than one revisions
part of the project.

Enter SVN information L l&]

Please enter the following information:

URI:  svn://anonsvn kde.org/home.fedeArunk koffice

» Revision: HEAD
Add: C:\Users'Mark . Documents DAprojects  KDOffice-svn\source tools'f-office \Office Interface h -

Add: C:\Users'Mark . DocumentstDAprojects  KDOffice-svn\source tools'f-office’\Presentation Tool Adaptor.cpp
Add: C:\Users'Mark Documents D Aprojects KDOffice-svn'\sourcetoolsfoffice’ Collaborate cpp

Add: C:\Users'\MarcDocumentstDAprojects \ KDOffice-svn\source tools'f-office\MotifyDialog cpp

Add: C:\Users'MarcDocumentsiDAprojects  KDOffice-svn\source tools kthesaurus

Add: C:\Users'MarcDocuments D Aprojects KD Office-svn\source tools kthesaurus ' Messages sh

Add: C:\Users"Mark Documents D Aprojects KD Office-svn\source tools kthesaurus' K Thesaurus desktop
Add: C:\Users'Mark . DocumentsiDAprojects  KDOffice-svn\source tools kthesaurusmain .cc

Figure 10: SVN checkout/update in progress.
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Figure 11: Open a Dependency Analyzer project.
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2.3 Open a project

To open an already created project go to File >Load. An ”Open project...”
window appears, now it is possible to navigate to the project file (see figure
11). A project file has the extension .DAP (Dependency Analyzer Project).

Note: The file structure in the project folder is important, changing anything
in the project folder can corrupt the project.

2.4 Close a project

A project can be closed using File > Close project. A project will be also
closed when exiting Dependency Analyzer. The project file is always up-
to-date, because it will be automatically saved during updates (adding or
removing a revision).

2.5 Show and compare dependencies

This section describes the features of Dependency Analyzer according to
showing and comparing dependencies. Because SolidSX is used to visualize
the dependencies we will also refer to the SolidSX manual which can be
found in the doc directory of the SolidSX installation folder.

2.5.1 Selecting revisions

All revisions that are part of the project are listed in the revision list (in
case of a local folder project, only "Local” is available). Each revision has
a checkbox, when a checkbox is checked, this revision will be opened in the
first free tab. A tab is free when there is not already a revision assigned to
that tab. There are two tabs, so there is a maximum of two revisions that
can be selected at the same time (see figure 12). To close a revision, just
uncheck the checkbox before the revision.

2.5.2 Toolbar and filetree

SolidSX has the possibility to show a filetree of the nodes. By default, this
filetree is hidden. To switch this filetree on and off go to View > Filetree.
Another option is to show and hide the SolidSX toolbar. This can be done
by View >Toolbar. With this toolbar there is the possibility to change the
colors, etc. For a detailed description see the SolidSX manual.

11
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2.5.3 Screenshot of the circle

To use the results of the visualized data, there is the possibility to make a
screenshot of the circle. Therefore use the Screenshot menu and select To
clipboard (to save the image to the clipboard) or To BMP (to save the image
as a BMP file to the desktop) and choose the desired quality. Unfortunately
at this moment only the normal quality is available, because SolidSX gives
an error when using the large parameter.

2.5.4 Auto expand node (beta)

Auto expand nodes is an experimental feature of Dependency Analyzer.
With this feature it is possible to easily compare two revisions, because the
two revisions are ”connected” to each other. When you double click on a
node in one of the revisions, there will be checked if this node also exists in
the revision opened in the other tab. Is that node also there available then
the node will be also expand. Is the node not available then the node will
be only expand in the current tab. When this feature is switched on both
revisions should collapse back to the start position, therefore a message is
shown (see figure 14).

To select the node in the other revision, the unique file path is used. This is
necessary because the SolidSX ID of the node in one revision can be different
in another revision when modules are added or removed.

Note: This is an experimental feature which make use of mouse events (at
system level) to reset the focus back from SolidSX to the Dependency An-
alyzer after each click. Sometimes it is possible that it will not work as
expected, for example the focus of the program is lost. When this occurs,
use the keyboard combination alt-tab to reset the focus on the application.
During testing, we discovered that this experimental feature works better on
relative faster systems.
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3 Uninstall Dependency Analyzer

To remove Dependency Analyzer from the computer, make use of the ” Win-
dows remove programs” feature which can be found at the Windows Configu-
ration screen. There the Dependency Analyzer can be selected and removed.
See figure 15 for an example of the ”Windows remove programs” screen in

Windows 7.
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Figure 15: Remove Dependency Analyzer using Windows
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