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Introduction

This document explains the installation of the POOSL IDE. This is a plug-in for Eclipse that relies on
the Xtext framework (http://www.eclipse.org/Xtext/) and the POOSL simulator (Rotalumis) of
Eindhoven University of Technology (http://www.es.ele.tue.nl/poosl).

Further information about the use of the POOSL IDE can be accessed through the built-in help.


http://www.eclipse.org/Xtext/
http://www.es.ele.tue.nl/poosl

1 Installation

1.1 Minimal system requirements
The POOSL IDE requires one of the following operating systems:

e Windows 7, 32 bit or 64 bit (Windows XP is not supported)
e Ubuntu 12.04, 32 bit or 64 bit
e Mac OS X 10.10 (Yosemite)

In addition it requires the following installed software:

e Java Runtime Environment (JRE) 1.7.0_55 or newer'  (Java 1.8 is supported)
o Eclipse Luna SR1 (version 4.4.1) for “Java Developers” or for “Java and DSL Developers”

For the JRE and Eclipse, make sure that both are 32-bit versions, or both are 64-bit versions.

1.2 Installing Eclipse
If a correct version of Eclipse is already installed, skip this section. Otherwise, follow these steps to
install Eclipse:

1. Download and Install Java Runtime Environment (JRE), see
http://www.oracle.com/technetwork/java/javase/downloads

2. Download the Eclipse IDE for Java Developers (Eclipse Luna version 4.4.1).
http://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/lunasrl

3. Unzip the Eclipse file at a location where you have permission to write files and directories.
Locate the “Eclipse.exe” file in directory “Eclipse”. Create a shortcut on the desktop or task
bar (In Windows, right click on the file -> Send to -> Desktop). When multiple JREs are
installed on your machine, specify the JRE to be used as follows: right-click on Eclipse
shortcut, select Properties, tab Shortcut; edit the “Target” field to specify the location of the
Java Virtual Machine. For instance:

C:\Eclipse\Luna\Eclipse.exe -vm "C:\Program Files\Java\jre8\bin\javaw.exe"
Note the use of “javaw” to avoid opening a additional window.

When opening Eclipse select a location for the workspace and click OK.

! To determine which version of Java is installed, type the following at the command prompt: java -version
4


http://www.oracle.com/technetwork/java/javase/downloads
http://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/lunasr1

1.3 Installing the POOSL IDE plug- in
To install the POOSL IDE plug-in in Eclipse follow these steps:

In Eclipse go to Help -> Install new software

In “Work with: “, click the Add... button. The Add Repository dialog box appears:
3. Copy one of the following links to the location box:

e http://poosl.esi.nl/downloads/ide/updates/release/ for the release version

e http://poosl.esi.nl/downloads/ide/updates/latest/ for the latest version

4. Enter a name for the repository and click OK.

£ Add Repositary @

MName: POOSLIDE Heleases| Local...
Location:  httpe//pooslesinl/downloads/ide/updates/release/

?) [ ok [ Cconcel |

L
5. Select the POOSL IDE plug-in from the update site and check the “Contact all update sites
during installation to find required software” checkbox.

1
= Install l_l_lﬂ:' =
Available Software

Check the items that you wish to install. \Di
(| Work with:  local - file:/C:/Developer/SVMN/POQSLIDE/nl.esi.poosl updatesite/ - Add... |

Find more software by working with the "Available Software Sites” preferences.
type filter text

MName Version
> [] 000 EMF Core and MDT XSD
> [] 000 EMF Xcore
4 (00 Poosl
B @ Legacy Support for POOSLIDE 3.20.201412161447
— (% POOSLIDE 3.2.0.201412161447
> [7] 000 Rotalumis
> [] 000 Sirius
> [] 000 Sirius SDK
> [] 000 Xtend
> [0 000 Ktext

[ Select All I [ Deselect All 1 itemn selected

Details

Show only the |atest versions of available software [] Hide items that are already installed
Group items by category What is already installed?

[7] Show only software applicable to target environment

ﬁ Contact all update sites during install to find required software

@. < Back Mest > Finish



http://poosl.esi.nl/downloads/ide/updates/release/
http://poosl.esi.nl/downloads/ide/updates/latest/

6. Click “Next” twice and accept the license agreement, click “Finish” to start the installation.
Because the software is not signed by Eclipse it will give a security warning. Click OK on the
security warning to continue installation.

e Installing the POOSL IDE plugin will automatically install the simulator (Rotalumis).

7. When asked, restart Eclipse.

If an error is reported during installation, please consult section 4.3 and section 4.4.

1.4 Updating the POOSL IDE
To update the POOSL IDE follow these steps:

1. In Eclipse select Help -> Check for Updates. If a newer version of the POOSL IDE or the
simulator (Rotalumis) are available, they will appear in the list of software to update.
2. Click Next to install the new updates.

1.5 Installation problems
In case errors occur after installing the POOSL IDE when opening files or running or debugging
models, make sure that the correct versions of the following software are installed:

e Java Runtime Environment (JRE) 1.7.0_55 or newer (see section 1.1)
e Eclipse Luna SR1 (4.4.1) or newer (see section 1.1)
o Check at Help -> About Eclipse
e Xtext 2.6.x or newer
o Check at Help -> About Eclipse -> Installation Details -> Installed Software

Xtext should have been installed automatically during the installation of the POOSL IDE. If it is missing
or an old version is present, it can be installed or updated using the Xtext update site:
http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/ .



http://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/

2 Testyour installation using the examples

This section describes a procedure to check whether the installation was successful, and whether the
POOSL IDE has enough permissions on your computer. To use the POOSL IDE to its full potential, it
needs enough permissions to write files and to create socket connections on your machine.

2.1 Download the example POOSL project
The example POOSL project can be downloaded from
http://poosl.esi.nl/downloads/examples/examples.zip. Save the file in a temporary location; do not

unzip the files or extract files from the zip file.

2.2 Import the example POOSL project
To create a POOSL project with the examples, follow these steps:
1. Click on File -> Import... -> General -> Existing Projects into Workspace.

< Import =[] X

Select \

Create new projects from an archive file or directory.

Select an import source:

type filter text

4 (= General o
& Archive File
= Existing Projects into Workspace
1 File System
[C1 Preferences

> = CVS

: = Git

¢ (= Install

= Maven -

1

. ¥

2. Click on Select archive file, and press Browse... to open the examples.zip file.



http://poosl.esi.nl/downloads/examples/examples.zip

& Import (=[=] % ]
Import Projects
Select a directory to search for existing Eclipse projects. -
() Select root directory: - Browse...

@) Select archive file: F\examples.zip

A Browse...

Projects:

nl.esi.poosl.examples (POOSLExamples)

Select All
Deselect All

Options
Search for nested projects
Copy projects into workspace
["| Hide projects that already exist in the workspace
Working sets
["] Add project to working sets

Working sets: A Select...

Next = Finish | [ Cancel

@

3. Click Finish to import the project.

2.3 Testyour installation using an example
1. Click on Window -> Open Perspective -> Other... -> POOSL Edit, which changes the screen
layout in order to support the editing POOSL models.

2. Double-click on the file producer_consumer.poosl. Check that the contents of the file is
shown in a syntax-highlighted way.

& o0s Ea - e e
Eile Edit Navigate Search Project Run Window Help
= T s e R e e = e
[ Project Explorer &2 E&|e¢ =0 [Fl producer_consumer.poosl &
4 [# nlesi.poosl.examples - // Data Classes
» & libraries ~data class Packet extends Object
4 5= models variables
+ & ATMSwitch 1D - Integer
) methods
» & Fisher setIdentity(I : Integer) : Packet
I+ & HelloWorld = e m:=71:
= : H
i = Jobshop return self
& & MarsRover @ getIdentity : Integer
i = MPSoC return ID
4 (= ProducerConsumer printString : String

\@ producel_consumer.poosl\
> &= SoClInterconnects
I+ = SocketExample

return("[" + ID printString + "1")

// Process Classes

~process class Producer(IdleTime : Integer)
I = Wireless v ports

4 i 3 Out
. i —a - = messages
52 Outline &2 B a Out!Message(Packet)
¢ = Imports variables
¢ b= Data classes ID : Integer
- = Process classes init eps s
- = Cluster classes Initialise() ()

_ methods
¢ = System - Initialise()()



3. Right-click on the file producer_consumer.poosl and select Debug as -> POOSL simulation.
The screen layout is changed in order to support the debugging of POOSL models.
N{'w »
Open 3
Open With »
Copy Cirl+C
~ O.ckllc Deleu.-

Mowe.
Rename.. F2

i Import.
ts Export.

¢ Refresh 5

Valicate
Debug As

Run As

Team
Compare With
Replace With

1 Java Application
2 Nest Plug-in Test
3 JUrst Test

4 POOSL Simulation

Debug Configurations..

‘e

Properties Alt+Enter
Generate Rotalumis XML

Generate DOT graph (beta)
Generate Legacy SHESIm XML

4. If no element is selected in the Debug view (top-left corner), then select any element.
5. Inthe top-left corner, click on the green Resume button (indicated by the green arrow in the
picture below). Check that the Sequence Diagram in the bottom-right corner fills up with

messages.

© POOSL Debug - Ecipse Platform NN

File Edit Navigate Search Project Run Window Help
N T S A= il 2R

:ﬁDebug E:E] \ |

4 1% Rotalumis producer_consumer.poosl [Simulated time: 0]

o /ProducerConsumer/Producer
o® /ProducerConsumer/Consumer
of® /Bus

6. Inthe top-left corner, click on the red Terminate button (indicated by the red arrow in the
picture above).
7. Inthe top-right corner, click on POOSL Edit to change back to the screen layout for editing.

-

|35 POOSL Debug | 27 POOSL Edit




3 User manual

The user manual for the POOSL IDE can be found inside the Eclipse environment. It can be opened in
several ways:

1. Click on the Help menu, and select “Help Contents”.

This will open the Eclipse built-in help in a separate window. The POOSL documentation is
located under Contents in the Poosl booklet.

= [ﬂ] Poosl
¥ Editing
8 Running and debugging
L} Importing and exporting
Bl Preferences

B FaQ

The recommended starting point for new users is Editing -> Create Projects and Models.

Click on the Help menu, and select “Dynamic help” (Or use keyboard shortcut <F1>).

This will open a window inside Eclipse. It shows brief information about the selected view, in
combination with references to the help Contents.

{® Help 32

Contents I5” Search

Related Topics ;w Bookmarks (& Index

About Poosl Editor

The POOSL editor provides you with POOSL specific text editing support.

This includes syntax highlighting, hovers, navigation, validation and
content assist (<CTRL>+<SPACE>).

See also:

B Creating models
B Editing models
More results:

%7 Search for About Poos! Editor

To switch between the main documentation (“Contents”) and the dynamic help (“Related
Topics”), use the tabs on top of the help page.
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4 FAQ

4.1 <CTRL>-<SPACE> does not work.
This is a general Eclipse problem. Some suggestions for solutions can be found online, such as:

1. Create a new workspace, and import your existing projects. Remember to check “Copy projects
into workspace” to copy all your existing work to new workspace.

2. Make sure that the <CTRL>+<SPACE> combination is not hijacked by any other application (such as
text input features).

3. Make sure “regional and language options” is in English language. For example, Windows, Control
panel —> Region and language options. Then

e Administrative (tab) —> Language for non-Unicode program. Make sure English (United
States) is selected, others may not work.

e Keyboards and Languages (tab) —> Change Keyboards. You'll see a list of languages
installed; remove any that you don’t want (click the language and then click the Remove
button) until you only have the ones you want left.

4. Change the key combination in Eclipse, via Window -> Preferences -> General -> Keys. The default
binding for command “Content Assist” is “Ctrl + Space”, but this can be changed into something else.

4.2 Internal null pointer exception when trying to run/debug a model.
The following error may occur when you try to run or debug a model:

An internal error occurred during: "Launching ...poosl". java.lang.NullPointerException

It usually indicates that your version of the Java Runtime Environment (JRE) is too old. Please check
the minimal system requirements in section 1.1.

4.3 Cannot complete the install because of a conflicting dependency.
The following error may occur during the installation of the POOSL IDE:

Cannot complete the install because of a conflicting dependency

If the remaining message refers to different version of the Eclipse Workbench, then it usually
indicates that your version of Eclipse is too old. Please check the minimal system requirements in
section 1.1.

4.4 An error occurred while collecting items to be installed
The following error may occur during the installation of the POOSL IDE:

An error occurred while collecting items to be installed

session context was:(profile=epp.package.java,
phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

Followed by the repositories it cannot find:
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No repository found containing: osgi.bundle,nl.esi.poosl.generatedxmlclasses,3.2.0.201501141011
No repository found containing: ... ... ...
This is a known problem in Eclipse and it can be solved by reloading the software site.

1. Go to Help-> Install New Software, then select “Available Software Sites”.

& Install - - I lenfiE sz o
Available Software
Select a site or enter the location of a site. \Di
| Work with: type or select a site - Add...

T T
= Preferences (=& & |
type filter text Available Software Sites & v

> General
> Ant type filter text
> Code Recommenders
> Help Name = Location Add...
4 Install/Update <] POOSL IDE http://poosl.esi.nl/downloads/ide/updates/release
Automatic Updates B Qﬂ i1 L i Edit
Available Software Sites 4 = Edit Site '_ 28 ‘
e - — |
]
> Maven a4 Name:  POOSLIDE
5 Mwel
> Mylyn o < Location:  http://poosl.esi.nl/downloads/ide/updates/release =
. o4
> Plug-in Development
> Run/Debug O :% I Import...
T O
s feam @ [ oK ] I Cancel l
> WindowBuilder
XML
> Ktend
o Mteut
4 UL} »
< . | »
® [ OK ] [ Cancel ]

2. Select the POOSL IDE site, and click “edit”. Change the location by removing or adding the trailing “/",
and click "OK".

3. Select the POOSL IDE site, and click “Reload”. Reloading may take a minute.

4. Once the software site has been reloaded, click "“OK" to go back to the “Install New Software” screen.
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5. The problem should now be resolved. Select the POOSL IDE site from the dropdown box to continue the
installation at point 5 of the manual (section 1.3).

= Install ’ [ -
Available Software
Select a site or enter the location of a site. \‘E) —
Work with:e type or select a site| H [ Add... ]

type or select a site
--All Available Sites--

type filter P9 POOSL IDE - http://poosl.esi.nl/downloads/ide/updates/release

ites” preferences.

I Name Version
[F] (@ There is no site selected.

Select All | [ Deselect Al
Details
|
Show enly the latest versions of available software Hide items that are already installed
Group items by category What is already installed?

[] Show only software applicable to target environment

Contact all update sites during install to find required software

@ < Back Next » Finish

4.5 Something doesn’t (seem to) work.

First of all, check whether your system meets the minimal installation requirements (see section 1.1),
and the other FAQ. Depending on the problem, the following information may support experts in
solving the problem that you experience:

e Version of the Java Runtime Environment

o At the command prompt, type: java -version
e Version of Eclipse

o Help -> About Eclipse
e Version of Xtext

o Help -> About Eclipse -> Installation Details -> Installed Software
e Version of Rotalumis

o Help -> About Eclipse -> Installation Details -> Installed Software
e Eclipse log

o Help -> About Eclipse -> Configuration -> View Error Log
e Log of the communication between Eclipse and the simulator

o Set the logging level in the preferences

o The Logging.html file can be found in the root of the Eclipse installation
e Console output and/or Eclipse screenshot
e The .poosl files causing the problem
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