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1 Guide to this manual

1.1 Introduction

This User Manual concerns the Remote Online Visualisation module (RemoteOLV) of the
Delft3D software suite. To make this manual more accessible we will briefly describe the
contents of each chapter and appendix.

If this is your first time working with RemoteOLV module we suggest you to read and practice
the getting started of chapter 3 and the tutorial of chapter 6. These chapters explain the user
interface options and guide you through the Remote Online Visualisation module.

chapter 2: Introduction to RemoteOLV, provides specifications of RemoteOLV.

chapter 3: Getting started, explains the use of the overall menu program, which gives access
to the Delft3D modules and to the pre- and post-processing tools. Last but not least you will
get a first introduction into the RemoteOLV Graphical User Interface.

chapter 4: General operation, provides practical information on the general operation of the
RemoteOLV module.

chapter 5: Menu options, provides a description of all menu and toolbar options.

chapter 6: Tutorial, emphasis at giving you some first hands-on experience in using the
RemoteOLV module.

References, provides a list of related material on the RemoteOLV module.

Appendix A: Files of RemoteOLV, gives a description of the files that can be used in Remo-
teOLV as input or output (i.e. colour map definitions and settings).

1.2 Manual version and revisions

A manual applies to a certain release of the related program. This manual applies to Remo-
teOLV version 4.01.01.

1.3 Typographical conventions

Throughout this manual, the following conventions help you to distinguish between different
elements of text to help you learn about RemoteOLV.

Example Description

Waves
Boundaries

Title of a window or sub-window.
Sub-windows are displayed in the Module window and
cannot be moved.
Windows can be moved independently from the Mod-
ule window, such as the Visualisation Area window.
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Example Description

Save Item from a menu, title of a push button or the name of
a user interface input field.
Upon selecting this item (click or in some cases double
click with the left mouse button on it) a related action
will be executed; in most cases it will result in displaying
some other (sub-)window.
In case of an input field you are supposed to enter input
data of the required format and in the required domain.

<\tutorial\wave\swan-curvi>
<siu.mdw>

Directory names, filenames, and path names are ex-
pressed between angle brackets, <>. For the Linux
and UNIX environment a forward slash (/) is used in-
stead of the backward slash (\) for PCs.

“27 08 1999” Data to be typed by you into the input fields are dis-
played between double quotes.
Selections of menu items, option boxes etc. are de-
scribed as such: for instance ‘select Save and go to
the next window’.

delft3d-menu Commands to be typed by you are given in the font
Courier New, 10 points.

User actions are indicated with this arrow.

[m/s] [-] Units are given between square brackets when used
next to the formulae. Leaving them out might result in
misinterpretation.

1.4 Changes with respect to previous versions

Version Description

0.90 First version of RemoteOLV manual
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2 Introduction to RemoteOLV

2.1 Introduction

The main purpose of the RemoteOLV module is to monitor the results during a simulation, e.g.
Delft3D-FLOW. You can select the type of parameter displayed, the type of view used (map or
cross-sectional), each with a different display, such as iso-lines and/or vector plots per layer.
When using several windows, each window can show you a different parameter and extent to
a different part of the model area. All these windows are steered from the main window which
has the control over the simulation. So if in the main window is said that the simulation should
do one time step, all windows are updated. On-line visualisation is a very powerful tool to
let you inspect the behaviour of your model; this will help you to see anomalies in the results
much better and in a much earlier stage than when using plots and figures.

The remote on-line visualisation module can be attached to a simulation at the start or at
an intermediate stage of the simulation. If the RemoteOLV module is used at the start of the
simulation you are able to check the behaviour of the simulation during spin-up time and when
the RemoteOLV module is attached to a running simulation you can examine the results so
far.

2.2 Program considerations

The RemoteOLV module is made to support the visualisation of simulation results during
the computation. Because the RemoteOLV module is a separate executable it does not run
necessarily on the same computer platform as the simulation. The data transport between
the two executables is performed by a Java server (called DOL-server; DelftOn-Line). At this
moment we support three different situations:

1 A single domain simulation on Linux or Windows with visualisation on Windows,
2 A multi domain simulation on Linux or Windows with visualisation of all domains (as one

model) on Windows, and
3 A multi domain and multi core simulation on Linux with visualisation of all domains (as one

model) on Windows

Remark:
� At this moment (early 2011) the RemoteOLV module can only be used in combination

with the computational core of Delft3D-FLOW.
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3 Getting started

3.1 Overview of Delft3D

The Delft3D program suite is composed of a set of modules (components) each of which
covers a certain range of aspects of a research or engineering problem. Each module can be
executed independently or in combination with one or more other modules.

Delft3D is provided with a menu shell through which you can access the various modules. In
this chapter we will guide you through some of the input screens to get the look-and-feel of
the program. In the Tutorial, Chapter 6, you will learn to define a simple scenario.

3.2 Starting Delft3D

To start Delft3D (Delft3D is already installed):

� On an MS Windows platform: select Delft3D in the Programs menu.
� On Linux machines: type delft3d-menu on the command line.

Next the title window of Delft3D is displayed, Figure 3.1.

After a short while the main window of the Delft3D-MENU appears, Figure 3.2.

Several menu options are shown. In Figure 3.2 all options are sensitive.

For now, only concentrate on exiting Delft3D-MENU, hence:

� Click on the Exit push button.

The window will be closed and you are back in the Windows Desktop screen for PCs or on
the command line for Linux workstations.

Remark:
� In this and the following chapters several windows are shown to illustrate the presen-

tation of Delft3D-MENU and Delft3D-FLOW. These windows are grabbed from the PC-
platform. For Linux workstations the content of the windows is the same, but the colours

Figure 3.1: Title window of Delft3D
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Figure 3.2: Main window Delft3D-MENU

Figure 3.3: Selection window for Hydrodynamics

may be different. On the PC-platform you can set your preferred colours by using the
Display Properties.

3.3 Getting into RemoteOLV

To continue restart the menu program as indicated above.

� Click the Flow button.

Next the selection window for Hydrodynamics is displayed for preparing a flow input MDF-file,
wave input MDW-file, to execute a computation in foreground (including on-line WAVE, on-line
coupling and/or remote on-line visualisation), to inspect the report files with information on the
execution and to visualise the results, see Figure 3.3.

Before continuing with any of the selections of this Hydrodynamics (including morphology)
window, you must select the directory in which you are going to prepare scenarios and execute
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Figure 3.4: Select working directory window

Figure 3.5: Select working directory window to set the working directory to
<remoteolv/flow>

computations:

� Click the Select working directory button.

Next the Select working directory window, Figure 3.4, is displayed (your current directory
may differ, depending on the location of your Delft3D installation).

� Browse to and open the <tutorial> sub-directory of your Delft3D Home-directory.
� Open the <remoteolv> directory.
� Enter the<flow> sub-directory and close the Select working directory window by click-

ing OK, see Figure 3.5.

Next the Hydrodynamics (including morphology) window is re-displayed, but now the
changed current working directory is displayed in the title bar (if the name is not too long),
see Figure 3.6.

Figure 3.6: The current working directory is not completely shown in the title bar due to
its length
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Remark:
� In case you want to start a new project for which no directory exists yet, you can select

in the Select working directory window to create a new folder.

Before you can use the RemoteOLV module a simulation need to be started, see Figure 3.3.

� Click on Start in the Hydrodynamics (including morphology) window and select the
<f34.mdf> Delft3D-FLOW input file.

The simulation is started, it will wait on the connection of the RemoteOLV module (see Fig-
ure 3.7) which takes over the simulation control.

Figure 3.7: The simulation output window, Delft3D - [f34] - running computational pro-
gram.

� Click on RemoteOLV in the Hydrodynamics (including morphology) window.

After the RemoteOLV is loaded, the main screen is opened, Figure 3.8.

In the lower-left corner of the status bar RemoteOLV gives additional operational information,
see Figure 3.9, such as:

� x and y co-ordinates of the current cursor position.
� Co-ordinate system: Cartesian or Spherical.

To visualise the results connect the RemoteOLV to the simulation

� Click on File→ Connect. . . and select the <f34.url> file.

After the connection between the RemoteOLV and the simulation is made the geometry is
visualised in the main window of the RemoteOLV module.

For now on this is sufficient and we will leave the RemoteOLV module and close the simulation.
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Figure 3.8: Main window of the RemoteOLV module

Figure 3.9: Operational information displayed in the statusbar

3.3.1 Exiting the RemoteOLV module

To exit RemoteOLV:

� From the File menu, select Exit.

Because the simulation is halted, the window Continue or Terminate Simulation appears,
see Figure 3.10

Figure 3.10: Window Continue or Terminate Simulation to continue or terminate simu-
lation

� Click on Terminate Simulation to terminate the simulationa and close the RemoteOLV
module.

You still have to close the simulation output window Delft3D - [f34] - running computational
program, see Figure 3.7. From this window

� Select File→ Exit to close the simulation output window.
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You will be back in the Hydrodynamics (including morphology) window of the Delft3D-
MENU program, Figure 3.3.

Ignore all other options and just:

� Click Return to return to the main window of Delft3D-MENU, Figure 3.2.
� Click Exit.

The window is closed and the control is returned to the desktop or the command line.

We encourage new users next to run the tutorial described in chapter 6.
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4 General operation

4.1 General program operation instruction

Help

Upon selecting Help → User Manual, the RemoteOLV User Manual in PDF-format will be
opened. Use the bookmarks in the contents to locate the subject you are interested in.

File menu

The file-menu is the standard Open and Save As window. The file mask depends on the type
of data that you want to open or save. You can change the directory by navigating through the
folders.

It is possible to specify whether to Stay on the Start-up Directory or not, in the Settings
General form.

General cursor and keyboard functions

The left mouse button activates or confirms desired actions. The Esc key cancels the last edit
action. The right mouse button may also confirm actions, or may put the program back into its
original mode.

4.1.1 Toolbars

The main window contains a men bar and two icon bars. The two icon bars are separated in
a main toolbar belonging to the overall handling and a toolbar belonging to specific handling
of the program QUICKIN.

4.1.1.1 Main toolbar

The main toolbar is shown in Figure 4.1.

Figure 4.1: Main toolbar

Print screen

Press Ctrl-P or click on the toolbar to obtain the print window for a hardcopy of the
current screen. This file is called <remoteolv_date_time.pdf>

Zoom to extent

Click the icon to zoom to the full extent of the project area.

Zoom in

Click on the toolbar to zoom in.
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Zoom out

Click on the toolbar to zoom out.

Zoom box

To define a zoom box, click on the toolbar and drag a box. If you define a zoom box from
right to left and from bottom to top then it will zoom out instead of zoom in.

Menu item to toolbar

When using the icon , the next chosen menu item will be placed in a separate toolbar.

As example, click the icon , and select from the menu File→Import→Grid (RGFGRID). . .
. An extra toolbar will appear with the chosen menu option, see Figure 4.2.

Figure 4.2: Menu item import Grid (RGFGRID) placed into extra toolbar

4.1.1.2 RemoteOLV toolbar

The program specific toolbar, see Figure 4.3, consists of icons which can also be reached via
menu options.

Figure 4.3: RemoteOLV specific toolbar

Recompute the stereographic projection.

See ?? key-stroke A.

Select a domain.
Show or hide the legend.

Do a single step of the simulation.

Do a pre-defined number of steps of the simulation.

Continue the simulation until end or pressing the halt-icon.

Halt the simulation.

4.2 Cursor and key stroke functions
Mouse wheel Use the mouse wheel to zoom in and zoom out. The mouse pointer

is a fix point.
CTRL+ + Zoom in

Keep the CTRL-key pressed and use the + key to zoom in more.
CTRL+ - Zoom out

Keep the CTRL-key pressed and use the - key to zoom out more.
CTRL+move cursor move focus of screen

Keep the CTRL-key pressed and move the cursor around. The cur-
rent screen will move accordingly.
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CTRL+arrow keys move focus of screen left, right, up or down.
Keep the Ctrl-key pressed and use the arrow keys to move the
focus of the screen accordingly.

CTRL+O Start the open dialog window to connect to a simulation, same as
selecting File→ Connect from the menubar.

CTRL+D Exit the RemoteOLV module, same as selecting File→ Disconnect
from the menubar

CTRL+E Exit the RemoteOLV module, same as selecting File→ Exit from the
menubar

CTRL+N Perform single simulation step, same as selecting Simulation Control
→ Next Step from the menubar

CTRL+S Perform several simulation steps, same as selecting Simulation Con-
trol→ Several Steps. . . from the menubar

CTRL+G Continue the simulation (Go), same as selecting Simulation Control
→ Continue from the menubar

CTRL+H Halt the simulation, same as selecting Simulation Control → Halt
Simulation from the menubar

CTRL+T Terminate simulation, same as selecting Simulation Control→ Ter-
minate from the menubar
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5 Menu options

The upper left corner of the main window looks as in Figure 5.1 and consist of three parts, the
window title, menubar and toolbar.

Figure 5.1: RemoteOLV window title, menu and toolbar

The window title is composed out of three parts, see Figure 5.1:

1 The program name, i.e. RemoteOLV.
2 The server name, e.g. Delft3D-FLOW.
3 The active domain, e.g. f34.

The menu bar contains the following items, each item is discussed in section 5.1,

� File
� Simulation control
� Operations
� View
� Settings
� Help

The icons on the toolbar are all related to menu options and are explained there.

5.1 File menu

On the File menu, see Figure 5.2, options are available to connect, disconnect, open a colour
map, open and save settings. The option to quit RemoteOLV is located here also.

Figure 5.2: Options on the File menu

5.1.1 Connect

Upon selecting File→ Connect. . . , the window Get the URL-file appears in which you can
browse to the required URL-file. This URL-file contains all necessary information to make the
connection between the simulation and the RemoteOLV module. The simulation writes this
URL-file, so the simulation need to be started first with the option that online visualisation is
allowed. For a description how to start the Delft3D-FLOW simulation see the corresponding
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user manual, Delft3D-FLOW (2013). For a short description how to start the tutorial model
see section 6.2.

5.1.2 Disconnect

Upon selecting File → Disconnect the simulation and the RemoteOLV module are discon-
nected from each other.

If the simulation is not running you have to choose to continue or to terminate the simulation,
see Figure 5.3.

Figure 5.3: Window Continue or Terminate to continue or terminate the simulation

5.1.3 Open Colour map

You can choose from a number of pre-defined colour schemes (default masks <∗.clr> or
<∗.clrmap>). These colour schemes have the same format as used for Delft3D-QUICKPLOT,
see Appendix A.1 for the file format.

Restriction:
� Only the colour space RGB is supported.

Remark:
� If the file<remoteolv.clrmap> exists on the start-up directory then this file will be read, if

the file does not exist on the start-up directory it will try to read the file on the installation
directory <$D3D_HOME/$ARCH/plugins/default>.

5.1.4 Open Settings

If you have saved your RemoteOLV settings in a previous session, you can open these settings
again, see Appendix A.2 for the file format.

Remark:
� If the file <remoteolv.ini> exists on the start-up directory then this file will be read, if

the file does not exist on the start-up directory it will try to read the file on the installation
directory <$D3D_HOME/$ARCH/plugins/default>.

5.1.5 Save Settings

If you have made changes in one of the forms on the Settings menu, you can save these
settings to be used later on again.
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5.1.6 Exit

Exit from the RemoteOLV program.

If the simulation is not running a window will appear to select to continue or terminate the
simulation, see Figure 5.3.

5.2 Simulation Control menu

Several options to control the simulation are available on the Simulation Control menu, see
Figure 5.4.

Figure 5.4: Options on the Simulation Control menu

5.2.1 Next step

Select Simulation Control → Next Step. . . and a single time step of the simulation will be

performed. It is also possible to press the icon on the toolbar.

5.2.2 Several steps

Select Simulation Control→ Several Step. . . . The window Several steps will appear, in this
window you can specify the number of time steps the simulation will run after it will halt and the
drawing interval in time steps, see Figure 5.5. After pressing OK the simulation will continue

Figure 5.5: Window Several step.

for the specified number of time steps and with the given drawing interval. Pressing Cancel
will close the window.

Time steps to run Default 10
Drawing Interval Default 1

When pressing the icon on the toolbar the simulation continues for the prescribed number
of time steps and with the same drawing interval.
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5.2.3 Continue with simulation

To continue the simulation select Simulation Control→ Continue from the menubar or press

icon on the toolbar.

The simulation will continue until you press the icon on the toolbar or select Simulation
Control→ Halt to halt the simulation.

5.2.4 Halt simulation

To stop a running simulation select Simulation Control→ Halt or press the icon on the
toolbar. Now the runtime control of the simulation is managed by the RemoteOLV module.

5.2.5 Terminate simulation

To stop the simulation select Simulation Control → Terminate. The simulation will be ter-
minated on the server while the RemoteOLV program still runs and is ready to connect to
another simulation.

5.3 Operations menu

Several options are available on the Operations menu, see Figure 5.6.

Figure 5.6: Options on the Operations menu

5.3.1 Change centre of projection

For spherical co-ordinates RemoteOLV can use two different projections, no projection and
stereographic projection. For stereographic projection a special function is implemented to
centre the computer screen to the centre of projection and the sphere. This function can be
invoked by clicking the menu item Operations→ Change Centre of Projection see Figure 5.6.
When using this command the centre of the projection is set to the centre of the screen. This
action requires recalculation of the projection and a new screen refresh. The centre of the
projection does not change when using zoom in, zoom out or pan, so there is no performance
drawback and a smooth screen-refresh is obtained.

5.3.2 Select drawing objects

When selecting Operations→ Select Drawing Objects. . . the window Select Drawing Item(s)
appears, see Figure 5.7. In this window you can select which objects need to be drawn by
checking one or more checkboxes in the checklist.
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Figure 5.7: Window Select draw item(s)

5.3.3 Select parameter

When selecting Operations → Select Parameters. . . the window Select Parameters ap-
pears. In this window you can select one parameter which will be drawn.

Figure 5.8: Window Select parameter

5.3.4 Select layer

This selection is only enabled for a 3D-simulation. When selecting Operations → Select
layer. . . the window Select a layer appears, see Figure 5.9. In that window you can enter the
layer number.

Remarks:
� In the hydrodynamic σ-model the layers are counted from surface to bedlevel.
� In the hydrodynamic Z-model the layers are counted from bedlevel to surface.

5.3.5 Select domain for Cross section

If your project consists of multiple grids (a so-called domain decomposition application) you

can switch between the grids by clicking Edit→ Select Domain (see Figure 5.10), or click
on the toolbar and next click on the grid you want to become the active grid.

Restriction:
� Just two cross-section can be opened.
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Figure 5.9: Window Select a layer

Figure 5.10: Window Select Domain

5.3.6 Create Map Window

After selecting Operations→Create Map Window an extra map window appears (Figure 5.11).
The window title contains the parameter which will be visualised in this window

Figure 5.11: Extra map window, no parameter selected yet

Restriction:
� Just three map windows can be opened.
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Figure 5.12: Options on the Select menu

Menu bar

In each map window you can select the visualised parameter, see Figure 5.12

Select Parameter
After selecting menu item Select→ Select Parameter the window of Figure 5.8 will appear
and you are able to select a parameter.

Close
After selecting menu item Select→ Close the map window will close.

5.3.7 Create Cross Section Window

Before you select a cross-section to visualise, you need to indicate the domain of interest (see
section 5.3.5).

After selecting a domain and after selecting Operations→ Create Cross Section Window. . .
from the menubar a window appears (Figure 5.13). In this window you can specify along
which M or N line the cross-section you want to observe lay. One of the edit input fields
should be zero.

Figure 5.13: Specify the M - or N -co-ordinate line

After pressing OK the cross-sectional window appears (Figure 5.14) and the cross-section is
indicated in the main window (default, green line).

The title bar is composed out of the domain name, between square brackets and the cross
section index co-ordinate (M or N ), see Figure 5.15
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Figure 5.14: Window Cross Section - [f34] M = 10 displaying a cross section

Figure 5.15: Title bar of the Cross Section window.

Menu bar

In each Cross Section window you can select the visualised parameter or change the cross
section index, see Figure 5.16

Select Parameter
After selecting menu item Select→ Select parameter the window of Figure 5.8 will appear
and you are able to select a parameter.

Select Cross Section line
After selecting menu item Select→ Select Cross Section line the window of Figure 5.13 will
appear and you are able to change the cross section index.

5.4 View menu

On the View menu, you may choose how to display the data sets, see Figure 5.17

5.4.1 Spherical Co-ordinates

Here you can select how to project the spherical co-ordinates onto the screen, see Fig-
ure 5.18.

Remarks:
� Only applicable for a spherical co-ordinate system.
� Default: A spherical grid is shown in stereographic projected co-ordinates.

Plane co-ordinates
Upon selecting View→ Spherical Co-ordinates→ Plane Co-ordinates, you choose to display
the co-ordinates as they are.

Stereographic projected co-ordinates
Upon selecting View → Spherical Co-ordinates → Stereo Projected Co-ordinates, the co-
ordinates are displayed using a stereographic projection onto the screen.
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Figure 5.16: Options on the Select menu

Figure 5.17: Options on the View menu

5.4.2 Legend

Show or hide the colour legend.

5.4.3 Continuous shades

Show the selected parameter with continuous shades.

5.4.4 Patches

Show the selected parameter with patches, centred at cell centre.

5.4.5 Coloured dots

Show the selected parameter with coloured dots.

5.5 Settings menu

The following options can be accessed through the Settings menu, see Figure 5.19.

5.5.1 Change colour map

When clicking on the Settings→ Change Colour Map. . . menu, a form opens in which you
can join a parameter (i.e. Water Level) with a colour map, see Figure 5.20.
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Figure 5.18: Options on the View→ Spherical Co-ordinates sub-menu

Figure 5.19: Options on Settings menu

5.5.2 Legend

When clicking on the Settings→ Legend menu, a form opens in which you can define how
the iso-colour figures should be displayed; see Figure 5.21

� Autoscale Legend default: On
Specify whether the program should determine the isocolour values automatically, or to
do it yourself. If you leave it to the program, it will determine the minimum and maximum
depth value within the viewing area and display the number of iso-colours specified above.
Zooming in will always result in display of the same number of iso-colours. If you want to
specify the isocolour values yourself, you have to specify one of the three parameters
below. When zooming in, the iso-colour values will remain fixed.

� Classes default: 20
The number of classes can be specified.

� X Co-ordinate Legend default: 16
X Co-ordinate of lower left corner of legend in pixels.

� Y Co-ordinate Legend default: 20
Y Co-ordinate of lower left corner of legend in pixels.

5.5.3 Colours

When clicking on the Settings→ Colours menu, a form opens in which you can define the
colours for background, land boundary, polygons, etc.; see Figure 5.22.

5.5.4 Sizes

When clicking on the Settings → Sizes menu, a form opens in which you can define the
linewidth in pixels. See Figure 5.23.

5.6 Help menu

On the Help menu, you may choose to read the user manual or the version number of Remo-
teOLV; see Figure 5.24.
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Figure 5.20: Window Colour Map for Paramter

Figure 5.21: Edit fields in the Legend window

5.6.1 User manual

When clicking on Help→ User Manual the user manual of RemoteOLV will be displayed (file
<RemoteOLV _User_manual.pdf>).

5.6.2 About

When clicking on the Help → About a window will display the current version number of
RemoteOLV.
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Figure 5.22: Options on Settings→ Colours menu

Figure 5.23: Options on Settings→ Sizes menu

Figure 5.24: Options on Help menu
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6 Tutorial

6.1 Introduction

In this tutorial some functionality of RemoteOLV will be demonstrated. On the basis of the
"Friesian Tidal Inlet" example a RemoteOLV session is explained. In advance, the final situa-
tion is shown in Figure 6.1.

Figure 6.1: Final situation of the clarified RemoteOLV session

This tutorial describes in detail how to proceed from the starting situation towards the final
situation.

Before you can start with the tutorial you have to install Delft3D. Then start Delft3D, and go
to the working directory <%D3D_HOME%/tutorial/remoteolv/flow> using the Select working
directory button.

6.2 Start simulation

Start Delft3D, and go to the working directory <%D3D_HOME%/tutorial/remoteolv/flow>.
Then select Flow and next Start. The simulation will start and run until the start of the first
time step and wait until the RemoteOLV module connects to the simulation and takes over the
control.

Remarks:
� When using the Start button in Delft3D-MENU the simulation will wait at the first time

step on the RemoteOLV module.
� When started in batch-mode the simulation will start until you connect to the simulation

or to the end of the simulation time.

For completeness we give the commandline options to allow access of the RemoteOLV mod-
ule to the simulation, this is needed when you want to write your own scripts (Delft3D-FLOW,
2013). The commandline to start deltares_hydro.exe read:

deltares_hydro.exe
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This execuatble needs a<config_flow2d3d.ini> file which needs the following parameters for
RemoteOLV (default settings on MSWindows):

[RemoteOLV]
JREpath = C:/Delft3D/w32/plugins/jre
JARpath = C:/Delft3D/w32/plugins/dol
Wait = yes

6.3 Start RemoteOLV

After starting the simulation, select the RemoteOLV button on the Hydrodynamics (including
morphology) window of Delft3D. The empty main window of the RemoteOLV module appears
and we need to connect to the tutorial simulation.

� On the File menu, select Connect.
� Select the file <f34.url> and press Open.

Also we want to visualise the parameter “Water level”, so

� Select Operations→ Select Parameter. . . from the menubar and select “Water level” from
the combo box, see Figure 6.2.

Figure 6.2: Window Select Parameter

� Select Settings→ Change colour map. . . from the menubar and select Parameter “Water
level” from the first combo box and Colour Map “bathymetry (inverse)” from the second
combo box.

The layout of the Friesian tidal inlet model will be shown, see Figure 6.3, i.e. closed bound-
aries, open boundary, thin dams and the just selected parameter.

6.4 Zoom out and zoom in

Zooming out the model in discrete steps

� Click on .

To zoom out to the full extent of the model

� Click on .

To zoom in on the grid there are several possibilities

� Use the mouse scroll wheel. The cursor is the fixed point when scrolling the mouse wheel.

� Click on and drag a rectangle. Do it several times after each other and terminate the
zoom in action by pressing the right mouse button.

� Click on .

28 of 38 Deltares



DRAF
T

Tutorial

Figure 6.3: Initial water level and layout

To pan the grid: keep the CTRL-key down and move around with the cursor.

6.5 Selecting a map view

The RemoteOLV module can show several map windows (upto 5). With these extra map
windows you can follow the behaviour of other parameters then in the main window. In this
tutorial we will visualise the “Velocity magnitude”.

� Select Operations → Create Map Window from the menu bar and a new map window
appear.

The map window does have the same layout as the main window, including the selected
parameter from the main window, i.e. “Water level”. We want to visualise the “Velocity magni-
tude”, so

� Select Operations→ Select Parameter from the menu bar and select “Velocity magnitude”
from the combo box and the same window appears as before, see Figure 6.4.

� Select Settings → Change Colour map. . . from the menu bar in the RemoteOLV -
Delft3D-FLOW - [f34] window. Select Parameter “Velocity magnitude” from the first
combo box and Colour Map “bathymetry (inverse)” from the second combo box.

Because it is the initial situation the “velocity magnitude” is zero.
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Figure 6.4: Initial Velocity magnitude

Figure 6.5: Specify the M - or N -co-ordinate line

6.6 Selecting a cross-sectional view

The RemoteOLV module can show several cross-sectional views (upto 2). With these extra
cross-sectional windows you can follow the behaviour of other parameters than in the main
window. In this tutorial we will visualise the “Velocity y component”.

� Select Operations→ Select Cross Section Window from the menubar
� Enter the values “10” in the edit field after M= and “0” after N=, see Figure 6.5.

The cross-section window appears and also a line is drawn in the main window. This line
indicates the location of the cross-section in the model area.

We want to visualise the “Velocity y component”, so

� Select Select from the menubar and select “Velocity y component” from the combo box
and the same window appears as before, see Figure 6.6.

Because it is the initial situation the “velocity y component” is zero.
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Figure 6.6: Initial Velocity y component

6.7 Time marching

After you have opened several windows with different parameters, or several windows with
the same parameter but zoomed in on another part of the model area. We will march through
the simulation. There are several ways to march through the simulation.

Using the icon we are able to march through the simulation, after each press on the icon
the simulation will proceed one time step and wait for an action of you.

� Press 5 times on the icon

On the status bar you see at which timestep the simulation holds.

Using the icon we are able to do a user-defined number of time steps and a user-
defined number of intervals to update the visualisation windows. Select Operations→ Sev-
eral steps. . . to specify the number of time steps to run and hold, and to specify the drawing
interval.

� Select operations→ Several steps. . .
� Specify “20” for the Time Steps to run
� Specify “4” for the Drawing interval
� Press OK, the simulation will run for 20 time steps and hold

For each drawing interval the three windows will be updated.

� Press 5 times on the icon

You see that after each hit the simulation will run for 20 time steps and that the drawing
interval is 4 time steps. After you have done this action, you should have a picture similar as
Figure 6.7.
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Figure 6.7: Final situation of the clarified RemoteOLV session

At this point you have the option

1 to inspect your simulation further,
2 to continue the simulation (Simulation Control→ Disconnect) and connect to the simula-

tion later on (File→ Connect. . . ), or
3 to terminate the simulation (Simulation Control→ Terminate).

6.8 Close the RemoteOLV module

After you have inspected the on-line results of the simulation you may leave the RemoteOLV
module. There are two options two leave the RemoteOLV module:

1 Disconnect from the current simulation, so you are able to connect to another (or the
same) simulation.

2 Exit the RemoteOLV module, you have to restart the RemoteOLV module to visualise the
on-line results again.
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A Files of RemoteOLV

In the following sections we describe the attribute files used in RemoteOLV.

For each file which can be handled by RemoteOLV we give the following information:

� File contents.
� Filetype (free formatted, fix formatted or unformatted).
� Filename and extension.
� Generated by (i.e. how to generate the file).
� Restrictions on the file contents.
� Example(s).

Remarks:
� The access mode of all attribute files is sequential.
� In the examples the file content is printed in font Courier and comment (not included in

the file) between curly brackets font, unless explicitly stated differently.

A.1 Colour scheme file
File contents The colour scheme
Filetype ASCII
File format Free formatted
Filename <name.clr> or <name.clrmap>
Generated manually

Record description:

Record Record description

1 COLORMAP

2 NAME=name

3 SPACE=RGB, RGB is the only allowed space for this program

4 – N one real and three integers.

The first column represent the relative distribution of the defined colours in column 2–4 (rep-
resenting the RGB values).

Example:

COLORMAP
NAME=copper
SPACE=RGB
0.0000 0 0 0
0.8000 255 159 101
1.0000 255 199 127
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A.2 Settings file
File contents Settings of the program
Filetype ASCII
File format Fix formatted
Filename <name.ini>
Generated By the program

Record description:

Record Record description

FileInformation

FileCreatedBy RemoteOLV version number

FileCreationDate creation date and time

FileVersion version number of <∗.ini> file

OLVParameter

name integer value

Colours

name RGB value (3 integers)
line width

dots sizes

Example:

[FileInformation]
FileGeneratedBy = Deltares, RemoteOLV Version 4.01.01.13880, Dec 2 2010, 20:45:14
FileCreationDate = 2010-12-02, 20:46:22
FileVersion = 0.02

[OLVParameter]
AutoscaleLegend = 1
XCoorLegend = 16
YCoorLegend = 20
StayOnStartupDirectory = 0

[Colours]
ColourBackground = 255 255 222
ColourGrid = 005 005 005
LegendColourBackground = 255 255 255
lineColourPolygon = 170 000 127
fillColourPolygon = 170 000 127
lineColourCrossSection = 005 005 005
DryPoints = 203 203 000
ThinDams = 203 203 000

[Width]
lineWidthPolygon = 1
lineWidthActiveGrid = 1
lineWidthActiveDDBnd = 3
lineWidthActiveCmpBnd = 1
lineWidthCrossSection = 1
lineWidthThinDams = 3
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