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Introduction

This document explains the installation of the POOSL IDE. This is a plug-in for Eclipse that relies on
the POOSL simulator (Rotalumis) of Eindhoven University of Technology
(http://www.es.ele.tue.nl/poosl).

Further information about the use of the POOSL IDE can be accessed through the built-in help.



1 Installation

1.1 Minimal system requirements
The POOSL IDE requires one of the following operating systems:

e Windows 7, 32 bit or 64 bit (Windows XP is not supported)
e Ubuntu 12.04, 32 bit or 64 bit
e Mac OS X 10.10 (Yosemite)

In addition it requires the following installed software:

 Java Runtime Environment (JRE) 1.7.0_55 or newer" (Java 1.8 is supported)
e Eclipse Mars (version 4.5) for “Java and DSL Developers” or for “Java Developers”

For the JRE and Eclipse, make sure that both are 32-bit versions, or both are 64-bit versions.

1.2 Installing Eclipse
If a correct version of Eclipse is already installed, skip this section. Otherwise, follow these steps to
install Eclipse:

1. Download and Install Java Runtime Environment (JRE), see
http://www.oracle.com/technetwork/java/javase/downloads

2. Download the Eclipse IDE for Java and DSL Developers (Eclipse Mars version 4.5.0).
http://www.eclipse.org/downloads/packages/eclipse-ide-java-and-dsl-developers/marsr

3. Unzip the Eclipse file at a location where you have permission to write files and directories.
Locate the “Eclipse.exe” file in directory “Eclipse”. Create a shortcut on the desktop or task
bar (In Windows, right click on the file -> Send to -> Desktop). When multiple JREs are
installed on your machine, specify the JRE to be used as follows: right-click on Eclipse
shortcut, select Properties, tab Shortcut; edit the “Target” field to specify the location of the
Java Virtual Machine. For instance:

C:\Eclipse\Mars\Eclipse.exe -vm "C:\Program Files\Java\jre8\bin\javaw.exe"

Note the use of “javaw” to avoid opening a additional window.

When opening Eclipse select a location for the workspace and click OK.

! To determine which version of Java is installed, type the following at the command prompt: java -version
4



ﬁ [¥] Contact all update sites during install to find required software

1.3 Installing the POOSL IDE plug- in
To install the POOSL IDE plug-in in Eclipse follow these steps:

1. In Eclipse go to Help -> Install new software

In “Work with: “, click the Add... button. The Add Repository dialog box appears:
3. Copy one of the following links to the location box:

e http://poosl.esi.nl/downloads/ide/updates/release/ for the release version

e http://poosl.esi.nl/downloads/ide/updates/Iatest/ for the latest version
4. Enter a name for the repository and click OK.
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5. Select the POOSL IDE and Rotalumis plug-in from the update site and check the “Contact all
update sites during installation to find required software” checkbox.
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6. Click “Next” twice and accept the license agreement, click “Finish” to start the installation.
Because the software is not signed by Eclipse it will give a security warning. Click OK on the
security warning to continue installation.
¢ Installing the POOSL IDE plugin will automatically install the simulator (Rotalumis).

7. When asked, restart Eclipse.

If an error is reported during installation, please consult section 4.3, 4.4 and 4.5.

1.4 Updating the POOSL IDE
To update the POOSL IDE follow these steps:

1. In Eclipse select Help -> Check for Updates. If a newer version of the POOSL IDE or the
simulator (Rotalumis) are available, they will appear in the list of software to update.
2. Click Next to install the new updates.

1.5 Installation problems
In case errors occur after installing the POOSL IDE when opening files or running or debugging
models, make sure that the correct versions of the following software are installed:

¢ Java Runtime Environment (JRE) 1.7.0_55 or newer (see section 1.1)
e Eclipse Mars (4.5.0) or newer (see section 1.1)
O Check at Help -> About Eclipse



2 Testyour installation using the examples

This section describes a procedure to check whether the installation was successful, and whether the
POOSL IDE has enough permissions on your computer. To use the POOSL IDE to its full potential, it
needs enough permissions to write files and to create socket connections on your machine.

2.1 Download the example POOSL project

The example POOSL project can be downloaded from
http://poosl.esi.nl/downloads/examples/examples.zip. Save the file in a temporary location; do not
unzip the files or extract files from the zip file.

2.2 Import the example POOSL project
To create a POOSL project with the examples, follow these steps:
1. Click on File -> Import... -> General -> Existing Projects into Workspace.

e
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2. Click on Select archive file, and press Browse... to open the examples.zip file.




& Import | =] % |
Import Projects =
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3. Click Finish to import the project.

2.3 Testyour installation using an example
1. Click on Window -> Perspective -> Open Perspective -> Other... -> POOSL Edit, which changes
the screen layout in order to support the editing POOSL models.
2. Double-click on the file producer_consumer.poosl. Check that the contents of the file is
shown in a syntax-highlighted way.
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3. Right-click on the file producer_consumer.poosl and select Debug as -> POOSL simulation. The
screen layout is changed in order to support the debugging of POOSL models.
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When it is the first time starting a simulation, a “Windows Security Alert” window will pop-up
with the question if it should block rotalumis.exe. To continue and run the simulation, click
“Allow access”.
If no element is selected in the Debug view (top-left corner), then select any element.

5. Inthe top-left corner, click on the green Resume button (indicated by the green arrow in the
picture below). Check that the Sequence Diagram in the bottom-right corner fills up with

messages.
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In the top-left corner, click on the red Terminate button (indicated by the red arrow in the
picture above).

In the top-right corner, click on POOSL Edit or the logo to change back to the screen layout
for editing. The edit perspective logo looks like: ~ ED

[E=REER —
Quick Access 11 [ Y [B0] 3
- 124 l [( Resource |20 POOSL Edit | %5 POOSL Debug
= 0

3 User manual

The user manual for the POOSL IDE can be found inside the Eclipse environment. It can be opened in
several ways:

1. Click on the Help menu, and select “Help Contents”.

This will open the Eclipse built-in help in a separate window. The POOSL documentation is
located under Contents in the Poosl booklet.

= [ﬂ] Poosl
¥ Editing
A Running and debugging
L] Impaorting and exporting
Bl Preferences

B FaQ

The recommended starting point for new users is Editing -> Create Projects and Models.

Click on the Help menu, and select “Dynamic help” (Or use keyboard shortcut <F1>).

This will open a window inside Eclipse. It shows brief information about the selected view, in
combination with references to the help Contents.

D Help 52 S

Contents T; Search =3 Related Topics []]1 Bockmarks & Index

About Poosl Editor

The POOSL editor provides you with POOSL specific text editing support.

This includes syntax highlighting, hovers, navigation, validation and
content assist (< CTRL>+<SPACE=).

See also

Bl Creating models
B Editing models
Maore results:

'3'.?- Search for About Poosl Editor

10



To switch between the main documentation (“Contents”) and the dynamic help (“Related
Topics”), use the tabs on top of the help page.
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4 FAQ

4.1 <CTRL>-<SPACE> does not work.

This is a general Eclipse problem. Some suggestions for solutions can be found online, such as:

1. Create a new workspace, and import your existing projects. Remember to check “Copy projects
into workspace” to copy all your existing work to new workspace.

2. Make sure that the <CTRL>+<SPACE> combination is not hijacked by any other application (such as
text input features).

3. Make sure “regional and language options” is in English language. For example, Windows, Control
panel —> Region and language options. Then

¢ Administrative (tab) —> Language for non-Unicode program. Make sure English (United
States) is selected, others may not work.

¢ Keyboards and Languages (tab) —> Change Keyboards. You'll see a list of languages
installed; remove any that you don’t want (click the language and then click the Remove
button) until you only have the ones you want left.

4. Change the key combination in Eclipse, via Window -> Preferences -> General -> Keys. The default
binding for command “Content Assist” is “Ctrl + Space”, but this can be changed into something else.

4.2 Internal null pointer exception when trying to run/debug a model.
The following error may occur when you try to run or debug a model:

An internal error occurred during: "Launching ...poosl". java.lang.NullPointerException

It usually indicates that your version of the Java Runtime Environment (JRE) is too old. Please check
the minimal system requirements in section 1.1.

4.3 Cannot complete the install because of a conflicting dependency.
The following error may occur during the installation of the POOSL IDE:

Cannot complete the install because of a conflicting dependency

If the remaining message refers to different version of the Eclipse Workbench, then it usually
indicates that your version of Eclipse is too old. Please check the minimal system requirements in
section 1.1.

4.4 An error occurred while collecting items to be installed
The following error may occur during the installation of the POOSL IDE:

An error occurred while collecting items to be installed

session context was:(profile=epp.package.java,
phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

Followed by the repositories it cannot find:
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No repository found containing: osgi.bundle,nl.esi.poosl.generatedxmiclasses,3.2.0.201501141011
No repository found containing: ... ... ...
This is a known problem in Eclipse and it can be solved by reloading the software site.

1. Go to Help-> Install New Software, then select “"Available Software Sites”.

= Install

Available Software

Select a site or enter the location of a site.,

Work with: _type or select a site - Add.. |
= Preferences B %
type filter text Available Software Sites ALY
General

b A type filter text

» Code Recommenders

@ Help Name 3 Location Add...

4 Install/lgdate 7] ¥l POOSLIDE http://poosl.esi.nl/downloads/ide/updates/release =
Automatic Updates £l \ﬂ TR Arspasy e Edit
Available Software Sites - = Edit Site 2|

i [ ‘ﬂ Remove

[+ Java m c%]

Moo 1 4 Name:  POOSLIDE

g o

= Mylyn e Location:  http://poosl.esi.nl/downloads/ide/updates/release E

{» Plug-in Development D “ e

Run/Debug o <l i Tenmcich
port..

» Team o« ,3‘) [ = ] [ = ; J

» WindowBuilder

AML
» Xtend
» Ktext
| 1l b
@[ m | »
\1?) [ OK J [ Cancel I

2. Select the POOSL IDE site, and click “edit”. Change the location by removing or adding the trailing “/",
and click "OK".

3. Select the POOSL IDE site, and click "Reload”. Reloading may take a minute.

4. Once the software site has been reloaded, click "OK" to go back to the “Install New Software” screen.
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5. The problem should now be resolved. Select the POOSL IDE site from the dropdown box to continue the
installation at point 5 of the manual (section 1.3).

e
= Install
Available Software | ‘
Select a site or enter the location of a site, \LD:_'
Work with: [ Add. |

type of select a site
--All Available Sites--
"type filter to POOSL IDE - http://poosl.esinl/downloads/ide/updates/release

ites” preferences.

Mame Version
[T (D) There is no site selected.

Select All | [ Deselect All
Details
l
[¥] Show only the latest versions of available software [#] Hidle iterns that are already installed
[¥] Group itemns by category What is already installed?

[7] Show enly software applicable to target environment
[¥] Contact all update sites during install to find required software

® < Back Mext > Fimish

4.5 Something doesn’t (seem to) work.

First of all, check whether your system meets the minimal installation requirements (see section 1.1),
and the other FAQ. Depending on the problem, the following information may support experts in
solving the problem that you experience:

* Version of the Java Runtime Environment
0 Atthe command prompt, type: java -version
e Version of Eclipse
0 Help -> About Eclipse
e Version of Xtext, Sirius and Rotalumis
0 Help -> About Eclipse -> Installation Details -> Installed Software
e Eclipse log
0 Help -> About Eclipse -> Configuration -> View Error Log
e Log of the communication between Eclipse and the simulator
0 Set the logging level in the preferences
0 The Logging.html file can be found in the root of the Eclipse installation
* Console output and/or Eclipse screenshot
e The .poosl files causing the problem

4.6 The installation could not be completed as requested
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When installing/updating to POOSL IDE 3.4.1 in Eclipse Luna, the following error will occur: “The
installation cannot be completed as requested”:

[ £ Install |. = %Jﬁ

Install Remediation Page
o)

(¥, Theinstallation cannot be completed as requested,

Chose one of the following alternate solutions:

@ Keep my installation the same and modify the items being installed to be compatible
Update my installation to be compatible with the items being installed

(1 Show eriginal error and build my own selution:

Solution Details

MName Version Id

4 % Will be upgraded/downgraded
4F Legacy Support for POOSL IDE 3.4.0.201506301149 nl.esi.pooslsdk.legacysupport.feat...
4 Rotalumnis 3.4.0.201506251535 nl.tue.rotalumis.sdk.feature.group

a Will not be installed

Lyt POOSLIDE nl.esi.poosl.sdk.feature.group

(:?,1 < Back ][ Mext = ] Finish Cancel

The original error contains:

Cannot complete the install because one or more required items could not be found.
Missing requirement: nl.esi.poosl.sirius 3.4.0.201506301149 (nl.esi.poosl.sirius 3.4.0.201506301149)
requires 'bundle org.eclipse.sirius 3.0.0' but it could not be found

Version 3.4.0 of the POOSL IDE is the last version that supports Eclipse Luna, up to Luna SR2 (4.4.2).

Updating to a higher version of POOSL IDE requires you to install Eclipse Mars, as described in section
1.2.

The following error looks similar and can occur when installing the POOSL IDE in Eclipse Mars:

Cannot complete the install because one or more required items could not be found.

Missing requirement: POOSL IDE3.4.0.201506301149 (nl.esi.poosl.sdk.feature.group
3.4.0.201506301149)

requires 'bundle org.eclipse.sirius 0.0.0' but it could not be found

When installing the POOSL IDE plug-ins the “Contact all update sites during installation to find
required software” checkbox was not selected. Restart the installation or press the back button and
continue from section 1.3 at step 5.
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