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Important User Information Solid state equipment has operational characteristics differing from those of 
electromechanical equipment.  "Safety Guidelines for the Application, Installation, and 
Maintenance of Solid State Controls" (Publication SGI-1.1) describes some important 
differences between solid state equipment and hard-wired electromechanical devices.  
Because of this difference, and because of the wide variety of uses for solid state 
equipment, all persons responsible for applying this equipment must satisfy themselves 
that each intended application of this equipment is acceptable. 

In no event will Rockwell Automation be responsible or liable for indirect or 
consequential damages resulting from the use or application of this equipment. 

The examples and diagrams in this manual are included solely for illustrative purposes.  
Because of the many variables and requirements associated with any particular 
installation, Rockwell Automation cannot assume responsibility or liability for actual use 
based on the examples and diagrams. 

No patent liability is assumed by Rockwell Automation with respect to use of the 
information, circuits, equipment, or software described in this manual. 

Reproduction of the contents of this manual, in whole or in part, without written 
permission of Rockwell Automation is prohibited. 

Throughout this manual, we use notes to make you aware of safety considerations. 

 

ATTENTION:  Identifies information about practices or 
circumstances that can lead to personal injury or death, 
property damage, or economic loss. 

 
Important:  Identifies information that is especially important for successful application 
and understanding of the product. 
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Read this preface to familiarize yourself with the rest of the manual.  The 
preface covers the following topics: 

• who should use this manual 

• the purpose of the manual 

• contents of the manual 

• conventions used in this manual 

• Allen-Bradley support 
 

Use this manual if you are responsible for installing, using, or 
troubleshooting the 6180 Industrial Computer.   

You should have a basic understanding of computers and the specific 
Microsoft Windows operating system that the 6180 Industrial Computer 
will run. 

This manual is a user guide for the 6180 Industrial Computer.  It gives an 
overview of the system and describes procedures you use to: 

• install the 6180 Computer in a rack, panel or enclosure 

• install and remove system components 

• run the system 

• troubleshoot the system 

PPPPrefacerefacerefacereface    

Who Should Use This 
Manual 

Purpose of this Manual 
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Chapter Title Contents 

 Preface Describes the purpose, background, 
and scope of this manual.  Also 
specifies the audience for whom this 
manual is intended. 

1 System Features Shows the different versions of the 
6180 Computer and system features. 

2 Installation  Describes how to install the 6180 
Computer in a panel or enclosure.  
Also tells how to connect devices 
(such as mouse or keyboard) to the 
system.   

3 Initial Operation and 
Setup 

Tells how to start and check out the 
system.   

4 Adding and 
Removing System 
Components 

Gives procedures for adding and 
removing the back panel  accessory 
drive cover, add–in boards, and 
processor board. 

5 Adding and 
Removing memory 

Gives procedures for adding and 
removing memory 

6 Adding and 
Removing 
Processors 

Gives procedures for adding and 
removing processors. 

7 Adding and 
Removing 
Removable Media 

Gives procedures for adding and 
removing removable media. 

8 Adding and 
Removing Data 
Storage Drives 

Gives procedures for adding and 
removing data storage drives. 

9 Adding and 
Removing Power 
Supplies 

Gives procedures for adding and 
removing power supplies. 

10 Adding and 
Removing Displays 
And Backlights 

Gives procedures for adding and 
removing displays and backlights. 

11 AB Video Cards Explains how to use video cards in 
the 6180 Computer. 

12 AB Keypad Interface 
Cards 

Explains how to use keypad interface 
cards in the 6180 Computer. 

13 Keypad 
Configuration Utility 
Software 

Gives procedures on how to use the 
Keypad Configuration Utility software 
in the 6180 Computer. 

14 Touchscreen Drivers 
and Utilities 

Explains how to use touchscreens in 
the 6180 Computer. 

15 System 
Troubleshooting 

Explains how to interpret and correct 
problems with the 6180 Computer. 

16 Maintenance Gives procedures for cleaning the 
6180 Computer display, and other 
components. 

Contents of this Manual 
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Chapter Title Contents 

Appendix A Specifications Provides physical, electrical, 
environmental, and functional 
specifications. 

Appendix B European Union 
Directive 
Compliance 

???? 

Appendix C Field Replacement 
Units 

???? 

Appendix D Glossary List of terms 
 

<<WRITER:  Update contents>> 
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The following conventions are used throughout this manual: 

• Bulleted lists such as this one provide information, not procedural 
steps. 

• Numbered lists provide sequential steps or hierarchical information. 
 

Allen-Bradley offers support services worldwide, with over 75 Sales and 
Support Offices, 512 authorized Distributors and 260 authorized Systems 
Integrators located throughout the United States alone, plus Allen-
Bradley representatives in every major country in the world. 

Local Product Support 

Contact your local Allen-Bradley representative for: 

• sales and order support 

• product technical training 

• warranty support 

• support service agreements 

Technical Product Assistance 

If you need to contact Allen-Bradley for technical assistance, please 
review the information in the System Troubleshooting chapter first.  
Then call your local Allen-Bradley representative or contact Allen-
Bradley technical support at (440) 646-5800. 

For additional product information and a description of the technical 
services available, visit the Rockwell Automation/Allen-Bradley Internet 
site at: http://www.ab.com. 

 

Manual Conventions 

Allen-Bradley Support 
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This chapter is an overview of the 6180 industrial computer including: 

• available versions  

• standard keypad 

• full alphanumeric keypad 

• software 

• additional catalog items 

The following table summarizes the options for each version: 

 

 
 
 

Feature 

 
NDM 

Version 
No 

Display, 
Metal 
Bezel 

 
NDP 

Version 
No 

Display, 
Plastic 
Bezel 

SD104 
Version 

10.4-inch 
(264 mm) 
Display, 
64−−−−key 

Standard 
Keypad 

SD104 Version  
10.4-inch  
(264 mm) 

Display, 96−−−−key 
Full 

Alphanumeric 
Keypad 

SD121 Version  
12.1-inch (307 
mm) Display, 

69−−−−key 
Standard 
Keypad 

SD150 Version  
15-inch  

(381 mm) 
Display, 
70−−−−key 

Standard 
Keypad 

 
SD150 Version,  

15-inch  
(381 mm) 

Display, No 
Keypad 

Pentium (Socket 
7) Processor 
Board 

√ √ √ √ √ √ √ 

(Slot 1) Pentium 
III Processor 
Board 

√ √ √ √  √ √ 

Pentium 
III/Celeron (Flip-
Chip PGA 370) 
Processor 
Board 

√ √ √ √ √ √ √ 

Hard Drive √ √ √ √ √ √ √ 

1.44 Mbyte 
Floppy Drive 

√ √ √ √ √ √ √ 

External Video 
Driver 

√ √ √ √ √ √ √ 

Integral Flat 
Panel Display 

   
√ 

 
√ 

 
√ 

 
√ 

 
√ 

Front Panel 
Access to 
Removable 
Media (Floppy, 
CD, or Tape) 

  
 

√ 

 
 

√ 

 
 

√ 

   

Chapter Chapter Chapter Chapter 1    

Chapter Objectives 

6180 Computer Versions 
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Feature 

 
NDM 

Version 
No 

Display, 
Metal 
Bezel 

 
NDP 

Version 
No 

Display, 
Plastic 
Bezel 

SD104 
Version 

10.4-inch 
(264 mm) 
Display, 
64−−−−key 

Standard 
Keypad 

SD104 Version  
10.4-inch  
(264 mm) 

Display, 96−−−−key 
Full 

Alphanumeric 
Keypad 

SD121 Version  
12.1-inch (307 
mm) Display, 

69−−−−key 
Standard 
Keypad 

SD150 Version  
15-inch  

(381 mm) 
Display, 
70−−−−key 

Standard 
Keypad 

 
SD150 Version,  

15-inch  
(381 mm) 

Display, No 
Keypad 

Front Panel 
Access to 
Mouse and 
Keyboard Ports 

  
 

√ 

 
 

√ 

 
 

√ 

   

Front Panel 
Keypad 

  √ √ √ √  
 

Integrated Front 
Panel Mouse 

   
√ 

  
√ 

  

Standard 19-
inch Rack 
Mounting 

 
√ 

 
√ 

 
√ 

 
√ 

 
√ 

 
√ 

 
√ 

Panel Mount 
with Studs or 
Clips 

  
√ 

 
√ 

 
√ 

 
√ 

 
√ 

 
√ 

Infrared (IrDA) 
Receiver/ 
Transmitter 

  
√ 

 
√ 

 
√ 

 
√ 

 
√ 

 
√ 

Touch Screen 
Option 

   
√ 

  
√ 

 
√ 

 
√ 

Field 
Replaceable 
Backlight 

   
√ 

 
√ 

 
√ 

 
√ 

 
√ 
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Common 6180 Computer Features 
Figure 1- 1 
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Figure 1- 2 

 

 

Figure 1- 3 

Need drawing for: Side Panel Connectors for Pentium II Class Computers (use illus. From Seattle II 
(see engineering) 

 

Figure 1- 4 

Need drawing for: Side Panel Connectors for Pentium III/Celeron Class Computers (use illus. From 
ITOX (see engineering) 
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NDM Version with No Display & Metal Bezel 

The following illustrations show the major features and controls of the 
non–display, metal bezel versions of the 6180 Computer  
(6180-xxAxxxxxxxx). 

Figure 1- 5 
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NDP Version with No Display & Plastic Bezel 

The following illustration shows the major features and controls of the 
non–display, plastic bezel versions of the 6180 Computer  
(6180-xxBxxxxxxxx). 

Figure 1- 6 
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The following illustration shows the major features and controls of the 
display, plastic bezel versions of 6180 Computer (6180-xxCxxxxxxxx, -
xxDxxxxxxxx). 

Figure 1- 7 

 
 

SD104 Version with 
Display and 64-Key 
Standard Keypad 
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SD104 Version with Display and Full Alphanumeric Keypad 

The following illustration shows the major features and controls of the 
full alphanumeric keypad versions of 6180 Computer  
(6180-xxGxxxxxxxx). 

Figure 1- 8 
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SD121 Version with Display and 69-Key Standard Keypad 

The following illustrations show the major features and controls of the 
12.1 in.  keypad versions of 6180 Computer (6180-xxLxxxxxxxx, 6180-
xxMxxxxxxxx). 

Figure 1- 9 
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SD150 Version with Display and 70-Key Standard Keypad 

The following illustration shows the major features and controls of the 
70-key keypad versions of 6180 Computer (6180-xxHxxxxxxxx, -
xxIxxxxxxxx).  

Figure 1- 10 
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SD150 Version with Display and no Keypad 

The following illustrations show the major features and controls of the 
15 in.  no keypad versions of 6180 Computer (6180-xxJxxxxxxxx, 6180-
xxKxxxxxxxx). 

Figure 1- 11 
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The standard SD104 keypad provides integrated keyboard and mouse 
control functionality. 

Figure 1- 12 

 

 

Numeric Keys 

The NUM LOCK key allows you to use the same set of keys on the 
numeric keypad for alternate Number and Cursor Control functions.  
Press the NUM LOCK key to select the Number function for these keys.  
The NUM LOCK LED on the keypad will be lit to indicate the Number 
function is active.  Press the NUM LOCK key again to select the Cursor 
Control function for these keys.  The NUM LOCK LED will be lit to 
reflect the function. 

For example, with the NUM LOCK key active (i.  e.  lit), the numeric 
key “4” allows you to enter the number “4”.  With the NUM LOCK key 
inactive, the numeric key “4” allows you to move the cursor to the left 
on the display. 

 
NUM LOCK “On” 
Number Function 

NUM LOCK “Off” Cursor Control Function 

1 End 

2 Down Arrow 

64−−−−Key Standard Keypad 
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NUM LOCK “On” 
Number Function 

NUM LOCK “Off” Cursor Control Function 

3 Page Down 

4 Left Arrow 

5 None 

6 Right Arrow 

7 Home 

8 Up Arrow 

9 Page Up 

0 Insert 

. Delete 

 
 

Configurable Keys 

User Configurable 
Key Legend 

Default User Defined Options 

F1 F1 

F2 F2 

F3 F3 

F4 F4 

F5 F5 

F6 F6 

F7 F7 

F8 F8 

F9 F9 

F10 F10 

F11 F11 

F12 F12 

F13 Left Windows Key 

F14 SHIFT + F1 

F15 SHIFT + F2 

F16 SHIFT + F3 

F17 SHIFT + F4 

F18 SHIFT + F5 

F19 SHIFT + F6 

F20 SHIFT + F7 

F21 SHIFT + F8 

F22 SHIFT + F9 

F23 SHIFT + F10 

 

 

 

 

 

 

 

 
 

 

Any alphanumeric 
character or string 
(restricted by KCU) 
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User Configurable 
Key Legend 

Default User Defined Options 

F24 SHIFT + F11 

F25 SHIFT + F12 

F26 Windows Application 
Key 

Any alphanumeric 
character or string 
(restricted by KCU) 
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The SD104 alphanumeric keypad provides full keyboard functionality. 

 

Figure 1- 13 

 

Alphanumeric Keys 

The “Fn” key allows you to use the same set of keys on the keypad for 
alternate functions.  The “Fn” key must be pressed and held while 
pressing another key to activate the other functions. 

For example, if you press the “D” key, the letter “D” is entered on the 
display.  If you press and hold the Fn key while pressing the “D” key, 
you activate the other function for that key, which is to print the screen. 

 
Alphanumeric 

Key 
Alternate 
Function 

Alphanumeric 
Key 

Alternate 
Function 

A ~ W { 

B ` X } 

D Print Screen Y / 

E Pause Z \ 

F Break 1 ! 

G − 2 @ 

H | 3 # 

SD104 Alphanumeric 
Keypad 
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Alphanumeric 
Key 

Alternate 
Function 

Alphanumeric 
Key 

Alternate 
Function 

M ? 4 $ 

N : 5 % 

O ; 6 ^ 

P “ 7 & 

Q ‘ 8 * 

R , 9 ( 

S < 0 ) 

T > − + 

U [ . = 

V ]   
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The SD121 keypad provides keyboard functionality.   

Figure 1- 14 

INSERT GRAPHIC HERE 
 

Numeric Keys 

The NUM LOCK key allows you to use the same set of keys on the 
numeric keypad for alternate Number and Cursor Control functions.  
Press the NUM LOCK key to select the Number function for these keys.  
The NUM LOCK LED on the keypad will be lit to indicate the Number 
function is active.  Press the NUM LOCK key again to select the Cursor 
Control function for these keys.  The NUM LOCK LED will be lit to 
reflect the function. 

For example, with the NUM LOCK key active (i.  e.  lit), the numeric 
key “4” allows you to enter the number “4”.  With the NUM LOCK key 
inactive, the numeric key “4” allows you to move the cursor to the left 
on the display. 

 
NUM LOCK “On” 
Number Function 

NUM LOCK “Off” Cursor Control Function 

1 End 

2 Down Arrow 

3 Page Down 

4 Left Arrow 

5 None 

6 Right Arrow 

7 Home 

8 Up Arrow 

9 Page Up 

0 Insert 

. Delete 

 
 

 

 

 

 

69−−−−Key Standard Keypad 
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Configurable Keys 

User Configurable 
Key Legend 

Default User Defined Options 

K1 F1 

K2 F2 

K3 F3 

K4 F4 

K5 F5 

K6 F6 

K7 F7 

K8 F8 

K9 F9 

K10 F10 

A A 

B B 

C C 

D D 

E E 

F F 

G G 

H H 

I I 

J J 

K K 

L L 

M M 

N N 

O O 

P P 

Q Q 

R R 

S S 

T T 

U U 

V V 

W W 

X X 

Y Y 

Z Z 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

Any alphanumeric 
character or string 
(restricted by KCU) 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 
 

 

 



  System Features 1–19 

 

Publication 6180-6.0 

User Configurable 
Key Legend 

Default User Defined Options 

Windows Logo  Left Windows Key 

Windows App Windows Application 
Key 

 

Any alphanumeric 
character or string 
(restricted by KCU) 
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The SD150 keypad provides keyboard functionality.   

Figure 1- 15 

 

 

 
The NUM LOCK key allows you to use the same set of keys on the 
numeric keypad for alternate Number and Cursor Control functions.  
Press the NUM LOCK key to select the Number function for these keys.  
The NUM LOCK LED on the keypad will be lit to indicate the Number 
function is active.  Press the NUM LOCK key again to select the Cursor 
Control function for these keys.  The NUM LOCK LED will be lit to 
reflect the function. 

For example, with the NUM LOCK key active (i.  e.  lit), the numeric 
key “4” allows you to enter the number “4”.  With the NUM LOCK key 
inactive, the numeric key “4” allows you to move the cursor to the left 
on the display. 

 
NUM LOCK “On” 
Number Function 

NUM LOCK “Off” Cursor Control Function 

1 End 

2 Down Arrow 

70−−−−Key Standard Keypad 
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NUM LOCK “On” 
Number Function 

NUM LOCK “Off” Cursor Control Function 

3 Page Down 

4 Left Arrow 

5 None 

6 Right Arrow 

7 Home 

8 Up Arrow 

9 Page Up 

0 Insert 

. Delete 

 

Configurable Keys 

User Configurable 
Key Legend 

Default User Defined Options 

K1 F1 

K2 F2 

K3 F3 

K4 F4 

K5 F5 

K6 F6 

K7 F7 

K8 F8 

K9 F9 

K10 F10 

A A 

B B 

C C 

D D 

E E 

F F 

G G 

H H 

I I 

J J 

K K 

L L 

M M 

N N 

 

 

 

 

 

 

 

 

Any alphanumeric 
character or string 
(restricted by KCU) 
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User Configurable 
Key Legend 

Default User Defined Options 

O O 

P P 

Q Q 

R R 

S S 

T T 

U U 

V V 

W W 

X X 

Y Y 

Z Z 

Windows Logo  Left Windows Key 

Windows App Windows Application 
Key 

 

 

 
 

 

 

Any alphanumeric 
character or string 
(restricted by KCU) 
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Using the Keyboard Configuration Utility software program, you can 
assign alpha characters or other functions to the keys in the configurable 
section of Model 6180 keypads.  For more information, refer to Chapter 
13, for the Keyboard Configuration Utility. 

The Legend Strip Kit (Catalog No.  6189-KEYKIT1) contains legend 
strips for the following computers.  . 

64-Key Standard Keypad 

Versions with an SD104 standard keypad (6180-xxC, -xxD) are shipped 
with the 26 configurable keys assigned to function keys F1 through F12, 
and shifted function keys S1 through S12.  Removable inserts provide 
standard or custom legends for these keys.   

Full Alphanumeric Keypad 

Versions with an SD104 alphanumeric keypad (6180-xxG) are shipped 
with the 36 configurable keys assigned to Function Keys K1 through 
K16 and F1 through F20.  Removable inserts provide standard or custom 
legends for the F1 through F20 keys. 

69-Key Standard Keypad 

Versions with an SD104 keypad (6180-xxL, -xxM) are shipped with the 
lower 28 configurable keys assigned to function keys F1 through F12 
and shifted function keys S1 through S12.  Removable inserts provide 
standard or custom legends for the 28 relegendable and reprogrammable 
keys.  (i.e.  A-Z keys, Windows key, and Application key).   

70-Key Keypad 

Versions with an SD121 keypad (6180-xxH, -xxI) are shipped with the 
lower 28 keys assigned to the A-Z keys, Windows key, and Application 
key. 

Removable inserts provide standard or custom legends for the 28 re-
legendable and re-programmable keys. 

The 6180 keypad can work simultaneously with an external keyboard.  
The 6180 Keyboard Interface Controller multiplexes information from 
both the 6180 keypad and the external keyboard.  Refer to Chapter 12, 
for information on the 6189-KICxxx card. 

On the SD104 and SD121 standard keypads, the integral mouse consists 
of left, right, and cursor control buttons.  Control the movement of the 
screen cursor by pressing the edge of the cursor button in the direction 

Configurable Keys 

Re-legendable Keys 

Keyboard Interface 
Controller Card 

Integral Mouse 
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you want the cursor to move.  The integral mouse can work 
simultaneously with the optional touchscreen. 

Figure 1- 16 

 

 
 

 

Indicator Color Indicates 

<<graphic needed>> Green Power On 

<<graphic needed>> Green Hard Drive Operating 

<<graphic needed>> Red Overtemperature.  Temperature inside 
the 6180 Computer enclosure is above 
1400 F (600 C) 

<<graphic needed>> Green Num Lock On 

<<graphic needed>> Green Caps Lock On 
 

Use the backlight brightness control to vary the screen lighting for 
optimal viewing. 

On SD150 versions without keypads (6180-xxJ and 6180-xxK), a 
backlight brightness adjustment knob is located on the right side of the 
chassis.   

LED Indicators 

Backlight Brightness 
Control <<graphics 
needed>> 
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Two chassis locking holes restrict unauthorized access to the 6180 
Computer internal components.  Standard padlocks may be used (user 
supplied). 

Figure 1- 17 

 
 

 

 

ATTENTION:  The chassis locking hole on the bottom 
of the chassis has been plugged with a steel cap for 
compliance with UL 1950 fire enclosure requirements.  
Removal of this plug will result in a failure to comply 
with UL 1950 safety requirements.  It is up to the user to 
determine if removal of the plug raises fire containment 
issues with individual installation(s), and to provide 
suitable preventive measures as necessary. 

 
 

 

 

 

Chassis Locks 
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This chapter describes installation of the 6180 Computer including how 
to: 

• install the 6180 Computer in a rack 

• install the 6180 Computer in a panel using mounting studs 

• install the 6180 Computer in a panel using mounting clips 

• change the voltage input setting 

The 6180 Computer meets the European Union Directive requirements 
when installed within the European Union or EEA regions and has the 
CE mark.  A copy of the Declaration of Conformity is available at the 
Rockwell Automation / Allen–Bradley Internet site: www.ab.com 

Mount the 6180 Computer in a panel or enclosure to protect the internal 
circuitry.  Versions with a gasketed bezel meet NEMA Type 1, 12, 13 
and 4/4X (indoor use) and IEC IP54, IP65 only when mounted in a panel 
or enclosure having an equivalent rating.  The No Display, Metal Bezel 
(NDM) version has a NEMA Type 1 and IEC IP2X rating. 

Allow enough room within the enclosure for adequate ventilation.  Also 
consider heat produced by other devices in the enclosure.  The ambient 
temperature around the 6180 Computer must be maintained between 5° 
and 50°C (41° to 122°F).  The 6180 Computer is intended for use in 
Pollution Degree 2 environments. 

Make sure you provide provisions for accessing the back and side panels 
of the 6180 Computer to install and remove components. 

The 6180 Computer must be mounted in a vertical position as illustrated 
in this manual.  Installing the 6180 Computer in any other orientation 
may result in overheating due to improper airflow. 

 

 

ATTENTION:  The bottom of the chassis has a knockout 
panel.  This knockout was provided for special 
applications with other Allen–Bradley products.  Do not 
remove this knockout.  If the knockout is removed, the 
6180 Computer will not meet UL 1950 standards for 
flammability containment. 

Chapter Chapter Chapter Chapter 2    

Chapter Objectives 

European Union 
Compliance 

Environmental 
Considerations 
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The 6180 Computer is shipped with the following mounting hardware 
installed on the bezel.   

 
Item Description Quantity Use For 

 

1.265−inch long 
mounting studs with 
integral spacer 

 
18 

Panel or enclosure 
mounting 

<<graphic 
needed>> 

Self-locking nuts 18 Panel, enclosure, or 
rack mounting 

 
Mounting clips can be used instead of the mounting studs and are 
ordered separately.   

 
Item Description Quantity Use For 

 

Mounting Clips 
Catalog No.  2711-
NP1 

Each 
Package 
Contains 
10 Clips 

Panel or enclosure 
mounting 

 
 

In addition to the tools required to make the cutout, you will need the 
following tools: 

• 3/8 inch socket 

• 14 inch (36 cm) extension rod (minimum) 

• Socket driver (in/lb torque wrench recommended) 

• 7/32 hex wrench 

• Ruler 

Mounting Hardware 

Tools Required 
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Allow adequate space for mounting, air flow, and maintenance.  The 
figure below shows recommended minimum clearances to other 
components within the rack or enclosure. 

 

 

ATTENTION:  The 6180 Computer should not be 
operated within a confined space of the dimensions 
shown below unless adequate ventilation or other cooling 
methods are used to lower the air temperature within the 
enclosure. 

 
 

Figure 2- 1 

 

 

ATTENTION:  Before installing the 6180 Computer in a 
panel, check the clearances of any add–in boards.  If your 
system has an Ethernet card installed, the card must be 
checked for clearance before installation.  Failure to 
follow this caution may result in damage to the 6180 
Computer and/or panel. 

 

Mounting Clearances 
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The following figures show the mounting dimensions. 

Versions with a Metal Bezel (No Display) 
Figure 2- 2 

 
 

 

 

Mounting Dimensions 
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Figure 2- 3 
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Versions with a Plastic Bezel (With or Without Display)  
Figure 2- 4 
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Versions with a Plastic Bezel (With or Without Display) 
Figure 2- 5 
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The following figure provides the dimensions for making the panel or 
enclosure cutout.  If you are using mounting clips, the mounting studs 
are removed and the 18 stud holes are not necessary. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Mounting Cutout 
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Figure 2- 6 
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To install the 6180 Computer in a panel using 18 mounting studs: 

 

 

ATTENTION: Disconnect all electrical power from the 
panel before making cutout.   

Make sure the area around the panel cutout is clear. 

Take precautions so that metal cuttings do not enter any 
components that are already installed in the panel. 

Failure to follow these warnings may result in personal 
injury or damage to the panel components. 

 
To install the 6180 Computer in a panel using mounting studs: 
1. Cut an opening in the panel using the panel cutout dimensions 

provided on page 28.  Carefully drill eighteen 1/4 inch (6.35 mm) 
holes for studs as indicated. 

2. The 18 mounting studs are factory installed.  In the event studs were 
removed for clip mounting, you can re–install studs using a 1/8 inch 
socket on the end of the stud.   Turn stud clockwise to tighten to 
approximately 10 inch pounds (1.1 N•m).   

Figure 2- 7 

 
 

 

 

ATTENTION: Be careful not to damage the sealing 
gasket when installing or removing studs.  A damaged 
seal may result in damage to the 6180 Computer and 
other panel components due to a leaking seal. 

 

Panel Mounting  
(with Studs) 

Mounting Studs
(Qty 18)

Bezel

Gasket

Spacer

Self-Locking Nuts

Panel or Enclosure
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3. Make sure the sealing gasket is properly positioned on the terminal.  
This gasket forms a compression type seal (NEMA Type 4x), do not 
use sealing compounds. 

4. Place the 6180 Computer in the panel cutout aligning the studs with 
the mounting holes.  The 6180 Computer will snap into the panel as 
the temporary retaining tabs lock against the panel (see note 
following). 

 
Note: Versions of the 6180 Computer designed for panel 

mounting have metal tabs that temporarily lock the 6180 
Computer against the panel.  These tabs only facilitate 
installation of the mounting hardware.  The tabs are not 
designed to provide permanent mounting. 

 
5. Install the 18 self–locking nuts hand tight. 

 

 

ATTENTION: Tighten mounting nuts to a torque of 10 
inch pounds (10 inch–pounds, 1.1 N•m) to provide a 
proper seal and prevent damage to the 6180 Computer.  
Allen–Bradley assumes no responsibility for water or 
chemical damage to the terminal or other equipment 
within the enclosure because of improper installation. 

 
6. Alternately tighten the self–locking nuts (use 3/8 inch socket) until 

the 6180 Computer is held firmly against the panel (see 
recommended tightening sequence below).  The studs have an 
integral spacer that prevents the gasket from being over–compressed.  
The amount of torque required increases significantly as the gasket 
reaches the proper compression.  Tighten nuts to a torque of 10 inch–
pounds (1.1 N•m). 

Figure 2- 8 
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To install the 6180 Computer in a panel using mounting clips: 

 

ATTENTION: Disconnect all electrical power from the 
panel before making cutout. 

Make sure the area around the panel cutout is clear. 

Take precautions so that metal cuttings do not enter any 
components that are already installed in the panel. 

Failure to follow these warnings may result in personal 
injury or damage to the panel components. 

 
1. Cut an opening in the panel using the panel cutout dimensions 

provided on page 2-8. 

2. If the mounting studs are present, they should be removed.  To 
remove a stud, use a 1/8 inch socket and turn counterclockwise to 
remove. 

 

 

ATTENTION: Be careful not to damage the sealing 
gasket when installing or removing studs.  A damaged 
seal may result in damage to the 6180 Computer and 
other panel components due to a leaking seal. 

 
3. Make sure the 6180 Computer sealing gasket is properly positioned 

on the terminal.  This gasket forms a compression type seal, do not 
use sealing compounds. 

4. Place the 6180 Computer in the panel cutout.   The 6180 Computer 
will snap into the panel as the temporary retaining tabs lock against 
the panel (see note below). 

 
Note: Versions of the 6180 Computer designed for panel 

mounting have metal tabs that temporarily lock the 6180 
Computer against the panel.  These tabs only facilitate 
installation of the mounting hardware.  The tabs are not 
designed to provide permanent mounting. 

 
5. Install the 10 mounting clips (Catalog No.  2711–NP1).  The 

mounting clips slide into the slots on the sides, top and bottom of the 
6180 Computer as indicated by the arrows shown on the following 
diagram (3 top, 3 bottom, 2 sides).  Gradually tighten the clips one at 
a time around the bezel (see tightening sequence next page).  Repeat 
this process at least three times until the clips are hand tight and the 
gasket is compressed uniformly against the panel. 

 

Panel Mounting (with 
Clips) 
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Figure 2- 9 

 
 

6. Tighten mounting clips to a torque of 10 inch–pounds (1.1 N•m) in 
the sequence shown above.  Do not over–tighten. 

 

 

ATTENTION: Tighten mounting clips to a torque of 10 
inch pounds (1.1 N•m) to provide a proper seal and 
prevent damage to the 6180 Computer.  Allen–Bradley 
assumes no responsibility for water or chemical damage 
to the terminal or other equipment within the enclosure 
because of improper installation. 

 
Note: The mounting clips on the hinge side interfere with the 

opening of the hinge.  Remove the clips before opening the 
hinge. 
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The 6180 Computer mounts in a standard EIA 19 inch (48.3 cm) rack.  
The 6180 Computer occupies 8U EIA units. 

Rack Mounting Guidelines 

Observe the following precautions before installing the 6180 Computer 
in a rack: 

 

 

Disconnect all electrical power from the rack before 
installing the 6180 Computer. 

If installing the 6180 Computer in an enclosed rack, make 
sure the ambient temperature stays within 5° to 50° C 
(41° to 122° F).  Be aware of other nearby devices which 
may raise the ambient temperature in the rack.  Make sure 
there is adequate room for air flow through the 6180 
Computer chassis vents. 

Verify that the addition of the 6180 Computer does not 
cause uneven loading (instability) of the rack. 

Check that the power supply limits for the rack 
components will not be exceeded by the addition of the 
6180 Computer. 

Make sure the installation of the 6180 Computer 
maintains proper earth grounding of the rack components.  
The 6180 Computer requires connection to a power 
source having an earth ground (three prong outlet). 

Failure to follow these warnings may result in personal 
injury or damage to the rack components. 

 

Rack Mounting  
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Rack Mounting Procedures 

To install the Plastic Bezel versions of the 6180 Computer in a rack: 
 

Note: The metal bezel versions of the 6180 Computer have 
mounting holes in the bezel.  User must provide rack 
mounting hardware (see example illustrated next). 

 
1. The 18 mounting studs are factory installed.  In the event studs were 

removed for clip mounting, you can re–install studs using a 1/8 inch 
socket on the end of the stud.  Turn stud clockwise to tighten to 
approximately 10 inch pounds (1.1 N•m).   

Figure 2- 10 

 
 

 
2. Place the 6180 Computer in the rack aligning the studs with the 

mounting holes. 

3. Install the 8 self–locking nuts hand tight. 

4. Alternately tighten the self–locking nuts until the 6180 Computer is 
held firmly against the rack.  Tighten nuts to a torque of 10 inch–
pounds (1.1 N•m). 

The mouse and keyboard plug directly into the side panel mouse and 
keyboard ports, or the front panel connectors as shown below.  When 
connected to the processor board ports, it does not matter if the keyboard 

Connecting a Mouse & 
Keypad (Side Panel) 
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and mouse cables are interchanged, the 6180 Computer will 
automatically detect them. 

Figure 2- 11 

 

Important: If the mouse and keyboard are connected to the side panel 
connectors, the keypad (if present) on the front of the 6180 
Computer is disabled.  The mouse and keyboard jumpers 
must be installed for operation of the keypad (see next 
page). 
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Note: The Keyboard Interface Card (KIC) has a keyboard 
connector.  If you use the processor board or front panel 
keyboard/ mouse connectors, the KIC keyboard port is 
overridden (disabled). 

 



2–18 Installation 

 

Publication 6180-6.0 

If you are using the front panel connectors, you must install jumper 
cables as shown below.  These jumpers route the keyboard and mouse 
ports from the processor board to the front panel connectors.  Make sure 
the correct ports are used. 

Figure 2- 12 

 

 

 

 

 

ATTENTION: When a keyboard or mouse is connected 
to the front panel connectors, you lose the NEMA 4x and 
NEMA 12 rating while the access door is open. 

 

Connecting a Mouse & 
Keyboard (Front Panel) 
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Note: The Keyboard Interface Card (KIC) has a keyboard 
connector.  If you use the processor board or front panel 
keyboard/ mouse connectors, the KIC keyboard port is 
overridden (disabled). 
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Add text…… Indirect Motherboard 
Connections 
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A standard IEC 320 power cord provides power to the 6180 Computer.  
The power supply input will accept 120/240V AC. 

 

 

ATTENTION: If the power supply has a manual input 
voltage selection switch, check voltage selection before 
applying power. 

 

 

ATTENTION: The power cord must be connected to an 
outlet having an earth ground (three prong outlet).  
Failure to follow this warning could result in severe 
electrical shock. 

 
Use the cord retainer to prevent accidental interruption of power to the 
6180 Computer.  Pull the cord retainer over the cord plug as shown 
below. 

The following illustration pertains to 6180 Computers equipped with a 
Pentium Class CPU. 

Figure 2- 13 

 

1 The power cord connector is recessed on 6180 Computers equipped with a 
Pentium III CPU. 

Power Connections (6180 
AC unit) 
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A standard IEC 320 power cord??? provides power to the 6180 
Computer.  The power supply input will accept ?????. 

 

The 6180 Computer 120/240VAC power supply can be configured to 
either power up using the on/off switch, or to automatically turn on when 
AC power is applied to the unit.  An internal jumper on the power supply 
wiring harness controls the configuration.  The factory default setting 
enables the on/off switch.  To change the configuration, perform the 
following steps: 

1. Remove power from the 6180 Computer.  Disconnect the power 
cord. 

2. Remove the 6180 Computer back cover.  Locate the power supply, 
and look for a single white wire not connected on the power supply 
wiring harness.  The white wire is shipped not connected from the 
factory, because this position enables the power switch to be used. 

3. If the power switch bypass mode is desired, then connect the white 
wire to its mating connector. 

4. Replace the back cover.  Reconnect power to the 6180 Computer. 

5. Press and hold the on/off switch for at least 10 seconds. 

6. Unplug the 6180 Computer and wait 5 seconds before plugging back 
in.  This clears the soft-start logic on the 6180 Computer 
motherboard. 

7. Plug in the unit again.  The on/off switch bypass mode is enabled. 

When using Microsoft Windows NT, a normal shut down and power 
cycle will restart the computer regardless if the computer needs the 
power button turned back on; steps 2 and 3 need to return to bypass 
mode.  A power outage in Windows 95/98 will still automatically reboot 
the computer. 

Power Connections (6180 
DC unit) 

Configuring the Power 
Supply Jumper 
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This chapter provides information on: 

• Operating recommendations 

• Bootup sequence 

• System reset and power on/off buttons 

• System hot keys 

We recommend these operating guidelines:  

• Avoid turning the system on and off frequently. 

• Never turn the system off when the hard drive indicator light is 
illuminated. 

• After shutting the system off, do not turn it back on again until the 
hard drive has come to a complete stop (about 30 seconds). 

• If using an external monitor,  turn on the monitor first. 

• Always use the proper power down procedures as required by your 
operating system such as the Shut Down command in the Microsoft 
Windows operating system. 

• Do not operate the 6180 Computer without the back panel installed.  
An electrical shock hazard exists.  In addition, removing the back 
panel disrupts air flow and may result in overheating.  The back panel 
also functions as an EMI shield. 

Operator access is limited to the front panel of the 6180 Computer.  This 
includes the display, front panel, keys, and front panel doors (accessory 
drive and mouse/keyboard connectors).  Access to components behind 
the rack or panel that the 6180 Computer is installed in is restricted to 
authorized and properly trained personnel. 

 

 

ATTENTION: Operator access is limited to the front 
panel controls and access doors of the 6180 Computer.   
Failure to observe this caution could result in severe 
electrical shock and/or damage to the 6180 Computer. 

 
 

 

 

Chapter Chapter Chapter Chapter 3    

Chapter Objective 

Operating Objectives 

Operator Access 
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If your computer has a front panel keypad, note the following: 

• Mouse and keyboard jumpers must be installed to activate the front 
panel, keypad, and mouse (see page 2-17). 

• The KIC card has a jumper (P1) that enables/disables the keypad.  
The default position is enabled (pins 2–3 jumpered).  For more 
information, refer to Chapter 13, Keyboard Configuration Utility. 

 

Keypad Operation 
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To boot up the system: 
1. Apply power and press the on/off button.  The 6180 Computer 

performs a Power On Self Test (POST) in which it tests the 
processor board, memory, keyboard, and certain peripheral devices.   

2. The 6180 Computer displays the progress of the POST and 
initialization of accessory devices.  This display varies depending on 
the system configuration and BIOS version, but will look similar to 
this: 

Figure 3- 1 

 

 
 

 

3. If your system does not boot up, or you notice other problems, refer 
to Chapter 15, System Troubleshooting. 

4. The 6180 Computer will then run any preloaded operating system 
software such as Windows 95/98 or Windows NT.  If no operating 
system is preloaded, the following prompt is displayed: 

Insert bootable media in the appropriate drive. 

 

The three ways to reset the 6180 Computer are to: 

• use the side mounted CPU reset button 

• press [Ctrl] [Alt] [Delete] 

System Checkout 

System Reset 
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• use power switch on front or side panel 

After resetting, the 6180 Computer will begin the Power On Self Test 
(POST).  During reset, the 6180 Computer: 

• clears RAM 

• starts the POST 

• initializes peripheral devices, such as drives and printers 

• loads the operating system (if pre–loaded) 

 

The keyboard controller supports the following hot key sequences: 

 
Use this key 
sequence: 

 
To: 

[Ctrl][Alt][Del]* Perform a software reset of the system. 

 
 
[Ctrl][Alt][+] 

Set the system to turbo mode (Default setting).  In turbo 
mode, the system bootup occurs at full speed.   

Switching to turbo mode may be prohibited by the 
operating system, or when the CPU is in protected mode 
or virtual x86 mode under DOS. 

[Ctrl][Alt][−] Set the system to deturbo mode.  In deturbo mode, the 
system operates at a slower speed (emulating a 23 MHz 
AT). 

 
 
 
[Ctrl][Alt][Defined 
in Setup] 

Enter energy saving standby mode.  Standby mode 
reduces the system’s power consumption while still 
responding to external interrupts, such as FAXs or 
network messages. 

Any keyboard or mouse activity brings the system out of 
standby mode. 

The Power Management hot key is defined in the 
Advanced screen of the Setup program. 

 
 
 
 
[Ctrl][Alt][Defined 
in Setup] 

Lock the keyboard (and clear the screen) until a User 
Password is entered.  The keyboard LEDs flash to 
indicate the keyboard is locked.  After entering the User 
Password, you do not have to press the [Enter] key. 

The security hot key is entered in the Security screen of 
the Setup program. 

The security hot key will not function unless a User 
Password is also defined in the Security screen of the 
Setup program. 

* May be inhibited (user configured) through KCU.  The default is Ctrl-Act-Del 
enabled. 

 

System Hot Keys 
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The 6189-KEYKIT1 legend kit contains legend strips for the following 
computers: 

 
Computer 

Catalog Number 
 

Computer Type 
 

Keypad 

6180-xxCxxxxxxxx 

6180-xxDxxxxxxxx 
6180 Industrial 
Computer, 10.4 inch 
Color Screen 

Standard 

6180-xxGxxxxxxxx 6180 Industrial 
Computer, 10.4 inch 
Color Screen 

Full Alphanumeric 

6180-xxLxxxxxxxx 
6180-xxMxxxxxxx 

6180 Industrial 
Computer, 12.1 inch 
Color Touchscreen 

Standard 

6180-xxHxxxxxxxx 

6180-xxIxxxxxxxx 
6180 Industrial 
Computer, 15 inch 
Color Touchscreen 

Standard 

 
The 6180 Computer models 6180-xxC, -xxD, xxG (with 10.4 inch 
screen) are provided with a keypad strip installed displaying function key 
labels F1 - F12 and S1 - S12.  The reverse side of this strip has labels for 
letters A - Z.  Custom legend strips can also be created using blank 
legend labels. 

The 6180 Computer models 6180-xxL and -xxM (with a 12.1 inch 
screen) are provided with an alpha keypad strip installed.  The reverse 
side of this strip has labels for function keys F1 - F12 and S1 - S12. 

The 6180 Computer models 6180-xxH and -xxI (with a 15 inch screen) 
are provided with an alpha keypad strip installed.  The reverse side of 
this strip has labels for function keys F1 - F12 and S1 - S12. 

Legend kit contents 
The Legend Strip Kit (Catalog No.  61 89-KEYKIT1) contains legend 
strips for both the standard and full alphanumeric keypad versions of the 
6180 Computer.  The standard keypad legend strips are longer than the 
strips for the full alphanumeric keypad.  The kit contains: 

• Two preprinted legend strips for standard keypads.  These strips are 
preprinted on both sides.  One side has function key labels.  The 
reverse side of this strip is preprinted with labels for letters A-Z. 

• Three blank legend strips for standard keypads.  The strips are blank 
on both sides and may be marked for custom legends. 

• Three Preprinted/Blank legend strips for full alphanumeric keypads.  
These strips are preprinted on one side with function key labels Fl —
F20.  The reverse side of the strips are blank for marking custom 
legends. 

Legend Strip for 
Configurable Keypad 
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Marking the legend strip 
When custom labeling the legend strips, use an indelible type of marker.  
All printing must appear within the white text areas.  We recommend that 
you test print the legends on a separate sheet of paper to verify that the 
insert has adequate space for the legends. 

To reverse or change a legend strip: 
1. Carefully pull the legend strip from the left side behind the bezel. 

Figure 3- 2 

 
 

2. If you are using the blank legend strips, mark the legends on the matt 
surfaces provided for marking. 

3. Re–insert the tab into the slot.  Here are some helpful hints: 

• Grip the legend strip near the point where the strip enters the slot 
and use short “pushes”.  This helps prevent buckling of the 
legend strip. 

• It may be helpful to “cup” the legend strip slightly as you hold it.  
This will stiffen the legend strip and also prevent buckling. 
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The IrDA receiver / transmitter (version 2.0 compatible) located behind 
the front connector access panel or directly on the front panel overlay 
(see pages 1–6 and 1−11) allows you to communicate with other devices 
also having an IrDA receiver / transmitter, such as printers or note book 
computers.  The IrDA link has a maximum baud rate of 115 
kilobytes/sec.  Both devices must be no more than 1 meter apart. 

Also note the following when using IrDA: 

• Microsoft Windows needs to be configured for IrDA support 
(software drivers loaded into operating system). 

• In BIOS setup, the Serial Port 2 IR Mode (in Peripheral 
Communication submenu) must be enabled. 

• You must be running a software application that uses IrDA. 

 

Some 6180 motherboards are provided with  USB connectors. 

The Universal Serial Bus (USB) is an external bus standard that supports 
data transfer rates of 12Mbps (12 million bits per second).  A single USB 
port can be used to connect up to 127 peripheral devices, such as mice, 
modems, and keyboards.  USB also supports Plug-and-Play installation 
and hot plugging. 

Refer to the USB peripheral documentation for installing any required 
software on the 6180 Computer.  Microsoft Windows 95, Windows 98, 
and Windows 2000 operating systems offer plug and play support for 
USB devices. 

Using IrDA 

Using USB 
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Adding and Removing System Adding and Removing System Adding and Removing System Adding and Removing System 
ComponentsComponentsComponentsComponents    

This chapter describes how to remove and install: 

• back panel and accessory drive cover 

• add–in boards 

• processor board 

The 6180 Computer contains line voltages.  Make sure you disconnect 
all power to the 6180 Computer before performing any of the operations 
described in this chapter.   

 

 

ATTENTION: Disconnect all power from the 6180 
Computer before removing components.  Failure to 
disconnect power could result in severe electrical shock 
or damage to the 6180 Computer. 

 

 

ATTENTION: Wear an ESD wrist strap (well grounded) 
and perform work in a static safe environment.  
Electrostatic discharge can damage the 6180 Computer 
and components. 

 

Chapter Chapter Chapter Chapter 4    

Chapter Objective 

Safety Precautions 
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This section shows how to remove the back cover to access internal 
components. 

 

 

ATTENTION: Review safety precautions on page 4-1 
before proceeding.  Failure to follow proper safety 
procedures could result in severe electrical shock or 
damage to the 6180 Computer. 

 
To remove the back panel: 
1. Disconnect power from the 6180 Computer. 

2. Loosen the 2 screws securing the back panel.  The screws are 
retained and cannot be removed from the panel.  

 
Figure 4- 1 

 

Removing the Back Panel 
and Accessory Drive 
Cover 
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3. To re–install back panel, position back panel tabs over the chassis 

and tighten the 2 screws (6-8 in./lb.) 

ISA compatible boards may be installed in any of the ISA slots or the 
ISA/PCI shared slot.  PCI compatible boards may be installed in any one 
of the PCI slots or the ISA/PCI shared slot. 

Note: If a floppy or other device is installed in the lower bay, the 
lower three slots are restricted to half-length cards. 

 
Refer to the Processor Board manual for the type and number of slots 
supported by your computer. 

 

 

ATTENTION:  Review safety precautions on page 4−1 
before proceeding.  Failure to follow proper safety 
procedures could result in severe electrical shock or 
damage to the 6180 Computer. 

 

 

ATTENTION: Add-in boards may be sensitive to ESD 
and require careful handling.  Hold boards only by the 
edges, do not touch connectors.  After removing a board, 
place the board on a flat static free surface, component 
side up.  Do not slide the board over any surface. 

 
To remove a slot cover (to add a board): 

 
Figure 4- 2 

 

Adding and Removing 
Add-in Boards 
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1. Remove the back panel.  See page 4-2. 

2. Locate the slot cover you want to remove.  We recommend that you 
remove adjacent add–in boards.   

3. Remove the screw securing the slot cover and remove cover. 

To install a slot cover (after removing a board) 
1. Insert the end of the cover into the slot in the chassis.   

2. Install the screw securing the slot cover, tighten to 6–8 in–lbs (.7–.9 
N•m) 

To install an add–in board: 
1. Remove the board from its anti–static packaging and place on a 

grounded, static free surface. 

2. Set any board jumpers or switches as described in the instructions for 
the board. 

3. Hold the board by the edges and firmly press the board into the 
connector on the processor board. 

Figure 4- 3 
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4. Align the notch in the board retainer with the threaded hole and 
install the screw.  Hold the notch tightly against the screw before 
tightening (6-8 in./lb.).   

 
Note: If you do not install the retainer tight against the screw, you 

may have problems inserting an adjacent board. 
 

5. Connect any board cables (if required). 

6. Install the back panel.  See page 4-2. 

To remove an add–in board: 
1. Disconnect the cables to the Keypad Interface Card (KIC) and video 

card. 

2. Remove the screw securing the board retainer. 

3. Hold the board at each end and carefully rock the board back and 
forth until the edge connectors pull free. 

4. Store the board in an anti-static wrapper. 

5. Remove any unused cable associated with the board. 

6. Install a slot cover over the open slot. 

Removal of the processor board may be required for repairs or future 
board upgrades. 

Refer to the Processor Board Manual for board specifications. 

 

 

ATTENTION:  Disconnect all power from the 6180 
Computer before removing components.  Failure to 
disconnect power could result in severe electrical shock 
or damage to the 6180 Computer. 

Wear an ESD wrist strap (well grounded) and perform 
work in a static safe environment.  Electrostatic discharge 
can damage the 6180 Computer and components. 

 
To remove the processor board: 
1. Remove the back panel.  See page 4-2. 

2. Remove the power supply.  See page 9-1. 

3. Remove all add-in boards.  See page 4-7. 

Installing and Removing 
the Processor Board 
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Figure 4- 4 

 
 

4. Disconnect the hard drive IDE cable connector. 

5. Disconnect the floppy drive connector. 

6. Disconnect the front header panel connector. 

7. The side board (shown previous page) restricts access to the upper 
left mounting screw of the processor board.  Remove the 3 screws 
that secure the board, you do not need to unplug any connectors from 
the side board.  Gently move the side board to allow access to the 
processor board (upper left) mounting screw. 

8. Remove the screws that secure the processor board and remove the 
board.  Place board in an anti–static wrapper. 
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Figure 4- 5 

!!emove!seven!screws
at these locations.

!!he!!entium!
motherboard is 
shown. The 
Pentium II 
motherboard 
uses ten screws.

 

 
 

To install the processor board: 
1. Position the board in the chassis and align the screw holes with the 

stand–off spacers on the chassis. 

2. Secure the processor board with the 6 screws (shown above).  
Tighten screws to 6–8 inch–pounds (.7 to .9 N•m). 

3. Secure the side board with the 3 mounting screws.  Tighten screws to 
6–8 inch–pounds (.7 to .9 N•m). 

4. Connect all cables and connectors including the IDE drive cable and 
front header panel connectors. 

5. Install all add–in boards.  See page 4-7. 
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6. Install the power supply.  See Chapter 9. 

7. Install the back panel.  See page 4-x. 
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This chapter describes how to remove and install memory. 

 

Available RAM Memory 

The Pentium III processor board has three 168–pin sockets supporting 8 
to 512 Megabytes (MB) of synchronous DRAM (SDRAM) in Dual 
Inline Memory Module (DIMM) packaging format. 

The ITOX P3/Celeron board supports: 

• 16-512 MB using unbuffered DIMMs 

 

The ITOX P3/Celeron board: 

• Uses x64 or x72 PC-66 SDRAM DIMMs for 66 Mhz FSB CPUs, or 

• Uses x64 or x72 PC-100 SDRAM DIMMs for 100 Mhz FSB CPUs 

• ECC supported with x72 

• All DIMMs must be 3.3V 

 

These sockets support the following DIMMs, arranged in banks 0, 1, and 
2:  

  
Pentium III 
(Use gold-plated DIMMs) 

Memory Module 
(DIMM) 

Catalog No.   ECC/Non-ECC Clock 
Frequency 

64 MegaBytes 
SDRAM 

6189–DIMM64 ECC 100 Mhz 

128 MegaBytes 
SDRAM 

6189–DIMM128 ECC 100 Mhz 

 
The minimum memory size is 64MB (one 64MB DIMM).  The 
maximum memory size is 512MB (two 128MB and one 256MB 
DIMMs) for Pentium II boards. 

Chapter Chapter Chapter Chapter 5    

Chapter Objective 

Memory Overview 
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Figure 5- 1 

 
Both ECC and non-ECC DIMMs are supported.  However, for ECC 
operation to be available exclusively, ECC DIMMs (x72) must be 
installed in the system.  Additionally, the user must enable the ECC 
Configuration feature in the CMOS setup utility.  The options are “Non-
ECC” (BIOS default) and “ECC”.   

 
Setup Utility 
Mode Option 

Disabled Parity ECC 

Non-parity DIMMs No error detection N/A N/A 

Parity DIMMs No error detection Single-bit error 
detection 

Single-bit error 
correction 
Double-bit error 
detection 

 
 

Note: If any non–parity DIMMs are added, system parity is 
disabled for all banks (even if one bank contains parity 
DIMMs). 

 
You can install from 64 MB to 512 MB of memory in the motherboard 
DIMM sockets.  The board has DIMM sockets arranged as banks 0, 1, 
and 2.  The motherboard supports the following memory features: 

• 168-pin DIMMs with gold-plated contacts 
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• 66 or 100 Mhz SDRAM 

• Non-ECC (64-bit) and ECC (72-bit) memory 

• 3.3 V memory only 

• Single- or double-sided DIMMs in the following sizes: 

 
DIMM Size Non-ECC 

Configuration 
ECC Configuration 

16 MB 2 Mbit x 64 2 Mbit x 72 

32 MB 4 Mbit x 64 4 Mbit x 72 

64 MB 8 Mbit x 64 8 Mbit x 72 

128 MB 16 Mbit x 64 16 Mbit x 72 
 

When adding memory, follow these guidelines: 

• You can install DIMMs in any of the three banks 

• You can use different sizes of DIMMs in different banks 

• The BIOS detects the size and type if installed memory 

• For ECC operation to be available, all installed memory must be 
ECC, and you must enable the ECC Configuration feature in the 
Setup program.  See the SE440BX Motherboard Product Guide for 
more information. 

 
When adding memory to the 6180 Computer processor board, follow 
these guidelines: 

• SDRAM DIMMs can be installed in one, two, or three sockets in any 
order.  The BIOS automatically detects memory type (i.e.  ECC, non-
ECC), size, and speed. 

• EDO DIMMs are not supported in the P3 motherboard.  Do not 
attempt to install these types of DIMMs. 

• Use only gold-plated DIMMs in your Pentium III motherboard  

• Use 168-pin (100 MHz), unbuffered SDRAM DIMMs.  Both single- 
and double-sided DIMMS, and registered DIMMs are supported. 

• Use of serial-presence detect (SPD) DIMMs is optional, but 
recommended. 

Adding and Removing Memory Modules 

This section gives instructions on how to add memory modules to or 
remove memory modules from the 6180 Computer processor board. 

Guidelines for Adding and 
Removing Memory 



5–4 Adding and Removing Memory 

 

Publication 6180-6.0 

Internal 6180 Computer components may be damaged by Electrostatic 
Discharge (ESD).  Make sure you wear a grounding strap whenever 
handling circuit boards, memory modules or other internal components. 

 

 

ATTENTION:  Wear a wrist strap (well grounded) and 
perform work in a static safe environment.  Electrostatic 
discharge can damage the 6180 Computer and 
components. 

 
Also observe the following precautions:  

• Always handle the memory cards by the ends not by the memory 
module contacts. 

• Store memory in an anti–static bag when it is not installed. 

• Never install or remove memory with the power turned on. 

To add or remove memory: 
1. Disconnect power from the 6180 Computer. 

 

 

ATTENTION:  Disconnect all power from the 6180 
Computer before adding and removing components.  
Failure to disconnect power could result in severe 
electrical shock or damage to the 6180 Computer. 

 
2. Remove the back panel of the 6180 Computer.   

See the “Removing the Back Panel and Accessory Drive Cover” 
section (on page 4-2 for details on how to remove the back panel. 

3. Remove the 5 screws securing the power supply (see illustration, 
next page). 

 
Note: You do not have to disconnect the power supply wiring.  

Carefully position the power supply out of the way. 
 

Carefully remove the power supply while noting how the cabling is 
dressed in the unit.  Also note that air diverting flap(s) are attached 
to the power supply.  Observe the position of the air diverting flap(s) 
for later re–installation.  Be careful not to damage them.  Because of 
the limited length of the main supply cable harness to the 
motherboard, the power supply can be moved only to the point that it 
just clears the edge of the chassis. 
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4. Holding the DIMM only by the edges, remove it from its anti–static 
package. 

Figure 5- 2 

 
 

 

5. Make sure the clips at either end of the socket are pushed away from 
the socket. 

6. Position the DIMM above the socket.  Align the two small notches in 
the bottom edge of the DIMM with the keys in the socket. 

7. Insert the bottom edge of the DIMM into the socket (see the figure 
above). 

8. When the DIMM is seated, push down on the top edge of the DIMM 
until the retaining clips snap into place.  Make sure the clips are 
firmly in place. 

9. If you installed a DIMM with ECC memory, turn on the computer 
and use the ECC Configuration feature in Setup to enable ECC (see 
the associated motherboard guide). 

10. After the DIMMs are installed, return the power supply to its 
mounting position in the chassis.  Dress the cables to their original 
position and ensure that the air diverting flap (s) are installed near 
the processor heat sink, as originally positioned. 
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11. Secure the power supply and install back panel. 

12. Replace the back panel.  See page 4-2. 
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This chapter describes how to remove and install processors. 
 

The 6180 Pentium III processor board has a 370 socket that supports a 
processor upgrade migration path that includes higher performance 
Pentium III processors.  The 6180 Computer Pentium processor board 
has a type 7 socket which supports the Pentium process. 

The types of processors supported are: 

• Pentium Classic-166Mhz and 233Mhz 

• Slot 1-PII and PIII 

• Phase 2 (or 4) PS/Finned H. S. 

• Phase 3 P. S. 

• Phase 4 P. S. with Puma H. S. 

 

 

ATTENTION:  Disconnect all power from the 6180 
Computer before removing components.  Failure to 
disconnect power could result in severe electrical shock 
or damage to the 6180 Computer. 

 

 

ATTENTION:  Wear a wrist strap (well grounded) and 
perform work in a static safe environment.  Electrostatic 
discharge can damage the 6180 Computer and 
components. 

 
To remove the processor: 
1. Disconnect the power from the 6180 Computer. 

2. Remove the back panel.  (See page 4-2). 

 

 

 

 

Chapter Chapter Chapter Chapter 6    

Chapter Objective 

Installing and Removing 
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Figure 6- 1 

 

 
3. Remove the five screws securing the power supply.   

 
Note: You do not have to disconnect the power supply wiring.  

Carefully move the cables, and position the power supply 
out of the way.  
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Figure 6- 2 

 

 

 

4. Refer to the following figures (the 6180 Computer has two types of 
processors).  While holding the heat sink, use pliers to carefully pull 
the spring clamp from the tab on the socket. 
 

 

ATTENTION:  The spring clip fits tightly on the socket 
base.  Use extreme caution when using a needle nose 
pliers to remove the spring clip.  Make sure pliers do not 
slip and damage the processor board. 

 
 

 

ATTENTION:  The spring clamp secures the heat sink to 
the processor.  When the clamp is removed, the heat sink 
will slide off.  Make sure the heat sink does not fall onto 
other components. 
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Figure 6- 3 

 
 

5. Remove the spring clamp, heat sink, and conductive pad.   

 

 

ATTENTION:  When the socket lever is raised, the 
processor is loose in the socket.  Make sure the processor 
does not drop out of the socket. 

 

 

ATTENTION:  Do not remove any heat conductive 
grease from the conductive pad.  Be careful not to damage 
the conductive pad.  Damage to the pad or removal of 
conductive grease may result in overheating and failure of 
the processor. 

 
 

6. Press lightly down and out on the lever of the processor socket until 
the lever can be pulled up. 

7. Note the orientation of the processor and remove the processor from 
the socket.  Do not touch or bend the pins. 
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8. Place the processor in conductive foam and store in an anti–static 
package. 

To install the processor: 

 

 

ATTENTION:  Do not force the processor into the 
socket.  The processor will only fit in the socket one way.  
Refer to the figure on the previous page for proper 
orientation.  Notice that both the socket and processor 
have a flat corner (chamfer) that must be aligned 

 
1. Make sure the socket locking lever is up.  Position the processor in 

the socket.  Make sure the processor is oriented the same way as 
when removed.  The processor pins will not completely align with 
the socket if the processor is not oriented correctly.  The processor 
fits easily into the socket; do not press on the processor or bend any 
pins. 

2. Lightly hold the processor in the socket and push down on the socket 
lever until it locks in place. 

3. Carefully remove the protective plastic liner on the pad. 

4. Position the heat conductive pad and heat sink on the processor.  The 
heat sink and pad should be approximately centered over the 
processor.  Make sure you do not wrinkle or remove conductive 
grease from thermal pad. 

 
Note: If the pad is damaged, it cannot be used.  Either replace the 

pad or use a layer of thermal grease as a substitute. 
 

 
5. Place the spring clip over the heat sink.  Position one end of the 

spring clip under the socket tab.  Use a needle nose pliers  to position 
the other end of spring clip under the tab on other side.  On versions 
with an extended heat sink, insert the spring clip into the slot on the 
heat sink first and then into the slot on the opposite side (see 
illustration previous page).  Be careful not to let the pliers slip. 

6. Secure the power supply with the same screws removed. 

 

 

ATTENTION:  Risk of Electrical Shock.  Do not use 
power supply mounting screws exceeding 0.438 inches 
(11.125 mm).  Screws that are longer than recommended 
may come in contact with voltage sources within the 
power supply. 
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7. Refer to the Processor Board User Manual to check system jumper 
settings. 
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This chapter describes how to remove and install removable media. 
 

Mounting Options 

The following shows the three methods of mounting a floppy drive.  The 
front mounting option is not available for the non–display, metal bezel, 
12-inch, and 15-inch versions of the 6180 Computer. 
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Figure 7- 1 
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To remove the floppy drive or CD-ROM drive: 
1. Disconnect power from the 6180 Computer. 

 

 

ATTENTION:  Disconnect all power before adding and 
removing components.  Failure to disconnect power could 
result in severe electrical shock or damage to the 6180 
Computer. 

 
 

2. Remove the back panel.  See page 4-2. 

Figure 7- 2 

 
 

 

ATTENTION:   If the 6180 Computer is installed with 
mounting clips, the mounting clips on the hinge side will 
interfere with the opening of the hinge.  Remove the 
mounting clips on the hinge side before swinging chassis 
away from the bezel.  Failure to remove clips may 
damage clips and the chassis. 
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3. From the bottom of the chassis (under the accessory drive), remove 

the 4 screws that secure the accessory drive/ bracket assembly. 

Figure 7- 3 

 
 

4. The sequence of the following steps depends on whether the floppy 
drive or CD-ROM drive is mounted to the rear or front: 

• If mounted for front access, do step 6 then step 7. 

• If mounted for rear access, do step 7 then step 6. 

5. Disconnect the ribbon cable connector and power cable connector 
from the accessory drive. 

 

 

 

 

Figure 7- 4 
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6. Remove the accessory drive / bracket assembly through the back of 
the chassis. 

7. Remove the screws that secure the accessory drive to the bracket.  
This will vary depending upon the type of drive. 
 

Installation 

 
Note: You can also use these procedures to install a front or rear 

facing CD-ROM drive (without using the mounting 
bracket).  The lower bay floppy drive mounting bracket and 
CD-ROM drive use the same sets of chassis mounting 
holes. 

 
To install a floppy using the lower bay mounting bracket: 
1. Secure the floppy drive to the drive bracket using four screws 

supplied with the bracket.  Tighten screws to a torque of 6–8 in.  lbs 
(.7–.9 N•m). 

2. Swing open the back of the computer chassis after removing the 
three bezel latching screws. 
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Figure 7- 5 

 

3. Position the accessory drive / bracket assembly into the chassis. 

 
Note: For rear facing drives, you may have to remove the 

panel knockout (shown above) if a rear mounted drive 
was not previously installed.  Insert screwdriver into 
slot on knockouts and pry back and forth on knockout 
to remove.  Use pliers to remove the center rib between 
the two knockouts. 
For front facing drives, if a floppy drive was not 
previously installed, you may have to replace the 
floppy drive cover behind the front access door with a 
cover having an opening. 
 

 
 

Note: You may have to remove the side panel knockout 
(shown below) if a side mounted drive was not 
previously installed.  Insert screwdriver into slot on 
knockouts and pry back and forth on knockout to 
remove.  Use pliers to remove the center rib between 
the two knockouts. 
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4. Connect the cable connectors to the floppy drive.  Connectors are 
keyed so they cannot be installed backwards. 

5. Align the floppy drive/bracket (or CD-ROM) and chassis mounting 
holes and secure them with the 4 mounting screws provided with the 
bracket (or CD-ROM).  Tighten screws to a torque of 6–8 in.  lbs 
(.7–.9 N•m). 

Figure 7- 6 

 
 

6. Swing the chassis back onto the bezel and secure chassis with the 
three latching screws.  Tighten screws to a torque of 18–22 inch lbs 
(2–2.5 N•m). 

7. Install the back panel.  See page 4-2. 
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8. Apply power to the 6180 Computer and verify operation of the drive.  
You may need to edit BIOS settings to recognize the drive or to 
allow the operating system to detect the new hardware. 

Floppy Drive Upper Bay Mounting Bracket 

The upper bay mounting bracket allows you to mount a floppy drive out 
the side of the 6180 Computer chassis. 

Mounting Bracket for Upper Bay Floppy Drive 
(Catalog No.  6189–UBFDBRKT for Series A; Catalog No.  6189-
UBFDBRKTB for Series B) 

Figure 7- 7 

 

 
 

Installation 

To install a floppy using the upper bay mounting bracket: 
1. Secure the floppy drive to the drive bracket using four screws 

supplied with the drive.  Tighten screws to a torque of 6–8 in.  lbs 
(.7–.9 N•m). 
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Figure 7- 8 

 

 

 
2. Remove the back panel to the 6180 Computer.  See page 4-2. 

3. A shorter drive cable is provided with the mounting kit for mounting 
in the upper bay.  Connect the cable to the floppy drive connector on 
the processor board (refer to the Processor Board user manual if 
necessary) and the connector on the back of the drive.   

4. Position the accessory drive / bracket assembly into the chassis.  The 
edge of the bracket fits under the tab at the front of the chassis. 

 
Note: You may have to remove the side panel knockout 

(shown below) if a side mounted drive was not 
previously installed.  Insert screwdriver into slot on 
knockouts and pry back and forth on knockout to 
remove.  Use a pliers to remove the center rib between 
the two knockouts. 

 

 

ATTENTION:  If knockout is removed, carefully remove 
any burrs or sharp edges.  Failure to remove sharp edges 
could result in personal injury. 

 
 

5. Align the bracket and chassis mounting hole and secure the drive / 
bracket assembly with a mounting screw.  Tighten screw to a torque 
of 6–8 in.  lbs (.7–.9 N•m). 
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Figure 7- 9 

 
 

6. Install the back panel.   

7. Apply power to the 6180 Computer and verify operation of the drive.  
You may need to edit BIOS settings to recognize the drive or to 
allow the operating system to detect the new hardware. 

 

Add text… 

 

 

Master/Slave Jumper 
Settings 
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This chapter describes how to remove and install data storage devices. 
 

The section gives instructions on how to install or remove a hard disk 
drive from the 6180 Industrial Computer.   

Internal components may be damaged by electrostatic discharge (ESD).  
Make sure you wear a grounding strap whenever handling circuit boards, 
memory modules or other internal components. 

 

 

ATTENTION:  Wear a wrist strap (well grounded) and 
perform work in a static safe environment.  Electrostatic 
discharge can damage the 6180 Computer and 
components. 

 

 

ATTENTION:  Be careful when setting a drive down on 
hard surfaces, to avoid damage due to shock or vibration. 

 
 

Observe the following precautions:  

• Always handle the drive by its metal frame. 

• Avoid touching the exposed printed circuit board and components. 

• Store a drive in an anti–static bag when it is not installed. 

• Avoid touching the cable connectors.   

• Never disconnect or connect a drive with power turned on. 

To remove a hard drive: 
1. Disconnect power from the 6180 Computer. 

 

 

ATTENTION:  Disconnect all power from the 6180 
Computer before adding and removing components.  
Failure to disconnect power could result in severe 
electrical shock or damage to the 6180 Computer 
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2. Remove the back panel of the 6180 Computer.  See page 4-2. 

Figure 8- 1 

 
3. Disconnect the ribbon cable connector from the drive.  On 3.5 inch 

drives, also disconnect the power connector from the drive. 

4. Remove the two screws securing the drive / bracket assembly. 

5. Remove the drive / bracket assembly. 

For 3.5 Inch Hard Disk Drives 

1. Remove the four drive mounting screws and the drive. 
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Figure 8- 2 

 
 

For 2.5 Inch Solid State Flash Drives 

1. Remove the four drive mounting screws and the drive. 

Figure 8- 3 

 

 

 
To install a hard drive: 

1. Secure the drive to the bracket with the four mounting screws.  
Tighten screws to a torque of 6–8 in–lbs. 
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2. Position the drive / bracket assembly into the chassis.  Make sure the 
tabs on the side of the bracket slide into the corresponding side hole 
in the chassis.  Also make sure that the key on the end of the bracket 
is inserted into the slot on the chassis front panel. 

3. Secure the drive / bracket assembly to the chassis with the two 
mounting screws.  Tighten screws to a torque of 6–8 in–lbs. 

4. Install the ribbon connector on the hard drive.  On 3.5 inch drives 
also connect the power cable.  Make sure that the ribbon cable is 
installed correctly.  The red wire of the cable must be at the bottom 
as shown below.  Connect the other side of the IDE ribbon cable to 
the motherboard. 

Figure 8- 4 

 
 

5. Install the back panel.   

6. Apply power and verify the operation of the drive.  Refer to any 
additional instructions provided with the drive. 

Master and Slave Jumper Settings 

Need text???? 
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This chapter describes how to remove and install power supplies. 
 

The AC input power supply accepts a 120/240V AC input power.  The 
DC input power supply accepts a 24V DC input power.  Each provides 
regulated lower DC voltages required for all internal components such as 
processor board, card connectors, peripherals, and chassis fan. 

The 160W and 210W power supplies are used with Pentium class 
processors, while the 180W power supply is used with the Pentium III 
processors.  The 200W DC power supply works with all of the above. 

 

 

ATTENTION: Review safety precautions before 
proceeding.  Failure to follow proper safety procedures 
could result in severe electrical shock or damage to the 
6180 Computer. 
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To remove the power supply: 
1. Disconnect power from the 6180 Computer. 

2. Remove the back panel.  See page 4-2. 

3. Unplug the power cord from the power supply. 

4. Remove the power supply filter. 

5. Follow the wires as they exit the power supply and disconnect the 
wiring at the connectors.  Pull on the connector to remove, do not 
pull on the wires.  Make sure you note the location of the connectors.  
Connectors P1 and P10 have latches that must be squeezed before 
the connector can be removed. 

6. While supporting the power supply, remove the 5 mounting screws 
that secure the power supply.   

7. Remove the power supply. 
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Figure 9- 1 
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Figure 9- 2 

 
 

To install the power supply: 
 

 

ATTENTION: Risk of Electrical Shock.  Do not use 
screws exceeding 0.438 inches (11.125 mm).  Screws that 
are longer than recommended may come in contact with 
voltage sources within the power supply. 

 
1. Position the power supply in the chassis and secure with the 5 

mounting screws.  Torque screws to 6–8 in–lbs (0.7 to 0.9 N•m). 

2. Connect the power supply cable connectors to the processor board 
and other internal components.  The connectors are keyed so they 
cannot be installed the wrong way, do not force connectors. 
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ATTENTION: Make sure the flow director is properly 
positioned between the power supply and base of the 
processor socket.  Failure to correctly install the flow 
director may result in excessive temperatures which can 
damage the processor. 

 
3. Make sure the flow director is positioned correctly. 

• On Pentium systems, the flow director is directed at the base of 
the processor socket.  The flow director tabs are inserted into the 
power supply below the fan.  The free end of the flow director is 
positioned against the base of the processor socket. 

• On Pentium II and Pentium III systems, the flow director is 
attached to the power supply.  The flow director surrounds the 
slot 1 processor module and draws air away. 

Figure 9- 3 

 

 

 
4. Install the power supply filter, if applicable (Pentium II and DC 

powered systems do not require power supply filters). 

5. Install the back panel. 
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160 Watt Supply - Check AC Voltage Selection Switch: 
 

Note: Voltage selection on the 210 and 180 Watt supply is 
automatic.  The following instructions only apply to the 160 
Watt supply. 

 
If a power cord is being connected for the first time, a protective warning 
label covers the power supply connector.  This warning label reminds 
you to set the proper input voltage and must be removed before the 
power cord is inserted. 

 

 

ATTENTION: Check voltage selection before applying 
power (160 Watt supply only). 

 
 

Figure 9- 4 

 

200W 24V DC Input Power Supply Connection 

Proper Earth grounding of the product chassis is required when using 
the 200W DC input power supply.  Keep the grounding wire short, and 
preferably use braided cable, in order to reduce the impedance of this 
connection as much as possible.  Improper grounding will result in 
reduced immunity to line transients and surges on the DC input power 
lines. 

It is recommended that the 24V DC power be supplied via 10 or 12 
gauge wiring kept as short as possible, preferably less than 3 meters in 
length.   
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This chapter describes how to remove and install displays and 
backlights. 
 

The backlight uses Cold Cathode Fluorescent (CCF) tubes to illuminate 
the display.   

 

 

ATTENTION: Disconnect all power from the 6180 
Computer before replacing the backlight.  Failure to 
disconnect power may result in electrical shock and/or 
damage to the terminal. 

 

 

ATTENTION: Do not touch any of the exposed 
electronic components to prevent damage from 
electrostatic discharge (ESD). 

 
 

The procedures for replacing the plastic bezel/displays are the same. 

If you are installing a bezel with no display, the procedures are the same 
except for the number of electrical connectors to the bezel. 

To remove a bezel/display: 
1. Disconnect the power from the 6180 Computer. 

2. Disconnect all communication and power cables. 

3. Remove the clips or mounting stud nuts that secure the computer to 
the panel. 

 
Important: There is metal tab that temporarily locks the bottom of the chassis 

in the panel during mounting.  This tab must be bent in before 
bezel / chassis can be removed. 

 
 

4. Remove the computer from the panel or enclosure. 
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5. Remove the three latching screws that secure the chassis to the front 
bezel. 

Figure 10- 1 

 
 

6. Swinging the chassis open about 90 degrees. 

7. Disconnect the electrical connectors from the front panel.  Note the 
location and orientation of the connectors. 

Figure 10- 2 

INSERT GRAPHIC HERE 
 

8. Drive the hinge pin up using a slotted screwdriver (under the head of 
the hinge pin) and a small hammer. 

Figure 10- 3 

INSERT GRAPHIC HERE 
 

9. Remove the bezel/display from the chassis. 
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To install a bezel display: 

1. Secure the bezel/display to the chassis by aligning the hinges and 
installing the hinge pin. 

2. Connect the electrical connectors between the bezel/display and the 
chassis.  The connectors are different sizes and each is keyed so that 
they cannot be installed incorrectly.  Do not force a connector. 

3. Swing the chassis closed.  Make sure the bezel/display cables and 
connectors move freely and do not crimp when the chassis is closed. 

4. Secure the chassis with the three latching screws.  Use the new 
screws provided. 

5. Mount the 6180 Computer in the enclosure or panel.   

6. Apply power and verify operation of the display. 

 

To replace the backlight (10.4 inch displays only): 
 

7. Disconnect the power from the 6180 Computer. 

8. Remove the three latching screws that secure the chassis to the front 
bezel. 

 

 

 

 

 

 

 

 

 

 

 

Replacing the 10.4 inch 
Display Backlight 
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Figure 10- 4 

 
 

9. Note the following precautions before swinging the chassis away 
from the bezel. 

 

 

ATTENTION: Remove all external cables from the side 
panel connectors.  Failure to remove cables may cause 
damage to the cables and connectors. 

 

 

ATTENTION: If the 6180 Computer is installed with 
mounting clips, the mounting clips on the hinge side will 
interfere with the opening of the hinge.  Remove the 
mounting clips on the hinge side before swinging chassis 
away from the bezel.  Failure to remove clips may 
damage clips and the chassis.   

 
10. Swing the chassis open about 90 degrees. 

11. Remove four screws that secure backlight and remove the backlight 
to allow access to the power connector 

12. Unplug the backlight power supply cable and remove the backlight. 

13. Plug the backlight power supply cable into the new backlight. 

14. Place the backlight on the four backlight standoffs. 
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15. Replace the four backlight mounting screws and tighten to a torque 
of 6 to 8 inch-pounds (.7 to .9 N_m). 

16. Swing the chassis back into position and tighten the three latching 
screws to a torque of 18 to 22 inch-pounds (2 to 2.5 N_m). 

17. Reconnect and install any external cables or mounting clips. 

18. Apply power and verify operation of the backlight. 

 

To replace the backlight (12.1 inch displays only): 
 
1. Disconnect the power from the 6180 Computer. 

2. Remove two screws each from the backlight assembly. 

3. Disconnect the two cables from the power supply. 

4. Remove the backlight assembly. 

 

To replace the backlight (15 inch displays only): ): 
 
1. Disconnect the power from the 6180 Computer. 

2. Remove two screws each from the backlight assembly. 

3. Disconnect the two cables from the power supply. 

4. Remove the backlight assembly. 

 

 

Replacing the 12.1 inch 
Display Backlight 

Replacing the 15 inch 
Display Backlight 
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This chapter describes how to add or remove video controller boards. 

Internal components may be damaged by Electrostatic Discharge (ESD).  
Make sure you wear a grounding strap whenever handling circuit boards, 
memory modules or other internal components. 

 

 

ATTENTION: Wear a wrist strap (well grounded) and 
perform work in a static safe environment.  Electrostatic 
discharge can damage the 6180 Computer and 
components. 

 
The Allen-Bradley Video board is available in four versions.  These 
versions provide 64-bit graphics processing and require a PCI slot 
(Pentium) or AGP slot (Pentium III).  They are both available with 
4Mbytes on board frame buffer memory. 

 
The video driver software is preloaded with the operating system on your 
computer.  If you need to reinstall the driver, the driver software is 
provided on the video driver diskette (s) provided with your computer. 

If you need to reload the video driver, follow the instructions for your 
operating system.  These instructions will also describe how to change 
your display properties. 

 
 Features Allen-Bradley Video Board 

Catalog No.  6189-FPABVC 
(SVGA only) 

 Interface PCI local device 

 Video Memory 2MB EDO DRAM 

 Resolutions 1280 x 1024, 256 Colors 
(Interlaced) 

1024 x 768,65K Colors 

800 x 600, 16.7M Colors 

640 x480, 16.7M Colors 

 Graphics Processing 64 Bit 
 Power Requirements 5V DC±5% @ 1A 

 Dimensions inches/mm 6.4 m.  (L) x 4.2 in.  
(H)163mm (L) x 107mm (H) 
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 Features Allen-Bradley Video Board 
Catalog No.  6189-FPABVC 

(SVGA only) 
 Display Type Flat Panel TFT SVGA 

 
Features Heading Heading 

Interface PCI local device. PCI local device. 

Video Memory 4MB EDO DRAM 4MB EDO DRAM 

Resolutions 1280 x 1024, 256 Colors 
(Interlaced) 

1024 x 768,65K Colors 

800 x 600, 16.7M Colors 

640 x480, 16.7M Colors 

1280 x 1024, 256 Colors 
(Interlaced) 

1024 x 768,65K Colors 

800 x 600, 16.7M Colors 

640 x480, 16.7M Colors 

Graphics Processing 64 Bit 64 Bit 

Power Requirements 5V DC±5% @ 0.5A 

3V DC±5% @ 0.25A 

5V DC±5% @ 

3V DC±5% @ 0.25A 

Dimensions inches/mm 6.4 m.  (L) x 4.2 in.  (H) 
163mm (L) x 107mm (H) 

6.4 m.  (L) x 4.2 in.  (H) 
163mm (L) x 107mm (H) 

Display Type Flat Panel TFT SVGA, 
XGA, and CRT 

CRT 
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This chapter describes how to add or remove keypad interface cards. 

Internal components may be damaged by Electrostatic Discharge (ESD).  
Make sure you wear a grounding strap whenever handling circuit boards, 
memory modules or other internal components. 

 

 

ATTENTION: Wear a wrist strap (well grounded) and 
perform work in a static safe environment.  Electrostatic 
discharge can damage the 6180 Computer and 
components. 

 

The Allen-Bradley Keypad Interface card (KIC) is available in several 
versions, depending on the bezel configuration option.  Only NDM 
Model 6180 does not require a KIC.  The KIC is an ISA-based add-in 
card that handles keypad/keyboard control, touch screen control, touch 
mouse control, and LCD backlight brightness and on/off controls. 

 

Two software components may be preinstalled for the KIC, based on 
your system configuration: touch screen drivers and utilities, and the 
Keypad Configuration Utility (see Chapter 12). 

The driver software is preloaded with the operating system on your 
computer.  If you need to reinstall the driver, the driver software is 
provided on the driver diskette (s) provided with your computer. 

If you need to reload the driver, follow the instructions for your 
operating system. 

 

Intro text. See Figure 12-x for the jumper settings. 

 

To disconnect the cables: 
5. Remove the back panel. 

6. Remove the mounting screw on the bracket. 
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7. Carefully remove the connector from the LCD and backlight cable to 
the backlight inverter board (P4). 

8. Carefully remove the ground wire (P5). 

9. Disconnect the connector from the front access port (P6). 

10. Push away the latching connector. 

11. Disconnect the (P8) connector to the bezel board. 

12. Disconnect the (P7) connector (PS/2) to the side board. 

13. Carefully remove the KIC card.  

14. Insert the new KIC card, being careful not to pinch the cables. 

Note: If using an ISA KIC card, be sure the card is inserted in the 
ISA slot farthest from the power supply. 

 
15. Reconnect the (P7) connector to the side board. 

16. Reconnect the (P8) connector to the bezel board. 

17. Reconnect the connector from the front access port (P6). 

18. Reconnect the ground wire (P5). 

19. Reconnect the connector from the LCD and backlight cable to the 
backlight inverter board (P4). 

20. Reconnect the mounting screw on the bracket. 

21. Replace the back panel. 

 

The P1 jumper (see Figure 12-x), is used to “hardwire” the bezel keypad 
to be disabled. The P2 jumper is used to control write protection of the 
boot block segment of the KIC flash memory. 

 

 

 

 

 

KIC Jumper Settings 
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This chapter describes how to setup and use the Keypad Configuration 
Utility (KCU) software. 

The Keypad Configuration Utility (KCU) allows you to modify, view, 
print and download keypad configurations/firmware upgrades to the 
following 6180 Industrial Computers. 

 
Catalog Number  Computer Type  Keypad 

6180-xxCxxxxxxxx  6180 Industrial 
Computer with 10.4 
inch Color Screen 

Standard 64 Key 

6180-xxDxxxxxxxx  6180 Industrial 
Computer with 10.4 
inch Color, 
Touchscreen 

Standard 64 Key 

6180-xxLxxxxxxxx  6180 Industrial 
Computer with 12.1 
Inch Color Screen 

Standard 69 Key 

6180-xxMxxxxxxxx  6180 Industrial 
Computer with 12.1 
Inch Color, 
Touchscreen 

Standard 69 Key 

6180-xxGxxxxxxxx  6180 Industrial 
Computer with 10.4 
inch Color Screen 

Full Alphanumeric 96 
Key 

6180-xxHxxxxxxxx  6180 Industrial 
Computer with 15 Inch 
Color Screen 

Standard 70 Key 

6180-xxIxxxxxxxx  6180 Industrial 
Computer with 15 inch 
Color Touchscreen 

Standard 70 Key 

 
For each keypad configuration you can: 

• enable or disable specific keys 

• retrieve, modify and save key codes associated with specific keys on 
the computer’s faceplate. 

If you modify the default codes and your computer is replaced in the 
future, you must either: 

Chapter Chapter Chapter Chapter 13    
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• transfer the old KIC card to the new computer. 

• modify the key codes in the KIC utility on the new computer to match 
the existing application.  Save the key code definitions to a Keypad 
Configuration file (*.key) for later retrieval. 

 

The Keypad Configuration Utility is a 32 bit Microsoft Windows 
application that runs on the 6180 computer in these environments: 

• Windows 95/98/2000 

• Windows NT, version 4.0 or later 

 
Several new keypad features were introduced in version A5.02 
Alphanumeric KIC card firmware.  Control of these new features is 
handled through a new release of the KCU, version 3.20.02 (or later).  

These new features affect either or both the programmable and fixed key 
groups of keys, depending on the particular feature.  Refer to Figure 1 
for information on key partitioning. 

Alphanumeric Keypad Layout 

Figure 13- 1 

 

 

System Requirements 

Keypad Configuration 
Utility – New Features 
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New Feature Description 

The new supported keypad features are: 

Single Programmable Key Mode with Abort 
This feature works similar to a previously implemented feature that was 
referred to as “Multi-Key Enable” (now called Standard Multi-Key 
Mode).  Single Programmable Key Mode with Abort limits 
programmable key activations to one and only one programmable key, 
with the further stipulation that any additional key activation will cause 
the initial key’s break code to be issued immediately.  No further key 
scan codes will be sent until all keys are released and new key 
activation(s) made.  There are two basic rules governing this feature as 
follows: 

• If a programmable key is pressed, any secondary key activation 
– regardless of key group association – will immediately cause 
the latter key to be ignored and the break code of the initial key 
to be sent.  No further scan code generation will occur until after 
all keys are first released. 

• Multiple key presses within the fixed key group will be allowed.  
However, if a programmable key is pressed while any fixed keys 
are currently activated, break codes for all active keys will be 
sent immediately. No further scan code generation will occur 
until after all keys are first released. 

This feature will be global, per the two behavioral rules, and applies to 
all keys except the brightness control keys. When neither of the two 
Single Programmable Key Modes (with or without abort) is selected, any 
number of programmable (blue) keys can then be pressed and will be 
processed normally, just as they would be on a standard 101-key 
keyboard.  This is Standard Multi-Key Mode.   

Make/Break Non-Repeat Mode   
This feature, as the name implies, allows the end-user to configure keys 
as make/break non-typematic (i.e., non-repeating).  When a key is first 
pressed, the make code is sent one time.  Regardless of the duration of 
the key activation, no autorepeating make codes will be sent thereafter.  
When the key is released, the break code is sent one time, as always.   

The obvious exception to this condition is the brightness control keys -- 
they must be processed normally as in all other configuration cases.  The 
programmable and fixed key groups can be independently configured to 
support this mode.   
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Single Key Hold-Off Interval   
This feature supports a user-definable key switch timeout period which 
ignores multiple instances of a single, same key press inside a timeout 
window (a scenario known as “key teasing”).  The time-out would apply 
to any singular, recently pressed and released key(s).   

For example, if key #1 is pressed and released with the timeout value is 
set for 0.5 seconds, the keypad controller will send the initial make/break 
codes, but will ignore any activation of that same key within a 1/2 
second timeframe.  It must be released for  greater than 0.5 seconds 
before any new scan codes for it will be sent.  However, a second key 
could be activated anytime after the first key is released.   

Due to the firmware’s built-in key switch debounce algorithm, holdoff 
values of less than 50mS will not be supported.  The options for the 
timeout period are: Disabled (no timeout period applies), 100mS, 
250mS, 500mS, 1 second, 2 seconds, 3 seconds and 4 seconds. 

Auxiliary Keyboard Enable  
An auxiliary (external) keyboard can be disabled by deselecting this 
feature.  If an external keyboard is unplugged and reconnected, the effect 
of the feature will remain persistent.  In order to re-enable the auxiliary 
keyboard, this feature must be selected.   

Ctrl-Shift-Esc Enable  
Ctrl+Shft+Esc hot-key sequences – which in the Windows OS 
environment cause the Task Manager to launch -- are inhibited when this 
feature is deselected.  

 

The Keypad Configuration Utility software is pre-installed on 6180 
Computers that are shipped with the Windows operating system and a 
keypad.  Installation disks are supplied with all 6180 Computers.   

To install the Keypad Configuration Utility software using Control Panel: 
1. Insert Disk 1 in Drive A: or Drive B: 

2. Click the Start button, click Settings and then click the Control 
Panel. 

3. Double-click the Add/Remove Programs icon. 

4. On the Install/Uninstall tab, click the Install button. 

 
Note: You can also uninstall the Keypad Configuration utility 

from this tab. 

Installing the Keypad 
Configuration Utility 
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5. Follow the install instructions on the screen. 

To install the Keypad Configuration Utility software using Run: 
1. Insert Disk 1 in Drive A: or Drive B: 

2. Click the Start button and select Run from the menu. 

3. Enter a:\setup in the Run dialog and click OK. 

4. Follow the install instructions on the screen. 
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The KCU Utility recognizes three file types. 

File Type Description 
.KEY  Keypad configuration file 

.BOO  Boot firmware file.  Cannot be edited.  Supplied by 
Allen-Bradley when upgrades of the boot code 
firmware are required. 

.APP Application firmware file.  Cannot be edited.  
Supplied by Allen-Bradley when upgrades of the 
application firmware are required. 

 
All file types can be downloaded to the Keyboard Interface Controller 
(KIC) in the 6180 Industrial Computer. 

To use the Keypad Configuration Utility, connect an IBM AT standard 
keyboard and mouse with PS/2 connectors (if you do not have touch 
screen or touch mouse) to the 6180 computer.  If you are using the front 
panel connectors, you must install jumper cables as shown below.  These 
jumpers route the keyboard and mouse ports from the processor board to 
the front panel connectors.  Make sure the correct ports are used.   

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

File Types 

Connecting the Keyboard 
to the 6180 Computer 
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Figure 13- 2 

 
 

 

Alternatively, the mouse and keyboard can plug into the side panel 
mouse and keyboard ports.   

Note: You must reconnect the patch cables for the keypad/KIC 
PS/2 connection to work.   

 
The Keyboard Interface Controller (KIC) has a keyboard connector.  If 
you use the side panel connectors, the KIC keyboard port is disabled.   
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To run the KCU Utility: 

1. For computers running Windows 95 or Windows NT: 

a. Click once on the Start button.  Place the cursor over Programs.  
You will see the Programs submenu. 

b. Place the cursor over Keypad Configuration Utility. 

c. Click on the icon. 

2. The Keypad Configuration Utility opens and shows the current 
keypad configuration stored on the KIC card.  Depending on the 
computer type, the keypad configuration will be 64 key, 69 key, 70 
key standard or full alphanumeric. 

The window that contains the keypad configuration stored on the KIC 
card is named KIC Keypad Configuration. 

Figure 13- 3 

 
You can now: 

• modify the keypad configuration stored on the KIC card 

• modify the keypad configuration and save it under a new .KEY file 
name 

• open and modify an existing keypad configuration (.KEY) file 

• open an existing firmware file (*.BOO or *.APP). 

Using the KCU Utility 
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Operations available from the menu bar are defined below. 

 
Select commands on 

this menu: 
To 

File Menu  Open, close, save, preview, print and download 
keypad configurations or firmware upgrades 

Edit Menu  Select keys, enable/disable keys, set the 
programmable keys to function keys or alpha keys, 
redefine programmable keys and edit keypad 
preferences 

View Menu  Toggle the tool bar or status bar on or off, or view 
the firmware contents of the KIC card 

Window Menu  Opens a new window and arranges open windows 
and keypad icons 

Help Menu  Display a list of help topics or the current version 
number of the Keypad Configuration Utility 

 

Keypad Configuration Window 

Each keypad configuration appears as a separate window.  All key 
editing is done within this window. You can: 

• enable/disable all or specific keys 

• set a default configuration for the programmable keys: 

− function keys or alpha keys on standard keypad 

− function keys on full alphanumeric keypad 

• edit the definitions of the programmable keys 

• enter a description of the keypad configuration 
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Figure 13- 4 

 

 

Entering a Keypad Description 

The text edit box at the bottom of the keypad configuration window 
allows you to enter a description to identify the keypad.  The text edit 
box accepts up to 128 characters.   

To edit a description, click in the text edit box and start typing or editing 
the text.   

With the cursor in the text edit box, click the right mouse button to open 
the popup menu.  Use the commands on this menu to copy/cut, paste and 
delete selected text.  To select all the text in the description box, choose 
Select All from the popup menu.   

The new keypad description takes effect when you select Store Keypad 
Configuration to KIC on the File menu.   

Getting Help 

You can get general Help information on the Keypad Configuration 
Utility by: 
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• accessing the Help menu on the tool bar. 

• clicking the Context Help tool to get context sensitive information. 
 

Opening Keypad Configurations 

This section shows how to open: 

• previously saved keypad configurations (*.KEY files) 

• KIC Keypad Configuration stored on the KIC controller card. 

To open an existing keypad configuration file: 
1. Choose Open from the File menu or click on the tool bar. 

Figure 13- 5 

 

 
The dialog shows all keypad configuration files (.KEY) in the folder 
C:\Program Files\RAC6000\KeyConfig\. 

2. Double-click the .KEY file you want to open or click on a .KEY file 
and then click the Open button. 

A window opens for the selected keypad configuration.  The name of 
the .KEY file shows in the title bar. 
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The window titled KIC Keypad Configuration is the configuration stored 
on the KIC card.  If this window and all other keypad configuration 
windows are closed, you can reopen the KIC Keypad Configuration from 
the File menu. 

To reopen the keypad configuration stored on the KIC card: 
Choose Open KIC Keypad Configuration from the File menu. 

A window opens with the KIC Keypad Configuration displayed in the 
title bar. 

Selecting Keys 
The table below shows how to select keys on the keypad.  You must 
select a key before you enable/disable a key or redefine its function. 

 
To Select: Do This: The result is: 

Single key  Click the left mouse 
button on the key.   

The selected key is 
highlighted with 
handles. 

Group of keys Click the left mouse 
button and drag the 
selection rectangle 
around the keys you 
want to select.   

The selected key is 
highlighted with 
handles. 

All keys Choose Select All Keys 
from the Edit menu.   

All keys are highlighted 
and appear with 
handles. 

All Programmable Keys Choose Select All 
Programmable Keys 
from the Edit menu. 

All programmable keys 
are highlighted and 
appear with handles. 

Multiple Keys Click the left mouse 
button while holding 
down the Ctrl key.   

The selected keys are 
highlighted and appear 
with handles. 

 
 

Enabling and Disabling Keys 
You can enable/disable all or specific keys on the keypad.  By default, all 
keys are initially enabled. 

 
Note: If the jumper P1 on the KIC board is in the non-default 

position 1-2 (see page XX), all keypad keys are hardware 
disabled. 
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To disable one or more keys: 
1. Select the key(s) you want to disable. 

2. Choose Enable Key from the Edit Menu or click the right mouse 
button on the key and choose Enable Key from the popup menu. 

A red X appears on the key, indicating that it is disabled and the check 
mark is removed from Enable Key on the Edit menu. 

To enable a key: 
1. Select the disabled key. 

2. Choose Enable Key from the Edit Menu or click the right mouse 
button on the key and choose Enable Key from the popup menu. 

The red X is cleared from the key, and a check mark appears next to 
Enable Key on the Edit menu. 

If multiple keys are selected with some keys enabled and others disabled, 
choosing the Enable Key command will enable all the selected keys. 

Setting Configuration of Programmable Keys 
(64-Key Standard Keypad) 

On a 64-key standard keypad, you can set the default configuration of 
the programmable keys to Function Keys or Alpha Keys. 

• Function Keys 

F1 - F12, S1 - S12 (shifted function keys) 
Figure 13- 6 
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Figure 13- 7 

• Alpha Keys (lower case a-z) 

INSERT SCREEN CAPTURE HERE 

 
You can set the configuration for all programmable keys or a selected 
group of keys. 

To set the default configuration to Function keys: 
1. Choose Select All Programmable Keys from the Edit menu 
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2. Choose Set Default Configuration  Function Keys from the Edit 
menu. 

The definitions of the programmable keys are updated: 

• F1-F12 are defined as <F1> - <F12> 

• S1-S12 are defined as <Left Shift+F1> - <Left Shift+F12> 

Note: These are the factory default settings. 
 

To set the default configuration to Alpha keys: 
1. Choose Select All Programmable Keys from the Edit menu. 

2. Choose Set Default Configuration _ Alpha (a-z) Keys from the Edit 
menu. 

The definitions of the programmable keys are updated: 

• F1-F12 are redefined as a – m. 

• S1-S12 are redefined as n – z. 

Please note that the key definitions change but the actual keys are not 
relabeled with lowercase characters. 

To view the definition of a key: 
• select the key and choose Key Configuration from the Edit menu. 

• or click the right mouse button on the key and select Key 
Configuration from the popup menu. 

• or select Print Preview from the File menu to view all keys. 

Setting Configuration of Programmable Keys  
(96-Key Full Alphanumeric Keypad) 

On a full alphanumeric keypad, you can set the default configuration of 
the programmable keys to the definitions listed below. 

• Function Keys F1 - F10 and F11 - F20 
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Figure 13- 8 
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• Function Keys K1 - K8 and K9 - K16 

You can set the configuration for all programmable keys or a selected 
group of keys. 

To set the default configuration to Function keys: 
1. Choose Select All Programmable Keys from the Edit menu 

2. Choose Set Default Configuration _ Function Keys from the Edit 
menu. 

The definitions of the programmable keys are updated: 

• F1 - F10 are defined as <F1> – <F10> 

• F11 - F20 are defined as <Left Shift+F1> – <Left Shift+F10> 

• K1 - K8 are defined as <Left Ctrl+F1> – <Left Ctrl+F8> 

• K9 - K16 are defined as <Left Ctrl+Left Shift+F1> – <LeftCtrl+Left 
Shift+F8> 

 
Note: These are the factory default settings. 

 
Please note that the key definitions change but the actual keys are not 
relabeled. 

To view the definition of a key: 
• select the key and choose Key Configuration from the Edit menu. 

• or click the right mouse button on the key and select Key 
Configuration from the popup menu. 

• or select Print Preview from the File menu to view all keys. 
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Figure 13- 9 

 

 

Setting Configuration of Programmable Keys  
(69-Key Standard Keypad) 

NEED TEXT FOR THIS SECTION: 

On a standard keypad, you can set the default configuration of the 
programmable keys to Function Keys or Alpha Keys. 

•  

•  
Figure 13- 10 
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Setting Configuration of Programmable Keys  
(70-Key Standard Keypad) 

On a standard keypad, you can set the default configuration of the 
programmable keys to Function Keys or Alpha Keys. 
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• Function Keys (K1-K12) 

• Alpha Keys (uppercase A – Z) 
Figure 13- 11 
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You can set the configuration for all programmable keys or a selected 
group of keys. 

To set the default configuration to Function keys: 
1. Choose Select All Programmable Keys from the Edit menu 

2. Choose Set Default Configuration _ Function Keys from the Edit 
menu. 

The definitions of the programmable keys are updated: 

• K1-K12 are defined as F1-F12 

• A–L are defined as F1–F12 

• M is disabled 

• N–Y are defined as <Left Shift+F1> - <Left Shift+F12> 

• Z is disabled 

To set the default configuration to Alpha keys: 
1. Choose Select All Programmable Keys from the Edit menu. 

2. Choose Set Default Configuration _ Alpha (A–Z) Keys from the Edit 
menu. 

The definitions of the programmable keys are updated: 

• A-Z are defined as a–z 

• K1–K12 are defined F1–F12 

 
Note: These are the factory default settings. 

 
To view the definition of a key: 
• select the key and choose Key Configuration from the Edit menu. 

• or click the right mouse button on the key and select Key 
Configuration from the popup menu. 

• or select Print Preview from the File menu to view all keys.  You 
must define a default printer before using Print Preview. 
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Figure 13- 12 
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Editing Definitions of Programmable Keys 

The Edit Programmable Key dialog lets you modify the key code 
definitions of the programmable keys on the computer’s faceplate.  The 
definitions are stored in the flash memory of the Keyboard Interface 
Controller (KIC).  Modifying the default key codes/modes is not 
recommended unless required by the application software.   

If you modify the default codes and your computer is replaced in the 
future, you must either: 

• transfer the old KIC to the new computer 

• modify the key codes in the new KIC card to match the existing 
application.  Save the key code definitions to a Keypad Configuration 
file (*.key) for later recall. 

Text Edit Box 
Figure 13- 13 

 

 
Displays the current key code definition for a selected programmable 
key.  You can enter a new key code definition directly into the edit box if 
the characters are printable (e.g., alphanumeric characters).  You must 
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enter nonprintable characters from the Add New Code list.  Use 
Backspace to remove existing codes and correct typing errors. 

Select Mode 
Displays the current mode for a selected programmable key.  Select 
Macro/String or Make/Break Typematic to enable a mode. 

In Macro/String mode, all Make and Break key codes are sent as a 
single string when the key is first pressed. 

Figure 13- 14 

 

In Make/Break Typematic mode, the Make codes are sent when the key 
is first pressed and the Break codes are sent when the key is released.  If 
the key is held down, the make codes are repeated at the typematic rate. 
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Figure 13- 15 

 

 

 

The default is Make/Break Typematic. 

Make/Break is available only for a single key code definition including 
its modifiers. 

For earlier firmware versions that do not support Make/Break, the Select 
Mode is inactive (grayed). 
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Add New Code 
Figure 13- 16 

 

 
Displays a list of valid keys and modifiers that you can assign to a 
programmable key.  Modifier (Shift, Ctrl, Alt, Win or Win Appl) are 
enabled for a key code, by selecting the appropriate check boxes. 

These check boxes are dynamically updated so that only valid 
combinations are allowed. 

After selecting a key code and modifiers, click the Enter button to 
display the new code in the Text Edit box.  You must click Enter after 
each new code selection. 

General Guidelines for Redefining Keys 
The Keyboard Interface Controller (KIC) card allocates 64 bytes of flash 
memory for the scan codes assigned to each programmable key. 

A programmable key may be assigned: 

• a single printable or a single nonprintable key code (for example the 
letter a or F1 or Left Ctrl+Left Alt+a). 

• multiple printable or multiple nonprintable key codes (for example, a 
Shell command such as DIR C:\, or Left Ctrl+a and Left Alt+b). 
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In general, an unshifted, printable character uses 3 bytes and a modified 
code uses more than 3 bytes. 

The following guidelines apply when editing definitions of the 
programmable keys. 

• Commands are limited to 20 shifted or 21 unshifted printable 
characters. 

• Avoid entering shifted and unshifted characters in a definition.  Using 
both in a definition requires more memory. 

The utility does not allow you to: 

• enter definition for a programmable key that exceeds 64 bytes 

• enter multiple key codes for a programmable key that is make/break 
typematic. 

 

To edit the definition of a programmable key: 
1. Select a single programmable key. 

2. Choose Key Configuration from the Edit menu. 

Or click the right mouse button on the key and choose Key 
Configuration from the popup menu. 

A dialog shows the current definition of the programmable key.  
Nonprintable key codes appear in brackets, for example, <F1> or 
<(L)Shift+F1>.  Modifiers appear to the left of a “+” symbol. 
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Figure 13- 17 

 

 
3. Edit the key definition. 

To select a key definition from the Add New Code list: 
• Select (or click on) a code in the Add New Code list. 

• Under Left or Right, select the Shift, Ctrl, Alt, or Win check boxes to 
enable one or modifiers for the code. 

To enter the shifted character for a code (e.g., A) select the left or right 
Shift check box after selecting the code a. 

To assign the Windows Application modifier to a code, select the 
WinAppl check box. 

• Click Enter to display the new code in the text box. 

If entering multiple codes, click Enter after each code selection or 
double-click each code selection.  The text box is automatically updated. 

To enter a command or key definition in the Text box: 
•  Type the characters in the Text box as you want them to appear using 

shifted or unshifted characters. 

Use the Backspace key to delete characters and re-enter text. 



13–24 Keypad Configuration Utility Software 

 

Publication 6180-6.0 

•  To insert a nonprintable code in the text, select the code from the 
Add New Code list and then click Enter.  The nonprintable code is 
inserted in the text with brackets. 

1. Under Select Mode, select Macro/String or Make/Break Typematic. 

2. Click OK to save the definition and close the dialog. 

To save the new key code definitions to KIC flash memory, use the Store 
Keypad Configuration Command on the File menu. 

Examples of Editing Key Definitions 
To redefine the F1 key as <Ctrl+Win+F> which is the Find Computer 
function in Windows: 
Figure 13- 18 

INSERT GRAPHIC OF 12 AND 15 INCH SCREEN. 

1. Select the key labeled K1. 

2. Choose Key Configuration from the Edit menu. 

Or click the right mouse button on the key and choose Key 
Configuration from the popup menu. 

3. In the text box, backspace to delete the current definition. 

4. Under Select Mode, select Make/Break Typematic. 

5. Select ’f’ from the Add New Code list. 

6. Under Left, select the Ctrl check box, then the Win check box. 

7. Click the Enter button to display the new definition. 

Figure 13- 19 
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8. Click OK to store the definition and exit the dialog. 

To redefine the F12 key to perform a DIR C:\ command: 
1. Select the key labeled K12. 

2. Choose Key Configuration from the Edit menu. 

Or click the right mouse button on the key and choose Key 
Configuration from the popup menu. 



  Keypad Configuration Utility Software 13–25 

 

Publication 6180-6.0 

3. In the text box, backspace to delete the current definition 

4. Under Select Mode, select Macro/String 

5. In the text box, type DIR C:\ 

Figure 13- 20 

 

 
6. Click OK to store the definition and exit the dialog. 

To redefine the F6 key to perform the RUN RSPROGRAM <ENTER> 
command: 
1. Select the key labeled F6. 

2. Choose Key Configuration from the Edit menu. 

3. In the text box, backspace to delete the current definition 

4. Under Select Mode, select Macro/String. 

5. In the text box, type RUN RSPROGRAM 

Figure 13- 21 
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6. Select Enter from the Add New Code list and click the Enter button.  

The nonprintable code is inserted in the Text box. 
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7. Click OK to store the definition and exit the dialog. 

Editing Keypad Preferences 

Select Keypad Preferences from the Edit menu to: 

• enable or disable the Ctrl+Alt+Delete function. 

If enabled, the keypad recognizes this key sequence as a warm reset. 

If disabled, the Delete key is ignored in the sequence, inhibiting a warm 
reset.  The default is enabled. 

• enable or disable simultaneous presses of remapped and/or modifier 
keys. 

If enabled, the keypad recognizes simultaneous key presses of remapped 
keys with or without the Ctrl, Alt, or Shift keys. 

If disabled, pressing a programmable key inhibits all other key presses.  
Pressing a non-programmable Ctrl, Alt, or Shift key inhibits any program 
key.  The default is disabled. 

Figure 13- 22 
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For earlier firmware versions that do not permit modification, the dialog 
is inactive (grayed). 

Note about Multi-key Enable: Some software applications may operate 
erratically when responding to simultaneous, multiple key presses.  The 
Multi-Key Enable option of 6180 Industrial Computers allows you to 
enable/disable multiple key presses for predictable, reliable operation. 

6180 Industrial Computers are shipped with a Multi-Key Enable 
function, that is enabled (by default) for the keypad.  Simultaneous key 
presses of programmable keys are inhibited by this default setting.  In 
addition, all programmable keys are inhibited when a Ctrl, Alt or Shift 
key is pressed.  For example, <Alt + F>, a shortcut key combination for 
the File menu function in many applications, is inhibited. 

Saving Keypad Configurations 

You can save a keypad configuration under the existing name or under a 
new name. 
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Save 
Choose Save from the File menu or click on the tool bar to save changes 
to a keypad configuration under the current name.  The default filename 
for the keypad configuration stored on the KIC card is KIC.KEY.  The 
first time you try to save a configuration, the Save As dialog opens. 

Save As 
Choose Save As from the File menu to save the keypad configuration 
under a new file name.  This command saves the original version of the 
keypad configuration without edits and the modified version under a new 
name.  The default file type for keypad configuration files is .KEY. 

Figure 13- 23 
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Previewing and Printing a Keypad Report 

The KIC utility creates a report for each Keypad configuration file.  You 
can print the report or preview the report first and then print it. 

Print Preview is a convenient way to view the keypad configuration. 

To preview a keypad configuration: 
1. Open the .KEY keypad configuration file you want to preview. 

2. Choose Print Preview from the File menu. 

The Preview workspace opens showing the keypad report.  The report 
includes: 

• keypad configuration file name .KEY or “KIC Keypad 
Configuration” if the keypad configuration stored on the KIC card is 
the current focus. 

• date/time report generated 

• description field of the keypad configuration 

• list of Non-programmable keys (enabled or disabled) 

• definitions of programmable keys (enabled or disabled), and whether 
the key code definition is Macro/String or Make/Break Typematic. 

• keypad preferences (Multi-Key Enable and Ctrl–Alt–Del Enable). 

 

Macro/String definitions appear in double quotes.  Make/Break 
Typematic definitions appear in single quotes. 
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Disabled keys appear with a line through the key name and definition. 

3. Select one of the buttons at the top of the workspace. 

 
Click this button: To: 

Print  Open a Print dialog allowing you to print the report.  
See the next page. 

Zoom In Increase the magnification of the view so the report 
looks larger.  You can increase the magnification 
several times. 

Zoom Out Decrease the magnification of the view so the report 
looks smaller.  You can decrease the magnification 
several times. 

Close  Exit the Preview workspace. 

 
To print a keypad report: 
1. Open the .KEY keypad configuration file. 

2. Choose Print from the File menu or click on the tool bar. 

Or choose Print Preview from the File menu and select Print at the 
top of the Preview workspace. 

A Windows Print dialog opens. 

Figure 13- 24 
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3. Select a printer from the Name list. 

If the printer you want to use is not listed, choose Print Setup from 
the File menu. 

4. Select the number of copies and other Properties. 

Print all reports in Portrait (not Landscape) mode. 

5. Click OK to print the report. 

Viewing Contents of KIC Card 

To view the current contents of the KIC card, choose KIC Contents from 
the View menu.  This command displays: 
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•  Description of the Keypad Configuration (entered on the Keypad 
Configuration Window) 

•  Firmware version of the Boot Code 

•  Firmware version of the Application Code 

Downloading a Keypad Configuration to the KIC Card 

To download a keypad configuration to the KIC card: 
1. The active window must contain the keypad configuration you want 

to download to the KIC card. 

If you updated the KIC Keypad Configuration stored on the KIC 
card, save the configuration to a file before downloading.  Save to a 
new file or overwrite the existing .KEY file. 

2. From the File menu, choose Store Keypad Configuration to KIC. 

A dialog opens asking you if want replace the current contents of the 
KIC flash memory with the contents of the active window. 

3. Click OK to continue with the download. 

Upgrading the Application Code Firmware 

This section shows how to upgrade the application firmware (*.APP) 
stored on the KIC Card. 

 
Note: You cannot edit the application firmware file (*.APP). 

 
Allen-Bradley supplies this file when an upgrade of the KIC card is 
required. 

To upgrade the application firmware on the KIC card: 
1. Choose Open From the File menu. 

2. Select Application Firmware Upgrade File (*.APP) from the Files of 
type list box. 

3. Double-click the *.APP file or select the file and click Open. 

A dialog opens showing details of the .APP upgrade file. 

•  file type is KIC Application Code 

•  file name of the application code firmware 
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•  last modification date/time of file 

•  description and version number of the application code 
firmware 

4. Choose Upgrade KIC Application Firmware from the File menu. 

A dialog opens asking if you want to replace the application code 
contents of the KIC flash memory with the contents of the current 
window. 

5. Click OK to continue with the download. 

Upgrading the Boot Code Firmware 

This section shows how to upgrade the boot code firmware (*.BOO) 
stored on the KIC Card.  Upgrading of the boot code firmware is not 
normally required, even if the application code firmware is upgraded. 

Upgrading the boot code firmware on the KIC card requires: 

•  setting the P2 jumper to the correct position on the KIC card. 

•  downloading the boot code *.BOO file to the KIC card. 

 
Note: You cannot edit the boot code firmware file (*.BOO). 

 
Allen-Bradley supplies this file when an upgrade of the KIC card is 
required. 

Setting the P2 Jumper 
When upgrading the boot code firmware, the P2 jumper on the KIC card 
(in the computer) must be in the Normal position.  The position of the P2 
jumper and its location on the KIC card is shown below. 

Figure 13- 25 
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Note: Removing Jumper P2 from the board enables write 

protection.  With write protection enabled, the Keypad 
Configuration Utility cannot write to the KIC boot code. 
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Upgrading the boot code firmware to the KIC card: 
 

Note: You cannot edit the boot code firmware file (*.BOO). 
 

Allen-Bradley supplies this file when an upgrade of the KIC card is 
required. 

1. Choose Open From the File menu. 

2. Select Boot Firmware Upgrade File (*.BOO) from the Files of type 
list box. 

3. Double-click the selected file or select the file and click Open. 

A dialog opens showing details of the *.BOO upgrade file. 

•  file type is KIC Boot Code 

•  file name of the boot code firmware 

•  last modification date/time of file 

•  description and version number of the boot code firmware 

4. Choose Upgrade KIC Boot Firmware from the File menu. 

A dialog opens asking if you want to replace the boot contents of the 
KIC flash memory with the contents of the current window. 

5. Click OK to continue with the download. 

Alphanumeric 6180 Industrial Computers are shipped with the following 
keypad features disabled: 

 

• Single Programmable Key Mode with Abort 

• Make/Break Non-Repeat Mode 

• Single Key Hold-Off Interval  
 

Alphanumeric 6180 Industrial Computers are shipped with the following 
keypad features enabled: 

• Auxiliary Keyboard Enable 

• Ctrl-Shift-Esc Enable  

• Ctrl-Alt-Del Enable 

• Single Programmable Key Mode 
 

Changing Keypad 
Configuration Utility 
Preferences 
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The following figure shows how the new feature controls are presented 
in the KCU’s Keypad Preferences window (default feature configuration 
shown): 

Figure 13- 26 

 

 
If either a non-Alphanumeric keypad configuration or a version of KIC 
Alphanumeric firmware older than A5.02 is detected by the KCU, the 
Keypad Preferences window will be displayed with the new feature 
selection controls grayed out.  This is because they don’t apply. 

Enabling Single Programmable Key Mode with Abort 

If you want to inhibit simultaneous presses of programmable keys and 
cause an abort of all key scan code activity if a multi-key sequence does 
occur, do the following: 

6. Run the Keypad Configuration Utility from the Start>Programs 
menu. 

7. From the Edit menu, select Keypad Preferences.   
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The Keypad Preferences dialog is displayed. 

8. Select the Single Programmable Key Mode with Abort button. 

9. From the File menu, select Store Keypad Configuration to KIC. 

Multi-key presses of programmable keys are now inhibited and will 
generate a global key abort if they are attempted.   

Note: Standard Multi-Key Mode, Single Programmable Key Mode 
and Single Programmable Key Mode with Abort are 
mutually exclusive modes; only one mode may be selected 
at a time. 

 
 

Enabling Make/Break Non-Repeat Mode 

If you want to prevent key autorepeating: 

1. Run the Keypad Configuration Utility from the Start>Programs 
menu. 

2. From the Edit menu, select Keypad Preferences.   

The Keypad Preferences dialog is displayed. 

3. Select the Make/Break Non-Repeat Mode box of the key group to 
which you wish to apply this feature.   

Both the programmable and fixed key groups can be selected 
simultaneously, if desired.   

4. From the File menu, select Store Keypad Configuration to KIC. 

When a programmable key is now pressed, only a single Make code will 
be generated when the key is initially pressed, and the Break code will be 
generated when the key is released. 
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Enabling Single Key Hold-Off Interval 

If you want to prevent “key teasing” for an end-user specified interval: 

1. Run the Keypad Configuration Utility from the Start>Programs 
menu. 

2. From the Edit menu, select Keypad Preferences.   

The Keypad Preferences dialog is displayed. 

3. Select the desired time value from the drop-down menu for either the 
programmable or the fixed key groups (or both).  In the example 
shown below, a value of 1 sec is selected for the programmable key 
group and 500 ms is selected for the fixed key group. 

Figure 13- 27 
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4. From the File menu, select Store Keypad Configuration to KIC. 

When a program key is now pressed and released, a further press of the 
same key within 1 second will be ignored.  A full second must pass from 
the last time the key was pressed before it can be used again (an 
“ignored” key will constitute a “last” key press).  Likewise, a fixed key 
will behave in the same manner, except the timeout will be 500 ms. 

 Disabling the Auxiliary Keyboard 

If you want to disable an external keyboard: 

1. Run the Keypad Configuration Utility from the Start>Programs 
menu. 

2. From the Edit menu, select Keypad Preferences.   

The Keypad Preferences dialog is displayed. 

3. Uncheck the Aux Keyboard Enable box.  

4. From the File menu, select Store Keypad Configuration to KIC. 

An external keyboard is now disabled. 

Inhibiting Ctrl-Shift-Esc 

If you want to inhibit the Ctrl-Shift-Esc hot-key sequence: 

1. Run the Keypad Configuration Utility from the Start>Programs 
menu. 

2. From the Edit menu, select Keypad Preferences.   

The Keypad Preferences dialog is displayed. 

3. Uncheck the Ctrl-Shift-Esc Enable box.  

4. From the File menu, select Store Keypad Configuration to KIC. 

Ctrl-Shift-Esc hot-key sequences are now inhibited. 

 

 

 





 

 

Touchscreen Drivers and Touchscreen Drivers and Touchscreen Drivers and Touchscreen Drivers and 
UtilitiesUtilitiesUtilitiesUtilities    

This chapter describes how to set up and use touchscreen utilities. 
 

The touchscreen controller and software installed in your system have 
been changed since the release of the v2.0 Touchscreen System User’s 
Guide.  Be aware of the following differences in operation: 

Allen-Bradley 6180 Industrial Computers typically use interrupt level 9 
(IRQ9) for the touchscreen controller hardware.  By traditional PC 
convention, IRQ 9 is unused by system board hardware and therefore is 
made available to ISA add-in cards.  However, some recent system 
boards, such as Intel’s SE440BX (Seattle) motherboard, automatically 
reserve IRQ 9 for system board functions (such as power management).  
Because of this, the touchscreen controller hardware in your computer, 
as well as the touchscreen software drivers, have been changed to 
support reconfiguration of the selected IRQ.  This is sometimes referred 
to as “interrupt steering”. 

Newer versions of the touchscreen software will auto-detect the type of 
system board installed in your computer.  Based on the system board’s 
interrupt requirements, the software will either: 

• leave the selected interrupt at the power on configuration (IRQ 9) 

• or “steer” the interrupt to some other unused IRQ level to avoid 
resource conflicts. 

The IRQ configuration conforms to the following table. 

 
System Configuration System Board Type IRQ 

6180-Axxxxxxxxxxxx Advanced/ML (Marl) 9 

6180-Bxxxxxxxxxxxx Advanced/ML w/MMX 
(Marl MMX) 

9 

6180-Cxxxxxxxxxxxx PD440FX (Portland) 9 

6180-Dxxxxxxxxxxxx SE440BX (Seattle) 5 

For computers without a touchscreen, no IRO is selected 

The following versions of the touchscreen software support the 
reconfigurable interrupt feature: 

• For Windows 95/98 —# v2.2.2 or later 

Chapter Chapter Chapter Chapter 14    

Chapter Objective 

Touchscreen IRQ 
Configuration 
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• Windows NT 4.0 —+ v2.2.1 or later 

 

The touchscreen software installation utility automatically selects the 
interrupt suitable for your system’s configuration as listed in the table 
above. 

Your computer is shipped with the touchscreen software installed.  If you 
have to re-install the touchscreen software, the IRQ is automatically 
selected for you.  You do not have to select IRQ 9 from a list of 
interrupts as described in the V2.0 Touchscreen System User’s Guide. 

In addition, the I/O address used by the touchscreen hardware has been 
expanded to include 321h (I/O range is now 320-321h). 

 

If your computer runs in a DOS environment, there are several software 
calibration and setup tools included in your software package.  These 
tools require that you enter the IRQ and I/O base address (decimal 
notation) in the command line: 

• If your computer is a 6180-Axxxxxxxxxxx, 6180-Bxxxxxxxxxxx or 
6180-Cxxxxxxxxxxx catalog number, follow the instructions 
provided in the Touchscreen System User’s Guide. 

• If your computer is a 6180-Dxxxxxxxxxxx catalog number, follow 
the instructions provided in the Touchscreen System User’s Guide but 
substitute IRQ 5 wherever you see IRQ2 (synonymous with IRQ9). 

Example #1; To calibrate your touchscreen in a 61 80-Axxxxxxxxx DOS 
based system you would type: PC2CAL 2 800 <Enter> This 
configures the software to use IRQ 9 and I/O 320h. 

Example #2; To calibrate your touchscreen in a 6180-Dxxxxxxxxx DOS 
based system you would type: PC2CAL 5 800 <Enter> This configures 
the software to use IRQ 5 and I/O 320h. 

 

 

 

 

 

Touchscreen Software 
Installation 

DOS Systems 
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This chapter describes the most common operating problems, the 
probable causes, and recommended corrective actions including: 

• LANDesk summary 

• troubleshooting procedure 

• troubleshooting checklists 

• bootup error messages 

• general error and information messages 

For units with the Pentium III processor, LANDesk Client Manager 
software is included on a CD-ROM.  The LANDesk software enables a 
user to: 

• Monitor and manage third-party DMI-compliant components 

• Backup and restore system configuration files 

• Receive notification of certain system events 

For units containing a Pentium II processor, the LANDesk Client 
Manager software is included on a CD-ROM.  For Pentium III units 
having a pre-installed operating system, the LANDesk software is also 
pre-loaded on the hard disk. 

Units containing the pre-loaded LANDesk software will contain a 
desktop icon called LANDesk Setup.  To install the customized 
LANDesk software, double-click this icon. 

Chapter Chapter Chapter Chapter 15    

Chapter Objective 

LANDesk Summary 
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Units not having the pre-loaded LANDesk software require the CD-
ROM to install the LANDesk software.  For these units, please note the 
following parameter settings: 

 
Fan Sensor 

Chassis Fan 

 Nominal Speed  3100 RPM 

 Threshold (80%)  2480 RPM 

 Minimum Threshold 2000 RPM 
 

Power Supply Fan 

 Nominal Speed  4200 RPM 

 Threshold (80%)  3360 RPM 

 Minimum Threshold 2700 RPM 
 

Temperature Requirements (Motherboard) 

Nominal Temperature 32° C 

Threshold  60° C 

Maximum Threshold 90° C 
 

Voltage Requirements (Motherboard) 

Nominal Voltage 

 +12 VDC Threshold Deviation _2.00 VDC 

   Max.  Threshold Deviation _2.00 VDC 
 

 -12 VDC  Threshold Deviation _2.00 VDC 

   Max.  Threshold Deviation _2.00 VDC 
 

 +5 VDC  Threshold Deviation _0.80 VDC 

   Max.  Threshold Deviation _1.00 VDC 
 

 -5VDC  Threshold Deviation _0.80 VDC 

   Max.  Threshold Deviation _1.00 VDC 
 

 +3.3VDC Threshold Deviation _0.35 VDC 

   Max.  Threshold Deviation _0.70 VDC 
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To help identify and isolate a problem, we recommend that you do the 
following when a problem occurs: 

1. Turn off the power to the 6180 Computer. 

2. Disconnect any peripheral devices such as printer. 

3. Connect the keyboard and mouse (if used) to the side panel 
connectors.  These connectors are connected directly to the processor 
board. 

4. Check the monitor connections. 

5. If the system normally loads from the hard drive, make sure there is 
not a disk in the floppy drive. 

6. Apply power and observe the LEDs on the front panel (if present).  
Make sure the power on indicator is illuminated. 

7. Monitor the Power On Self Test (POST).  One of 3 events will 
occur: 

• The 6180 Computer will complete the bootup process. 

• An error message will occur indicating a non–fatal fault.  You 
may have to acknowledge the message before the bootup process 
is allowed. 

• The boot process will terminate (fatal error). 

If a fatal or non–fatal error occurs, note the displayed message and 
refer to the error message descriptions at the end of this chapter. 

8. If the system boots up, isolate the problem by connecting peripheral 
devices one at a time until the problem occurs.  If the problem is 
with a specific software package, you may want to re–install the 
software. 

9. If there is a problem not related specifically to a software installation 
or peripheral device, refer to the following troubleshooting 
checklists. 

Troubleshooting 
Procedure 
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The following are checklists of items that you may have overlooked. 

If you are having problems during bootup: 
√  Are all connections secure? 

√  Are the device drivers installed? 

√  Are the jumpers on the processor board correctly positioned (refer to 
    the separate Processor Board User Manual)? 

√  Are the jumpers on any add–in boards correctly positioned? 

√  Is the hard drive formatted and defined? 

√  Are the RAM memory (SIMMs) properly installed?  You may want to  
    re–install them to ensure a good connection. 

√  Is the IDE cable from the hard drive properly connected?  You may  
    want to see if the system will boot from a floppy drive. 

√  Is BIOS properly configured (refer to the separate Processor Board  
    User Manual)? 

If there is a problem after bootup: 
√  If you are running a software package, re–install the software. 

√  If the problem is intermittent, you may have a loose connection.   
    Check all connections including any ISA / PCI cards.  Check that the  
    memory modules (SIMMs) are fully installed. 

√  Does your system have a virus?  Run anti–virus software if it is  
    available. 

√  Try clearing CMOS and running BIOS Setup (refer to the separate  
    Processor Board User Manual). 

√  Although the 6180 Computer has a regulated and protected power  
    supply, a transient voltage in the power line or peripheral cable may  
    cause a flickering display, unexpected reboots, or a locked up system.   
    If so exit the application and start over. 

√  Is the IDE cable from the hard drive properly connected.  You may  
    want to see if the system will boot from a floppy drive. 

√  Is the system overheating?  Look at the overtemperature light on the  
    front panel display (if present).  Verify that the power supply and  
    chassis fans are working and the filters are clean. 

Troubleshooting Check 
Lists 
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If there is a problem running new software: 
√  Does the software have a hardware requirement that is not present? 

√  Are you using an authorized copy of the software?  Some copies of  
    software will not work. 

√  Did the software install correctly?  Re–install the software. 

√  Are you following the software’s instructions.  Refer to the user  
    manual. 

If there is a problem with an add–in board: 
√  Is the board installed and configured correctly?  Recheck jumper and  
    other configuration settings. 

√  Are any cables correctly installed? 

If the board is an ISA board (not Plug and Play) refer to the following 
suggestions: 

√  If the board uses an interrupt, run BIOS Setup and set the interrupt  
    used by the ISA board to Used by ISA Card (refer to the Processor  
    Board User Manual provided with the 6180 Computer).  In the  
    advanced BIOS menu, select the Plug and Play configuration  
    subscreen and then select the use Setup Utility option.  If that does not  
    work, try the Use ICU option. 

√  If the board uses memory between 80000H and 9FFFFH, run BIOS  
    setup and set conventional memory to 512K. 

√  If the board uses memory between C8000H and DFFFH, run BIOS  
    setup and enable shared memory for the appropriate memory space. 

If incorrect characters are displayed or are distorted: 
√  Are the display contrast and brightness controls properly adjusted?   
    Refer to the operating system containing the video driver for setup  
    functions. 

√  Is the video cable / card properly installed? 

√  Is the monitor compatible with the selected video mode? 

√  If using the integrated display, swing the chassis away from the bezel  
    and check the connection to the display. 
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If characters are not displayed on an external monitor: 
√  Is the monitor functioning properly? 

√  Is the video cable / card properly installed? 

√  Check that selected character color is not set the same as the  
    background color. 

√  Is the video board and driver properly installed? 

√  Reboot the 6180 Computer. 

If the hard drive active LED indicator does not come on: 
√  Check the IDE cable connections to the drive. 

√  Check the front panel connector on the processor board (refer to the 
    separate processor board instructions). 

√  Check BIOS Setup for proper configuration, is drive enabled? 

√  Reboot the 6180 Computer. 

If the Power On LED indicator does not come on: 
√  Check the front panel connector on the processor board (refer to the 
    separate processor board instructions).   

If the Power On LED flashes: 
√  CPU is in a reduced power mode, pressing any key should reactivate  
    normal operation. 

If you can not enter BIOS Setup: 
√  Check position BIOS enable jumper.  If the jumper enables access to  
    the Setup program, you may have to clear CMOS RAM to default  
    values and reconfigure the setup values.  Refer to the separate   
    Processor Board User Manual. 
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This chapter describes routine maintenance procedures for: 

• cleaning the display 

• cleaning the chassis fan filter 

• cleaning the power supply filter 

Note: See the procedures for replacing the SD104 and SD150 
backlights earlier in this manual. 

 
Clean the 6180 Computer with the front panel access doors closed. 

 

 

ATTENTION: Use of abrasive cleansers or solvents may 
damage the display window.  Do not scrub or use brushes. 

 
 

To clean the display: 
1. Disconnect power from the 6180 Computer at the power source.  

2. Using a clean sponge or a soft cloth, clean the display with a mild 
soap or detergent.  

3. Dry the display with a chamois or moist cellulose sponge to avoid 
water spots. 

Removing Paint and Grease   
Remove fresh paint splashes and grease before drying by rubbing lightly 
with isopropyl alcohol.  Afterward, provide a final wash using a mild 
soap or detergent solution.  Rinse with clean water. 

 

 

ATTENTION: Make sure the isopropyl alcohol does not 
come in contact with the equipment labels.  Alcohol may 
cause the label printing to smear. 

 

Chapter Chapter Chapter Chapter 16    

Chapter Objective 

Cleaning the Display 
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Equipment Hose Downs 
If the 6180 Computer has a touchscreen, be aware that screen objects on 
touchscreens may activate during equipment hose downs. 

 

 

ATTENTION: Because touchscreens have sensitive 
touch cell regions, it is possible for screen objects to 
activate during equipment hose downs. 

 
Clean the chassis fan filter at least once a month under normal 
conditions.  You may need to clean the filter more frequently if the 6180 
Computer is located in an area with high levels of dust. 

 

 

ATTENTION: Disconnect all power from the 6180 
Computer before removing components.  Failure to 
disconnect power could result in severe electrical shock 
or damage to the 6180 Computer. 

 
To clean the chassis fan filter (Series B): 

 
Note: A replacement filter kit is available (Catalog No.  6189–

FAN2FIL).  This kit contains a chassis fan filter (includes 
retainer).   

 
1. Disconnect all power from the 6180 Computer. 

Figure 16- 1 

 

Cleaning the Chassis Fan 
Filters 
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2. Pull the tab to gain access to the system filter. 

3. Clean with soap and water. 

4. Re-install the filter. 
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Clean the power supply fan filter at least once a month under normal 
conditions.  You may need to clean the filter more frequently if the 6180 
Computer is located in an area with high dust levels. 

 

 

ATTENTION:  Disconnect all power from the 6180 
Computer before removing components.  Failure to 
disconnect power could result in severe electrical shock 
or damage to the 6180 Computer. 

 
To clean the power supply fan filter: 

 
Note: The Pentium II product does not have a power supply fan 

filter. 
 
 

Note: A replacement filter kit is available (Catalog No.  6189–
FANFIL).  This kit contains a chassis fan filter (includes 
retainer) and a power supply filter. 

 
1. Disconnect all power from the 6180 Computer. 

2. Remove the back panel and accessory drive panel.  See page 4-2. 

3. Remove the power supply filter.. 

Figure 16- 2 

 
 
 

Cleaning the Power 
Supply Fan Filter 
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4. Clean the filter with soap and water and allow to dry before 
installing. 

5. Install filter.  Note:  Filter is rectangular not square make sure it is 
oriented correctly. 

6. Install the back panel.  See Chapter 4. 
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Description Catalog Number 
ENCLOSURE:  

  
  
  
  

BEZEL:  
  
  
  

CPU CARD:  
  
  
  
  
  
  
  

COMPUTER:  
  
  
  
  

6181 COMMON PARTS:  
  

 
 

 

 

 

 

Replacement Parts 
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Electrical  

AC Power  

 Supply Voltage 
Limits  

Refer to separate power supply publication provided with 
computer. 

 Power 
Consumption 

475 VA maximum 
 

Total Power Available 
PCI and ISA Slot Cards 

 
+5V  .  .  .  .  .  12A 
+3.3V  .  .  .  .3.5A 
+12V  .  .  .  .  1A 
–5V  .  .  .  .  .  0.2A 
–12V  .  .  .  .  0.5A 

Mechanical  

Enclosure  

 Versions with 
Bezel Gasket 

NEMA Types 1, 4/4X (indoor), 12, 13 
IEC IP54 IP65 

 Versions without 
Bezel  Gasket 

NEMA Type 1 and IEC IP2X 
 

LED Indicators (if present)  

 Power On Green 

 Hard Drive 
Read/Write Access 

Green 

 Overtemperature Red 

 Numeric Lock 
On 

Green 

 Caps Lock On Green 
 

Weight  

 No Display, 
Metal Bezel  

11.25 kg (25 lbs) 

 All Other Models
  

15.75 kg (35 lbs) 
 

Appendix Appendix Appendix Appendix A    
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Dimensions (overall) − 
Series B  

 

 No Display, 
Metal Bezel mm 

317.5 (H) x 482.6.0 (W) x 177.8 (D) 

  
  inches 

12.5 (H) x 19.0 (W) x 7.00 (D) 
 

 All Other Models
  mm 

355.6 (H) x 482.8 (W) x 211.15 (D) 

  
  inches 

14.0 (H) x 19.0 (W) x 8.375 (D) 
 

Cutout Dimensions  
(All Models) 
  mm 

 
429.26 (W) x 325.39 (W) 

  
  inches 

16.9 (W) x 12.85 (H) 
 

19 Inch Rack EIA Units 8U 
 

 
 

Display  (if present)  

10.4 inch (264 mm)   

 Type  Thin Film Transistor Liquid Crystal Display (TFT-LCD) 

 Touch Cells 
(Touchscreen) 

_ 1000 x 1000 touch points 

 Touch Cell Size
  

_ .21 X .16 mm
2 

 

12.1 inch (??? mm)   

 Type  ??? 

 Touch Cells 
(Touchscreen) 

??? 

 Touch Cell Size
  

??? 

15 inch (384 mm)   

 Type  Thin Film Transistor Liquid Crystal Display (TFT-LCD) 

 Touch Cells 
(Touchscreen)  

_ 1000 x 1000 touch points 

 Touch Cell Size
  

_ .30 X .23 mm
2 

 
 

Environment  

Operating Temperature 5 to 50° C (41 to 122° F) 
 

Storage Temperature
  
  

–25 to 60° C (–13 to 140° F) 
 

Relative Humidity 8 to 80% (non–condensing) 
 

Heat Dissipation 
   

210 Watts (716 BTU/hr) 
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Shock and Vibration  

Impulse Shock  
 operating 
 non–operating 
 

 
15G (1/2 sine, 11 msec) 

30G (1/2 sine, 11 msec) 

Vibration Operating Swept sine input, 
0.006 inch displacement 10–57 Hz 
1.0g acceleration 57–150 Hz 
 

Agency Certifications UL/cUL 508/1950 

FCC class A 

CE marked for all applicable directives 

   EMC EN 50081–2/82–2 
   LVD EN 60950 

 
The following table provides operating and technical specifications of 
the available power supplies: 

 
Phase 1 and 2 160 Watt Supply 210 Watt Supply 

Input Voltage 100 to 120V AC RMS 100 to 120 AC RMS 

 200 to 240V AC RMS 200 to 240V AC RMS 

Min.  and Max.  Voltages 1 90 to 135V AC RMS 
180 to 265V AC RMS 

85 to 135V AC RMS 
170 to 265V AC RMS 

Input Voltage Selection Input Selector Switch Automatic 

Input Frequency 47 to 63 Hz 47 to 63 Hz 

Output Power at 50°C 160 Watts 210 Watts 

Operating Temperature 10 to 50°C (40 to 122°F) 0 to 50°C (32 to 122°F) 

Shock 15G 
30G Non–Operating 

15G Operating  
30G Non–Operating 

Vibration 1G Operating, 2G Non-
operating 

1G Operating, 2G Non-
operating 

Thermal Shutdown No Yes 

Voltage Holdup Time 17msec at 115V AC  
and full power 

20msec at 85V AC 
and full power 

1 These voltages are operating limits not recommended operating voltages.  Refer to Input 
Voltage specifications for recommended supply voltage ranges. 

 
 

 
Phase 3 180 Watt Supply for Slot 1 CPUs 

Input Voltage 100 to 120 AC RMS 

 200 to 240V AC RMS 

Min.  and Max.  Voltages1 85 to 135V AC RMS 
170 to 265V AC RMS 

Input Voltage Selection Automatic 

Input Frequency 47 to 63 Hz 
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Output Power at 50°C 180 Watts 

Operating Temperature 0 to 50°C (32 to 122°F) 

Shock 15G Operating  
30G Non–Operating 

Vibration 1G Operating, 2G Non-operating 

Thermal Shutdown Yes 

Voltage Holdup Time 20msec at 85V AC 
and full power 

1 These voltages are operating limits not recommended operating voltages.  Refer to Input 
Voltage specifications for recommended supply voltage ranges. 
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 DC Input 200 Watt Supply 

Input Voltage 24 V DC 

Min.  and Max.  Voltages1 18-32 V DC 

Output Power at 50°C 200 Watts 

Operating Temperature 0 to 50°C (32 to 122°F) 

Storage Temperature -30 to 70°C (-22 to 158°F) 

Shock 20G Operating  
30G Non–Operating 

Vibration 1G Operating 
2G Non–Operating 

Thermal Shutdown Yes 

 
 

 
Phase 4 210 Watt Supply  

Input Voltage ??? 

  

Min.  and Max.  Voltages1 ??? 

Input Voltage Selection ??? 

Input Frequency ??? 

Output Power at 50°C ??? 

Operating Temperature ??? 

Shock ??? 

Vibration ??? 

Thermal Shutdown ??? 

Voltage Holdup Time ??? 
1 These voltages are operating limits not recommended operating voltages.  Refer to Input 
Voltage specifications for recommended supply voltage ranges. 
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European Union Directive European Union Directive European Union Directive European Union Directive 
ComplianceComplianceComplianceCompliance    

If the 6180 Industrial Computer is installed within the European Union 
or EEA regions and has the CE mark, the following regulations apply. 

EMC Directive 

This apparatus is tested to meet Council Directive 89/336/EEC 
Electromagnetic Compatibility (EMC) using the following standards, in 
whole or in part: 

• EN 50081–2:1993   EMC - Generic Emission Standard,  
Part 2 - Industrial Environment 

• EN 50082–2:1995   EMC - Generic Immunity Standard,  
Part 2 - Industrial Environment 

The product described is intended for use in an industrial environment. 

LV Directive 

This apparatus is designed and tested to meet Council Directive 
73/23/EEC Low Voltage Directive (LVD) using the following standards, 
in whole or in part: 

• EN 60950 with all national deviations 

• UL 508 

• UL 1950 

Intended Use of Product 

According to these Standards, the factor which determines, for EMC 
purposes, whether an apparatus is deemed to be “Industrial” or 
“Residential, commercial and light industrial”, is given in Clause 1 of 
EN50081–2 as follows: 

Apparatus covered by this standard is not intended for connection to a 
public mains network but is intended to be connected to a power network 
supplied from a high– or medium–voltage transformer dedicated for the 
supply of an installation feeding a manufacturing or similar plant. 
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The 6180 Industrial Computers are intended for use solely in an 
industrial environment as defined above.  When installed in Europe, any 
other application is in contravention of European Union Directives, and a 
breach of these laws. 

Wiring Recommendations 

To reduce electrical noise, connect the 6180 Industrial Computer to its 
own branch circuit.  The input power source should be protected by a 
fuse or circuit breaker rated at no more than 15 Amps.  Route incoming 
power to the 6180 Industrial Computer by a separate path from the 
communications cables. 

Where power and communications lines must cross, they should cross at 
right angles.  Communications lines can be installed in the same conduit 
as low level DC I/O lines (less than 10 Volts). 

Declarations of Conformity 

The Declaration of Conformity is available at the Rockwell Automation / 
Allen–Bradley Internet site: www.ab.com   
This document declares that the computers conform to the applicable 
directives. 

 

 

 

 

 

 

 



 

 

Field Replacement Units (FRU)Field Replacement Units (FRU)Field Replacement Units (FRU)Field Replacement Units (FRU)    

The replacement units 6189-FD144 and 6189-CD-ROM include the 
following items: 

• Floppy drive or CD-ROM drive 

• IDE cable 

For additional information on mounting brackets and covers, refer to 
6180 Accessory Mounting Brackets and Covers publication. 

AppendixAppendixAppendixAppendix    C    
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BIOS 

Acronym for Basic Input/Output System.  A set of low level routines 
stored in the 6180 Industrial Computer's Read Only Memory (ROM) that 
application programs use to interact with hardware such as a keyboard, 
mouse, add-in card, accessory drives, and printer. 

BIOS Setup 

Menu driven program for viewing and changing the BIOS.  Pressing the 
[F1] key while the system is booting up, accesses the BIOS Setup. 

CPU 

Acronym for Central Processing Unit.  The formal terminology for the 
6180 Industrial Computer Intel Pentium processor chip. 

DMA 

Acronym for Direct Memory Access. 

DIMM 
Acronym for Double In Line Memory Module.  These memory chips add 
RAM to a computer. 

IDE 

Acronym for Integrated Device Electronics.  A drive interface 
specification for hard disks up to 4 GB capacity.  The 6180 Industrial 
Computer has 2 IDE connectors. 

IrDA 

Acronym for Infrared Data Association.  The 6180 Industrial Computer 
IrDA (not on all versions) provides a high speed wireless link between a 
PC and other devices also having an IrDA receiver / transmitter. 

IRQ 

Acronym for Interrupt Request. 

AppendixAppendixAppendixAppendix    D    
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ISA 

Acronym for Industry Standard Architecture.  The 8 and 16 bit bus 
design for add-in cards featured in the IBM PC/AT. 

KIC 

Acronym for Keyboard Interface Card.  An Isa based, multi-purpose I/O 
board that provides an interface for the input devices such as keyboard, 
mouse, touchscreen, and front panel keys (if present). 

KIC Configuration Utility 

Offline software tool for configuring the KIC card.  This utility allows a 
user to customize the operation of an input device.  Typically the KIC 
Configuration Utility is used to map the keys located on the front panel 
of some versions of the 6180 Industrial Computer. 

LCD 

Acronym for Liquid Crystal Display.  A display technology that relies on 
polarizing filters and liquid crystal cells rather than phosphorous 
illuminated by electron beams to produce a screen image. 

PCI 

Acronym for Peripheral Component Interconnect Bus.  A 32/64 bit local 
bus architecture developed by DEC, IBM, Intel and others that is widely 
used in Pentium based personal computers.  A PCI bus provides a high 
bandwidth data link between system board components. 

Pentium 

A processor chip made by Intel that uses a 64-bit internal architecture. 

Plug and Play 

Also shown as PnP.  A specification developed by Intel and Microsoft 
that makes many computers and peripheral devices self configuring by 
determining their own DMA, IRQ, and address.  Part of Windows 95, 
Plug and Play requires an operating system with PnP BIOS. 

RAM 

Acronym for Random Access Memory, the main computer operating 
memory.  Programs and data must first be loaded into RAM and 
executed or processed from there.  RAM is volatile, losing its contents 
when power is removed. 
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SIMM 

Acronym for Single In Line Memory Module.  These memory chips add 
RAM to a computer.  The most popular format is the 72-pin SIMM 
which holds from I to 64 Mbytes.  SIMMs are available in different 
speeds, with typical response times of 50 to 80 nano seconds. 

SVGA 

Acronym for Super Video Graphics Array.  An extension of the VGA 
video standard.  SVGA enables video adapters to support resolutions of 
800 x 600 pixels and higher with up to 16.7 million colors. 

USB 

The Universal Serial Bus (USB) is a new external bus standard that 
supports data transfer rates of 12Mbps (12 million bits per second).  A 
single USB port can be used to connect up to 127 peripheral devices, 
such as mice, modems, and keyboards.  USB also supports Plug-and-
Play installation and hot plugging. 

Starting in 1996, a few computer manufacturers started including USB 
support in their new machines.  It is expected to be commonplace and to 
eventually replace serial and parallel ports completely. 

XGA 

Acronym for Extended Graphics Array.  This video standard was 
introduced in 1990 to replace the older 8515/A video standard.  It 
provides the same resolutions (640 by 480 or 1024 by 768 pixels), but 
supports more simultaneous colors (65,000 vs the 8514/A's 256).  In 
addition, XGA allows monitors to be non-interlaced. 

 

 

 





 

 

 

1 

10.4 in display version 
dimensions, 2-4 

12.1 in display version 
dimensions, 2-4 

6 

6181 Computer 
connectors, 1-3 
features, 1-2 
installation, 2-1 
operating recommendations, 3-1 
removing covers, 4-2 
specifications, A-1 
system checkout, 3-2 
versions, 1-1 

A 

Add-in cards 
adding or removing, 4-1 
thermal considerations, 4-1 

Air flow director, 4-7, 5-4, 5-6 

B 

Back cover, removing, 4-2 
Backlight 

dimming controls, 1-5 
removing the flat panel display, 9-1 
replacing tubes, 9-1 
replacing tubes, 10.4 in display version, 9-4 
replacing tubes, 12.1 in display version, 9-5 

BIOS 
accessing the BIOS Setup screen, B-2 
hardware diagnostics, 10-1 
settings, B-2 

C 

CD-ROM 
connecting, 7-1 
expansion bay, 6-1 

Clearances, 2-3 
Connectors, 1-3 
CPU card.  See also Add-in cards 
CPU specifications, B-1 
Cutout dimensions 

10.4 in display version, 2-7 
12.1 in display version, 2-8 

D 

Diagnostics, hardware, 10-1 
Dimensions, 2-5 

10.4 in display version, 2-4 
12.1 in display version, 2-4 
non-display version, 2-5 

Drive bay 
installing, 6-3 
removing, 6-2, 6-7 
replacing the floppy drive, 6-4 

Drives.  See Drive bay, Hard drive, Floppy drive, 
Expansion bay 

E 

Ethernet connections, 2-12 
Expansion bay 

exchanging drive cables, 6-5 
installing drives, 6-7 
installing or removing, 6-1 
installing the expansion bay, 6-7 

F 

Filter, chassis fan, 11-3 
Floppy drive 

installing or removing, 6-1 

IIIIndexndexndexndex    
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removing the drive bay, 6-2, 6-7 
replacing in the drive bay, 6-4 

H 

Hard drive 
installing or removing, 6-1 
removing the drive bay, 6-2, 6-7 

I 

Installation 
clearances, 2-3 
cutout dimensions, 2-7, 2-8 
dimensions, 2-4, 2-5 
keyboard, 2-10 
mounting hardware, 2-1 
mouse, 2-10 
network, 2-12 
NT networking, 3-3 
panel mounting, 2-9 
power, 2-11, 2-12 
tools required, 2-3 

K 

Keyboard connections, 2-10 

L 

LED indicators, 1-4, 10-1 

M 

Maintenance, 11-1 
cleaning the chassis fan filter, 11-3 
cleaning the display, 11-1 
replacement parts, 11-6, 11-7 

Memory modules 
installing or removing, 8-1 

Mouse connections, 2-10 

N 

Network connections, 2-12 
Networking for NT workstations, 3-3 
Non-display version 

dimensions, 2-5 

O 

Operation 
initial setup, 3-2 

Operator access, 3-1 

P 

Parts, 11-6, 11-7 
Power connections, 2-11, 2-12 
Power supply 

AC, 5-2 
installing or removing, 5-1 

R 

RAM memory.  See Memory modules 

S 

Setup, initial operation, 3-2 
Specifications 

CPU, B-1 
General, A-1 

T 

Top cover, removing, 4-2 
Touchscreen, connecting, C-1 
Troubleshooting 

check lists, 10-4 
hardware diagnostics, 10-1 
procedures, 10-3 
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V 

Versions of 6181 Computers, 1-1.  See also 10.4 in 
display version, 12.1 in display version, Non-
display version 
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