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1 SPATIAL ANALYSIS

1 SPATIAL ANALYSIS

StaƟsƟcal spaƟal analysis is defined as a set of techniques for studying data which are located in space
viewed in relaƟonship with the surface of the Earth. ParƟcular techniques of spaƟal analysis are used
in diverse areas of science, from medicine (epidemiology), through logisƟcs and physics, to economy
(finding the best locaƟons for plants, shops, etc.).

The development of themethods of spaƟal distribuƟon analysis and of the analysis of interrelaƟon-
ships among objects has been and is, to a large extent, determined by the development of informaƟon
technology. Computers with ever increasing compuƟng power, together with GIS systems, allow the
processing of large amounts of geographic data.

1.1 BASIC DEFINITIONS

Geographic InformaƟon System - GIS –is a system for entering, storing, processing, and visualizaƟon
of geographic data. From the technical point of view GIS is a tool which allows the analysis of
interrelated:

• informaƟon about spaƟal locaƟons of objects –represented by means of amap;
• descripƟve characterisƟc concerning objects presented on a map –represented by means

of a database.

Objects represented by means of a map are:

• Points –the locaƟon of which, in 2D, is defined with the help of two coordinates (x, y);
• MulƟpoints –they are points grouped in sets:

•

◦
• ◦

⋆

◦

•

◦◦
⋆

⋆

1)

1) An example of a mulƟpoint in which each point is defined as belonging to one of 3
groups.

• Lines –they are created by linking subsequent points, in proper order (lines can intersect);
• Polygons –they are closed spaces, restricted by means of external rings (closed lines which

do not intersect and which go through at least 3 points, in an appropriate order). Polygons
can also contain internal rings consƟtuƟng their internal boundaries. External rings are de-
fined clockwise and the internal ones the other way round.

Copyright ©2010-2014 PQStat SoŌware− All rights reserved 2



1 SPATIAL ANALYSIS

1) 2)

1) An example of a polygon which only has an external boundary (with no internal rings);
2) An example of a polygon which has both an external boundary and internal boundaries

(areas defined by the internal rings consƟtute a part of an external area, i.e. they do
not belong to the polygon).

Object aƩributes are entered into the base in the form of:
numbers –e.g. area, temperature,
texts –e.g. names of objects.

Map projecƟon is a mathemaƟcal method of mapping the surface of the Earth onto a map surface.
There is a number of methods for suchmapping. The mappings can be based on a spheroid or on
the surface of a ball (a sphere), or on a part of either of them. Each mapping forms the basis for
defining an appropriate coordinate system. Because each projecƟon of a surface entails certain
distorƟons (distorƟons of angles, areas, lengths), the choice of a proper system depends on the
aim for which the map is to be used.

Coordinate systems used in cartography are classified as:

• geographic coordinate systems (they define geographic laƟtude and longitude);

• cartesian coordinate systems;

• polar coordinate systems.

For a map to be loaded correctly, the program PQStat requires a vector map saved in a SHAPEFILE
(shp) type of file and defined in a proper Cartesian coordinate system, with line scale.

The program tries to automaƟcally detect maps with geographic coordinates. If, while imporƟng
the map, the program detects a geographic coordinate system, it suggests converƟng the coordi-
nates into a UTM system (Universal Transverse Mercator), on the basis of the WGS-84 system of
reference. As conversion might be incorrect (due to the use of many geographic coordinate sys-
tem and the lack of certainty with regard to the applied system), it is recommended that properly
prepared maps be used –in a Cartesian coordinate system.
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1 SPATIAL ANALYSIS

1.2 MAP OPENING

A map with the aƩribute file assigned to the map can be loaded via:

• import of a shapefile, SHP, into the datasheet,

• loading the PQS/PQX file which contains data from shapefiles (SHP).

Import of a Shapefile (SHP)
Import is made by choosing the menu opƟon File→Import data...→SHP/SHX/DBF ESRI Shapefile
(*.shp).

In the import window we can preview the imported map and its aƩributes saved in a DBF file. If the
directory fromwhichwe import contains all files necessary for loading themap then the correct reading
of appropriate files is confirmed in yellow by proper controls. AƩributes ascribed to a shapefile, in
the form of a DBF database, are not required for proper loading of a map. An aƩribute table can be
completed aŌer a map file has been loaded, by filling in proper cells of the datasheet linked with the
map.
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1.3 MAP MANAGER

The Map Manager is a tool for managing a map and the layers ascribed to the map. It is possible to
view both maps imported to the PQStat program and maps opened directly from an SHP file.

The Map Manager is acƟvated through the:

- menu Spacial analysis→Map Manager,
- buƩon on the tool bar,
- context menuMap Manager on the name of a datasheet linked to the map.

A map can be opened with the help of the Map Manager:

- menu File→Open file... –if we open a map from a shapefile (SHP),
-menuPlik→Project maps or buƩon on the tool bar –if we open amap from the PQStat
program,

or in the NavigaƟon tree of the PQStat program:

- context menuMap Manager on the name of the datasheet linked to the map.

The image which presents a map can be exported to a file in the BMP, PNG, or JPG format, by choosing,
in the Map Manager window:

- menu File→Export view....

Copyright ©2010-2014 PQStat SoŌware− All rights reserved 5
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1.3.1 Map Viewing Tools

Zoom in –allows to view a map in a larger scale and see its details;

Zoom out –allows to view a map in a smaller scale and see all its parts;

Adjust to the window –allows such a view of a map that the whole image is displayed in a window;

Select –allows to choose a rectangular part of a map, which will be enlarged and adjusted to the
window size;

Grabber –allows to move the image in the browser window so as to place a given part of the image
in a chosen posiƟon.

As we are browsing the map we also get a toolƟp concerning the ID and the name of the object we
point to with the cursor. The name is loaded from the data sheet, it is the variable indicated as acƟve
in the Map manager. By default, during import the first variable of the text type is set as acƟve.

We can get more informaƟon about the object pointed at by choosing the opƟon Identify from the
context menu. In the idenƟficaƟon window it is also possible to AcƟvate/DeacƟvate object.

1.3.2 SelecƟon Area Tools

CreaƟng and saving a selecƟon area allows to choose parts of a map which can later be subjected to a
separate analysis.

CreaƟng a SelecƟon Area
To select and save a selected area we choose Tools→Create selection area. Then, using the
mouse or filling in the fields in the upper part of theMapManager window, we select the chosen
part of a map (ellipƟcal or rectangular shape). The selecƟon is saved with the use of the buƩon
Save.

EdiƟon of a SelecƟon Area
The placement of each selecƟon area which was saved can be changed. In the ediƟon window
we can also delete a selecƟon area.
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That window is opened with the help of the menu Tools→Edit selection area, and closed with
the use of the buƩon Close.

DeleƟng All SelecƟon Areas
All selecƟon areas can be deleted with the use of the menu Tools→Delete all selection areas.

1.3.3 Layers

Both a map and elements added to it form layers. Layers are organized so that they only contain infor-
maƟon about objects of one type. The use of layered organizaƟon enables easy modificaƟon of only
selected objects.

The basic layer is the base layer containing a map. We can add new elements to that layer by creaƟng
new layers.

Adding Layers –to draw objects on subsequent layers choose the menu Feature Layers→Add Layer.

• Layer –Result of staƟsƟcal analysis
It is a layer created together with a report on the staƟsƟcal spaƟal analysis. It presents
the result of the staƟsƟcal analysis, appended to the report. The informaƟon about the
existence of layers one can draw on the map can be found at the boƩom of the report (the
buƩon ). The layer can also be addedwith the buƩon in theMapManager
window.
As long as there are no reports on staƟsƟcal spaƟal analysis, the opƟon window for analysis
results is empty. When there are such reports the opƟon window contains a list of layers.
The names of the layers on the list consist of the name of the report from which a layer
comes, together with the date and hour the report was created, and a descripƟon of the
type of objects drawn there.

• Layer –View of another map
That is a layer which presents a map related to another datasheet (the buƩon in the
Map Manager window). The map view can be a single layer or it can consist of a number
of layers. It cannot be edited directly. The change of the look of the view is only possible
when parƟcular layers forming that view and placed in a real locaƟon (i.e. linked to another
datasheet) are edited.
As long as there is only one datasheet related to a map in the project, the opƟon window
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of another map is empty. When there are several datasheets the opƟon window contains
a list of layers. The names of the layers on the list comprise the number and name of the
datasheet linked to the map and the name of the file from which the map was imported.

If themap is appendedwith amap view from another datasheet in such away that a circular
reference is made (e.g. map 2 is assigned a view of map 1, and map 1 is assigned a view
of map 2), then a message is displayed about a circular reference. The reference will be
managed but circular references are not advised.

• Layer –Centroid of a polygon –that is a layer of the point type.

A centroid of a polygon is a point lying within a polygon and represenƟng the center of mass
(O'Rourke J (1998)[9]).

Centroids can be drawn on the basis of calculaƟons made on the map –in such a case we
choose the opƟonDraw and calculate based on map data, or on the basis of exisƟng points
the coordinates of which are in the datasheet –we then choose the opƟon Draw based on
the datasheet.

• Layer –Center of a polygon –that is a layer of the point type.

A center is a point with coordinates of the X axis and the Y axis calculated as a mean from
the coordinates of points consƟtuƟng polygon verƟces.

Centers can be drawn on the basis of calculaƟons made on the map –in such a case we
choose the opƟonDraw and calculate based on map data, or on the basis of exisƟng points
the coordinates of which are in the datasheet –we then choose the opƟon Draw based on
the datasheet.

• Layer –Label for an object –that is a layer of the text type.

A label is any text or number concerning objects presented on a map. Objects can be de-
scribed by choosing from the datasheet a variable which contains proper labels.

• Layer –Bounding types –that is a layer of the polygonal type.

Min. Bounding - convex hull –that is the smallest convex polygon in which analysed objects
are enclosed (Yamamoto J.K. 1997 [14]);
Min. Bounding - rectangle –that is the smallest rectangle in which analysed objects are
enclosed;
Min. Bounding - circle –that is the smallest circle in which analysed objects are enclosed;
Rectangle from map bounding –that is a rectangle in which analysed objects are enclosed,
with coordinates of the lower leŌ-hand vertex = (minX , minY ) and of the upper right-hand
vertex = (maxX , maxY ).

Layer List –the layer list allows to check howmany visible layers consƟtute the received image (buƩon
on the tool bar).

The list also allows switching on and off visibility of a layer and changing the order in which layers
are added , ediƟng the layers , and deleƟng them . If the source of a layer (a report or
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a map linked to the layer) is removed then such a layer is automaƟcally removed from the layer
list.
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1.3.4 Map Style EdiƟon

We can edit map layers by choosing the buƩon in the map list. The manner of ediƟng depends on
the type of objects presented on a given map (points, mulƟpoints, lines, polygons). It is possible to
select the style of lines, color fill, and the level of its transparency. By default the coloring uƟlizes one
color only. In the case of layers represenƟng the base map there is a number of coloring methods.

Coloring Methods:

Full color –when thismethod is used, all objects will be coloredwith the use of the samemethod –with
the use of one color only (the buƩon Fill).

Color gradaƟon –when this method is used, objects will be colored according to the value assigned to
them in a selected datasheet variable (the buƩon Color gradation). For example, when coloring
a map which shows alƟtude, color shade for points lying higher will be different from that for
points lying lower. The variable according to which we will do the coloring should only contain
numerical values. If that is not the case then the object for which there is no numerical value is
not colored according to the coloring method chosen for that variable but has the default color
for the map.

Methods for variable breaks used in color gradaƟon:

• Natural Breaks (Jenks) –amethod inwhich a variable is broken into such classes that variance
in classes is minimized and variance among classes is maximized.

• QuanƟle Breaks –a method in which a variable is broken into classes with an equal number
of units.

Copyright ©2010-2014 PQStat SoŌware− All rights reserved 10
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1.4 HOW TO REDUCE A WORKSPACE).

Workspace is limited for the purpose of indicaƟng only those objects which will be subjected to the
analysis. Such objects are indicated in the program by acƟvaƟng or deacƟvaƟng them. InacƟve objects
are not subjected to staƟsƟcal analyses.

Manual acƟvaƟon/deacƟvaƟon of objects

• IndicaƟng a row in the data sheetwhich describes the appropriate object and selecƟng the
opƟon Activate/Deactivate from the context menu on its name;

• IndicaƟng an object on the map and selecƟng, from the context menu, the opƟon Acti-
vate/Deactivate or Identify→ Activate/Deactivate object.

AutomaƟc acƟvaƟon/deacƟvaƟon of objects

• SelecƟng objects on the basis of data sheet – for example, one can indicate as acƟve only
those shops which are groceries with an area not larger than 1000m2. In such a case, the
seƫng of appropriate condiƟons for selecƟng objects takes place in the window of Activa-
tion/Deactivation available aŌer selecƟng theEdit→Activate/Deactivate (filter)... menu.
A detailed descripƟon of the manners of selecƟon of that type can be found in the User
Manual - PQStat (Chapter: How to Reduce Data Sheet Workspace).

• SelecƟng objects on the basis of a map – for example, one could only disƟnguish those
shops which are within a rectangular or ellipƟcal area marked on a map. We select the
area with the use of the selecƟon area tools (see Chapter 1.3.2) and later acƟvate or deacƟ-
vate in the window Activate/Deactivate in the selection available aŌer selecƟng the Tools
→Activate/Deactivate in the selectionmenu in the window of the Map manager.

In order to acƟvate all objects one should select the Tools →Activate all menu in the window of the
Map manager or the Edit→Activate allmenu in the window of PQStat.
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1.5 GEOMETRIC CALCULATIONS

Geometric calculaƟons are formulas (read theUserManual - PQStat (Chapter: Formulas)). The formulas
can pertain data which describe map geometry and data visible in a datasheet.

• Formulas for data which describe map geometry - geometric/geographic functions
Data for transformaƟon are chosen from a shapefile (SHP)

Available formulas:
meanCenter (poly) - gives center coordinates for polygons,
centroid (poly) - gives centroid coordinates for polygons,
area (poly) - gives polygon areas,
perimeter (poly) - gives polygon perimeters.

• Formulas for data visible in a datasheet - creating maps
Available formulas:
map (points) - gives a vector map presenƟng points together with assigned datasheet.
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1.6 SPATIAL WEIGHTS MATRIX

SpaƟal relaƟons among objects presented on a map can be organized in the form of a matrix. The
matrices are calledweightsmatrices. Due to their large size and a great amount of detailed informaƟon,
weights matrices are not carriers of knowledge which could be presented directly in the results of a
conducted study but they form the basis of further analysis. The data included in the matrices are
usually treated as weights in spaƟal analyses and, in this manner, allow to use the informaƟon from the
map.

The simplest form of a weights matrix is a neighbor matrix. Neighbor matrix is a square table with
zeros on the main diagonal, where the neighborhood of objects is marked with a binary value (1 – for
neighboring objects, 0 – for non-neighboring objects).

nr 1 2 3 4 5 6 7 8
1 0 1 1 1 0 0 0 0
2 1 0 1 0 0 1 1 0
3 1 1 0 1 1 1 0 0
4 1 0 1 0 1 0 0 0
5 0 0 1 1 0 1 1 1
6 0 1 1 0 1 0 1 1
7 0 1 0 0 1 1 0 1
8 0 0 0 0 1 1 1 0

Table 1: Example of a neighbor matrix

In staƟsƟcal analyses the most commonly used matrices are row-standardized matrices with the values
of each of its rows summing to one. Row standardizaƟonmeans that each weight is divided by the sum
of a row (the sum of the weights of all neighboring elements). As a result, the obtained weights are in
the range from 0 to 1. The influence of objects with varying numbers of neighbors, in analyses based
on a weights matrix standardized in this way, is balanced.

nr 1 2 3 4 5 6 7 8
1 0 1/3 1/3 1/3 0 0 0 0
2 1/4 0 1/4 0 0 1/4 1/4 0
3 1/5 1/5 0 1/5 1/5 1/5 0 0
4 1/3 0 1/3 0 1/3 0 0 0
5 0 0 1/5 1/5 0 1/5 1/5 1/5

6 0 1/5 1/5 0 1/5 0 1/5 1/5

7 0 1/4 0 0 1/4 1/4 0 1/4

8 0 0 0 0 1/3 1/3 1/3 0

Selected weights matrices should reflect spaƟal relaƟonships which connect the analyzed objects. The
more realisƟc the reflecƟon of themodel of mutual influence of objects in space, themore exact results
will be obtained.

Thewindowwith seƫngs forweights matrices is accessed via themenuSpacial analysis→Tools→Spatial
weights matrix.
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1.6.1 Weights matrix according to distance

For creaƟng a weights matrix based on the distances of points we should have at our disposal data from
a map which contains objects such as a point, a mulƟpoint, or a polygon. In the case of an analysis of
polygons, calculaƟons are based on centroids, and in the case of mulƟpoints they are based on centers
of objects.

DescripƟon you can find in User Guide - PQStat, secƟon: the similarity matrix.

1.6.2 Weights matrix according to conƟguity

For creaƟng a weights matrix based on proximity of objects (conƟguity) we should have at our disposal
data from a map which contains objects such as a mulƟpoint or a polygon.

Type of conƟguity

The conƟguity is usually understood as a common secƟon with a non-zero length (i.e. a secƟon longer
than 1 point) – it is the Rook type neighborhood, or as any secƟon (also of zero length, i.e. a point) – it
is the Queen type neighborhood.

Weights matrix according to conƟguity:

• Immediate neighbors – it is a square symmetrical matrix in which on the main diagonal there are
zeros, the elements outside the diagonal are:

Copyright ©2010-2014 PQStat SoŌware− All rights reserved 14
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wij = 1 – if the objects are connected along a common border,
wij = 0 – in the opposite case.

• Neighbors (order of conƟguity <=k) – it is a square symmetrical matrix in which on the main
diagonal there are zeros, the elements outside the diagonal are:

wij = 1 – if the objects are direct neighbors (they are connected along a common border),
wij = 2 – if the objects are the second nearest neighbors (the second degree of neighbor-

hood, i.e. the so-called neighbor's neighbor)
...
wij = k – if the objects are the kth neighbors (kth degree of neighborhood)
wij = 0 – neighborhood is farther than the kth degree.

• Neighbors (order of conƟguity =k) – it is a square symmetrical matrix in which on the main diag-
onal there are zeros, the elements outside the diagonal are:

wij = 1 – if the objects are the kth neighbors (kth degree of neighborhood)
wij = 0 – in the opposite case.

Weightsmatrices can be row standardized – it is the recommendaƟon of some staƟsƟcal analyses based
on those matrices.

1.7 SPATIAL SMOOTHING

The idea of spaƟal smoothing is obtaining a beƩer (more stable and less noisy) value of the variable.
The most common methods of building such a variable are based on borrowing the informaƟon from
neighboring areas or on using a larger amount of informaƟon from the studied region.

1.7.1 Locally weighted averages

The method is based on transforming the value of the studied variableX with elements x1, x2, ..., xn
into a new, smoothed variable smooth(X) with elements smooth(x1), smooth(x2), ..., smooth(xn).
The transformaƟon consists of calculaƟng the arithmeƟc mean of the values of the variable X for the
studied object and its neighboring objects, in accordance with the given weights matrix. The zero ele-
ments of the main diagonal of the weights matrix are replaced with the value 1.

Locally weighted averages – simple
The value xi is transformed into the smoothed value smooth(xi) according to the formula:

smooth(xi) =

∑n
j=1wijxj∑n
j=1wij

Copyright ©2010-2014 PQStat SoŌware− All rights reserved 15
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n – the number of spaƟal objects (the number of points or polygons),
xi, xj – are the values of the variable for the compared objects,
wij – elements of the spaƟal weights matrix.

If the smoothing is made with the use of a neighbor matrix – which only carries the informaƟon
about the presence (1) or absence (0) of neighborhood, then smooth(xi) is really themean value
for the studied object and the neighboring objects. However, if a weights matrix is used – e.g.
according to the inverse Euclidean matrix inside a circle with the radius d – and it carries the
informaƟon about the real distance of objects, then the nearer objects will have a greater impact
on the result than farther objects, and the influence of objects outside of the circle will be zero.
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2 TESTING HYPOTHESES

VerificaƟon of staƟsƟcal hypotheses is checking certain assumpƟons formulated for parameters of a
general populaƟon on the basis of results from a sample.

FormulaƟon of hypotheses which will be verified with the help of staƟsƟcal tests.

Each staƟsƟcal test gives the general form of a null hypothesis –H0 and of an alternaƟve hypoth-
esis –H1:

H0 : in the studied populaƟon THERE IS NOT a staƟsƟcally significant
e.g. dependence,
e.g. difference,
...

between
e.g. spaƟal distribuƟon,
e.g. presence of parƟcular values,
...

in the analysed area,

H1 : in the studied populaƟon THERE IS a staƟsƟcally significant
e.g. dependence,
e.g. difference,
...

between
e.g. spaƟal distribuƟon,
e.g. presence of parƟcular values,
...

in the analysed area.

Example:

H0 : THERE IS NOT a staƟsƟcally significant dependence between the spaƟal distribuƟon
of chemist's shops in Wielkopolska –we assume that their distribuƟon in
the studied area is random.

If we do not know if the distribuƟon of the shops can bemore regular than randomdistribuƟon, or
the other way round –more clustered than random distribuƟon, then the alternaƟve hypothesis
should be two-sided, i.e. we do not presume a parƟcular direcƟon:

H1 : THERE IS a staƟsƟcally significant dependence between the spaƟal distribuƟon
of chemist's shops in Wielkopolska –we assume that their distribuƟon in
the given area is not random, i.e. we presume the presence of 2 direcƟons: a distribuƟon
which is more regular than random distribuƟon and a distribuƟon which is more clustered than
random distribuƟon.
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2 TESTING HYPOTHESES

It may happen (in very rare cases) that we are certain that we know the direcƟon in the alterna-
Ɵve hypothesis. We can then uƟlize a one-sided alternaƟve hypothesis.

Hypothesis VerificaƟon

To check which of the hypotheses,H0 orH1, is more probable, we select a proper staƟsƟcal test.

Test staƟsƟc of a chosen test, calculated according to its formula, is subjected to the theoreƟcal
distribuƟon appropriate for that staƟsƟc.

α/2 α/2

1− α

value of test staƟsƟc

The program calculates the value of a test staƟsƟc and p-value for that staƟsƟc (that is the part
of the area under the curve which corresponds to the value of the test staƟsƟc). Value p allows
to choose which hypothesis, the null hypothesis or the alternaƟve hypothesis, is more probable.
The truth of the null hypothesis is always presumed and the proofs gathered in the data are to
provide a sufficient number of arguments against that hypothesis:

if p ≤ α =⇒ rejectH0 and acceptH1,
if p > α =⇒ there is no reason to rejectH0.

Usually, significance level α = 0.05 is chosen with the acceptance of the premise that in 5%
of situaƟons the null hypothesis will be rejected being a true one. In special cases a different
significance level, e.g. 0.01 or 0.001, can be set.
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3 DESCRIPTIVE STATISTICS

To conduct DescripƟve StaƟsƟcs on the basis of a Map data we should have at our disposal a point,
mulƟpoint, or polygonal file. In the case of an analysis of a polygonal file, calculaƟons are based on
centroids of polygons, and in the case of a mulƟpoint file they are based on centers of objects.

Boundaries of an area in which analysed points are enclosed can be defined, depending on a parƟcular
need, with the help of: a convex hull, the smallest rectangle, a rectangle from from layer bounding, or
the smallest circle. The studied area can also be defined only with the use of the size of its area.

The distance between the points is measured with the Euclidean metric.

The basic staƟsƟcs made for point analysis:

• A –the area of a studied region,

• n –the size of a sample, i.e. the number of points lying within the studied region,

• D = n
A –density,

• descripƟve staƟsƟcs of the distance matrix between points:

– arithmeƟc mean with confidence interval,

– standard deviaƟon,

– median,

– quarƟles,

– minimum and maximum.

The analysis also gives a graph pertaining to a distance matrix and layers which can be drawn on the
surface of a map. Layers pertain to centrographic measures: the measure of central tendency and the
measure of dispersion:

• The center of point distribuƟon: the mean of coordinates of theX axis and the Y axis (x, y),

• The area of standard deviaƟons, built around the center, defined by:

– Circle
The radius of the circle is sdd –standard distance from the center ( standard distance devi-
aƟon) expressed with the formula:

sdd =

√∑n
i=1 x

′2
i +

∑n
i=1 y

′2
i

n− 2
,

where:
x

′
i = xi − x,

y
′
i = yi − y.

Copyright ©2010-2014 PQStat SoŌware− All rights reserved 19



3 DESCRIPTIVE STATISTICS

– Ellipse
The angle of the inclinaƟon of an ellipse axis (Y) with respect to the coordinate system (OY
axis) is expressed with the formula:

θ = arctan
(
A+B

C

)
,

where:

A =

n∑
i=1

x
′2
i −

n∑
i=1

y
′2
i ,

B =

√√√√( n∑
i=1

x
′2
i −

n∑
i=1

y
′2
i

)2

+ 4

(
n∑

i=1

x
′
iy

′
i

)2

,

C = 2

n∑
i=1

x
′
iy

′
i.

The lengths of the semiaxes of an ellipse:

σx =

√√√√ 2

n− 2

n∑
i=1

(
x

′
i cos θ − y

′
i sin θ

)2

σy =

√√√√ 2

n− 2

n∑
i=1

(
x

′
i sin θ + y

′
i cos θ

)2
– Rectangle

The lengths of rectangle sides are: a = 2sdx, b = 2sdy, where sdx and sdy are standard
deviaƟons for the coordinates of theX and Y axes

AŌer the weights for parƟcular objects have been defined, we calculate the weighted center of point
distribuƟon and the weighted circle represenƟng the standard deviaƟon area.

• The weighted center of point distribuƟon: the weighted mean of coordinates of the X axis and
the Y axis:

xw =

∑n
i=1wixi∑n
i=1wi

, yw =

∑n
i=1wiyi∑n
i=1wi

where:
wi –weights represenƟng the value of a feature in the ith object.

• Weighted circle
The radius of the circle is wsdd –weighted standard distance from the center expressed with the
formula:

wsdd =

√∑n
i=1wix∗2i +

∑n
i=1wiy∗2i∑n

i=1wi − 2
,

where:
x∗i = xi − xw,
y∗i = yi − yw.

Note
In the formulas concerning the lengths of the radius of a circle and of a semiaxis of an ellipse, the
denominator was decreased by value 2 –Buliung (2008)[2], Smith (2007)[10].
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3 DESCRIPTIVE STATISTICS

The windowwith seƫngs forDescriptive statistics is accessed via the menu Spacial analysis→ Spatial
descriptive statistics.

Eø�ÃÖ½� 3.1. (directory: snow, SHP files: deaths, pumps, streets)

Data for the analysis are probably the best known, classical example of the use of cartog-
raphy in epidemiology. They present the epidemic of cholera in London in 1854. The map
which presents the range of the epidemic wasmade by John Snow, a doctor and the discov-
erer of the cause of the epidemic, considered to be one of the founders of epidemiology.
The coordinates of points which consƟtuted the basis for drawing the maps come from the
original John Snow's mapwhich was digitalized by Rusty Dodson from the US NaƟonal Cen-
ter for Geographic InformaƟon Analysis (hƩp://ncgia.ucsb.edu/PublicaƟons/SoŌware/cholera/) and later
presented in meters.

- The map deaths contains informaƟon about the locaƟon of 578 points (deaths due to
cholera) in Soho –a London district.

- The map pumps contains informaƟon about the locaƟon of 13 points (water pumps)
in Soho.

- The map streets contains informaƟon about the locaƟon of lines (streets) in Soho.

AŌer imporƟng the above shapefiles (SHP) we can view and edit each of them in the Map
manager.

To conduct an analysis we select the deathsmap and perform theSpatial descriptive statis-
tics. Because we will uƟlize the map coordinates as data for the analysis, in the descrip-
Ɵve staƟsƟcs window we select the opƟon Use points from map coordinates and, as the
bounding type, we select the Convex Hull.
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The area in which there are the points (defined by the convex hull) is 0.257531km2. We
can draw them on the map by pressing the buƩon and selecƟng the layer
of object bounding.

There is on average over 2 points per 1000m2 (density=0.002244 points perm2).
The analysis of the point distance matrix allows a more exact evaluaƟon of their density.
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Some points are in the same place because the smallest distance is 0m. There are also
points at a far greater distance from each other –the greatest distance is 662.896352m.
We can also find informaƟon about the average distance and the standard deviaƟon of the
points here.

The most interesƟng informaƟon in the analysis of the deaths map is offered by the lo-
calized Center of point distribuƟon (703.79, 631.65), together with the area of standard
deviaƟons which describe the the degree of concentraƟon and the direcƟon of dispersion
(circle, ellipse, rectangle).

The ellipse of standard deviaƟons and the Center is drawn again by moving on to the map
manager (on the layer list we uncheck the bounding).

As a result of conversaƟons with local people, Snow suspected that water could have been
the source of the epidemic. When the three maps are joined we can idenƟfy the water
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pump the water from which turned out to be the cause of the epidemic. To find it we
should first display the streets map in the Map Manager and next we should overlay the
deathsmap and the pumps onto it by pressing the buƩon .

The source of the epidemic turned out to be the water pump on the Broad Street (we
can display its label in the MapManager). That is the only pump which was in the selected
ellipƟcal area, and its locaƟon (678.85, 633.27) and the locaƟon of themiddle of the ellipse
(703.79, 631.65), i.e. the place around which the deaths centered, are very close to each
other.
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4 ANALYSIS OF THE RANDOMNESS OF POINT DISTRIBUTION

To conduct analysis of the randomness of point distribuƟon on the basis of a Map data we should have
at our disposal a point, mulƟpoint, or polygonal file. In the case of an analysis of a polygonal file,
calculaƟons are based on centroids of polygons, and in the case of a mulƟpoint file they are based on
centers of objects.

The effect of uniform dispersion appears when points are distributed more regularly than the possible
result of randomdistribuƟon. If the spaƟal distribuƟon is as probable as any other distribuƟonwe speak
about spaƟal randomness. When the points come in groups we speak about clustered distribuƟon.
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uniform distribuƟon random distribuƟon clustered distribuƟon

4.1 Nearest Neighbor Analysis

In the Nearest Neighbor Analysis the boundaries of the area in which the analysed points are enclosed
have the crucial influence on the result. The example below illustrates regularly distributed points and
their clustered distribuƟon when bounded by a large rectangle.

◦
◦◦
◦

Depending on the needs, the bounding can be defined with the help of: a convex hull, the smallest
rectangle, a rectangle from layer bounding, or the smallest circle. The studied area can also be defined
only with the use of the size of its area.
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The distance between the points is measured with the Euclidean metric.

The first stage of the nearest neighbor analysis is calculaƟng the distance among all points. Next, for
each point we search for the nearest point, i.e. for the nearest neighbor (NN ).

Note!
The distances between all points are defined by a spaƟal weight matrix. In Moran's analysis window
we can choose matrix generated previously by using menu Spatial analysis→Tools→ Spatial weights
matrix or indicate the neighbor matrix according to conƟguity – Queen, row standardized, that is pro-
posed by the program.

The basic staƟsƟcs for the analysis of the nearest neighbors are:

• di(NN) –the distance of each point from its nearest neighbor,

• NN –the mean nearest neighbor distance:

NN =

n∑
i=1

di(NN)

n

• SD(NN) –standard deviaƟon of the nearest neighbors distance,

• ran –mean random nearest neighbor distance:

ran =
0.5√

n
A

Nearest Neighbor Index

Nearest Neighbor Index ( NNI) is based on a method described by botanists: Clark and Evans
(1954) [3]. NNI compares distances observed between the nearest points, and distances which
would appear for a random distribuƟon of points.

NNI =
NN

ran

When the compared distances are the same then NNI = 1. When the observed distances be-
tween the nearest points are smaller than expected then the points are nearer to one another
than in a random distribuƟon, andNNI < 1. In such a case, clusters occur. When the situaƟon
is reverse, thenNNI > 1, which points to the occurrence of the effect of uniform distribuƟon,
i.e. points are distributed more regularly than in a case of random distribuƟon.

Significance of the Nearest Neighbor Index

The test for checking the significance of the Nearest Neighbor IndexNNI serves the purpose of
verifying the hypothesis that the distances observed between the nearest points are the same as
the expected distances which would appear in a random distribuƟon of points.

Hypotheses:

H0 : NNI = 1,
H1 : NNI ̸= 1.
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The test staƟsƟc has the form presented below:

Z =
NN − ran

SEran
,

where:

SE(ran) =
√

4−πA
4πn2 –standard error of the mean random

nearest neighbor distance

StaƟsƟcs Z asymptoƟcally (for a large sample size) has the normal distribuƟon.

Value p, defined on the basis of test staƟsƟcs, is compared with the significance level α :

if p ≤ α =⇒ we rejectH0 and acceptH1,
if p > α =⇒ there is no reason to rejectH0.

Analysis of Subsequent Nearest Neighbors

To analyse subsequent nearest neighbors one takes into account the distance to the second near-
est neighbor, the third nearest neighbor, and so on, to the k-order nearest neighbor. For the
neighborhood of each order (from the nearest neighbor to the k-order neighbor) subsequent
Nearest Neighbor Indexes korderedNNI are calculated:

korderedNNI =
korderedNN

korderedran

where:
korderedNN –mean distance from neighbors of k-order,

korderedran =
k(2k)!

(2kk!)
2√ n

A

–mean random distance from neighbors of k-order.

The results of the point density analysis conducted for subsequent neighbors can be presented
on a graph so as to illustrate the placement of NNI in reference to the line which shows the
random point structure and so as to check if a growing or falling trend has been achieved for the
indexes.

Edge Effect

Objects placed near the bounding show a tendency to be further away from their nearest neigh-
bors than other objects within the analysed area. The reason for it is the simple fact that the
nearest neighbors of the objects near the border can be objects outside the studied area. In such
a situaƟon we can conduct an analysis with an adjustment for the edge effect. In such a case the
distance of a point from its nearest neighbor (di(NN)) is calculated as the minimum distance of
the point from its neighbors and from the boundary. Thus, if the distance of the point from the
boundary will be smaller than the distance from its neighbors, then the distance from the bound-
ary is considered to be di(NN). However, such a calculaƟon of the nearest neighbor requires
an assumpƟon that there will always be a neighboring point on the border.

The window with seƫngs for Nearest Neighbor Analysis is accessed via the menu Spacial analysis→
Spatial Statistics→ Nearest Neighbor Analysis.
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Eø�ÃÖ½� 4.1. (directory: districts, SHP files: districts)

The admistraƟve division of Poland into powiats should, by definiƟon, be uniform. With
the use of NNI we will check if that is the case.

- The districtsmap contains informaƟon about locaƟons of polygons (Polish powiats).

The nearest neighbor analysis will be based on centroids represenƟng powiats. We can
draw them (add the centroid layer to themap of powiats) with the use of theMapmanager.
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The nearest neighbor analysis will be made with the use of informaƟon about the size of
the area of Poland –it is 311888000000m2. Apart from the nearest neighbor index we will
also calculate the indices of subsequent neighbors, up to 15.

AŌer entering the size of the area in the analysis window, a nearest neighbor index amount-
ing to 1.37127 was received. Its staƟsƟcal significance was (p < 0.000001), greater than
value 1. The mean distance between the nearest neighboring centroids is 19668.564923m
and the standard deviaƟon is 9102.84769m. We will receive a very similar result when
we return to the analysis (the buƩon ) and choose the convex hull as the bounding
(NNI = 1.382828, p < 0.000001).

We add the boundaries defined by the convex hull by pressing the buƩon
and choosing the layer of bounding.
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The correcƟon of the effect of a boudary defined in this way lowers the value of NNI
to 1.340503 but leaves the general tendency of the subsequent nearest neighbor indices
unchanged.

In each of the analysis described above the subsequent neighbor indices are greater than 1
and, although they iniƟally approximate 1, from order 5 they stabilize at the level of about
1.1. The result, then, confirms the uniform distribuƟon of Polish powiats.

Eø�ÃÖ½� 4.2. (directory: poplar, SHP files: T-poplar, S-poplar)
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CompeƟƟon among species has an influence on the changes in the distribuƟon of parƟcu-
lar species of plants and on their density. CompeƟƟon within a species is usually stronger
than that among different species as members of the same species have almost idenƟ-
cal demands and compete for the same resources. The intensity of compeƟƟon within a
species increases with the growth of the populaƟon. To check the influence of the com-
peƟƟon on a certain species of balsamic poplar, a wooded area not regulated by man was
studied. LocaƟons of young trees and of old ones were studied.

- Mapa T-poplar contains ficƟƟous informaƟon about the locaƟons of 121 points (old
balsamic poplars) in a rectangular wooded area.

- MapaS-poplar contains ficƟƟous informaƟonabout the locaƟons of 326points (young
balsamic poplars) in a rectangular wooded area.

On the map young poplars were marked in red and old poplars were marked in blue.

On the basis of the nearest neighbor indices, the structure of poplar density was compared
in the area defined by a rectangle of layer bounding.
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Young poplars have greater density than old ones. Their mean nearest neighbor distance
is 103.12m whereas for old poplars the value is 282.27m. Due to compeƟƟon in the de-
velopment of the structure of forest stand the spaƟal paƩern for old trees is more regular
(NNI = 1.68, p < 0.000001) than the one for young poplars (NNI = 1.01, p = 0.8498).
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5 SPATIAL AUTOCORRELATION

To conduct spaƟal autocorrelaƟon on the basis of a Map data we should have at our disposal a point,
mulƟpoint, or polygonal file. In the case of an analysis of a polygonal file based on the calculaƟon of
objects distances, calculaƟons are based on centroids of polygons, and in the case of a mulƟpoint file
they are based on centers of objects.

An analysis of the phenomenon of autocorrelaƟon is based on values assigned to spaƟal objects. SpaƟal
autocorrelaƟon means that the values of geographically near objects are more similar to one another
than those of remote objects. The phenomenon causes the creaƟon of spaƟal clusters with similar val-
ues.

SpaƟal autocorrelaƟon may not occur – we then speak of spaƟal randomness. The obtained spaƟal
distribuƟon is as probable as any other distribuƟon. When the neighboring values are similar to one
another we can speak about posiƟve autocorrelaƟon. NegaƟve autocorrelaƟon occurs when the values
of neighboring areas are more varied than in the case of random distribuƟon.
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negaƟve autocorrelaƟon a lack of autocorrelaƟon posiƟve autocorrelaƟon
When analyzing autocorrelaƟon we can consider a dichotomous variable (i.e. the presence or absence
of a given feature) or a variable withmany categories, poinƟng to the degree of intensity of the analyzed
feature.

For a dichotomous variable the analysis of posiƟve autocorrelaƟon consists of searching for clusters
with the same value. Usually, objects in which the studied phenomenon occurs are marked in black
color on the map, and the ones in which the phenomenon does not occur are marked in white color.
Clusters of objects of the same color – the so-called "black-black","white-white" – are looked for.

For a variable which describes the degree of intensity of a studied feature the analysis of posiƟve auto-
correlaƟon consists of searching for clusters with similar values. Usually, objects on themap are colored
in accordance with the degree of intensity of the studied phenomenon, from the lightest (low values)
to the darkest (high values). Clusters of objects with a similar shade are looked for.

5.1 Global Moran's I staƟsƟc

It is an analysis of the degree of intensity of a given feature in spaƟal objects.
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We use two pieces of informaƟon for the construcƟon of a coefficient which will allow to check if the
neighboring objects form clusters with similar values of the variable:

1. informaƟon about the values of a variable for parƟcular objects xi,

2. informaƟon about which objects are neighbors – weights matrix with elements wij .

Note!
The objects neighborhood is defined by a spaƟal weight matrix. In Moran's analysis window we can
choose any matrix generated previously by using menu Spatial analysis → Tools → Spatial weights
matrix or indicate the neighbor matrix according to conƟguity – Queen, row standardized, that is pro-
posed by the program.

Note!
It is not recommended to conduct Moran's analysis for objects without neighborhood (objects de-
scribed in the weight matrix only with the 0 value). Such objects can be excluded from the analysis
by deacƟvaƟng them or an analysis can be made with the use of a different manner of defining neigh-
borhood (a different weight matrix).

Moran's I coefficient – introduced by Moran in 1948 [8].

In order to check if the selected objects are characterized by similar values of the variable one can
use themulƟplying rule which says that mulƟplying 2 posiƟve numbers gives a posiƟve result and
mulƟplying 2 different numbers (1 posiƟve and 1 negaƟve) gives a negaƟve result. With the use
of this rule we calculate

∑∑
xixj . Unfortunately, as the results of that rule are only obtained

when there are both posiƟve and negaƟve values, the simple rule must be modified so as to
ensure the presence of different signs. The values of the variable will, then, be replaced in the
earlier formula with the differences of the values of the variable and of its mean value. In this
way the objects with values smaller than themean will be negaƟve and those with values greater
than themean will be posiƟve:

∑∑
(xi−x)(xj−x). Obviously, the summaƟon should concern

neighboring objects, which means that, at this point, informaƟon fromweights matrices must be
used: ∑∑

wij(xi − x)(xj − x)

In this way non-neighboring objects obtain the weight value 0, for which reason the values of
those objects are not added. Further operaƟons which change the formula obtained in this man-
ner are made with the view to making the obtained coefficient I independent from the number
of analyzed objects and to standardizing it so that its values are limited to the interval< −1; 1 >.
As a result, Moran's autocorrelaƟon coefficient is expressed with the formula:

I =

∑n
i=1

∑n
j=1wij (xi − x) (xj − x)

S0σ2

where:
n – the number of spaƟal objects (the number of points or polygons),
xi, xj – are the values of the variable for the compared objects,
x – it is the mean value of the variable for all objects,
wij – elements of the spaƟal weights matrix (weights matrix row standardized),
S0 =

∑n
i=1

∑n
j=1wij ,

σ2 =
∑n

i=1(xi−x)2

n – variance
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Figure 1: Moran's diagram

Moran's linear autocorrelaƟon coefficient I studies the strength of the linear relaƟonship be-
tween the standardized variable X (stand(xi)) and the spaƟal lag of the variable X (L(xi)).
SpaƟal lag is the weighted mean from the standardized values of neighboring objects

L(xi) =

N∑
j=1

wijstand(xj).

A graphic presentaƟon of spaƟal autocorrelaƟon isMoran's scaƩer plot. Points in the first quarter
(HH) and in the third quarter (LL) are objects surrounded by similar neighbors: HH (high-high) –
objects with high values, surrounded by objects with high values; LL (low-low) – objects with
low values, surrounded by objects with low values. Points in the second quarter (LH) and the
fourth quarter (HL) are objects surrounded by neighbors not similar to them. LH (low-high) –
objects with low values, surrounded by objects with high values; HL (high-low) – objects with
high values, surrounded by objects with low values.

The belonging to and distribuƟon of points in the four quarters of Moran's diagram indicates the
type of autocorrelaƟon. If points are distributed mainly in the second quarter (LH) and fourth
(HL) – it is a sign of negaƟve correlaƟon, if they belong mainly to the first quarter (HH) and third
(LL) – it is a sign of posiƟve correlaƟon. If the points are distributed evenly in all four quarters
then spaƟal autocorrelaƟon does not exist.

On the Moran's diagram there is a regression line, the direcƟon of which also allows to interpret
Moran's coefficient I:

• I > 0 indicates the presence of clusters of similar values – posiƟve autocorrelaƟon, i.e.
measurement points lie near the straight line, and the increase of the variable standX is
reflected in the increase of the variable L(X);

• I < 0 indicates the presence of the so-called hot spots, i.e. decidedly different values in
neighboring areas – negaƟve autocorrelaƟon, i.e. measurement points lie near the straight
line but the increase of the variable standX is accompanied by a decrease of the variable
L(X);
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• I ≈ 0 indicates randomdistribuƟon of the studied value in space – a lack of autocorrelaƟon,
i.e. the obtained spaƟal distribuƟon is as probable as any other distribuƟon.

The square of Moran's coefficient I2 informs about the degree (it is a percentage) to which the
value of the variable in the object i is explained by the value of that variable in neighboring ob-
jects.

Note!
When the values of a studied feature are characterized by a great variability of variance then it is
desirable to stabilize that variability. The basic informaƟon about smoothing variables have been
described in the Chapter 1.7 SPATIAL SMOOTHING

Significance of Moran's autocorrelaƟon coefficient

A test for checking the significance of Moran's autocorrelaƟon coefficient serves the purpose of
verifying the hypothesis about a lack of correlaƟon between standX and spaƟal lag L(X).

Hypotheses:

H0 : I = 0,
H1 : I ̸= 0.

The test staƟsƟc has the form presented below:

Z =
I − E(I)√

var(I)
,

where:
E(I) =

−1

n− 1
– the expected value,

var(I) – variance.

Depending on the assumpƟon concerning the distribuƟonof the populaƟon fromwhich
the sample has been taken, the manner of selecƟng variance is chosen (Cliff and Ord
(1981)[4], and Goodchild (1986)[7]). If it is normal distribuƟon, then:

var(I) =
n2S1 − nS2 + 3S2

0

S2
0(n

2 − 1)
− E(I)2,

where:
S1 =

1
2

∑n
i=1

∑n
j=1 (wij + wji)

2,

S2 =
∑n

i=1

(∑n
j=1wij +

∑n
j=1wji

)2
.

If it is random distribuƟon, then:

var(I) =
n
(
(n2 − 3n+ 3)S1 − nS2 + 3S2

0

)
(n− 1)(3)S2

0

−
K2

(
(n2 − n)S1 − 2nS2 + 6S2

0

)
(n− 1)(3)S2

0

−E(I)2,

where:
K2 =

n
∑n

i=1(xi−x)4

(
∑n

i=1(xi−x)2)
2 ,

n(b) = n(n− 1)(n− 2)...(n− b+ 1).

StaƟsƟcs asymptoƟcally (for a large sample size) has the normal distribuƟon.

On the basis of test staƟsƟcs, p value is esƟmated and then compared with the significance level
α :
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if p ≤ α =⇒ we rejectH0 and acceptH1,
if p > α =⇒ there is no reason to rejectH0.

Thewindowwith seƫngs forMoran’s analysis is accessed via themenuSpacial statistics→Tools→Moran’s
global I statistic.

Eø�ÃÖ½� 5.1. (catalog: leukemia, file: leukemia.pqs)

The analysis will concern the data gathered and analyzed by L.A. Waller and others in
1992[11] and 1994[12], described on 281 objects in 2004[13].

- The map leukemia contains informaƟon about the locaƟon of 281 polygons (census
tracts) in the northern part of the state of New York. The map is prepared in the set
of flat rectangular coordinate system UTM 18N and is based on the data of the file
BNA (Boundary File) available on the server CIESIN Ōp.ciesin.columbia.edu

- Data for the map leukemia:
- Column CASES – the number of cases of leukemia in the years 1978-1982, as-
cribed to parƟcular objects (census tracts). The value should be an integral num-
ber, however, in agreement with Waller's (1994) descripƟon, some cases which
could not be objecƟvely ascribed to a parƟcular region have been divided propor-
Ɵonately. Hence, the numerousnesses of the cases ascribed to the 281 objects
are not integral numbers.

- Column POP – populaƟon size in parƟcular objects.
- Column prev – the frequency coefficient of leukemia per 100000 people, for each
object in one year: prev=(CASES/POP)*100000/5

Epidemiologically interesƟng are the regions in which the prevalence of leukemia is higher,
as their grouping could indicate the existence within their boundaries of environmental
teratogens causing an increased frequency of occurrence of leukemia.

We start from presenƟng the geographic distribuƟon of the frequency coefficient (prev)
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on the map. For that purpose we draw a map in the Map Manager and edit the layer ,
choosing Graduated colors:

We have at our disposal several ways of coloring a map – we choose coloring in accordance
with the values of the variable prev, dividing it into quarƟles:

Copyright ©2010-2014 PQStat SoŌware− All rights reserved 38



4 ANALYSIS OF THE RANDOMNESS OF POINT DISTRIBUTION

Dark colors on the map present the places with a higher frequency coefficient of leukemia,
whereas light places signify a lower frequency coefficient. In order to learn if their ge-
ographic distribuƟon is random or if they forms clusters, we will calculate Moran's coef-
ficient. Before calculaƟng that coefficient we should determine the manner of defining
neighborhood of regions and it is advisable to create an appropriate weights matrix. In
Moran's analysis window we can choose any matrix generated previously by using menu
Spatial analysis→Tools→ Spatial weights matrix or indicate the neighbormatrix accord-
ing to conƟguity – Queen, row standardized, that is proposed by the program.

Having generated the weights matrix we select the file leukemia and start Moran's analysis
by selecƟng the menu Spatial analysis→ Spatial statistics→ Global Moran’s I statistic.
In the analysis window we select the variable Prev and the neighbor matrix Queen, and
select the opƟon Add graph.
Moran's correlaƟon coefficient obtained in the analysis is small and has the value I =
0.048577:
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When we test the significance of Moran's coefficient we study the randomness of the dis-
tribuƟon of the frequency coefficient of leukemia in the studied region. We check if similar
shades on the map are located close to one another or not. In other words: we check if
the odds of having leukemia in the studied populaƟon depends on geographic locaƟon or
not. The value p calculated with the assumpƟon of randomness, as in the case of the as-
sumpƟon of normality, is greater than the standard assumed significance level 0.05, which
means that there is no evidence for autocorrelaƟon. Thus, we assume that the distribuƟon
of the variable prev is a random distribuƟon. Moran's diagram confirms that assumpƟon:

The existence of posiƟve autocorrelaƟon, inwhichwe are themost interested, would result
in the distribuƟon of the points of theMoran's diagram in quarters I and III. Here, however,
we see that the points are as frequent in quarters I and III as in II and IV.
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5.2 Global Geary's C staƟsƟc

Similarly to Moran's analysis, global Geary's staƟsƟc studies the degree of the intensity of a given fea-
ture in spaƟal objects.

Note!
It is not recommended to conduct Geary's analysis for objects without a neighborhood (objects de-
scribed in a weight matrix only with the value 0). Such objects can be excluded from the analysis by
deacƟvaƟng them (Chapter ??), or the analysis can bemadewith the use of a different manner of defin-
ing neighborhood (a different weight matrix).

Geary's autocorrelaƟon coefficient – introduced by Geary in 1954 [6].

It is one of the possible alternaƟves for the global Moran's staƟsƟc. Similarly to Moran's analysis,
Geary's staƟsƟc studies the degree of intensity of a given xi feature in spaƟal objects described
with the use of a weight matrix with wij elements. This Ɵme, instead of compuƟng the sum of
quoƟents:

∑∑
wij(xi − x)(xj − x) we compute the sum of the difference squares:∑∑

wij(xi − xj)
2

As a result, Geary's autocorrelaƟon coefficient is expressed with the formula:

c =

∑n
i=1

∑n
j=1wij(xi − xj)

2

2S0sd2

where:
n – the number of spaƟal objects (the number of points or polygons),
xi, xj – are the values of the variable for the compared objects,
wij – elements of the spaƟal weights matrix (weights matrix row standardized),
S0 =

∑n
i=1

∑n
j=1wij ,

sd2 =
∑n

i=1(xi−x)2

n−1 – variance,
x – it is the mean value of the variable for all objects.

The interpretaƟon of Geary's coefficient:

• c < 1 and c ≈ 0means the occurrence of clusters with similar values – a posiƟve autocor-
relaƟon;

• c > 1 means the occurrence of the so-called hot spots, i.e. disƟnctly different values in
neighboring areas – a negaƟve autocorrelaƟon;

• c ≈ 1means a random spaƟal distribuƟon of the studied variable – a lack of autocorrelaƟon.

Note!
When the values of a studied feature are characterized by a great variability of variance then it is
desirable to stabilize that variability. The basic informaƟon about smoothing variables have been
described in the Chapter 1.7 SPATIAL SMOOTHING

Significance of Geary's autocorrelaƟon coefficient

A test for checking the significance of Geary's autocorrelaƟon coefficient serves the purpose of
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verifying the hypothesis about a lack of spaƟal autocorrelaƟon

Hypotheses:

H0 : C = 1,
H1 : C ̸= 1.

The test staƟsƟc has the form presented below:

Z =
C − E(C)√

var(C)
,

where:
E(C) = 1 – the expected value,
var(C) – variance.

Depending on the assumpƟon concerning the distribuƟonof the populaƟon fromwhich
the sample has been taken, the manner of selecƟng variance is chosen (Cliff and Ord
(1981)[4], and Goodchild (1986)[7]). If it is a normal distribuƟon, then:

var(C) =
(2S1 + S2)(n− 1)− 4S2

0

2(n+ 1)S2
0

,

where:
S1 and S2 are defined as for Moran's analysis.

If it is a random distribuƟon, then:
var(CS) =

(n−1)S1(n2−3n+3−(n−1)b2)−(n−1)S2(n2+3n−6−(n2−n+2)b2) 1
4
+S2

0(n2−3−(n−1)2b2)
n(n−2)(2)S2

0
,

where:
b2 =

1
n

∑n
i=1(xi−x)4

( 1
n

∑n
i=1(xi−x)2)

2 ,

n(b) = n(n− 1)(n− 2)...(n− b+ 1).

StaƟsƟcs Z has, asymptoƟcally (for large sample sizes), normal distribuƟon.

On the basis of test staƟsƟcs, p value is esƟmated and then compared with the significance level
α :

if p ≤ α =⇒ we rejectH0 and acceptH1,
if p > α =⇒ there is no reason to rejectH0.

Thewindowwith seƫngs forGeary’s analysis is accessed via themen Spacial analysis→ Spacial statis-
tics→ Global Geary’s C statistic.
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Eø�ÃÖ½� 5.1 cont. (catalog: leukemia, file: leukemia)

We will analyze the data concerning leukemia.

- The map leukemia contains informaƟon about the locaƟon of 281 polygons (census
tracts) in the northern part of the state of New York.

- Data for the map leukemia:
- Column CASES – the number of cases of leukemia in the years 1978-1982, as-
cribed to parƟcular objects (census tracts). The value should be an integral num-
ber, however, in agreement with Waller's (1994) descripƟon, some cases which
could not be objecƟvely ascribed to a parƟcular region have been divided propor-
Ɵonately. Hence, the numerousnesses of the cases ascribed to the 281 objects
are not integral numbers.

- Column POP – populaƟon size in parƟcular objects.
- Column prev – the frequency coefficient of leukemia per 100000 people, for each
object in one year: prev=(CASES/POP)*100000/5

Global Moran's analysis has pointed to a lack of spaƟal autocorrelaƟon. This Ɵme, in order
to check if in the studied area of the northern part of the state of New York it is possible to
localize clusters of leukemia we will compute the global Geary's C staƟsƟc.

We start from the presentaƟon of the geographic distribuƟon of the prevalence coefficient
(prev) on the map, according to the values of the prev variable, dividing it into quarƟles:
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Dark colors on the map present the places with a higher prevalence of leukemia, whereas
light places signify a lower prevalence. Geary's correlaƟon coefficient obtained in the anal-
ysis equals: 0.884986.
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The obtained result, assuming a random distribuƟon of data, is different from the result
obtained with the assumpƟon of a normal distribuƟon. That can be indicaƟve of an insta-
bility of the results and point to the need of further analyses based on smoothed variables.
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6 LOCAL ESTIMATE OF SPATIAL CLUSTERING

In the local analysis we try to define clusters according to their placement, size, and intensity. A cluster
is understood as a limited gathering of objects of certain intensity, placed in space and/or Ɵme, an acci-
dental appearance of which is highly improbable. If we idenƟfy such a gathering which is not accidental
but is a staƟsƟcally significant cluster we can infer the reasons for its occurrence.

6.1 Local Moran's I staƟsƟc

Local Moran's I staƟsƟc is the most popular analysis from those defined as LISA (Local Indicators of
SpaƟal AssociaƟon) (Luc Anselin 1995 [1]). In contrast to Global Moran's I staƟsƟc it defines the local
spacial autocorrelaƟon, i.e. defines the similarity of a spaƟal unit to its neighbors and studies the sta-
ƟsƟcal significance of that dependence.

Local Moran's I coefficient

The local form of Moran's I coefficient for the i observaƟon is defined with the formula:

Ii =
(xi − x)

∑n
j=1wij (xj − x)

σ2

where:
n – the number of spaƟal objects (the number of points or polygons),
xi, xj – are the values of the variable for the compared objects,
x – it is the mean value of the variable for all objects,
wij – elements of a spacial weight matrix (it is recommended that the matrix is row
standardized),
σ2 =

∑n
i=1(xi−x)2

n−1 – variance

The interpretaƟon of the localMoran's coefficient is analogous to its global counterpart, however,
it largely depends on the selected weight matrix. Most oŌen non-zero matrices are ascribed only
to neighboring objects. As a result the local coefficient only describes the similarity of objects in
the zone of neighborhood. Row standardizaƟon makes it easier to compare the values of coeffi-
cients obtained for various objects as the expected value for each coefficient is then the same.

High values of a coefficient point to the occurrence of clusters with similar valueswhile low values
of a coefficient point to the occurrence of the so-called hot spots, and values near the expected
value E(Ii) point to the random distribuƟon in space of the studied variable.
The expected value is defined with the formula:

E(Ii) =
−
∑n

j=1wij

n− 1

The significance of Moran's autocorrelaƟon coefficient

By tesƟng the staƟsƟcal significance of the relaƟonship among the neighboring objects the fol-
lowing hypotheses are studied:

Copyright ©2010-2014 PQStat SoŌware− All rights reserved 46



4 ANALYSIS OF THE RANDOMNESS OF POINT DISTRIBUTION

H0 : Ii = E(Ii),
H1 : Ii ̸= E(Ii).

The test staƟsƟc has the form presented below:

Zi =
Ii − E(Ii)√

var(Ii)
,

where:

var(Ii) =
wi(2)(n− b2)

n− 1
+

2wi(kh)(2b2 − n)

(n− 1)(n− 2)
−

(∑n
j=1wij

)2
(n− 1)2

– variance in a random

distribuƟon,

b2 =
(n−1)

∑n
i=1(xi−x)4

(
∑n

i=1(xi−x)2)
2 ,

wi(2) – the sum of weights square for the i row,
2wi(kh) – the sum of possible weights raƟos for the i row, aŌer the exclusion
of raƟos with the same indexes.

The Zi staƟsƟcs has, asymptoƟcally (for large sample sizes), normal distribuƟon.

On the basis of test staƟsƟcs, p value is esƟmated and then compared with the significance level
α :

if p ≤ α =⇒ we rejectH0 and acceptH1,
if p > α =⇒ there is no reason to rejectH0.

Due to the problem of a lack of independence of coefficients computed for neighboring objects
it is suggested to use a corrected significance level α. The suggested correcƟons are: Bonferroni
correcƟon: α1 = α/k or Šidák correcƟon: α1 = 1− (1− α)1/k, where k is the arithmeƟc mean
number of the neighbors.

Map layers
The combinaƟon of informaƟon fromMoran's scaƩer plot (the division of objects into: High-High,
Low-Low, Low-High, High-Low) and from the significance of the local Moran's staƟsƟcs presents
on a map the so-called spaƟal regimes:

• StaƟsƟcally significant High-High objects (objects with high values surrounded by objects
with high values) are marked in red on the map;

• StaƟsƟcally significant Low-Low objects (objectswith low values surrounded by objectswith
low values) are marked in blue on the map;

• StaƟsƟcally significant Low-High objects (objects with low values surrounded by objects
with high values) are marked in light blue on the map;

• StaƟsƟcally significant High-Low objects (objects with high values surrounded by objects
with low values) are marked in light red on the map.

The window with the seƫngs of the local Moran’s analysis opƟon is accessed via the menu Spatial
analysis→ Spatial statistics→ Local Moran’s I statistic.

Copyright ©2010-2014 PQStat SoŌware− All rights reserved 47



4 ANALYSIS OF THE RANDOMNESS OF POINT DISTRIBUTION

Eø�ÃÖ½� 5.1 cont. (catalog: leukemia, file: leukemia)

We will analyze data about leukemia.

- The map leukemia contains informaƟon about the locaƟon of 281 polygons (census
tracts) in the northern part of the state of New York.

- Data for the map leukemia:
- Column CASES – the number of cases of leukemia in the years 1978-1982, as-
cribed to parƟcular objects (census tracts). The value should be an integral num-
ber, however, in agreement with Waller's (1994) descripƟon, some cases which
could not be objecƟvely ascribed to a parƟcular region have been divided propor-
Ɵonately. Hence, the numerousnesses of the cases ascribed to the 281 objects
are not integral numbers.

- Column POP – populaƟon size in parƟcular objects.
- Column prev – the frequency coefficient of leukemia per 100000 people, for each
object in one year: prev=(CASES/POP)*100000/5

The global analysis has not yielded an unambiguous answer as to the occurrence of spa-
Ɵal autocorrelaƟon. We will, then, check if we can find regions in which the prevalence of
leukemia is significantly higher.

In order to localize clusters of leukemia and regions which contrast with the environment
with respect to the prevalence of that disease we will compute the local Moran's coeffi-
cient. For the analysis we will use the prev variable and the neighborhood matrix – Queen,
row standardized (according to the conƟguity) which is suggested by the program. In order
to use a different matrix one has to generate it first, see chapter: SpaƟal weight matrix.
We also select one of the correcƟons of the significance level.
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The obtained report presents the values of local coefficients, the values of test staƟsƟcs,
and the corresponding values of test probability. We will also find here the informaƟon
about the number of regions defining the spaƟal regimes (High-High, Low-Low, Low-High,
High-Low).

Also, a result is ascribed to the analysis, whichwe candrawon themap (buƩon
) – those are spaƟal regimes described in the report with the use of the color column.
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We have been able to localize small but significant clusters in which the prevalence of
leukemia is higher. The red color is used for the 2 clusters (4 register regions) lying in smaller
and more populated regions – they are the centers of the clusters with high leukemia val-
ues. The light red color is used for the census tract with high values of the coefficient
describing the prevalence of leukemia. The region contrasts with the neighboring census
tracts which are characterized by a relaƟvely low coefficient.

The obtained results can be further illustrated when the map is colored with the values of
the local Moran's Ii coefficient or the values of a test staƟsƟc, or p values. One just has
to copy the appropriate columns from the report into a datasheet. In this example we will
use the values of the Z(Ii) test staƟsƟc for coloring. Having pasted it into an empty col-
umn of a datasheet, in the map manager we color the base map according to the values of
that column, selecƟng the standard deviaƟon with the coefficient 3 as a way of gradiaƟng
colors. PosiƟve and high values of the Zi staƟsƟcs point to the occurrence of clusters of
similar values while negaƟve and low values of that staƟsƟc point to the occurrence of the
so-called hot spots. Values close to 0 point to a random distribuƟon of the studied value in
space.
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By analyzing the smoothed variable textsfprev we strengthen the clusterizaƟon effect. We
obtain a similar result but this Ɵmewe localize 3 clusters (19 census tracts) which are cluster
centers.
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6.2 Local GeƟs-Ord’s G staƟsƟc

GeƟs and Ord's Gi staƟsƟc (GeƟs and Ord 1992, Ord and GeƟs 1995) allows the detecƟon of a local
concentraƟon of high and low values in neighboring objects and studies the staƟsƟcal significance of
that dependence. GeƟs and Ord have also defined a G∗

i staƟsƟcs, very similar to theGi staƟsƟcs. The
only difference between them is that in the case of the former the object for which the study is made
also takes part in the analysis. In a weightmatrix, then, the so-called potenƟal is defined for that object,
i.e. the neighborhood with itself (values on the axis are greater than 0).
GeƟs-Ord’s G coefficient

The local form of GeƟs and Ord'sG coefficient for the i observaƟon is defined with the formula:

Gi =

∑n
j=1wijxj∑n
j=1 xj

, where: i ̸= j.

TheG∗
i coefficient is defined with the same formula but the computaƟons are also made for the

studied object, that is the object for which the i and the j indexes are equal.
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As the coefficient is based on a quoƟent of two sums of the values of the (xj) objects, in order
to interpret the coefficient correctly it is important that the analyzed phenomenon is described
with the use of posiƟve numbers. The interpretaƟon of GeƟs and Ord's local coefficient, simi-
larly to local Moran's coefficient, depends, to a great degree, on the selected weight matrix (row
standardizaƟon of the matrix is recommended). High values of the Gi or G∗

i coefficients point
to a concentraƟon of objects with high values of the analyzed phenomenon, whereas low values
point to a clustering of objects with low values. When the values are close to the expected value
then the spaƟal distribuƟon of the studied value is random.
The expected value is defined with the formula:

E(Gi) =

∑n
j=1wij

n− 1
, where: i ̸= j;

E(G∗
i ) =

∑n
j=1wij

n
.

The significance of GeƟs and Ord's coefficient

By tesƟng the staƟsƟcal significance of the relaƟonship among the neighboring objects the fol-
lowing hypotheses are studied:

H0 : Gi = E(Gi) H0 : G∗
i = E(G∗

i )
H1 : Gi ̸= E(Gi), H1 : G∗

i ̸= E(G∗
i ).

The test staƟsƟc has the form presented below:

Zi(G) =

∑n
j=1wijxj − x(i)

∑n
j=1wij

s(i)

√
(n−1)

∑n
j=1 w

2
ij−(

∑n
j=1 wij)

2

n−2

, where: i ̸= j;

Zi(G∗) =
∑n

j=1wijxj − x∗
∑n

j=1wij

s∗

√
n
∑n

j=1 w
2
ij−(

∑n
j=1 wij)

2

n−1

.

where:
x(i) i x∗ – the mean of the variableX ,
s(i)2 i s∗2 – the variance of theX variable.

The Zi staƟsƟcs has, asymptoƟcally (for large sample sizes), normal distribuƟon.

On the basis of test staƟsƟcs, p value is esƟmated and then compared with the significance level
α :

if p ≤ α =⇒ we rejectH0 and acceptH1,
if p > α =⇒ there is no reason to rejectH0.

Due to the problem of a lack of independence of coefficients computed for neighboring objects
it is suggested to use a corrected significance level α. The suggested correcƟons are: Bonferroni
correcƟon: α1 = α/k or Šidák correcƟon: α1 = 1− (1− α)1/k, where k is the arithmeƟc mean
number of the neighbors.

Map layers
The combinaƟon of the informaƟon from the value of theZi staƟsƟc and its significance presents
the so-called spacial regimes on the map:
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• StaƟsƟcally significant objects with high values of the Zi staƟsƟc are marked as High-High
(objects with high values surrounded by objects with high values) and marked in red on the
map;

• StaƟsƟcally significant objects with low values of the Zi staƟsƟc are marked as Low-Low
(objects with low values surrounded by objects with low values) and marked in blue on the
map;

The window with seƫngs for Local Getis and Ord’s analysis is accessed via the menu Spatial analysis
→ Spatial statistics→ Getis-Ord Gi statistic.

Eø�ÃÖ½� 5.1 cont. (catalog: leukemia, file: leukemia)

We will analyze the data concerning leukemia.

- The map leukemia contains informaƟon about the locaƟon of 281 polygons (census
tracts) in the northern part of the state of New York.

- Data for the map leukemia:
- Column CASES – the number of cases of leukemia in the years 1978-1982, as-
cribed to parƟcular objects (census tracts). The value should be an integral num-
ber, however, in agreement with Waller's (1994) descripƟon, some cases which
could not be objecƟvely ascribed to a parƟcular region have been divided propor-
Ɵonately. Hence, the numerousnesses of the cases ascribed to the 281 objects
are not integral numbers.

- Column POP – populaƟon size in parƟcular objects.
- Column prev – the frequency coefficient of leukemia per 100000 people, for each
object in one year: prev=(CASES/POP)*100000/5
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The global analysis has not yielded an unambiguous answer as to the occurrence of spaƟal
autocorrelaƟon. We will, then, check if we can find regions in which the prevalence of
leukemia is significantly higher.

In order to localize leukemia clusters we will compute the Gi and G∗
i coefficients. The

analysis will be conducted with the prev variable and the neighborhood matrix – Queen,
row standardized (according to conƟguity) which is suggested by the program. In order to
use a different matrix one has to generate it first, see chapter: SpaƟal weight matrix. We
also select one of the correcƟons of the significance level.

The obtained report presents the values of local coefficients, the values of test staƟsƟcs,
and the corresponding values of test probability. We will also find the informaƟon about
the number of regions defining the spaƟal regimes (High-High, Low-Low). Also, a result is
ascribed to the analysis, which we can draw on the map (buƩon ) – those
spaƟal regimes are defined in the report with the use of the color column.
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We were able to localize 3 clusters (6 census tracts in the analysis of the Gi coefficient
and 4 tracts in the analysis of the G∗

i coefficient) in which the prevalence of leukemia is
significantly higher. They are the centers of clusters with high values of leukemia, marked
in red on the map.

The obtained results can be addiƟonally illustrated by coloring the map so as to present
the values of the local GeƟs and Ord's coefficient or the values of the test staƟsƟc, or the p
values. One just has to copy the appropriate columns from the report and paste them into
a datasheet. In this example we will use the values of the Z(Gi) test staƟsƟc for coloring.
Having pasted it into an empty column of a datasheet, in the map manager we color the
base map according to the values of that column, selecƟng the standard deviaƟon with
the coefficient 3 as a way of gradiaƟng colors. PosiƟve and high values of the Zi staƟsƟc
point to a concentraƟon of objects with high values, whereas negaƟve and low values point
to a concentraƟon of objects with low values, and the values near zero point to a random
spaƟal distribuƟon of the studied variable (amap can be addedwithmeans and confidence
intervals).
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By analyzing the smoothed variable textsfprev we strengthen the clusterizaƟon effect. We
obtain a similar result, i.e. 3 clusters (15 census tracts in the analysis of the Gi coefficient
and 9 tracts in the analysis of theG∗

i coefficient) which are cluster centers.
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