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Notices
Copyright
Copyright © Measurement Engineering Australia Pty. Ltd. 2011

All rights reserved.  Under the copyright laws, this manual may not be copied, in whole or in 
part by any means without the written consent of Measurement Engineering Australia Pty. Ltd.

Design Changes
Measurement Engineering Australia Pty. Ltd. reserves the right to change the designs and 
specifications of its products at any time and without prior notice.

Measurement Engineering Australia Pty. Ltd.
41 Vine Street
MAGILL SA 5072
Telephone 08 8332 9044
Fax:  08 8332 9577
Email:  mea@mea.com.au
Web:  www.mea.com.au

Warranty
MEA offers a 12 month, return-to-factory warranty on all new logging systems and hardware.  
The warranty applies to hardware, software and system defects only.  The warranty does not 
cover acts of misuse by the user or third parties, including misuse arising from failure to install 
or operate a system or its components in accordance with relevant system documentation, or 
failure to seek advice from MEA regarding correct installation or operation of a system or its 
components.

Support
If you have questions or problems that cannot be resolved using the information in this manual, 
contact MEA technical support using the details above.  If phoning, ask for the Operations 
Manager and explain the issue.  The Operations Manager will assign a Technician to help 
resolve the issue.  Quoting your MEA Job Reference Number will enable us to quickly locate 
your details.

Phone support is generally available Monday to Friday between 9am and 5pm Central (ie 
South Australian) Standard or Summer Time.  Support for warranty or once-off issues which 
can be quickly resolved is generally free.  Support for ongoing or more complex issues will be 
charged for.

Site visits can be arranged but will incur charges for labour, travel time and where applicable, 
accommodation and meals.

MEA Technicians can only offer support for issues relating directly to the operation of Magpie 
software or MEA logging systems or hardware.  For general computer issues please consult 
a computer technician.
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1. Introduction
Magpie 3 is a Microsoft Windows® compatible program used in all measurement 
systems designed and manufactured by MEA.  The software provides a flexible, 
functional and easy-to-use tool for the collection and display of recorded information 
from MEA logging systems.

1.1. Glossary
A Framework For All Schemes
MEA provides a set of libraries with Magpie 3 that allows you to further customise 
the behaviour of your system.  Advanced users can even maintain their own custom 
instrument libraries and direct Magpie 3 to search these libraries when building 
Schemes.

Buffer
Grouped memory location in a Data Logger.  Able to hold a number of log variables 
for instruments logged at a common rate.

Data Storage
Magpie 3 stores data in a continuous database using the dBase IV format.  When 
unloading, Magpie 3 retrieves only the data added since the last unload - “topping up” 
the database as it goes - so unloads can be performed as often or as infrequently as 
required.  Any part of this complete record of data can be selected and viewed as a 
Table or Graph.

Dial-up Telemetry
For logging systems which incorporate an industrial modem, Magpie 3 provides a 
manual dial / hang-up facility which allows you call a site, unload the data and even 
check the current sensor readings.  Calls can also be automated using the Windows 
Scheduler.

Graphical Data Display
Magpie 3 creates new Graphs with just the click of a button.  Magpie 3 offers a variety 
of ways to customise Graphs, to help you to generate a Graph view most appropriate 
for the application.  These customised Graphs can be saved as Favourites for fast 
recall at a later date.

Multi-User Access
Magpie 3 supports multi-user access to the Scheme and Scheme data so information 
can be shared over a network.
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Scheme Building
Magpie 3 also offers the power to generate a wide range of Logger programs, from 
simple to extremely complex allowing for a high level of system customisation when 
required.  The Magpie Scheme Editor allows you to pick and choose the functionality 
you require. 

Tabular Data Display
Magpie’s tabular data display is useful to track down specific times, events or values.  
Tables can be easily navigated to find the area of interest.  A subset of the data can 
be selected and exported for further processing in third party applications.

1.2. Parts List
The follow parts list shows all items other than this document that should be received 
in the Magpie 3 software consignment:

 ● Magpie 3 Installation CD

 ● MEA2304 Logger to PC serial communications cable

 ● MEA2303 USB to Serial (RS-232) adaptor cable

1.3. Compatibility Information
This manual is written to cover the features of Magpie 3 including Unidata Logger 
support.  Magpie 3 with Unidata Logger support is designed for use with systems 
which utilise the following Data Loggers:

 ● MEA 8007 Micrologger

 ● Unidata 8010 Micrologger

 ● Unidata Model 6004 A,B, C, D Starlogger

 ● Unidata Model 7001 Prologger

 ● Unidata Model 6526 Starflow

 ● Unidata Model 6536 EC Micrologger

1.4. Minimum Computer Specifications
To run Magpie 3 a computer which meets or exceeds the following specifications is 
required:

 ● Operating System Windows 2000 or later.

 ● CPU Pentium 3 or better
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 ● RAM 64 MB or greater.

 ● Hard Disk 70 MB free space.

 ● Video Super VGA (800 x 600 resolution) 256 colours.

 ● Misc CD-Rom drive.

For direct communications with the Data Logger the computer will require a serial 
port.  If the computer is not fitted with a serial port, a USB to Serial adaptor and 
appropriate software drivers are required.

For remote communications with a logging system which has a modem, the user's 
computer will need to be connected to a dial-up modem with access to a landline 
telephone circuit.  The telephone line must be a standard landline (POTS) and not a 
PABX circuit.  In an office environment, a Fax line is usually a standard line.  A DSL 
("Broadband") modem cannot be used to make dial-up connections.
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SECTION A: 
MAGPIE BASICS
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2. Features of Magpie 3
Magpie 3 introduces several new features and improves upon some existing features 
from its predecessor, Magpie 2.

Several different Schemes can be combined to form a Magpie Project:

 ● Create Graphs with series data from several Schemes

 ● Quickly open any Table from any Scheme within the Project

 ● Simultaneously open Tables from different Schemes next to each other 

 ● Unload all Schemes with the click of a button

 ● Direct access to every Favourite from every Scheme in the Project

 ● Benefit from the improved efficiency of Project automation

 ● Edit any specific Scheme from within a Project.

 ● Easily manage Projects with the new Project Manager

 ● Support for 128 COM ports

Other features include:

 ● The Magpie Helper to help you get started

 ● Many improvements to the Wind Rose 
module

 ● New automation commands 

 ● Complete Windows 7 compatibility

 ● Various Graphical enhancements

 ● Bug fixes

 ● Magpie 3 Schemes are backwards-
compatible with Magpie 2

 ● Drag-and-drop Schemes and Projects 
onto Magpie 3 to open them
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3. Quick Start Guide
The following instructions are aimed at the experienced computer user who has 
purchased Magpie 3 as part of an MEA supplied measurement system.  A detailed 
guide to installing the software is included in  section 4. Installing Magpie.

1. Install the data logging system

If you are installing a new logging system, complete the hardware installation following 
the directions in the system documentation.

2. Install Magpie software

Install Magpie 3 using the Magpie 3 Installation CD provided.

3. Install the Scheme

Install the Scheme for the system from the Magpie 3 Installation CD (the Scheme will 
automatically install immediately after Magpie 3 if the check-box is checked).

4. Connect the computer to the system

The communications setup you use will depend on whether your computer is directly 
connected to the Logger or will be dialling the Logger using a modem:

 ● Direct Connection: If connecting a computer directly to the Data Logger, plug the 
Logger into a communications port on the computer using the supplied serial 
cables.  It is recommended that you connect directly to the Logger if the system 
is a new installation.

 ● Modem Connection: If connecting to the Data Logger via a modem, ensure your 
computer’s modem is plugged into a telephone line and that the remote Data 
Logger is active and connected to its modem.

5. Run Magpie 3 and open the Scheme

Start Magpie 3 and open the newly installed Scheme:

 ● From the menu bar select File ⇒ Open Scheme, locate the Scheme for your 
system and open it.

6. Confirm the communications details in the Scheme

Confirm that the communications details in the Scheme match the data Logger 
connection:

 ● From the menu bar select Logger ⇒ Edit Scheme 

 ● Select the Communications page in the Scheme editor.
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 ● Check the details on this page (communications port, phone number, baud rate) 
match your setup and then choose Finish when done.

7. Load the Scheme into the Logger

Load the Scheme into the data Logger to start the measurement system.

 ● From the menu bar select Logger ⇒ Load Program

 ● A confirmation question will appear regarding the load.  Choose Yes.

8. Check the operation

Make sure the system is operating correctly by viewing Real Time Information from 
the data Logger.

 ● From the menu bar select Logger ⇒ Real Time Information ⇒ Standard

 ● In the Real Time Information screen confirm that the Logger state is Logging and 
that all sensor inputs look normal

Note:  It will take a number of Logger scans before the Logger state changes from 
“Primed” to “Logging”.
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4. Installing Magpie 3
Magpie 3 operates with the following Microsoft Windows Operating Systems – 
Windows 2000, XP, Vista and Windows 7.  It will not run on Windows 95, 98 or earlier. 

4.1. Installation Instructions
Magpie 3 is distributed on a CD-ROM.  In most cases, all of the required software will 
be supplied on this CD-ROM.

 ● Load the Magpie 3 CD-ROM into your computer’s CD-ROM drive

 ● An installation program will start automatically.  This will display a list of Magpie 
components to be installed.

 ● It is possible to uncheck components that you do not wish to install, although it 
is generally desirable to install everything.

 ● Press the Install button to continue with the installation.
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 ● Press Next to continue.

 ● Read the agreement, check I accept... and select Next to continue.
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 ● Select Next to use the default installation location (recommended), or Browse to 
choose an alternate location, then select Next to continue.
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4.2. If the Installer Does Not Start Automatically
If the installer does not start automatically you may need to run the installer manually.  
The steps to achieve this are slightly different depending on which version of Windows 
you are running:

Windows 2000

 ● Double-click on  from the Windows Desktop

 ● Right-click your CD drive which has the Magpie 3 CD in it

 ● Click Explore

 ● Double-click install.exe to run the installer. 

Windows XP

 ● Click on  from the Windows Taskbar

 ● Click on  from the list on the right

 ● Right-click your CD drive which has the Magpie 3 CD in it

 ● Click Explore

 ● Double-click install.exe to run the installer.

Windows Vista

 ● Click on  from the Windows Taskbar

 ● Click on Computer from the list on the right

 ● Right-click your CD drive which has the Magpie 3 CD in it

 ● Click Explore

 ● Double-click install.exe to run the installer.

Windows 7

 ● Click on  from the Windows Taskbar

 ● Click on Computer from the list on the right

 ● Right-click your CD drive which has the Magpie 3 CD in it

 ● Click Explore

 ● Double-click install.exe to run the installer.
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4.3. Unlocking Magpie 3
After installation, you must register your software to enable all of the software’s 
functions.  A registration form will be displayed when Magpie 3 is started and the 
appropriate registration details need to be entered into this form.

Serial Number
The serial number can be found on the Magpie 3 installation CD.

User Name and Company
The User Name and Company details are used to tell us who will be the registered 
owner of the software.  The Company may be left blank if you are a private user 
however the User Name must contain the name of an individual to whom the software 
will be registered.

Unlock Code
The Unlock Code is a unique code that is issued by MEA.  If you have not received 
an Unlock Code click on the Request Unlock Code button.  Magpie 3 will open a new 
email message with your default mail program that has all the necessary information 
to send to MEA copied to it automatically.  Simply send the message. 

Note: You will need to enter your Serial Number, User Name and Company Name (if 
applicable) details before pressing this button. 
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4.3.1. Notes About Software Registration
There can be only one User Name for each Magpie 3 serial number released.  When 
an Unlock Code is requested from MEA, the serial number, user and company details 
are stored in a registration database.

It is essential that all details are entered exactly as they are supplied by MEA otherwise 
the unlock code will not be accepted.  This includes capitals and spaces.  A green tick 
is displayed when the correct details and code are entered.

Magpie 3 licensing allows multiple copies of the software to be installed within an 
organisation or department on a limited basis without additional fees.

Until Magpie 3 is unlocked, an UNREGISTERED message will appear in the top 
left of the Magpie main window and selected functionality in the software will be 
unavailable.

You will still be able to operate your logging system, however you will be unable to 
make changes to the Scheme until the Unlock Code has been obtained from MEA.
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5. Magpie 3 Schemes
The Magpie Scheme is a description of a data logging system.  It defines the sensors 
in detail, how these sensors are to be logged, what type of Data Logger they are fitted 
to, and how to communicate with the Logger.  This description is held in a Scheme 
file.  Magpie 3 requires a Scheme in order to interact with the data logging system.

Whenever changes are made to the Scheme, the Logger must be re-programmed 
(see section 6.7.3 Load the Scheme).  All new MEA logging systems will be supplied 
with a specific scheme.

5.1. One Scheme per Logging System
The Scheme controls the format that data collected from the system will take. The 
Scheme also keeps track of how much data needs to be collected from the Logger 
when next unloaded.  As a result, there can only be one Magpie Scheme per data 
logging system.  It is important to ensure that the correct Scheme is used.

5.2. How to Find Magpie 3 Files on the Computer
The default installation folder for Magpie 3 is:

C:\Program Files\Magpie 3

The location of the Schemes and Projects folders will differ according to your 
Operating  System.  The path will be auto-set when Magpie is installed, but can be 
altered if required.

The default paths for different operating systems are:

Windows XP and 2000
C:\Documents and Settings\All Users\Documents\MEA\Magpie\Schemes

Note:  In Explorer Documents will be displayed as Shared Documents.

Windows Vista and Windows 7
C:\Users\Public\Documents\MEA\Magpie\Schemes

Note:  In Explorer Documents will be displayed as Public Documents.
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Each Scheme has a folder of its own.  The folder holds the collected data and any 
other support files used by the Scheme.  You can quickly and easily move a Scheme 
from one computer to another by copying or moving the complete folder contents.  
Each computer must have an installed copy of Magpie 3.

Consider a Scheme called MyScheme.

In Windows 7 the Scheme would be found in the folder:

C:\Users\Public\Documents\MEA\Magpie\Schemes\MyScheme

Scheme files use a Magpie icon, as demonstrated to the right.  If you 
have Windows set to display file extensions you will notice that the 
Scheme file has an extension of SCM.

Project files have an icon of a piece of paper with three small magpies on it.  
These have the file extension of MPJ.

You can double-click on a Scheme or Project file and Magpie 3 will run and open that 
file.  If you already have Magpie 3 running you can click and drag the file into the main 
window to have Magpie 3 open that file.

5.3. The Magpie Sample Scheme
Magpie 3 installs with a sample Scheme that you can use to familiarise yourself with 
Magpie 3.  It contains some sample logged data that can be used to view Tables, 
Graphs and Wind Roses.  The sample Scheme can be freely modified without the risk 
of causing problems with your Schemes. 

Note: Some functionality of the sample Scheme is disabled, such as loading and 
unloading the data Logger.  It is still possible to run the Scheme Editor to view the 
Scheme construction.

The Magpie 3 demonstration Scheme is called Sample.  In Windows 7 it is found in 
the folder

C:\Users\Public\Documents\MEA\Magpie\Schemes\Sample
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To open the sample Scheme:

 ● Start Magpie 3.

 ● From the menu select  File ⇒ Open Scheme.

 ● Locate the Sample Scheme in the Schemes folder and open it.
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6. Basic Magpie Functions
This chapter gives examples of the most commonly used functions of Magpie 3.  Some 
of the steps listed here will have icons to the right of them which represent speed 
buttons that can be pressed as an alternative way to perform the same function.

Note: These examples describe what could be considered as standard sequences of 
Magpie 3 functions.  In many cases the functions in each example can be executed in 
any order, or specific functions can be excluded if not required.

6.1. Opening a Scheme
A Scheme needs to be opened before most functions in the software can be used.

Note: Opening a different Magpie Scheme will automatically close the currently open 
Scheme or Project.

6.1.1. Using the Scheme Open Dialogue
 ● Choose File ⇒ Open Scheme from the menu.

 ● The Open Scheme form will be displayed.

 ● Open the folder for the required Scheme and select the Scheme file displayed.  
Press the Open button.
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6.1.2. Selecting a Recently Used Scheme
 ● Whenever a Scheme is opened, the name of the Scheme is pushed on to the 

top of a list of most recently used Schemes at the bottom of the File menu.  
Whenever a Scheme is selected from this list, the current file is closed and the 
selected Scheme is opened.

6.1.3. Automatically Opening the Scheme You Last Used
It is also possible to have Magpie 3 automatically open the last Scheme used.  This 
can be very useful when using the same Scheme repeatedly.

 ● Choose Options ⇒ Magpie Settings… from the menu.

 ● Select the Application option.

 ● Check the Open last used Scheme on startup box.

Whenever a Scheme is open, Magpie 3 will display the name of the Scheme in the 
title of the program.

6.2. Unload the Logger
6.2.1. Connect to the Data Logger
If using a direct cable connection, ensure the Logger and computer are connected.

If the data logging system is fitted with telemetry then a dial-up connection can be 
used.

Select Logger ⇒ Dial

6.2.2. Unload the Newest Data from the Logger
Once a connection (either direct or via telemetry) has been made, select Logger ⇒ 
Unload Data

6.2.3. Disconnect from the Data Logger
If a dial-up connection was made to the system then it is a good idea to terminate the 
connection before performing other non-Logger specific functions.  However, if the 
user wishes, a dial-up connection can be maintained for the entire Magpie session 
with the active Scheme.

Select Logger ⇒ Hangup
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6.3. Navigate to the Data of Interest
Use the Data Navigator on the tool bar to select the range of data of interest.  For the 
data just unloaded, select New Data Only.

6.4. View a Graph and Print 
6.4.1. Create or Open a Graph
Create a new Graph by selecting Graph ⇒ New Graph

If you have previously saved a Favourite you can reopen it by selecting Favourites ⇒ 
Graph ⇒ “Graph name”

Note: Several Graph windows can be open simultaneously in the workspace.

Click on channels in the Channel Selection Grid at the bottom of the Graph window to 
add/remove traces from the Graph.  Modify the appearance of the Graph as required.  
If you want to be able to recall the Graph at a later date then save the Graph as a 
Favourite by selecting Favourites ⇒ Save Graph.

6.4.2. Print the Graph or Save it to a File
To print the Graph, simply make sure that the Graph is the active window in the 
Magpie workspace and then choose File ⇒ Print

To save the Graph image to a file that can be e-mailed or placed on an Internet web 
site, choose Graph ⇒ Save Graph Image

Specify a name for the file to be created and choose Save

6.5. View a Table, Summarise and Export
6.5.1. Create or Open a Table
Select a Table from the Table menu or from the toolbar.

If you have previously saved a Favourite you can reopen it by 
selecting Favourites ⇒ Table ⇒ “Table name”

Some Schemes will have multiple Tables available for display whereas others will 
have only one – the number available is determined by the Scheme setup.
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Click on channels in the Channel Selection Grid at the bottom of the window to add/
remove channels from the Table.

The order of the columns may be changed by clicking and dragging the column 
headers.

Note: Date and Time columns are fixed and cannot be moved.

Summaries can be made to appear at the bottom of each column of data (with the 
exception of date and time) by clicking on the sensor column to highlight the heading, 
then selecting Table ⇒ Summarise and picking a summary action from the list.

If you wish to save this view of the tabular data for recall at a later date then save the 
Table as a Favourite by selecting Favourites ⇒ Save Table.

6.5.2. Export the Table
Once you have the presentation of the data looking the way you want it, choose Table 
⇒ Export Table.  You can then choose the format in which you want the data to be 
saved: CSV, HTML or XML.  After choosing the format for the exported file, enter the 
name you wish to give the file before pressing Export to create it.

6.6. View Sensor Inputs
6.6.1. Look at Current Values
Make a connection to the data logging system, then select Logger ⇒ Real Time 
Information ⇒ Standard from the menu

6.6.2. Customise the View
Instruments can be added and removed from the display by clicking on the Channel 
Selection Grid at the bottom of the window.  If a particular selection of channels is to 
be recalled at a later date then save the Real Time Information screen as a Favourite 
by selecting Favourites ⇒ Save Real Time Screen.

To view how much data has been collected by each log Buffer (although with other 
Buffer specific information) choose Logger ⇒ Real Time Information ⇒ Buffer 
Information

To view the status of the Data Logger including configuration parameters and raw 
input channel values choose Logger ⇒ Real Time Information ⇒ Logger Information
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6.7. Modify User Settings in a Scheme
Many Schemes provide a number of User Settings that are specific to the system.  
For example, if the data logging system is fitted with a modem and the modem power 
is being controlled by the data Logger, the user can choose to turn the power to the 
modem off outside selected “windows” to save battery power.  These times are can 
be set in the User Settings section of the Scheme.

6.7.1. Edit the Telemetry Windows
Open the Scheme and then choose Logger ⇒ Edit Scheme from the menu and 
select User Settings from the Scheme Pages.  The following window will be 
displayed:

In the screen shown above, you will see that four time windows are available, each 
with an Open and Close time.  Open is the time at which the power will turn on.  Close 
is the time it will turn off again.  Modify the desired user setting as required and select 
Finish to complete Scheme editing.

Note: Telemetry window times are written in 24-hour time, eg 2:00 AM would be 2, 
9:00 AM would be 9, 1:00 PM would be 13 etc.
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6.7.2. Unload the Logger
The program which is running inside the Logger must now be updated in order for 
the change in Telemetry On / Off times to take effect.  Before re-loading the Logger 
program, it is important to unload the data stored in the Logger because the load 
process will clear the Logger memory.

Select Logger ⇒ Unload Data

Note: If the data stored in the Logger is unimportant (or there is no data in the Logger) 
then proceed to the next step.

6.7.3. Load the Program
The modified Scheme is loaded into the Logger by choosing Logger ⇒ Load Program 
from the menu.

After the modified program has been loaded successfully, the new User Settings will 
be used.

If using a dial-up connection, remember to terminate the call.
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6.8. Change the Displayed Sensor Name
The sensor name appears in the display of Graphs, Tables, and Real Time display.  
Schemes supplied by MEA may come with generic sensor names.  Sometimes it is 
desirable to change the displayed sensor name (for example, to provide information 
on the deployment of the sensor, such as depth).  The following procedure describes 
how to change the name of an existing sensor in the Scheme.  

Open the Scheme then the Scheme Editor and select Instruments from the 
Scheme Pages.  You will see the following screen:

6.8.1. Locate the Instrument to Change
From the Instruments List find the instrument that is to be changed.  In the Instrument 
Details click on the Name entry and enter the new name.  Repeat this for all instruments 
as required.  Do not change other parameters as they are specific to the scaling and 
processing of sensor values.

6.8.2. Finish editing
Select Finish when done.  The name changes will be applied automatically.  Some 
windows will update immediately with the new names while others will need to be 
closed and then re-opened before the changes can be seen.
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SECTION B: 
MAGPIE IN DETAIL
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7. The Magpie Desktop
The picture below shows a sample Magpie desktop once a Scheme is loaded.

The major components of the desktop are:

Logger Toolbar
Provides shortcuts to the most common Logger functions

Menu Bar
Provides access to the various program menus

Navigator
Used to control how much data appears on the screen

Project Toolbar
Provides shortcuts to Project functions.  Only appears when a Project file is open.

Scheme Toolbar
Provides shortcuts to Scheme functions such as Graphing and tabling

Workspace
Displays windows of Scheme data and other information.

Project
toobar

Logger
toolbar

Menu
barNavigator

Scheme
toolbar

Workspace
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8. The Workspace
The Magpie workspace is empty when a Scheme is first opened.  When a Table, 
Graph or other display is opened, a new window for each will appear inside the 
workspace.  The number of windows which you can open in the Magpie workspace is 
unlimited.  The physical space on the Windows desktop will determine how many 
windows you can comfortably view at any one time.

Windows can be arranged manually by re-sizing and moving them or they can be 
arranged automatically by using options in the Window menu.

 ● To arrange the open windows so that the titles of each can be seen cascading 
across the screen, choose Window ⇒ Cascade 

 ● To perform a horizontal tiling of the open windows in the workspace choose 
Window ⇒ Tile Horizontal

 ● To perform a vertical tiling of the open windows in the workspace choose Window 
⇒ Tile Vertical  

 ● To minimise all of the windows currently on view in the workspace (allowing 
the windows to remain in the workspace but just not visible) choose Window ⇒ 
Minimize All

 ● To close all of the windows in the workspace (minimised or otherwise) choose 
Window ⇒ Close All

Table
window

Graph
window

Minimised window
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9. Logger Communications
Magpie 3 can communicate with the Data Logger in two ways:

 ● The Logger can be directly connected to the computer with a serial cable

 ● The Logger can be remotely connected using a modem (if your logging system 
has telemetry devices).

9.1. Direct Connection
Direct connection is where the computer communicates with the Logger via a serial 
communications port (COM port) and a serial communications cable.

When using a Direct Cable connection, there is no special connection procedure 
for Magpie 3 to begin communicating with the Data Logger.  Once the physical 
connection has been made, as soon as any of the Logger communications functions 
are chosen (eg Load, Unload, display RTI), the software will automatically open the 
communications port and begin talking to the Data Logger.  The communications port 
will remain open until the Scheme is closed.

9.1.1. Supplied Serial Communications Cables
Serial communications cables will be supplied with your logging system.

In most cases an AT Modem communications cable will be supplied.  This will have a 
D-25 Male connector on one end, suitable for plugging into the communications port 
of the Data Logger, and a D-9 Female connector on the other end, to plug into the 
serial port on your computer.

In other cases D-9 Male to D-9 Female, or 4-Pin Milspec to D-9 Female cables will 
be supplied as appropriate.

INPUT

COMPUTER
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9.1.2. Supplied USB-to-Serial Adaptor
Computers are increasingly being supplied 
without a 9-pin serial communications port, 
with USB ports taking their place.  This is 
especially true for notebook computers.  
Communicating  with a Data Logger directly 
via a serial cable using a computer with no 
9-pin serial ports requires a USB to serial 
adaptor.  The adaptor plugs in to a USB port 
on the computer and makes a serial port 
available.  These adaptors can be purchased 
from MEA (MEA2303).

9.1.3. Installing a USB to Serial Adaptor
If you have a USB to serial adaptor that has been supplied by MEA follow the steps 
below to install it.

 ● Place your Magpie Software CD in the disk drive on your computer.

 ● Navigate to the disk drive using My Computer.

 ● Highlight the drive, right-click and select Explore.

 ● Open the USB-Serial Drivers folder to find the file PL2303_Prolific_
DriverInstaller_v1210.exe

 ● Double left-click PL2303_Prolific_DriverInstaller_v1210.exe to start the driver 
installation.

 ● When the installation is complete, plug your adaptor into a spare USB port.

 ● Windows should automatically install the driver for the adaptor and assign a 
communications (COM) port to it.

 ● When the installation process is complete, check which COM port the Adaptor 
has been installed on by following the steps described in section 9.2.2 Identifying 
Which COM Port to Use for Direct connection

9.1.4. Identifying Which COM Port to Use for Direct Connection
Windows XP

 ● Follow the path: Start ⇒ Control Panel ⇒ System ⇒ Hardware ⇒ Device 
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Manager ⇒ Ports (COM & LPT).

 ● Expand the list of ports.  The USB to serial adaptor should be installed as Prolific 
USB-to-serial Bridge (COMx) - where x is the port number.

Windows Vista and 7
 ● Follow the path Start ⇒ Control Panel ⇒ Device Manager ⇒ Ports (COM & 

LPT).

 ● Expand the list of ports.  The USB to serial adaptor should be installed as Prolific 
USB-to-serial Bridge (COMx) - where x is the port number.

These methods can also be used to identify which COM port is in use if you have 
more than one 9-pin serial port on your computer.

9.2. Remote Connection
Systems that are configured for dial-up telemetry require that a connection to the 
remote site must be established before attempting communications with the Logger.  
Once a dial-up connection is made, all subsequent communications continue as 
though the Logger was directly connected to the computer.

9.2.4.1. Automatic Remote Connection

The Load and Unload process will automatically make the dial-up connection 
to the remote system if a connection does not already exist.  At the end of the 
function, they will also automatically hang up the dial-up connection.

9.2.4.2. 'Manual' Remote Connection

In some cases, you may prefer to make the connection manually prior to executing 
the unload or load sequences.  A manual connection will stay open until you close it.

 ● To make a manual dial-up connection, select Logger ⇒ Dial.  Once the 
connection has been made, the dial button will de disabled and the hangup 
button will be enabled.

 ● To terminate the dial-up connection select Logger ⇒ Hangup

Note: Magpie 3 will automatically hang up the connection if you close the Scheme or 
exit Magpie.
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9.2.1. Identifying Which COM Port to Use for Remote 
Connection

Windows XP
 ● Follow the path: Start ⇒ Control Panel ⇒ System ⇒ Phone and Modem Options.

 ● Click on the Modems tab.  Your modem should be listed along with the port it is 
attached to.

Windows Vista and 7
 ● Follow the path: Start ⇒ Control Panel ⇒ Phone and Modem.

 ● Click on the Modems tab.  Your modem should be listed along with the port it is 
attached to.

9.3. Setting the Communications Port in Magpie
Having identified the communications port in use, you need to configure your Scheme 
to use it.

 ● From the menu bar select Logger ⇒ Edit Scheme.

 ● Select the Communications page in the Scheme Editor.

 ● Edit the communications details (communications port, phone number, baud 
rate) as required.  Unless replacing a modem or SIM card, the phone number 
and baud rate should not require changing.
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9.3.1. Direct Connection Port Settings
If your computer is connected to the Logger by a serial cable: 

 ● Click on the Direct (via cable) button and the options for a direct connection will 
display (the remote options will be greyed out).

 ● Set the Communications Port to the one you identified following the methods 
outlined in section 9.2.2 Identifying Which COM Port to Use for Direct Connection.

 ● The Baud Rate setting should be left at the default value, normally 9600 unless 
otherwise specified in the measurement system documentation.

 ● Click on the Finish button to save the changes.

9.3.2. Modem/Telemetry Port Settings
If your computer is remotely connected to the Logger using a modem:

 ● Click on the Remote (via modem) button and the options for a telemetry 
connection will display (the direct options will be greyed out).

 ● In the Phone Number field, type in the telephone number for the service to which 
the Logger is connected (if MEA has supplied your modem, this number will 
usually be filled in for you).

 ● The Modem Setup field holds any configuration information which must be written 
to the modem.  It is usually entered by MEA when the system is configured.  Do 
not change this unless instructed to do so by MEA staff.

 ● For all cellular phone connections and most landline services, the Dial 
Type will be Tone.  The Pulse setting may be required in areas with very old 
telecommunications infrastructure.

 ● Set the Communications Port to the one you identified following the methods 
outlined in section 9.2.1 Identifying Which COM Port to Use for Remote 
Connection.

 ● The Baud Rate setting will vary depending on the type of telemetry used in the 
system.  This will normally be set by MEA during system configuration.

 ● Click on the Finish button to complete the Scheme changes.
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9.4. The Communications Window
The communications window 
provides a simple means of 
monitoring communications 
between the Logger and 
computer (whether directly 
connected or via telemetry).

Though the data that appears 
in the communications window 
is not in any meaningful form 
for the user, the alternating Red 
and Blue text being echoed in 
the communications window 
indicates that the Logger is 
communicating correctly with 
the software.

Whenever a communications sequence is being executed 
(unloading, loading, dialling, etc.) a Communications button will 
be available in the sequence status box.  Click on the button to 
view communications between the Logger and the computer.

Alternatively, when a sequence is not currently running, the communications window 
can be shown by choosing Logger ⇒ View Communications.

When there are no communications sequences running and there is no Real Time 
Information screen active, regular Blue “*” characters should appear in the left hand 
margin of the communications window.  These indicate that the software is using the 
correct communications port and correct baud rate and that the Logger is ready to 
accept commands from the software.
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10. Starting a Logging System
Whenever a data logging system is installed, re-installed or modified, the Scheme 
must be loaded into the Data Logger.  This performs a number of key functions:

1. It clears any unwanted data from the Logger memory.

Often it is desirable to log new data from the time of system re-start.

2. It enables the Logger to enter the “Logging” state.

If a system is decommissioned for a period of time and the Data Logger is removed 
or the Input Signals connector is disconnected, the Logger will enter the “Stopped” 
state.  The Logger must be re-loaded to enable it to commence logging again.

3. It ensures that the program in the Logger is valid.

If the Scheme has been changed then it is important to ensure that the Logger is 
loaded with the most recent version of the Scheme.

4. It sets the Logger time.

Loading a Scheme sets the time of the Logger.  The Logger takes its' time from the 
computer which was used to load it.  The Logger time does not automatically update 
at the start or end of Daylight Savings.

10.1. Loading the Scheme into the Logger
 ● Make sure the Logger (or Modem if connecting remotely) is connected to the 

computer.

 ● From the menu bar select Logger ⇒ Load Program.

 ● Magpie 3 will display the following message…

If there is data in the Logger that has not been unloaded then choose No and unload 
the data.  If you have made changes to the Scheme you will have to unload the 
Logger with the old Scheme.  Otherwise choose Yes and continue loading the Logger 
with the Scheme.
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If the load sequence fails check the communications settings, cabling, Logger, etc. 
and try again.

Note: If the Logger is not loaded successfully it will not record any data from the 
system.

10.2. Check the Logger Status
Once the Logger has been loaded it is important to confirm its correct operation.  
This can be done by opening the Scheme RTI.  Once the RTI screen is open, check:

 ● The Scheme Name is correct.

 ● Date and time is correct (taken from the loading PC).

 ● The Logger State is 'Logging'.  Note that the state first goes to 'Primed' and then 
will go to 'Logging'.  This can take as little as 10 to 15 seconds or may take longer 
if the system switches sensor power.

 ● Once the state has changed to 'Logging' observe the displayed sensor outputs 
against expected values.
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11. Unloading the Logger
The process of transferring readings collected by the Data Logger to the computer is 
referred to as unloading the Logger.  This new data is then added to the end of the 
database in the Scheme on the computer.

An incremental unload can be performed at any time by simply selecting Logger ⇒ 
Unload Logger from the menu bar.  Magpie 3 determines how much data has been 
logged since the last time the Logger was unloaded and only requests the newest 
data. 

A full unload can be performed by selecting Logger ⇒ Unload All Data from the menu 
bar.  The entire contents of the Logger memory will be retrieved.

The Unload Logger status box will be displayed, showing the 
status of the unload.  Unloading can be safely cancelled at any 
time by pressing the Cancel button. 

The unload process has two stages: 

 ● Data is retrieved from the Data Logger in a Raw form and stored in a 'dump' file. 
Dump files have a .dmp extension, and are stored in a DumpFiles folder inside 
the Scheme folder.

 ● Magpie 3 then processes these records into real sensor values in the Scheme 
database(s).

11.1. Unloading by Direct Cable Connection
This simply requires that an appropriate cable is connected between the Computer 
and the Data Logger.  Select the unload icon to begin the unload.

11.2. Unloading by Remote Connection
If the Scheme is configured for a dial-up connection and there is no active connection, 
the selecting the unload icon will automatically establish a dial-up connection 
before proceeding with the unload.

11.3. Unloading by FTP
If your logging system is fitted with an MEA2213 Packet Data Terminal then data is 
periodically uploaded to an FTP (File Transfer Protocol) server on the Internet.  See 
section 11.3.1 Packet Data Terminal (PDT)

When Magpie 3 is told to perform an unload it checks the files on the FTP server 
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(instead of communicating with the Logger) and downloads any new data for 
processing.

FTP unloading is useful in the following circumstances:

 ●  Frequent remote unloading of a logging system is desired and repeated dialling-
in would be expensive.

 ● A number of people to download require direct access to the system data.

11.3.1. Packet Data Terminal (MEA2213)
FTP unloading requires a 
Packet Data Terminal (PDT) 
to be configured with the 
FTP account details and an 
unload schedule and installed.  
This device is responsible for 
retrieving the data from the 
Logger and uploading it to a 
predetermined FTP server 
where it can later be retrieved 
using Magpie 3.

For enquiries regarding Packet 
Data Terminals please contact 
MEA using the details printed 
inside the cover of this manual.
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11.3.2. Setting Up FTP Unloading
This section assumes that you already have a Packet Data Terminal and an FTP 
account where the dump files will be stored. 

 ● Open your Scheme, select Logger ⇒ Edit Scheme from the menu and select 
Communications from the Scheme Pages.  The relevant fields are listed 
under the FTP Details group.

 ● You need to check the Unload using FTP option to enable FTP unloading and 
enter the appropriate details for Server address, User name, Password, and 
the Storage folder.  When you are satisfied that everything has been entered 
correctly press the Finish button to apply the changes.

Note: You do not need to reload the Logger when making changes to communications 
settings.

FTP unloading overrides other connection options when enabled.  To check that it is 
working, connect to the Internet and then select Logger ⇒ Unload Data.  Magpie 3 
will make an FTP connection and continue the unload process normally. 
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11.3.3. If the FTP Unload Fails
There are several reasons why an FTP unload may be unsuccessful:

 ● Your computer is not connected to the Internet.  If no Internet connection is 
available Magpie 3 will be unable to connect to the FTP server.

 ● The FTP connection details are incorrect.  Double-check that the address, user 
name and password are correct.  Sometimes FTP user names will simply be the 
user name itself (e.g. john) and other times it will include the FTP address (e.g. 
john@somewhere.com). 

 ● FTP unloading has not been enabled.  Ensure the Unload using FTP box is 
checked.

11.3.4. FTP Cleanup
FTP servers usually have a data storage quota.  As the Packet Data Terminal is 
continually adding new data it is possible that all of the allocated FTP space will get 
filled up.  If this happens no new data can be written to the FTP server.  To prevent 
this from happening Magpie 3 offers the option to automatically delete old dump files:

 ● Select Options ⇒ Unidata Options… from the menu and choose the FTP 
Unloading page.

 ● Check the option to Enable automatic cleanup of files from the FTP server and 
set the number of days as desired.
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12. Processing Unload Files
12.1. Unload Files Explained
When Magpie 3 retrieves data from the Data Logger, a dump (unload) file (is created.  
This dump file contains the unprocessed binary data exactly as it was stored in the 
data Logger's memory.  Scheme information is then used in conjunction with this 
binary data in order to create the scaled numbers that are stored in the Scheme 
database(s).

12.1.1. Dump File Storage
 ● Dump files are stored in a DumpFiles folder inside each Scheme folder.

 ● The DumpFiles folder contains a list of chronologically named files prefixed with 
the Scheme name.

 ● If using a direct or dial-up connection to perform unloads, a new dump file is 
created for each unload.

 ● When unloading with a PDT, a single file is created for each new day.  All 
subsequent unloads from the system are appended to the dump file for the rest 
of the day or until a system configuration change is made.

 ● These dump files are useful because they can be sent to other users who wish 
to process data into their own Magpie 3 databases with the same Scheme.

DumpFiles
folder
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12.1.2. Individual Dump File Processing
Magpie 3 allows the user to inspect the contents of the DumpFiles folder and 
select individual dump files for processing.  This will cause the selected data to be 
reprocessed using current Scheme information.

If using a PDT multiple unloads are written into each dump file, and the user can also 
inspect the unload file directly and observe what data is available for processing. 

 ● To process a dump file manually choose Logger ⇒ Process Previous Unload… 
from the main menu.  This will display a form that shows all available dump files 
in the DumpFiles folder.

Note: It is possible to redirect this form to look in other folders that may contain 
unload file information.  This is useful if dump files have been provided by a third party 
and exist somewhere else on the local computer / network.

 ● Select the desired dump file and click Process.

 ● If you are satisfied that the Logger date and time are correct, select Yes and the 
file will be processed.  If the unload period overlaps that of previously processed 
data, Magpie 3 will automatically removed duplicate entries from the database.
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12.1.3. Viewing Unload File Information
Dump files will contain at least one unload.  In systems which employ a PDT which 
unloads they system more than once per day, a dump file will contain multiple unloads.   
Selecting an unload file for processing will cause all unloads in the unload file to be 
processed.

There is a button directly to the right of the dump file listing that provides access to 
more information about the file.  This is useful for knowing what data is available 
inside the dump file for processing.  There will be one or a number of unloads for each 
active buffer of the Scheme.

12.1.4. Extracting Discrete Unloads from the Dump File
If there is a need to extract a single unload from the listing inside the dump file simply 
click the right mouse button over the entry of interest.  A popup menu will appear with 
the option Extract selection from dump file.

The extraction process will request a new unload file name (which the user must 
specify) and then write a new unload file with only the highlighted unload. This is 
useful as a diagnostics tool for viewing discrete unloads in isolation of others in the 
unload file.  This unload file can then be processed separately using the Process 
Previous Unload… facility.

Left-click on this 
button to view more 
information about 

the dump file

Right-click the 
unload of interest to 
extract the selection 
from the dump file
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12.2. Processing Unloaded Data
When the software obtains the required data, it will process these 
new records into the Scheme databases.  The progress bar 
indicates how many records are being written into the database.

12.2.1. Multiple Databases in a Scheme
A Scheme will have a least one database Table, but may have a number of Tables.

Multiple database tables are created:

 ● If data from the sensors in the system must be collected at different rates. For 
example, a weather station fitted with soil moisture sensors might record climate 
information every 15 minutes, daily summary information every 24 hours and 
soil moisture data every 2 hours.  In this case the Scheme would be configured 
to have separate climate, daily and soil moisture buffers (grouped memory 
locations).

 ● There is a limit to the number of log actions that can be assigned to a buffer.  If 
this number is exceeded then additional buffers must be defined in the Scheme 
to accommodate further log actions.

A separate database file (*.dbf) is created for each 
Log Buffer.  To view the different databases in Table 
view select Table (or Table ⇒ "Scheme name.scm" in 
Projects) then select the desired Table.

In Graph view, the different databases are available all the time.  The view can be 
customised by selecting different Channels (corresponding to instrument inputs).
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13. Data Navigation

The database Tables maintained by the Scheme contain all logged records retrieved 
from the logging system.  Since these database Tables continue to grow in size 
as more data is unloaded from the Logger, it is rare that the user wishes to view 
all available data in the database.  Instead, the user needs a method of selecting 
only data within a range of interest (i.e last month, last week, last hour, etc)  Magpie 
provides the Navigator for just this purpose.

The Navigator is a multi-function control that appears in the toolbar area of the 
software and allows the user to pick from a number of methods for selecting a time 
and date range of data to display.

13.1. How the Navigator is Used by Magpie 3
When changes are made to Navigator settings, all windows open in the workspace 
are updated to reflect the changed time and date range selection.  Individual data 
windows may allow further data and time selections but this will always be within the 
bounds of the Navigator settings.

13.2. Navigator Methods
The Navigator offers three methods for the selection of data.

13.2.1. New Data Only
The New Data Only method causes all windows to show only data which was collected 
during the last download from the data Logger.  This option is useful when only the 
newest data is of interest such as when running experiments with regular and frequent 
unloads.  When the New Data Only method is selected, the date/time for the data 
collected from the last download is displayed to the right of the method selection.

Navigator 
method

Navigator 
Favourites

Apply 
navigator 
settings

Method 
options

Auto apply 
navigator 
settings
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13.2.2. Date Range
The Date Range method allows explicit start and end date/time selections to be 
specified for all windows.  This is useful when calendar dates need to be chosen for a 
selection or when there is a particular time frame of interest.  When the Date Range 
method is selected, start and end date editors will appear to the right of the method 
selection.

Date Editing
The date can be edited directly by simply clicking on 
the date field with the left mouse button and typing the 
required date in the field.  The values can also be modified 
by using the cursor up/down keys to provide a scrolling 
effect.

Alternatively, click on the down arrow to make a date 
selection from the calendar.

Time Editing
By default, date selections begin from 12:00 am and end at 11:59 pm.  In some cases 
it is desirable to navigate to times within this range.

To adjust the time, click on the clock button 
next to the date, and the time editor will be 
shown.  Click onto the time editor with the left mouse button and modify the time 
as required.  This can be done by entering a time or by clicking the up/down arrows 
to increment or decrement the value.  Time is displayed in 12-hour time (am / pm) 
regardless of the time format chosen for display in Table view - see section 15.7.1 
Date and Time Formatting for more information.

To revert to date editing click on the calendar button immediately to the right of the 
time editor. 

Start 
date
or

time
Clock

or
calendar

End
date
or

time
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13.2.3. Length From Reference
The Length From Reference method allows the user to specify a fixed time reference 
and then request Magpie 3 to display an amount of data either side of that reference.  
When the Length From Reference method is selected, reference and length editors 
will be displayed.

Reference Editing
The reference can be selected by clicking the down arrow immediately to the right of 
the Reference: label.  This will produce a popup menu from which one of the following 
three reference options can be selected:

 ● Last Record.  The end of the data (the most recent value in the Table).  This view 
is very useful for looking at data which is time sensitive.  For example with soil 
moisture data you may be interested in the last seven days worth of readings.

 ● First Record.  The start of the data (the first recorded value in the Table).

 ● Date.  A specific date.  This will produce a date and time editor identical to that 
shown when selecting a date range.  This allows data to be displayed from either 
side of a user specified date and time.

Length Editing
The length editor controls how much data will be displayed from the reference.

 ● If the Reference is the First Record only data forwards (+) can be selected.

 ● If the Reference is the Last Record only data backwards (-) can be selected.

 ● If the Reference is a Date, data can be selected as either backwards or forwards 
from the reference.

13.3. Applying the Selection
Whenever changes are made to Navigator settings, they must be applied before 
Magpie 3 will respond and update data displays.  This is done by pressing the 
Apply button on the far right of the Navigator bar.

The Navigator can be set to apply changes automatically whenever any of the settings 
change.  In order to automatically apply Navigator changes make sure the 
Auto box is checked.

Reference Length
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Note: On slower computers or when navigating through large databases, the 
automatic apply function may cause the application to run very slowly and in these 
cases it is best to turn it off, then apply the changes when all ranges are set.

13.4. Saving Navigator Settings as Favourites
Magpie 3 also offers the ability to save Navigator settings as Favourites.  Navigator 
Favourites appear in the method selection list providing quick and easy access to a 
previously recorded period of interest.

Saving a Favourite captures the current Navigator details regardless of what method 
is currently being used.

13.4.1. Creating a Navigator Favourite
 ● Click on the Navigator Favourites button immediately to the right of the 

Method dropdown menu.

 ● An dialog will appear that will allow the name of the Favourite to be specified.

 ● Click the OK button to save the Favourite.

 ● The Navigator method will now display the newly created Favourite.

13.4.2. Saving Changes to a Navigator Favourite
Whenever a Navigator Favourite is being used and changes are subsequently made 
to the Navigator settings the Save button will be enabled allowing the changes to be 
saved against that Favourite if the user requires.

13.4.3. Renaming/Deleting a Favourite
Whenever Favourite Navigator settings are being applied the 
Black arrow to the right of the Favourite button will be displayed.  
Clicking this button will produce a popup menu from which the 
Favourite can be renamed or deleted as required.
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14. Graphs
Magpie Graphs provide a simple, flexible method of viewing data.  Graphs are capable 
of accepting small amounts of data (eg two data points) to large amounts of data (eg 
years of data) from multiple instruments.  A wide range of settings are available to 
customise the look and feel of the Graph including colours, styles and axis scaling.  
Any Graph can be saved as a Favourite for easy recall at a later date.

14.1. Creating a New Graph
 ● From the menu select Graph ⇒ New Graph. 

 ● A new blank Graph will be displayed.

 ● If you have a Project open, a tab will appear for every Scheme in the Project. 
The bracketed number represents how many of the Graph traces come from 
each respective Scheme.



www.mea.com.au   Page  56

User Manual for Magpie 3

14.1.1. Adding Channels to the Graph
At the bottom of the Graph the Channel Selection Grid will be displayed.  This gives 
a list of all the instruments that can be included on the Graph.

 ● To add a channel to the Graph, place a tick in the check-box preceding its name 
(an unlimited number of channels may be displayed on the Graph),

 ● By default, newly added channels are displayed against the left axis,

 ● The Graph time axis will take on the range displayed by the Navigator

14.1.2. Modifying the Style of Displayed Channels
Clicking the right mouse button over any channel in the Channel 
Selection Grid will display a popup menu with a variety of 
additional graph options.

Data can be displayed on the Graph using four basic Graph 
types:

Line
Draws a simple line between consecutive data points.

Points
Draws a simple line between consecutive data points and additionally draws a square 
point marker on each point.

Bar
Draws a bar from 0 to each point.

Area
Draws a simple line between consecutive points and fills the area below the line.

The default drawing style is the Line Graph.
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14.1.3. Hiding the Channel Selection Grid
Once the desired channels have been added to the Graph, the Channel Selection 
Grid can be hidden to maximise the Graph area displayed.  This is done by clicking 
the White arrow on the caption bar of the channel selection grid.

Double-clicking the mouse anywhere on the caption bar of the Channel Selection 
Grid will also show/hide the grid.

Alternatively, from the menu select Graph ⇒ Show/Hide Channel Selection Grid.

14.1.4. Setting the Graph Title
The Graph title is displayed at the top of a Graph.  By default any new Graph will use 
the Scheme name as its title; this can be changed at any time.  From the menu select 
Graph ⇒ Title, or simply use the mouse to click the title on the Graph.  A popup will 
be displayed allowing a new title to be entered.

Note: The title is lost if the Graph is closed without saving it as a Favourite.

14.1.5. Selecting the Left or Right Axis
Magpie 3 allows you to display readings referenced to two vertical axes – one which 
displays on the left of the Graph and one on the right.  This allows you to show 
readings from sensors which have different measurement units (e.g. mm and Watts) 
or widely different scales.   For example, if Temperature and Solar Radiation were to 
be plotted together, Temperature could be sent to the left axis and Solar Radiation 
would be sent to the Right. 

 ● To change the axis a channel is plotted against, click the right mouse button 
over the channel in the Channel Selection Grid and select Left Axis or Right Axis 
from the menu.
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14.1.6. Changing the Vertical Axis Scaling 
When channels are added to a Graph the scaling is determined by the Display Type 
Minimum and Maximum values specified in the scheme instrument definition.  This 
scale can be modified at any time without using the Scheme Editor by using a number 
of methods.

14.1.6.1. Using Axis Editors

At the top of the Graph, above the left and right axes, there is a pair of edit 
boxes with push-pin buttons alongside them.  Min is the minimum value 
currently set for the axis and Max is the maximum value currently set for 
the axis.  The state of the push-pin indicates whether automatic or manual scaling is 
selected.

Automatic scaling
When automatic scaling is selected, the axis range will be scaled to fit to the 
maximum (or minimum) series value attached to that vertical axis.  The values 
appearing in the edit boxes for the maximum and minimum will reflect these 
automatically generated values.

Manual scaling
When manual scaling is selected, the axis range can be scaled by typing maximum 
and minimum values into the edit boxes.  Typing values into these boxes is enough 
to change from automatic scaling mode to manual scaling mode.

Press the tab key to move quickly from one setting to the next.

14.1.6.2. Dragging the vertical axis with the mouse

The vertical axis scaling can also be changed by clicking and dragging the mouse 
cursor over a vertical axis.

 ● Move the mouse cursor over the left or right vertical axis.

 ● The cursor will change to one of the following images:

Icon When It Displays What It Does
Active if the cursor is over the top 
25% of the range

Drag the cursor up and down to 
increase and decrease the Max value

Active if the cursor is over the 
middle 50% of the range

Drag the cursor up and down to adjust 
the Min and Max values together

Active if the cursor is over the 
bottom 25% of the range

Drag the cursor up and down to 
increase and decrease the Min value
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 ● Click and hold the left mouse button down to begin the scaling action, then move 
the moused up or down as desired.

14.1.7. Changing the Horizontal Axis Scaling
It is also possible to expand and contract the time axis of the Graph in a manner 
similar to the vertical axis scaling.  By clicking and dragging the mouse cursor over 
the time axis it is possible to dynamically modify the range of data that appears in the 
Graph

 ● Move the mouse cursor over the time axis.

 ● When the cursor is over the values on the axis it will change to one of the 
following images:

Icon When It Displays What It Does
Active if the cursor is in the left 25% 
of the range

Drag the cursor left and right to modify 
the start time

Active if the cursor is over the 
middle 50% of the range

Drag the cursor left and right to move 
the full viewing range

Active if the cursor is over the right 
25% of the range

Drag the cursor left and right to modify 
the end time

 ● Click and hold the left mouse button down to begin the scaling action, then move 
the mouse left or right as desired.

Note: The Graph will not allow the time axis to expand past the current Navigator 
settings.  Therefore, when the period displayed is at the limits of the Navigator settings, 
the time axis will not respond to further mouse scaling actions.  The Navigator remains 
the prime tool for selecting the time and date range of data for display.

14.1.8. Inverting the Vertical Axis
Graphs are normally drawn with low values at the bottom and high values at the top.  
For some types of sensors (such as gypsum blocks), it may be preferable to invert the 
scale so that low tensions (high levels of moisture) appear at the top of the Graph and 
high tensions (low moisture levels) at the bottom.

 ● From the menu select Graph ⇒ Left Axis ⇒ Invert Axis or Graph ⇒ Right Axis 
⇒ Invert Axis to toggle the respective axis inversion on or off.
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14.1.9. Selecting Linear or Logarithmic Scaling
By default Graphs are plotted with a linear scale.  You can change to logarithmic 
scaling as follows:

 ● From the menu select Graph ⇒ Left Axis ⇒ Logarithmic Scale or Graph ⇒ Right 
Axis ⇒ Logarithmic Scale to toggle the respective axis logarithmic scaling on 
or off.

14.1.10. Setting the Axes Titles
Titles can be added to the left and right vertical axes.

 ● From the menu select Graph ⇒ Left Axis ⇒ Title to set the left hand axis title.

 ● Similarly, from the menu select Graph ⇒ Right Axis ⇒ Title to set the right hand 
axis title. 
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14.2. Manipulating a Graph
Graph manipulation allows the user to 'move the data around' rather than just viewing 
a static display.  The user can click and drag using the options described below to 
quickly identify and inspect regions of interest in the Graph.

14.2.1. Data Zooming
Magpie 3 includes a zoom function which allows the user to quickly home in on an 
area of interest.

To zoom in:

 ● Move the mouse cursor over the start of the data range of interest (the top left 
corner of the area).

 ● Press and hold down the left mouse button.

 ● Move the mouse cursor to the end of the data range of interest (the bottom right 
corner of the area).

 ● Release the mouse button.

 ● The Graph will now zoom to that selection.
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 ● It is possible to continue zooming or “drilling down” to individual samples in the 
data set.

To zoom out:

 ● Place the mouse cursor anywhere on the screen, press down the left mouse 
button and drag up and to the left.  When the mouse button is released, the 
Graph will be returned to its original, un-zoomed state.

 ● Alternatively, click on the Unzoom button on the Options bar of the channel 
selection grid.

14.3. Saving Graphs as Favourites
Favourites are provided as a mechanism for saving all Graph settings (channels, 
vertical axis ranges, styles, colour bands, titles, etc.) such that the Graph can be 
easily recalled at a later time.  The Scheme can support an unlimited number of 
Favourites allowing for quick and easy access to the most desirable view of the data.

 ● From the menu select Favourites ⇒ Save Graph.

 ● An input box titled Save Graph as Favourite will appear.  Type the name of the 
Favourite and choose OK.

The Graph will now be available in the list of Graph Favourites under the Favourites 
menu.

14.4. Graph Comments
It is possible to select any part of a trace on a Graph and add a comment to it.  Any 
comments that have been added to a Graph will also appear on the corresponding 
Table view.

To add a comment to the Graph do the 
following:

 ● Move the mouse pointer over the top of 
the desired point on the trace.

 ● Click the right mouse button.
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 ● A menu will appear.

 ● Select Comment ⇒ Add Comment.

Note: If the mouse pointer is not directly over the line on the Graph then the menu 
option will not be available.  Consider zooming in on the trace in order to allow the 
comment to be added to the correct point.

 ● Enter a comment for this point on the line and choose OK.

 ● The comment will now be displayed.

Note: The comment remains attached to this data point in the database and will 
appear in subsequent Graph views and Table views.

14.5. Locating Data Values
In the same way that comments can be added to the Graph at selected points, it is 
also possible to instruct the software to find the value in the corresponding Table 
display.  To locate a point in the Table do the following…

 ● Move the mouse pointer over the top of the desired point on the trace.

 ● Click the right mouse button

 ● A menu will appear

 ● Select Locate in Table

Note: If the mouse pointer is not directly over the line on the Graph then the menu 
option will not be available.  Consider zooming in on the trace in order to allow the 
point to be located in the Table.
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14.6. Additional Graph Options
14.7. Colour Bands
Colour bands are user defined regions of interest with particular colour attributes.  
Bands apply only to the Graph on which they were created.  Colour bands are used 
to highlight particular value ranges, for example to display alarm limits or to highlight 
full and refill points in a soil moisture monitoring system.  The transparency of the 
bands can be adjusted to suit individual preferences.  Multiple bands can be defined 
for a single Graph and bands can individually be visible or hidden as required.

To add a colour band to a Graph:

 ● Create a Graph (or open a Favourite) and determine which axis to apply a band 
(left or right).  Make a note also of the range to apply the band (e.g. Soil tension 
8 to 60 kPa).

 ● From the menu bar select Graph ⇒ Colour Bands, or click on the Edit Colour 
Bands button on the Options bar of the channel selection grid.
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 ● When the Edit Colour Bands form is displayed, set up the band as required.

The Bands list box displays any existing bands.  To create a new band ensure that the 
[new band] entry is highlighted.

Start
The value from which the band begins (e.g. 8 kPa).

End
The value at which the band ends (e.g. 60 kPa).

Axis
The axis to which the band will be applied (e.g. Left).

Colour
Click on the entry and then select a suitable colour for the band

Visible
This box controls whether the band will be visible or not.  Pre-defined bands can be 
toggled on or off depending on the view required at the time.

Transparency
Controls the colour intensity of the band.  A low value (e.g. 10) results in the highest 
colour intensity; a high value (e.g. 80) results in a lower intensity.

14.8. Graph Printing
Magpie 3 allows a Graph to be printed.  This is done by first showing a preview of the 
Graph allowing margin and detail settings to be modified prior to printing.  To print a 
Graph:

 ● Open the Graph of interest (either a Favourite or a new Graph).

 ● From the menu select File ⇒ Print.
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 ● The Graph print preview form will be displayed.

 ● Click on the Portrait or Landscape buttons to change the orientation of the 
Graph on the page.

 ● Modify the Print scaling to generate a Graph with more or less detail.  This will 
depend on the final size of the image and print properties of the selected printer.

 ● Use the mouse to modify the margins on the top, bottom, left and right sides of 
the page to increase or decrease the size of the Graph on the paper.

 ● Click-and-drag the Graph image to a more desirable location on the page.

 ● Click on the Print button to print the Graph as it appears in the preview window.

Note: Any changes to settings in the Graph preview form will be retained and used in 
subsequent print actions unless modified.

14.9. Saving the Graph Image to File
Saving a Graph image to a file is an excellent way of providing Scheme data to a third 
party not using Magpie 3.  A file version of the Graph image is very portable and can 
be e-mailed or posted to a web site.
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 ● From the menu select Graph ⇒ Save Graph Image.

 ● Select a destination to save the image to.

 ● The Graph image can be saved in the following formats: JPG, BMP, WMF or 
PNG.  The options are displayed by activating the drop-down menu to the right 
of the Save as Type: field.

 ● Type the name in the Save Graph Image To File form and press Save.
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15. Tables
Numeric display of data collected by the measurement system is often important 
where more detailed analysis of the data is required and the real values need to be 
scrutinised.  A Scheme will have at least one Table available for viewing.

15.1. Opening a Table
 ● Go to the Table menu and select a Table from the bottom of the 

menu.

 ● Alternatively, click the Table button on the toolbar and select a 
Table from the popup menu.

15.2. The Table View
Records in the database are displayed on the Table in chronological order from oldest 
to newest.  The date and time fields always occupy the two leftmost columns.

The range of data displayed in a Table is defined by the Navigator settings.

15.3. Arranging Data in a Table
Tables allow the user to decide what channels should appear and in what order.  This 
is done in one of two ways: 

15.3.1. Select channels in the Channel Selection Grid
The Channel Selection Grid is displayed at the bottom of the table.  The Channel 
Selection Grid is a list of all available instruments that can be viewed on the Table.

By default, all channels will appear when the Table is first opened.

 ● To remove a channel from the Table simply uncheck the box next to its name.

 ● To include a channel in the Table check the box next to its name.
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Note: When a channel is added to a Table, it is automatically added to the rightmost 
column, not to its original position.

15.3.2. Arrange Columns in a Table
 ● Columns can be rearranged by clicking and dragging the column headings.

15.4. Showing Summaries on the 
Table

Summary information can be added to the bottom of all 
columns of the Table.  Statistical summaries available 
are No Summary, Minimum, Average, Maximum and Sum.

This allows for simple statistical analysis to be done on the data on view in the Table.  
Only one statistic can be displayed at a time for each column.

To add a summary to the bottom of a column use one of 
the following methods:

 ● Highlight a cell in a table, then from the menu bar 
select Table ⇒ Summarise and choose an option 
from the list.

Channel selection grid
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 ● Highlight a cell and right-click, select Summarise and choose an option from the 
list.

15.5. Adding Comments to a Table
Comments can be added to individual data points in a Table allowing the user to 
correlate a particular event of interest with the selected data.

To add a comment to a table use one of the following methods:

 ● Highlight a cell, then from the menu bar select Table ⇒ Comments and select 
Add Comment from the list.  Note that the list also provides options for editing or 
deleting existing comments.

 ● Highlight a cell and right-click, select Comments then select Add Comment from 
the list.

When a comment has been added to a Table, an indicator will appear in the top right 
hand corner of the data holding the comment.

Moving the mouse over this indicator will cause the comment text to be shown.

15.6. Saving Tables as Favourites
Favourites are provided as a mechanism for saving all Table settings (column 
positions, summary information, etc.) such that the Table can be easily recalled at a 
later time.

The Scheme can support an unlimited number of Favourites allowing for quick and 
easy access to the most desirable view of the data.

 ● From the menu select Favourites ⇒ Save Table.
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 ● An input box titled Save Table as Favourite will appear.  Type the name of the 
Favourite and choose OK.

The Table will now be on the list of Table Favourites in the Favourites menu.

15.7. Additional Table Display Options
Other options for Table display are available from Options ⇒ Magpie Settings… in the 
menu and clicking on the Tables page.  These settings apply to all Tables displayed.

15.7.1. Date and Time Formatting 
These options allow the user to specify a preferred format for the display of time and 
date in Table display.  The user can use the default Windows time and date formatting 
or specify a different format using this form.

15.7.1.1. Date Formatting

Export file dates can assume the standard Windows date format (this is set in the 
Windows Control Panel).  Magpie 3 also allows the user to specify an alternative date 
format.  Click on the drop down list and select a preferred format or enter your own.
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Specifier Displays
c Displays the date using the Windows short date setting
d Displays the day as a number without a leading zero (1-31)
dd Displays the day as a number with a leading zero (01-31)
ddd Displays the day as an abbreviation (Sun-Sat)
dddd Displays the day as a full name (Sunday-Saturday)
ddddd Displays the date using short date format
dddddd Displays the date using long date format
m Displays the month as a number without a leading zero (1-12)
mm Displays the month as a number with a leading zero (01-12)
mmm Displays the month as an abbreviation (Jan-Dec)
mmmm Displays the month as a full name (Janauary-December)
yy Displays the year as a two-digit number (00-99)
yyyy Displays the year as a four-digit number (0000-9999)

15.7.1.2. Time Formatting

Export file times can assume the standard Windows time format (this is set in the 
Windows Control Panel).  Magpie 3 also allows the user to specify an alternative time 
format.  Click on the drop down list and select a preferred format or enter your own.

Specifier Displays
h Displays the hour without a leading zero (0-23)
hh Displays the hour with a leading zero (00-23)
n Displays the minute without a leading zero (0-59)
nn Displays the minute with a leading zero (00-59)
s Displays the second without a leading zero (0-59)
ss.xx Displays the seconds with milliseconds with a leading zero (00-59)
t Displays the time using the format given by the ShortTimeFormat 

global variable
tt Displays the time using the format given by the LongTimeFormat 

global variable
am/pm Uses the 12-hour clock for the preceding h or hh specifier, and displays 

'am' for any hour before noon, and 'pm' for any hour after noon.  The 
am/pm specifier can use lower, upper, or mixed case, and the result is 
displayed accordingly.
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15.8. Copying Data to the Windows Clipboard
The Windows Clipboard provides a simple, standard mechanism for transferring data 
between applications.  To copy data using the clipboard:

 ● Open the required Table (from the Table or Favourites menu).

 ● Move the mouse cursor to the top left of the data to be selected.

 ● Press and hold down the left mouse button.

 ● Drag the cursor to the bottom right of the data.

 ● Click on the Copy to Clipboard icon at the bottom of the screen, or alternatively 
right-click the mouse on the Table and select Copy from the popup menu.

 ● Run the destination application and paste the contents of the clipboard into that 
application.

15.9. Exporting Data from a Table
A number of methods are provided by Magpie 3 to allow data to be exported to a third 
party program for further manipulation.

 ● From the menu or toolbar, open the Table from which data is to be exported.

 ● Use the Navigator to select the date and time range to be exported.

 ● From the menu select Table ⇒ Export Table.
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 ● When the Export Table form appears, the name of the Table from which data will 
be exported is displayed.  There are also additional fields that can be modified 
to control the way the export file is generated.

Export File Type
Magpie 3 can export the data in a number of standard formats.

CSV
Comma Separated Variable.  This format is a standard format used in many programs.  
Each field is separated by a comma.

HTML
Hyper Text Mark-up Language.  This is the standard format for web pages.  By 
choosing this format, data can be easily posted to a web site.

XML
Extensible Mark-up Language.  This is a standard way of storing data that can later 
be accessed by web sites.

Export File Name
Click on the browse button to select the name of a file to export data to.  Alternatively, 
type an export file name.

For each Table, Magpie 3 will remember the selected export format and export file 
name.

 ● Click on the Export button to begin the export process.

Note: Tables with very large amounts of data may take some time to be exported.  
Magpie 3 will indicate when the export process is complete.

15.10. Additional export options
Other options for exporting are available from Options ⇒ Magpie Settings… in the 
menu and clicking on the Export page.  These settings apply to all exported data.

The additional export options allow separate time and date formats to be set for Table 
exporting so that data can be exported in the most desirable format for use by third 
party applications.

The time and date selection formats are the same as for Table display as shown in 
“Additional Table display options” - see section 16.7.

Additionally, it is possible to select whether titles are exported with the data.



www.mea.com.au   Page  75

User Manual for Magpie 3

Note: If summaries are displayed in the Table then these summaries will be appended 
to the exported data.

15.11. Printing Table Data
Table printing is very similar to Table exporting except that the results are sent to a 
printed page.

Care needs to be used when printing Tables with large numbers of records as this will 
result in an excess number of pages being printed.

15.11.1. To Print a Table:
 ● Open the Table of interest (from the Table or Favourites menu)..

 ● From the menu select File ⇒ Print.

15.11.2. Additional Printing Options
There are a range of additional options that can be used to control the printed Table 
result.  These additional settings can be accessed from Options ⇒ Magpie Settings… 
in the menu and selecting the Printing page.
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16. Wind Roses
A Wind Rose is a type of Graph that is used to represent wind speed versus wind 
direction.  Wind Roses also display what percentage of time the wind was blowing 
from each compass direction.  It has the advantage of being easier to interpret than a 
traditional bar Graph.

A Wind Rose is drawn on a compass where each petal represents the percentage of 
time wind was blowing from each respective direction.  In the example above the wind 
was mostly blowing from South-Southwest. 
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The values down the South axis are the percentages.  Notice how the centre of the 
compass is not zero.  This is deliberately done to prevent the middle of the Wind Rose 
becoming cluttered.  Instead, the zero percentage radius is spaced out a little and is 
the circle from which all the petals start from.

Each petal is divided into a series of coloured bins, which each bin representing a 
range of wind speeds.

16.1. Creating a New Wind Rose
To create a Wind Rose in Magpie 3 you must first open a Magpie Scheme that 
contains wind speed and direction information.   Once the Scheme is open, select 
Wind Rose ⇒ New Wind Rose from the main menu. 

16.1.1. Source Data
There is no Wind Rose yet because Magpie 3 needs to know which fields to use.  This 
is done via the Source Data panel.  Magpie 3 will hint you through the necessary 
steps to create a new Wind Rose.

Scheme
If you have a Project open you will first need to select the 
Scheme from the drop-down menu.  If the menu is disabled 
you can ignore this step. 

Table
Select an appropriate Table from the drop-down menu.

Wind direction and Wind speed
Select the Wind direction and Wind speed fields as desired. 

Direction and speed from same table?
If the wind direction and wind speed data is located in separate Tables you can 
uncheck the Direction and speed from same Table? option to use different source 
Tables.
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Attempt to filter instrument lists?
This function searches for instrument names containing "wind", "wnd", "dir", "speed" 
and "spd" and will present only those instruments for selection if found.  If you have 
labelled your wind instruments differently you can uncheck.

Once everything has been selected the new Wind Rose will be automatically 
generated.

Note: Depending on the settings of your Magpie Scheme you may see some source 
data options that are not valid wind speed or direction fields.  If you attempt to create 
a Wind Rose from these fields Magpie 3 will alert you that you have selected invalid 
data.

16.1.2. Changing the Wind Rose Title
 ● Click on the current Wind Rose title (by default this will be the Scheme or Project 

name, depending on which is open)

 ● Enter the new title in the popup and press OK

16.1.3. Bin Ranges
Underneath the Source Data panel is the Bin Ranges panel.  You can use this panel 
to change what range of values each part of the petal will include.

When changing these values ensure that each field is greater than or equal to the 
field preceding it.  Magpie 3 will warn you if you have 
entered an invalid range (e.g. 3 - 2 m/s does not make 
sense).

The default values can be restored at any time by 
pressing the Defaults button.

Note: Setting two or more of these fields to the same 
value will result in certain bars of the petal being 
excluded.

16.1.4. Changing the Bin Colours
The Wind Rose is drawn using the same colours as set for regular Graphs. 

 ● Click on Options ⇒ Magpie Settings… 

 ● Select Graphing to show the Graph options page

 ● The bin colours are derived from the first nine series.
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 ● The new colours will be automatically applied to all Wind Roses when you click 
OK.

Note: Click the Monochrome Graph checkbox to have Magpie 3 use an alternating 
black and white sequence for the bin colours.

16.1.5. Time Limitations
Values used to generate the Wind Rose can be filtered 
such that data is only displayed for a specific time 
range for each day.  For example, perhaps you are only 
interested in what the wind is doing between 9:00AM 
and 12:00PM.

To use this, click the Use Time Limitations checkbox 
in the options panel to the left and select your desired 
range.

Note: As the time is restricted for each day, it is not possible to specify time ranges 
through midnight (e.g. 11:00PM - 1:00AM). 

16.1.6. Limiting Data by Date
The Wind Rose module uses the Magpie Navigator bar to restrict source data by date 
or reference.

16.1.7. Additional Options
There are a couple of extra options that can be independently toggled on or off as 
desired:

Include source data information
This will add information to the bottom-left corner of 
the Wind Rose that states the Scheme, Table(s) and 
measurements that the Wind Rose was generated from. 

Skinny Wind Rose
When checked, all of the Wind Rose petals will have half their default width. This 
option is intended for use with small Wind Roses where the normal widths would 
cause the petals to overlap.
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16.1.8. Displaying the Control Panel
In the top-left corner of the Wind Rose is a button with a blue arrow pointing left.  
Clicking on this will cause all of the options to disappear, leaving more space for 
the Wind Rose to take up.  This is handy if you have a small Wind Rose window.

When the panel is hidden the button will change to an arrow pointing right, which 
can be clicked to bring back the control panel. 

16.2. Saving Wind Roses as Favourites
 ● Set the Wind Rose up as you desire, and then click on 

the Favourites menu.

 ● Select Save Wind Rose.

 ● A Save Wind Rose as Favourite form will appear.  You 
will be prompted to enter a name for this 
Favourite, and that’s it!

To open a saved Favourite:

 ● From the menu bar, select Favourites ⇒ Wind Rose and then select the name 
you gave the Favourite. 

16.3. Saving a Wind Rose Image
To save an image:

 ● From the menu bar, select the Wind Rose menu and select Save Wind Rose 
Image.  
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 ● Aternatively, right-clicking anywhere on the Wind Rose will display some options, 
and you can then left-click on Save Wind Rose Image to bring up the save 
options dialog box.

Through the saving options you are able to modify the size and - if saving with JPEG 
format - the quality. 

Size to Scale
The default scale and dimension values are those of the Wind Rose as it is currently 
displayed.  If you desire a smaller image you can reduce the scale percent.  There is 
an imposed minimum scale to ensure the saved image is still comprehensible.

Size to Dimension
Size to Dimension is an alternative to Size to Scale.  Specify a width and height in 
pixels, which is also possible.  The height and width can be set independently of each 
other.  If you wish the keep the ratio you should use the scale option instead.

Save
Click the Save button to bring up the save file browser.



www.mea.com.au   Page  82

User Manual for Magpie 3

There are four file formats available, which can be changed by the Save as type: 
dropdown menu. 

Image quality
Quality is only relevant if you are saving the image with JPEG format.  The default 
value is set to 50%.  This produces files of approximately a quarter of the file size as 
100% quality ones without any visible image degradation.

16.4. Exporting Wind Rose Data
The data used to draw the current Wind Rose can be exported to a comma-separated 
variable file (CSV).  This will tell you the exact percentage of measurements in each 
direction for each wind range.  Exported CSV files also include the appropriate date 
range, time range and number of measurements used to produce the Graph.

To export the data

 ● Select Export Wind Rose Data from the Wind Rose menu, or right-click on the 
Wind Rose and select Export Data as a CSV File. 

16.5. Printing a Wind Rose
It is possible to print the current Wind Rose directly from Magpie 3.

To print a Wind Rose:

 ● Select Print from the File menu.

Alternatively, you may right-click on the Wind Rose and select Print Wind Rose.  
Options include whether to print portrait or landscape, colour or black and white etc.

Note: If you are printing in black and white, it might be worth considering setting the 
Graph colours to monochrome as explained in the section 16.1.4  Changing the Bin 
Colours.
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17. Real Time Information
Real Time Information (RTI) screens allow you to see at what is currently happening 
in the measurement system without having to unload any data.

17.1. Standard Real Time Information
The Standard RTI screen shows current values for each instrument connected to the 
system along with the Logger status.  When connected to the Data Logger the values 
on the RTI screen will be updated at the scan rate of the Logger.

Channel Inputs

Logger Information

Channel Selection 
Grid
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To display the RTI select Logger ⇒ Real Time Information ⇒ Standard.

If the system is accessed by telemetry then a manual dial-up connection must be made 
before RTI screens will begin updating.  To make a manual dial-up connection 
select Logger ⇒ Dial.

17.1.1. Logger Information
The Logger Information section shows:

Scheme Name
This confirms the name of the Scheme currently loaded into the Data Logger, and 
should be the same as the Scheme open in Magpie 3.

Logger State
When the Logger is operating normally the state will be Logging.

When the Logger has just been loaded with the Scheme the state will be Primed.

If the Input Signals connector has been removed from the Input Signals port on the 
Logger, it will stop logging, and the state will be Stopped.  In order to return to a 
Logging state, the Logger must be re-loaded with a Scheme.

Scan Rate
The Logger scan rate is the primary sampling rate for all sensors, and should reflect 
the scan rate setting in the Scheme.

Logger Time
When viewing the Standard RTI, it is worth checking that the time and date in the 
Logger are correct.  The Logger takes its time (and date) from the computer which 
was used to load the Scheme into it.  The time does not automatically change to 
accommodate Daylight Savings.  Most users leave their Logger on local Standard 
Time throughout the year.

If required, the time and date can be changed without re-loading the whole Scheme 
by selecting Logger ⇒ Advanced ⇒ Set Logger Time.

17.1.2. Channel Inputs
Channel inputs can be selected for viewing on the real time screen by using the 
Channel Selection Grid.  This is useful when there are a large number of instruments 
in the system.
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17.1.3. Saving Standard RTI Screens as Favourites
After selecting a set of channels to display on the RTI screen, it is possible to save 
the selection as a Favourite for easy recall at a later date.  This allows the user to 
create a range of RTI screens for the display of specific sets of channels.  An example 
could be a weather station with both climate and soil moisture sensors.  It is possible 
to make two different RTI screens, one with only climate sensors and the other with 
only soil moisture sensors.

 ● From the menu select Favourites ⇒ Save Real Time Screen.

 ● An input box titled Save Real Time As Favourite will appear.  Type the name of 
the Favourite and press OK.

 ● The real time screen will now be available in the list of Real Time Favourites 
under the Favourites menu.

17.2. Other Real Time Information
Along with Standard RTI, Magpie 3 provides a number of other RTI screens to observe 
the status of the data Logger and the system.

17.2.1. Buffers Information
The Buffers RTI screen displays the status of each Log Buffer.  To display Buffers 
information select Logger ⇒ Real Time Information ⇒ Buffer Information.  For each 
log buffer there are a number of entries:

Status: Circular or Linear
When a circular Buffer reaches capacity it will begin overwriting the earliest data.  
When a linear Buffer reaches capacity it will stop writing data to the Buffer.

First Log
This is the time of the first log taken by the Logger after it was last programmed.

Note: If the Buffer is circular and the Logger has been logging for some time, this will 
not necessarily be the earliest record available for unloading.

Last Log
This is the time of the most recent log taken by the Buffer.

Log Interval
This is the rate at which data is stored.
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Log Size
Indicates how many bytes are stored in the Buffer with each log.

Total Bytes Logged
Indicates how many bytes have been logged by the Buffer since the Logger was last 
programmed.  Once again, depending on how long the Logger has been logging, this 
does not mean that this number log bytes is available for unloading.

17.2.2. Logger Information
The Logger RTI screen displays information such as the Serial Number, Firmware 
version, internal configuration details, and the raw input values for the Counter and 
Analogue channels.  The screen displayed will depend on the Logger model used by 
the Scheme.  To display Logger information choose Logger ⇒ Real Time Information 
⇒ Logger Information.
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17.3. Other RTI Screens
Many Schemes will have libraries added that provide the system with some additional 
functionality.  Some examples include controlling telemetry system power, sending 
short messages, alarms etc.  Many of these libraries will create additional RTI screens 
that can be opened from Logger ⇒ Real Time Information ⇒ Other… for viewing.  
This allows the function of the library (and any associated hardware) to be diagnosed 
by the user.

17.4. Printing Real Time Data
The details displayed in the RTI screen can be printed at any time.  To print real time 
data:

 ● Open the RTI screen of interest (from the Logger or Favourites menu).

 ● From the menu select File ⇒ Print.

17.5. Real Time Data Takes Time To Update
In general, Real Time Information screens should update at the Logger scan rate, 
however when an RTI screen is first opened it may take some time before valid 
Real Time Data appears on the screen.  Prior to this, the values that appear on the 
screen may appear incorrect.  This is the result of default values being processed 
with reference to the instrument scaling values defined in the Scheme.  Once 
communications is established with the Data Logger, the real time screen will be 
updated with correct information.

The rate of update of information will also depend on the speed of the logger to 
computer connection: a direct cable connection will usually update each Logger scan, 
whilst a dial-up connection will result in less frequent updates.  Individual sensor 
values will  update less frequently if those sensors are being powered and sampled 
less frequently.  See your individual system documentation for details.
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18. Validation Errors
Each instrument fitted to the Scheme can have a series of validation limits associated 
with it.  When data from the instrument is imported into the Scheme databases, 
Magpie 3 will test the values against the validation limits assigned to the instrument.  
If the data does not satisfy the requirements of these limits then a validation error is 
raised.  This function is useful for keeping track of critical parameters such as the 
system battery voltage.

18.1. Setting Validation Limits
To set validation limits for an instrument, or to see if limits have already been applied, 
do the following:

 ● Open the Scheme Editor

 ● Go Configuration ⇒ Instruments and select the instrument you want

 ● Go to the bottom of the Instrument Details section, and select {Limits} in the field 
adjacent to Validation Limits.  The following dialog will be displayed:

 ● To set the validation limits check the Less than and Greater than boxes and 
type your desired limits into the fields.  Magpie 3 will automatically use the units 
specified for the instrument.

18.2. Viewing Validation Errors
At the completion of importing new data into the Scheme databases, the software 
will check to see if there are any new validation errors.  If so, the user will receive a 
prompt from the software indicating that there are new validation errors, allowing the 
user the choice to view these errors immediately.  To display the validation errors 
window choose View ⇒ Validation Errors from the menu.
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New validation errors appear in Red.  They will remain this colour until acknowledged 
or deleted.

18.3. Acknowledging Errors
To acknowledge a validation error but keep it in the list, click on the 
Acknowledge button or simply double click the entry.  You can press [ctrl] 
+ [a] to select all entries so you can acknowledge them all at once. 

18.4. Deleting Errors
To remove one or more selected validation errors entirely, click on the Delete 
button.

18.5. Validation Error Details
Source
This is the Scheme database from which the error was generated.  More than one 
database in the Scheme could be a source of the same validation error.

Type
This is the type of validation error and includes the channel name and a description 
of the condition that was tested.

Started/Ended
The software will identify when the condition first occurred and when it finished.  
These dates and time are displayed with the error.

Comments
This is the user defined comment attached to the instrument in the Scheme editor 
when the validation error is enabled.  This allows the user to specify some action or 
offer additional information when this condition occurs.
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19. Miscellaneous Features
19.1. Log File
Magpie 3 maintains a log file for all Schemes.  The log file contains a list of transactions 
that are time and date stamped.  These transactions form a history of usage of the 
Scheme.  Most errors that occur in the software are recorded in the log file.  To 
display the log file:

 ● Select View ⇒ Log File from the menu bar.

19.2. Advanced Logger Commands
The Logger menu provides a number of Advanced commands.  To access these 
commands: 

 ● From the menu bar, select Logger ⇒ Advanced, and select a command from 
the list.

Initialise Logger

Initialising a Logger is the process of waking a Logger which has gone to sleep.  The 
Logger can be in sleep mode for a number of reasons from low battery, internal error 
or battery replacement.  It is also possible to turn the Logger OFF (put it into sleep 
mode) via the CONFIG menu on the Logger's keypad.  This can be done to conserve 
battery life during transit.

 ● To initialise the Logger, select Logger ⇒ Advanced ⇒ Initialise.

The computer will toggle the RTS line to the Logger in an attempt to wake it up.   It 
then sends an initialise command to force the Logger to come out of sleep mode.  
This function will not cause any harm to the logging system or any data loss.
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SDI-12 Test Mode
The SDI-12 test mode is useful for allowing the user to communicate directly with 
SDI-12 connected sensors.

 ● To enter SDI-12 test mode, select Logger ⇒ Advanced ⇒ SDI-12 Test Mode.

The Logger operates in this SDI-12 transparent mode until the user exits.  The 
Logger's clock will be suspended whilst in SDI-12 test mode; no recording will occur 
until the user exits the test mode.

Set Logger Time
The time and date can be changed without reloading the entire Scheme (and so 
without deleting any data currently in the Logger memory).

 ● To set the Logger time, select Logger ⇒ Advanced ⇒ Set Logger Time.

User Reset Variables
A handful of instruments in the Magpie library will generate free running statistics 
such as averages, totals, minima and maxima.  These statistics can be triggered to 
reset by the user.  This is useful for maintaining records between sites visits, etc.

 ● To reset variables select Logger ⇒ Advanced ⇒ User Reset Variables.

If viewing data on a RTI screen, the statistics affected will reset themselves within 2 
or 3 scans.
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20. Scheme Creation
When a complete logging system is purchased from MEA, it will be supplied with a 
Scheme that best supports the sensors and features of the system.  Both Scheme 
and system are rigorously tested prior to shipping.  Sometimes it is desirable for the 
user to make changes to the scheme operation, such as changing logging intervals or 
changing the time when the system dial-in modem is available.  It is recommended that 
users seek advice from MEA before making large changes to the Scheme supplied 
with the system, as improper changes will adversely affect its operation.  Refer to 
the system-specific documentation which was provided with the hardware; this will 
explain the more common Scheme attributes that the user may desire to change.

The following sections describe the creation of new Schemes.

20.1. Preparation
Before beginning to build a Scheme, it is worthwhile to have an understanding of 
the instruments and type of data Logger being used.  Mapping out all instruments, 
their output types and the corresponding Logger input channels before building the 
Scheme will greatly reduce the likelihood of errors.

This also includes channels added using additional system hardware (e.g.  MEA 
Radio).

Data Type Sensor Output Channel
Climate Wind Speed Pulse Counter 0
Climate Rain Gauge Pulse Counter 1
Soil Moisture Theta Probe 1 Voltage Analogue 1

With this information in hand you can build the Scheme by following a number of 
simple steps:

20.2. Creating a Scheme
 ● Select File ⇒ New Scheme or select the New Magpie File button on the 

toolbar.

 ● After selecting the New Magpie File button, the New 
Magpie File screen will display.  Select New Scheme.
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The New Scheme Wizard will be displayed.

A choice of Logger type and model must be made at this stage:

 ● Select the Logger type.  At the time of this revision of the Manual, Magpie 3 only 
supports Unidata Loggers.  This may change in the future.

 ● Select the model of Logger from the Models list.  The model cannot be changed 
once the Scheme is created.

 ● Click on the Next button to continue.

The second page requests the Scheme name, title and destination.
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Name
Type in a short form name that you will use to identify this Scheme (maximum of 8 
characters).  This is the name that will be loaded into the Logger to distinguish one 
Logger from the next.

Title
Type in a descriptive title to help you identify this Scheme at a later time.

Destination
Magpie 3 will display a default location for you within the Magpie/Schemes folder 
for the Scheme.  To choose an alternative location, click on the Browse button  or 
simply type a preferred path to the Scheme.

Click the Create button to create the Scheme.

20.3. The Scheme Editor
Magpie 3 will create the new Scheme and open the Scheme Editor to allow the 
Scheme definition to be completed.  Scheme information is accessed by selecting 
items from Scheme Pages.  The Scheme Pages are split into three categories.
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20.3.1. Operation
The pages in the Operation category are:

20.3.1.1. General

This page allows a Scheme title and comments to be entered for the Scheme.  
Comments is a memo entry field and is a good place to keep track of versions of the 
Scheme or who changed it and when.  Entries in the Comments field do not affect the 
operation of the system.

20.3.1.2. User Settings

User Settings are parameters that result from custom source code interfaces or 
sensor specific code that a user can change in order to alter the way that code runs in 
the data Logger.  These settings might be times when particular events are to occur, 
messages or thresholds, etc.

20.3.1.3. Communications

The communications page allows the user to modify the communications port, baud 
rate, telemetry and FTP settings.  Changes made here do not require the Logger to 
be re-loaded.

20.3.2. Configuration
Configuration pages are all about the building of the Scheme.  A user with a basic 
understanding of Magpie 3 and the Unidata Logger can construct a Scheme within 
the Configuration pages.  The pages in this category are:

20.3.2.1. Data Logger

The data Logger page gives details of the Logger model selected for this Scheme, 
and allows the user to change the Scan rate.

20.3.2.2. Instruments

The Instruments page is where all instruments are described in the Scheme.  
Instruments can be sensors and other supporting hardware that can be added 
multiple times to the Scheme, or 'virtual' instruments.

20.3.2.3. Logging

The Logging page allows the user to describe how to log selected instruments and the 
rate at which they are logged.  Logging is defined in terms of Buffers and the Logger 
can offer up to eight Buffers for different logging schedules or sensor groupings.
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20.3.2.4. Events

The Events page allows the user to describe conditions that the Logger can identify 
as an event of interest.  The Logger can take action as a result of the event in the 
form of either triggering the logging of data or initiating some Logger output control 
function.

20.3.2.5. SDI-12

Magpie 3 has extensive support for SDI-12 and provides an SDI-12 page for the 
mapping of sensor addresses, data values, conversion types, etc.

20.3.3. Advanced
The Advanced pages are for users who have a complete understanding of the 
Unidata Logger and Magpie Scheme building.  Uninformed alteration of settings in 
these pages can result in improper measurement system function or total failure.

20.3.3.1. Communications

Advanced communications include the scripts for dialling, hanging up, loading and 
unloading.  Scripts can be customised.

20.3.3.2. Program

The Program page contains references to allow source code libraries operating in this 
Scheme.  It also includes parameters that an advanced user can use to modify the 
operation of these libraries.

20.3.3.3. Configuration

The Configuration page allows the Logger non-volatile configuration to be edited.  
This is commonly referred to as the Logger CDT (Configuration Data Table).

20.3.3.4. User Libraries

Magpie 3 enables users to create their own user-defined libraries that can be attached 
to other Schemes in order to offer the same customisations.  This way, future Magpie 
3 updates do not threaten the customisation work performed by the user.
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20.4. Editing a Scheme
20.4.1. Operation ⇒ Communications
To communicate with the data Logger the communications settings in the Scheme 
must be set correctly.  Refer to section 9. Logger Communications for a detailed 
explanation of Scheme communications settings.

20.4.2. Configuration ⇒ Data Logger ⇒ Scan rate
The Unidata Logger is highly energy efficient because for the bulk of the time the 
Logger is asleep and doing no work.  The data Logger wakes up at a rate called the 
scan rate to make measurements, run the Scheme program and then fall back to 
sleep.  The scan execution time will vary depending on the complexity of the Scheme 
program however most scans will execute in well under 50 milliseconds.

There are other processes that will keep the Logger awake for longer (communications, 
SDI-12, etc.) however these have a minimal effect on the Logger “on” time in most 
applications.

A typical scan rate for a StarLogger is 5 seconds and at this rate (assuming the 
Logger is not powering sensors with a high current consumption) the Loggers' internal 
battery can last up to 2 years.  When the Logger is powering high current consumption 
sensors it is possible to change the scan rate on the Data Logger page of the Scheme 
editor.

For example, doubling the scan rate (say from 5 to 10 seconds) halves the energy 
consumed and doubles battery lifetime.

Since Logger communications are linked to the scan rate, a longer scan rate can lead 
to longer delays during communications.

Note: Some Magpie 3 source code libraries use “scans” rather than “seconds” as 
parameters to control the function of the library.  Arbitrarily changing the Logger scan 
rate without giving consideration to the effects on any of these libraries can cause 
improper program function in the Logger.

20.4.3. Configuration ⇒ Instruments
All devices added to the data Logger are described as Instruments.  An instrument 
can be a sensor, some other peripheral device or even a software calculation.  Each 
instrument must be added to the Scheme and then configured to ensure that it is 
measured and displayed correctly.
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20.4.3.1. Add Instruments

Instruments are added from the Instrument Library by pressing the Add button.  
Initially, pressing the Add button will display a list of all instruments in the Instrument 
Library.  Subsequent presses of the Add button will add the selected instrument to 
the Scheme.

20.4.3.2. Search for an Instrument in the Library

A search facility has been added to make it easier to find instruments in the library.  
To search, type some characters from the model number, name or category of the 
required sensor in the search box and click on the Search button.

Alternatively, click on the Model, Description or Category column headers to sort the 
list according to the selected column and then scroll down the list until the required 
sensor is located.

Once the sensor is found, click on it with the mouse to highlight it, and then click on 
the Add button to add the selected instrument to the Scheme.  Alternatively, just 
double click the instrument in the library.

Add the required number of sensors (more can be added easily at a later date).  To 
minimise the Instrument Library, click on the white arrow in the right-hand end of the 
library title bar (or simply double click anywhere on the bar itself).

Search

Add
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As instruments are added to the Scheme, the Instruments List will display the name 
of each instrument added.

20.4.3.3. Edit Instrument Details

Once instruments have been added from the library, the details of each instrument 
will most likely need to be changed to reflect specific instrument details (i.e. Logger 
channel, instrument name, scaling, etc.).

The Instruments List displays a list of all instruments described in the Scheme.  When 
an instrument is selected in this list the details of the instrument are displayed in the 
Instrument Details panel on the right.

The following is a description of each of the Instrument Details settings:

Model
Every instrument in the instrument library has a unique model name.  The model 
name cannot be modified in the Scheme editor.  All Logger source code required for 
the instrument is linked to the model name.

Description
This is the description for this model of instrument.  The description usually contains 
information about the manufacturer and type of instrument.  Whilst it can be changed 
in the Scheme editor, the description is not used anywhere else in Magpie 3.

Name
The name of the instrument is used in all views throughout Magpie 3 operation.  
Changing the name will modify labels in Graphs, Tables, Real Time displays and 
reports.  Note that the name can also be used as an argument to formulae for other 
instruments and care must be taken when other instruments refer to this name.  The 
name must be unique.

Units
The units are displayed along with the instrument name in all views that show data in 
the software.
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Channel
This is the Data Logger channel that the instrument is fitted to.  This can be a real 
Logger channel selected from the drop down list or a virtual Logger channel whose 
name must be entered by the user.

 ● [Channel] Type

This tells the Scheme editor what type of channel is being used.  The channel may 
be treated as a voltage or current or simply as an un-scaled Logger memory value.  
Different models of Logger will have different channel types available for selection.  
The channel type is an integral part of the scaling for the instrument and must be 
selected correctly.

 ● [Channel] Minimum / Maximum

The channel range indicates the expected input range for the chosen channel type.  
The user can modify this to specify a different input range which is then carried 
through to the scaling of the instrument.

For example, if a voltage instrument is being used in the Scheme and the default 
channel input range is 0 to 2550 mV but the instrument of choice has a specified 
voltage output range of 100 to 500 mV then the channel range can be modified to 
reflect this range.  Then, when the scaling for the instrument is specified, the user can 
enter the relationship directly without needing to consider the Logger channel input 
range.

Note: When formula scaling (see below) is used, Magpie 3 processes the raw binary 
value from the Logger memory and not the scaled version from the channel type/
range settings.  This is a limitation and not by design.

Scaling
The channel scaling type describes how the values from the Data Logger are scaled 
in order to display instrument values in engineering units.  There are two linear fits 'A 
gain B' or ‘A to B’, or a ‘Formula’ option that allows more complex processing via a 
reverse polish notation calculator.

 ● ‘A’ gain ‘B’ is a linear scaling option.

‘A’ is the offset and ‘B’ is the gain. (e.g. f(x) = Bx + A)

If A = 10 and B = 0.1 and the channel measurement is 20 then the scaled result will 
be 20 * 0.1 + 10 = 12.

 ● ‘A’ to ‘B’ is a linear scaling option.
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‘A’ represents the scaled result at the minimum channel input value and ‘B’ represents 
the scaled result at the maximum channel input value.  Using the two endpoints, the 
software will calculate the scaling for the line and be able to generate scaled values 
for any channel input.

 ● ‘Formula’ is an RPN (Reverse Polish Notation) formula

Reverse Polish Notation is a method of calculating complex non-linear equations 
allowing the combination of values from one or more other sensors if required.  The 
standard formula library is FORMULA.LIB.  User defined formula libraries can also 
be included with the Scheme.

Note: The scaling is usually only applied to the number stored in the Logger memory 
during processing of unloaded data or during RTI display.  The number is not stored in 
the Logger memory as a scaled number.  If the user requires this channel to be stored 
in the Logger memory with scaling included then they should choose an instrument 
that generates a scaled result in the Logger.  Instruments that generate a scaled 
result in the Logger generally have an 'i' suffix.

Display Type
Controls how the processed value will be displayed.  Options are –

Real is a real number.

Real (No Keyboard) is a real number that is not displayed on the Logger display.

Real (No Real Time) is a real number (not displayed in Real Time Information)

String is text result from a formula (this will not be displayed on Logger display)

None means that the result of this instrument will never be displayed in RTI, Graphs 
or Tables (most commonly used when the instrument result needs to be calculated 
and fed into the formula for another instrument).

 ● [Display] Minimum

This is used by the software to offer the default minimum value on the Graph axis 
when Graphing the data.

 ● [Display] Maximum

This is used by the software to offer the default maximum value on the Graph axis 
when Graphing the data.
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 ● [Display] Width

This determines how the result of this instrument is displayed and stored in the 
database.  It is important that this is set correctly because the fields in the database 
are created on the basis of this selection.  If the result of the instrument exceeds the 
width specified then the software may have difficulty displaying the result.

eg # # #. # # means 3 digits before the decimal point and 2 digits after the 
decimal point.  The width setting can be selected from the drop down list or entered 
manually.

Parameters
Many instruments that use virtual 
channels have a list of parameters which 
allow the user to control how that code 
behaves.  Click on the blue hyperlink to 
open the parameters form.

Validation Limits
Each instrument offers a high and 
low validation rule that can be 
applied to data that is processed 
into the database.  This allows 
the user to establish an automatic 
check of data unloaded from the 
Logger - see section 18 Validation 
Errors for more details.
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20.4.4. Configuration ⇒ Logging
Magpie 3 can log data into as many as eight separate memory blocks in the data 
Logger memory.  These memory blocks are referred to as Buffers.  Each Buffer has 
its own program which dictates when to log instrument values and what instruments 
to log.

20.4.4.1. Choose a Buffer

A logging Buffer is enabled by first selecting the required Buffer from the drop down 
list titled Selected Buffer and then by clicking the Use this buffer check box.

20.4.4.2. Logging Details

Buffer name
The Buffer name is used as the title for the Scheme database Tables.

Log data
This setting determines whether the data will be recorded on a simple time basis or 
whether it will be recorded based on an event defined in the Events page.

Log data options are:

 ● at the log interval
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 ● when an event is true

 ● at the log interval or when an event is true

The last option offers the ability to capture events of interest inside of a more normal 
logging regime.

Event to trigger logging
When the buffer is set to log on an event, a drop down box will allow the user to select 
the event that will be used to trigger logging.  Events are defined on the Events page.

Log data every
This is the fundamental rate at which data is recorded by the Logger.  Data is recorded 
aligned with the hour (i.e. 15 minute log interval is recorded at 10:00, 10:15, 10:30, 
10:45, etc.).  Select the time and unit to set the interval (i.e. 10 secs, 10 mins, 10 hours 
etc).

Logging can only occur at multiple intervals of the logger scan rate.  For example 
a 5 second scan rate means logging cannot occur more frequently than every five 
seconds - see section 21.4.2 for more information.

When triggering logging from events, the log interval controls the rate of data collection 
whilst the event is true.

Offset data by
The interval offset allows data logged to be offset in time for the selected log interval.  
For example, a log interval of four hours with an interval offset of 30 mins will log data 
at times of 4:30, 8:30, 12:30, etc.

Another example where this can be used is in daily data where the log interval is one 
day and the interval offset is 9 hours.  This will log data every 24 hours at 9am.

Sub interval
Use the sub interval to constrain the time over which average, minimum, maximum, 
total data is collected over the log interval.  For example a log interval of one hour 
with a sub interval of 10 mins will only process average, minimum, maximum, total 
information over the last 10 mins of each hour.

When buffer is full…
When the buffer memory is full the Logger can either stop logging (Linear buffer) or 
begin logging over the oldest data (Circular buffer).  If the buffer is set to stop when 
full then the Logger will need to be reloaded with the Scheme  to allow the buffer to 
begin logging new data.
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Buffer memory
Each buffer must have a percentage of the total Logger memory allocated to it.  The 
amount of memory will be determined by the rate of data collection, and the total 
number of log entries for the buffer.  The minimum memory increment is 1%.

An estimate of the capacity of the log buffer is shown in the bottom panel of the 
Logging Details page (there must be at least one log entry for this estimate to show 
a non-zero value).

Auto-Allocate
This button adjusts the Buffer memory percentages to achieve (as far as 
possible) an equal amount of logging time for each Buffer.

With event-based logging it is not possible to auto-allocate memory between buffers 
and the capacity shown is as if the event will always be true.  The user will need to 
estimate how much memory to allocate to the event Buffer based on the likelihood of 
the event being true.  This could involve some degree of 'trial and error'.

20.4.4.3. Log Entries

Click on the Log Entries button to show the log entries for the selected buffer.
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The instruments available for logging will appear in the Instruments list on the left and 
the Log Entries for the Scheme will be displayed on the right.

Add Log Entries
Click the Add button to add the selected instrument to the list.

Log Action
Once the new log entry has been added, click on the Log Action for the new log entry 
and choose the method the Logger should use to log this instrument.

Available logging methods are:

 ● Average records the average value of measurements taken over the log interval

 ● Minimum records the minimum value of measurements taken over the log 
interval

 ● Maximum records the maximum value of measurements taken over the log 
interval

 ● Raw Value records the instantaneous value from the sensor from the last scan 
of the log interval

 ● Total records the sum of all measurements taken over the log interval.  When 
choosing to sum a sensor value, specify the number of bytes to totalise.  This 
choice requires an understanding of the size of the channel and the expected 
range of values.  If unsure, use 4 bytes.

 ● Standard Deviation records the statistical standard deviation of all measurements 
taken over the log interval

Removing Log Entries
By clicking on an entry in the Log Entries list, the Remove button will be 
enabled and it will be possible to remove the log entry from the Scheme.

Note: Before making any changes to the log entry list, make sure that any wanted 
data is unloaded from the Logger first because changing the number or type of log 
entries will mean that the user will no longer be able to unload a Logger running the 
old Scheme program.
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“Cannot Unload” Indicator
On the Scheme editor status bar there is an indicator to inform the user that Scheme 
changes will prevent a Logger running the previous version of the Scheme from being 
unloaded.  This does not mean that there is anything wrong with the Scheme; it 
simply means that the list of log entries no longer matches the program that is running 
in the data Logger.  As a result, when Magpie 3 attempts to unload data from the 
Logger and reconcile this data with the Scheme information, errors will result.

Generally, only changes to logging information will show this indicator.  If there is data 
in the Logger that is still important cancel the Scheme changes, go back 
and unload the Logger, then implement the Scheme changes.

If this is not possible, then consider saving the Scheme to a new name, leaving the 
old Scheme intact whilst the required changes are made to the new Scheme.

20.5. Finish Editing
Adding instruments, defining log entries and setting the communications details is 
enough to produce a normal Scheme.

Press the Finish button to complete the Scheme.  The Scheme editor will 
execute a Build and Assemble to create a new Logger program.  

Note: Not all changes in the Scheme editor will trigger a program rebuild.  For 
example, changes in the Communications sections do not trigger a rebuild, and do 
not require the Logger to be re-programmed before unloading can occur.

20.6. Scheme Assembly Errors
If the Scheme building process fails then the Scheme editor will raise a prompt.  In 
some cases the prompt will offer the option to ignore the error and  close the Scheme 
Editor.  This allows the Scheme changes to be saved even though the Scheme is in 
error.
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Magpie 3 will not allow you to load the Logger with a Scheme that contains errors 
(a “broken” Scheme).  If an attempt is made to do this Magpie 3 will prompt you to 
correct the Scheme and try again.

It is highly recommended that the user return to the Scheme editor and correct the 
problem.  If the problem cannot subsequently be resolved then cancelling the Scheme 
editing will restore the Scheme to its pre-edited state.

Note: In most cases, assembly errors result from incorrect or missing parameter 
values associated with instruments or where calculation resulting from sensor scaling 
values cause an arithmetic overflow.

20.7. Load the Scheme into the Logger
Once the Scheme has been created without errors, it needs to be loaded into the 
Logger.

Load Indicator
The need to load the Logger is indicated by the text in the status 
bar of the Scheme editor which says:

Once the Logger is loaded, this message will disappear.

Note: Loading the Logger with the Scheme will erase all stored data.  Ensure that any 
wanted data is unloaded first.
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21. Advanced Scheme Editing
21.1. Virtual vs. Real Channels
The Unidata Logger provides a modest number of physical input channels.  Depending 
on the model there will be some analogue, counter and sense inputs.  Additionally the 
Logger provides SDI-12 and HSIO serial data buses.  These are referred to as Real 
channels.

Magpie 3 can make additional channels very easily.  These are not real physical 
channels on the Logger but software generated virtual channels.  Magpie 3 uses 
virtual channels to expand Logger capabilities, allowing for a large number of 
additional channels to be added by exploiting both SDI-12 and HSIO buses.  Magpie 
3 also uses virtual channels to store the results of instrument calculations.

Further, the results of real and/or virtual channels can be fed into other instruments to 
generate new channels.  An example of this is shown in the diagram below.

This example demonstrates how…

 ● Instrument 1

An analogue channel fitted with a current loop device can have the engineering 
result calculated by the Logger.

 ● Instrument 2

The engineering result can then be passed to another instrument responsible for 
making a rolling average of the current loop average.  This is useful for filtering 
out any unwanted fluctuations in the input.

 ● Instrument 3

The rolling average value can then be passed to another instrument that uses 
the input channel value as an index into a lookup Table of values (a rating Table 
or other relationship) to create the final value of interest.
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Instruments that have virtual channels can be used in logging and events just like 
instruments that derive from real channels.

21.1.1. Identifying an Instrument that uses a Virtual Channel
It is not immediately obvious in the Scheme editor that an instrument uses a virtual 
channel instead of a real channel.  However there are two key indicators of a virtual 
channel instrument.

Channel Selection
A virtual channel will be identified as such in 
the Instrument Details page.  The user must 
specify a unique channel name for a virtual 
channel.

Parameters
The second distinction between instruments with real and virtual channels is the use 
of parameters.  All instruments with virtual channels have some instrument specific 
source code which processes the data from one or more input channels in order to 
generate the new virtual channel.  The {Parameters} default text indicates that there 
are no parameters attached to the instrument.  When other text is displayed in the 
form of an assignment (eg InputChan=h0) then this indicates a virtual channel.
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21.1.2. What are parameters?
Parameters are constant values entered by the user that control how source code 
attached to an instrument will function.  In most cases, parameters are used to tell 
Magpie 3 how to create and maintain a virtual channel.

21.1.3. Editing the Parameters of a Virtual Instrument
When an instrument has parameters indicated click the blue underlined text to display 
the parameters editor.

Name
The source code reference used by Magpie 3 when building a program.

Value
Modified by the user as required.  If the Name is InputChan then the value can be 
selected from a drop down list of channels available from the Scheme.  Otherwise the 
Value must be typed by the user.

Comment
Is added from the sensor library.  It will indicate what the setting means or what logical 
options are available.  It can also be edited by the user to allow alternative comments 
if required, eg. to put in the serial number for an instrument with a unique calibration.

21.1.4. Global Parameters
If a parameter setting is common to a number of like instruments, the parameter name 
and value can be added to the Operation ⇒ User Settings or Advanced ⇒ Program 
⇒ Program Settings section of the Scheme.  The user can thereby avoid entering 
the same value more than once.  The parameter name must be removed from each 
instrument that is to defer to the alternate definition.

If an instrument requires a parameter setting which is different to the global setting, 
then the parameter can be specified in the Parameter Editor for that instrument.  
The local parameter setting will be used in preference to the global setting for that 
instrument.
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21.2. Advanced ⇒ Program

21.3. Interfaces
The Scheme building process in Magpie 3 is all about grabbing libraries of Logger 
source code and inserting them into a bare skeleton in order to make an appropriate 
program for a given system.  Some of this code is attached directly to instruments and 
may be replicated a number of times for each instance of that instrument type.  Other 
code is added to the Scheme just once in order to effect some function in the system 
as a whole.  These are referred to as Interfaces and are managed on the Program 
page of the Scheme editor.

Interfaces allow custom Logger source code to be written for specific applications.  
The interfaces can then be attached to any Scheme which requires this customised 
functionality.
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Magpie 3 provides a number of standard libraries that provide additional functionality 
to Schemes.  As long as the libraries added to the Scheme do not attempt to access 
Logger resources in a conflicting manner (i.e. by driving the same Logger output), all 
libraries can operate independently in the Logger.

Some examples of standard interfaces are…

Telemetry Power Control Library (TELEMPWR.LIB)
This library will drive a Logger output in order to power a telemetry device on or off 
at user specified intervals in the day.  This is intended as a power saving measure for 
systems that have a strict energy budget.

TELEMPWR.LIB monitors the system battery and will shut down the telemetry device 
entirely in low battery conditions.

TELEMPWR.LIB also monitors the state of the Logger RTS line and will not remove 
power from the telemetry device if there are active communications in progress.

Instrument Power Switching Library (MEA2107.LIB)
This library will drive a Logger output in order to power sensors at a required interval.  
This is intended to allow instruments with a high power consumption to be powered at 
intervals less frequent than the Logger scan rate.  MEA2107.LIB makes a clone of all 
native Logger channels and writes new results into these cloned channels only when 
valid readings are available.  Cloned channel  values remain stable during periods 
when power is not applied to sensors.

Note: Most interfaces will be added automatically when instruments are added to the 
Scheme.

21.3.1. Program settings
The Program Settings on the Program page are used to allow the function of attached 
interfaces to be changed by the user.
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As with interfaces, program settings are added automatically when an interface is 
added to the Scheme.  To alter a program setting any existing value should be removed 
and manually replaced with the required value.  In most cases, the comments added 
with the setting will indicate what values are appropriate.

21.4. Advanced ⇒ Configuration
The Logger has a non-volatile configuration that can be modified by Magpie 3 in the 
Configuration page of the Scheme editor.

21.4.1. Existing Settings
Whenever a Scheme is generated in Magpie 3, there will be some default configuration 
settings.  The existing settings in the configuration page are essential configuration 
settings.

Address
Specifies the Loggers' fixed internal address for the configuration setting.

Mask 
This determines which bits in the relevant configuration string are overwritten.

Value
The applied value determines the configuration setting.
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Users who want to modify the Configuration settings will require a Technical User 
Manual for the relevant Logger.

The Logger configuration is only modified when the Scheme is loaded into the Logger.

Note: Making modifications to the Logger configuration without an understanding of 
the configuration setup of the Logger can render the Logger unusable. 

21.5. Configuration ⇒ Events
Event-based logging allows the user to specify more detailed conditions for logging.  
Whereas normal time-based logging occurs steadily at a fixed period, event-based 
logging allows the Logger to make a decision about whether or not to log a record.  
Event-based logging conserves memory when there is nothing of interest to record.

Some examples of events would be when a stream depth exceeds a threshold, when 
a wind speed exceeds a threshold, or when the temperature changes by a certain 
amount.

All events also allow some output process to be triggered when the event changes 
state from false to true and vice versa.  Since events are defined independently from 
logging, it is possible to use events for the sake of triggering outputs if this is required.
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21.5.1. Event Types
There are a variety of different event types available with standard “greater than”, 
“less than”, and “equal to” types of comparisons.  Additionally, there are event types 
that can test when two or more events are true allowing for complex conditions to be 
created to drive logging or outputs.

21.5.2. Event Parameters
The number of event parameters displayed under the event type is dependent on 
the type of event selected.  Typically, there are only two parameters for simple tests.  
However it is possible for a total of four parameters to be available for selected event 
types.

Parameters can be either values or references to other channels (or events) depending 
on the event type.

Note: When the parameter is a value, it is the binary value in the Logger and not the 
scaled equivalent in engineering units.  Therefore, if the channel value in the Logger 
is 200 and the scaled equivalent is 20 (as per the instrument definition) then the 
parameter value to trigger the event should be 200.
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22. Projects
22.1. What is a Project?
Previous versions of Magpie software have only been able to open one Scheme at 
a time.  This has meant that data could not easily be directly compared between 
Schemes.  Magpie 3 supports a file type called a Project (*.MPJ).  Projects allow you 
to group several Schemes together, offering a range of functionality that is useful for 
people who own two or more data logging systems and associated Schemes.

22.2. Why use a Project?
There is certain functionality that is only available by using Projects:

 ● Ability to create Graphs with series data from several Schemes

 ● Quickly open any Table from any Scheme within the Project

 ● Open Tables from different Schemes next to each other to compare data

 ● Unload all Schemes with the click of a button

 ● Direct access to every Favourite from every Scheme in the Project

 ● Benefit from the improved efficiency of Project automation

22.3. Creating a Project
To begin taking advantage of the features offered by Projects you first need to create 
a Project file.

 ● From the menu bar select File ⇒ New Project, or select the New Magpie File 
button from the toolbar.

 ● After selecting the New Magpie File button, the New 
Magpie File screen will display.  Select New Project.

 ● The Project Wizard will open.  Enter a file name for your Project.  If you wish to 
save the file somewhere specific, click the  button to choose a location.
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 ● Press the Create button to continue.

22.3.1. The Project 
Manager

When you create a new Project 
you will be presented with the 
Project Manager:

When a Project is open you 
can open the Project Manager 
by selecting Project ⇒ Project 
Manager from the menu bar, or 
selecting the Project Manager 
button  from the toolbar.  The 
Project Manager is used to add, 
remove and rearrange Schemes 
from the Project.
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22.3.2. Project Manager Options
Title
Here you can enter a title that will show up in the Magpie 3 application title whenever 
this Project is open.

Comments
Comments such as when a Scheme was added or removed can go here.

Save Scheme file addresses relative to Project file
The Project remembers where its Schemes are by saving their file paths.  If you 
intend to move the Project and / or Scheme files you can check or uncheck this option 
as required:

 ● To move the Project file but not the Schemes, uncheck this option so it uses 
absolute pathing.

 ● To move the Project and Scheme files together, check the option.

This can be changed at any time.

Add Scheme
Click the Add Scheme button to add a Scheme to Project.  You will be prompted with 
a dialog box to help locate the Scheme.

Adding Schemes to a Project does not affect the individual Schemes themselves.  
That is, no changes are made to the Schemes that would prevent them from being 
used normally outside of the Project they’re added to.  In fact, the same Scheme can 
be added to as many different Projects as you like.  It does not affect other users who 
may be accessing the system using their own copy of the scheme.

Note: If you attempt to add a Magpie 1 Scheme you will be prompted to convert it to 
the current Scheme format before you can add it to a Magpie 3 Project.  Magpie 2 
Schemes do not require conversion.

Remove Scheme
If you select a Scheme from the list and click the Remove Scheme button you can 
remove a Scheme reference from the Project.  The original Scheme is not deleted.
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If there are any Project Favourites that use data from this Scheme you will be warned 
that removing this Scheme will also cause those Favourites to be deleted.

Note: Removing a Scheme will cause any Tables, Graphs, etc that you have open to 
be closed once you apply the changes to the Project.

Set As Focussed
When you have several Schemes open you can select one from the list and click the 
Set As Focussed button.  This causes any Scheme-specific Magpie operations to be 
made on the selected Scheme.  For example, if you were to open the Scheme Editor 
it will only display options for the Focussed Scheme. 

The Focussed Scheme can also be changed through the Project 
menu.

 ● Open the menu and click on the Scheme you want to set as 
Focussed.  The current Focussed Scheme will have a tick 
next to it.

Rearranging Schemes
The order in which the Schemes appear in the Project Manager reflects the order 
that they will appear throughout Magpie 3.  You can modify the order of Schemes 
in the Project Manager by selecting a Scheme and pressing the Up and Down 
buttons. 
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22.4. Opening a Project
You can open an existing Project by selecting File ⇒ Open Project.

If you have previously opened the Project you can:

 ● Select the file from the bottom of the File menu.

 ● Open the file using Open Last File from the Magpie Helper.

22.4.1. Scheme File Not Found
If Magpie 3 cannot find any of the Scheme files when it attempts to open a Project you 
will see the following message:

You have several options provided by the buttons:

Yes
An Open Scheme dialog will appear and you can use it to locate the Scheme file.  
Once found all Project references will be updated to the new location.

No
Instead of updating any references the Scheme will be completely removed from the 
Project.  You will be prompted to confirm the removal of any Project Favourites that 
rely on this Scheme.

Cancel
Leave the reference to the missing Scheme in the Project.  Missing Schemes appear 
at the bottom of the list in the Project Manager and can only be removed.

If you leave the missing Scheme in the Project you will be prompted for a response 
again the next time you open the Project.
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22.5. Unloading in Projects
Logging systems associated with a Project can be unloaded all together or as 
individual systems.

To unload all logging systems associated with a Project:

 ● From the menu bar, select Project ⇒ Unload All Schemes.

To unload an individual system within a project:

 ● From the menu bar, select Project, and ensure the system you 
want to unload is selected by checking the scheme on the list.

 ● Select Logger ⇒ Unload Data.

22.6. Project Mode Differences to Scheme Mode
Magpie 3 behaves a bit differently depending on whether it has a Project or a Scheme 
file open.  Whenever a file is open, we can say that Magpie 3 is running in ‘Project 
mode’ or ‘Scheme mode’.  Some of the basic differences are explained here.

22.6.1. Favourites in Project Mode
Any Favourite saved in Project mode is considered a Project Favourite.  This means 
that it belongs to the Project itself and not to any of the individual Schemes.  Schemes 
maintain ownership over their pre-existing Favourites.  To accommodate this, the 
Favourites menu changes slightly when a Project is open.
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22.6.2. Tables in Project Mode
Similarly, the Tables menu changes to accommodate access to all Tables from all 
Schemes.

22.6.3. Graphs in Project Mode
The Channel Selection Grid will contain a tab for each Scheme in the Project.  The 
number in the brackets represents how many measurements are currently being 
plotted for each respective Scheme.
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22.6.4. Wind Roses in Project Mode
The Scheme drop-down menu will be enabled, allowing you to plot a Wind Rose from 
any Scheme in the Project.  In Scheme mode this dropdown menu is disabled.
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23. Automation
Some Magpie 3 functions such as unloading a Data Logger, and the export of Graphs 
and Tables can be automated.

Automation is useful when:

 ● Call costs can be saved by dialling telemetered systems off-peak.

 ● Semi-real time data is required for updating third party applications (such as an 
automated web site).

 ● Magpie 3 is operated on a number of client computers across a network and the 
common Scheme data needs automatic updating.

Automation involves: 

 ● Creating a script file using a text editor, which defines what actions Magpie 3 
should take, and

 ● Configuring a scheduling program such as Microsoft Windows Scheduled Tasks 
(or any program capable of running a task at user defined intervals) to run the 
script file.

23.1. Creating the Script File 
There are a number of ways to create a new text file in Windows.  The easiest way is 
to use Notepad, a simple text editor that comes with Windows. 

To run Notepad…

 ● Click on the Start button in Windows.

 ● Click All Programs.

 ● Select Accessories.

 ● Click on Notepad.

Note: Notepad is preferred because it only creates basic text files.  If other programs 
are used the resultant file must be saved as a '.txt' file in order to work.

23.2. Editing the Script File
There are a range of commands that Magpie 3 can process from the script file.  Many 
of these commands follow a logical sequence (i.e. one must be performed before 
another).  The script file can be almost endless and so may contain commands for 
several Schemes.
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Below is an example script file:

Note: Any line in the script file with a ';' (semicolon) in front of it is ignored and so can 
be used as a comment.

23.2.1. General Automation Commands
open “file name”
Open the Scheme or Project indicated by the file name.  This needs to be fully 
path qualified (“drive:\path\file name”).  It is recommended you enclose the path in 
quotation marks.

e.g. open “C:\Program Files\Magpie 3\Projects\MyProject.mpj”

unload
Perform an unload for the currently opened Scheme.  This uses the Scheme 
communications settings.  Telemetry Schemes will dial out automatically prior to 
unloading, whereas FTP Schemes will download the data via the Internet. 

unload “Scheme”
In Project mode this will only unload the Scheme specified.  You can use either the 
full Scheme path or just the Scheme file name.

e.g. unload “C:\Program Files\Magpie 3\Schemes\SomeScheme.scm”

or

e.g. unload “SomeScheme.scm”
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unload all
In Project mode this will attempt to sequentially unload all Schemes that are part of 
the Project. 

navigator “period” 
This sets the navigator to define the period of interest.  A limited number of options 
are available for the period option as indicated below.

e.g. navigator “last –1 week”

Period can be:

 ● new data

 ● last –(10,5,3,2,1) years    e.g. last –2 years

 ● last –(10,9,8,7,6,5,4,3,2,1) months e.g. last –1 month

 ● last –(3,2,1) weeks   e.g. last –3 weeks

 ● last –(6,5,4,3,2,1) days

 ● last –(12,6,5,4,3,2,1) hours

 ● last –(30,15,10,5,4,2,1) minutes

Favourite “type” “name” 
Open an existing Favourite of the specified type with a given name.  Type can be 
either Graph, Windrose or Table.  If you have a Project open this command will only 
open Project Favourites.

e.g. Favourite graph “Air Temperature”

e.g. Favourite windrose “Wind Today”

e.g. Favourite table “Daily Data”

Favourite “type” “name” from “Scheme”
This command allows you to open Favourites from the Schemes that are part of a 
Project.  The format is the same as the previous command, except with the addition 
of ‘from Scheme’. 

“Scheme” may be the full path to the Scheme, or just the file name of that particular 
Scheme.

For example, the following two commands are equivalent:
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Favourite graph “Air Temperature” from “C:\Schemes\SomeScheme.scm”

or

Favourite graph “Air Temperature” from “SomeScheme.scm”

wait “time” 
Wait for a user defined period (in seconds) to expire.

print
Sends the contents of the currently open window to the printer.

23.2.2. Graph-specific Commands
save Graph “filename” “width” “height”
Saves an image of the currently open Graph to file with the nominated width and 
height settings. 

e.g. save graph “C:\Graph2.jpg” “640” “480”

23.2.3. Wind Rose-specific Commands
save Windrose “filename” “scaling”
Saves an image of the currently open Wind Rose to file.  The scaling value is optional, 
and represents the percentage of the original image size that the saved image should 
be.  This cannot be greater than 100. 

e.g. save windrose “C:\windrose.jpg”

e.g. save windrose “C:\windrose2.bmp” 75

Note: The Wind Rose image is saved in the format specified by the target file 
extension.  It must be JPG, PNG, BMP or WMF.

export Windrose “filename” 
Exports the table of values relating to the currently open Wind Rose.  This allows you 
to see exact percentages of readings per wind range per wind direction.

e.g. export windrose “C:\winddata.csv”
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23.2.4. Table-specific Commands:
Table “table name” 
Open the Table indicated by Table name.  Note that this is the name of the database 
file and not the title given to the database.  Generally, the database name will be the 
Scheme name with the Buffer number appended.

e.g. Table SCHEME0.dbf (for Buffer 0)  or   Table SCHEME1.dbf (for Buffer 1)

Table “table name” from “Scheme”
In Project mode allows you to open a specific Table from a Scheme.  Scheme can be 
either the full file path of the Scheme or just the file name.

Note: You must include the appropriate file extensions for this to work (.dbf and .scm 
for the Tables and Schemes respectively).

export “filename” 
Exports the contents of the currently open Table to the name specified e.g. export “C:\
Tabledata.csv”

Note: The exported file format will depend on which file extension is used here. It 
must be CSV, HTML or XML.

When the script file is complete, save it to a meaningful location such as the Magpie 
3 or Scheme folder.

Note: The name of the script file is not important.  Also, there may be more than one 
script file for different types of Magpie automation processes.

23.3. Scheduling the Process
Set up a task scheduler to run the automation process at the desired times.  This 
allows automation to run even if no users are logged in (the computer needs to be 
on, however).

The following examples describe setting up Windows Scheduled Tasks.  Setting up 
a scheduled task is a bit different depending on what version of Windows you are 
running.  Below is the Windows 2000 / XP implementation, followed by the Vista / 
Windows 7 implementation.
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23.3.1. Create the Scheduled Task in Windows XP
 ● Run the task scheduler:

Start ⇒ Control Panel ⇒ Scheduled Tasks

 ● Choose Add Scheduled Task from the Scheduled Tasks window.

 ● Follow the wizard and select Magpie 3 from the list of programs available.

 ● Give the task a name (e.g. “Unload Weather Station”) and select a frequency for 
the task from the list provided.  Press Next when done.

 ● The wizard will ask for the specifics of the time and day to be completed.  Press 
Next when done.

 ● Enter User information (your login credentials).

 ● Basic schedule is complete.

 ● Check the Open advanced properties… check box and select Finish.
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23.3.1.1. Edit Advanced Properties

 ● To the ‘Run’ line add the text:

“C:\Program Files\Magpie 3\magpie.exe” /s “C:\Program Files\Magpie 3\
MyScheme.txt”

"C:\Program Files\Magpie 3\Magpie.exe"
The full path to the Magpie 3 program

/s
The switch to tell Magpie 3 that the file being passed is an automation script file and 
not a Scheme.  The switch must be separated by a space from both the Magpie and  
script file paths.

“C:\Program Files\Magpie 3\MyScheme.txt
The full path to the script file.  In this example, the script file is stored in C:\Program 
Files\Magpie 3, and is called "MyScheme.txt"

Note: The script file may have any name and may be in any other folder other than 
C:\Program Files\Magpie 3.
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 ● Choose OK when done.

 ● There should now be a new scheduled task in the Scheduled Tasks folder for 
running Magpie 3 software.

 ● To do a trial run of the task click the right mouse button over the task and select 
Run from the popup menu.

23.3.2. Create the Scheduled Task in Windows Vista and 
Windows 7

 ● Run the Task Scheduler:

 ⇒ Control Panel ⇒ Administrative Tools ⇒ Task Scheduler 

 ● Choose Create Basic Task from the Actions panel (on the right).
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 ● Give the task a name (e.g. “Unload Weather Station”) and press Next.

 ● Select how frequently you want the task to run, press Next.
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 ● Enter the start Date and Time of the task, press Next.

 ● Ensure Start a program is selected and press Next.
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 ● For Program/script, enter the Magpie 3 executable path.  Use the Browse button 
to locate the Magpie.exe file and the path will be added automatically.

 ● For Add arguments, type “/s (script file)” (see section 23.3.1.1 Edit Advanced 
Properties for more information)).  Press Next.
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 ● Your automation task will now be created, and will appear somewhere in the 
scheduled task list.

23.4. Troubleshooting Automation
If your automation process does not work try checking the following:

 ● Thoroughly check all spelling

 ● Ensure Favourite names and file names are enclosed in quotes (“”).

 ● Exported images / data generally need a file extension to be specified.
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24. Backing Up and Restoring Magpie 
Data

Magpie 3 stores data in continuous database files that continue to grow over the 
lifetime of the Scheme.  The database files contain all of the data collected by the 
measurement system and if the files are lost, there is no way in which the data can be 
recovered unless a backup strategy is implemented.

Ideally, the frequency of backup should be shorter than the storage capacity of the 
logging system, so that if a critical error occurs and data is lost, the backup data can 
be restored and the remainder of the data can be collected from the measurement 
system.

If Magpie Schemes are stored on a network server, then the network server will most 
likely have its own backup regime that will prevent a catastrophic loss of data in failure 
conditions.

Remember that if the measurement systems that were acquired to measure the data 
are worth thousands of dollars to purchase and maintain, then the data collected from 
these systems is worth at least this much.  Therefore it is worth spending time and 
money to keep it safe.

24.1. Backing Up Magpie Schemes
Backups should always be made to a removable storage device (such as a CD-ROM 
or flash drive) or network drive.  Ideally, backups should be stored at a separate site 
or location from the computer which holds the data.

24.1.1. What Files to Backup?
The easiest choice is to choose the entire Schemes folder.  This makes sure that 
current versions of Scheme files are stored along with the data.  It is not necessary 
to backup any other Magpie 3 files as these can be easily obtained by re-installing 
from the original Magpie 3 CD and then updating to the current version from the MEA 
web site.  An exception to this is where a customer has generated his/her own user 
libraries for sensors and formulas.

24.1.2. What Files to Restore?
If a loss of data or Scheme information occurs, then one or more of the Scheme 
folders backed up from Schemes can be returned to the original location.
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25. Uninstalling Magpie 3
The proper method to correctly uninstall Magpie 3 is:

Windows 2000
 ● Click on  ⇒ Settings ⇒ Control Panel

 ● Double-click Add/Remove Programs to run it

 ● Locate Magpie 3 in the list and click on it to select it.

 ● Click the Change/Remove button to run the uninstaller. 

 ● Follow the uninstall prompts.

Windows XP

 ● Click on  ⇒ Control Panel

 ● Double-click Add or Remove Programs to run it

 ● Locate Magpie 3 in the list and click on it to select it.

 ● Click the Change/Remove button to run the uninstaller. 

 ● Follow the uninstall prompts.

Windows Vista and Windows 7

 ● Click on  ⇒ Control Panel

 ● Double-click Programs and Features to run it

 ● Locate Magpie 3 in the list and click on it to select it.

 ● Click the Uninstall/Change button to run the uninstaller. 

 ● Follow the uninstall prompts.
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26. Updating Magpie
Magpie updates can be downloaded for free from the MEA web site: 

http://www.mea.com.au/downloads/magpie/

The update process will update Magpie 3 with bug fixes and minor additions.  There 
will be no loss of data or system function as a result of performing an update.

Updates to the Magpie User Manual can also be found by following the above link.
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SECTION C: 
APPENDICES
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A1: Magpie 1 Scheme Conversion
For existing Magpie 1 users, a conversion wizard is provided to allow a seamless 
transfer of Magpie 1 Schemes to the Magpie 3 format.  There are a number of reasons 
why Magpie 1 Schemes need conversion.

A1.1. Reasons for Conversion
New format
Magpie 3 Scheme files are written in a different file format.  This format is called XML 
(Extensible Mark-up Language).  The choice of XML allows for additional Scheme 
information to be added easily to the Scheme file.

New location
The default installation folder for Magpie 3 is in the standard Windows C:\Program 
Files folder rather than directly drive C:

It is therefore no longer appropriate to have Magpie Schemes under the default 
Magpie 1 Scheme folder of C:\Magpie 

Magpie 3 takes responsibility for copying the Magpie 1 Scheme to the default Magpie 
3 Schemes folder which is C:\Program Files\Magpie 3\Schemes

A1.2. The Scheme Conversion Wizard
Whenever the user attempts to open a Magpie 1 Scheme with Magpie 3, the 
Scheme conversion wizard 
will automatically be displayed 
to guide the user through the 
conversion process.

 ● From the menu select 
File ⇒ Open Scheme and 
navigate to the installed 
Magpie 1 folder.
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 ● Locate and open the Magpie 1 Scheme to be opened with Magpie 3

 ● Allow Magpie 3 to select the destination folder automatically, or choose to specify 
the folder manually:  If the Magpie 1 Scheme is in the C:\Magpie folder then the 
destination folder will be the default Magpie 3 Schemes folder.  Otherwise the 
Scheme will be left where it is (which is most appropriate for Magpie 1 Schemes 
that exist on network servers, etc.)

 ● If choosing your own location for the converted Scheme, the following page of 
the wizard will be displayed.

 ● The New Scheme Location page allows the user to select one of three possible 
locations for the creation of the Magpie 3 Scheme:

1. The default Magpie 3 Schemes folder,

2. The existing Magpie 1 folder,

3. Another location - The Somewhere else option allows you to place the Scheme 
in an entirely different folder from either the old Magpie 1 Scheme folder or the 
new Magpie 3 default Schemes folder.

 ● Once the destination folder has been selected, the next page of the wizard 
will indicate where the Magpie 3 Scheme will be written and where backed up 
Magpie 1 Scheme files will be stored.

 ● The conversion process will always make a backup copy of the Magpie 1 
Scheme folder and this folder will always be written directly beneath the new 
Magpie 3 Scheme folder.

 ● Pressing Next will complete the Scheme conversion process.  The wizard will 
make all necessary folders, copy all required files to the folders and ultimately 
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make the new Magpie 3 Scheme files.  All settings in the Magpie 1 Scheme will 
be retained along with all existing data, Favourites and navigator settings.

 ● Once the Scheme has been successfully converted press Finished  The Scheme 
will then be opened ready for use by Magpie 3.  You can start using the Scheme 
immediately.  This includes viewing historical data collected with Magpie 1 as 
well as communicating with the data logging system and unloading new data.

A1.3. Scheme Compatibility Issues
A1.3.1. Logger Program
The data Logger program generated by Magpie 1, 2 and 3 is identical for the same 
Scheme configuration.  As a result, it is not necessary to re-program the Logger after 
converting a Magpie 1 Scheme to a Magpie 3 Scheme.

A1.3.2. Mixed Users
This also means that multiple users accessing the same data logging system - where 
some users are still running Magpie 1 and some users are running Magpie 3 - will not 
negatively effect each other; again this is because the data Logger program remains 
the same.

A1.3.3. Backwards Compatibility
Magpie 2 and Magpie 3 Schemes cannot be opened with Magpie 1.  Magpie 2 and 
Magpie 3 Schemes are interchangeable. 

A1.3.4. Instrument Labels
Magpie 1 uses a short description and a long description for each instrument.  This 
is due to the need to label fields in the databases (which have a restricted character 
limit).

Magpie 3 overcomes this problem and so now only one name is required to describe 
the instrument.  This name will be used uniformly in all displays of data in the software.  
The name used from the Magpie 1 Scheme is the short name and this is applied to all 
views in Magpie 3.  Consequently, the Real Time Information screen may look very 
different from the screen presented in Magpie 1.

To resolve this, run the Scheme Editor and edit the names of the instruments to make 
them more meaningful and descriptive.  This can be done at any time without adverse 
effects on the Scheme.
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A2: Magpie and the Data Logger
A2.1. What is a Data Logger?
The Logger is a piece of customised electronics, much like a personal computer.  
Whilst a PC is tailored to running programs which let you perform tasks such as word 
processing or web browsing, the hardware inside the Logger is tailored to reading a 
large variety of sensors to measure parameters such as temperature, rainfall, wind or 
moisture content.

Sensors can be connected using standard input channel types (i.e. voltage and 
counter channels) or more sophisticated channels such as SDI-12, HSIO or RS232.

The core of the Data Logger is the processor unit – the section of electronics that 
manages everything which happens inside the Logger.  

The keypad and display (where fitted) provide a means of interacting with the Logger 
in the field – for example to view sensor input values without the need for a computer. 

The outputs may be used to interface the Logger to other systems: for example to turn 
on a telephone to enable the system to send out an SMS message or to start a pump 
when a level sensor reaches a certain threshold.

The memory stores the Logger program, any temporary values being used in 
processing the sensor readings and finally the logged sensor readings.



www.mea.com.au   Page  145

User Manual for Magpie 3

A2.2. Data Logger Memory
A2.2.1. Data Storage
The data Logger implements a very efficient data storage mechanism so that even 
though data Logger memory capacities range from only 128kB to 1024kB (model 
dependent), the Logger may be able to log several months or even years of data.  
This ultimately depends on how many sensors are measured and how often the 
measurements are stored.

A2.2.2. Minimising the Risk of Data Loss
The Data Logger stores readings in RAM (random access memory).  The RAM is 
maintained by the Logger battery.  It is therefore critical to ensure that the Logger 
battery is regularly replaced so that the risk of data loss is minimised.

The Logger implements a low battery shutdown mechanism, to protect the contents 
of the RAM in extreme low battery conditions.  The data held can be safely recovered 
provided battery levels have not fallen too far, however no new readings will be 
recorded.

A2.3. Data Logger Program
A computer runs programs at a number of different levels: the Operating System (eg. 
Windows) controls how information on the computer will be saved and how you will 
interact with the computer (keyboard, mouse, display).  To perform a specific task, an 
application is written for that purpose.

In the same way, the Unidata Logger is a very flexible piece of equipment and operates 
at multiple levels.  The lowest level is transparent to the user and controls tasks such 
as keeping track of the time, reading the keypad, writing to the display, reading inputs 
etc.  The most important level for users is the next level, where the Logger is told 
how to operate.  The data Logger program is what controls this behaviour; the type of 
sensors which are connected, how often to read them, what to do with the readings.  
Magpie 3 is used to create these data Logger programs, which are referred to as 
“Schemes”.
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A3: Contents of the Scheme Folder
The Scheme folder contains a number of files whose purposes are described below.  
Generally, to transport the Scheme from one location to another, the entire Scheme 
folder should be transported.

A3.1. Files
Assume a Scheme named DEMO.  The files in the DEMO Scheme folder would 
appear as follows…

Demo0.DBF The database file for buffer 0

Demo1.DBF The database file for buffer 1

Demo.ERR A record of any errors produced after editing the Scheme.

Demo.KBD Keyboard file loaded into display model Loggers during the load  
  sequence.

Demo.LST Assembler listing file (not always generated).  Shows the                        
  source code with the corresponding binary Logger instructions.

Demo.LDR Binary image file that constitutes the Logger program.  This is   
  loaded into the Logger memory during a load sequence.

Demo.LOG Log file contains a continuous record of all transaction that the   
  software undertakes.

Demo.SCM This is the Scheme file.  It holds a complete description of the   
  logger program.

Demo.SET This file holds a range of information including how much data   
  to retrieve on the next unload, what are the current Navigator   
  settings, Favourites, databases attached to the Scheme, etc.

Demo.SR0 Intermediate file created during Scheme building.

Demo0.XML Contains an XML description of all fields in the buffer 0 data  
  base.  All comments added to the data are stored in this file.

Demo1.XML As for Demo0.XML but for the buffer 1 database.

Buffers.rti Allows the user to view buffer information in real time.
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A3.2. Folders
Backup (folder)  When converting a Magpie 1 Scheme to Magpie 3, this  
   directory holds a copy of the original Magpie 1 Scheme.

DumpFiles (folder) Contains all the unload files.
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A4: Other MEA Products
A4.1. GDot (MEA2194)
The GDot is used with a single GBLite for displaying soil 
moisture tension measurements.  The GDot will run for 
several years on a pair of alkaline AA batteries.  It never 
needs adjustment or calibration and can be installed in 
minutes with the most unsophisticated equipment.  For 
more information, please go to: 

http://www.gdot.com.au

A4.2. GDot Switch Box (MEA2276)
The GDot Switch Box is a switching device which allows 
users to read up to 4 gypsum blocks using 1 Gdot.  Blocks 
are selected using a simple rotary switch.

A4.3. MEA Retriever (MEA2261)
The MEA Retriever is used to store data 
from our Bug range of loggers.  It can 
accept data from Bugs connected to 
gypsum blocks, temperature sensors, 
ThetaProbes, and Aquaflex sensors.  
Data is downloaded to MEA Bug 
software for analysis.  The Retriever can 
store data from up to 100 sites for up to 
20 days each

http://www.gdot.com.au
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A4.4. GBug (MEA2262)
The GBug can be connected to up to 4 gypsum blocks 
(GBHeavies and / or GBLites) for continuous soil moisture 
monitoring.  It can store 20 days of readings  Stored data is 
transferred to an MEA Retriever for download to MEA Bug 
software for analysis.

A4.5. GTBug (MEA2263)
The GTBug can be connected to up to 3 gypsum blocks.  A 
soil temperature sensor is factory fitted.  The GTBug can store 
20 days of readings.  Stored data is transferred to an MEA 
Retriever for download to MEA Bug software for analysis.

A4.6. TBug (MEA2266)
The TBug is used with ThetaProbe soil moisture 
content sensors.  It can accept up to 4 sensors.  It can 
store 8 days of data at 15-minute increments and a 
further 20 days of data at 2-hour increments.  Stored 
data is transferred to an MEA Retriever for download 
to MEA Bug software for analysis.
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A4.7. ABug (MEA2268)
The ABug is used with Aquaflex soil moisture content 
sensors.  It can accept 2 sensors.  It can store 8 days 
of data at 15-minute increments and a further 20 days 
of data at 2-hour increments, and log both moisture 
content and soil temperature from each one.  Stored 
data is transferred to an MEA Retriever for download to 
MEABug software for analysis.  For more information 
please go to

A4.8. MEA Bug Software
This software (for PC) is used with our Bug range of loggers.  
Data from Bugs is downloaded to it from an MEA Retriever.  
Data can be viewed as Graphs and Tables and exported to 
other programs.  Users can enter their own irrigation and 
rainfall data to assist in irrigation management.  The software 
comes bundled free with the MEA Retriever when purchased.  
Users can download the latest version free from our web site.

A4.9. MEA TPReader (MEA2240)
The TP Reader is an inexpensive handheld reader used to take 
‘spot’ measurements from ThetaProbes as % moisture content.  
The Reader does not store data.
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A4.10. HH2 Reader
The HH2 Reader is used with the ThetaProbe, Profile Probe 
and the WET Probe.  Up to 2100 readings (depending on the 
sensor and configuration) can be stored in the HH2 memory for 
downloading to a PC. The HH2 can also be used to calibrate the 
ThetaProbe.

A4.11. SML
MEA’s SML range of Soil Moisture Loggers 
are built around the EnviroPro EP100C 
series of sub-surface probes, which provide 
soil moisture, salinity and temperature 
measurements at multiple depths.  An SML 
consists of an EnviroPro probe connected to 
an enclosure containing a data logger, and 
a power supply.  An SML is an affordable, 
reliable solution to continuous soil moisture 
profiling.  Data can be downloaded from an 
SML by direct serial cable connection to a 
computer, via dial-up connection, or can be 
automatically delivered to a file server.

A4.12. MEA Radio
The MEA Radio system can be used 
for continuous monitoring of gypsum 
blocks, ThetaProbes, Profile Probes, and 
EnviroPro probes.  A Base station can 
support up to 32 Field stations.  Data 
storage can be handled by a Pocket 
Logger integral to the Base, or the system 
can be integrated with an existing MEA 
Automatic Weather Station.
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A4.13. Automatic Weather Station (MEA103)

A fully featured range of high quality automatic 
logging weather stations for recording climate 
information,  Delivers data back to a personal 
computer where it is displayed using Magpie 
3 software.

A4.14. Class A Evaporation Pan (MEA132)
The Class A Evaporation Pan has been a 
standard measure of evaporation for many 
years.  MEA offers Class A Evaporation Pans 
with data logging and automatic refill options, 
either as a standalone system or as an add-
on for an Automatic Weather Station.

For more information on MEA’s range of 
Soil Moisture Monitoring systems and 
Automatic Weather Stations, please visit:

http://www.mea.com.au

www.mea.com.au
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