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ABSTRACT

The Harpoon Weapons System (HWS) is the principal long-range anti-ship missile
(ASM) in service with the ADF. Effective deployment of the missile is dependant upon
operators being familiar with the sensitivity of the HWS to launch input parameters
and environmental effects. The expense of live firings and the absence of appropriate
range facilities in Australia severely restricts the opportunity for operator training. The
use of a HWS simulator will be a valuable tool for operators to obtain familiarity with
important aspects of the HWS. The Harpoon Shipboard Simulator is a Windows based
missile simulator that allows a user to simulate missile firings using either manually
entered data or data files down-loaded from the SWG1-A fire control system. Results
of a missile simulation can be viewed as a simulation of the missile during flight time
or as plots of the missile flight profile. Simulation launch settings and data can be
saved to data files for later analysis and manipulation.
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A User Manual for the Harpoon Shipboard
Simulator

Executive Summary

The Harpoon Weapons System (HWS) is the principal anti-ship missile (ASM) in
service with the ADF, and is deployed on surface, sub-surface and air platforms.
Harpoon is a complex weapon designed to operate autonomously over long ranges.
For this reason the effectiveness of the HWS is particularly sensitive to the targeting
data supplied at launch, and the effects of the environment during flight. Therefore,
there is a need for operators and commanders to become familiar with the HWS to
ensure they deploy the Harpoon missile to its maximum operational effectiveness.

The lack of an Australian range facility and the cost of live firing a Harpoon missile
means that telemetry firings are not a practical option for operator training. A tool that
enables operators to go through the same pre-launch processes and then obtain
feedback on non firing exercise is valuable for the purposes of operator training, and
post firing analysis of engagements for tactical considerations.

The Harpoon Shipboard Simulator package developed under task NAV93/294
provides operators with a windows based simulation tool that enables them to input
firing data, either manually or via the SWGI-A fire control system, and obtain
feedback of the outcome during non-firing exercises. Using the simulation package
will enhance operator training value and give operators the ability to modify specific
launch parameters and examine different firing outcomes.

This report is a user manual for the Harpoon Shipboard Simulator, and describes how
to use the simulator program. The manual provides information on installation of the
package onto a PC, how to set simulation data, either manually or by loading a
settings file from the SWGI1-A, running a simulation, and observing the outcome of a
missile firing. The report also describes how data generated from a missile firing can
be saved to disk, or printed to a printer for later analysis and re-runs.
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1. Introduction

The Harpoon Shipboard Simulator (HSS) is a PC-based windows program that can be
used to simulate Harpoon missile firings either on-board ship or ashore. The HSS can
be used for operator training, pre-firing and post-firing analysis of Harpoon launches,
and also for tactics development.

The HSS provides a graphical user interface (GUI) to a fly out model of the Harpoon
missile. The GUI allows the input of data files extracted from the SWG-1A fire control
suite on the FFG’s, or manual input of data. The data includes missile parameters such
as waypoints and seeker turn-on time and search mode, as well as environmental
parameters and contact data. Detailed information about the extraction of data from
the SWG-1A and the format of the reduced data files that are produced is contained in
the manual listed as reference 1.

It is possible to specify up to six contacts, with the first specified contact as the primary
target. It is also possible to include the position of known stand-off jammers or decoys
as one of the contacts. The seeker search mode can be either range and bearing launch
(RBL) large, medium or small, a bearings only launch (BOL) with the maximum range
search (MRS) option, or a line-of-sight (LOS) mode.

The HSS uses this input data to simulate the expected outcome of the engagement
specified. The simulated outcome is replayed graphically as a faster than real-time plot
of the missile and contact trajectories. After seeker turn-on, the seeker search area is
displayed on the plot and the seeker head pointing angle is displayed in a separate
window.

A Cartesian axis plot of the missile and contact trajectories and the missile altitude
profile can be viewed after the engagement has completed, as can a plot of the seeker
head pointing angle. It is also possible to produce the plots in postscript format for
later analysis. The simulation data generated can be saved in either binary or ASCII
format.

Detailed technical information about the Harpoon model is contained in the working
papers listed as reference 2 and reference 3.
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2. Installation

The Harpoon Shipboard Simulator can be installed on your computer by executing the
file setup.exe provided on the distribution disk. This executable file will extract and
install all of the required files into the appropriate directories, and set up the program
so that it is ready to be executed.

The Harpoon Shipboard Simulator cannot be set up by simply copying all of the files
contained on the distribution disk onto your hard disk. The setup.exe file must be used.

2.1 Before Running Setup.exe

The Harpoon Shipboard Simulator has several hardware and software requirements
which must be satisfied before the program can be installed and set up. The Simulator
package should also be checked to ensure that everything is provided.

2.1.1 Check the System Requirements
The system requirements that must be satisfied include:

¢ Any IBM compatible machine with an 80386 processor or higher, preferably with a
processor speed of at least 50 MHz .

A hard disk.

A 3 %2" disk drive.

A SVGA or compatible display (minimum 800 x 640).

One megabyte of memory.

A mouse (a keyboard without mouse can be used).

Microsoft MS-DOS version 3.1 or later.

Windows version 3.0 or later in standard or enhanced mode.

2.1.2 Check the Harpoon Shipboard Simulator Package
The Simulator package includes the following:

e The Harpoon Shipboard Simulator User Manual.
e Program Disk.

2.1.3 Make Backup Copies of the Distribution Disk

Before running the installation program, backup copies of the distribution disk should
be made. This can be done using the Copy or Copy Disk commands from the Windows
File Manager, or by using the Copy or Diskcopy commands in MS-DOS.
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2.2 Running Setup.exe

The installation program, setup.exe, will prompt you for a directory name in which to
place the Harpoon Shipboard Simulator program. It will then extract the required files
and copy them to the selected directory, as well copying other required files into the
Windows system directory.

The installation program can be executed as follows:

L Insert the distribution disk into the disk drive (A or B).
IL Either:
A. Select Run from the File Manager File menu.
B. Then type a:setup or b:setup.
Or
i) Double click on the file name setup.exe listed in File Manager.
II. Follow the instructions provided by the installation program.

3. Setting Simulation Data

After the Harpoon Simulator program has been successfully installed it is possible to
execute the program and simulate missile firings.

3.1 Getting Started

The Harpoon Simulator Program can be started from either Windows or from the
Windows File Manager.

3.1.1 Starting from the Windows File Manager

The Simulator program can be started as follows:

1. Select Run from the File Manager File menu.

2. Then type the directory name followed by harpgui.exe.

1. g(r)uble click on the file name harpgui.exe listed in File Manager.

3.1.2 Starting from Windows

To start the simulator program from Windows double click on the Harpoon Shipboard
Simulator icon as shown in figure 3-1.
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Harpoon Harpoon Shipboard
Simulator : Simulator Icon

Figure 3-1 Program Icon in Windows

3.2 The Simulator Settings Window

i

|

l

| The first screen to be displayed when the Harpoon Shipboard Simulator program is
‘ run is the main settings window shown in figure 3-2.
i

|

|

|

\

|

Menu Bar Tool Bar Filename Box

Information line Settings display

Figure 3-2 The Harpoon Shipboard Simulator Main Settings Window
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The main settings window consists of a menu bar, a tool bar, a text box containing the
current file name, the main settings display, and an information line.

3.2.1 The Menu Bar

The menu bar is used to access commands for controlling data input and output,
running the simulation, and exiting the program. It contains a File menu, and a
Simulation menu.

3.2.1.1 The File Menu

The File menu, figure 3-3, contains commands relating to input and output of
simulation settings to and from the program. The quit command is also contained in
this menu. The New command is also available and can be used to reset the simulator
settings to their default values.

Cirl+N

Figure 3-3 The File Menu

3.2.1.2 The Simulation Menu

The Simulation menu, figure 3-4, only contains two menu items and these are the
commands for going directly to the simulator plot display window, without running a
simulation, and the run command for running the simulation with the current
simulation settings.

Simulation

== Go To Plot Display Cirl+G
i T

Figure 3-4 The Simulation Menu

Selecting the Go To Plot Display option will display the simulator plot display
window, but without having loaded any simulation data. Before viewing a simulation
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the simulation data from a previous firing must first be loaded using the Load option
from the File menu, in the plot display window.

3.2.2 Settings Display

The settings display region of the main window shows the current simulation settings
for the five sets of parameters, including environmental, target, guidance, seeker and
simulation parameters. The display is updated when settings are modified, which can
be done either by the use of the spin buttons attached to a parameters text box, or by
entering new values directly into the text boxes provided.

Only one set of target data is displayed on the screen. To view other target data the
spin button attached to the target number box can be used. Clicking on the up or down

arrow of the spin button will increment or decrement the target number accordingly
and all of the associated parameters for that particular target will be updated.

3.2.3 The Tool Bar
The following table shows the tool bar icons that are available for selection.

Table 3-1 Tool Bar Icons and Commands

Icon Action Menu equivalent

Open a settings data file Open command on the File menu

Save current simulation settings to file Save As command on the File
menu

Print the current simulation settings ~ Print command on the File menu

Run simulation with current settings ~ Run command on the Simulation
menu

Go to plot display window Go to plot display window

command on the Simulation
menu

The tool bar provides a set of icons for executing commands for data input and output,
and running the simulation. The required action can be executed by clicking once on
the corresponding icon, as described in the previous table.
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3.24 Information Line

The information line is located at the bottom of the main display window and displays
information relating to the current location of the mouse pointer. It describes what the
tool bar icons are used for when the mouse pointer is located on a particular icon, it
also describes what each of the menu items are for when one is highlighted.

Figure 3-5 Example of the Information Line when the Mouse Pointer is on the Run
Simulation Icon :

3.2.5 File Name Box

The file name box is located below the tool bar in the main settings window and
displays the file name of the current simulation settings file. If there has not been a file
opened or saved then the text box will display the name “SETTINGS”.

The file name box cannot be edited and is for information purposes only. figure 3-6
shows an example of the file name box in its default state.

R e S e

3.3 Loading a Data File

A settings data file can be opened by either selecting the Open command from the File
menu or by clicking once on the Open file icon from the tool bar. Using either of these
two methods will bring up an Open file window.

This window is similar to the Open file type of window used in other Windows
applications. It allows the user to change working directories and then select the
required file from the list of files displayed.
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File Hame: Directories:

[‘. dat . c:\harpoon
ey

2= harpoon
£3 air
curment
datafile
dosver
£33 har32003

asc_dat
ascl.dat
bin.dat
output.dat
rdcout.dat
temprdc.dat
test.dat
testout.dat

List Files of Type: Drives:
Data Files {*.dat] 3 L c: ms-dos_6

Figure 3-7 The Open Data File Window

There are two types of data files that can be used by the Harpoon Shipboard Simulator,
these include .dat files and .rdc files. The .dat files are ASCII data files that have been
generated by the Harpoon Shipboard Simulator program. The .rdc files are reduced
data files that have been extracted from the SWGI-A fire control system. The
specifications and format of both the .7dc and .dat files are contained in Appendix A.

When a new data file has been chosen and the OK button selected, the main settings
window will become visible and it will be updated with the new simulation settings.
Selecting the Cancel button will return control to the main settings window without
changing any of the simulation parameters.

3.4 Modifying Simulation Settings

The simulation settings can be modified by either clicking on the up or down arrows of
a spin button or by entering a new value directly into a parameters text box. The only
settings that do not use the spin button method are the target type and the missile pop
up switch.

3.4.1 Edit Box

The edit box can be used to enter new values directly without the use of a spin button.
To enter data into an edit box click once within the border of the box and then use the
keyboard to modify the existing value. Normal edit functions available on the
keyboard, including the delete and backspace keys, can be used to modify values
within the edit box.
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3.4.2 Spin Button

A spin button is used to increment or decrement the value that is displayed in the
attached text box. Clicking once on an up or down arrow will change the
corresponding parameter by the smallest unit, nominally 1 for parameters that have a
small change between simulations, such as temperature, and 5 for parameters that
have a greater change, such as bearings.

Clicking on an arrow and keeping the mouse button depressed will continuously
increment or decrement the corresponding parameter setting, until the mouse button is
released.

3.4.3 Target Type List Box

The type of target for a particular target number is selected by the use of a list box
containing the four possible target types, which include: valid target, no target,
jammer, and decoy. Clicking on the arrow at the edge of the list box will display the
list containing the different target types. Select one of these types by clicking the
mouse button once on the required target type. Alternatively, the target type can be
modified by clicking in the text part of the list box and then stepping through the
possible target types by the use of the up and down cursor keys.

3.4.4 Missile Pop Up Switch

The missile pop up switch is a simple toggle button that is activated by clicking the
mouse button once when the pointer is on top of the button. The text on the switch
changes to indicate the current state of the switch. When the button is depressed it
means that the missile pop up switch is on, and when the button is up the missile pop
up switch is off.

3.5 Saving a Data File
A settings data file can be saved by either selecting the Save As command from the
File menu or by clicking once on the Save file icon from the tool bar. Using either of

these two methods will bring up the Save As Data File Window.

An example of the Save As Data File Window is shown in figure 3-8.
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" Save As

File Hame: Directories:
Fm c:\harpoon

asc.dat
ascl.dat
bin.dat

output.dat
rdcout.dat curmrent
temprdc.dat datafile
test.dat ‘

testout.dat har32003

Save File as Type: Drives:
[Data Files (=.dat] #| |[=c msdos B

Figure 3-8 Save As Data File Window

Select the working directory in which to save the data file and then either select an
already existing file name from the list or enter a new file name in the File Name edit
box. The data files saved from the Harpoon Shipboard Simulator can be saved with the
.dat file name extension or any other file name extension entered, except for the file
name extension .7dc, because this refers to files in a specific format. The format of data
files saved from the Main Settings Window is included in Appendix A.

After a file name has been entered click on the OK button to the save the current
settings data under that file name, or click on Cancel to ignore the command and
return to the Main Settings Window.

3.6 Printing a Data File

A settings data file can be printed by either selecting the Print command from the File
menu or by clicking once on the Print file icon from the tool bar. Using either of these
two methods will bring up the Print file Window.

An example of the Print file window is shown in figure 3-9.

The print window is similar to the print file prompts of other windows applications.
Printing from the main settings window produces a single page print out of the
current simulator settings on the selected printer. Changing the current printer is done
simply by clicking on the Setup button and then following the prompts to choose a
new printer, much like in other windows applications.




DSTO-GD-0128

Printer: Default Printer (HP LaserJet IID
E‘o_s_l_S_c_r_ipt on gwdserver/ifslaser

"~ Print Range

O‘gglecﬁcn
O Pages
From: l ] To: I I

Print Quality: !300 dpi Copies: I:I

] collate Copies

Figure 3-9 Print File Window

The only option available under the print range selection is the Print All option,
because there is always only one page of data that will be printed, although multiple
copies can still be printed.

3.7 Quitting the Harpoon Shipboard Simulator

The only method of quitting from the Harpoon Shipboard Simulator is to select the
Quit command from the File menu. Selecting this command will cause a quit
simulator window to be displayed, as shown in figure 3-10.

‘Quit Simulator:

Figure 3-10 Quit Simulator Window

Clicking once on Yes will halt the execution of the program and return control to the
normal Windows environment. Clicking on No will redisplay the main settings
window ready for the modification of simulation settings or the running of a
simulation.

11
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4. Running a Simulation

After simulation settings have been entered or loaded from a data file the simulation is
ready to be executed. The simulation can be run by clicking once on the run simulation
icon in the tool bar or selecting the Run command from the Simulation menu.

Using either of these two methods will hide the main settings window and then
display the generating data window shown in figure 4-1. This window will remain
displayed whilst the program is generating simulation results and writing simulation
data to an output file.

o Generating Simulation Data.
. Please Wait.

Figure 4-1 Generating Data Window

5. Examining Simulation Output

After data has been generated the Harpoon Plot Display Window will become
enabled. This window consists of a plot display region, a menu bar, the seeker angle
display, system information, and control buttons.

The Plot Display Window during a missile simulation is shown in figure 5-1.
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Menu Bar System Information
Plot Display Region Seeker Angle Display

Search ‘E,

Sea State : 5 Wind Speed : 28 kts Wind Direction -

Control Buttons

Figure 5-1 Harpoon Plot Display Window

i 5.1 Trajectory Display

The trajectory display shows the trajectory of both the missile and targets during the
flight time of the missile. Other information contained on the display window includes

the plot scale indicated on the x-axis in nautical miles, wind speed, sea state, and wind
direction.

The missile trajectory is indicated by a multi-coloured line. A description of the color
corresponding to each condition is contained in Table 5.1. The text “TGT” will flash in

red next to target number one for the first 5 to 40 seconds to indicate the initial position
of that target.

13
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Table 5-1 Colour Combinations for Missile and Target Trajectories

Condition Colour of Missile Trajectory Colour of Contact
initial fly out white

initial search cyan

home on target (HOT) light red light red (target/s)
home on jammer (HOJ) light green light green (jammer/s)
home on decoy (HOD) gray gray (decoy/s)

5.2 Seeker Angle Display

The seeker angle display provides a graphical representation of the seeker head angle.
The display becomes active once the seeker turn on time has elapsed. During the
simulation run time the red line, the centreline extending from the head of the missile
in figure 5-2, indicates the current position of the seeker angle whilst the white region
of the display indicates where the seeker head has already scanned.

The search mode being used by the missile, and the status of the seeker at a given time
are displayed in text boxes at the bottom part of the seeker angle display. An example
of the seeker angle display after a simulation run is shown in figure 5-2.

Search gE; Seeker

P S L o A e o O L

Figure 5-2 Seeker Angle Display

5.3 System Information

The system information contained on the Harpoon Plot Display Window includes the
flight time of the missile, the status of the missile, the initial heading, the seeker turn
on time, and waypoint information including start time and turn angle for each
waypoint.
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When the seeker power is on the seeker mode indicates the mode that the missile is in,
which includes initial search mode (IS), home on target (HOT), home on jammer
(HQOJ), and home on decoy (HOD).

The {light time box displays the simulated flight time of the missile. The state of the
missile describes the outcome of the missile firing, which can include hit contact,
missed contact, passed contact, hit ground or aborted. The seeker turn on time and
waypoint information are initialised when simulation data is loaded.

5.4 Control Buttons

The control buttons accessible from the Harpoon display window are for controlling
the running of the simulation, displaying of plots, and exiting the simulation.

Figure 5-3 shows the control buttons that can be selected from the Harpoon Plot
Display Window.

Figure 5-3 Control Buttons

5.4.1 Executing a Simulation

Running of the simulation is controlled by the simulation Start and Reset buttons.
Clicking on the Start button after running a simulation from the settings window will
start the plotting of the simulation data, otherwise a prompt window, figure 5.4, will
be displayed indicating that simulation data must first be loaded before plotting can
commence.

Load Data

@ Load data before starting simulation

Figure 5-4 Load Data Warning Window

15
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After the simulation has commenced and plotting of the missile and target trajectories
has started the caption on the Start button will change to Pause. Clicking once on this
button will pause the simulation. When the simulation is in a paused state the control
button will have the caption Resume. Clicking on the button with the Resume caption
will re-start the simulation at the time the simulation was paused.

The Reset button can be used to stop the simulation and reset the simulation
parameters. When this command button is used the missile information display will
show the state of the missile at launch time.

5.4.2 Plotting Missile Data

There are three types of plots that can be generated from a missile firing simulation.
These include missile x-y trajectory plot (Traj), missile altitude plot (Altitude), and
missile seeker head angle plot (Seeker). Clicking on any of the three plot control
buttons will display the corresponding plot in the plot display region, replacing the
trajectory display described in section 5.1. Examples of the types of plots that can be
produced are included in Appendix B. ‘

5.5 Menu Bar

The menu bar contains the File menu and Display Plot menu. The File menu is similar
to the File menu in the main settings window and includes menu items for the input
and output of data and exiting from the plot display window. The Display Plot menu
contains a menu item for each of three plots that it is possible to generate. Selecting
any of these options from this menu is the same as selecting the corresponding control
button from the Display Plot control buttons, as described in section 5.4.

5.5.1 Saving and Loading Data

The menu items for loading and saving data are labelled Load, Save and Save ASCIL
Selecting the Load option will display the load prompt window for selecting the file to
load. The load prompt window is the same as the Open Data File Prompt window
shown in figure 3-7 of section 3.3. The data files are binary files produced in a format
specified by the Harpoon simulator program and described in Appendix A.

To display a previous simulation firing only binary data files can be used. These are
the only type of files that can be loaded from the plot display window. The option of
saving ASCII data files is provided to enable manipulation and viewing of simulation
data using external packages.

The simulation information can be saved either as data, in a binary or ASCII data file,
or as plots, in a word meta-file format or bitmap.
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Selecting the Save item will display an option window from which the option of
saving data or graphical output can be chosen.

Figure 5-5 Save Option Window

Choosing either option and then clicking on OK will display the save prompt window
which allows the file name to be entered and the directory in which to save the file to
be selected. The save prompt window is the same window that is used for saving
settings files from the Harpoon Main Settings Window shown as figure 3-8 in section
3.5. Data files are saved with the file extension .dat, whereas graphic plots are saved
with either the .bmp file extension or .wmf file extension.

To save data in an ASCII format for viewing outside of the simulator program select
the Save ASCII menu item. The save prompt window that is displayed is the same as
the window used for saving graphical data and binary simulation data. The format of
the ASCII data file is included in Appendix A.

Clicking on the Cancel button in any of the prompt windows will return control to the
Harpoon Plot Display Window.
5.5.2 Exiting the Plot Window

To quit from the Harpoon display window select the Exit control button or select the
Exit menu item from the File menu. A prompt window will be displayed with the
option of quitting back to the main settings window, by selecting Yes, or cancelling the
option and keeping the Harpoon plot display window enabled, by selecting No.

17
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Exit Plot Screen

Figure 5-6 Exit Plot Screen Window
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Appendix A: Input and Output Data Files

This appendix contains the file formats of the data files used for the input and output
of data to and from the Harpoon Shipboard Simulator Program.
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A-1 Format of SWG1-A Extracted Data File

The values indicated in bold are the values that are read when a .rdc file is selected ,
from the open settings data file window. The values that are read in as n/a are assigned |
the value of zero and in the case of a target bearing and range being n/a the target is

designated as target type no target. :

| HARPOON AN/SWG-1A DATA EXTRACT --- Reduced 6/08/1995 |
I i '
| |
| === - T e e — |
| Large Target | TARTAR RSR 1 Data Block 8 |
| == ———— | Salvo Count = 1 of 1
| Trk = LOC 0001 | Missile Type = RGM-84D |
| Brg = 49.977 deg | Status Word = 00000 1 0000 111110 GMTR |
| Rng = 64.736 kyd |=-=-——-- e
| Hdg = n/a deg | Own-ship Hdg = 56.375 deg High-alt Flyout: yes |
| Spd = n/a kts | " " Pitch = 0.805 deg Presearch Skim: yes
| Sens = Active | " " Roll = 1.758 deg Terminal Mode: popup |
| bata Age = 1 min | " " Speed = 5.453 kts i
= ——— | Search : RBL |
| Desig Aimpoint | Lchr Deck Brg = 269.359 deg Pattern: |
[emmm e i " " Elev = 36.109 deg
| Brg = n/a deg | WPl Brg = n/a deg |
| Rng = n/a kyd | Launch Mode = STOT Rng = n/a kyd |
[ == e | ]
| 3rd Party / Bkgnd | Launch Time = 00:21:35.96 2 WP2 Brg = n/a deg |
| mm e | Flight Time = 03:58.63 Rng = n/a kyd |
| Trk = n/a | Pwr-on Time = 00:21 |
] Brg = n/a deg | WP3 Brg = n/a deg |
| Rng = n/a kyd | Initial Turn = 84.367 deg Rng = n/a kyd |
| Sens = n/a ittt ity |
| | Nav Error = 4.051 kyd | Tgt PACQ = .97
| Trk = n/a L e e
| Brg = n/a deg | Temp = 59.000 deg F Precipitation = no
| Rng = n/a  kyd | !
| Sens = n/a | Wind = 0.000 deg / 0.000 kts |
| f = e e e e |
| Trk = n/a | Missile Orders |
| Bxg = mn/a deg |-- -—= ittt }
| Rng = n/a kyd | CW-DW OCT HEX CW-DW OCT HEX CW-DW OCT HEX |
| et e |
| Trk = n/a | 4-0 000246 00A6 6-0 000243 00A3 A-0 000207 0087 |
| Brg = n/a deg | 4-1 007517 OF4F 6-1 000000 0000 A-1 000001 0001 |
| Rng = n/a kyd | 4-2 043464 4734 6-2 045000 4a00 A-2 077777 TFFF |
| |  4-3 015225 1A95 6-3 175063 FA33 A-3 000000 0000 |
| Trk = n/a }] 4-4 000270 00B8 6-4 144012 C80A A-4 000000 0000 |
| Brg = n/a deg | 4-5 020532 215a €6-5 004215 088D A-5 077777 TFFF |

| | Rng = =n/a kyd | 4-6 024025 2815 6-6 000627 0197 A-6 000000 0000 |

| | | 4-7 166154 EC6C 6-7 041104 4244 A~7 000000 0000 |

‘ | Trk = n/a | 4-8 000000 0000 6-8 002260 04BO  A-8 000206 0086

| | Brg = n/a deg | 4-9 000000 0000 6-9 032107 3447

1 | Rng = n/a kyd | 4-A 124121 A851 6-A 111077 923F |
| | |
| Trk = =n/a | 5-0 000165 0075 8-0 000244 0024 B-0 000210 0088
| Brg = =n/a deg | 5-1 145455 CB2D 8-1 000000 0000 B-1 000001 0001 | ;
| Rng = n/a kyd | 5-2 155740 DBEO 8-2 000000 0000 B-2 077777 7FFF |
| | 5-3 000032 001A 8-3 000000 0000 B-3 000000 0000 |
| Trk = n/a | 5-4 155740 DBEO 8-4 077777 TFFF B-4 000000 0000 |
| Brg = n/a deg | 5-5 032322 34D2 8-5 000000 0000 B-5 077777 TFFF |
| Rng = n/a kyd | 5-6 177425 FF15 8-6 077777 TFFF B-6 000000 0000 |
| | 5-7 133543 B763  8-7 000000 0000 B-7 000000 0000 |
| Trk = n/a | 8-8 000000 0000 B-8 000207 0087
| Brg = n/a deg | 8-9 035010 3208 |
| Rng = n/a kyd | 8-A 035252 322A

22
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The values shown in the missile orders section are in hexadecimal and correspond to
the following parameters.

Reference Number Conversion Factor | Parameter
(units)
4-1 x 0.04 (sec) seeker on time
4-2 x 4/6076 (nm) range to go
4-3 x 0.04 (sec) simulation end time
4-4 N/A search mode
4-5 1 (nm) xysearch (x value)
4-6 1 (nm) xysearch (y value)
5-2 + 16384 (rad) 121
5-5 + 16384 (rad) L31
A-2 x 2 (time units) 1st waypoint turn time
A-3 + 4096 (radians) 1st waypoint azimuth command
A-4 x 4 (feet) 1st waypoint crossrange command
A-5 x 2 (Hme units) 2nd waypoint turn command
A-6 + 4096 (radians) 2nd waypoint azimuth command
A-7 x 4 (feet) 2nd waypoint crossrange command
8-4 (+8192) x (180/IT) | mid-course guidance command
(degrees)

23
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A-2 Format of Settings data file

The settings data file is an ASCII file generated from the Harpoon Simulator program.
This file is used to set the launch parameters for a missile firing and is given the file
name settings.in, and is located in the application working directory, which is the
directory selected when the program is installed.

HARPOON SIMULATION DATA

GUIDANCE DATA
"Launch Angles",325.5,34.3
"Initial Position",0,0,0
"Inititial Heading",54.6
"Waypoint 1",1310.6,0,0
"Waypoint 2",1310.6,0,0
"Pop up Switch",1
"Gyroscope Drift",0
"Search Mode",1

TARGET DATA

no_target = 0 Valid_target = 1 Jammer = 2 Decoy =3
Target Type Range Bearing Course Speed Size
1,1,14.9,49.9,0,0,0

2,0,0,0,0,0,0

3,0,0,0,0,0,0

4,0,0,0,0,0,0

5,0,0,0,0,0,0

6,0,0,0,0,0,0

"Target Point Altitude",6

SEEKER DATA
"Seeker On Time",156.7
"Range to go",12

ENVIRONMENTAL DATA
"Wind Speed",0

"Wind Bearing",0

"Sea State",5
"Temperature", 15

SIMULATION DATA
"Simulation End Time",272.1




DSTO-GD-0128

A-3 Format of Simulation Data File

The table below describes the format of data that is output from the simulation
program, and is the same as the data format used when the Save option is selected
from the File menu of the plot display window. The data is stored as a binary data file.
When a simulation is run from the main settings window the data file is given the file
name harp.out and is located in the application working directory, otherwise the file
name is selected from the save prompt window when the Save option is used.

Variable Type | Number of Values Description
num_time int 1 number of time elements
num_seek int 1 number of seeker data points
NUMVALS int 1 number of simulation data points
sim_outcome int 1 final outcome of simulation
0 : hit target
1: hit ground
2 : missile past target
3 : missile outside firing envelope
4 : aborted
num_actions int 1 number of missile actions during flight
msl_action float num_actions flag indicating missile action
0 : home on target (HOT)
1: home on jammer (HOJ)
2 : home on decoy (HOD)
msl_action_time | float num_actions time that action occurred
tsearch float 1 seeker on time
windbrg float 1 wind bearing
windspd float 1 wind speed
seastate float 1 sea state
trange(1) float 1 range to target 1
wpl(1) float 1 waypoint 1 activation time
wpl(2) float 1 waypoint 1 turn angle
wp2(1) float 1 waypoint 2 activation time
wp2(2) float 1 waypoint 2 turn angle
num_tgts int 1 number of targets
seek_on_time float 1 actual time of seeker turn on
(used for LOS/MRS)
search_mode int 1 number indicating search mode used
1:RBL large
2 : RBL medium
3 : RBL small
4:MRS
5:LOS
seeka float num_seek seeker head angle values
Xm float NUMVALS missile x value
ym float NUMVALS missile y value
zm float NUMVALS missile altitude
xt1 float NUMVALS target 1 x value
ytl float NUMVALS target 1 y value
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Variable (cont) Type | Number of Values | Description (cont)
{cont) | (cont)

xt2 float NUMVALS target 2 x value
yi2 float NUMVALS target 2 y value
trange(1) float 1 target 1 range
tbearing(1) float 1 target 1 bearing
trange(2) float 1 target 2 range
tbearing(2) float 1 target 2 bearing
trange(3) float 1 target 3 range
tbearing(3) float 1 target 3 bearing
trange(4) float 1 target 4 range
tbearing(4) float 1 target 4 bearing
trange(5) float 1 target 5 range
tbearing(5) float 1 target 5 bearing
trange(6) float 1 target 6 range
tbearing(6) float 1 target 6 bearing
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A-4 Format of ASCII Data File

An ASCII data file can be created by selecting the Save ASCII command from the File
menu in the plot display window. This type of file can be used to examine and
manipulate simulation data externally to the Harpoon Shipboard Simulator program.

The data is written in columns with the following sequence: time in seconds, missile x,
y, and z co-ordinates (xm, ym, zm), target one x and y co-ordinates (xt1, yt1), and
target two x and y co-ordinates (xt2, yt2). All of the co-ordinate values are given in
metres. An example segment of the data file produced is shown below.

-4.095773 -5.720469 4.543769 5893.728 31492.86 -10212.63 5248.583
-4.095773 -5.720469 4.543769 5893.728 31492.86 -10212.63 5248.583
-22.96872 -20.07907 17.23276 5893.728 31492.86 -10212.63 5248.583
-57.94265 -43.69754 36.23877 5893.728 31492.86 -10212.63 5248.583
-109.7329 -76.98794 60.46595 5893.728 31492.86 -10212.63 5248.583
-179.0621 -120.3667 88.53826 5893.728 31492.86 -10212.63 5248.583
-266.3279 -174.0632 119.2089 5893.728 31492.86 -10212.63 5248.583
-360.4286 -231.6943 147.7099 5893.728 31492.86 -10212.63 5248.583
-454.9878 -289.5937 171.6457 5893.728 31492.86 -10212.63 5248.583
-550.2523 -347.903 191.0833 5893.728 31492.86 -10212.63 5248.583
-646.1482 -406.58  206.009 5893.728 31492.86 -10212.63 5248.583
5.5 -742.7062 -465.3879 216.4653 5893.728 31492.86 -10212.63 5248.583
6 -840.3992 -523.1498 222.7643 5893.728 31492.86 -10212.63 5248.583
6.5 -939.3243 -579.3885 225.0089 5893.728 31492.86 -10212.63 5248.583

¢, ]

ul

TG WWNNR R0 @
v )

120 -780.9865 18365.97 8.825041 5893.728 31492.86 -10212.63 5248.583
120.5 -720.3813 18489.24 8.693323 5893.728 31492.86 -10212.63 5248.583
121 -659.6819 18612.61 8.568035 5893.728 31492.86 -10212.63 5248.583
121.5 -598.8894 18736.02 8.448868 5893.728 31492.86 -10212.63 5248.583
122 -538.0049 18859.51 8.335511 5893.728 31492.86 -10212.63 5248.583
1225 -477.0296 18983.08 8.227686 5893.728 31492.86 -10212.63 5248.583
123 -415.9649 19106.71 8.125122 5893.728 31492.86 -10212.63 5248.583
123.5 -354.8116 19230.41 8.027557 5893.728 31492.86 -10212.63 5248.583
124 -293.5713 19354.18 7.934756 5893.728 31492.86 -10212.63 5248.583
124.5 -232.2452 19478.01 7.846488 5893.728 31492.86 -10212.63 5248.583
125 -170.8341 19601.9 7.762536 5893.728 31492.86 -10212.63 5248.583
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Appendix B: Example Output Plots

This appendix includes an example of the three plots that can be produced from the
Harpoon Shipboard Simulator program. They include a trajectory plot, missile altitude
plot, and a seeker head angle plot.
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B-1 Trajectory Plot

The trajectory plot is an x-y plot that displays the final trajectory of the missile and the
first two targets, with the axes in metres. The x and y axis may not have the same

scaling, hence plots may appear to be different to the simulated trajectory plot
displayed in the main plotting window.

Harpoon Trajectory Plot

Figure B-1 Example of a Harpoon Missile Trajectory Plot
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B-2 Altitude Plot

The altitude plot shows the altitude of the missile, in metres, over the duration of the
simulated missile flight. Time is measured in seconds and is shown on the x-axis,
scaled according to the total missile flight time.

Harpoon Missile Altitude Plot

Altitude
(m) Nl

Time (sec)

Figure B-2 Example of a Harpoon Missile Altitude Plot
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B-3 Seeker Head Angle Plot

The seeker head angle plot shows the angle, in degrees, of the missile seeker head
relative to the centreline of the missile. The seeker head angle is plotted from the time
of seeker turn on until the end of the missile flight.

Seeker Head Angle
Plot
Angle
(deg) ° = '
Time (sec)

Figure B-3 Example of a Seeker Head Angle Plot
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