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1 Introduction
The topics in this section provide some basic information about CadTracker, what it is for and what you can
do with it.

How to get started

See Getting help for details on using the help system and how to get more help if you need it.

Study this Introduction chapter and the Getting started sections to familiarise yourself with the application.

1.1 About CadTracker
CadTracker is a drawing and document control solution created for design, detail and manufacturing offices
in the architectural, engineering and construction industry. It is specifically designed to meet the needs of
small to medium enterprises (SMEs) which produce documentation using AutoCAD®.

Create, track, and deliver your in- and outbound documents with greater speed and precision, through
CadTracker’s cloud-ready, SQL database system.

Take control of your projects.

Control

CadTracker lets you take control and organise your projects, by helping you:
Preview, open, categorise and track document revisions with a complete issue history in and out
Enforce CAD standards such as:
o drawing and plot name formats
o revision codes
o status descriptions
o file locations

Author

CadTracker makes it easy to create deliverable AutoCAD drawings. You can:
Create drawings using in-house or client title blocks and borders
Assign plot settings for PDF, DWF and physical printers for each drawing type
Batch process drawings to update, revise, supersede and print

Deliver

CadTracker improves efficiency by streamlining the delivery of documents:
You can rapidly create, zip and e-mail issues with drawings, documents and files, complete with transmittal
advice reports
Keep your clients up-to-date with comprehensive and flexible document registers and spreadsheets

1.2 Getting started
The CadTracker application has three main components: the menu, the Explorer, and the window area.
 

The menu

File
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      Connect to primary database
      Connect to secondary database
      Disconnect
      -
      Set up database connections
      -
      Exit

View
      Show archived records
      Single document interface
      -
      Start page
      Virtual drives

Tools
      E-mail manager
      -
      Document
            Areas
            Categories
            Subcategories
            Titles
            Related file codes
            Revision statuses
      Drawing
            Categories
            Revision descriptions
            Templates
            Titles 3
            Titles 4
            Types
      Generic data
            Categorical data types
            Generic classes
            Property types
            Unit types
      Issue
            In
                  Subjects
            Out
                  Advice templates
                  Categories
                  Subjects
      Scales
      -
      Address types
      E-mail address types
      Phone number types
      -
      Operators
      -
      Report templates
      -
      Configuration

Window
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Help
      View help
      -
      Check for updates
      View change log
      -
      About CadTracker

The Explorer

The Explorer is a hierarchical list of the projects and companies in your CadTracker database.

The window area

The window area is where you view and edit most records. Window management options may be viewed by
right-clicking a window's tab, or by clicking the Window menu.

The window area may be configured to show only one window at a time with the single document interface
option.

 TIP   You can close a window by middle-clicking the window's tab.

1.2.1 Database connections

CadTracker stores its data in an SQL Server database.

In the File menu, there are two ways to connect to databases:
Connect to primary database,
Connect to custom database.

To disconnect from the current database, click File > Disconnect.

To set up up database connections, click File > Set up database connections.

Primary databases

Select the primary database connection from the list. The primary database connections are stored in
CadTracker's connection strings configuration file.

 TIP 
IT/CAD managers should edit the configuration file and copy it to the shared deployment folder.

Custom database

Some operators may like to have their own local CadTracker database for small projects or for testing. The
custom database connection is useful for these types of situations, as the connection details are stored in the
user's application data.

Machine name
Enter the computer name or IP address, e.g.

xyz-server
192.168.0.100
a single dot (.) for the current PC
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tcp:<server name>.database.windows.net,1433 for Windows Azure SQL databases

 IMPORTANT   Leave out the slashes which are normally used for UNC paths.

Instance name
Enter the SQL Server instance, e.g. CadTechSoftware or SqlExpress.

Database name
Enter the database name, e.g. CadTracker.

Authentication
Select either Windows Authentication or SQL Server Authentication. Windows Authentication should work for
databases installed to the local PC. SQL Server Authentication requires a user name and password.

User name
Enter an SQL Server user name, e.g. sa.

Password
Enter the SQL Server password.

 NOTE   The default password for CadTracker databases is C4dTech

Click Test to try to connect to the database.

Firewall settings for VPN connections

CadTracker can connect to databases over virtual private network (VPN), but by default Windows may block
the connection.

To allow the connection:

1. Click Start > Run
2. Type wf.msc
3. Select Inbound Rules
4. Click New Rule (on the right-hand side)
5. Select Port
6. Click Next
7. Select UDP
8. Select All local ports
9. Click Next
10. Select Allow the connection
11. Select Private
12. Clear Domain and Public (the VPN is a private network location)
13. Click Next
14. Type a name, e.g. All private UDP ports
15. Click Finish
16. Restart CadTracker and test the connection again.

1.2.2 Explorer

The Explorer is a hierarchical list of the projects and companies in your CadTracker database.

Buttons

There are six buttons at the top of the Explorer:
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 New

 View/Edit

 Delete

 Refresh

 Set current project and job

 Launch AutoCAD

The buttons are context sensitive, i.e. the item currently selected in the Explorer determines what action the
button will perform. Tool tips display what action will be performed when a button is clicked.

The hierarchy of items

 Projects

       <Project>

             Documents

                   (Groups)

                         <Document group>

                         <Document category>

                               <Document subcategory>

                                     <Document area>

                                           <Document>

                                           <Document>

             Generic data

                   <Generic objects folder>

                         <Generic object>

                         <Generic object>

                   <Generic objects folder>

                         <Generic object>

                         <Generic object>

             Issues

                   In

                         <From>

                               <Issue in>

                               <Issue in>

                         <From>

                               <Issue in>

                               <Issue in>

                   Out

                         <Category>

                               <Issue out>

                               <Cancelled issue out>

                         <Category>

                               <Cancelled issue out>

                               <Issue out>

             Jobs
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                   <Job>

                         Drawings

                               (Groups)

                                     <Drawing group>

                                     <Drawing group>

                               <Category>

                                     <Drawing>

                                     <Drawing>

                               <Category>

                                     <Drawing>

                                     <Drawing>

                         Models

                               <Model>

                               <Model>

 Companies

       <Company>

             Contacts

                   <Contact>

                   <Contact>

Items formatted like this are standard folders which cannot be renamed; items like <this> are editable items.

How to create new items

1. Select the appropriate folder for the item you want to create.

2. Do one of the following:

o Click  New.

o Right-click the folder, and then click  New.

3. The new item's property window will appear.

 NOTE   You may also create new items from the folder's list window.

 IMPORTANT 
The following items require different steps:

Drawings
Issues out
Models

How to edit items

1. Select the item you want to edit.

2. Do one of the following:

o Click  Edit.

o Right-click the item, and then click  Edit.

o Middle-click the item.
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3. The item's property window will appear.

 NOTE   You may also edit items from the folder's list window.

How to delete items

1. Select the item you want to delete.

2. Do one of the following:

o Click  Delete.

o Right-click the item, and then click  Delete.

o On the keyboard, press Delete.

3. Click OK to confirm the delete.

 NOTE   You may also delete items from the folder's list window.

1.2.3 Start page

Operator
Shows the current operator. Click Change or double-click the tile to view the Operators window.

Quick links
Provides easy access to common tasks.

Current project
Shows the current project and job. Click Change or double-click the tile to switch to a different project and
job.

 NOTE 
This allows switching to a project that does not have any jobs. The Explorer only allows setting the current
project and job by selecting a job.

Virtual drives
Shows the computer's currently mapped virtual drives. Click Change or double-click the tile to view the Virtual
drives window. Click on a virtual drive letter or the physical path to open the folder in File Explorer.

Show page on startup
Select this check box to show the Start page when CadTracker starts.

1.2.4 Shortcuts

General shortcuts

KEY MEANING

F1 Display context-sensitive help.

F3, Ctrl+E, Ctrl+F Activate the Search box.

Ctrl+O Open selected documents or drawings.

Ctrl+Shift+O Open each selected drawing in a new instance of AutoCAD. If no drawings are
selected, a new AutoCAD instance is launched with the working directory set to
the current job.

Ctrl+S Save the active record.

Ctrl+F4 Close the active window.
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Text box and drop-down list shortcuts

KEY MEANING

Ctrl+U Convert the selected text, or the next character if nothing is selected, to lower
case.

Ctrl+Shift+U Convert the selected text, or the next character if nothing is selected, to UPPER
CASE.

Ctrl+Shift+S Convert the selected text, or all characters if nothing is selected, to Sentence case.

Ctrl+Shift+T Convert the selected text, or all characters if nothing is selected, to Title Case.

F8 Displays a drop-down to insert a common character such as the diameter or
degrees symbol. Windows Character Map may also be opened from this drop-
down.

Numeric text box shortcuts

KEY MEANING

F9 Change the sign of the current number, i.e. equivalent to pressing +/- on a
calculator.

+, -, *, / Open the calculator to add, subtract, multiply or divide.

= Calculates the result in calculator mode.

Enter Commits a number to the text box in calculator mode.

Escape Cancel the calculation in calculator mode.

Selection list shortcuts

KEY MEANING

spacebar Check or uncheck the selected items.

double-click Check or uncheck one item.

F4 Toggle Show checked items only.

1.2.5 View menu

Multi-line window tabs
Select this option to display more than one row of window tabs.

Prompt to import document data
Select this option to display more than one row of window tabs.

Show archived records
Select this option to show archived projects in the Explorer.

Single document interface
When this option is selected, only the Start page and one other window is shown in CadTracker. Opening a
new window will automatically close the existing window. If there are unsaved changes, you will be prompted
to save or discard the changes.

Start page
Shows the Start page.



18 CadTracker

© 2014 CadTech Software

Virtual drives
Shows the Virtual drives window.

1.2.6 Window menu

With single document interface switched off, you may open many windows at the same time.

Click Window to see the windows you currently have open or to switch to a different window.

 TIP   You can close a window by middle-clicking the window's tab.

1.2.7 Virtual drives

View > Virtual drives

A virtual drive is a physical or logical resource mapped to a local drive letter.

There are two types:
subst - a drive substitution to a local resource, and
net use - a drive substitution to a network resource.

Project, server, standards and job folders may be mapped as virtual drives.

1.2.8 Tips for managers

Deployment via a shared folder

IT/CAD managers should set up a shared folder to deploy CadTracker, e.g. \\nas\Common\CadTracker.

Remember setup path
When CadTracker is launched, it checks for updates from the internet. In the CadTracker installer, there is an
option to Remember setup path, which should be selected for shared folder deployments. With this option
selected, CadTracker will only check for updates of the setup file in the shared folder; internet updates will be
ignored. IT/CAD managers can then decide when to deploy a new version. When CadTracker starts, if a new
version of the setup file is detected, the operator will be prompted to install it.

Connection strings configuration file

CadTracker's connection strings configuration file stores a list of primary database connections. By default, the
configuration file is installed to:

%ProgramFiles%\CadTech Software\CadTracker\CadTechSoftware.CadTracker.ConnectionStrings.config

There may already be a connection strings configuration file in the shared deployment folder. If a config file is
present in this folder, it will be copied automatically by CadTracker's client application installer.

Edit the XML configuration file and enter the connection strings for all of the CadTracker databases that will be
used in your company.

To connect to an SQL Server database:
<add name="<connection name>" connectionString="Data Source=<machine name>\<instance
name>;Initial Catalog=<database name>;uid=<user name>;pwd=<password>;"
providerName="System.Data.SqlClient"/>

To connect to an Azure SQL database:

http://en.wikipedia.org/wiki/SUBST
http://en.wikipedia.org/wiki/Net_use
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<add name="<connection name>" connectionString="Data Source=tcp:<server
name>.database.windows.net,1433;Database=<database name>;uid=<user name>@<server
name>;pwd=<password>;Trusted_Connection=False;Encrypt=True;Connection Timeout=30;"
providerName="System.Data.SqlClient"/>

 TIP 
In the CadTracker installation folder, there is a console application named 
CadTechSoftware.ConnectionStringsEditor which can help you create or edit connection string
configuration files. There may also be a copy of this application in the shared deployment folder. Double-click
the application or run CadTechSoftware.ConnectionStringsEditor /? to display help.

1.3 Getting help
There are a number of different sources of help in CadTracker. In addition to this help file you can also access
video tutorials, the user forum and CadTech Software support.

This help file is the best way to get started. It will provide all the information you need to learn and use
CadTracker.

Before contacting support, please search for the information here or on the user forum.

Displaying the help

The quickest way to display the help is to press F1 or click Help > View help. If context-sensitive help is
available it will be displayed automatically.

 IMPORTANT 
The following internet resources are not yet available.

Video tutorials
You can view video tutorials for some of more complex CadTracker processes at:

cadtracker.com.au/home/support

Contacting CadTech Software support

Support is available from the team at:

cadtracker.com.au/home/contact

Print the user guide

The CadTracker PDF user guide is included in the CadTracker installation folder, or you can download it from:

cadtracker.com.au/userguide

http://www.cadtracker.com.au/home/support
http://www.cadtracker.com.au/home/contact
http://www.cadtracker.com.au/userguide
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2 Tools menu
The Tools menu contains many configuration items and some commands, too.

2.1 Common values
Lists of common values may be set up for many properties via the Tools menu.

Document
Areas
Categories
Subcategories
Titles
Related file codes
Revision statuses

Drawing
Categories
Revision descriptions

Issue
In > Subjects
Out > Categories
Out > Subjects

Address types

E-mail address types

Phone number types

2.2 Drawing titles 3 and 4
Drawing titles are usually mapped to border attributes. Titles 1 and 2 are usually the project and job names,
respectively. Common values for drawing titles 3 and 4 may also be set up.

There is a list of standard drawing titles, and each project also has its own list of drawing titles. When a new
project is created, all of the standard titles are copied into the project. Changes made to a project's drawing
titles do not affect the standard list, or any other project's drawing titles.

Standard drawing titles

Tools > Drawing > Titles 3
Tools > Drawing > Titles 4

Project drawing titles

To add, edit or delete project drawing titles, edit the project, and select the Drawing titles tab.

When creating or editing a drawing record, project drawing titles may be selected from the lists. They are
shown in the same order as they appear in the Drawing titles tab, so move the most common titles to the top
of the list.
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2.3 Drawing types
A drawing type associates a border DWG file to plot settings for physical, DWF and PDF plots.

There is a list of standard drawing types, and each project also has its own list of drawing types. When a new
project is created, all of the standard drawing types are copied into the project. Changes made to a project's
list of drawing types do not affect the standard list, or any other project's drawing types.

Standard drawing types

Tools > Drawing > Types

Project drawing types

To add, edit or delete project drawing types, edit the project, and select the Drawing types tab.

When creating or editing a drawing record, project drawing types may be selected from the list. They are
shown in the same order as they appear in the Drawing types tab, so move the most common types to the
top of the list.

Border path
The path to the DWG file to be used as the border for this drawing type.

The path may be:
Absolute path
Relative to project
Relative to server

Subfolders are acceptable for relative paths, e.g. Borders\A1Standard.dwg.

 IMPORTANT 
The selected DWG file must match an existing border record name. Only the file name must match, not the
full path.

For example, the following border paths will use the same border setup:
\\NAS\Borders\A1Standard.dwg
\\Server\Common\A1Standard.dwg
Title blocks\A1Standard.dwg (Relative to project)

If the border has not been set up, do that first. Then click  Re-validate border path.

Plot settings

Physical plotter
Select a plot setting to be used when drawings of this type are plotted to a physical plotter.

PDF
Select a plot setting to be used when drawings of this type are plotted to PDF.

DWF
Select a plot setting to be used when drawings of this type are plotted to DWF.
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2.4 Issue advice templates
Tools > Issue > Out > Advice templates

Issue advice documents may be customised using templates.

Template name
Type a name that briefly describes the template. This will help your operators choose the correct template
when creating an issue. Each project can also set a default issue advice template.

Show line number
Select this check box to show a line number for each transmittal item. This can be useful when manually
checking large numbers of items.

Show type
Select this check box to show the Type column, which describes the type of the transmittal item, i.e. Drawing,
Document, or Attachment.

Show file name
Select this check box to show the File name column, which displays the file name of the transmittal item.

 NOTE 
Some offices prefer not to show the file name column, as it may be inferred from the number and revision
code. However, the file name may be unrelated to the number and revision code. For example, consider a
paper space drawing in a 2D model. If you select the DWG file to send, it is very unlikely that the file name will
match the drawing number. In cases like this, it is better to choose a template which displays the file name.

Show title 1
Select this check box to show the Title 1 field. For drawings and documents, title 1 is usually the project name.
For a particular issue, if you know that none of the drawings have used different values for title 1, you could
use an advice template which does not show title 1.

Show title 2
Select this check box to show the Title 2 field. For drawings and documents, title 2 is usually the job name. For
a particular issue, if you know that none of the drawings have used different values for title 2, you could use an
advice template which does not show title 2.

Show title 3
Select this check box to show the Title 3 field. For a particular issue, if you know that none of the drawings
have values for title 3, you could use an advice template which does not show title 3.

Show title 4
Select this check box to show the Title 4 field. For a particular issue, if you know that none of the drawings
have values for title 4, you could use an advice template which does not show title 4.

Title display style
Select one of the following:

Separate cells in columns to create columns for each of the visible title columns, or
One cell with multiple lines to create one title column and display the visible titles vertically.

Page orientation
Portrait works well for templates that do not display every column. If the template has many columns, or a
project has long number or column values, Landscape may be a better choice.

Additional columns
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Additional columns are added to the right-hand side of the transmittal table in the issue and transmittal advice
documents.

Additional columns may be useful for handwritten notes, annotations or stamps.

Column name
The name that will appear in the column header.

Width (mm)
Use Auto to let the table auto-size the column, or specify the width of the column in millimetres.

Left border
Prints a vertical border on the left-hand side of the column. Borders may be useful for handwritten notes,
annotations or stamps.

2.5 Scales
Tools > Scales

These are standard scales for drawing Scale factor values.

2.6 Operators
Tools > Operators

Each drawing and revision has a list of operators. These values may be entered manually, but are usually
entered by selecting an operator from the list. Contacts may be set up as operators with codes, a certification
number, and a signature.

Click  Add new to select contacts to set up as operators.

Click  Delete to delete a contact from the operators list.

Code for drawings
This code is used for drawing operator properties, e.g. Drawn by or Checked by. Many borders allow sufficient
space for the drawing operator codes to use a full surname, e.g. C.S. LEWIS. This code may be up to 20
characters.

Code for revisions
Codes for revisions may be up to 20 characters, but are typically only two or three, i.e. the person's initials.
Long codes may not fit in the space allocated in drawing borders.

 IMPORTANT   UPPER CASE codes are recommended, as this is usually required to meet national drafting
standards.

 TIP 
Use full stops with no spaces when abbreviating a first or second name, but with a space before the surname,
e.g. C.S. LEWIS. Eschew the full stops when using initials alone, e.g. CSL.

Certification
This property may be used to record an operator's industry certification or license number.

Signature
The signature may be the name or initials of the operator entered as text, or a link to an image of a scanned
signature or company logo.
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To set the current operator on a workstation, select the appropriate check box in the Current operator
column.

2.7 Report templates
Tools > Report templates

CadTracker reports may be configured with templates. Extension applications may also provide their own
report templates.

 TIP 
Don't drown in the data! It may be tempting to include every available property in every report template, but
this is not necessarily a good idea. Too much information can be overwhelming to the reader, and it is also
more difficult to print the reports as they become too wide Think about who will be reading your reports and
which properties are valuable to them. You may create as many different report templates as you wish, so
design your templates for particular use cases.

Name
Enter a descriptive name for the template. The template name forms part of the default report file name when
it is saved, e.g.
<project number> <project name> - <report template name> - <timestamp>.xlsx

Properties

Select the properties to include in the report. Click  Move up (Ctrl + U) or  Move down (Ctrl + D) to
order the columns.

Options
Each type of report template may provide various options relating to data or presentation.
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3 Configuration
Tools > Configuration

The Configuration has many important options. Most of the options serve as default values for new projects.
Setting up the Configuration correctly will allow you to create new projects more quickly.

There is only one Configuration for each CadTracker database, which is shared by all users.

3.1 Drawings + revisions
The Drawings + revisions tab in the Configuration is used to define default values for new projects.

When a new project is created, all of the values are copied from the Configuration into the project. Each
project may use different values.

3.1.1 Drawing name format

The drawing name format defines the default format for new drawing names.

When a new project is created, the drawing name format is copied from the Configuration. Each project may
have a different default format, and the project's format may be changed for any drawing when it is first
created.

Every drawing name format must have one <DrawingNo> (drawing number) and one <RevCode> (revision

code) keyword placeholder. Click  Insert keyword placeholder to see a list of standard keyword
placeholders that may be inserted.

Drawing name formats cannot contain any of the following characters:
\ / : ; , * ? < > | = " `

When a border is added and a new drawing is created in the model space layout tab, the DWG file is saved as
the drawing name plus the .dwg file extension. Alternatively, when a new drawing is created in a paper space
layout tab, the layout tab is renamed to match the drawing name.

 NOTE   For most projects, the drawing name format is simply <DrawingNo><RevCode>. Occasionally, there
may be a requirement to add other values that are not part of the drawing number, such as a project number
or discipline code; these values are typically added to the start of the format.

3.1.2 Plot name format

The plot name format defines the file name format for drawings plotted to file-based plotters.

When a new project is created, the plot name format is copied from the Configuration. Each project may have
a different format.

Every plot name format must have one <DrawingName> (drawing name) keyword placeholder. Click 
 Insert keyword placeholder to see a list of standard keyword placeholders that may be inserted.

Drawing plot name formats cannot contain any of the following characters:
\ / : ; , * ? < > | = " ` [ ]

 NOTE   For most projects, the plot name format is simply <DrawingName>. Some offices append -
<ModelName>, which can make it easier to identify which model a drawing belongs to.
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3.1.3 Revision options

When a new project is created, all of the following values are copied from the Configuration. Each project may
use different values.

Revision code prefix
This value is displayed before the revision code in DWG, PDF and DWF file names, and in paper space layout
tab names. The default value is [.

Revision code suffix
This value is displayed after the revision code in DWG, PDF and DWF file names, and in paper space layout tab
names. The default value is ].

Work in progress

Check print

Check approved

Preliminary revisions use:
For approval revision code
P1, P2, P3, etc.

For tender revisions use:
For approval revision code
T1, T2, T3, etc.

For construction revisions use:
Numbers
Letters

Revision letters to omit

Single-letter prefix
Some offices require single-letter revisions to be preceded by a specific character in file names, such as zero, to
make files sort in a certain way.

Numeric revisions start at:
Zero
One

Minimum digits
Numeric revisions may be configured with or without leading zeroes, e.g. 1, 02, 003, or 0004.

New revisions default to:
Work in progress
Current revision type

If Current revision type is selected, when the Rev Up This Drawing dialog is displayed in AutoCAD, the Rev up
to box will default to the drawing's current revision type, e.g. For approval -> For approval, For construction ->
For construction.

As built revisions display:
All public issue history lines
As built revision only

If As built revision only is selected, when a drawing is revised to As built, all previous revision history lines will
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not be displayed in the border.

3.1.4 Work in progress character

The work in progress character is appended to the revision code when a drawing is revised to Work in progress.
The default value is w.

For example, if a drawing is revised from revision A to Work in progress, and the project's work in progress
character is w, the drawing's new revision code would be Aw0. The next work in progress revision would be
Aw1, etc.

When a new project is created, the work in progress character is copied from the Configuration. Each project
may use a different work in progress character.

The work in progress character cannot be any of the following characters:
1 2 3 4 5 6 7 8 9 0 \ / : * ? < > | "

3.1.5 Check print character

The check print character is appended to the revision code when a drawing is revised to Check print. The
default value is c.

For example, if a drawing is revised from revision A to Check print, and the project's check print character is c,
the drawing's new revision code would be Ac.

When a new project is created, the check print character is copied from the Configuration. Each project may
use a different check print character.

The check print character cannot be any of the following characters:
1 2 3 4 5 6 7 8 9 0 \ / : * ? < > | "

3.1.6 Check approved character

The check approved character is appended to the revision code when a drawing is revised from Check print to
Check approved. The default value is a.

For example, if a drawing is revised from check print revision Ac to Check approved, and the project's check
print character is c, the drawing's new revision code would be Aa.

When a new project is created, the check approved character is copied from the Configuration. Each project
may use a different check approved character.

The check approved character cannot be any of the following characters:
1 2 3 4 5 6 7 8 9 0 \ / : * ? < > | "

3.1.7 Revision letters to omit

Letters in the list of revision letters to omit will not be used as revision codes for any revision of a drawing in
the project. The default values are IOW to avoid confusion with the numbers 1 and 0, and the letter w, which is
the default work in progress character.

For example, if a project defines I as a revision letter to omit, and a drawing is revised from revision H to the
next letter revision, the drawing's new revision code would be J; letter I would be automatically skipped.

When a new project is created, the revision letters to omit are copied from the Configuration. Each project
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may use different revision letters to omit.

3.1.8 Static revision codes

Static revision codes may be defined for As built or Redundant revisions.

For example, if a project has enabled AB as the static revision code for as built revisions, all drawings revised to
As built will have the revision code AB, regardless of what the previous construction revision codes were.

When a new project is created, the static revision codes are copied from the Configuration. Each project may
use different static revision codes.

Static revision codes cannot contain any of the following characters:
\ / : ; , * ? < > | = " `

3.2 Folders
 NOTE   Standard folders can be particularly useful to help managers enforce standard folder structures for
drawings, documents, and transmittals, and to quickly copy common files such as spreadsheets, documents,
borders or other AutoCAD blocks.

Project

Standard folder
When a new project is created, you have the option to copy all folders and files from the standard project
folder into the new project's folder.

Map drive
When a project is set as the current project, the project folder may optionally be mapped to a drive letter, e.g. 
P:.

Issue folder
The issue folder defines the name of the folder where issues and transmittals are saved. The path is relative to
the project folder. Subfolders are acceptable, e.g. Issues\Out.

Reports folder
The reports folder defines the name of the folder where reports are saved.

The path may be:
Absolute path
Relative to project
Relative to server

Subfolders are acceptable for relative paths, e.g. Documents\Reports.

Server

Folder (optional)
The server folder may be used as a common resource for a project. Reports folders, superseded folders, and
drawing type border paths may be relative to the server folder.

Map drive
When a project is set as the current project, the server folder may optionally be mapped to a drive letter, e.g. S:.
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Standards

Folder (optional)
The standards folder may be used as a common resource for a project.

The path may be:
Absolute path
Relative to project

Subfolders are acceptable for relative paths, e.g. Common\Standards.

Standard folder
When a new project is created, you have the option to copy all folders and files from the standard standards
folder into the new project's folder.

Map drive
When a project is set as the current project, the standards folder may optionally be mapped to a drive letter,
e.g. V:.

Job

Standard folder
When a new job is created, you have the option to copy all folders and files from the standard job folder into
the new job's folder.

Map drive
When a job is set as the current job, its folder may optionally be mapped to a drive letter, e.g. J:.

Reports folder
The reports folder defines the name of the folder where reports are saved.

The path may be:
Absolute path
Relative to job
Relative to project
Relative to server

Subfolders are acceptable for relative paths, e.g. Documents\Reports.

Superseded folder
The superseded folder defines the name of the folder where superseded drawings, models and file-based plot
files are moved when a drawing is revised.

The path may be:
Absolute path
Relative to job
Relative to project
Relative to server

Subfolders are acceptable for relative paths, e.g. Drawings\Superseded.
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3.3 Operators

Operator aliases

Each drawing may have up to seven operators. Your company may use different names for one or more
operator roles, or there may be a special operator role that is unique to a particular client or project. Drawing
edit and rev up windows will display these aliases in place of the standard names.

For example, a client may require two approvals per drawing: Project approved by and Technical approved by.
You could use the Approved by property for Project approved by and the Directed by property for Technical
approved by.

When a new project is created, the operator aliases are copied from the Configuration. Each project may use
different values.

Default public issue operators

When a drawing is revised to a public issue revision, i.e. Preliminary, For approval, For tender, For construction,
As built, or Redundant, the following values may be entered:

Issue drawn by
Issue checked by
Issue approved by
Issue verified by

The Operators tab lets you define the default operator for each of these fields. The default operator may be
the (Current operator) or a contact from your company or another company who has been set up as an
operator.

3.4 Status descriptions
When a new project is created, all of the following status descriptions are copied from the Configuration. Each
project may use different values.

Status descriptions are required for the following revision types:
Work in progress
Preliminary
For approval
For tender
For construction
As built
Redundant
Check print suffix
Check approved suffix

The Check print suffix and Check approved suffix values are appended to the current status description of a
revision.

 IMPORTANT   UPPER CASE status descriptions are recommended, as this is usually required to meet national
drafting standards.
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3.5 E-mail
If you want to e-mail issues and transmittals directly from CadTracker, you must set up an e-mail account.

E-mail address
The from address for the e-mail message. If Send with Outlook is selected as the issue e-mail type, CadTracker
will search for this e-mail account in Outlook. If the account is not set up for the current user, the default e-
mail account will be used.

Display name
The display name associated with the e-mail address. This is typically your company name.

User name
The user name for the SMTP server credentials.

Password
The password for the user name associated with the SMTP server credentials.

SMTP server
The name or IP address of the host computer used for SMTP transactions, e.g. mail.bigpond.com.

Issue e-mail type
When a new project is created, the issue e-mail type is copied from the Configuration. Each project may use a
different issue e-mail type. This is the default value for a new issue; it may be changed for any issue.

Issue advice Outlook template
When a new project is created, the issue advice Outlook template value is copied from the Configuration. Each
project may use a different template. If Send with Outlook is selected as the e-mail type for an issue, the
project's Outlook template will be used. The issue advice and each transmittal e-mail may be previewed and
edited in Outlook before being sent. There is a sample Outlook template in the CadTracker installation folder.

The following keyword placeholders may be used in issue advice Outlook templates:

%issue number% The issue's number
%project number% The project's number
%project name% The project's name
%client% The client's company name
%subject% The issue subject
%memo% The issue memo
%message% The issue advice e-mail message

 TIP 
The fastest way to create your own Outlook template is to copy and edit the sample from the CadTracker
installation folder. Alternatively, create a new e-mail in Outlook. Do not enter any recipients or a subject. When
you are ready to save the template, click File > Save As. Under Save as type select Outlook Template (*.oft).
Browse to the folder where you wish to save your template, type a file name, and click Save.

Outlook automatic signatures on templates and custom forms
When you use an e-mail template, Outlook will add your default signature to the bottom. This is usually not
desirable, as the template will typically contain a signature. Outlook has a hidden option to enable or disable
this feature. CadTracker allows you to enable or disable automatic signatures for the current user. Outlook
must be restarted for the change to take effect.



35Configuration

© 2014 CadTech Software

3.6 Reports
The following values are used to set up reports generated by CadTracker, such as issue and transmittal advice
documents, drawing registers and document registers.

Company logo file name
Select an image file to use as your company logo.

 NOTE   For best results, use a PNG file that is at least 250 pixels wide or 100 pixels high, and has a transparent
background.

Supported file types are:
Bitmap (*.bmp)
Device independent bitmap (*.dib)
MS Paint (*.msp)
Tagged Image File Format (*.tif, *.tiff)
Joint Photographic Experts Group (*.jpg, *.jpeg)
Portable Network Graphics (*.png)
MacPaint (*.mac)
Macintosh Pict (*.pct)

Company contact details

Address
Select (Not used) or one of your company addresses.

Phone
Select (Not used) or one of your company phone numbers.

Fax
Select (Not used) or one of your company phone numbers.

E-mail
Select (Not used) or one of your company e-mail addresses.

Include website
Select this option to include the website entered into your company record.

3.7 Miscellaneous

AutoCAD

Command line switches

In the Explorer, when you click  Launch AutoCAD, these command line arguments are used when starting
the application.

Some common AutoCAD switches include:

/nologo No product logo screen

/p "<profile name>" Set current profile

/t "<template file name>" Create new DWG file with this template

Border layer name
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When you add a border and create a new drawing, the border block will be inserted onto this layer. If the layer
does not exist, CadTracker will create it.

Enable DWF options
When DWF options are disabled, CadTracker will hide options related to DWF files in drawing context menus
and the issue wizard.

If your office does not issue drawings in DWF format, you may want to clear this check box.

Preview handler

File types to display as text
There are many different file types which are actually plain text files, e.g. CSV, XML. Many of these file types do
not have preview handler controls. If a preview handler could not be found for a particular file and the file
extension is listed here, CadTracker will attempt to display the file as text.
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4 Project
The project property window has several tabs:

Project
Folders
Drawing titles
Drawing types
Drawings + revisions
Status descriptions
Related companies

4.1 Project
Number (required)
The project's human-readable identifier. The number is displayed in the Explorer, on issue and transmittal
advice documents, and on reports. It is usually mapped to an attribute in drawing borders.

Numbers cannot contain any of the following characters:
\ / : ; , * ? < > | = " `

Alternative number
For some projects, clients may provide their own project numbers. The alternative number may be mapped to
an attribute in drawing borders.

Alternative numbers cannot contain any of the following characters:
\ / : ; , * ? < > | = " `

Name (required)
The project name is displayed on issue and transmittal advice documents, and on reports. It is usually mapped
to an attribute in drawing borders. The name is displayed in the Explorer if the project does not have an
internal name.

Internal name
If a project has an internal name, the internal name is displayed in the Explorer instead of the project name.
Internal names can be useful when you want to abbreviate very long names, or when you simply refer to the
project internally by a different name.

Client
If the project has a client, select it from the box. If no company record exists for the client, you may create one

by clicking .

When a project has a client assigned, the company e-mail addresses, addresses, and contact e-mail addresses
may be selected as recipients in the issue wizard.

Issue advice template
The default template for a new issue; it may be changed for any issue.

Issue e-mail type
The default e-mail type for a new issue; it may be changed for any issue. When a new project is created, this
value is copied from the Configuration.

Issue advice Outlook template

Date created
The date and time when the project was first saved.
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Archived
When a project is archived, it will not be visible in the Explorer, unless the View menu has Show archived
records selected.

Edit all drawings in this project
Opens the Multiple Drawings Editor for all drawing records in the project.

4.2 Folders

Project

Folder
The root folder where all of the project's files and folders are stored.

If you have entered a server folder, or it has been copied from the server folder in the Configuration,
CadTracker may suggest a project folder in the form <server folder>\<project number> <project name> or

<server folder>\<project number> <project internal name> if the project has an internal name. Click 
 Create project folder to create the suggested project folder.

If a standard folder has been set up in the Configuration, you may click  Copy files and folders from the
standard project folder.

Map drive
Select this check box and choose a drive letter if you want to map a drive to the project folder when the project

is set as the current project. Type a drive label or click  Generate a project drive label.

Issue folder
The issue folder defines the name of the folder where issues and transmittals are saved. The path is relative to
the project folder. Subfolders are acceptable, e.g. Issues\Out.

Reports folder
The reports folder defines the name of the folder where reports are saved.

The path may be:
Absolute path
Relative to project
Relative to server

Subfolders are acceptable for relative paths, e.g. Documents\Reports.

Server

Folder (optional)
The server folder may be used as a common resource for a project. Reports folders, superseded folders, and
drawing type border paths may be relative to the server folder.

Map drive
Select this check box and choose a drive letter if you want to map a drive to the server folder when the project

is set as the current project. Type a drive label or click  Generate a server drive label.

Standards
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Folder (optional)
The standards folder may be used as a common resource for a project.

The path may be:
Absolute path
Relative to project

Subfolders are acceptable for relative paths, e.g. Common\Standards.

Map drive
Select this check box and choose a drive letter if you want to map a drive to the standards folder when the

project is set as the current project. Type a drive label or click  Generate standards drive label.

Job

Map drive
Select this check box and choose a drive letter if you want to map a drive to the job folder when a job is set as

the current job. Type a drive label or click  Generate a job drive label.

4.3 Related companies
Related companies are other companies that are associated with the project.

When a project has related companies, the company e-mail addresses, addresses, and contact e-mail
addresses may be selected as recipients in the issue wizard.

4.4 Alternative revision code seed
The alternative revision code seed is assigned to the first public issue revision for each drawing.

Subsequent public issue revisions will try to automatically increment the last used alternative revision code.

4.5 Generic data
Enter topic text here.
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5 Document
In its simplest form, a document is a record of a file that is associated with a project. A document has a
number, it may have titles, and it may be categorised to three levels. Each document has one or more
revisions. Documents may be linked to an issue in, and document files may be included as part of an issue out.

The document property window has several tabs:
Document
Revisions
Related files
Issues out

5.1 Document
Category
Subcategory
Area
It can be helpful to organise documents into categories, subcategories and areas. Type or select values from
the lists. The lists shows all of the standard document categories, subcategories and areas, plus the non-
standard values that have been used in this project.

Number (required)
The document's primary identifier. It is usually related to the document's file name.

Alternative number
For some projects, clients may provide their own document or drawing numbers.

Title
Type or select up to four title lines.

Click one of the  Edit titles buttons to edit multiple title lines together.

If you are copying title values from a document register or a drawing title block, click one of the  Paste
clipboard contents to titles and CadTracker will attempt to split the titles into multiple lines automatically.

Notes
Document notes may be included in document register reports. Notes may also be edited with the Multiple
Documents Editor.

5.2 Revisions
The revisions tab shows a full history of the document's revisions. The grid is read-only; to edit a revision,
select a row and use the controls below.

Auto-sort revisions

Click  Auto-sort revisions to sort the revisions using the most common revision code sequence, i.e. alpha
codes followed by numeric codes.

Revision code (required)
The document's revision code, e.g. A or 1.1.

Description
Type or select a description from the list. The list shows all of the standard document revision descriptions
plus the non-standard descriptions that have been used in this project.
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Date
The date on which the document revision was created.

Status
The status of the document for this revision.

File name (required)
The absolute or project-relative path to the file.

Notes
Revision notes may be included in document register reports.

 IMPORTANT 
If the document has already been issued and you need to edit any of these values, you may need to re-issue
the document. You can check if a revision has been issued in the Issues out tab.

Transmittals in
The list shows every time the selected document revision was received via a transmittal in.

Select a transmittal in and click Edit transmittal to open the transmittal in record.

5.3 Related files
Documents may have one or more related files which need to be reviewed or updated when a new revision of
the document is created or received.

For example, let's say you have received a drawing, 123[A].pdf, which you have recorded as a document. Based
on the information in 123[A].pdf you have drawn a background DWG called Background.dwg which is used as
an external reference in other drawings. You receive a new revision, 123[B].pdf, and now Background.dwg
needs to be reviewed, and possibly updated. Document related files can help manage this scenario.

Code
It may be helpful to organise related files with a code. Type or select a code from the list. The list shows all of
the standard related file codes plus the non-standard codes that have been used in this project.

File name (required)
The absolute or project-relative path to the related file.

Review required
When a new revision of a document is recorded, all of the document's related files are automatically flagged
as Review required. When new document revisions have been recorded, you should also review related files.
Select or clear this check box to manually set this value.

5.4 Issues out
This tab lists the full issue history for this document. Click View out issue to open the issue property window
for the selected row.

5.5 Multiple Documents Editor
Many properties may be edited quickly with the Multiple Documents Editor. The Multiple Documents Editor
can be used to add new or edit existing documents.

To launch the Multiple Documents Editor, right-click a documents in the Explorer, and doing one of the
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following:
Click New > Open Multiple Documents Editor to add new documents
Click Edit > Open Multiple Documents Editor to edit existing documents

 NOTE   The Multiple Documents Editor can also be launched from the Documents tab in the transmittal in
property window.

Editable properties:
Category
Subcategory
Area
Number
Alternative number
Title 1
Title 2
Title 3
Title 4
Notes
Revision code
Revision description
Revision date
Revision status
Revision file name
Revision notes
Related file code
Related file name
Related file review required

Auto-sort revisions

Click  Auto-sort revisions to sort the revisions for all of the selected documents.

Create PDF binder

Click  Create PDF binder to create a PDF file containing all of the selected documents.

 NOTE   This only works for PDF files.

Edit multiple values simultaneously

To edit multiple values at the same time, select multiple rows and edit a property.

Copy values to selected items

To copy a property value from one item to other items, select multiple rows and click the appropriate  Copy
to selected items button.

 NOTE   The last item selected shows the value which will be copied.

Import data from spreasheet

Document properties may be set by importing data from a CSV, XLS or XLSX file. If you have received a
document register you may be able to format it and save it as one of these spreadsheet file types.

The following document properties may be set with a spreadsheet file:
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Property Alternative column names
Number (required) Name, Document number, DocumentNumber, DocumentNo, Drawing number,

DrawingNumber, DrawingNo
Alternative number Alternative number, AlternativeNumber, Client number, ClientNumber
Category
Subcategory Discipline
Area Job
Title 1 Title1
Title 2 Title2
Title 3 Title3
Title 4 Title4
Title Titles (automatically split into separate titles)
Notes Note, Comments, Comment
Revision code RevisionCode, Rev, Revision
Revision
description

RevisionDescription, Description

Revision date RevisionDate, Date
Revision status RevisionStatus, Status, Document status
Revision notes RevisionNotes
File name FileName, Revision file name, RevisionFileName, Drawing file name, DrawingFileName

The columns in the spreadsheet file must match a property name, or one of the allowable alternative names.
Column names must be in the first row of the spreadsheet; they are not case sensitive.

 NOTE 
To import data for documents with file names that are unrelated to their numbers, you will need to use the file
name column. If there is a file name column in the spreadsheet file, CadTracker will first look for a matching
record using the file name. If a match cannot be found, it will then search by the number column.

 IMPORTANT  Avoid using merged cells whenever possible, as they may produce unexpected results.

 XLS and XLSX files 
XLS and XLSX files will only work if Microsoft Excel 2007 or later is installed. If an XLS or XLSX file is selected,
CadTracker will attempt to convert the file to a CSV file first. If you have trouble importing data from an XLS or
XLSX, check the formatting of the spreadsheet, save it as a CSV file, and try again with the CSV file.

Don't show this again
Select this option to suppress this message in the future. The message may be switched on again by clicking 
Prompt to import document data in the View menu.

Adding new documents

The Multiple Documents Editor is the fastest way to add new documents or new revisions of documents.

CadTracker will attempt to parse the document number and revision code from the file name using the most
common naming conventions. If the number matches an existing document record in the project, the file will
be added as a new revision of that document. It will be displayed in the New revisions tab. If a file has not
been matched to an existing document, it will be displayed in the New documents tab.

If you know a file is a new revision of an existing document, but it was not correctly matched to an existing
document, select the row in the New documents tab and click Move to new revisions tab. Select the correct
document and the file will be added as a new revision.

If you know a file is a new document, but it was incorrectly matched to an existing document, select the row in
the New revisions tab and click Move to new documents tab.
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5.6 Review related files
To review related files which have been flagged for review, in the Explorer, right-click a documents item and
click Review related files.

Select a row, click Open related file and Open document to open the files and review them. Clear Review
required when you are satisfied that the related file is up-to-date.

5.7 Document revision code styles
Revision code styles may be selected and edited to help CadTracker parse document numbers and revision
codes. Any changes or new styles are remembered only for the current CadTracker session. This means you
can add, remove or edit styles to suit a particular set of documents that you wish to import.

CadTracker will attempt to parse each document using the selected styles in the order in which they appear,
until a value is found for both the number and revision code. Sometimes you may need to break up a large
group of documents into smaller groups with similar file name formats.

The Preview shows how the documents will be parsed with the selected styles.

 TIP   If you are importing documents that do not have revision codes, such as photos, uncheck all styles.

Use prefix/suffix

Most file name formats use one or more characters before the revision code, and sometimes one or more
characters after the revision code.

Prefix
One or more characters that mark the start of the revision code.

Suffix
One or more characters that mark the end of the revision code.

Require preceding digit
This option ensures that a number occurs immediately before the revision code prefix.

For example, with a dash as the prefix, “123-A - Model” would be parsed as:

Number: 123
Revision code: A

Use format

A custom format allows a greater degree of control  of the file name format.

The format characters are:

* Specifies zero or more characters at the start of the file name which do not form
part of the number or revision code. This effectively forces CadTracker to parse
the file name in reverse order. Format may only contain one * character at the
start.

? Specifies a single character which does not form part of the number or revision
code, and should be ignored.
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N Specifies a single character which forms part of the number. At least one N
character is required if no * character is present. Multiple N characters must be in
a single sequence.

R Specifies a single character which forms part of the revision code. At least one R
character is required.

Examples:

FILE NAME FORMAT NUMBER REVISION CODE

ABCD-1234X.pdf *NNNNR 1234 X

ABCD-1234X.pdf ?????NNNNR 1234 X

1234B.docx *R 1234 B

1234XYZAA.dwg NNNN???RR 1234 AA

01X123.txt RRNNNN X123 01

ABC 123 001.xlsx *NNN?RRR 123 001

5.8 Document group
Document groups make it easy to perform many actions, such as:

Creating an issue
Opening documents
Printing documents
Creating PDF binders
Creating reports

 NOTE   The current revision for each document is used.

Name
Type a group name or select and update an existing group name. The new group name must be unique; the
list of existing names makes it easier to create sequentially numbered groups.

Documents
Select one or more documents to be included in the group.
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6 Job
A job is logical unit of work for a project.

It can be helpful to divide large projects into several jobs. Consider creating jobs based on one of the following
criteria:

Discipline
Service
Floor (for multi-storey projects)
Area
Stage

 IMPORTANT   Spend some time planning your jobs before you start adding models and drawings, because
you cannot move them later.

The job property window has two tabs:
Job
Folders

6.1 Job
Number (required)
The job's human-readable identifier. The number is displayed in the Explorer, and optionally on reports. It may
be mapped to an attribute in drawing borders.

Numbers cannot contain any of the following characters:
\ / : ; , * ? < > | = " `

Alternative number
For some projects, clients may provide their own job numbers. The alternative number may be mapped to an
attribute in drawing borders.

Alternative numbers cannot contain any of the following characters:
\ / : ; , * ? < > | = " `

Name (required)
The job name is optionally displayed on reports. It is usually mapped to an attribute in drawing borders. The
name is displayed in the Explorer if the job does not have an internal name.

Internal name
If a job has an internal name, the internal name is displayed in the Explorer instead of the job name. Internal
names can be useful when you want to abbreviate very long names, or when you simply refer to the job
internally by a different name.

Date created
The date and time when the project was first saved.

Use project name as title 1
Drawings may have title 1 values which are not identical to the project name. Click this button to use the
project name for all drawing title 1 values.

Use job name as title 2
Drawings may have title 2 values which are not identical to the job name. Click this button to use the job name
for all drawing title 2 values.

Edit all drawings in this job
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Opens the Multiple Drawings Editor for all drawing records in the job.

6.2 Folders
Folder
The root folder where all of the job's files and folders are stored.

CadTracker may suggest a job folder relative to the project folder in the form <job number> <job name> or

<job number> <job internal name> if the project has an internal name. Click  Create folder to create the
suggested job folder.

If a standard folder has been set up in the Configuration, you may click  to copy files and folders from the
standard job folder.

Drive label

If the project has set up a mapped drive for jobs, type a drive label or click  Generate default drive label.

Reports folder
The reports folder defines the name of the folder where job reports are saved.

The path may be:
Absolute path
Relative to job
Relative to project
Relative to server

Subfolders are acceptable for relative paths, e.g. Documents\Reports.

Superseded folder
The superseded folder is where superseded drawings, models and file-based plot files are moved when a
drawing is revised.

The path may be:
Absolute path
Relative to job
Relative to project
Relative to server

Subfolders are acceptable for relative paths, e.g. Drawings\Superseded.
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7 Drawing
A drawing is a record of a deliverable item with a border.

A drawing record represents one of the following:
a DWG file with a border in model space, or
a border in a paper space layout tab, inside a model.

Drawing records can only be created through AutoCAD.

The drawing property window has several tabs:
Drawing
Operators
File info
Notes
Revisions
Issues out

7.1 Drawing
Category
It can be helpful to organise drawings into categories. Type or select a category from the list. The list shows all
of the standard drawing categories plus the non-standard categories that have been used in this project.

Number
The drawing's primary identifier. It should be mapped to an attribute in drawing borders.

Alternative number
For some projects, clients may provide their own drawing numbers. The alternative number may be mapped
to an attribute in drawing borders.

When drawings are issued, they may be sent using alternative numbers for zip item names.

Title 1
Title 1 defaults to the project name, but it may be edited. If title 1 differs from the project name, you may click 

 Use project name as title 1. If title 1 is identical to the project name, this button will be disabled. Title 1 is
usually mapped to an attribute in drawing borders.

Title 2

Title 2 defaults to the job name, but it may be edited. If title 2 differs from the job name, you may click  Use
the job name as title 2. If title 2 is identical to the job name, this button will be disabled. Title 2 is usually
mapped to an attribute in drawing borders.

Title 3 (optional)
Type or select a title from the list. Title 3 is usually mapped to an attribute in drawing borders.

Title 4 (optional)
Type or select a title from the list. Title 4 is usually mapped to an attribute in drawing borders.

Drawing type
The drawing type controls which plot settings are used for physical, DWF and PDF plots.

Scale factor
When you add a border and create a new drawing, the scale factor is pre-filled with the dimscale of the DWG. If
you change the DWG's dimscale later, the drawing record will not be automatically updated. The scale factor
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may be mapped to an attribute in drawing borders.

7.2 Operators
Each drawing may have up to seven operators:

Drawn by
Checked by
Approved by
Designed by
Verified by
Directed by
Authorised by

Operator aliases may be set up in the Configuration or in each project.

Each operator has the following properties:

Name
The name of the operator, or blank if the code does not match an operator.

Code
The code of the operator. This is usually mapped to an attribute in drawing borders.

Date
The date on which the operator performed this action. This may be mapped to an attribute in drawing 
borders.

Certification
The certification number of the operator. This may be mapped to an attribute in drawing borders.

Signature
The signature may be the name or initials of the operator entered as text, or a link to an image of a scanned
signature or company logo.

Recommendations for signature images

If the signature property is mapped to an attribute in a drawing border, the image is attached to the DWG at
the insertion point of the attribute definition, and scaled to the scale factor of the border block reference.
Images should be sized for 300 DPI output, so that they look crisp when plotted to paper, PDF or DWF. The
following formulae can be used to work out the required pixel dimensions of the image:

Millimetres
Width  = (desired width in mm)  ÷ 25.4 × 300
Height = (desired height in mm) ÷ 25.4 × 300

Inches
Width  = (desired width in inches)  × 300
Height = (desired height in inches) × 300

For example, if you want a signature image to fill a space that is 20mm wide and 5mm high, the image
dimensions must be no larger than:

20mm ÷ 25.4 × 300 = 236 pixels width
 5mm ÷ 25.4 × 300 =  59 pixels height
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7.3 File info
Name
The current name of the drawing.

Folder
The absolute or relative path of the folder where the drawing's DWG is located. If the DWG file has been

moved, click  Browse folder to re-select the DWG's folder. If the folder is an Absolute path, you may click

 Scan for relative path to scan for a path relative to the project or job folders.

File path
The full path of the drawing's DWG, or the model DWG if it is a paper space drawing.

Border path
The full path of the border DWG.

7.4 Notes
Drawing notes may be included in drawing register reports. Notes may also be edited with the Multiple
Drawings Editor.

7.5 Revisions
The revisions tab shows a full history of the drawing's revisions. The grid is read-only; to edit a revision, select
a row and use the controls below.

Notes
Revision notes may be included in drawing register reports.

Alternative revision code
For some projects, clients may provide their own drawing revision codes. This property may also be used as a
public issue counter. The alternative revision code may be mapped to attributes in drawing borders.

Alternative revision codes can be automatically assigned and incremented by setting up the project's 
alternative revision code seed.

When drawings are issued, they may be sent using alternative numbers & revs for zip item names.

 NOTE   The As built, Description, Drawn by, Checked by, Approved by, Date returned and Resolved properties
may only be edited for public issue revisions, i.e. Preliminary, For approval, For tender, For construction, As
built, or Redundant.

As built
This check box may be selected or cleared for any construction revision.

Description
Type or select a description from the list. The list shows all of the standard drawing revision descriptions plus
the non-standard descriptions that have been used in this project.

If the description differs from the project's status description for this revision type, you may click  Use
default description. If the description is the default description, this button will be disabled. The description is
usually mapped to a public issue history line attribute in drawing borders.

Drawn by
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The code of the operator who drew this public issue revision. This is usually mapped to an attribute in
drawing borders.

Checked by
The code of the operator who checked this public issue revision. This is usually mapped to an attribute in
drawing borders.

Approved by
The code of the operator who approved this public issue revision. This is usually mapped to an attribute in
drawing borders.

Verified by
The code of the operator who verified this public issue revision. This is sometimes mapped to an attribute in
drawing borders.

Date
The date and time when the revision was created.

 IMPORTANT 
If the drawing has already been issued and you need to edit any of these values, you may need to re-issue the
drawing. You can check if a revision has been issued in the Issues out tab.

7.6 Issues out
This tab lists the full issue history for this drawing. Click View out issue to open the issue property window for
the selected row.

7.7 Multiple Drawings Editor
Many properties may be edited quickly with the Multiple Drawings Editor.

To open the editor, in the Explorer, right-click a project or job item, or a drawings folder and click Multiple
Drawings Editor.

Editable properties:
Category
Alternative number
Title 1
Title 2
Title 3
Title 4
Drawing type
Scale factor
Drawn by
Drawn date
Checked by
Checked date
Notes

Edit multiple values simultaneously

To edit multiple values at the same time, select multiple rows and edit a property.
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Copy values to selected items

To copy a property value from one item to other items, select multiple rows and click the appropriate  Copy
to selected items button.

 NOTE   The last item selected shows the value which will be copied.

Generate numbers

Multiple drawings can be sequentially numbered using the Alternative number, Title 3 or Title 4 properties.

To sequentially number multiple drawings, select multiple rows and click the appropriate button:

       Generate alternative numbers

       Generate Title 3 numbers

       Generate Title 4 numbers

Enter the first number in the sequence and click OK.

 NOTE 
You may use separators and leading zeroes. Only the last part of the sequence is incremented. For example:

A1 > A2 > A3
XYZ-123-001 > XYZ-123-002 > XYZ-123-003
25.9 > 25.10 > 25.11
FRAME DETAILS - SHEET 1 > FRAME DETAILS - SHEET 2 > FRAME DETAILS - SHEET 3

7.8 Drawing group
Drawing groups make it easy to perform many actions, such as:

Creating an issue
Opening DWG, PDF or DWF files
Printing DWG, PDF, or DWF files
Creating PDF binders
Creating reports

 NOTE   The current revision for each drawing is used.

Name
Type a group name or select and update an existing group name. The new group name must be unique; the
list of existing names makes it easier to create sequentially numbered groups.

Drawings
Select one or more drawings to be included in the group.

7.9 Printing
To print a drawing to the Windows default printer , do one of the following:

Right-click a  <Drawing> in the Explorer and click Quick print DWG, Quick print PDF, or Quick print
DWF

 NOTE 
The PDF and DWF options are hidden if the files do not exist. You can create PDF and DWF plots through
AutoCAD.

View the  Drawings list window, select one or more drawings and then click  Quick print.
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You may also create a PDF binder and print.
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8 Model
A model is a record of a DWG file.

Models may contain drawings with borders in paper space layout tabs, but cannot have borders in model
space. A model with paper space drawings is often called a 2D model. Conversely, 3D models do not normally
have 2D drawings in paper space. CadTracker does not make a distinction between 2D and 3D models, but
understanding the terminology can be helpful.

How to create a new model

Model records can only be created through AutoCAD.

File name

The file name that is recorded for this model. If the file name is an Absolute path, you may click  Scan for
relative path to scan for a path relative to the project or job folders.

File path

The full path that the file name resolves to. If the DWG file has been moved or renamed, click  Re-select
DWG file.
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9 Issue in
An issue in is a collection of files that have been received.

Number
The official issue number or a description of the issue.

From
Type or select the sender's name, or select one from the list.

 NOTE   In the Explorer, issues in are organised into folders by the sender's name.

Date created
The date on which the issue was created.

Date received
The date on which the issue was received.

Subject (optional)
The subject, or reason, for the issue.

Advice memo (optional)
The message that was displayed on the issue advice.

Advice file name (optional)
The issue advice file.

E-mail message (optional)
If there was important information in the body of the e-mail message, you may wish to copy and paste it here.

9.1 Transmittal in
Each issue is made up of one or more transmittals, and each transmittal has one or more transmittal item files.
A transmittal item may be a document revision, or any other file.

The transmittal in property window has several tabs:
Transmittal
Documents
Other items

9.1.1 Transmittal

Number
The official transmittal number or a description of the issue. If the issue contains multiple transmittals, the
transmittal number is usually the issue number plus a suffix, e.g. 1234-01.

Date received
The date on which the transmittal was received.

Advice file name
The transmittal advice file. For issues with only one transmittal, this may be the same as the issue advice file.
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9.1.2 Documents

Transmittal items are usually recorded as new documents or new revisions of existing documents.

The Multiple Documents Editor is the fastest way to record transmittal items as new documents or new
revisions. Click New > Select document files to get started.

If you have already entered the documents, then you may select a document revision to link it to this
transmittal. Click New > Include an existing document revision in this transmittal and select the documents
to be linked.

9.1.3 Other items

If there were any other files that were received with the transmittal, but you do not want to record them as
documents, you may record the files as other items.





X
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10 Issue out
An issue out is a collection of files to be sent to one or more recipients. Each issue is made up of one or more
transmittals, and each transmittal has one or more transmittal items. A transmittal item may be a drawing, a
document, or any other file.

To create a new issue, launch the create issue wizard.

10.1 Create issue
The issue wizard leads you through steps required to create a new issue.

How to create a new issue out

Do one of the following:

On the Start page, under Quick links, click  Create issue or

In the Explorer, right-click the project item, then click  Create issue

The steps in the wizard are:
1. Select or type a subject
2. Select drawings to send
3. Select documents to send
4. Create reports to send
5. Add other attachments to send
6. Select the e-mail recipients
7. Select e-mail options
8. Select the postal recipients
9. Summary
10.Creating issue

10.1.1 Select or type a subject

Select or type a subject for the issue. The list shows all of the standard issue out subjects.

Memo for issue and transmittal advice documents (optional)
On advice documents, the memo is shown directly below the issue subject.

 NOTE 
This box accepts very long memos. If you need more space, there is a splitter below the subject list which may
be dragged up to increase the size of this box.

Issue advice template
Select the issue advice template.

Category (optional)
It can be helpful to organise issues into categories. Type or select a category from the list. The list shows all of
the standard issue out categories plus the non-standard categories that have been used in this project.

Save issue to category subfolder
Select this check box if you want to save the issue files inside a category subfolder in the project's issue folder,
i.e.
<issue folder>\<category>\<issue number>

Maximum transmittal size (MB)
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Transmittal items are packaged in zip files. If the issue will e-mailed, it is best to use an upper limit for the
transmittal size. The issue will be divided into multiple transmittals no larger than the specified size. Select No
limit to save all of the transmittal items to a single zip file.

 NOTE   If a transmittal item is larger than the maximum transmittal size it will be packaged in its own
transmittal zip.

10.1.2 Select drawings to send

Select the drawing DWG, PDF or DWF files to be issued.

 TIP   You can select multiple rows and hit spacebar to toggle a selection, or use the context menu.

Click  Load group to load one or more drawing groups.

Filter by job
If there are multiple jobs in the current project, you may use the filter to hide drawings from jobs that you are
not interested in. If you already have some drawings selected, select Uncheck drawings that are not in the
selected jobs to remove the unwanted drawings from the issue.

Show checked items only
Select this check box to hide the drawings that have not been included in this issue.

Use alternative drawing numbers & revs for zip items
Occasionally, a client may require you to issue drawings using their alternative drawing numbers and revision
codes. Select this check box to rename the files to be issued. This does not affect the original files, only the
copies included in the zips.

10.1.3 Select documents to send

Select the documents to be issued.

 TIP   You can select multiple rows and hit spacebar to toggle a selection, or use the context menu.

Click Load group to load one or more document groups.

Show current revisions only
If you want to issue an old revision of a document, clear this check box.

10.1.4 Create reports to send

Reports may be generated and sent as attachments with the issue advice e-mail.

1. Click  Add report and select a report type.

2. Select a report template, or create a new one.

3. Select a report data filter. For example:

o Select Project if you want to report on all items in the project.

o Select Jobs if you want to report on all items in one or more jobs.

o If you selected a document report, select Documents if you want to report on one or more documents.

o If you selected a drawing report, select Drawings if you want to report on one or more drawings.

 NOTE   The drawings to be issued will be pre-selected.
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4. Click OK.

Reports are created in a Reports subfolder in the issue folder. The reports are not listed in the issue or
transmittal advice documents, nor are they included the transmittal zips. As they are sent with the issue advice
e-mail, recipients who are selected as advice only will also receive the reports.

10.1.5 Add other attachments to send

Add any other file to be included in the issue.

10.1.6 Select the e-mail recipients

Select the company and/or contact e-mail addresses to send the issue to. Recipients may be To, Cc (carbon
copy) or Bcc (blind carbon copy).

Advice only
Some recipients need to be advised when new revisions have been issued, but do not need to receive the
drawing or document files. Advice-only recipients are sent the issue advice e-mail, but not the transmittal e-
mails. The issue advice e-mail also includes any reports that have been created for the issue.

 NOTE   Only e-mail addresses from the project's client and related companies are shown.

10.1.7 Select e-mail options

E-mail type
Select Send now with CadTracker to send the issue using the Configuration e-mail account.
Select (Don't send) if you want to create the issue without e-mailing it. The e-mails may be sent at any time
from the issue's property window.
Select Send with Outlook to use Outlook. Issue advice and transmittal e-mails may be previewed and edited in
Outlook before being sent. Outlook issue advice e-mails will use the project's Outlook template.

Include CSV data file
A CSV data file is always generated with each issue. Recipients may use it to import data into their own
document management systems.

Issue advice e-mail message (optional)
Type a message for the issue advice e-mail. This message only appears in the e-mail. If you want the message
to appear on the issue and transmittal advice documents, use the memo box.

10.1.8 Select the postal recipients

Select the company addresses to send the issue to.

 NOTE   Only addresses from the project's client and related companies are shown.

10.1.9 Summary

The summary page shows the selected recipients and how many transmittals will be created.

Set quantity
If you will be sending multiple hard copies of drawings or documents, you may want to set the quantities.
Enter a number, select one or more rows and click Set quantity. The Quantity column is not displayed in the
issue or transmittal advice documents if all of the quantities are 1.
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10.1.10 Creating issue

This page allows you to monitor the progress of the issue as it is created. You may also open or print the issue
and transmittal advice documents, or open the issue folder location.
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11 AutoCAD
All of the commands in this section are only available in AutoCAD, on the Plug-ins tab, in the CadTracker

group. Less common commands may not be visible until you click the CadTracker  slideout.

11.1 Add border and create new drawing

 Add border and create new drawing
Adds a border to the current layout and creates a new drawing record in the CadTracker database.
CTRK_AddBorder

 TIP 
If you have not set the current operator, you should do that before you add a border and create a new
drawing. CadTracker remembers the last new drawing each operator created in each job. When this window is
displayed, the number and several other values are pre-filled based on the last new drawing created by the
current operator.

Number

Enter the drawing's primary identifier, or click  Select an existing drawing number to follow and select a
drawing from the list shown. The next available number in the sequence will be selected. You may also select
values to copy from the selected drawing such as category, drawing type, titles, or folder.

Alternative number

Category

Drawing type
The drawing type also determines the default plot device and paper size for paper space layouts. These values
are copied from the drawing type's first available plot setting: physical, PDF or DWF.

Scale factor
The scale factor is pre-filled with the dimscale of the DWG.

Borders in model space are automatically scaled to match the scale factor selected.

 NOTE 
Each paper space layout tab has a page setup which defines the default plot device and paper size. Therefore,
it is best to scale layout viewports rather than the border itself. For paper space drawings, design your border
DWG file to fit the target paper size, and scale the border at 1:1. If you want to use a border DWG file that is not
the correct size, i.e. it was designed to be scaled in model space, you may select Scale border to force the
border to be scaled. However, setting up a new border would be considered best practice.

Title 1

Title 2

Title 3 (optional)

Title 4 (optional)

Operators

Each drawing may have up to seven operators.
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Folder
If you are adding a border to model space, select the folder where the DWG will be saved.

 IMPORTANT 
You may select any folder you wish, but it is best to choose a folder that is relative to the project or job folders.

Drawing name format

11.2 Create new model

 Create new model
Creates a new model record for the current DWG in the CadTracker database.
CTRK_CreateModel

You will be prompted to confirm the project and job, and then to select a folder and file name for the model.

11.3 Rev up

 Rev up this drawing
Creates a new revision record for the drawing in the current layout, and supersedes the DWG.
CTRK_RevUp

 Rev up multiple drawings
Creates new revision records for multiple drawings, and supersedes their DWGs.
CTRK_RevUpMultiple

As drawings are revised, the old DWG, PDF and DWF files are superseded to the job's superseded folder.

Rev up to
Select the revision type for the new revision.

 NOTE 
When revising the current drawing, only allowable revision types will be shown. For example, you may not
revise a drawing For construction before revising it For approval.
When revising multiple drawings, all revision types are shown, but only the drawings which may be revised to
the selected revision type will be shown. For example, if you select Check approved, only drawings with a
current revision of Check print will be selectable.

Operators

Each drawing may have up to seven operators.

Public issue

When a drawing is revised to a public issue revision, i.e. Preliminary, For approval, For tender, For construction,
As built, or Redundant, the following values are required:

Description
Enter the description for the revision. The default value is the status description for the revision type. Common

revision descriptions may be selected from the list. Click  Use default description to reset the value.

Drawn by
Select the operator who drew this revision, or type an operator code.
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Checked by
Select the operator who checked this revision, or type an operator code.

Approved by
Select the operator who approved this revision, or type an operator code.

Alternative revision code

Plot

Select the plot options.

Save new group (Rev up multiple drawings only)
You may save a new drawing group for the selected drawings. Type a group name or select and update an
existing group name. The new group name must be unique; the list of existing names makes it easier to create
sequentially numbered groups.

Purge items not used in the drawing
Select this check box to run the AutoCAD purge command as the drawing is revised.

Revision notes
Optionally, record notes about the new revision. Revision notes can be included in drawing register reports.

Drawings (Rev up multiple drawings only)
Select the drawings to revise. You may select drawings by loading one or more drawing groups.

11.4 Plot

 Plot to PDF
Plots the drawing in the current layout using the PDF plot setting assigned to the drawing's type.
PlotToPdf

 Plot to DWF
Plots the drawing in the current layout using the DWF plot setting assigned to the drawing's type.
PlotToDwf

 Plot this drawing
Plots the drawing in the current layout to a physical plotter, PDF or DWF.
CTRK_Plot

 Plot multiple drawings
Plots multiple drawings to a physical plotter, PDF or DWF.
CTRK_PlotMultiple

Plot

Select the Physical plottor, PDF or DWF plots you wish to produce. Plots will be produced using the plot
settings assigned to the drawing's type.

Custom
Occasionally, you may want to produce one or more plots using different settings, e.g. using a different
physical plotter, or a different style sheet.
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11.5 Refresh border

 Refresh this border
Refreshes the attributes in this drawing's border with the current values from the CadTracker database.
CTRK_RefreshBorder

 Refresh multiple borders
Refreshes the attributes in multiple drawing borders with the current values from the CadTracker database.
CTRK_RefreshMultiple

Refresh multiple borders

Select one or more drawings. You may select drawings by loading one or more drawing groups.

Purge items not used in the drawing
Select this check box to run the AutoCAD purge command as the drawing is revised.

Plot

Select the plot options.

11.6 Replace border

CadTracker  > Replace border

Replace this border
Replaces the border for the drawing in the current layout with a different border block.
CTRK_ReplaceBorder

Replace multiple borders
Replaces the borders for multiple drawings with a different border block.
CTRK_ReplaceMultiple

New border

Name
The name of the new border file. The name must match an existing border record name.

Path

Click  Browse border to select the new border DWG file.

Replace:
All borders
Matching borders

Select Matching borders if you want to replace only borders with existing block names that match the new
border's block name. For example, let's say you have updated border A1Standard.dwg with a client logo and
some new attribute mappings, and every drawing in the job that used A1Standard needs to be updated with
the new border, so you select all the drawings. With Matching borders selected, every drawing that has a
border block named A1Standard will have its border replaced with the new one; all other borders will remain
unchanged.
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11.7 Re-number drawing

CadTracker  > Re-number drawing

Re-number this drawing
Re-numbers the drawing in the current layout, and renames the DWG if necessary.
CTRK_ReNumber

Re-number multiple drawings
Re-numbers multiple drawings, and renames the DWGs if necessary.
CTRK_ReNumberMultiple

New number
Enter the drawing's new number.

Drawing name format
Optionally, modify the drawing name format.

11.8 Import drawing
Sometimes you may need to import drawings that were not created with CadTracker.

CadTracker  > Import drawing

Import this drawing
Imports the drawing in the current layout to the CadTracker database.
CTRK_ImportDrawing

Import multiple drawings
Imports multiple drawings to the CadTracker database.
CTRK_ImportMultiple

The import process

1. The current layout is searched for a border block reference that has a matching border record in the
CadTracker database.

 IMPORTANT   If the border has not been set up, do that first.
2. The attribute values are copied into a new drawing record.
3. The Import Drawing window is displayed where you may edit values before saving them to the database.

(Import this drawing only)
 TIP   Importing one drawing at a time gives you more control over the values that are imported.

4. Identity data is added to the DWG file.
5. The border is refreshed.
6. If the border is in model space, the DWG is saved as a new DWG in the selected folder.

 NOTE 
If you are importing drawings with borders in model space, it is best to move the DWG files out of the job
folder first. As each DWG file is successfully imported, it is saved into the job folder with the correct
drawing name format and current revision code.

Import multiple drawings

Use this command if you need to import many drawings with borders in model space, and you do not need to
preview the attribute values before the drawing records are saved.
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Import to folder
Select the folder to save the imported DWG files.

Issue date format
For some borders, the public issue history lines do not allow very much room for dates. Consequently, the
date values may use a non-standard format. If the drawings you are importing have an unusual date format,
specifying the format can help CadTracker parse the values.

This field is optional - leave blank for typical date formats.

Valid format strings:
d The one- or two-digit day.
dd The two-digit day. Single-digit day values are preceded by a 0.
ddd The three-character day-of-week abbreviation.
dddd The full day-of-week name.
M The one- or two-digit month number.
MM The two-digit month number. Single digit values are preceded by a 0.
MMM The three-character month abbreviation.
MMMM The full month name.
y The one-digit year (2001 is displayed as "1").
yy The last two digits of the year (2001 is displayed as "01").
yyyy The full year (2001 is displayed as "2001").

Delete existing identity data
By default, drawings which contain CadTracker identity data will not be imported.

Use this option to automatically delete the existing data and import the drawings as new records.

File names
Select the DWG files you want to import.

11.9 Import model
Sometimes you may need to create a model record for a DWG that already has identity data. This is quite
different to importing a drawing with a border, which would not normally have any identity data.

Some example scenarios:
The model record has been deleted from your database
The database has been restored to a point in time before the model record existed
The model record existed in a different CadTracker database

CadTracker  > Import drawing > Import this model
Imports this DWG as a model in the CadTracker database.
CTRK_ImportModel

 NOTE   If you need to edit the project, job, or model Ids stored in the DWG's identity data, do that first.

11.10 Identity data
Each model and drawing created with CadTracker has the following identity data saved inside the DWG file:

Project Id
Job Id
Model Id
Drawing Id
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Each drawing in a paper space layout tab records its own drawing Id.

The following commands may be used to manually manage identity data.

CadTracker  > Identity data

Audit identity data
Compares the project, job, model and drawing Ids saved in DWGs with the values in the CadTracker database.
CTRK_AuditIdentityData

Edit identity data
Allows the project, job, model and drawing Ids to be manually edited for the model or drawing in the current
layout.
CTRK_EditIdentityData

Add identity data to this drawing
Searches for a matching model or drawing record with the same file name as the current DWG, and adds the
project, job, model and drawing Ids to the DWG.
CTRK_AddIdentityData

Add identity data to multiple drawings
Searches for matching model or drawing records with the same file names as the selected DWG files, and adds
the project, job, model and drawing Ids to the DWGs.
CTRK_AddIdentityDataMultiple

Delete identity data
Deletes the project, job, model and drawing Ids from the model or drawing in the current layout.
CTRK_DeleteIdentityData

11.11 Console

CadTracker  > Console

Show console
Shows the CadTracker console tool palette, where information or error reports may appear.
CTRK_Console

Reset console position
Moves the CadTracker console tool palette back onto the primary monitor.
CTRK_ConsoleResetPosition

11.12 Set up borders
Border records define mappings between drawing record properties and DWG attributes.

Recommendations

1. When you start a new project, spend some time organising your border DWG files before you start creating
new drawings.

2. Copy your border DWG files into a subfolder of each project, e.g. Borders.
3. Add any client logos, or static text values to the project's local copy of the border.
4. Whenever possible, use the same attribute names for your borders.
5. If the border uses different attribute names to the standard border, rename the DWG and set it up as a new

border in CadTracker.
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6. If a client has provided a border to be used for a project, check with the client before adding or renaming
any attributes.

CadTracker  > Set up borders
Sets up border attribute mappings and paper sizes.
CTRK_SetUpBorders

Copy another border
If you are setting up a border that has some attributes that match an existing border record, save time by
copying the attribute mappings from the existing border. You may still make changes to the new border
record before saving it.

Create border attributes
This command allows you to create new AutoCAD attributes in the current DWG document, and map them
automatically into the current border record. Select the attributes you wish to create from each tab, and enter
the number of issue lines to create if you have selected any issue line attributes. Click OK and the attributes
will be added to the current layer. Move, recolour, or switch the layer of the attributes if necessary.

Border

Name (read-only)
The border name is the name of the DWG file without the .dwg extension.

Last file path (read-only)
The full path of the DWG file that was last used to edit this border record.

Paper size
Enter a paper size for this border. If the Paper size attribute property is mapped to an attribute, the attribute is
populated with this value. Showing the original paper size is important if you are mapping the Scale factor
property.

Project

The following project properties may be mapped to attributes:
Number
Alternative number
Name
Internal name
Extended data

Job

The following job properties may be mapped to attributes:
Number
Alternative number
Name
Internal name
Number - name

Drawing

The following drawing properties may be mapped to attributes:
Category
Number
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Alternative number
Title 1
Title 2
Title 3
Title 4
Sheet number
Sheet total
Sheet number / total
Drawing type
Scale factor
Notes
Drawn by
Drawn date
Checked by
Checked date
Revision code
Alternative revision code
Revision status
Scale factor
Paper size

Public issue history lines

Public issue revisions, i.e. Preliminary, For approval, For tender, For construction, As built, or Redundant, are
usually mapped to a history table in the border.

The following revision properties may be mapped to attributes:
Revision code
Alternative revision code
Description
Drawn by
Checked by
Approved by
Date

 TIP 
When you add a new public issue history line, CadTracker tries to automatically assign the attributes based on
the number format of the previous row. To take advantage of this feature, number your attributes sequentially,
e.g. RevCode1, RevCode2, etc.

11.13 Plot settings

CadTracker  > Plot settings

Name
Type a descriptive name for the plot setting.

Device
Select the physical or file-based plot device.

Paper size
Select the target paper size. The paper sizes listed are provided by the selected device.

Style sheet
Select the CTB or STB style sheet to use.
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Plot to file
Select this check box if the device selected is a file-based plotter. This is automatically selected for some
devices.

Plot rotation
Select the rotation for the plots.

Plot scale
Select the plot scale. Plot settings for model space drawings typically use Scale to fit, while paper space
drawings are commonly 1:1.

 TIP 
Using a virtual private network (VPN), you can send plots to a physical plotter in another office. This can be
helpful when the DWG files are in one office, and you need to plot drawings for checking or archiving in
another office. When revising or plotting drawings, you may select multiple custom plot settings to plot hard
copies simultaneously in multiple offices.
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12 Create PDF binder and print
When you want to print a drawing or document PDF file, CadTracker checks which application is associated
with PDF files. If the default application is Adobe Reader or Adobe Acrobat, a Print window will be displayed
where you can select options before sending the document to the printer. If you need to print multiple files,
confirming the print options for every document quickly becomes tiresome. To overcome this, CadTracker
can create a temporary PDF file containing all of the documents you wish to print. The Print window is
displayed once, and then all of the documents are sent to the printer as one document with multiple pages.

 NOTE 
This may produce unexpected results if you are trying to print documents with different paper sizes or
orientations. In the Print window, select the appropriate size option and orientation, and preview each page
before clicking Print.
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13 Create report
Reports may be created from various places throughout CadTracker.

To create a report, do one of the following:

Select an item in the Explorer, right-click the item, click  Create report, and then click the desired report
type.

View an item folder's list window, click  Create report, and then click the desired report type.

The reports are context sensitive, i.e. the item currently selected in the Explorer determines what data will be
included in the report.

For example, if you right-click a project item in the Explorer and create a document register, the report will

include every document in the project. For example, if you right-click an  Administration documents folder
and create a document register, only documents categorised as Administration will be included in the report.

The Create Report window allows you to select an existing template, create, edit, delete and customise
templates.

Customise template
Click Customise template to make changes to an existing report template. The edited template may only be
saved as a new template to prevent the original template from being accidentally overwritten. Click Create
report to see how the changes will look.

 TIP 
When you are happy with your report templates, encourage your CadTracker operators to use the Customise
template option to make one-off reports, rather than editing the templates.
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14 Generic data
CadTracker includes a comprehensive system which allows you to define your own data structures.

The following topics explain the components of the generic data system:
Unit types
Data types
Categorical data types
Property types
Generic classes
Generic objects

The Walkthrough ties all of these concepts together.

You can also add extended data to projects.

14.1 Unit types
Each unit type has a name and may have a symbol. Property types may have a unit type.

 NOTE 
The International System of Units (SI) is the world's most widely used system of measurement. Most of the
common SI units and their derivatives are included in CadTracker by default.

14.2 Data types
Each property type is set up as one of the following data types:

NAME DESCRIPTION

Categorical Categorical data type

Date Calendar date

Decimal Positive or negative number with a decimal value

GUID Globally unique identifier

Image URL Path to an image file or web address

Integer Positive or negative whole number

Multi-line text One or more lines of text

Text A single line of text

True/false Displayed as a check box

URL Path to a file or web address

14.3 Categorical data types
Tools > Generic data > Categorical data types

A categorical data type is a set of possible values. Categorical data types help ensure that data is valid and
consistent, as operators may only select from the list of possible values.

Typically, a categorical property requires exactly one value to be selected, but in some cases zero or more
values may be independently selected. When only a single value is allowed, all possible values are displayed in
a list, and one value must be selected. 
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Examples of single-value categorical properties include:
The profile of a piece of air-conditioning duct: Rectangle, Circle, or Flat oval
The blood type of a person: A, B, AB, or O
The state of a postal address in Australia: ACT, NSW, NT, QLD, SA, TAS, or WA

Allow multiple values to be selected
When multiple values may be selected, each possible value is displayed as a check box, and each value may be
independently selected or cleared.

Examples of multiple-value categorical properties include:
Blank-off plates for an air-conditioning grille: North, South, East, West
Car accessories: Headlamp protectors, Roof racks, Towbar

 NOTE  Codes are automatically generated for categorical data types which allow multiple values to be
selected.

Code
The code is the integer that is stored in the database to represent the selected value.

Value
The value is the human-readable text that is displayed to the operator.

14.4 Property types
Generic classes can contain zero or more property types. Property types may be shared between many generic
classes. For example, a Mass (kg) property type could be included as a property for Beam, Car, and Fan classes.

Name
The name of the property. This is the value that is displayed to the operator in the generic object property
window.

 RECOMMENDED  Include the unit type in the property name to distinguish similar properties, e.g. Mass (g),
Mass (kg), Mass (t).

Data type
The data type that this property may store.

Categorical data type
If Categorical is selected as the data type, a categorical data type must be selected.

Unit type
The unit type of the property.

14.5 Generic classes
A generic class is a template which describes a type of object.

Name
The name of the generic class. The singular form of the noun is recommended, e.g. Fan, rather than Fans or
Fan data.

Properties
A generic class can contain zero or more property types. Each property may enforce minimum and maximum
values based on the property's data type. When a generic object property has an invalid value, an error icon
and message is displayed.
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Generic object properties are displayed in the order that they appear in the generic class. Use the  Move up

and Move down buttons to sort the properties.

Integer value
Integer properties may enforce minimum and maximum values.

For example, an Air quantity (L/s) property for a Fan class may specify a range of valid values of 5 - 100 L/s.

Decimal value
Decimal properties may enforce minimum and maximum values.

For example, a Mass (kg) property for a Fan class may specify a range of valid values of 0.1 - 500 kg.

String length
String properties have a data type that is stored as text, i.e. Image URL, Multi-line text, Text, or URL. String
properties may enforce a minimum and maximum length.

For example, a Reference number property for a Fan class may specify a minimum length of 1, and a
maximum length of 20. A minimum length of 1 forces the operator to enter a value before the record may be
saved.

Deprecated
By default, deprecated properties are not shown in property dialogs or reports.

Deprecating properties may be more desirable than deleting them when there are existing values which you
wish to keep.

14.6 Generic objects
A generic object is an instance of a generic class.

Show deprecated properties
Deprecated properties are hidden by default, but may be displayed when needed.

Name
The name of this generic object. This is the value that is displayed in the Explorer tree and other lists.

 TIP 
It is common for the value of the first property of a generic object to be identical to the name property, e.g. 

Reference number. Click  to copy the name to the first property.

Copy properties from another object
This allows you to copy values from an object defined in another project with similar or identical property
values, e.g. an off-the-shelf item from a particular manufacturer.

Get organised

Generic objects can be dragged and dropped within the Explorer tree, inside their own project. This allows you
to organise your objects into folders, and/or create complex hierarchies.
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14.7 Walkthrough
In this walkthrough, we will create a new generic class to record data about fan units for ducted air-
conditioning systems, and create two new fan records in a project.

For each fan unit, we want to record the following data:

PROPERTY DATA TYPE

Reference number Text

Fabricator name Text

Catalogue number Text

Air quantity (L/s) Decimal

Power (kW) Decimal

Mass (kg) Decimal

Power phase Categorical

Technical data sheet URL

Comment Multi-line text

 NOTE 
Some of the unit types, categorical data types and property types may already be included in CadTracker by
default. For the purposes of this walkthrough, we will assume they are not present and need to be added.

Unit types

First, we will add litre per second, kilowatt and kilogram to the list of unit types.

1. Go to Tools > Generic data > Unit types

2. Click  Add new
3. In the Name box, type litre per second
4. In the Symbol box, type L/s

5. Repeat steps 2 to 4 for kilowatt (kW) and kilogram (kg)

6. Click OK to save the changes

Categorical data types

Next, we will add a new categorical data type for Power phase.

1. Go to Tools > Generic data > Categorical data types

2. Click  New
3. Type Power phase in the Name box

4. Click  Add new
5. In the Code box, type 1
6. In the Value box, type Single

7. Repeat steps 4 to 6 for Code 3, Value Three
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8. Click OK to save the changes

Property types

Now, we will add new property types.

1. Go to Tools > Generic data > Property types

2. Click  Add new
3. In the Name box, type Reference number
4. For the Data type, select Text
5. For the Unit type, select (None)

6. Repeat steps 3 to 5 for the remaining properties listed in the table above, selecting the appropriate data
types and unit types

7. Click OK to save the changes

Generic class

Now, we are ready to define a Fan class.

1. Go to Tools > Generic data > Generic classes

2. Click  New
3. Type Fan in the Name box

4. Click  Add new
5. Select the Reference number property and click OK, or double-click the row
6. In the Minimum string length box, type 1
7. In the Maximum string length box, type 20

8. Repeat steps 4 to 7 for the remaining properties listed in the table above. For the decimal properties, add a
minimum value of 1 and maximum value of 100.

9. Click OK to save the changes

Folder

Let's create a Fans generic object folder.

1. In an existing project, right-click the  Generic data folder and click   New generic object
2. Select (Folder) and click OK, or double-click the row
3. In the Name box, type Fans

4. Click OK to save the changes

Generic object

Now we can create a new Fan object inside our Fans folder.

1. Right-click the  Fans folder and click   New generic object
2. Select Fan and click OK, or double-click the row
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3. In the Name box, type SAF-1

4. Click  Copy to Reference number
5. Note that the properties that have minimum and maximum value rules are displayed with error icons and

messages
6. Enter values for the remaining properties

7. Repeat steps 1 to 6 for fan SAF-2

8. Click OK to save the changes

14.8 Project extended data
There is a special generic class, (Project extended data), which allows extended data to be added to projects.
For example, you may wish to add properties to record the project's address, a URL to specifications, a website,
etc. Extended data may be mapped to attributes in drawing borders.

Edit project extended data class

1. Create new property types that you want to include in the project extended data

2. Go to Tools > Generic data > Generic classes

3. Select (Project extended data) and click  Edit

4. Click  Add new
5. Select the desired property and click OK, or double-click the row

6. Repeat steps 4 and 5 for any other properties you wish to include

7. Click OK to save the changes

Add extended data to a project

1. Edit the project
2. Click the Extended data tab
3. Click Add extended data
4. Add values for the properties
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