
 

 
航空氣象現代化系統 

The Advanced Operational Aviation Weather System 
(AOAWS) 

 
 

系統監控手冊 
SYSVIEW (SMD) USER MANUAL 

 

 

交通部民用航空局 

 
Civil Aeronautics Administration (CAA) 

 

 

修訂日期:2008年9月  

Updated: September 2008 

   美國國家大氣研究中心 (National Center for Atmospheric Research) 

  財團法人資訊工業策進會 (Institute for Information Industry, III) 

 

 

 



 

 

 

 

文件修改紀錄（Updated Notes） 

 

修改日期 Date  修改紀錄 Modification Records  

2002 年 06 月 01 日 

06/01/2002 

新修訂 

New version 

2008 年 09 月 22 日 

09/22/2008 

更新所有的圖示、設定以及加入其他修訂。 

Changed all the screen shots, the config file, and other 
modifications. 

 



i 

 

1 引言 (Introduction) ..................................................................................................... 1 

1.1 SysView   是什麼 (What is SysView)?.............................................................. 1 

1.2 Process Mapper   是什麼 (What is the Process Mapper)?.................................. 1 

1.3 DataMapper 是什麼 (What is the DataMapper)?............................................... 2 

1.4 SysView 如何使用 procmap 及 DataMapper 所產生的資訊 (How does 
SysView use the procmap and DataMapper information)? ................................. 3 

1.5 SysView 參數檔案 (The SysView parameter file) ............................................ 3 

1.6 啟動 SysView  (Starting SysView) .................................................................. 20 

2 主選單 (The Main Menus) ....................................................................................... 22 

2.1 檔案選單 (The File Menu) ............................................................................... 22 

2.2 參數選單(The Params Menu)........................................................................... 22 

2.3 流程圖選單(The Diagram Menu) .................................................................... 23 

2.4 輸出選單(The Export Menu) ........................................................................... 23 

2.5 編輯選單 (The Edit Menu)............................................................................... 24 

2.6 詢問要求選單 (The Query Menu) ................................................................... 24 

2.7 執行選單 (The Run Menu)............................................................................... 25 

3 檔案之使用 (Using the File menu) .......................................................................... 26 

3.1 結束 (Quitting).................................................................................................. 26 

4 使用編輯功能來建立流程圖 (Creating a diagram using the Edit menu functions) 27 

4.1 概觀 (Overview) ............................................................................................... 27 



ii 

4.2 子流程圖說明 (A note on sub-diagrams)......................................................... 27 

4.3 改變主要流程圖標題 (Changing the main diagram title) ............................... 28 

4.4 設定子流程圖元件機器名稱 (Setting the host name for elements on a sub-
diagram.) ....................................................................................................................... 28 

4.5 增加一個程序 (Adding a process) ................................................................... 29 

4.6 增加資料集 (Adding a data set) ....................................................................... 31 

4.7 增加文字方塊 (Adding a text box) .................................................................. 33 

4.8 增加註解字串 (Adding annotation strings) ..................................................... 33 

4.9 增加資料流向線 (Adding a flow line)............................................................. 34 

4.10 增加複段線 (Adding a polyline) ...................................................................... 35 

4.11 增加子流程圖 (Adding a sub-diagram) ........................................................... 35 

5 編輯流程圖 (Editing a diagram) .............................................................................. 36 

5.1 概觀 (Overview) ............................................................................................... 36 

5.2 移動流程圖上物件 (Moving diagram objects around).................................... 36 

5.3 編輯物件 (Editing objects)............................................................................... 36 

5.4 停止物件運作 (Disabling objects) ................................................................... 36 

5.5 啟動物件 (Enabling objects) ............................................................................ 37 

5.6 顯示資訊 (Showing information)..................................................................... 37 

5.7 編輯程序 (Editing a process) ........................................................................... 38 

5.8 編輯資料集 (Editing a data set) ....................................................................... 39 

 



iii 

5.9 編輯文字方塊 (Editing a text box) .................................................................. 39 

5.10 編輯資料流向線條 (Editing a flow line) ......................................................... 40 

5.11 編輯複段線 (Editing a polyline) ...................................................................... 41 

5.12 編輯子流程圖 (Editing a sub-diagram) ........................................................... 41 

5.13 刪除一項物件 (Deleting an object).................................................................. 42 

5.14 複製物件 (Copying an object).......................................................................... 42 

 

 



SysView User Manual 1 Introduction 

1 引言 (Introduction) 

1.1 SysView   是什麼 (What is SysView)? 

SysView 是 NCAR 發展出來的一套以圖形畫面來協助使用者監看 AOAWS 系統狀態的監

控工具，也可用來監看其他使用 procmap及 DataMapper的軟體系統。 

本文件將說明如何從頭開始製作一套 SysView 流程圖以及如何使用該流程圖。 

SysView was developed and used as the AOAWS system monitor.  It is a graphical tool for 
monitoring any software system which makes use of the procmap and DataMapper facilities.  

This document will describe how to set up a SysView diagram from scratch and how to make 
this a working diagram for your project. 

1.2 Process Mapper   是什麼 (What is the Process Mapper)? 

Process Mapper 為一 AOAWS 系統管理程式，簡稱為 procmap。它的作用在監看系統正在

執行的程序。 

使用者可以利用 print_procmap這個指令來查看系統內有那些程序正在執行中。下列為系

統上執行 print_procmap指令時，所顯示出的資料範例。每個程序都有一個名稱及一個執

行代號。使用者可以透過執行代號來辨別在同一主機上同名稱的程序。也可從表格中得知

機器名稱、使用者帳號、以及程序 ID。 

The Process Mapper is a program called procmap. procmap keeps track of processes (programs) 
running on the system. 

You can see which processes are running by using the print_procmap command. Below you 
will see the output from running print_procmap on our test machine. Processes have a Name 
and an Instance. The instance distinguishes between two or more programs of the same name 
running on the same machine. You will also see the Host (machine name), User (user name) and 
Pid (process ID). 

titan:~/sysview> print_procmap 
PROCS REGISTERED - localhost - Mon May 13 21:35:32 2002 
Uptime: 32.9 d 
Name         Instance     Host       User       Pid    
====         ========     ====       ====       ===    
DataMapper   primary      titan      aoaws      16560  
DsFCopyServe manager      titan      aoaws      9140   
DsFileDist   primary      titan      aoaws      8649   
DsServerMgr  primary      titan      aoaws      8584   
DsSpdbServer manager      titan      aoaws      10436  
Janitor      primary      titan      aoaws      8601   
LdataWatcher tacc         titan      aoaws      8766   
MM52Spdb     aoaws        titan      aoaws      8734   
MM52Tacc     aoaws        titan      aoaws      8750   
MM5Ingest    domain1      titan      aoaws      8668   
MM5Ingest    domain2      titan      aoaws      8684   
MM5Ingest    domain3      titan      aoaws      8702   
Scout        primary      titan      aoaws      8617   
WinsRadar2Md mosaic       titan      aoaws      8785 
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若程序的名稱過長，在顯示時會自動被截短。例如：程序名稱 WinsRadar2Mdv 會被截成

WinsRadar2Md。當執行 print_procmap –plain 指令時，顯示出來的資料較不整齊，但是

會顯示完整的程序名稱及其他相關資訊。 

Some of the processes have long names, which are truncated in the printout. For example, 
WinsRadar2Mdv is truncated to WinsRadar2Md. You can get full information on the file names 
by using the print_procmap -plain command line argument. The output is less tidy, but you 
will find all of the necessary information. 

titan:~/sysview> print_procmap -plain 
localhost 
2843051 
DataMapper primary titan aoaws 16560 120 -48 -1308947 21458 0 
DsFCopyServer manager titan aoaws 9140 120 -6 -2842951 46606 0 
DsFileDist primary titan aoaws 8649 120 -54 -2843048 46607 0 
DsServerMgr primary titan aoaws 8584 120 -52 -2843050 46607 0 
DsSpdbServer manager titan aoaws 10436 120 -41 -2842371 46596 0 
Janitor primary titan aoaws 8601 120 -11 -2843050 46607 0 
LdataWatcher tacc titan aoaws 8766 120 -22 -2843043 65048 0 
MM52Spdb aoaws titan aoaws 8734 120 -46 -2843045 46596 0 
MM52Tacc aoaws titan aoaws 8750 120 -31 -2843044 46598 0 
MM5Ingest domain1 titan aoaws 8668 120 -6 -2843047 46607 0 
MM5Ingest domain2 titan aoaws 8684 120 -39 -2843047 46605 0 
MM5Ingest domain3 titan aoaws 8702 120 -33 -2843046 46545 0 
MM5Ingest domain4 titan aoaws 8718 120 -18 -2843045 46485 0 
Scout primary titan aoaws 8617 120 -42 -2843049 46599 0 
WinsRadar2Mdv mosaic titan aoaws 8785 120 -22 -2843043 44164 0 

1.3 DataMapper 是什麼 (What is the DataMapper)? 

DataMapper 是用來監看系統的資料接收狀態。執行 PrintDataMap命令可顯示目前資料集

狀態。資料集是以其類型及目錄之名來分別顯示，資料目錄名是根據 RAP_DATA_DIR 或 
DATA_DIR這兩個環境變數而界定的。 

The DataMapper keeps track of data sets stored on the system. You can list out the data sets 
using the PrintDataMap command. Data sets are described by the data type and the directory in 
which the data resides. Data directories are made relative to the RAP_DATA_DIR or DATA_DIR 
environment variable. 

titan:~/sysview> PrintDataMap 
   DataType                       Dir  HostName 
   ========                       ===  ======== 
             /home/aoaws/projDir/data     titan 
                    www_content/stats     titan 
        mdv           mdv/mm5/domain1     titan 
        mdv           mdv/mm5/domain2     titan 
        mdv           mdv/mm5/domain3     titan 
        mdv           mdv/mm5/domain4     titan 
        mdv          mdv/radar/mosaic     titan 
        raw             raw/acars_wmo     titan 
        raw           raw/ltg_renamed     titan 
        raw           raw/mm5/domain1     titan 
        raw           raw/mm5/domain2     titan 
        raw           raw/mm5/domain3     titan 
        raw           raw/mm5/domain4     titan 
        raw            raw/mm5/status     titan 
        raw              raw/mm5/tacc     titan 
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        raw          raw/radar/mosaic     titan 
       spdb                  spdb/mm5     titan 
www_content         www_content/stats     titan 

1.4 SysView 如何使用 procmap 及 DataMapper 所產生的資訊 (How does SysView 
use the procmap and DataMapper information)? 

SysView 以一種資料流程圖的格式來顯示其資訊。這是一種用圖形來顯示資料如何在系

統中流動及程序如何處理資料的表現方式。 

SysView 的程式會查詢 procmap 及 DataMapper來取得最新的程序及資料資訊。然後再

以不同顏色的圖示來表示各程序及資料的狀態。一般而言，綠色表示 OK，黃色表示有點

小問題，紅色表示問題嚴重。這些皆為預設的顏色，使用者也可以依下一節的例子及說明

來改 SysView.params 檔的內容，以設定自定的顏色。 

SysView presents its information in the format of a Data Flow Diagram. This is a graphical 
representation of how the data moves around the system, and how the processes are involved in 
handling the data. 

SysView routines contact procmap and the DataMapper to get the latest information on the 
processes and data.  SysView then sets the colors of the process and data set icons to represent 
the state of the process or data set. Generally, green means OK, yellow means a minor problem 
and red means a serious problem. These are the default colors. You can set your own colors if 
you wish, in the SysView.params file - see below. 

1.5 SysView 參數檔案 (The SysView parameter file) 

SysView 開始執行時需要讀取 SysView 的參數檔 SysView.params。SysView 使用 XML 來存

參數檔。使用者可以使用編輯器，或是利用 SysView 中的‘Params’選單來修正參數

檔。 

以下為 SysView 參數檔的範例，其中已包含一些簡單的說明。 

You will need a SysView parameter file. Let us suppose that it is called SysView.params.  
SysView uses XML to store its parameters.  You can edit the parameter file by hand with a text 
editor, or via the ‘Params’ menu in SysView. 

The following is an example of a SysView parameter file. The file is commented with brief 
descriptions of the parameters. 
<?xml version="1.0" encoding="ISO-8859-1" standalone="yes"?> 
<!DOCTYPE parameters [ 
 <!ELEMENT parameters (param+) > 
 <!ELEMENT param (label?, description?, info?, value?, param*) > 
 <!ELEMENT label (#PCDATA)> 
 <!ELEMENT description (#PCDATA)> 
 <!ELEMENT info (#PCDATA)> 
 <!ELEMENT value (#PCDATA)> 
 <!ATTLIST param name NMTOKEN #REQUIRED> 
 <!ATTLIST param type NMTOKEN #REQUIRED> 
 <!ATTLIST param type ( String | Boolean | Integer | Float | Double | Option | 
Collection ) #REQUIRED> 
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 <!ATTLIST param view_x NMTOKEN #IMPLIED> 
 <!ATTLIST param view_y NMTOKEN #IMPLIED> 
 <!ATTLIST param view_width NMTOKEN #IMPLIED> 
 <!ATTLIST param view_height NMTOKEN #IMPLIED> 
]> 
 
<parameters> 
 
  <!-- ====== start of collection Root ====== --> 
 
  <param name="Root" type="Collection" view_x="-1" view_y="-1" 
view_width="467" view_height="449"> 
    <label>Param manager</label> 
    <description>Root-depth parameter manager</description> 
 
    <param name="debug" type="Boolean"> 
      <label>Debugging flag</label> 
      <description></description> 
      <value>false</value> 
    </param> 
 
    <param name="queryInterval" type="Integer"> 
      <label>Query interval</label> 
      <description>Query interval (secs)</description> 
      <info> 
        <![CDATA[ 
 

SysView 會定時詢問系統中的程序，資料和其他組件。每詢問之間的時間間隔是以秒計

算。 
 
SysView will query the process, data and other components of the system at regular intervals. 
This is the interval between queries, in seconds. 
 
        ]]> 
      </info> 
      <value>120</value> 
    </param> 
 
    <!-- ====== start of collection process ====== --> 
 
    <param name="process" type="Collection"> 
      <label>Process params</label> 
      <description>Edit the process parameters</description> 
      <info> 
        <![CDATA[ 
 
這些參數控制如何將程序資訊解譯為圖示呈現。 

 
These parameters control how the information about the processes is interpreted on the diagram. 
 
        ]]> 
      </info> 
 
      <param name="outlineColor" type="Color"> 
        <label>Outline color</label> 
        <description>Color of the process icon outlines</description> 
        <info> 
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          <![CDATA[ 
          Outline color for the process icons. 
          ]]> 
        </info> 
        <value>0x000000</value> 
      </param> 
 
      <param name="disabledColor" type="Color"> 
        <label>Disabled color</label> 
        <description>Color for disabled processes</description> 
        <info> 
          <![CDATA[ 
 
在圖示中有些程序是不活動的，也就是說沒狀況可報告。然而，在圖示上展示這些程序還

是有用處的。在這種狀況下，程序的圖示會以灰色展示，用以表示不活動的顏色。 

 

In the diagram, some processes are not 'active', in the sense that there is no information available 
on their status. However, it may still be useful to show them in the diagram. In this case, the 
process icon is shown 'grayed' out, with this disabled color. 
 
          ]]> 
        </info> 
        <value>0x888888</value> 
      </param> 
 
      <param name="okColor" type="Color"> 
        <label>Ok color</label> 
        <description>Color for processes which are OK</description> 
        <info> 
          <![CDATA[ 
          
此顏色是用來展示在規定的時間內來註冊的程序。 

 
 This is the color for processes which have registered within the required period. 
          ]]> 
        </info> 
        <value>0x00aa00</value> 
      </param> 
  <param name="downColor" type="Color"> 
        <label>Down color</label> 
        <description>Color for processes which are DOWN</description> 
        <info> 
          <![CDATA[ 
          

此顏色是用來展示在規定的時間內沒來註冊的程序，表示它們停下來了。 

 

This is the color for processes which have not registered. They are considered down. 
 
          ]]> 
        </info> 
        <value>0xcc0000</value> 
      </param> 
 
      <param name="lateRegColor" type="Color"> 
        <label>Late reg color</label> 
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        <description>Color for processes which are late in their 
registration</description> 
        <info> 
          <![CDATA[ 
 

此顏色是用來展示在規定的時間內沒來註冊的程序，但是它們在規定的兩倍的時間內有來

註冊。表示它們也許沒停但是有困難完成指定的工作項目。 

 

This is the color for processes which have not registered within the required period, but have 
registered within twice the required interval. They might be up but are having trouble completing 
their tasks before registering. 
 
          ]]> 
        </info> 
        <value>0xffaa00</value> 
      </param> 
 
      <param name="statusInvalidColor" type="Color"> 
        <label>Status invalid color</label> 
        <description>Color for processes for which no valid status is 
known.</description> 
        <info> 
          <![CDATA[ 
 

此顏色是用來展示從沒來註冊過的程序，因此沒有任何資訊可查。 

 
This is the color for processes which have never registered and for which no information is 
available. 
          ]]> 
        </info> 
        <value>0xffafaf</value> 
      </param> 
 
      <param name="defaultWidth" type="Integer"> 
        <label>Default width</label> 
        <description>Default width of a text box (pixels)</description> 
        <info> 
          <![CDATA[ 
 
建立此文字盒時會有預設的寬度，使用者可在編輯對話框內填入不同值來改變其大小。 

 
When a text box is created, it will have this width by default. You can then resize the box by 
entering a different value in the edit dialog. 
 
          ]]> 
        </info> 
        <value>100</value> 
      </param> 
 
      <param name="defaultHeight" type="Integer"> 
        <label>Default height</label> 
        <description>Default height of a text box (pixels)</description> 
        <info> 
          <![CDATA[ 
建立此文字盒時會有預設的高度，使用者可在編輯對話框內填入不同值來改變其大小。 
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When a text box is created, it will have this height by default. You can then resize the box by 
entering a different value in the edit dialog. 
 
          ]]> 
        </info> 
        <value>50</value> 
      </param> 
 
      <param name="cornerRadius" type="Integer"> 
        <label>Corner radius</label> 
        <description>Radius of the corner arc (pixels)</description> 
        <info> 
          <![CDATA[ 
 
此文字方塊的四角可選用半徑角度之像素值來設定為圓弧形。 

 
The corners of the text box may optionally be rounded by a corner arc of this radius. Value is in 
pixels. 
 
          ]]> 
        </info> 
        <value>40</value> 
      </param> 
 
      <param name="fontName" type="String"> 
        <label>Font name</label> 
        <description>Font name for text</description> 
        <info> 
          <![CDATA[ 
          Set the font name for the text in the text boxes. 
          ]]> 
        </info> 
        <value>Dialog-plain-12</value> 
      </param> 
 
      <param name="procmapHost" type="String"> 
        <label>Procmap Host</label> 
        <description>Host where the procmap server is running</description> 
        <info> 
          <![CDATA[ 
          Host where the procmap server is running 
          ]]> 
        </info> 
        <value>localhost</value> 
      </param> 
 
      <param name="procmapPort" type="Integer"> 
        <label>Procmap Port</label> 
        <description>The port to connect to the procmapper</description> 
        <info> 
          <![CDATA[ 
          The port that sysview will use to connect to the procmapper 
          ]]> 
        </info> 
        <value>5433</value> 
      </param> 
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    </param> 
 
    <!-- ======= end of collection process ======= --> 
 
    <!-- ====== start of collection dataset ====== --> 
 
    <param name="dataset" type="Collection" view_x="-1" view_y="-1" 
view_width="497" view_height="519"> 
      <label>Dataset params</label> 
      <description>Edit the dataset parameters</description> 
      <info> 
        <![CDATA[ 
       
這些參數控制如何將資料集資訊解譯為圖示呈現。 

 

These parameters control how the information about the datasets is interpreted on the diagram. 
 
        ]]> 
      </info> 
 
      <param name="outlineColor" type="Color"> 
        <label>Outline color</label> 
        <description>Color of the dataset icon outlines</description> 
        <info> 
          <![CDATA[ 
          Outline color for the dataset icons. 
          ]]> 
        </info> 
        <value>0x000000</value> 
      </param> 
 
      <param name="disabledColor" type="Color"> 
        <label>Disabled color</label> 
        <description>Color for disabled datasets</description> 
        <info> 
          <![CDATA[ 
 
 

在圖示中有些資料集是不活動的，也就是說沒狀態可報告。然而，在圖示上展示這些資料

集還是有用處的。在這種狀況下，資料集的圖示會以灰色展示，用以表示不活動的顏色。 

 
In the diagram, some datasets are not 'active', in the sense that there is no information available 
on their status. However, it may still be useful to show them in the diagram. In this case, the 
dataset icon is shown 'grayed' out, with this disabled color. 
 
          ]]> 
        </info> 
        <value>0x888888</value> 
      </param> 
 
      <param name="okColor" type="Color"> 
        <label>Ok color</label> 
        <description>Color for datasets which are OK</description> 
        <info> 
          <![CDATA[ 
 
此顏色是用來展示在規定的時間內來註冊的資料集。 
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This is the color for datasets which have registered within the required 
period. 
          ]]> 
        </info> 
        <value>0x00aa00</value> 
      </param> 
 
      <param name="downColor" type="Color"> 
        <label>Down color</label> 
        <description>Color for datasets which are DOWN</description> 
        <info> 
          <![CDATA[ 
 

此顏色是用來展示在規定的時間內沒來註冊的資料集，表示它們停下來了。 
 
This is the color for datasets which have not registered. They are considered 
down. 
          ]]> 
        </info> 
        <value>0xaa0000</value> 
      </param> 
 
      <param name="noDataColor" type="Color"> 
        <label>No data color</label> 
        <description>Color for datasets for which no data is 
available</description> 
        <info> 
          <![CDATA[ 
 
此顏色是用來展示不存在的資料集。 
 
This is the color for datasets for which there is no data available. 
          ]]> 
        </info> 
        <value>0x888888</value> 
      </param> 
 
      <param name="lateColor" type="Color"> 
        <label>Data late color</label> 
        <description>Color for datasets for which data is late</description> 
        <info> 
          <![CDATA[ 
 
此顏色是用來展示在規定的時間內沒來註冊的資料集。 
 
This is the color for datasets for which data has not come in within the late 
period. 
          ]]> 
        </info> 
        <value>0xffcc00</value> 
      </param> 
 
      <param name="veryLateColor" type="Color"> 
        <label>Data very late color</label> 
        <description>Color for datasets for which data is very 
late</description> 
        <info> 
          <![CDATA[ 
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此顏色是用來展示在很長的時間內沒來的資料集。 
 
This is the color for datasets for which data has not come in within the very 
late period. 
          ]]> 
        </info> 
        <value>0xdd0000</value> 
      </param> 
 
      <param name="statusInvalidColor" type="Color"> 
        <label>Status invalid color</label> 
        <description>Color for datasets for which no valid status is 
known.</description> 
        <info> 
          <![CDATA[ 
 

此顏色是用來展示從沒來註冊過的資料集，因此沒有任何資訊可查。 
 
This is the color for datasets which have never registered and for which no 
information is available. 
          ]]> 
        </info> 
        <value>0x00ffff</value> 
      </param> 
 
      <param name="defaultLateReference" type="Option"> 
        <label>Default reference time</label> 
        <description>Time stamp from which to measure late and very late 
offsets.</description> 
        <info> 
          <![CDATA[ 
          Determines which time is used to evaluate timeliness. 
          ]]> 
        </info> 
        <value>26 Last Registration Time</value> 
      </param> 
 
      <param name="defaultLateSecs" type="Integer"> 
        <label>Default late period</label> 
        <description>Default late period - in secs</description> 
        <info> 
          <![CDATA[ 
 

如果資料在延遲秒數期間內沒來，表示遲到。這是每項新資料的延遲秒數期間的預設值。

此值可依資料集之基值更改。 
 
If data has not come in within the late secs period, it will be considered 
late. This is the default value for the late secs period which is assigned to 
a new data set. The value may then be edited on a dataset by dataset basis. 
          ]]> 
        </info> 
        <value>1800</value> 
      </param> 
 
      <param name="defaultVeryLateSecs" type="Integer"> 
        <label>Default very late period</label> 
        <description>Default very late period - in secs</description> 
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        <info> 
          <![CDATA[ 
 

如果資料在嚴重延遲秒數期間內沒來，表示很晚到。這是每項新資料的嚴重延遲秒數期間

的預設值。此值可依資料集之基值更改。 
 
If data has not come in within the very late secs period, it will be 
considered very late. This is the default value for the very late secs period 
which is assigned to a new data set. The value may then be edited on a dataset 
by dataset basis. 
          ]]> 
        </info> 
        <value>3600</value> 
      </param> 
 
      <param name="defaultWidth" type="Integer"> 
        <label>Default width</label> 
        <description>Default width of a text box (pixels)</description> 
        <info> 
          <![CDATA[ 
 
建立此文字方塊時會有預設的寬度，使用者可在編輯對話框內填入不同值來改變其大小。 
 
When a text box is created, it will have this width by default. You can then 
resize the box by entering a different value in the edit dialog. 
          ]]> 
        </info> 
        <value>100</value> 
      </param> 
 
      <param name="defaultHeight" type="Integer"> 
        <label>Default height</label> 
        <description>Default height of a text box (pixels)</description> 
        <info> 
          <![CDATA[ 
 
建立此文字方塊時會有預設的高度，使用者可在編輯對話框內填入不同值來改變其大小。 
 
When a text box is created, it will have this height by default. You can then 
resize the box by entering a different value in the edit dialog. 
          ]]> 
        </info> 
        <value>50</value> 
      </param> 
 
      <param name="cornerRadius" type="Integer"> 
        <label>Corner radius</label> 
        <description>Radius of the corner arc (pixels)</description> 
        <info> 
          <![CDATA[ 
 
此文字方塊的四角可選用半徑角度之像素值來設定為圓弧形。 
 
The corners of the text box may optionally be rounded by a corner arc of this 
radius. Value is in pixels. 
          ]]> 
        </info> 
        <value>1</value> 
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      </param> 
 
 
      <param name="fontName" type="String"> 
        <label>Font name</label> 
        <description>Font name for text</description> 
        <info> 
          <![CDATA[ 
          Set the font name for the text in the text boxes. 
          ]]> 
        </info> 
        <value>Dialog-plain-12</value> 
      </param> 
 
      <param name="datamapHost" type="String"> 
        <label>Datamap Host</label> 
        <description>Host where the datamap server is running</description> 
        <info> 
          <![CDATA[ 
          Host where the datamap server is running 
          ]]> 
        </info> 
        <value>localhost</value> 
      </param> 
 
      <param name="datamapPort" type="Integer"> 
        <label>Datamap Port</label> 
        <description>The port to connect to the datamapper</description> 
        <info> 
          <![CDATA[ 
          The port that sysview will use to connect to the datamapper 
          ]]> 
        </info> 
        <value>5434</value> 
      </param> 
 
    </param> 
 
    <!-- ======= end of collection dataset ======= --> 
 
    <!-- ====== start of collection diagram ====== --> 
 
    <param name="diagram" type="Collection" view_x="-1" view_y="-1" 
view_width="478" view_height="281"> 
      <label>Diagram params</label> 
      <description>Edit the diagram parameters</description> 
     <param name="gridRes" type="Integer"> 
        <label>Grid resolution</label> 
        <description>Grid resolution (pixels)</description> 
        <info> 
          <![CDATA[ 
          A grid is placed on the canvas to aid in drawing. This is the color 
of the grid lines. 
          ]]> 
        </info> 
        <value>50</value> 
      </param> 
 
      <param name="gridColor" type="Color"> 
        <label>Grid color</label> 
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        <description>Color of the grid lines</description> 
        <value>0x0000ff</value> 
      </param> 
 
      <param name="labelFontName" type="String"> 
        <label>Font name</label> 
        <description>Font name for labels</description> 
        <info> 
          <![CDATA[ 
          Set the font name for the labels in the diagram. 
          ]]> 
        </info> 
        <value>Dialog-plain-12</value> 
      </param> 
 
      <param name="labelColor" type="Color"> 
        <label>Label color</label> 
        <description>Color of the labels</description> 
        <info> 
          <![CDATA[ 
          Label color for the text in the diagram. 
          ]]> 
        </info> 
        <value>0x000000</value> 
      </param> 
 
      <param name="displayLastQueryTime" type="Boolean"> 
        <label>Display last query time?</label> 
        <description>Should the last query time be shown on 
sysview?</description> 
        <info> 
          <![CDATA[ 
          If this is true, the last query time will be displayed 
          ]]> 
        </info> 
        <value>true</value> 
      </param> 
     <param name="lastQueryTimeFont" type="String"> 
        <label>Font for last query time</label> 
        <description>Which Font to use for the last query time.</description> 
        <info> 
          <![CDATA[ 
          This is the font which will be used when the last query time is 
displayed 
          ]]> 
        </info> 
        <value>Helvetica-bold-12</value> 
      </param> 
 
      <param name="lastQueryTimeX" type="Integer"> 
        <label>X for last query time</label> 
        <description>X location for last query time label</description> 
        <info> 
          <![CDATA[ 
          X location, in pixels from left margin, for last query time label. 
          ]]> 
        </info> 
        <value>10</value> 
      </param> 
 

 



SysView User Manual 14 Introduction 

      <param name="lastQueryTimeY" type="Integer"> 
        <label>Y for last query time</label> 
        <description>Y location for last query time label</description> 
        <info> 
          <![CDATA[ 
          Y location, in pixels from left margin, for last query time label. 
          ]]> 
        </info> 
        <value>10</value> 
      </param> 
 
      <param name="windowX" type="Integer"> 
        <label>X location of window</label> 
        <description>The window X offset from the top-left of 
screen</description> 
        <value>0</value> 
      </param> 
 
      <param name="windowY" type="Integer"> 
        <label>Y location of window</label> 
        <description>The window Y offset from the top-left of 
screen</description> 
        <value>0</value> 
      </param> 
 
      <param name="windowWidth" type="Integer"> 
        <label>Window width</label> 
        <description>The window width in pixels</description> 
        <value>1181</value> 
      </param> 
 
      <param name="windowHeight" type="Integer"> 
        <label>Window height</label> 
        <description>The window height in pixels</description> 
        <value>974</value> 
      </param> 
 
    </param> 
 
    <!-- ======= end of collection diagram ======= --> 
 
    <!-- ====== start of collection flowline ====== --> 
 
    <param name="flowline" type="Collection" view_x="-1" view_y="-1" 
view_width="466" view_height="252"> 
      <label>Flowline params</label> 
      <description>Edit the flowline parameters</description> 
 
      <param name="lineColor" type="Color"> 
        <label>Line color</label> 
        <description>Color of the flow lines</description> 
        <info> 
          <![CDATA[ 
          Flow lines indicate the logical flow of data or information through 
the diagram. This is the color of the flow lines 
          ]]> 
        </info> 
        <value>0xa52a2a</value> 
      </param> 
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      <param name="outlineColor" type="Color"> 
        <label>Outline color</label> 
        <description>Color of the flow outlines</description> 
        <info> 
          <![CDATA[ 
          Flow lines indicate the logical flow of data or information through 
the diagram. This is the outline color of the flow lines 
          ]]> 
        </info> 
        <value>0x000000</value> 
      </param> 
 
      <param name="fillArrowHead" type="Boolean"> 
        <label>Fill arrow head?</label> 
        <description>Set to true for solid arrow heads</description> 
        <info> 
          <![CDATA[ 
          Flow lines indicate the logical flow of data or information through 
the diagram. The lines optionally have arrowheads on the en 
ds indicating the direction of information flow. If this is set true, the 
heads will be solid. If not, they will be open. 
          ]]> 
        </info> 
        <value>true</value> 
      </param> 
 
      <param name="arrowHeadAngle" type="Double"> 
        <label>Arrow head angle</label> 
        <description>Arrow head angle (degrees)</description> 
        <info> 
          <![CDATA[ 
          Flow lines indicate the logical flow of data or information through 
the diagram. The lines optionally have arrowheads on the en 
ds indicating the direction of information flow. This is the angle of the 
arrowhead, in degrees. 
          ]]> 
        </info> 
        <value>30.0</value> 
      </param> 
 
      <param name="arrowHeadLength" type="Integer"> 
        <label>Arrow head length</label> 
        <description>Arrow head length (pixels)</description> 
        <info> 
          <![CDATA[ 
          Flow lines indicate the logical flow of data or information through 
the diagram. The lines optionally have arrowheads on the en 
ds indicating the direction of information flow. This is the length of the 
arrowhead, in pixels. 
          ]]> 
        </info> 
        <value>10</value> 
      </param> 
 
    </param> 
 
    <!-- ======= end of collection flowline ======= --> 
 
    <!-- ====== start of collection polyline ====== --> 
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    <param name="polyline" type="Collection" view_x="-1" view_y="-1" 
view_width="293" view_height="165"> 
      <label>Polyline params</label> 
      <description>Edit the polyline parameters</description> 
 
      <param name="lineColor" type="Color"> 
        <label>Line color</label> 
        <description>Color of the poly lines</description> 
        <info> 
          <![CDATA[ 
          Poly lines are arbitrary multi-point lines used to help organize the 
information on the diagram. This is the color of the poly 
lines 
          ]]> 
        </info> 
        <value>0x000000</value> 
      </param> 
 
      <param name="outlineColor" type="Color"> 
        <label>Outline color</label> 
        <description>Color of the poly outlines</description> 
        <info> 
          <![CDATA[ 
          Poly lines are arbitrary multi-point lines used to help organize the 
information on the diagram. This is the outline color of t 
he poly lines 
          ]]> 
        </info> 
        <value>0x000000</value> 
      </param> 
 
    </param> 
 
    <!-- ======= end of collection polyline ======= --> 
 
    <!-- ====== start of collection textbox ====== --> 
 
    <param name="textbox" type="Collection" view_x="-1" view_y="-1" 
view_width="440" view_height="281"> 
      <label>Textbox params</label> 
      <description>Edit the textbox parameters</description> 
 
      <param name="defaultWidth" type="Integer"> 
        <label>Default width</label> 
        <description>Default width of a text box (pixels)</description> 
        <info> 
          <![CDATA[ 
          When a text box is created, it will have this width by default. You 
can then resize the box by entering a different value in the edit dialog. 
          ]]> 
        </info> 
        <value>100</value> 
      </param> 
 
      <param name="defaultHeight" type="Integer"> 
        <label>Default height</label> 
        <description>Default height of a text box (pixels)</description> 
        <info> 
          <![CDATA[ 
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          When a text box is created, it will have this height by default. You 
can then resize the box by entering a different value in t 
he edit dialog. 
          ]]> 
        </info> 
        <value>50</value> 
      </param> 
     <param name="cornerRadius" type="Integer"> 
        <label>Corner radius</label> 
        <description>Radius of the corner arc (pixels)</description> 
        <info> 
          <![CDATA[ 
          The corners of the text box may optionally be rounded by a corner 
arc of this radius. Value is in pixels. 
          ]]> 
        </info> 
        <value>10</value> 
      </param> 
 
      <param name="outlineColor" type="Color"> 
        <label>Outline color</label> 
        <description>Color of the flow outlines</description> 
        <info> 
          <![CDATA[ 
          Outline color for the text boxes. 
          ]]> 
        </info> 
        <value>0x000000</value> 
      </param> 
 
      <param name="fillColor" type="Color"> 
        <label>Fill color</label> 
        <description>Color of the flow fills</description> 
        <info> 
          <![CDATA[ 
          Fill color for the text boxes. 
          ]]> 
        </info> 
        <value>0x4090a0</value> 
      </param> 
 
      <param name="fontName" type="String"> 
        <label>Font name</label> 
        <description>Font name for text</description> 
        <info> 
          <![CDATA[ 
          Set the font name for the text in the text boxes. 
          ]]> 
        </info> 
        <value>Dialog-plain-12</value> 
      </param> 
 
    </param> 
 
    <!-- ======= end of collection textbox ======= --> 
 
    <!-- ====== start of collection annotation ====== --> 
 
    <param name="annotation" type="Collection" view_x="-1" view_y="-1" 
view_width="416" view_height="164"> 
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      <label>Annotation params</label> 
      <description>Edit the annotation parameters</description> 
 
      <param name="textColor" type="Color"> 
        <label>Text color</label> 
        <description>Color of the annotation text</description> 
        <value>0x00fa00</value> 
      </param> 
 
      <param name="fontName" type="String"> 
        <label>Font name</label> 
        <description>Font name for annotation text</description> 
        <value>Dialog-plain-12</value> 
      </param> 
 
    </param> 
 
    <!-- ======= end of collection annotation ======= --> 
 
    <!-- ====== start of collection autodump ====== --> 
 
    <param name="autodump" type="Collection" view_x="100" view_y="100" 
view_width="831" view_height="316"> 
      <label>Autodump params</label> 
      <description>Edit the autodump parameters</description> 
 
      <param name="active" type="Boolean"> 
        <label>Autodump active?</label> 
        <description>Set autodump on?</description> 
        <info> 
          <![CDATA[ 
          If true, HTML autodump feature will be set active. Autodump creates 
images and html files which represent the SysView diagram s 
tate. These files are then available for viewing via a browser. 
          ]]> 
        </info> 
        <value>true</value> 
      </param> 
    <param name="outdir" type="File"> 
        <label>Output directory</label> 
        <description>Output directory for autodump files</description> 
        <info> 
          <![CDATA[ 
          The HTML and image files will be written to this directory. See also 
the 'outdir' parameter. 
          ]]> 
        </info> 
        <value>/d1/aoaws/data/www_content/SysView</value> 
      </param> 
 
      <param name="dated" type="Boolean"> 
        <label>Dated directories?</label> 
        <description>Set autodump into dated mode?</description> 
        <info> 
          <![CDATA[ 
          If true, the autodump files will be written into a subdirectory 
named from the current date. 
          ]]> 
        </info> 
        <value>true</value> 
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      </param> 
 
      <param name="template" type="File"> 
        <label>Template file</label> 
        <description>HTML template for autodump files</description> 
        <info> 
          <![CDATA[ 
          The HTML autodump files are based upon this template. The sysview 
data replaces the '<edu.ucar.rap.sysview.apps.sysview1image>' 
 in this file. 
          ]]> 
        </info> 
        <value>/home/aoaws/projDir/sysview/params/template.html</value> 
      </param> 
 
      <param name="objectInfo" type="Option"> 
        <label>Object info format</label> 
        <description>Format of object information</description> 
        <info> 
          <![CDATA[ 
          The object information can be either provided in HTML or graphical 
format. 
          ]]> 
        </info> 
        <value>HTML</value> 
      </param> 
 
      <param name="dumpInterval" type="Integer"> 
        <label>Dump interval (mins)</label> 
        <description>How often to dump - in minutes</description> 
        <info> 
          <![CDATA[ 
          The application will dump HTML files at regular intervals, 
controlled by this parameter. It will start dumping on the hour, and 
 then regular intervals thereafter. 
          ]]> 
        </info> 
        <value>15</value> 
      </param> 
 
    </param> 
 
    <!-- ======= end of collection autodump ======= --> 
 
    <!-- ====== start of collection status ====== --> 
 
    <param name="status" type="Collection" view_x="-1" view_y="-1" 
view_width="567" view_height="190"> 
      <label>Status params</label> 
      <description>Edit the Status parameters</description> 
 
      <param name="useLocalXML" type="Boolean"> 
        <label>Use Local XML Status Files</label> 
        <description>Status is determined by looking at local XML 
files</description> 
        <info> 
          <![CDATA[ 
          Querying the status of process, data, etc. over the network allows 
momentary network congestion appear as a more critical probl 
em. 
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          ]]> 
        </info> 
        <value>true</value> 
      </param> 
 
      <param name="xmlStatusLocation" type="String"> 
        <label>Path to XML status files</label> 
        <description>This is the full path to the XML status 
files.</description> 
        <value>/d1/aoaws/data/monitoring/sysview</value> 
      </param> 
 
      <param name="maxAge" type="Integer"> 
        <label>Max. age of an XML status file (sec)</label> 
        <description>XML status files older than this (sec) will not be 
used</description> 
        <info> 
          <![CDATA[ 
          When parsing XML files to get status information, the time in the 
filename will be used to determine if they are older than thi 
s. 
          ]]> 
        </info> 
        <value>900</value> 
      </param> 
 
    </param> 
 
    <!-- ======= end of collection status ======= --> 
 
  </param> 
 
  <!-- ======= end of collection Root ======= --> 
 
</parameters> 

1.6 啟動 SysView  (Starting SysView) 

若使用者帳號為 aoaws，其登入目錄為 /home/aoaws，且 SysView 的參數檔位於 

/home/aoaws/sysview目錄中。 

SysView 是以 Java 封裝檔案格式，jar 檔，安裝。此 jar 檔之路徑為

/home/aoaws/projDir/bin/sysview.jar。欲使用 SysView，使用者必須先將下列變數加

到 LD_LIBRARY_PATH 環境變數中： 

  /home/aoaws/projDir/lib/ 

Suppose your user name is aoaws, and your home directory is /home/aoaws. 

SysView will be installed as a Java Archive file, a jar file. Let us suppose that it is installed as 
/home/aoaws/projDir/lib/sysview.jar.  To use SysView you will need to add the 
following to your LD_LIBRARY_PATH environment variable: 

  /home/aoaws/projDir/lib/ 
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然後才可執行下列指令來啟動 SysView： 

Then you can start Sysview as follows: 

java -jar /home/aoaws/projDir/lib/sysview.jar 

SysView 首次執行時，SysView.diagram檔並不會存在。必須先執行 Diagram->Save 功能

後，SysView 才會產生 SysView.diagram檔。參數(parameter)檔也不會存在，必須先執行 
Params->Save 才會產生參數檔。下圖為 SysView 首次執行時的空白畫面。 

When you start SysView up for the first time, the diagram file SysView.diagram will not exist. 
It will be created the first time you use the Diagram->Save feature. Your parameter file will not 
exist either, but will be created when you use the Params->Save feature.  The first time you start 
SysView, the SysView window will be empty - see the figure below.  

 

 

尚未執行 Save 功能的畫面 (Example of an empty SysView page ready for editing) 
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2 主選單 (The Main Menus) 
SysView 有七個主選單列於視窗左上角的選單列上。這些主選單的詳細說明如下： 

SysView has 7 main menus - see the menu bar on the upper left of the window. The main menus 
selections are detailed below. 

2.1 檔案選單 (The File Menu) 

 
• Quit: 離開 SysView  (quit SysView) 

2.2 參數選單(The Params Menu) 

 
• New: 產生新流程圖檔 (reset your parameters to the default settings) 

• Open: 開啟流程圖檔 (open an existing parameter file) 

• Edit: 編輯流程圖  (edit the parameters) 

• Save: 儲存流程圖 (save the current parameters) 

• Save As: 儲存流程圖至另一檔案 (save the current parameters to another file name)  

• Reset: 重排視窗位置(reset view panal locations) 
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2.3 流程圖選單(The Diagram Menu) 

 
• New: 產生新流程圖檔 (reset the diagram to an empty diagram) 

• Open: 開啟流程圖檔 (open an existing diagram file) 

• Save As: 儲存流程圖至另一檔案 (save the current diagram to another file name)  

• Save: 儲存流程圖 (save the current diagram) 

 

2.4 輸出選單(The Export Menu) 

 
• Print:  列印流程圖 (print a hard copy of the diagram) 

• Export Diagram: 儲存流程圖之圖示(save an image of the diagram) 

• Export All Diagrams: 儲存所有流程圖之圖示(save images of all diagrams) 

• Export All wih HTML: 以 HTML 格式儲存所有流程圖之圖示(save images of all 
diagrams with HTML to tie them together)  
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2.5 編輯選單 (The Edit Menu) 

 
• Change Title: 修改主要流程圖之標題 (change main diagram title) 

• Change All Hosts: 於副流程圖上修改所有的程序及資料集的電腦名字 (change 
host name for all processes and data sets in a sub-diagram) 

• Add Process: 新增一個程序圖示 (add a process icon) 

• Add Data Set: 新增一個資料集圖示 (add a data set) 

• Add Text Box: 新增一個文字方塊 (add a text box) 

• Add Annotation: 新增註解 (add annotation) 

• Add Flow Line: 新增一條流向線 (add a flow line) 

• Add Polyline: 新增一條複段線 (add a multi-segment line) 

• Add Sub-diagram: 新增一個子流程圖 (add a sub-diagram) 

• Add Zudnik Object: 新增一個子流程圖 (add a Zudnik Object) 

• Show Grid: 顯示或隠藏網格  (toggle grid on/off) 

2.6 詢問要求選單 (The Query Menu) 

 

• Query Mappers: 編輯時要求 procmap 及 DataMap 更新流程圖  (query procmap and 
DataMap to update diagram while editing.) 
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2.7 執行選單 (The Run Menu) 

 
• Edit Mode: 設為編輯模式  (set in edit mode) 

• Run Mode: 設為執行模式 – 唯讀 (set in run mode – cannot edit) 
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3 檔案之使用 (Using the File menu) 

3.1 結束 (Quitting) 

選取 File->Quit 來結束 SysView  (Select File->Quit.)  

請注意，若使用者沒有儲存編輯過的流程圖便離開 SysView ，SysView 並不會提醒使用者

應儲存編輯過的流程圖。(BE CAREFUL, SysView does NOT prompt you if you have not 
saved your editing work.) 
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4 使用編輯功能來建立流程圖 (Creating a diagram using the Edit menu 
functions) 

4.1 概觀 (Overview) 

使用者可以透過編輯功能來建立流程圖。下圖為一具有多元件的簡單流程圖範例。在本範

例中，SysView 必須設定為編輯模式，且會顯示格線。 

You use the Edit functions to create a diagram for your system. The figure below shows an 
example of a simple diagram with at least one of each of the various elements. In this example, 
SysView is in Edit mode and the grid lines are on. 

4.2 子流程圖說明 (A note on sub-diagrams) 

子流程圖主要是用來製作多層次的流程圖，協助使用者將一個過於複雜的流程圖再細分為

數個子流程圖頁面。通常一個子流程圖代表一個主機系統，但若需顯示的資訊過於複雜

時，子流程圖可再細分成數個次一層子流程圖。如果系統所有資訊可於單一個頁面上顯示

時，就不需要子流程圖。 

Sub-diagrams are used to provide multiple levels to the diagram. This enables you to break 
complicated diagrams up into multiple pages, with each page representing part of the diagram. 
Frequently, a sub-diagram represents a computer host. On complicated hosts this sub-diagram 
may itself be broken down into further sub-diagrams. If all of the elements of your system can be 
represented on a single page, you will not require any sub-diagrams. 
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4.3 改變主要流程圖標題 (Changing the main diagram title) 

先選取 Edit->Change Title。 

Select Edit->Change Title 

.  

再於方字方塊內輸入想要的標題，並按下 OK 鍵即可。 

Enter the title in the text box. Click on OK 

4.4 設定子流程圖元件機器名稱 (Setting the host name for elements on a sub-diagram.) 

本功能最常用在被複製的子流程圖的複本上，一個被複製的子流程圖複本上的每個程序和

資料集可能與被複製的子流程圖不同。使用者可透過編輯功能來編輯複本上的每個程序及

資料集，但耗費時間，透過 Change All Hosts 功能，則只要一個步驟即可修改所有子流程

圖上執行程序的機器名稱。 

This function is most useful after you have used the copy feature to copy a sub-diagram. The 
copy will probably represent processes and data sets on a different host from the original. You 
can edit each process and data set in the diagram copy and set the host, but this is tedious. Using 
the Change All Hosts feature allows you to change the host name for all active objects on a sub-
diagram in a single step. 

選擇 Edit->Change All Hosts。 

Select Edit->Change All Hosts.  

 

 

輸入機器名稱並按下 OK 鍵。 
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Enter the host name and then click on OK. 

4.5 增加一個程序 (Adding a process) 

程序圖示為動態物件，其顏色會依據程序在系統中的執行狀況來改變。 

A process icon is a dynamic object. It changes color depending on whether the process is up or 
not. 

選取 Edit->Add Process。 

Select Edit->Add Process. 

 

Process Name 及 Process Instance 是根據 print_procmap輸出決定的。 

Priority 的預設值為 PRIORITY_HIGH，另可以設定為 PRIORITY_MEDIUM或

PRIORITY_LOW。其值決定本程序圖示對位於上層子流程圖之圖示的影響。 

若其值為 PRIORITY_HIGH，在上層的子流程圖的圖示狀態將會同步反映本程序狀態，即若

程式圖示顯示為紅色，在上層的子流程圖的圖示也會顯示為紅色。同樣的，如果程式圖示

顯示為黃色，在上層的子流程圖的圖示也會顯示為黃色。 

若其值為 PRIORITY_MEDIUM，上層的子程式圖示顯示為紅色或黃色，在上一層子流程圖的

圖示則會顯示為黃色。 

若其值為 PRIORITY_ LOW，上層的子程式圖示顯示將不會受本程序圖示影響。 

設定好 Priority 後，按下 Add and Close。呈現紅色的程序圖示會顯示在圖的左上方，使用

者可將圖示拉到其他適當的地方。 

若按下 Add 而非 Add and Close，則此選單視窗不會關閉，使用者可在同一個視窗上增加

多個程序圖示。 

使用者亦可於 Info link for web output 填入 URL，此時在 SysView 網頁上便會顯示

Troubleshooting 鍵。點選此鍵便可以連結到使用者之前設定的疑難排解訊息網頁。請注
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意：本功能只於 SysView HTML 網頁輸出有作用，在 X Windows 上的 SysView 並不提供

本項功能。 

若 AOAWS 系統正在運作中，使用者可選取 Query->Query Mappers 來查看程序設定是否

正確，此時程序圖示應為綠色。 

Refer to your print_procmap output to determine the Process Name and Process Instance. 

You can also change the Priority. The default is PRIORITY_HIGH. You can change this to 
PRIORITY_MEDIUM or PRIORITY_LOW. The priority determines the way in which the state of a 
process affects the state of sub-diagrams at higher levels. 

If the priority is high, the state of the sub-diagram at the next level up will reflect the state of the 
process. If the process is red, the sub-diagram will be red. Likewise for yellow. 

If the priority is medium and the process is red or yellow, the sub-diagram at the next level up 
will be yellow. 

If the priority is low the state of the next level up will not be affected by the state of the process. 

When done with setting the process properties, click on Add and Close. The process icon, will 
appear at the top left. Drag it to the desired location. 

If you click on Add instead of Add and Close, the popup menu will not close. In this way you 
can add a number of processes using the same popup menu. 

You may optionally fill in the Info link for web output, inserting a URL. If you do so, the process 
info page in the SysView web output will include a button marked Troubleshooting. Clicking on 
this button will connect you to the specified URL. This is a useful way to provide trouble-
shooting information to the end user. Note that this is only active for the web HTML output, not 
in the SysView application itself. 

If your software system is running, select Query->Query Mappers to check that you have entered 
the process details correctly. The process icon should turn green. 
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4.6 增加資料集 (Adding a data set) 

資料集圖示為動態物件，其顏色會隨資料在系統中的接收狀態：準時、延遲，以及嚴重延

遲的情況而改變。 

A data set icon is a dynamic object of a diagram. It changes color depending on whether the data 
is on time, late or very late. 

選取 Edit->Add Data Set。 

Select Edit->Add Data Set. 

 

 

資料集種類及目錄是根據 PrintDataMap之輸出來決定，使用者必須將對應資料填入視窗

選單表格內。並填入 Late Time (secs)及 Very Late Time (secs)，系統依據這兩個時間

值來定義資料傳送嚴重延遲 (紅色) 或延遲 (黃色)，並設定資料集圖示之顏色。當資

料傳送延遲時，圖示為黃色，資料傳送嚴重延遲時，則以紅色來表示。因為每種資料集傳

送時間不一樣，使用者必須填入兩個正確的時間值。 

Refer to your PrintDataMap output to determine the data set type and directory. Fill these in on 
the popup menu form. Also fill in the Late Time (secs) and Very Late Time (secs) fields. These 
are the times at which the data set icon will go yellow and red respectively if the data flow stops 
and the data becomes late. The intention is to change the color to yellow when the data is late, as 
a warning, and red when the data is very late. Since these values will vary from data set to data 
set, you need to fill them in individually for each data set. 

Priority 預設值為 PRIORITY_HIGH，另可設為 PRIORITY_MEDIUM或 PRIORITY_LOW。Priority
決定資料集對上層子流程圖之圖示的影響。 

You can also change the Priority. The default is PRIORITY_HIGH. You can change this to 
PRIORITY_MEDIUM or PRIORITY_LOW. The priority determines the way in which the state of a 
data set affects the state of sub-diagrams at higher levels. 
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若 Priority 為 PRIORITY_HIGH，上層的子流程圖的圖示狀態會同步反映資料集傳送狀態。

若資料集圖示顯示為紅色，在上層子流程圖的圖示也會顯示為紅色。同樣的，若資料集圖

示顯示為黃色，在上層子流程圖的圖示也會顯示為黃色。 

If the priority is high, the state of the sub-diagram at the next level up will reflect the state of the 
data set. If the data set is red, the sub-diagram will be red. Likewise for yellow. 

 

若 Priority 為 PRIORITY_MEDIUM，資料集圖示顯示為紅色或黃色，則在上層子流程圖的圖

示會顯示為黃色。 

If the priority is medium and the data set is red or yellow, the sub-diagram at the next level up 
will be yellow. 

若 Priority 為 PRIORITY_LOW，則上層子流程圖的圖示將不會受本資料集圖示的影響。 

If the priority is low the state of the next level up will not be affected by the state of the data set. 

設定好 Priority 後，按下 Add and Close。呈現紅色的資料集圖示會顯示在畫面的左上方，

使用者可將圖示拉到其他適當的地方。 

When done setting the data set properties, click on Add and Close. The data set icon, in red, will 
appear at the top left. Drag it to the desired location. 

如果你是按下 Add 而不是 Add and Close，此選單視窗不會關閉。在這個情況下你便可以

在同一個視窗上多增加幾個資料集圖示。 

If you click on Add instead of Add and Close, the popup menu will not close. In this way you 
can add a number of data sets using the same popup menu. 

你亦可以在 Info link for web output 填入 URL，如此即可以在 SysView 網頁上看到

Troubleshooting 按鈕。點選此按鈕可以連結到提供使用者疑難排解訊息網頁。請注意：這

個功能只提供給 web HTML 輸出，在 SysView 應用上並沒有此項功能。 

You may optionally fill in the Info link for web output, inserting a URL. If you do so, the data 
set info page in the SysView web output will include a button marked Troubleshooting. Clicking 
on this button will connect you to the specified URL. This is a useful way to provide trouble-
shooting information to the end user. Note that this is only active for the web HTML output, not 
in the SysView application itself. 

如果你的軟體系統正在運作中，你可以選取 Query->Query Mappers 來核對你輸入的資料

集說明是否正確。這時資料集圖示應該轉變為綠色。 

If your software system is running, select Query->Query Mappers to check that you have entered 
the data set details correctly. The data set icon should go green. 
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4.7 增加文字方塊 (Adding a text box) 

文字方塊內容不會自動改變，通常只用來標示流程圖資訊。 

A text box is not dynamic. It is only used to add information to the diagram. 

選取 Edit->Add Text Box。 

Select Edit->Add Text Box. 

 

於 Text 處輸入要顯示的文字，並在 Width 及 Height 處設定文字方塊大小。 

最後按下 Add and Close。此時文字方塊會出現在流程圖左上方，再將文字方塊拉至其他

適當位置。 

若按下 Add 而非 Add and Close，本選單視窗不會關閉。使用者可以在同一個視窗上再增

加數個文字方塊。 

Fill in the Text you wish to appear in the box, plus the desired Width and Height. 

Click on Add and Close. The text box will be placed at the top left of the diagram. Drag it to the 
required location. 

If you click on Add instead of Add and Close, the popup menu will not close. In this way you 
can add a number of text boxes using the same popup menu. 

4.8 增加註解字串 (Adding annotation strings) 

註解物件為靜態的文字字串，用來標示流程圖之附加說明。 

Annotation objects are static text strings which add extra detail to a diagram. 

選取 Edit->Add Annotation。 

Select Edit->Add Annotation.  
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在 Annotation 處輸入文字，並按下 Add and Close。此時註解字串會出現在流程圖左上

方，使用者可將註解字串拉至其他適當位置。 

若按下 Add 而非 Add and Close，此選單視窗不會關閉。使用者可以在同一個視窗上多增

加數個註解字串。 

Fill in the Annotation string you want, and click Add and Close. The annotation string will be 
placed at the top left of the diagram. Drag it to the desired location. 

If you click on Add instead of Add and Close, the popup menu will not close. In this way you 
can add a number of annotation strings using the same popup menu. 

4.9 增加資料流向線 (Adding a flow line) 

資料流向線為靜態物件，主要用來表示資料在系統間傳遞之狀況。一般帶有箭頭，用來表

示資料流動方向。 

選取 Edit->Add Flow Line。然後按下滑鼠左鍵，先設定資料流向線的起點。接著移動滑

鼠，此時線條會隨著游標移動。每按下一次滑鼠左鍵，便會產生一個資料流向線的轉折

點。在最後一點上 (或接近該點) 的位置上，以滑鼠快速按兩下，便完成一條新增的資料

流向線。 

在產生資料流向線時，若按住 Shift 鍵，線條將會與格線平行，換言之，線條將沿著水平

或垂直方向畫，如此一來畫 90 度線條便簡單些。 

Flow lines are static objects which show how the data moves around the system. Flow lines 
normally have an arrow-head to show the data flow direction. 

Select Edit->Add Flow Line. Then left-click on the start point of the flow line. Move the mouse, 
and the line will rubber-band as it follows the cursor. Clicking again will set a point at which the 
line will change direction. Double-clicking on a single point (or close to it) completes the line. 

If you hold the Shift key down while drawing the line, the line will be forced to be parallel to the 
grid, i.e. it will only follow 90-degree directions. This makes it simpler to draw 90-degree lines. 
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4.10 增加複段線 (Adding a polyline) 

複段線在流程圖上是由多個固定線條組成，用來增加流程圖之詳細說明，該線條不含箭

頭。 

選取 Edit->Add Polyline。增加的方式請參考前一小節增加資料流向線的操作說明。 

Polylines are static multi-segmented lines which add detail to the diagram. They do not have 
arrow-heads. 

Select Edit->Add Polyline. Then follow the same procedure as for drawing flow lines. 

4.11 增加子流程圖 (Adding a sub-diagram) 

選取 Edit->Add Sub-diagram。 

Select Edit->Add Sub-diagram. 

 

 

設定 Label 並按下 Add and Close。此時新的子流程圖會出現在目前視窗左上方，再將流程

圖拉至其他適當位置。 

於子流程圖上以滑鼠左鍵快速按兩下，即可編輯本流程圖內容。想要回到上層時，使用者

只要按下子流程圖視窗左上方相關圖示即可。 

子流程圖上的物件放置方式和主要流程圖完全相同。 

Set the Label and then click Add and Close. The sub-diagram icon will be placed at the top-left 
of the current page. Drag it to the desired location. 

To enter the sub-diagram, double-click on it. This will take you down one level. To move back to 
the previous level, click on the relevant icon at the top-left of the sub-diagram page. 

Objects are placed on a sub-diagram in exactly the same way as they are on the main diagram. 
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5 編輯流程圖 (Editing a diagram) 

5.1 概觀 (Overview) 

在流程圖上的物件可能需要移動或修改編輯。如何修改物件是依據其種類而定。 

Objects on a diagram may be moved around and edited once they have been placed on a diagram. 
The exact manner in which they are edited depends on the type of object. 

5.2 移動流程圖上物件 (Moving diagram objects around) 

使用者可在物件上按下滑鼠左鍵，並拖拉至適當位置。 

Click on the object with the left mouse button, and drag to the desired location. 

5.3 編輯物件 (Editing objects) 

若使用者於一流程圖物件上按下滑鼠右鍵，即可進入編輯功能。使用者可選取 Copy 
Object 來複製物件、利用 Cut Object 來剪下物件，或利用 Edit Object 來編輯物件。 

If you right click on a diagram object, you will get the edit menu. You can select Copy Object, 
Cut Object or Edit Object. 

 

5.4 停止物件運作 (Disabling objects) 

對動態物件而言 (如程序，資料集，以及子流程圖)，選單上另有一個 Disable Object 選
項。 

For active objects, (processes, data sets and sub-diagrams) you get an additional option, 
Disable Object. 

 

當必須暫停流程圖中某物件的作用時，例如：某物件將停止運作一段時間，而使用者不希

望見到其出現警告狀態時，便可使用此選項。 
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如果使用者選取 Disable Object，該物件將停止其作用。 

This is useful for temporarily removing an object from the active state of the diagram when, for 
example, you know it will be down for some time and you do not wish to be warned about its 
state. 

If you select Disable Object, the object will no linger be included in the active functions of the 
diagram. 

5.5 啟動物件 (Enabling objects) 

使用者可選取被停止作用的物件，以 Enable Object 來恢復該物件功能。 

You can edit an object which has been disabled and select Enable Object to make it active again. 

 

5.6 顯示資訊 (Showing information) 

本功能可以顯示程序或資料集的相關資訊。 

You can show the information on a process or data set, using the edit menu. 

                        

選取 Show Info 即會顯示程序或資料集的相關資訊。 

下列為程序相關資訊範例。 

Selecting Show Info will bring up the information for the process or data set. 

The following shows the information for a process. 
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下列為資料集的範例。 

The following shows the information for a data set. 

 

5.7 編輯程序 (Editing a process) 

若選取程序的 Edit 編輯功能，便會出現下列視窗選單。 

If you select Edit for a process, you will receive the following popup menu. 
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請編輯需要修改的地方，然後按下 OK。 

Edit any required fields, and select OK. 

5.8 編輯資料集 (Editing a data set) 

若選取資料集上的 Edit 編輯功能，便會出現下列視窗選單。 

If you select Edit for a data set, you will receive the following popup menu. 

 

請編輯需要修改的地方，然後按下 OK。 

Edit any required fields, and select OK. 

5.9 編輯文字方塊 (Editing a text box) 

若選取文字方塊上的 Edit 編輯功能，便會出現下列視窗選單。 

If you select Edit for a text box, you will receive the following popup menu. 
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請編輯需要修改的地方，然後按下 OK。 

其中文字方塊顏色設定為 16 進位 0xrrggbb。 

Edit any required fields, and select OK. 

Remember colors are specified in Hex as 0xrrggbb. 

5.10 編輯資料流向線條 (Editing a flow line) 

若選取資料流向線條上的 Edit 編輯功能，便會出現下列視窗選單。 

If you select Edit for a flow line, you will receive the following popup menu. 

 

 

大部分情況下，使用者只需修改線條箭頭方向或其他細節部分。只需於下列選項中選取線

條呈現方式即可： 

Most likely, you will only wish to change the direction or details of the arrow. Do this by 
clicking on the required selection: 

• Reverse Flow Direction: 改變箭頭方向 (change arrow direction) 

• Flow Left: 箭頭向左邊 (arrow points left) 
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• Bi-directional Flow Direction: 線條兩端都有箭頭 (two-headed arrow) 

• No Direction: 不需要箭頭 (two-headed arrow) 

• Flow Right: 箭頭向右邊 (arrow points right) 

 

使用者可利用 FlowLine 視窗來修改資料流向線條位置，但這方式須要技巧。較佳的方式

為於編輯選單上利用 Cut Object 來刪除資料流向線，並增加一條新的。 

You can also manually edit the flow line location using the FlowLine window. However, this is 
tricky and not recommended. It is better to delete the flow line with Cut Object on the Edit menu 
and then create a new one. 

5.11 編輯複段線 (Editing a polyline) 

若選取複段線的 Edit 編輯功能，便會出現下列的視窗選單。 

If you select Edit for a polyline, you will receive the following popup menu. 

 

使用者可利用視窗手動編輯資料流向線條位置，但這方式須要技巧。較佳的方式是在編輯

選單上利用 Cut Object 刪除複段線，並增加一條新的。 

本功能並不常使用，手動編輯方式須要技巧。較佳的方式是在編輯選單上利用 Cut Object
刪除 polyline 並增加一條新的。 

You can also manually edit the flow line location using the Polyline window. However, this is 
tricky and not recommended. It is better to delete the polyline with Cut Object on the Edit menu 
and then create a new one. 

This feature is seldom used. You can manually edit the polyline location, though this is tricky. It 
is better to delete the polyline with Cut Object, and then create a new one. 

5.12 編輯子流程圖 (Editing a sub-diagram) 

若選取子流程圖上的 Edit 編輯功能，便會出現下列視窗選單。 
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If you select Edit for a sub-diagram, you will receive the following popup menu. 

 

請編輯需要修改的地方，然後按下 OK。 

Edit any required fields, and select OK. 

5.13 刪除一項物件 (Deleting an object) 

於物件上按下滑鼠右鍵便會開啟編輯選單，再選取 Cut Object 來刪除物件 

Bring up the edit menu, by right-clicking on an object. Select Cut Object to delete the object. 

5.14 複製物件 (Copying an object) 

在物件上按下滑鼠右鍵以開啟編輯選單。選取 Copy Object，並在流程圖上空白處按下滑

鼠右鍵，會得到一個貼上選單，選取 Paste，複製的物件即會產生。如果有需要可以拖曳

物件並編輯物件。 

亦可以使用剪下並貼上物件方式。不過這樣的方式與將物件拉至適當位置結果是相同的。 

使用者也可以從一個子流程圖複製物件到另一個子流程圖上。 

Bring up the edit menu, by right-clicking on an object. Select Copy Object. In a blank part of the 
diagram, click the right mouse button. You will get the paste menu. Select Paste, and a copy of 
the object will be pasted in at that location. Drag the object to the required location, and edit it as 
required. 

You can also paste an object after cutting it. However, the same effect is achieved by dragging it 
to a new location. 

You can copy an object from one sub-diagram to another. 
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