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Chapter 1
Getting Started

What is BrightAuthor?
BrightAuthor is a software application that helps you create presentations for your digital sign or
kiosk. You can play your BrightAuthor presentations on BrightSign models: HD110, HD210,
HD210w, HD410, HD810, HD1010, and HD1010w. Your presentations can include any of the
following types of content:
* Images
* Pre-recorded videos
* Live videos (HD810,HD1010, and HD1010w only)
* Audio
* RSS
* Dynamic Playlists

* SignChannel (HD210, HD210w, HD1010, and HD1010w only, subscription required,
go to www.signchannel.com for details)

e Text
e Date or time



http://www.signchannel.com

What kind of presentations can | create?
You can create two types of presentations with BrightAuthor:

* Non-interactive: A slide show or video that plays as a continuous loop. You can play non-
interactive presentations on all BrightSign models that are compatible with BrightAuthor.

* Interactive: A presentation that requires input from the user via a button board, keyboard,
mouse, or similar input device. To play interactive presentations, you must use an HD210,
HD210w, HD410, HD810, HD1010, or HD1010w.

What type of layouts can | use?

You can choose from a variety of ready-to-use layout templates or create your own layout
template. Layout templates fall into two basic categories:

* Full screen: A slide show or video that occupies the full screen.

* Multi-zone: A presentation with different types of content in each region of the screen. The
screen can include one video zone, and multiple Clock, Text, Ticker, or Image zones.

Step 1: Get the hardware you need
To create presentations with BrightAuthor and play these presentations, you need the following:
* Windows PC
* BrightSign
* Display
 Storage card
* Card reader/writer (optional if using USB storage)
* Input device (optional)
See below for details on these requirements.



Windows PC Any Windows PC that meets or exceeds the following minimum requirements:
e 23GHzCPU
* 2 GB RAM required (4 GB recommended)

* 100 MB available hard disk space for program files (additional disk space required if storing
content and/or presentations on your hard disk)

* One of these operating systems:
* Windows XP with SP2 or SP3
* Windows Vista 32 or 64 bit
* Windows7 32 or 64 bit
BrightSign Any of the following models with firmware version 3.5.68 or later:
* HD110
* HD210 and HD210w
* HD410
* HD810
* HD1010and HD1010w
Display Any monitor, TV, or Elo touch screen with one of the following types of inputs:
* VGA
* Component (HD810, HD1010, and HD1010w only)
* HDMI
Storage card Either of the following:
* USB Flash card (HD810, HD1010, and HD1010w only)
e SDcard
* SDHC card

Card Reader/Writer (not required with USB Flash card) The card reader/writer must be
connected to your PC and must be compatible with your storage card.

Input device (HD410,HD810,HD1010, and HD1010w only) One or more of the following types
of input devices:
* Elo Touch Screens that support an HID driver (HD810, HD1010, and HD1010w only)



* Many brands of USB Keyboards (HD810, HD1010, and HD1010w only)
* Many brands of USB Mouse or Trackballs (HD810, HD1010, and HD1010w only)

* Many brands of USB Bar Code Scanners (these appear as a keyboard; HD810, HD1010, and
HD1010w only)

¢ Quadravox Serial Button Board
¢ AMX, Crestron, and similar control devices (serial & ethernet)

* Any GPIO button, signal, or LED (your custom board or LED display). BrightSign has a test
button board available for purchase on our estore.

* PCvia serial port

* IR remote control using the NEC Remote Control Protocols. You can purchase a compatible
remote from BrightSign (see Appendix A for remote control codes).

Step 2: Install the BrightAuthor software

1
2
3

Download the latest software and install it on your PC.

NOTE: BrightAuthor requires the latest version of Microsoft .Net Framework. If this component is
not already on your PC, BrightAuthor installs it during the installation. However, if BrightAuthor
needs to install Microsoft .Net Framework, the installation may take up to 45 minutes to complete
and you may need to restart your PC to complete the installation process.

Go to the BrightSign web site www.brightsign.biz/support.
Click the BrightAuthor Downloads link.
Follow the onscreen instruction to install the software on your PC.

Step 3: Launch the BrightAuthor application

1
2

Double-click the BrightAuthor icon on your desktop.

(Optional) If prompted, sign in to BrightSign Network (account required). See Publishing a
presentation using BrightSign Network for details.
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Step 3: Add your content

Your BrightAuthor presentations can include the following types of media files:

* Video files. You can use a single file as a loop, or multiple files. Video files can be MPEG-2 files
that are saved as transport or program streams, MPEG-1 files that are saved as system streams,
or H.264 files that are saved as transport or program streams. Supported file extensions: MP4,
MOV, TS, VOB, and MPG

* Audiofiles. Any AAC audio in an MOV/MP4 file or MP3 audio in a video or mp3 file. MP3 audio
must have a sample rate of 48 kHz, 44.1 kHz, or 32 kHz.

* Imagefiles. For stillimages, use BMP, PNG, and JPEG files. The maximum supported resolution
is 1920x1080.

Step 4: Create your presentations

Now you're ready to start using your BrightAuthor to create presentations. Just add your content
and follow the directions in the next chapter of this guide to create your presentations.

Step 5: Publish your presentations

After create presentations, use the publishing feature to deliver them to your BrightSign units.
See Publishing Presentations for details.




Chapter 2
Creating Presentations

Creating a full-screen presentation
In a full-screen presentation, your images or video occupy the entire screen.

1 Create a new presentation project:

a

Double-click the BrightAuthor icon on your
desktop.

In the Create a new BrightSign project window,
enter a name for the presentation in the Save As
field.

TIP: If you do not see the Create a new BrightSign project
window, do the following to open it: on the menu bar,
click File > New Presentation.

C

In the Where field, enter the folder where you want
to store the presentation. To navigate to the folder
you want to select, click Browse.

D Mew project Iﬁ
Create a new BrightSign project
Save As:  Project 2
Where:  C:\,.\BrightSign Presentations
BrightSign Model: [HDiDlO '|
Connector type: [HDMI '|
Screen resolution: [lQZOxIUSUxGOi 'l
Maonitor overscan: @ No awverscan - use full screen
Overscan - action safe area
Overscan - title safe area
Create ‘ Cancel |

Select your BrightSign Model, Connector type, and Screen resolution.

Select a Monitor overscan setting to control how the image fills the display screen:

* No overscan: Displays images all the way to the edge of the video signal.



* Overscan action safe: Restricts the image display to an area that is compatible with
most displays.

* Overscan title safe: Restricts the image display to an area that is much smaller than the
image generated by the video signal.

NOTE: Don't be afraid to experiment to find the overscan setting that works best with your display.

f Click Create.

Click the Full Screen template, and then click
Choose.

Add your Media Library:
a On the left side of the screen, click Browse.

Select a Template View: | System Templates -

b Navigate to the folder where your content is
stored.

¢ Click OK. | |

NOTE: If you have a lot of large files in your content Faome Srzone withcock
folder, it may take a while for the thumbnail images
to appeatr.

Full Screen 2-zene horizontal 2-zone vertical

Add media files to your presentation by

dragging files from the Media Library folders to
the playlist area. ([Cchoose [ concel |

* To select a series of adjacent media files, press Rl R Cock 0 videoorimages
Shift+Click as you select the files.

* To select a group of non-adjacent files, press Ctrl+Click as you select the files.

* To arrange the files in the order in which you want them to play, drag the thumbnails in the
playlist area.

* To refresh the Media Library folders, click 5; (next to the Browse button).

* To remove an item from a playlist, highlight it in the playlist area and press Delete on your
PC keyboard.



e (HD210,HD210w, HD410,HD810,HD1010, and HD1010w only) To enable the presentation to
respond to user input, see Making a presentation interactive for details.
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5 HD810,HD1010, and HD1010w only (Optional) Add Live Video to your playlist:
a Click the Other tab on the left side of the screen.

b Drag the Live Video m iconto the
playlist area. To add more than one
live video sequence, drag the Live
Video icon to your playlist again for
each sequence you want to add.
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8

¢ (Optional) Set the video volume: Right-click Live Video T =
in the playlist area, select Edit, and then enter the e -
settings you want to apply to the selected item. S —— ] 00 |

TIP: To remove a Live Video item from a playlist, highlight it in [ ox ][ concel |
the playlist area and press Delete on your PC keyboard.
HD210, HD210w, HD1010, and HD1010w only
(Optional) Add SignChannel content to your playlist:

a Click the Other tab on the left side of the screen.

b Drag the SignChannel u icon to the playlist area.
TIP: To remove a SignChannel item from a playlist, highlight it in the playlist area and press

Delete on your PC keyboard.

HD210, HD210w, HD1010, and HD1010w only (Optional) Add Dynamic Playlist content
to your playlist:

a Click the Other tab on the left side of the screen.

b Drag the Dynamic Playlist u icon to the playlist area.

TIP: To learn more about Dynamic Playlists, see Creating a Dynamic Playlist. To remove a
Dynamic Playlist item from a playlist, highlight it in the playlist area and press Delete on your
PC keyboard.

(Optional) Rename the playlist:

A [] Playlist0 DT X

a Click Edit in the upper-right corner of the D it Pt ==
playlist area. e p——

b Enter a new name for the playlist. . | r—

¢ Click OK. i

‘1



9 (Optional) Set playback options:
* Toedit settings for a single item, right-click the thumbnail

* To edit settings for multiple items, press Ctrl+Click to

Edit Image Parameters

Time on screen: 3

in the playlist area, select Edit, and then choose the
settings you want to apply to the selected item.

Transition: [Fade to new image - ‘

OK | Cancel ‘

select the items in the playlist area. On the menu bar, click =
Edit > Selected Items, and then choose the settings you want to apply to all selected items.

10 On the menu bar, click File > Save... to store your presentation.

NOTE: To save the presentation with a different name or in a different folder, select
File > Save... As. To export the presentation and associated content, select File > Export... .

11 Publish your presentation. See Publishing Presentations for details.

Creating a multi-zone presentation

In a multi-zone presentation, BrightAuthor divides the screen into rectangles called zones. You
can play different content in each zone and each zone supports a specific type of content.
BrightAuthor provides a handful of multi-zone templates. You can choose one of the existing
templates, or create your own (see Customizing template layouts).

When using a multi-zone template, you need to know which type of content you can include in
each zone. The color-coded key at the bottom of the template screen shows the available
content types, and the color-coded templates indicate which type of content you can include in
each zone of the templates. The following list describes the available content types:

Images: Plays images. You can include multiple Images zones.

Ticker: Plays an RSS feed or pre-defined text strings. You can include multiple Ticker zones.
Clock: Displays the time or date. You can include multiple Clock zones.

Video or Images: Plays videos and images. You can include only one Video or Images zone.
Video Only: Plays videos. You can include only one Video Only zone.




* Background Image: Places an image in the background of your presentation. All other zones

appear on top of the background image. When using a background image, you cannot
include a Video Only zone or a Video or Images zone. You can include only one Background

Image zone.

NOTE: You can include only one zone with video per presentation. Therefore you must choose
between a Video or Images zone, a Video Only zone, or a Background Image zone. You cannot
have more than one of these zone types in the same presentation.

1 Create a new presentation project:

a Double-click the BrightAuthor icon on your
desktop.

b Inthe Create a new BrightSign project window,
enter a name for the presentation in the Save As
field.

TIP: If you don't see the Create a new BrightSign project
window, do the following to open it: on the menu bar,
click File > New Presentation.

¢ Inthe Where field, enter the folder where you want
to store the presentation. To navigate to the folder
you want to select, click Browse.

ﬂn New project l&J
Create a new BrightSign project
Save As:  Project 2
Where:  C:\,.\BrightSign Presentations
BrightSign Model: [HDLDID '|
Connector type: [HDMI '|
Screen resolution: [lQZOxIUSUxGOi 'l
Maonitor overscan: @ No awverscan - use full screen
Overscan - action safe area
Overscan - title safe area
Create ‘ Cancel |

d Select your BrightSign Model, Connector type, and Screen resolution.

e Select a Monitor overscan setting to control how the image fills the display screen:

* No overscan: Displays images all the way to the edge of the video signal.

* Overscan action safe: Restricts the image display to an area that is compatible with

most displays.

* Overscan title safe: Restricts the image display to an area that is much smaller than the

image generated by the video signal.

2 Click the multi-zone template you want to use, and then click Choose.



4

Add your Media Library:

a On the left side of the screen, click Browse.

b Navigate to the folder where your content is stored.
¢ Click OK.

NOTE: If you have a lot of large files in your content folder, it may take a while for the thumbnail
images to appear.

G Multizone - HD1010 - BrightA

File Edit Tools Help
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Add content to each zone in your presentation:
a Click the zone you want to populate.
NOTE: Each zone has its own playlist.



b Drag items from the Media Library folders to the playlist area.
* To select a series of adjacent files, press Shift+Click as you select the files.
* To select a group of non-adjacent files, press Ctrl+Click as you select the files.

* Toarrange thefiles in the order in which you want them to play, drag the thumbnails in the
playlist area.

* To add an RSS feed, select the Ticker zone, click the RSS tab drag the New RSS Feed icon
onto the playlist, when prompted, enter the URL, and then click OK. Repeat this step to add
additional RSS feeds.

* To add a text feed, create a text file that contains the text. Insert a line break between each
text item in the text file. Save the text file and place it in your Media Library folder. Select
the Ticker zone, click the Text tab, and then drag the text file onto the playlist. Repeat this
step to add additional text files.

* To remove an item from a playlist, highlight it in the playlist area and press Delete on your
PC keyboard.

* (HD210,HD210w, HD410,HD810,HD1010,and HD1010w only) To enable the presentation
to respond to user input, see Making a presentation interactive for details.

* (HD810,HD1010,and HD1010w only) To add live video, click the Other tab on the left side
of the screen and drag the Live Video |__jiconto the playlist area.

* (HD210,HD210w, HD1010, and HD1010w only) To add SignChannel content click the
Other tab on the left side of the screen and drag the SignChannel |__jiconto the playlist
area.

* (HD210, HD210w, HD1010, and HD1010w only) To add a Dynamic Plavlist, click the Other
tab on the left side of the screen and drag the Dynamic Playlist | j icon to the playlist
area. To learn more about Dynamic Playlists, see Creating a Dynamic Playlist.

¢ Repeat steps a and b for the remaining zones.
5 (Optional) Set playback options:

* To edit settings for a single item, right-click the thumbnail in the playlist area and select Edit,
and then choose the settings you want to apply to the selected item.

* To edit settings for multiple items, press Ctrl+Click to select the items in the playlist area. On
the menu bar, click Edit > Selected Items, and then choose the settings you want to apply to
all of the selected items.



6 (Optional) Rename the playlists:
a Foreach playlist, click Edit in the upper-right corner of the playlist area.
b Enter a new name for the selected playlist.
¢ Click OK.

7 (Optional) Set zone properties. See Setting zone properties for details.

On the menu bar, click File > Save... to store your presentation.

NOTE: To save the presentation with a different name or in a different folder, select
File > Save... As. To export the presentation and associated content, select File > Export... .

9 Publish your presentation. See Publishing Presentations for details.

Making a presentation interactive

You can use BrightAuthor to make presentations interactive. Interactive presentations respond
to interactive events, such as input from buttons or other GPIO devices, or from devices
connected to a BrightSign communication port. The supported communication methods vary
by BrightSign model.

RS232 serial devices: HD410, HD810, HD1010, and HD1010w

USB devices (such as touch screens, mice, keyboards, barcode scanners, IR remote
controls): HD810, HD1010, and HD1010w (see Appendix A for remote control codes)

Ethernet devices: HD210, HD210w, HD1010, and HD1010w

1 Open a presentation project:

NOTE: /fyou haven't already created a presentation project, see Creating a full-screen
presentation or Creating a multi-zone presentation for details.

a Double-click the BrightAuthor icon on your desktop.
b Onthe menu bar, click File > Open Presentation.

(o]

Select the presentation you want to open.
Click Open.

Q.

® o 0o 0 00
=
o



2 Choose the Home screen:
The Home ) icon identifies the Home screen in your playlist. The Home screen is the first media
file (video or image) in the playlist, and it is where the presentation begins. It usually includes
either of the following:

* An attract video that loops until the user provides input
* Alist of options from which the user can choose the next action

File Edit Tools Help

Create Edit Publish
Loyout | B Playlist

Zone

|1: Video orImages -

[ VideoOrtmages

i o —
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a Click the Edit tab.

On the left side of the screen, click any zone (except a ticker or clock zone) that you want to
make interactive.

¢ Ontheright side of the playlist area, click interactive.



d Drag the media file you want to use as the first file in your presentation (Home screen) to the
playlist.

TIP: If the item you want to use as your Home screen is already in your playlist, double-click that

item to open the Media Properties window, check the Set as initial state box, and then click OK.

e Repeat steps b - d for any other zones you want to make interactive.

3 Ifyouhaven'talready done so, add media files to each of the zones in your presentation. See
Creating a full-screen presentation or Creating a multi-zone presentation for details.

4 Define interactive events:

a Inthe playlist toolbar, click the interactive event button you want to define. For example, to
define what happens when the user presses button 1 on a button board, click &3).

b Click the file name below the Home screen’s thumbnail image (the pointer becomes a hand).

¢ Drag the hand pointer to the thumbnail image of the media file you want to play when the
user presses the button you selected in step (a).

d Repeat steps a — ¢ to define the remaining interactive events. Note that subsequent
interactions can start with any item. (They don't need to start with the Home screen.)

For example, you can set the first interaction to display an image when the user presses
button 1 from the Home screen. You can set a second interaction to display a second image
if the user presses button 1 a second time while the first image is displayed.

If you don't see the button you want in the playlist toolbar, click the arrow to the left of the

Zoom control to display more toolbar buttons. You can also access Eventicons by clicking the
events tab under Media Library. However, when you use the events tab, you need to select
the next event from the Specify next state list instead of dragging to the target item.

Alternatively, you can choose to return to the prior state and play the content from the
previous action, or keep the current state after the interaction. For example, if you choose to
keep the current state, the user can press a button to adjust the volume without changing
the image.

® o 0o 0 00
=
©



TIP: You can also apply interactions to multiple items (except for touch events). To select
consecutive items, press Shift and click the first and last items. To select non-consecutive items,

press and hold Ctrl while clicking the items. To select all items, press Ctrl + A.
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Interactions can include any of the following events:

Event lcon

Description

Timeout

Displays an item for a predetermined period of time before the next action occurs
automatically. To create a Timeout event, drag the Timeout icon onto the item to which it
applies and then drag to the target item. To define the length of the timeout interval double-
click the Timeout icon below the item to open the Timeout Event window. In the Specify
timeout (seconds) field, enter the number of seconds you want the item to display, and
then click OK.

Iﬂ'p

Mediz End

Sets the action that occurs after a video or audio file finishes playing.

0

GPIO Event

Sets the action that occurs when a specific GPIO button/input is pressed or activated. By
default, the playlist toolbar includes several GPIO buttons which you can use to define
interactions. To define a GPIO interaction, click the GPIO button on the Event bar and then
drag a line from the trigger item to the target item.

Q

Synchronize

Synchronizes content with another BrightSign on the same network. To define the
connection, drag the Synchronize icon onto the item to which it applies. When the
Synchronize Event window opens, enter the trigger in the Specify synchronization
keyword field, and then click OK.

UDP Input

Sets the action that occurs when BrightSign receives input from a network device. Use this
event when you want an external device to control BrightSign using UDP (User Datagram
Protocol or Universal Datagram Protocol). To define the trigger, drag the UDP Input icon
onto the item to which it applies and then drag to the target item. When the UDP Input
Event window opens, enter the network address for the external device in the Specify UDP
input field, and then click OK.




Event Icon Description
Sets the action that occurs when BrightSign receives specific input from a device connected
o&o to the serial port. To define the input, drag the Serial Input icon onto the item to which
it applies and then drag to the target item. When the Serial Input Event window opens,
Sarial Input

enter the serial string that triggers the next event in the Specify serial input field, and
then click OK.

(s

Rectangular Touch

Sets the action that occurs when the user touches the specified rectangular area on a
touchscreen. To define the area, drag the Rectangular Touch icon onto the item to which it
applies and then drag to the target item. When the Add Touch Event window opens, drag
the box to resize the touch area (or enter the exact Size and Position). To add additional
touch regions to the selected item, click Add Touch Region, and define the parameters, and
then click OK.

Keyboard Input

Sets the action that occurs when BrightSign receives specific input from a keyboard. To
define the keyboard input, drag the Keyboard Input icon onto the item to which it applies.
When the Keyboard Input Event window opens, enter the keyboard input that triggers the
next event in the Specify keyboard input field, and then click OK.

USB Input

Sets the action that occurs when BrightSign receives input from a device connected to the
USB (Universal Serial Bus) port. To define the trigger, drag the USB Input icon onto the item
to which it applies and then drag to the target item. When the USB Input Event window
opens, enter the USB input that triggers the next event in the Specify USB input field, and
then click OK.

Remote Input

Sets the action that occurs when BrightSign receives specific input from a remote control
(Iguanaworks USB transceiver required). To define the remote input, drag the Remote Input
icon onto the item to which it applies and then drag to the target item. When the Remote
Input Event window opens, enter the remote character that triggers the next event in the
Specify remote input field, and then click OK. For more info, see Appendix A for remote
control codes.




Eventicon

Description

s

Link Zones

Synchronizes content in another zone. To define the link, drag the Link Zones icon onto the
item to which it applies. When the Link Zones Event window opens, enter the trigger in the
Specify link keyword field, and then click OK.

Video Tims Code

Performs commands at specific times during video playback. To define the commands and
times, drag the Video Time Code icon onto the video to which it applies. When the Video

Time Code Events window opens, click Add Time Code, enter the Timeout interval, select
the Command and Parameters from the corresponding lists, and then click OK.

Adding commands to your playlists

To add extended functions to your presentations, you can connect devices to the ports on your
BrightSign and then add commands to your playlist to control these devices. For example, you
can connect a projector to BrightSign's serial port and then create a playlist to turn it on and
another playlist to turn it off. You can then use the playlist scheduling feature to automatically
turn the projector on in the morning and off in the evening.

2

Open an interactive presentation project:

NOTE: Ifyou haven't already created an interactive presentation project, see Making a
presentation interactive for details.

a Double-click the BrightAuthor icon on your desktop.

b Onthe menu bar, click File > Open Presentation.

¢ Select the presentation you want to open.

d Click Open.

In the playlist area, double-click the media file to which you want to apply the command.




In the Media Properties window, click
Advanced.

Click Add Command.

Select the command you want to add
from the list and enter the appropriate
parameter for that command. The
commands vary based on the type of
content you selected and may include
any of the following:

* Set Audio Output: Specifies the type of
audio you want to use for this item.

D Media Properties lﬂhj

I ]

State name:  Attract.mpg

Current file:  Attract.mpg

Select different file: [Attractmpg = ‘ | Update ‘

Volume: 100

Set as initial state: [ Yes

) Advanced

Commands to execute when entering this state

Command Parameter |

+ ) Add Command

» Set Volume: Specifies the volume level. Enter a value between 0 and 100.

* Increment Volume: Specifies how much the volume level increases with each interaction.

* Decrement Volume: Specifies how much the volume level decreases with each interaction.

* Mute/Unmute Digital Audio: Turns digital audio output on or off.

* Mute/Unmute Analog Audio: Turns analog audio output on or off.

* Send UDP: Sends a command to the device using UDP protocols.

* Serial-send string (CR): Sends the specified string to the specified serial port. This command
adds a carrier return at the end of the string.

* Serial-send string (no CR): Sends the specified string to the specified serial port. This
command does not add a carrier return at the end of the string.

* Serial-send byte: Sends the specified byte to the specified serial port.

* Serial-send bytes (comma separated): Sends the specified bytes to the specified serial port

in comma-separated format.

* Synchronize: Specifies the synchronization trigger.

* Link Zones: Specifies the trigger to link zones.
* GPIO On: Turns on the specified GPIO outputs. Other GPIO output are not affected.




GPIO Off: Turns off the specified GPIO output.

Set GPIO Set State: Enables you to turn each GPIO line on or off.

Pause Video: Pauses video playback.

Resume Video: Resumes video playback.

Enable monitor power save mode: Turns the monitor's power saving mode on.
Disable monitor power save mode: Turns the motor's power saving mode off.
Pause: Pauses presentation playback for specified number of milliseconds.

Creating a Dynamic Playlist

A Dynamic Playlist enables you to easily update and share content in multiple presentations. For
example, you need to add daily announcements to your presentations, and you don't want to
update each presentation separately. You can add an empty Dynamic Playlist to all of your
presentations and each day insert a new video announcement in the Dynamic Playlist. When you
upload the revised Dynamic Playlist to the network, every presentation that includes the
Dynamic Playlist receives the new content, so a single update reaches multiple presentations. To
use Dynamic Playlists, you must have a BrightSign Network account.

1 Open a presentation project:

NOTE: Ifyou haven't already created a presentation project, see Creating a full-screen
presentation or Creating a multi-zone presentation for details.

a
b

o n

Double-click the BrightAuthor icon on your desktop.
On the menu bar, click File > Open Presentation.
Select the presentation you want to open.

Click Open.
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Click the Create tab.

Add media files to your Dynamic Playlist by dragging files from the Media Library folders to
the playlist area (see Creating a full-screen presentation or Creating a multi-zone
presentation for details).

On the menu bar, click File > Save... to store your Dynamic Playlist.

NOTE: To save the Dynamic Playlist with a different name or in a different folder, select
File >Save... As.

Click Upload to network (in the upper-right corner) to upload your Dynamic Playlist to the
BrightSign Network server. (If prompted, enter your Account, User name, and Password, and
then click Sign In.)
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Chapter 3
Publishing Presentations

After you create and save a presentation, you're ready to publish it and play it on your BrightSign.
There are three ways to publish a presentation:

* Local Storage

* BrightSign Network

» Simple File Networking

The following sections describe each of these publication methods.

Publishing a presentation using Local Storage

Publishing a presentation using Local Storage enables you to copy your presentation to an SD
card or USB Flash card which you can insert directly into your BrightSign. A BrightSign account is
not required. When you want to change or replace your presentation, you must save a copy of
the new presentation on an SD card or USB Flash card and insert it into your BrightSign.

1 Open the presentation project you want to publish:
a Double-click the BrightAuthor icon on your desktop.
b Onthe menu bar, click File > Open Presentation.
¢ Select the presentation you want to open.
d Click Open.



2 Select the presentation you want to publish:

a
b

C

d

File Schedule

Click the Publish tab on the upper-left side of the screen.
Click Local Storage (below the Publish tab).

Under Presentations, click Browse, select the folder where your presentations are located,
and then click OK.

Select the presentation(s) you want to publish from the list of presentations.

Edit Tools Help.

BrightAuthor

Presentations

CalUsers\Noam Levi\Documents

[Project 1

Firmware

(@ Production Release : Version 3,5.68
) Beta Release s Version 3568

) Minimum Compatible Release : Version 3.5.68
1) Select specific file

® Do not update
Publish to.

F\




3 Create a schedule for the presentation.

a

b

Drag the presentation(s) to the time slots during which you want them to play. To play a
presentation 24 hours a day, drag the presentation onto the schedule, double-click the
presentation, select Active all day, every day, and then click OK.

If prompted, indicate whether you want to replace the existing schedule and then click OK.

TIP: To change the date, use the controls above the calendar grid.

4 Publish the presentation on your SD card:

a
b

C

Insert an SD card into your card reader.

(Optional) Under Firmware, select an update option.

Under Publish to, click Browse, select the drive where your SD card is located, and then

click OK.
Click Publish.

When the Publish complete message appears, click OK.

Browse For Folder

[S=5c)

Select the presentation target folder

B Patty
+ . Public
4 M Computer
- &, Local Disk (C3)
- —a Data (D)
- —a LEXAR (2GB) (E:)

- 188 My Sharing Folders
- F Network
. [E Contral Panel

- &% DVD RW Drive (F) Nov 24 2008 d2

m

| Make MNew Folder | [ oK

] | Cancel

R Publish =]

Publish complete

CK Cancel |
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Publishing a presentation using BrightSign Network

Publishing a presentation using BrightSign Network enables you to distribute your presentation
to your BrightSign units via an Internet connection. To publish via BrightSign Network, you must
first contact BrightSign to obtain an account name, a user name, and a password. You must also
upload your presentation to the BrightSign Network server and then add your BrightSign units
to your network (see Adding BrightSign units to your BrightSign Network).

1 Open the presentation project you want to publish:
a Double-click the BrightAuthor icon on your desktop.
b Onthe menu bar, click File > Open Presentation.
¢ Select the presentation you want to open.
d Click Open.
2 Upload your presentation to the BrightSign Network server:
a Onthe menu bar, click Tools > Sign In to BrightSign Network.
b If prompted, enter your Account, User name, and Password, and then click Sign In.
¢ Onthe Edit tab, click Upload to network (in the upper-right corner).
d When the upload is complete, click OK.
3 Select the group and presentation you want to publish:
a Click the Publish tab on the upper-left side of the screen.
b Click BrightSign Network (above the calendar).

¢ Under Select Group to Schedule, select the group to which you want the presentation
to belong. For details on setting up groups, see Creating groups in your BrightSign
Network.

d Under Presentations, select the presentation you want to publish.
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File Edit Tools Help

BrightAuthor
Publish
Lacal Storage ® BrightSign Network Simple File Network
Select Crojpdoschedile Week of 6/19/2011
= -
Sun, 6/19 Mon, 6/20 Tue, 6/21 ‘Wed, 6/22 Thu, 6/23 Fri, 6/24 Sat, 6/25
‘ non-stop
8am
7) Production : Version 3.5.58
= 9am
) Beta : Version 3.5.68
7' Minimum : Version 3.5.68 20am
® Do not update
Publish Schedule 11am

4 Create a schedule for the presentation.

a Drag the presentation(s) to the time slots during which you want them to play. To play a
presentation 24 hours a day, drag the presentation onto the schedule, double-click the
presentation, select Active all day, every day, and then click OK.

b If prompted, indicate whether you want to replace the existing schedule and then click OK.
TIP: To change the date, use the controls above the calendar grid.
5 Publish the presentation:
a (Optional) Under Firmware, select an update option.
b Click Publish Schedule.
¢ When the Publish complete message appears, click OK.



Publishing a presentation using Simple File Networking

Publishing a presentation using Simple File Networking enables you to distribute your
presentation to your BrightSign units via a web folder. To use Simple File Networking, you must
first add each unit to your network (see Adding BrightSign units to your Simple File Network).

1 Open the presentation project you want to publish:
a Double-click the BrightAuthor icon on your desktop.
b On the menu bar, click File > Open Presentation.

N

Select the presentation you want to open.
d Click Open.

2 Select the presentation you want to publish:
a Click the Publish tab on the upper-left side of the screen.
b Click Simple File Networking (above the calendar).

¢ Under Presentations, click Browse, select the folder where your presentations are located,
and then click OK.

d Select the presentation(s) you want to publish.
3 Create a schedule for the presentation.

a Drag the presentation(s) to the time slots during which you want them to play. To play a
presentation 24 hours a day, drag the presentation onto the schedule, double-click the
presentation, select Active all day, every day, and then click OK.

b If prompted, indicate whether you want to replace the existing schedule and then click OK.
TIP: To change the date, use the controls above the calendar grid.
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File Schedule Edit Tooks Help

Local Storage

Presentations

v
CAUsers\Nearn Levi\Documents
Projec

7 Broduction Release : Version 3.5.68

) Beta Release : Version 2.5.68

) Minimum Compatible Release : Version 3.5.68
() Select specific file

@ Do not update
Simple File Networking Parameters
Publish to

BrightAuthor

Brightsign Network | ® Simple File Network

Tue, 6/21 Wed.

a IIIIIII

4 Publish the presentation:

a (Optional) Under Firmware, select an update option.
b Click Set Parameters.

¢ Under Unit Configuration, enter the URL for the web folder.

IMPORTANT: The Web folder URL must be identical to the URL you entered when you set up your
Simple File network. See Adding BrightSign units to your Simple File Network for details.

d (Optional) Under Logging, check any of the following boxes to create the selected type of
logs and to specify upload settings, and then click OK:

* Enable playback logging: Creates a log that specifies when a playlist was used.
* Enable event logging: Creates a log that specifies when events are triggered.

* Enable diagnostic logging: Creates a log that provides troubleshooting information.
* On startup: Uploads log files each time you start the unit.



* At specific time each day: Uploads log files daily at the specified time.
* Relative URL for log handler: Uploads log files to this location.

Under Publish to, click Browse, select the location where you want to store the files, and
then click OK.

* If you have a mapped drive or shortcut that points to your web folder, publish your
presentation to that location.

* If you use FTP to transfer files to your web folder, publish your presentation to a folder on
your computer and then use FTP software to copy the files to your web folder.

Click Publish.
When the Publish complete message appears, click OK.

<33



Chapter 4
Setting Up Units

If you're using BrightSign Network or Simple File Networking to publish your presentations, you
must set up your BrightSign units by adding them to your network. You can also set up units for
use as standalone units that are not connected to a network. The following sections describe
how to add units to your network or set them up for standalone use.

Adding BrightSign units to your BrightSign Network

To publish and manage presentations using BrightSign Network, you must first contact
BrightSign to obtain an account name, user name and password. After you obtain your account
credentials, you need to add your BrightSign units to your network by creating and installing a
setup file for each unit. The setup file provides details about your network and BrightSign
Network connections, where the presentations associated with the selected group are stored,
and when to run the presentations.

1 Sign in to your BrightSign Network account:
a Onthe menu bar, click Tools > Sign In to BrightSign Network.
b If prompted, enter your Account, User name, and Password, and then click Sign In.

2 Onthe menu bar, click Tools > Setup BrightSign Unit.

3 Under Name Specification, do the following:
a Enter a Name and Description for this unit.
b Select whether you want to append the unit ID to the name or to use the name only.
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D BrightSign Urit Setup

Name Specification Firmware

Logging
Mame: () Production Release : Version 3.5.68 [] Enable playback logging
() Bata Release : Version 3568 [ Enable event logging |
Desctiption @ Minimum Compatible Release : Version 3.5.68 [¥] Enable diagnostic logging
Coistarization () Select specific file Upload logs I
2 Use name only Browss -
© Append unit ID © Do not tpdate 21 On startup

[T At specific time each day

Network Properties Unit Configuration | i
Time server.  timebrightsignnetwork.com 8! Metworked with the BrightSign Network fiiative Uk e log isadlers ey Yogfiandicesip)
Group: | Default 5 . -

@ Obtain an IP address automatically Netwark Connection Frequency:
) Use the following IP address:

1P Address: Connect to Server: | Every 5 minutes ,|

Subnet mask; | [T] Limit content downioads
Default gateway: | Start of range: (00 ~ | * |00
Broadcast: End ofrange! (00 - | |00
DNS L
DNS 2: | | Content:
NS 3 : [7] Copy content from the current published schedule
) 1.2 Networked with Simple File Netwarking
[ Wied
SSID:
Security key:

Creste Setup files | | Cancel. |

4 Under Network Properties, set the following:
* Time zone: Select the time zone where this unit is located.
* Time server: Select the clock for this unit.

* IP address: Indicate whether the IP is auto-generated or static. If you're using a static IP
address, enter parameters.

* Wired/Wireless: Indicate whether the network is wired or wireless and enter the SSID and
Security key if the network is secured.

5 Under Firmware, indicate whether you want to update the firmware and to which version.



Under Unit Configuration, click Networked with BrightSign Network, and then specify
the following:

Group: Assigns this unit to the specific group in which you published the presentation (see
Creating groups in your BrightSign Network and Publishing a presentation using
BrightSign Network).

Network Connection Frequency: Sets how often this unit checks the server for updates.

Limit content downloads: Sets a timeframe during which downloads can take place.

Copy content from the current published schedule: Copies content from the current
published schedule to your storage card. Use this option to reduce initial download time
when setting up a unit.

Under Logging, check any of the following boxes to create the selected type of logs and to
specify upload settings:

Enable playback logging: Creates a log that specifies when a playlist was used.
Enable event logging: Creates a log that specifies when events are triggered.
Enable diagnostic logging: Creates a log that provides troubleshooting information.
On startup: Uploads log files each time you start the unit.

At specific time each day: Uploads log files daily at the specified time.

Create and install the setup file:

a
b
4
d

Click Create Setup Files.

Select an SD or SDHC card or a USB Flash drive to store the setup files.
Turn off the BrightSign unit and insert the card or Flash drive into the unit.
Turn on the BrightSign unit.

If the unit is connected to the network and you've already scheduled and published
presentation(s) for this unit, the unit retrieves the presentation(s) and displays them at the
scheduled time.
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Adding BrightSign units to your Simple File Network

To publish and manage presentations using Simple File Networking, you must first add your
BrightSign units to your network by creating and installing a setup file for each unit. The setup

1

file provides details about your network, the web folder associated with a unit, where
presentations are stored, and when to check for updates.

On the menu bar, click Tools > Setup BrightSign Unit.

2 Under Name Specification, do the following:

a Enter a Name and Description for this unit.

b Select whether you want to append the unit ID to the name or to use the name only.

URL for web folder: (e.g., http//www.brightsign.com/files/)
'@ Obtain an IP address automatically

") Use the following TP address: .
Network Connection Frequency:

P Address:
Connect to Server: [EvasySmmu{as—v|
Subnet mask: = -
Default gateway: [T Limit cantent downloads
Broadcast: Start of range: | 00 |00
el s End ofrange: |00 ~ |7 (00
DNS 2«
DNS 3:
[ Wired ~|
SSID:
Security key:

& RrightSign Unit Setup. L=l
Name Specification Firmware Logging
Name: (2 Production Release : Version 3.5.68 7] Enable playback logging
é . () Beta Release ; Version 3.5.68 [ Enable event lagging
ription: =
R * Selact specific file 7] Enable diagnostic logging
Customization: Browse | e
2 . LENEE pload logs
) Use name only @ D ot update
@ Append unit ID | On startup
Unit Configuration At specific time each day
Network Properties =
(7 Standalone el = s
[7' pload time; |00 ik ]
Time zone: EST: US Eastern Time ‘ ! Networked with the BrightSign Netwark
Timeserver  timebrightsignnetwork.com @ Networked with Simple File Networking i Relative URL for log handler: (e.g, loghandier.php)

Create Setup files | [ Cancel




Under Network Properties, set the following:

Time zone: Select the time zone where this unit is located.
Time server: Select the clock for this unit.

IP address: Indicate whether the IP is auto-generated or static. If you're using a static IP
address, enter parameters.

Wired/Wireless: Indicate whether the network is wired or wireless and enter the SSID and
Security key if the network is secured.

Under Firmware, indicate whether you want to update the firmware and to which version.

Under Unit Configuration, click Networked with Simple File Networking, and then
specify the following:

URL for the web folder: Sets the location from which this unit downloads presentations. Do
not use trailing slashes in your URL; some web servers do not support trailing slashes.

IMPORTANT: The URL for the web folder must be identical to the Web folder URL you enter when
you publish your presentation (see Publishing a presentation using Simple File Networking).

Network Connection Frequency: Sets how often this unit checks the web folder for updates.
Limit content downloads: Sets a timeframe during which downloads can take place.

Under Logging, check any of the following boxes to create the selected type of logs and to
specify upload settings:

Enable playback logging: Creates a log that specifies when a playlist was used.
Enable event logging: Creates a log that specifies when events are triggered.
Enable diagnostic logging: Creates a log that provides troubleshooting information.
On startup: Uploads log files each time you start the unit.

At specific time each day: Uploads log files daily at the specified time.

Relative URL for log handler: Uploads log files to this location.
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7 Create and install the setup file:
a Click Create Setup Files.
b Select an SD or SDHC card or a USB Flash drive to store the setup files.
¢ Turn off the BrightSign unit and insert the card or Flash drive into the unit.
d Turn on the BrightSign unit.

If the unit is connected to the network and you've already scheduled and published
presentation(s) for this unit, the unit retrieves the presentation(s) and displays them at the
scheduled time.

Setting up BrightSign units for standalone use

To publish and manage presentations for standalone use, you must create and install a setup file
for each unit. The setup file provides details about where presentations are stored and whether
logging options are enabled.

On the menu bar, click Tools > Setup BrightSign Unit.
2 Under Name Specification, do the following:

a Enter a Name and Description for this unit.

b Select whether you want to append the unit ID to the name or to use the name only.
3 Under Network Properties, set the following:

* Time zone: Select the time zone where this unit is located.

* Time server: Select the clock for this unit.

 IP address: Indicate whether the IP is auto-generated or static. If you're using a static IP
address, enter parameters.

Under Firmware, indicate whether you want to update the firmware and to which version.
Under Unit Configuration, click Standalone.



6 Under Logging, check any of the following boxes to create the selected type of logs:
* Enable playback logging: Creates a log that specifies when a playlist was used.
* Enable event logging: Creates a log that specifies when events are triggered.
* Enable diagnostic logging: Creates a log that provides troubleshooting information.

@ siansion o5t |

Name Specification
Name:
Description:

Customization:

B thenamely
@ Append unit ID

Network Properties
Time zone: | PST: US Pacific Time |

Timeserver:  timebrightsignnetwork.com

Firmware
(2 Production Release : Version 3.5.68
(7 Beta Release : Version 3.5.68
@ Minimum Compatible Release : Version 3.5.68
(7 Select specific file
| Browse ‘

) Do not update

Unit Configuration
@' Standalone
() Networked with the BrightSign Network

Logging
7] Enable playback logging
[ Enable event logging
[¥] Enable diagnostic logging

Uplasd logs

On startup

At specific ime each day
Upload time: (00 ~ | ¢ |00

Relative URL for log handler: {e.g, loghandler.php)

| 1) Metworked with Simple File Networking
'@ Obtain an IP address automatically
_ Use the following IP address:

IP Address:
Subnet mask:
| Default gateway:
Broadcast:
DNS 1:
DNS 2:
DNS 3:
[ wired |
SSID:

Security key:

Create Setup Files | | Cancel

7 Create and install the setup file:
a Click Create Setup Files.
b Select an SD or SDHC card or a USB Flash drive to store the setup files.
¢ Turn off the BrightSign unit and insert the card or Flash drive into the unit.
d Turn on the BrightSign unit.
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Chapter 5
Customizing Presentations

Setting zone properties

Whether you're creating a full-screen presentation with a single zone or a multi-zone
presentation, you can customize the settings for each zone in your presentation as
described in this section. For information about changing the default zone settings,
see Setting default properties.

1 Open a presentation project:

NOTE: If you haven't already created a presentation project, see Creating a full-screen
presentation or Creating a multi-zone presentation for details.

a Double-click the BrightAuthor icon on your desktop.

b On the menu bar, click File > Open Presentation.

¢ Select the presentation you want to open.

d Click Open.

In the upper-left corner, click the zone for which you want to change the properties.
Click Zone Properties.

Set any of the following:

NOTE: The settings vary based on your BrightSign model and the type of zone you selected.
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View Mode D toit zone |
* Scale to Fit: Scales the video to fill the screen
without maintaining the aspect ratio. Images may

View Mode: [ScaletoF\II '|

appear Stretched_ Image Mode: [Scaleto Fit v|
LiveVideo
* Letterboxed and Centered: Centers theimage and put [svideo 7]
adds black borders. The aspect ratio is maintained. Video Standarct (NTSCM________ |

Brightness: 128

* Fill Screen and Centered: Centers the image and

Contrast: 64

fills the screen. The aspect ratio is maintained. a0

Image Mode il
* CenterImage: Centers the image without scaling ok ([ Concel ]

(may result in cropping if the image is larger than
the current videomode resolution).

* Scale to Fit: Scales the image to fit the display. The whole image is displayed as large as
possible with correct aspect ratio.

* Scale to Fill and Crop: Scales the image to fill the display while maintaining aspect ratio.
* Scale to Fill: Scales the image to fill the screen without maintaining aspect ratio.
Live Video

Sets attributes for a live video feed. You can select the Input and Video Standard types and enter
parameters for Brightness, Contrast, Saturation, and Hue.

Number of Lines
Sets the number of lines of text in a Ticker zone.

Time to Display Each Line
Sets how long each line of text displays in a Ticker zone.

Rotation
Sets the angle of the text in a Ticker zone.

Alignment
Sets whether the text is left aligned, right aligned, or centered in a Ticker zone.



Text Appearance

Sets whether the text is animated or static in a Ticker zone.

Foreground Text Color
Sets the text color in Ticker or Clock
zones.

Background Text Color
Sets the color of the background behind
the text in Ticker or Clock zones.

Transparency
Sets the transparency of the text in
Ticker or Clock zones.

Font

Sets the font of the text in Ticker or
Clock zones. You can use any TrueType
font.

Background Bitmap

G Edit Zone

Number of Lines:

Time to Display Each Line:

Rotation:

Alignment:

Text Appearance:

Foreground Text Color:

Background Text Color:

Transparency:

Font:

w | Advanced

¥ x g |

3

5

0 degrees - |
Leftaligned ~ |
9 Animated Static Text
Choose |
Example R55 Text
Shows Colors El
oose

0% (100% is fully transparent)

[ Browse |[ Reset to System Font |

System

CK | Cancel |

Adds the specified file as a background image. You can add a background bitmap to Ticker or

Clock zones. You can also indicate whether you want to stretch the image to fill the zone region.

Safe Text Region

Defines the location and size of the text region within the zone.




Setting presentation properties

Presentation properties apply to your entire presentation. The default settings are based on your
current default property settings (see Setting default properties).

1 Open a presentation project:

NOTE: /f you haven't already created a presentation project, see Creating a full-screen

presentation or Creating a multi-zone presentation for details.

a
b
c
d

Double-click the BrightAuthor icon on your desktop.
On the menu bar, click File > Open Presentation.
Select the presentation you want to open.

Click Open.

On the menu bar, click File > Presentation Properties.

Click the Main tab and set any of the following:

Connector type: Indicates the type of display that is
connected to the BrightSign on which you want to run the
presentation: VGA, HDMI, or Component.

Screen resolution: Sets the display resolution. Choose a
resolution that is compatible with the display that is
connected to your BrightSign.

RSS Update Frequency: Sets how often BrightSign checks
for RSS feed updates.

Background screen color: Sets the backdrop color for your
sign. Click Choose, select a color, and then click OK.

Language: Sets the date and time format in the Clock zone.

4 C(lick the I/0 tab and click Input or Output next to each
GPIO port to indicate whether the port is sending or
receiving information.

r ~
ﬂb Presentation Properties [&J

Main | /O | Interactive | Autorun

Connector type: [HOMI - |
Screen resolution: |1920x1080x60p ~ |
RSS Update Frequency: |Every 24 hours ~ |

Background screen color: . Choose |

Language: .English v|

Cancel |

r ~
ﬂb Presentation Properties [iE-J

Main | 'O

GPIO 0:
GPIO 1:
GPIO 2:
GPIO 3:
GPIC 4
GPIO 5:
GPIO 6:
GPIO 7:

GPIC Configuration

o)

Interactive | Autorun

9 Input Output
9 Input Output
9 Input Output
9 Input Output
9 Input Output
9 Input Output
@ Input Output

9@ Input Output




Click the Interactive tab and set any of the following:

* Serial: Sets the parameters for serial communications.
You can enter the following settings for multiple serial
ports: Port (number), Baud rate, Data bits, Parity, and
Stop bits. Note that the standard port is port 0 and the 5v
TTL port is port 1.

* UDP: Sets the parameters for UDP communications. You
can specify the UDP Destination Address (in dotted quad
form), the UDP Destination Port, and the UDP Receiver
Port.

¢ Touch: Cursor sets whether the cursor is hidden, visible, or
present only if there is more than one touch region on the
screen. Flip Coordinates reverses the coordinates of the
touch screen. Use this option only if the touch screen
coordinates appear to be reversed.

Click the Autorun tab and click Standard Autorun or

Select custom Autorun to select the Autorun file for the

presentation.

Click OK.

ﬂb Presentation Properties [iz-,l

Main | /O | Interactive |Autorur1

Serial

Port0 ~
Baud rate: (115200 |
Databits: (8 ~]
Parity: [none _ ~|
Stopbits: (1 ~]

uoP
UDP Destination Address:  235.255.2535.255

UCP Destination Port: 21075
UCP Receiver Port: 21075

Touch
Cursor
Always hide cursor
Always display cursor
9@ Auto display cursor

Flip Coordinates

OK Cancel |




Customizing template layouts
If the predefined template layouts do not meet your e ——

needs, you can create your own templates.

1 Create a new presentation project:

a

b

TIP: If you do not see the Create a new BrightSign project
window, do the following to open it: on the menu bar,

C/ICk Fi’e > NeVV. Qverscan - action safe area
Overscan - title safe area
¢ Inthe Wherefield, enter the folder where you want to [ ] (o

2 C(lick the template that is most similar to the layout you want to use, and then click Choose.

Create a new BrightSign project

Save As:  Project 2
Double-click the BrightAuthor icon on your desktop. || ... c. snsen sresension

In the Create a new BrightSign project window,
enter a name for the presentation in the Save As field.

BrightSign Model: [HDLOIO V‘

Connector type: [ HDMI A ‘

Screen resolution: [iBZOxlUSUxGOi "

Monitor overscan: @ Mo overscan - use full screen

store the presentation. To navigate to the folder you
want to select, click Browse.

Select your BrightSign Model, Connector type, and Screen resolution.

Select a Monitor overscan setting to control how the image fills the display screen:
* No overscan: Displays images all the way to the edge of the video signal.

* Overscan action safe: Restricts the image display to an area that is compatible with
most displays.

* Overscan title safe: Restricts the image display to an area that is much smaller than the
image generated by the video signal.

3 Click Layout (below the Edit tab) and do any of the following:

Resize a zone by clicking the zone and then dragging the selection handles, or enter the Size
and Position information on the left side of the screen.

Make two or more zones the same size by pressing Ctrl+Click to select the zones you want to
resize. On the menu bar, click Format > Make Same Size and then select a resize option.

Align two or more zones by pressing Ctrl+Click to select the zones you want to align. On the
menu bar, click Format > Align and then select an alignment option.



File Edit Format Tools Help

BrightAuthor

4] Clock

3] ap1 |

T video orImages

+' Add Zone

Monitar Overscan

- full screen
safe area

Images ] Ticker 1 Clock [E Video /Images . [l Video Cnly J Background

* Center a zone on the screen by clicking the zone you want to center. On the menu bar, click
Format > Center in Form and then select Horizontally or Vertically.

* Remove an unwanted zone by clicking the zone and then pressing Delete on your keyboard.

* Add azone by clicking Add Zone, entering a Zone name, selecting the Zone Type, and then
dragging the rectangle to the appropriate size and location.

* Rename a zone by entering a new label in the Name field on the left side of the screen.

TIP: You can place an Image zone, a Ticker zone, or a Clock zone on top of a Video Only zone. You
can then use the transparency settings in the Ticker or Clock zone to control how much of the
underlying video is visible. Note that you cannot place zones on top of a Video or Images zone.

Click Save Template (in the bottom of the left pane), enter a name for the template, and
then click OK.



Setting default properties

When you create or add to a presentation project, the initial settings are based on the default
properties. If you often use the same set of properties, you can streamline the development
process by changing the default property settings to match the settings you use most often.

NOTE: Changing the default properties does not change an existing presentation. To modify
presentation, zone, or item properties, open the presentation and then change and save the new
settings.

On the menu bar, click Edit > Preferences.

2 CliCk the Sign tab and SeleCt the defaUIt Sign _ngn_'\.-'ldeollmageszlck.eri Clock | Interactive |' MNetworking !
settings: I
RSS Update Frequency: |Er).l 24 hours = |
RSS Update Frequency Time zone: EST: US Esstern Time ~

Sets how often RSS feeds are updated.
Background screen color: . Choose

Time zone
Sets the default time zone for presentation | - GPIO Configuration
ScheduleS. GPIO0: @ Input ) Output
GPIOL: @ Input ) Qutput
Background screen color GPIOZ ® Input ©) Output
Sets the default background color. Click Choose, GPIO3: ® Input © Output
select a color, and then click OK. GPIO4: @ Input ) Output
. . GPIO5: @ Input () Qutput
GPIO Configuration GPIOG: ® Input ) Output
Sets whether each of the GPIO ports is an input port GPIO7: @ Input © Output

or an output port. = ————
putp ok || Cancel




3 Click the Video tab and select the default video Sign | Video [images | Ticker | Ciock | interactive | Networking
settings: View Mode: | Letterboxed and Centered = |
NOTE: The settings vary based on your BrightSign model. | auio output [ansleg Audio -]
View Mode Audio Mode: [ Multichannel Suround =
* Scale to Fill: Scales the video to fill the screen Volume: |10
without maintaining the aspect ratio. Images may T )
appear stretched. Video Standard: [NTSCM. 7]
* Letterboxed and Centered: Centers the image and Brightness: 128
adds black borders. The aspect ratio is maintained. Contrast: 64
* Fill Screen and Centered: Centers the image and Saturation: | 4
fills the screen. The aspect ratio is maintained. . *W f"ac
Audio Output e s 0
Sets the destination for audio content. = —
Audio Mode

Sets whether audio content is set to play in stereo, surround sound, or not at all.

Volume
Sets the volume level by specifying a value between 0 and 100. 100 is full volume.

LiveVideo
Sets the default attributes for live video feeds. You can select Input and Video Standard types and
enter parameters for Brightness, Contrast, Saturation, Hue, Volume, and Time on Screen.

4 Click the Images tab and select the defaultimage
settings:

| Sign j.\."ideo_l Images i Tick.er; Clack Ir Interactive i Networking .

Image Mode: |_5caie to Fit v|

Image Mode

* Centermage: Centers the image without scaling
(may result in cropping if the image is larger than
the current videomode resolution). ook [ Coneet |

* Scale to Fit: Scales the image to fit the display.
The whole image displays as large as possible with correct aspect ratio.

* Scale to Fill and Crop: Scales the image to fill the display while maintaining aspect ratio.
* Scale to Fill: Scales the image to fill the screen without maintaining aspect ratio.

Slide Transition: | No effect ! |

Slide Delay Interval: 3

® o 0o 0 00
I
©



Slide Transition
Sets the effect between images.

Slide Delay Interval
Sets the how long each image displays.

Click the Ticker tab and select
the default ticker settings:

?-Sign"i \."ideo.i.lmages.i Ticker | Clock"gulnteradive |' MNetworking !

Number of Lines: B

Number of Lines

Sets the number of lines of textin a Tt e T line: (2

TICker Zone. Rotation: |D degrees '|
Time to Display Each Line Abgnment: |{ehaliapedas)

Sets the how long each line of text Text Appearance; | @ Animated © Static Text

displays in a Ticker zone.

Foreground Text Color: Example RSS Text

Shows Colors

ROtation Background Text Color: | Ehoose |
Setstheangle of the textin a Ticker i
Transparency: 0% {100% is fully transparent)

zone.

. Font:  System | Browse | | Reset to System Font |
Alignment

. | [ » ) Advanced

Sets whether the text is left
aligned, right aligned, or centered [oc J[ concel

in a Ticker zone.

Text Appearance
Sets whether the text is animated or static in a Ticker zone.

Foreground Text Color
Sets the text color in Ticker zones.

Background Text Color
Sets the color of the background behind the text in Ticker zones.

Transparency
Sets the transparency of the text in Ticker zones.

eeeoceooe
[8)]
o



Font
Sets the font of the text in Ticker zones. You can use any TrueType font. Click Browse to select a
font. Click Reset to System Font to make the current font the default system font.

Background Bitmap

Adds the specified file as a background image. You can add a background bitmap to Ticker zones.

You can also indicate whether you want to stretch the image to fill the zone region.

Safe Text Region
Defines the location and size of the text region within the zone.

Click the Clock tab and
select the default clock

Sign | Video | Images | Ticker | Clock | Interactive | Networking

settings: Language: v
Language Foreground Text Color: E?::t‘gﬁufvsss
Sets the date and time '
Background Text Color: Colors
format. Select a language
to use a predefined format. Transparency | 0% (100% is fully transparent)
p —
To CUStO.I’nIZG a format, click Font: | System ’ Browse ] ’ Reset to System Font ]
Customize, enter the +) Advanced
settings you want to use,
and then click OK.

Foreground Text Color
Sets the text color in Clock zones.

Background Text Color
Sets the color of the background behind the text in Clock zones.

Transparency
Sets the transparency of the text in Clock zones.

Font
Sets the font of the text in Clock zones. You can use any TrueType font.



Background Bitmap

Adds the specified file as a background image. You can add a background bitmap to Clock zones.

You can also indicate whether you want to stretch the image to fill the zone region.

Safe Text Region

Defines the location and size of the text region within the zone.

Click the Interactive tab and set any of the
following:

Timeout Event
Sets the default value for how long an item displays
before the next action occurs.

Serial

Sets the default parameters for serial
communications. You can select the Port (number),
Baud rate, Data bits, Parity, and Stop bits.

ubpP

Sets the default parameters for UDP
communications. You can specify the UDP
Destination Address (in dotted quad form), the UDP
Destination Port, and the UDP Receiver Port.

Touch

Cursor sets whether the cursor is hidden, visible, or
presentonly if there is more than one touch region on
the screen. Flip Coordinates reverses the coordinates
of the touch screen. Use this option only if the touch
screen coordinates appear to be reversed.

?-Sign"i \.-'ideo.i.lmagesug.;ﬁck.er-: Clock.i Interactive | Networking !

|~ Timeout Event

Default timeout value:

Serial

Port: |G >

Baud rate: [ 115200 = |

Data bits: |8 -

Parity: | AoRe . ¥

Stop bits: |1 -

| “UDP

UDP Destination Address:

p

255.255.255.255

UCP Destination Port:

UDP Receiver Port:

Touch

Cursor
! Always hide cursar

! Always display cursor

@ Auto display cursor

[Z1 Elip Coardinates

[ ok ][ cancel




8 Click the Networking tab to enable and disable
BrightSign Network and Simple File Networking
settings. When these networking settings are
disabled, you cannot see network options on
BrightAuthor screens.

9 Click OK.

| Sign j.\."ideo. ] Images Ir Ticker ; Clack Ir Interactive | Networking

|#] Enable BrightSign Network
|#] Enable Simple Networking

| Cancel




Chapter 6
Managing Your BrightSign Network

Viewing unit status on your BrightSign Network

Viewing network status enables you to see unit activation status, the group to which the unit is
assigned, and which presentations are associated with that unit.

1 Signinto your
BrightSign Network D ——
aCCOUHt: i i Manage "g t Ut or

» Status Presentations Library Dynamic Playfist

a Onthemenu bar,
click Tools > Sign In

Status

Status Group

~ ) farm-5

to BrightSign
Network.

b If prompted, enter J
your Account, User
name, and
Password, and then
click Sign In.

2 C(lick the Manage tab
on the upper-left side
of the screen.

v jd4

v | farm-2
¥ ddr
v jd2
v jdg
v jd9
v d7

‘ MewFarmal |
NewFarm4] |
N
feomt ]

v jds

¥ jd1

~ farm-3

2
2
2
1
it
1
1
1
1
1
i
1



Click Status (below the Manage tab).
Click a group to view details for current presentations in that group.

Right-click a presentation within a group and then click Download Progress to view
whether all files have been fully downloaded.
(Optional) Sort the Status view by clicking the column you want to use as the sort criteria.

For example, to sort by Status, click the Status column. To switch between ascending and
descending order, click Status again.

NOTE: When a presentation is active, you cannot delete it. You can, however, delete presentations
that are not scheduled to run in the future and were not scheduled to run in the past 24 hours.

Creating groups in your BrightSign Network

A W N =

Groups enable you to test your presentation and then distribute them to a specific set of
BrightSigns. For example, you can create groups based on the region or department in which the
BrightSigns reside.

BrightAuthor includes two default groups: Default and LocalTest. LocalTest is the group you use
to test your presentations on your local network.

Click the Manage tab on the upper-left side of the screen.

Click Status (below the Manage tab).

Click Add Groups (in the lower-left corner of the screen).

Enter the name of the group you want to add, and then click OK.

e0o 0000
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Viewing presentation status on your BrightSign Network

4
5

Viewing presentation status enables you to see which presentations you've uploaded to your
BrightSign Network, which presentations are active, and when presentations were last modified.

Sign in to your BrightSign Network account:

a Onthe menu bar, click Tools > Sign In to BrightSign Network.

b If prompted, enter your Account, User name, and Password, and then click Sign In.
Click the Manage tab on the upper-left side of the screen.

Click Presentations (below the Manage tab).

BB Project 2 - HD1010 - BrightAuthar
Fle Edit Tools Help

BrightAuthor

Manage

Status . B Preseniations Library Dynamic Playfist

Presentations

Active & Name Date modified

@ ¥ | NewFarm4]

@ ¥ | jdAttract

W ¥ | smallFarm

< v farm-1
¥ NewFarm4
¥ NewFarm1l
¥ | NewFarm3I
¥ | MewFarm2l
~ | NewFarm1 10/5/2010 10:11:20 AM
v farm-2 12/22/2009 10:10:56 AM
~ | NewFarm2 2010 10:30:31. AM
¥ | NewFarm5 10/5/2010 2:36:42 PM
¥ | NewFarm3 10/5/2010 10:32:50 AM

Click a presentation to view which groups are currently using the presentation.

(Optional) Sort the Presentation view by clicking the column you want to use as the sort
criteria. For example, to sort by Name, click the Name column. To switch between ascending
and descending order, click Name again.

NOTE: When a presentation is active, you cannot delete it. You can, however, delete presentations
that are not scheduled to run in the future and were not scheduled to run in the past 24 hours.



Viewing your library on your BrightSign Network

Viewing your library enables you to see the content you've uploaded to your BrightSign Network.

1 Sign in to your BrightSign Network account:
a Onthe menu bar, click Tools > Sign In to BrightSign Network.
b If prompted, enter your Account, User name, and Password, and then click Sign In.
Click the Manage tab on the upper-left side of the screen.
Click Library (below the Manage tab).

File Edit Tools Help

BrightAuthor

Create Edit Publish Manage

Status Presentations | # Library Dynamic Playlist | Refresh |

Library El=]

) o) He
N N e
273 Konekt1811 G |22 2510T-31181000 |22 2510T-211809,0000 | 262 23107111808 A G 273 Hors-2118020)
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4 Do any of the following:

* Identify which items are currently in use in a presentation. A green checkmark indicates
the item is in use. You cannot delete an item when it is in use.

* Switch between thumbnail and list view. Click the icons in the upper-right part of the
screen.



* View item info. Right-click an item and select Info to see the file size, type, date modified,
date uploaded and presentations that are using the item.

* Delete an item. Right-click an item and select Delete. Remember that you cannot delete an
item when it is in use.

* Refresh the Library display. Click Refresh in the upper-right corner.

NOTE: The thumbnails you see in Library view are based on the codecs available on your PC. If an
image does not display properly, you may not have the necessary codecs on your PC.

Using advanced tools

Advanced tools enable you to control your units remotely. You can reboot units, upload logs, and
put a unit in recovery mode with or without reformatting the unit’s storage card.

Sign in to your BrightSign Network account:

a Onthe menu bar, click Tools > Sign In to BrightSign Network.

b If prompted, enter your Account, User name, and Password, and then click Sign In.

On the menu bar, click Tools > Advanced.

Click the Update Autorun tab.

Select the groups for which you want to update the Autorun file with the latest version stored in
the Templates folder, and then click Update now.

Click the Unit Control tab.

( @ Advanced Tools | ]
In the Serial Number field, enter the serial number of the unit Update Autorun | Unit Control
yOU want to COhtI’O'. Enter the BrightSign serial number

Serial Number:

Click the Action list and select the action you want to perform:

Action

* Reboot unit: Restarts the unit. )

Reboat unit =

Reboat unit

* Upload logs: Uploads log files based on the Upload Log setting Recovery - reformat
you selected on the Unit Setup screen.

Recovery - don't reformat

* Recovery - reformat: Puts the unit in recovery mode and
reformats the unit’s storage card.

* Recovery-don’t reformat: Puts the unit in recovery mode and downloads the latest autorun
script to the storage card without reformatting the unit’s storage card.



8 (Optional) To add another action, click Add action.
9 C(lick Close.

TIP: To remove a Unit Control action, on the menu bar click Tools > Advanced, click the Unit
Control tab, enter the Serial Number of the device from which you want to remove the action,
click Remove action, and then click Close.



Chapter 7
Frequently Asked Questions

To view additional Frequently Asked Questions, go to support.brightsign.biz/forums.

Can | use BrightAuthor with the HD600 or HD2000?

No, BrightAuthor only supports the HD110, HD210, HD210w, HD410, HD810, HD1010, and
HD1010w, and we do not plan to add support for the HD600 or HD2000.

Can | open the autoplay.xml file using BrightAuthor?

No. The autoplay.xml file that is generated when you publish a presentation is a playlist file. This
file includes only the information required for playback on a BrightSign. This file is not the same
as a presentation project file.

How do | use a different font?

To use a different font, browse to a folder on your computer that has a true type font. This font
will be copied to the SD card when you publish the presentation. You can use your own custom
font or download free TrueType fonts from the web.

Can | export a template?

Yes. While there isn't a template export option, you can save the presentation project you're
using with the new template. You can then open the presentation project on another computer,
click the Layout tab, and select Save Template.
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Can | use the schedule feature on the HD110 or HD410?

No. Only network-enabled units that set the time over the network, or the HD810, with a real-
time clock, can use the schedule feature.

Why does BrightAuthor take a long time to process my folder?

If the folder you selected has a large number of images and videos, the files list on the Playlist tab
may take a couple minutes to update. Please be patient.

Why can’t BrightAuthor locate my files when | try to publish my presentation?

If you copy a presentation project from one computer to another computer, or if you move or
rename files used in a BrightAuthor presentation, BrightAuthor cannot locate your files and you
get an error when you try to publish. To resolve the error, you must remove the files from each
playlist in your presentation, and then add them again.

Why are some of my videos missing thumbnails in the Files tab?
The thumbnails are generated by codecs installed on your computer. If you don't see thumbnails
for your transport streams, for example, you can try downloading a codec such as K-Lite.

What do | do if BrightAuthor crashes while I'm using it?
For any errors or crashes you encounter with BrightAuthor, post a description of the problem in
the forums or send us an email at support@brightsign.biz and be sure to include the following
information:
* Steps to duplicate the problem (or indicate that you can't duplicate it)
* Any error dialogs you saw, and any text from the error dialog

» The contents of your event log right after the crash. You can find the log in this folder:
C:\Users\Owner\AppData\Local\BrightSign\BrightAuthor\. Look for a subfolder named after
the BrightAuthor version number, such as 2.2.0

* A copy of the presentation project where you experience this problem

. 61



Appendix A
Remote Control Protocols

Follow these steps to set up your BrightSign to communicate with a remote control:

a Create an interactive presentation (see Making a presentation interactive).
Select Remote Input as the input device.

¢ Enter any of the following remote control codes:
remoteCommands[0]="WEST"

remoteCommands[1]="EAST"
remoteCommands[2]="NORTH"
remoteCommands[3]="SOUTH"
remoteCommands[4]="SEL"
remoteCommands[5]="EXIT"
remoteCommands[6]="PWR"
remoteCommands[7]="MENU"
remoteCommands[8]="SEARCH"
remoteCommands[9]="PLAY"
remoteCommands[10]="FF"
remoteCommands[11]="RW"
remoteCommands[12]="PAUSE"
remoteCommands[13]="ADD"
remoteCommands[14]="SHUFFLE"
remoteCommands[15]="REPEAT"
remoteCommands[16]="VOLUP"
remoteCommands[17]="VOLDWN"
remoteCommands[18]="BRIGHT"
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