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Troubleshooting GPS Data

Introduction
GPS data can appear in a variety of formats (.txt, .csv, .gpx, .xls, .xlsx, .tab, etc.) and coordinate units resulting in ‘messy’
data that must be cleaned up before it can be used in ArcGIS. This document attempts to address some common issues
encountered with GPS data.

If the data hasn’t been loaded from the GPS, follow the steps for getting waypoints from the GPS to GIS using DNRGPS

utility. This is the optimal method for plotting GPS data.

If the data is already in .gpx format, run the conversion tool “GPX to Features” in ArcGIS.

GPS Data in Degrees, Minutes, Seconds

Ideally, latitude/longitude coordinate pairs are most useful in decimal degree format (hddd.dddd). However, some cases
have data in degrees and decimal minutes or even degrees, minutes and decimal seconds. The data file (.txt or .csv) will

be fixed using Microsoft Excel.

1. Run Excel.

2. Select File > Open. Navigate to the location of the text file (if necessary, change the file type to “Text Files” in order

to see all files of this type.
Text Import Wizard

e Step1:

o ldentify the data as delimited (tab or comma) or fixed width

Identify the ‘start import at row’
click Next
e Step2:

o Choose delimiter (preview indicates how your choice affects the data)

o Click Next

Text Import Wizard - Step 2 of 3

This screen lets you set the delimiters your data contains. You can see how your text is affected in the

preview below,

Delimiters
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Cancel < Back

e Step3:

o Set the data format for each column (this can also be done later, if necessary).

o Click Finish.
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The table appears squished.

3. To expand columns, click and drag across all column headers (A through L) to select the affected data.
4. From the HOME ribbon and CELLS > Format section, choose AutoFit Column Width.
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In the above example, Lat/Long coordinates are found in column E under the name “Position”. This format shows both
latitude and longitude in a single column as degrees, minutes and decimal seconds. Unfortunately, this format is
unacceptable for GIS. We will convert them to decimal degrees.

Converting to Decimal Degrees

Remove unwanted columns
GPS data sometimes includes a lot of extra data not pertinent to your specific study.

1. Identify columns and/or rows to delete and tidy up the table.
2. When all changes are made, copy/paste the POSITION column so that it is the last populated column, if necessary.

Splitting the Column

1. Activate the DATA ribbon.

2. Select the column containing the coordinate pairs.

3. From Data Tools, select Text to Columns. The 3 step wizard will guide us to split this column such that we will be
able to calculate decimal degrees.

Step 1: select Fixed Width. Click Next.

Data preview

10 20 30 40 50 60
Step 2: Identify breaklines within the column. Each piece of | I 1; T oo e pos R
the coordinates will need to have separate columns. Click g e 4 e e
Next. D sl e g e v
Step 3: default data format is acceptable. Click Finish. e < Back Einish

4. The coordinate pairs have been parsed into 8 separate columns.
5. Save your work in a new Excel workbook (.xIsx).

Calculating Latitude

1. Enter a new column with the name “Latitude”.
2. Click the cell directly below and enter the following equation using corresponding cells

= Degrees + ((Minutes / 60) + (Seconds/ 3600)) HIT ENTER

=D2+((E2/60)+(F2/3600)) RESULTSIN  43.19319
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3. Click the cell containing the equation and click/drag the black handle in the lower right down the entire column to
apply the equation to the whole column.

Calculating Longitude

1. Click the first row cell of the first vacant column and enter the name “Latitude”.
2. Click the cell directly below and enter the following equation using corresponding cells

=-1*(Degrees + ((Minutes / 60) + (Seconds/ 3600))) HIT ENTER
=-1*(H2+((12/60)+(J2/3600))) RESULTSIN  -79.2661111

3. Click the cell containing the equation and click/drag the black handle in the lower right down to apply the equation
to the whole column.
4. Save the Excel file.

Deleting redundant columns

1. At this point, the latitude and longitude columns are reliant on the 8 columns we created earlier. If we tried to
delete the seemingly meaningless columns, we would lose the calculated values.
2. To make the calculated values permanent, select the 2 columns, hit Ctrl-C on the keyboard or right-click and select

Copy.
3. Highlight two empty columns, right-click and from the paste options, choose the second option called “paste

values”.

15i tio n Latitude Longitude Latitude Longitude
43 11 35.5 W 79 15 58 43.15315444 -79.26611111 43.19315444 -79.26611111
43 11 40.7 W 79 16 3.5 43.19453889 -79.26763889 43.19453889 -79.26763889
43 7 15.5 W 79 15 7.9 43.12097222 -79.25219444 43.12097222 -79.252159444
43 6 52.7 W 79 15 27.4 43.11463889 -79.25761111 43.11463889 -79.25761111
43 10 52.7 W 79 16 18.7 43.18130556 -79.27186111 43.18130556 -79.27186111
43 11 23.5 W 79 15 9.3 43.18986111 -79.25258333 43.18986111 -79.25258333
43 7 19.8 W 79 15 37.7 43.12216667 -79.26047222 43.12216667 -79.26047222
43 12 46.2 W 79 14 32.9 43.21283333 -79.24247222 43.21283333 -79.242472322
43 10 9w 79 11 47.8 43.16916667 -79.19661111 43.16916667 -79.19661111

IT is now safe to highlight and delete the 8 parsed columns plus the first 2 calculated lat/long columns resulting in a tidy
Excel table.

A B C D

Name Description Latitude Longitude
2 |GC10119 OH CANADA, EH? 43.19319444 -79.26611111
3 GClo2QC WEEPING WILLOW CACHE 43.19463889 -79.26763889
4 |GC11EPM BROCK BASEMENT CACHE 43.12097222 -79.25219444
5 |GC11EQ2 ATRIBUTE TO SCRATCH N WIN 43.11463883 -79.25761111
6 |GC1INOK GRAMDPA'S CACHE 43.18130556 -79.27186111
7 GC11X9Y THE 3 AMIGO'S CACHE 43.18986111 -79.25258333
g |GC12PQ0 OH GEOCACHE! WHERE MIGHT YOU B 43.12216667 -79.26047222
9 GCl312y CALM 43.21283333 -79.24247222

4. Save the Excel file.
5. Save a second copy in CSV format to be used in ArcGIS. If prompted with a warning, click continue.
6. Close all Excel windows before proceeding.

If this section was useful, move on to the instructions for Plotting X,Y Data in ArcGIS, found on page 7.




GPS Data in UTM
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Sometimes GPS data has coordinates described by UTM eastings and northings in a single column. Before these
coordinates can be plotted, they must be parsed into separate fields.

Sample text file with UTM coordinates (this is a very messy file)

Grid utM
Datum  NAD83

Header MName
Categories

Waypoint
Waypoint
Waypoint
Waypoint
Waypoint
Waypoint
Waypoint
Waypoint

Description Type
aes 83-AUG-87 1:
aee 83-AUG-87 1:
aa7 18-AUG-87 6:
aes 18-AUG-87 6:
aa9 24-AUG-87 5:
a1e 24-AUG-87 5:
@24 25-5EP-87 9:
825 24-0CT-87 3:

1. Run Excel.
2. Select File > Open. Navigate to the location of the text file (if necessary, change the file type to “Text Files” in order
to see all files of this type.

Text Import Wizard

The table appears squished.

Step 1:

Position Altitude
:13PM User Waypoint 17 T 499914
:16PM User Waypoint 17 T 499915
1 25PM User Waypoint 17 N 891735
1 21PM User Waypoint 17 T 648318
:36PM User Waypoint 17 T 648768
1 23PM User Waypoint 17 T 648655
1@3AM User Waypoint 17 T 639431
:51PM User Waypoimt 17 T 678528

Depth  Proximity

Temperature

4935922 243 m 9.0 ft
4935922 243 m  B.0 ft
18635 112 m 8.0 ft
4780537 187 m 8.8 ft
4783885 8.8 ft
4783732 8.8 ft
4782830 78.3 m 8.0 ft
4752678 162 m 8.0 ft

Identify the data as delimited (tab or comma) or fixed width
Identify the ‘start import at row’

click Next

Display Mode Color Symbol Facility

Choose delimiter (preview indicates how your choice affects the data)
Click Next

Symbol & Mame  Unknown Crossing
Symbol & MName  Unknown Crossing
Symbol & Mame  Unknown Crossing
Symbol & MName  Unknown Crossing
Symbol & MName  Unknown Crossing
Symbol & Mame  Unknown Crossing
Symbol & MName  Unknown Crossing
Symbol & MName  Unknown Crossing

Set the data format for each column (this can also be done later, if necessary)
Click Finish.

3. To expand columns, click and drag across all column headers (A through L) to select the affected data.
4. From the HOME ribbon and CELLS > Format section, choose AutoFit Column Width.

ey Y e o] = - (mm] mx =3 2 - A
5 Calibri -l - AN == #-  EWapTet General - - E 7] 4 em = @
O g - = P s % B H .ZY ik
Paste " Iu- === & 3= Merge & Center ~ $ .05 G0 om Cunditi?:nal Formatas Cell Insert Delete Format . S?rt & Find &
- Formatting - Table~ Styles~ @ @ @ — " Filter - Select -
Clipboard Font [ Alignment [ Mumber [F1 Styles Cells | Cell Size
+ e
Al I Header {L Row Height..
AutoFit Row Height
A B C D E F G H | J K L M N 0 ol Vit R
olumn Width...
1 |Header |Name Descriptic Type Position Altitude Depth Proximity Temperat Display M Color Symbol .Facility City State -
2 AutoFit Column Width
3 |waypoint 5 03-AUG-0TUser Way| 17749991243 m 0.0t Symbol & Unknown Crossing Default Width...
4 |Waypoint 6 03-AUG-07User Way} 17 T 49991243 m 0.0ft Symbol & Unknown Crossing Visibility
1 5 |wWaypoint 7 10-AUG-07User Way| 17 N 6917:112 m 0.0 ft Symbol & Unknown Crossing Hide & Unhide »
6 |Waypoint 8 10-AUG-07User Way} 17 T 64031107 m 0.0ft Symbol & Unknown Crossing T
7 |wWaypoint 9 24-AUG-07User Way} 17 T 640760 4783885 0.0 ft Symbol & Unknown Crossing o S

In the above example, UTM coordinates are found in column E under the name “Position”. This format shows eastings
and northings in a single column. GIS requires they be in separate columns.



Splitting the Column
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Before splitting the column, it is a good idea to clean up the table by deleted redundant columns and rows.
Make sure the Position column has 3 blank columns to the right where parsed data will be saved.
Activate the DATA ribbon.
Select the column containing the UTM coordinates.
From Data Tools, select Text to Columns. The 3 step wizard will guide us to split this column.

Step 1: select Fixed Width. Click Next.

Step 2: Identify breaklines within the column. Each piece of the coordinates will need to have separate columns.

Click Next.

Step 3: default data format is acceptable. Click Finish.

6. The coordinate pairs have been parsed into 4 separate columns. In the example below, columns G and H include
eastings and northings, respectively. Change the name of these columns accordingly.

= h fou  La pa

A B
Header Name
Waypoint GC10119
Waypoint GC1020C
Waypoint GC11EPM
Waypoint GC11EQ2
Waypoint GCL1IMOK
Waypoint GC11X9Y

Description

OH CANADA, EHT

WEEPING WILLOW CACHE
BROCK BASEMENT CACHE
ATRIBUTETO SCRATCH N WIN
GRANDPA'S CACHE

THE 3 AMIGO'S CACHE

c D

Type

User Waypoint
User Waypoint
User Waypoint
User Waypoint
User Waypoint
User Waypoint

7. Clean up the table by deleting unwanted columns and rows.
8. Save your work in a new Excel workbook (.xIsx). Then save as a CSV file (say YES to prompt) and close Excel.
Follow the steps for Plotting X,Y Data in ArcGIS.

9.

N FE R S

= ohooun

MName
10119
GC1020C
GC11EPM
GC11EQ2
GCIINOK
GC11X9Y

Description

OH CAMNADA, EH?

WEEPING WILLOW CACHE
BROCK BASEMENT CACHE

A TRIBUTE TO SCRATCH N WIN
GRAMNDPA'S CACHE

THE 3 AMIGQO'S CACHE

Po

E

L
Easting
640885
840757
642183
g41757
640445
641991

Si
17T
17T
17T
17T
17T
177

D |
Morthing

4783727
4783886
4775732
4775020
4782398
4783380

tion

]

640885
640757
642183
641757
640445
641991

4783727
4783886
4775732
4775020
4782398
4783380
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Field data represented by 6 digit UTM references

A B
Data gathered in the field using a 6 digit UTM grid reference system must be expanded to reflect 1 |site utm
more complete UTM coordinate pairs. In a 6 digit grid reference, the first 3 digits represent the Z 1] 615458
easting and the last 3, the northing. The 6 digit reference must be split in two then expanded. - z g:zi:
Splitting the Column > 4] 503487
B 5 588565
1. Activate the DATA ribbon. 7 6 586470
2. Select the column containing the 6-digit reference.
3. From Data Tools, select Text to Columns. The 3 step wizard will guide us to split this column. 10
Step 1: Select Fixed Width. Click Next. shaa
513
Step 2: Identify breaklines within the column by clicking between the 3™ and 4" character. Sqpias
Click Next.
Step 3: Default data format is acceptable. Click Finish.
A E C
4. The coordinate pairs have been parsed into 2 separate columns. site utm
5. Save the document in Excel (.xIsx) format. 1 615 488
2 568 518
Before continuing, you must confirm the geographic area where the points were gathered. 3 556 443
Refer to a 1:50k topographic map of the area to identify the expanded values of 4 503 487
northings/eastings, as well as the UTM Grid Zone (Niagara is in 17N). 3 588 565
& 586 470

6. Enter a new column title for Easting. Click in the first cell and enter the following equation to expand the grid
reference (assuming a Niagara location):

=CONCATENATE("6",B2,"00") HIT ENTER
RESULTS IN 661500

7. Click in the cell where you entered the equation and drag the black handle down to apply the function to the rest of

the list.
8. Enter a new title for Northing. Click the first cell and enter the following equation to expand the grid reference:

=CONCATENATE("47",C2,"00")

RESULTS IN 4748800

The table should look like this:

A B C D E
site utm Easting Morthing
1 615 438 661500 4748800
2 568 518 656800 4751800
3 556 443 655600 4744300
4 503 487 650300 4748700
5 588 565 658800 4756500
i] 586 470 658600 4747000

9

9. Save the Excel file and save a second copy in CSV format.
10. Close Excel before continuing with steps to plot X,Y data in ArcGlIS.
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Plotting X,Y Data in ArcGIS

It is simple to plot X,Y locations if the data table (ideally in CSV format) has two separate fields for coordinate pairs such
as, latitude and longitude (decimal degrees) or UTM eastings and northings. The table may look similar to this:

10.
11.

12.
13.
14.

A B C D
1 |Name Description Latitude Longitude
2 |GC10119 OH CANADA, EH? 43.19315444 -79.26611111
3 |GC1020C WEEPING WILLOW CACHE 43.19463889 -79.26763889
4 |GC11EPM BROCK BASEMENT CACHE 43.12097222 -79.25219444
5 |GC11EQ2 ATRIBUTE TO SCRATCH N WIN 43.11463889 -79.25761111
6 |GCIINOK GRANDPA'S CACHE 43.18130556 -79.27186111
7 |GC11X9Y THE 3 AMIGO'S CACHE 43.18986111 -79.25258333
A B C D |
1 |Name Description Easting MNorthing
2 |GC10119 OH CANADA, EH? 640885 4783727
3 |GClo2ac WEEPING WILLOW CACHE 640757 4733886
4 |GC11EPM BROCK BASEMENT CACHE 642183 4775732
5 |GC11EQ2 ATRIBUTE TO SCRATCH N WIN 641757 4775020
6 |GC11NOK GRANDPA'S CACHE 640445 4782398
7 |GCLIX9Y THE 3 AMIGQO'S CACHE 641991 4733380

Run ArcMap.

Click Add Data and navigate to the CSV file, select it and click Add. The table appears in the Table of Contents.
NOTE that the file must be closed in all other applications or you will receive error messages.

Right-click the table and select Display XY Data...

In the Add XY Data dialog, specify the fields that contain the X and Y coordinates, with X corresponding to longitude
(easting) values and Y corresponding to latitude (northing) values.

**TIP: the following table summarizes X, Y formats.**

Latitude 43 degrees UTM-Y 4,763,000 metres N
Longitude -79 degrees UTM-X 623,000 metres E

Under Coordinate System of Input Coordinates, click Edit...
Identify the spatial reference according to your data:

For Latitude/Longitude use:
Geographic Coordinate Systems > North America > NAD 1983

For UTM Eastings/Northings in most of Southern Ontario use:
Projected Coordinate Systems > UTM > NAD 1983 > NAD 1983 UTM Zone 17N

Click OK.

The Display XY Data dialogue box is now complete. Click OK.

A message box will appear stating that the table does not have an Object-ID field. This field will automatically be
created in the next steps.

Click OK. The XY data is displayed as points on the map.

This point data file is called an "event" file. To make a permanent shape file, right-click on the point data layer and
choose Data > Export Data.

Ensure the Save as type: is shapefile and the location is your student space. Click Save.

Accept the rest of the defaults and click OK.

When prompted to add the exported data to the map as a layer, click Yes.

The layer is now a permanent shape file including an Object-ID field meaning the data may be used in analysis.



