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CHAPTER 1 

Welcome to WhatsConfigured 

In This Chapter 

What is WhatsConfigured? ................................................................................. 1 

Finding more information and updates ........................................................ 1 

Sending feedback .................................................................................................. 2 
 
 

What is WhatsConfigured? 

WhatsConfigured enables effective management of one of the most critical assets on your 
network—device configurations. As a fully integrated plug-in for WhatsUp Gold, 
WhatsConfigured automates the key configuration and change management tasks required 
to maintain and control configuration files for networking devices, reducing the risk of 
network outages caused by misconfigured devices. Network managers can leverage this 
automated configuration to reduce the amount of time spent ensuring their network devices 
are configured correctly, freeing valuable time.  

WhatsConfigured is built around an automated task execution engine that allows network 
managers to dynamically gather configuration data about their network devices through 
configuration tasks. These tasks can be scheduled to run on a regular basis or can be 
manually ran as needed to upload, download, and backup configuration files, manage device 
credentials, and much more. WhatsConfigured comes with several pre-defined configuration 
tasks with the option to create custom tasks. Additionally, WhatsConfigured works with the 
WhatsUp Gold Alert Center and can alert you on the success or failure of a task, or when 
changes are detected on a device.   

With support for heterogeneous networks, WhatsConfigured provides secure SNMP, SSH and 
unsecure Telnet, SNMPv1, SNMPv2 or TFTP access, to download and store device 
configuration files in an independently secured repository, keeping them readily available for 
file compares and restoration on a device. 

WhatsConfigured not only reduces the time and effort required to maintain device 
configurations and changes while providing increased security, compliance, and visibility, it 
also reduces the risk of costly network downtime.    
 

Finding more information and updates 

The following are information resources for WhatsConfigured. This information may be 
periodically updated and available on the WhatsUp Gold web site 
(http://www.whatsupgold.com/support/index.aspx).  

http://www.whatsupgold.com/support/index.aspx
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§ Release Notes. The release notes provide an overview of changes, known issues, and 
bug fixes for the current release. The release notes are available on the WhatsUp Gold 
web site (http://www.whatsupgold.com/WUG162releasenotes). 

§ Application Help for the console and web interface. The console and web help 
contain dialog assistance, general configuration information, and how-to's that 
explain how to use the features. The Table of Contents is organized by functional 
area, and can be accessed from the main menu or by clicking Help in the console, or 
the ? icon in the web interface. 

§ Additional WhatsUp Gold resources. For a listing of current and previous guides 
and help available for WhatsUp Gold products, see the WhatsUp Gold web site 
(http://www.whatsupgold.com/support/guides.aspx). 

§ Licensing Information. Licensing and support information is available on the 
WhatsUp Customer Portal (http://www.whatsupgold.com/wugCustPortal). The web 
portal provides enhanced web-based capabilities to view and manage Ipswitch 
product licenses. 

§ Technical Support. Use the WhatsUp Gold Support Site for a variety of WhatsUp 
Gold product help resources. From here you can view product documentation, search 
Knowledge Base articles, access the community site for help from other users, and get 
other Technical Support information. The Support Site is available on the WhatsUp 
Gold web site (http://www.whatsupgold.com/support/index.aspx). 

 

Sending feedback 

We value your opinions on our products and welcome your feedback. 

To provide feedback on existing features, suggest new features or enhancements, or suggest 
ways to make our products easier to use, please fill out our product feedback form 
(http://www.whatsupgold.com/wugfeedback). 
 

http://www.whatsupgold.com/WUG162releasenotes
http://www.whatsupgold.com/support/guides.aspx
http://www.whatsupgold.com/wugCustPortal
http://www.whatsupgold.com/support/index.aspx
http://www.whatsupgold.com/wugfeedback
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STEP 8: Configure templates .......................................................................... 10 
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STEP 1: Prepare the network 

Prepare devices for discovery 
In order for WhatsConfigured to properly discover and identify devices, each device must 
respond to the protocols that WhatsConfigured uses during discovery. 

Preparing devices to be discovered 
To discover that a device exists on an IP address, WhatsConfigured uses the following 
protocols: 

§ Ping (ICMP) 

§ TCP 

If a device does not respond to ping or TCP requests, it cannot be discovered by 
WhatsConfigured. We recommend ensuring that all devices respond to at least one of these 
types of requests prior to running a discovery. 

Preparing devices to be identified 
After WhatsConfigured discovers a device on an IP address, it queries the device to determine 
its manufacturer and model and other device property information. To gain this information, 
WhatsConfigured uses SNMP. 
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Enabling SNMP on devices 
We recommend that important devices be configured to respond to SNMP requests. For 
information about how to enable SNMP on a specific device, see Enabling SNMP on Windows 
devices in the WhatsUp Gold Online Help (http://www.whatsupgold.com/wug161webhelp) or 
consult the device documentation. For information about configuring SNMP on network 
devices, you may also want to view the WUG Guru video How to enable SNMP on a Windows 
server (http://www.whatsupgold.com/wug123snmpvideo). 

 Note: If a firewall exists between WhatsConfigured and the devices to be discovered (or if the 
Windows Firewall is enabled on the computer where WhatsConfigured is installed), make 
sure that the appropriate ports are open on the firewall to allow WhatsConfigured to 
communicate via SNMP.  

 

Install and activate WhatsConfigured 
WhatsConfigured can share a server with Ipswitch WhatsUp Gold, or can be installed as a 
standalone application on a separate server. In either case, WhatsConfigured is licensed 
separately. If you use the application as a plug-in, it is installed with WhatsUp Gold. If you are 
installing the application separately, it is installed using the WhatsConfigured installation 
program. The WhatsConfigured Release Notes 
(http://www.whatsupgold.com/WCfg31ReleaseNotes) contain the most up-to-date information 
about installing. 

Before installing, we recommend that you read the WhatsConfigured Release Notes for 
possible application update details and review the system requirements information to 
ensure that the system, on which you are attempting to install, meets the base-level 
requirements.  

After you install, the product should automatically activate using the license you purchased 
for WhatsConfigured. In the even that you should need to manually activate your 
WhatsConfigured installation, see Activating WhatsConfigured. 
 

STEP 2: Discover the network 

Before you can begin using WhatsConfigured with your network, you must first discover your 
network. You can do this using the WhatsUp Gold Discovery Console upon starting WhatsUp 
Gold. 

For information about discovery methods and the protocols required to discover your 
network, please see the Using the Discovery Console section of the WhatsUp Gold Help. 
 

http://www.whatsupgold.com/wug161webhelp
http://www.whatsupgold.com/wug123snmpvideo
http://www.whatsupgold.com/WCfg31ReleaseNotes
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STEP 3: Configure and assign credentials 

WhatsConfigured uses SSH and Telnet credentials to communicate with the devices on your 
network. You need to assign appropriate credentials to every device that you plan to manage 
through WhatsConfigured, as credentials are required for most WhatsConfigured features. 

Credentials are configured and assigned to devices in the WhatsUp Gold Credentials Library. 

 

For more information, see Using Credentials in the WhatsUp Gold Help. 
 

STEP 4: Configure the TFTP Server 

The WhatsConfigured TFTP server is required in order for WhatsConfigured to restore device 
configurations to your network devices. Additionally, you have the option to use the TFTP 
server when backing up device configurations.  

The Ipswitch TFTP Server is accessed from Start > Programs > Ipswitch TFTP Server. 

Please ensure that your TFTP server is appropriately configured for your network. For more 
information, see WhatsConfigured Integration in the Ipswitch TFTP Server Help. 
 

STEP 5: Configure Remote CLI Settings 

At its base functionality, WhatsConfigured is a software tool that can help you automate 
many configuration tasks for your network devices. WhatsConfigured carries out theses 
configuration tasks by programmatically interacting with your devices' command line 
interface (CLI). Many device vendors specify different standards for how network 
administrators interact with their CLI. For example, the character sequence in a command 
prompt, or the sequence that indicates the end of a command. To provide you with greater 
flexibility, WhatsConfigured allows you to override the default CLI settings by defining 
custom sets of CLI elements for devices from a particular vendor or for specific IP addresses. 
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This helps ensure that WhatsConfigured can correctly communicate with these devices as it 
attempts to carry out tasks. The Remote CLI Settings library stores all CLI Settings used to 
issue the commands necessary to carry out WhatsConfigured tasks on your network devices.  

The library includes two default settings and various pre-defined system settings that come 
installed with WhatsConfigured. You can use these system settings, or copy them to create 
new, user-defined settings for devices that support a particular OID or a specific IP address.  

 

For more information, see the About the CLI Settings Library (on page 56). 
 

STEP 6: Configure task scripts and tasks 

Task scripts login to devices through SSH or Telnet, and run command-line interface (CLI) 
commands on devices. These tasks can perform a number of operations, such as restoring or 
backing up a running or startup configuration, or changing an application password.  

WhatsConfigured comes with several pre-configured task scripts; you can also configure your 
own custom task scripts using the WhatsConfigured Custom Script Language. For more 
information, see the WhatsConfigured for WhatsUp Gold v.16.2 Custom Script Language Guide 
(http://www.whatsupgold.com/WCfg31CustScriptLangforWUG162). 

http://www.whatsupgold.com/WCfg31CustScriptLangforWUG162
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Task scripts are configured from and stored in the Task Script Library.  

 

You can associate task scripts with configuration tasks in the New/Edit Configuration Task 
dialog. 

 

For more information, see the Using Task Scripts (on page 22) section. 

Task scripts are powered by user-configured tasks. When you configure a configuration task, 
you select the specific task script that you want the task to execute at the time it is run. 

You can configure both schedulable and password tasks. Schedulable Tasks run associated 
task scripts on a regularly scheduled basis. For example, you can have WhatsConfigured make 
a daily backup of a device's running configuration. Password Tasks modify credentials on the 
devices to which they are assigned. For example, removing a set of SNMPv1 credentials from 
a device.  
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Tasks are configured from and stored in the WhatsConfigured Task Library and are associated 
with devices in the WhatsConfigured Task dialog's Devices tab.  

 

For more information, see the Using Tasks (on page 33) section. 
 

Assign tasks to the appropriate devices 
A task must be assigned to a device in order to execute the selected task script. Tasks are 
assigned during the initial task configuration process via the New/Edit WhatsConfigured Task 
dialog's Devices tab. 
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Configure task thresholds 
As you configure tasks, you have the opportunity to assign thresholds through which you can 
receive task threshold alerts. This can be done on the Threshold tab of the New/Edit 
Configuration Task dialog. 

 

You can choose to have email notifications sent to you when a task meets any of the criteria 
you select for the threshold. 

For more information, see the Using Tasks (on page 33) section. 
 

STEP 7: Configure and audit policies 

WhatsConfigured policies search through archived configuration files for strings that are 
either expected or not expected within the file(s).  

When a scheduled task fails a policy, any associated notification policies alert you that the 
policy has failed due to unexpected content that has been flagged in an archived config file. 
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Policies are configured from and stored in the Policy Library.  

 

From the Policy Library, you can also run policies immediately for a specific Archive Key using 
the Audit Now option. 

 

For more information, see the Using Policies (on page 44) section. 
 

STEP 8: Configure templates 

WhatsConfigured script templates allow network admins to automatically push device 
configurations to devices of the same type by replacing device-specific (IP address, 
hostname) information with variables, saving time and reducing the possibility of error from 
one manual device configuration to another. 



WhatsConfigured for WhatsUp Gold 16.2 User Guide 

  11 

Templates are configured from and stored in the Template Library. You can also use the 
Template Library's Import and Export buttons to import previously saved configuration 
templates, or to export configuration templates. 

 

After you configure a template, you can generate the template for specific devices to ensure 
that the script is properly configured to be pushed to the device(s). For more information, see 
the Using Templates (on page 48) section. 
 

STEP 9: Manage network devices 

After tasks are configured and assigned, they either run on the schedule you configure, or can 
be run as needed from the WhatsConfigured Task Library's Run Now button.  

 Note: When you run tasks on demand, they run for every device to which they are assigned. 
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STEP 10: View network data 

As WhatsConfigured runs tasks, it stores data in the WhatsConfigured database. You can view 
this configuration data from several places in WhatsConfigured, including the Configuration 
Task Log report, and the Archive Search tool. 
 

View configuration data 
The Archive Search tool allows you to search for and view the content of archived config files.  

 

For more information, see About Archive Search (on page 61).  
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View task data 
The WhatsConfigured Task Log report displays log messages generated by WhatsConfigured 
tasks. You can filter the report by date, task, result, and the device(s) for which the selected 
tasks ran. 

 

For more information, see About WhatsConfigured Task Log in the WhatsUp Gold Help. 
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CHAPTER 3 

Accessing WhatsConfigured Features in 
WhatsUp Gold 

In This Chapter 

Finding WhatsConfigured on the Configure menu ............................... 14 

The Configured tab ............................................................................................ 15 

Finding WhatsConfigured on Device Properties .................................... 15 

Finding WhatsConfigured thresholds in Alert Center ........................... 16 
 
 

Finding WhatsConfigured on the Configure menu 

You can access WhatsConfigured from the WhatsUp Gold console's main menu at Configure 
> WhatsConfigured Task Library Configure >, WhatsConfigured Task Script Library, or 
Configure > WhatsConfigured Policy Library. 

 

 Note: The WhatsConfigured commands on the Configure menu are only enabled if you have 
a license for WhatsConfigured. To update your license for WhatsConfigured, visit the 
WhatsUp Customer Portal (http://www.whatsupgold.com/wugCustPortal).  

 

http://www.whatsupgold.com/wugCustPortal
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The Configured tab 

The Configured tab on the WhatsUp Gold web interface is the main access point for 
WhatsConfigured features, tools, and reports.  

 

 Note: The Configured tab is only visible if you have a license for WhatsConfigured. To update 
your license for WhatsConfigured, visit the WhatsUp Customer Portal 
(http://www.whatsupgold.com/wugCustPortal).  

 
 

Finding WhatsConfigured on Device Properties 

WhatsConfigured can be found on the Tasks section of the WhatsUp Gold Device Properties 
dialog. 

 

http://www.whatsupgold.com/wugCustPortal
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To access WhatsConfigured through Device Properties: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
2 Click Tasks. The Tasks section of Device Properties appears. 
 

Finding WhatsConfigured thresholds in Alert Center 

If you assign an Alert Center threshold to a WhatsConfigured task, a custom threshold 
dashboard report for the WhatsConfigured task threshold is displayed on the WhatsUp Gold 
web interface's Alert Center tab. 

 

For more information, see Using Alert Center with WhatsConfigured (on page 65). 
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CHAPTER 4 

Viewing WhatsConfigured reports 

In This Chapter 

About the WhatsConfigured Task Log ........................................................ 17 

About the WhatsConfigured Start vs Run Configuration report ....... 19 

About the Policy Audit report ........................................................................ 20 
 
 

About the WhatsConfigured Task Log 

The WhatsConfigured Task Log displays log messages generated by WhatsConfigured tasks. 

 

To access the report:  

On the WhatsUp Gold web interface, go to Configured > Task Log. 

Report body 
§ Date. Displays the date the task ran. 

§ Task. Displays the name of the specific task. 

§ Device. Displays the network device for which the task ran. 

§ Severity. Displays the severity of the task. 

§ Result. Displays the outcome of the task. 

§ Type. Displays the task type. 

§ Message. Displays the log message that generated according to the task's result. 
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Filtering the report 
Date range 

Use the date/time picker at the top of the report to select a date range and time frame. 

In the Date range list, group reports also allow you to specify and customize the business 
hour report times for reports to display. This allows you to view the network activity only for 
specified business hours. The date and time format for the date on this report matches the 
format specified in Program Options > Regional set in the WhatsUp Gold console. 

 Note: The Business Hours setting is available for group reports only. 

Task  

Use the Task list to select a specific task for which to view report data. This list is populated 
with scheduled tasks currently configured in the Scheduled Task Library. 

Device 

Use the Device list to select a specific network device for which to view report data. You can 
view data for all devices in the group.  

 Tip: You can change the device group you are viewing by clicking the group name in the 
application bar at the top of the page. 

Result 

Use the Result list to select a specific result for which to view report data. You can choose to 
view data for all results. 

Printing 
You can print a fully formatted report through your browser by clicking the print icon in the 
browser's toolbar, or selecting File > Print from the browser's menu. 

Toolbar buttons 
Use the following toolbar buttons to manage report exports, schedule report emails, and get 
application help.  

 
Click this icon to select the device group for which you want to view report data. 

 

Click this icon to view and edit dynamic group properties.  

Note: This icon only appears when you are viewing a device group other than the default All 
Devices dynamic group. 

 

Click this icon to export the report to a file (Text, Microsoft Excel, or PDF available in full 
reports and PDF available in dashboard reports). 
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Click this icon to select the device group for which you want to view report data. 

 

Click this icon to: 

§ email a report as a PDF attachment. 

§ schedule reports to be emailed.  
Note: JavaScript must be enabled on your browser for this feature to work. 

 

Click this icon to view help for the current report. 

 
 

About the WhatsConfigured Start vs Run 
Configuration report 

The WhatsConfigured Start vs Run Configuration report gives a visual representation of the 
differences between Startup and Running configuration scripts for devices in a particular 
device group. 

 

To access the report:  

On the WhatsUp Gold web interface, go to Configured > Task Log. 

Report body 
The report displays the following information for each device: 

§ Result. The status of detected changes. Either Unavailable, Different, or Same.  

§ Device. The network device name.  

§ Startup Config. The specific archive Startup Config file. Click an entry in this column 
to view the configuration archive for a file. 

§ Running Config. The specific archive Running Config file. Click an entry in this 
column to view the configuration archive for a file. 
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§ Differences. If applicable, the number of detected differences. Click an entry in this 
column to view differences broken down by line for a device. 

Filtering the report 
Use the Device list at the top middle of the screen to select to view report data for either all 
devices in the selected group or to view report data for a specific device. 

Printing 
You can print a fully formatted report through your browser by clicking the print icon in the 
browser's toolbar, or selecting File > Print from the browser's menu. 

Toolbar buttons 
Use the following toolbar buttons to manage report exports, schedule report emails, and get 
application help.  

 
Click this icon to select the device group for which you want to view report data. 

 

Click this icon to view and edit dynamic group properties.  

Note: This icon only appears when you are viewing a device group other than the default All 
Devices dynamic group. 

 

Click this icon to export the report to a file (Text, Microsoft Excel, or PDF available in full 
reports and PDF available in dashboard reports). 

 

Click this icon to: 

§ email a report as a PDF attachment. 

§ schedule reports to be emailed.  
Note: JavaScript must be enabled on your browser for this feature to work. 

 

Click this icon to view help for the current report. 

 
 

About the Policy Audit report 

The WhatsConfigured Policy Audit report lists policy audit results for devices in the selected 
group. 

To access the report: 

On the WhatsUp Gold web interface, go to Configured > Policy Audit. 

Report body 
The report displays the following information for each device: 

§ Result. The policy result; either Pass or Fail. 
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§ Device. The device name on which the policy ran. 

§ Archive. The configuration archive. 

§ Pattern. The policy pattern(s) as defined in the policy; either a regular expression or a 
string. 

§ Description.  A description of the pattern. 

§ Ignore Case. Specifies if the Ignore Case option was applied during the policy's 
configuration. 

§ Regex. Specifies if the Regex (Regular Expression) option was applied during the 
policy's configuration. 

§ Type. Indicates whether the policy pattern is an include or an exclude pattern. 

§ Match Line. A comma separated list of configuration file line numbers where the 
pattern matched the specified line. If the pattern matched no lines of the 
configuration, this column displays None. 

Filtering the report 
Use the various lists at the top of the page to filter report data.  

§ Policy list. Select a specific policy for which to view report data. Alternatively, keep 
the default selection of None to view report data for no policies.  

§ Device list. Select a specific device for which to view report data. Alternatively, keep 
the default selection of All Devices in the Group to view report data for all devices in the 
selected group. 

§ Archive Key list. Select a specific archive key for which to view report data. 
Alternatively, keep the default select of All to view report data for all archive keys. 

§ Max Archive Count list. Select to view report data for all archives, the most recent 
archive, or for the 5 most recent archives. 

§ Results list. Select to view report data for all results (both pass and fail), all pass 
results, or all fail results.  

After you make report filter selections using the lists above, click Apply to reload the report 
with the filtered report information. 
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CHAPTER 5 

Using Task Scripts 

In This Chapter 

About Task Scripts .............................................................................................. 22 

Using the WhatsConfigured Task Script Library ...................................... 22 

Configuring custom task scripts.................................................................... 32 

About the WhatsConfigured Custom Script Language ........................ 32 
 
 

About Task Scripts 

Task scripts login to devices through SSH or Telnet and run command-line interface (CLI) 
commands on devices. These tasks can perform a number of operations, such as restoring or 
backing up a running or startup configuration, or changing an application password.  

WhatsConfigured comes with two pre-configured task scripts; you can also configure your 
own custom task scripts using the WhatsConfigured Custom Script Language 
(http://www.whatsupgold.com/WCfg31CustScriptLang). A script debugger is available to assist 
you in script creation when you access the Task Script Library from the WhatsUp Gold 
console.  

Task scripts are configured from and stored in the Task Script Library and associated to 
WhatsConfigured tasks in the WhatsConfigured Task dialog. 
 

Using the WhatsConfigured Task Script Library 

The WhatsConfigured Configuration Script Library displays all scripts currently configured for 
use in WhatsConfigured tasks. 

There are several pre-configured configuration scripts available for use in WhatsConfigured.  

§ Backup Running Config 

§ Backup Startup Config 

Backup Running Config 

The backup running config task script makes a backup copy of a device's running config and 
stores it in the WhatsConfigured database. After you have made a backup copy of a running 
config, you can restore it on the device at any time for as long as the copy is stored in the 
database.  

http://www.whatsupgold.com/WCfg31CustScriptLang
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Backup Startup Config 

The backup running config task script makes a backup copy of a device's startup config and 
stores it in the WhatsConfigured database. After you have made a backup copy of a startup 
config, you can restore it on the device at any time for as long as the copy is stored in the 
database. 

 Tip: You can set the number of maximum configuration files to store in WhatsConfigured 
database on the New WhatsConfigured Task dialog's Schedule tab. 

To access the WhatsConfigured Configuration Script Library: 

From the WhatsUp Gold admin console, go to Configure > WhatsConfigured Task Script 
Library. 

To configure new or existing task scripts: 

 Note: The Edit, Copy, Delete, and Export buttons are disabled for the default, pre-
configured task scripts, as you cannot modify or remove default scripts.  

§ Click Add to configure a new task script. 

§ Select a custom task script, then click Edit to change its configuration. 

§ Select a custom task script, then click Copy to make a duplicate of the selected task 
script. 

§ Select a custom task script, then click Delete to remove it from the library. 

 Caution: When you delete a non-default task script from the Task Script Library, it is 
removed from all tasks that are using that task script. 

§ Select a task script, then click Run Now to run the task script immediately. 

§ Select a custom task script, then click Export to export it as an XML file. 

§ Click Import to import an XML file into the library. 

 Note: Modifying XML files or attempting to create an XML file from scratch can invalidate a 
script file. 

 Note: You can only Export custom task scripts. 

 Tip: You can view a device's current and archived config files on the Device Properties - 
Tasks dialog. 

 

Creating and editing a WhatsConfigured Task Script 
Use the Task Script dialog to create or edit a WhatsConfigured task script. Task scripts are 
used in WhatsConfigured scheduled tasks.  
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To configure a Task Script: 
1 Go to the Task Script Library: 

§ From the WhatsUp Gold admin console, go to Configure > WhatsConfigured Task 
Script Library. The Task Script Library appears. 

§ To create a new custom task script, click New. 

- or -  

§ To modify an existing custom script, select the appropriate script, then click Edit.  
2 In the Task Script dialog, enter the appropriate information into its boxes. 

§ Enter a Name for the script. The script name will display in the Task Script Library. 

§ Enter a brief Description for the script. 

§ Enter or paste the Script for the task that you want WhatsConfigured to complete. For 
more information on WhatsConfigured scripts, see Using the WhatsConfigured Custom 
Script Language (http://www.whatsupgold.com/WCfg31CustScriptLang). 

3 Click OK to save changes. 
 

Debugging task scripts 
The WhatsConfigured Visual Script Runner extends visibility into how task scripts interact 
with devices. This tool allows users to change task scripts and associated device settings in 
real-time, displaying their script and setting modifications dynamically as they are made.  

 Note: The capability to debug WhatsConfigured scripts using the Visual Script Runner is only 
available on the WhatsUp Gold admin console. 

To access and use the WhatsConfigured Visual Script Runner: 
1 From the WhatsUp Gold admin console, go to Configure > WhatsConfigured Task 

Script Library. The Task Script Library appears. 

http://www.whatsupgold.com/WCfg31CustScriptLang
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2 Select a task script, then click Debug. The Visual Script Runner dialog appears. 

 
3 Select a Device against which the script will run. 
4 The Visual Script Runner requires either that a device have either SSH or Telnet 

credentials. WhatsConfigured looks for and uses SSH credentials first, and if none exist, 
look for and use Telnet credentials. If the device you choose does not have either SSH or 
Telnet credentials assigned, go to the device's Properties (right-click > Properties > 
Credentials) to configure and assign credentials to the selected device. 

After you select a device that has appropriate credentials assigned, the script runs for the 
selected device and displays in the Script Text section of the Visual Script Runner. The 
following sections describe the Visual Script Runner dialog components. 

Script Text Tab 

The Script Text tab displays the selected script in the context of the selected device.  

 Note: You must have a device selected in order to have the script display in the Script Text 
section of the dialog. 

When the script debugging has completed, or is paused, you can modify the script text. As 
you modify the script text, the commands, variables, and trimmed command output update 
dynamically.  

§ If you add a new command to the script, it is added to the parsed Script Commands 
list.  

§ If you replace script text with a variable, it is added to the Variables tab.  

§ If you modify or add trim options, the Trimmed Command Output tab lists these 
modifications and/or additions.  



WhatsConfigured for WhatsUp Gold 16.2 User Guide 

  26 

If the modifications you make render the script unusable, dynamic updates stop until you 
reformat the script correctly. See the Script Commands section for more information. 

To modify the script: 
1 Click inside of the Script Text box to modify the script as needed.  
2 After making modifications, click Save. 

 Tip: Click RegEx to verify regular expressions you use in your script modifications.  

Client Settings Tab 

Client Settings are system- or user-defined settings that instruct the WhatsConfigured 
configuration task runner how to interact with the selected device. These CLI settings define 
how a device prompts WhatsConfigured and how WhatsConfigured responds to that device's 
prompts. For example, what a device responds with when it is ready to receive a command 
(CommandPrompt), or what to respond with when requesting the next page in a paged 
response (MoreResponse). WhatsConfigured defines and uses system settings for devices for 
which you have not specified custom settings. You can specify custom settings on a per-
device basis in the Remote CLI Settings library to map to either a specific IP address or OID. 
When user-defined settings exist for a device or an OID, WhatsConfigured uses these custom 
settings rather than the default or system settings. For more information, see About the 
Remote CLI Settings Library. 

WhatsConfigured displays client settings for each device that is selected. These settings can 
be overridden within the script by defining a variable and a value. For more information on 
variables, see About the WhatsConfigured Custom Script Language.  

 Note: If a setting is overridden, the Client Settings tab displays the settings value, and the 
Variables tab displays the overridden script value for the variable. 

When the script debugging has completed, or is paused, you can modify the Client Settings. 

To modify a setting: 
1 Double-click a settings' Value box to activate it for modification.  
2 After making modifications, click Save. 

 Tip: Click RegEx to verify regular expressions you used in your settings modifications.  

Saving changes 
Changes you make to the script text or client settings do not automatically persist; you must 
click Save in order modifications to persist. If you change a device or close the debugging 
session before saving changes, WhatsConfigured prompts you to ask if you want to save 
changes. 
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 Note: If the device you have selected currently maps to a system (non-custom) script or to 
predefined, system CLI settings, WhatsConfigured prompts that you must create a user-
defined entry for the modifications you are attempting to make. When creating the user-
defined entry, whether a script or CLI settings, you can associate the user-entry to a specific 
device IP address or to an OID. If you select to associate the user-entry to an OID, all devices 
with that OID will map to the user-entry you create. If you associate the user-entry with an IP 
address, only that IP address will map to the user-entry you create. 

Script Commands and Debugging  

Commands are parsed out of the script text and displayed in the Script Commands section of 
the dialog in the order in which they run in the script. The list displays the command text, the 
result if the command has run, the archive key, query prompt, query response, and any 
existing trim commands.  

Debugging  
Use the debugging buttons to control a debugging session. 

Button Description  

Back   
Moves back one command. Click to move back one command in the 
script. 

Run   
Runs all commands continuously in one debugging session. Click to 
begin running the script. 

Pause   
Pauses the debugging session. Click to pause a running debugging 
session. 

Forward    
Runs commands one at a time. Click to move to the next command in the 
script. 

Stop   
Stops the debugging session. Click to stop a running debugging session. 

 Note: If you attempt to run a script with a formatting issue, you are prompted to fix the issue 
before running the script.  

 Note: The @connect and @login commands can only be issued one time per run; if you 
back to either of these commands and attempt to run again, the script will fail. If you must re-
run either command again, stop the debugging session using the stop button, and begin 
another session using the run button.  

 Note: Some devices accept exit and logout commands; if a script issues this command to 
a device that accepts either command, the debugger can no longer issue commands to the 
device. In this case, you must stop the debugging session using the stop button and begin 
another session using the run button. 
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 Tip: You can refer to the script status icon at the bottom right of the Script Commands 
section to see if your script has any formatting issues before attempting to run a script. 

Viewing debugging results 

 

1 Commands ready to be debugged/commands currently being debugged in a running 
script are highlighted in yellow and indicated with a green arrow.  

2 After a command is debugged, information about the debugging is displayed in the 
Script Commands columns. 

3 The script status icon at the bottom right of the Script Commands indicates the 
verification status of the script and commands.  

 Note: If a command fails, the debugger stays at that command. This gives you a chance to 
modify the command and run it again without having to back up to the command before 
attempting modifications. To skip a failed command, click the forward button. 

Log 
The Log tab displays all of the interaction between WhatsConfigured and the selected device 
along with details about what the task runner is doing as the script runs. For example, the log 
indicates that the task runner read input or wrote an output. Further, the log indicates that 
the debug session read some output and was issued the more prompt, it would then show 
that it gave the more response. This continues until all page output is read by the script 
debugger. Viewing this interaction can be useful to you, as it may indicate at which point a 
failed script became hung. 

In addition to the interaction between WhatsConfigured and the device, the Log tab reports 
when it starts and ends commands and gives details about each command.  

Trace 
The Trace tab displays a view of the interaction between WhatsConfigured and the selected 
device. This tab closely resembles what you would see if you were logged into the device 
issuing command from the CLI. The Trace resets each time a debugging session runs. 
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Log and Trace right-click menu 
You can select text and right-click inside the Log and Trace tabs to display right-click menu 
operations for interacting with the CLI settings or the RegEx Tester.  

 

The CLI setting operations allow you to add the selected text to the back of the selected CLI 
setting. This is useful when a script becomes stuck reading a command prompt. For example, 
if the script is having trouble logging in, you can select the password prompt in the script, 
right-click and select Add to PasswordPrompt. When you run the script again, you will see if 
the change corrected the script's login problem.  

If the pattern in the CLI settings is not currently a regular expression, the menu selection 
converts it to a regular expression and appends the new text to the newly created pattern.  

The RegEx Tester operations allow you to add the selected text to the RegEx Tester. If a 
pattern does not match the device output, you can select the output, and then select Make 
RegEx Tester Content. The selected output is placed in the RegEx Tester Content, at which time 
you can modify the regular expression and test it against the output until it succeeds.  

Variables 
The Variables tab shows all variables associate with the currently running script. The variables 
can originate from the script, the client (CLI) settings, or the TFTP server settings. If the script 
overrides or defines a variable, updates to the script appear in the variable table dynamically 
as they are made. Changes to the CLI settings not overridden in the script also appear in the 
variable table and update dynamically as they are modified.   

Trimmed Command Output 
When a command is run using a capture key, the entire output is collected and stored. If that 
command is selected from the command list, the trim commands are applied to the output, 
and the output is displayed on the Trimmed Command Output tab. If you add, edit, or 
remove a trim command on this tab, the updates are applied to the raw output and 
redisplayed in the tab's output text box. This allows you to fine tune command trimming 
without having to repeatedly run the command. 

The output text box has a context menu that allows you to select and use text with trim 
commands. 

§ The Trim Start option adds a trim-start command with the selected text that trims all 
output before and including the selected text. 

§ The Trim End option adds a trim-end command with the selected text that trims all 
output after and including the selected text. 

§ The Trim Before option adds a trim-before command with the selected text that trims 
all output before the selected text (not including). 
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§ The Trim After option adds a trim-after command with the selected text that trims all 
output after the selected text (not including). 

§ The Remote Lines option adds a remove-lines command with the selected text that 
removes all lines that match the selected text. 

 

Using the Regular Expression Tester 
The Regular Expression Builder allows you to test any regular expression patterns that you 
use in a task script against the device output for which you are using the expression. 

To access the Regular Expression Tester: 

The Regular Expression Builder is accessible from the WhatsConfigured Script Debugger. 

To use the Regular Expression Tester: 
1 From the WhatsUp Gold admin console, go to Configure > WhatsConfigured Task 

Script Library. The Task Script Library appears. 
2 Select a task script, then click Debug. The Visual Script Runner dialog appears. 
3 Click RegEx. The Regular Expression Tester dialog appears. 

 
4 Use the dialog boxes to verify any regular expression you are using in the task script. 

§ Regular Expression Pattern. Enter the regular expression you want to verify. For 
example, /.*password:/, or /.+(>|#)?/ . 

§ Select Configuration Script Pattern to have WhatsConfigured ignore any delimiters 
or escaping forward slashes that you include in the Regular Expression Pattern box. 
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§ Search Content. Enter the pattern that regular expression will be verified against. 
Typically, this is what you expect the device to respond with to the regular expression 
you enter above. You can copy and paste this information directly from the script you 
for which you are verifying content. 

Clear Ensure match occurs at end of content to allow WhatsConfigured to consider 
pattern matches that do not occur at the end of the device output. This option is 
selected by default because by default the WhatsConfigured scripting engine only 
considers pattern matches valid if they occur at the end of the device output in order 
to eliminate erroneous matches in the middle of a device output. 

5 Click Search to verify the regular expression against the device output for the 
expression. Results are displayed in the Pattern Search Results section.  

6 View the Pattern for user in Configuration Scripts section to see a list of regular 
expressions used in the script delimited by forward slashes (/). 

 Note: WhatsConfigured escapes forward slashes (/) contained in regular expression patterns 
that are not meant to be delimiters. 

 

Importing and exporting task scripts 
You can import scripts written outside of WhatsConfigured into WhatsConfigured to be used 
in tasks.  

To import a custom script for use in a WhatsConfigured task: 
1 Go to the WhatsConfigured Task Script Library: 

From the WhatsUp Gold admin console, go to Configure > WhatsConfigured Task 
Script Library. The Task Script Library appears. 

2 Click Import. The Import Configuration Scripts dialog appears.  
3 Browse to the script file that you want to import. 
4 Click OK to import the selected script file. 

You can export scripts that you develop within WhatsConfigured.  

 Note: WhatsConfigured default scripts cannot be exported. 

To export a custom task script: 

1 Go to the WhatsConfigured Task Script Library: 

From the WhatsUp Gold web interface, go to Configure > WhatsConfigured Task Script 
Library. The Task Script Library appears. 

2 Select the custom script you want to export, then click Export. The Export Configuration 
Scripts dialog appears. 

3 Browse to the location on your local system where you want to save the script file. 
4 Give the script file a Name. 
5 Click Save to export the script to the specified location. 
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Configuring custom task scripts 

In addition to the pre-configured task scripts included in WhatsConfigured, you can configure 
custom task scripts that either configure devices or gather device data and store it in the 
WhatsUp Gold database. These tasks are configured using the WhatsConfigured Custom Script 
Language (http://www.whatsupgold.com/WCfg31CustScriptLang), a combination of 
WhatsConfigured and device commands.  
 

About the WhatsConfigured Custom Script 
Language 

WhatsConfigured users can write custom scripts that log in to devices through Telnet or SSH 
and run CLI commands on their devices. Scripts can be used to configure devices or to 
capture information about them in the WhatsConfigured database.  

For the most recent information about the WhatsConfigured Custom Script Language and 
how to use it with your devices, see the script documentation 
(http://www.whatsupgold.com/WCfg31CustScriptLang) on the Ipswitch Support page. 
 

http://www.whatsupgold.com/WCfg31CustScriptLang
http://www.whatsupgold.com/WCfg31CustScriptLang
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CHAPTER 6 

Using Tasks 

In This Chapter 

About tasks ........................................................................................................... 33 

Using the WhatsConfigured Task Library .................................................. 33 
 
 

About tasks 

Task scripts are powered by user-configured tasks. When you configure a WhatsConfigured 
task, you select the specific task script that you want the task to execute at the time it is run. 

Tasks are configured from and stored in the WhatsConfigured Task Library and are associated 
with devices in the WhatsConfigured Task dialog. Additionally, you can view tasks associated 
with a specific device from the Device Properties - Tasks dialog in WhatsUp Gold. 
 

Using the WhatsConfigured Task Library 

The WhatsConfigured Task Library displays all tasks configured for use in WhatsConfigured.  

To access the WhatsConfigured Task Library: 

On the WhatsUp Gold admin console, go to Configure > WhatsConfigured Task Library. 

Use the WhatsConfigured Task Library to configure new or existing tasks. 

§ Click New to configure a new task. 

§ Select an existing task, then click Edit to modify its configuration. 

§ Select an existing task, then click Copy to create a new task based on the selected 
task. 

§ Select an existing task, then click Delete to remove it from the list.  

§ Select a task, then click Run Now to perform the task immediately. The task will be 
run for all devices to which it is assigned. Additionally, to run a task only for a single 
device, use the Run Now option on the WhatsUp Gold Device Properties - Tasks 
dialog for a specific device. 

 

Selecting a task type 
There are two types of tasks that you can configure. Select one of the following: 
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§ Schedulable Task. Schedulable Tasks run associated task scripts on a regularly 
scheduled basis. 

§ Password Task. Password Tasks modify credentials on the devices to which they are 
assigned. 

 

Configuring Schedulable Tasks 
Schedulable tasks are configured to run on the regularly scheduled basis that you choose. 
You can configure a task to run on a daily, weekly, monthly, yearly, or custom schedule.  

To configure a daily task schedule: 
1 From the WhatsUp Gold web interface, click Configure > WhatsConfigured Task 

Library. The WhatsConfigured Task Library appears. 
2 Click New. The WhatsConfigured Task dialog appears. 
3 Select the Schedule tab.  
4 Select Enable this schedule. 
5 Under the Interval list, select Daily. 
6 Specify the Start Time.  
7 Specify how often the task should be performed. For example, if you want the task to 

run every other day, specify that the task should repeat every 2 days. You can select to 
have the task run every ___ day, or every weekday at the specified time. 

To configure a weekly task schedule: 
1 From the WhatsUp Gold web interface, click Configure > WhatsConfigured Task 

Library. The WhatsConfigured Task Library appears. 
2 Click New. The WhatsConfigured Task dialog appears. 
3 Select the Schedule tab.  
4 Select Enable this schedule. 
5 Under the Interval list, select Weekly. 
6 Specify the Start Time. 
7 Specify how often the task should be performed. For example, if you want the task to 

run to run every other week during the work week, specify that the task run every 2 
weeks and select Monday through Friday.  

To configure a monthly task schedule: 
1 From the WhatsUp Gold web interface, click Configure > WhatsConfigured Task 

Library. The WhatsConfigured Task Library appears. 
2 Click New. The WhatsConfigured Task dialog appears. 
3 Select the Schedule tab.  
4 Select Enable this schedule. 
5 Under the Interval list, select Monthly. 
6 Specify the Start Time. 
7 Specify the day of the month the task should run. You can select a numerical date, such 

as the 15th, or a generic date, such as the third Wednesday. 
8 Specify how often the task should be performed. For example, if you want the task to 

run every other month, specify that the task repeat every 2 months.  
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To configure a yearly task schedule: 
1 From the WhatsUp Gold web interface, click Configure > WhatsConfigured Task 

Library. The WhatsConfigured Task Library appears. 
2 Click New. The WhatsConfigured Task dialog appears. 
3 Select the Schedule tab.  
4 Select Enable this schedule. 
5 Under the Interval list, select Yearly. 
6 Specify the Start Time. 
7 Specify the day and month the task should run. You can select a month with a numerical 

date, such as the June 1st, or a generic date with a month, such as the first Friday of 
June. 

To configure a custom task schedule: 
1 From the WhatsUp Gold web interface, click Configure > WhatsConfigured Task 

Library. The WhatsConfigured Task Library appears. 
2 Click New. The WhatsConfigured Task dialog appears. 
3 Select the Schedule tab.  
4 Select Enable this schedule. 
5 Under the Interval list, select Custom. 
6 Specify the Start Time. 
7 Specify how often the task should be performed. You can select minutes, hours, or days. 

For example, you can specify that the task run at 2:00:00 AM every 2 days. 
 

Configuring password tasks 
Use the New Password Task dialog to configure a WhatsConfigured Password Task. Password 
tasks allow you to add, edit, or delete device SNMP, SSH, or Telnet credentials. 
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 Note: Password tasks only modify credentials by device. Changes made using a 
WhatsConfigured password task do not affect the Credential Library. 

To access this dialog:  
1 From the WhatsUp Gold admin console, go to Configure > WhatsConfigured Task 

Library. The WhatsConfigured Task Library appears. 
2 Do one of the following: 

§ Click New to configure a new task. The Select Task type dialog appears.  

§ Select Password Task, then click OK. The New Task dialog appears. 

- or - 

§ Select an existing Password task, then click Edit. The Edit Task dialog appears. 

To add, edit, or remove SNMP, SSH, or Telnet credentials to a device: 
1 Go to the WhatsConfigured Task Library: 

From the WhatsUp Gold admin console, click Configure > WhatsConfigured Task 
Library. The WhatsConfigured Task Library appears. 

2 Do one of the following: 

§ Click New to configure a new task. The Select Task type dialog appears.  

§ Select Password Task, then click OK. The New Task dialog appears. 

- or - 

§ Select an existing task, then click Edit. The Edit Task dialog appears. 
3 Enter or select the appropriate information in the dialog boxes. 

§ Enter a Name for the task. This name is listed in the Task Library. 

§ Enter a brief Description for the task. This description is listed in the Task Library to 
help you differentiate it from other tasks. 

4 Select the Credential Type that you want to add, either SNMP, SSH, or Telnet. 
5 If you want to add credentials, select Add Credential to select the specific credentials to 

add, click the browse (...) button to browse to browse the Credentials Library and select 
a credential to add. 

6 Select whether to Associate this credential with network devices. Selecting this 
option adds the set of credentials to the selected devices. 

7 Select whether to Add this credential with read only privileges. Selecting this option 
disables the ability for other users to edit the credential. 

 Note: If you are using HP ProCurve series devices, you must select to Add Credential first, 
then select the Add this credential with read only privileges box to remove the Operator 
credential password or you must clear the Add this credential with read only privileges 
box to remove the Manager credential password. The SNMP credential type only allows 
Manager credentials and the SSH and Telnet credential types allow both Manager and 
Operator credential types. 
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8 If you want to remove credentials, click Remove Credential then select the specific 
credentials to remove, click the browse (...) button to browse to the Credentials Library 
and select a credential to remove. This list is populated from the credentials currently 
configured for the selected device. 

9 Select an existing Discovery Filename or type a new Discovery Filename for which 
you want to save the password task to. 

10 Under the Devices box, click Add to select the device(s) to which you want to add the 
credentials. 
- or -  
If removing credentials from a device, select the device(s) in the Devices box, then click 
Remove to remove selected credentials from the device. 

11 Click OK to save changes. 
 

Viewing task results 
The Task Results dialog displays results for tasks that have been run using the Scheduled Task 
Library's Run Now option.  

To view Task Results for a task: 
1 Click Configure > WhatsConfigured Task Library. The WhatsConfigured Task Library 

appears. 
2 Select a task, then click Run Now. A dialog displaying the task's progress appears. 
3 When the task completes, click Results. The Task Results dialog appears. 
4 Optionally, click Save to save the results to a local file. 

The dialog displays the following result for a task that was ran using the Run Now option: 

§ Task status. The result of the entire task. A task is considered to be successful only if 
the task completes successfully for all devices for which it runs. In the event that the 
task fails, the task message displays information regarding the failure. 

§ Task Message. A message that explains why the task failed. If the task runs 
successfully for all devices, this box is empty. 

§ Task Devices. The devices for which the task was run.  

 Tip: Select a device to view its result information in the following section of the dialog. 

Below, the dialog displays device-specific results in six tabs.  

 Tip: Select a dialog tab to view information for its specific dialog boxes. 

The Output tab displays the task's result, relevant messages, and a trace of all 
communication between the device and the WhatsConfigured service. 

For each task it displays: 

§ Result. The result of the task for the selected device.  
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§ Message. Any message pertaining to the task for the selected device. In some 
instances, this box may be empty. 

§ Trace. A history of all communication that takes place between the device and the 
WhatsConfigured service during the task's attempted completion. If the task collects a 
configuration file as part of the task, it is included in the trace. If the task was 
successful for this device, the trace displays what the command prompt would have 
looked like if the user consoled into the device and run the commands manually using 
a command prompt.  

§ If the task failed and no communication took place between the device and the 
WhatsConfigured service due to communication or configuration errors, the box 
displays "No communication with the device was recorded." Finding the cause of this 
failure may be accomplished by reviewing the credentials listed on the Settings tab, 
reviewing device configurations, attempting to communicate with the device 
manually, or by checking the log. 

The Script tab displays the task script assigned to this task as it is saved in the Task Script 
Library, and how the task looks after it is processed through the WhatsConfigured task 
runner. 

For each task it displays: 

§ Script Text. The script assigned to be run by the task. If this script is a custom script, it 
appears exactly as it did when it was configured in the New/Edit WhatsConfigured 
Task Script dialog. If this is a predefined password or backup task, the script displayed 
is the script chosen for this device based on the WhatsConfigured script registry. 

 Note: Scripts for predefined WhatsConfigured tasks are looked up based on the OID 
associated with the device. If there is no OID assigned to the device, the lookup fails and no 
script is listed. OID's can be assigned to a device from the Device Properties - Tasks dialog, or 
collected by discovering the device. Due to the large number of devices and their varying 
commands this script to device mapping may fail. 

§ Processed Text. The WhatsConfigured scripting language allows for variable 
replacement within scripts. WhatsConfigured pre-defined scripts utilize this ability 
when running password tasks. Before the script is run the script is processed and all 
variable references are replaced with the variables corresponding value. The 
processed text displays the resulting script after processing. This box allows the user 
to ensure variable declarations are being assigned and interpreted properly. 

 Tip: If you are experiencing a problem with a script, Save the results listed in the script tab to 
a text (.txt) file. If you contact Technical Support, this file aids in troubleshooting your script 
problem. 

The Variables tab displays the name and value of all variables associated with the task script. 

For each task it displays: 

The Commands tab displays a list of the commands as they were interpreted by the 
WhatsConfigured script runner. It also displays the results of those commands if they were 
run against the device when the task was run. 
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For each task it displays: 

§ Command. The specific command; for example, login or show configuration. 

§ Result. The success or failure of the command when it was ran by the task. 

§ Output. The results of the responses declared by the WhatsConfigured script 
language. 

The Log tab displays any error messages that were logged as the task ran. 

The Settings tab displays the protocol credentials used to complete the task. 

For each task it displays: 

§ Type. The type of protocol credentials; for example, SSH or Telnet. 

 Note: WhatsConfigured defaults to SSH credentials when available. If SSH credentials are not 
assigned to a device, WhatsConfigured looks for/uses Telnet credentials. 

§ Name. The name of the credentials as assigned in the Credentials Library. 

§ Description. The description of the credentials as assigned in the Credentials Library. 
 

Assigning a task to a device 
Tasks are assigned to individual devices from either the Device Properties - Tasks dialog or 
when configuring the task in the Task Library. 

To assign a WhatsConfigured task to a device from Device Properties: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
2 Click Tasks. The Tasks section of Device Properties appears. 
3 Under WhatsConfigured tasks attached to this device, click Add. The Add Task to 

Device dialog appears. 
4 Select the task that you want to assign to the device, then click OK. If the list is empty, or 

you do not see the task you want to assign, browse (...) to the WhatsConfigured Task 
Library to configure a new task. 

For information on assigning a device during task configuration, see Configuring Tasks. 
 

Running a task immediately 
To run a task immediately from the Task Library: 
1 From the main menu of the WhatsUp Gold admin console, click Configure > 

WhatsConfigured Task Library. The WhatsConfigured Task Library appears. 
2 Select the scheduled task that you would like to run at this time, then click Run Now.  
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Using Device Properties - Tasks 

The Device Properties - Tasks dialog displays task and archived device data.  

From this dialog you can add or remove device tasks, run a task immediately, restore a device 
to a previously archived configuration file, delete an archived configuration, modify 
configuration files, and import or export archived configuration files. In addition to these 
management capabilities, the Device Properties - Tasks dialog allows you to view and 
compare archived configuration files by accessing the WhatsConfigured Diff Viewer. 

The top section of the dialog, WhatsConfigured tasks attached to this device, lists the tasks 
that are assigned to the device. Each task is listed by its name, description, and the time the 
task was last run. 

The bottom section of the dialog, Archives saved for this device, lists each archived 
configuration file that has been obtained by a task or that has been imported, and is saved for 
the device. Each archived configuration file is listed by the time it was created, the task it was 
created by, the key associated with the archive, its description, and whether the Retain 
option is selected for the archive. 
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Assigning tasks 

To assign a WhatsConfigured task to a device from Device Properties: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
2 Click Tasks. The Tasks section of Device Properties appears. 
3 Under WhatsConfigured tasks attached to this device, click Add. The Add Task to 

Device dialog appears. 
4 Select the task that you want to assign to the device, then click OK. If the list is empty, or 

you do not see the task you want to assign, browse (...) to the WhatsConfigured Task 
Library to configure a new task. 

 

Comparing archived configuration files 

To compare two device config files: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
2 Click Tasks. The Tasks section of Device Properties appears. 
3 Under Archives saved for this device, select two configuration files, then click 

Compare. The WhatsConfigured Diff Viewer appears. 
 

Deleting archived configuration files 

To delete an archived configuration file from a device: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
2 Click Tasks. The Tasks section of Device Properties appears. 
3 Under Archives saved for this device, select an archived config file, then click Delete. 

You can run a task on demand from either the Device Properties - Tasks dialog, or from the 
WhatsConfigured Task Library.  

 Note: If you run the task from Device Properties the task only runs for that specific device. If 
you run the task from the Task Library, the task runs for any device to which it is assigned. 

 

Exporting archive configuration files 

To export an archived configuration file: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
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2 Click Tasks. The Tasks section of Device Properties appears. 
3 Click Export. The file is downloaded. 

 
 

Importing configuration files to archive 

To import a configuration file to archive: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
2 Click Tasks. The Tasks section of Device Properties appears. 
3 Click Import. The Import Configuration Archive dialog appears. 
4 Click Browse to navigate to the location on your directory where the file exists. 
5 Enter the file's Archive Key. The Archive Key describes the type of the configuration file, 

such as running-config or startup-config. 
6 Optionally, enter a Description for the file to briefly describe the archived configuration 

file. 
7 Click to select Retain if you do not want the imported archive to be deleted. 

 Note: The maximum number of archives stored per archive key is set on the New or Edit 
WhatsConfigured Task dialog. Archives marked as Retain are stored in addition to other 
archvies. Archives not marked as Retain are deleted when a task adds an archive that 
exceeds the maximum number specified for that task. 

 

Modifying archived configuration files 

To edit an archived configuration file for a device: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
2 Click Tasks. The Tasks section of Device Properties appears. 
3 Under Archives saved for this device, select an archived config file, then click 

Edit/View. The Edit/View Configuration Archive dialog appears. 
4 You can modify all dialog boxes except for the Time Stamp. 
5 Click OK to save changes. 
 

Removing tasks from devices 

To remove a task from a device: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
2 Click Tasks. The Tasks section of Device Properties appears. 
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3 Under Tasks attached to this device, select a task, then click Remove to delete the task 
from this device.  

 

Restoring archived configurations 

To restore a device to an archived configuration: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
2 Click Tasks. The Tasks section of Device Properties appears. 
3 Under Configuration archives saved for this device, select a configuration, then click 

Restore to restore the device to the selected configuration. 
 

Running tasks immediately 

To run a task immediately from Device Properties: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
2 Click Tasks. The Tasks section of Device Properties appears. 
3 Under Tasks attached to this device, select a task, then click Run Now to perform the 

selected task immediately.  

You can remove a task attached to a device from the Device Properties - Tasks dialog. 
 

Viewing archived configuration files 

To view an archived configuration file for a device: 
1 In the Device List or Map View, right-click a device, then click Properties. The Device 

Properties dialog appears. 
2 Click Tasks. The Tasks section of Device Properties appears. 
3 Under Archives saved for this device, select an archived config file, then click 

Edit/View. The Edit/View Configuration Archive dialog appears. 
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About policies 

WhatsConfigured policies search through archived configuration files for strings that are 
either expected or not expected within the file(s).  

Policies can be added to Alert Center Task Thresholds. When a scheduled task fails a policy, 
any associated notification policies alert you that the policy has failed due to unexpected 
content that has been flagged in an archived config file. 
 

About the Policy Library 

The WhatsConfigured Policy Library displays all policies currently configured for use with 
WhatsConfigured archive configuration files by name, description, and type (either system, 
pre-defined policies, or user-defined policies).  

To access the Policy Library: 

On the WhatsUp Gold admin console, go to Configure > WhatsConfigured Policy Library. 

Use the WhatsConfigured Policy Library to configure new or existing policies. 

§ Click New to configure a new policy. 

§ Select a policy, then click Edit to modify its configuration. 

§ Select a policy, then click Copy to make a duplicate of the selected policy. 

§ Select a policy, then click Delete to remote it from the library. 

§ Select a policy then click Audit Now to audit (test) a policy. 

§ Click Import to add a previously configured policy to the Policy Library. 

§ Click Export to save the policy as an .xml file to another location. 
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Configuring a policy 

Use the Configuration Policy dialog to configure a WhatsConfigured Policy. 

To configure a WhatsConfigured Policy: 
1 On the WhatsUp Gold admin console, go to Configure > WhatsConfigured Policy 

Library. The WhatsConfigured Policy Library appears. 

Click New. The WhatsConfigured Policy dialog appears. 

- or - 

Select an existing policy, then click Edit. The WhatsConfigured Policy dialog appears. 
2 Enter a Name for the policy. This name is displayed in the WhatsConfigured Policy 

Library. 
3 Enter a short Description for the policy. This description is displayed next to the policy's 

name in the WhatsConfigured Policy Library. 
4 In the following sections of the dialog, you have the opportunity to specify strings that 

you either expect or do not expect to see within the configuration files the policy audits. 
You can choose to enter only include patters, only exclude patterns, or both. 

 Note: The more restrictive the audit criteria, the less audit results you may obtain as a result.  

5 Under the Include Patterns section of the dialog, click Add to enter a string Pattern 
that you expect to see in the archived configuration files. Additionally, 

§ Select RegEx if you want the string to be interpreted as a Regular Expression.  

§ Select Ignore Case the case of the string is irrelevant to the string. 

§ Optionally, enter a Description for the include pattern. 

 Tip: Select an include pattern, then click Remove to delete it from the list. 

6 Under the Exclude Patterns section of the dialog, click Add to enter a string Pattern 
that you do not expect to see in the archived configuration files. Additionally, 

§ Select RegEx if you want the string to be interpreted as a Regular Expression.  

§ Select Ignore Case the case of the string is irrelevant to the string. 

§ Optionally, enter a Description for the exclude pattern. 

 Tip: Select an include pattern, then click Remove to delete it from the list. 

7 Click OK to save changes. 
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Auditing a policy 

To audit a WhatsConfigured policy: 
1 On the WhatsUp Gold admin console, go to Configure > WhatsConfigured Policy 

Library. The Policy Library appears. 

Click New. The WhatsConfigured Policy dialog appears. 

- or - 

Select an existing policy, then click Edit. 
2 Select a policy, then click Audit Now. The WhatsConfigured Policy Audit dialog appears. 
3 Under the Audit Criteria section of the dialog, click Add to select the device(s) against 

which to audit the policy. 

 Tip: To delete a device from the list, select it, then click Remove. 

4 Select the Archive Key of the configuration files for which the policy will be audited. For 
example, to view audit results for running config archives, select the running-config key 
from the list. This list is populated with all of the keys from the configuration files 
archived for the selected device(s). To view all possible archives, select All. 

 Tip: To limit audit results to a device's most recently archived configuration file for a 
particular key, select Latest Archive Only. 

5 After you have specified the appropriate audit criteria, click Audit to verify the policy. 
Results from the audit are displayed in the Audit Results section of the dialog: 

§ The either successful or failed Audit Result. 

§ The Device Name of the device by which the policy was audited. 

§ Any relevant Message regarding the policy audit. For example, the number of 
archives that failed against the policy. 

 Tip: Select an audit result, then click View to see the details for that result.  

6 Click Close to exit the dialog. 
 

Viewing archive policy audit results 
The Archive Policy Audit dialog displays the results of a WhatsConfigured policy audit.  

Archives 

The following information is displayed for each archive found as a result of the policy 
audit: 

§ The successful or failed Audit Result. 

§ The specific Archive config file and the time it was created. 

§ Any relevant Message regarding the policy audit. 
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Audit Results 

The following information is displayed for any Include Patterns or Exclude Patterns. 

§ The audit Result of the pattern. 

§ The specific Pattern selected in the policy configuration. 

§ If the pattern was interpreted as a regular expression (RegEx). 

§ Whether the pattern's case was relevant to the audit results (Ignore Case). 

Pattern Matches 

Any matches found during the audit are displayed in the bottom section of the dialog. 

 Tip: Use the forward and backward buttons to navigate through the matches. 

Button  Description 

 
Moves one match forward 

 
Moves one match backward 

 
Moves to the first match 

 
Moves to the last match 
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About WhatsConfigured templates 

Network administrators of medium- to large-sized networks can spend a lot of time manually 
configuring devices. For example, a network administrator purchases 10 new Cisco router 
devices. If the network admin made a backup of the configuration of one router to push to 
the remaining nine, the configuration file fails on the other routers because of device-specific 
information included in the first router's network file, such as its device's name and IP 
address. As such, the network administrator must manually configure each of the new router 
devices separately, eating into his busy schedule.  

Templates were created to allow network admins to automatically push device 
configurations to devices of the same type by replacing device-specific (IP address, 
hostname) information with variables, saving them time and reducing the possibility of error 
from one manual device configuration to another. 
 

Using the Template Library 

The WhatsConfigured Template Library displays all templates currently configured for use on 
network devices. Use the Template Library to view, configure, and apply templates. 
Additionally, use the Import and Export buttons to import previously saved configuration 
templates, or to export configuration templates. 

 Note: There are no default, pre-configured templates. Until you configure a template, the 
Template Library remains empty. 

To access the Template Library: 

On the WhatsUp Gold web interface, go to Configured > Template Library. 
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To configure new or existing templates: 

§ Click New to configure a new configuration template. 

§ Select an existing template, then click Edit to modify a template. 

§ Select an existing template, then click Copy to duplicate a template. 

§ Select an existing template, then click Delete to remove it from the Template Library. 

§ Click Import to import a script to the Template Library. 

§ Select an existing template, then click Export to save the script to another location. 
 

Configuring templates 

The first step in using templates is configuring the template script. After you configure a 
template, it will then need to be generated and applied to your network devices. For more 
information, see Generating and applying templates. 

To configure a new template: 
1 Go to the Template Library: 

On the WhatsUp Gold web interface, go to Configured > Template Library. The 
Template Library appears. 

2 Click New. The New Configuration Template dialog appears. 
3 Enter a unique Name and Description for the template to differentiate it from other 

templates in the Template Library. 
4 Click Capture. The Select Configuration Archive dialog appears. 
5 Click Select Device to select a device from which to choose the config file upon which 

you are basing this template. 

If the device you select has archived config files, they are displayed in the Select Config 
Archive dialog. If there are no archived config files for the device, click Capture to grab a 
config file with the WhatsConfigured Select Configuration dialog. After you capture a 
config, it is displayed in the Select Configuration Archive dialog. 

6 Select the archive upon which you want to base the template. The config script is added 
to the Template section of the New Configuration Template dialog. 

7 Adjust the config file as needed to replace any relevant device-specific information with 
variables, such as the hostname and the IP address. For information on variables in 
WhatsConfigured, see the WhatsConfigured for WhatsUp Gold v.16.2 Custom Script 
Language Guide (http://www.whatsupgold.com/WCfg31CustScriptLangforWUG162). 

8 Click OK to save the template. 

To modify an existing template: 
1 Go to the Template Library: 

On the WhatsUp Gold web interface, go to Configured > Template Library. The 
Template Library appears. 

2 Select an existing template, then click Edit. The Edit Configuration Template dialog 
appears. 

3 Modify the Description as needed. 

http://www.whatsupgold.com/WCfg31CustScriptLangforWUG162
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 Note: You cannot modify the template Name. 

4 Modify the Template script as needed. For information on WhatsConfigured variables 
you can use to replace device specific information, such as hostname and IP address, see 
Using the WhatsConfigured Custom Script Language 
(http://www.whatsupgold.com/WCfg31CustScriptLang). 

5 Click OK to save the template. 

To copy a template to use as a base for another template: 
1 Go to the Template Library: 

On the WhatsUp Gold web interface, go to Configured > Template Library. The 
Template Library appears. 

2 Select an existing template, then click Copy. The New Configuration Template: Copy of 
... dialog appears. 

3 Enter a unique Name and Description for the template to differentiate it from other 
templates in the Template Library. 

4 Modify the Template script as needed. For information on WhatsConfigured variables 
you can use to replace device specific information, such as hostname and IP address, see 
Using the WhatsConfigured Custom Script Language 
(http://www.whatsupgold.com/WCfg31CustScriptLang). 

5 Click OK to save the template. 

To remove a template from the Template Library: 
1 Go to the Template Library: 

On the WhatsUp Gold web interface, go to Configured > Template Library. The 
Template Library appears. 

2 Select an existing template, then click Delete. You are prompted to be sure you want to 
delete the template.  

3 Ensure that you are removing the appropriate template, then click Yes. The template is 
removed from the library. 

 

Generating and applying templates 

After you configure a template, you can generate the template for specific devices to ensure 
that the script is properly configured to be pushed to the device(s). 

To generate and apply a template: 
1 Go to the Template Library: 

On the WhatsUp Gold web interface, go to Configured > Template Library. The 
Template Library appears. 

2 Select the template you want to verify, then click Generate. The Configuration 
Template Artifacts dialog appears. 

3 Click Add to select the device(s) for which you want to apply the template.  

http://www.whatsupgold.com/WCfg31CustScriptLang
http://www.whatsupgold.com/WCfg31CustScriptLang
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 Important: Ensure that the devices you select are able to accept the configuration you are 
applying with the template. 

 Tip: To view the template in the context of a certain device, select a device from the list, then 
click Preview. If something looks awry in the template in relation to the selected device, you 
can adjust the template script or remove the device from the list of devices to which you are 
applying the template. 

4 After you have verified both the template in relation to the devices you have selected, 
you are ready to apply the template by clicking Upload. You are prompted to be sure 
that you are applying the correct template to the appropriate device(s).  

5 Ensure that you are applying the correct template, then click Yes to apply the template.  
 

Importing and exporting templates 

To import a config file: 
1 Go to the Template Library: 

On the WhatsUp Gold web interface, go to Configured > Template Library. The 
Template Library appears. 

2 Click Import. The Import Configuration Templates dialog appears. 
3 Navigate to the location on your directory of the .xml file that you want to import.  
4 Select the file, then click OK. 
5 The file is added to the Template Library. 

 Note: If the .xml file that you are importing is identical to any existing templates stored in the 
library, the file does not import. 

To export a template: 
1 Go to the Template Library: 

On the WhatsUp Gold web interface, go to Configured > Template Library. The 
Template Library appears. 

2 Click Export.  
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About the System Script Library 

The WhatsConfigured Default Script Library stores various pre-configured scripts configured 
for use with WhatsConfigured configuration tasks. You can add to this script library by adding 
new scripts or copying and modifying existing scripts.  

The Default Script Library was designed to allow you to create scripts to override 
WhatsConfigured's pre-configured, global scripts for specific functions, such as backup 
running config scripts or password change scripts. For example, you could create a script for 
backing up the running config for Cisco devices by copying an existing backup config script 
and modifying the script to map to a Cisco OID. As such, the script would serve as the new 
default backup config script for Cisco devices, backing up the running config for all devices 
that support the Cisco OID you specified in the script.  

To access the Default Script Library: 

On the WhatsUp Gold web interface, go to Configured > System Script Library.  

By default, the library displays pre-configured scripts for all devices. By filtering by a specific 
device, or group of devices, you can see which default scripts can be used with that device or 
filter. 

To configure new or existing scripts: 

 Note: The Edit, Delete, and Export buttons are disabled for the pre-configured system 
scripts, as you cannot modify or remove system scripts.  

§ Click New to configure a new script. 

§ Select a user script, then click Edit to change its configuration. 

§ Select a script, then click Copy to make a duplicate of the selected script. 

§ Select a user script, then click Delete to remove it from the library. 

§ Click Import to import a script file into the library.  

§ Select a user-defined script, then click Export to save the script to another location. 
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Configuring system scripts 

To add a new default script: 
1 On the WhatsUp Gold web interface, go to Configured > System Script Library. The 

System Script Library appears.  
2 Click New. The New WhatsConfigured System Script dialog appears. Use the dialog 

options to modify the script as desired. 
3 Enter a Description for the script. This description is displayed in the default script 

library to differentiate the script from other scripts. 
4 In the Keys section of the dialog, click Add to add a new OID or IP key and value. 
5 Select a Script Type. Select to create one of the following: 

§ BackupStartupConfig. Create a script to backup a device's startup config file. 

§ BackupRunningConfig. Create a script to backup a device's running config file. 

§ UploadStartupConfig. Create a script to upload a device's startup config file. 

§ UploadRunningConfig. Create a script to upload a device's running config file. 

§ TelnetPasswordAdd. Create a script to add a new Telnet password to a device. 

§ TelnetPasswordEdit. Create a script to edit a device's Telnet password. 

§ TelnePasswordDelete. Create a script to delete a device's Telnet password. 

§ SshPasswordAdd. Create a script to add a new SSH password to a device. 

§ SshPasswordEdit. Create a script to edit a device's SSH password. 

§ SshPasswordDelete. Create a script to delete a device's SSH password. 

§ SnmpPasswordAdd. Create a script to add a new SNMP password to a device. 

§ SnmpPasswordEdit. Create a script to edit a device's SNMP password. 

§ SnmpPasswordDelete. Create a script to delete a device's SNMP password. 

§ CustomScript. Create a custom script type. 

§ TftpBackupStartupConfig. Create a script to backup a device's TFTP startup config 
file. 

§ TftpBackupRunningConfig. Create a script to backup a device's TFTP running config 
file. 

§ UploadStartupConfig_REBOOT. Create a script to upload a startup config for a 
device in order to reboot that device. 

§ SecureUploadStartupConfig. Create a script to upload a startup config file for a 
device using either SCP or SFCP. 

§ SecureUploadRunningConfig. Create a script to upload a running config file for a 
device using either SCP or SFCP. 

6 Enter the Script Text. 
7 Click OK to save changes. 
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To modify an existing system script: 

 Note: You cannot modify default system scripts provided by WhatsConfigured. You can only 
modify system scripts that you and other WhatsUp Gold users have configured for use on 
your network. 

1 On the WhatsUp Gold web interface, go to WhatsConfigured > System Script Library. 
The Default Script Library appears. 

2 Select an existing script, then click Edit. The Edit Configuration Script dialog appears. 
Use the dialog options to modify the script as desired. 

3 Enter a Description for the script. This description is displayed in the default script 
library to differentiate the script from other scripts. 

4 In the Keys section of the dialog, click Add to add a new OID or IP key and value. 

- or - 

Select an existing Key, then click Edit or Delete to modify or remove the key value. 

5 Select a Script Type. For a complete listing of available script types, see the previous 
section, To add a new default script. 

6 Enter or modify the Script Text as needed. 
7 Click OK to save changes. 

To copy an existing script to modify for a new script: 
1 On the WhatsUp Gold web interface, go to WhatsConfigured > System Script Library. 

The Default Script Library appears. 
2 Select an existing script, then click Copy. The New Configuration Script dialog appears 

with a copy of the existing script. Use the dialog options to modify the script as desired. 
3 Enter a Description for the script. This description is displayed in the default script 

library to differentiate the script from other scripts. 
4 In the Keys section of the dialog, click Add to add a new OID or IP key and value. 

- or - 

Select an existing Key, then click Edit or Delete to modify or remove the key value. 
5 Select a Script Type. For a complete listing of available script types, see the previous 

section, To add a new default script. 
6 Enter or modify the Script Text as needed. 
7 Click OK to save changes. 
 

Importing and exporting system scripts 

To import a script file: 
1 Go to the System Script Library: 

On the WhatsUp Gold web interface, go to Configured > System Script Library. The 
System Script Library appears. 

2 Click Import. The Import WhatsConfigured System Script dialog appears. 
3 Click Browse. The Choose File to Upload dialog appears.  
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4 Navigate to the .xml file you want to import, then click Open. The script is added to 
the System Script Library. 

 Note: If the .xml file that you are importing is identical to any existing templates stored in 
the library, the file does not import. 

To export a template: 

 Note: You can only export user-defined system scripts. WhatsConfigured default scripts 
cannot be exported. 

1 Go to the System Script Library: 

On the WhatsUp Gold web interface, go to Configured > System Script Library. The 
System Script Library appears. 

2 Select a user-defined script, then click Export. The Export WhatsConfigured System 
Script dialog appears. 

3 Navigate to the location on your directory where you want to export the .xml file. 
4 Click Save. A copy of the file is saved in the location you specified. 
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About the CLI Settings Library 

At its base functionality, WhatsConfigured is a software created to help you automate many 
configuration tasks for your network devices. WhatsConfigured carries out these 
configuration tasks by programmatically interacting with your devices' command line 
interface (CLI). Many device vendors specify different standards for how network 
administrators interact with their CLI. For example, the character sequence in a command 
prompt, or the sequence that indicates the end of a command. To provide you with greater 
flexibility, WhatsConfigured allows you to override the default CLI settings by defining 
custom sets of CLI elements for devices from a particular vendor or for specific IP addresses. 
This helps ensure that WhatsConfigured can correctly communicate with these devices as it 
attempts to carry out tasks. The Remote CLI Settings library stores all CLI Settings used to 
issue the commands necessary to carry out WhatsConfigured tasks on your network devices.  

The library includes two default settings and various pre-defined system settings that come 
installed with WhatsConfigured. You can use these system settings, or copy them to create 
new, user-defined settings for devices that support a particular OID or a specific IP address.  

To access the Remote CLI Settings library: 

From the WhatsUp Gold web interface, go to Configured > CLI Settings Library. 

To configure new or existing settings: 

 Note: The Edit and Delete, buttons are disabled for the default and pre-configured system 
scripts, as you cannot modify or remove default or system scripts.  

§ Click New to configure a new group of settings. 

§ Select user-created setting, then click Edit to change its configuration. 

§ Select a setting, then click Copy to make a duplicate of the selected group of settings. 

§ Select a user-created setting, then click Delete to remove it from the library. 
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§ Click Import to import a script file into the library.  

§ Select a user-defined script, then click Export to save the script to another location. 

OID and device IP address keys 
The two default scripts for telnet and SSH do not use keys (OID nor IP). WhatsConfigured uses 
the default scripts to communicate with devices for which it does not find OIDs or an IP 
address. Pre-configured, system settings are based on specific OIDs, SNMP objects assigned 
by manufacturers in their private MIBs that identify different models of the equipment. 
WhatsConfigured can use these settings on any device that supports the OID specified in the 
set of CLI settings. User-defined settings can be based on either a single or grouping of OIDs, 
or on a specific device IP address. 

Filtering 
You can filter the Remote CLI Settings library for a specific device or group of devices with the 
Filter by Device list. This list is populated by previous devices by which you have filtered. The 
first time you open this dialog the list is unpopulated (<None>). To select a device for which 
to view and/or configure settings, click the Select button.  

Order of settings 
WhatsConfigured first looks for and uses user-defined settings to communicate with a device. 
If no user-specified settings exist, it looks for and uses appropriate system settings. If a device 
does not support an OID specified within any of the system settings, WhatsConfigured falls 
back on the default settings which do not specify specific OIDs.  

In the event that you configure two sets of settings for the same IP address or OID/grouping 
of OIDs, WhatsConfigured uses the last set of settings in the list, or the second set of settings 
you created for the specific IP address or OID(s).  
 

About CLI Settings 

The following CLI settings are used by WhatsConfigured to issue commands on your network 
devices. 

§ Username Prompt. The username of the Telnet or SSH credential associated with the 
device. WhatsConfigured uses this username to login to the device. 

§ Password Prompt. The password of the Telnet or SSH credential associated with the 
device. WhatsConfigured uses this password to login to the device. 

§ Command Prompt. The character sequence WhatsConfigured looks for to know it is 
the appropriate time to issue a device command. 

§ More Prompt. The character sequence WhatsConfigured looks for from the device to 
know that multiple pages of information exist.  

§ More Response. The character sequence WhatsConfigured automatically sends after 
receiving the More Prompt specified above. 

§ Login Terminator. The character sequence WhatsConfigured issues after submitting 
the credential username and password to login to the device. 
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§ Command Terminator. The character sequence WhatsConfigured issues at the end 
of a device command to submit the command to the device. 

All of the CLI settings can be specified as either strings or regular expressions. For more 
information see About strings and regular expressions in WhatsConfigured. 
 

Configuring CLI settings 

The simplest way for you to configure a new set of CLI settings is to use an existing set of 
system settings as a template and to modify the template settings as desired for use with a 
specific device or group of devices. 

To copy a set of remote CLI settings: 
1 Go to the CLI Settings Library: 

On the WhatsUp Gold web interface, go to Configured > CLI Settings Library. The CLI 
Settings Library appears. 

 Tip: By default, the dialog displays all remote CLI settings currently configured. You can filter 
this list by selecting a specific device by which to filter. 

2 Click Copy. The New Settings: Copy of ... dialog appears. 
3 Enter a unique Description for the settings. This description differentiates it from other 

settings in the Remote CLI Settings library. 
4 To add an IP address, or another OID, click Add. The Add Key dialog appears. 

Alternatively, select an existing key from the list and click Edit to modify it, or click 
Delete to remove it from the list of keys. 

5 If you add or modify a key, select the Key Type that you want to add, either oid or ip. If 
you choose to map the settings to an OID, or group of OIDs, the settings apply to any 
device with that OID that uses the SSH or Telnet credentials associated with the settings 
you are configuring. If you choose to map the settings to a specific IP address, the 
settings only apply to the device with the specific IP address you specify.  

6 Enter the appropriate OID or IP address. 
7 Click OK to add the new key and to return to the settings configuration dialog. 
8 Ensure that the correct Protocol is selected, ssh, telnet, or All. 
9 Ensure that all prompt, response and terminator boxes are specified appropriately. For 

more information about these boxes, see About CLI Settings. 

 Note: Boxes that indicate specific settings override the default settings. If boxes are blank, 
WhatsConfigured uses either the default Telnet or SSH settings for that box.   

10 Click OK to save copied/modified settings to the Remote CLI Settings library. 

If none of the existing system and/or previously-configured user settings can serve as a 
template for settings that you need, you can configure entirely new settings. 
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To configure new remote CLI settings: 
1 Go to the Remote CLI Settings dialog: 

On the WhatsUp Gold web interface, go to Configured > CLI Settings. The CLI Settings 
Library appears.  

 Tip: By default, the dialog displays all remote CLI settings currently configured. You can filter 
this list by selecting a specific device by which to filter. 

2 Click New. The New Remote Login CLI Settings dialog appears. The New Settings: New 
Remote Login CLI Settings dialog appears.  

3 Enter a unique Description for the settings. This description differentiates it from other 
settings in the Remote CLI Settings library. 

4 To add an IP address, or another OID, click Add. The Add Key dialog appears. 
5 Select the Key Type that you want to add, either oid or ip. If you choose to map the 

settings to an OID, or group of OIDs, the settings apply to any device with that OID that 
uses the SSH or Telnet credentials associated with the settings you are configuring. If 
you choose to map the settings to a specific IP address, the settings only apply to the 
device with the specific IP address you specify.  

6 Enter the appropriate OID or IP address. 
7 Click OK to add the new key and to return to the settings configuration dialog. 
8 Ensure that the correct Protocol is selected, ssh, telnet, or All. 
9 Ensure that all prompt, response and terminator boxes are specified appropriately. For 

more information about these boxes, see About CLI Settings. 

 Note: If you leave any box blank, WhatsConfigured uses either the default Telnet or SSH 
settings for that box.  

10 Click OK to save copied/modified settings to the Remote CLI Settings library. 

To remove settings from the Remote CLI Settings library: 
1 Go to the CLI Settings Library: 

On the WhatsUp Gold web interface, go to Configured > CLI Settings. The CLI Settings 
Library appears. 

2 Select a set of User settings, then click Delete. 

 Note: You cannot remove pre-defined, system settings from the Remote CLI Settings library. 

 

Importing and exporting CLI settings 

To import CLI settings: 
1 Go to the CLI Settings Library: 
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On the WhatsUp Gold web interface, go to Configured > CLI Settings. The CLI Settings 
Library appears. 

2 Click Import. The Import WhatsConfigured Remote CLI Settings dialog appears. 
3 Navigate to the location on your directory of the .xml file that you want to import.  
4 Select the file, then click OK. 
5 The file is added to the CLI Settings Library. 

 Note: If the .xml file that you are importing is identical to any existing templates stored in 
the library, the file does not import. 

To export CLI settings: 

 Note: You can only export user-defined CLI settings. WhatsConfigured default CLI settings 
cannot be exported. 

1 Go to the CLI Settings Library: 

On the WhatsUp Gold web interface, go to Configured > CLI Settings. The CLI Settings 
Library appears. 

2 Select a set of user-defined settings, then click Export. The Export Configuration 
Templates dialog appears. 

3 Navigate to the location on your directory where you want to export the .xml file. 
4 Click Save. A copy of the file is saved in the location you specified. 
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CHAPTER 12 

Using WhatsConfigured Tools 

In This Chapter 

About Archive Search ....................................................................................... 61 

Performing an archive search ........................................................................ 61 

Using the WhatsConfigured VLAN Manager ............................................ 62 
 
 

About Archive Search 

The Archive Search feature allows you to search the content of device configuration archives. 
A configuration archive is any device output captured when running a configuration 
task/script. When a configuration script is run, the output from one or more commands may 
be captured and stored in a user or system specified key. The output is saved to the device 
using the key name and the time-stamp as a look-up key. The archive is persisted with the 
device in the WhatsUp Gold database. 
 

Performing an archive search 

To perform an archive search: 
1 Go to the Archive Search dialog: 

On the WhatsUp Gold, admin console, go to Configured > Archive Search. The Archive 
Search dialog appears. 

2 Click Add. The Select Device dialog appears.  
3 Select the device(s) for which you want to perform an archive search, then click OK. 
4 Specify the Search Criteria: 

§ Select an Archive Key for which to refine search results. For example, to view running 
config archives, select the running-config key from the list. This list is populated with 
all of the keys from the archived configuration files for the selected device(s). To view 
all possible archives, select All. 

§ To view only the latest archives for the selected device(s), select Latest Archive Only. 

§ Enter a Search Pattern for which the search should attempt to find in the archived 
config files. This can be a phrase or regular expression. 

§ Select Regular Expression for the contents of search pattern to be interpreted as a 
regular expression. 

§ If the contents of the search pattern are case insensitive, select Ignore Case. 
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 Tip: Select a device, then click Remove to delete it from the list. 

5 Click Search. The dialog displays the following Search Results in the bottom half of the 
dialog: 

§ The Archive Key under which the file was saved in the database. 

§ The Device for which the config file was saved. 

§ The time at which the configuration file was created (Time Created). 

§ The name of the configuration task for which the file was collected (Created by).  

 Tip: Select an archive file, then click View to see the specific archived file. 

 

Configuration Archive Search Result 
The Configuration Archive Search Result dialog displays the following results from a 
WhatsConfigured Archive Search. 

§ The specific Archive file and the time on which it was created. 

§ The Search Pattern used by WhatsConfigured to refine search results. 

§ The relevant archived file contents for each match are displayed under Search 
Results. 

 Tip: Use the forward and backward buttons to navigate through the matches. 

Button Description 

 
Moves one match forward 

 
Moves one match backward 

 
Moves to the first match 

 
Moves to the last match 

 
 

Using the WhatsConfigured VLAN Manager 

The WhatsConfigured VLAN Manager allows users to easily and dynamically update VLAN 
configurations. Through the VLAN Manager, users can add, edit, and delete VLANs from 
individual devices. Additionally, users can easily copy and move single or multiple VLANs 
from one network device to other VLAN capable network devices through the VLAN 
Manager. 
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To access the VLAN Manager: 

§ From the WhatsUp Gold web interface, go to Configured > VLAN Config.  

VLAN Manager Requirements 
In order to manage device VLAN configurations through the WhatsConfigured VLAN 
Manager, ensure that your devices meet the following requirements. 

§ The devices you attempt to configure must have proper read/write SNMP credentials 
assigned.  

§ For Cisco devices, your device must support the Cisco VTP MIB 
(http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml).   

For more information on Cisco trunking, see Cisco's documentation 
(http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.1/19ew/configuration/guide/la
yer2.html). 

To configure device VLANs using the VLAN Manager: 
1 Click Select to choose a device from the Select Device dialog.  
2 Click Discover to discover and view the VLAN configuration for the selected device. The 

discovered VLAN information is displayed in the VLANs section of the dialog. 
3 In the VLANs section of the dialog, configure device VLANs, 

§ Click Add to add a VLAN to the device. 

§ Select a VLAN, then click Edit to modify its properties. 

 Note: You cannot edit the VLAN Index. If you want to modify a VLAN's index number, you 
must delete the VLAN and add the VLAN again with the desired index number. Additionally, 
you cannot edit VLANs that are reserved by the switch vendor. For example, default VLANs 
and Cisco Reserved (1000-1024). 

§ Select a VLAN, then click Delete to remove it from the device. 

 Note: You will be prompted before you remove a VLAN from a device. 

§ Select a VLAN, then click Copy To to duplicate the VLAN Name/Index configuration to 
another VLAN capable device. 

 Note: You can select multiple VLANs in which to copy to another network device. 
Additionally, you can copy one or more VLANs to multiple network devices at one time. 

4 In the Port VLAN Configuration section of the dialog, configure VLAN port assignments, 
and/or commit configuration changes. 

§ Select a VLAN switch port, then click Assign To to set the static (primary) VLAN ID. 

§ Select a VLAN switch port, then click Add/Edit Trunk to modify its Trunk 
configuration tags.  

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml
http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.1/19ew/configuration/guide/layer2.html
http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.1/19ew/configuration/guide/layer2.html
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§ Select a VLAN switch port, then click Remove Trunk to return the port to its default, 
non-trunking configuration. 

§ Click Commit Changes to copy the currently running config of the selected device to 
the startup config. 

5 Click Close to exit the dialog. 
 

Configuring VLAN Trunks 
Use the Add/Edit VLAN Trunk dialog to configure VLAN trunking and tagging for local 
WhatsConfigured devices.  

To configure VLAN trunk settings: 
1 Ensure that the appropriate device is selected.  
2 Select the appropriate Interface/Port.  
3 Ensure that the appropriate Primary VLAN ID (PVID) is selected.  
4 Select the VLANs to which you want to assign membership for the selected port. Click 

Select All to tag all VLANs, click Clear All to clear selection from all VLANs. 

 Note: The Primary VLAN ID (PVID) cannot be tagged. 

5 Click Apply to save changes. 
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CHAPTER 13 

Using Alert Center with WhatsConfigured 

In This Chapter 

Assigning an Alert Center threshold to a task .......................................... 65 
 
 

Assigning an Alert Center threshold to a task 

You can assign an Alert Center threshold to a task to notify you on task activities. This is done 
from the Threshold tab of the WhatsConfigured Task dialog. 

After you have assigned a threshold to a task, a custom threshold dashboard report for the 
task threshold is displayed on the Alert Center tab. 

To assign a threshold to a WhatsConfigured task: 
1 Navigate to the WhatsConfigured Task Library (Configured > Task Library). The 

WhatsConfigured Task Library appears. 
2 Do one of the following: 

§ Click New to configure a new task. The Select Task type dialog appears.  

§ Select Schedulable Task, then click OK. The New WhatsConfigured Task dialog 
appears. 

§ - or - 

§ Select an existing task, then click Edit. The Edit WhatsConfigured Task dialog appears. 
3 Select the Threshold tab. The threshold tab appears. 
4 Select Enable this threshold to enable and configure the threshold options. 
5 Enter a Name for the threshold. This name is displayed in the WhatsUp Gold Alert 

Center Threshold Library. 
6 Select to have the Threshold alert when any of the following criteria are met:   

§ Detects configuration changes on a device 

§ Fails to run for a device 

§ Successfully runs for a device 

§ Fails these policies (Select one or more policies from the list. Click Add Policies if the 
list is empty or to add a new Policy.) 

7 Select the Alert Center Notification Policy you would like Alert Center to use to notify 
you when the threshold is met. If the list is empty or you want to configure a new 
notification policy, go to the Alert Center Notification Policy Library (Alert Center > 
Notification Policies) to create a Notification Policy. 
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CHAPTER 14 

Managing the WhatsConfigured and TFTP 
services 

In This Chapter 

Starting, stopping and restarting WhatsConfigured services ............ 66 
 
 

Starting, stopping and restarting WhatsConfigured 
services 

To start, stop or restart the WhatsConfigured or TFTP service: 
1 Navigate to the TFTP Server (Start > Programs > Ipswitch TFTP Server). 
2 Refer to the application Help for instructions on how to interact with the TFTP Server. 
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