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Typographic Conventions

Convention Meaning

Abbreviated menu 
commands

This document uses abbreviated menu.

For example, "Click  Display > Toolbars > Standard" means that you should 
click the Display menu, point to Toolbars, and click the Standard entry.

Boldface type Boldface type is used for commands, keywords, file names URLs, or other 
information that you must use literally.

Name of windows, dialogs, and other controls also appear in boldface type.

Initial Capital Letters The first letter of the names of menus, dialog boxes, dialog box elements, and 
commands are capitalized.

<Text in angle 
brackets>

Angle brackets are used for variables and values that you must provide.

Emphasized type Emphasized type is used for words and phrases that need to be emphasized, as 
for new terms defined in the text.

Monospace Code and script examples appear in a monospace font.

Plus sign in text Keyboard shortcuts are indicated by a plus sign separating key names.

For example, Ctrl+F1 means that you must press the Ctrl and F1 keys at the 
same time.
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Introduction
Chapter 1 Introduction 

The Position Report Manager User Guide for Approved Participants has been created for 
the Position Report Manager application, developed by the Technology division of the 
Montréal Exchange Inc. , a member of the TMX Group Inc.

1.1 Purpose
The purpose of the application enables Approved Participants (APs) to submit their open 
positions and account information on a daily basis to the Montréal Exchange Inc. 
Regulatory (MX-R).

1.2 Scope
This guide will provide a detailed description of the Position Report Manager (PRM) 
application that Approved Participants will use to enter their client’s positions and account 
information for the MX-R.

Topics covered in this guide will include:

• Application Overview
• Getting Started

• Connecting to the application (Login)
• Getting around the application
• Disconnecting from the application (Logout)

• Entering and submitting positions and client information
• Description of data fields
• Tools to facilitate the searching and analysis of data
• Manipulation of data windows within the Workspace
• Help Menu information on the format required to import Position and Account data

1.3 Audience
The Position Report Manager User Guide for Approved Participants will be primarily used 
by Approved Participants.
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Application Overview
Chapter 2 Application Overview 

The Position Report Manager application enables Approved Participants to report open 
positions and account information. Open position data will be on options, futures, and 
futures on options.

The illustration below shows the various components of the LOPR System and the 
interaction of the Approved Participants and MX-R.

Figure 1: Services Offered by SOLA® LOPR System
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2.1 Objectives
To significantly reduce the time required by Approved Participants to prepare and submit 
open positions and client information, and to increase the accuracy of the submitted data.

2.2 Account Details
Approved Participants will create new Account records for each of their clients for 
submission to MX-R. Account records can be modified or deleted as required. Data fields 
that make up an Account record are as follows:

• AffiliatedCie
• AccountNumber
• AccountType
• AccountOwnerType
• OwnerId
• HedgeSpec
• Name
• Address
• City
• State (Province)
• ZipPostalCode
• Phone
• Fax
• Email
• CountryCode

For details on how to create, modify, or delete Account records, please refer to Chapter 4, 
Business Item - Accounts.
Montréal Exchange Inc. Page 4 External
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Application Overview
2.3 Position Details
Approved Participants will create open Position records for each of their Accounts for 
submission to MX-R on a daily basis. 

Note: In the event the Approved Participant has no open positions to report on a given day, 
notification to MX-R that there are no positions to report must still be submitted. Refer to 
Chapter 5, Business Item - Positions, for details on how this is accomplished.

Position records can be modified or deleted as required. Data fields that make up a 
Position record are as follows:

• ReportDate
• AccountNumber
• ExternalSymbol
• ClassSymbol
• ExpirationDate
• CallPutCode
• StrikePrice
• LongQuantity
• ShortQuantity

For details on how to create, modify, or delete Position records, please refer to Chapter 5, 
Business Item - Positions.

Note: It is also possible for Approved Participants to create a CSV file for their Position records, 
which can then be ’Imported’. Import formats for CSV files will be covered in Chapter 7, 
Importing CSV Files.
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Getting Started
Chapter 3 Getting Started

This chapter introduces the user to the Position Report Manager application. Topics that 
will be covered are:

• Starting the Application
• Connecting / Disconnecting
• Navigating within the Application Graphical User Interface (GUI)

3.1 Starting the Application
The application can be started in a number of ways depending on the system 
environment. Follow the instructions as presented in the following table to start Position 
Report Manager.

STEPS DESCRIPTION

1 Depending on the system environment, do one of the following:
• From the Windows status bar select Start > Programs > Position Report Manager
• Double-click the Position Report Manager icon on the PC desktop
The Position Report Manager Workspace window is displayed as follows:
Montréal Exchange Inc. Page 7 External
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3.2 Connecting / Disconnecting
Once the Position Report Manager application has been started, the next step is to 
Connect or Login to the application. Once the session is over, the user will disconnect or 
Logout from the application.

Note: When logging into the application you will be required to enter your User Name and 
Password. 

Detailed steps on how to accomplish both functions follow.

3.2.1 Login

STEPS DESCRIPTION

1 To log into the Position Report Manager application from within the Workspace window, 
do either of the following:
• From the application Main Menu options, select File > Login (shown below)
• Use the shortcut key sequence: F9

• Use the  icon from the Toolbar
Montréal Exchange Inc. Page 8 External
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Getting Started
2 • Enter your User Name and Password
The completed dialog is as follows:
• Click OK

3
To verify connectivity status, click the  icon located on the Toolbar:
The Communication Status Details window appears, as shown below, displaying 
connectivity status. 
Note: If you were not able to log in to the application, this window will display a related 

error message. For additional information on the Communication Status Details 
icon, refer to section  3.3.2, Toolbar and Icons.

• Click Clear and Exit to exit the window

STEPS DESCRIPTION
Montréal Exchange Inc. Page 9 External
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3.2.2 Logout

3.3 Navigating Within the Application Graphical User Interface (GUI) 
This section deals with navigating within the Position Report Manager GUI. Topics 
covered are:

• Main Menu Items
• Toolbar & Icons
• Workspace & Windows

3.3.1 Main Menu Bar Items

The illustration displayed below displays the top part of the GUI.

Figure 2: Application Name and Main Menu Items

STEPS DESCRIPTION

1 To log out from within the Position Report Manager application from the Workspace 
window, do either of the following:
• From the application main menu options, select File > Logout (shown below)
• Use the shortcut key sequence: Ctrl + F9
Montréal Exchange Inc. Page 10 External
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Getting Started
The top line contains the application name ’Position Report Manager’, followed by:

• Workspace: Not defined, or name of a Workspace saved as a default 

For information on working with Workspaces, refer to section  A.1, The Workspace.

The second line contains the application functions which are:

• File
• Business Item
• Tools
• Window
• Help

Table 1: Position Report Manager Main Menu Items Definition 

MAIN MENU ITEMS DESCRIPTION

File

The File menu item enables the user to:
• Log in and out of the application
• Open an existing Window or Workspace
• Save a current Window under a new name
• Save a specific Window as a default style
• Save a Workspace
• Rename a Workspace
• Save the Workspace and its contents as the default environment

Business Item

Business Item enables you to open the two main data windows in the 
PRM application.
The two windows are:

• Accounts
• Positions

It also provides you with the option:
• No Position to report
Montréal Exchange Inc. Page 11 External
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Tools

The Tools menu item enables the user to customize individual Informa-
tion Data windows, with the following functions:

• Sort
• Filter
• Hide
• Edit Column Properties
• Edit Window Title

Additional functions are:
• Export to Clipboard
• Print
• Search
• Grid Options

For detailed information on the above functions, refer to Chapter 8, Data 
Window Customization.

Window

The Window menu item enables you to change the display of open win-
dows with the following features:

• Cascade
• Tile Horizontally
• Tile Vertically
• Minimize All
• Arrange All

For detailed information on the above functions, refer to section  
A.2, Data Windows.

Help

The Help menu item contains the following entries:
• Position Import Format – field layout for .csv file
• Account Import Format – field layout for .csv file
• About… – details about the application name and version

For more information on importing .CSV files, refer to Chapter 7, 
Importing CSV Files.

Table 1: Position Report Manager Main Menu Items Definition (Continued)

MAIN MENU ITEMS DESCRIPTION
Montréal Exchange Inc. Page 12 External
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3.3.2 Toolbar and Icons

The following illustration is the Toolbar section of the Position Report Manager GUI 
window.

Figure 3: Position Report Manager Toolbar

Toolbar Icons are defined in the following table.

Table 2: Toolbar Icons Definition

ICONS DEFINITION

Log In
Keyboard Shortcut: F9 (Ctrl +F9 to Log Out)

Ascending Quick Sort
Keyboard Shortcut: Shift+F7

Descending Quick Sort
Keyboard Shortcut: Shift+F8

Remove Column Sort
Keyboard Shortcut: Shift+Ctrl+F7

Set Quick Filter
Keyboard Shortcut: Ctrl+Q

Remove Column Filter
Keyboard Shortcut: Ctrl+Alt+Q

Hide Columns
Keyboard Shortcut: Ctrl+Alt+H

Hide a single Column
Keyboard Shortcut: Ctrl+H

Print

Search
Keyboard Shortcut: Ctrl+F

Cascade Windows
Montréal Exchange Inc. Page 13 External
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3.3.3 Workspace & Windows

Workspace

When you first log into the Position Report Manager, the following workspace is 
displayed. The Workspace is where you open Business Item Data windows (refer to 
section  A.2, Data Windows for further information on working with data windows).

Figure 4: Workspace After Initial Signon

Tile Windows Horizontally

Tile Windows Vertically

View Communications Status Detail such as warnings, errors, alerts, etc.

Command History shows status of recently executed commands.
For an example of how this icon is used, refer to section  5.5, No Positions to 
Report.

Table 2: Toolbar Icons Definition

ICONS DEFINITION

Workspace

Main Menu

Functionality Description

Title Bar

Toolbar
Montréal Exchange Inc. Page 14 External
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Getting Started
Initially, the Workspace is as it appears above, empty and unnamed, unless you have 
previously set up a named Workspace to be the default Workspace. In this case, your 
default Workspace is displayed when you log in. At any time, you are able to open 
another Workspace that has been previously saved. 

The following functions that pertain to Workspaces are:

• Open Workspace…
• Save Workspace
• Save Workspace As…
• Save Workspace As Default

For further information on the above functions, refer to section  A.1, The Workspace in 
Appendix A, Workspaces and Data Windows.

Data Windows

A Data Window displays information pertaining to a Business Item and is presented in a 
multi-column format. Each column has a title that relates to a data field. Approved 
Participants are able to open Data Windows for one or more Business Items to track 
specific information such as Account and Position data. When you first open a Data 
window, it is unnamed and contains only a sequence number representing the number of 
times the Business Item has been accessed. 

The following functions that pertain to Windows are:

• Open Window…
• Save Window As…
• Save Window As Template

For further information on the above functions, refer to section  A.2, Data Windows in 
Appendix A, Workspaces and Data Windows.
Montréal Exchange Inc. Page 15 External
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Business Item - Accounts
Chapter 4 Business Item - Accounts

4.1 Opening the Accounts Data Window
The Accounts Business item enables the Approved Participant to create, modify, and 
delete an Account. To open the Business Item Accounts Data Window, follow the steps 
below:

STEPS DESCRIPTION

1 From the Main Menu, select Business Item > Accounts as indicated below:
Montréal Exchange Inc. Page 17 External
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The following Data Window titled Accounts ’X’ is displayed, where X is the sequential 
number of the Accounts Data Window that has been accessed in the current session:

2 From within the active Data Window, right-click the mouse to display the sub-menu:

STEPS DESCRIPTION
Montréal Exchange Inc. Page 18 External
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Business Item - Accounts
4.1.1 Account Sub-Menu Functionality

After right-clicking the mouse button, a sub-menu with multiple functionality is displayed 
as shown in the previous section. Available functions are explained as follows:

The top section contains items that can be used to customize Data Windows. They are:

• Sort - sort single or multiple columns
• Filter - filter for specific data
• Hide - hide single or multiple columns

• Edit Column Properties - customize individual columns for heading and layout1

• Edit Window Title - change the title of a Data Window

• Grid Options - change overall appearance of the Data Window1

For detail information on how to use the above features for customizing the Data Window, 
refer to Chapter 8, Data Window Customization.

Note: Some of the above items can also be found on the Toolbar for quicker access.

The next section consists of the following items:

• New - Creating a new Account
• Copy - Copy of an existing Account for the purpose of creating a new Account with 

similar information
• Edit Row - The ability to modify existing information within a previously entered 

Account
Note: A number of functions which are ’greyed out’ are not available to the Approved 

Participant.
• Delete - Used to delete an existing Account record
• Delete All Displayed… - used to delete multiple records displayed as a result of using 

the filter

The above functions will all be covered in the following section.

The next section of the sub-menu contains the following functions which are useful not so 
much in the customization of the Data Window, but more so in working with the contents:

The sub-menu above displays all the available functions that can be performed on 
Account records.
Note: Items which are ’greyed out’ are not available to Approved Participants.

STEPS DESCRIPTION

1. This feature is not available in Position Report Manager
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• Import - import .csv data (for more information on this, refer to Chapter 7, Importing 
CSV Files)

• Export to Clipboard - copy data to the clipboard for other uses
• Export to CSV File - export to a .csv file to be used in a spreadsheet
• Copy Row - copy the contents of a specific row
• Copy Cell - copy the contents of a specific cell
• Copy Column Values - copy the contents of an entire column

For detail information on how to use the above features, refer to Chapter 8, Data Window 
Customization.

The last section contains the following functions:

• Search… - search for data within a column
• search Column… - search for a specific column
• Print…- print the contents of a Data Window

For detail information on how to use the above features, refer to Chapter 8, Data Window 
Customization.
Montréal Exchange Inc. Page 20 External
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4.2 Working with Accounts
This section will presume that the Position Report Manager application is running and 
that the Accounts Data Window has been opened with the sub-menu displayed. If the 
Accounts Data Window is not open, refer to section  4.1, Opening the Accounts Data 
Window.

4.2.1 Creating New Account Records

STEPS DESCRIPTION

1 With the sub-menu displayed within the Data Window, do either of the following:
• Select New…
• Use the Shortcut Key: Ins

The Create Account Profile form is displayed as shown below.

Fill in the form fields as indicated below.
For an explanation on the form fields, refer to Chapter 6, Field Types.
Note: Fields with a red ’*’ must be filled.

2 • Enter the account owner name in the Name field
Montréal Exchange Inc. Page 21 External
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3 • Enter an Affiliated Company Name (optional)
4 • Enter an Account Number in the Number field
5 • Enter a unique identification for the owner in the Owner ID field
6 • Select the type of owner from the Owner Type drop-down menu
7 • Select either Hedger or Speculator from the Risk drop-down menu
8 • Select the type of account from the Account Type drop-down menu
9 • Enter the address of the account owner in the Address field

10 • Enter the Province or State of the account owner in the Province/State field
11 • Select the country of the account owner in the Country field
12 • Enter the postal code of the account owner in the Postal Code field
13 The next three fields are optional:

• Enter the phone number of the account owner in the Phone field
• Enter the fax number of the account owner in the Fax field
• Enter the email address of the account owner in the Email field

STEPS DESCRIPTION
Montréal Exchange Inc. Page 22 External
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Mo External

in the snippet below:
ntréal Exchange Inc. 23

STEPS DESCRIPTION

14 The completed form should resemble the following:

Click OK
15 If you have entered incorrect data, an error message will be displayed as indicated 
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STEPS DESCRIPTION

16 • Correct the error indicated and click OK
Note: In this example the account Number was changed to 399925

17 The following confirmation window should display as follows:

• Click OK
The resulting new Account record is displayed in the Account Data Window below.
Montréal Exchange Inc. Page 24 External
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4.2.2 Copying Account Records

This procedure is used as a quick way to create a new Account. When an existing record 
is copied, all field information is displayed. Key fields must be changed before submitting 
the new record. Those fields which contain data that is the same as the new record can 
be left as is, therefore saving some time.

To copy an existing record to create a new record, follow the steps below:

STEPS DESCRIPTION

1 With the sub-menu displayed within the Data Window, do either of the following:
• Select the Account record to be copied
• Select Copy…
• Use the Shortcut Key: Ctrl+C
Montréal Exchange Inc. Page 25 External
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The Create Account Profile form is displayed as shown below with full details from the 
copied record.

Note: At this point, the procedure follows the exact same process as creating a new 
account. Refer to section  4.2.1, Creating New Account Records, starting at Step 
2 thru Step 17.

The new Account record will be displayed in the Accounts Data Window as shown below.

STEPS DESCRIPTION
Montréal Exchange Inc. Page 26 External
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4.2.3 Editing an Account Record

This function enables the Approved Participant to modify an Account record if necessary. 
The process is the same as if a record was being copied, the exception being no new 
record will be created, only the existing record will be modified.

Note: All fields, with the exception of the Account Number can be modified.

To edit an existing record, follow the steps as outlined below.

STEPS DESCRIPTION

1 With the sub-menu displayed within the Data Window, do either of the following:
• Select the Account record to be modified
• Select Edit Row…
• Use the Shortcut Key: Ctrl+Alt+R
Montréal Exchange Inc. Page 27 External
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The Create Account Profile form is displayed as shown below with full details from the 
copied record.

2 As mentioned earlier, all fields with the exception of Account Number can be modified. 
Refer to section  4.2.1, Creating New Account Records, starting at Step 2, Step 3 and 
Step 5 thru Step 17 for information on entering/selecting data.
The new Account record will be displayed in the Accounts Data Window as shown below.
Note: The modification to the existing Account record was to change the Owner Type 

field from CanadianBroker to FundManager.

STEPS DESCRIPTION
Montréal Exchange Inc. Page 28 External
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4.3 Deleting an Account Record
On occasion it may be necessary to delete an Account Record. This feature enables the 
Approved Participant to delete Account records when called for.

To delete an Account Record, follow the steps as outlined below.

STEPS DESCRIPTION

1 With the sub-menu displayed within the Data Window, do either of the following:
• Select the Account record to be deleted
• Select Delete…
• Use the Shortcut Key: Ctrl+Del

The Single Record Deletion confirmation window is displayed as shown below.
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2 Enter the Total number of records to be deleted as indicated in the following illustration.

• Click OK
The Accounts Data Window is displayed with the previously selected Account record no 
longer present as indicated in the illustration below.

STEPS DESCRIPTION
Montréal Exchange Inc. Page 30 External
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4.4 Deleting All Displayed Records
The Delete feature enables the deletion of one record at a time. Depending on the 
number of records there are to delete, this could be time consuming. The Delete All 
Displayed feature enables the Approved Participant to display a group of records that will 
be deleted by using the ’Filter’ function in either the sub-menu, or within the main menu 
item ’Tools’.

For information on how to use the Filter on Data Window records, refer to section  
8.3, Filter, in Chapter 8, Data Window Customization.

To delete multiple records at the same time, follow the steps as outlined below.

STEPS DESCRIPTION

1 From the active Data Window, do either of the following:
• Right-click to display the sub-menu and select Filter > Filter Selection
• From the Main Menu, select Tools > Filter > Filter Selection
• Use the Shortcut Key: Ctrl+Alt+F
The Filter Definition Form is displayed.
At this point refer to section  8.3, Filter for details on how to fill out the Filter Definition 
Form.
Note: In this example, all ’Firms’ within Account Type have been filtered out.

The completed Filter Definition Form is shown below.

• Click OK
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The selected Account Records for the Account Type ’Firm’ are now displayed below.

The above two (2) records will now be deleted.
2 • Right-click in the Accounts Data Window and select Delete All Displayed… as shown 

below.

STEPS DESCRIPTION
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3 The All Displayed Record Deletion confirmation window is displayed as shown below.
As a precaution to verifying that these two (2) records are to be deleted, the Approved 
Participant is requested to enter the actual number of records in the Total number of 
records area.

• Click Yes
The two (2) records have been deleted from the Accounts Data Window.

STEPS DESCRIPTION
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Business Item - Positions
Chapter 5 Business Item - Positions

5.1 Opening the Positions Data Window
The Positions Business item enables the Approved Participant to create, modify, and 
delete Position records. To open the Business Item Positions Data Window, follow the 
steps below:

STEPS DESCRIPTION

1 From the Main Menu, select Business Item > Positions as indicated below:
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The following Data Window titled Positions X is displayed, where X is the sequential 
number of the Data Window that has been accessed in the current session:

2 From within the active Data Window, right-click the mouse to display the following sub-
menu:

STEPS DESCRIPTION
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5.1.1 Positions Sub-Menu Functionality

After right-clicking the mouse button, a sub-menu with multiple functionality is displayed 
as shown in the previous section. Available functions are explained as follows:

The top section contains items that can be used to customize Data Windows. They are:

• Sort - sort single or multiple columns
• Filter - filter for specific data
• Hide - hide single or multiple columns
• Edit Column Properties - customize individual columns for heading and layout
• Edit Window Title - change the title of a Data Window
• Grid Options - change overall appearance of the Data Window

For detail information on how to use the above features for customizing the Data Window, 
refer to Chapter 8, Data Window Customization.

Note: Some of the above items can also be found on the Toolbar for quicker access.

The next section consists of the following items:

• New - Creating a new Position
• Copy - Copy of an existing Position for the purpose of creating a new Account with 

similar information
• Edit Row - The ability to modify existing information within a previously entered 

Position
• Delete - Used to delete an existing Position record
• Delete All Displayed…- used to delete multiple records displayed as a result of using 

the filter

The above functions will all be covered in the following section.

The next section of the sub-menu contains the following functions which are useful not so 
much in the customization of the Data Window, but more so in working with the contents:

• Import - import .csv data (for more information on this, refer to Chapter 7, Importing 
CSV Files)

• Export to Clipboard - copy data to the clipboard for other uses
• Export to CSV File - export to a .csv file to be used in a spreadsheet
• Copy Row - copy the contents of a specific row

The sub-menu above displays all the available functions that can be performed on 
Positions records.

STEPS DESCRIPTION
Montréal Exchange Inc. Page 37 External



Position Report Manager User Guide for Approved Participants, v1.3
• Copy Cell - copy the contents of a specific cell
• Copy Column Values - copy the contents of an entire column

For detail information on how to use the above features, refer to Chapter 8, Data Window 
Customization.

The last section contains the following functions:

• Search… - search for data within a column
• search Column… - search for a specific column
• Print…- print the contents of a Data Window

For detail information on how to use the above features, refer to Chapter 8, Data Window 
Customization

5.2 Working with Positions
This section will presume that the Position Report Manager application is running and 
that the Positions Data Window has been opened with the sub-menu displayed. If the 
Positions Data Window is not open, refer to section  5.1, Opening the Positions Data 
Window.

5.2.1 Creating New Position Records

STEPS DESCRIPTION

1 With the sub-menu displayed within the Data Window, do either of the following:
• Select New…
• Use the Shortcut Key: Ins
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The Create a position form is displayed as shown below.

Fill in the form fields as indicated below.
For an explanation on the form fields, refer to Chapter 6, Field Types.
Note: Fields with a red ’*’ must be filled.

2 • Enter an account number in the Account Number field
3 • Enter an External Symbol by selecting from the External Symbol drop-down list as 

indicated below.
Note: Double click the External Symbol so that it fills the External Symbol field

Note: After entering the External Symbol, if a change is required, delete the existing data 
in the External Symbol field, and click the External Symbol drop-down button to 
see a refreshed list.

STEPS DESCRIPTION
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Once the External Symbol is entered, the following three fields are automatically filled:
• Class Symbol
• Call Put Code
• Strike Price

4 • Enter a quantity in the Short (Quantity) field if required1

5 • Enter a quantity in the Long (Quantity) field if required1

6 • The completed Create a position form should resemble the one below.
• Click OK

7 If you have entered incorrect data, an error message will be displayed as indicated in the 
snippet below:

Note: Neither Long or Short Quantity has been entered

• Click OK
• Correct the problem, and re-submit the Position Record

STEPS DESCRIPTION
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8 The following Create a position confirmation window is displayed as indicated below.

The Positions Data Window shows the result of adding a new record below.

1. Quantity must be positive, and Long and/or Short Quantity must be filled. If both are empty, Posi-
tion will be rejected

STEPS DESCRIPTION
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5.2.2 Copying Position Records

This procedure is used as a quick way to create a new position. When an existing record 
is copied, all field information is displayed. Key fields must be changed before submitting 
the new record. Those fields which contain data that is the same as the new record can 
be left as is, therefore saving some time.

To copy an existing record to create a new record, follow the steps below:

STEPS DESCRIPTION

1 With the sub-menu displayed within the Data Window, do either of the following:
• Select the Position record to be copied
• Select Copy…
• Use the Shortcut Key: Ctrl+C
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The Create a position form is displayed as shown below with full details from the copied 
record.

Note: At this point, the procedure follows the exact same process as creating a new 
Position. Refer to section  5.2.1, Creating New Position Records, starting at Step 
2 thru Step 8.

The new Position record will be displayed in the Positions Data Window as shown below.

STEPS DESCRIPTION
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5.2.3 Editing a Position Record

This function enables the Approved Participant to modify a Position record if necessary. 
The process is the same as if a record were being copied, the exception being no new 
record will be created, only the existing record will be modified.

Note: The only fields that can be modified are Short and Long Quantities.

To edit an existing record, follow the steps as outlined below.

STEPS DESCRIPTION

1 With the sub-menu displayed within the Data Window, do either of the following:
• Select the Position record to be modified
• Select Edit Row…
• Use the Shortcut Key: Ctrl+Alt+R
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The Modify a position form is displayed as shown below with full details.

2 As mentioned earlier, the only fields that can be modified are the Short and Long 
Quantity fields. 
• Enter a correct quantity in either the Short or Long Quantity field.
Note: In this example the Long Quantity was changed from 2000 to 2500

• Click OK to submit the modification
3 The Positions Data Window now displays the modified Long Quantity as indicated below.

STEPS DESCRIPTION
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5.3 Deleting a Position Record
On occasion it may be necessary to delete an Position Record. This feature enables the 
Approved Participant to delete Position records when called for.

To delete an Position Record, follow the steps as outlined below.

STEPS DESCRIPTION

1 With the sub-menu displayed within the Data Window, do either of the following:
• Select the Position record to be deleted
• Select Delete…
• Use the Shortcut Key: Ctrl+Del

2 The Position Deletion confirmation window is displayed as shown below.

• Click Yes
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Business Item - Positions
The Position Data Window is displayed with the previously selected Position record no 
longer present as indicated in the illustration below.

STEPS DESCRIPTION
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5.4 Deleting All Displayed Records
The Delete feature enables the deletion of one record at a time. Depending on the 
number of records there are to delete, this could be time consuming. The Delete All 
Displayed feature enables the Approved Participant to display a group of records that will 
be deleted by using the ’Filter’ function in either the sub-menu, or within the main menu 
item ’Tools’.

For information on how to use the Filter on Data Window records, refer to section  
8.3, Filter, in Chapter 8, Data Window Customization.

Do delete multiple records at the same time, follow the steps as outlined below.

STEPS DESCRIPTION

1 From the active Data Window, do either of the following:
• Right-click to display the sub-menu and select Filter > Filter Selection
• From the Main Menu, select Tools > Filter > Filter Selection
• Use the Shortcut Key: Ctrl+Alt+F
The Filter Definition Form is displayed.
At this point refer to section  8.3, Filter for details on how to fill out the Filter Definition 
Form.
Note: In this example, all ’Q0’ within Groups have been filtered out.

The completed Filter Definition Form is shown below.

• Click OK
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Business Item - Positions
The selected Position Records for the Group ’Q0’ are now displayed below.

The above three (3) records will now be deleted.
2 • Right-click in the Accounts Data Window and select Delete All Displayed… as shown 

below.

STEPS DESCRIPTION
Montréal Exchange Inc. Page 49 External



Position Report Manager User Guide for Approved Participants, v1.3
3 The All Displayed Record Deletion confirmation window is displayed as shown below.
As a precaution to verifying that these three (3) records are to be deleted, the Approved 
Participant is requested to enter the actual number of records in the Total number of 
records area.

• Click Yes
The four (4) records have been deleted from the Accounts Data Window.

STEPS DESCRIPTION
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5.5 No Positions to Report
Should an Approved Participant have no positions to report on a given day, they must still 
submit this fact to MX-R. To do this, follow the steps as outlined below.

STEPS DESCRIPTION

1 From the Main Menu, do the following:
• Select Business Items > No Position to report… as shown below.

The End of positions confirmation window is now displayed below.

• Click OK
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2 To view the result of declaring no positions, the Command History Data Window can be 
displayed below by selecting the:

• Command History icon 

The Command History Data Window is displayed indicating an 
EndOfPositionDeclaration as follows:

STEPS DESCRIPTION
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Field Types
Chapter 6 Field Types

The following tables display the format, length, and description for each field type. value 
lists (Enum) are also listed within the Description column.

Under the Format column note that:

• A = Alphabetic
• N = Numeric
• X = Alphanumeric

6.1 Account Data Fields

FIELD NAME

FO
R

M
A

T

LG
TH DESCRIPTION

Affiliated Cie X 24 If the Account Owner has affiliations to a company, 
the company name is indicated.

Account Number X 16 Account number of the owner at the Approved Partic-
ipant system.

Account Type X 1

Type of account (for Account Type definitions, refer to 
B.3, Account Types on page 104
Acceptable values are:
1 = Client
2 = Firm
8 = Market Maker
3 = Omnibus
4 = Professional
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Account Owner Type A 1

Type of owner (for Owner Type definitions, refer to 
B.2, Account Owner Types on page 103
Allowable Values are:
A = Canadian Bank
B = Foreign Bank
C = Canadian Broker
D = Foreign Broker
E = Fund Manager
F = Pension Fund
G = Government and State Owned Companies
H = Retail Client
I = Insurance Company
J = Miscellaneous
K = Hedge Funds
L = Mutual Funds
M = Commodity Trading Advisor (CTA)
N = Corporate
O = Proprietary Trading Firms Primarily Algorithmic
P = Proprietary Trading Firms Local

Owner Id X 24
Account Owner’s unique identification.
Refer to B.5, Account Owner ID on page 105

Hedge Spec A 1

Acceptable values are:
H = Hedger
S = Speculator
Note: Default value is ’S’.

Name A 25
Account Owner Name
Refer to B.4, Account Ownership on page 105

Address X 48 Account Owner Address

City A 24 Account Owner City

State A 24 Account Owner State

Zip Postal Code X 12 Account Owner Zip or Postal Code

Phone N 24 Account Owner Phone Number

Fax N 24 Account Owner Fax Number

Email X 48 Account Owner Email Address

Country Code X 2 Account Owner Country Code

FIELD NAME

FO
R

M
A

T

LG
TH DESCRIPTION
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6.2 Position Data Fields

FIELD NAME

FO
R

M
A

T

LG
TH DESCRIPTION

Report Date N 8
Acceptable format:
YYYYMMDD (year, month, day)

Submission Date N 8
Acceptable format:
YYYYMMDD (year, month, day)

Submission Time N 6
Acceptable format:
HHMMSS (Hour, Minutes, Seconds)

Account Number X 16 Account number of the owner at the Approved Partic-
ipant system.

External Symbol 1 X 30
Identification of a SOLA Instrument by MX.
Optional - Can be filled if known

Class Symbol 2 X 20 Symbol for all series of an Option or Ticker Symbol 
for a Future

Expiration Date 2 N 8
Acceptable format:
YYYYMMDD (year, month, day)

Call Put Code 2,3 A 4

Acceptable values are:
C or Call
P or Put
Note: Either a single letter or the full word will be 

accepted.

Strike Price 2,3 X 10
Price format up to 3 decimals.
Example: 12.875

Long Quantity 4 N 8 Number of contracts or shares.

Short Quantity 4 N 8 Number of contracts or shares.

1. If External Symbol is known and filled, it takes precedence over the detailed description of the 
instrument (ClassSymbol, Expiration Date, CallPutCode, and Strike Price). In other words, the 
detailed description is ignored.

2. If ExternalSymbol is filled, ClassSymbol, ExpirationDate, CallPutCode, and StrikePrice do not 
need to be filled.

3. Required for Options, optional for Futures.
4. Quantity must be positive, Long and/or Short Quantity must be filled. If both are empty, Position 

will be rejected
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Chapter 7 Importing CSV Files

When there are a large number of entries to be entered, it is possible to import a file in the 
Comma Separated Value (CSV) format, which contains all necessary data fields in their 
correct order, instead of entering individual entries one at a time using the ’New’ or ’Copy’ 
functions from the sub-menu of the respective Positions and Accounts Data Window.

7.1 Viewing Import Formats
It is possible to view the format of the import file which will contain the data fields and their 
correct order for either the Position or Account records.

For detail information on how to create a .csv file for either Positions or Accounts, refer to 
section  7.3, CSV Record Layouts.

To view the data fields in the Position .csv file, do the following.

STEPS DESCRIPTION

1 From the Main Menu, select Help > Position import format as shown below:
66



To view the data fields in the Account .csv file, do the following.

2 The Position Import File Fields window appears displaying all the data fields and their 
correct order in the Position .csv file.
• Review and click Exit.

STEPS DESCRIPTION

STEPS DESCRIPTION

1 From the Main Menu, select Help > Account import format as shown below:
66



2 The Account Import File Fields window appears displaying all the data fields and their 
correct order in the Accounts.csv file.
• Review and click Exit.

STEPS DESCRIPTION
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7.2 Importing Files in .csv Format
To import a text file in .csv format into the Position Report Manager for Accounts and 
Positions, follow the instructions given below.

Note: In this example, Accounts records will be imported.

STEPS DESCRIPTION

1 In the Accounts or Position Data Window, do the following:
• Right-click and select Import from the pop-up menu 

2 The Import Data window appears, as shown below, enabling you to select the .csv 
import file you want to import.
Do the following:
• Navigate to the folder in which the file is stored
• Select the file
• Click Open
66



3 During the import process, if errors are detected, the following Import Summary Errors 
window is displayed:

• To copy the error details to another application such as TextPad or Word click  
Copy to Clipboard

STEPS DESCRIPTION
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Note: Correct the records in error and re-import (depending on number of errors), or 
enter directly as a New record

Do either of the following:
• Click Clear and Exit to remove error details and close the window
• Click Cancel to close the window

4 Once the application has completed the import process, a log window called 
Importation Status appears displaying the results of the import. If the import contained 
records in error, a message is displayed similar to the one shown below.
• Click OK

5 As a result of the import process, seven records have been processed to the Accounts 1 
data window as indicated in the following illustration:

STEPS DESCRIPTION
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7.3 CSV Record Layouts
The following tables define the Comma Separated Values (CSV) that are required for 
import into the Position Report Manager for both the Account Record and the Position 
Record.

Note: Fields must be separated by the semi-colon (;) character.

Not all fields are mandatory. That being the case, the following legend will be used for the 
Req./Opt. column:

• R = Required
• O = Optional

For the FMT column, the following legend will be used:

• A = Alphabetic
• N = Numeric (digits 0 thru 9)
• X = Alphanumeric 

Note: The header line is mandatory, and must appear as the first line in the .csv file(s) for import 
of both the accounts and positions records. Refer to section  7.4, Header Samples for 
examples of the header line.

7.3.1 Account Record

ACCOUNT DATA FMT MAX.LGTH REQ/OPT
AffiliatedCie X 24 O
AccountNumber X 16 R
AccountType N 1 R
AccountOwnerType A 1 R
OwnerId X 24 R
HedgeSpec A 1 R
Name A 25 R
Address X 48 R
City A 24 R
State A 24 R
ZipPostalCode X 12 R
Phone N 24 O
Fax N 24 O
Email X 48 O
CountryCode X 2 R
66



7.3.2 Position Record

POSITION DATA FMT MAX.LGTH REQ/OPT
ReportDate N 8 R
AccountNumber X 16 R
ExternalSymbol X 30 O1

ClassSymbol X 20 O2

ExpirationDate N 8 O2

CallPutCode A 4 O2,3

StrikePrice X 10 O2,3

LongQuantity N 8 R4

ShortQuantity N 8 R4

1. If External Symbol is known and filled, it takes precedence over the detailed description of the 
instrument (ClassSymbol, Expiration Date, CallPutCode, and Strike Price). In other words, the 
detailed description is ignored.

2. If ExternalSymbol is filled, ClassSymbol, ExpirationDate, CallPutCode, and StrikePrice do not 
need to be filled.

3. Required for Options, optional for Futures
4. Quantity must be positive, and Long and/or Short Quantity must be filled. If both are empty, Posi-

tion will be rejected.
66
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4 Header Samples

4.1 Account Record Header

The following is an example of the Account Record Header:

iliatedCie;AccountNumber;AccountType;AccountOwnerType;OwnerId;HedgeSpec;Name;Address;City;State;ZipP

;BG1002003;1;E;12345654321;S;Bob Gauthier;1234 Oak Street;Montreal;Quebec;H1H 2O2;5555555555;666666

4.2 Position Record Header

The following is an example of the Position Record Header:

portDate;AccountNumber;ExternalSymbol;ClassSymbol;ExpirationDate;CallPutCode;StrikePrice;LongQuantity;Sh

110228;BG1002003;;ABX;20110122;Call;38.00;275;;
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Data Window Customization
Chapter 8 Data Window Customization

8.1 Introduction
This section explains the various functions that are available to a user for the purpose of 
customizing a Data Window in an effort to facilitate information tracking.

When viewing the contents of a Data Window, the user uses the horizontal scroll bar at 
the bottom of the window to scroll across the columns searching for specific information. 
With the amount of information being viewed, it is not uncommon for specific information 
to leave the window, resulting in the user having to scroll again to find it. The user uses 
the vertical scroll bar on the right side of the window to search for and view information 
within a specific column.

The Main Menu item ’Tools’ contains a number of functions that will enable users to 
customize a Data Window to their own specific requirements. These functions along with 
additional functions are also available by:

• Right-clicking from within an active Data Window to display the sub-menu
• Selecting the appropriate ’Icon’ from the ToolBar

The table below lists the functions along with a brief description, that are available from 
within the Main Menu item Tools, as an Icon on the ToolBar, or from the Data Window 
sub-menu:

Note: The description for some features are self contained within the table and do not have further detail. 
Those features in ’blue’ contain a link to a more detailed description.

FEATURE DESCRIPTION

Sort Enables the user to sort a single column in either ascending or 
descending order, or perform a complex sort using multiple columns.

Filter

Enables the user to filter information pertaining to the selected cell. 
For example, clicking within a cell under the column Product Type, 
with the contents indicating ’Bond’, then by selecting the Filter 
option, only data for Bond records will be displayed. The Filter Crite-
ria selection enables the user to use more than one field type to 
select specific filter criteria.

Hide Enables the user to quickly ’Hide’ a column by not displaying it, or to 
hide multiple columns as required.
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8.2 Sort
Sorting allows you to sort information within a Business Item window. This option can be 
used for locating specific Accounts or Positions, or Positions within a specific Account.

To sort data within a Business Item window, follow the instructions given below.

Edit Column Properties

Column titles that appear on the data window are quite often trun-
cated to minimize space. In some cases the user must ’lock onto’ 
the cell border and stretch the column to display the full title. 
To alleviate this, the user can change the name of the column title to 
a more meaningful name. Additionally, both the colour of the column 
background and the font colour can be changed, to either bring 
attention to new data as the window is updated, or to make search-
ing for a particular column easier.

Editing Window Title
Enables the user to change the title of a Data window from the 
sequential number that is assigned to the window to a more mean-
ingful name.

Grid Options Note: This feature is not available to the Position Report Manager.

Import
Enables the user to import a .csv file directly into the Data Window. 
For more information on this topic, refer to Chapter 7 Importing 
CSV Files

Exporting to Clipboard
Enables the user to export the contents of the Data Window to the 
clipboard, where it can be pasted into another application for further 
use.

Export to CSV File

Enables the user to export the contents of the Data Window in a 
CSV (Comma Separator Value) format, where it can be opened 
within another application such as Excel, for further use. The file is 
exported to the working directory set up for the Approved Participant

Copy Row Copies the contents of an entire row.
Copy Cell Copies the contents of a single cell.
Copy Column Values Copies the values within a column.
Search Enable the user to search specific content within a selected column.
Search Column Enable the user to search for a specific column.
Print Enables users to print the contents of a Data window.

FEATURE DESCRIPTION

STEPS DESCRIPTION

1 From within an active Data Window, do either of the following:
• Right-click the mouse button and select Sort > Sort Criteria as shown below.
• From the Main Menu item Tools, select Sort > Sort Criteria
• Use the Shortcut Keys: Ctrl+Alt+S
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2 The following Sort Selection Form will appear.

STEPS DESCRIPTION
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8.3 Filter
Filtering allows you to filter information within a Business Item window so that only the 
records that contain the data you are interested in are displayed.

The filtering option allows you to select specific data in order to record data or print 
reports.

To filter data within an open Business Item window, follow the instructions given below.

3 Select the fields according to which one you want to sort, by clicking on the field name in 
the Fields box and then clicking the > arrow to copy it to the Sort By Fields box. 
Repeat this for each field you wish to sort by.
Clicking on >> arrows move all fields to the Sort by Fields box.
Note: All field names are displayed in alphabetical order in the Fields list. To sort by one 

or many fields, the fields need to be copied from the Fields list to the Sort by Fields 
list by clicking on the field and pressing the > arrow.

To remove a field from the Sort by Fields list, click on the field name and then click on the 
< arrow.
Clicking on << arrows removes all fields from the Sort by Fields box.

4 Select items in the Sort By Fields box to include them in the sort (ascending only), by 
clicking on the check box beside each field.
Note: To deselect an item, click on the check box to remove the check mark. This will 

remove it from the sort process.
5 Use the Up and Down buttons to change the position of a field name from the order in 

which it appears in the sort list.
6 Click OK when the sort criteria selection is completed.

STEPS DESCRIPTION

STEPS DESCRIPTION

1 From within an active Data Window, do either of the following:
• Right-click the mouse button and select Filter > Filter Selection as shown below.
• From the Main Menu item Tools, select Filter > Filter Selection
• Use the Shortcut Keys: Ctrl+Alt+F
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2 The Filter Definition Form is displayed as follows.

STEPS DESCRIPTION
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3 All column (field) names are displayed in alphabetical order in the Columns list.To set fil-
ters for a column; click on the box beside the column name to select it. 
Note: Filter settings for multiple columns can be set, but each one must be set 

individually.

Under the Columns list, a box will be displayed which will allow the user to compare the 
value of multiple columns. 
In addition, a filter negation box will be available which will enable the user to put a global 
negation on all of the filters set for each column.

4 When a column has been selected, the Filter Condition in the center of the window 
becomes active, and all of the different data values in the column are displayed in 
sequential order in the box on the right side of the screen.

5 Select your filter criteria.
6 You can make the filter criteria negative by clicking on the box beside Negation and this 

will set a negation on the column selected.
Note: The table below explains this.

7 Select options viewed on the right side of the filter condition.
8 Repeat for other columns as necessary.
9 When all the fields that you want to filter by have been set,

• Click OK to perform the filter process
10 To cancel the filter process, 

• Click Cancel.

STEPS DESCRIPTION
Montréal Exchange Inc. Page 72 External
82



Data Window Customization
8.4 Hide
The Hide Column(s) function enables you to temporarily remove the selected column(s) 
from the display on your screen.

There are two formats for hiding columns:

• Hide one column
• Hide multiple columns

They can be accessed from the Main Menu Tools item, as icons on the Toolbar, or from 
the sub-menu displayed by right-clicking the mouse button in the Data Window. 

To hide a single column, simply position the cursor in the column on the Data window 
that is to be hidden and then select the appropriate feature from any of the above 
mentioned sources. 

• For example, the icon from the Toolbar.

To hide multiple columns, follow the instructions given below.

1 From within an active Data Window, do either of the following:
• Right-click the mouse button and select Hide > Hide Columns as shown below.
• From the Main Menu item Tools, select Hide > Hide Columns
• Use the Shortcut Keys: Ctrl+Alt+H

• Select the from the Toolbar
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The Column Hiding Selection form is displayed as shown below.

2 Click the box next to the column name that you wish to hide.
Note: Multiple columns can be hidden at the same time.

3 Click OK.
The selected columns will not appear on the screen.

4 Note: To re-display the hidden columns, do the following.

• Right click and select Hide Columns from the sub-menu.
• Remove checkmarks from boxes by clicking on the boxes next to the column names to 

be re-displayed
• Click OK
Note: Re-displayed columns are not displayed where they originally were, but are 

displayed at the far right of the Data Window.
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8.5 Edit Column Properties
This function enables you to change the text of a column title to a more meaningful name, 
or to change the background or font color of a column.

To edit column properties within an open Business Item file, follow the instructions given 
below.

STEPS DESCRIPTION

1 To edit column properties, do either of the following:
• From the Main Menu choose Tools > Edit Column Properties, as shown below
• From within an active Data Window, right-click the mouse to display the sub-menu, 

and click Edit Column Properties
• Use the Shortcut Keys: Ctrl+Alt+C

The Titles Edit Form is displayed with default titles for all columns.
In this example we will change the name of the column AccountNumber to Acct-Nbr, the 
font will be red on a green background.
• Click in the second row under AccountNumber (this becomes the active column)
The name appears in the User Title area.
• Change the name to Acct-Nbr
• Click Set
The text Acct-Nbr now appears in the AccountNumber column of the Edit Titles Form.
Montréal Exchange Inc. Page 75 External



Position Report Manager User Guide for Approved Participants, v1.3
2 To change the background color of the selected column, do the following:
• Click the Background Color button
The Color palette is displayed showing the default color (white) for the background color.
• Select the color of choice (green)
The Color palette now shows the selected color as indicated below.

• Click OK 
3 To change the Foreground or font color, do the following;

• Click the Foreground Color button
The Color palette appears showing the default color of the font.
• Select the color of choice (Red)
• Click OK
The final Titles Edit Form is displayed as follows.

STEPS DESCRIPTION
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4

• Click OK
Note: The Default Colors button next to the Background and Foreground Color buttons 

will return both the font and background colors of the selected column to their 
default value. 
Under the Global Settings, the Default Titles button returns all titles to their 
default value. The Default Colors button will return both the font and background 
colors to their default value for all columns.

The result of the above changes is displayed below.

STEPS DESCRIPTION
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8.6 Editing Window Title
The Edit Window Title function allows you to change the names of any Business Item 
window.

To edit the window title of an open Business Item file, follow the instructions given below.

STEPS DESCRIPTION

1 To edit the Data Window Title, do either of the following:
• From the Main Menu choose Tools > Edit Window Title…, as shown below
• From within an active Data Window, right-click the mouse to display the sub-menu, 

and click Edit Window Title…
• Use the Shortcut Keys: Ctrl+Alt+W

2 The Window Title - Editing dialog box appears displaying the current title:
• Enter the new window title as shown below.

3 Click OK.
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8.7 Rearranging Columns
Rearrange columns by dragging and dropping the column heading to the desired 
location.

To move a column within a file, follow the instructions given below.

The title of the Data Window has changed.

STEPS DESCRIPTION

STEPS DESCRIPTION

1 Click on the heading of the column you want to move and hold the mouse button down.
2 While continuing to hold down the mouse button, move the cursor with the mouse along 

the column heading line to the location where you would like to place the column.
3 Release the mouse button.
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8.8 Exporting to Clipboard

8.8.1 When to export data to the clipboard?

The following option allows the user to copy the current screen to a clipboard for copying 
to another program. It is most often used to cut and paste information from a Business 
Item window into an Excel spreadsheet so that the user can view, manipulate, and print 
the data outside of LOPR. Prior to exporting to a clipboard, the Business Item window can 
be filtered or columns hidden/displayed so that only the desired information is exported. 
This option is frequently used to generate customized reports.

Windows can be set up for:

• Executed Reports
• Cleared All Report 
• Unallocated Screen

8.8.2 How to Export to Clipboard

To export data from a window to the clipboard, follow the instructions given below.

STEPS DESCRIPTION

1 Sort; filter the selected window, and/or display/hide columns to display what you want 
to export on the monitor. Refer to the relevant sections in this document for details. 

2 Click Tools on the menu bar at the top of the LOPR application window.
3 Click Export to Clipboard on the drop-down menu.

or
Shortcut Key: Ctrl + Ins
Note: The information is copied to the clipboard.

4 Use the clipboard function under Edit in Excel (or another program) to paste the infor-
mation into another file.
or
Shortcut Key : Ctrl + V
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8.9 Search
The Search option enables the user to search for specific data within a column. This 
function can be found in:

• The Main Menu Tools sub-menu
• By right-clicking in an active Data Window to display the sub-menu
• The Toolbar as an icon

Once the Search item has been selected, the following Find dailog box is displayed.

• Enter the search criteria in the Find what: area (can be a partial entry)
• Select the box to match on a whole word only
• Select the box to match the case (upper/lower)
• Select the direction the search will take
• Click Find Next

8.10 Search Column
This Search Column function enables the user to search for a specific column, not the 
contents. The dialog box is identical to the Search function and functions in the same 
manner.
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8.11 Print
The Print option allows you to print the contents of the current file.

8.11.1 Printing a Business Item

To print data from a Business Item window, follow the instructions given below.

Note: The Print option in will only be available if a printer is linked to the LOPR PC.

STEPS DESCRIPTION

1 Sort; filter the file, and/or display/hide columns to display what you want to export on 
the monitor. Refer to the relevant sections in this document for details.

2 To print the displayed data, do either of the following:
• From the Main Menu select Tools > Print
• From within the active Data Window, right-click the mouse to display the sub-menu, 

then click Print

• Click the icon  on the Toolbar
3 The Print dialog box will be displayed.

• Click OK on the print management window.
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Appendix A Workspaces and Data Windows

This section explains the functionality of the Workspace and Data Windows within the 
Position Report Manager application.

A.1 The Workspace
As mentioned in Chapter 3, Getting Started, When you first log into Position Report 
Manager, the Workspace is empty and unnamed, unless you have previously set up a 
named Workspace to be the default Workspace.

A.1.1 Opening a Workspace

Once you have logged in to the Position Report Manager, you can either open Data 
Windows in the current Workspace, or you can open a pre-saved Workspace from an 
earlier session, or that has been created by someone else. For information on how to 
save and name a current Workspace, refer to section  A.1.2, Saving the Workspace.

STEPS DESCRIPTION

1 To open an existing Workspace, do either of the following:
• From the Main Menu, select File > Open Workspace… as indicated below.
• Use the Shortcut Key: Ctrl+F11
102



The Open Workspace dialog window is displayed as shown below.

2 In the Open Workspace dialog window, do either of the following:
• Double-click the directory that contains the Workspace 
• Select the directory that contains the Workspace and click Open.

3 When you have located the Workspace:
• Select it and click Open as illustrated below

STEPS DESCRIPTION
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A.1.2 Saving the Workspace

To save a ’Not defined’ Workspace or the initial Workspace, after you have opened Data 
Windows for one or more Business Items, you will be required to use the Save 
Workspace As… option within the File menu. This function will also be used when it is 
necessary to rename an existing Workspace. The next time this Workspace is opened, 
the same settings will be displayed.

Note: More than one Workspace can be named and saved, however, only one can be the ’Default’ 
Workspace, and only one Workspace at a time can be accessed.

Once a Workspace has been named and is in use, to save the Workspace, use Save 
Workspace within the File menu. the Workspace will be saved with no dialog window 
intervention necessary.

In this example, a ’Not defined’ Workspace containing a renamed Data Window for the 
Business Item ’Positions’ is to be saved. Follow the steps as outlined below:

A new Workspace named Account-Position Tracking is displayed below.
Note: The Workspace contains a Positions Data Window which has also been renamed. 

For information on how to edit the title of a Data Window, refer to section  
8.6, Editing Window Title.

STEPS DESCRIPTION
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STEPS DESCRIPTION

1 To save the current Workspace with a new name, do either of the following:
• From the Main Menu, select File > Save Workspace As… as indicated below.
• Use the Shortcut Key: Shift+F12

Note: The first time a Workspace is saved, you are forced to choose the Save 
Workspace As option. In the above illustration, you can see that the Save Window 
option is not available.

The Save Workspace As dialog window is displayed prompting the user to enter a 
name for the Workspace.
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2 Do the following:
• Navigate to the directory where the Workspace will be stored
• Enter the name of the Workspace (i.e. Account-Position Tracking)
The Dialog window should resemble the following illustration.

• Click Save
The Workspace now displays the new name as shown below.

STEPS DESCRIPTION
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A.1.3 Saving the Workspace As…

In the situation where a Workspace has been previously named and opened, the user 
may have altered the contents by opening new windows, modified content in one of the 
fields, or added records, yet would like to retain the original Workspace, as well as saving 
the current content. To do this, you would have to save the Workspace as a new ’named’ 
Workspace. This would leave the original Workspace untouched in the directory. Refer to 
section A.1.2, Saving the Workspace, for information on how to name or rename a 
Workspace.

A.1.4 Saving a Workspace as the Default

As you work within a Workspace, you may decide that the Workspace should be the 
default Workspace once it has been set up to your preference with specific Data 
Windows. By setting up a specific Workspace as the default, the next time you log into 
Position Report Manager, the default Workspace is displayed.

To use the Save Workspace As Default option, the Workspace must be a named. 

STEPS DESCRIPTION

1 To save the current Workspace as the Default Workspace, do either of the following:
• From the Main Menu, select File > Save Workspace As Default as indicated below.
• Use the Shortcut Key: F6
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A.2 Data Windows
A Data window displays information pertaining to a Business Item and is presented in a 
multi column format. Each column has a title that relates to a data field. Users are able to 
open Data windows for one or several Business Items to track specific information such 
as their positions or assets within the Workspace. When you first open a Data Window, it 
is unnamed and contains only a number. This number simply indicates the number of 
times the Business Item has been accessed within the current session. You are able to 
rename this Data Window with a more meaningful name by using the Edit Window Title 
feature within the Main Menu item ‘Tools’. Refer to section  8.6, Editing Window Title.

A.2.1 Open a Saved Data Window

To open an existing Business Item Data Window, follow the steps as outlined below.

Note: There is no display of a dialog box. The workspace must be a named 
workspace and therefore was previously saved to a location.

STEPS DESCRIPTION

STEPS DESCRIPTION

1 From within the current Workspace, do either of the following:

• From the Main Menu, select File > Open Window as indicated below
• Use the Shortcut Key: F11
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2 The Load Configuration dialog box is displayed. Do either of the following:
• Double-click the directory that contains the Data Window
• Select the directory that contains the Data Window and click Open.

3 In the selected directory (APL Dir), do either of the following:
• Double-click the Data Window file
• Select the Data Window file and click Open.

STEPS DESCRIPTION
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The selected Data window is displayed below.
Note: The filename of the Data Window is APL Positions, however the title of the Data 

Window is Positions (03082011).To change the title of a Data Window, refer to 
section  8.6, Editing Window Title.

STEPS DESCRIPTION
102



A.2.2 Saving a Data Window As…

To save a current Business Item Data window, follow the steps as outlined below.

STEPS DESCRIPTION

1 From within the current Workspace above, do either of the following:

• From the main menu, select File > Save Window As, as indicated below
• Use the Shortcut key: Ctrl+F12
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The Save Window dialog box is displayed.

2 • Navigate to the directory (APL Dir) where you will save the Data Window
• Enter a name for the Data Window
• Click Save

Note: Although you are asked to name the Data Window, in fact you are naming the file 
that will be stored. This name has nothing to do with the actual name of the Data 
Window. To change or edit the Data Window title, refer to section  8.6, Editing 
Window Title

STEPS DESCRIPTION
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 A.3 Window Functions within the Workspace.
As mentioned above, more than one Data window for multiple Business Items can be 
opened within a Workspace. To track or monitor a specific window within many windows 
in a Workspace, the Main Menu item ’Window’ contains a number of functions that will 
facilitate this.

Functions such as:

• Cascade
• Tile Horizontally
• Tile Vertically
• Minimizing All
• Arranging All
• Active Window Listing

A.3.1 Cascade

The following table illustrates the Cascade function on a Workspace containing four (4) 
Data windows opened at random.

STEPS DESCRIPTION

The Workspace below contains four (4) randomly opened Data windows.
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1 From within the Workspace, do either of the following to Cascade the windows:

• From the Main Menu, select Window > Cascade as shown below

• From the Toolbar, select 

The Workspace now displays the Data Windows as follows.

STEPS DESCRIPTION
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A.3.2 Tile Horizontally

The following illustrates the Tile Horizontally function on two Data windows.

STEPS DESCRIPTION

1 From within the Workspace, do either of the following to tile the windows horizontally:

• From the main menu, select Window > Tile Horizontally as shown below

• From the Toolbar, select 

The Workspace now displays the Data windows as follows.
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A.3.3 Tile Vertically

The following illustrates the Tile Vertically function on two Data Windows.

STEPS DESCRIPTION

1 From within the Workspace, do either of the following to tile the windows vertically :

• From the main menu, select Window > Tile Vertically as shown above

• From the Toolbar, select 

The Workspace now displays the Data Windows as follows.
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Note: The Tile Horizontally and Tile Vertically can sometimes display the same result when 
arranging open windows, depending on the number of windows that are ’open’. Initially, the Tile 
Horizontally will attempt to display open windows from top to bottom of the Workspace, while the 
Tile Vertically displays the windows from left to right. If enough windows are open, both features 
display the windows from top to bottom and from left to right. The top leftmost window in both 
cases is the last window opened, while the window in the bottom lower right of the Workspace is 
the first window opened.

A.3.4 Minimizing Windows

The following table illustrates the Minimize All function on four (4) Data Windows.

STEPS DESCRIPTION

1 From within the Workspace, do the following to Minimize the windows:

• From the main menu, select Window > Minimize All as shown below

The Workspace now displays the Data windows as follows.
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A.3.5 Arranging all Windows

This feature will simply arrange ’minimized windows’ in the same fashion that the 
Minimize All function does. Open windows are not affected by this feature. Only 
minimized windows will be re-arranged in the event thay have been dragged to another 
location within the Workspace

STEPS DESCRIPTION
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A.3.6 Active Window Selection

This feature enables you to select a specific window among many windows within a 
workspace. From the main menu select Window. Open window names are listed at the 
bottom of the sub-menu, with a  next to the active window in the workspace. Click on 
the required Data Window, and it becomes the active window.

STEPS DESCRIPTION

1 From within a Workspace with multiple open Data windows, do the following:

• From the main menu, select Window

2 The Active Data window contains the  beside it. 
To change to another Data window:

• Click the filename as indicated below
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This Data Window is now the active window.

STEPS DESCRIPTION
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Acronyms and Definitions
Appendix B Acronyms and Definitions

B.1 Acronyms
The following table defines some of the acronyms that are used in this document.

B.2 Account Owner Types

ACRONYM DEFINITION

CSV Comma Separated Value
ETX End-of-Text
ID Identification
LOPR Large Open Position Reporting
MX Montréal Exchange Inc.
MX-R Montréal Exchange Inc. - Regulatory

SAIL SOLA® Access Information Language

ACCOUNT OWNER TYPE DEFINITION

Canadian Bank A Schedule ’A’ Bank or Credit Union.
Foreign Bank A Schedule ’B’ Bank or a bank based outside Canada.
Canadian Broker A Broker based in Canada that is a member of IIROC.
Foreign Broker A Broker based outside Canada.

Fund Manager
A professional who manages various securities and assets to meet 
his or her clients' specified investment goals (e.g., pool operator, 
options advisor).

Pension Fund

Any plan, fund (including pension fund of government-owned corpo-
ration or State-owned enterprise), or program that provides retire-
ment income to employees or that includes schemes that result in a 
deferral of income by employees.

Government and State 
Owned Companies

A Government Ministry or a legal entity created by a government to 
undertake commercial activities for an owner government.

Retail Client Generally refers to individuals, families and small businesses.

Insurance Company A company that provides insurance coverage to a person or entity 
that buys an insurance policy.

Miscellaneous Refers to all other client types.

Hedge Funds
An investment fund open to a limited number of investors, and that 
takes on investments that carry a higher degree of risk than the risk 
taken by traditional investment funds.
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B.3 Account Types

Mutual Funds A professionally managed investment scheme that pools money 
from investors and that invests it in various investment securities.

Commodity Trading  
Advisor (CTA) An asset manager or a firm that invests in the futures market.

Corporate

An entity that is engaged in a commercial activity (other than portfo-
lio management   and other than Financial institutions, brokers and 
Government - owned corporation) that is granted a charter recogniz-
ing it as a separate legal entity which has its own rights, privileges, 
and liabilities and which are distinct from those of its shareholders.

Proprietary Trading Firms 
Primarily Algorithmic

A Trader who trades primarily for his or her own account using a 
computer programmed with an algorithm.

Proprietary Trading Firms 
Local A Trader who trades primarily for his or her own account.

ACCOUNT OWNER TYPE DEFINITION

ACCOUNT TYPE DEFINITION

Client

Means an order for a security or a derivative instrument entered for 
the account of a customer of any Approved Participant, or of a cus-
tomer of a related firm of an Approved Participant, but does not 
include an order entered for an account in which an Approved Par-
ticipant, a related firm of an Approved Participant, a person 
approved by the Bourse or a restricted trading permit holder has a 
direct or indirect interest, other than an interest in a commission 
charged.

Firm

Means an order for a security or a derivative instrument for an 
account in which the Approved Participant or a related firm of the 
Approved Participant has a direct or indirect interest, other than an 
interest in a commission charged.

Market Maker
An account established by an Approved Participant that is confined 
to transactions executed by and positions carried by the Approved 
Participant on behalf of a Market-Maker.

Omnibus
An account held in the name of an entity or person which may be uti-
lized for recording and clearing the trades of two or more undis-
closed customers of the account holder.

Professional

Means an order for a security or a derivative instrument for an 
account in which a director, officer, partner, employee or agent of an 
Approved Participant or of a related firm of the Approved Participant, 
a person approved by the Bourse or a restricted trading permit 
holder has a direct or indirect interest, other than an interest in a 
commission charged. The Bourse may designate any order as being 
an order for the account of a professional if, in its opinion, circum-
stances justify it.
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 B.4 Account Ownership
For the purposes of the LOPR project, the account ownership shall be determined by 
applying the following subsequent steps:

A. Person or entity that has more than 50% ownership interest in the account

B. Name of the account (e.g. Mr. and Mrs. Smith, ABC Investment club),

It is the approved participants' responsibility to determine account ownership based on 
the information that has been or can be provided by the account owner(s). In case of 
doubt, approved participants should not hesitate to communicate with the Division to 
assist them in determining whether or not accounts should be considered as having the 
same owner(s).

Note: The Account Owner "Name" field can accommodate up to 25 characters. If the full 
account owner name should exceed 25 characters, use abbreviations which best 
describes the entity. (Do not hesitate to contact the Regulatory division for guidance).

 B.5 Account Owner ID
The Account Owner ID field will allow the Division to assign a unique identifier to a 
Beneficial Account Owner in order to aggregate positions through different account 
numbers across all approved participants for each said account owner. For more 
information on aggregating positions, refer to B.6, Account Aggregation on page 107.

The following guidelines are to be used when populating the Account Owner ID field for 
LOPR with possible escalation when there is a legitimate unavailability of the required 
information:

A. For an account in the name of an individual or of a registered1 or corporate entity 
owned exclusively2 by this individual:
The Account Owner ID  unique identifier that must be used are:
• For Canadian residents: last 4 digits of the Social Insurance Number (SIN)
• For U.S. residents : Social Security Number (SSN)
• For other countries residents: similar number such as, for example, tax 

identification number

If, and only if, the above identifiers are unavailable, approved participants will be allowed 
to use one of the following identifiers:

1. Internal identifier used by the approved participant to link accounts belonging to 
the same beneficial account owner within the firm.

2. Account owner's last name

1. The term " registered " means a business name that has been registered by an individual in order to 
reserve that name.  A registered entity is not a corporation.

2. An example of a corporation exclusively owned by an individual is a personal holding corporation created 
for tax or estate planning purposes.
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B. For an account belonging to multiple individuals (partnerships, joint accounts, invest-
ment clubs, registered entities other than corporations, etc) :

1. If one of the account owners holds an ownership interest of more than 50% in the 
account, then use the succession of identifiers found in A) above related to this 
account owner. 

2. For all other circumstances populate field with account's name (e.g. Mr. & Mrs. 
Smith, ABC Investment club etc..). Please note that the Account Owner ID field 
can accommodate up to 24 characters. If the full account name should exceed 24 
characters, create an acronym from the entity's legal name. (Do not hesitate to 
contact the Regulatory division for guidance). 

C. For an account belonging to a Corporation other than a Corporation 100% owned by 
one individual (see A) above:

1. If the corporation is more than 50% owned by an individual, then use the succes-
sion of identifiers found in A) above related to this account owner.

2. If the corporation is more than 50% owned by another corporation, then use the 
incorporation number of the controlling corporation.

3. For other cases, the Account Owner unique identifier that must be used is the 
incorporation number of the corporation in whose name the account is opened.

If, and only if, the above identifiers are not available, approved participants will be allowed 
to use one of the following identifiers:

1. Internal identifier used by the approved participant to link accounts belonging to 
the same beneficial account owner within the firm.

2. Account owner corporate legal name. Please note that the Account Owner ID field 
can accommodate up to 24 characters. If the full account owner corporate legal 
name should exceed  24 characters create an acronym from the legal name. (Do 
not hesitate to contact the Regulatory division for guidance).

D. For any account not covered in sections A) B) or C)

1. Registration number (e.g.:: charitable organization)
2. Internal identifier used by the approved participant to link accounts belonging to 

the same beneficial account owner within the firm.
3. Account owner legal name. Please note that the Account Owner ID field can 

accommodate up to 24 characters. If the full account owner legal name should 
exceed  24 characters create an acronym from the legal name. (Do not hesitate to 
contact the Regulatory division for guidance).
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 B.6 Account Aggregation
In order to determine if the reporting threshold is attained, approved participants must 
aggregate positions belonging to the same beneficial account owner as previously 
defined in sections B.4 and B.5 above.  

The following guidelines are to be used when aggregating by beneficial Account Owner 
for LOPR:

A. Aggregate positions for all accounts in the name of an individual and for all registered 
or corporate entities owned exclusively by that single individual. 

B. For accounts belonging to multiple individuals (partnerships, joint accounts, invest-
ment clubs, registered entities other than corporations, etc), aggregate positions to 
the account owner who holds an ownership interest of more than 50% in the account.

C. For accounts belonging to a corporation, other than 100% owned by one individual, or 
any other entity, aggregation of position shall be done by beneficial ownership of the 
account.

In all cases, aggregation of positions shall be done by beneficial account owner as 
determined by the approved participant and/or its clients and/or its account owners 
directly.  Accounts traded by registered persons pursuant to some discretionary trading 
authorization such as managed accounts and discretionary (carte blanche) accounts 
must not be aggregated except for those accounts that have a common beneficial owner.

Once it has been determined that the reporting threshold has been attained for a 
beneficial account owner after aggregating all positions held in his accounts, each of 
these accounts containing positions must be reported separately in LOPR.

Example: same account owner (Mr. X) may have multiple accounts 

RRSP: Long 50 CALL RIM @ 50 JUN 11

TFSA : Long 200 PUT RIM @ 52 SEP 11

Margin CDN: Long 50 CALL RIM @ 60 JAN 12

Although the accounts taken individually do not meet the reporting threshold, once 
aggregated by account owner (Mr. X) the cumulative open position exceeds the reporting 
threshold (300 total open contracts on same underlying). Therefore, each of the three 
accounts above must be reported and this in a separate manner.
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