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Introduction

The Matisse Editor is an application development tool that can be used by
developers and database administrators to view, create, modify, or delete
database objects.

Conventions
This document uses the following conventions:

Text

The running text is written in 9-point Times.

Code
All computer variables, code, commands and interactions are
shown in 9-point Courier.
Code and commands that the user must enter are shown in this font
on a gray background.

variable
In a program example, or in an interaction, a variable, which means
anything that is dependent on the user environment, is written in 9-
point Courier italics.

References
References to another part of the Matisse documentation are made
in 9-point Arial.



1 Getting Started

1.1 Starting the Matisse Editor
1. Select mt_editor from the Matisse folder of the Start menu, or enter

mt_editor at a command prompt.

2. In the Client connection dialog, enter the name of the database you wish to
edit. If the database is not local, enter the host, username, and password as
necessary. If you wish to select a particular version for editing, check
Choose Version (see section 2.1, Selecting a Different Version (Logical
Time)).

3. Click OK.

The Matisse Editor will establish a connection with the specified database on
the specified host. After a successful connection, the message “Connected to
database_name at host_name” appears in the title of the window. If connection
is unsuccessful, “No database selected” or an error message appears instead.
After you connect to a database, the Matisse Editor appears:

The left frame displays all the objects in the database as a browsable tree. (If
you do not see two frames, drag the separator bar to the middle of the window.)
The right frame displays information on the currently selected object. (To select
an object in the tree, double-click.) The status bar at the bottom of the window
displays the connection status.
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2 Working with Databases

2.1 Selecting a Different Version (Logical Time)
If multiple versions of the database have
been created by declaring savetimes, you
may select a saved version to edit instead.

1. Select Database -> Set Time.

2. Select the savetime you wish to edit
and click OK.

NOTE: How the Matisse Editor
handles new savetimes
declared while it is running is
determined by the setting
chosen on the Versions tab of
User Preferences.

2.2 Connecting to a Different Database
Before you can connect to a different database you must disconnect the one you
are currently editing.

1. Select Database -> Disconnect and click OK to confirm. (If this command is
greyed out, abort or commit the current transaction.)

2. Select Database -> Connect.

Proceed as described in section 1.1, Starting the Matisse Editor.

2.3 Importing and Exporting Database Schema
The menu choices under Database -> Schema allow you to generate a Matisse
ODL file from the currently selected database’s schema, or update the
database’s schema from an ODL file. See Getting Started with Matisse for more
information on these options.
8 Matisse Editor User Guide for MS Windows



3 Editing Objects

3.1 Selecting an Object for Editing
You may select an object to view or edit its properties by double-clicking it in
the tree. Alternatively, you may select an object with one of the following
methods.

Browsing
Instances of an
Existing Class

1. Select Object -> Class
Instances to display the “Class
browser” window:

2. Select the name of the class
whose instances you want to
browse, and click OK.

The “Instances browser” window
will appear with a list of instances
of the selected class. Select one
and click OK to display its
properties.

The most recently selected
instances may be redisplayed by
selecting Collections -> Last Class
Instances.

Browsing Entry
Points

When you create the schema for your
application, you can specify a make entry
function to be associated with some of the
attributes. If so, the related objects can be
found by specifying an entry point value.

1. Select Object -> Entry Point to display
the Matisse Entry Point dialog.

2. Select an attribute for which an entry
point has been defined in the schema.

3. If you wish to restrict the request to a
particular class, select it.

4. Click OK.

5. If Matisse finds more than one
matching object, it will display the
“Entry Point instance browser” dialog. Select the instance you want and
click OK.
Editing Objects 9



The most recently selected entry points may be redisplayed by selecting
Collections -> Last Entry Points.

Finding an
Object with a
SQL Query

1. Select Object - > SQL Query.

2. Enter a SQL statement using the syntax:

select ref (x) from class_name into x where
attribute_name like value into sel

For example, if the application had a class Person with an attribute
LastName, to find a person named Smith:

select ref (x) from Person into x where LastName like
'Smith' into sel

If useful, you may paste a SQL query copied from a text editor or other
application. See the Matisse SQL Programmer’s Guide for more
information.

3. Click Execute.

4. If you want to edit an object among the results, click on the object reference
that is listed as part of the result set. The object properties will appear in the
main Object Editor window.

Finding an
Object by its
Identifier

Select Object -> Object Identifier, enter the identifier of the object you wish to
select, and click OK.

Access an
Object Through
a Relationship

An object may have relationships with other objects. These relationships are
represented as object names within a list:

To access any object that is referenced by a relationship, just click the
reference.

3.2 Starting and Ending an Edit Transaction
When you select Object -> Edit, or Object -> Create, the changes you make are
not immediately applied to the database. Instead, the Matisse Editor
accumulates your changes in an edit transaction. A single transaction may
include changes to an unlimited number of objects.
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Your changes are not applied to the database until you select Transaction ->
Commit or Transaction -> Commit & Name as discussed below. Alternatively,
you may abandon your changes at any time by selecting Transaction -> Abort.

1. If you are editing an instance (as opposed to a schema object) and need to
select new or different successors for one or more of its relationships,
browse the new successors. This will add them to the Edit Relationship
dialog’s “possible successors” list. (See section 3.4, Editing Relationships,
for more details.)

2. Select an object by double-clicking it in the tree or with one of the
alternative methods described in the previous section. Select Object -> Edit.
(If this command is greyed out, you do not have write access to the
database.) Buttons appear next to the object’s editable properties, as shown
below.

NOTE: Selecting edit automatically selects the current version of the
database.

3. Edit the object’s attributes values as desired.

To set NULL or return the value to its default, click its “…” button. See
Setting NULL or Default Value on page 12 for more information.

To change a relationship, click its “…” button. See section 3.4, Editing
Relationships for more information.
Editing Objects 11



When you click OK, the Matisse Editor checks the consistency of the
changes against the schema constraints. Certain changes that would produce
an inconsistency will produce an error message, and the Transaction ->
Commit and Transaction -> Commit & Name buttons will be greyed out
until the inconsistency is corrected.

4. If you wish, select and edit additional objects.

5. When you have finished making changes, select Transaction -> Commit to
update the current version of the database, or Transaction -> Commit &
Name to create a new version (declare a new savetime) containing your
changes. If your changes would create an inconsistency, the attempted
commit with fail with an error message.

3.3 Editing Attribute Values

The Restore and
Delete Value
Buttons

Two of the buttons in the Edit Attribute dialog are not self-explanatory:

Restore: Click to undo changes to the attribute value.

Delete Value: Click to return the attribute value to its default, as defined in
the schema.

Setting NULL or
Default Value

To set an attribute value to NULL or the default value, click the ... button and
pick NULL or “default value” from the drop-down list. Do not select “default
value” if no default value has been defined and the attribute is not nullable.

Unspecified
Value vs. NULL

[UNSPECIFIED VALUE] means (1) the attribute is nullable, (2) no default
value has been specified in the attribute descriptor, and (3) the attribute value is
currently unset for the object being browsed or edited.

NULL means that the attribute value has been set to NULL for the type.

Editing String
Values

Enter any characters. You may paste strings copied from other applications or
other fields in the editor.

Editing Float
and Double
Values

You may use scientific notation for float and double values, as for example in
23.5e12.

Editing Numeric
Values

Numeric values are values that are declared with a fixed precision and scale.
For instance Numeric (10,2) has precision 10, which means it can hold ten
digits maximum and scale 2, which means two digits on the right of the decimal
point. For instance for a Numeric (10, 2), the following values are valid:
12 Matisse Editor User Guide for MS Windows
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100000.99

-123.1

Editing
Character
Values

You may enter characters directly, or specify them using escape sequences
composed of a backslash followed by the octal code for the character: for
example, \015 for CR.

Editing Date and
Timestamp
Values

Enter dates in the format 2001-10-30. For a timestamp value, you may include
a fractional value of up to six decimal places, for example, 2001-10-30
14:10:00.000001.

Editing Time
Interval Values

Specify time intervals in days with a + or –. For example:

+256 12:10:00.000000

Editing Lists Use standard C notation. For example, {3, 4, 5} for a list of Integer values,
{"abc","def"} for a list of String values.

3.4 Editing Relationships
The Edit Relationship dialog allows you to add, remove, and reorder
successors:

You may move items between the “possible successors” and “successors” list
by double-clicking.

The “possible successors” list includes only objects that are authorized as a
successors of the selected relationship.
Editing Objects 13



When editing an instance (as opposed to a schema object), the “possible
successors” list includes only those authorized successors that appear in the
“Last browsed” lists accessible via the Collections menu. This limitation is
necessary because with large or complex databases the list could easily include
thousands of objects. Thus, as discussed section 3.2, Starting and Ending an Edit
Transaction, it is necessary to browse the new successors before attempting to
edit the relationship.

Adding objects in the Possible Successors area is also possible by using the
Class Instances or Entry Point options.

3.5 Creating a New Object
1. Select Object -> Create. (If this command is greyed out, you do not have

write access to the database.)

2. Select the class for the new object and click OK.

Continue as when editing an existing object, as discussed in section 3.2,

Starting and Ending an Edit Transaction.

3.6 Deleting an Object
1. Select the object to be deleted using one of the methods discussed in

section 3.1, Selecting an Object for Editing.

2. Select Object -> Edit. (If this command is greyed out, you do not have write
access to the database.)

3. Select Object -> Delete.

4. Select Transactions -> Commit or Transactions -> Commit & Name (see
section 3.2, Starting and Ending an Edit Transaction).
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4 Setting User Preferences

Select View -> User Preferences to set the following options.

Streams /
Number of
Objects

Sets the maximum number of objects that the Matisse Editor will display for a
given stream, for example, the stream returned for Class Instances.

Streams / First
Object Offset

Specifies the minimum number of instances required for the Matisse Editor to
return the object. Set to 0 (the default) to return all objects.

Relationship
Ordering

As stored in the database (that is, in the order defined by the schema) or
alphabetically.

Versions Controls what happens when a new savetime is declared.

Warn you that there is a more recent version of the database and change the
Status Area contents indicating the logical number of that version.

Update automatically the objects that you are currently browsing, setting
your version access in the new version.

Do nothing, but change the Status Area contents indicating the logical
number of the new version.
Setting User Preferences 15


	Matisse® Editor User Guide for MS Windows
	Contents
	Introduction
	Conventions


	1 Getting Started
	1.1 Starting the Matisse Editor

	2 Working with Databases
	2.1 Selecting a Different Version (Logical Time)
	2.2 Connecting to a Different Database
	2.3 Importing and Exporting Database Schema

	3 Editing Objects
	3.1 Selecting an Object for Editing
	Browsing Instances of an Existing Class
	Browsing Entry Points
	Finding an Object with a SQL Query
	Finding an Object by its Identifier
	Access an Object Through a Relationship

	3.2 Starting and Ending an Edit Transaction
	3.3 Editing Attribute Values
	The Restore and Delete Value Buttons
	Setting NULL or Default Value
	Unspecified Value vs. NULL
	Editing String Values
	Editing Float and Double Values
	Editing Numeric Values
	Editing Character Values
	Editing Date and Timestamp Values
	Editing Time Interval Values
	Editing Lists

	3.4 Editing Relationships
	3.5 Creating a New Object
	3.6 Deleting an Object

	4 Setting User Preferences
	Streams / Number of Objects
	Streams / First Object Offset
	Relationship Ordering
	Versions


