
 

SensoMaker

 

User guide 
 

 

 

 

 

 

Cleiton A. Nunes; Ana Carla M. Pinheiro 

Universidade Federal de Lavras 

Lavras – MG – Brasil 

May/2014 



2 

 

Contents 

 

Installing 3 

   Installation on Microsoft Windows 3 

   Installation on Unix-like systems 3 

   Updating 3 

   Running 3 

Sample codification 4 

Tests with category scale 5 

   Setting the experiment 5 

   Performing the experiment 6 

   Arranging the data set for analysis 6 

Tests with line scale 8 

   Setting the experiment 8 

   Performing the experiment 9 

   Arranging the data set for analysis 10 

Time-intensity analysis 11 

   Setting the experiment 11 

   Performing the experiment 11 

   Data analysis 12 

   Calculated curve parameters 13 

Temporal Dominance of Sensations analysis 14 

   Setting the experiment 14 

   Performing the experiment 14 

   Data analysis 15 

Discrimination Testing 16 

   Setting the experiment 16 

   Performing the experiment 17 

   Data analysis 17 

Preference mapping 19 

   Internal preference mapping 19 

      Inserting data set 19 

      Performing analysis 19 

   External preference mapping 19 

      Inserting data set 19 

      Performing analysis 20 

Three-way preference mapping 22 

   Three-way internal preference mapping 22 

      Inserting data set 22 

      Performing analysis 22 

   Three-way external preference mapping 22 

      Inserting data set 22 

      Performing analysis 22 

Basic statistics, ANOVA and mean tests 24 

   Inserting data set 24 

   Performing tests 24 

Polynomial regression 26 

   Inserting data set 26 

   Performing regression 26 

   Obtaining regression graph 26 

Exploratory multivariate analysis (PCA and HCA) 28 

   Inserting data set 28 

   Performing PCA 29 

   Performing HCA 30 

Sequential Analysis of Wald 31 

Binomial Test 32 

Figure handling  33 

   Saving figure with high resolution 33 

   Tools on the figure window 34 

References 35 

 



3 

 

Installing 

 

Senso Maker is a computer program which was developed in the MATLAB environment. Since it is a stand-

alone application, it does not require a MATLAB license installation to run. However, it requires MATLAB 

Compiler Runtime (MCR) in order to be installed, which is available for free at SensoMaker’s website. MCR 

is a set of shared libraries which provides complete support for all the MATLAB features. 

 

Installation on Microsoft Windows 

 Download and install MCR (www.ufla.br/sensomaker). 

 Download and install SensoMaker (www.ufla.br/sensomaker). 

 

Installation on Unix-like systems 

 Install MCR and SensoMaker using Wine (www.winehq.org). 

For better viewing, install corefonts and enable fontsmooth. 

Installing corefonts using Winetricks: 

 Select default wineprefix > Install a font > check corefonts > OK 

Enabling fontsmooth using Winetricks: 

 Select default wineprefix > Change settings > check fontsmooth=rgb > OK  

 

Updating 

In order to update, go to SensoMaker’s home screen, access Help menu>Check for update. If there is a new 

version, download and install SensoMaker as reported above. MCR installation is not required for updating. 

 

Running 

Access the modules from SensoMaker home screen (Figure 1). 

Is not recommended to run it in a screen resolution lower than 1024x768. 

SensoMaker uses dot (.) as decimal mark. 

 

Figure 1. SensoMaker’s home screen 

Modules for 

data acquisition 
Modules for 

data analysis 
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Sample codification 

 

SensoMaker has a proper system to identify codified samples in the Data Acquisition modules. The 

codification system is based on a random 3-digit code which has to follow strict rules. 

To allow a correct identification of the samples when importing data, such as in the Category/Line scale 

Tests - Data Organizer or in the Discrimination Testing - Data Analysis modules, one of the 3 digits is used 

as reference. Numbers at 1
st
 digit can vary in a range from 1 to 9. Numbers at 2

nd
 and 3

rd
 digits can vary in a 

range from 0 to 9. The following examples show how the system operates. 

 

Sample A: _ 6 _ 

Samples A have 6 at 2
nd

 digit. Number 6 cannot appear at 2
nd

 digit of the other samples. Digits 1 and 3 are 

randomized, but it cannot be 2 at 1
st
 digit and 8 at 3

rd
 digit, because they are used in samples C and D 

respectively. 

 

Sample B: _ 9 _ 

Samples B have 9 at 2
nd

 digit. Number 9 cannot appear at 2
nd

 digit of the other samples. Digits 1 and 3 are 

randomized, but it cannot be 2 at 1
st
 digit and 8 at 3

rd
 digit, because they are used in samples C and D 

respectively. 

 

Sample C: 2 _ _ 

Samples C have 2 at 1
st
 digit. Number 2 cannot appear at 1

st
 digit of the other samples. Digits 2 and 3 are 

randomized, but it cannot be 6 or 9 at 2
nd

 digit and 8 at 3
rd

 digit, because they are used in samples A, B and 

D respectively. 

 

Sample D: _ _ 8 

Samples D have 8 at 3
rd

 digit. Number 8 cannot appear at 3
rd

 digit of the other samples. Digits 1 and 2 are 

randomized, but it cannot be 6 or 9 at 2
nd

 digit and 2 at 1
st
 digit, because they are used in samples A, B and 

C respectively. 
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Tests with category scale 

 

Tests with category scale
3
, such as consumer acceptance test, multiple comparison test, just about right 

scale, intensity tests and others, can be performed using Category Scale data acquisition module (Figure 3). 

The obtained data, after the testers have savored/tried all samples, are rearranged using Category/Line 

scale Tests - Data Organizer (Figure 4) in order to be analyzed. 

 

Setting the experiment 

 Select the directory to save files using menu File > Directory to save. 

 Set the number of samples, attributes and scale type (Figure 2A) using menu File > Experiment 

settings. Provide the attribute names when asked (Figure 2B). 

Note: If all attributes use a 9-point scale, set the field Number of attributes with 5-point scale in 0. If all 

attributes use a 5 or 7 point scale, set the field Number of attributes with a 5 or 7 point scale equal to the 

field Number of attributes (max. 7) (Figure 2A). 

 Set instructions for testers using menu File > Set instructions. 

Note:  

- Optionally, the scales can be altered (by other terms, or translated, etc.) using menu Edit > Set 9-point 

Scale, or Set 5 or 7 point Scale (Figure 2C). Insert the numbers and the respective terms (only 9, 7 or 5 

items). 

- Attributes are colored according to the scale (Figure 3[3]). 

 

A  
 

B  
 

C  
 
Figure 2. Setting category scale experiment 
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Performing the experiment 

After the tester has savored/tried a sample, he/she must evaluate it according to the proper scale: 

 Insert the sample code (1). 

 Provide scores for the attributes in the table (2) according to the proper scale (3). See Sample 

Codification chapter for details. 

 Insert the file name (4) (e.g. initials of the tester name). Avoid special characters and spaces in file 

name. 

 When completed, press Finish button (5). A successful message is shown and a file (.txt) is saved. The 

table is ready for a new analysis. 

 

Figure 3. Performing tests with category scale 

 

Arranging the data set for analysis 

After each tester evaluation, a new data file (.txt) is generated with the sample codes and its respective 

scores for the evaluated attributes. These files must be rearranged in order to generate a data set proper for 

analysis: one data set for each attribute, with samples in rows and tester scores in columns. The 

rearrangement can be carried out using a proper module accessed using menu Tools > Category/Line scale 

Tests - Data Organizer (Figure 4) at SensoMaker home screen, and then: 

 Select the proper number of samples (1). 

 Indicate the digit used to identify each sample (2). 

 Indicate the digit value used to identify each sample (3). 

Note: In the example, Sample 1 has 3 at 1
st
 digit, Sample 2 has 2 at 2

nd
 digit, Sample 3 has 3 at 2

nd
 digit, 

Sample 4 has 7 at 3
rd

 digit, and Sample 5 has 5 at 2
nd

 digit. See Sample Codification chapter for details. 

 Select the data type (4). Category scale in this case. 

 Press Import Data button (5). 

 Select all individual tester files (.txt) and press Open. Data set size is shown (6). 

 Select the attribute to be exported (7). 

 Select the directory to save (8) and modify the file name (9) if appropriate. 

1 

2 3 
 
 
 
 
 
3 

4                                                                  5 

3 



7 

 

 Press Save button (10). The saved file (.txt) has the tester scores (columns) for the samples (rows) (like 

Figure 14A). These files are proper to be used in the analysis modules, such as Two-way Preference 

Mapping, Three-way Preference Mapping, Multivariate Exploratory Analysis and Basic Stats/ANOVA. 

 

 

A  
 
Figure 4. Arranging data set from category scale tests 

1 
2              3          5 

4 

6 

7 

8 

9                                  10 
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Tests with line scale 

 

Tests with line scale
3
, such as Quantitative Descriptive Analysis (QDA), acceptance tests, flavor profile, 

texture profile, free profile and others, can be performed using Line Scale data acquisition module (Figure 6). 

The obtained data, after evaluations by all tasters, are rearranged using Category/Line scale Tests - Data 

Organizer (Figure 7) to be analyzed. 

 

Setting the experiment 

 Select the directory to save the files using menu File > Directory to save. 

 Set the number of samples and attributes (Figure 5A) using menu File > Experiment settings. Indicate if 

enable (structured) or disable (unstructured) scale values when asked. 

 Insert the attribute names (Figure 6[8]). 

 Set the instructions for testers using menu File > Set instructions. 

 If appropriate, set the terms at extremes of the scales using menu File > Set extremes of the scales. If 

Cancel, it is disabled. (Figure 5B) 

 

 

A  
 

B  
 

Figure 5. Setting line scale experiment 
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Performing the experiment 

After the tester has savored/tried a sample, he/she must evaluate it using line scales: 

 Insert the sample code (1). See Sample Codification chapter for details. 

 Rate the attributes using the line scale cursor (2). 

 Press Next button (3) to evaluate the next sample. 

Note: The scales are zeroed and the next sample to be tried is indicated (4). 

 When the last sample is evaluated, press OK button (5). Finish button is enabled. 

 Insert the file name (6) (e.g. initials of the tester name). Avoid special characters and spaces in file 

name. 

  Press Finish button (7). A successful message is shown and the window is ready for a new analysis. 

 

   
 

                                                                       
 
Figure 6. Performing tests with line scale 

Wen last sample is 

evaluated, Next is 

replaced by OK and 

Finish is enabled 

1 

2 
3 

4 

5 

6 
 
 
7 

8 
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Arranging the data set for analysis 

After each tester evaluation, a data file (.txt) is generated with the sample codes and its respective rates for 

the evaluated attributes. These files must be rearranged to generate a data set proper to analysis: one data 

set for each attribute, with samples in rows and tester rates in columns. The arrangement can be carried out 

using a proper module accessed using menu Tools > Category/Line scale Tests - Data Organizer (Figure 7) 

at SensoMaker’s home screen, and then: 

 Select the proper number of samples (1). 

 Indicate the digit used to identify each sample (2). 

 Indicate the digit value used to identify each sample (3). 

Note: In the example, Sample 1 has 3 at 1
st
 digit, Sample 2 has 2 at 2

nd
 digit, Sample 3 has 3 at 2

nd
 digit, 

Sample 4 has 7 at 3
rd

 digit, and Sample 5 has 5 at 2
nd

 digit. See Sample Codification chapter for details. 

 Select the data type (4). Line scale in this case. 

 Press Import Data button (5). 

 Select all individual tester files (.txt) and press Open. Data set size is shown (6). 

 Select the attribute to be exported (7). 

 Select the directory to save (8) and modify the file name (9) if appropriate. 

 Press Save button (10). The saved file (.txt) has the tester attribute rates (columns) for the samples 

(rows) (like Figure 14A). These files are proper to be used in the analysis modules, such as Two-way 

Preference Mapping, Three-way Preference Mapping, Multivariate Exploratory Analysis and Basic 

Stats/ANOVA. 

 

 

  
Figure 7. Arranging data set from category scale tests 

1 2              3          5 

4 

6 

7 

8 

9                                  10 
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Time-intensity analysis 

 

Time-Intensity tests
4
 can be performed using Time-Intensity data acquisition module (Figure 8) and analyzed 

using Time-Intensity data analysis module (Figure 9). 

 

Figure 8. Performing Time-Intensity analysis 

 

Setting the experiment 

 Set the instructions to tester using menu File > Set instructions. 

 Select the directory to save (1). 

 Set the total time for evaluation (2). 

 If appropriate, set the delay time (3) to be counted before starting analysis. 

 

Performing the experiment 

 Insert the file name (4). 

Note: for further identification of the samples, provide the sample code in the file name. 

 Try the sample and press Start button (5). 

 Rate the sensation intensity (6) using right or left arrow keys of the keyboard. 

 When completed, a successful message is shown and then the window is ready for a new analysis. 

 

 

 

 

 

 

 

1 

2 
 

3 

4 

5 

6 



12 

 

Data analysis 

 On the Time-Intensity data analysis module (Figure 9), press Import Data button (1). 

 Select all files obtained for a sample (identified by the code in the file name; in the following example, 

files for the sample in question is identified by 2 in 1
st
 digit; Figure 9B). 

 Press Open (Figure 9B). The analysis time and number of observations (testers in the following 

example) is shown. 

 Select the analysis type (2): mean curve or individual curves for each observation. 

 Set the smooth level for the curve (3). If smooth is not appropriate, disable this option (4). 

 Press Plot button (5) to obtain the curve (Figure 9C). 

 Press Compute Parameters button (6) to obtain quantitative curve parameters (Figure 9D, Figure 10). 

Note: Data from curves and tables can be copied using respective Copy Data buttons (7). 

 

 

A   

 

B  C  

 

D  
 

Figure 9. Analyzing Time-Intensity tests  

 

1 

2 

4                                          3 

5 
                                                              7 
6 
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Calculated curve parameters 

 

 

 

 

 

I_max: maximum intensity 

TI_5%: time when intensity is 5% of I_max at increasing part of the curve 

TD_5%: time when intensity is 5% of I_max at decreasing part of the curve 

TI_90%: time when intensity is 90% of I_max at increasing part of the curve 

TD_90%: time when intensity is 90% of I_max at decreasing part of the curve 

Plateau_90%: time interval which the intensity is ≥ 90% of I_max 

: area under the curve 

 

Figure 10. Time-Intensity curve parameters 

 

 

   Area 

I_max 

5% of I_max 

TI_5%                                                                                                          TD_5% 

 

90% of I_max 

TI_90%                  TD_90% 

 

Plateau_90% 
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Temporal Dominance of Sensations analysis 

 

Temporal Dominance of Sensations tests
5
 can be performed using Temporal Dominance of Sensations data 

acquisition module (Figure 11) and analyzed using Temporal Dominance of Sensations data analysis 

module (Figure 12). 

 

Figure 11. Performing Temporal Dominance of Sensations analysis 

 

Setting the experiment 

 Set the instructions for tester using menu File > Set instructions. 

 Select the directory to save (1). 

 Set the total time for evaluation (2). 

 If appropriate, set the delay time (3) to be counted before starting analysis. 

 Set the sensations names (4). 

Note: Set a dash (-) for not used sensations. Leaving it blank is not appropriate. 

 

Performing the experiment 

 Insert the file name (5). 

Note: for further identification of the samples, provide the sample code in the file name. 

 Try the sample and press Start button (6). 

 Check the dominant sensation (7) using the proper button. The chosen sensation turns green 

 When completed, a successful message is shown and then the window is ready for a new analysis. 

 

 

 

1 

2 
 

3 

5 

6 
4 7 
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Data analysis 

 On the Temporal Dominance of Sensations data analysis module (Figure 12), press Import Data (1). 

 Select all files obtained for a sample (identified by the code in the file name; in the following example, 

files for the sample in question is identified by 5 in 1
st
 digit; Figure 12B). 

 Press Open (Figure 12B). The analysis time and number of observations (testers in example) is shown. 

 If appropriate, disable sensations in order to not be analyzed (2). 

 Set the smooth level for the curve (3). If smooth is not appropriate, disable this option (4). 

 Chance (5) and significance (6) lines also can be disabled. 

 Press Plot button (7) to obtain the curve (Figure 12C). 

 Press Compute Parameters button (8) to obtain quantitative curve parameters (Figure 12D). 

Note: Data from curves and tables can be copied using respective Copy Data buttons (9). 

 

A   
 

B  C  
 

D                                      
 

Figure 12. Analyzing Temporal Dominance of Sensations tests 

1 

2 

4                       3 
5                                       7 
6                                       8 

Maximum Dominance rate 

 
Time for DR_max 

 
Time interval which 
dominance rate is             
≥ 90% of DR_max 

9 
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Discrimination Testing 

 

Discrimination testing (between two samples, A and B)
3
, such as triangle test, duo-trio test, and paired 

compassion test can be performed using Discrimination Testing data acquisition module (Figure 14A). After 

evaluations by all tasters, the obtained data can be analyzed using Discrimination Testing data analysis 

module (Figure 15A). 

 

Setting the experiment 

 Select the directory to save the files using menu File > Directory to save (Figure 14A). 

 Set the test type using menu File > Experiment settings (Figure 13A). 

Note: 

- For Duo-trio test 

In this case, the following sample set can be used: 

Balanced reference test: 

       

Constant reference test: 

     

When asked (in File > Experiment settings), provide the digit and value associated to R (similar to sample A) 

and to S (similar to sample B). For constant reference test, set the second field as 0;0. (Figure 13B) 

See Sample Codification chapter for details. 

 

- For Paired Comparison test 

To perform one-tailed test, provide (in File > Experiment settings) digit and value associated with the sample 

to be correctly selected. For two-tailed test, set it as 0. (Figure 13C) 

 Set the instructions to testers using menu File > Set instructions. 

  

A  
 

B  
 

C  
 

R: reference for sample A 

There are two possible serving orders (R AB, R BA). 

R: reference for sample A; S: reference for sample B 

There are four possible serving orders (R AB, R BA, S AB, S BA) 

R B A 

S R B A 
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Figure 13. Setting discrimination testing experiment 

Performing the experiment 

After the tester has savored/tried the samples, he/she must evaluate it according to the instructions (Figure 

14): 

 Insert the sample code (1). 

 Check the sample according to instructions (2). 

 Insert the file name (3) (e.g. initials of the tester name). Avoid special characters and spaces in file 

name. 

When completed, press Finish button (4). A successful message is shown and a file (.txt) is saved. Then the 

screen is ready for a new analysis. 

Note:  

- If balanced reference Duo-trio test is performed, the testes must indicate the served reference (R or S). 

(Figure 14B). For constant reference Duo-trio test, it is not asked. 

- For Triangle test, a same code system should be used for each sample, i.e., one digit/value for sample 

A and one digit/value for sample B. In the following example (Figure 14A), sample A is coded as 5 in 2
nd

 

digit and sample B is coded as 6 in 2
nd

 digit. 

 

 

A  
 

B  
 
Figure 14. Performing discrimination tests 

 

Data analysis 

 On the Discrimination Testing data analysis module (Figure 15A), select the analysis type (1). 

 Press Import Data button (2). 

 Select all data files to be analyzed and press Open. 

 Indicate the digit used to identify each sample (3). 

1 

2 

3                                                             4 
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 Indicate the digit value used to identify each sample (4). 

 Press Binomial Test (5). 

 A table with the results is shown (Figure 15B). 

 

A  
 

B  
 
Figure 15. Analyzing discrimination tests  

 

1 

2 
 
 
 
5 

3            4 
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Preference mapping 

 

Internal and external preference mapping
6,7

 can be carried out using Two-way Preference Mapping module 

(Figure 16). 

 

Internal preference mapping 

Inserting data set (table at the top) 

 If the data set is a .txt file (Figure 17A) with samples in rows and consumer scores in columns (columns 

separator must be space or TAB), such as the files saved using Category/Line scale Tests - Data 

Organizer module (Figure 4), press Open button (1) and load the data file. 

 If the data set is not a .txt file, type the data on the table (3) or paste it from a spreadsheet (Figure 17B) 

using Paste button (2). Use samples in rows and consumer scores in columns. 

 If appropriate, insert consumer classes (5). If the columns headers in the data set are consumer classes 

(Figure 17B), they are inserted when the file is opened (1) or pasted (2). 

 If appropriate, set sample labels (4). If they are in the opened .txt file or in the pasted data, they are 

loaded. If it is not provided, they are numbered. 

 

In the following example, the data are hedonic scores for smell of 6 grape juices evaluated by 100 

consumers; classes are MEN and WOMAN. 

 

Note:  

- After inserted, the data set can be saved as .txt file using Save button (6). 

- Additional columns and rows can be inserted on the tables using + buttons (7). 

 

Performing analysis 

 Select the preprocessing (Standardized (correlation matrix) or Mean centering (covariance matrix)) (8). 

 Select the plot type (vector or contour) (9). 

Note: contour plot represents the number of consumer per area, ranging from 0 (low) to 1 (high). 

 Press Plot button at left (10) to obtain the internal map (Figure 18A). 

 

External preference mapping 

Inserting data set (tables at the top and at the bottom) 

 Insert the consumer scores similarly as described above for internal mapping. 

 Similarly insert the descriptive data on the table at the bottom (11). Use samples in rows and variables 

in columns. Data set can be opened (12) from a .txt file, typed (11), or pasted (13) from a spreadsheet. 

In the following example, data (.txt) from a QDA of grape juices was used as external data (Figure 17C). 

 If appropriate, set variable labels (14). If they are the opened .txt file, they are loaded. If it is not 

provided, these are numbered. 

Note:  

- After inserted, the data set can be saved as .txt file using Save button (15). 

- Additional columns and rows can be inserted on the tables using + buttons (16). 
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Performing analysis 

 Select the preprocessing (Standardized (correlation matrix) or Mean centering (covariance matrix)) (8). 

 Select the plot type (vector or contour) (17). 

Note: contour plot represents the number of consumer per area, ranging from 0 (low) to 1 (high). For 

circular model, also are available positive and negative ideal points. 

 Select the model type (vectorial or circular) (18). 

 Select the alpha to be used in the selection of the fitted consumers (19). 

 Press Plot button at right (20) to obtain the external map (Figure 18B). Info for the fitted model also is 

shown (Figure 18C). 

 

 

Figure 16. Performing preference mapping 

 

 

 

 

 

 

 

 

 

1         2            6                                                                                
 
                      4 
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A  
 

B  
 

C  
 

Figure 17. Data set for preference mapping 

 

 

A B  
 

C  
 

Figure 18. Internal and external preference mapping 

purple color (PC), turbidity (TU), 

natural grape smell (NS), sweet 

smell (SS), natural grape taste 

(NT), and sweet taste (TS) 
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Three-way preference mapping 

 

Thee-way internal and external preference mapping
8,9

 can be carried out using Three-way Preference 

Mapping module (Figure 19). Please see cited references
8,9

 for theoretical approach. 

 

Three-way internal preference mapping 

Inserting data set 

Data set can be inserted only by .txt file (like Figure 17A) with samples in rows and consumer scores in 

columns (columns separator must be space or TAB), such as the files which are saved using Category/Line 

scale Tests - Data Organizer module (Figure 4). 

 Press Load button (1) and load the data file (.txt). 

 The next attribute to be loaded is automatically set (2); then, press Load (1) to open the next file. 

 If appropriate, set sample labels (3). If they are in the .txt file, they are loaded. If it is not provided, these 

are numbered. 

 If appropriate, set attribute names (4). 

 If appropriate, insert consumer classes (5). If the columns headers in the data set are consumer classes 

(similar to Figure 17B, but in the .txt file), they are inserted when the file is loaded. 

In the example, data are hedonic scores for appearance, color, smell, taste and intention to purchase of 6 

grape juices evaluated by 100 consumers; classes are MEN and WOMAN. 

  

Performing analysis 

 Select the number of factors to be tested on the optimization step (6). 

 Press Optimize button (7). 

 Based on model performance (8) choose the number of factors (9) to be used in the PARAFAC model. 

 Press Fit button (10). 

 Select the plot type (11). 

Note: contour plot represents the number of consumer per area, ranging from 0 (low) to 1 (high). 

 Press the proper button (12) to obtain plots (Figure 20A). 

 

Three-way external preference mapping 

Inserting data set 

 Insert the consumer scores similarly as described above for three-way internal mapping. 

 Check External approach (13) 

 Press Load external data button (14) and open the external data in a .txt file (like Figure 17C). In the 

following  example, external data are QDA of grape juices (Figure 17C). 

 If appropriate, set the external data labels (15). If it is not provided, these are numbered. 

 

Performing analysis 

 Optimize (7) and fit (10), as described above. Get the plots (Figure 20B) using proper button (12). 
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Figure 19. Performing three-way preference mapping 

 

 A           B  
 

Figure 20. Internal (A) and external (B) three-way preference mapping 

2           1 
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6             7                              9          10 
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    14                                          15 
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Basic statistics, ANOVA and mean tests 

 

ANOVA and basic stats (such as mean, standard deviation and coefficient of variation), in addition to mean 

tests can be performed by Basic Stats/ANOVA module (Figure 21), which is accessed using menu Tools. 

 

Inserting data set 

 Type data on the table (1) or paste it from a spreadsheet using Paste button (2). Data set can also be 

opened from a .txt file with treatments in rows and observations in columns using Open button (3); 

columns separator must be space or TAB. In the following example, treatments are different grape 

juices (named A to F) and observations are hedonic scores for appearance. 

 If appropriate, set treatment labels (4). If they are in the opened .txt file or in the pasted data, they are 

loaded. If it is not provided, they are numbered. 

Note:  

- After inserted, the data set can be saved as .txt file using Save button (5). 

- Additional columns and rows can be inserted on the tables using + buttons (6). 

 

Performing tests 

 Set the number of replications into observations (7) (see Figure 22 for details). 

 Select the type of mean test (8). 

Note: For Dunnett test, the control treatment is the first. An asterisk (*) indicates difference from control. 

 Set the alpha for the significance level (9). 

 Select the type of ANOVA (10) 

 Press ANOVA button (11) to perform ANOVA (Figure 23A). 

 Press Basic Stats button (12) to obtain basic statistics and to perform mean test (Figure 23B). 

Note: Data from obtained tables are automatically copied and can be pasted in a spreadsheet. 

 

 

Figure 21. Performing ANOVA and mean test 

1 

    3        2       5 

4 

6 

6 
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For example, if there are two replications into each observation: 

 

 

 

 

 

 

Set the number of replications into observations: 

 

Figure 22. Arranging data set with replications 

 

 

A  
 

B  
 

Figure 23. ANOVA and basic stats outputs 

 

  

replication 1 
  

replication 2 
  

replication 1 
  

replication 2 
  

replication 1 
  

replication 2 

observation 1                                     observation 2                                     observation 3 
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Polynomial regression 

 

Polynomial regression by linear or quadratic model can be performed by Polynomial regression module 

(Figure 24), which is accessed using menu Tools. 

 

Inserting data set 

 Type data (x and y) on the table (1) or paste it from a spreadsheet using Paste button (2). Data set also 

can be opened from a .txt file using Open button (3); columns separator must be space or TAB. In the 

example, independent variable (x) is the content of sugar in a grape juice (from 1 to 10%), and 

dependent variable is the respective means of hedonic scores for overall liking. 

Note:  

- After inserted, the data set can be saved as .txt file using Save button (4). 

- Additional columns and rows can be inserted on the tables using + buttons (5). 

 

Performing regression 

 Select the polynomial degree (7). 

 Set the alpha for significance level (8). 

 Press Regression Stats button (9) to obtain the equation and statistics for the model (Figure 25A). 

 

Obtaining regression graph 

 Set dependent and independent variable name (10). 

 Indicate if the equation will be shown on the graph or not  (11). 

 Press Regression Graph button (12) to obtain the graph (Figure 25B). 

 

Figure 24. Performing polynomial regression 
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Figure 25. Polynomial regression outputs 
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Exploratory multivariate analysis (PCA and HCA) 

 

Exploratory multivariate analysis by Principal Component Analysis (PCA) and Hierarchical Cluster Analysis 

(HCA) can be performed by Exploratory Multivariate Analysis module (Figure 26), which is accessed using 

menu Tools. 

 

Figure 26. Multivariate exploratory analysis by PCA and HCA 

 

Inserting data set 

 Type data on the table (1) or paste it from a spreadsheet (Figure 27A) using Paste button (2). Use 

treatments in rows and variables in columns. In the following example, treatments are different grape 

juices (named from A to F) and variables are physicochemical measurements. 

 If appropriate, set treatment labels (3). If they are in the opened .txt file or in the pasted data, they are 

loaded. If it is not provided, they are numbered. 

 If appropriate, insert variable labels (4). If they are in the opened .txt file or in the pasted data, they are 

loaded. If it is not provided, they are numbered. 

 

Note:  

- Data set can also be opened from a .txt file (like Figure 17) with treatments in rows and variables in 

columns using Open button (18); columns separator must be space or TAB. 

- After inserted, the data set can be saved as .txt file using Save button (19). 

- Additional columns and rows can be inserted on the tables using + buttons (11). 
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A  
 

B                          C  

 

D                             E  
 

Figure 27. Performing PCA and HCA analysis 

 

Performing PCA 

 Select the preprocessing method (5) 

 Press Run PCA button (6). 

 Select PC to be plotted on X and Y axis (7). 

 For scores graph, press Scores plot button (8) (Figure 27B). 

 For loadings graph (Figure 27C), select the plot type (8) and press Loadings plot button (10). 

 For a scores and loadings graph (Figure 27D), press Biplot button (11) 
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Performing HCA 

 Select the distance type (12). 

 Select the linkage type (13). 

Note: Optionally PCA can be previously applied to HCA: select Use PCA (14) and the number of PC to be 

used (15). 

 Press Dendrogram button (16) to run HCA and obtain the dendrogram (Figure 27E). 
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Sequential Analysis of Wald 

 

Graphs for Sequential Analysis of Wald
10

 can be performed by Sequential Analysis of Wald module (Figure 

28), which is accessed using menu Tools. 

Figure 28. Sequential Analysis of Wald 

 

Inserting data set 

 Set p0, p1, alpha and beta parameters (1). 

 Set the maximum value to be exhibited in x axis (2). 

 Set the number of tests (n), the number of correct responses, and the label for each test (3). 

 Press Plot to visualize the graph (4). 

 Press Export Graph to export the graph as a figure file (5). See Figure Handling Chapter for details. 
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Binomial Test 

 

Binomial tests
3
 (useful for Discrimination Testing data analysis) can be performed by Binomial Test module 

(Figure 29), which is accessed using menu Tools. 

 

Figure 29. Binomial test 

 

Inserting data set 

 Set the total number of observations (n), the number of successes, the probability and the type of test 

(one or two tailed test) (1). 

 Press Compute (2) to obtain the p-value associated with the data (3). 
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Figure handling 

 

Saving figure with high resolution 

 Access menu File > Export setup at the figure window. 

 At the setup window (Figure 30A), access Rendering (1). 

 Set the color to be saved, e.g., RGB color, gray scale, etc (2). 

 Set the resolution to be saved, e.g., 600 dpi (3). 

 Press Export button (4). 

 Set the file name (5) (Figure 30B) 

 Select the file type, e.g., .tif (6). 

 Press Save button (7) 

Note: If .fig (MATLAB figure) is selected in file type, the file can be opened only using menu File > Open 

Figure in the SensoMaker’s home screen or using Matlab software. Figures (.fig) can be edited (e.g., font 

size, font color) only on the Matlab software. 

 

 

A  
 

B  
Figure 30. Exporting figure 
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Tools at the figure window 

 

 

 

 

 

 

*To move legend, click with left mouse button and drag. 
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