
Introducción

MPLAB es un entorno de desarrollo inte-
grado que le permite escribir y codificar
los microcontroladores PIC de Microchip
para ejecutarlos. El MPLAB incluye un edi-
tor de texto, funciones para el manejo de
proyectos, un simulador interno y una va-
riedad de herramientas que lo ayudarán a
mantener y ejecutar su aplicación. Tam-
bién provee una interfase de usuario para
todos los productos con lenguaje Micro-
chip, programadores de dispositivos, siste-
mas emuladores y herramientas de tercer
orden. 

El MPLAB está diseñado para ser ejecu-
tado bajo Windows 3.11, y puede operar
con Windows 95 y 98. Asume que el usua-
rio ya conoce el entorno de Windows y sa-
be manejarlo.

La guía que describimos en este capítu-
lo le permitirá realizar las siguientes tareas:

• Manejar el escritorio MPLAB
• Crear un nuevo archivo de código

fuente para el ensamble e ingresarlo a un
nuevo proyecto para el 16F84

• Identificar y corregir los errores simples
• Ejecutar el simulador interno
• Marcar puntos de interrupción 
• Crear ventanas de observación
• Manejar ventanas para el seguimiento

de errores

Para que Ud. aprenda a programar sus
microcontroladores, damos a continua-
ción, paso a paso, las instrucciones de ins-
talación y uso de la aplicación:

1)  Instalación

Descargue los archivos del software de
instalación y ejecute el archivo MPxxxxx.E-
XE. Estos archivos puede obtenerlos por
medio de Internet en la dirección:

http//www.microchip.com/10/Tools 

Estos archivos pueden ser transferidos a
disquetes si desea instalar el MPLAB en otra
computadora. De acuerdo a la versión
que haya descargado, los nombres de los
archivos pueden variar levemente. Por
ejemplo, la versión 4.00 del MPLAB tendría
los siguientes archivos:

MP40000.EXE 
MP40000.WO2 
MP40000.WO3 
MP40000.WO4 
MP40000.WO5 
MP40000.WO6

Si Ud. lo prefiere, puede venir a nuestras
oficinas con este libro y 6 disquetes vír-
genes y tendrá la oportunidad de llevarse
dicho programa sin cargo.

Copie el contenido de los 6 disquetes
en el disco rígido de su PC (en un lugar
que pueda identificar).

Cuando ejecute el archivo .EXE, co-
menzará la instalación del MPLAB en su sis-
tema. Seguidamente deberá elegir los
componentes del MPLAB que desea insta-
lar en su sistema. A menos que haya com-
prado un programador o emulador del dis-
positivo, sólo debiera instalar las siguientes
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herramientas del software:

Archivos MPLAB IDE 
Archivos MPASM/MPLINK/MPLIB
Archivos de Protección del Simula-

dor MPLAB-SIM
Archivos de Ayuda (vea la figura 1

que aparecerá cuando ejecute el
programa).

Luego aparecerá el menú de la fi-
gura 1 que le permitirá seleccionar
los componentes de lenguaje Micro-
chip que desee instalar. Usualmente
debiera seleccionarlos todos (por de-
fecto). Al hacer “doble click” en
MP40000.EXE, el instalador le va di-
ciendo lo que debe hacer.

Luego de instalarlos, ejecute
MPLAB.EXE o clique el ícono MPLAB
para iniciar el sistema. 

Aparecerá el escritorio del MPLAB
(figura 2).

2) Configurar el Modo
de Desarrollo

El escritorio básico del MPLAB se
asemeja al de las aplicaciones de
Windows (como pudo ver en la pan-
talla de la figura 2). Tiene una barra
de menú en el margen superior, una
barra de herramientas y también una
barra de estado en el margen inferior.
Podrá advertir que la barra de esta-
do incluye información sobre cómo
se ha configurado el sistema. 

Nota: El "modo de desarr"modo de desarrollo"ollo" de-
termina la herramienta, debe elegir
alguna, que ejecutará el código. Pa-
ra esta guía, usaremos el simulador de soft-
ware MPLAB-SIMMPLAB-SIM. Si sabe del tema y tiene
un emulador, en este capítulo encontrará

más información para cambiar a una de
sus operaciones.  Al seleccionar el ítem del
menú "Opciones>Modo de Desarrollo",

CÓMO ESCRIBIR PROGRAMAS Y HACER LA VERIFICACIÓN EN LOS PICS

34 Todo sobre PICs

Figura 1

Figura 2

Figura 3



aparecerá una caja de
diálogo semejante a la de
la figura 3.

El MPLAB es un produc-
to en constante evolu-
ción, de modo que pue-
den aparecer sutiles dife-
rencias entre la pantalla
que usted vea y la que mostramos aquí.
Seleccione el ícono próximo al Simulador
MPLAB-SIM (MPLAB-SIM Simulator) y elija
16F84 (que corresponde a un tipo de PIC)
en la lista de procesadores disponibles que
pueden ser resistidos por el simulador. Cli-
que 16F84 y luego presione el botón "Re-
set". De este modo se iniciará el simulador,
y debería aparecer en la barra de estado
"16F84" y "Sim". Se encuentra así en el mo-
do simulador para el 16F84.

3) Cómo Crear un Proyecto Simple

El simulador se ejecutará desde el mis-
mo archivo, llamado "archivo hex", el cual
puede ser programado en el micro PIC.
Para que se ejecute el simulador, primero
deberá crear un archivo de código fuente
y realizar el montaje del código fuente.

A continuación explicaremos cómo lle-
var a cabo este proceso:

Nota: El lenguaje ensamblador produce,
entre otros elementos, un archivo hex. Este
archivo tiene la extensión (.hex).  A este
archivo lo llamaremos:

tutor84.hex. 

Más adelante este archivo puede ser
cargado directamente en el programador
del dispositivo sin usar el ensamblador o un
proyecto del MPLAB. Este archivo también
puede ser cargado por otros programado-
res de tercer orden. 

Seleccione "Archivo>Nuevo (File>New)"

en el menú y aparecerá la ca-
ja de diálogo de la figura 4.

Clique en el botón Sí, segui-
damente aparecerá un diálo-
go de exploración de Windows
estándard. Decida dónde de-
sea crear su proyecto (en qué
carpeta o lugar de su disco rígi-

do lo va a guardar) y recuerde dónde lo
ubicó. Más tarde necesitará esta informa-
ción. Esta guía usa un directorio en c:
\temp\tutorial y crea el archivo de pro-
yecto llamado tutor84.pjt (figura 5). "PJT" es

el sufijo estándar para los archivos de pro-
yectos en el MPLAB. El prefijo del nombre
de archivo del proyecto, en este caso "tu-
tor84", será el prefijo por defecto de mu-
chos de los archivos que el MPLAB usará o
creará para esta guía.  Clique "Aceptar
(OK)" para que aparezca el diálogo Pro-
yecto MPLAB. Este diálogo puede parecer
confuso, pero en realidad es muy simple.

Nota: El simulador, los programadores y
los sistemas emuladores que operan con el
MPLAB usan un archivo  hex creado por el
ensamble, la compilación y/o el “linking”
del código fuente. Algunas herramientas
diferentes pueden crear archivos hex, al
tener en cuenta que estas herramientas
formarán parte de cada proyecto. 

Los proyectos le dan la flexibilidad para
describir cómo se construirá la aplicación
y qué herramientas se usarán para crear el
archivo .hex. 

Obviamente, en la guía nos ocupare-
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mos de todos estos detalles.
El diálogo "Editar Proyecto" será seme-

jante al mostrado en la figura 6.
Advierta que el nombre del archivo de

destino ya ha sido completado. Ya cono-
ce el modo de desarrollo que configura-
mos previamente y asume que usaremos
la serie de herramientas de lenguaje Mi-
crochip. En la ventana "Archivos de Pro-
yecto (Files proyect)", encontrará tutor84.
[hex]. Al destacar este nombre, se podrá
utilizar el ícono "Propiedades del Nodo
(Node Properties)". Seguidamente debe
indicarle al MPLAB cómo crear el archivo
hex. Hágalo clicando el botón "Propieda-
des del Nodo". Aparecerá el diálogo "Pro-
piedades del Nodo".  Este diálogo contie-
ne todas las configuraciones por defecto
para una herramienta de lenguaje -en es-
te caso MPASM, como podrá ver en en el
ángulo superior derecho del diálogo. En
su forma más simple, el proyecto contiene
un archivo hex creado desde un archivo

fuente de ensamble. Esta será la configu-
ración por defecto cuando aparezca el
diálogo "Propiedades del Nodo (Node
Properties)", vea la figura 7.

Nota: Como puede ver, hay una canti-
dad de filas y columnas en este diálogo. 

Cada fila usualmente corresponde a
un "cambio", aquellos elementos que se
establecen en la línea de comando
cuando se invoca una herramienta. De
hecho, la configuración de estos cambios
se refleja en la ventana "Línea de Coman-
do (comand line)", próxima al margen in-
ferior de la pantalla. Esta es la línea de
comando que se usará cuando se invo-
que el MPASM desde el MPLAB. Por el mo-
mento, puede usar las configuraciones
por defecto, pero cuando ya sepa cons-
truir una aplicación, probablemente de-
seará cambiar algunas. 

Al clicar el botón "Aceptar (OK)", apli-
cará estas configuraciones, y retornará al
diálogo "Editar Proyecto (Edit Project)", con
el ícono (botón) "Agrega Nodo (Add No-
de)" disponible. 

Presione el botón "Agregar Nodo". Apa-
recerá el diálogo de exploración de Win-
dows estándar, con el mismo directorio
usado para el proyecto. Ingrese el nombre
de archivo: tutor84.asm y presione "Acep-
tar". Retornará al diálogo "Editar Proyecto",
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donde podrá ver "tutor84.asm" añadido
debajo del archivo hex, que indica que es
un nodo concurrente.   Al presionar "Acep-
tar", retornará al escritorio MPLAB con un
archivo de código fuente abierto y aún sin
nombre. 

4) Cómo Crear un nuevo 
Archivo Fuente Simple

Clique dentro del espa-
cio en blanco de la venta-
na de archivo creada. Se-
guramente se llamará "Sin
título (Untitled)". De este
modo accederá al "foco"
de la ventana. Use la op-
ción de menú "Archivo-
>Guardar como...", y guar-
de el archivo vacío como
tutor84.asm. Cuando abra
el diálogo de exploración
estándar, encontrará su
ubicación en el directorio
del proyecto. Ingrese el
nombre de archivo y pre-
sione "Aceptar". Vea la fi-
gura 8.

Ahora estarán disponi-
bles el escritorio MPLAB y
la ventana de archivo va-

cío, pero el nombre de la ventana de
archivo reflejará su nuevo nombre. 

Nota: El nombre del archivo fuente
y el nombre del proyecto ("tutor84" en
esta guía) deben ser iguales en este ti-
po de proyectos. Hay otros proyectos
de archivo múltiple que usan el “lin-
ker” y permiten que el nombre del ar-
chivo de salida sea diferente al del ar-
chivo de entrada (hay una guía apar-
te para los proyectos de archivos múl-
tiples que usan el linker). 

El MPASM siempre creará un archi-
vo hex de salida con el mismo nombre
que el archivo fuente, y esta configuración
no puede modificarse.  Si cambia el nom-
bre del archivo fuente, también deberá
cambiar el nombre del proyecto. 

Ahora ya está listo para escribir el códi-
go que almacenará en el PIC para que
cumpla una función determinada.
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Tabla 1

list p=16f84
include  <p16F84.inc>

c1 equ h'0c' ; Establece el contador de variable temp c1 en la 
dirección 0x0c

org h'00' ; Establece la base de memoria del programa en el vector 
reset 0x00

reset
goto start ; Ir a inicio en el programa principal 

org h'04' ; Establece la base de memoria del programa al comienzo 
del código del usuario

start
mov1w h'09' ; Inicializa el contador a un valor arbitrario mayor 

que cero
movwf c1 ; Guarda el valor en la variable temp definida

loop
incfsz c1,F ; Incrementa el contador, ubica los resultados en el 

registro de archivos
goto loop ; loop hasta que el contador se completa

goto bug ; Cuando el contador se completa, va a start para reiniciar
end



5) Ingresar el Código Fuente

Use el mouse para ubicar el cursor al
comienzo de la ventana de archivo vacío
tutor84.asm, e ingrese el texto de la tabla
1(vea la página anterior), exactamente
como está escrito en cada línea. No debe
ingresar los comentarios (los textos que si-
guen a cada punto y coma).

Este código es un programa muy simple
que incrementa un contador y lo "resetea"
a un valor predeterminado cuando el
contador vuelve a cero. 

Nota: Todos los rótulos comienzan en la
primera columna, y la última línea tiene
una directiva "end". Las páginas de datos
del micro PIC contienen información com-
pleta sobre instrucciones con ejemplos pa-
ra su uso. 

Guarde el archivo usando la función de
menu "Archivo>Guardar" (File>Save).

6) Ensamble del Archivo Fuente

El ensamble del archivo puede realizar-
se de varias maneras. Aquí describiremos
un método. Use el ítem de menú "Proyec-
to>Construir todo (Proyect>Build All)". De
este modo ejecutará el lenguaje ensam-
blador MPASM en el trasfondo usando las
configuraciones guardadas con el proyec-
to anteriormente. Una vez completado el
proceso de ensamble, aparece-
rá la ventana "Resultados de"Resultados de
Construcción (Build Results"Construcción (Build Results" (fi-
gura 9):

Ha ingresado intencionalmen-
te al menos “un error” si ingresó
el código tal como lo hemos es-
crito en el paso anterior. El último
"goto" en el programa refiere a
un rótulo inexistente llamado

"bug". Dado que este rótulo no ha sido de-
finido previamente, el lenguaje ensambla-
dor informará el error. También podría rele-
var otros errores.

Haga un doble clic sobre el mensaje de
error. De este modo ubicará el cursor en la
línea que contiene el error en el código
fuente. Cambie "bug" por "start". Use la
ventana "Resultados de construcción
(Build Results)" para hacer una búsqueda
de errores, y reparar los que aparecieran
en el código fuente. Reensamble el archi-
vo ejecutando la función de menú "Pro-
yecto>Construir todo". Este procedimiento
puede demandar un par de repeticiones. 

Nota: Cuando reconstruya un proyecto,
todos sus archivos fuente serán guardados
en el disco.

Luego de reparar todos los problemas
en el código fuente, la ventana "Resulta-
dos de construcción" mostrará el mensaje
"Construcción completada exitosamente
(Build completed successfully)". Ya ha
completado un proyecto que puede eje-
cutarse usando el simulador. 

Como verá, aún no tiene ni ideaComo verá, aún no tiene ni idea
que prque programó, perogramó, pero ya pro ya programó algoogramó algo
que luego intrque luego introducirá en un PIC. Paraoducirá en un PIC. Para
tener idea cabal de lo que está hatener idea cabal de lo que está ha--
ciendo, continúe leyendo esta guía yciendo, continúe leyendo esta guía y
con una PC al lado, haga Ud. mismocon una PC al lado, haga Ud. mismo
lo que se indica paso por paso.lo que se indica paso por paso.
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7) Ejecución de su Programa

Use "Debug>Ejecutar>Reset
(Debug>Run>Reset)" para iniciar
el sistema. El contador del pro-
grama se reseteará a cero, que
es el vector de reset en el 16F84.
La línea del código fuente en es-
ta dirección será destacada con
una barra oscura. También ad-
vertirá que en la barra de esta-
do, la PC se establecerá en 0x00.

Use el ítem de menú "Debu-
g>Ejecutar>Paso (Debug>Run>s-
tep)" (figura 10). Al hacerlo, el contador
del programa avanzará hasta la siguiente
ubicación de instrucción. La barra oscura
seguirá el código fuente y el contador del
programa desplegado en la barra de es-
tado avanzará hasta "4". 

Cuando ejecute el ítem de menú "De-
bug>Ejecutar>Paso", advierta la aparición
de un texto en el lado derecho del ítem
de menú que dirá "F7". El mismo equivale a
"tecla de función siete" en su teclado. Mu-
chas funciones del MPLAB se asignan a
"teclas-especiales". Estas teclas cumplen la
misma función que los ítems de menú a los
cuales corresponden. Presione F7 varias
veces y verá cómo el contador del pro-
grama y la barra avanzan a través del pro-
grama. 

Ejecute el ítem de menú "Debug>Ejecu-
tar>Ejecutar (Debug>Run>Run)" o presione
F9 para inciar la ejecución del programa
desde la la ubicación actual del contador.
Los colores de la barra de estado cambia-
rán, para indicar que el programa está
ejecutando las instrucciones. Ninguno de
los campos de la barra de estado se ac-
tualizará mientras el programa esté en eje-
cución.

Detenga el programa ejecutando el
ítem de menú "Debug>Run>Halt (detener)"
o presionando F5. La barra de estado vol-

verá a su color original, y el contador del
programa y otras informaciones de su es-
tado serán actualizadas.

Nota: Otra manera de ejecutar funcio-
nes es usar la barra de herramientas ubi-
cada en el margen superior de la panta-
lla. Si ubica el cursor sobre los ítems de la
barra de herramientas, podrá ver el nom-
bre de su función en la barra de estado. El
botón de la izquierda es un botón están-
dar "cambiar barra de herramientas
(change tool bar)" que le permite desple-
gar las barras de herramientas disponibles.
Estas pueden ser personalizadas, como
podrá advertirlo en la sección "Algunas Su-
gerencias" al final de esta guía. En la barra
de herramientas de Debug, la luz verde es
equivalente a F9 (Ejecución) y la luz roja
equivale a F5 (Detención).

Hasta aquí, aprendió a instalar el pro-
grama y crear un archivo para “apr“aprenderender
a pra programar”ogramar”. Dimos un ejemplo de pro-
gramación y ya sabemos cómo “corr“correr eler el
prprograma en la PC”ograma en la PC” para saber si todo
está bien, antes de escribir dicho progra-
ma en nuestro PIC. Sin embargo, cuando
los programas son más largos, es posible
cometer errores, para evitarlos, sigamos le-
yendo este capítulo.
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8) Abrir Otras Ventanas Para 
el Seguimiento de Errores

Hay muchas maneras de visualizar el
programa y su ejecución usando el
MPLAB. Por ejemplo, este programa está
destinado a incrementar un contador tem-
porario pero, ¿cómo puede asegurarse
que se está produciendo dicho incremen-
to? Una manera es abrir e inspeccionar
una ventana de registro de archivo. Puede
hacerlo ejecutando el ítem de menú "Ven-
tana>registros de archivo (Window>File Re-
gister)". Aparecerá una pequeña ventana
con todos los registros de archivo o el RAM
del 16F84.

Presione F7 (ejecute instrucción por ins-
trucción, si piensa anularlo) varias veces, y
observe la actualización de valores en la
ventana de registro de archivo. Hemos co-
locado la variable del contador en la ubi-
cación de dirección 0x0C. Mientras el con-
tador temporario se incremente, este in-
cremento se reflejará en la ventana de re-
gistro de archivo. Los registros de archivo
cambian de color cuando su valor cam-
bia, de modo que los cambios puedan
advertirse fácilmente en la inspección. De
todos modos, en muchos programas com-
plejos, varios valores pueden cambiar, así
resultará más difícil focalizar las variables
que le interesan. Usando una ventana de

observación especial, este problema pue-
de solucionarse.

Ahora, ya sabemos mejor qué es lo que
estamos haciendo: 

PrProgramamos algo que incrogramamos algo que incrementaementa
en “1” cada vez que viene una señal”en “1” cada vez que viene una señal”
y podemos verificarlo virtualmente, any podemos verificarlo virtualmente, an--
tes de prtes de programar el PIC.ogramar el PIC.

9) Creación de una 
Ventana de Observación

Ejecute el ítem de menú "Ventana>Nue-
va ventana de observación (Window>New
Watch Window)". Aparecerá el diálogo
"Agregar Símbolo de observación (Add
Watch Symbol)" (figura 11). 

Tipee "c1" en la caja de nombre de sím-
bolo para que la lista se despliegue hasta
el símbolo deseado. Selecciónelo, presione
el botón "Agregar (Add)", y luego el botón
"Cerrar (Close)". Aparecerá en su escritorio
MPLAB una ventana de observación que
mostrará el valor actual del valor "c1" del
contador temporario. 

Presione F7 varias veces para advertir
cómo se actualiza la ventana de observa-
ción mientras el valor del contador se in-
crementa. Si dejó la ventana de registro
de archivo abierta, la misma también será
actualizada (mueva una de ellas para que
pueda ver las dos en la pantalla). 

Puede guardar la ventana de observa-
ción y sus configuraciones al ejecutar el
ítem "Guardar observación (Save Watch)"
debajo del botón del sistema, ubicado en
el ángulo superior izquierdo de la ventana
de observación. Al clicar este botón, se
desplegará un menú en cascada. Selec-
cione "Guardar observación" y aparecerá
el diálogo de exploración estándar ubica-
do en el directorio del proyecto. Elija algún
nombre arbitrario y presione "Aceptar
(OK)".
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Si no nombra la ventana de observa-
ción, el MPLAB lo hará por usted. La ubica-
ción y el estado en la pantalla de la ven-
tana abierta o cerrada serán guardados
con el proyecto, de modo que la próxima
vez que abra su proyecto, sus ventanas de
observación aparecerán restauradas.

Nota: También puede editar ventanas
de observación luego de crearlas. Use el
botón del sistema y seleccione "Agregar
Observación (Add Watch)" para que apa-
rezca un diálogo mediante el cual podrá
agregar más ítems. Con la tecla "Ins" po-
drá hacer lo mismo. Si desea borrar un
ítem, selecciónelo y presione la tecla Supri-
mir (Delete); la observación referida desa-
parecerá de la ventana. Puede seleccio-
nar "Editar observación (Edit Watch)" en el
menú del sistema para cambiar el modo
en el cual se muestra el ítem (en hex, bina-
rio, como una variable de 16-bit en vez de
8-bit, etc.). 

10) Cómo se Marca un Punto 
de Interrupción

Presione F5 ("Debug>Ejecutar>Detener")
para asegurarse que el procesador del si-
mulador se ha detenido. Clique dentro de
la ventana del código fuente la línea si-
guiente al rótulo "start", que dice "movlw
0'09'". Presione el botón derecho del mou-
se para que aparezca el menú de la figu-
ra 12.

Clique el ítem de menú "Punto(s) de in-
terrupción (Break Point)". El menú desapa-
recerá y la línea donde se ubicó el cursor
cambiará de color, para indicar que ha si-
do establecido un punto de interrupción
en dicha ubicación.

Presione F6 o ejecute el ítem de menú
"Debug>Ejecutar>Reset (Debug>Run>Re-
set)" para resetear el sistema. Luego, pre-
sionando F9, ejecute el sistema. El progra-
ma se ejecutará y se detendrá en la ins-
trucción ubicada luego del punto de inte-
rrupción. "c1", como aparece en la venta-
na de observación o en la de registro de
archivo, si la tiene aún abierta, reflejará el
estado reset de cero, el modo instrucción
por instrucción ejecutará la carga y c1 lue-
go reflejará un valor de 0x09. Presione F9
varias veces y advierta que la barra de es-
tado cambia de color mientras el progra-
ma se esté ejecutando, y luego retorna a
su color original cuando el procesador se
detiene.

Resumen

Hasta aquí, en este capítulo Ud. ha
aprendido:

* configurar un nuevo proyecto.
* crear e ingresar un archivo fuente en un

proyecto
* ensamblar un código
* ejecutar su código usando el simulador
* marcar puntos de interrupción y ejecu-

tar su código paso a paso (instrucción por
instrucción)

* observar variables en su código

Algunas Sugerencias:

PUNTOS DE INTERRUPCION - Puede marcar
puntos de interrupción en la ventana "Ven-
tanas>Memoria de programa (Window-
>Program Memory)", en la ventana de ar-

Figura 12
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chivo fuente (en este caso tutor84.asm), o
en la ventana "Ventanas>Listado Absoluto
(Windows>Absolute)".

ARCHIVOS FUENTE - Use "Ventana>Ventana
de Proyecto (Window>Projet Window)" pa-
ra que aparezca una lista de sus archivos
fuente. Puede hacer un doble clic sobre el
nombre de un archivo para trasladarlo al
editor. 

ERRORES MPASM - Si el MPASM le da un
error, haga un doble clic sobre el error en
la ventana de error para ir al error en el
código fuente. Si tiene múltiples errores,
siempre elija el primer error —generalmen-
te un error causa errores subsiguientes y al
reparar el primero corregirá los restantes.

CONFIGURACIÓN DE BITS Y EL MODO DEL PROCE-
SADOR - La configuración de bits en el archi-
vo fuente no determinará el modo del pro-
cesador para el simulador (o los emulado-
res). Use "Opciones>Configurar Procesa-
dor>Hardware (Options>Procesor Setup-
>Hardware)" para estas configuraciones.
Aún cuando puede establecer estos bits
en el archivo fuente del MPASM o del
MPLAB-C17, el MPLAB no cambia automá-
ticamente los modos. Por ejemplo, la con-
figuración de bit Activar Observación de
Dog Timer puede hacerse de tal modo
que, cuando programe un dispositivo, el
Dog Timer sea activado. En el MPLAB tam-
bién necesitará acceder al diálogo "Op-
ciones>Configurar Procesador>Hardware"
para activar el WDT para el simulador o el
emulador. Esto le permitirá hacer un segui-
miento de errores con el WDT activado o
desactivado sin cambiar su código fuente. 

OPCIONES - Use "Opciones>Configurar En-
torno (Options>Enviroment Setup)" para
hacer lo siguiente:

* Establecer teclas de Mapa Europeo

para funciones MPLAB y caracteres ASCII
especiales

* Cambiar la fuente de la pantalla o el
tamaño de la fuente

* Posicionar la barra de herramientas a
un lado o al pie de la pantalla

* Modificar la barra de herramientas
* Cambiar la cantidad de caracteres

desplegados para los rótulos.

ARCHIVOS MAPA - Use el diálogo "Proyec-
to>Editar Proyecto" y cambie las Propieda-
des del Nodo del MPASM para producir un
archivo MAP llamado tutor84.map. Luego
de construir el proyecto, busque el tutor-
84.map para ver información de la cons-
trucción.

MENUS DESACTIVADOS - Si encuentra menús
desactivados (opacados), verifique que
no haya ingresado el modo "sólo Editor
(Editor Only)". Si está seguro de que ha
realizado correctamente la configuración,
intente salir del MPLAB y reinicie el progra-
ma.

Características del MPLAB no 
Abarcados en este capítulo

Hay muchas características del MPLAB
que no se tratan en esta guía. En lugar de
describir cada característica, generando
una guía extensa y complicada, primero
hemos decidido darle el conocimiento bá-
sico para operar el MPLAB. Le ofrecemos a
continuación un punto de inicio para ayu-
darlo a explorar otras herramientas del
MPLAB.

Otras Ventanas de Datos y Diálogos

Hasta aquí, los diferentes “comandos” u
“órdenes” del MPLAB, las hemos dado en



CÓMO ESCRIBIR PROGRAMAS Y HACER LA VERIFICACIÓN EN LOS PICS

Todo sobre PICs   43

castellano y en inglés, dado que el progra-
ma está en inglés, pero para que sepa lo
que está haciendo, decidimos colocar su
traducción. De aquí en más, sólo coloca-
remos la traducción, dado que el lector
sabrá a qué orden nos referimos.

Esta guía ya le ha presentado la Venta-
na de Memoria de Programa y las Venta-
nas de Observación. Aún no ha explorado
las otras ventanas. Debiera buscar
en "Ventana>Conjunto" y "Venta-
na>Registros de Función Especial"
para ver cómo el MPLAB puede
mostrar otras áreas de memoria.

Hay otros diálogos, como el diá-
logo "Debug>Configuración de
puntos de interrupción" para mar-
car puntos de interrupción. 

La ayuda online y la Guía del Usuario
de MPLAB le explicarán el uso de estas ca-
racterísticas.

Rastreo

La ventana de rastreo le brinda una
imagen "instantánea" de la ejecución de
su programa. Los emuladores que tienen
un amortiguador de rastreo, pueden mos-
trar cómo se ejecuta su programa a altas
velocidades. 

Nota: Algunas aplicaciones, como los
sistemas de control de motor, no pueden
ser detenidos. Algunos errores sólo apare-
cen cuando la aplicación está en ejecu-
ción, no ocurren cuando se ejecuta el có-
digo instrucción por instrucción. El amorti-
guador de rastreo le brinda otra herra-
mienta para probar este tipo de aplicacio-
nes. 

En el simulador, el amortiguador de ras-
treo es útil para recoger un extenso regis-
tro de la ejecución del programa, de mo-
do que pueda retornar al mismo y anali-
zarlo cuidadosamente. El simulador mos-

trará una información algo diferente de la
registrada por el rastreo del emulador. 

Para usar el amortiguador de rastreo del
simulador, primero debe seleccionar un
código a rastrear. Si clica y arrastra toda la
ventana de memoria del programa, pue-
de seleccionar instrucciones para rastrear.
Presione luego el botón derecho del mou-
se para que aparezca un diálogo en el
cual podrá seleccionar "Rastrear Punto(s)". 

Ahora resetee y ejecute el código, lue-
go deténgalo después de haberse ejecu-
tado durante algunos segundos. Seleccio-
ne "Ventana>Rastreo" para ver los resulta-
dos del rastreo (figura 13). 

El simulador coloca una marca de tiem-
po en cada línea y también muestra todos
los registros que cambiaron junto a sus va-
lores (figura 14). 

El estímulo genera señales para el simu-
lador. Puede establecer pines (pasadores)
altos o bajos, e introducir valores directa-
mente en los registros. Hay cuatro modos
de estímulo:

* Estímulo asincrónico  - Un diálogo inte-
ractivo para controlar señales en los pines
de entrada

* Estímulo de Archivo Pin - Los conteni-

Figura 13

Figura 14



dos de un archivo de texto
que describe señales a los
pines de entrada

* Estímulo de Archivo de
Registro - Los contenidos de
un archivo de texto usado
para configurar valores de
8-bit directamente en un
registro

* Estímulo de reloj - Una
fuente de pulsos de estímu-
lo periódica, regular y pro-
gramable.

Diálogo de Estímulo 
Asincrónico

Esta característica de es-
tímulo provee un botón de
diálogo para simular volts
+5 y 0 aplicados a pines de
entrada. Mientras su pro-
grama se ejecuta con el si-

mulador, puede presionar los botones de
este diálogo para cambiar los niveles de

los pines. 
Por ejemplo, hemos configurado una

señal que cambiará de nivel en un pin I/O
sobre el puerto b del 16F84.

Seleccione "Debug>Estímulo de Simula-
dor>Estímulo Asincrónico..."

Vea la figura 15. Se desplegará el diálo-
go de la figura 16.

Ahora coloque el cursor sobre el botón
rotulado "Stim1 (P)" y clique el botón dere-
cho del mouse para que aparezca un diá-
logo en el cual debe seleccionar "Toggle"
(figura 17).

Coloque otra vez el cursor sobre el bo-
tón rotulado ahora "Stim1 (T)" (la "P" fue
reemplazada por una "T", que significa
"Toggle"), presione el botón derecho del
mouse, y seleccione "Asignar Pin..." (figura
18).

Aparecerá otro diálogo con una lista de
los pines conectados al 16F84 (figura 19).

Coloque el cursor sobre el "RB0" y haga
un doble clic.

Debería aparecer el diálogo de la figu-
ra 20, de Estímulo Asincrónico.

Advierta que el botón ahora aparece
como "RB0 (T)".

Elija "Debug>Ejecutar>Animado" para
que el procesador se ejecute en el modo
"paso a paso rápido". La barra de estado
alternará la ejecución con una detención
muy rápida. 

Presione el botón "RB0 (T)" en el diálogo
Estímulo Asincrónico. Debería ver el cam-
bio de valor del puerto b en la ventana
Registro de Función Especial mientras re-
petidamente clique el botón para simular
una señal alta y luego una baja aplicadas
al pin 0 del puerto b. 
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Fig.17

Fig.18

Fig.19
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Archivos de “Estímulo Pin”

Un archivo de estímulo pin
consiste en columnas de unos y
ceros de ingreso que serán apli-
cadas a los pines cuando el va-
lor "Ciclo" en el Reloj de deten-
ción alcance al de la columna
CICLO.

Use "Archivo>Nuevo archivo"
y tipee el texto de la tabla 2. No
debe tipear el texto que sigue a
los ";" y "!", que se limita a co-
mentarios. 

Use "Archivo>Guardar co-
mo..." para guardar como tu-
tor84.sti.

Nota: Para mantener una
compatibilidad retroactiva con
versiones anteriores del MPSIM,
la primera línea siempre debe
comenzar con las palabras "CI-
CLO" o "STEP". Esta columna es-
pecifica el CICLO (como lo de-
termina la Ventana del Reloj de
Detención del MPLAB) donde
los valores de las otras columnas
serán aplicados. 

Luego de la palabra "CICLO"
en la primera línea del archivo
se colocan los nombres de los
pines del microPIC que recibirán
los valores de estímulo altos y
bajos. En este ejemplo los pines
RB1 y RB0, por dos entradas del
port (puerto) B, recibirán
entradas de estímulo.  En
este archivo, la segunda
columna contiene valo-
res que serán aplicados a
RB1 (puerto b bit 1) y la
tercera columna presen-
ta los valores para RB0
(puerto b bit 0). Estos
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Figura 21

Figura 22

Tabla 2

CICLO RB1 RB0
20 0 0
41 1 0 ; aplicar alta a puerto b bit 1
52 0 1 ; aplicar alta a puerto b bit 0, establecer bit 1 bajo
55 1 1
60 0 0
65 1 0 ; toggle bit 1, luego...
76 0 1 ! ...toggle bit 0.



nombres deben ser compatibles con los
nombres de pin del microPIC de Microchip
para el procesador que está siendo simu-
lado. 

Nota: Puede ver  todos los pines de so-
porte en la lista de asignación de pines
para el Estímulo Asincrónico (clique el bo-
tón derecho del mouse sobre un botón de
estímulo y se desplegará la pantalla de la
figura 21). Se pueden hacer comentarios
en una línea usando los caracteres ";" o "!",
precedidos y seguidos, como mínimo, por
un espacio.  La ventana del Reloj de De-
tención también mostrará el tiempo trans-
currido a cada instrucción, determinado
desde el valor CICLO y la frecuencia del
reloj.  Si el Reloj de Detención se resetea a
0, el archivo de estímulo pin también será
efectivamente reseteado. 

Abra la ventana del Reloj de Detención
y seleccione "Ventana>Reloj de Deten-
ción". También seleccione "Ventana>Regis-
tros de Función Especial". 

Estaremos interesados en observar el
"puerto b".  También se puede agregar el
puerto b a una ventana de observación
(figura 22). 

Resetee y ejecute instrucción
por instrucción hasta ejecutar
41 ciclos. Luego verá que el
"puerto b" cambió su valor al
asignado en la segunda línea
del archivo de estímulo. 

Archivos de Estímulo
de Registro

Un archivo de estímulo de re-
gistro consiste en una columna
de los valores que serán envia-
dos a un registro cuando la di-
rección de memoria del progra-
ma alcance la ubicación esta-

blecida en el Diálogo Estímulo de Registro.
Esto es útil para simular una operación
A/D. Abra un nuevo archivo usando "Archi-
vo>Nuevo Archivo" y tipee la siguiente lista
de números:

10
2E
38
41
50
7A
99
A0
FD

Guárdela usando "Archivo>Guardar co-
mo..." y nómbrela tutor84.reg.
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Este archivo será usado para introducir
secuencialmente estos valores en un regis-
tro. Seleccione "Estímulo de Simulador>Estí-
mulo de Registro>Activar..." (figura 23)

Luego configure "loop" para que se ubi-
que en el programa cuando se introduz-
can los valores, y para propósitos de de-
mostración, introdúzcalos en el registro de
archivo en la dirección 0x0d. Luego de
configurar "loop" y "0d" en sus cajas corres-
pondientes, presione "Explorar" para que
aparezca el diálogo de archivo, en el cual
podrá seleccionar tutor84.reg como el ar-
chivo de estímulo de registro (figura 24).

Abra la ventana "Ventana>Registros de
archivo" para ver el efecto de este estímu-
lo, aparecerá el listado de la figura 25.

Resetee y luego ejecute instrucción por
instrucción el procesador. Cada vez que
llegue a 'loop', el valor en el registro de ar-
chivo en la dirección 0x0D cambiará. La
lista de valores en tutor84.reg será secuen-
cialmente introducida en el registro de ar-

chivo seleccionado (0x0D, con un valor de
0x50 como se muestra en la figura 25). Los
valores 0x10, 0x2E, etc. serán introducidos
en el registro seleccionado en el diálogo
"Debug>Estímulo de Simulador>Registro de
Estímulo", cada vez que se ejecute "loop".

Luego de introducido el último valor
(0xFD en tutor84.reg), el primer valor será
usado nuevamente (0x10). La lista será cí-
clica mientras se ejecute el MPLAB-SIM.

Estímulo de Reloj 

El estímulo de reloj genera una onda re-
gular sobre un pin con un ciclo obligatorio
especificado en términos de los ciclos de
reloj del procesador (figura 26). 

Si abre el diálogo "Debug>Estímulo del
Simulador>Estímulo de Reloj...", podrá in-
gresar varios estímulos de reloj como se
muestra en la figura 26. Cuando ejecute el
programa usando las configuraciones es-
tablecidas en la figura, RB3 será Alta para
4 ciclos de reloj, y luego Baja para 6 ciclos
de reloj. RB4 será Alta para 8 ciclos de reloj
y luego Baja para 8 ciclos de reloj. Ambos
valores se repetirán hasta que salga del
MPLAB o los elimine usando este diálogo. 

Interrupción Condicional

El diálogo punto de interrupción com-
plejo es útil para configurar un punto de in-
terrupción en una condición compleja y
especial. 

Cómo Cargar el PIC

Una vez que estamos seguros que nues-
tro programa funciona de acuerdo con el
test realizado mediante el empleo de
nuestro programa, estamos en condicio-
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nes de “grabar nuestr“grabar nuestro PIC”o PIC”, para lo
cual debemos seguir las instrucciones da-
das en el capítulo 2.

Cabe aclarar que el programa MPLAB
tiene, en su barra de herramientas, un íco-
no de ayuda (HELP) que explica paso por
paso todo lo que se puede hacer con el
programa. Para muchos, el problema resi-
de en que los textos de ayuda están en in-
glés. Para que tenga una idea de la infor-
mación que contienen dichos archivos de
ayuda, nosotros hemos traducido unas 450
páginas que paulatinamente iremos publi-
cando a modo de guías para diferentes
funciones.

Veamos entonces, algunos de los pro-
ductos que podremos consultar:

Características del Editor

El editor de archivo del programador
con el MPLAB tiene un conjunto de carac-
terísticas para la escritura y edición del có-
digo fuente. 

Reloj de Detención

El Reloj de Detención le permite medir el
tiempo de ejecución del código. No siempre
es preciso en la ejecución instrucción por ins-
trucción. El reloj de detención calcula el
tiempo en base a la frecuencia del reloj del
microPIC. Configure la frecuencia del reloj
en el diálogo "Opciones>Configurar Proce-
sador>Frecuencia de Reloj...".

Proyectos de Archivo Múltiple
Usando el linker, puede tener dos o más

archivos en un proyecto. Vea la Guía del
Proyecto v3.40 de MPLAB para más infor-
mación. 

MPASM
El MPASM, junto con la guía del Usuario

de MPLINK & MPLIB describe la operación

del lenguaje ensamblador, el linker y el bi-
bliotecario, que pueden ser descargados
de la página web de Microchip. También
está disponible una guía del linker en las
direcciones de Internet que fuimos especi-
ficando.  

PICMASTER, ICEPIC, MPLAB-ICE
Estas son Guías de Usuario separadas

para la operación de emuladores que
pueden descargarse de la página web de
Microchip. 

PICSTART Plus y PRO MATE
Estos son programadores de dispositivo

de Microchip. Vea la Guía del Usuario
MPLAB PRO MATE y la del PICSTART Plus.
Ambos manuales pueden descargarse de
la página web de Microchip. 

MPLAB-C17
El compilador 17cxxx opera con el

MPLINK y el Administrador de Proyecto del
MPLAB. Vea la Guía del Usuario de MPLAB-
C17 y la Guía del Proyecto v3.40 del
MPLAB.

Herramientas de Tercer Orden 
El PIC C de alta tecnología, el compila-

dor CCS y el PIC BASIC de MicroIngeniería
pueden ser usados con el MPLAB. Vea sus
documentaciones respectivas para obte-
ner más información sobre su uso con el
MPLAB.

Problemas

Vaya a las conferencias sobre el micro-
PIC y Sistemas de Desarrollo en www.mi-
crochip.com para hacer preguntas que
pueden ser útiles para principiantes o ex-
pertos. Los ingenieros de Microchip Appli-
cation, experimentados usuarios del micro-
PIC, y los ingenieros de Sistemas de Desa-
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Figura 27

Figura 28



rrollo participan en estas conferencias. 
Este es el modo más rápido para ven-

cer los obstáculos que puedan surgir, infor-
mar sobre problemas o simplemente revi-
sar las preguntas ya registradas de otros
usuarios a fin de obtener ayuda.  

EJEMPLOS DE APLICACIÓN CON PICS

Reloj con Display de Cristal LCD

En la figura 27 se da el circuito de un re-

loj con microcontrolador que emplea un
display de cristal líquido de muy bajo con-
sumo. El diagrama posee el valor de cada
componente. El programa en Assembler se
grafica en la figura 28. 

Lector de Tarjeta 
Magnética Codificada.

Este circuito es muy fácil de construir y
emplea un PIC preprogramado, lo cual no
impide que un lector “experto” pueda pro-
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gramar su
propio com-
ponente,
dado que
brindamos el
listado del
programa
compilado.

El prototi-
po emplea
un lector de
tarjeta mag-
nética Ca-
non CCM02
2NO 21 93
20 u otro si-
milar. Preci-
samente, la
dificultad de
conseguir
este compo-
nente en el
mercado lo-
cal es causa
de que aún
no hayamos
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publicado un artículo completo sobre el
tema, que tenemos a disposición desde
hace varios meses. Sin embargo, confia-
mos en que los proveedores locales impor-
ten a la brevedad estos elementos con el
obejeto de que podamos publicar la men-
cionada nota.

En la figura 29 se da el circuito comple-
to del lector de tarjeta (smnartcard o tarje-
ta inteligente) con el valor de sus compo-
nentes.

En la figura 30 se da el diseño de la pla-
ca de circuito impreso para realizar el
montaje y en la figura 31 se da el listado
del programa compilado, que deberá ser
cargado en el PIC.

Cuando se desea “grabar” una tarjeta
con un código almacenado en el PIC, se
debe colocar el jumper (puente) JP2,
cuando se desea “leer” el código graba-
do en la tarjeta, se debe hacer un puente
en JP1 y quitar el de JP2.
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