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Preface 1
Purpose of this documentation 

This documentation provides a comprehensive overview of the basic steps you must take in 
order to adapt your existing PCS 7 process control system to the new SIMATIC PCS 7 V7.1. 
It will assist you when updating PCS 7 projects and guide you through installation and 
commissioning of the up-to-date software. 
The content of the documentation is directed toward service personnel, commissioning 
personnel, and experienced PCS 7 users with the necessary system knowledge. The 
documentation provides instructions for carrying out the software update. 
Refer to the documentation for specific products for information regarding the handling of 
these products.  

Required Basic Knowledge 
General knowledge in the area of automation engineering and basic knowledge of PCS 7 is 
required to understand this documentation. Furthermore, you will need to know how to use 
PCs with Windows operating systems. 
The following documentation explains the basics of how to use PCS 7: 
● Configuration manual Process Control System PCS 7; Engineering System 
● Configuration manual Process Control System PCS 7; Operator Station 
● Getting Started Process Control System PCS 7; Part 1 

Validity of the documentation 
This documentation is valid for the software package Process Control System; PCS 7 
Toolset V7.1. 

Documentation for the Software Update 
The following is an overview of all documentation concerning the topic "Software Update." 
The documentation can be downloaded free-of-charge in PDF format from: 
(http://www.siemens.com/automation/service&support)  
 
Documentation Content 
Manual Software update without 
utilization of new functions 
(PCS 7 V6.x or higher to V7.1) 

Describes the procedure for the software update from 
PCS 7 V6.x to V7.1 without utilization of the new 
functions. 

Manual Software update with utilization of 
new functions 
(PCS 7 V6.x or higher to V7.1) 

Describes the procedure for the software update from 
PCS 7 V6.x to V7.1 with utilization of the new functions. 

http://www.siemens.com/automation/service&support
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Software update up to PCS 7 V5.x 
Up to PCS 7 V5.x, the update process for all projects comprises a number of steps. The 
automation system must be stopped when an update is taking place. You will receive the 
necessary instructions with the associated software packages.  

Additional documentation for the software update 
Additional information from the following documentation is required for carrying out the 
software update: 
 
Documentation Content 
Manual Process Control System PCS 7; 
Service Support and Diagnostics 

Ensuring the Availability of a PCS 7 System; contains 
information on creating backups and how to perform 
firmware updates. 

Manual Process Control System PCS 7; 
PC configuration and authorization 

PCS 7 PC - hardware and installations; 
Windows settings and utility programs;  
software packages and necessary authorizations 

Configuring Manual Process Control 
System PCS 7; Engineering System 

Guide to configuration steps in SIMATIC Manager, CFC, 
SFC, NetPro 

Configuration manual Process Control 
System PCS 7; Operator Station 

Guide to configuration steps in WinCC 

Function manual Process Control System 
PCS 7; Fault-tolerant Process Control 
Systems 

Guide to configuration steps for fault-tolerant process 
control systems 

Documentation  
Process Control System PCS 7; 
Released Modules 

All modules released for SIMATIC PCS 7 are listed 
together with the following information: 
• Product designation 
• Order number 
• Firmware version 
• Product brief 

Online Help for  
WinCC Information System 

Describes the updating of WinCC projects. 

Manual Process Control System PCS 7; 
OS Web Option 

Describes the installation process for and application of 
the OS Web Option in PCS 7. 

Manual Process Control System PCS 7; 
OPC A&E for PCS 7 

Describes how an OPC A&E server with hierarchical 
access is used in PCS 7 systems. 

Function manual Process Control System 
PCS 7; 
Fault-tolerant Process Control Systems 

Describes the principles of use of fault-tolerant 
(redundant) components in SIMATIC PCS 7. 

SIMATIC manual S7 F/FH Automation 
Systems 
 
Readme for 
SIMATIC S7 F Systems V6.0 

Describes the configuration and programming of S7 F/FH 
fail-safe systems using S7 F systems. 
Contains important information which must be taken into 
account when installing and using the S7 F system 
optional package in PCS 7. 

What's new? Information on the differences between this version and 
the previous version of PCS 7 
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Conventions 
In this documentation the designations of elements of the user interface are specified in the 
language of this documentation. If you have installed a multi-language package for the 
operating system, some of the designations will be displayed in the base language of the 
operating system after a language switch and will, therefore, differ from the designations 
used in the documentation. 

Changes compared with previous versions 
In the following you will find an overview of the most important changes compared with 
previous versions: 
● PCS 7 V7.1 or higher:  

– PCS 7 setup automatically installs the necessary hotfixes and SQL server. 
– Use of OS clients as maintenance clients (default configuration for an OS client in 

terms of the maintenance server) 
– Information on Microsoft Windows settings and security settings can be found in the 

whitepaper SIMATIC Process Control System PCS 7; Security Information Note 
. This can be downloaded via the Internet from the Customer Support websites: 
 (http://support.automation.siemens.com/WW/view/en/26462131) 

– Information on virus scanners can be found in the whitepaper SIMATIC Process 
Control System PCS 7; Security Information Note; Setting Virus Scanners. This can 
be downloaded via the Internet from the Customer Support websites: 
(http://support.automation.siemens.com/WW/view/en/26366540) 

– The architecture for SIMATIC PDM has been modified. 
You can find additional information about this in the section titled "How to configure 
the SIMATIC PDM Server (Page 74)". 

● As of PCS 7 V7.0 SP1:  
– Option to monitor AS emergency operation (CPU stop avoidance). You can find 

additional information about this in the section titled "How to Activate the Display of AS 
(CPU) Emergency Operation (Page 100)." 

– Displaying limit values in online trend control.  
You can find additional information about this in the section titled "How to Configure 
Extensions for Online Trend Control (Page 89)." 

● PCS 7 V7.0 or higher:  
– The PCS 7 licensing scheme has been changed for some PCS 7 components. 

You can find additional information about this in the section titled "Licensing with the 
Automation License Manager (Page 22)". 

– If you use chip cards to authenticate users in SIMATIC Logon, new ones will be 
required.  
You can find more information about this in the SIMATIC; SIMATIC Logon 
documentation. 

– The archive server's archiving concept has been changed. 
You can find information about necessary adaptations in the section titled "How to 
Prepare the Software Update with Central Archiving (Page 32)". 

– Single clients are no longer supported by PCS 7 V7.0 and higher. 
You can find additional information about this in the section titled "Converting Single 
Clients (Page 106)". 

http://support.automation.siemens.com/WW/view/en/26462131
http://support.automation.siemens.com/WW/view/en/26366540
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– You can find information on updating the SIMATIC BATCH configuration in the 
following documentation: 
- SIMATIC BATCH Readme; Part C1, Installation 
- Manual Process Control System PCS 7; SIMATIC BATCH 

– Information on updating the SIMATIC Route Control configuration. 
You can find this in the documentation titled Process Control System PCS 7; SIMATIC 
Route Control. 

– Improved PC station diagnostics 

PCS 7 Glossary 
You can find a PCS 7 glossary defining the most important technical terms used in the 
documentation on the SIMATIC PCS 7 DVD Manual Collection or in the PCS 7 software via 
the SIMATIC Manager help menu (menu command Help > Topics > "Glossary" button). 
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Further Support 
If you have any technical questions, please get in touch with your Siemens representative or 
responsible agent. 
You will find your contact person at:  
http://www.siemens.com/automation/partner 
You will find a guide to the technical documentation offered for the individual 
SIMATIC Products and Systems at: 
http://www.siemens.com/simatic-tech-doku-portal 
The online catalog and order system is found under: 
http://mall.automation.siemens.com/ 

Training Centers 
Siemens offers a number of training courses to familiarize you with the Process Control 
System SIMATIC PCS 7. Please contact your regional training center or our central training 
center in D 90327 Nuremberg, Germany for details:  
Telephone:   +49 (911) 895-3200 *) 
Internet:  http://www.sitrain.com 

http://www.siemens.com/automation/partner
http://www.siemens.com/simatic-tech-doku-portal
http://mall.automation.siemens.com/
http://www.sitrain.com/
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Technical Support 
You can reach the Technical Support for all Industry Automation and Drive Technology 
products 
● Via the Web formula for the Support Request 

http://www.siemens.com/automation/support-request 
● Phone:  + 49 180 5050 222 *) 
● Fax: + 49 180 5050 223 *) 
Additional information about our Technical Support can be found on the Internet pages 
http://www.siemens.com/automation/service 

Service & Support on the Internet 
In addition to our documentation, we offer our Know-how online on the internet at: 
http://www.siemens.com/automation/service&support 
where you will find the following: 
● The newsletter, which constantly provides you with up-to-date information on your 

products. 
● The right documents via our Search function in Service & Support. 
● A forum, where users and experts from all over the world exchange their experiences. 
● Your local representative for Industry Automation and Drive Technology. 
● Information on field service, repairs, spare parts and consulting. 

 
*) Please note the following if you call the phone number listed: You may incur costs which 
vary from the standard costs for land lines. Calls from a cellular network may be more 
expensive. 
 
 

http://www.siemens.com/automation/support-request
http://www.siemens.com/automation/service
http://www.siemens.com/automation/service&support
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Introduction 2
2.1 Selecting the Correct Documentation 

The selection and use of the correct documentation depends on the comprehensiveness of 
your software update. The current status of the software and any boundary conditions that 
may exist. 

Decision Process 
The flow chart below shows you the steps that must be performed to update a PCS 7 plant. 

PCS 7 
Fault-tolerant Process 
Control Systems
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2.2 General Requirements 
The following requirements must be met regardless of whether you execute the software 
update with or without the utilization of new functions: 

General Requirements for Updating the Software 
● Your PC hardware must meet the hardware requirements of PCS 7 V7.1. 

For additional information, refer to the pcs7 readme documentation on your PCS 7 
Toolset DVD. 

● The PC where the PCS 7 software is installed must meet one of the following 
requirements: 
– It can access a DVD drive via a network. 
– It has its "own" DVD drive (example: USB DVD drive). 

 

 
 

Note 
You must complete the software update before beginning with any additional changes 
to the configuration. 
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2.3 Important Information for Updating Software with Utilization of New 
Functions 

Requirements for Performing a Software Update 
● The software update with utilization of new functions requires that the CPU be switched 

to STOP mode. 
● The manual contains some sections that are not listed in the overview. These sections 

contain information which should be taken into account when updating software. You 
should also check whether this information is relevant to your PCS 7 system. 

● The project must be fully compatible with a project that was configured in PCS 7 V6.x or 
higher. Pay particular attention to the following if you have carried out earlier updates 
without utilization of new functions. 

● PCS 7 only runs on the following operating systems: 
– Windows Server 2003 
– Windows XP Professional 
Information on the operating systems and the service packs required can be found in the 
PCS 7 Readme file. 
Windows XP Professional is required for the following PC stations: 
– Engineering station (also for installation of SIMATIC PDM) 
– Single station system (redundant and non-redundant) for OS, SIMATIC BATCH, 

SIMATIC Route Control 
– Clients (OS, SIMATIC BATCH, SIMATIC Route Control, OpenPCS 7) 
Windows Server 2003 is required for the following PC stations: 
– Server (redundant and non-redundant) for OS, SIMATIC BATCH, SIMATIC Route 

Control or 
– Server for PCS 7 OS Web Option 
– Server for engineering station with multiproject (central data store) for engineering with 

multiple engineering stations 
● If using high-precision time stamping in PCS 7, you should configure it in accordance with 

PCS 7 V7.1. 
● When updating the BIOS or the components' firmware, we recommend that these 

components be completely separated from any connected networks. 
● If PCS 7 functions require certain modules and a firmware update cannot be performed, 

these modules must be replaced. 
● The default setting for the LAST_ON input has been modified at the "CH_AI" block in the 

PCS 7 V7.1 library. If a limit value violation generates the "retain last value" response, the 
LAST_ON input will need to be set to 1 (SUBS_ON remains at 0). 

● In an AS, the blocks of all the PCS 7 libraries for a PCS 7 version can be operated 
together. 
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Software update of a project that contains blocks created in PCS 7 V6.x      
The channel blocks were modified in PCS 7 based on the introduction of version V7.0 and 
the enhancements of the Maintenance Station within SIMATIC PCS 7. In the channel blocks 
of version 6.x it was not possible to output a faulty process value with the associated "quality 
code" at the block or to realize a failure in conformity to the recommendation NE 107 on the 
OS. The following states were displayed after failure of a process value: 
● Simulation (corresponds to a manipulated process value) 
● Substitute value (corresponds to a manipulated process value) 
These states are displayed clearly and legibly using the new channel blocks. The default 
characteristics have also changed due to the adapted functionality, i.e. starting with PCS 7 
V7.0 library, after a signal failure without project-specific default, the process value is 
displayed on the OS as having failed in terms of its value and quality code. 

Migrating PCS 7 H Systems 
 

CAUTION  
Migrating PCS 7 V6.0.3 H Systems 
If PCS 7 V6.0.3 has been used to configure a cyclic interrupt with default priority (<=15) as 
an OB with special treatment, AS changes can only be loaded by means of STOP. Please 
configure the priority of the OB with special treatment as described in the "S7-400H 
Automation System; Fault-Tolerant Systems" documentation. 

 

Setting up the passivation reaction of the CPU modules     
The passivation reaction of the modules depends on the library used: 
● Starting with the "Redundant IO" V5.0 library, this setting is defined for specific channels. 
● The "Redundant IO" V4.0 library allows you to select a channel-specific setting, 

depending on the module used. 
● The "Redundant IO" V3.0 library only allows you to select module-specific settings. 
The "Redundant IO" library V5.0 or higher allows you to automatically identify the possible 
passivation reaction for a module, based on the configured hardware. The passivation 
reaction is automatically adjusted during generation of the user program to suit the reaction 
with the smallest number of passivated module channels. 
for further information, refer to the documents in Process Control System PCS 7; Redundant 
process control systems. 
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Time synchronization in a PCS 7 system 
Following a software update, the time synchronization of all OS components corresponds to 
the standard in PCS 7, V7.0 SP1 or higher (V5-incompatible mode). 

Result of the Software Update 
● Following a software update with utilization of new functions, an updated PCS 7 project 

will behave similar to a project created in PCS 7 V7.1. 
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2.4 Information for changing the operating system 
Note the following recommendations if you wish to change operating systems.  

Recommendation 
Even in Windows domains, use only the following operating systems when connecting your 
system to other PCs via an Intranet or the Internet or when utilizing the PCS 7 Web Option. 
You can find additional information about different modules in the manual PCS 7 Process 
Control System; PCS 7 Readme. 

PC naming rules 
Please note the following: 
● Make sure that the name of the PC does not contains any special characters; for 

example, if you are assigning a name to ir following installation of the operating system. 
● The name of a PC should be set before PCS 7 is installed. 
The name can be corrected by accessing Start > Settings > Control Panel > System; 
 in Windows XP Professional and Windows Server 2003, it appears on the "Computer 
Name" tab. 



 Introduction 
 2.5 Requirements for New Functions of PCS 7 

Software update with utilization of new functions (PCS 7 V6.x or higher to V7.1) 
Service Manual, 03/2009, A5E02128573-01 19 

2.5 Requirements for New Functions of PCS 7 

Requirements for Performing a Software Update   
 
Function Available as 

of version 
Requirements STOP of AS required 

Use of a maintenance 
station 

PCS 7 V6.1 As of library PCS 7 V6.1 Required for updating PCS 7 
V6.0 
Not required for updating 
PCS 7 V6.1 if old libraries are 
used. 

Disabling and enabling 
messages for blocks 
and OS areas 

PCS 7 V6.1 Faceplates of PCS 7 V6.1 Required for updating PCS 7 
V6.0 
Not required for updating 
PCS 7 V6.1 if old libraries are 
used. 

SIMATIC Logon (new 
functions) 

PCS 7 V7.0 
SP1 

SIMATIC Logon V1.4 Not required 

Version Cross Manager 
(VXM) 

PCS 7 V7.0 PCS 7 V7.0  
License key for VXM 

Not required 

Manual Hiding and 
Showing of Messages 
in Process Mode  

PCS 7 V7.0 Faceplates of PCS 7 V6.1 Required for updating PCS 7 
V6.0 
Not required for updating 
PCS 7 V6.1 if old libraries are 
used. 

Automatic hiding and 
displaying of messages 
in process mode 

PCS 7 V7.0 As of library PCS 7 V7.0 Requirement 

Using the PCS 7 V7.1 
libraries 

PCS 7 V7.1 PCS 7 V7.1 or later 
• PCS 7 Basic Library 
• PCS 7 Library 

Requirement 

Integration of the APC 
Library blocks (PCS 7 
V7.0 SP1) 

PCS 7 V7.1 PCS 7 V7.1 or later 
• PCS 7 Basic Library 
• PCS 7 Library 

Requirement 

Using the blocks of the 
Advanced Process 
Library  

PCS 7 V7.1 PCS 7 V7.1 or later 
• PCS 7 Basic Library 
• PCS 7 Advanced 

Process Library 

Requirement 

Advanced diagnostic 
functions with the 
CPU_RT block 

PCS 7 V7.0 • As of library PCS 7 
V7.0 

• SIMATIC S7-400, CPU 
firmware version V5.0 

• SIMATIC S7-400H, 
CPU firmware version 
V4.5 

• BOX PC RTX 

Requirement 



Introduction  
2.5 Requirements for New Functions of PCS 7 

 Software update with utilization of new functions (PCS 7 V6.x or higher to V7.1) 
20 Service Manual, 03/2009, A5E02128573-01 

Function Available as 
of version 

Requirements STOP of AS required 

Stop avoidance at 
overload with the 
CPU_RT block 

PCS 7 V7.0 Library of PCS 7 V7.0 Requirement 

Watchdog module for 
ET 200iSP 

PCS 7 V7.0 • As of library PCS 7 
V7.0 

• Watchdog module 

Requirement 

Modules for ET 200iSP 
with newly configured 
shutdown logic 

PCS 7 V7.0 • Library of PCS 7 V7.0 
• Modules for ET 200iSP 

with newly configured 
shutdown logic 

Requirement 

Redundant 
PROFIBUS PA 

PCS 7 V7.0 • As of library PCS 7 
V6.1 SP1 

• IM 153-2 >= V4.0.0 
• Redundant PA coupler 
• Active field distributor 

(AFD/AFS) 

Required for updating PCS 7 
V6.0 
Not required for updating 
PCS 7 if the library of PCS 7 
V6.1 SP1 is already in use. 

Diagnostic functions for 
network components 
from the SCALANCE 
X200 series 

PCS 7 V7.0 Library of PCS 7 V6.1 Required for updating PCS 7 
V6.0 
Not required for updating 
PCS 7 V6.1 

SIMATIC BATCH new 
functions  

PCS 7 V7.0 You can find additional 
information on this in the 
PCS 7 Process Control 
System; SIMATIC BATCH 
manual 

AS can remain in the RUN 
state 

SIMATIC Route Control 
new functions  

PCS 7 V7.0 You can find additional 
information about this in 
the manual Process 
Control System PCS 7; 
SIMATIC Route Control. 

AS can remain in the RUN 
state 

Monitoring of AS (CPU) 
emergency operation 

PCS 7 V7.0 
SP1 

As of library PCS 7 V7.0 
SP1 

Requirement 

Parameterizing limit 
values for online trend 
control 

PCS 7 V7.0 
SP1 

Blocks can be operator-
controlled and monitored 
(S7_m_c=TRUE)  

AS can remain in the RUN 
state 

Enhanced network 
component diagnostics 
by means of 
SNMP-OPC 

PCS 7 V7.1 OPC Server of PCS 7 V7.1 
must be configured 

AS can remain in the RUN 
state 

Enabling maintenance 
for plant objects 

PCS 7 V7.1 Starting with library PCS 7 
V7.1 
Only possible with 
Advanced Process Library. 
for further information, refer 
to the operating manual 
Process Control System 
PCS 7; Advanced Process 
Library 

Requirement 
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Function Available as 
of version 

Requirements STOP of AS required 

Maintenance Client on 
OS Client 

PCS 7 V7.1 For further information, 
refer to the Configuring 
Manual Process Control 
System PCS 7; Operator 
Station 

AS can remain in the RUN 
state 

PDM Client on OS 
Client 

PCS 7 V7.1 SIMATIC PDM V6.0 SP5 or 
higher 
For further information, 
refer to the SIMATIC; 
Process Device Manager; 
SIMATIC PDM Manual. 

AS can remain in the RUN 
state 
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2.6 Information on Products from the PCS 7-Add On Catalog 

Important Information 
If you used PCS 7 add-on products (software packages or hardware components) in your 
process control system, contact your SIMATIC PCS 7 representative 

2.7 Licensing with the Automation License Manager 

Changing the License Concept 
The licensing scheme has changed in PCS 7 V7.0: 
● The method for counting process objects between the OS and engineering system has 

been simplified. 
● The Certificate of License for the AS process mode is supplemented by a license key. 

When the AS is loaded, the number of process objects already loaded will be determined. 
You can find additional information on license keys/authorizations in the manual 
Process Control System PCS 7; PC Configuration and Authorization. 

Managing the License Keys 
Both license keys and authorizations can be transferred using the Automation License 
Manager. In the following, the term "license key" is always used even when a product uses 
the old license scheme based on authorizations. 
Different types of licenses are used in the Automation License Manager: 
Each license consists of a basic license type and a license type. 

Additional information 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
● Online help for Automation License Manager 
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Overview of Upgrade Steps 3
3.1 Information about software update procedure 

-The following tables provide an overview of all of the necessary steps for updating software 
with utilization of new functions.  

Rules to Follow Based on the Tables 
● Use these tables as guidelines for systematically carrying out all of the updating steps in 

a sequence. 
 

 
 

Note 
The exact sequence of configuration steps specified in this documentation must be 
followed in order to carry out the software update. 

 

● You will receive information for every step as to where you must carry out the 
configuration work. 

● If you do not require some of the new PCS 7 functions, you do not need to activate them. 
It is possible to activate them later. However, we recommend the complete upgrade of 
functions described in this document. 

Exchanging Data Via OPC A&E 
If exchanging data within the PCS 7 system by means of OPC A&E, note the information in 
the readme file for Process Control System PCS 7; OPC A&E for PCS 7 when updating 
software. 
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3.2 Overview of the Procedure 
The following is a general overview of the procedure for updating software. This document 
contains comprehensive instructions on every step in the table below. 

 

 Note 
You must complete the software update before beginning with any additional changes to the 
configuration. 

 

Legend for overview 
X - perform this step at the relevant stations. 
X1 - to be performed only for the central archive server 
X2 - to be performed only on the StoragePlus server for central archiving 

Overview of the procedure 
 
Step Action ES OS 

server 
OS 
client 

AS 

Adaptations for central archiving 
1 Determine archive server configuration data (Page 31)   X1, X2   
2 Prepare for the software update on the central archive 

server (Page 32)  
 X1, X2   

3 Detach linked archive segments (Page 33)   X1, X2   
4 Back up archives from the central archive server 

(Page 34)  
 X1, X2   

Backup of PCS 7 V6.x project 
5 Back up PCS 7 V6.x project data (Page 36)  X    
6 Back up the libraries you created (Page 39)  X    
7 Export operator and display texts (Page 41)  X    
8 Check the CPs and network cards (Page 43)  X X X  
9 Prepare projects with high precision time stamping 

(Page 44)  
(only required for projects with high-precision time 
stamping) 

X    

10 Back up the license keys and authorizations (Page 46)  X X X  
Update of Hardware 
11 Prepare for replacing hardware (Page 48)     X 
12 Update and replace hardware (Page 49)     X 
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Step Action ES OS 
server 

OS 
client 

AS 

Installation and settings on the ES and OS 
13 Prepare the PC station (Page 52)  X X X  
14 Install the PCS 7 software (Page 53)  X X X  
15 Set the operating mode "configured mode"/"PG mode" 

(Page 56)  
X X   

16 Configure and download the PC stations (Page 57)  X X X  
17 Install additional PCS 7 libraries (Page 62)  X    
18 Install additional non-standard libraries (Page 64)  X    
General adaptations in the project 
19 Update the OS with Project Migrator (Page 68)  X    
20 Check PH consistency (Page 69)  X    
Adaptations in HW Config 
21 Configure replaced hardware (Page 71)  X    
22 Setting the CPU properties (Page 72)  X    
23 Updating the hardware configuration (Page 73)  

(only for projects with SIMATIC PCS 7 BOX RTX or 
SIMATIC PCS 7 AS RTX) 

    

24 Configuring the address for the PDM Server (Page 74)  
(only for projects with SIMATIC PDM V7.0) 

X    

25 Assigning an Asset-ID (Page 76)  X    
Adaptations in NetPro and conversion of the CFC/SFC charts 
26 Check and adapt connection data in NetPro (Page 77)  X    
27 Convert CFC and SFC charts (Page 79)  X    
Steps for updating blocks 
28 Copy objects from other libraries into the master data 

library (Page 86)  
X    

29 Complete the master data library (Page 87)  X    
30 Synchronize blocks (Page 91)  X    
31 Include event texts (Page 93)  X    
32 Import operator texts (Page 94)  X    
33 Adapt operator texts (Page 95)  X    
34 Configure limit values for online trend control (Page 89) X    
35 Update block types (Page 96)  X    
36 Update SFC block types (Page 97)  X    
37 Replace blocks for the motor starter (Page 99)  X    
38 Activate the display of AS emergency operation 

(Page 100)  
X    

39 Inserting blocks for high-precision time stamping 
(Page 101)  

X    

40 Copying messages for high-precision time stamping 
(Page 102)  

X    

41 Compile CFC charts (Page 104)  X    
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Step Action ES OS 
server 

OS 
client 

AS 

Adaptation of OS-relevant settings 
42 Change single clients (Page 106)  X X   
43 Synchronize OS basic pictures, local computer actions, 

and faceplates (Page 107)  
X    

44 Replace controls with picture objects (Page 112)  X    
45 Update picture objects (Page 114)  X    
46 Set time synchronization (Page 115)  X X   
Adaptations for the Maintenance Station 
47 Update a maintenance station (Page 120)  X X   
48 Changing the version for the OPC Server object in HW 

Config (Page 122)  
X    

49 Updating the diagnostics settings (Page 123)  X    
50 Carrying out a complete export of ID data (Page 125)  X    
51 Prepare for ASSET-specific export (Page 126)  X    
Additional options 
52 Update PCS 7 OS Web Option (Page 128)  X X   
53 Update PCS 7 components to enable SIMATIC Logon 

services to be used (Page 129)  
X X X  

Work for the OS in SIMATIC Manager 
54 Specify the compilation mode (Page 131)  X    
55 Compile the OS (Page 132)  X    
56 Adapting the OS Client (Page 134)  X    
Adaptation on operator stations 
57 Install additional libraries on the OS (Page 140)   X   
Adapt the central archive server 
58 Adapt central archives (Page 142)   X1, X2   
59 Update the archive data (Page 144)   X1, X2   
Downloading of Target Systems 
60 Download target systems (Page 145)  

You can find information about download options in the 
configuration manual Process Control System PCS 7; 
Engineering Station. 

X X X X 

Overview of activating the operator stations 
61 Sequence during Activation of the Operator Stations 

The following sequence applies when activating process mode (runtime): 
• Master server (OS server) 
• Standby server (redundant OS server) 
• OS clients 

62 Check settings on OS servers (Page 148)   X   
63 Check settings on OS clients (Page 149)    X  
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Step Action ES OS 
server 

OS 
client 

AS 

Software update for SIMATIC BATCH 
64 Updating SIMATIC BATCH (Page 151)  Only for projects with 

SIMATIC BATCH 
Software update for SIMATIC Route Control 
65 Updating SIMATIC Route Control (Page 153)  Only for projects with 

SIMATIC Route Control 
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Preparing for the software update 4
4.1 Adapt the central archive server 

4.1.1 Overview of Adaptations for Central Archiving 

Introduction     
If archive data is to be available after the software update, you must perform the steps listed 
below. 

 

 Note 
Take the steps in this section into account only if you are using one of the following servers 
for archiving in the PCS 7 project: 
• Central archive server 
• StoragePlus server (only recommended for smaller systems) 

 

Expanding a central archive server from the "non-redundant" to the "redundant" type 
You can find information about this in the Process Control System PCS 7; PC Configuration 
and Authorization documentation. 
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Preparation time 
You must begin the preparations for updating the central archive server or StoragePlus 
server before you start updating the PCS 7 project. 
The amount of time you have for updating the archive server is the amount of time in which 
archive data can be stored in the short-term archive on the OS servers. The time will depend 
on the following system-specific features: 
● Available memory for the short-term archive of the OS server 
● Scope defined for the short-term archive of the OS server 
● Available memory for page files 

 

 Note 
Projects with PCS 7 V6.x 
Please note that the archives of the archive server must be closed before you start the 
software update for the archive server.  
With PCS 7 V7.0, the archiving process has been changed so that the archive server can be 
updated in the same way as an OS server. 

 

Overview of the Procedure 
 
Step Action ES OS 

server 
OS 
client 

AS 

1 Determine archive server configuration data (Page 31)   X1, X2   
2 Prepare for the software update on the central archive 

server (Page 32)  
 X1, X2   

3 Detach linked archive segments (Page 33)   X1, X2   
4 Back up archives from the central archive server 

(Page 34)  
 X1, X2   

X1 - to be performed only for the central archive server 
X2 - to be performed only on the StoragePlus server for central archiving  
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4.1.2 How to Determine Configuration Data on the Archive Server 

Introduction    
You need this information when you reinstall the archive server and do not wish to make any 
configuration changes. 

Requirement 
Before you run the software update (e.g. in PCS 7 V6.x), perform these steps directly on the 
archive server (central archive server (CAS) or StoragePlus server). 

Determining the database name, database path and archive share name 
1. Use Windows Explorer to search for the "C:\Program 

Files\SIEMENS\StoragePlus\Common" folder. 
– When you have found the folder, look for the "StoragePlus.config" file in the detail 

view. Continue editing with Step 6. 
– If you do not find the folder, perform the following steps. 

2. In Windows Explorer, click "Search". 
3. In the "Find the Following Files and Folders:" input box:" enter the "StoragePlus.config" 

configuration file. 
4. In the "Search in" drop-down list: select the "Local hard drives (...)" setting. 
5. Click "Find Now". 

The "StoragePlus.config" configuration file is searched for. 
In the case of a standard installation, the configuration file will be located in folder 
"C:\Program Files\SIEMENS\StoragePlus\Common". 

6. Select the "StoragePlus.config" file from the list. 
7. In the shortcut menu, select the menu command Open with > Notepad. 
8. Search the entries for the following configuration information: 

– Database (<Database> "name of the database" <Database>) 
– DatabasePath (<Database> "path of the database" <Database>) 
– Logpath (<Logpath> " path of the data log" <Logpath>) 
– ArchivePath (<ArchivePath> "directory of the archive" <ArchivePath>) 

9. Select the menu command Start > Settings > Control Panel > Administrative Tools > 
Computer Management. 

10. In the tree view, select the folder System > Shared Folders > Shares. 
11. Look for the archive path in the list in the "Shared Path" column.  

The archive share name for the OS archives is displayed in the "Shared Folders" column 
in this line. 
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4.1.3 How to Prepare the Software Update with Central Archiving 

Requirement      
Before you run the software update (e.g. in PCS 7 V6.x), perform these steps directly on the 
archive server (central archive server (CAS) or StoragePlus server). 

Lock Archiving 
To prevent new data from being entered in the central archive server, the archive server can 
be locked for archiving. The data is then saved on the OS server.  
1. Select the menu command Start > Settings > Control Panel > Administrative Tools > 

Computer Management. 
2. In the tree view, select the folder System > Shared Folders > Shares. 
3. Select the archive path from the list. 
4. Select the menu command Action > Clear Share. 

The "Shared Folders" dialog box is displayed. 
5. Click "Yes". 

Only required for archive servers with PCS 7 V6.x: Changing the Swap-out Time Period 
 
Step Change the swap-out time period  

for the central archive server 
(Steps 6-15 are performed on the engineering station.) 

Change the swap-out time period  
for the StoragePlus server 

6 Select the menu command View > Component View in 
SIMATIC Manager. 

Select the "Common" folder. 

7 In the tree view, select the "[OS]" object underneath the 
archive server's SIMATIC PC station. 

In the "Period over All Segments" box of the "Archive 
Size" area, enter the value "1" "Day". 

8 Select the menu command Edit > Object Properties. 
The "Properties - OS:[Name of OS]" dialog box opens. 

Click the "Save Settings" button. 
 

9 Select the "CAS – Central archive server options" tab. 
Select the "All" option. 

Continue to Step 16 

10 In the "Period over All Segments" box of the "Archive 
Size" area, enter the value "1" "Day". 

 

11 Click "OK".  
Load the changed swap-out time period 
12 In the tree view of the component view, select the "[OS]" 

object underneath the archive server's SIMATIC PC 
station. 

 

13 Select the menu command CPU > Download. 
The "OS Download" dialog box is displayed. 

 

14 Select the "Changes only" check box.  
15 Click "OK".  
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Step Change the swap-out time period  
for the central archive server 
(Steps 6-15 are performed on the engineering station.) 

Change the swap-out time period  
for the StoragePlus server 

Wait 
16 Wait until the "last" archive has been closed and swapped out. 

• Select the menu command Start > SIMATIC > StoragePlus > Administration Console. 
The "StoragePlus Administration Console" dialog box opens. 

• Click "Catalog". 
The "Catalog" dialog box opens. The table indicates the period during which data is stored in the 
"MidTermArchive". When updating software, it is essential that the values in the following columns match 
for the "MidTermArchive": 
– Date from 
– Date to 

4.1.4 How to Detach Attached Archive Segments on the Central Archive Server 

Requirements       
● Before you run the software update (e.g. in PCS 7 V6.x), perform these steps directly on 

the archive server (central archive server (CAS) or StoragePlus server). 
● You must be authorized to access the Windows user interface of the central archive 

server. 

Procedure 
1. Select Start > SIMATIC > StoragePlus > Administration Console from the menu. 
2. In the detail view, click "Detach". 

The catalog of all linked archive segments which have already been swapped out is 
displayed. 

3. Select an archive segment you wish to remove from the archive. 
4. Click "Open". 

The selected archive segment is detached from the archive. Once the archive segment 
has been detached from the archive, it is also deleted from the central archive server's 
hard disk. A message window whether the archive segment has been deleted. 

5. Click "OK". 
6. Repeat steps 2 through 5 for all closed archives. 
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4.1.5 How to Back Up the Archives of the Central Archive Server 

Requirements     
● Before you run the software update (e.g. in PCS 7 V6.x), perform these steps directly on 

the archive server (central archive server (CAS) or StoragePlus server). 
● You must be authorized to access the Windows user interface of the central archive 

server. 

Preparation 
Perform the following tasks for the software update: 
1. Select the menu command Start > Settings > Control Panel > Software > "Add/Remove 

Windows Components" button. 
2. Remove the "StoragePlus" software package. 
3. PCS 7 V6.x only: Remove the "SQL Server 2000" software package. 

 

 
 

Note 
Path of the directories to be backed up 
For additional information, refer to the "How to Determine Configuration Data on the 
Archive Server (Page 31)" section. 

 

Procedure 
1. Open Windows Explorer. 
2. Select the database directory (DatabasePath). 
3. Back up all the files from this directory (to CD or DVD, for example). 
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4.2 Necessary preparations 

4.2.1 Overview of Backing Up a PCS 7 Project 

Important information  
 

NOTICE  
You must perform the steps listed below prior to carrying out an update, in order to prevent 
data being lost. 

 

Overview of the procedure 
It is essential that you back up your PCS 7 project before you start the software update. 
 
Step Action ES OS 

server 
OS 
client 

AS 

5 Back up PCS 7 project data (Page 36)  X    
6 Back up the libraries you created (Page 39)  X    
7 Export operator and display texts (Page 41)  X    
8 Check the CPs and network cards (Page 43)  X X X  
9 Prepare projects with high-precision time stamping  

(Page 44) (only required for projects with high-
precision time stamping). 

X    

10 Back up the License Keys and Authorizations 
(Page 46)  

X X X  

4.2.2 Exchanging Data Via OPC A&E 
If exchanging data in the PCS 7 system using OPC A&E, take note of the information in the 
SIMATIC Process Control System, OPCA&E for PCS 7documentation. 



Preparing for the software update  
4.2 Necessary preparations 

 Software update with utilization of new functions (PCS 7 V6.x or higher to V7.1) 
36 Service Manual, 03/2009, A5E02128573-01 

4.2.3 How to Back Up PCS 7 Project Data 
 

NOTICE  
You must prepare and backup your original project so that you can update the software 
before you reinstall PCS 7. This is a requirement particularly for installation of a new 
operating system. 

 

Carry out the following instructions in succession. 

Archiving a project 
1. In SIMATIC Manager, select the menu command File > Archive. 

The "Archive" dialog box opens. 
2. Select the "Multiprojects" (or "User Projects") tab. 
3. Click "Browse" and select the project you want to archive from the list. 
4. Click "OK" to save your settings. 

The "Archive - Select Archive" dialog box opens. 
5. Make the following settings for archiving: 

– Select the drive and the folder for the archive file from the "Save" drop down list box. 
– Enter the name under which the archive file should be saved in the "File name" text 

box. 
Recommendation: 
Choose a name for the project's archive file which indicates the date on which 
archiving took place. Example: "yearmonthdayprojectname"; 091230name 

6. Click "Save" to apply your entries. 
The "Archive – Options" dialog box opens. 
If you wish to archive your project on a disk, select the disk size. 
You can find additional information on this dialog box by clicking the "Help" button. 

7. Click "OK". 
The archiving process begins. 

When the "Archive" dialog box closes, archiving is finished. 
 

 Note 
The archived project will reflect the state of the project before the software update. 
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Comparing Time Stamps 
1. Open your PCS 7 project in SIMATIC Manager. 
2. In the component view, select the chart folder of an AS. 
3. Double-click on any chart. 

The CFC editor opens. 
4. Select the menu command CPU > Compare. 
5. Compare the time stamps "Last compilation" and "Compilation of the loaded program". 

 

If the time stamps are... ... Then 
Identical 1. Click "Close". 

The dialog box is closed. 

Different 1. Select the menu command CPU > Download. 
2. Select the "Changes" check box and apply all other standard 

settings. 
3. Click "OK". 

Changes start to be downloaded. 
4. If changes have been downloaded without errors, select the 

menu command CPU > Compare. 
The "Last offline program change" and "Last online program 
change" time stamps must match up. 

6. Perform steps 2 to 5 for each automation system. 

Reading Back the AS Parameter Settings 
If parameters which are not in the configuration have been set in the AS, you will be able to 
read these settings back into the project.  

 

CAUTION  
Please note that the parameters in the configuration will be overwritten. The decision 
concerning whether to use this function will depend on the nature of the system involved 
and must be made by the skilled personnel with responsibility for the system. 

 

1. Open your PCS 7 project in SIMATIC Manager. 
2. In the component view, select the chart folder of an AS. 
3. Double-click on any chart. 

The CFC editor opens. 
4. Select the menu command Chart > Read Back. 
5. Select the entries "Program on the CPU" and "Only data relevant for operator control and 

monitoring" in the "Read Back" dialog box. 
6. Click "OK".  

The read-back process begins. 
7. Perform steps 2 to 6 for the automation systems whose current parameters you require. 
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Backing Up OS Data 
If you want to operate the OS server on a newly installed PC following the software update, 
we recommend you back up the OS project of the OS server. 
By default, the configuration data and the archive data of the OS are stored in the OS project 
of the OS server. 
To back up data, compress the project paths in this folder and save them on a suitable 
medium (such as a CD). 

SIMATIC PDM 
SIMATIC PDM configuration data is included automatically in the backup of a SIMATIC 
project. 
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4.2.4 How to Back Up User Created Libraries 

Introduction 
Generate a backup copy of any project library that contains a collection of user-specific 
blocks for the project to be updated so that you can retrieve this data after having updated 
the software. Carry out these steps for each library that you would like to back up. 

Procedure 
1. Start SIMATIC Manager. 

No PCS 7 project must be open. 
2. In SIMATIC Manager, select the menu command File > Archive.  

The "Archiving" dialog box opens. 
3. Open the "Libraries" tab. 
4. Select the library to be backed up and click "OK". 

The "Archiving - Select an Archive" dialog box opens. 
5. Specify the file name and the storage path. 
6. Click on the "Save" button. 

Additional information 
● Online help for STEP 7 
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4.2.5 Operator and Display Texts in Blocks 

Information in Faceplates   
Faceplates visualize processes on the operator station and provide the plant operator with 
information, such as: 
● Measured values 
● Operating limits 
● Units 
● Block operator texts 

Change in Operator and Display Texts in Blocks 
If you have changed operator or display texts in the blocks (so that these now differ from 
how they appeared on delivery) and wish to use the new PCS 7 V7.1 blocks, you must back 
up these "old" operator or display texts. 

Diagnostic screens with project-specific adaptation 
In a project created with a version lower than PCS 7 V7.0 SP1, you must back up the 
diagnostic screens which have undergone project-specific adaptations.  

Exporting Operator and Display Texts 
SIMATIC Manager supports the export of information pertaining to parameters, signals, and 
messages to a file (format: *.csv). 
You can edit this file in standard MS Office applications such as Excel and Access. The 
same mechanisms are used for the export as are used for changeover to project-specific 
languages.  
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4.2.6 How to Export Operator and Display Texts 

Requirement     
● The required language is installed in your project. 

 

 
 

Note 
You can view the available languages in SIMATIC Manager via the menu command 
Options > Language for Display Units. The number of available languages is specified 
when Windows is installed (system characteristics). 

 

Procedure 
1. Open the project to be updated in the SIMATIC Manager. 
2. In the component view, select the master data library folder. 

If the master data library folder is not available, select the project folder. 
3. Select the menu command Options > Manage Multilingual Texts > Export. 

The "Export User Texts" dialog box opens. 
4. Make the following settings: 

– In the "Text tables" group, select the storage location and the format of the export file 
(possible formats: *.xls and *.csv). 

– Select the target language and source language that correspond with the display 
language in the "Language" area. 

5. Click "OK". 
6. If you are managing multilingual projects, repeat steps 3 thru 5. Make sure that you 

specify different destination directories or export file names. 

Importing user texts 
 

NOTICE  
You must always import exported user texts in the language which was used to export this 
data. 
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4.2.7 Unauthorized CPs and Network Adapters 

Communications Processors that Are No Longer Supported 
 

 Note 
The following generally applies as of PCS 7 V6.0: 
PROFIBUS is no longer supported as the plant bus. Only Industrial Ethernet is supported as 
the plant bus.  

 

For this reason the following PCS 7 communications processors (CPs) are no longer 
supported: 
● CP 1413 Industrial Ethernet 
● CP 5412 A2 PROFIBUS 
● CP 5613 PROFIBUS 
These CPs must be uninstalled and removed. 

Communications Processors that Are Not Detected 
The following communication processors cannot be detected during installation of the 
operating system: 
● Non-"Plug&Play" compatible communications processors 
● ISA plug-in cards as communications processors 
Replace these CPs with "PCI" cards prior to installation of the operating system. 

Communications Processors in the PC Stations 
Note that you must also remove the hardware indicated above in the PC stations of your 
PCS 7 project.  

 

 Note 
You must reconfigure the connections after the communications processors are removed. 
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4.2.8 How to Check the CPs and Network Adapters 

Introduction 
After you have installed the operating system on the PCs, you should check whether the 
CPs or network adapters being used are recognized by the operating system. 

Procedure 
1. Click the "Workspace" icon on the desktop. 
2. In the context menu, select the menu command Properties. 
3. Open the "Hardware" tab. 
4. Click "Device Manager". 

The "Device Manager" dialog box opens. 
The detected modules can be found in the "Device Manager": 
– The detected communications processor (CPs) can be found in the "SIMATIC Net" 

folder. 
– The detected network adapters can be found in the "Network Adapters" folder. 

5. Close the dialog box. 

Additional information 
● Documentation: PCS 7; Released Modules 
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4.2.9 How to prepare projects with high-precision time stamping 
These steps are only required for projects in which the PCS 7 function "high-precision time 
stamping" is used. 

Requirement 
● The current version of all SIMATIC stations has been compiled and transferred. 

Procedure 
For each CPU with time stamping: 
1. Select the following path from the "Project" > "SIMATIC Station" > CPU > S7 Project > 

Charts tree structure. 
2. Select Options > Charts > Chart Reference Data. 

The "Chart ref.: Chart reference data.." dialog box opens. 
3. Select the View > Block types menu command. 
4. Click the table header "Block type" in the table. 

The blocks of this CPU are displayed in sorted order. 
5. Search for "IM_DRV" in the "Chart ref.: Chart reference data.." dialog box. 
6. Double-click on the "IM_DRV" entry. 

The CFC associated chart opens. 
7. Select the Chart > New... menu command in the CFC editor 

The "Open" dialog box opens. 
8. Go to the "Object name" input line and type in a name (e.g. TEMP_IM_DRV_"Number" ) 

for the temporary CFC chart (e.g. TEMP_IM_DRV_1). 
9. Select the Window > Arrange > Tile vertically menu command in the CFC editor. 
10. Drag-and-drop the IM_DRV block from the system chart to the temporary CFC chart (e.g. 

TEMP_IM_DRV_1). 
11. Save the CFC charts. 
12. Repeat steps 5 through 11 for all IM_DRV blocks in the CPU. 

 

 
 

Note 
The system chart will no longer contain any IM_DRV blocks after you have successfully 
moved them all to temporary CFC charts. The name of system charts starts with the "@" 
character. 
The path name is available in the "Chart ref.: Chart reference data..." column in the dialog 
window. 

 

13. Repeat steps 1 through 12 for all SIMATIC stations in your project. 
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Updating PCS 7 on a new engineering station 
If you wish to perform the update on a new engineering station or with a newly installed 
operating system, you will need to archive the PCS 7 project again (see section titled "How 
to Back Up PCS 7 Project Data (Page 36)"; archiving projects). 
Perform the update with the rearchived project. 

Generating the AS 
 

NOTICE  
Do not generate this automation system after having moved the IM_DRV blocks.  
The blocks would be moved to the system charts automatically and the message texts 
would be deleted in the course of your software update. 
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4.2.10 Backing Up the License Keys and Authorizations 

Introduction     
You must backup the license keys/authorizations stored on your hard disks before changing 
the operating system or using new PC stations. 

 

 Note 
All License Keys can be saved to a License Key USB stick that is available starting with PCS 
7 V7.1.  
You must write the authorizations back to a license key disk/multi-authorization disk. 

 

Programs for Backing Up the License Keys 
Use one of the following programs depending on the current PCS 7 Version you have 
installed: 
 
PCS 7 Version Required Program 
up to PCS 7 V6.0 SP2 AuthorsW 

Menu command Start > Simatic > License Management > 
Automation License Manager 

Up to PCS 7 V6.0 SP3 Automation License Manager 
Menu command Start > Simatic > License Management > 
Automation License Manager 

 
 

 Note 
Reinstall the License Keys from the backup file using the "Automation License Manager" 
(available on the PCS 7 Toolset DVD) after having installed the operating systems to enable 
an upgrade of the License Keys (Upgrade License Key and Power Pack license key). You 
can only upgrade the License Keys after the old License Keys are available on the 
corresponding PC. 

 

Additional information 
● Online help for Automation License Manager 
● Online help for WinCC Information System > Authorization 
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Adaptations to the Hardware 5
5.1 Overview of Update of the Hardware 

Overview of the procedure 
 
Step Action ES OS 

server 
OS 
client 

AS 

11 Prepare the hardware replacement (Page 48)     
12 Update and replacement of the hardware (Page 49)     

5.2 Planning and preparation 
If you want to use the new PCS 7 V7.1 functions, all the hardware components (modules) of 
the process control system in the PCS 7 plant must meet the requirements of the this PCS 7 
version.  

Necessity of Updating or Replacing Hardware Components 
You can determine if a hardware component needs to be updated by referring to the PCS 7; 
Released Modules documentation. It does not automatically follow that you will be able to 
use the new PCS 7 V7.1 functions if you have earlier product releases and versions.  
Contact your Siemens representative if replacement of a module is required. 

Result of the Analysis 
An analysis of the hardware can result in the following scenarios: 
● Module can continue to be used in its full scope. 
● Module can be updated. 
● Current module must be replaced with a new module. 

 

CAUTION  
 

A STOP of the AS may be required to update or replace a component. 
Example: during a CPU-firmware update or when the plant bus is changed from 
PROFIBUS to Industrial Ethernet. 
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5.3 How to Prepare for Replacement of the Hardware 

Options for Reading Out Module Information 
You can read out information about the following modules in HW Config: 
 
Components Information concerning 
Network components Menu command Object Properties > Diagnostics: 

NCM S7 Diagnostics 
CPU Menu command Object Properties 
Interface modules  
• IM 153 
• IM 157 
• IM 151 

Menu command CPU > Module information 
The interface module (IM) product version can be found of the front 
panel at the lower right. 

Basic Procedure 
The following tasks are required if you plant to replace hardware in an AS: 
1. Analyze the actual state of the modules used. 
2. Define the desired state: 

Define what the future structure of your system should be. Define your future automation 
goals and align them with the requirements found in the PCS 7; Released Modules 
documentation.  
You can find additional information about different modules in the manual Process 
Control System PCS 7; PC Configuration and Authorization. 

3. Carry out the module planning: 
Produce planning documents, which establish the following: 
– Parts of the plant that should remain 
– Parts of the plant that should be expanded 
– Old modules that should still be used 
– Parts of the plant that should be upgraded with new modules in order to use the full 

scope of SIMATIC PCS 7 V7.1 functionality 

Special Information via the Internet 
You can find special information about the firmware update and the corresponding updates 
on the Internet at: 
(http://www.siemens.com/automation/service)  
Select Online Support > Search and enter, for example, "Firmware Update CP1623" in the 
search window. 

http://www.siemens.com/automation/service
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5.4 How to Perform Updates and Replace the Hardware 

Introduction 
The following table offers an overview of the hardware updates that may be required. You 
can find detailed step-by-step instructions for the procedure in the manual Process Control 
System PCS 7; Service Support and Diagnostics. 

Overview of the Hardware Updates with Supplemental Information 
 
Hardware Update, 
Hardware 
Replacement 

Basic Procedure For additional information... 

Updating the CPU 
Operating System 

1. Check the type and product release of 
the module. 

2. If required: 
Perform an update or replace the 
module. 

Process Control System PCS 7; 
Service Support and 
Diagnostics manual, section 
"Update of CPU Operating 
System". 

Firmware update of 
CP 443-5 Extended 

1. Check the type and product release of 
the module. 

2. If required: 
Perform an update or replace the 
module. 

Manual Process Control System 
PCS 7; Service Support and 
Diagnostics, section "CP 443-5 
Extended: Firmware Update". 

Firmware update of 
CP 443-1 

1. Check the type and product release of 
the module. 

2. If required: 
Perform an update or replace the 
module. 

Manual Process Control System 
PCS 7; Service Support and 
Diagnostics, section "CP 443-1: 
Firmware Update". 

Replacement of 
IM 153-2 and IM 157 

1. Check the type and product release of 
the module. 

2. If required: 
Perform an update or replace the 
module. 

3. Take into account the necessary bus 
modules. 

Process Control System PCS 7; 
Service Support and 
Diagnostics manual, section 
"Update of an Interface Module 
(IM)". 
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Hardware Update, 
Hardware 
Replacement 

Basic Procedure For additional information... 

Firmware update of Y 
coupler 

1. Check the type and product release of 
the module. 

2. If required: 
Perform an update or replace the 
module. 

3. In addition, take into account the 
necessary bus modules. 

Process Control System PCS 7; 
Service Support and 
Diagnostics manual, section 
"Update of an Interface Module 
(IM)". 

Replacement of 
diagnostic repeaters 

1. Check the type and product release of 
the module. 

2. If necessary: 
 Perform an update or replace the 
module. 

• The diagnostics repeater 
with the order number  
6ES7972-0AB01-0XA0 
supports the functions 
introduced with PCS 7 V6.0. 

• The diagnostics repeater 
with the order number  
6ES7972-0AB00-0XA0 does 
not support the functions 
introduced with PCS 7 V6.0. 

Additional information 
You can find additional information in the following documentation: 
With the menu command Start > SIMATIC > Product Information > "Language [e.g., 
English]": 
● File PCS 7 WhatsNew.wri 
With the menu command Start > SIMATIC > Documentation > "Language [e.g., English]": 
● Documentation: PCS 7 - Released Modules 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
● Manual STEP 7; Modifying the System during Operation via CiR 
● Manual Process Control System PCS 7; Service Support and Diagnostics 
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Installation of PCS 7 and Settings on the ES 6
6.1 Overview of Installation and Settings on the ES and OS 

Overview of the procedure  
 
Step Action ES OS 

server 
OS 
client 

AS 

13 Prepare the PC station (Page 52)  X X X  
14 Install the PCS 7 software (Page 53)  X X X  
15 Set the operating mode "configured mode"/"PG 

mode" (Page 56)  
X X   

16 Configure and download the PC stations (Page 57)  X X X  
17 Install additional PCS 7 libraries (Page 62)  X    
18 Install additional non-standard libraries (Page 64)  X    
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6.2 Preparing the PC Station 

Preparing the PC Station  
The remaining procedure depends on the operating system on the PC stations to be 
updated: 
● The operating system of the PC stations is Windows Server 2003 and Windows XP: 

– You can continue with the software update using the available operating system 
installation. 

● The operating system of the PC stations is Windows 2000 Server or Windows 2000 
Professional. You need to update the operating system: 
– Consult with a network administrator about the configuration of the networks. 
– You can find information about backing up data in the manual Process Control System 

PCS 7; Service Support and Diagnostics 
– You can find information about the installation and configuration of the PC stations in 

the "Installing the Operating System" section of the Process Control System PCS 7; 
PC Configuration and Authorization manual. 

 

 
 

Note 
You can install a new operating system immediately if you have not stored the project 
data on the operating system partition. 

 

Additional information 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
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6.3 How to install PCS 7 

Requirements   
● PCS 7 project data has been backed up. 

For detailed information on the backup of project data, referred to the Process Control 
System PCS 7; Service Support and Diagnostics documentation, section "Ensuring 
Availability, Data Backup". 

● The hardware planning and hardware update are complete. 
● The necessary preparations have been made. 
● Read the latest information about installation and the software and hardware 

requirements in the PCS 7 Readme file on the PCS 7 Toolset DVD. 
● In the case of PC stations with INTEL network cards, the driver for the network cards 

must be updated before the service packs for the operating systems are installed. You 
can find this driver on the PCS 7 Toolset DVD in the folder 
"Additional_Products\Drivers\NETWORK\Intel". 

● The operating system of the PC station will be updated. 
● Install the time synchronization software for the update of SIMATIC PCS 7 BOX and 

SIMATIC PCS 7 AS RTX. The software package is available on the PCS 7 Toolset DVD: 
Additional_Products\WinAC_SLOT__V4.4\CD\WinAC_Slot_V44\PLCTSync\ 
Disk1\setup.exe 

 

 
 

Note 
Hotfix and SQL server 
PCS 7 setup automatically installs the necessary hotfix and SQL server. 

 

 
 

Note 
Replacing the operating system of servers 
If the server operating system is replaced during a software update (Windows 2000 
Server replaced with Windows Server 2003), the following must be taken into account: 
• Shut the redundant server down completely if you do not want to perform a server 

software update during operation. 
• Restart the servers following installation. 

 

SIMATIC PDM 
Install the SIMATIC PDM Server on the Engineering Station if using the Maintenance Station 
of PCS 7 and if the project contains intelligent field devices configured in SIMATIC PDM. 
Select "User-defined settings"in the setup dialog. 
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WebNavigator client and WebNavigator diagnostics client 
Please note the following when updating software: 
● The WebNavigator client is only used to update the software. 
● With the WebNavigator diagnostics client, you will have to uninstall and then reinstall the 

software. 

Procedure 
1. Insert the PCS 7 Toolset DVD in the DVD drive. 
2. Select the "Install" setup type. 

You will find a more detailed description of how to install the required software in the 
Process Control System PCS 7; PC Configuration and Authorization documentation, 
section "How to Install PCS 7 Software". 

 

NOTICE  
 

The PCS 7 V7.1 components can only be installed using this setup type. 
 

3. Restore the old project data from the backup copy to the PC. 

Libraries installed in PCS 7 V7.1 or higher 
Starting with PCS 7 V7.1, the following libraries are installed by default: 
● PCS 7 Basis Library and PCS 7 Library 

contains the updated blocks of the PCS 7 Library up to PCS 7 V7.0 SP1. 
The blocks of the APC Library of PCS 7 V7.0 SP1 were updated and are integrated into 
the PCS 7 Library. 

● PCS 7 Advanced Process Library 
Contains the blocks of the PCS 7 Advanced Process Library 

In PCS 7 V7.1 or higher, the PCS 7 Basis Library is prerequisite for using the PCS 7 Library 
and the PCS 7 Advanced Process Library. 

Additional information 
● Manual Process Control System PCS 7; PC Configuration and Authorization 
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6.4 Updating SIMATIC PCS 7 AS RTX 

Update package 
You will need the following product for the purpose of updating SIMATIC PCS 7 AS RTX: 
PCS 7 AS RTX V7.1 Update Package  

Basic Procedure 
1. Backing up user and network settings 
2. Backing up license keys 
3. Updating SIMATIC PCS 7 AS RTX in accordance with the Product Information 

SIMATIC PCS 7; PCS 7 AS RTX V7.1 Update Package  
4. Creating user and network settings 
5. Downloading SIMATIC PCS 7 AS RTX 

Additional information 
● Product Information SIMATIC PCS 7; SIMATIC PCS 7 AS RTX 
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6.5 Modules in Configured Mode and PG Mode 

Operating Modes     
Two operating modes are always differentiated: 
● Module in configured mode 
● Module in programming device (PG) mode 

Module in "Configured Mode" 
You can only transfer configured connections from NetPro to the module in "Configured 
Mode". All of the logs provided by SIMATIC NET are available when using this operating 
mode. For this reason, we recommend using this setting. 
As a requirement for the "Configured Mode" setting, your PCS 7 project must contain a 
SIMATIC PC station with a WinCC application for the engineering station (ES). Check 
whether this requirement has been met for your PCS 7 project. 

Module in "PG Mode" 
In "PG mode", you can assign parameters for the network module. You can assign the 
network-related parameters, such as station address and transmission speed, with the "Set 
PG/PC Interface" configuration program. The configuration can only be set locally on the 
computer. 
No communication is possible with the PC stations in this operating mode. 

Requirement 
● The network addresses and network settings of the PC stations are configured. 
● The configuration of the PC stations match in HW Config and in the Station Configuration 

Editor. 
● The configuration of the PC stations is loaded on the PC stations. 
● The connection data of the PC stations are loaded. 

Procedure 
1. Select the menu command Start > SIMATIC > SIMATIC NET > Set PC Station. 
2. In the tree view, select the "Modules> <Network Card on System Bus> >General" folder. 
3. Select the appropriate entry from the "Module Mode" drop-down list box. 
4. Click "Apply". 

 

NOTICE  
 

For process mode, the network card must be set to "Configured Mode". 
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6.6 How to Configure and Download the PC Stations 

Introduction       
With PCS 7 V6.1 SP1 and higher, the project-specific network settings for the 
communication cards (Ethernet) of the engineering station are downloaded directly to the PC 
station. 

Requirements 
● The following is installed on each PC station: 

– Operating system 
– Specific software for the PC station (e.g., PCS 7 Engineering, OS server) 

● All PC stations to be downloaded are linked to the engineering station by means of at 
least one network. 

● The protocol for the communication on the terminal bus is set to TCP/IP. 
● The network is administered (terminal bus and system bus). The network addresses of 

the PC stations are configured. 
● The PC station access point is set on each PC station as follows: "S7ONLINE: = PC 

internal (local)". 

Procedure 
 

 Note 
Perform the following steps for the engineering station first before configuring and 
downloading the other PC stations. 

 

1. In SIMATIC Manager, open the PCS 7 project. 
2. In the component view, select the target computer. 
3. Select the menu command CPU > Configure. 

The "Configure" dialog box opens. 
4. From the "Local Network Connection" drop-down list box, select the network connection 

to be used to access the target computer. 
5. Click "Update". 

The list of accessible computers is updated. 
The PC station selected in the project is entered in the "Target computers" area. 

6. Select the desired target computer (PC station). 
 

 
 

Note 
If the selected PC station does not appear in the list, this suggests network problems or a 
faulty configuration in the project. 

 

7. Click "Configure". 
Dialog box "Configure: <Selected Station>" opens. 
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8. In the "Configure: Target Computer" dialog box, click "OK". 
9. Click "OK" in the "Information" dialog box. The configuration data is transferred to the PC 

station. To activate the network connections, you must then download the network 
settings to this PC station. The completion of the "Configuration" step is indicated in the 
dialog box message line. 

10. Click "Close". 
11. For the computer selected in step 2, select the menu command CPU > Download. 

The "Download to CPU in Current Project" dialog box opens. 
 

 
 

Note 
The configured network address of the Ethernet interface in the PC station must match 
the preset address in the target system. 

 

12. When the dialog box tells you that you are overwriting the configuration data, respond as 
follows: 
– During initial commissioning, click "Yes". 
– If the PC station is in process mode, you can only click "Yes" when a communication 

interruption is permissible. 
The "Stop Target Module" dialog box opens. 

13. In the "Stop Target Module" dialog box, click "OK" to confirm. 
The "Download" dialog box opens. 

14. Click "OK" to confirm. 
The download is performed. 
Once the configuration has been applied, the PC station is ready to operate. 

15. Repeat steps 2 through 14 for all of the PC stations. 

Switching the Logs on the Bus (Industrial Ethernet) 
 

NOTICE  
You must not deactivate the TCP/IP protocol or the ISO protocol during operation. These 
protocols are mandatory for the configured operating mode! 

 

If a bus within a system must be switched to a different protocol (for example, from TCP 
protocol to ISO protocol), you must temporarily set a mixed protocol (TCP and ISO) on the 
engineering station. You then download the configuration data to the AS and the operator 
control and monitoring systems. 

Additional information 
● SIMATIC NET; Commissioning PC Stations - Manual and Getting Started manual 
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6.7 Transmission Rate and Operating Mode in the PC Network 

Introduction     
For communication in a network, you must ensure that the following parameters are set 
consistently for all network nodes: 
● Transmission rate 
● Operating mode 

Automatic Recognition of the Transmission Rate and the Operating Mode 
Autonegotiation means the automatic identification and negotiation of the transmission rate 
(10/100 Mbps) and the operating mode (full duplex/half duplex). 
● Full duplex is an operating mode with bidirectional data exchange, in which the 

communication partners can send data independently of one another on the transmission 
link. 

● Half duplex is an operating mode with bidirectional data exchange, in which only one 
communication partner at a time can send data on the transmission link. 

Requirement 
Siemens devices used in PCS 7 are factory preset to enable the parameters for the 
transmission rate and the operating mode to be identified automatically (autonegotiation). 
This setting must be changed only if communication in the network is necessary with nodes 
that do not have the autonegotiation setting. 

Assigning Parameters to Network Nodes 
 
Location of 
Use 

Network Node Steps for Calling Parameter Assignment 
Dialog Box 

Parameter Setting 

PC Communications processor 
CP 1613/CP 1623 

1. Start > SIMATIC > SIMATIC NET > 
Set PC Station 

2. PC Station > Modules > Network 
Parameters 

Selects options for duplex 
mode and transmission rate 

PC Setting for INTEL network 
card (or similar standard 
network adapters) 

1. Start > Settings > Control Panel > 
Administrative Tools > Computer 
Management > Device Manager > 
Network Adapters 

2. Select network card 
3. File > Properties 
4. Advanced" tab 

Set the values for the 
property. 
Typical name for the 
property (depends on the 
network module used): 
• Speed and duplex mode 
• Link speed & duplex 



Installation of PCS 7 and Settings on the ES  
6.7 Transmission Rate and Operating Mode in the PC Network 

 Software update with utilization of new functions (PCS 7 V6.x or higher to V7.1) 
60 Service Manual, 03/2009, A5E02128573-01 

Location of 
Use 

Network Node Steps for Calling Parameter Assignment 
Dialog Box 

Parameter Setting 

Switches SCALANCE X400 
SCALANCE X200 
ESM 
OSM 

• To call parameter assignment dialog 
box (Web-based management) of the 
switch via Internet Explorer: 

http : \\<TCP-IP address> 
• Configuration via telnet (DOS window: 

telnet) 

Port configuration 

AS CP 443-1 communications 
processor 

• HW Config: CP 443-1 Properties > 
"Options" tab > "Individual network 
settings" area 
"Transmission medium/duplex" drop-
down list box 

Automatic Setting" default 

Additional information 
● Operating Instructions SIMATIC NET; Industrial Ethernet Switches SCALANCE X-400 
● Configuration manual SIMATIC NET; Industrial Ethernet Switches SCALANCE X-400 
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6.8 Installation of Additional PCS 7 Libraries 
After having installed PCS 7 V7.1, install a suitable PCS 7 library for your PCS 7 project on 
the ES.  
You will find the required PCS 7 library on the PCS 7 Toolset DVD of the corresponding 
PCS 7 version. 

 

NOTICE  
If you are using your own faceplates or old controls, please ensure these are installed 
before the software is updated. 

 

Basic Procedure during Installation 
The procedure is described in the section titled "How to Install Additional PCS 7 Libraries 
(Page 62)", using the example of PCS 7 library V5.2 from PCS 7 Toolset DVD V6.1. 
You install the PCS 7 Library V5.0 and V5.1 the same way using the PCS 7 installation 
CD_1 V5.0 and V5.1, respectively. During installation of the PCS 7 Library V5.0, the setup 
program must be executed in each of the folders "Comm", "Field" and "Tech" in the folder 
"09_BIB__V5.0+SP1SP2". 

 

NOTICE  
If older library versions (PCS7_Library_V5.x) are post-installed or uninstalled, the current 
version of the PCS 7 library must be reinstalled in order to ensure that the CFC driver 
generator functions correctly. 

 

NOTICE  
Only the AS blocks of one PCS 7 version may be loaded on an AS. 
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6.9 How to Install Additional PCS 7 Libraries 

Requirements   
● The operating system including the required components is installed. 
● PCS 7 has been installed. 
● All applications are closed. 
● The PCS 7 Toolset software package and the required library are available on the 

DVD of the original PCS 7 version, for example. 
● Request hotfixes for the previous versions of the PCS 7 libraries from Customer Support. 

Procedure 
The following steps serve as an example.  
1. Run the "SETUP" program.  

You can find the libraries on the DVD of the original PCS 7 version. 
2. Select a setup language. 
3. Click "Next". 
4. Follow the instructions in the setup wizard, and install the "Faceplates" component. 
5. Follow the instructions in the setup wizard and then close it. 

 

NOTICE  
 

Only the AS blocks of one PCS 7 version may be loaded on an AS. 
 

Additional information 
Libraries included on the PCS 7 Toolset DVD: 
● PCS 7 Basic Library: File bli readme.wri 
● PCS 7 Library: File LIB-Readme.wri 
● PCS 7 Advanced Process Library: File APL readme.wri 
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6.10 What are the requirements for using the Advanced Process Library? 
The PCS 7 Advanced Process Library (APL) can only be used if the PCS 7 Basic Library is 
installed. 
The use of the APL blocks APL requires an application-specific configuration and is not part 
of the software update with utilization of new functions. 

PCS 7 Advanced Process Library (APL) 
PCS 7 V7.1 supports the use of the blocks of the PCS 7 Advanced Process Library (APL) in 
PCS 7 projects. 
● AS configuration 

Within an AS project, the APL blocks can be combined with any other AS blocks. 
● OS configuration 

The faceplates as of PCS 7 V7.0 SP1 can be used to access the following AS blocks: 
– faceplates of APL V7.1. 
– Faceplates of PCS 7 V7.0 or higher 

● Signal exchange between the APL and the PCS 7 Library  
The following conversion blocks of the APL are used to exchange signals between the 
APL and the PCS 7 Library: 

 
Block  Description  Application 
StruAnIn Segmentation of an analog value 

with a structure into a variable of 
data type REAL and a signal status. 

The block splits a structured analog value that is interconnected to 
input parameter In into a variable (Out) of data type REAL and a signal 
status (ST). 

StruAnOu Creating an analog process value 
from a variable of data type REAL 
and a signal status. 

The block merges an analog value (Value) of data type REAL and a 
signal status (ST) to form a structured analog value (Out). 

StruDiIn Splitting a binary process value into 
a variable of data type BOOL and a 
signal status. 

The block splits a binary process value that is interconnected to input 
parameter In into a variable of data type BOOL and a signal status. 

StruDiOu 
 

Creating a binary process value from 
a variable of data type BOOL and a 
signal status. 

The block merges a variable of data type BOOL and a signal status to 
form a binary process value. 

STIn The block splits a signal status that 
is interconnected with the input 
parameter into separate binary 
displays. 

Splitting the signal status into separate binary displays 

STOu Merging separate binary signals to 
form a signal status. 

The block merges separate binary signals to form a signal status Out. 
If several binary signals are set, the one with the lowest number 
becomes effective. Signal status "Bad, due to process" is set if no 
binary signal is set. 

MSTIn Splitting the maintenance status into 
separate status displays 

The block splits a maintenance status that is interconnected with the 
input parameter into separate status displays. 

MSTOu Merging separate status displays to 
form a maintenance status 

The block merges status displays to form a maintenance status. The 
status display with the lowest number becomes effective if several 
status displays are set. 
Maintenance status Out = 16#00 is set if no status display is set. 
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6.11 How to Install Additional Non-standard Libraries 

Introduction 
Note this section if you are using and would like to continue using libraries in the PCS 7 
project to be updated that are not standard in PCS 7 or that contain modified blocks. 

Requirement 
The library has been archived with the menu command File > Archive in SIMATIC Manager. 

Procedure 
1. Start the SIMATIC Manager. A PCS 7 project does not have to be open. 
2. In SIMATIC Manager, select the menu command File > Retrieve.  

The "Retrieving - Select Archive" dialog box opens. 
3. Specify the path to the archived library.  

Click "Open".  
The "Select Destination Directory" dialog box opens. 

4. Set the destination directory. 
5. Click "OK". 

 

NOTICE  
 

Only the AS blocks of one PCS 7 version may be loaded on an AS. 
 

Additional information 
Information concerning the modification of libraries is available in the following 
documentation: 
● Manual Process Control System PCS 7; Programming Instructions for Blocks 
● Manual Process Control System PCS 7; Programming Instructions for Driver Blocks 
● Online help for WinCC; Faceplate Designer 
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Adaptations in the PCS 7 Project on the ES 7
7.1 Update of a PCS 7 Project 

Basic procedure    
This section describes how to update your PCS 7 project for use with SIMATIC PCS 7 V7.1. 
The software update is performed and completed offline on the ES. Thus, system operation 
is not affected. The target stations will only be loaded once all the update steps listed below 
have been performed. You can find additional information on downloading in the Configuring 
Manual Process Control System PCS 7; Engineering Station. 
If you have completed all of the following update steps on the engineering system (ES) and 
you then continue configuring the now updated PCS 7 project, you may need to perform 
certain steps such as compiling CFC charts and downloading (changes or complete project) 
to the automation system. 



Adaptations in the PCS 7 Project on the ES  
7.2 General adaptations 

 Software update with utilization of new functions (PCS 7 V6.x or higher to V7.1) 
66 Service Manual, 03/2009, A5E02128573-01 

7.2 General adaptations 

7.2.1 Overview of General Adaptations in the Project 

Overview of the procedure   
 
Step Action ES OS 

server 
OS 
client 

AS 

19 Update the OS with Project Migrator (Page 68)  X    
20 Check PH consistency (Page 69)  X    

7.2.2 Update of Operator Stations with the Project Migrator 
The Project Migrator is used to update the pictures and libraries of an OS. 

Requirement 
Projects that were created with PCS 7 versions earlier than V6.0 must first be updated to 
PCS 7 V6.0. 

Length of the Updating Process 
 

 Note 
Depending on the scope, the updating process can take several hours. 
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7.2.3 Changing the Configuration of Multilingual Texts 
If you want to use additional interface languages, please take note of the information below. 

Changing Multilingual Texts 
If you want to display text in more than one language in PCS 7 (for example, message texts 
or OS area IDs), always use the export/import function to change the multilingual texts 
(menu command Options > Manage Multilingual Texts > Export and then Import after the 
changes have been made).  

 

NOTICE  
If you change individual texts with the functions in CFC, SFC or PH, be sure to immediately 
compile the texts in all locations (for example, all block types and all copies of a blocks). 
Otherwise, inconsistencies may occur and lead to the display of an incorrect language 
version of this text. 

 

7.2.4 Importing Data from the User Archives 

Import Runtime Data 
 

NOTICE  
You must always import runtime data from the user archives in the language in which the 
runtime data was exported. 
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7.2.5 How to Update Operator Stations with the Project Migrator 

Procedure 
Carry out the following steps for each OS project: 
1. Select the menu command Start > SIMATIC > WinCC > Tools > Project Migrator. 

The "CCMigrator" dialog box opens, displaying "Step 1 of 3". 
2. Click "Next". 

"Step 2 of 3" opens. 
3. In the OS project path, select the MCP file. 

OS projects are located in the PCS 7 project path under "wincproj". 
4. Check the following settings: 

– "Pictures and libraries" check box: Selected (default) 
– "Configuration data" check box: Deactivated (grayed out) 
– "RT data" check box: Deactivated (grayed out) 
– "dBase archives" check box: Deactivated (grayed out) 

5. In "Step 3 of 3", click "Finish". 
The update is performed automatically. 

6. Repeat these steps for every OS of your PCS 7 project. 

Additional information 
● Online help WinCC Information System > Migration 
● Online help WinCC Information System > Working with WinCC > Archiving process 

values 
● Configuration manual Process Control System PCS 7; Operator Station 
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7.2.6 How to Check the PH Consistency 
This step shows you if all the data in the "plant hierarchy" are consistent. 

Requirement 
● The project in SIMATIC Manager is open in the plant view. 

Procedure 
The following steps can be performed for the multiproject or for each individual project (in the 
multiproject). 
1. In the tree view, select the object to be checked (e.g., the multiproject). 
2. Select the menu command Options > Plant Hierarchy > Check Consistency. 

The check of the PH is performed.  
The "Check Consistency - Log" dialog box opens. 

3. Correct any errors that were found. 
 

 
 

Note 
If you need more information about the possible errors, click the "Help" button in the 
"Check Consistency – Log" dialog box. 
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7.3 Adaptations in HW Config 

7.3.1 Overview of Adaptation of the Hardware 

Important information 
The PCS 7 configuration data must be adapted in the following cases: 
● When a module is replaced with a different type. 
● When the CPU operating system or the firmware for CPs or IMs is updated. 

Overview of the procedure 
 
Step Action ES OS 

server 
OS 
client 

AS 

21 Configuring replaced hardware (Page 71)  X    
22 Setting the CPU properties (Page 72)  X    
23 Updating the hardware configuration (Page 73)  

(only for projects with SIMATIC PCS 7 BOX RTX or 
SIMATIC PCS 7 AS RTX) 

X    

24 Configuring the address for the PDM Server (Page 74)  
(only for projects with SIMATIC PDM V7.0) 

X    

25 Assigning an ASSET-ID (Page 76)  X    
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7.3.2 How to Configure Replaced Hardware 
After you have replaced modules in your process control system or performed a firmware 
update, the hardware version status must be updated in your PCS 7 project. 

Requirement 
● The PCS 7 project operator stations have been updated with the Project Migrator. 

Procedure 
1. Open HW Config. 
2. Drag the object (e.g. CPU: type, firmware version x.x) from the hardware catalog to the 

corresponding slot in the AS configuration table.  
The following system message is displayed: "Do you want to replace the component ... 
with component ...?" 

3. Check the hardware types. 
4. Click "Yes". 
5. Select the menu command Station > Save/Compile. 
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7.3.3 How to Set the CPU Properties 

Reason for Checking the CPU Properties 
When you update a firmware version of a CPU, for example, in HW Config, certain 
parameters might not be accepted and might be replaced by default values during the 
update. In this case a message will appear. When this occurs, check the settings of the CPU 
properties and adapt them if necessary. 

Requirements 
● A message indicates that not all parameters were applied when the modules were 

replaced. 
● HW Config is open. 

Procedure 
1. Select the CPU being used in the configuration table in HW Config. 
2. In the context menu, select the menu command Object Properties. 
3. Open the "Diagnostics/Clock" tab and check the settings in the "Clock" area: 

– The "In AS" synchronization must be set to the "As slave" synchronization type. 
– The "On MPI" synchronization must be set to the "None" synchronization type. 

4. Open the "Cycle/Clock Memory" tab and check the settings: 
– If you are using module drivers from PCS 7 V6.0 and higher, the "Update OB1 

process image cyclically" check box must be selected. 
– From the "OB85 Call for I/O Access Errors" drop-down list box, select "Only for 

incoming and outgoing errors". 
5. Select the menu command Station > Save/Compile. 



 Adaptations in the PCS 7 Project on the ES 
 7.3 Adaptations in HW Config 

Software update with utilization of new functions (PCS 7 V6.x or higher to V7.1) 
Service Manual, 03/2009, A5E02128573-01 73 

7.3.4 How to update the hardware configuration for SIMATIC PCS 7 BOX RTX and 
SIMATIC PCS 7 AS RTX 

The steps described below only have to be carried out for project with SIMATIC PCS 7 BOX 
RTX or SIMATIC PCS 7 AS RTX implementation. 
Replace the automation system in the hardware configuration of the PC station. 

Requirements 
● The AS version in HW Config is not up to date (Version 3.3 or older) 
● The assignments of CPs to the master systems are known. 

Procedure 
1. Open the PC station in HW Config (SIMATIC PCS 7 BOX RTX or SIMATIC PCS 7 AS 

RTX). 
2. Select the PROFIBUS CP to which the distributed I/O is connected. 
3. Select the Edit > Master system > Disconnect menu command. 
4. Select the CP. 
5. Select the Edit > Delete menu command. 
6. Select the "Win LC RTX" CPU in the rack in HW Config. 
7. Go to the"SIMATIC PC-Station > Controller > Win LC RTX" folder in HW Config. 
8. Double-click the object "V4.4". 

The "Insert ..." dialog box opens. 
9. Click "Yes". 

The controller is replaced. 
10. Go to the"SIMATIC PC-Station > Controller > Win LC RTX > V4.4" folder in HW Config. 
11. Select the PROFIBUS CP used (default: CP 5613). 
12. Drag-and-drop the selected PROFIBUS CP to the controller slot in the station window. 

The "Properties ..." dialog box opens. 
13. Select the entry of the associated bus system from the "Subnet" list. 
14. Click "OK". 

The "Insert master system" dialog box opens. 
15. Select the entry of the associated bus system from the "Subnet" list. 
16. Click "OK". 
17. Select the Station > Save and Compile menu command. 
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7.3.5 How to configure the SIMATIC PDM Server 

Requirements 
● The project/multiproject has been created. 
● The SIMATIC PDM (Server) software package is installed on the Engineering Station. 

Selecting the name of the PC station 
 

 Note 
Restrictions 
The following restrictions must be observed: 
• Valid characters: [A-Z 0-9]{1,32} 
• Use uppercase letters only. 
• The first character of the PC station's name must be a letter. 
• Maximum length: 32 characters 

 

Procedure 
1. Select the Options > SIMATIC PDM > Settings command in SIMATIC Manager. 

The "SIMATIC PDM settings" dialog box opens. 
2. Select the "Maintenance Station" tab. 
3. Go to the input field and enter the project/multiproject in which you have defined the MS 

server or execute the following steps: 
– In a multiproject:  

Click "Current Multiproject" or "Browse." You can select the current project using the 
"Browse" button. 

– For a project:  
Click on "Current Project" or "Browse." You can select the current project using the 
"Browse" button. 

4. Click "OK". 
5. Open SIMATIC Manager in the component view. 
6. In the project, select the engineering station in which you wish to insert the "PDM Server" 

object. 
7. Double-click the "Configuration" object in the detail view. 

The hardware configuration of the SIMATIC PC station opens. 
If you cannot see the hardware catalog, select the View > Catalog menu command. 
The hardware catalog opens. 

8. Select SIMATIC PC Station > PDM Server from the list in the folder. 
9. Drag and drop the "PDM Server" object to the PC station of the engineering station. 
10. Select the menu command File > Save. 
11. Download the configuration to the engineering station. 
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Requirements for diagnostics with SIMATIC PDM 
Diagnostics can only be performed on the PDM devices for a given station (OS client, 
maintenance server, etc.) if SIMATIC PDM is active on the engineering station. This is the 
default scenario after the configuration has been downloaded.  

Additional information 
● STEP 7 and SIMATIC PDM Online Help 
● Whitepaper SIMATIC; Security concept PCS 7 and WinCC - Main document 
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7.3.6 How to assign the ASSET-ID in projects 
 

 Note 
Those steps are only required for projects with Maintenance Station that were created in a 
version lower than PCS 7 V7.0.1. 

 

Procedure 
 

 Note 
Carry out those steps for all SIMATIC S7 400 stations and PC stations. 

 

1. Open the station (AS or PC station) in HW Config. 
2. Select Edit > Assign Asset ID... menu command. 
3. Click "OK". 
4. Select the Station > Save and Compile menu command. 

7.3.7 Specific Characteristics of GSD Files 

Checks on GSD Files Starting with PCS 7 V6.0 
For SIMATIC PCS 7 V6.0 and higher the GSD files (Generic StationDescription files) are 
checked more closely. Syntax errors or illegal operation errors can occur with GSD files from 
an older project.  
Improved help texts are provided for syntax errors and GSD problems starting with 
SIMATIC PCS 7 V6.0.  
If you have problems, contact the device manufacturer to obtain the correct GSD files. 

Signal and Diagnostic Blocks for PA Devices in PCS 7 V5.2 and Higher 
PA devices are supported by the new signal and diagnostic blocks starting with PCS 7 V5.2 
including Service Pack 3. This also includes the "Generate Module Drivers" function. In order 
for this function of PCS 7 to be executed correctly, the GSD file (Rev. 3) of the relevant PA 
device must contain the entry "Slave Family = 12". If this is not the case, then contact the 
device manufacturer to obtain the correct GSD file. 

Use of Correct GSD Files 
The PA devices used in HW Config must use a GSD file from the 
Siemens/Step7/S7data/nsmet directory. This ensures that the driver generator creates the 
driver blocks for the PA device correctly. 
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7.4 Adaptations in NetPro and conversion of the CFC/SFC charts 

7.4.1 Overview of Adaptation of OS-relevant Settings 

Overview of the procedure   
 
Step Action ES OS 

server 
OS 
client 

AS 

26 Check and adapt the connection data in NetPro 
(Page 77)  

X    

27 Convert the CFC charts and SFC charts (Page 79)  X    

7.4.2 How to Check and Adapt the Connection Data in NetPro 
In NetPro, check whether all of the connection and configuration data are configured for the 
target stations.  

Requirements 
● The PCS 7 project is open on the ES. 

Procedure 
1. In SIMATIC Manager, select the PCS 7 project. 
2. Select the menu command Options > Configure Network. 

NetPro opens. 
3. Select the menu command View > Cross-Project Network View. 

The cross-project network view is displayed. 
This allows you to toggle directly between all projects in the multiproject. 
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4. Check the connections to the various stations: AS-OS, AS-AS, ES-AS.  
You can make all necessary changes after the "cross project network view" is 
deactivated. 
You must configure the connection between the ES and AS if you want to check the 
communication for process mode (runtime) on the ES. This requires the following steps to 
be taken: 
– Select the menu command New Connection in the shortcut menu of the WinCC 

application. 
– Select the destination. AS or OS. 
– Select the connection. 
– Select the name for the connection. 
– Click "OK". 
Recommendation 
To enable you to easily identify the connections, we recommend that they be assigned 
default names in accordance with the name of the target. 
Example:  
You configure a connection from OS_X to AS_X.  
The connection might then be named "AS_X_OS_X ". 

5. If you are using time synchronization, you must check the time settings of the network 
adapter (e.g. communications processor) for the ES and OS. Double-click the network 
adapter of the OS/ES. Time-of-day mode must be selected for time synchronization in the 
"Options" tab. 

6. If you have made changes in NetPro, you must perform a "Save and Compile" operation 
with the "Save and Compile All" option. 
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7.4.3 How to Convert CFC Charts and SFC Charts 

Requirement  
The PCS 7 project is open on the ES. 

Procedure 
 

 Note 
This procedure must be carried out for all S7 programs in your PCS 7 project. 

 

1. Open a CFC chart and move any block contained within it. 
This action will cause the conversion dialog to open immediately. 

2. Click "Yes". 
The "Convert Format" message window opens. 

3. Click "Yes". 
4. Click "OK". 
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7.5 Updating the blocks 

7.5.1 Overview of tasks for updating blocks 

Overview of the procedure   
 
Step Action ES OS 

server 
OS 
client 

AS 

28 Copy objects from other libraries into the master data 
library (Page 86)  

X    

29 Complete the master data library (Page 87)  X    
30 Synchronize blocks (Page 91)  X    
31 Include event texts (Page 93)  X    
32 Import operator texts (Page 94)  X    
33 Adapt operator texts (Page 95)  X    
34 Configure limit values for online trend control 

(Page 89)  
X    

35 Update block types (Page 96)  X    
36 Update SFC block types (Page 97)  X    
37 Replace blocks for the motor starter (Page 99)  X    
38 Activate the display of AS emergency operation 

(Page 100)  
X    

39 Inserting blocks for high-precision time stamping 
(Page 101)  

X    

40 Copying messages for high-precision time stamping 
(Page 102)  

X    

41 Compile CFC charts (Page 104)  X    

 
 

NOTICE  
Block "CH_AI", default setting for the LAST_ON input modified 
The default setting for the LAST_ON input has been modified at the "CH_AI" block in the 
PCS 7 V7.1 library. If a limit value violation generates the "retain last value" response, the 
LAST_ON input will need to be set to 1 (SUBS_ON remains at 0). 
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7.5.2 Integration of a New Master Data Library 
 

 Note 
The following section applies only if the project to be updated does not contain a master data 
library before starting the software update.  

 

Basic Procedure 
Creating a multiproject will also create an empty master data library. You copy all blocks 
from the first AS from the "Offline" block folder with the version to be updated to the master 
data library. Then compare the blocks in the master data library with the "Offline" block folder 
of the next AS. If it contains other blocks that have not been stored in the master data library, 
you also copy these to the master data library. Repeat this procedure through to the final AS. 

 

NOTICE  
Only the AS blocks of one PCS 7 version can be loaded on an SIMATIC station. 

 

7.5.3 Updating the format of an existing master data library 
All blocks that you use in your PCS 7 project must be replaced with blocks from the new 
library. This process involves several steps. 
If the master data library contains charts which were created with a PCS 7 version older than 
7.0, the master data library must have been converted into the V7.0 format. 
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7.5.4 Language of Message Texts in Faceplates 

Texts in Faceplates 
If you want to convert messages displayed in the faceplates and generated from the ES data 
management from the English default to other languages, such as Italian or Spanish, you 
must perform the following procedure: 
● Copy objects from other libraries to the master data library 
● Copy the blocks used in the project to the master data library 
● Edit the event texts and operator texts in the faceplates 
● Update the block types in the project 

Message Texts in Block Instances 
Message texts from block instances that were created by copying block types have no type 
reference. 
If other display languages (such as Italian, Spanish) are added after the software update, the 
message texts of these added display languages are shown in English in the block instances 
of the block types. 

Including Message Text in the Block Import 
If you want to include messages text in a block import, you need to make settings for the 
block type in the library (master data library). 

 

NOTICE  
The message texts will be overwritten for all block instances of the block type in the entire 
S7 program! 

 

Additional information 
You can find additional information about this in the section "How to Include Event Texts 
from the Block Type in the Block Import (Page 93)". 
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7.5.5 Editing Texts for Faceplates 

Applications 
The procedure steps in the section "Adapting Operator Texts with Import File" must be 
executed under the following conditions: 
● You want to convert texts displayed in the faceplates from the default language (English) 

to another language, such as German or French. 
● You want to retain old operator texts (created with PCS 7 V5.x or PCS 7 V6.x) from your 

project. 

What Happens to Operator Texts when the Software is Updated? 
If new faceplates are used, the original operator texts associated with analog- and binary-
value operator control will be missing from the updated faceplates. Add any operator texts 
created in PCS 7 V5.x or PCS 7 V6.x which were anchored to the faceplates to the function 
block if you are also going to use those texts for PCS 7 V7.1 applications. 
The standard operator texts for the updated faceplates are located in the parameter 
attributes "s7_shortcut," "S7_string_0," "S7_string_1," and "S7_unit".  

 

 Note 
The standard operator texts are only available in one language. 

 

Operator Texts in Block Instances 
 

 Note 
You can no longer reintegrate the operator texts by importing a block type if you have made 
changes to the operator texts in the block instances in your CFC charts. You can then only 
change the operator texts in the block instances. 
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7.5.6 Rules for Copying Objects from Other Libraries 

Rules for Copying 
● If you want to copy the process tag types supplied in the PCS 7 library to your master 

data library, select only the process tag types you require in the "Templates" folder. Copy 
these types and paste them into your master data library's "Charts" folder. 

● If you copy blocks into the master data library from different libraries, it is possible that 
blocks will be assigned different names (and functions) but the same block numbers. If 
this does occur, a dialog box will open where you can rename the block or synchronize 
the attributes. 
Blocks can only be renamed (reassigned) when they are copied to the "Offline" block 
folder. 

● The symbolic name is also copied when you copy the blocks from a library. The symbolic 
name is lost and must be subsequently reentered in the symbol table if you copy from an 
S7 program and not from a library. 

 

NOTICE  
 

Only the AS blocks of one PCS 7 version may be loaded on a SIMATIC station. 
 

Rules for Multi-instance Blocks 
● In the case of blocks whose codes are used to call other blocks (multiple instance 

blocks), these lower-level blocks must be copied in the right version too. 
Any missing lower-level FBs are displayed when the user program is compiled. 

 

 
 

Note 
Note that the ES does not identify the missing FCs when the user program is compiled.  
If an FC is missing from the user program, the AS CPU will enter the STOP mode 
following download. 
If necessary, test the executability of a user program with a "reduced library" on a 
separate CPU. 

 

● The code of the multiple instance block always stores the numbers of the blocks it calls. 
You can edit those numbers and, therefore, the program code itself, using the Options > 
Rewire ... menu command in SIMATIC Manager.  
Exception: The numbers of protected blocks cannot be changed. 
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7.5.7 Rules for Editing the Operator Texts 
Comply with the following rules when modifying default texts.  

Rules 
● The new texts must not be longer than the default texts. If longer texts cannot be avoided, 

you must check to see whether the message is displayed correctly on the faceplate. 
● The "s7_unit" attribute does not have to be considered for the translation since blank 

spaces or international codes were used as default values. 
● If you require multilingual texts, use the WinCC Editor "Text Library" to translate these 

texts into other languages. 
However, in this case, the default language for the display devices is set in SIMATIC 
Manager and must always be the same language as used to configure the operator texts 
and display text (usually "English"). This is the only way to ensure that the translated 
messages are not overwritten the next time the OS is translated. 

● When the OS is compiled, the column that is always used as a reference is the one 
containing the language set in SIMATIC Manager as the "Standard language for display 
units".  
The texts in the Text Library of WinCC Explorer are automatically entered by PCS 7. 
Change the texts only if you have adapted unit and operator texts. 

 

 
 

Note 
If you recompile the OS, you cannot switch the "Default language for display devices" in 
SIMATIC Manager. In this case already compiled entries can be overwritten. 
For more information, refer to the Process Control System PCS 7; Operator Station 
manual, section "Relationship between Compile OS and Text Library". 
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7.5.8 How to Copy Objects from Other Libraries to the Master Data Library 
This section describes how to transfer objects from the supplied PCS 7 library, or other 
libraries provided by suppliers, to the master data library. 

 

 Note 
During the software update, copy the only objects versions used in the project to be updated 
from the PCS 7 V7.1 library to the new master data library. 

 

NOTICE  
Only the AS blocks of one PCS 7 version may be loaded on a SIMATIC station. 

 

Requirement 
● The master data library has been created in the project to be updated. 

Procedure 
1. Select the menu command File > Open in the SIMATIC Manager. 
2. Open the "Libraries" tab. 
3. Select the required library and click "OK".  

The library opens. 
4. Select the library section to be copied from the open library (source). 
5. Select the menu command Edit > Copy (e.g., process tag types, blocks). 
6. Select the folder in the master data library (target) where the copied library section is to 

be stored. 
7. Select the menu command Edit > Paste. 

The copied library section is saved in the master data library. 

Adapting default texts 
Adapt the default texts accordingly in the master data library in which you have replaced the 
blocks you created in PCS 7 V5.x or PCS 7 V6.x with PCS 7 V7.1 blocks. 

Additional information 
● Section "Editing Texts for Faceplates (Page 83)" 
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7.5.9 How to fill the master data library 
The following tasks are only necessary if you update a project that has not been completely 
configured from the master data library.  

Requirements 
● The master data library has been created and is open. 
● The "Offline" block folder of a SIMATIC station is open. 
● You are only using the original blocks from the PCS 7 libraries in the SIMATIC stations. 
● You are not using blocks from different PCS 7 versions in the SIMATIC stations and wish 

to continue using the blocks from a single PCS 7 version following the PCS 7 update. 
 

 
 

Note 
Only the AS blocks of one PCS 7 version may be loaded on a SIMATIC station. 

 

Procedure 
1. Select the menu command View > Details. 
2. Select the detail view and click the column heading "Author".  

This arranges the blocks used in your project and contained in the offline block folder 
according to "Author". 

3. Select all blocks listed with an "older" version number in the "Author" column (e.g. 
DRIVER60, "...60", "...70", ...) 
Keep the <Ctrl> key pressed to select several blocks. 

 

 
 

Note 
You also need to select the following BATCH blocks for projects with BATCH 
configuration: 
• All blocks with the "BATCH" entry in the "Family" column 
• The blocks READ_CLK and NOTIFY_8P, when they are used 

 

4. Select the blocks or block areas that are not available in the master data library. 
5. Select the menu command Copy in the shortcut menu. 
6. Select the "Blocks" folder in the open master data library. 
7. Select the menu command Paste in the shortcut menu.  

 If you have selected the "Always prompt for settings" check box in the "Set Message 
Range" dialog box, the "Message Number Assignment Selection" dialog box appears 
when you copy blocks. 

8. Select the "Always assign CPU-oriented unique message numbers" check box. 
9. Select the next "Offline" block folder and compare its blocks to the blocks that are already 

contained in your master data library. If the "Offline" block folder contains additional 
blocks, copy these blocks to the master data library you have created. 

10. Repeat the steps 5 through 9 with all other "Offline" block folders. 
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7.5.10 Trend Control for Displaying Archive Values 

Display in Trend Control 
The following notes only need to be taken into account if you want to display archive values 
in trend control. 
This section is not relevant for displaying online tags in trend control. 

Name of the Available Archive 
If the project being updated contains an archive called "Process Value Archive", the archive 
tags generated by the system are saved in an archive called "SystemArchive".  
If these archive values are to be accessed using the trend control display, the following 
settings must be changed in the block icon properties in the Graphics Designer: 
● ReturnPath:  

Transfers trend data for the corresponding process tag. 
● StandardTrend:  

Used to define the trend functionality to be visualized in the trend view. 

Procedure 
1. In the tree structure, select the "Styles" object. 
2. Make the following settings: 

– StandardTrend:  
Change from 2 to 3. 

– ReturnPath:  
Add the following in the return path: *archivname:Systemarchiv*asia: 
Example: U:CO_DKGREEN*archivname:SystemArchive*asia: 

Additional information 
Manual Process Control System PCS 7; Programming Instructions for Blocks 
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7.5.11 How to Configure Extensions for Online Trend Control 
You can specify the following parameters for automatically displaying value axis values in 
online trend control as part of process control: 
● Limit values 

– Maximum value (high limit) 
– Minimum value (low limit) 

● Unit 
These parameters for displaying a tag in online trend control are automatically adopted by 
the associated function block when the OS is compiled. 

Parameter Attribute "S7_trend" 
Parameter attribute "S7_trend" can be assigned for function block I/Os, if the data type is 
one of the following: 
● INT 
● DINT 
● Real 

Requirements   
● Parameter attribute "S7_m_c" is set to TRUE for the block and corresponding I/Os to be 

taken into account with (high and low) limit values in online trend control. 
● The "Online trend control" object is inserted in the process picture. 

 

 
 

Note 
The "automatic" check box is activated by default for "Online Trend Control" objects 
(Properties, "Value axis" tab, "Range selection" group). 

 
 

 Note 
Automatic adaptation of the high an low limits for archive tags in the Online Trend Control 
requires the following CFC configuration: 
Set the archiving parameter (that is assigned parameter S7_trend) when you configure the 
associated block in the CFC. 
Configurations using WinCC Tag Logging are not supported in PCS 7. 

 



Adaptations in the PCS 7 Project on the ES  
7.5 Updating the blocks 

 Software update with utilization of new functions (PCS 7 V6.x or higher to V7.1) 
90 Service Manual, 03/2009, A5E02128573-01 

Procedure 
1. Open SIMATIC Manager in the component view. 
2. Select the block (block type) in the library (master data library). 
3. Select the menu command Edit > Open Object. 

The "LAD/FBD/STL" dialog box opens. 
 

 

 
 

Note 
If a message appears that the block is write-protected, just ignore it. 

 

4. In the tree structure, select the block I/O for which you want to specify parameters. 
5. Select the menu command Edit > Object Properties. 
6. Select the "Attributes" tab. 
7. In an empty line, select the "S7_trend" entry from the drop-down list box. 
8. Enter the name of the block I/Os at which you want to parameterize high and low limits 

for the selected I/O in the "Value" column. A comma separates the names (for example, 
LL_Name, HL_Name). 

9. Click "OK". 
10. Select the menu command File > Save. 

The "Save ..." dialog box opens. 
11. Click "Yes". 
12. Select the menu command File > Close. 

Additional information 
● Online help STEP 7 
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7.5.12 How to Update the Master Data Library 

Introduction 
The blocks of the master data library that has been created must be replaced by those of the 
current PCS 7 library. 

 

 Note 
PCS 7 libraries 
Starting with PCS 7 V7.1, the PCS 7 blocks included on the Toolset DVD are distributed to 
different libraries. 

 

Library for Redundant I/O Modules 
If you are using redundant modules in the project, then you must also update the 
"Redundant IO (V1)" library. 

Requirements 
● The master data library contains all blocks of the project being updated. 
● The master data library is open. 
● It does not contain any PCS 7 V4 or V5 blocks (types: IN_..., Out_ ..., and PA_blocks of a 

block version lower than 5.2). 

Rule 
 

 Note 
The attributes of the individual blocks must be synchronized when replacing the blocks in the 
project being updated. Individual attributes of the old blocks can be applied if you have 
provided additional outputs with the "S7_m_c" attribute. You can apply the attributes of the 
new blocks if you have not made any changes to the default settings. 

 

Validity 
 

 Note 
The procedure described in the sections that follow is only valid for blocks whose object 
name and name (header) have not changed between library versions. 
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Procedure 
1. Select the menu command File > Open in the SIMATIC Manager. 
2. Open the "Libraries" tab. 
3. Select a library from which you wish to import blocks (for example, PCS 7 Library V7.1). 

Click "OK".  
The library opens. 

4. Double-click the "Blocks+Templates" folder and then on the "Blocks" folder. 
5. Arrange the library one beneath the other so that the contents of both windows can be 

easily seen and the master data library is on the top. 
6. Keeping the <Ctrl> key pressed, select all blocks which also exist in the master data 

library from the library you selected. 
7. Right-click a selected block or block area, and select the menu command Copy in the 

shortcut menu. 
8. Select the "Blocks" folder in the master data library, and select the menu command Paste 

in the shortcut menu. 
9. Synchronize the attributes for each block individually by clicking the "Synchronize 

Attributes" button. 
If various attributes are found, a dialog box displays the differences between the block 
attributes. 

10. Check the attributes and the project-specific settings. 
 

 
 

Note 
We recommend applying the default settings. 

 

 
 

Note 
If you click the "All“ button in the "Insert Function Block" dialog box, all blocks will be 
copied without synchronizing the attributes. 

 

11. Click "OK".  
If no differences between the attributes are identified, a dialog box indicating this is 
displayed. 

12. Click "OK". 
13. Click "Yes".  

The corresponding block is copied to the master data library with the synchronized 
attributes. 

14. Repeat those steps to select additional libraries. 
 

 
 

Note 
For projects with BATCH configuration, repeat the procedure with the SIMATIC BATCH 
BLOCKS library. 
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7.5.13 How to include event texts from the block type in the block import 

Introduction 
One aspect that should be noted with a software update of projects, is that the message 
texts of block instances, generated by copying block types, have no type references. If other 
display languages (such as Italian, Spanish) are added after the software update, the 
message texts of these display languages are shown in English in the block instances of the 
block types. 

Importing and Editing Message Text of Block Instances 
The following setting is required if you want to automatically overwrite the message texts of 
all instances in a block type for the entire S7 program. 
If you want to edit the message texts of the instances, you need to deactivate this setting 
and perform an import again. 

Procedure 
1. Open the SIMATIC Manager in the component view. 
2. Select the block (block type) in the library (master data library). 
3. Select the menu command Edit > Special Object Properties > Messages. 

The "PCS 7 Message Configuration" dialog box opens. 
4. In the table to the right of the "Event" column, make the following setting in the colum  

for the message texts: 
– Activate the check box for the message texts you want to import from the block type. 
– Deactivate the check box for the message texts you do not want to import from the 

block type. 
 

NOTICE  
 

The message texts will be overwritten for all block instances of the block type in the 
entire S7 program!  
If you wish to modify the instances of the block types again, you must clear the 
corresponding check marks and perform another block import. 

 

5. Click "OK". 
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7.5.14 How to import the operator texts 

Requirement 
The user texts have been exported from the project to be updated. 

Importing User Texts 
1. Open the project to be updated in the SIMATIC Manager. 
2. Select the master data library folder in the component view. If this folder is not available, 

select the project folder. 
3. Select the menu command Options > Manage Multilanguage Texts > Import. 

The "Import User Texts" dialog box opens. 
4. Specify the storage location and the format of the import file (possible formats: *.xls and 

*.csv). 



 Adaptations in the PCS 7 Project on the ES 
 7.5 Updating the blocks 

Software update with utilization of new functions (PCS 7 V6.x or higher to V7.1) 
Service Manual, 03/2009, A5E02128573-01 95 

7.5.15 How to adapt the operator texts 

Requirements 
● The master data library contains the PCS 7 V7.1 blocks. 
● The master data library is open. 
● You have made a note of the texts of the parameter attributes "S7_shortcut," 

"S7_string_0," "S7_string_1" and the corresponding PCS 7 blocks. 

Procedure 
There are different procedures for adapting the operator texts:  
● Adapting for block types 

You can find more information about this in the manual Process Control System PCS 7; 
Operator Station in the section "How to Edit Texts for a Block Type". 

●  
You can find additional information in the "Process Control System PCS 7; Operator 
Station" manual in the section "How to Edit Texts in a Block Type." 

We recommend that you adapt the operator texts for block types. This ensures the following: 
● Operator texts of identical blocks are consistent in the different automation systems. 
● Adapted texts are readily available for subsequent configuration. 
You must also adapt the block type in the modified block instance if you have already 
manually adapted operator texts in CFC block instances. 

Additional information 
● Manual Process Control System PCS 7; Programming Instructions for Blocks in the 

section "ES Texts for Operator Control of Analog and Binary Values" 
● Configuration manual Process Control System PCS 7; Operator Station in section 

"Adapting the Unit and Operating Texts". 
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7.5.16 How to update the block types in the project 
 

NOTICE  
It is only possible to work with a master data library if blocks with the same designation 
have the same structure and attributes in all projects of the multiproject.   

 

Requirement 
The master data library has been created with the current block types. 

 

NOTICE  
Block "CH_AI", default setting for the LAST_ON input modified 
The default setting for the LAST_ON input has been modified at the "CH_AI" block in the 
PCS 7 V7.1 library. If a limit value violation generates the "retain last value" response, the 
LAST_ON input will need to be set to 1 (SUBS_ON remains at 0). 

 

Procedure 
1. Select all blocks that to be updated in the block folder of the master data library. 
2. Select the menu command Options> Charts > Update Block Types. 

The "Update Block Types" dialog box opens. 
3. Select the S7 programs to be analyzed for the selected block types that differ from those 

in the master data library. 
4. Click "Continue". 

All the S7 programs selected are checked and another dialog box for selecting the block 
types opens. This provides information about the potential consequences of updating the 
block types. 

5. Specify the block types to be updated for the individual S7 programs. You must select all 
the block types to be updated. If required, you can deselect those that should not be 
updated. If there are no block types available for updating, no block types are displayed. 
In this case, close the dialog box. 

6. Click "Next". 

Result 
The block types are updated in all selected S7 programs and a log is displayed. 

Additional information 
● Online help on the dialog boxes 
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7.5.17 How to update the SFC block types in the project 
 

NOTICE  
It is only possible to work with a master data library if blocks with the same designation 
have the same structure and attributes in all projects of the multiproject.   

 

Listing components with "old" versions of a block type 
After inserting a new version of a block type or SFC type into the master data library or after 
adapting a block type in the master data library, you can use the "Update Block Types" 
function to list all components in which an older version of the modified block type is used. 
Throughout the entire multiproject, you can also select the components in which the modified 
block type will be updated. 

Requirement 
● The master data library has been created with the current block types. 

Procedure 
1. Select one or more SFC types in the chart folder of the master data library. 
2. Select the menu command Options> Charts > Update Block Types. 

The "Update Block Types" dialog box opens. 
3. Select the S7 programs to be checked for differences compared with the block types/SFC 

types selected in the master data library. 
4. Click "Continue". 

All the S7 programs selected are checked and another dialog box for selecting the 
block/SFC types opens. Here you also obtain information about the possible effects of 
updating the block/SFC types. 

5. Specify the block/SFC types to be updated for the individual S7 programs. You must 
select all the block/SFC types to be updated. If required, you can deselect those that 
should not be updated. 

6. If there are no block/SFC types that have to be updated, no block/SFC types are 
displayed. In this case, close the dialog box. 

7. Click "Make". 

Result 
The block/SFC types are updated in all the selected S7 programs and a log is displayed. 

Additional information 
● Online help on the dialog boxes 
● Configuration manual Process Control System PCS 7; Engineering Station 
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7.5.18 Operating Principle of the Improved Block for the Motor Starter 
In PCS 7 V6.1 and higher, the PCS 7 Library contains an improved block for ET 200S motor 
starter modules.  

Operating principle 
The improved block can be used to configure a direct symbolic connection between the 
motor blocks in the CFC and the corresponding motor starter module. The connection of all 
other functions is automatically carried out when the module driver is created using the 
"Create module driver" function. 
Conversion is necessary if you wish to fully exploit the diagnostic potential of the 
maintenance station for ET 200S motor starters. 

Advantages 
● Special block for motor diagnostics 
● Simple configuration 
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7.5.19 How to Replace the Blocks for the Motor Starter 
The following tasks are only necessary if you update a project from PCS 7 V6.0 that contains 
the motor starter modules of ET 200S. 

Requirements 
● PCS 7 V7.1 is installed. 
● There are motor starter modules of ET 200S in the project. 
● CFC is open. 
● The chart reference data has been searched for motor blocks (so all motor starter 

modules have been identified). 

Procedure 
 

 Note 
The procedure is described for a PCS 7 system in which a motor block (FB66) was used to 
control the motor. 

 

1. Open the CFC chart containing the motor block and navigate to the channel driver-blocks 
(CH_DI, CH_AI). 

2. Place a CH_MS block in the CFC chart. 
3. Interconnect the "Value" input of the CH_MS block. 
4. Interconnect the outputs to the "Motor" block. 
5. Delete the old channel driver blocks that belonged to the motor block selected in Step 1. 
6. Repeat steps 1 to 5 until all motor blocks for the motor starter are interconnected to the 

ET 200S. 
7. Compile the CFC charts when all CH_MS blocks have been interconnected. 
8. Test the function of the motor starter. 
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7.5.20 How to Activate the Display of AS (CPU) Emergency Operation 
PCS 7 V7.1 or higher supports activation of the function for monitoring emergency operation 
of the CPU in systems without Maintenance Station. 

CPU Emergency Operation 
All functions are processed in CPU emergency operation. The processing period is longer 
than the configured processing time. 

Basic Procedure 
Configure the OCM attribute at all instances of OB_BEGIN (system chart "@(2)"). You can 
do this in the following ways: 
● Activate the OCM attribute at the OB_BEGIN instance of every AS to be monitored 

(Object Properties > General tab > "OCM possible" option). 
● Alternatively, you can delete all system charts and import OB_BEGIN from the current 

library. 
 

 
 

Note 
In PCS 7, emergency operation is created as a message with priority 16 by default. 
Messages with this priority can also be viewed by users who do not have access rights. 
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7.5.21 How to insert blocks for high-precision time stamping 

Requirements 
The CFC charts of the project to be updated are compiled using the current PCS 7 version. 

Procedure 
1. To be carried out for all CPUs with time stamping: 
2. Select the path "Project" > "SIMATIC Station" > CPU > S7 project > Charts from the tree 

structure. 
3. Select the Options > Charts > Chart reference data. 

menu command. The "Chart Ref.: Chart reference data..." dialog box opens. 
4. Select the View > Block types menu command. 
5. Click the "Block type" header of the table. 

The blocks of this CPU are displayed in sorted order. 
6. Go to the "Chart Ref.: Chart reference data..." dialog box to search for the "IM_DRV" 

block type. 
7. Double-click the "IM_DRV" entry.  

The assigned CFC chart is opened. 
8. Open the "Driver" folder from the "PCS 7 Library71". 
9. Drag up to eight MSG_TS blocks to the temporary CFC chart (e.g. TEMP_IM_DRV_1). 
10. Repeat step 5 through 9 for all IM_DRV blocks that exist in the CPU. 
11. Open the project in the SIMATIC Manager. 
12. Open the following views: 

– Component view 
– Plant view 

13. Select the temporary charts from the component view. 
14. Select the Edit > Cut menu command. 
15. Select an area in the plant view to which you want to save the temporary charts. 
16. Select the Edit > Paste menu command. 
17. Repeat steps 1 through 13 for all the SIMATIC stations of the project. 
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7.5.22 How to copy the messages for high-precision time stamping 

Requirements 
The IM_DRV block and the MSG_TS blocks exist in the same chart. 

Procedure 
1. Open the process object view in SIMATIC Manager. 
2. Select the path to the temporary charts from the tree structure. 
3. Select a temporary chart from the tree structure. 
4. Select the "Messages" tab from the list view. 
5. Select the "Block type" entry from the "Filter by columns" list box. 
6. Enter the name of the "IM_DRV" block type in the "Display" input field. 

The messages are displayed. 
7. Copy up to 16 messages from the IM_DRV to the MSG_TS. 
8. Move the MSG_TS blocks to a chart to suit technological requirements.  

The temporary chart contains only one IM_DRV block. 
9. Delete the temporary chart. 
10. Interconnect the inputs of the MSG_TS blocks with the assigned input signals.  

Tip: Refer to the symbolic names of the input signals for orientation. 
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7.5.23 Sequences during Compiling of CFC Charts 

Driver Blocks for Compiling the CFC Charts 
Since new block types were imported in the chart folder, you need to compile all CFC charts. 
This will use the imported driver blocks and optimize the program. 

Relationship between the Driver Blocks and the Master Data Library 
 

 Note 
In the case of PCS 7 libraries, the reference to the associated library is assumed by the 
driver generator. 
When compiling with the "Generate module drivers" option, you can select an additional 
library (for example, a master data library) under "Settings Module Drivers". All driver blocks 
contained in the project must then be in this library. 

 

F Charts/F Blocks 
 

 

NOTICE  
If your project contains F charts/blocks and you do not upgrade to the new F technology, 
the F-@ charts should not be deleted. Otherwise, your F program will receive a different 
signature. The F system would then have to undergo the acceptance process again 
according to the country-specific guidelines due to the changed signature. 
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7.5.24 Compiling the CFC Charts 

Procedure 
1. Perform a complete compilation of the S7 program. 

Additional information 
● Configuration manual Process Control System PCS 7; Engineering Station 
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7.6 Adaptation of OS-relevant settings 

7.6.1 Overview of Adaptation of the Operator Stations 

Overview of the procedure    
 
Step Action ES OS 

server 
OS 
client 

AS 

42 Converting Single Clients (Page 106)  X X   
43 Synchronize OS basic pictures, local computer 

actions, and faceplates (Page 107)  
X    

44 Replace controls with picture objects (Page 112)  X    
45 Update picture objects (Page 114)  X    
46 Set time synchronization (Page 115)  X X   

User interface and design 
You can define the appearance of the user interface in process mode.  
We recommend that you use the WinCC 3D or WinCC Classic design. 
● It is important to ensure a uniform design setting is made for all projects within a system. 
● When changing the setting for the WinCC design, check how self-generated objects 

appear and make adjustments where necessary. 
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7.6.2 Converting Single Clients 

Single Clients in PCS 7 
A single client is a client which does not have its own project. As of PCS 7 V7.0, this client 
type is no longer supported. 

 

 Note 
You can link single clients to a PCS 7 plant via WinCC. 
Be aware that not all of the functions of the newer PCS 7 versions are available for this client
type. You should therefore convert to the OS client that conforms to PCS 7. 

 

Additional information 
You can find more information about how to convert single clients in the "Process Control 
System PCS 7; SW Update with Utilization of New Functions (Version PCS 7 V4.xx to V5.2)" 
manual, in the section "Converting WinCC Client to Multi-client", which can be found as an 
FAQ under Service & Support: 
Software Update From PCS 7 Version 4.xx to PCS 7 Version 5.2 
(http://support.automation.siemens.com/WW/view/en/8786009)  

7.6.3 Synchronization of OS Basic Pictures, Local Computer Actions and Faceplates 
You have to transfer OS basic pictures and local computer actions to your project. The 
faceplates of the project can continue to be used.    

Synchronization in the OS Project Editor 
You perform this procedure with the OS project editor, which is included in WinCC Explorer. 

Deleting the template from the APC library      
If you have used the "PCS 7 APC V70" library in the project, you must delete the 
"@PCS7TypicalsAPC.pdl" template from the old project. Starting with PCS 7 V7.1, the 
blocks of the "PCS 7 APC V70" library are contained in the "PCS 7 Library V71" library. 
1. Select the Graphics Designer in WinCC Explorer for this purpose. 
2. Select the "@PCS7TypicalsAPC.pdl" object in the detail window. 
3. Select the Delete picture(s) command from the shortcut menu. 

http://support.automation.siemens.com/WW/view/en/8786009
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7.6.4 How to Synchronize OS Basic Pictures, Local Computer Actions, and Faceplates 

Requirements 
● The operator stations contained in the PCS 7 project have been updated with the Project 

Migrator. 
● The PCS 7 OS is open in WinCC Explorer. 

Procedure 
1. Select the OS Project Editor and select the menu command Open in the shortcut menu. 
2. Select the "Complete configuration" check box on the "General" tab. 
3. Click the "Layout" tab. 
4. Select the required layout and the monitor configuration. 
5. Click the "Basic Data" tab. Make the required settings in accordance with the "Basic 

Data" table below. 
6. Only carry out this step if the "For observation only" authorization level must be activated 

for some users after the software has been updated. 
Select the "Message Display" tab.  
Activate the required message filters (see the "Message Filters" table below). 

 

 
 

Note 
No settings are necessary for the software update on the remaining tabs. The default 
settings can be applied. 

 

7. Click "OK". 
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Basic Data 
 
Dialog Area Note Action 
Top left  
window 

This window lists all basic pictures 
having a different product version and 
project version change date. 
Every basic picture with a selected 
check box is overwritten in the project 
version at the start of the OS Project 
Editor with pictures from the product 
version. 

Activate the check boxes for all of the basic pictures identified 
with a red "X". 

Top right  
window 

This window lists all local computer 
actions having a different product 
version and project version change 
date. 
Every local computer action with a 
selected check box is overwritten in the 
project version at the start of the OS 
Project Editor with the corresponding 
local computer action from the product 
version. 

Activate the check boxes for all of the basic pictures identified 
with a red "X". 

Bottom left  
window 

This window lists all faceplates having a 
different product version and project 
version change date. 

You can replace the faceplates available in the project with 
those of the relevant product version by transferring  
the default settings. 
Note: If you wish to continue using the controls from older 
PCS 7 versions in the project, you should not replace the 
faceplates in the project with the faceplates from the product 
version. 
Requirement: The controls of the PCS 7 version (for example, 
V5.2) must be installed on the engineering station and the 
operator stations used for the process operation (OS clients, 
for example). 
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Message Filters 
 
Parameters Meaning 
Messages that 
can be 
acknowledged in 
a separate list 

The message windows have two message lists.  
One list shows all messages from the area for which the user has access rights for all "operator process 
controls". The user can acknowledge messages in this list.  
The other list shows all messages from the area for which the user has an "authorization for area" but 
no access rights for "operator process controls". The user cannot acknowledge messages in this list.  
The message line in the overview area only shows messages that can be acknowledged with the 
access right for "operator process controls". 

Messages that 
can be 
acknowledged 
on a separate 
page (switch-
selectable) 

Both of the message pages indicated above are available to the user. Only messages from areas for 
which the user has access rights for "operator process controls" are displayed on the message page 
with only one list and in the message line of the overview area. 

Additional information 
● Online help WinCC Information System > Options > Options for Process Control > OS 

Project Editor 
● Online help OS Project Editor 
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7.6.5 Replacing Controls with Picture Objects 

Important Information 
 

 Note 
Read the section about replacing controls with picture objects if the project to be updated 
was originally created with a PCS 7 version earlier than PCS 7 V6.0. 

 

Controls and picture objects 
We recommend you replace the controls with picture objects. 
 
Object Controls Picture objects 
Origin Controls were use in the PCS 7 OS up to 

and including PCS 7 V5.2. 
Controls are programmed faceplates that 
cannot be edited.  

Picture objects are objects that are 
assembled in the Graphics Designer for 
the PCS 7 OS. 

Performance The use of controls in pictures decreases 
the performance on the OS compared to 
the use of picture objects. 

Compared to the use of controls, the use 
of picture objects in pictures results in 
better OS performance. 

Configuration 
of the display 
of trend 
values 

The time-consuming configuration of the 
display of trend values with controls 
means that trend values are shown 
immediately in an OS picture (archive 
tags). 

The display of trend values therefore 
requires no configuration effort since only 
online tags are displayed. User-
programmable curves are recommended 
for past values. 

Compatibility 
Controls and picture objects can be used simultaneously. 
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7.6.6 Rules for Replacing Controls with Picture Objects 

Important Information 
 

 Note 
Read the section about replacing controls with picture objects if the project to be updated 
was originally created with a PCS 7 version earlier than PCS 7 V6.0. 

 

Rules 
● If you want to replace controls with picture objects, you will need to have the controls 

from the associated PCS 7 library (e.g., PCS7_Library__V5.2) on the engineering station. 
● If the faceplates for WinCC have not been installed from the corresponding PCS 7 library, 

the controls will not be replaced. 
If the faceplates for WinCC have not been installed from the corresponding PCS 7 library, 
the blocks and picture objects will not be replaced. 

● We recommend that you replace the controls picture by picture if some of the process 
pictures contain controls and some of the process pictures contain picture objects. Then 
follow the procedure in the section "How to Update Picture Objects (Page 114)". 

● The existing picture objects will also be replaced if the process pictures contain a mixture 
of controls and picture objects. 

● The dynamic wizard does not distinguish between different icons of a picture object. 
Picture objects are always replaced by the first picture object found. After the 
replacement, therefore, you may have to process icons which were used originally. 
For example: 
A valve was originally integrated in a process picture as a picture object in a horizontal 
position. However, when the picture object is replaced, the valve is displayed in the 
vertical position. You must now reconfigure the valve in the process picture. 

 

NOTICE  
 

To keep the same trend display functionality in faceplates as in PCS 7 V5.x, you must 
change the parameter setting of the "Standard Trend" attribute in the "Styles" property of 
the "@Template.pdl" from 2 to 0 for all faceplates. You must do this before calling the 
dynamic wizard and before replacing the controls with picture objects. 
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7.6.7 How to Replace Controls with Picture Objects 

Important Information 
 

 Note 
Read the section about replacing controls with picture objects if the project to be updated 
was originally created with a PCS 7 version earlier than PCS 7 V6.0. 

 

Requirements 
● All basic pictures are replaced with the OS Project Editor. 
● The PCS 7 OS is open in WinCC Explorer. 
● The dynamic wizard can be seen in the Graphics Designer (menu command View > 

Toolbar > "Dynamic Wizard" option). 
● The library with the faceplates (for example, PCS 7 Library V5.2) is installed. 

Procedure 
1. Open any WinCC picture with a control in the Graphics Designer and select that control. 
2. In the dynamic wizard, select the "Picture Functions" tab. 
3. Double-click the "Update Picture Objects" function. 

This "Dynamic Wizard" dialog box opens. 
4. Click "Next". 
5. Select one of the check boxes, "Yes, all pictures" or "Update active picture only", 

according to your requirements (see note above). 
6. Click "Next". 
7. The "@TEMPLATE.pdl" from the GraCS folder in the project folder of the corresponding 

OS server is the default setting for the "Please specify name of " field. This must be used. 
8. In the "Please specify name of configuration file" field, use the browse button to locate the 

configuration file "ChangeOCXtoUdo.cfg". You can find the default file 
"TemplateControl.cfg" in the "Wscripts" folder in the project folder of the corresponding 
OS server. 

9. Click "Next". 
10. Click "Finish". 

The generation of picture objects in the dynamic wizard will begin. 
11. Check to see if you need to edit the replaced picture objects afterwards. 
12. If you are updating only the controls of the active picture, you must save the changes and 

repeat steps 1 through 7 for each WinCC picture. 
When all controls are replaced, the Dynamic Wizard saves the changes. 
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7.6.8 Update of Picture Objects 

Application Case 
In the course of the update of picture objects, the block icons of the PCS 7 version to be 
updated are replaced with PCS 7 V7.1 block icons. This action is necessary in order to 
provide the complete functionality of PCS 7 V7.1. 

Rules 
● If you want to set the same trend display functionality in faceplates as in PCS 7 V5.x, you 

must change the parameter setting of the "Standard Trend" attribute in the "Styles" 
property of the "@Template.pdl" from 2 to 0 for all faceplates. This must be done before 
the dynamic wizard is called or the basic steps listed below are performed. 

● In PCS 7 V5.x, the use of archive tags enabled trend values to be displayed immediately 
upon selection of the trend display. However, this did call for configuration effort. 
As of PCS 7 V6.0, trend values are shown in the trend display after a short period with 
the help of online tags, without any parameter reassignment required. The default setting 
for the trend display shows online tags, thus eliminating the configuration effort for new 
projects. 

● Only the block icons of the selected are updated. Therefore depending on which template 
you have used for configuration, you must use either "@Template.pdl" or 
"@@PCS7Typicals.pdl" as the template for updating the picture objects. We recommend 
performing the update once with the "@Template" template picture and one time with 
"@@PCS7Typicals." 

 

 Note 
The "Create/Update Block Icons" function uses the "@@PCS7Typicals" template picture. 
User scripts and modified properties of the picture objects are overwritten by the default 
settings. 
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7.6.9 How to Update the Picture Objects 
Depending on which template you have used for configuration, you must use either 
"@Template.pdl" or "@@PCS7Typicals.pdl" as the template for updating the picture objects. 
It is recommended that you perform the update procedure once with the "@Template" 
template display and once with the "@@PCS7Typicals" template display. Only the block 
icons of the selected template display are updated. 

Requirements 
● The operator stations contained in the PCS 7 project have been updated with the Project 

Migrator. 
● All basic pictures are replaced with the OS Project Editor. 
● The PCS 7 OS is open in WinCC Explorer. 

Procedure 
1. Open any WinCC picture containing a picture object in the Graphics Designer. Select the 

picture object. 
2. In the dynamic wizard, open the "Picture Functions" tab and select "Update Picture 

Objects".  
This "Dynamic Wizard" dialog box opens. 

3. Click "Next". 
4. Select the "Yes, all pictures" check box. 
5. Click "Next". 
6. Select the template in the list which has been configured with the picture objects of the 

OS. (default:@Templatel.pdl) 
7. Select the default "TemplateControl.cfg" in the "Please specify name of configuration file" 

field. 
8. Click "Next". 
9. Click "Finish". 

This initiates generation of the picture objects in the Dynamic Wizard. 
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7.6.10 How to set the time synchronization 
Perform the following tasks if you want to change the time synchronization mode in PCS 7 
plants from "WinCC V5 compatibility mode" to the "PLC is set to coordinated universal time 
(UTC)" mode. 

Procedure  
1. In the WinCC Explorer tree structure, select the "Computer" object. 
2. Select the menu command Edit > Properties. 

The "Computer List Properties" dialog box opens. 
3. Click "Properties". 

The "Computer Properties" dialog box opens. 
4. Select the "Parameters" tab. 
5. In the "PLC Clock Setting" group, activate the "PLC is set to coordinated universal time 

(UTC)" check box. 
6. Click "OK". 
7. Click "OK". 
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7.6.11 Adaptations for projects created in PCS 7 V6.x 

V6 functions that require additional steps 
These steps only need to be followed if the PCS 7 project to be updated was created with 
PCS 7 V6.x and one of the following functions is used: 
● Trend view 
● ASSET-specific export 
● Archive for Tag Logging (PCS 7 V6.1 or higher) 

Trend view in faceplate with archive tags is used in PCS 7 project 
The block programming instructions provides a description of the previous trend view 
configuration. 
Name the archive "process value archive" to utilize the trend view in the faceplate with 
archive tags. The "process value archive" is created manually in WinCC Tag Logging. 
PCS 7 V6.1 or higher supports the automatic creation of archive tags for process values that 
are marked accordingly. Identify the connections as being archive-relevant by assigning 
these the "archiving" attribute in the CFC as preliminary measure. The archive tags are then 
generated automatically in an archive named "SystemArchive". 
Starting with PCS 7 V7.0 SP1, the automatic generation of archive tags is set by default for 
the control blocks of the following libraries: 
● PCS 7 Library 
● Advanced Process Library  

(contains the updated control blocks of the "PCS 7 APC V70" library) 
The archive values of the control blocks are required for statistic evaluation. Corresponding 
archive tags are generated automatically in the "SystemArchive" after one of those blocks 
was reconfigured. The trend view in the faceplate with archive tags is now using only the 
"SystemArchive". 
It is advisable to edit the following settings after having updated PCS 7 V6 projects: 
At all block icons already assigned the "StandardTrend" > 2 property in the pictures, the 
*ArchiveName:ProcessValueArchive parameter must be added to the "ReturnPath" property. 
Use the corresponding options described in the "PCS 7 - Configuring Manual Operator 
Station", section "Function and implementation of block icons and faceplates". 
The functional expansion for the trend view in faceplates with archive tags also leads to a 
change of the default response of parameter *asia: (add server prefix to archive tag) 
parameter in the "ReturnPath" property.  
The default response as of PCS7 V7.0 SP1 is independent of the server prefix in the 
"tagname" of the block icon if parameter *asia: is not being used. The server prefix is now 
ignored in the derivation of the archive tag name. 
We recommend the following changes if you already configured archive tags with server 
prefix: 
For all block icons that have already been configured in the pictures with the server prefix in 
the "tagname" and "StandardTrend" > 2 property, you should supplement the "ReturnPath" 
property with the *asia:MyServerPrefix parameter. 
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Using the archives for Tag Logging 
Starting with PCS 7 Version 6.1, the archives for Tag Logging are generated automatically 
under the name "System archives". Archives previously created by users continue to exist in 
parallel. 
Note the following information if the archives were used under the name "Process Value 
Archive" in the context of PCS 7 faceplates: 
● As standard, PCS 7 faceplates of version V7.0.2 or higher only use the archives created 

by the system. 
● Previous archives can only be used under the name "Process Value Archive" if additional 

configuration is performed.  
Expand the existing parameter assignment to include the 
"*ArchiveName:ProcessValueArchive" attribute by selecting Block Icon -> Object 
Properties -> Styles -> ReturnPath. 

● The archive tag name may not have a leading server prefix. 
● If archive tags were configured in PCS 7 V6.0 with the server prefix before the archive tag 

name, subsequent configuration is required: 
 Expand the existing parameter assignment to include the "*asia:MyServerPrefix" attribute 
by selecting Block Icon -> Object Properties -> Styles -> ReturnPath. 
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7.7 Adaptations for the Maintenance Station 

7.7.1 Overview of the Maintenance Station update 
The Maintenance Station server (MS server) is an OS server. The MS server also fetches 
messages from devices which only provide the messages locally (SNMP devices, PC 
stations) and saves their identification data.  
In addition to the steps described for the OS server, further steps must be carried out for the 
update of an MS server. The corresponding additional steps are listed below. 

Overview of the procedure     
 
Step Action ES OS 

server 
OS 
client 

AS 

47 Updating the Maintenance Station (Page 120)  X X   
48 Changing the version for the OPC Server object in 

HW Config (Page 122)  
X    

49 Updating the diagnostics settings (Page 123)  X    
50 Carrying out a complete export of ID data 

(Page 125)  
X    

51 Prepare for ASSET-specific export (Page 126)  X  X  

Notes on maintenance functions in process mode 
PCS 7 V7.1 or higher supports the operation of any PC (e.g. OS client) as an MS client.  
SIMATIC PDM runs on the engineering station after the software has been updated. 
SIMATIC PDM must always be stopped in order to carry out any exclusive tasks on the 
multiproject, such as backing up data or copying subprojects between engineering stations. 
Detailed information on devices and signals configured with SIMATIC PDM is only available 
at the engineering station. 

 

 Note 
Detailed information on devices and signals configured with SIMATIC PDM 
The following scenarios are possible with SIMATIC PDM V7.0 and higher: 
• SIMATIC PDM can be switched to the server/client architecture. The PDM Server can run 

on the engineering station. 
• The PDM client can access the PDM Server on SIMATIC PDM via a WEB connection in 

a separate Internet Explorer dialog box. This enables a PDM client to access detailed 
information on devices and signals configured with SIMATIC PDM. 

• The PDM "ChangeLog" and "Parameters" views, including the "filtered complete export", 
are not available on the PCS 7 Web client. 
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Additional information 
For information pertaining to the options of accessing maintenance functions, refer to the 
following documentation: 
● Configuring manual Process Control System PCS 7; Operator Station 
● Function manual Process Control System PCS 7; OS Web Option 
● Process Control System PCS 7;.OS Process Control operating instructions 
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7.7.2 How to Update the Maintenance Station 
The basis of a maintenance station is always an OS that provides additional maintenance 
functions. To use the maintenance station for asset management, you can create project-
specific user diagnostic screens for the maintenance station in a user diagnostics structure.       

Requirements 
● The blocks, charts and OS pictures of the project are updated. 
● The SIMATIC programs and OS are compiled. 
● Only blocks from the PCS 7 library starting with V7.0 may be used in the PCS 7 project in 

order to take advantage of the full range of diagnostic and maintenance functions and to 
display the diagnostic information. 

● The monitored PC stations are preconfigured PC systems from PCS 7 (product bundle) 
or hardware and installation have been correspondingly performed. 

● DiagMon software V3.0 or higher is installed. 
You can find more information about this in the manual Process Control System PCS 7; 
PC Configuration and Authorizations. 

● A PC station is configured for the OPC server. 
● The PC stations of the Maintenance Station (MS server and MS client) are updated in the 

same way as an OS. 

Procedure 
1. In HW Config, select the PC station's OPC server, then select the menu command Edit > 

Object Properties... . 
The "Properties – OPC Server" dialog box opens. 

2. Open the "SNMP" tab. 
3. Click "Edit Plant Configuration...". 

The "Edit Plant Configuration" dialog box opens. 
4. In the list, select the PC station whose settings you wish to edit. 
5. Click "Edit". 

The "Edit Nodes" dialog box opens. 
6. Select the entry "Profil_IPC_V13.txt" from the "Device Profile" drop-down list. 
7. Click "OK" in the dialog boxes. 
8. Select the menu command PC Station > OPC Server > SNMP > Export Tags for WinCC. 
9. Select Station > Save and Compile from the menu. 
10. Select the PC station in NetPro. 
11. Select the menu command PLC > Download to Current Project > Selected Stations. 
12. Perform the following if field devices have been configured in the project with SIMATIC 

PDM: 
13. In SIMATIC Manager, select the menu command Options > SIMATIC PDM > Settings. 

The "SIMATIC PDM Settings" dialog box opens. 
14. Select the "Maintenance Station" tab. 
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15. Enter the file path of the STEP 7 project. 
16. Click "OK". 
17. In the plant view of the SIMATIC Manager, select the menu command Options > Plant 

Hierarchy > Create/Update Diagnostic Screens. 
18. Update the diagnostic screens.  

You can find additional information about this in the configuration manual Process Control 
System PCS 7; Operator Station. 

19. Compile the OS of the maintenance station (changes). 
20. Update the server data of the MS server. 
21. Download the MS server. 

Additional information 
● You can find information about configuring the user diagnostics structure and user 

diagnostic screens in the configuration manual Process Control System PCS 7; Operator 
Station. 

● You will find a description of working with the maintenance station in process mode in the 
manual Process Control System PCS 7; Operator Station Process Control. 

● Manual PCS 7; Creating Driver Blocks 
● Manual Process Control System PCS 7; PC Configuration and Authorizations 
● Online help DiagMon 
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7.7.3 Changing the version for the OPC Server object in HW Config 

Requirements 
● OPC Servers are configured in the PC stations within the SIMATIC project. 
● The Maintenance Servers must be configured as OPC Servers. 
● Redundant server pairs have to include an OPC server. 

Procedure 
1. In the component view of SIMATIC Manager, select the project in which you have to 

replace the OS Servers. 
2. Select a PC station in the component view and open HW Config by double-clicking the 

"Configuration" object in the detail view. 
The hardware configuration of the SIMATIC PC station opens. 
If the hardware catalog is not visible, select the View > Catalog menu command. 
The hardware catalog opens. 

3. Select the current version of the OPC server from the hardware catalog at SIMATIC PC-
Station > User application > OPC Server and drag-and-drop it to the position of the OPC 
server. 

4. Click "OK" to confirm the replacement of the OPC server as. 
5. Save and compile your changes. 
6. Close HW Config. 

Additional information 
● STEP 7 and SIMATIC PDM Online Help 
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7.7.4 How to update the diagnostics settings 

Procedure 
1. Select the multiproject in the plant hierarchy. 
2. Select the Extras > Plant Hierarchy > Settings command. 

The "Plant Hierarchy - Settings" dialog box opens. 
3. Activate the "Migrate diagnostics settings" check box. 
4. Click "OK". 

Changing the layout 
With PCS 7 V7.1 or higher, the OS project editor contains a number of layouts with specific 
templates for diagnostics screens. If you wish to change the layout, you will have to replace 
the Overview.pdl template with the layout-specific template. 
You will then have to recreate or update the diagnostics screens. 
 
Changing the screen resolution 
If the screen resolution is changed under the "Available layouts" group on the "Layout" tab in 
the OS project editor, the existing overview screen will be renamed the next time 
"Create/update diagnostic screens" is called up and a new overview screen will be created 
with the new screen resolution. The log for the "Create/update diagnostic screens" function 
contains a note to this effect which also gives the new name for the previous overview 
screen. 
If you have changed the overview screen manually, you will be able to update the changes in 
the current overview screen by copying them from the previous overview screen. 
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7.7.5 Complete export of data 

Complete export 
Use this function in process control to export ID data from all the components with 
diagnostics functionality (for example, field devices, PCs, AS components, network 
components).    
The data from all the components with diagnostics functionality is exported to the export file 
"@XML_Export.sml". 
The storage path for the export file is pre-assigned by the system. 
A copy can be saved automatically in a configured storage path. 

Pre-assigned storage path 
The export file is saved to the MS server's project folder. 
For plant configurations with an MS server and a standby MS server, the export file is saved 
to the project folder on the MS server which is the master at the point at which the export is 
initiated.  

Configured storage path 
The storage path can be configured as an absolute or relative path. 

 
Path Example of a storage path Storage path 
Absolute path D:\Folder To the MS server which is the master at the point at which the 

export is initiated, in the configured path 
Relative path \\Computer name\Enabled 

drive\Folder 
To the computer specified in the configured path 

 
 

 Note 
We recommend that you configure the storage path as a relative path for a plant 
configuration with an MS server and a standby MS server. This will ensure that the export file 
is always stored in the same "place", regardless of which MS server is the master at the time 
the export is initiated. 

 

You can find additional information about this in the section titled "How to configure the 
storage path for the complete export file (Page 125)." 

Additional information 
● Process Control System PCS 7; OS Process Control manual 
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7.7.6 How to configure the storage path for the complete export file 

Introduction 
The storage path for the export file is set via the start value for the "@ExportPath" tag.    

Requirement 
The WinCC project for the MS server must be opened. 

Procedure 
1. Select the "Tag Management" editor from the tree view in WinCC Explorer. 
2. Select the "Internal tags" object. 
3. Open the shortcut menu and select the New Tag... command. 

The "General" tab of the "Tag Properties" dialog box opens. 
4. Go to the "Name:" input field to enter the name "@ExportPath." 
5. Go to the "Data type:" drop-down list box and select the "Text tag 16-bit character set" 

entry. 
6. Select the "Limits / Logging" tab. 
7. Select the "Start value" check box. 
8. Enter the path details for the export file as a start value. 

You can find additional information about this in the section titled "Complete export of 
data". 

9. Click "OK". 

Result 
The storage location is set up. 
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7.7.7 How to prepare for ASSET-specific exports 
These steps are only required for projects with the Maintenance Station that were created in 
a version lower than PCS 7 V7.0 SP1. 
Carry out the following steps in preparation for ASSET-specific exports.  

Requirements 
● A backup copy of the diagnostics screens with project-specific adaptations has been 

generated. 
● An asset ID has been assigned to each AS and PC station in HW Config. See Assigning 

Asset-ID (Page 76). 

Procedure 
1. Select a project in the multiproject. 
2. Select the Options > Plant Hierarchy > Settings menu command. 

The "Plant Hierarchy - Settings" dialog box opens. 
3. Disable the "Derive diagnostic screens from the plant hierarchy" check box. 

 

 
 

Note 
Note that all diagnostics screens will be deleted if you disable this function. You should 
have generated a backup copy of the diagnostics screens with project-specific 
adaptations. 

 

4. Click "OK". 
5. Select the Options > Plant Hierarchy > Settings menu command. 

The "Plant Hierarchy - Settings" dialog box opens. 
6. Enable the "Derive diagnostics screens from the plant hierarchy" check box. 
7. Carry out steps 1 through 6 for all projects to be updated within the multiproject. 
8. Select the multiproject (project). 
9. Select the Options > Plant Hierarchy > Create/Update Diagnostics Screens menu 

command. 
 

 
 

Note 
The final dialog informs you of the AS and OS projects to be compiled and downloaded. 
Do not download the data until you have executed the software update sequence 
described in the "Downloading of Target Systems (Page 145)" section. 

 

10. Copy any diagnostics screens that contain project-specific changes and were in your 
current project to the new projects. In the next step, execute the "Create/update 
diagnostic screens" again to update such screens. 
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Additional information 
For information on generally valid single export functions, refer to the SIMATIC PCS 7; 
Operator Station configuration manual. 
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7.8 Additional Options 

7.8.1 Overview of additional options 

Overview of the procedure 
 
Step Action ES OS 

server 
OS 
client 

AS 

52 Updating the PCS 7 OS Web Option (Page 128)  X X   
53 Updating PCS 7 Components that Use SIMATIC 

Logon Services (Page 129)  
X X X  

  

7.8.2 Updating the PCS 7 OS Web Option 

Requirement    
To use the entire range of PCS 7 Web Option functions, use blocks from the PCS 7 library 
V7.0 or higher in the PCS 7 project only. 

Procedure 
● You update the OS Web server, an OS client, similar to an OS client. 
● The process pictures that will be opened on a Web client must be "published" again. 
● You only need to update the software when performing a software update for a Web 

client. 
● When updating software for a Web diagnostics client, you will have to remove and then 

install the software. 

Additional information 
You can find comprehensive instructions on how to set up PCS 7 OS Web Option in the 
manual Process Control System PCS 7; PCS 7 OS Web Option. 



 Adaptations in the PCS 7 Project on the ES 
 7.8 Additional Options 

Software update with utilization of new functions (PCS 7 V6.x or higher to V7.1) 
Service Manual, 03/2009, A5E02128573-01 129 

7.8.3 Updating PCS 7 Components that Use SIMATIC Logon Services 

Additional information 
● Refer to the respective components that use SIMATIC Logon to find detailed instructions 

about the setup, configuration and changes needed for SIMATIC Logon. 
● You can find basic, generally applicable information about SIMATIC Logon in the online 

help for SIMATIC Logon. 
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7.9 Work for the OS in SIMATIC Manager 

7.9.1 Overview of compiling 

Overview of the procedure   
 
Step Action ES OS 

server 
OS 
client 

AS 

54 Specifying the compilation mode (Page 131)  X    
55 Compiling the OS (Page 132)  X    
56 Adapting the OS client (Page 134)  X    

7.9.2 Information regarding the compilation modes 
The compilation mode determines which data are downloaded to the OS server. The setting 
must be made separately for each project of a multiproject.  

Compilation modes 
The following modes are available: 
 
Mode Meaning 
Area-oriented This setting enables you to assign an OS area of the PH to an OS server. This 

is the default setting for projects created as of PCS 7 version 6.1. All data of 
an OS area are downloaded to the OS server when this compilation mode is 
used. 

AS-oriented This setting enables you to assign an S7 program to an OS server, i.e. you 
define which OS accesses data from which automation system. All data of an 
automation system are downloaded to the OS server when this compilation 
mode is used. This is the default setting for projects created with a PCS 7 
version earlier than V6.1. 

 
 

 Note 
If you use a maintenance station in the project, you need to set "area-oriented" compilation 
mode for the multiproject. 

 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 
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7.9.3 How to Specify the Compilation Mode 

Requirement 
● The operator stations contained in the PCS 7 project have been updated with the Project 

Migrator. 

Procedure 
 

NOTICE  
After changing the compilation mode, you can only perform an online download after 
performing a complete download of the OS. 

 

1. Open SIMATIC Manager and select any view. Component view, plant view or process 
object view. 

2. Select a PCS 7 project from the tree structure. 
3. Select the menu command Options > "Compile Multiple OSs" Wizard > Compilation 

Mode.  
The "Compilation Mode" dialog box opens. 

4. Select the compilation mode (refer to the introduction of this section above). 
5. Click "OK". 
The settings for the compilation mode are applied in the "Compile Multiple OSs" wizard.  

 

 Note 
These settings are applied to all OS servers in a project. 

 

Additional information 
● Configuration manual Process Control System PCS 7; Operator Station 
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7.9.4 How to Compile the OS 
 

 Note 
You must compile the OS if you changed the target paths on the ES. 

 

 
 

 Note 
If a maintenance station is integrated in the project, the diagnostic screens must be 
recreated. 

 

Requirements 
● The PC station has been configured. 
● The configuration in CFC and SFC has been completed. 

 

NOTICE  
 

If you have changed unit and operator texts of the block types in the master data library, 
be sure to set your default language as the "Language for display devices". 

 

Procedure 
 

 Note 
You can find additional information about the compilation options in the configuration manual 
Process Control System PCS 7; Engineering Station. 

 

1. Select the object (multiproject, project, station) in SIMATIC Manager that you wish to 
compile or compile/download. 

2. In SIMATIC Manager, select the menu command CPU > Compile and Download Objects. 
The "Compile and Download Objects" dialog box opens. 

3. Open the tree structure. 
4. Activate the check box in the "Compile" column for all objects that you want to compile. 
5. Click the "Operating State" button and check the operating states of your objects (RUN, 

activated, etc.) so that you can make the correct settings for compilation. 
6. Select the OS that you wish to compile. 
7. Click "Edit". 

The "Settings: Compile OS ... Areas ..." dialog box opens. 
8. Click "Next". 

The "Settings: Compile OS ... Network Connections ..." dialog box opens. 
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9. Click "Next". 
The "Settings: Compile OS ... Compilation Data and Scope of Compilation" dialog box 
opens. 

10. In the "Scope" group, activate the "Entire OS" and "With memory reset" check boxes. 
11. Click "Apply". 

 

 
 

Note 
Once you have completed your settings for compiling an operator station, please wait 
until the compilation settings have been saved and the download dialog box appears.  

 

12. Make the required settings for the individual objects. 
13. Click "Help" in the dialog box for detailed information about the settings. 
14. Click the "Start" button.  

The compilation process will begin. 
15. Follow the instructions on the screen. 
16. If you wish to see a log of the compilation once it is complete, click the following buttons 

in the "Display Log" area: 
– "Single object": the detailed compilation log of the selected OS is displayed. 
– "All": the results of all compilation operations (without details) are displayed. 
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7.9.5 How to make adaptations for the OS clients 
 

 Note 
The following procedures musts be carried out for each OS server if there are several OS 
servers present in the project.  

 

Procedure 
1. In the component view of the SIMATIC Manager, select the OS client project on the PC 

station. 
2. Select the menu command Options > OS > Assign OS Server.... 

The "Assign OS Sever ..." dialog box opens. 
3. In the list of OS servers, check for the server whose data you would like to view on this 

client, to ensure the check boxes for this OS server have been selected. 
4. Click "OK". 
5. In the component view in SIMATIC Manager, select the "OSC" object of the OS client. 
6. Select the menu command Edit > Open Object. 

The WinCC Explorer opens. 
7. Select the menu command Configure in the context menu of the "Server data" editor in 

order specify the preferred server if there are redundant OS servers. 
8. Select the menu command Standard server in the context menu of the "Server data" 

editor in order to specify a standard server for AlarmLogging and SSM. 
9. Select the OS Project Editor and select the menu command Open in the context menu. 
10. Activate the "Complete configuration ..." check box on the "General" tab. 
11. Open the "Layout" tab. 
12. Select the required layout and the monitor configuration. 
13. Open the "Basic Data" tab. Make the required settings in accordance with the "Basic 

Data" table below. 
14. Only carry out this step if the authorization level "For observation only" must be activated 

for some of the users after the software has been updated: 
15. Select the "Message display" tab.  

Activate the required message filters (see the "Message Filters" table below). 
 

 
 

Note 
No settings are necessary for the software update on the remaining tabs. The default 
settings can be applied. 
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16. Click "OK". 
17. If you want to replace controls with picture objects, perform the "How to Replace Controls 

with Picture Objects (Page 112)" step on the OS client. 
18. In WinCC Explorer, open the "Time Synchronization" editor. 

Activate the "Synchronization via terminal bus (slave)" check box.  
Select the "Use the time from a connected WinCC server" option.  
Close the dialog box. 

19. Open the "Lifebeat Monitoring" editor and click the "Update" button in the dialog box. 
Close the dialog box. 

Basic Data 
 
Dialog Area Note Action 
Top left  
window 

This window lists all basic pictures 
having a different product version and 
project version change date. 
Every basic picture with a selected 
check box is overwritten in the project 
version at the start of the OS Project 
Editor with the pictures from the product 
version. 

Activate the check boxes for all of the basic pictures identified 
with a red "X". 

Top right  
window 

This window lists all local computer 
actions having a different product 
version and project version change 
date. 
Every local computer action with a 
selected check box is overwritten in the 
project version at the start of the OS 
Project Editor with the corresponding 
local computer action from the product 
version. 

Activate the check boxes for all of the basic pictures identified 
with a red "X". 

Bottom left  
window 

This window lists all faceplates having a 
different product version and project 
version change date. 

You can replace the faceplates available in the project with 
those of the relevant product version by transferring  
the default settings. 
Note: If you wish to continue using the controls from older 
PCS 7 versions in the project, you should not replace the 
faceplates in the project with the faceplates from the project 
version. 
Requirement: The controls of the PCS 7 version (for example, 
V5.2) must be installed on the engineering station and the 
operator stations used for the process operation (OS clients, 
for example). 
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Message Filters 
 
Parameters Meaning 
Acknowledgeabl
e messages in a 
separate list 

The message windows have two message lists.  
One list shows all messages from the area for which the user has access rights for all "operator process 
controls". The user can acknowledge messages in this list.  
The other list shows all messages from the area for which the user has an "authorization for area" but 
no access rights for "operator process controls". The user cannot acknowledge messages in this list.  
The message line in the overview area only shows messages that can be acknowledged with the 
access right for "operator process controls". 

Acknowledgeabl
e messages on a 
separate page 
(switch-
selectable) 

Both of the message pages indicated above are available to the user. Only messages from areas for 
which the user has access rights for "operator process controls" are displayed on the message page 
with only one list and in the message line of the overview area. 
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7.9.6 Mixed Operation of Faceplates from Different Versions of PCS 7 

Definition of Mixed Operation  
Mixed operation is the visualization of AS blocks from different PCS 7 versions on one OS 
client. 

Compatibility of PCS 7 V7.1 Faceplates 
 

 Note 
You can use the faceplates from PCS 7 Version 7.1 to control and monitor the AS blocks of 
the following PCS 7 versions: 
• PCS 7 V5.x 
• PCS 7 V6.x 
• PCS 7 V7.0 
• PCS 7 V7.0 SPx 
• PCS 7 V7.1 

 

Compatibility with faceplates of the Advanced Process Library (APL) of PCS 7 V7.1 
 

 Note 
The APL faceplates can be used to monitor and control AS blocks of the APL. 

 

Rules 
 

NOTICE  
Mixed operation is only permitted on OS clients. 

 

● AS blocks of different PCS 7 versions (V5.0 and higher) can be visualized on an OS 
client, if the server data of several OS servers are loaded to the OS client with AS blocks 
of different PCS 7 versions (e.g., V5.2 AS blocks and V6.1 AS blocks). 

● Only the AS blocks of one PCS 7 version may be loaded on an AS. 
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Adaptations on the Individual Operator Stations 8
8.1 Overview of Adaptations to Individual Operator Stations 

Overview of the procedure 
 
Step Action ES OS 

server 
OS 
client 

AS 

57 Installing additional libraries on the OS (Page 140)  X   
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8.2 How to install additional libraries on operator stations 

Important information  
 

 Note 
Only perform the following procedure if you want to use faceplates from the following 
sources in your project: 
• Faceplates that do not conform to the PCS 7 standard 
• Faceplates that originate from a PCS7 V 5.x project 

 

 Note 
You must install these libraries on all operator stations. 

 

Requirement 
The library has been archived with the menu command File > Archive in SIMATIC Manager. 

Procedure 
1. Start the SIMATIC Manager.  

A PCS 7 project does not have to be open. 
2. In SIMATIC Manager, select the menu command File > Retrieve.  

The "Retrieving - Select Archive" dialog box opens. 
3. Specify the path to the archived library. Click "Open". 

The "Select Destination Directory" dialog box opens. 
4. Set the destination directory. 
5. Click "OK". 

Additional information 
You can find additional information about modifying libraries in the WinCC Online Help; 
Faceplate Designer 
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Adaptations on the Central Archive Server 9
9.1 Overview of Updating the Servers for Central Archiving 

Overview of the procedure    
 
Step Action ES OS 

server 
OS 
client 

AS 

58 Adapt the central archives (Page 142)  X1, X2   
59 Update the archive data (Page 144)  X1, X2   

X1 - to be performed only on the central archive server 
X2 - to be performed only on the StoragePlus server for central archiving 
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9.2 How to adapt the archives of the central archive server to PCS 7 V7.1 

Requirements     
● All archives are swapped to a file in PCS 7 (to SPB files in PCS 7 V6.x or higher). 
● The data (LDF files and MDF files) from the database path are backed up. 
● The name of the database of the PCS 7 project to be updated is known. 
● The data saved (LDF files and MDF files) can be accessed from the archive server's PC 

station. 
● The server data for the OS server are generated. 

Procedure 
1. Install the software of the archive server (central archive server or StoragePlus server). 

Make sure the following information is entered correctly (see section titled "Overview of 
Adaptations for Central Archiving (Page 29)"): 
– Name of the database 
– Path of the database 
– Path of the data log 
– Shared archive directory 

2. Check the configuration of the archive server: 
Central archive server 
– In SIMATIC Manager, check the configured properties of the central archive serve and 

download the "central archive server" target system. 
You can find additional information in the Process Control System PCS 7; Operator 
Station manual. 

StoragePlus Server 
– Select Start > SIMATIC > StoragePlus > Administration Console from the menu. 
– Check the parameter assignment for the StoragePlus server in the System 

Configuration > Common folder. 
3. Select the Start > SIMATIC > StoragePlus > Administration Console menu command. 
4. The data (LDF files and MDF files) are saved to the database path. 
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Differences between Archiving with the Central Archive Server and StoragePlus 
 

NOTICE  
In contrast to StoragePlus, a central archive server only processes the archives when 
process mode (runtime mode) is activated on the central archive server. 

 

Configuration of a redundant central archive server 
You can configure the central archive server redundantly as of PCS 7 V7.0.  
You configure the redundant central archive server as a redundant OS server. 
You can find more information about this in the manual Process Control System PCS 7; 
Fault-tolerant Process Control Systems. 
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9.3 How to Update PCS 7 Archive Data 

Introduction     
The following steps are to be performed only on the server for central archiving (central 
archive server or StoragePlus server). 

Procedure 
1. Select the Start > SIMATIC > WinCC > WinCC Explorer menu command. 

The "WinCC Explorer" dialog box opens. 
2. Open the OS project of the archive server. 
3. Select the menu command Start > SIMATIC > StoragePlus > Administration Console. 

The "StoragePlus Administration Console" dialog box opens. 
4. In the tree structure, select the folder System Configuration > Advanced. 
5. If you want to adapt the archive database of StoragePlus V1.0 (PCS 7 V6.0 SP3), 

perform the following steps: 
– In the "Migration V1.0 > V1.1" area, click "Start". 

The "Database Migration Procedure" dialog box is displayed. 
– Click "Yes". 

The "Migration Status" dialog box is displayed. The update is complete, the "OK" 
button will be available for selection. 

– Click "OK". 
The archive database is adapted to StoragePlus V1.1 (PCS 7 V6.1). 

6. If you want to adapt the archive database of StoragePlus V1.1 (PCS 7 V6.1), or of 
StoragePlus V1.2 (PCS 7 V7.0), perform the following steps: 
– Click "Start" in the "Migration V1.1 > V1.3" area. 

The "Database Migration Procedure" dialog box is displayed. 
– Click "Yes". 

The "Migration Status" dialog box is displayed. The update is complete, the "OK" 
button will be available for selection. 

– Click "OK". 
The archive database is adapted to StoragePlus V1.3 (PCS 7 V7.1). 

7. In the tree structure, select the folder System Configuration > Archive. 
8. In the detail view, click "Attach". 

The catalog of all archive segments in the archive path is displayed. 
9. Enter the folder that contains the swapped-out archive segment (CD, DVD, or network 

drive, for example). 
10. Select the archive segment from which you require data in the archive. 
11. Click "Open". 

The selected archive segment is copied. Once the archive segment has been 
successfully copied, the archive segment is linked to the archive. 
A message window indicates whether the archive segment has been linked. 

12. Click "OK". 
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Downloading of Target Systems 10
10.1 Downloading of Target Systems 

Once you have updated your PCS 7 project offline, you must download the changes to the 
target systems (PLC, OS).  

 

NOTICE  
If using new or updated blocks from the PCS 7 libraries, set the AS to STOP before you 
download any data for the target systems. 

 

Requirement 
● The network addresses and network settings of the PC stations are configured. 
● The configuration of the PC stations match in HW Config and in the Station Configuration 

Editor. 
● The configuration of the PC stations is loaded on the PC stations. 

Procedure 
1. Download connection and configuration data to the all stations via NetPro. Begin with the 

ES. 
2. Check the setting for the access points on each PC station (local) using the menu 

command Start > SIMATIC > SIMATIC NET > Set PC Station. 
3. You can successively download all target systems systematically and automatically. In 

SIMATIC Manager, select the menu command PLC > Compile and Download Objects. 

Additional information 
You can find additional information about the download options in the configuration manual 
Process Control System PCS 7; Engineering Station. 
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Activate the operator stations 11
11.1 Overview of activating the operator stations 

Sequence during Activation of the Operator Stations  
The following sequence applies when activating process mode (runtime): 
● Master server (OS server) 
● Standby server (redundant OS server) 
● OS clients 

Overview of the Procedure 
 
Step Action ES OS 

server 
OS 
client 

AS 

60 Check the settings of the OS servers (Page 148)  X   
61 Check the settings of the OS clients (Page 149)   X  
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11.2 How to Check the Settings on the OS Servers 
Before activating the projects downloaded to the various OS servers, you need to check 
some of the settings in each OS as a safety precaution. 

Requirement 
● The PCS 7 OS is open in WinCC Explorer. 

Procedure 
1. Open the "Redundancy" editor in WinCC Explorer. 
2. Check all settings. 
3. Click "OK". 
4. Open the "Time Synchronization" editor in WinCC Explorer. 
5. Check all of the settings in the dialog box. 
6. Click "OK". 
7. Repeat steps 1 through 6 for the second OS server and all other redundant OS servers. 
8. Activate process mode on the OS servers. 
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11.3 How to Check the Settings on the OS Clients 
Before activating the projects downloaded to the various OS clients you must check some of 
the settings in each OS. 

Requirement 
● The PCS 7 OS is open in WinCC Explorer. 

Procedure 
1. Open the "Time Synchronization" editor in WinCC Explorer. 
2. Check all settings. 
3. Click "OK". 
4. Repeat steps 1 through 3 for the other OS clients. 
5. Activate process mode on the OS clients. 
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Updating SIMATIC BATCH 12
12.1 Updating SIMATIC BATCH 

Update for SIMATIC BATCH  
You can find information on this in following documents: 
● SIMATIC BATCH Readme; Part C1, Installation 
● Manual Process Control System PCS 7; SIMATIC BATCH 
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Updating SIMATIC Route Control Stations 13
13.1 Updating SIMATIC Route Control 

Updating SIMATIC Route Control 
You can find information about this in the Process Control System PCS 7; SIMATIC Route 
Control documentation. 
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