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Legal information
Warning notice system

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
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DANGER
indicates that death or severe personal injury will result if proper precautions are not taken.

WARNING
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CAUTION
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NOTICE
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used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to property 
damage.

Qualified Personnel
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified 
personnel are those who, based on their training and experience, are capable of identifying risks and avoiding 
potential hazards when working with these products/systems.

Proper use of Siemens products
Note the following:

WARNING
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended or 
approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed.

Trademarks
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner.

Disclaimer of Liability
We have reviewed the contents of this publication to ensure consistency with the hardware and software described. 
Since variance cannot be precluded entirely, we cannot guarantee full consistency.  However, the information in 
this publication is reviewed regularly and any necessary corrections are included in subsequent editions.
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Security information 1
Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, solutions, machines, equipment and/or networks. They are 
important components in a holistic industrial security concept. With this in mind, Siemens’ 
products and solutions undergo continuous development. Siemens recommends strongly that 
you regularly check for product updates.

For the secure operation of Siemens products and solutions, it is necessary to take suitable 
preventive action (e.g. cell protection concept) and integrate each component into a holistic, 
state-of-the-art industrial security concept. Third-party products that may be in use should also 
be considered. For more information about industrial security, visit http://www.siemens.com/
industrialsecurity.

To stay informed about product updates as they occur, sign up for a product-specific 
newsletter. For more information, visit http://support.automation.siemens.com.
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Preface 2
Purpose of this documentation

This documentation provides a comprehensive overview of the steps you must take to adapt 
your existing PCS 7 process control system to the new SIMATIC PCS 7 version. It supports 
you in updating PCS 7 projects and guides you through installation and commissioning of the 
current software.

The contents of the documentation are directed toward service personnel, commissioning 
personnel, and experienced PCS 7 users with the necessary system knowledge. The 
documentation provides instructions for carrying out the software update.

Refer to the documentation for specific products for information regarding the handling of these 
products.

Scope of the documentation
This documentation is valid for the software package Process Control System; SIMATIC PCS 7 
V8.1 SP1.

Options for accessing PCS 7 documentation
You can find the PCS 7 documentation at the following locations:

● On the Process Control System; SIMATIC PCS 7 DVD 

● After installation, on the computer 

● On the Internet

Full versions of the documentation are available from the "Technical Documentation SIMATIC 
PCS 7" website: http://www.siemens.com/pcs7-documentation (http:\\www.siemens.com/
pcs7-documentation)

Note
PCS 7 Readme (Internet version)

The information provided in the PCS 7 Readme on the Internet takes precedence over all PCS 
7 documentation. 

Read this PCS 7 Readme carefully; it contains important and supplementary information for 
PCS 7.

Software update without utilization of new functions
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PCS 7 documentation on the Process Control System; SIMATIC PCS 7 DVD
● PCS 7 Readme (DVD version)

The PCS 7 Readme on the Process Control System; SIMATIC PCS 7 DVD contains 
important information about PCS 7 and takes precedence over the PCS 7 documentation 
supplied with the product. After installation of PCS 7, you can find the Process Control 
System PCS 7; PCS 7 Readme document in the Windows Start menu using the following 
path: 
Siemens Automation > SIMATIC > Product Notes > <language>

● You can find the most important PCS 7 system documentation at the following locations:

– On the SIMATIC PCS 7 DVD in the "_Manuals" folder

– On the engineering station as online help (CHM file) for the SIMATIC Manager 
application

– On the engineering station as a PDF file in the Windows Start menu using the following 
path:
Siemens Automation > SIMATIC > Documentation > <language>

Note

The following PCS 7 system documentation is included:
● Catalog Overview Process Control System PCS 7; PCS 7 Documentation
● Configuration manual Process Control System PCS 7; Engineering System
● Function manual Process Control System PCS 7; PCS 7 PC Configuration
● Configuration manual Process Control System PCS 7; Operator Station
● Function manual Process Control System PCS 7; OS Process Control

● The product documentation is installed with the relevant product.

Preface
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Documentation for PCS 7 on the Internet (current versions)
The latest documentation on the PCS 7 versions is available from the "Technical 
Documentation SIMATIC PCS 7" website:

● In the section "Software manuals for SIMATIC PCS 7 ..."

– The link to the latest system and product documentation of the particular PCS 7 version.

– The link to download the Setup for the latest system documentation 
"PCS 7 Documentation Portal Setup". 

Note
PCS 7 Documentation Portal Setup

Setup includes the complete system documentation for PCS 7 (PDF files and online 
help). 
● You can install this Setup without PCS 7. 
● The following documentation is updated when you install the Setup on the 

engineering station (completed and overwritten - if you select the original installation 
folder):
– Online help of the "SIMATIC Manager" application: (CHM files)
– System documentation for PCS 7 in the Windows Start menu: 

Siemens Automation > SIMATIC > Documentation > Language > PDF files
● The PCS 7 Newsletter keeps you informed when new versions of the system 

documentation become available.

– The link to download the entire PCS 7 documentation as a Manual Collection in the My 
Documentation Manager (http://support.industry.siemens.com/my/ww/en/
documentation/advanced/).
The Manual Collection includes the manuals for hardware and software.

● In the section "Hardware Manuals for SIMATIC PCS 7 ..."

– The link to the latest manuals for components approved for a PCS 7 version.

– The link to the latest manuals for approved SIMATIC PCS 7 industry software for PCS 
7.

Catalogs, brochures, customer magazines and demo software

This information is available on the Internet at: Information and Download Center (http://
www.automation.siemens.com/mcms/infocenter)

Preface
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Documentation for the software update
You can find all documentation on the topic of "Software update" on the Internet. 

Documentation Contents
Manual Software update without utiliza‐
tion of new functions

Describes the procedure for the software update of PCS 7 
projects without utilization of new functions.
● Original version of the existing project: 

PCS 7 as of V7.1 SP4
● Project to be updated to the following version without 

utilization of new functions: 
PCS 7 V8.1 SP1

Manual Software update with utilization 
of new functions

Describes the procedure for the software update of PCS 7 
projects with utilization of new functions.
● Original version of the existing project: 

PCS 7 as of V7.1 SP4
● Project to be updated to the following version with 

utilization of new functions: 
PCS 7 V8.1 SP1

Additional documentation for the software update
Additional information from the following documentation is required for carrying out the 
software update:

Documentation Contents
Manual Process Control System PCS 7; 
Service Support and Diagnostics

Ensuring the Availability of a PCS 7 System; contains infor‐
mation on creating backups and how to perform firmware 
updates.

Manual Process Control System PCS 7
PCS 7 PC Configuration

PCS 7 PC - Hardware and Installation;
Windows settings and tools; 
Software packages and required license keys.

Configuration manual Process Control 
System PCS 7; Engineering System

Guide to configuration steps in SIMATIC Manager, CFC, 
SFC, NetPro

Configuration manual Process Control 
System PCS 7; Operator Station

Guide to configuration steps in WinCC

Function manual Process Control Sys‐
tem PCS 7; Fault-tolerant Process Con‐
trol Systems

Guide to configuration steps for fault-tolerant process control 
systems

Documentation 
Process Control System PCS 7;
Released Modules

All modules released for SIMATIC PCS 7 are listed together 
with the following information:
● Product designation
● Article number
● Firmware version
● Brief description

Online help
WinCC Information System

Describes the updating of WinCC projects.

Process Control System PCS 7; Web 
Option for OS manual

Describes the installation and use of the Web Option for OS 
in PCS 7

Preface
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Documentation Contents
Manual Process Control System PCS 7; 
OpenPCS 7

Describes how an OPC A&E server with hierarchical access 
is used in PCS 7 systems

Function manual Process Control Sys‐
tem PCS 7; Fault-tolerant Process Con‐
trol Systems

Describes the principles of use of fault-tolerant (redundant) 
components in SIMATIC PCS 7.

SIMATIC manual S7 F/FH Automation 
Systems
SIMATIC S7 F Systems

Describes the configuration and programming of S7 F/FH 
failsafe systems using S7 F systems.
Contains important information which must be taken into ac‐
count when installing and using the S7 F system optional 
package in PCS 7.

What's new? Information on the differences between this version and the 
previous version of PCS 7

Required basic knowledge
General knowledge in the area of automation engineering and basic knowledge of PCS 7 is 
required to understand this documentation. You also need to know how to use PCs with 
Windows operating systems.
The following documentation provides basic information on working with PCS 7:

● Configuration manual Process Control System PCS 7; Engineering System
● Configuration manual Process Control System PCS 7; Operator Station
● Getting Started Process Control System PCS 7; Part 1

Software update up to PCS 7 V7.1 SP4
All projects up to PCS 7 V7.1 SP4 are updated in several steps. You will receive the necessary 
instructions with the associated software packages.

Conventions
In this documentation, the names of elements in the software interface are specified in the 
language of this documentation. If you have installed a multi-language package for the 
operating system, some of the designations will be displayed in the base language of the 
operating system after a language switch and will, therefore, differ from the designations used 
in the documentation.

Changes compared with previous versions
Below, you will find an overview of the most important changes compared with previous 
versions:

Preface
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As of PCS 7 V8.1

● The operating systems must be changed (Windows 7 or Windows Server 2008 R2) 

Note
Central archive server

The central archive server (CAS) is not supported. Replace the CAS with the following PC 
stations:
● Process Historian as external archive server
● Information Server as reporting system

Information on configurations can be found in the documentation Process Control System 
PCS 7; PCS 7 PC Configuration.

Information on Migration can be found in the documentation SIMATIC; Process Historian 
2014; Process Historian Administration.

● PC stations that are involved in process mode can be connected using encrypted 
communication.

● When the Advanced Process Library is used, the operator station can display the block 
icons for AS blocks from different library versions in the process pictures.

As of PCS 7 V8.0 including SP1

● User-configurable message classes

● Redundant, fault-tolerant terminal bus based on the Parallel Redundancy Protocol (PRP)

● Process Historian

– Redundant Process Historian

– Migration of the central archive server (CAS) to Process Historian
You can find additional information on this in the "WinCC Classic Information System".

● Updating computers using the SIMATIC Management Console
You can find information on this in the online help SIMATIC Process Control System PCS 7; 
SIMATIC Management Console.

As of PCS 7 V8.0: 

● Use of the Advanced Process Library (APL) V8.0 as standard library for configuration.

PCS 7 V7.1 or higher: 

● PCS 7 setup automatically installs the necessary hotfixes and SQL server.

● Use of OS clients as maintenance clients (default configuration for an OS client in terms of 
the maintenance server)

● Information on Microsoft Windows settings and security settings can be found in the 
whitepaper SIMATIC Process Control System PCS 7; Security Information Note
It can be downloaded via the Internet from the Customer Support (https://
www.siemens.com/automation/service) website under the following entry number:
26462131 (http://support.automation.siemens.com/WW/view/en/26462131)

Preface
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● Information on virus scanners can be found in the whitepaper SIMATIC Process Control 
System PCS 7; Security Information Note; Setting Virus Scanners
It can be downloaded from the Customer Support (https://www.siemens.com/automation/
service) websites under the following entry number:
26366540 (http://support.automation.siemens.com/WW/view/en/26366540).

● The architecture for SIMATIC PDM has been modified.
You can find additional information on this in the section "How to configure the SIMATIC 
PDM Server (Page 55)".

Preface
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Introduction 3
3.1 Defining a strategy for the software update

Decision process
The selection and use of the correct documentation depends on the comprehensiveness of 
your software update. the current status of the software and any boundary conditions that may 
exist.  

The figure below shows you the documentation you should use to update a PCS 7 plant.

PCS 7 Fault-tolerant Process 

Control Systems

Software update without utilization of new functions
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Note
Operating systems

Observe the requirements for the operating systems. You can find additional information in 
the Process Control System PCS 7; PCS 7 Readme documentation (Internet version).

Note
Intermediate steps required for the software update

If you cannot directly upgrade to the current PCS 7 version of a PCS 7 project, the intermediate 
steps shown in the figure are required. The steps described in the accompanying 
documentation must be completed. 

Exception: when permanent operability of the system is not required: You can skip the 
download to the operator control and monitoring systems in the intermediate steps.

See also
General Requirements (Page 19)

Introduction
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3.2 General Requirements

General requirements for updating the software
● Your PC hardware must meet the hardware requirements of the current PCS 7 version.

For additional information, refer to the Process Control System PCS 7; PCS 7 - Readme 
documentation (Internet version). 

● The PC where the PCS 7 software is installed must meet one of the following requirements:

– It can access the PCS 7 software via a network (sharing of a network folder or DVD 
drive).

– It has its "own" DVD drive (example: USB DVD drive).

Note

You must complete the software update before beginning with any additional changes 
to the configuration.

● The project must be updated to at least PCS 7 V7.1 SP3. You can only use AS blocks of 
the following versions in the updated project:

– PCS 7 V7.1 SP3; PCS 7 V7.1 SP4

– PCS 7 V8.0 SPx

– PCS 7 V8.1 SPx

Note

If AS blocks from other PCS 7 versions are used in the project, it will be necessary to 
update these blocks via a software update using new functions.

You can find the setups for the libraries of PCS 7 V7.1 SP3/PCS 7 V7.1 SP4 on DVD2 
Process Control System; SIMATIC PCS 7 in the "Additional_Products" folder.

Asian text in PCS 7
In the following cases, you need a USB hardlock for your PCS 7 version:

● You want to install PCS 7 on an Asian operating system

● You want to install an Asian version of PCS 7 

● You want to display Asian text in the user interface 

Introduction
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The USB hardlock stores the license information you need to operate and configure your 
version of PCS 7. Please contact your Siemens representative for information on the available 
Asian language versions.

Note
A message indicates missing ASIA hardlock in a non-Asian project

Check the language of the operating system and PCS 7.
When language columns are configured for Asian text in a PCS 7 project and you do not need 
this Asian text, you can delete these language columns from the text library of all OS projects. 
It is then possible to operate with a license key for the PCS 7 version and without a USB 
hardlock.

Check compatibility
Siemens offers a compatibility tool for automation and drive technology. You can find 
information on this in the PCS 7 Readme (Internet version, see preface). 

Introduction
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3.3 Important Information for Software Update without Utilization of New 
Functions

Requirements for Performing a Software Update   
● PCS 7 can only run on operating systems that have been approved for PCS 7. You can 

find information on approved operating systems in the Process Control System PCS 7; 
PCS 7 Readme documentation (Internet version). This file contains additional information 
pertaining to the operating systems and necessary service packs.
The Server operating system is required for the following PC stations:

– Server (redundant and non-redundant) for OS, SIMATIC BATCH, SIMATIC Route 
Control or

– Server for Web Option for OS

– Server for engineering station with multiproject (central data store) for engineering with 
multiple engineering stations

● If you change the operating system, you will have to update the version of the 
communication components in the Station Configuration Editor and HW Config. The version 
depends on the version of SIMATIC NET installed on the target station.

– As of Windows 7 or Windows Server 2008 R2, SIMATIC NET 12.x is installed. 
Depending on the network adapter used, select the following version of the 
communication component in HW Config:
- When using 'IE General' standard network adapters: V8.2
- When using communication processors (e.g. CP 16xx): V8.1.1

– Ensure that the hardware of the PC stations is suitable for use with the updated PCS 7 
version (e.g. operating systems, network adapter).

Note
Central archive server

The central archive server (CAS) is not supported. Replace the CAS with the following PC 
stations:
● Process Historian as external archive server
● Information Server as reporting system

Information on configurations can be found in the documentation Process Control System 
PCS 7; PCS 7 PC Configuration.

Information on migration can be found in the documentation SIMATIC; Process Historian; 
Process Historian Administration.

● The software update of password-protected projects requires SIMATIC Logon on an ES.

● For projects with activated FDA access protection for WinCC tag export, you have to open 
the WinCC project in SIMATIC Manager beforehand.

● Ensure that your hardware meets the requirements for PCS 7. You can find more 
information in the documentation Process Control System PCS 7 Catalog Overview; 
Released Modules. If system components are not suitable for the updated version of PCS 
7, you must replace them. In some cases, you must adapt or redo the configuration of the 
components that have been replaced in the updated project.
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● You need additional upgrade license keys for updating PCS 7 prior to V8.0: 

– V7.1 -> V8.0 

– V8.0 -> V8.1 

● The automation system can remain in the RUN state during a software update without 
utilization of the new functions. The process can be continued. Program changes can be 
downloaded during operation. Functions that require a new library version (for example, 
SIMATIC Route Control) require a STOP of the automation system.

● The manual contains some sections that are not listed in the overview. Observe the 
information provided in these sections when updating the software and check whether this 
information is relevant to your PCS 7 system.

● You do not need any new hardware or firmware for your automation system.

● You want to perform the software update without a great deal of configuration effort.

● The process can always be operator-controlled and monitored, if you use redundant OS 
servers and update the software accordingly. 
You can find more information about this in the manual Process Control System PCS 7; 
Fault-tolerant Process Control Systems > Guidelines for updating a redundant OS in 
runtime.

Note

A complete software update is required in order to update PCS 7 projects with a version prior 
to V7.1 to V8.1.

Read the decision-making aid in section: Defining a strategy for the software update 
(Page 17)

Projects with add-on applications/products

Note

In some cases, add-on applications/products require intermediate steps. Read the relevant 
documentation before starting the software update.

Downloading Changes

Note

Sequencers from SFC charts are not canceled during a software update, provided no changes 
have been made within the sequencer.
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Libraries
As of PCS 7 V8.0, the libraries of PCS 7 are updated with each PCS 7 version. The following 
libraries are installed by default:

● PCS 7 Basis Library
Contains the blocks of the PCS 7 Basis Library of PCS 7. 
The PCS 7 Basis Library is a prerequisite for the use of the PCS 7 Library and the Advanced 
Process Library.

● Advanced Process Library
Contains the blocks of the PCS 7 Advanced Process Library.

Note
Library required

Installation of additional PCS 7 libraries is required for the software update without utilization 
of new functions.

Libraries that were supplied prior to PCS 7 V8.1 cannot be installed.

You can find additional information on this in the section "Installation of Additional PCS 7 
Libraries (Page 47)".

Result of the Software Update
Following the software update described here, the updated PCS 7 project will behave as it did 
before the update. New functions can be implemented by performing additional steps.

You can find information on this in the current manual Process Control System PCS 7; Software 
update with utilization of new functions.

3.4 Modifying the internal authentication mechanism of the OS

General information
Starting with PCS 7 V7.1 SP3, the PCS 7 OS works with a modified internal authentication 
mechanism. Certain security settings will be modified accordingly on the SQL Server and in 
the project databases. These changes are carried out automatically during installation and 
when you initially open an OS project.

Install a copy of PCS 7 as of V7.1 SP3 on all OS stations of your plant so that all components 
of your OS system operate with the modified authentication function.

Launch the "SIMATIC Rights" tool with administrator privileges immediately on completion of 
this installation. The tool is available in the "Additional_Products\SimaticRights\" folder on your 
SIMATIC PCS 7 DVD 2/2. Run the tool with double-click on "SimaticRights.exe". Select the 
path that contains your STEP 7, PCS 7, or WinCC project folders from the "Storage location". 
Confirm with "OK". Run the tool for all paths that contain STEP 7, PCS 7, or WinCC projects.

All users must have been assigned to the "SIMATIC HMI" user group. This rule also applies 
users who want to open the OS projects remotely. Access by members of the "SIMATIC HMI" 
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user group to the OS database has been restricted to the necessary minimum authorizations 
(read/write). Unrestricted access to the OS database is granted as usual only to users who 
have Windows administrator privileges. 

Add users who only need read access to the OS database to the "SIMATIC HMI VIEWER" 
group.

Members of the Windows user group "SIMATIC HMI" should not also be members of the 
Windows user group "SQLServer2005MSSQLUser$<Computername>$WINCC".

Members of this user group have administrator privileges on the SQL Server. Remove all 
Windows users who only need restricted access to the OS database from this group.

The user "SA" (System Administrator) of the SQL Server is deactivated during installation.

The "WinCCAdmin" and "WinCCConnect" user names have been removed from the OS 
database in order to improve access security. These user names can no longer be used to 
access the OS database. Application using their own SQL user name and password are not 
affected by this change.

Modified authorizations for access to system information
Following the installation of PCS 7 as of V7.1 SP3, users with standard Windows user rights 
are denied access to specific system information. This concerns in particular the following 
system information of the WinCC channel "System Info": 

- CPU load

- Status of the swap file

Assign all users who need this system information to the Windows group "System monitor 
users".

Restrictions for access to ODK functions
The following ODK functions are no longer available to users with standard Windows 
authorization: 

- CreateDatabase 

- DatabaseAttach

- DatabaseDetach

3.5 Information on the Operating System

Recommendation
In Windows domains, too, you must always use the operating systems approved for PCS 7 if 
you want to connect your system to other PCs via Intranet or Internet, or if using the PCS 7 
Web Option for OS. You can find information on approved operating systems in the Process 
Control System PCS 7; PCS 7 Readme documentation (Internet version).

Introduction
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Naming conventions for a PC station name and its computer names
Select short and descriptive computer names that provide some information about the function 
of the PC station in the overall system. 

● The computer name starts with a letter.

● The computer name must only contain letters and numbers.

● The computer name can contain up to 15 characters (limited by the operating system).

Note

When using the operating systems approved for PCS 7, verify that the naming conventions 
for computer names have been adapted in accordance with RFC1123. However, a dash 
"-" character in the computer name is invalid in PCS 7!

● The following names must be identical when you configure an OS or BATCH Server and 
an engineering station:

– Computer name

– Name of the PC station (in the PCS 7 project)

Note

Additional naming conventions for projects are specified in:
● WinCC Information system "Working with projects > Appendix > Invalid characters"
● C:\Program Files\SIEMENS\WINCC\Documents\English\Projects.pdf

3.6 Information on Products from the PCS 7-Add On Catalog

Important Information
If you used PCS 7 add-on products (software packages or hardware components) in your 
process control system, contact your SIMATIC PCS 7 representative

3.7 Licensing with the Automation License Manager

Managing the License Keys
Both license keys and authorizations can be transferred using the Automation License 
Manager. In the following, the term "license key" is always used even when a product uses 
the old license scheme based on authorizations.

Different types of licenses are used in the Automation License Manager.

Each license consists of a basic license type and a license type.

Introduction
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Licensing levels     
You can find an overview about licenses and configuration limits in the following documents:

● Catalog ST PCS 7 in the Internet via Technical Support (https://www.siemens.com/
automation/service)

● Documentation Process Control System PCS 7; Licenses and Configuration Limits (see 
Preface: Options for accessing PCS 7 documentation)

Additional information
Online help for Automation License Manager

Introduction
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Overview of the update tasks 4
4.1 Information about software update procedure

The following tables provide an overview of all of the necessary steps for updating software 
without utilization of new functions. 

Rules to Follow Based on the Tables
● Use these tables as guidelines for systematically carrying out all of the updating steps in a 

sequence.

Note

The exact sequence of configuration steps specified in this documentation must be followed 
in order to carry out the software update.

● You will receive information for every step as to where you must carry out the configuration 
work.

● You can perform the full functional expansion of the PCS 7 project at a later point in time.

Exchanging Data Via OPC A&E
If you exchange data using OPC A&E in the PCS 7 plant, please read the information in the 
Process Control System PCS 7; OpenPCS 7 documentation when updating software.

4.2 Overview of the Procedure
The following is a general overview of the procedure for updating software. This document 
contains comprehensive instructions on every step in the table below.   

Note

You must complete the software update before beginning with any additional changes to the 
configuration.

Recommendation:

Finish updating the engineering system and the project before you begin to update the other 
PC stations.

Legend for overview
X - perform this step at the relevant stations

X1 - to be performed only for the central archive server
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X2 - to be performed only for the Process Historians

Overview of the procedure

Step Action ES OS server OS client AS
Adaptations for central archiving
1 Migration of CAS databases to the Process Historian (Page 31) Only for projects with central archive 

server (CAS)
Backing up the PCS 7 project to be updated
2 Back up project data (Page 35) X    
3 Back up the libraries you created (Page 37) X    
4 Export operator and display texts (Page 39) X    
5 Checking the network adapter (Page 40) X X X  
6 Backing Up the License Keys and Authorizations (Page 41) X X X  
Installation and settings on the ES and OS
7 Updating PCS 7 (Page 66) X X X  
8 Installing additional libraries (Page 48) X X X  
General adaptations in the project
9 Updating the OS with the Project Migrator (Page 52) X    
10 Check PH consistency (Page 53) X    
11 Updating the hardware configuration (Page 54) 

(only applies in the current context to SIMATIC PCS 7 BOX RTX and 
SIMATIC PCS 7 AS RTX)

X    

12 Configure the PDM Server address (Page 55)
(only for projects with SIMATIC PDM V7.0)

X    

Adaptations in NetPro and conversion of the CFC/SFC charts
13 Checking and adapting the connection data in NetPro (Page 57) X    
14 Converting the CFC and SFC charts (Page 58) X    
Adaptation of OS-relevant settings
15 Synchronize OS basic pictures, local computer actions, and face‐

plates (Page 60) 
X    

16 Update picture objects (Page 63) X    
Adaptations for the Process Historian
17 Updating Process Historian and Information Server X X   
18 Replacing a central archive server with a Process Historian (Page 66) X X X  
Adaptations for the Maintenance Station
19 Changing the OPC Server and adapting the SNMP configuration 

(Page 68)
X    

20 Updating the diagnostics settings (Page 70) X    
21 Updating the diagnostics screens (Page 71) X    
Additional options
22 Updating the PCS 7 Web Option for OS  (Page 73) X X   
23 Updating PCS 7 Components that Use SIMATIC Logon Services 

(Page 73) 
X X X  

Work for the OS in SIMATIC Manager

Overview of the update tasks
4.2 Overview of the Procedure
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Step Action ES OS server OS client AS
24 Compiling the OS (Page 74) X    
25 Adapting the OS client (Page 75) X    
Downloading to target systems
26 Downloading of Target Systems (Page 77) 

For more information on the download options, refer to the Process 
Control System PCS 7; Engineering Station Configuration Manual.

X X X X

Activating operator stations
Sequence for activating process mode (Runtime):
● Process Historian (if available in the project)
● Master server (OS server)
● Standby server (redundant OS server) 
● OS clients
27 Checking the settings of the OS servers (Page 79)  X   
28 Checking the settings on the OS clients (Page 80)   X  
SIMATIC BATCH software update
29 Updating SIMATIC BATCH stations (Page 81) Only for projects with SIMATIC BATCH
SIMATIC Route Control software update
30 Updating SIMATIC Route Control (Page 83) Only for projects with SIMATIC Route 

Control
Migration of archive data from a central archive server (CAS)
31 Migrate the archives in the Process Historian (Page 85) Only for projects in which the central ar‐

chive server (CAS) has been replaced 
with a Process Historian.

See also
How to migrate the archives in the Process Historian (Page 85)

How to Detach Attached Archive Segments on the Central Archive Server (Page 31)

Overview of the update tasks
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Preparing for the software update 5
5.1 Migration of CAS databases to the Process Historian

5.1.1 Overview of Adaptations for Central Archiving

Central archive server (CAS)
The central archive server (CAS) is not approved for PCS 7 as of V8.1. 

Replace the CAS with a Process Historian.
The migration of archive data from a central archive server is available as of PCS 7 V7.0 
(StoragePlus V1.2).

If archive data is to be available after the software update, you must perform the steps listed 
below.

You can find information on this in this documentation and in the documentation on the Process 
Historian:

● system manual SIMATIC; Process Historian Administration, "Migration" section 

● Installation manual SIMATIC; Process Historian Installation Notes

5.1.2 How to Detach Attached Archive Segments on the Central Archive Server

Requirements 
● Before you run the software update, perform these steps directly on the archive server 

(Central Archive Server (CAS), or StoragePlus Server).   

● You are authorized to access the Windows user interface on the CAS.

Procedure
1. In the Windows Start menu, select the "Administration Console" command from the 

SIMATIC > StoragePlus submenu.

2. In the detail view, click "Detach".
The catalog of all linked archive segments which have already been swapped out is 
displayed.

3. Select an archive segment you wish to remove from the archive.
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4. Click "Open".
The selected archive segment is detached from the archive. Once the archive segment has 
been detached from the archive, the archive segment is deleted from the hard disk of the 
CAS. A message window shows whether the archive segment has been deleted.

5. Click "OK".

6. Repeat steps 2 through 5 for all closed archives.

5.1.3 Migration of CAS databases to the Process Historian
If a central archive server (CAS) was used in the PCS 7 project, this cannot archive new plant 
data from PCS 7 plants as of V8.1. 

Recommendation:

Replace the CAS with the following PC stations:

● Process Historian as external archive server

● Information Server as reporting system

Requirement
The CAS databases were created with a central archive server as of PCS 7 V7.0 (Storage 
Plus V1.2).

Preparing for the software update
5.1 Migration of CAS databases to the Process Historian
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Basic procedure
The following figure shows an example of the migration concept for a CAS (Central Archive 
Server) database to the Process Historian in a PCS 7 environment.

Legend

1. Installation of a new PC station 
Selection for PCS 7: Process Historian
For more information, refer to the Process Historian; Installation Notes documentation.

2. Updating the software of the engineering station.
You can find information on this in the section "Installation of PCS 7 and settings on the ES 
and OS (Page 43)".

3. Performing the software update for the PCS 7 project.
You can find information on this in the section "Adaptations in the PCS 7 project on the 
ES (Page 51)".

4. Within the PCS 7 project:
Replacing the  CAS object in the PCS 7 project with a PH object. 
You can find information on this in the section "How to replace the CAS with the PH 
(Page 66)".

5. Stopping OS servers / OS single-station systems and updating the software.

Preparing for the software update
5.1 Migration of CAS databases to the Process Historian
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6. Run "PH-Ready Configuration"

Note
Configuration of Process Historian Ready

The "CCCAPHService" must be configured on the updated OS servers/OS single-station 
systems before process mode is activated.

You can find information about this in the documentation Process Historian; Installation 
Notes, section 'Installing the Process Historian Ready component'

7. Restarting OS servers/single-station systems
The Process Historian must be operating in the "Active" state before the updated OS 
servers are started for the first time. You can find additional information on this in the section 
"How to Check the Settings on the OS Servers (Page 79)".

Note
Note the start sequence for initial commissioning

Restart process mode for OS servers if necessary in order to establish the connection to 
the Process Historian. 

8. Starting the migration tool
You can find information on this in the section "How to migrate the archives in the Process 
Historian (Page 85)".
The migration of all CAS databases is performed in the background during ongoing 
operation.

5.2 Preparatory tasks

5.2.1 Overview of preparations

Overview of the procedure

Note

You must perform the steps listed below prior to carrying out an update in order to prevent 
data being lost.

It is essential that you back up your PCS 7 project before you start the software update.     

Step Action ES OS serv‐
er

OS cli‐
ent

AS

2 Backing up the project data (Page 35) X    
3 Back up the libraries you created (Page 37) X    
4 Export operator and display texts (Page 39) X    

Preparing for the software update
5.2 Preparatory tasks
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Step Action ES OS serv‐
er

OS cli‐
ent

AS

5 Checking the network adapter (Page 40) X X X  
6 Backing Up the License Keys and Authorizations 

(Page 41)
X X X  

Additional preparations

Note
Updating SIMATIC BATCH

If you want to use and update SIMATIC BATCH in the project, make sure to read the important 
information in "Updating SIMATIC BATCH stations (Page 81)" in preparation for the update.

 

5.2.2 Exchanging Data Via OPC A&E
If you exchange data in the PCS 7 system by means of OPC A&E, observe the information in 
the Process Control System PCS 7; OpenPCS 7 documentation when updating the software.

5.2.3 How to Back Up PCS 7 Project Data

Note

Before you install or update PCS 7, you must prepare and backup your original project so that 
you can perform the software update.

NOTICE

Ensuring safe system configuration 

If you want to perform a software update in runtime, you must ensure the following:
● All configurations are closed.
● All changes are loaded in the system.

Carry out the following instructions in succession.

Archiving a project
1. In SIMATIC Manager, select the menu command File > Archive.

The "Archive" dialog box opens.

2. Select the "Multiprojects" (or "User Projects") tab.

3. Click "Browse" and select the project you want to archive from the list.

Preparing for the software update
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4. Click "OK" to save your settings.
The "Archive - Select Archive" dialog box opens.

5. Make the following settings for archiving:

– Select the drive and the folder for the archive file from the "Save" drop down list box.

– Enter the name under which the archive file should be saved in the "File name" text box.
Recommendation:
Choose a name for the project's archive file that indicates the date on which archiving 
took place. Example: "yearmonthdayprojectname"; 091230name

6. Click "Save" to apply your entries.
The "Archive – Options" dialog box opens.
If you wish to archive your project on a disk, select the disk size.
You can find additional information on this dialog box by clicking the "Help" button.

7. Click "OK".
The archiving process begins.

When the "Archive" dialog box closes, archiving is finished.

Note

The archived project will reflect the state of the project before the software update.

Comparing Time Stamps
1. Open your PCS 7 project in SIMATIC Manager.

2. In the component view, select the chart folder of an AS.

3. Double-click on any chart.
The CFC editor opens.

4. Select the menu command CPU > Compare.

5. Compare the time stamps "Last compilation" and "Compilation of the loaded program".

If the time stamps are... ... Then
Identical 1. Click "Close".

The dialog box is closed.
Different 1. Select the menu command CPU > Download.

2. Select the "Changes" check box and apply all other standard 
settings.

3. Click "OK".
Changes start to be downloaded.

4. If changes have been downloaded without errors, select the menu 
command CPU > Compare.
The "Last offline program change" and "Last online program 
change" time stamps must match up.

6. Perform steps 2 to 5 for each automation system.

Preparing for the software update
5.2 Preparatory tasks

Software update without utilization of new functions
36 Service Manual, 03/2015, A5E32786218-AB



Reading Back the AS Parameter Settings
If parameters which are not in the configuration have been set in the AS, you will be able to 
read these settings back into the project. 

CAUTION

Parameters will be overwritten. 

Please note that the parameters in the configuration will be overwritten. The decision 
concerning whether to use this function will depend on the nature of the system involved and 
must be made by the skilled personnel with responsibility for the system.

1. Open your PCS 7 project in SIMATIC Manager.

2. In the component view, select the chart folder of an AS.

3. Double-click on any chart.
The CFC editor opens.

4. Select the menu command Chart > Read Back.

5. Select the entries "Program on the CPU" and "Only data relevant for operator control and 
monitoring" in the "Read Back" dialog box.

6. Click "OK". 
The read-back process begins.

7. Perform steps 2 to 6 for the automation systems whose current parameters you require.

Backing Up OS Data
If you want to operate the OS server on a newly installed PC following the software update, 
we recommend you back up the OS project of the OS server.

By default, the configuration data and the archive data of the OS are stored in the OS project 
of the OS server.

To back up data, compress the project paths in this folder and save the backup on a suitable 
medium.

SIMATIC PDM
SIMATIC PDM configuration data is included automatically in the backup of a SIMATIC project.

5.2.4 How to Back Up User Created Libraries

Introduction
Generate a backup copy of any project library that contains a collection of user-specific blocks 
for the project to be updated so that you can retrieve this data after having updated the 
software. Carry out these steps for each library that you would like to back up.   

Preparing for the software update
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Procedure
1. Start SIMATIC Manager.

No PCS 7 project must be open.

2. In SIMATIC Manager, select the menu command File > Archive. 
The "Archiving" dialog box opens.

3. Open the "Libraries" tab.

4. Select the library to be backed up and click "OK".
The "Archiving - Select an Archive" dialog box opens.

5. Specify the file name and the storage path.

6. Click on the "Save" button.

Additional information
● Online help for STEP 7

5.2.5 Operator and Display Texts in Blocks

Information in Faceplates   
Faceplates visualize processes on the operator station and provide the plant operator with 
information, such as:

● Measured values

● Operating limits

● Units

● Block operator texts

Change in Operator and Display Texts in Blocks
If you have modified the operator texts or display texts in the blocks so that they do not 
correspond to the delivery state and you want to use the new PCS 7 blocks, you must back 
up these "old" operator texts or display texts.

Diagnostic screens with project-specific adaptation
In a project created with a version lower than PCS 7 V7.0 SP1, backup the diagnostic screens 
that were adapted to a specific project. 

Exporting Operator and Display Texts
 SIMATIC Manager supports the export of information pertaining to parameters, signals, and 
messages to a file (format: *.csv).

Preparing for the software update
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You can edit this file in standard MS Office applications such as Excel and Access. The same 
mechanisms are used for the export as are used for changeover to project-specific languages. 

5.2.6 How to Export Operator and Display Texts

Requirement     
● The required language is installed in your project.

Note

You can view the languages available in the project in SIMATIC Manager using the menu 
command Options > Language for Display Devices. The number of available languages is 
specified when Windows is installed (system characteristics).

Procedure
1. Open the project to be updated in the SIMATIC Manager.

2. Select the master data library folder in the Component View.
If this folder is not available, select the project folder.

3. Select the Options > Manage Multilingual Texts > Export menu command.
The "Export user texts" dialog opens.

4. Make the following settings:

– In the "Text tables" group, select the storage location and the format of the export file 
(possible formats: *.xls and *.csv).

– Select the target language and source language that correspond with the display 
language in the "Language" area.

5. Click "OK".

6. If you are managing multilingual projects, repeat steps 3 thru 5. Make sure that you specify 
different destination directories or export file names.

5.2.7 Non-approved network adapters

Communications Processors that Are No Longer Supported

Note

Generally, the following applies as of PCS 7 V7.0:

PROFIBUS is no longer supported as the plant bus. Only Industrial Ethernet is supported as 
the plant bus. 

Preparing for the software update
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The following communication processors are no longer supported by PCS 7:

● CP 1413 Industrial Ethernet

● CP 1613 A1

● CP 5412 A2 PROFIBUS

● CP 5613 PROFIBUS

These communication processors must be uninstalled and removed.

Communications Processors that Are Not Detected
The following communication processors cannot be detected during installation of the 
operating system:

● Non-"Plug&Play" compatible communications processors

● ISA plug-in cards as communications processors

Replace these CPs with approved communication processors prior to installation of the 
operating system.

Communications Processors in the PC Stations
Note that you must also remove the hardware specified above from the PC stations of your 
PCS 7 project. 

Note

You must reconfigure the connections after the communications processors are removed.

Additional information
You can find information about suitable PCs and network adapters in the catalog overview 
Process Control System PCS 7; Released Modules.

5.2.8 How to check the network adapter

Introduction
After you have installed the operating system on the PCs, you should check whether the 
network adapters (communication processors or network cards) being used are recognized 
by the operating system.

Procedure
1. Click the "Workspace" icon on the desktop.

2. In the shortcut menu, select the menu command  Properties.

Preparing for the software update
5.2 Preparatory tasks

Software update without utilization of new functions
40 Service Manual, 03/2015, A5E32786218-AB



3. Open the "Hardware" tab.

4. Click the "Device Manager" button.
The "Device Manager" dialog opens.
The detected modules can be found in the "Device Manager":

– The detected communication processors (CPs) are listed in the"SIMATIC NET" folder.

– The detected network adapters can be found in the "Network Adapters" folder.

5. Close the dialog box.

Additional information
● Documentation: PCS 7; Released Modules

5.2.9 Backing up pictures for user-defined status displays.
If prior to PCS 7 V8.1 you have used your own pictures when creating the status displays for 
user-defined extended status displays, you should save these screens (EMF files) in a 
separate folder.

Procedure
1. Open the "GraCS" folder in the OS project folder in Windows Explorer.

2. Create a folder for your own pictures.

3. Copy the pictures (EMF files) that are used into the newly created folder.

5.2.10 Backing Up the License Keys and Authorizations

Introduction     
You must backup the license keys/authorizations stored on your hard disks before changing 
the operating system or using new PC stations.

Note

You can backup all License Keys to a License Key USB stick that is available as of PCS 7 V7.1. 
You must transfer the authorizations to a License Key disk/multi-authorization disk.

Preparing for the software update
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Program for backing up the License Keys
Use the Automation License Manager for this purpose. 

Note

Reinstall the License Keys from the backup file using "Automation License Manager" (available 
on the Process Control System; SIMATIC PCS 7 DVD) after having installed the operating 
systems to enable an upgrade of the License Keys (Upgrade License Key and Power Pack 
License Key). You can only upgrade the License Keys if the License Keys to be updated are 
available on the corresponding PC station.

Additional information
● Online help for Automation License Manager
● Online help for WinCC Information System > Authorizations

Preparing for the software update
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Installation of PCS 7 and settings on the ES and OS 6
6.1 Overview of Installation and Settings on the ES and OS

Overview of the procedure     

Step Action ES OS serv‐
er

OS cli‐
ent

AS

7 Updating PCS 7 (Page 43) X X X  
8 Installing additional libraries (Page 48) X X X  

6.2 How to Update PCS 7

Requirements
● The PCS 7 project data is backed up.    

You can find detailed information about how to back up project data in the Process Control 
System PCS 7; Service Support and Diagnostics manual, section "Safeguarding 
Availability, Data backup".

● The hardware planning and hardware update are complete.

● The necessary preparations have been made.

● The operating system of the PC station to be updated is updated.
You can find information on approved operating systems in the Process Control System 
PCS 7; PCS 7 Readme documentation.

● Read the latest information in the Process Control System PCS 7; PCS 7 Readme 
documentation (Internet version).
– Hardware and software requirements, installation 

– If you use an INTEL network adapter, install the driver suitable for your device type and 
operating system version. You can find this information in the "01_Drivers\NETWORK
\Intel" folder of the "PCS 7 Software Support and Tools" DVD 2014.02 from the "PCS7 
V8.x Software Support Package" that can be ordered separately (article number 
6ES7 650‑4xx08‑0YT8).

– Information on the software for the automation system of SIMATIC PCS 7 BOX:
The software for time synchronization must be installed for an update of SIMATIC PCS 
7 BOX and SIMATIC PCS 7 AS RTX. 
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Note
Software update of password-protected projects

The software update of password-protected projects requires SIMATIC Logon on an ES.

Note
Archive server
● The central archive server (CAS) must be replaced with a Process Historian. 

You can find information on migration in the section "How to replace the CAS with the PH 
(Page 66)".

● Sequence for starting Process Historian and OS server
If the Process Historian is commissioned after activation of the OS servers, you need to 
restart the 
OS servers to establish the connection to the Process Historian.

Note
Sequence for starting Process Historian and OS server
● If the Process Historian runs in process mode, the OS servers can be activated.
● Note the following if the Process Historian is commissioned after activation of the OS 

servers:
You must restart the OS servers to establish the connection to the Process Historian. 

SIMATIC PDM
Install SIMATIC PDM on the engineering station if using the Maintenance Station of PCS 7 
and if the project contains intelligent field devices configured with SIMATIC PDM. The PDM 
Server must be installed on the engineering station for the complete Asset Management 
functionality.

Read the information and requirements in the readme for the current version of SIMATIC PDM.

Note
Installing SIMATIC PDM

If you are using a PDM version lower than V8.0 SP1 and want to perform an update installation, 
uninstall the old PDM version before the installation.
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Installing PCS 7
If you use the "Update" function in the PCS 7 setup, we recommend you reboot the PC before 
performing the installation.

1. Insert the Process Control System; SIMATIC PCS 7 DVD into the DVD drive.

2. Select the "Update" setup type.
You can find a detailed description of how to install the required software in the Process 
Control System PCS 7; PCS 7 PC Configuration documentation, in the section "How to 
Install PCS 7 Software".

Note

During the installation, a message will appear several times prompting you to reboot your 
PC. Reboot the PC. The installation then continues automatically.

Note
Required access rights for changing the project path

The project path in "Storage location for projects/multi-projects" is set by default to 
"SIEMENS\STEP7\S7Proj" and all necessary access rights are set for this project path.

If you use another project path, you need to set the necessary access rights using the 
"SimaticRights.exe" tool.

For more information, refer to the Process Control System PCS 7; PCS 7 PC 
Configuration manual, in the section "How to set permissions for the project paths".

Microsoft SQL Server
As of PCS 7 V8.1, no configuration of PCS 7 requires Microsoft SQL Server 2005. 

If Microsoft SQL Server 2005 is installed on the PC and is not required for specific purposes 
in the plant, you should uninstall this software after the update installation of PCS 7 V8.1. You 
can find the required menu command in the Control Panel.

Additional information
● Process Control System PCS 7; PCS 7 - Readme file (see "Preface (Page 9)")

● Manual Process Control System PCS 7; PCS 7 PC Configuration

6.3 How to enable encrypted communication between the PC stations

Changing the access protection of communication
Typical situations are:

● Software update of PC stations

● Switching to encrypted communication in non-redundant configurations
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● Switching to encrypted communication in runtime in redundant configurations

● Changes to settings for encrypted communication in runtime (for example, changing a 
password).

Note
Disruption of communication connections

Activation of the migration mode described below is only required if the communication 
connections between the following PC stations must not be disrupted in any way: 
● PC stations with access protection for communication 
● PC stations without access protection for communication 

Activation of the migration mode 

If you want to make a change to the access protection of the communication in process mode 
of the system, you must follow this sequence of actions:

1. Temporarily enable the "migration mode" option for all PC stations for the next procedure.

2. Before activating secure communication without migration mode, evaluate the potential 
impact.

NOTICE

Secure communication in a system

Before you enable exclusive use of encrypted communication, you must ensure the 
following:
● Migration mode must be enabled on all the required PC stations.
● The encrypted communication must be enabled on all the required PC stations.

3. Temporarily disable the "migration mode" option for all PC stations for the next procedure.

Using secure communication for a PC station
1. Select the "SIMATIC Shell" folder in the tree view of Windows Explorer on the PC station. 

2. Select the "Settings..." command from the shortcut menu. 
The "Communication Settings" dialog opens. 

3. Enable the "Use encrypted communication" option. 
The "Set PSK" dialog box opens.

Note
Changing the PSK

When the "Set PSK" option is enabled, you can change the PSK. Click the "Set" button.

Please note the documentation Process Control System PCS 7; PCS 7 PC Configuration; 
section "How to change the PSK for encrypted communication".

4. Enter characters with a high password strength for the key. 
The key must be at least 8 characters long and include numbers and symbols in addition 
to uppercase/lowercase letters. 
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5. Confirm your entries. Click "OK".

6. If you want to use an available port instead of the port allocated by default, you can specify 
the assignment of the incoming port.

7. Check the setting for the "Migration mode" check box.

Note

Please note the documentation Process Control System PCS 7; PCS 7 PC Configuration; 
section "How to use migration mode when changing encrypted communication".

8. Click "OK".

Additional information
● Please note the documentation Process Control System PCS 7; PCS 7 PC Configuration; 

section "How to access PC stations outside a subnet".

6.4 Installation of Additional PCS 7 Libraries

Post-installing libraries used in the project
Depending on the blocks used, you have to post-install libraries and update the blocks used 
in the project with the blocks of the following libraries:

● PCS 7 Basic Library

● PCS 7 Advanced Process Library (PCS 7 APL)

● PCS 7 Library

PCS 7 faceplates of the PCS 7 library are contained in the project
If you are updating PCS 7 (setup type "Update"), you can ignore the following information. The 
PCS 7 faceplates are installed automatically.

Note
Carrying out the "Install" setup type

If you are installing PCS 7 new ("Install" setup type), you need to observe the following:
● If you are using the PCS 7 Library in the project to be updated under PCS 7 V8.1, you must 

install the faceplates (PCS 7 faceplates) of PCS 7 V7.1 on the following PC stations after 
a new installation of PCS 7:
−    Engineering station
−    All operator stations

● You can find the setup for this on the DVD2 Process Control System; SIMATIC PCS 7 in 
the folder "Additional_Products\PCS7LIBRARY__V7.1<...>".
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Note
Libraries for projects with "PCS7 Library V7.1" and "PCS 7 APL" as of PCS 7 V8.0 

The additional blocks in the PCS 7 Library in the "PCS7 Library V71/ChnBlocks for PCS7 V8" 
folders may solely be used for projects that use APL as of V8.0.

Basic Installation Procedure
The procedure is described in the section "How to install additional PCS 7 libraries (Page 48)".

An AS download without a stop is possible. You can find the basic procedure for this in the 
Process Control System PCS 7; Engineering System configuration manual. 

6.5 How to Install Additional PCS 7 Libraries

Note
Post-installing or removing PCS 7 libraries

If you install or remove an older version of the PCS 7 Library, PCS 7 Basis Library or PCS 7 
Advanced Process Library after the installation of PCS 7, you must post-install the current 
versions of the PCS 7 Basis Library or PCS 7 Advanced Process Library.

Install the required libraries using the PCS 7 setup; an installation using the product setup of 
the libraries is not permitted. This applies, for example, to the PCS 7 libraries which are located 
on the DVD2 Process Control System; SIMATIC PCS 7 in the folder Additional_Products .

You can find information about the versions of the libraries (including updates) in the file 
Process Control System PCS 7; PCS 7 Readme (see "Preface (Page 9)").

Requirements
● The operating system including the required components is installed.  

● PCS 7 has been installed.

● All applications are closed.

● The required software for the required library is available, on the Process Control System; 
SIMATIC PCS 7 DVD, for example.
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Procedure
The following steps serve as an example. 

1. Run the "SETUP" program.
You can find the libraries and corresponding setup program on the DVD2 Process Control 
System; SIMATIC PCS 7 in the folder "Additional_Products".

2. Select a setup language.

3. Click "Next".

4. Follow the instructions of the setup wizard and then close the setup program.

5. After installing all the required libraries, you need to install the following libraries from the 
latest Process Control System; SIMATIC PCS 7 DVD over them using the setup of PCS 7:

– PCS 7 Advanced Process Library (APL) 

– PCS 7 Basic Library

Note
Installing the current library by means of the PCS 7 setup

The PCS 7 setup always installs the latest version of the library that is available on the 
DVD.

Additional information
Included with the PCS 7 libraries delivered:

● PCS 7 Basis Library: bli-Readme.rtf file
● PCS 7 Library: LIB-Readme.wri file
● PCS 7 Advanced Process Library: APL-Readme.rtf file
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Adaptations in the PCS 7 project on the ES 7
7.1 Update of a PCS 7 Project

Basic procedure
This section describes how to update your PCS 7 project for use with SIMATIC PCS 7. The 
PCS 7 project is updated on the ES in offline mode. Thus, system operation is not affected. 
The target stations will only be loaded once all the update steps listed below have been 
performed. For more information on downloading, refer to the Process Control System PCS 
7; Engineering Station Configuration Manual.   

Note

If you want to reuse existing projects without updating the automation system, you also need 
to install the libraries of the existing project. 

You can find additional information on this in the section "Installation of Additional PCS 7 
Libraries (Page 47)". 

7.2 General adaptations

7.2.1 Overview of General Adaptations in the Project

Overview of the procedure   

Step Action ES OS serv‐
er

OS cli‐
ent

AS

7 Updating the OS using Project Migrator (Page 52) X    
8 Checking PH consistency (Page 53) X    
9 Updating the hardware configuration for the SIMATIC 

PCS 7 BOX and SIMATIC PCS 7 AS RTX (Page 54) 
X    

10 Configuring the PDM Server address (Page 55) 
(for projects with SIMATIC PDM V8.0 only)

X    

7.2.2 Changing the Configuration of Multilingual Texts
If you want to use additional interface languages, please take note of the information below.
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Changing Multilingual Texts
If you want to display text in more than one language in PCS 7 (for example, message texts 
or OS area IDs), always use the export/import function to change the multilingual texts (menu 
command Options > Manage Multilingual Texts > Export and then Import after the changes 
have been made). 

Note

If you change individual texts with the functions in CFC, SFC, or PH, be sure to immediately 
compile the texts in all locations (for example, all block types and all copies of a block). 
Otherwise, inconsistencies may occur and lead to the display of an incorrect language version 
of this text.

7.2.3 Importing Data from the User Archives

Import Runtime Data

Note

You must always import runtime data from the user archives in the language in which the 
runtime data was exported.

7.2.4 How to update the configuration of the operator stations
If the configuration of an OS in a multiproject or project does not correspond to the installed 
PCS 7 version, this is automatically detected in SIMATIC Manager as of PCS 7 V8.0 SP1.         

Requirements 
● Projects with a current PCS 7 version earlier than PCS 7 V7.1 SP3 must first be updated 

to PCS 7 V7.1 SP4.

● For password-protected projects only:
Disable the password protection during the following actions.

Procedure 
Carry out the following steps for a given OS project:

1. Open your project/multiproject in the component view of SIMATIC Manager.

2. Select an OS project of your choice.
If required, the "Migrator" dialog window is opened by the system.
The message "Migration is required ..." is displayed.
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3. Click "Yes".

Note
Declining migration

If you decline the migration, you cannot change the OS project or load it. 

You can start the migration at any time. To do this, select the menu command Options > 
Migrate OS projects.

4. Check the project language set in the "Migrator" dialog box. If necessary, set the project 
language in which the project was created.
Recommendation:
No settings are required in the dialog box. 

– If you clear the "Migrate database only..." check box, considerably more time will be 
needed for the migration. 

– The migration of the excluded components in process mode has no effect on process 
mode.

5. Click "Next".
The configuration of all operator stations contained in the multiproject/project is performed.

Duration of the update process

Note

Depending on the scope, the update process can take several hours.

Additional information
● Online help WinCC Information System > Migration
● Configuration manual Process Control System PCS 7; Operator Station

7.2.5 How to Check the PH Consistency
This step shows you if all the data in the plant hierarchy is consistent.  

Requirement
● The project in SIMATIC Manager is open in the plant view.
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Procedure
The following steps can be performed for the multiproject or for each individual project (in the 
multiproject).

1. In the tree view, select the object to be checked (e.g., the multiproject).

2. Select the Options > Plant Hierarchy > Check Consistency command.
The program checks the PH. 
The "Check Consistency – Log" dialog box opens.

3. If errors are found, make the appropriate corrections.

Note

If you need information on the possible errors, click the "Help" button in the "Check 
Consistency - Log" dialog box.

7.2.6 How to update the hardware configuration for SIMATIC PCS 7 BOX RTX and 
SIMATIC PCS 7 AS RTX

The steps described below only have to be carried out for project with SIMATIC PCS 7 BOX 
RTX or SIMATIC PCS 7 AS RTX implementation.

Replace the automation system in the hardware configuration of the PC station.

Requirements
● The AS version in HW Config is not up to date (Version 3.3 or older)

● The assignments of CPs to the master systems are known.

Procedure
1. Open the PC station in HW Config (SIMATIC PCS 7 BOX RTX or SIMATIC PCS 7 AS RTX).

2. Select the PROFIBUS CP to which the distributed I/O is connected.

3. Select the Edit > Master system > Disconnect menu command.

4. Select the CP.

5. Select the Edit > Delete menu command.

6. Select the "Win LC RTX" CPU in the rack in HW Config.

7. Go to the"SIMATIC PC-Station > Controller > Win LC RTX" folder in HW Config.

8. Double-click the object "V4.4".
The "Insert ..." dialog box opens.

9. Click "Yes".
The controller is replaced.

10.Go to the"SIMATIC PC-Station > Controller > Win LC RTX > V4.4" folder in HW Config.

11.Select the PROFIBUS CP used (default: CP 5613).
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12.Drag-and-drop the selected PROFIBUS CP to the controller slot in the station window.
The "Properties ..." dialog box opens.

13.Select the entry of the associated bus system from the "Subnet" list.

14.Click "OK".
The "Insert master system" dialog box opens.

15.Select the entry of the associated bus system from the "Subnet" list.

16.Click "OK".

17.Select the Station > Save and Compile menu command.

7.2.7 How to configure the SIMATIC PDM Server

Requirements
● The project/multiproject has been created.

● The SIMATIC PDM (Server) software package is installed on the Engineering Station.

Note
Requirements for the use of SIMATIC PDM

Please observe the conditions for the use of SIMATIC PDM versions.

Selecting the name of the PC station

Note
Restrictions

The following restrictions must be observed:
● Valid characters: [A-Z 0-9]{1,32}
● Use uppercase letters only.
● The first character of the PC station's name must be a letter.
● Maximum length: 32 characters

Note

We recommend that the PC name is the same as the name of the station.
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Procedure
1. Select the Options > SIMATIC PDM > Settings command in SIMATIC Manager.

The "SIMATIC PDM settings" dialog box opens.

2. Select the "Maintenance Station" tab.

3. Go to the input field and enter the project/multiproject in which you have defined the MS 
server or execute the following steps:

– In a multiproject: 
Click "Current Multiproject" or "Browse." You can select the current project using the 
"Browse" button.

– For a project: 
Click on "Current Project" or "Browse." You can select the current project using the 
"Browse" button.

4. Click "OK".

5. Open SIMATIC Manager in the component view.

6. In the project, select the engineering station in which you wish to insert the "PDM Server" 
object.

7. Double-click the "Configuration" object in the detail view.
The hardware configuration of the SIMATIC PC station opens.
If you cannot see the hardware catalog, select the View > Catalog menu command.
The hardware catalog opens.

8. Select SIMATIC PC Station > PDM Server from the list in the folder.

9. Drag and drop the "PDM Server" object to the PC station of the engineering station.

10.Select the menu command File > Save.

11.Download the configuration to the engineering station.

Requirements for diagnostics with SIMATIC PDM
Diagnostics can only be performed on the PDM devices for a given station (OS client, 
maintenance server, etc.) if SIMATIC PDM is active on the engineering station. This is the 
default scenario after the configuration has been downloaded. 

Additional information
● STEP 7 and SIMATIC PDM Online Help

● Whitepaper SIMATIC; Security concept PCS 7 and WinCC - Main document
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7.3 Adaptations in NetPro and conversion of the CFC/SFC charts

7.3.1 Overview of adaptations in NetPro and conversion of the CFC/SFC charts

Overview of the procedure   

Step Action ES OS serv‐
er

OS cli‐
ent

AS

11 Checking and adapting the connection data in NetPro 
(Page 57)

X    

12 Converting the CFC and SFC charts (Page 58) X    

7.3.2 How to Check and Adapt the Connection Data in NetPro
In NetPro, you check the configuration to the target stations:

● Connection data

● Configuration data

● After changing the operating system

Note
Operating system change

When you change the operating system, the network adapters may be detected in a different 
order in the system. This is caused by the operating system. 
Take this into consideration with systems with multiple network adapters and adapt the 
configuration accordingly in HW Config.

Update the version of the communication components in the Station Configuration Editor and 
HW Config. The version depends on the version of SIMATIC NET installed on the target station.

As of Windows 7 or Windows Server 2008 R2, SIMATIC NET as of V12.x is installed. 
Depending on the network adapter used, select the following version of the communication 
component in HW Config:
● When using 'IE General' standard network adapters: V8.2
● When using communication processors (e.g. CP 16xx): V8.1.1

Requirement
● The PCS 7 project is open on the ES.
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Procedure
1. Select the PCS 7 project in SIMATIC Manager.

2. Select the menu command Options > Configure Network.
NetPro opens.

3. Select the menu command View > Cross-Project Network View.
The cross-project network view is displayed.
This allows you to toggle directly between all projects in the multiproject.

4. Check the connections to the various stations: AS-OS, AS-AS, ES-AS. 
You can make any necessary changes when the "cross-project network view" is 
deactivated.
You must configure the connection between the ES and AS if you want to check the 
communication for process mode (runtime) on the ES. This requires the following steps to 
be taken:

– Select the menu command New Connection in the shortcut menu of the WinCC 
application.

– Select the destination: AS or OS.

– Select the connection.

– Select the name for the connection.

– Click "OK".

Recommendation
To enable you to easily identify the connections, we recommend that they be assigned 
default names in accordance with the name of the target.
Example: 
You configure an OS to AS_X connection. 
The corresponding connection name could be "ASX_connection".

5. If you use time synchronization, you must check the time settings of the network adapters 
(e.g. CP 1623) in the ES and OS. Double-click the network adapter of the OS/ES. Time-of-
day mode must be selected for time synchronization on the "Options" tab.

6. If you have made changes in NetPro, you must perform a "Save and Compile" operation 
with the "Save and Compile All" option.

7.3.3 How to Convert CFC Charts and SFC Charts

Requirement
● The PCS 7 project is open on the ES.  

Procedure

Note

This procedure must be carried out for all S7 programs in your PCS 7 project.
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1. Open a CFC chart and move any block it contains.
This change immediately start the conversion dialog.

2. Click "Yes".
The "Convert Format" message window opens.

3. Click “Yes".

4. Click "OK".

5. Execute a complete compilation of the S7 program.

6. Download changes to the automation system.

NOTICE

Updating a Redundant OS During Operation (in accordance with manual
Process Control System PCS 7; Fault-tolerant Process Control Systems; Guide to
Updating a Redundant OS During Operation)

If you update a redundant OS during operation, do not load the AS until phase 3 (in step 
6 of the Process Control System PCS 7; Fault-tolerant Process Control Systems manual).

Note

If you use SFCs in your project, please note that you need to update the SFC blocks. 

Additional information
SFC Readme

7.4 Adaptation of OS-relevant settings

7.4.1 Overview of Adaptation of OS-relevant Settings

Overview of the procedure   

Step Action ES OS serv‐
er

OS cli‐
ent

AS

15 Synchronize OS basic pictures, local computer actions, 
and faceplates (Page 60) 

X    

16 Update picture objects (Page 63) X    

User interface and design
After the software update, the design of the user interface for process mode must be set to 
the following:
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WinCC 3D

This setting is available automatically in projects created as of PCS 7 V8.0. 
Other designs are not approved for PCS 7.

You need to check or change this setting for existing projects.

● Ensure that all projects in a plant have uniform settings for the design.

● If you change the setting for the WinCC design, check the appearance of objects you have 
created yourself and adapt them if necessary.

7.4.2 Synchronization of OS Basic Pictures, Local Computer Actions and Faceplates
You have to transfer OS basic pictures and local computer actions to your project. The 
faceplates of the project can continue to be used.

Synchronization in the OS Project Editor
You perform this procedure with the OS project editor, which is included in WinCC Explorer.

7.4.3 How to Synchronize OS Basic Pictures, Local Computer Actions, and Faceplates

Requirements
● The operator stations contained in the PCS 7 project have been updated with the Project 

Migrator.

● The PCS 7 OS is open in WinCC Explorer.

Procedure
1. Select the OS Project Editor and select the menu command Open in the shortcut menu.

2. Select the "Complete configuration" check box on the "General" tab.

3. Click the "Layout" tab.

4. Select the required layout and the monitor configuration.

5. Click the "Basic Data" tab. Make the required settings in accordance with the "Basic Data" 
table below.
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6. Only carry out this step if the "For observation only" authorization level must be activated 
for some users after the software has been updated.
Select the "Message Display" tab. 
Activate the required message filters (see the "Message Filters" table below).

Note

No settings are necessary for the software update on the remaining tabs. The default 
settings can be applied.

7. Click "OK".

Basic Data

Dialog Area Note Action
Top left 
window

This window lists all basic pictures having a differ‐
ent product version and project version change 
date.
Every basic picture with a selected check box is 
overwritten in the project version at the start of the 
OS Project Editor with the pictures from the prod‐
uct version.

Activate the check boxes for all of the basic pictures 
identified with a red "X".

Top right 
window

This window lists all local computer actions having 
a different product version and project version 
change date.
Every local computer action with a selected check 
box is overwritten in the project version at the start 
of the OS Project Editor with the corresponding 
local computer action from the product version.

Activate the check boxes for all of the basic pictures 
identified with a red "X".

Bottom left 
window

This window lists all faceplates having a different 
product version and project version change date.

● If you want to replace the faceplates available in 
the project with those of the relevant product 
version, select the corresponding check box. The 
settings provided by the product will then be 
applied.

● If you have made project-specific customizations 
to the color ranges of the faceplates of the 
Advanced Process Library and do not want to 
reset them, make sure that the "Update palette 
colors of Advanced Process Library" check box 
is not selected. (default setting).

● If you want to restore the default, select the check 
box "Update palette colors of Advanced Process 
Library".

Note

In PCS 7 V8.1, the Dynamic Wizard has been changed because of the AS-granular structure 
types. 

Make sure that the "Update Dynamic Wizard Scripts" check box is selected. 
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Message Filters

Parameters Meaning
Messages that 
can be acknowl‐
edged in a sepa‐
rate list

The message windows have two message lists. 
One list shows all messages from the area for which the user has access rights for all "operator process 
controls". The user can acknowledge messages in this list. 
The other list shows all messages from the area for which the user has an "authorization for area" but no 
access rights for "operator process controls". The user cannot acknowledge messages in this list. 
The message line in the overview area only shows messages that can be acknowledged with the access 
right for "operator process controls".

Messages that 
can be acknowl‐
edged on a sepa‐
rate page 
(switch-selecta‐
ble)

Both of the message pages indicated above are available to the user. Only messages from areas for 
which the user has access rights for "operator process controls" are displayed on the message page with 
only one list and in the message line of the overview area.

Additional information
● Online help WinCC Information System > Options > Options for Process Control > OS 

Project Editor

● Online help OS Project Editor

7.4.4 Mixed Operation of Faceplates from Different Versions of PCS 7

Definition of Mixed Operation   
Mixed operation is the visualization of AS blocks from different PCS 7 versions on one OS 
client.

Compatibility of the PCS 7 faceplates
You can use the PCS 7 V8.1 faceplates to control and monitor the AS blocks of the following 
PCS 7 versions:

● PCS 7 V7.1 SP3; PCS 7 V7.1 SP4

● PCS 7 V8.0 SPx

● PCS 7 V8.1
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Rules
Beginning with PCS 7 V8.1, the same block icons for AS blocks from different library versions 
can be shown in the process pictures of an OS. If an OS is assigned to several AS, only AS 
blocks of the following versions of the Advanced Process Library can be configured for each 
AS:

● AS blocks from PCS 7 V7.1 SP3

● AS blocks as of PCS 7 V8.1

The block icons are inserted into the process pictures when the OS is compiled. The standard 
picture "@PCS7TypicalsAPLV8.pld" serves as the template for creating/updating the block 
icons of all AS in the process pictures. 

7.4.5 How to Update the Picture Objects

Introduction
If you have manually inserted and interconnected picture objects from a template picture into 
a process picture, you must manually update these picture objects. 

When the picture objects are updated, the block icons of the previous PCS 7 version are 
replaced with the block icons of the current PCS 7 version.

You have to use the corresponding template picture that you used for configuration to update 
the picture objects. 
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Recommendation: Perform the update one by one with each template picture of the library 
used.

● For block icons of the PCS 7 library:
"@Template.pdl" or "@@PCS7Typicals.pdl" 

● For APL block icons

– PCS 7 V8.1 template pictures:
- "@PCS7TypicalsAPLV8.pdl" 
- "@TemplateAPLV8.pdl"

Note

Using a template picture for APL block icons of PCS 7 prior to V8.0

The APL template pictures of PCS 7 as of V7.1.3 can continue to be used in PCS 7 for 
updating picture objects:
● "@PCS7TypicalsAPLV7.pdl"
● "@TemplateAPLV7.pdl"

By using these template pictures as of PCS 7 V8.0 , the display of the block icons 
remains unchanged. 

Please note that executing the project editor copies the files 
"@PCS7TypicalsAPLV8.pdl"/"@TemplateAPLV8.pdl" into the project. 
● Delete the "@PCS7TypicalsAPLV8.pdl"/"@TemplateAPLV8.pdl" files. In this way, 

these template pictures ("@PCS7TypicalsAPLV7.pdl" / "@TemplateAPLV7.pdl") are 
used when executing the function "Create/update block icons" and in compilation 
processes.

● It is imperative that you always use the same versions of the 
@TemplateAPL<Version>.pdl" and "@PCS7TypicalsAPL<Version>.pdl" files.

Overwriting default settings

User scripts and modified properties of the picture objects are overwritten by the default 
settings.

Only the block icons of the selected template picture are updated.

Requirements
● The operator stations contained in the PCS 7 project have been updated with the Project 

Migrator.

● All basic pictures are replaced with the OS Project Editor.

● The PCS 7 OS is open in WinCC Explorer.

● Read the following section in the Process Control System PCS 7; Operator Station 
configuration manual; section "Rules for using multiple template files".
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Procedure
1. Open any WinCC picture containing a picture object in the Graphics Designer. Select the 

picture object.

2. In the dynamic wizard, open the "Picture Functions" tab and select "Update Picture 
Objects". 
This "Dynamic Wizard" dialog opens.

3. Click "Next".

4. Select the "Yes, all pictures" check box.

5. Click "Next".

6. Select the template in the list which has been configured with the picture objects of the OS. 
(Default:@Template.pdl)

7. Select the default "TemplateControl.cfg" configuration file in the "Please specify name of 
configuration file" field.

8. Click "Next".

9. Click "Finish".
Generation of the picture objects is initiated in the Dynamic Wizard.

7.5 Adaptations for the Process Historian

7.5.1 Adaptations for the Process Historian at a glance

Overview of the procedure

Step Action ES OS serv‐
er

OS cli‐
ent

AS

17 Updating Process Historian and Information Server 
(Page 66) 

X X   

18 Replacing a central archive server with a Process 
Historian (Page 66) 

X X X  
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7.5.2 How to update the Process Historian and Information Server
You must update the following PC stations, if they were present in the PCS 7 project before 
the software update:

● Process Historian 
You can find information on this in the SIMATIC HMI; Process Historian system manual.

● Information Server
You can find information on this in the SIMATIC HMI; SIMATIC Information Server system 
manual

7.5.3 How to replace the CAS with the PH
If a central archive server (CAS) was used in the PCS 7 project, this cannot archive new plant 
data from PCS 7 plants as of V8.1. 

Recommendation:

Replace the CAS with the following PC stations:

● Process Historian as external archive server

● Information Server as reporting system

Requirements
● The Process Historian is installed.

● The Process Historian is configured according to the guidelines specific to the plant (new 
PC station in the workgroup/domain - network addresses, user etc.).

● The software of the engineering station is updated.

● The PCS 7 project is updated.

Procedure
1. Open the SIMATIC Manager on the engineering station.

2. Open the PCS 7 project in the component view.

3. Do the following in the component view of SIMATIC Manager:

– If the CAS station is located in a separate project in the multiproject:
Select the project of the CAS station.
Select Multiproject - Remove from multiproject from the shortcut menu.
The CAS station is removed from the multiproject.

– If the CAS station is located in a project with other stations:
In the component view of SIMATIC Manager, select the PC station with the "CAS" role.
Select Delete from the shortcut menu. Click "Yes". 
The CAS station is removed from the project.
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4. Perform the following sequence of tasks for all OSs in the multiproject that have stored data 
on the CAS (OS servers and single-station systems):

– Open the "Backup Configuration" tab in the "Properties" dialog of the PC station.

– Clear the "Backup enabled" check box for the following options:
- Tag Logging > Archive configuration > Tag Logging Fast
- Tag Logging > Archive configuration > Tag Logging Slow
- Alarm Logging > Archive configuration > Message archive

– If SIMATIC BATCH reports are to swapped out, you need to disable the export of the 
reports to CAS. 

Note
CAS backup configuration

If there is no longer a CAS computer in the project but the destination paths are entered, 
a process control error is generated at each segment transition.

5. Perform the following sequence of tasks for all operator stations in the multiproject that 
have a CAS assignment:

– Select the OS project in the component view of the SIMATIC Manager on the PC station.

– Select the menu command Options > OS > Assign OS Server....
The "Assign OS Server ..." dialog box opens.

– In the list of OS servers, check the following:
Make sure that the check box for the OS server with the data you want to visualize on 
this operating station is selected.

– Clear the check box for the PC station of the CAS.

6. Create a new PC station for the Process Historian in the project.

7. Configure a new PC station for the Process Historian.
You can find additional information about this in the documentation Process Control System 
PCS 7; Engineering System.
Save and compile the configuration.

8. Set the properties in the SIMATIC Manager. For this purpose, select the Process Historian's 
PC station and then select the shortcut menu command Object properties. 

9. Enter the computer name in the "Computer name" group or activate the "Computer name 
identical to PC station name" check box.

10.Click "OK". 
The "Properties" dialog box closes.
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7.6 Adaptations for the Maintenance Station

7.6.1 Overview of the Maintenance Station update
The process of updating an MS server involves some additional steps which are not required 
when updating an OS server. The corresponding additional steps are listed below.

Overview of the procedure

Step Action ES OS serv‐
er

OS cli‐
ent

AS

19 Changing the OPC Server and adapting the SNMP 
configuration (Page 68) 

X    

20 Updating the diagnostics settings (Page 70) X    
21 Updating the diagnostics screens (Page 71) X    

7.6.2 How to change the OPC Server and adapt the SNMP configuration

OPC Server version
Run a compatibility check after migration to a different operating system, as the OPC Server 
version is dependent on the operating system used.

If incompatible, replace the OPC Server. 

The following table lists the compatibilities.

Operating system of the MS Server OPC Server version
Windows Server 2008 R2
Windows 7

V8.2

Requirements
● The blocks, charts and OS pictures of the project are updated.

● The SIMATIC programs and OS are compiled.

● The PC stations of the Maintenance Station (MS Server and MS Client) are updated in a 
similar way to an OS.

● MS single station system

– An OPC Server is configured on the PC Station of the MS single station system.

● MS multiple station system

– In a system with redundant MS Servers, you configured an OPC Server both for the PC 
Station of the MS Server and for the PC Station of the redundant partner.
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● Lifebeat monitoring is disabled 
If you use the Maintenance Station in the project, lifebeat monitoring must be disabled.

Procedure
1. Select the PC station in the Component View.

– In an MS multiple station system, this is the PC Station of the MS Server or of the 
redundant partner.

– In an MS single station system, this is the PC Station of the MS single station system.

2. Double-click the "Configuration" object in the detail view to open HW Config.
The hardware configuration of the SIMATIC PC station opens.
If you cannot see the hardware catalog, select the View > Catalog menu command.
The hardware catalog opens.

3. Select the current version of the OPC Server from the hardware catalog at SIMATIC PC 
Station > User application > OPC Server and drag-and-drop it to the position of the OPC 
Server.

4. Click "OK" to confirm the replacement of the OPC Server.

5. Save and compile your changes.

6. Select the "OPC Server" object in the rack.

7. Select the menu command Station > Properties.

8. Open the "SNMP" tab.

9. Click the "Export Tags for WinCC" button.

10.Select the Station > Save and Compile menu command.

11.Repeat steps 1 to 5 if using the MS Server in a redundant MS multiple station system.

12.Perform the following actions if the project contains field devices that were configured in 
SIMATIC PDM:

– Select the Options > SIMATIC PDM > Settings command in SIMATIC Manager.
The "SIMATIC PDM settings" dialog box opens.

– Select the "Maintenance Station" tab.

– Enter the file path of the PCS 7 project.

– Click "OK".

Updating SIMATIC PDM
Check which version of SIMATIC PDM has been approved for the updated PCS 7 plant.

Install SIMATIC PDM. Refer to the PDM Readme.
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The SIMATIC PDM-related project data is updated automatically after the project is opened 
in SIMATIC Manager. 

Note

During the update, new PLT IDs are assigned to the configured ASSETMON objects. Then, 
perform the following steps:
● Adapt these PLT IDs to the corresponding ASSETMON block instances.
● Compile the automation systems.
● Create the diagnostics screens again.
● Compile the corresponding operator stations.

Note
Requirement for displaying PDM data on the engineering station 

Note that you need to start the SIMATIC PDM ASSET service in the SIMATIC PDM ASSET 
Service Manager on the engineering station once manually. You will find the SIMATIC PDM 
ASSET Service Manager in the information area of the toolbar of your operating system.

7.6.3 How to update the diagnostics settings

Introduction
If you operate a PCS 7 Maintenance Station in your project, various settings must be migrated 
when upgrading to the current PCS 7 version.

Requirement
The OS project editor is running. It is not necessary to make any settings in the OS project 
editor.

Note
If the project was retrieved

If the project was retrieved to update the software, additional steps are necessary when you 
use a Maintenance Station:
1. Compile the hardware configurations of all automation systems.
2. Compile all automation systems with the option "Update module drivers". 
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Procedure
1. Select the multiproject in the plant hierarchy.  

2. Select the Options > Plant Hierarchy > Settings... menu command.
The "Customize Plant Hierarchy" dialog opens.

3. Select the "Migrate diagnostic settings" check box.

Note

This field is grayed out if this action is not required.

4. Click "OK".

Note

If you want to restore the project-specific changes, you have to adapt the automatically 
created overview screen. After the "Migrate diagnostic settings" function, copy the project-
specific changes from the renamed overview screen of the project that is to be updated to 
the current overview screen.

7.6.4 How to update the diagnostics screens
Updating the diagnostics screens has the following effects:

● Pictures in the AS objects area
Block icons that represent racks will be repositioned in the picture.
You can move the block icons to different positions.

● Pictures in the PC Stations and network objects area
The block icons will possibly overlap in these pictures.
You can move the block icons to different positions.

Requirements
● A backup copy of the diagnostics screens with project-specific adaptations has been 

generated.

● An asset ID has been assigned to each AS and PC station in HW Config.

● Diagnostics settings are updated.
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Procedure
1. Select the multiproject (project) in the plant hierarchy.

2. Select the Options > Plant Hierarchy > Create/Update Diagnostics Screens menu 
command. 
Update the diagnostics screens. You can find information on this in the Process Control 
System PCS 7; Operator Station Configuration Manual.

Note

The diagnostics screen for the AS detail view is automatically created new for fault-tolerant 
automation systems.
● The previous diagnostics screen is saved with a name extension to the "Graphics" folder 

of WinCC Explorer.
● If you want to restore project-specific changes, you have to adapt the automatically 

created diagnostics screen. After the "Create/update diagnostics screens" function, 
copy the project-specific changes from the previous diagnostics screen to the current 
diagnostics screen.

3. Compile the OS of the Maintenance Station.

4. Update the server data of the MS server.

5. Download the MS server.

Additional information
For information on options for accessing maintenance functions, refer to the following 
documentation:

● You can find a description of working with the Maintenance Station in process mode in the 
Process Control System PCS 7; OS Process Control function manual.

● Configuration manual Process Control System PCS 7; Operator Station
● Function manual Process Control System PCS 7; Maintenance Station

7.7 Additional Options

7.7.1 Overview of additional options

Overview of the procedure   

Step Action ES OS serv‐
er

OS cli‐
ent

AS

22 Updating the PCS 7 Web Option for OS (Page 73) X X   
23 Updating PCS 7 Components that Use SIMATIC Logon 

Services (Page 73) 
X X X  
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7.7.2 Updating the PCS 7 Web Option for OS

Requirement
In order to utilize the full functional scope of the PCS 7 Web Option for OS, you may only use 
blocks from the current PCS 7 library in the PCS 7 project.       

Procedure
● You update the OS Web server, an OS client, similar to an OS client.

● The process pictures that will be opened on a Web client must be "published" again.

Additional information
For more information, refer to the Process Control System PCS 7; Web Option for OS Manual. 

7.7.3 Updating PCS 7 Components that Use SIMATIC Logon Services

Additional information 
● Refer to the respective components that use SIMATIC Logon to find detailed instructions 

about the setup, configuration and changes needed for SIMATIC Logon.

● You can find basic, generally applicable information about SIMATIC Logon in the online 
help for SIMATIC Logon.

7.8 Work for the OS in SIMATIC Manager

7.8.1 Overview of compiling

Overview of the procedure     

Step Action ES OS serv‐
er

OS cli‐
ent

AS

24 Compiling the OS (Page 74) X    
25 Adapting the OS client (Page 75) X    
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7.8.2 How to Compile the OS

Note
Using the template picture for V7 or V8 block icons

You can use the "@PCS7TypicalsAPLV7.pdl" template picture if the following requirements 
are met:
● You do not want to use new functions from PCS 7 V8.1
● You do not want to use the latest block icons from the "@PCS7TypicalsAPLV8.pdl" 

template picture for updating the picture objects, for example, because the icon sizes have 
been changed

The "@PCS7TypicalsAPLV8.pdl" file needs to be renamed or deleted in order to use the 
"Create/Update Block Icons" function and compiling processes of this 
"@PCS7TypicalsAPLV7.pdl" template picture in subsequent executions. Renamed files must 
not start with the following characters:
● @PCS7Typicals
● @TemplateAPL

Recommendation:

Always use the same versions of the "@TemplateAPL<Version>.pdl" and 
"@PCS7TypicalsAPL<Version>.pdl" files for a PCS 7 project.

Overwriting default settings

User scripts and modified properties of the picture objects are overwritten by the default 
settings.

Requirements
● The PC station has been configured.

● The configuration in CFC and SFC has been completed.

Note

If you have changed unit and operator texts of the block types in the master data library, 
be sure to set your default language as the "Language for display devices".

Procedure

Note

You can find additional information about the compilation options in the configuration manual 
Process Control System PCS 7; Engineering Station.
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1. Select the object (multiproject, project, station) in SIMATIC Manager that you wish to 
compile or compile/download.

2. Select the PLC > Compile and download objects command in SIMATIC Manager.
The "Compile and download objects" dialog box opens.

3. Open the tree structure.

4. Activate the check box in the "Compile" column for all objects that you want to compile.

5. Click the "Operating State" button and check the operating states of your objects (RUN, 
activated, etc.) so that you can make the correct settings for compilation.

6. Select the OS that you wish to compile.

7. Click "Edit".
The "Settings: Compile OS ... Areas ..." dialog box opens.

8. Click "Next".
The "Settings: Compile OS ... Network Connections ..." dialog box opens.

9. Click "Next".
The "Settings: Compile OS ... Compilation Data and Scope of Compilation" dialog box 
opens.

10.In the "Scope" group, activate the "Entire OS" and "With memory reset" check boxes.

11.Click "Apply".

Note

Once you have completed your settings for compiling an operator station, please wait until 
the compilation settings have been saved and the download dialog box appears. 

12.Make the required settings for the individual objects.

13.Click "Help" in the dialog box for detailed information about the settings.

14.Click the "Start" button. 
Compilation starts.

15.Follow the instructions on the screen.

16.If you wish to see a log of the compilation once it is complete, click the following buttons in 
the "Display Log" area:

– "Single object": The detailed compilation log of the selected OS is displayed.

– "All": Displays the results of all compilations (without details).

7.8.3 How to make adaptations for the OS clients

Note

The following procedures musts be carried out for each OS server if there are several OS 
servers present in the project.   
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Procedure
1. In the component view of SIMATIC Manager, select the OS client project on the PC station.

2. Select the menu command Options > OS > Assign OS Server....
The "Assign OS Server ..." dialog box opens.

3. In the list of OS servers, check for the server whose data you would like to view on this 
client, to ensure the check boxes for this OS server have been selected.

4. Click "OK".

5. In the component view of SIMATIC Manager, select the "OSC" object of the OS client.

6. Select the menu command Edit > Open Object.
WinCC Explorer opens.

7. Select the menu command Configure in the shortcut menu of the "Server data" editor in 
order specify the preferred server if there are redundant OS servers.

8. Select the menu command standard server in the shortcut menu of the "Server data" editor 
in order to specify a standard server for interrupts and SSM.

9. Select the OS Project Editor and select the menu command Open in the shortcut menu.

10.Activate the "Complete configuration ..." check box on the "General" tab.

11.Click the "Layout" tab.

12.Select the required layout and the monitor configuration.

13.Click the "Basic Data" tab. Make the necessary settings.

14.Click "OK".

15.Close the dialog box.
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Downloading of Target Systems 8
8.1 Downloading of Target Systems

Once you have updated your PCS 7 project offline, you must download the changes to the 
target systems.   

NOTICE

Updating a redundant OS in runtime 

Updating a redundant OS during operation (according to the manual Process Control System 
PCS 7, Fault-tolerant Process Control Systems; Guidelines for updating a redundant OS in 
runtime)

If you update a redundant OS during operation, do not load the AS until phase 3 (in step 6 of 
the Fault-tolerant Process Control Systems manual).

Requirement
● The network addresses and network settings of the PC stations are configured.

● The configuration of the PC stations match in HW Config and in the Station Configuration 
Editor.

● The PC station has been configured.

● The configuration and connection data of all stations has been downloaded via NetPro.

Procedure
1. Check the setting of the access points on each PC station (locally).

In the submenu SIMATIC > SIMATIC NET of the Windows Start menu, select the menu 
command Configuration Console.

2. You can successively download all target systems systematically and automatically. In 
SIMATIC Manager, select the menu command PLC > Compile and Download Objects. 
You will find more information on loading options in the configuration manual Process 
Control System PCS 7; Engineering Station.
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Activate the operator stations 9
9.1 Overview of activating the operator stations

Introduction
Sequence for activating process mode (Runtime):     

● Process Historian (if available in the project)

● Master server (OS server)

● Standby server (redundant OS server)

● OS clients

Overview of the procedure

Step Action ES OS serv‐
er

OS cli‐
ent

AS

27 Checking the settings of the OS Servers (Page 79)  X   
28 Checking the settings on the OS Clients (Page 80)   X  

9.2 How to Check the Settings on the OS Servers

Introduction
Before activating the projects downloaded to the various OS servers, you need to check some 
of the settings in each OS as a safety precaution.   

Requirements
● The PCS 7 OS is open in WinCC Explorer.

● The following applies if a Process Historian is in the project:

– The Process Historian has the "Active" status.

– The "PH-Ready Configuration" is performed on each OS server.

Procedure
1. Open the "Redundancy" editor in WinCC Explorer.

2. Check all settings.

3. Click "OK".
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4. Open the "Time Synchronization" editor in WinCC Explorer.

5. Check all of the settings in the dialog box.

6. Click "OK".

7. Repeat steps 1 through 6 for the second OS server and all other redundant OS servers.

Note

If you have installed a new operating system or have changed the settings, restart the 
computer.

8. Activate process mode on the OS servers.

Note
Process Historian

After activating process mode, the OS server automatically connects to the Process Historian. 
● For non-redundant systems, the data is sent to Process Historian starting with the activation 

of the process mode. 
● For redundant systems, only data from the current master is sent to the Process Historian.

You can now import data segments created before the software update using Process Data 
Migrator on the Process Historian. 
You can find information on this in the section "How to migrate the archives in the Process 
Historian (Page 85)".

9.3 How to Check the Settings on the OS Clients
Before activating the projects downloaded to the various OS clients you must check some of 
the settings in each OS.  

Requirement
● The PCS 7 OS is open in WinCC Explorer.

Procedure
1. Open the "Time Synchronization" editor in WinCC Explorer.

2. Check all settings.

3. Click "OK".

4. Repeat steps 1 through 3 for the other OS clients.

5. Activate process mode on the OS clients.
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Updating SIMATIC BATCH stations 10
Introduction

Note

Please observe the following when updating the software from PCS 7 V7.1 SP3 (with SIMATIC 
BATCH) to PCS 7 V8.1 (with SIMATIC BATCH):
● To save the project "with reorganization", you first need to manually replace the BATCH 

application in the PC stations in HW Config.
● Set the BATCH Start Coordinator to "Manual" start mode before you update the software.

It is essential that you observe these points when you prepare the software update. You can 
find additional information on this in the section "Overview of preparations (Page 34)". 

For more information on updating SIMATIC BATCH, refer to the following documentation:   

● SIMATIC BATCH Readme; Part B, Installation

● Manual Process Control System PCS 7; SIMATIC BATCH
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Updating SIMATIC Route Control stations 11
11.1 Updating SIMATIC Route Control

Updating SIMATIC Route Control
You can find information about this in the Process Control System PCS 7; SIMATIC Route 
Control documentation.

Note
STOP of automation system required

SIMATIC Route Control V8.0 SP1 requires functions of libraries from PCS 7 V8.0 SP1. The 
automation system must be in STOP in order to load these libraries.
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Migration of archive data from a central archive server 
(CAS) 12
12.1 Archive migration at a glance

Overview of the procedure

Step Action ES OS serv‐
er

OS cli‐
ent

AS

31 Migrating archive data from CAS (Page 85) Only for projects in which the central 
archive server (CAS) has been re‐
placed with a Process Historian.

Reporting system for archive data
The Information Server is the reporting system for the Process Historian. Report templates 
and automatic logs from archives must be created again.

12.2 How to migrate the archives in the Process Historian

Requirements
● Central archive server as of PCS 7 V7.0 (Storage Plus V1.2)

● All archives are swapped out under PCS 7.      

● The Process Historian is created and configured in the PCS 7 project.

● The Process Historian was started before the OS servers.

● The database of the central archive server is accessible from the Process Historian.

● The OS servers are in process mode. The connection to the Process Historian has been 
established.

● The current data is archived on the Process Historian.

Archives on OS servers
The last archive segments of the OS servers are no longer swapped out to the CAS by the 
OS servers. You must import these archives directly from the OS servers in the Process 
Historian. 

Keep in mind that this import must happen rather timely, depending on the setting of the OS 
server circulating archives. 
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Recommendation: Start by importing those archive segments of the OS servers that were not 
swapped out to the CAS.

Procedure
1. On the CAS, configure sharing for access to CAS archives for the Process Historian.

2. Configure a network drive for access to CAS archives on the Process Historian.

3. Start the migration tool. Follow the instructions. 
You can find detailed information on this in the documentation SIMATIC; Process Historian; 
Process Historian Administration.

4. Select the CAS database of the server.

5. Assign the data to the subproject.

6. Start the migration process.

Note

All CAS databases are migrated in the background during operation.

You must perform the data migration for each OS subproject.

Additional information
You can find detailed information on this in the documentation SIMATIC; Process Historian; 
Process Historian Administration.

Migration of archive data from a central archive server (CAS)
12.2 How to migrate the archives in the Process Historian
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