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Preface 1
Purpose of this documentation

This documentation provides a comprehensive overview of the steps you must take to adapt 
your existing PCS 7 process control system to the new SIMATIC PCS 7 version 8.0. It supports 
you in updating PCS 7 projects and guides you through installation and commissioning of the 
current software.

The contents of the documentation are directed toward service personnel, commissioning 
personnel, and experienced PCS 7 users with the necessary system knowledge. The 
documentation provides instructions for carrying out the software update.

Refer to the documentation for specific products for information regarding the handling of these 
products. 

Options for accessing PCS 7 documentation
 

 Note
PCS 7 Readme

The information given in the PCS 7 Readme on the Internet takes precedence over all the 
PCS 7 manuals. Please read this PCS 7 Readme carefully; it contains important information 
and amendments on PCS 7.
● The PCS 7 Readme on the Process Control System; SIMATIC PCS 7 DVD includes 

important notes on PCS 7 and takes precedence over the documentation supplied for 
PCS 7.

● Following the installation of PCS 7, you can find documents such as Process Control 
System PCS 7; PCS 7 Readme and What's New in PCS 7? via the submenu SIMATIC > 
Product Information > <Language>.

 

As of PCS 7 V8.0, you receive basic PCS 7 system documentation with the Process Control 
System; SIMATIC PCS 7 DVD. 

The PCS 7 Internet site http://www.siemens.com/pcs7-documentation (http:\
\www.siemens.com/pcs7-documentation) provides convenient access to the complete PCS 7 
documentation. You can find the following for current PCS 7 versions:

Software update with utilization of new functions
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● In the section "Hardware manuals for SIMATIC PCS 7 ..."

– The manuals for components approved for a PCS 7 version

● In the section "Software manuals for SIMATIC PCS 7 ..."

– The complete system documentation

– The separate setup program for PCS 7 documentation and the PCS 7 help system for 
download. After the installation of the setup program, you will find the documentation at 
the following locations on the Engineering Station:
- as online help (CHM file) for the SIMATIC Manager application
- as PDF file in the Windows Start menu with the SIMATIC documentation

– The complete documentation for PCS 7 as a Manual Collection

Documentation for the Software Update
You will find all documentation on the topic of "Software update" on the Internet. 

Documentation Contents
Manual Software Update Without 
Utilization of the New Functions

Describes the procedure for the software update of PCS 7 
version 7.1 SP3 or higher to V8.0 Update 1 without utilization 
of the new functions.

Manual Software Update with Utilization 
of the New Functions

Describes the procedure for the software update of PCS 7 
version 7.1 SP3 or higher to V8.0 Update 1 with utilization of 
the new functions.

Additional documentation for the software update
Additional information from the following documentation is required for carrying out the 
software update:

Documentation Contents
Manual Process Control System PCS 7; 
Service Support and Diagnostics

Ensuring the Availability of a PCS 7 System; contains 
information on creating backups and how to perform 
firmware updates.

Manual Process Control System PCS 7;
PC Configuration and Authorization

PCS 7 PC - Hardware and Installation;
Windows settings and tools; 
Software packages and authorizations required.

Configuration manual Process Control 
System PCS 7; Engineering System

Guide to configuration steps in SIMATIC Manager, CFC, 
SFC, NetPro

Configuration manual Process Control 
System PCS 7; Operator Station

Guide to configuration steps in WinCC

Manual Process Control System PCS 7; 
Fault-tolerant Process Control Systems

Guide to configuration steps for fault-tolerant process 
control systems

Preface
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Documentation Contents
Documentation 
Process Control System PCS 7;
Released Modules

All modules released for SIMATIC PCS 7 are listed 
together with the following information:
● Product designation
● Order number
● Firmware version
● Brief description

Online Help for
WinCC Information System

Describes the updating of WinCC projects.

Manual Process Control System PCS 7; 
Web Option for OS

Describes the installation and use of the Web Option for 
OS in PCS 7

Process Control System PCS 7; 
OpenPCS 7 Manual

Describes how an OPC A&E server with hierarchical 
access is used in PCS 7 systems

Function manual Process Control System 
PCS 7;
Fault-tolerant Process Control Systems

Describes the principles of use of fault-tolerant 
(redundant) components in SIMATIC PCS 7.

SIMATIC manual S7 F/FH Automation 
Systems

Readme for SIMATIC S7 F Systems V7.1

Describes the configuration and programming of S7 F/FH 
failsafe systems using S7 F systems.
Contains important information which must be taken into 
account when installing and using the S7 F system 
optional package in PCS 7.

What's new? Information on the differences between this version and 
the previous version of PCS 7

Validity of the documentation
This documentation is valid for the software package Process Control System; SIMATIC PCS 7 
DVD V8.0 including Update 1.

Required Basic Knowledge
General knowledge in the area of automation engineering and basic knowledge of PCS 7 is 
required to understand this documentation. You also need to know how to use PCs with 
Windows operating systems.
The following documentation provides basic information on working with PCS 7:

● Configuration manual Process Control System PCS 7; Engineering System
● Configuration manual Process Control System PCS 7; Operator Station
● Getting Started Process Control System PCS 7; Part 1

Software update up to PCS 7 V7.1.3
Up to PCS 7 version 7.1.3, the update process for all projects comprises a number of steps. 
You will receive the necessary instructions with the associated software packages. 

Preface
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Conventions
In this documentation, the designations of elements of the user interface are specified in the 
language of this documentation. If you have installed a multi-language package for the 
operating system, some of the designations will be displayed in the base language of the 
operating system after a language switch and will, therefore, differ from the designations used 
in the documentation.

Changes compared with previous versions
Below, you will find an overview of the most important changes compared with previous 
versions:

● As of PCS 7 V8.0 Update 1

– Use of PCS7 Library V6.1 SP1 Update 17. This library allows the software update of 
projects from PCS 7 V6.1 SP4 to PCS 7 V8.0 Update 1 without an automation system 
STOP, although the project must first be updated to PCS 7 V7.1 SP3.

● As of PCS 7 V8.0:

– Use of the Advanced Process Library (APL) V8.0 as standard library for configuration.

● PCS 7 V7.1 or higher: 

– PCS 7 setup automatically installs the necessary hotfixes and SQL server.

– Use of OS clients as maintenance clients (default configuration for an OS client in terms 
of the maintenance server)

– You can find information on Microsoft Windows settings and security settings in the 
whitepaper SIMATIC Process Control System PCS 7; Security Information Note 
This can be downloaded via the Internet at Customer Support (http://
www.siemens.automation.com/service) under the following entry ID 26462131 (http://
support.automation.siemens.com/WW/view/en/26462131)

– Information on virus scanners can be found in the whitepaper SIMATIC Process Control 
System PCS 7; Security Information Note; Setting Virus Scanners
This can be downloaded from the Customer Support (http://
www.siemens.automation.com/service) Web pages under the following entry number 
26366540 (http://support.automation.siemens.com/WW/view/en/26366540).

– The architecture for SIMATIC PDM has been modified.
For more information on this, refer to section "How to configure the SIMATIC PDM 
Server (Page 59)".

See also
Licensing with the Automation License Manager (Page 15)

How to Prepare the Software Update with Central Archiving (Page 23)

How to Configure Extensions for Online Trend Control (Page 70)

Preface
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Introduction 2
2.1 Selecting the Correct Documentation

Decision Process
The selection and use of the correct documentation depends on the comprehensiveness of 
your software update. the current status of the software and any boundary conditions that may 
exist.           

The following flow chart shows you the documentation to use when updating a PCS 7 plant.

PCS 7 Fault-tolerant Process 

Control Systems

2.2 General Requirements
The following requirements must be met regardless of whether you execute the software 
update with or without the utilization of new functions:   

Software update with utilization of new functions
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General Requirements for Updating the Software
● Your PC hardware must meet the hardware requirements for PCS 7 V8.0 .

For more information, refer to the pcs7-readme documentation on your Process Control 
System; SIMATIC PCS 7 DVD.

● A PC on which the PCS 7 software is to be installed must meet one of the following 
requirements:

– The PC can access a DVD drive via a network.

– It has its "own" DVD drive (example: USB DVD drive).
 

  Note

You must complete the software update before beginning with any additional changes 
to the configuration.

 

● The project must be updated on PCS 7 V7.1 SP3 because only the AS blocks of the 
following PCS 7 versions can be operated and monitored with the PCS 7 V8.0 libraries:

– PCS 7 V7.1 SP3 

– PCS 7 V8.0

2.3 Important Information for Updating Software with Utilization of New 
Functions

Requirements for Performing a Software Update
● The software update with utilization of new functions requires that the CPU be switched to 

STOP mode.

● The manual contains some sections that are not listed in the overview. Observe the 
information provided in these sections when updating the software and check whether this 
information is relevant to your PCS 7 system.

● The project must be fully compatible with a project that was configured in PCS 7 V7.1.3 or 
higher. Pay particular attention to the following if you have carried out earlier updates 
without utilization of new functions.

● If you switch to the Windows 7/Windows Server 2008 R2 operating system, you will have 
to update the version of the communication components in the Station Configuration Editor 
and HW Config. The version depends on the version of SIMATIC NET installed on the target 
station.

– SIMATIC NET V8.1.x is installed as of Windows 7 and Windows Server 2008 R2 (e.g. 
for CP 16xx -> SW 8.1.1).

– The CP 1613 A1 communication processor is no longer supported by PCS 7 on 
operating systems as of Windows 7/Windows Server 2008.

Introduction
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● PCS 7 can only be executed on the operating systems listed in the PCS 7 ‑ Readme file. 
This file contains additional information pertaining to the operating systems and necessary 
service packs.
The operating system is required for the following PC stations:

– Engineering station (also for installation of SIMATIC PDM)

– Single station system (redundant and non-redundant) for OS, SIMATIC BATCH, 
SIMATIC Route Control

– Clients (OS, SIMATIC BATCH, SIMATIC Route Control, OpenPCS 7)

The Server operating system is required for the following PC stations:

– Server (redundant and non-redundant) for OS, SIMATIC BATCH, SIMATIC Route 
Control

– Server for Web Option for OS

– Server for engineering station with multiproject (central data store) for engineering with 
multiple engineering stations

● If using ultra-precise time stamping in PCS 7, you should configure it in accordance with 
PCS 7 V8.0.

● When updating the BIOS or the components' firmware, we recommend that these 
components be completely separated from any connected networks.

● If PCS 7 functions require certain modules and a firmware update cannot be performed, 
these modules must be replaced.

● In an AS, the blocks of all PCS 7 libraries for a PCS 7 version can be operated together.

● The software update of password-protected projects requires SIMATIC Logon on an ES.

● For projects with activated FDA access protection for WinCC tag export, you have to open 
the WinCC  project in SIMATIC Manager beforehand.

Setting up the passivation reaction of the CPU modules       
The passivation reaction of the modules depends on the library used:

● Starting with the "Redundant IO" V5.0 library, this setting is defined for specific channels.

● The "Redundant IO" V4.0 library allows you to select a channel-specific setting, depending 
on the module used.

● The "Redundant IO" V3.0 library only allows you to select module-specific settings.

The "Redundant IO" library V5.0 or higher allows you to automatically identify the possible 
passivation reaction for a module, based on the configured hardware. The passivation reaction 
is automatically adjusted during generation of the user program to suit the reaction with the 
smallest number of passivated module channels.
for further information, refer to the documents in Process Control System PCS 7; Redundant 
process control systems.

Time synchronization in a PCS 7 system
Following the software update, the time synchronization of all OS components corresponds to 
the PCS 7 V8.0 standard (not V5-compatible mode).

Introduction
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Result of the Software Update
● Following the software update with utilization of new functions, an updated PCS 7 project 

will behave in a similar way to a project created in PCS 7 V8.0 Update 1.

2.4 Information on the Operating System

Recommendation
In Windows domains, too, you must always use the operating systems approved for PCS 7 if 
you want to connect your system to other PCs via Intranet or Internet, or if using the PCS 7 
Web Option for OS. For more information on the approved operating systems, refer to the 
PCS 7 Process Control System; PCS 7 Readme documentation.

Naming conventions for a PC station name and its computer names
Select short and descriptive computer names that provide some information about the function 
of the PC station in the overall system.           

● The name of a PC must be set before PCS 7 is installed.

● The computer name starts with a letter.

● The computer name contains only uppercase letters and numbers.

● The first 12 characters (max. 15 characters) in the computer name are unique.
 

  Note

When using the Windows 7 and Windows Server 2008 operating systems, verify that the 
naming conventions for computer names have been adapted in accordance with 
RFC1123. However, a dash "-" character in the computer name is invalid in PCS 7!

 

● The following names must be identical when you configure an OS or BATCH Server and 
an Engineering Station:

– Computer name

– Name of the PC Station (in the PCS 7 project)
 

  Note

Additional naming conventions for projects are specified in:
● WinCC Information system "Working with projects > Appendix > Invalid characters"
● C:\Program Files\SIEMENS\WINCC\Documents\English\Projects.pdf
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2.5 Information on Products from the PCS 7-Add On Catalog

Important Information
If you used PCS 7 add-on products (software packages or hardware components) in your 
process control system, contact your SIMATIC PCS 7 representative

2.6 Licensing with the Automation License Manager

Managing the License Keys
Both license keys and authorizations can be transferred using the Automation License 
Manager. In the following, the term "license key" is always used even when a product uses 
the old license scheme based on authorizations.

Different types of licenses are used in the Automation License Manager.

Each license consists of a basic license type and a license type.

Licensing levels     
You can find an overview of the licenses and quantity structures in the ST PCS 7 catalog or 
on the Internet at Technical Support (http://www.siemens.com/automation/service):

● Keyword: PCS7 licenses and quantity structures:
Process Control System SIMATIC PCS 7; Licenses and Quantity Structures documentation.

Additional information
● Manual Process Control System PCS 7; PC Configuration and Authorization
● Online help for Automation License Manager

Introduction
2.6 Licensing with the Automation License Manager
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Overview of Upgrade Steps 3
3.1 Information about software update procedure

-The following tables provide an overview of all of the necessary steps for updating software 
with utilization of new functions.    

Rules to Follow Based on the Tables
● Use these tables as guidelines for systematically carrying out all of the updating steps in a 

sequence.
 

  Note

The exact sequence of configuration steps specified in this documentation must be 
followed in order to carry out the software update.

 

● You will receive information for every step as to where you must carry out the configuration 
work.

● If you do not require some of the new PCS 7 functions, you do not need to activate them. 
It is possible to activate them later. However, we recommend the complete upgrade of 
functions described in this document.

Exchanging Data Via OPC A&E
If exchanging data in the PCS 7 system by means of OPC A&E, note the information in the 
Process Control System PCS 7; OpenPCS 7 documentation when updating the software.

3.2 Overview of the Procedure
The following is a general overview of the procedure for updating software. This document 
contains comprehensive instructions on every step in the table below.     

 

 Note

You must complete the software update before beginning with any additional changes to the 
configuration.

 

Recommendation:

Finish updating the engineering system and the project before you begin to update the other 
PC stations.

Software update with utilization of new functions
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Legend for overview
X - perform this step at the relevant stations.

X1 - to be performed only for the central archive server

X2 - to be performed only on the StoragePlus server for central archiving

Overview of the procedure

Step Action ES OS 
Server

OS 
Client

AS

Adaptations for central archiving
1 Determine archive server configuration data (Page 22)  X1, X2   
2 Prepare for the software update on the central archive 

server (Page 23) 
 X1, X2   

3 Detach linked archive segments (Page 23)  X1, X2   
4 Back up archives from the central archive server 

(Page 24) 
 X1, X2   

Backing up the PCS 7 project
5 Back up PCS 7 project data (Page 26) X    
6 Back up the libraries you created (Page 28) X    
7 Export operator and display texts (Page 30) X    
8 Check the CPs and network cards (Page 31) X X X  
9 Prepare projects with high precision time stamping 

(Page 32) 
(only required for projects with high-precision time 
stamping)

X    

10 Back up the license keys and authorizations (Page 33) X X X  
Update of Hardware
11 Prepare for replacing hardware (Page 36)    X
12 Update and replace hardware (Page 37)    X
Installation and settings on the ES and OS
13 Prepare the PC station (Page 39) X X X  
14 Install the PCS 7 software (Page 40) X X X  
15 Set the operating mode "configured mode"/"PG mode" 

(Page 43) 
X X   

16 Configure and download the PC stations (Page 44) X X X  
17 Install additional PCS 7 libraries (Page 48) X    
18 Install additional non-standard libraries (Page 51) X    
19 Installing additional faceplates on the OS (Page 49)  X   
General adaptations in the project
20 Updating the OS with the Project Migrator (Page 55) X    
21 Check PH consistency (Page 55) X    
Adaptations in HW Config
22 Configuring replaced hardware (Page 57) X    
23 Setting the CPU properties (Page 57) X    

Overview of Upgrade Steps
3.2 Overview of the Procedure
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Step Action ES OS 
Server

OS 
Client

AS

24 Updating the hardware configuration (Page 58) 
(only for projects with SIMATIC PCS 7 BOX RTX or 
SIMATIC PCS 7 AS RTX)

    

25 Configuring the address for the PDM Server (Page 59) 
(only for projects with SIMATIC PDM V7.0)

X    

Adaptations in NetPro and conversion of the CFC/SFC charts
26 Checking and adapting the connection data in NetPro 

(Page 61) 
X    

27 Converting the CFC and SFC charts (Page 62) X    
Steps for updating blocks
28 Copy objects from other libraries into the master data 

library (Page 67) 
X    

29 Complete the master data library (Page 68) X    
30 Synchronize blocks (Page 72) X    
31 Include event texts (Page 74) X    
32 Import operator texts (Page 75) X    
33 Adapt operator texts (Page 75) X    
34 Configure limit values for online trend control (Page 70) X    
35 Update block types (Page 76) X    
36 Update SFC block types (Page 78) X    
37 Compile CFC charts (Page 80) X    
Adaptation of OS-relevant settings
38 Synchronize OS basic pictures, local computer actions, 

and faceplates (Page 81) 
X    

39 Update picture objects (Page 83) X    
Adaptations for the Maintenance Station
40 Changing the OPC Server and adapting the SNMP 

configuration (Page 85) 
X    

41 Updating the diagnostics settings (Page 87) X    
42 Updating the diagnostics screens (Page 88) X    
Additional options
43 Updating the PCS 7 Web Option for OS (Page 89) X X   
44 Updating PCS 7 Components that Use SIMATIC Logon 

Services (Page 90) 
X X X  

Work for the OS in SIMATIC Manager
45 Specifying the compilation mode (Page 91) X    
46 Compiling the OS (Page 92) X    
47 Adapting the OS Client (Page 94) X    
Adjustments when using the Advanced Process Library V8.0
48 Creating the project library (Page 100) X    
49 Copying blocks to the project library  (Page 101) X    
50 Creating a reference list  (Page 102) X    
51 Replacing APL blocks (Page 102) X    

Overview of Upgrade Steps
3.2 Overview of the Procedure
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Step Action ES OS 
Server

OS 
Client

AS

52 Copying blocks to the block folder (Page 104) X    
53 Importing blocks to the chart folder (Page 104) X    
54 Interconnecting block I/Os (Page 105) X    
Adjustments for the central archive server
55 Adapting the central archives (Page 107)  X1, X2   
Downloading to target systems
56 Downloading of Target Systems (Page 109) 

For more information on the download options, refer to 
the Process Control System PCS 7; Engineering 
Station Configuration Manual.

X X X X

Overview of activating the operator stations
 Sequence for activating operator stations

The following sequence applies when activating process mode (runtime):
● Master Server (OS Server)
● Standby server (redundant OS Server)
● OS clients

57 Checking the settings of the OS Servers (Page 111)  X   
58 Checking the settings on the OS Clients (Page 112)   X  
SIMATIC BATCH software update
59 Updating SIMATIC BATCH (Page 113) Only for projects with SIMATIC 

BATCH
SIMATIC Route Control software update
60 Updating SIMATIC Route Control (Page 115) Only for projects with SIMATIC 

Route Control

Overview of Upgrade Steps
3.2 Overview of the Procedure
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Preparing for the software update 4
4.1 Adapt the central archive server

4.1.1 Overview of Adaptations for Central Archiving

Introduction
If archive data is to be available after the software update, you must perform the steps listed 
below.       

 

 Note

The steps in this section apply only if one of the following servers is used for archiving in the 
PCS 7 project:
● Central archive server
● StoragePlus server (only recommended for smaller systems)

 

Preparation time
Start with the preparations for updating the Central Archive Server or StoragePlus Server 
before you start updating the PCS 7 project.

The amount of time you have for updating the archive server is the amount of time in which 
archive data can be stored in the short-term archive on the OS servers. The time will depend 
on the following system-specific features:

● Available memory for the short-term archive of the OS server

● Scope defined for the short-term archive of the OS server

● Available memory for page files

Overview of the Procedure

Step Action ES OS 
server

OS 
client

AS

1 Determine archive server configuration data (Page 22)  X1, X2   
2 Prepare for the software update on the central archive 

server (Page 23) 
 X1, X2   

3 Detach linked archive segments (Page 23)  X1, X2   
4 Back up archives from the central archive server 

(Page 24) 
 X1, X2   

Software update with utilization of new functions
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X1 - to be performed only for the central archive server

X2 - to be performed only on the StoragePlus server for central archiving 

4.1.2 How to determine the configuration data on the Archive Server

Introduction
You need this information when you reinstall the archive server and do not wish to make any 
configuration changes.   

Requirement
Before you run the software update, perform these steps directly on the archive server (Central 
Archive Server (CAS), or StoragePlus Server).

Determining the database name, database path and archive share name
1. Use Windows Explorer to search for the "C:\Program Files\SIEMENS\StoragePlus

\Common" folder.

– When you have found the folder, look for the "StoragePlus.config" file in the detail view. 
Continue editing with Step 6.

– If you do not find the folder, perform the following steps.

2. In Windows Explorer, click "Search".

3. In the "Find the Following Files and Folders:" input box:" enter the "StoragePlus.config" 
configuration file.

4. In the "Search in" drop-down list: select the "Local hard drives (...)" setting.

5. Click "Find Now".
The "StoragePlus.config" configuration file is searched for.
In the case of a standard installation, the configuration file will be located in folder "C:
\Program Files\SIEMENS\StoragePlus\Common".

6. Select the "StoragePlus.config" file from the list.

7. In the shortcut menu, select the menu command Open with > Notepad.

8. Search the entries for the following configuration information:

– Database (<Database> "name of the database" <Database>)

– DatabasePath (<Database> "path of the database" <Database>)

– Logpath (<Logpath> " path of the data log" <Logpath>)

– ArchivePath (<ArchivePath> "directory of the archive" <ArchivePath>)

9. In the Windows Control Panel, double-click the "Administrative Tools" icon and then 
"Computer Management".

Preparing for the software update
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10.In the tree view, select the folder System > Shared Folders > Shares.

11.Look for the archive path in the list in the "Shared Path" column. 
The archive share name for the OS archives is displayed in the "Shared Folders" column 
in this line.

4.1.3 How to Prepare the Software Update with Central Archiving

Requirement
Before you run the software update, perform these steps directly on the archive server (Central 
Archive Server (CAS), or StoragePlus Server).       

Lock Archiving
To prevent new data from being entered in the central archive server, the archive server can 
be locked for archiving. The data is then saved on the OS server. 

1. In the Windows Control Panel, double-click the "Administrative Tools" icon and then 
"Computer Management".

2. In the tree view, select the folder System > Shared Folders > Shares.

3. Select the archive path from the list.

4. Select the menu command Action > Clear Share.
The "Shared Folders" dialog box is displayed.

5. Click "Yes".
 

 Note

The CAS downtime must not exceed the shortest circular archive time of the OS servers.
 

4.1.4 How to Detach Attached Archive Segments on the Central Archive Server

Requirements 
● Before you run the software update, perform these steps directly on the archive server 

(Central Archive Server (CAS), or StoragePlus Server).   

● You are authorized to access the Windows user interface on the CAS.

Preparing for the software update
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Procedure
1. In the Windows Start menu, select the "Administration Console" command from the 

SIMATIC > StoragePlus submenu.

2. In the detail view, click "Detach".
The catalog of all linked archive segments which have already been swapped out is 
displayed.

3. Select an archive segment you wish to remove from the archive.

4. Click "Open".
The selected archive segment is detached from the archive. Once the archive segment has 
been detached from the archive, the archive segment is deleted from the hard disk of the 
CAS. A message window whether the archive segment has been deleted.

5. Click "OK".

6. Repeat steps 2 through 5 for all closed archives.

4.1.5 How to Back Up the Archives of the Central Archive Server

Requirements
● Before you run the software update, perform these steps directly on the archive server 

(Central Archive Server (CAS), or StoragePlus Server).    

● You are authorized to access the Windows user interface on the CAS.
 

  Note

Before you update the central archive server software (SW update installation), you need 
to disconnect any *.SPB (StoragePlus Backup) databases that may be linked to the 
project. 
SPB databases come from CAS/StoragePlus PCS 7 < V7.0 or up to V1.1.1 inclusive. 

Testing and disconnection takes place via the StoragePlus Administration Console.
 

Preparation
Perform the following tasks for the software update:

1. Double-click "Add or remove programs" in the Windows Control Panel.

2. Click the "Add/Remove Windows Components" button in this dialog.

3. Remove the "StoragePlus" software package.
 

  Note
Path of the directories to be backed up

For additional information, refer to the "How to determine the configuration data on the 
Archive Server (Page 22)" section.

 

Preparing for the software update
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Procedure
1. Open Windows Explorer.

2. Select the database directory (DatabasePath).

3. Back up all the files from this directory (to CD or DVD, for example).

Additional information
Section "Overview of Updating the Servers for Central Archiving (Page 107)"

4.2 Necessary preparations

4.2.1 Overview of preparations

Overview of the procedure
 

 NOTICE

You must perform the steps listed below prior to carrying out an update, in order to prevent 
data being lost.

 

Always backup your PCS 7 project before you run the software update.     

Step Action ES OS 
Server

OS 
Client

AS

5 Back up PCS 7 project data (Page 26) X    
6 Back up the libraries you created (Page 28) X    
7 Export operator and display texts (Page 30) X    
8 Check the CPs and network cards (Page 31) X X X  
9 Prepare projects with high-precision time stamping  

(Page 32) (only required for projects with high-
precision time stamping).

X    

10 Backing Up the License Keys and Authorizations 
(Page 33) 

X X X  

Preparing for the software update
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Additional preparations
 

 Note
Update of SIMATIC BATCH

If you want to update SIMATIC BATCH that you may be using in the project, you must strictly 
observe the update information provided in section "Updating SIMATIC BATCH (Page 113)".

 

 

4.2.2 Exchanging Data Via OPC A&E
If you exchange data in the PCS 7 system by means of OPC A&E, observe the information in 
the Process Control System PCS 7; OpenPCS 7 documentation when updating the software.

4.2.3 How to Back Up PCS 7 Project Data
 

 NOTICE

Before you install or update PCS 7, you must prepare and backup your original project so 
that you can perform the software update.

 

Carry out the following instructions in succession.

Archiving a project
1. In SIMATIC Manager, select the menu command File > Archive.

The "Archive" dialog box opens.

2. Select the "Multiprojects" (or "User Projects") tab.

3. Click "Browse" and select the project you want to archive from the list.

4. Click "OK" to save your settings.
The "Archive - Select Archive" dialog box opens.

5. Make the following settings for archiving:

– Select the drive and the folder for the archive file from the "Save" drop down list box.

– Enter the name under which the archive file should be saved in the "File name" text box.
Recommendation:
Choose a name for the project's archive file which indicates the date on which archiving 
took place. Example: "yearmonthdayprojectname"; 091230name

Preparing for the software update
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6. Click "Save" to apply your entries.
The "Archive – Options" dialog box opens.
If you wish to archive your project on a disk, select the disk size.
You can find additional information on this dialog box by clicking the "Help" button.

7. Click "OK".
The archiving process begins.

When the "Archive" dialog box closes, archiving is finished.
 

 Note

The archived project will reflect the state of the project before the software update.
 

Comparing Time Stamps
1. Open your PCS 7 project in SIMATIC Manager.

2. In the component view, select the chart folder of an AS.

3. Double-click on any chart.
The CFC editor opens.

4. Select the menu command CPU > Compare.

5. Compare the time stamps "Last compilation" and "Compilation of the loaded program".

If the time stamps are... ... Then
Identical 1. Click "Close".

The dialog box is closed.
Different 1. Select the menu command CPU > Download.

2. Select the "Changes" check box and apply all other standard settings.
3. Click "OK".

Changes start to be downloaded.
4. If changes have been downloaded without errors, select the menu 

command CPU > Compare.
The "Last offline program change" and "Last online program change" 
time stamps must match up.

6. Perform steps 2 to 5 for each automation system.

Reading Back the AS Parameter Settings
If parameters which are not in the configuration have been set in the AS, you will be able to 
read these settings back into the project. 

 

 CAUTION

Please note that the parameters in the configuration will be overwritten. The decision 
concerning whether to use this function will depend on the nature of the system involved and 
must be made by the skilled personnel with responsibility for the system.

 

Preparing for the software update
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1. Open your PCS 7 project in SIMATIC Manager.

2. In the component view, select the chart folder of an AS.

3. Double-click on any chart.
The CFC editor opens.

4. Select the menu command Chart > Read Back.

5. Select the entries "Program on the CPU" and "Only data relevant for operator control and 
monitoring" in the "Read Back" dialog box.

6. Click "OK". 
The read-back process begins.

7. Perform steps 2 to 6 for the automation systems whose current parameters you require.

Backing Up OS Data
If you want to operate the OS server on a newly installed PC following the software update, 
we recommend you back up the OS project of the OS server.

By default, the configuration data and the archive data of the OS are stored in the OS project 
of the OS server.

To back up data, compress the project paths in this folder and save them on a suitable medium 
(such as a CD).

SIMATIC PDM
SIMATIC PDM configuration data is included automatically in the backup of a SIMATIC project.

4.2.4 How to Back Up User Created Libraries

Introduction
Generate a backup copy of any project library that contains a collection of user-specific blocks 
for the project to be updated so that you can retrieve this data after having updated the 
software. Carry out these steps for each library that you would like to back up.   

Procedure
1. Start SIMATIC Manager.

No PCS 7 project must be open.

2. In SIMATIC Manager, select the menu command File > Archive. 
The "Archiving" dialog box opens.

3. Open the "Libraries" tab.

4. Select the library to be backed up and click "OK".
The "Archiving - Select an Archive" dialog box opens.

Preparing for the software update
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5. Specify the file name and the storage path.

6. Click on the "Save" button.

Additional information
● Online help for STEP 7

4.2.5 Operator and Display Texts in Blocks

Information in Faceplates   
Faceplates visualize processes on the operator station and provide the plant operator with 
information, such as:

● Measured values

● Operating limits

● Units

● Block operator texts

Change in Operator and Display Texts in Blocks
If you have modified the operator texts or display texts in the blocks so that they do not 
correspond to the delivery state and you want to use the new PCS 7 blocks, you must back 
up these "old" operator texts or display texts.

Diagnostic screens with project-specific adaptation
In a project created with a version lower than PCS 7 V7.0 SP1, backup the diagnostic screens 
that were adapted to a specific project. 

Exporting Operator and Display Texts
 SIMATIC Manager supports the export of information pertaining to parameters, signals, and 
messages to a file (format: *.csv).

You can edit this file in standard MS Office applications such as Excel and Access. The same 
mechanisms are used for the export as are used for changeover to project-specific languages. 

Preparing for the software update
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4.2.6 How to Export Operator and Display Texts

Requirement     
● The required language is installed in your project.

 

  Note

You can view the languages available in the project in SIMATIC Manager using the menu 
command Options > Language for Display Devices. The number of available languages 
is specified when Windows is installed (system characteristics).

 

Procedure
1. Open the project to be updated in the SIMATIC Manager.

2. Select the master data library folder in the Component View.
If this folder is not available, select the project folder.

3. Select the Options > Manage Multilingual Texts > Export menu command.
The "Export user texts" dialog opens.

4. Make the following settings:

– In the "Text tables" group, select the storage location and the format of the export file 
(possible formats: *.xls and *.csv).

– Select the target language and source language that correspond with the display 
language in the "Language" area.

5. Click "OK".

6. If you are managing multilingual projects, repeat steps 3 thru 5. Make sure that you specify 
different destination directories or export file names.

4.2.7 Unauthorized CPs and Network Adapters

Communications Processors that Are No Longer Supported
 

 Note

General rules as of PCS 7 V7.0:

PROFIBUS is no longer supported as the plant bus. Only Industrial Ethernet is supported as 
the plant bus. 

 

For this reason, the following PCS 7 communication processors (CPs) are no longer supported:

● CP 1413 Industrial Ethernet

● CP 5412 A2 PROFIBUS

● CP 5613 PROFIBUS

Preparing for the software update
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These CPs must be uninstalled and removed.

Communications Processors that Are Not Detected
The following communication processors cannot be detected during installation of the 
operating system:

● Non-"Plug&Play" compatible communications processors

● ISA plug-in cards as communications processors

Replace these CPs with "PCI" cards prior to installation of the operating system .

Communications Processors in the PC Stations
Note that you must also remove the hardware specified above from the PC stations of your 
PCS 7 project. 

 

 Note

You must reconfigure the connections after the communications processors are removed.
 

4.2.8 How to Check the CPs and Network Adapters

Introduction
After you have installed the operating system on the PCs, you should check whether the CPs 
or network adapters being used are recognized by the operating system.

Procedure
1. Click the "Workspace" icon on the desktop.

2. In the context menu, select the menu command  Properties.

3. Open the "Hardware" tab.

4. Click the "Device Manager" button.
The "Device Manager" dialog opens.
The detected modules can be found in the "Device Manager":

– The detected communication processors (CPs) are listed in the"SIMATIC NET" folder.

– The detected network adapters can be found in the "Network Adapters" folder.

5. Close the dialog box.

Preparing for the software update
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Additional information
● Documentation: PCS 7; Released Modules

4.2.9 How to prepare projects with high-precision time stamping
These steps are only required for projects in which the PCS 7 function "high-precision time 
stamping" is used.

 

 Note
Blocks of the Advanced Process Library (APL)

If you intend to use the APL functions, you need to reconfigure the project in accordance with 
the Process Control System PCS 7; High-precision time stamping documentation. 

 

Requirements
● The current version of all SIMATIC stations has been compiled and transferred.

Procedure
For each CPU with time stamping:

1. Select the following path from the "Project" > "SIMATIC Station" > CPU > S7 Project > 
Charts tree structure.

2. Select Options > Charts > Chart Reference Data.
The "Chart ref.: Chart reference data.." dialog box opens.

3. Select the View > Block types menu command.

4. Click the "Block type" header of the table.
The blocks of this CPU are displayed in sorted order.

5. Search for "IM_DRV" in the "Chart ref.: Chart reference data.." dialog box.

6. Double-click on the "IM_DRV" entry.
The CFC associated chart opens.

7. Select the Chart > New... menu command in the CFC editor
The "Open" dialog box opens.

8. Go to the "Object name" input line and type in a name (e.g. TEMP_IM_DRV_"Number" ) 
for the temporary CFC chart (e.g. TEMP_IM_DRV_1).

9. Select the Window > Arrange > Tile vertically menu command in the CFC editor.

10.Drag-and-drop the IM_DRV block from the system chart to the temporary CFC chart (e.g. 
TEMP_IM_DRV_1).

11.Save the CFC charts.
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12.Repeat steps 5 through 11 for all IM_DRV blocks in the CPU.
 

  Note

The system chart will no longer contain any IM_DRV blocks after you have successfully 
moved them all to temporary CFC charts. The name of system charts starts with the "@" 
character.
The path name is available in the "Chart ref.: Chart reference data..." column in the dialog 
window.

 

13.Repeat steps 1 through 12 for all SIMATIC stations in your project.

Updating PCS 7 on a new engineering station
If you wish to perform the update on a new engineering station or with a newly installed 
operating system, you will need to archive the PCS 7 project again (see section titled "How to 
Back Up PCS 7 Project Data (Page 26)"; archiving projects).
Perform the update with the rearchived project.

Generating the AS
 

 NOTICE

Do not generate this automation system after having moved the IM_DRV blocks. 
The blocks would be moved to the system charts automatically and the message texts would 
be deleted in the course of your software update.

 

4.2.10 Backing Up the License Keys and Authorizations

Introduction     
You must backup the license keys/authorizations stored on your hard disks before changing 
the operating system or using new PC stations.

 

 Note

You can backup all License Keys to a License Key USB stick that is available as of PCS 7 
V7.1. 
You must transfer the authorizations to a License Key disk/multi-authorization disk.
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Program for backing up the License Keys
Use the Automation License Manager for this purpose. 

 

 Note

Reinstall the License Keys from the backup file using "Automation License Manager" 
(available on the Process Control System; SIMATIC PCS 7 DVD) after having installed the 
operating systems to enable an upgrade of the License Keys (Upgrade License Key and 
Power Pack License Key). You can only upgrade the License Keys if the License Keys to be 
updated are available on the corresponding PC station.

 

Additional information
● Online help for Automation License Manager
● Online help for WinCC Information System > Authorization
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Adaptations to the Hardware 5
5.1 Overview of Update of the Hardware

Overview of the procedure

Step Action ES OS 
server

OS 
client

AS

11 Prepare the hardware replacement (Page 36)     
12 Update and replacement of the hardware (Page 37)     

5.2 Planning and preparation
If you want to use the new PCS 7 V8.0 functions, all hardware components (modules) of the 
process control system in the PCS 7 system must meet the requirements of the PCS 7 
version.  

Necessity of Updating or Replacing Hardware Components
To determine whether it is necessary to update a hardware component, refer to the PCS 7; 
Released Modules documentation. It does not automatically follow that you will be able to use 
the new PCS 7 V8.0 functions if you have earlier product releases and versions. 

Contact your Siemens representative if replacement of a module is required.

Result of the Analysis
An analysis of the hardware can result in the following scenarios:

● Module can continue to be used in its full scope.

● Module can be updated.

● Current module must be replaced with a new module.
 

 
 CAUTION

A STOP of the AS may be required to update or replace a component.

Example: During a CPU firmware update, or when the plant bus is changed from 
PROFIBUS to Industrial Ethernet.
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5.3 How to Prepare for Replacement of the Hardware

Options for Reading Out Module Information
You can read out information about the following modules in HW Config:

Component Information concerning
Network components Menu command Object Properties > Diagnostics:

NCM S7 Diagnostics
CPU Menu command Object Properties
Interface modules 
● IM 153
● IM 157
● IM 151

Menu command CPU > Module information
The interface module (IM) product version can be found of the front 
panel at the lower right.

Basic procedure
The following tasks are required if you plant to replace hardware in an AS:

1. Analyze the actual state of the modules used.

2. Define the desired state:
Define what the future structure of your system should be. Define your future automation 
objectives and coordinate these with the requirements specified in the PCS 7; Released 
Modules documentation. 
For more information on the various modules, refer to the Process Control System PCS 7; 
PC Configuration and Authorization Manual.

3. Carry out the module planning:
Produce planning documents, which establish the following:

– Parts of the plant that should remain

– Parts of the plant that should be expanded

– Old modules that should still be used

– Parts of the plant that should be upgraded with new modules in order to utilize the full 
functional scope of SIMATIC PCS 7 V8.0 Update 1

Special Information via the Internet
You can find special information about the firmware update and the corresponding updates 
on the Internet at:

http://www.siemens.com/automation/service (http://www.siemens.com/automation/service) 

Select Search and enter "CP1623 firmware update" in the search window, for example.
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5.4 How to Perform Updates and Replace the Hardware

Introduction
The following table offers an overview of the hardware updates that may be required. You can 
find detailed step-by-step instructions for the procedure in the manual Process Control System 
PCS 7; Service Support and Diagnostics.

Overview of the Hardware Updates with Supplemental Information

Hardware Update, 
Hardware 
Replacement

Basic procedure For additional information...

Updating the CPU 
Operating System

1. Check the type and product release of 
the module.

2. If required:
Perform an update or replace the 
module.

Process Control System PCS 7; 
Service Support and 
Diagnostics Manual, section 
"Update of the CPU Operating 
System".

Firmware update of 
CP 443-5 Extended

1. Check the type and product release of 
the module.

2. If required:
Perform an update or replace the 
module.

Process Control System PCS 7; 
Service Support and 
Diagnostics Manual, section 
"CP 443-5 Extended: Firmware 
Update".

Firmware update of 
CP 443-1

1. Check the type and product release of 
the module.

2. If required:
 Perform an update or replace the 
module.

Process Control System PCS 7; 
Service Support and 
Diagnostics Manual, section 
"CP 443-1: Firmware Update".

Replacing IM 153-2 
and IM 157

1. Check the type and product release of 
the module.

2. If required:
Perform an update or replace the 
module.

3. Take into account the necessary bus 
modules.

Process Control System PCS 7; 
Service Support and 
Diagnostics Manual, section 
"Update of an Interface Module 
(IM)".
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Hardware Update, 
Hardware 
Replacement

Basic procedure For additional information...

Firmware update of Y 
coupler

1. Check the type and product release of 
the module.

2. If required:
Perform an update or replace the 
module.

3. In addition, take into account the 
necessary bus modules.

Process Control System PCS 7; 
Service Support and 
Diagnostics Manual, section 
"Update of an Interface Module 
(IM)".

Replacement of 
diagnostic repeaters

1. Check the type and product release of 
the module.

2. If required:
 Perform an update or replace the 
module.

● The Diagnostics Repeater 
with the order number 6ES7 
972-0AB01-0XA0  supports 
the functions introduced with 
PCS 7 V6.0.

● The Diagnostics Repeater 
with order number 6ES7 
972-0AB00-0XA0  does not 
support the functions 
introduced with PCS 7 V6.0.

Additional information
You can find additional information in the following documentation:

In the Windows Start menu, SIMATIC > Product information submenu, in the corresponding 
language folder:

● File PCS 7-WhatsNew.wri
In the Windows Start menu, SIMATIC > Documentation submenu, in the corresponding 
language folder:

● Documentation PCS 7 - Released Modules
● Manual Process Control System PCS 7; PC Configuration and Authorization
● Manual STEP 7; Modifying the System during Operation via CiR
● Manual Process Control System PCS 7; Service Support and Diagnostics
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Installation of PCS 7 and settings on the ES and OS 6
6.1 Overview of Installation and Settings on the ES and OS

Overview of the procedure  

Step Action ES OS 
server

OS 
client

AS

13 Prepare the PC station (Page 39) X X X  
14 Install the PCS 7 software (Page 40) X X X  
15 Set the operating mode "configured mode"/"PG 

mode" (Page 43) 
X X   

16 Configure and download the PC stations (Page 44) X X X  
17 Install additional PCS 7 libraries (Page 48) X    
18 Install additional non-standard libraries (Page 51) X    
19 Installing additional faceplates on the OS (Page 49)  X   

6.2 Preparing the PC Station

Preparing the PC Station   
The further procedure depends on the operating system of the PC Stations to be updated. The 
operating systems recommended for PCS 7 are listed in the PCS 7 Readme file on the Process 
Control System; SIMATIC PCS 7 DVD.

Recommendation 
Use the latest approved operating systems for PC Stations (workstation and server).

● Consult with a network administrator about the configuration of the networks.

● You can find information about backing up data in the manual Process Control System 
PCS 7; Service Support and Diagnostics

● You can find information about the installation and configuration of the PC stations in the 
"Installing the Operating System" section of the Process Control System PCS 7; PC 
Configuration and Authorization manual.

 

  Note
Re-installing the operating system

You can re-install the operating system directly if the operating system partition does not 
contain project or archive data.
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Additional information
● Manual Process Control System PCS 7; PC Configuration and Authorization
● PCS 7 - Readme file

6.3 How to install PCS 7

Requirements
● The PCS 7 project data is backed up.    

You can find detailed information about how to back up project data in the Process Control 
System PCS 7; Service Support and Diagnostics  documentation, section "Safeguarding 
Availability, Data Backup".

● The hardware planning and hardware update are complete.

● The necessary preparations have been made.

● Read the current information about installation and software and hardware requirements 
in the PCS 7 Readme file on the DVD Process Control System; SIMATC PCS 7.

● In the case of PC stations with INTEL network adapters, the driver for the network adapters 
must be updated before the service packs for the operating systems are installed. You can 
find the driver on the "Process Control System; SIMATC PCS 7 DVD in the folder 
"Addtional_Products\Drivers\NETWORK\Intel".

● The operating system of the PC station will be updated.

● Install the software for time synchronization when updating SIMATIC PCS 7 BOX and 
SIMATIC PCS 7 AS RTX.
You can find information on the software for the automation system of SIMATIC PCS 7 
BOX in the PCS 7 Readme documentation on DVD 1 Process Control System; 
SIMATC PCS 7.

 

 Note
Software update of password-protected projects

The software update of password-protected projects requires SIMATIC Logon on an ES.
 

 Note
Windows User Groups

Members of the Windows user group "SIMATIC HMI" should not be members of the Windows 
user group "SQLServer2005MSSQLUser$<computer name>$WINCC" at the same time. 

Members of the "SQLServer2005MSSQLUser$<computer name>$WINCC" group have 
administrator rights on the SQL Server. You should therefore remove all Windows users who 
only need restricted access to the OS database from this group.
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 Note
Hotfix and SQL server

PCS 7 Setup automatically installs the necessary hotfix and SQL Server.
 

 Note
Replacing the operating system of servers

Observe the following instructions if the server operating system is replaced during a software 
update:
● Shut the redundant server down completely if you do not want to perform a server software 

update during operation.
● Restart the servers following installation.

 

SIMATIC PDM
If you are using the PCS 7 Maintenance Station and the project contains intelligent field devices 
configured with SIMATIC PDM , install SIMATIC PDM on the Engineering Station. Select "User-
defined settings"in the setup dialog.   

 

 Note
Installation of SIMATIC PDM

Remove SIMATIC PDM before you install a new version.
 

WebNavigator client and WebNavigator diagnostics client
Please note the following when updating software:

● You can update the software (without removing it beforehand) on the WebNavigator client.

● With the WebNavigator diagnostics client, you will have to uninstall and then reinstall the 
software.
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Procedure
1. Insert the Process Control System; SIMATC PCS 7 DVD into the DVD drive.

2. Select the "Install" setup type.
You will find a more detailed description of how to install the required software in the Process 
Control System PCS 7; PC Configuration and Authorization documentation, section "How 
to Install PCS 7 Software".

 

 
 NOTICE

Only this setup type installs all new PCS 7 components.
 

3. Restore the old project data from the backup copy to the PC.
 

  Note
Required access rights for changing the project path

The project path in "Storage location for projects/multi-projects" is set by default to 
"SIEMENS\STEP7\S7Proj" and all necessary access rights are set for this project path.

If you use another project path, you need to set the necessary access rights using the 
"SimaticRights.exe" tool.

For more information, refer to the Process Control System PCS 7; PC Configuration and 
Authorization manual, section "How to set authorizations for project paths".

 

Installed libraries as of PCS 7 V8.0 
The libraries of PCS 7 are updated with each PCS 7 version. As of PCS 7 V8.0 , the following 
libraries are installed by default.

● PCS 7 Basic Library
Contains the blocks of the PCS 7 Basic Library of PCS 7. The PCS 7 Basic Library is a 
prerequisite for the use of the PCS 7 Library and the Advanced Process Library.

● Advanced Process Library
Contains the blocks of the Advanced Process Library of PCS 7.

Additional information
● Process Control System PCS 7; PC Configuration and Authorization Manual

6.4 Updating SIMATIC PCS 7 AS RTX

Update package
You need the following product for the update of SIMATIC PCS 7 AS RTX :

PCS 7 AS RTX V8.0 Update Package 

Installation of PCS 7 and settings on the ES and OS
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Basic procedure
1. Backing up user and network settings

2. Backing up license keys

3. Updating SIMATIC PCS 7 AS RTX in accordance with the  SIMATIC PCS 7; PCS 7 AS 
RTX V8.0 Update Package product information

4. Creating user and network settings

5. Loading SIMATIC PCS 7 AS RTX

Additional information
● Product information SIMATIC PCS 7; SIMATIC PCS 7 AS RTX

6.5 Modules in Configured Mode and PG Mode

Operating Modes       
Two operating modes are always differentiated:

● Module in configured mode

● Module in programming device (PG) mode

Module in "Configured Mode"
You can only transfer configured connections from NetPro to the module in "Configured Mode". 
All of the logs provided by SIMATIC NET are available when using this operating mode. For 
this reason, we recommend using this setting.

As a requirement for the "Configured Mode" setting, your PCS 7 project must contain a 
SIMATIC PC station with a WinCC application for the engineering station (ES). Check whether 
this requirement has been met for your PCS 7 project.

Module in "PG Mode"
In "PG mode", you can assign parameters for the network module. You can assign the network-
related parameters, such as station address and transmission speed, with the "Set PG/PC 
Interface" configuration program. The configuration can only be set locally on the computer.
No communication is possible with the PC stations in this operating mode.

Requirements
● The network addresses and network settings of the PC stations are configured.

● The configuration of the PC stations match in HW Config and in the Station Configuration 
Editor.
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● The configuration of the PC stations is loaded on the PC stations.

● The connection data of the PC stations are loaded.

Procedure
1. In the Windows Start menu, select SIMATIC > SIMATIC NET, menu command Configure 

PC Station.

2. In the tree view, select the "Modules> <Network Card on System Bus> >General" folder.

3. Select the appropriate entry from the "Module Mode" drop-down list box.

4. Click "Apply".
 

 
 NOTICE

For process mode, the network card must be set to "Configured Mode".
 

6.6 How to Configure and Download the PC Stations

Introduction           
The project-specific network settings for the communication types (Ethernet) of the 
Engineering Station are downloaded directly to the PC station.

Requirements
● The following is installed on each PC station:

– Operating system

– Specific software for the PC station (e.g., PCS 7 Engineering, OS Server)

● All PC stations to be downloaded are linked to the engineering station by means of at least 
one network.

● The protocol for the communication on the terminal bus is set to TCP/IP.

● The network is administered (terminal bus and system bus). The network addresses of the 
PC stations are configured.

● The PC station access point is set on each PC station as follows: "S7ONLINE: = PC internal 
(local)".

Procedure
 

 Note

Perform the following steps for the engineering station first before configuring and 
downloading the other PC stations.
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1. In SIMATIC Manager, open the PCS 7 project.

2. In the Component View, select the target computer.

3. Select the menu command CPU > Configure.
The "Configure" dialog box opens.

4. From the "Local Network Connection" drop-down list box, select the network connection to 
be used to access the target computer.

5. Click "Update".
The list of accessible computers is updated.
The PC station selected in the project is entered in the "Target computers" area.

6. Select the desired target computer (PC station).
 

  Note

If the selected PC station does not appear in the list, this suggests network problems or 
a faulty configuration in the project.

 

7. Click "Configure".
Dialog box "Configure: <Selected Station>" opens.

8. In the "Configure: Target Computer" dialog box, click "OK".

9. Click "OK" in the "Information" dialog box. The configuration data is transferred to the PC 
station. To activate the network connections, you must then download the network settings 
to this PC station. The completion of the "Configuration" step is indicated in the dialog box 
message line.

10.Click "Close".

11.For the computer selected in step 2, select the menu command CPU > Download.
The "Download to CPU in Current Project" dialog box opens.

 

  Note

The configured network address of the Ethernet interface in the PC station must match 
the preset address in the target system.

 

12.When the dialog box tells you that you are overwriting the configuration data, respond as 
follows:

– During initial commissioning, click "Yes".

– If the PC station is in process mode, you can only click "Yes" when a communication 
interruption is permissible.

The "Stop Target Module" dialog box opens.

13.In the "Stop Target Module" dialog box, click "OK" to confirm.
The "Download" dialog box opens.

14.Click "OK" to confirm.
The download is performed.
Once the configuration has been applied, the PC station is ready to operate.

15.Repeat steps 2 through 14 for all of the PC stations.
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Switching the Logs on the Bus (Industrial Ethernet)
 

 NOTICE

You must not deactivate the TCP/IP protocol or the ISO protocol during operation. These 
protocols are mandatory for the configured operating mode!

 

If a bus within a system must be switched to a different protocol (for example, from TCP protocol 
to ISO protocol), you must temporarily set a mixed protocol (TCP and ISO) on the engineering 
station. You then download the configuration data to the AS and the operator control and 
monitoring systems.

Additional information
● SIMATIC NET; Commissioning PC Stations - Manual and Getting Started manual

6.7 Transmission Rate and Operating Mode in the PC Network

Introduction
For communication in a network, ensure that the following parameters are set consistently for 
all network nodes:       

● Transmission rate

● Operating mode

Automatic Recognition of the Transmission Rate and the Operating Mode
The term autonegotiation denotes the automatic identification and negotiation of transmission 
rate and operating mode (full duplex/half duplex).

● Full duplex is an operating mode with bidirectional data exchange, in which the 
communication partners can send data independently of one another on the transmission 
link.

● Half duplex is an operating mode with bidirectional data exchange, in which only one 
communication partner at a time can send data on the transmission link.

Requirement
With their factory settings, Siemens devices used in PCS 7 automatically identify 
(autonegotiation) the transmission rate and operating mode parameters.

This setting must be changed only if communication in the network is necessary with nodes 
that do not have the autonegotiation setting.
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Assigning Parameters to Network Nodes

Location of 
Use

Network Node Steps for Calling Parameter Assignment 
Dialog Box

Parameter Setting

PC Communication processor CP 
1613 / CP 1623

1. In the Windows Start menu, select the 
SIMATIC > SIMATIC NET submenu, 
menu command Configure PC-Station

2. PC Station > Modules > Network 
Parameters

Selects options for duplex 
mode and transmission rate

PC INTEL  network adapter 
settings (or similar standard 
network adapters)

1. In the Windows control panel, select 
"Administrative Tools" > "Computer 
Management" > "Device Manager" > 
"Network adapters"

2. Select network card
3. File > Properties
4. Advanced" tab

Set the values for the 
property.
Typical name for the property 
(depends on the network 
module used):
● Speed and duplex mode
● Link speed & duplex

Switches SCALANCE X400
SCALANCE X200
ESM
OSM

● To call parameter assignment dialog 
box (Web-based management) of the 
switch via Internet Explorer:
http : \\<TCP-IP address>

● Configuration via telnet (DOS window: 
telnet)

Port configuration

AS Communication processor CP 
443-1

● HW Config: CP443-1  Properties > 
"Options" tab > "Individual network 
settings" group 
"Transmission medium/duplex" drop-
down list box

Automatic Setting" default

Additional information
● Operating Instructions SIMATIC NET; Industrial Ethernet Switches SCALANCE X-400
● Configuration manual SIMATIC NET; Industrial Ethernet Switches SCALANCE X-400

6.8 Installation of Additional PCS 7 Libraries

Overview
Observe the following specifications with regard to the PCS 7 libraries when updating the 
software:         

The PCS 7 Library V7.1 SP3 must be post-installed on the engineering station for the software 
update to PCS 7 V8.0 Update 1 if the blocks of this PCS 7 Library are also to be used in the 
PCS 7 project.
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● If you wish to operate a mixture of APL V8 blocks and PCS 7 standard blocks, you need 
to update the blocks with the blocks stored in the PCS 7 Library V7.1 SP3 in the "ChnBlocks 
for PCS7 V8" folder.

● If you are using the PCS 7 Library in the project to be updated under PCS 7 V8.0 Update 
1 , you need to install the  PCS 7 V7.1 SP3 PCS 7 Faceplates on the following PC stations 
after a new installation of PCS 7 :

– Engineering station

– All operator stations
 

  Note

You can find the setup program for the faceplates on the Process Control System; 
SIMATIC PCS 7 DVD in the folder "Additional_Products
\PCS7Faceplates__V7.1+SP3".

 

Basic Installation Procedure
The procedure is described in the section "How to install additional PCS 7 libraries (Page 48)".

 

 NOTICE

Only the AS blocks of the same PCS 7 version may be loaded on an AS.
 

6.9 How to Install Additional PCS 7 Libraries
 

 NOTICE

Post-installing or removing PCS 7 libraries

If you install or remove an older version of the PCS 7 Library, PCS 7 Basic Library or PCS 7 
Advanced Process Library after the installation of PCS7 V8.0 including Update 1, you must 
re-install the latest versions of the PCS 7 Basic Library or PCS 7 Advanced Process Library 
via the PCS 7 system setup afterwards. Do not use the product setup of these libraries to do 
this. This relates, for example, to PCS 7 Library V6.1+SP1+Upd17, PCS 7 Basis Library V7.1 
SP3+Upd6 and PCS 7 Advanced Process Library V7.1 SP5+Upd3, which are located on the 
SIMATIC PCS 7 DVD 2/2 in the Additional_Products folder. This is necessary in order to 
guarantee proper functioning of the CFC driver generator.

 

Requirements
● The operating system including the required components is installed.  

● PCS 7 has been installed.
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● All applications are closed.

● The PCS 7 software package with the required library is available on the Process Control 
System; SIMATC PCS 7 DVD, for example.

Procedure
The following steps serve as an example. 

1. Run the "SETUP" program.
The libraries and corresponding setup program are available on the Process Control 
System; SIMATIC PCS 7 DVD in the "Additional_Products" directory.

2. Select a setup language.

3. Click "Next".

4. Follow the instructions of the setup wizard and then close the setup program.
 

 
 NOTICE

Only the AS blocks of the same PCS 7 version may be loaded on an AS.
 

5. Install the latest version of this library from the current Process Control System; SIMATC 
PCS 7 DVD.

Additional information
Included with the PCS 7 libraries delivered:

● PCS 7 Basis Library: bli-readme.rtf file
● PCS 7 Library: LIB-Readme.wri file
● PCS 7 Advanced Process Library: APL-Readme.rtf file
● PCS 7 Faceplates: fpd-readme.wri file

6.10 How to install additional faceplates on operator stations

Important information
Only follow the instructions below if you are using blocks from PCS 7 Standard Library of PCS 
7 V7.1.3 in the automation system and you have performed a new installation of PCS 7 V8.0 
Update 1 (not an update installation).

Requirements
● The operating system including the required components is installed.  

● PCS 7 has been installed.
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● All applications are closed.

● The PCS 7 software package with the required library is available on the Process Control 
System; SIMATC PCS 7 DVD, for example.

Procedure
The following steps serve as an example. 

1. Run the "SETUP" program.
The faceplates and corresponding setup are available in the "Additional_Products" folder 
on your Process Control System; SIMATIC PCS 7 V8.0  DVD.

2. Select a setup language.

3. Click "Next".

4. Follow the instructions of the setup wizard and then close the setup program.

Additional information
On the faceplates supplied with PCS 7:

● PCS 7 Faceplates_<...>: fpd readme.wri file

Additional information
You can find additional information about modifying libraries in the WinCC Online Help; 
Faceplate Designer

6.11 What are the requirements for using the Advanced Process Library?
You need the following libraries to use the functions provided in PCS 7 V8.0 or higher:

● PCS 7 Advanced Process Library (APL)

● PCS 7 Basic Library

The PCS 7 Advanced Process Library (APL) can only be used if the PCS 7 Basic Library is 
installed.

 

 Note

When upgrading PCS 7 with utilization of new functions, you must always upgrade all libraries. 
It is not allowed to use the new functions only for one library in the PCS 7 project!

 

The use of APL blocks requires application-specific configuration. 
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Additional information
● Section "Using the APL V8.0 (Page 99)"

6.12 How to Install Additional Non-standard Libraries

Introduction
Note this section if you are using and would like to continue using libraries in the PCS 7 project 
to be updated that are not standard in PCS 7 or that contain modified blocks.

Requirement
The library has been archived with the menu command File > Archive in SIMATIC Manager.

Procedure
1. Start the SIMATIC Manager. A PCS 7 project does not have to be open.

2. In SIMATIC Manager, select the menu command File > Retrieve. 
The "Retrieving - Select Archive" dialog box opens.

3. Specify the path to the archived library. 
Click "Open". 
The "Select Destination Directory" dialog box opens.

4. Set the destination directory.

5. Click "OK".
 

 
 NOTICE

Only the AS blocks of one PCS 7 version may be loaded on an AS.
 

Additional information
Information concerning the modification of libraries is available in the following documentation:

● Manual Process Control System PCS 7; Programming Instructions for Blocks
● Manual Process Control System PCS 7; Programming Instructions for Driver Blocks
● Online help for WinCC; Faceplate Designer
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6.13 How to update user-specific APL faceplates 

Introduction
You need to make certain adaptations for APL faceplates that were created in accordance 
with APL style guide using APL version SP4. 
You should also observe the instructions in the Readme file with regard to APL faceplates SP5.

 

 NOTICE

Take into account that you have to re-enter the parameterization of the objects you replaced.
 

Requirements
Advanced Process Library Version SP5.

Procedure
Replace the following objects in your basic faceplate picture (e.g. @PG_MyAPLFP.PDL) with 
the corresponding object from the @PCS7ElementsAPL.pdl picture.

● The "AlwaysOnTop" object with the "APL_PIN_BUTTON" object Version >= 10061101.

● The "ObjCollection" object with the "ObjCollection" Version >=10102501.

● The "@Faceplate" object with the "@Faceplate" Version >= 10110501.

● Copy the complete C-script from the @PG_PIDConL.pdl picture of APL SP5, ViewWindow/
Height/OnPropertyChanged and completely replace the script in your own basic picture, 
ViewWindow/Height/OnPropertyChanged.

● Copy the complete C-script from the @PG_PIDConL.pdl picture of APL SP5,  ViewWindow
\PictureName\OnPropertyChanged and completely replace the script in your own basic 
picture, ViewWindow\PictureName\OnPropertyChanged.

 

 
 NOTICE

Take into account that you have to re-enter the parameterization of the objects you 
replaced as specified in the APL style guide, chapter 1.3.2.

 

● Change the following parameter assignments:

– In the "@Faceplate" object, change the "Firstview" property to the new picture name, 
e.g. "PG_MyAPLFP_Standard.PDL".

– In the "ObjCollection" object, change the "BlockType" property to the name of the new 
faceplate type (server name), e.g. "MyAPLFP".

 

 
 NOTICE

When using controllable objects with APL SP5, it is imperative to create a tag link at 
the "PermissionTag" or "LinkTag3" property. A parameter assignment as specified in 
the APL style guide, chapter 1.3.7, will no longer be functional. 
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Adaptations in the PCS 7 Project on the ES 7
7.1 Update of a PCS 7 Project

Basic procedure
This section describes how to update your PCS 7 project for use with SIMATIC PCS 7. The 
PCS 7 project is updated on the ES in offline mode. Thus, system operation is not affected. 
The target stations will only be loaded once all the update steps listed below have been 
performed. For more information on downloading, refer to the Process Control System PCS 
7; Engineering Station Configuration Manual   

Once you have completed all of the following update steps on the ES and continue with the 
configuration of the updated PCS 7 project, you may need to complete specific steps such as 
compiling CFC charts and downloading changes or the complete project to the AS.

7.2 General adaptations

7.2.1 Overview of General Adaptations in the Project

Overview of the procedure    

Step Action ES OS 
Server

OS 
Client

AS

20 Updating the OS with the Project Migrator (Page 55) X    
21 Check PH consistency (Page 55) X    

7.2.2 Update of Operator Stations with the Project Migrator
The Project Migrator is used to update the pictures and libraries of an OS.     

Requirement
Projects that were created with PCS 7 versions earlier than V7.1 SP3 must first be updated to 
PCS 7 V7.1 SP3.
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Length of the Updating Process
 

 Note

Depending on the scope, the updating process can take several hours.
 

7.2.3 Changing the Configuration of Multilingual Texts
If you want to use additional interface languages, please take note of the information below.

Changing Multilingual Texts
If you want to display text in more than one language in PCS 7 (for example, message texts 
or OS area IDs), always use the export/import function to change the multilingual texts (menu 
command Options > Manage Multilingual Texts > Export and then Import after the changes 
have been made). 

 

 NOTICE

If you change individual texts with the functions in CFC, SFC or PH, be sure to immediately 
compile the texts in all locations (for example, all block types and all copies of a blocks). 
Otherwise, inconsistencies may occur and lead to the display of an incorrect language version 
of this text.

 

7.2.4 Importing Data from the User Archives

Import Runtime Data
 

 NOTICE

You must always import runtime data from the user archives in the language in which the 
runtime data was exported.
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7.2.5 How to Update Operator Stations with the Project Migrator

Requirements
● Projects that were created with PCS 7 versions prior to V7.1.3 must first be updated to PCS 

7 V7.1 SP3.

● Only for password-protected projects:
Deactivate password protection for the following actions.       

Procedure
Carry out the following steps for each OS project:

1. In the Windows Start menu, select SIMATIC > WinCC > Tools, menu command Configure 
PC Station.
The "CCMigrator" dialog opens with "Step 1 of 3".

2. Click "Next".
"Step 2 of 3" opens.

3. Select the MCP file in the project path for the OS.
OS projects are located in the PCS 7 project path under "wincproj".

4. Click "Finish" in "Step 3 of 3".
The update is performed automatically.

5. Repeat these steps for every OS of your PCS 7 project.

Additional information
● Online help WinCC Information System > Migration
● Online help WinCC Information System > Working with WinCC > Archiving process values
● Process Control System PCS 7; Operator Station Configuration Manual

7.2.6 How to Check the PH Consistency

Introduction
This step shows you if all the data in the "plant hierarchy" are consistent.  
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Requirements
● The project is opened in the Plant View in SIMATIC Manager.

Procedure
The following steps can be performed for the multiproject or for each individual project (in the 
multiproject).

1. In the tree view, select the object to be checked (e.g., the multiproject).

2. Select the Options > Plant Hierarchy > Check Consistency menu command.
The PH will be checked. 
The "Check Consistency - Log" dialog box opens.

3. Correct any errors that were found.
 

  Note

If you need more information about the possible errors, click the "Help" button in the 
"Check Consistency – Log" dialog box.

 

7.3 Adaptations in HW Config

7.3.1 Overview of Adaptation of the Hardware

Important information
The PCS 7 configuration data must be adapted in the following cases:

● When a module is replaced with a different type.

● When the CPU operating system or the firmware for CPs or IMs is updated.

● If you switch to the Windows 7/Windows Server 2008 R2 operating system, you will have 
to update the version of the communication components in the Station Configuration Editor 
and HW Config. The version depends on the version of SIMATIC NET installed on the target 
station.

– SIMATIC NET V8.1.x is installed as of Windows 7 and Windows Server 2008 R2 (e.g. 
for CP 16xx -> SW 8.1.1).

– The CP 1613 A1 communication processor is no longer supported by PCS 7 on 
operating systems as of Windows 7/Windows Server 2008.
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Overview of the procedure

Step Action ES OS 
Server

OS 
Client

AS

22 Configuring replaced hardware (Page 57) X    
23 Setting the CPU properties (Page 57) X    
24 Updating the hardware configuration (Page 58) 

(only for projects with SIMATIC PCS 7 BOX RTX or 
SIMATIC PCS 7 AS RTX)

X    

25 Configuring the address for the PDM Server (Page 59) 
(only for projects with SIMATIC PDM V7.0)

X    

7.3.2 How to Configure Replaced Hardware
After you have replaced modules in your process control system or performed a firmware 
update, the hardware version status must be updated in your PCS 7 project. 

Requirements
● The PCS 7 project operator stations have been updated with the Project Migrator.

Procedure
1. Open HW Config.

2. Drag the object (e.g. CPU: type, firmware version x.x) from the hardware catalog to the 
corresponding slot in the AS configuration table. 
The following system message is displayed: "Do you want to replace the component ... with 
component ...?"

3. Check the hardware types.

4. Click "Yes".

5. Select the menu command Station > Save/Compile.

7.3.3 How to Set the CPU Properties

Reason for Checking the CPU Properties
When you update a firmware version of a CPU, for example, in HW Config, certain parameters 
might not be accepted and might be replaced by default values during the update. In this case 
a message will appear. When this occurs, check the settings of the CPU properties and adapt 
them if necessary.
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Requirements
● A message indicates that not all parameters were applied when the modules were replaced.

● HW Config is open.

Procedure
1. Select the CPU being used in the configuration table in HW Config.

2. In the context menu, select the menu command Object Properties.

3. Open the "Diagnostics/Clock" tab and check the settings in the "Clock" area:

– The "In AS" synchronization must be set to the "As slave" synchronization type.

– The "On MPI" synchronization must be set to the "None" synchronization type.

4. Open the "Cycle/Clock Memory" tab and check the settings:

– If you are using module drivers from PCS 7 V6.0 and higher, the "Update OB1 process 
image cyclically" check box must be selected.

– From the  "OB85 Call for I/O Access Errors" drop-down list box, select "Only for incoming 
and outgoing errors".

5. Select the menu command Station > Save/Compile.

7.3.4 How to update the hardware configuration for SIMATIC PCS 7 BOX RTX and 
SIMATIC PCS 7 AS RTX

The steps described below only have to be carried out for project with SIMATIC PCS 7 BOX 
RTX or SIMATIC PCS 7 AS RTX implementation.

Replace the automation system in the hardware configuration of the PC station.

Requirements
● The AS version in HW Config is not up to date (Version 3.3 or older)

● The assignments of CPs to the master systems are known.

Procedure
1. Open the PC station in HW Config (SIMATIC PCS 7 BOX RTX or SIMATIC PCS 7 AS RTX).

2. Select the PROFIBUS CP to which the distributed I/O is connected.

3. Select the Edit > Master system > Disconnect menu command.

4. Select the CP.

5. Select the Edit > Delete menu command.

6. Select the "Win LC RTX" CPU in the rack in HW Config.

7. Go to the"SIMATIC PC-Station > Controller > Win LC RTX" folder in HW Config.
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8. Double-click the object "V4.4".
The "Insert ..." dialog box opens.

9. Click "Yes".
The controller is replaced.

10.Go to the"SIMATIC PC-Station > Controller > Win LC RTX > V4.4" folder in HW Config.

11.Select the PROFIBUS CP used (default: CP 5613).

12.Drag-and-drop the selected PROFIBUS CP to the controller slot in the station window.
The "Properties ..." dialog box opens.

13.Select the entry of the associated bus system from the "Subnet" list.

14.Click "OK".
The "Insert master system" dialog box opens.

15.Select the entry of the associated bus system from the "Subnet" list.

16.Click "OK".

17.Select the Station > Save and Compile menu command.

7.3.5 How to configure the SIMATIC PDM Server

Requirements
● The project/multiproject has been created.

● The SIMATIC PDM (Server) software package is installed on the Engineering Station.
 

  Note
Requirements for the use of SIMATIC PDM

Please observe the conditions for the use of SIMATIC PDM versions.
 

Selecting the name of the PC station
 

 Note
Restrictions

The following restrictions must be observed:
● Valid characters: [A-Z 0-9]{1,32}
● Use uppercase letters only.
● The first character of the PC station's name must be a letter.
● Maximum length: 32 characters
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 Note

We recommend that the PC name is the same as the name of the station.
 

Procedure
1. Select the Options > SIMATIC PDM > Settings command in SIMATIC Manager.

The "SIMATIC PDM settings" dialog box opens.

2. Select the "Maintenance Station" tab.

3. Go to the input field and enter the project/multiproject in which you have defined the MS 
server or execute the following steps:

– In a multiproject: 
Click "Current Multiproject" or "Browse." You can select the current project using the 
"Browse" button.

– For a project: 
Click on "Current Project" or "Browse." You can select the current project using the 
"Browse" button.

4. Click "OK".

5. Open SIMATIC Manager in the component view.

6. In the project, select the engineering station in which you wish to insert the "PDM Server" 
object.

7. Double-click the "Configuration" object in the detail view.
The hardware configuration of the SIMATIC PC station opens.
If you cannot see the hardware catalog, select the View > Catalog menu command.
The hardware catalog opens.

8. Select SIMATIC PC Station > PDM Server from the list in the folder.

9. Drag and drop the "PDM Server" object to the PC station of the engineering station.

10.Select the menu command File > Save.

11.Download the configuration to the engineering station.

Requirements for diagnostics with SIMATIC PDM
Diagnostics can only be performed on the PDM devices for a given station (OS client, 
maintenance server, etc.) if SIMATIC PDM is active on the engineering station. This is the 
default scenario after the configuration has been downloaded. 

Additional information
● STEP 7 and SIMATIC PDM Online Help

● Whitepaper SIMATIC; Security concept PCS 7 and WinCC - Main document
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7.4 Adaptations in NetPro and conversion of the CFC/SFC charts

7.4.1 Overview of Adaptation of OS-relevant Settings

Overview of the procedure   

Step Action ES OS 
Server

OS 
Client

AS

26 Checking and adapting the connection data in NetPro 
(Page 61) 

X    

27 Converting the CFC and SFC charts (Page 62) X    

7.4.2 How to Check and Adapt the Connection Data in NetPro
In NetPro, you check the configuration to the target stations:

● Connection data

● Configuration data

● after a change of operating system:
Processing sequence of network adapters in the system 

Requirements
● The PCS 7 project is open on the ES.

Procedure
1. In SIMATIC Manager, select the PCS 7 project.

2. Select the menu command Options > Configure Network.
NetPro opens.

3. Select the menu command View > Cross-Project Network View.
The cross-project network view is displayed.
This allows you to toggle directly between all projects in the multiproject.
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4. Check the connections to the various stations: AS-OS, AS-AS, ES-AS. 
You can make any necessary changes when the "cross-project network view" is 
deactivated.
You must configure the connection between the ES and AS if you want to check the 
communication for process mode (runtime) on the ES. This requires the following steps to 
be taken:

– Select the menu command New Connection in the shortcut menu of the WinCC 
application.

– Select the destination: AS or OS.

– Select the connection.

– Select the name for the connection.

– Click "OK".

Recommendation
To enable you to easily identify the connections, we recommend that they be assigned 
default names in accordance with the name of the target.
Example: 
You configure an OS to AS_X connection. 
The corresponding connection name could be "ASX_connection".

5. If you are using time synchronization, you must check the time settings of the network 
adapter (e.g. communications processor) for the ES and OS. Double-click the network 
adapter of the OS/ES. Time-of-day mode must be selected for time synchronization on the 
"Options" tab.

6. If you have made changes in NetPro, you must perform a "Save and Compile" operation 
with the "Save and Compile All" option.

7.4.3 How to Convert CFC Charts and SFC Charts

Requirements
The PCS 7 project is opened on the ES.  

Procedure
 

 Note

This procedure must be carried out for all S7 programs in your PCS 7 project.
 

1. Open a CFC chart and move any block contained within it.
This action will cause the conversion dialog to open immediately.

2. Click "Yes".
The "Convert Format" message window opens.
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3. Click "Yes".

4. Click "OK".

7.5 Updating the blocks

7.5.1 Overview of tasks for updating blocks

Overview of the procedure     

Step Action ES OS 
Server

OS 
Client

AS

28 Copy objects from other libraries into the master data 
library (Page 67) 

X    

29 Complete the master data library (Page 68) X    
30 Synchronize blocks (Page 72) X    
31 Include event texts (Page 74) X    
32 Import operator texts (Page 75) X    
33 Adapt operator texts (Page 75) X    
34 Configure limit values for online trend control 

(Page 70) 
X    

35 Update block types (Page 76) X    
36 Update SFC block types (Page 78) X    
37 Compile CFC charts (Page 80) X    

7.5.2 Integration of a New Master Data Library

Basic Procedure
Creating a multiproject will also create an empty master data library. You copy all blocks from 
the first AS from the "Offline" block folder with the version to be updated to the master data 
library. Then compare the blocks in the master data library with the "Offline" block folder of the 
next AS. If it contains other blocks that have not been stored in the master data library, you 
also copy these to the master data library. Repeat this procedure through to the final AS.

 

 NOTICE

Only the AS blocks of one PCS 7 version may be loaded on a SIMATIC station.
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7.5.3 Language of Message Texts in Faceplates

Texts in Faceplates
If you want to convert messages displayed in the faceplates and generated from the ES data 
management from the English default to other languages, such as Italian or Spanish, you must 
perform the following procedure:

● Copy objects from other libraries to the master data library

● Copy the blocks used in the project to the master data library

● Edit the event texts and operator texts in the faceplates

● Update the block types in the project

Message Texts in Block Instances
Message texts from block instances that were created by copying block types have no type 
reference.

If other display languages (such as Italian, Spanish) are added after the software update, the 
message texts of these added display languages are shown in English in the block instances 
of the block types.

Including Message Text in the Block Import
If you want to include messages text in a block import, you need to make settings for the block 
type in the library (master data library).

 

 NOTICE

The message texts will be overwritten for all block instances of the block type in the entire 
S7 program!

 

Additional information
You can find additional information about this in the section "How to Include Event Texts from 
the Block Type in the Block Import (Page 74)".
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7.5.4 Editing Texts for Faceplates

Applications
The procedure steps in the section "Adapting Operator Texts with Import File" must be 
executed under the following conditions:

● You want to convert texts displayed in the faceplates from the default language (English) 
to another language, such as German or French.

● If you want to retain the old operator texts of your project.

Operator Texts in Block Instances
 

 Note

You can no longer re-integrate the operator texts by importing a block type if you have made 
changes to the operator texts in the block instances in your CFC charts. You can then only 
change the operator texts in the block instances.

 

7.5.5 Rules for Copying Objects from Other Libraries

Rules for Copying
● If you want to copy the process tag types supplied in the PCS 7 library to your master data 

library, select only the process tag types you require in the "Templates" folder. Copy these 
types and paste them into your master data library's "Charts" folder.   

● If you copy blocks into the master data library from different libraries, it is possible that 
blocks will be assigned different names (and functions) but the same block numbers. If this 
does occur, a dialog box will open where you can rename the block or synchronize the 
attributes.
Blocks can only be renamed (reassigned) when they are copied to the "Offline" block folder. 

● The symbolic name is also copied when you copy the blocks from a library. The symbolic 
name is lost and must be subsequently entered in the symbol table if you copy blocks from 
an S7 program and not from a library.

 

 
 NOTICE

Only the AS blocks of one PCS 7 version may be loaded on a SIMATIC station.
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Rules for Multi-instance Blocks
● In the case of blocks whose codes are used to call other blocks (multiple instance blocks), 

these lower-level blocks must be copied in the right version too.
Any missing lower-level FBs are displayed when the user program is compiled.

 

  Note

Note that the ES does not identify the missing FCs when the user program is compiled. 

If an FC is missing from the user program, the AS CPU will enter the STOP mode following 
download.

If necessary, test the executability of a user program with a "reduced library" on a separate 
CPU.

 

● The code of the multiple instance block always stores the numbers of the blocks it calls. 
You can edit those numbers and, therefore, the program code itself, using the Options > 
Rewire ... menu command in SIMATIC Manager. 
Exception: The numbers of protected blocks cannot be changed.

7.5.6 Rules for Editing the Operator Texts

Introduction
Comply with the following rules when modifying default texts.   

Rules
● The new texts must not be longer than the default texts. If longer texts cannot be avoided, 

you must check to see whether the message is displayed correctly on the faceplate.

● The "s7_unit" attribute does not have to be considered for the translation since blank spaces 
or international codes were used as default values.
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● If you need multilingual texts, use the WinCC Editor "Text Library" to translate these to other 
languages.
In SIMATIC Manager, you must therefore set exactly the dialog language that is to be used 
by default to configure the operator texts and display texts (usually "English") for display 
devices. This is the only way to ensure that the translated messages are not overwritten 
the next time the OS is translated.

● When the OS is compiled, the column that is always used as a reference is the one 
containing the language set in SIMATIC Manager as the "Standard language for display 
units". 
The texts in the Text Library of WinCC Explorer are automatically entered by PCS 7. 
Change the texts only if you have adapted unit and operator texts.

 

  Note

If you recompile the OS, you cannot switch the "Default language for display devices" in 
SIMATIC Manager. In this case, translated entries can be overwritten.
For more information, refer to the Process Control System PCS 7; Operator Station 
documentation, section "Relationship between Compile OS and Text Library".

 

7.5.7 How to Copy Objects from Other Libraries to the Master Data Library
This section describes how to transfer objects from the libraries supplied with your PCS 7 
version, or other libraries provided by external suppliers, to the master data library.     

 

 Note

During the software update, copy only the objects with versions that were used in the project 
to be updated from PCS 7 V8.0 to the new master data library.

 

 NOTICE

Only the AS blocks of one PCS 7 version may be loaded on a SIMATIC station.
 

Updating libraries used in the project
Depending on the blocks used, you need to update these with the blocks of the following 
libraries:

● PCS 7 Basic Library

● PCS 7 Advanced Process Library (APL)

● PCS 7 Library (For information on this, refer to the "How to Install Additional PCS 7 
Libraries (Page 48)" section)
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Requirement
● The master data library has been created in the project to be updated.

Procedure
1. Select the menu command File > Open in the SIMATIC Manager.

2. Open the "Libraries" tab.

3. Select the required library and click "OK". 
The library opens.

4. Select the library section to be copied from the open library (source).

5. Select the menu command Edit > Copy (e.g., process tag types, blocks).

6. Select the folder in the master data library (target) where the copied library section is to be 
stored.

7. Select the menu command Edit > Paste.
The copied library section is saved in the master data library.

Adapting default texts
Adapt the default texts in the master data library in which you have replaced the blocks (created 
in PCS 7 V7.1. SP3, for example) with PCS 7 V8.0 blocks.

Additional information
● Section "Editing Texts for Faceplates (Page 65)"

7.5.8 How to fill the master data library
The following tasks are only necessary if you update a project that has not been completely 
configured from the master data library.    

Requirements
● The master data library has been created and is open.

● The "Offline" block folder of a SIMATIC station is open.

● You are only using the original blocks from the PCS 7 libraries in the SIMATIC stations.

● You are not using blocks from different PCS 7 versions in the SIMATIC stations and wish 
to continue using the blocks from a single PCS 7 version following the PCS 7 update.

 

  Note

Only the AS blocks of one PCS 7 version may be loaded on a SIMATIC station.
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Procedure
1. Select the menu command View  > Details.

2. Select the detail view and click the column heading "Author". 
This arranges the blocks used in your project and contained in the offline block folder 
according to "Author".

3. Select all blocks listed with an "older" version number in the "Author" column (e.g. 
DRIVER60, "...60", "...70", ...)
Keep the <Ctrl> key pressed to select several blocks.

 

  Note

You also need to select the following BATCH blocks for projects with BATCH configuration:
● All blocks with the "BATCH" entry in the "Family" column
● The blocks READ_CLK and NOTIFY_8P, when they are used

 

4. Select the blocks or block areas that are not available in the master data library.

5. Select the menu command Copy in the shortcut menu.

6. Select the "Blocks" folder in the open master data library.

7. Select the menu command Paste in the shortcut menu. 
 If you have selected the "Always prompt for settings" check box in the "Set Message 
Range" dialog box, the "Message Number Assignment Selection" dialog box appears when 
you copy blocks.

8. Select the "Always assign CPU-oriented unique message numbers" check box.

9. Select the next "Offline" block folder and compare its blocks to the blocks that are already 
contained in your master data library. If the "Offline" block folder contains additional blocks, 
copy these blocks to the master data library you have created.

10.Repeat the steps 5 through 9 with all other "Offline" block folders.

7.5.9 Trend Control for Displaying Archive Values

Display in Trend Control
The following notes only need to be taken into account if you want to display archive values 
in trend control.

This section is not relevant for displaying online tags in trend control.

Name of the Available Archive
If the project being updated contains an archive called "Process Value Archive", the archive 
tags generated by the system are saved in an archive called "SystemArchive". 

If these archive values are to be accessed using the trend control display, the following settings 
must be changed in the block icon properties in the Graphics Designer:
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● ReturnPath: 
Transfers trend data for the corresponding process tag.

● StandardTrend: 
Used to define the trend functionality to be visualized in the trend view.

Procedure
1. In the tree structure, select the "Styles" object.

2. Make the following settings:

– StandardTrend: 
Change from 2 to 3.

– ReturnPath: 
Add the following in the return path: *archivname:Systemarchiv*asia:
Example: U:CO_DKGREEN*archivname:SystemArchive*asia:

Additional information
Manual Process Control System PCS 7; Programming Instructions for Blocks
 

7.5.10 How to Configure Extensions for Online Trend Control
You can specify the following parameters for automatically displaying value axis values in 
online trend control as part of process control:

● Limit values

– Maximum value (high limit)

– Minimum value (low limit)

● Unit

These parameters for displaying a tag in online trend control are automatically adopted by the 
associated function block when the OS is compiled.

Parameter Attribute "S7_trend"
Parameter attribute "S7_trend" can be assigned for function block I/Os, if the data type is one 
of the following:

● INT

● DINT

● Real
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Requirements  
● Parameter attribute "S7_m_c" is set to TRUE for the block and corresponding I/Os to be 

taken into account with (high and low) limit values in online trend control.

● The "Online trend control" object is inserted in the process picture.
 

  Note

The "automatic" check box is activated by default for "Online Trend Control" objects 
(Properties, "Value axis" tab, "Range selection" group).

 

 

 Note

Automatic adaptation of the high an low limits for archive tags in the Online Trend Control 
requires the following CFC configuration:

Set the archiving parameter (that is assigned parameter S7_trend) when you configure the 
associated block in the CFC.

Configurations using WinCC Tag Logging are not supported in PCS 7.
 

Procedure
1. Open SIMATIC Manager in the component view.

2. Select the block (block type) in the library (master data library).

3. Select the menu command Edit > Open Object.
The "LAD/FBD/STL" dialog box opens.

 

  Note

If a message appears that the block is write-protected, just ignore it.
 

4. In the tree structure, select the block I/O for which you want to specify parameters.

5. Select the menu command Edit > Object Properties.

6. Select the "Attributes" tab.

7. In an empty line, select the "S7_trend" entry from the drop-down list box.

8. Enter the name of the block I/Os at which you want to parameterize high and low limits for 
the selected I/O in the "Value" column. A comma separates the names (for example, 
LL_Name,HL_Name).

9. Click "OK".

10.Select the menu command File > Save.
The "Save ..." dialog box opens.

11.Click "Yes".

12.Select the menu command File > Close.
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Additional information
● Online help STEP 7

7.5.11 How to Update the Master Data Library

Introduction
The blocks of the master data library you created must be replaced with blocks of the current 
PCS 7 library. 

 

 Note
PCS 7 libraries

As of PCS 7 V7.1, the PCS 7 blocks included on the Process Control System; SIMATC PCS 
7 DVD are distributed to different libraries.

 

Library for Redundant I/O Modules
If you are using redundant modules in the project, then you must also update the "Redundant 
IO (V1)" library.

Requirements
● The master data library contains all blocks of the project being updated.

● The master data library is open.

● It does not contain any PCS 7 V4 or V5 blocks (types: IN_..., Out_ ..., and PA_blocks of a 
block version lower than 5.2).

Rule
 

 Note

The attributes of the individual blocks must be synchronized when replacing the blocks in the 
project being updated. Individual attributes of the old blocks can be applied if you have 
assigned the"S7_m_c" attribute to additional outputs, for example. You can apply the 
attributes of the new blocks if you have not made any changes to the default settings.
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Validity
 

 Note

The procedure described in the sections that follow is only valid for blocks whose object name 
and name (header) have not changed between library versions.

 

Procedure
1. Select the menu command File > Open in the SIMATIC Manager.

2. Open the "Libraries" tab.

3. Select a library from which you want to import blocks (e.g. PCS 7 AP Library V80). Click 
"OK". 
The library opens.

4. Double-click the "Blocks+Templates" folder and then on the "Blocks" folder.

5. Arrange the library one beneath the other so that the contents of both windows can be 
easily seen and the master data library is on the top.

6. Keeping the <Ctrl> key pressed, select all blocks which also exist in the master data library 
from the library you selected.

7. Right-click a selected block or block area, and select the menu command Copy in the 
shortcut menu.

8. Select the "Blocks" folder in the master data library, and select the menu command Paste 
in the shortcut menu.

9. Synchronize the attributes for each block individually by clicking the "Synchronize 
Attributes" button.
If various attributes are found, a dialog box displays the differences between the block 
attributes.

10.Check the attributes and the project-specific settings.
 

  Note

We recommend applying the default settings.
 

  Note

If you click the "All“ button in the "Insert Function Block" dialog box, all blocks will be copied 
without synchronizing the attributes.

 

11.Click "OK". 
If no differences between the attributes are identified, a dialog box indicating this is 
displayed.

12.Click "OK".
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13.Click "Yes". 
The corresponding block is copied to the master data library with the synchronized 
attributes.

14.Repeat those steps to select additional libraries.
 

  Note

For projects with BATCH configuration, repeat the procedure with the SIMATIC BATCH 
BLOCKS library.

 

 

7.5.12 How to include event texts from the block type in the block import

Introduction
One aspect that should be noted with a software update of projects, is that the message texts 
of block instances, generated by copying block types, have no type references. If other display 
languages (such as Italian, Spanish) are added after the software update, the message texts 
of these display languages are shown in English in the block instances of the block types.     

Importing and Editing Message Text of Block Instances
The following setting is required if you want to automatically overwrite the message texts of 
all instances in a block type for the entire S7 program.

If you want to edit the message texts of the instances, you need to deactivate this setting and 
perform an import again.

Procedure
1. Open the SIMATIC Manager in the Component View.

2. Select the block (block type) in the library (master data library).

3. Select the Edit  > Special Object Properties > Message Numbers menu command.
The "PCS 7 message configuration" dialog opens.
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4. Complete the following settings in the message texts column on the right side of the "Event" 
column of the table: The symbol appears as follows:

– Activate the check box for the message texts you want to import from the block type.

– Deactivate the check box for the message texts you do not want to import from the block 
type.

 

 
 NOTICE

The message texts will be overwritten at all block instances of the block type in the S7 
program! 

If you wish to modify the instances of the block types again, you must clear the 
corresponding check marks and perform another block import.

 

5. Click "OK".

7.5.13 How to import the operator texts

Requirements
The user texts have been exported from the project to be updated.  

Importing User Texts
1. Open the project to be updated in the SIMATIC Manager.

2. Select the master data library folder in the Component View. If this folder is not available, 
select the project folder.

3. Select the Options > Manage Multilingual Texts > Import menu command.
The "Import User Texts" dialog opens.

4. Specify the storage location and the format of the import file (possible formats: *.xls and 
*.csv).

7.5.14 How to adapt the operator texts

Requirements
● The master data library contains the PCS 7 V8.0 Update 1 blocks.

● The master data library is open.

● You have noted down the texts of the"S7_shortcut", "S7_string_0" and "S7_string_1" 
parameter attributes and the corresponding PCS 7 blocks.
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Procedure
There are different procedures for adapting the operator texts:   

● Adapting for block types
You can find more information about this in the manual Process Control System PCS 7; 
Operator Station in the section "How to Edit Texts for a Block Type".

●
You can find additional information in the "Process Control System PCS 7; Operator 
Station" manual in the section "How to Edit Texts in a Block Type."

We recommend that you adapt the operator texts for block types. This ensures the following:

● Operator texts of identical blocks are consistent in the different automation systems.

● Adapted texts are readily available for subsequent configuration.

You must also adapt the block type in the modified block instance if you have already adapted 
operator texts in CFC  block instances in manual mode.

Additional information
● Manual Process Control System PCS 7; Programming Instructions for Blocks in the section 

"ES Texts for Operator Control of Analog and Binary Values"

● Configuration manual Process Control System PCS 7; Operator Station in section 
"Adapting the Unit and Operating Texts".

7.5.15 How to update the block types in the project
 

 NOTICE

It is only possible to work with a master data library if blocks with the same designation have 
the same structure and attributes in all projects of the multiproject.   

 

Requirement
The master data library has been created with the current block types.

Procedure
1. Select all blocks that to be updated in the block folder of the master data library.

2. Select the menu command Options> Charts > Update Block Types.
The "Update Block Types" dialog box opens.

3. Select the S7 programs to be analyzed for the selected block types that differ from those 
in the master data library.
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4. Click "Next".
All S7 programs selected are checked and another dialog for selecting the block types 
opens. This provides information about the potential consequences of updating the block 
types.

5. Specify the block types to be updated for the various S7 programs. You must select all the 
block types to be updated. You can exclude selected block types from the update. If there 
are no block types available for updating, no block types are displayed. In this case, close 
the dialog box.

6. Click "Next".

Cleaning up block folders
Once the block types in the project have been updated, it is advisable to clean up the block 
folder in all automation systems. This action prevents inconsistency in data management 
caused by unused blocks. 

1. Open the CFC chart for each AS.

2. In the CFC Editor, select Options > Block types.
The "Block types" dialog opens.

3. Click "Clean Up".
The "Clean up block types in the block folder" dialog opens.

4. Select the block you do not need from the list.

5. Click "OK".

Result
The block types are updated in all selected S7 programs and a log is displayed.

Project with SFC
 

 Note

If you use SFCs in your project, please note that you need to update the SFC blocks. Refer 
to the SFC Readme.
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Additional information
● Online help on the dialog boxes

7.5.16 How to update the SFC block types in the project
 

 NOTICE

It is only possible to work with a master data library if blocks with the same designation have 
the same structure and attributes in all projects of the multiproject.   

 

Listing components with "old" versions of a block type
After having inserted a new version of a block type orSFC type into the master data library, or 
after you customized a block type in the master data library, you can use the "Update Block 
Types" function to list all components in which an older version of the modified block type is 
still in use. Throughout the entire multiproject, you can also select the components in which 
the modified block type will be updated.

Requirements
● The master data library has been created with the current block types.

Procedure
1. Select one or more SFC types in the chart folder of the master data library.

2. Select the menu command Options> Charts > Update Block Types.
The "Update Block Types" dialog box opens.

3. Select the S7 programs to be checked for differences compared with the block types/SFC 
types selected in the master data library.

4. Click "Next".
All S7 programs selected are checked and another dialog for selecting the block/SFC types 
opens. The dialog also provides information about the possible effects of the update of the 
block/SFC types.

5. Specify the block/SFC types to be updated for the S7 programs. You have selected all block/
SFC types to be updated. You can exclude selected block types from the update, if required.

6. If there are no block/SFC types to be updated, no block/SFC types will be displayed. In this 
case, close the dialog box.

7. Click "Make".

Result
The block/SFC types are updated in all selected S7 programs and a log is displayed.
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Additional information
● Online help on the dialog boxes

● Process Control System PCS 7; Engineering System Manual

7.5.17 Sequences during Compiling of CFC Charts

Driver Blocks for Compiling the CFC Charts
Since new block types were imported in the chart folder, you need to compile all CFC charts. 
This will use the imported driver blocks and optimize the program. 

Relationship between the Driver Blocks and the Master Data Library
 

 Note

In the case of PCS 7 libraries, the reference to the associated library is assumed by the driver 
generator.

When compiling with the "Generate module drivers" option, you can select an additional 
library (for example, a master data library) under "Settings Module Drivers". All driver blocks 
contained in the project must then be in this library.

 

F Charts/F Blocks
 

 

 NOTICE

If your project contains F charts/blocks and you do not upgrade to the new F technology, the 
F-@ charts should not be deleted. Otherwise, your F program will receive a different 
signature. The F system would then have to undergo the acceptance process again according 
to the country-specific guidelines due to the changed signature .
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7.5.18 Compiling the CFC Charts

Procedure
1. Perform a complete compilation of the S7 program.  

Additional information
● Process Control System PCS 7; Engineering System Manual

7.6 Adaptation of OS-relevant settings

7.6.1 Overview of Adaptation of the Operator Stations

Overview of the procedure

Step Action ES OS 
Server

OS 
Client

AS

38 Synchronize OS basic pictures, local computer 
actions, and faceplates (Page 81) 

X    

39 Update picture objects (Page 83) X    

User interface and design
After the software update to PCS 7 V8.0, the user interface for process mode must be set up 
according to the "WinCC 3D" design.         

You must check or edit this setting for existing projects. 

This setting is available automatically in projects created in PCS 7 V8.0. 

● It is important to ensure a uniform design setting is made for all projects within a system.

● When changing the setting for the WinCC design, check the visualization of user objects 
and customize these if necessary.

7.6.2 Synchronization of OS Basic Pictures, Local Computer Actions and Faceplates
You have to transfer OS basic pictures and local computer actions to your project. The 
faceplates of the project can continue to be used.   

Synchronization in the OS Project Editor
You perform this procedure with the OS project editor, which is included in WinCC Explorer.
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7.6.3 How to Synchronize OS Basic Pictures, Local Computer Actions, and Faceplates

Requirements
● The operator stations contained in the PCS 7 project have been updated with the Project 

Migrator.

● The PCS 7 OS is open in WinCC Explorer.

Procedure
1. Select the OS Project Editor and select the menu command Open in the shortcut menu.

2. Select the "Complete configuration" check box on the "General" tab.

3. Click the "Layout" tab.

4. Select the required layout and the monitor configuration.

5. Click the "Basic Data" tab. Make the required settings in accordance with the "Basic Data" 
table below.

6. Only carry out this step if the "For observation only" authorization level must be activated 
for some users after the software has been updated.
Select the "Message Display" tab. 
Activate the required message filters (see the "Message Filters" table below).

 

  Note

No settings are necessary for the software update on the remaining tabs. The default 
settings can be applied.

 

7. Click "OK".

Basic Data

Dialog Area Note Action
Top left 
window

This window lists all basic pictures having a different 
product version and project version change date.
Every basic picture with a selected check box is overwritten 
in the project version at the start of the OS Project Editor 
with pictures from the product version.

Activate the check boxes for all of the basic 
pictures identified with a red "X".

Top right 
window

This window lists all local computer actions having a 
different product version and project version change date.
Every local computer action with a selected check box is 
overwritten in the project version at the start of the OS 
Project Editor with the corresponding local computer action 
from the product version.

Activate the check boxes for all of the basic 
pictures identified with a red "X".

Bottom left 
window

This window lists all faceplates having a different product 
version and project version change date.

You can replace the faceplates available in 
the project with those of the relevant product 
version by transferring 
the default settings.

Adaptations in the PCS 7 Project on the ES
7.6 Adaptation of OS-relevant settings

Software update with utilization of new functions
Service Manual, 03/2012, A5E02779783-02 81



Message Filters

Parameters Meaning
Messages that 
can be 
acknowledged in 
a separate list

The message windows have two message lists. 
One list shows all messages from the area for which the user has access rights for all "operator process 
controls". The user can acknowledge messages in this list. 
The other list shows all messages from the area for which the user has an "authorization for area" but no 
access rights for "operator process controls". The user cannot acknowledge messages in this list. 
The message line in the overview area only shows messages that can be acknowledged with the access 
right for "operator process controls".

Messages that 
can be 
acknowledged 
on a separate 
page (switch-
selectable)

Both of the message pages indicated above are available to the user. Only messages from areas for 
which the user has access rights for "operator process controls" are displayed on the message page with 
only one list and in the message line of the overview area.

Additional information
● Online help WinCC Information System > Options > Options for Process Control > OS 

Project Editor

● Online help OS Project Editor

7.6.4 Update of Picture Objects

Introduction
In the course of the update of picture objects, the block icons of the PCS 7 version to be updated 
are replaced with block icons of the current PCS 7. This is necessary in order to enable you 
to use all functions of PCS 7 V8.0 Update 1.     

Rules
Only the block icons of the selected picture template are updated. For this reason, you must 
use the corresponding picture template for updating the picture objects, depending on the 
template you have used for configuration. 

● Use "@TemplateAPLV8.pdl" or "@PCS7TypicalsAPLV8.pdl" for the APL block icons.

● "@Template.pdl" or "@@PCS7Typicals.pdl" for block icons of the PCS 7 Library.

It is recommended to perform the update once on each individual picture template.
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7.6.5 How to Update the Picture Objects

Introduction
If you have manually inserted and interconnected picture objects from a picture template into 
a process picture, you must manually update these picture objects. 

When you update picture objects, the block icons of the previous PCS 7 version are replaced 
with the latest PCS 7 block icons.

You have to use the corresponding picture template that you used for configuration to update 
the picture objects. 
Recommendation: Perform the update one by one with each picture template of the library 
used.

● For block icons of the PCS 7 library:
"@Template.pdl" or "@@PCS7Typicals.pdl" 

● For APL block icons

– PCS 7 V8 template pictures:
- "@PCS7TypicalsAPLV8.pdl" 
- "@TemplateAPLV8.pdl"

 

  Note

Using a picture template for APL block icons of PCS 7 V7.1.3

The APL picture templates of PCS 7 V7.1.3 can continue to be used in PCS 7 V8.0 for 
updating picture objects:
● "@PCS7TypicalsAPLV7.pdl"
● "@TemplateAPLV7.pdl"

By using these picture templates in PCS 7 V8.0, the display of the block icons remains 
unchanged. 

Please note that executing the project editor copies the files 
"@PCS7TypicalsAPLV8.pdl"/"@TemplateAPLV8.pdl" into the project. 
● Delete the "@PCS7TypicalsAPLV8.pdl"/"@TemplateAPLV8.pdl" files. In this way, 

these picture templates ("@PCS7TypicalsAPLV7.pdl" / "@TemplateAPLV7.pdl") 
are used when executing the function "Create/update block icons" and in 
compilation processes.

● It is imperative that you always use the same versions of the 
@TemplateAPL<Version>.pdl" and "@PCS7TypicalsAPL<Version>.pdl" files.

Overwriting default settings

User scripts and modified properties of the picture objects are overwritten by the default 
settings.

 

Only the block icons of the selected picture template are updated.
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Requirements
● The operator stations contained in the PCS 7 project have been updated with the Project 

Migrator.

● All basic pictures are replaced with the OS Project Editor.

● The PCS 7 OS is open in WinCC  Explorer.

Procedure
1. Open any WinCC picture containing a picture object in the Graphics Designer. Select the 

picture object.

2. In the dynamic wizard, open the "Picture Functions" tab and select "Update Picture Objects".
This "Dynamic Wizard" dialog opens.

3. Click "Next".

4. Select the "Yes, all pictures" check box.

5. Click "Next".

6. Select the template in the list which has been configured with the picture objects of the OS. 
(Default:@Template.pdl)

7. Select the default "TemplateControl.cfg" configuration file from the "Please specify name 
of configuration file" field.

8. Click "Next".

9. Click "Finish".
Generation of the picture objects is initiated in the Dynamic Wizard.

7.7 Adaptations for the Maintenance Station

7.7.1 Overview of the Maintenance Station update
Along with the steps specified for the OS Server, you also need to complete a sequence for 
updating an MS server. The corresponding additional steps are listed below.

Overview of the procedure

Step Action ES OS 
Server

OS 
Client

AS

40 Changing the OPC Server and adapting the SNMP 
configuration (Page 85) 

X    

41 Updating the diagnostics settings (Page 87) X    
42 Updating the diagnostics screens  (Page 88) X    
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7.7.2 How to change the OPC Server and adapt the SNMP configuration

OPC Server version
Run a compatibility check after migration to a different operating system, as the OPC Server 
version is dependent on the operating system used.

If incompatible, replace the OPC Server.

The following table lists the compatibilities:

Operating system of the MS Server OPC Server version
Windows XP
Windows Server 2003
Windows Server 2008

V7.0

Windows Server 2008 R2
Windows 7

V8.1

Requirements
● The blocks, charts and OS pictures of the project are updated.

● The SIMATIC programs and OS are compiled.

● The PC stations of the Maintenance Station (MS Server and MS Client) are updated in a 
similar way to an OS.

● MS multiple station system

– The OPC Server is configured on the PC Station of the MS Server.

– In a system with redundant MS Servers, you configured an OPC Server both for the PC 
Station of the MS Server and for the PC Station of the redundant partner.

● MS single station system

– An OPC Server is configured on the PC Station of the MS single station system.

Procedure
1. Select the PC station in the Component View.

– In an MS multiple station system, this is the PC Station of the MS Server or of the 
redundant partner.

– In an MS single station system, this is the PC Station of the MS single station system.

2. Double-click the "Configuration" object in the Detail View to open HW Config.
The hardware configuration of the SIMATIC PC station opens.
If you cannot see the hardware catalog, select the View > Catalog menu command.
The hardware catalog opens.

3. Select the current version of the OPC Server from the hardware catalog at SIMATIC PC 
Station > User application > OPC Server and drag-and-drop it to the position of the OPC 
Server.
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4. Click "OK" to confirm the replacement of the OPC Server.

5. Save and compile your changes.

6. Select the "OPC Server" object in the rack.

7. Select the menu command Station > Properties.

8. Open the "SNMP" tab.

9. Click the "Export Tags for WinCC" button.

10.Select the Station > Save and Compile menu command.

11.Repeat steps 1 to 5 if using the MS Server in a redundant MS multiple station system.

12.Perform the following actions if the project contains field devices that were configured in 
SIMATIC PDM:

– Select the Options > SIMATIC PDM > Settings command in SIMATIC Manager.
The "SIMATIC PDM settings" dialog box opens.

– Select the "Maintenance Station" tab.

– Enter the file path of the PCS 7 project.

– Click "OK".

Updating SIMATIC PDM to V8.0
Install SIMATIC PDM. Refer to the PDM Readme.

The SIMATIC PDM-related project data is updated automatically after the project is opened 
in SIMATIC Manager. 

 

 NOTICE

During the update, new PLT IDs are assigned to the configured ASSETMON objects. Then, 
perform the following steps:
● Adapt these PLT IDs to the corresponding ASSETMON block instances.
● Compile the automation systems.
● Create the diagnostics screens again.
● Compile the corresponding operator stations.

 

Please note that you need to start the SIMATIC PDM ASSET Service in the SIMATIC PDM 
ASSET Service Manager on the engineering station once manually in order to receive data 
from PDM. You will find the SIMATIC PDM ASSET Service Manager in the information area 
of the toolbar of your operating system.
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Additional information
● Information about the configuration of user diagnostic structures and user diagnostic 

screens is available in the Process Control System PCS 7; Operator Station Configuration 
Manual.

● You will find a description of working with the maintenance station in process mode in the 
manual Process Control System PCS 7; Operator Station Process Control.

● Process Control System PCS 7; Creating Driver Blocks manual

7.7.3 How to update the diagnostics settings

Introduction
The representation of devices and the block icons have been revised. The modified geometry 
has an impact on the positioning of objects in the pictures. 

The revised design will be used in the pictures if you run the "Migrate diagnostics settings" 
function.

This has the following implications:

● Overview screen
The new "overview.pdl" overview screen will be created. Changes you inserted from the 
previous overview screen will be discarded.
The previous overview screen will be renamed and saved to the "Graphics" folder of WinCC 
Explorer.
Copy the changes from the previous overview screen.

Requirement
● The OS Project Editor is running.

It is not necessary to make any setting in the OS Project Editor. 

Procedure
1. Select the multiproject in the plant hierarchy.  

2. Select the Options > Plant Hierarchy > Settings... menu command.
The "Plant Hierarchy - Settings" dialog opens.

3. Activate the "Migrate diagnostics settings" check box.

4. Click "OK".
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7.7.4 How to update the diagnostics screens
Updating the diagnostics screens has the following effects:

● Pictures in the AS objects area
Block icons that represent racks will be repositioned in the picture.
You can move the block icons to different positions.

● Pictures in the PC Stations and network objects area
The block icons will possibly overlap in these pictures.
You can move the block icons to different positions.

Requirements
● A backup copy of the diagnostics screens with project-specific adaptations has been 

generated.

● An asset ID has been assigned to each AS and PC station in HW Config.

● Diagnostics settings are updated.

Procedure
1. Select the multiproject (project) in the plant hierarchy.

2. Select the Options > Plant Hierarchy > Create/Update Diagnostics Screens menu 
command. 
Update the diagnostics screens. You can find information about this in the Process Control 
System PCS 7; Operator Station configuration manual.

3. Compile the OS of the maintenance station (changes).

4. Update the server data of the MS server.

5. Download the MS server.

Additional information
For information on options for accessing maintenance functions, refer to the following 
documentation:

● Process Control System PCS 7; Operator Station manual

● Process Control System PCS 7; Web Option for OS manual

● Process Control System PCS 7;.OS Process Control operating instructions

● Information about the configuration of user diagnostic structures and user diagnostic 
screens is available in the Process Control System PCS 7; Operator Station Configuration 
Manual.

● You will find a description of working with the maintenance station in process mode in the 
manual Process Control System PCS 7; Operator Station Process Control.

● Process Control System PCS 7; Creating Driver Blocks manual
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7.8 Additional Options

7.8.1 Overview of additional options

Overview of the procedure

Step Action ES OS 
Server

OS 
Client

AS

43 Updating the PCS 7 Web Option for OS (Page 89) X X   
44 Updating PCS 7 Components that Use SIMATIC 

Logon Services (Page 90) 
X X X  

 

7.8.2 Updating the PCS 7 Web Option for OS

Requirement
In order to utilize the full functional scope of the PCS 7 Web Option for OS, you may only use 
blocks from the current PCS 7 library in the PCS 7 project.       

Procedure
● You update the OS Web server, an OS client, similar to an OS client.

● The process pictures that will be opened on a Web client must be "published" again.

● You only need to update the software when performing a software update for a Web client.

● When updating software for a Web diagnostics client, you will have to remove and then 
install the software.

Additional information
For more information, refer to the Process Control System PCS 7; Web Option for OS Manual. 
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7.8.3 Updating PCS 7 Components that Use SIMATIC Logon Services

Additional information 
● For detailed instructions about the setup, parameter assignment and changes to complete 

for SIMATIC Logon, refer to the respective components that use SIMATIC Logon.

● Generally valid basic information about SIMATIC Logon is available in the SIMATIC 
Logon Online Help.

7.9 Work for the OS in SIMATIC Manager

7.9.1 Overview of compiling

Overview of the procedure     

Step Action ES OS 
Server

OS 
Client

AS

45 Specifying the compilation mode (Page 91) X    
46 Compiling the OS (Page 92) X    
47 Adapting the OS client (Page 94) X    

7.9.2 Information regarding the compilation modes
The compilation mode determines which data are downloaded to the OS Server. The setting 
must be made separately for each project of a multiproject.    
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Compilation modes
The following modes are available:

Mode Meaning
Area-oriented This setting enables you to assign an OS area of the PH to an OS Server. This 

is the default setting for projects created as of PCS 7 version 6.1. 
All data of an OS area are downloaded to the OS Server when this compilation 
mode is used.
This mode can only be set for projects with configured PH.

AS-oriented This setting enables you to assign an S7 program to an OS Server, i.e. you 
define which OS accesses data from which automation system. All data of an 
automation system are downloaded to the OS Server when this compilation 
mode is used. This mode is set by default for:
● Projects created in PCS 7 version previous to V6.1.
● Projects without configured PH.
 

 

 Note

If you use a maintenance station in the project, you need to set "area-oriented" compilation 
mode for the multiproject.

 

Additional information
● Process Control System PCS 7; Operator Station Configuration Manual

7.9.3 How to Specify the Compilation Mode

Requirements
● The Operator Stations in the PCS 7 project have been updated using Project Migrator.   

Procedure
 

 NOTICE

After changing the compilation mode, you can only perform an online download after 
performing a complete download of the OS.

 

1. Open SIMATIC Manager and select any view. Component view, plant view or process 
object view.

2. Select a PCS 7 project from the tree structure.
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3. Select the menu command Options > "Compile Multiple OSs" Wizard > Compilation Mode. 
The "Compilation Mode" dialog box opens.

4. Select the compilation mode (refer to the introduction of this section above).

5. Click "OK".

The settings for the compilation mode are applied in the "Compile Multiple OSs" wizard. 
 

 Note

These settings are applied to all OS servers in a project.
 

Additional information
● Process Control System PCS 7; Operator Station Configuration Manual

7.9.4 How to Compile the OS
 

 Note

You must compile the OS if you changed the target paths on the ES.   
 

 
 

 Note

Using a picture template for APL block icons of PCS 7 V7.1.3

The APL picture templates of PCS 7 V7.1.3 can continue to be used in PCS 7 V8.0 for 
updating picture objects:
● "@PCS7TypicalsAPLV7.pdl"
● "@TemplateAPLV7.pdl"

By using these picture templates in PCS 7 V8.0, the display of the block icons remains 
unchanged. 

Please note that executing the project editor copies the files 
"@PCS7TypicalsAPLV8.pdl"/"@TemplateAPLV8.pdl" into the project. 
● Delete the "@PCS7TypicalsAPLV8.pdl"/"@TemplateAPLV8.pdl" files. In this way, these 

picture templates ("@PCS7TypicalsAPLV7.pdl" / "@TemplateAPLV7.pdl") are used when 
executing the function "Create/update block icons" and in compilation processes.

● It is imperative that you always use the same versions of the 
@TemplateAPL<Version>.pdl" and "@PCS7TypicalsAPL<Version>.pdl" files.

Overwriting default settings

User scripts and modified properties of the picture objects are overwritten by the default 
settings.
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Requirements
● The PC station has been configured.

● The configuration in CFC and SFC has been completed.
 

 
 NOTICE

If you have changed unit and operator texts of the block types in the master data library, 
be sure to set your default language as the "Language for display devices".

 

Procedure
 

 Note

For more information on compilation options, refer to the Process Control System PCS 7; 
Engineering System Configuration Manual.

 

1. Select the object (multiproject, project, station) in SIMATIC Manager that you wish to 
compile or compile/download.

2. Select the PLC > Compile and download objects command in SIMATIC Manager.
The "Compile and download objects" dialog box opens.

3. Open the tree structure.

4. Activate the check box in the "Compile" column for all objects that you want to compile.

5. Click the "Operating State" button and check the operating states of your objects (RUN, 
activated, etc.) so that you can make the correct settings for compilation.

6. Select the OS that you wish to compile.

7. Click "Edit".
The "Settings: Compile OS ... Areas ..." dialog box opens.

8. Click "Next".
The "Settings: Compile OS ... Network Connections ..." dialog box opens.

9. Click "Next".
The "Settings: Compile OS ... Compilation Data and Scope of Compilation" dialog box 
opens.

10.In the "Scope" group, activate the "Entire OS" and "With memory reset" check boxes.

11.Click "Apply".
 

  Note

Once you have completed your settings for compiling an operator station, please wait until 
the compilation settings have been saved and the download dialog box appears. 

 

12.Make the required settings for the individual objects.

13.Click "Help" in the dialog box for detailed information about the settings.

14.Click the "Start" button. 
Compilation starts.
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15.Follow the instructions on the screen.

16.If you wish to see a log of the compilation once it is complete, click the following buttons in 
the "Display Log" area:

– "Single object": the detailed compilation log of the selected OS is displayed.

– "All": Displays the results of all compilations (without details).

 

7.9.5 How to make adaptations for the OS clients
 

 Note

The following procedures musts be carried out for each OS Server if there are several OS 
servers present in the project.   

 

Procedure
1. In the component view of the SIMATIC Manager, select the OS client project on the PC 

station.

2. Select the menu command Options > OS > Assign OS Server....
The "Assign OS Server ..." dialog box opens.

3. In the list of OS servers, check for the server whose data you would like to view on this 
client, to ensure the check boxes for this OS Server have been selected.

4. Click "OK".

5. In the component view in SIMATIC Manager, select the "OSC" object of the OS client.

6. Select the menu command Edit > Open Object.
The WinCC Explorer opens.

7. Select the menu command Configure in the shortcut menu of the "Server data" editor in 
order specify the preferred server if there are redundant OS servers.

8. Select the menu command standard server in the shortcut menu of the "Server data" editor 
in order to specify a standard server for interrupts and SSM.

9. Select the OS Project Editor and select the menu command Open in the shortcut menu.

10.Activate the "Complete configuration ..." check box on the "General" tab.

11.Click the "Layout" tab.

12.Select the required layout and the monitor configuration.

13.Click the "Basic Data" tab. Make the required settings in accordance with the "Basic Data" 
table below.

14.Only carry out this step if the authorization level "For observation only" must be activated 
for some of the users after the software has been updated:
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15.Select the "Message display" tab. 
Activate the required message filters (see the "Message Filters" table below).

 

  Note

No settings are necessary for the software update on the remaining tabs. The default 
settings can be applied.

 

16.Click "OK".

17.In WinCC Explorer, open the "Time Synchronization" editor.
Activate the "Synchronization via terminal bus (slave)" check box. 
Select the "Use the time from a connected WinCC server" option. 
Close the dialog box.

18.Open the "Lifebeat Monitoring" editor and click the "Update" button in the dialog box. Close 
the dialog box.

Basic Data

Dialog Area Note Action
Top left 
window

This window lists all basic pictures having a different 
product version and project version change date.
Every basic picture with a selected check box is overwritten 
in the project version at the start of the OS Project Editor 
with the pictures from the product version.

Activate the check boxes for all of the basic 
pictures identified with a red "X".

Top right 
window

This window lists all local computer actions having a 
different product version and project version change date.
Every local computer action with a selected check box is 
overwritten in the project version at the start of the OS 
Project Editor with the corresponding local computer action 
from the product version.

Activate the check boxes for all of the basic 
pictures identified with a red "X".

Bottom left 
window

This window lists all faceplates having a different product 
version and project version change date.

You can replace the faceplates available in 
the project with those of the relevant product 
version by transferring 
the default settings.
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Message Filters

Parameters Meaning
Messages that 
can be 
acknowledged in 
a separate list

The message windows have two message lists. 
One list shows all messages from the area for which the user has access rights for all "operator process 
controls". The user can acknowledge messages in this list. 
The other list shows all messages from the area for which the user has an "authorization for area" but no 
access rights for "operator process controls". The user cannot acknowledge messages in this list. 
The message line in the overview area only shows messages that can be acknowledged with the access 
right for "operator process controls".

Messages that 
can be 
acknowledged 
on a separate 
page (switch-
selectable)

Both of the message pages indicated above are available to the user. Only messages from areas for 
which the user has access rights for "operator process controls" are displayed on the message page with 
only one list and in the message line of the overview area.

7.9.6 Mixed Operation of Faceplates from Different Versions of PCS 7

Definition of Mixed Operation   
Mixed operation is the visualization of AS blocks from different PCS 7 versions on one OS 
client.

Compatibility of the PCS 7 V8.0 faceplates
 

 Note

You can use the PCS 7 V8.0 faceplates to control and monitor the AS blocks of the following 
PCS 7 versions:
● PCS 7 V7.1.3
● PCS 7 V8.0

 

Compatibility with faceplates of the Advanced Process Library (APL) of PCS 7 V8.0
 

 Note

The APL faceplates can be used to monitor and control AS blocks of the APL.
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Rules
 

 NOTICE

Mixed operation is only permitted on OS clients.
 

● AS blocks of different PCS 7 versions can be visualized on an OS client if the server data 
of several OS servers is loaded to the OS client with AS blocks of different PCS 7 versions.

● Only the AS blocks of one PCS 7 version may be loaded on an AS.
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Using the APL V8.0 8
8.1 Migrating to APL V8.0

Measures to be taken when migrating to APL V8.0
When migrating to APL V8.0, replace the old blocks and modify the configuration data 
accordingly. This chapter specifies the measures to take when migrating PCS 7 projects to 
APL V8.0.

 

 Note

If you are going to use the APL V8.0 blocks, you cannot use blocks of any other APL version 
in the project.

 

 Note

The APL V8.0 setup routine does not overwrite old libraries.
 

 

8.2 Customization overview

Replacing blocks
Replace the following blocks when updating APL V7.1 to APL V8.0:

● Channel blocks (e.g. CH_CNTx)

● Motor starters

● Blocks for high-precision time stamping

Expenditure
● Replacement of APL V7.1 blocks with APL V8.0 blocks

● Corresponding modification of the configuration data for all blocks migrated from the 
Standard Library to APL.

 

  Note

It is not possible to customize all blocks to suit the new requirements of APL V8.0 by 
running an operating system update, i.e. it is possibly inevitable to replace hardware.
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Requirement
APL V8.0 has been installed.

Procedure

Step Action ES OS 
Server

OS 
Client

AS

48 Creating the project library (Page 100) X    
49 Copying blocks to the project library (Page 101) X    
50 Creating a reference list  (Page 102) X    
51 Replacing APL blocks (Page 102) X    
52 Copying blocks to the block folder (Page 104) X    
53 Importing blocks to the chart folder X    
54 Interconnecting block I/Os (Page 105) X    

 
 

 Note
Run a test prior to commissioning

You are strongly advised to test your reconfigured charts before you start commissioning.
 

 

See also
How to import the blocks to the chart folder (Page 104)

8.3 How to create a project library

Optional task
It is not necessary to complete this task if you have already created a project library in your 
V7.x project. You can use a copy of this project library to complete the further procedures in 
this chapter. It is advisable to create a project-specific library at this point if you have not already 
completed that task. The blocks pending replacement in the PCS 7 project are copied to this 
library.

Requirements
● The Operator Stations in the PCS 7 project have been updated using Project Migrator

● The PCS 7 project is opened (on the ES).
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Procedure
1. Select File > New to open the "New" dialog.

2. Select the "Libraries" tab and set the type: "Library".

3. Enter a name for your new library (e.g. NAME:"NEW_BIB") in the "Name" input field

4. Confirm and save your entries with "OK"

5. Select the folder in the next dialog

6. Insert an S7 program with right-click > Insert new object > S7 program

7. Select the block folder for the new project-specific library S7 program\Blocks

8. Copy the blocks of the same name used or to be used from the PCS 7 V8.0 APL to the 
new project-specific library.

8.4 How to copy blocks to the project library

Collecting the blocks used in the project library
It is not necessary to carry out this step if a project library was already available in the project 
before the software update. You can use a copy of this project library to complete the further 
procedures in this chapter.

Copy the V7.1 blocks of your PCS 7 project from the Offline folder to the new project library.

The objective is to copy all blocks from all automation systems to the project library. 

Start by copying all V7.x blocks of the first AS from the "Offline" block folder to the master data 
library. Compare the blocks in the library with the Offline block folder of the next AS. Copy any 
additional blocks found to the project library. Complete this task for all automation systems.

Requirement
● The project library is opened

● The block folder is opened and offline.

Procedure
1. Select View > Details to open the Details View and click in the "Author" column heading. 

This sorts the V7.1 blocks used in your project and contained in the offline block folder by 
the "Author" column.

2. Hold down the "CTRL" key and select all APL V7.1 blocks listed in the "Author" column with 
left-click.

3. Right-click a selected block or block area and select the "Copy" command from the shortcut 
menu.
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4. Select and right-click the "Blocks" folder in the open project library.
Select "Insert" from the shortcut menu. 
 If you have selected the "Always prompt for settings" in the "Set Message Range" dialog, 
the "Message Number Assignment Selection" dialog appears when you copy blocks. 
Activate the "Always assign CPU-oriented unique message numbers" check box.

5. Select the next offline block folder and compare its block content with the block content of 
your project library.
Copy any additional blocks found from the offline block folder to your new project library.

6. Repeat step 5 with all other offline block folders.

8.5 How to create a reference list

Creating reference lists
A reference list of all blocks can be useful when you replace driver blocks. 

Procedure
Complete the following actions to create this reference list (block types):

1. CFC: Open any chart of the AS.

2. CFC: Select the Options > Chart Reference Data menu command to open the view of chart 
reference data. 

3. Chart ref: Run the View > Cross-References menu command.

The list that is now generated covers all blocks.

● Select Chart Reference Data > Generate Export File to save the list to a file. It is 
recommended to review the list in a tool such as MS EXCEL. The list should only contain 
the references to channel and driver blocks, as well as to the blocks for high-precision time 
stamping.

● Select Chart Reference Data > Print to obtain a printed copy of the list.

8.6 How to replace APL V7.1 blocks with V8.0 blocks

Replacing blocks
APL V7.1 blocks that you copied to your new project library must be replaced with the new 
APL V8.0 blocks.

 

 Note

Synchronize the attributes of all APL V7.1 blocks that you replace. You can apply the 
attributes of the new blocks if you have not made any changes to the default settings.
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Requirement
● The project library contains APL V7.1 blocks

● The project library is opened

Procedure
1. In SIMATIC Manager, select the "Libraries" tab and click File > Open  to open the "PCS 7 

AP Library V80".

2. Double-click the "Blocks+Templates" folder and then the "Blocks" folder.

3. Arrange both library windows vertically to obtain a clear view of their contents. The library 
window should be positioned on the top.

4. In the "PCS 7 AP Library V80", hold down the "CTRL" key and select all blocks that are 
also contained in the project library with left-click.

5. Right-click a selected block or block area and select the "Copy" command from the shortcut 
menu.

6. Select and right-click the "Blocks" folder in the project library. Select "Insert" from the 
shortcut menu.

7. Click "Synchronize Attributes" to synchronize the attributes separately for each block.

8. A dialog displays any attribute differences found. Check the attributes and the project-
specific settings.

 

  Note

It is recommended to accept the default settings that are offered. 

Click "OK" to copy the corresponding block to the project library, including the 
synchronized attributes.

A dialog informs you accordingly if no different attributes are found. Confirm this dialog 
with "OK". 

Click "Yes" to copy the corresponding block to the project library, including the 
synchronized attributes.

Click the "All“ button in the "Insert Function Block" dialog to copy all blocks without 
synchronizing their attributes.

 

9. Copy the APL V8.0 counterpart of the remaining blocks that were not replaced to the project 
library and delete the old blocks.
Use the overview of old and new blocks that are provided in the annex of this documentation 
to select the suitable blocks. 
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Further notes
● For more information on the APL V8.0 blocks, refer to the documentation in the PCS 7 

Library: file LIB-Readme.wri

8.7 How to copy the new blocks to the block folder

Copying blocks
Copy all new blocks from the project library to the offline folder of the S7 program. Complete 
the following steps for all S7 programs of your PCS 7 project, or for all offline block folders, as 
well as for the program folder that possibly contains model solutions.

Requirements
● The APL V7.1 blocks in the project library were replaced with APL V8.0 blocks with attribute 

synchronization.

● The project library is opened

● The block folder is opened and in "offline" state.

Procedure
1. Select all blocks in your project library and then right-click these.

2. Select "Copy" from the shortcut menu.

3. Left-click in the selected area, hold down the mouse button and move the selected blocks 
from the project library to the offline folder.

4. Click the "All“ button in the "Insert Function Block" warning dialog as you already 
synchronized their attributes.

5. Close the project library.

8.8 How to import the blocks to the chart folder

Importing Blocks
Import the newly replaced blocks from the offline folder to the chart folder. Complete the steps 
specified in the procedures section for all S7 programs of your PCS 7 project, or for all offline 
block folders, as well as for the program folder that possibly contains model solutions.

Procedure
1. Open a CFC chart from the S7 program in which you have just replaced the library blocks.

2. In the CFC , select Options > Block types to open the "Block types" dialog.
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3. Select all blocks in the "Chart folder" field on the right side and click "New version". The 
new block versions are now imported. Confirm all dialogs output during the import with 
"Yes".

4. Once you completed the block import, click "Clean Up". The first dialog lists the block types 
that are not in use in your program, but still contained in your chart folder. Select the blocks 
you no longer need. These blocks will be deleted from the chart folder. The second dialog 
lists the block types that are not in use in your program, but still contained in your offline 
block folder, or which are superfluous. Select the blocks you no longer need. These blocks 
will be deleted from the offline block folder.

5. Close the dialog.

8.9 How to create new interconnections for the block I/O

Inserting and reconnecting blocks
You need to complete this task if blocks of a different library (not APL) are to be replaced with 
APL V8.0 blocks. The following actions must be completed for all connections of each block 
to be replaced (block types reference list).

A comparison of the block I/O is available in the "Overview of the block I/O of the 'Pcs7Cntx' 
blocks (Page 117)" section. 

Requirements
● The reference list is open.

● The chart folder contains the APL V8.0 blocks.

● The CPU is in "offline" state.

Procedure
1. Open the chart

2. Copy the new block to the chart

3. Drag the interconnections from the old block (e.g. CH_CNT1 - input LADDR) to the new 
block (e.g. Pcs7Cnt2 - input Laddr).

4. Repeat steps 1 to 3 for all other blocks to be replaced.
 

  Note
Run a test prior to commissioning

You are strongly advised to test your reconfigured charts before you start commissioning.
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Adaptations on the Central Archive Server 9
9.1 Overview of Updating the Servers for Central Archiving

Overview of the procedure       

Step Action ES OS 
Server

OS 
Client

AS

55 Adapting the central archives (Page 107)  X1, X2   

X1 - to be performed only on the central archive server

X2 - to be performed only on the StoragePlus server for central archiving

Manually connected databases from CAS/Storage Plus PCS 7 < V7.0
Before you update the central archive server software (SW update installation), you need to 
disconnect any *.SPB (StoragePlus Backup) databases that may be linked to the project. SPB 
databases come from CAS/Storage Plus PCS 7 < V7.0 or up to V1.1.1 inclusive.         

Testing and disconnection takes place via the StoragePlus Administration Console.
 

 Note

If you still need the values archived in the SPB databases for display, you must reconnect 
these SPB databases after the update. 
● You may see an error message during the software update: 

"Error when disconnecting backup databases from the SQL server!"
Provided there are no SPB databases connected with the project, you can ignore this 
message and confirm with "OK".

 

9.2 How to adapt the archives of the Central Archive Server (CAS)

Requirements
● All archives are swapped out under PCS 7.      

● The data (LDF files and MDF files) from the database path are backed up.

● The name of the database of the PCS 7 project to be updated is known.

● The backed up data (LDF files and MDF files) can be accessed from the PC station of the 
CAS.

● The server data for the OS server are generated.
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Procedure
1. Install the software of the archive server (central archive server or StoragePlus server). 

Make sure the following information is entered correctly (see section titled "Overview of 
Adaptations for Central Archiving (Page 21)"):

– Name of the database

– Path of the database

– Path of the data log

– Shared archive directory

2. Check the configuration of the archive server:
Central archive server

– In SIMATIC Manager, check the parameterized properties of the CAS and load the 
"Central Archive Server" target system.
For more information, refer to the Process Control System PCS 7; Operator Station 
Manual.

StoragePlus Server

– In the Windows Start menu, select the "Administration Console" command from the 
SIMATIC > StoragePlus submenu.

– Check the parameter assignment of the StoragePlus Server in the System Configuration 
> Common folder.

3. In the Windows Start menu, select the "Administration Console" command from the 
SIMATIC > StoragePlus submenu.

4. The data (LDF files and MDF files) are saved to the database path.

Differences between Archiving with the Central Archive Server and StoragePlus
 

 NOTICE

In contrast to StoragePlus, a central archive server only processes the archives when process 
mode (runtime mode) is activated on the central archive server.
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Downloading of Target Systems 10
 

Once you have updated your PCS 7 project in offline mode, download the changes to the 
target systems (AS, OS).   

 

 NOTICE

If using new or updated blocks from the PCS 7 libraries, set the AS to STOP before you load 
the target systems.

 

Requirements
● The network addresses and network settings of the PC stations are configured.

● The configuration of the PC stations in HW Config and in the Station Configuration Editor 
match.

● The configuration of the PC stations is loaded on the PC stations.

Procedure
1. Download connection and configuration data to the all stations via NetPro. Begin with the 

ES.

2. Check the setting of the access points on all PC Stations (local).
In the Windows Start menu, select SIMATIC > SIMATIC NET, menu command Configure 
PC Station.

3. You can successively download all target systems systematically and automatically. In 
SIMATIC Manager, select the menu command PLC > Compile and Download Objects.

Additional information
For more information, refer to the Process Control System PCS 7; Engineering System manual.
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Activate the operator stations 11
11.1 Overview of activating the operator stations

Introduction
The following sequence applies when activating process mode (runtime):     

● Master Server (OS Server)

● Standby server (redundant OS Server)

● OS clients

Overview of the procedure

Step Action ES OS 
Server

OS 
Client

AS

57 Checking the settings of the OS Servers (Page 111)  X   
58 Checking the settings on the OS Clients (Page 112)   X  

11.2 How to Check the Settings on the OS Servers
Before activating the projects downloaded to the various OS servers, you need to check some 
of the settings in each OS as a safety precaution.   

Requirement
● The PCS 7 OS is open in WinCC Explorer.

Procedure
1. Open the "Redundancy" editor in WinCC Explorer.

2. Check all settings.

3. Click "OK".

4. Open the "Time Synchronization" editor in WinCC Explorer.

5. Check all of the settings in the dialog box.

6. Click "OK".
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7. Repeat steps 1 through 6 for the second OS Server and all other redundant OS servers.
 

  Note

If you have installed a new operating system or have changed the settings, restart the 
computer.

 

8. Activate process mode on the OS servers.

11.3 How to Check the Settings on the OS Clients

Introduction
Before activating the projects downloaded to the various OS clients you must check some of 
the settings in each OS.   

Requirements
● The PCS 7 OS is open in WinCC Explorer.

Procedure
1. Open the "Time Synchronization" editor in WinCC Explorer.

2. Check all settings.

3. Click "OK".

4. Repeat steps 1 through 3 for the other OS clients.

5. Activate process mode on the OS clients.

Activate the operator stations 
11.3 How to Check the Settings on the OS Clients
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Updating SIMATIC BATCH 12
 

Introduction
 

 Note

Please observe the following when updating the software from PCS 7 V7.1 SP3 (with 
SIMATIC BATCH V7.1 SP1) to PCS 7 V8.0 (with BATCH V8.0):
● To save the project "with reorganization", you first need to manually replace the BATCH 

application in the PC stations in HW Config.
● Set the BATCH Start Coordinator to "Manual" start mode before you update the software.

It is essential that you observe these points when you prepare the software update. You can 
find additional information on this topic in the section "Overview of preparations (Page 25)". 

 

For more information on updating SIMATIC BATCH, refer to the following documentation:   

● SIMATIC BATCH Readme; Part C1, Installation

● Manual Process Control System PCS 7; SIMATIC BATCH
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Updating SIMATIC Route Control Stations 13
13.1 Updating SIMATIC Route Control

Updating SIMATIC Route Control
You can find information about this in the Process Control System PCS 7; SIMATIC Route 
Control documentation.

 

 NOTICE

STOP of automation system required

SIMATIC Route Control V8.0 requires functions from the PCS 7 V8.0 libraries. To load these 
libraries, a STOP of the automation system is necessary.
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Appendix A
A.1 Overview of the block I/O of the 'Pcs7Cntx' blocks

Overview
The following tables list the assignment of block I/O in the Standard Library to the block I/O of 
APL V8.0:

Standard Library APL V8.0
Block name I/O Type Block name I/O Type
CH_CNT LATCH I Psc7Cnt1 Connect In
 SET_DO1 I  Laddr In
 LADDR I  Channel In
 CHANNEL I  EnSetUp In
 ENSET_UP I  EnSetDn In
 ENSET_DN I  CtrlDO0 In
 CTRL_DO0 I  CtrlDO1 In
 CTRL_DO0 I  CtrlDO2 In
 CTRL_DO2 I  CtrlDO3 In
 CTRL_DO3 I  SetDO0 In
 SET_DO0 I  SetDO1 In
 SET_DO2 I  SetDO2 In
 SW_GATE I  SetDO3 In
 SET_DO3 I  SwGate_En In
 GATE_STP I  StopGate In
 USE_CNT I  Cnt_En In
 USE_MSRV I  MsrV_En In
 LAST_ON I/O  Feature bit 30 In
 LOAD_VAL I  LoadCnt / LoadCnt_IN 

(Struct)
In

 CMP_V0 I  CmpV0 In
 CMP_V1 I  CmpV1 In
 CMP_V2 I  CmpV2 In
 CMP_V3 I  CmpV3 In
 LOAD_PRE I  LoadPre_IN In
 LOAD_DIR I  LoadDir_IN In
 RES_SYNC I/O  ResSync_IN In
 R_OP_ERR I/O  ResOpErr_IN In
 SIM_ON I  SimOn In
 SIM_CNT I  SimCnt In
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Standard Library APL V8.0
 SIM_MSRV I  SimMsRv In
 SUBS_CNT I  SubsCnt In
 SUBS_MSRV I  SubsMsRv In
 SUBS_ON I  Feature bit 29 In
 FM_DATA I/O  FM_DATA In/Out
 MODE I/O  mode In/Out
 QBAD O  Bad Out
 QMOD_ERR O  ModErr Out
 QOP_ERR O  OpErr Out
 QSIM O  SimAct Out
 QRUN O  CntRun Out
 QDIR O  CntDir Out
 RES_SYNC I/O  ResSync_OUT Out
 QZERO O  ZeroSt Out
 QOFLW O  OFlow Out
 QUFLW O  UFlow Out
 QSYNC O  CntSync Out
 QGATE O  IntGate Out
 QSW_G O  SwGate Out
 QUALITY O  --  
 QSET O  Set_DI Out
 QLAST O  ??? Out
 QLATCH O  NewLatch Out
 QSTA O  StartDI Out
 QSTP O  StopDI Out
 QSUBS O  ???  
 QCMP1 O  CmpVal0 Out
 QCMP2 O  CmpVal1 Out
 QCMP3 O  CmpVal2 Out
 QCMP4 O  CmpVal3 Out
 QCOMP1 O  StCmpV0 Out
 QCOMP2 O  StCmpV1 Out
 QCOMP3 O  StCmpV2 Out
 QCOMP4 O  StCmpV3 Out
 ACT_MSRV O  MsrV / MsrV_OUT Out
 ACT_CNTV O  CntV / CntV_OUT Out

 

Standard Library APL V8.0
Block name I/O Type Block name I/O Type
CH_CNT1 LADDR I Pcs7Cnt2 Laddr In
 LADDR1 I  Laddr1 In

Appendix
A.1 Overview of the block I/O of the 'Pcs7Cntx' blocks

Software update with utilization of new functions
118 Service Manual, 03/2012, A5E02779783-02



Standard Library APL V8.0
 LAST_ON I/O  Feature bit 30 In
 CHANNEL I  Channel In
 VALUE I  Connect In
 LOAD_VAL I  LoadCnt / LoadCnt_IN 

(Struct)
In

 RES_DO I  ResDO_IN In
 RES_CNT I  ResCnt_IN In
 GATE_STP I  StopGate In
 SIM_ON I  SimOn In
 SIM_CNT I  SimCnt In
 SUBS_CNT I  SubsCnt In
 SUBS_ON I  Feature bit 29 In
 MODE I/O  mode In/Out
 QBAD O  Bad Out
 QMOD_ERR O  ModErr Out
 QOP_ERR O  OpErr Out
 QSIM O  SimAct Out
 QZERO O  ZeroSt Out
 QRES_DO O  ResDO_OUT Out
 QRES_CNT O  ResCnt_OUT Out
 QSUBS O  ??? Out
 QGATE O  Gate Out
 QLAST O  ??? Out
 ACT_CNTV O  CntV / CntV_OUT (Struct) Out
 QUALITY O  -- Out

 

Standard Library APL V8.0
Block name I/O Type Block name I/O Type
CH_CNT2M / 
CH_CNT2C

ACT_CNTV O Pcs7Cnt3 CntV Out

 ACT_MSRV O  MsrV / MsrV_OUT Out
 ACT_LATCH I  ???  
 CMP_VAL1 I  CmpV1 In
 CMP_VAL2 I  CmpV2 In
 CTRL_DO1 I  CtrlDO1 In
 CTRL_DO2 I  CtrlDO2 In
 CTRL_SYN I  CtrlSync_En In
 EXTF_ACK I  AckTrip In
 L_DIRECT I  LoadDir In
 L_PREPAR I  LoadPre In
 LADDR I  Laddr In

Appendix
A.1 Overview of the block I/O of the 'Pcs7Cntx' blocks
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Standard Library APL V8.0
 LAST_ON I  Feature bit 30 In
 LATCH I  Connect In
 LOAD_VAL I  LoadCnt / LoadCnt_IN 

(Struct)
In

 MODE I  mode In
 MSRV I  MsrV / MsrV_OUT (Struct) In
 OFLW I  OFlow / OFlow_IN In
 QBAD O  Bad Out
 QCMP1 O  CmpVal1 Out
 QCMP2 O  CmpVal2 Out
 QCNT_DN O  CntDown Out
 QCNT_UP O  CntUp Out
 QDI O  Set_DI Out
 QDO1 O  DO1St Out
 QDO2 O  DO2St Out
 QERR_24V O  V24Err Out
 QERR_DO1 O  DO1Err Out
 QERR_LOAD O  LoadErr Out
 QERR_PARA O  ParaErr Out
 QGATE O  IntGate Out
 QLAS O  ???  
 QMOD_ERR O  ModErr Out
 QOFLW O  OFlow_OUT Out
 QSIM O  SimAct Out
 QSUBS O  ???  
 QSYNC O  CntSync Out
 QUALITY O  --  
 QUFLW O  UFlow_OUT Out
 QZERO O  ZeroSt Out
 SET_DO1 I  SetDO1 In
 SET_DO2 I  SetDO2 In
 SIM_CNTV I  SimCnt In
 SIM_MSRV I  SimMsRv In
 SIM_LATCH I  ???  
 SIM_ON I  SimOn In
 SUBS_CNTV I  SubsCnt In
 SUBS_MSRV I  SubsMsRv In
 SUBS_LATCH I  ???  
 SUBS_ON I  Feature bit 29 In
 SW_GATE I  SwGate_En In
 UFLW I  UFlow / UFlow_IN In

Appendix
A.1 Overview of the block I/O of the 'Pcs7Cntx' blocks
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See also
How to create new interconnections for the block I/O (Page 105)

Appendix
A.1 Overview of the block I/O of the 'Pcs7Cntx' blocks
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