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Safety Guidelines

This manual contains notices which you should observe to ensure your own personal safety, as well as to
protect the product and connected equipment. These notices are highlighted in the manual by a warning
triangle and are marked as follows according to the level of danger:

Danger

/N

precautions are not taken.

indicates that death, severe personal injury, or substantial property damage will result if proper

Warning

/N

precautions are not taken.

indicates that death, severe personal injury, or substantial property damage can result if proper

Caution

/N

indicates that minor personal injury or property damage can result if proper precautions are not taken.

Qualified Personnel

The device/system may only be set up and operated in conjunction with this manual. Only qualified
personnel should be allowed to install and work on this equipment. Qualified persons are defined as
persons who are authorized to commission, to ground, and to tag circuits, equipment, and systems in
accordance with established safety practices and standards.

Correct Usage

Warning

Note the following:

This device and its components may only be used for the applications described in the catalog or the

technical description, and only in connection with devices or components from other manufacturers which
have been approved or recommended by Siemens.

This product can only function correctly and safely if it is transported, stored, set up, and installed
correctly, and operated and maintained as recommended.

Trademarks

SIMATIC®, SIMATIC HMI® and SIMATIC NET® are registered trademarks of SIEMENS AG. Microsoft®
and Visual Basic® are registered trademarks and ActiveX™ is a trademark of Microsoft Corporation.

Some of the other designations used in these documents are also registered trademarks; the owners’
rights may be violated if they are used by third parties for their own purposes.

Copyright Siemens AG 1998 All rights reserved

The reproduction, transmission or use of this document or its contents is not
permitted without express written authority. Offenders will be liable for
damages. All rights, including rights created by patent grant or registration of
a utility model or design, are reserved.

Siemens AG

Bereich Automatisierungs- und Antriebstechnik
Geschaeftsgebiet Industrie-Automatisierungssysteme
Postfach 4848, D- 90327 Nuernberg

Disclaimer of Liability

We have checked the contents of this manual for agreement with the
hardware and software described. Since deviations cannot be precluded
entirely, we cannot guarantee full agreement. However, the data in this
manual are reviewed regularly and any necessary corrections included in
subsequent editions. Suggestions for improvement are welcomed.

© Siemens AG 1998
Technical data subject to change.

Siemens Aktiengesellschaft
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Preface

Audience

S7-PLCSIM is an optional software product for STEP 7. (The S7-PLCSIM software
enables you to run and test your program on a simulated programmable logic
controller (PLC) that exists on your computer or programming device (such as a
PG 740). Because the simulation exists completely within the STEP 7 software,
you do not need to be connected to any S7 hardware (CPU or I/O modules). With
the simulated S7 CPU, you can test and debug programs for both the S7-300 and
S7-400 CPUs.

S7-PLCSIM provides a simple interface for monitoring and modifying different
parameters used by the program (such as for turning inputs on and off). You can
also use the various applications of the STEP 7 software while you are running
your program on the simulated CPU. This allows you to use such tools as the
variable table (VAT) to monitor and modify variables.

The Readme file for S7-PLCSIM provides information about the system
requirements and the versions of STEP 7 that support S7-PLCSIM version 4.

This manual is intended for engineers, programmers, and maintenance personnel
who have a general knowledge of programmable logic controllers.

Scope of the Manual

This manual describes the features and the operation of S7-PLCSIM, version 4. In
order to install S7-PLCSIM, you must have an authorized version of STEP 7
installed on your computer.

Testing Your S7 Progams with S7-PLCSIM
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Other Manuals

You can find information in the online help for STEP 7 and for S7-PLCSIM. In
addition, the following manuals provide information about STEP 7.

Title Content

System Software for The System Software for S7-300/S7-400 Program Design
S7-300 and S7-400 Programming Manual provides basic information on the structure
Program Design of the operating system and of a user program of an S7 CPU.
Programming Manual

S7-300 and S7-400 The S7 CPUs have integrated system functions and organization

System and Standard  blocks included with their operating system, which you can use

Functions Reference  when programming. This manual provides you with descriptions

Manual of the system functions, organization blocks, and loadable
standard functions available in S7.

STEP 7 User Manual The STEP 7 User Manual explains the main usage and the
functions of the STEP 7 automation software. This manual
provides you with an overview of the procedures used to
configure, program, and start up an S7-300/S7-400 PLC.

Statement List, Ladder The manuals for the programming language packages Statement

Logic, STGRAPH!, List, Ladder Logic, and SCL (Structured Control Language)
SCL1, and FBD? contain both the user’s guide and the reference description of the
Manuals programming language or representation type.

1 Optional package for system software for S7-300/S7-400

Additional Assistance

If you have any questions not answered in this or one of the other STEP 7
manuals, if you need information on ordering additional documentation or
equipment, or if you need information on training, please contact your Siemens
distributor or sales office.

. Testing Your S7 Progams with S7-PLCSIM
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Product Overview 1

Overview

The S7-PLCSIM software enables you to run and test your program on a simulated
PLC that exists on your computer or programming device (such as a PG 740).
Because the simulation exists completely within the STEP 7 software, you do not
need to be connected to any S7 hardware (CPU or I/O modules). With the
simulated S7 CPU, you can test and debug programs for both the S7-300 and
S7-400 CPUs.

S7-PLCSIM provides a simple interface for monitoring and modifying different
parameters used by the program (such as for turning inputs on and off). You can
also use the various applications of the STEP 7 software while you are running
your program on the simulated CPU. This allows you to use such tools as the
variable table (VAT) to monitor and modify variables.

Section Description Page
1.1 Features of S7-PLCSIM 1-2

Testing Your S7 Progams with S7-PLCSIM
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Product Overview

1.1 Features of S7-PLCSIM

S7-PLCSIM offers the following features for running a program on a simulated
PLC:

A button on the SIMATIC Manager toolbar turns the simulation on or off.
Turning on the simulation button opens the S7-PLCSIM software with its
simulated PLC. When the S7-PLCSIM software is running, all communication
from STEP 7 goes to the simulated PLC.

It does not matter whether your program is intended for either an S7-300 or an
S7-400 CPU module; you can use the simulated PLC to test programs for any
S7 CPU module.

You can create “view objects” that allow you to access the input and output
memory areas, accumulators, and registers of the simulated CPU. You can
modify any of this data.

You can choose to have the timers run automatically, or you can set or reset the
timers manually. You can reset individual timers, or you can reset all of the
timers at once.

You can change the CPU operating mode (STOP, RUN, and RUN-P) as with a
real CPU. In addition, S7-PLCSIM provides a Pause function that allows you to
halt the CPU momentarily without affecting the state of the program.

You can simulate interrupt OBs.

The “single scan” feature allows you to test your program one scan at a time.

S7-PLCSIM also allows you to use all of the STEP 7 tools to monitor and modify
the activities of the simulated PLC.

New Features for S7-PLCSIM Version 4

There have been several enhancements to S7-PLCSIM:

1-2

A slider control has been added to the options for displaying data. Use the
slider to enter analog values (or other values for byte, word, or double word
memory locations). The slider control provides configurable minimum and
maximum values.

The STEP 7 toolbar button now opens and closes S7-PLCSIM.
Timers now measure real-time, and not simulated, increments.

Writing to the Input (1) and output (Q) memory areas now writes also to the
peripheral input (PI) and peripheral output (PQ) memory areas.

Testing Your S7 Progams with S7-PLCSIM
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Product Overview

In addition to these enhancements, the following features have been added to
S7-PLCSIM version 4:

Additional S7 data types (Char, Date, S5Time, and Time Of Day)
Additional SFBs and SFCs

Alarm and Scan support for WinCC (Windows Command Center), SFC, CFC,
and PCS7

Clock memory
Connection to WinAC Computing (version 1.2 or higher)
Priority classes (OBs)

User-generated events to trigger interrupt OBs

Other features (such as an “Always on Top” function, an “undo” function, sort by
absolute address, and scrollbars) have also been added.

PLC Functions Supported

The simulated PLC functions as a superset of the S7-300 and S7-400 CPUs. It
provides the following capabilities:

Timers: 512 (T 0 to T 511).
Memory bits: up to 16,384 bits (2048 bytes) of M memory.
Total addressable 1/O memory: up to 16,384 bytes (16 Kbytes) of I/O memory.

Process image (updated every scan): as determined by the hardware
configuration in the system data downloaded from STEP 7, S7-PLCSIM
simulates a process image of either 512 bytes or 1024 bytes.

Logic blocks and data blocks: 65,536 function blocks (FBs) and functions (FCs),
and 65,535 data blocks (DBs).

System function blocks (SFBs): SFBO, SFB1, SFB2, SFB3, SFB4, SFB5,
SFB16, SFB32, SFB33, SFB34, SFB35, SFB36, and SFB37.

Note that SFB16 (“PRINT”) is a NOP (does not perform any operation). You do
not have to modify a program that calls SFB16.

System functions (SFCs): SFCO0, SFC1, SFC2, SFC3, SFC4, SFC5, SFC6,
SFC9, SFC10, SFC13, SFC14, SFC15, SFC17, SFC18, SFC19, SFC20,
SFC21, SFC22, SFC23, SFC24, SFC26, SFC27, SFC28, SFC29, SFC30,
SFC31, SFC32, SFC33, SFC34, SFC39, SFC40, SFC41, SFC42, SFC43,
SFC44, SFC46, SFC47, SFC49, SFC50, SFC51, SFC52, SFC54, SFC55,
SFC56, SFC57, SFC58, SFC59, SFC64, SFC79, and SFC80.

For SFC26 and SFC27, the only input parameter supported is O.

OBs: OB1 (free cycle), OB10 to OB17 (time-of-day interrupt), OB20 to OB23
(time-delay interrupt), OB30 to OB38 (cyclic interrupt), OB40 to OB47
(hardware interrupt), OB80 (time error), OB82 (diagnostic interrupt), OB83
(insert/remove interrupt), OB85 (priority class error), OB86 (rack failure),
OB100 (complete restart), OB101 (restart), OB121 (programming error), and
OB122 (access error).

Testing Your S7 Progams with S7-PLCSIM
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Product Overview

Limitations of the Simulated PLC

S7-PLCSIM has the following limitations:
¢ You can run only one simulated PLC at a time.

e The simulated PLC does not support all of the error messages written to the
diagnostic buffer. For instance, bad batteries in the CPU or EPROM errors
cannot be simulated. However, most I/O and program errors can be simulated.

Differences between a Simulated PLC and a Real PLC

The simulated PLC provides the following capabilities which are not available in a
real PLC:

e The Pause function halts the simulated CPU and allows you to resume the
execution of the program at the instruction where the program was halted.

¢ Any change that you make with a view object immediately updates the contents
of the memory location. The CPU does not wait until the beginning or the end of
the scan to update any changed data.

e Execution options allow you to select how the CPU runs the program:

— Single Scan executes the program for one scan and then waits for you to
start the next scan.

— Continuous Scan executes the program like a real PLC: it starts a new scan
immediately after the previous one finishes.

e Changing the CPU view object to STOP mode does not change the state of the
outputs.

¢ You can allow the timers to run automatically, or you can choose to enter values
for the timers manually. You can also reset the timers to 0. (For Single Scan
mode, the timers function in manual mode only.)

¢ You can manually trigger the interrupt OBs: OB40 to OB 47 (hardware
interrupt), OB80 (time error), OB82 (diagnostic interrupt), OB83 (insert/remove
module), OB85 (priority class error), and OB86 (DP slave or rack failure). To
simulate 1/O interrupt events, the simulator must have a valid 1/O configuration.

Using S7-PLCSIM with a Process Simulation Program

1-4

S7-PLCSIM provides an ActiveX™ control (S7ProSim) that allows you to attach a
process simulation program to the simulated PLC. You can use the S7ProSim
Control with any application that supports Microsoft's OLE/COM technology, such
as Visual Basic version 5.0.

For more information about the properties, methods and events of the S7ProSim
Control, refer to the documentation that was installed with the S7-PLCSIM
software. Use the following path to display the documentation:

Siemens\Step7\S7manual\S7wsi\S7wspms x.pdf

(where x indicates the language: a=German, b=English, c=French, d=Spanish, and
e=ltalian)

Testing Your S7 Progams with S7-PLCSIM
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Installing the S7-PLCSIM Software

Overview

2

The Setup program guides you through the installation of the S7-PLCSIM software
by means of dialog boxes and menus. You call the Setup program using the

standard Windows 95 or Windows NT software installation procedure.

Refer to the Readme file for information about the system requirements and the
versions of STEP 7 that support S7-PLCSIm version 4.

Section Description Page
21 Authorization 2-2
2.2 Installing and Uninstalling the S7-PLCSIM Software 2-4
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Installing the S7-PLCSIM Software

2.1

Authorization

The S7-PLCSIM programming software requires a product-specific authorization
(or license for use). The software is therefore copy-protected and can be used only
if the relevant authorization for the program or software package has been found
on the hard disk of the respective programming device or personal computer.

Authorization Disk

/N

A read-only authorization disk is included with the software. It contains the
authorization and the program (AUTHORSW) required to display, install, and
remove the authorization.

For more information and rules on how to handle authorizations, see the STEP 7
User Manual.

Caution

Note the information in the README.WRI file on the authorization disk. If you do
not adhere to these guidelines, the authorization may be irretrievably lost.

Installing the Authorization for the First Time

When installing your software for the first time, a message prompts you to install
the authorization. Follow the steps outlined below:

1. When prompted, insert the authorization disk in drive A.
2. Acknowledge the prompt.

The authorization is transferred to a physical drive and your computer registers the
fact that the authorization has been installed.

Adding an Authorization at a Later Date

2-2

If you attempt to start the S7-PLCSIM software and there is no authorization
available for the software, a message informs you of this. If you want to install the
authorization, use the AUTHORSW program on the authorization disk. This
program allows you to display, install, and remove authorizations. The program is
menu-driven.

Note

Always enter drive C as the destination drive for the authorization for S7-PLCSIM.

Testing Your S7 Progams with S7-PLCSIM
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Installing the S7-PLCSIM Software

Removing an Authorization

If you should need to repeat the authorization, for example, if you want to reformat
the drive on which the authorization is located, you must remove the existing
authorization first. You need the original authorization disk to do this.

To transfer the authorization back to the authorization disk, follow the steps
outlined below:

1.
2.
3.

Insert the original authorization disk in your floppy disk drive.
Start the program AUTHORSW.EXE from the authorization disk.

From the list of all authorizations on drive C, select the authorization to be
removed.

Select the menu command Authorization » Transfer... .

In the dialog box, enter the target floppy drive to which the authorization will be
transferred and confirm the dialog box.

The window with the list of authorizations remaining on the drive is then
displayed. Close the AUTHORSW program if you do not want to remove any
more authorizations.

You can then use the disk again to install an authorization.

If Your Hard Drive Is Defective...

If a fault occurs on your hard disk before you can back up the authorization,
contact your local Siemens representative.

Testing Your S7 Progams with S7-PLCSIM
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Installing the S7-PLCSIM Software

2.2

Installing and Uninstalling the S7-PLCSIM Software

S7-PLCSIM includes a Setup program which executes the installation
automatically. Prompts on the screen guide you step by step through the
installation procedure.

Preparing for Installation

Before you can start installing the software, the STEP 7 basic package must be
loaded.

Starting the Installation Program

The Setup program guides you step by step through the installation process. You
can switch to the next step or to the previous step from any position. To start the
installation program, proceed as follows:

1. Start the dialog box for installing software under Windows 95 or Windows NT by
double-clicking on the Add/Remove Programs icon in the Control Panel.

2. Click on “Install...”

3. Insert disk 1 and click on “Next.” Windows searches automatically for the
installation program SETUP.EXE.

4. Follow the instructions displayed by the installation program step by step.

If a Version of S7-PLCSIM Is Already Installed

2-4

If the installation program finds another version of S7-PLCSIM on the programming
device, the program reports this and prompts you to decide how to proceed by
offering the following choices:

e Abort the installation so that you can uninstall the old S7-PLCSIM version under
Windows 95 or Windows NT and then start the installation again.

¢ Continue the installation and overwrite the old version with the new version.

Your software is better organized if you uninstall any older versions before
installing the new version. Overwriting an old version with a new version has the
disadvantage that if you then uninstall, any remaining components of the old
version are not removed.

During installation, queries are shown in dialog boxes for you to answer, and
options are displayed for you to select. Read the following notes so you can reply
to the queries faster and more easily.

Testing Your S7 Progams with S7-PLCSIM
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Uninstalling

Use the usual Windows 95 or Windows NT procedure to uninstall:

1.

Start the dialog box for installing software under Windows 95 or Windoes NT by
double-clicking on the Add/Remove Programs icon in the Control Panel.

. Select the SIMATIC S7-PLCSIM entry in the displayed list of installed software.

Click on the “Add/Remove...” button to uninstall the software.

If the “Remove Enable File” dialog boxes appear, click the “No” button if you are
unsure how to respond.

Memory Requirement for Languages and Examples

All languages of the user interface and all examples require approximately
8 Mbytes of memory capacity.

Authorization Requirement

During installation, the program checks to see whether an authorization is installed
on the hard disk. If no authorization is found, a message appears that the software
can be used only with an authorization. You can run the authorization program
immediately, or continue the installation and execute the authorization at a later
date.

See Section 2.1 for a description of how to run the authorization program.

Result of the Installation

Once the installation has been completed successfully, a message to that effect is
displayed on the screen.

If Errors Occur during the Installation

The following errors may cause the installation to fail:

Initialization error immediately after starting Setup: The SETUP.EXE program
was probably not started under Windows 95 or Windows NT.

Not enough memory: You need at least 8 Mbytes of free space on your hard
disk.

Bad disk: Verify that the installation disk is bad, then call your local Siemens
representative.

Operator error: Start the installation again and read the instructions carefully.

Testing Your S7 Progams with S7-PLCSIM
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Getting Started with S7-PLCSIM 3

Overview

STEP 7 provides a sample program called “S7_ZEBRA”". You can use this program
to become familiar with the features of the S7-PLCSIM software.

This chapter provides the basic steps for downloading and running the program on
a simulated CPU. It also provides information about using the different view objects
and a variable table (VAT) with the simulation.

Section Description Page
3.1 Opening a Simulated PLC and Downloading the Sample 3-2
Program
3.2 Setting Up the Simulated PLC 3-4
3.3 Running the Sample Program 3-5
3.4 Using STEP 7 Tools to Monitor the Program 3-7
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Getting Started with S7-PLCSIM

3.1 Opening a Simulated PLC and Downloading the Sample
Program

Opening the S7-PLCSIM PLC
Use the following procedure to open the simulator:

1. Start the SIMATIC Manager.

2. Open the S7-PLCSIM PLC by clicking on the Simulation On/Off button located
on the SIMATIC Manager toolbar, as shown in Figure 3-1, or by selecting the
menu command Options » Simulate Modules .

The S7-PLCSIM application window opens with a default CPU view object.

SIMATIC Manager - S7_ZEBRA
File Edit Insert PLC View Options Window Help

Dlz|Elr| X8| ol w2

lation On/Off button

Simu

[l S7-PLCSIM - Zebra.plc
Simulation Edit Insert PLC Execute View Options Window Help

D2l | x|zl =B x| =l=lElkelzlelz])m

% g'; [ RUN-P

Boc [ RUN
Bl RUN & o1op
[ ]sTOP WEES

Ready MPI =2 | [NUM | Y
Figure 3-1  Using the Simulation On/Off Button to Open the Simulated PLC
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Getting Started with S7-PLCSIM

Downloading the Program
Use the following procedure to download the sample program:

1. Use the SIMATIC Manager menu command File » Open » Project or click on
the Open Project/Library button to open the S7_ZEBRA project. This project is
supplied with the STEP 7 software.

2. Navigate through the object hierarchy until you get to the blocks object.
Figure 3-2 shows the S7_ZEBRA project structure.

3. Select the menu command PLC » Download or click on the Download button
to download the blocks object to the simulated CPU.

SIMATIC Manager - S7_ZEBRA
File Edit Insert PLC View Options Window Help

= ¥l

Dlzlgl| x]=le] & 2

&) S7_ZEBRA - <Standarc Hieg \e> (Project)

EHSS s7_ZEBRA \( JL 300-Station(1)
= SIMATIC 300-Station ~| o

N Download button

\

ZEBRA blocks object

Press F1 for Help [NUM | | 7

Figure 3-2 Downloading the S7_ZEBRA Program to the Simulated PLC
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3.2 Setting Up the Simulated PLC

Creating View Objects for the Sample Program

The S7_ZEBRA sample program uses several inputs, outputs, and timers. You can
use view objects to turn the inputs on and off, and you can watch the timer values
and outputs change as the program runs. Figure 3-3 shows the view objects used
with the sample program. Use the following procedure to create the different view

objects:

1. Create a view object that accesses the inputs used by the program:

— Select the menu command Insert » Input Variable .

— The default value is IBO (for input byte 0). Press ENTER to accept.

2. Create a view object that accesses the outputs used by the program:

— Select the menu command Insert » Output Variable .

— The default value is QBO (for output byte 0). Press ENTER to accept.

3. Create three view objects to access the timers used by the program:

— Select the menu command Insert » Timer.
— The default value is T 0, with the 0 highlighted. Type 2 in the view object (for

Timer T 2) and press ENTER.

— Repeat fortimers T3 and T 4.

[@ S7-PLCSIM - Zebra.plc = [=] x]

Simulation Edit Insert PLC Execute View Options Window Help

[ crpu3oois00 S B3

% g'; [ RUN-P
Boc [ RUN

Bl RUN 5 stop
[ JsTOP MRES

BT 2 =1 x|
T 2

Ready

| MPI=2

Figure 3-3  View Objects for the S7_ZEBRA Sample Program
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3.3 Running the Sample Program

Selecting the Execution Option

With the sample program downloaded to the CPU, you can now run the program.
Before starting the program, ensure that the program execution is set for
continuous scan. Use the menu command Execute » Scan Mode » Continuous
Scan or click on the toolbar button (shown in Figure 3-4) to select the execution
control option for running the program continuously.

BIUEE | 1) +1

o

Click here for Continuous Scan program execution.

Figure 3-4  Selecting Continuous Scan Program Execution

Starting the Program

Use the following procedure to switch the CPU into RUN mode and start the
program.

1. Click the RUN check box in the CPU view object. See Figure 3-5.

[ cPu300/400  |H[= |

[ ISF
= [ RUN-P

Bmoc [M\RUN =———

Bl RUN = g70op
[ ]sTOP L) MRES

Figure 3-5  Selecting RUN Mode

| Click here to switch the
CPU to RUN mode.

2. Click either bit 0 or bit 1 in the Input Variable view object to turn on 1 0.0 or 1 0.1,
as shown in Figure 3-6.
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EB o =[] x]
B 0 IBits | ¥]

76 54 3210 .
DCOC DODM=— fibiioo

Figure 3-6  Turning On Input | 0.0

In the view objects, you can watch the timer values as they change and the
outputs as they turn on or off, as shown in Figure 3-7. As each timer reaches its
preset value, the corresponding outputs turn on or off.

To speed up the operation of the sample program, you can reset the timers by
clicking on the “T = 0" button in each Timer view object.

Saving the Layout of View Objects

You can save your layout of view objects within the simulated PLC window by
selecting the menu command Simulation » Save Layout . You can then retrieve
the saved layout at any time by selecting the menu command Simulation » Open
Layout .

[@ S7-PLCSIM - Zebra.plc = [=] x]

Simulation Edit Insert PLC Execute View Options Window Help
12T R =) 2T el T ol i e = Gl i i VT ST RS

[ ISF

- [ RUN-P

B oC RUN

Il RUN

[ ]sTOP [7'STOP WMRES

T2
lﬁms ;lgﬂ

Ready | MPI = 2 | |NUM | //

Figure 3-7  Sample View Objects Showing Status in RUN Mode
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3.4 Using STEP 7 Tools to Monitor the Program

Using a Variable Table to Monitor or Modify Data

STEP 7 allows you to use a variable table (VAT) to monitor the status of any
variable in your program. Figure 3-8 shows a VAT for the sample program. You can
also modify the variables which are defined for the VAT. To monitor program status
using the variable table, follow these steps:

1.
2.

Access the SIMATIC Manager window.

Select VAT1 and double-click with the mouse or use the menu command
Edit » Open Object to open the variable table for the “S7_ZEBRA” project.

Select the menu command PLC » Connect To » Configured CPU to establish
an online connection with the program in the simulated PLC.

Select the menu command Variable » Monitor to start monitoring the program
data.

You can now observe the values of the input, output, and timer elements in the
Monitor Value column of the VAT, as shown in Figure 3-8.

| Address | Symbol | Monitor Format | Monitor Value | Modify Value |
/ISwitch right/left
| 0.0 | “Switch_right” BOOL 2#1
| 0.1 | “Switch_left” BOOL 2#1
/IOutputs cars/pedestrians
Q 0.0 | “Ped_red” BOOL —
Q 0.1 | “Ped_green” BOOL —_—
Q 0.5 | “Car_red” BOOL —
Q 0.6 | “Car_orange” BOOL —_—
Q 0.7 | “Car_green” BOOL —_—
/[Timer
T 2 “Car_orange_phase” SIMATIC_TIME S5T#0ms
T 3 “Ped_green_phase” SIMATIC_TIME S5T#0ms
T 4 “Car_delay_red” SIMATIC_TIME S5T#0ms
T 5 “Car_red_orange_phase” | SIMATIC_TIME S5T#0ms
T 6 “Ped_delay_green” SIMATIC_TIME S5T#0ms

Figure 3-8 Example of a STEP 7 Variable Table (VAT)
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Using the Program Editor to Monitor Status

To view the execution of program logic in the ladder view of the program, follow
these steps:

1. Access the SIMATIC Manager window.

2. Select FC1 in the online view and double-click with the mouse or use the menu
command Edit » Open Object to open the program for the “S7_ZEBRA”
project.

If necessary, select View » LAD in the LAD/STL/FBD application to switch from
the statement list view to the ladder view.

3. Select the menu command Debug » Monitor to enable the animation of
program execution in the ladder networks.

You can now observe the power flow to the inputs, outputs, memory bits, and timer
elements in the ladder networks, as shown in Figure 3-9.

LAD/STL/FDB—[S7_ZEBRA\SIMATIC 300-STATION(1)\CPU 314(1)\...\ - [FC1 - <On-line>] EE n
: Determining green request for pedestrians =l
Determiningwhether 1 0.0 or 1 0.1 is set J
IOI.(? IT6 IT5 I\/IIO.O
11 I |__ /{ \ )_
10.1
|
I
MO0.0
| |
11
Network2 : Green phase for cars
If10.0 or 1 0.1 are not set, the light stays green for cars.
M|0'0 Q/O.?
4 ( F
A
<_| Y

Figure 3-9  Monitoring Program Status in the Ladder View
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Running a Program on the Simulated PLC

Overview

A

S7-PLCSIM works with the STEP 7 software to test and debug your program on a
simulated PLC. This chapter describes how to start the S7-PLCSIM, download a

program, select execution options, and access data in the program.

Section Description Page
4.1 Starting the S7-PLCSIM 4-2
4.2 Selecting the Simulation Options 4-3
4.3 Accessing Data in the Simulated PLC 4-4
4.4 Opening, Saving, and Closing the Simulated PLC 4-6
4.5 Using Interrupt OBs in Your Program 4-8

Testing Your S7 Progams with S7-PLCSIM

C79000-G7076-C201-02

4-1
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4.1

Starting the S7-PLCSIM

You use the SIMATIC Manager to open a simulated PLC.

Selecting Simulation

STEP 7 provides a button on the SIMATIC Manager toolbar that opens the
simulated PLC of S7-PLCSIM. Because of the risk of unintentionally editing a real
online program, you cannot start a simulation session until you close all windows or
applications that are connected to real PLCs.

STEP 7 disables the Simulator On/Off button whenever a project is open (whether
on-line or off-line). To enable the Simulator On/Off button, close all STEP 7 project
windows. Clicking on the Simulator On/Off button opens the S7-PLCSIM software
with a simulated PLC. (You can also use this button to close the S7-PLCSIM
software.)

Figure 4-1 shows the SIMATIC Manager window with the Simulation On/Off button.

Note

You can have only one simulated PLC active at a time. When the Simulation
On/Off button is turned on, clicking on the Accessible Nodes button shows the
node address for the simulated PLC that you have created. When the Simulation
On/Off button is turned off, the Accessible Nodes window shows the network of
real PLCs.

SIMATIC Manager - S7_ZEBRA
File View PLC Options Window Help

i =2 T e

Press F1 for Help | [NUM | | 7

Figure 4-1  Selecting S7-PLCSIM with the SIMATIC Manager
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4.2 Selecting the Simulation Options

Selecting the Execution Options

You select the program execution options with the Execute menu commands. You
can also access these options with the toolbar buttons, as shown in Figure 4-2.
These options control the execution of the program:

e Continuous Scan: The CPU executes one complete scan and then starts
another scan. Each scan consists of the CPU reading the inputs, executing the
program, and then writing the results to the outputs.

e Single Scan: The CPU executes one scan and then waits for you to initiate
another scan. Each scan consists of the CPU reading the inputs, executing the
program, and then writing the results to the outputs.

Using the Pause Function

The Pause function allows you to halt the execution of a program temporarily.
Unlike placing the CPU into STOP mode (which restarts the execution of the
program at the first instruction in your program when you return to RUN mode),
halting the execution of a program lets you resume the execution at the instruction
where you halted the program.

You can turn the Pause function on and off with the Execute » Pause menu
command, or you can use the toolbar button, as shown in Figure 4-2.

Cycling Power On and Off

You can simulate turning power on and off for the CPU. This allows you to check
the different startup OBs. Use the PLC » Power Off /Power On menu commands
to cycle power.

IR T T
T T Next Scan Resets all of the

Single Scan Pause timers

Continuous Scan

Figure 4-2  Toolbar Buttons for Program Execution Options
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4.3

Accessing Data in the Simulated PLC

You can access data in the simulated PLC with the view objects provided by the
main S7-PLCSIM window, or with the standard STEP 7 tools for monitoring
program status, or a combination of both.

Using the S7-PLCSIM View Objects

View objects allow you to monitor the program by displaying the values or the
states of the variables used by the program. Some view objects are read-only;
others allow you to change the values of specific memory locations. S7-PLCSIM
provides view objects for the following types of data:

e Variable data. This view object allows you to display or modify the values of
timers, counters, 1/O bits, or other memory locations.

The following view objects can provide useful information for debugging a program
when used with the breakpoint function in STEP 7:

e Accumulators and the status word. The read-only “ACCUs & Status Word” view
object accesses the contents of the accumulators and the values stored in the
pointer address registers (AR1 and AR2). It also displays the states of the
status word bits.

e Block registers. The read-only “Block Regs” view object accesses the contents
of the data block address registers (DB1 and DB2). It also displays the identity
of the logic block being executed and the step address counter (SAC).

e Stacks (nesting stack and MCR stack). The read-only “Stacks” view object
accesses the contents of the nesting stack, which consists of the RLO bit and
the OR bit of the status word. (The nesting stack shows the state of the status
word for each instruction in the logic string.) This view object also shows the
state of the MCR (master control relay) stack.

There is no restriction on the number of view objects that you can create and
display. For more information on using view objects, see Chapter 5.

Using the STEP 7 Tools

4-4

You can use the STEP 7 tools to monitor and modify the program that is being
executed by the simulated CPU. This allows you to create and test a variable table
(VAT) or to use the debugging tools provided by STEP 7. For more information
about the STEP 7 tools, see the STEP 7 User Manual or the manual for your
programming language.

S7-PLCSIM requires you to disconnect any STEP 7 tool before closing the
simulated CPU or exiting the S7-PLCSIM application.

Testing Your S7 Progams with S7-PLCSIM
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Note

Using the Pause function can cause the STEP 7 tools to disconnect from the
simulated PLC because of a time-out while STEP 7 waits for a request to be
acknowledged. After you turn Pause off, you can reconnect the STEP 7 tool.

Using a Variable Table to Monitor or Modify Data

You can use a variable table (VAT) to monitor the status of any variable in your
program. You can also modify the variables which are defined for the VAT. You can
use the simulated CPU to test a VAT that is being prepared as an interface.

Figure 4-3 shows a sample VAT for the S7_ZEBRA program.

| Address | Symbol | Monitor Format | Monitor Value | Modify Value |
/ISwitch right/left
| 0.0 | “Switch_right” BOOL 2#1
| 0.1 | “Switch_left” BOOL 2#1
/IOutputs cars/pedestrians
Q 0.0 | “Ped_red” BOOL —
Q 0.1 | “Ped_green” BOOL —_—
Q 0.5 | “Car_red” BOOL —
Q 0.6 | “Car_orange” BOOL —_—
Q 0.7 | “Car_green” BOOL —_—
/[Timer
T 2 “Car_orange_phase” SIMATIC_TIME S5T#0ms
T 3 “Ped_green_phase” SIMATIC_TIME S5T#0ms
T 4 “Car_delay_red” SIMATIC_TIME S5T#0ms
T 5 “Car_red_orange_phase” | SIMATIC_TIME S5T#0ms
T 6 “Ped_delay_green” SIMATIC_TIME S5T#0ms

Figure 4-3 Example of a STEP 7 Variable Table (VAT)
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4.4

Opening, Saving, and Closing the Simulated PLC

You can save and re-open a simulated PLC. You can also save and re-open the
layout of the view objects that you inserted.

Opening a Simulated PLC

Saving the

4-6

You can open a simulated PLC in one of the following ways:

e From STEP 7 with no project open, click on the Simulation On/Off button to
start the S7-PLCSIM software.

e Use the Start menu (Start » SIMATIC » STEP 7» S7-PLCSIM Simulating
Modules ) to start the S7-PLCSIM software.

Note
S7-PLCSIM supports only one simulated PLC at a time.

You have two options for loading a program into the simulated PLC:
e You can download a program from the SIMATIC Manager or the program editor.

¢ If you have already saved one or more simulated PLCs to a file, you can open a
specific PLC by using the Simulation ~ Open PLC menu command.

Simulated PLC

Use the Simulation » Save PLC or the Simulation » Save PLC As... menu
command to archive a simulated PLC. The following elements are saved with the
PLC:

e Program

e CPU operating mode (RUN-P, RUN, or STOP)

e Power state (on or off)

e Execution control option (continuous scan or single scan)
e The status of the I/O

¢ Timer values

Testing Your S7 Progams with S7-PLCSIM
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Saving the Layout of View Objects

To save the layout of the view objects you have inserted for the simulated PLC,
select the menu command Simulation » Save Layout . Any time you reopen a
saved simulated PLC, you can also open a saved layout using the Simulation »
Open Layout menu command.

Closing the Simulated PLC

You can close a PLC either by selecting the Simulation » Close PLC menu
command or by clicking on the exit button in the top-right corner of the CPU view
object. Closing the simulated PLC ends the simulation of the program, but does not
exit the S7-PLCSIM application.

Note

When you close the simulated PLC, S7-PLCSIM provides a dialog box that allows
you to save the PLC. This dialog box allows you to save only the PLC; it does not
save the layout before closing both the PLC and the layout. To save the layout,
select the menu command Simulation  Save Layout before closing the
simulated PLC.

Testing Your S7 Progams with S7-PLCSIM
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4.5

4-8

Using Interrupt OBs in Your Program

Note

For the simulated PLC to run a program for an interrupt OB, you must have
created and downloaded the interrupt OB. Furthermore, to simulate the 1/0-related
interrupts, you must have successfully downloaded your I/O configuration.

You can use S7-PLCSIM to test how your program handles different interrupt OBs.
S7-PLCSIM supports simulation of the following interrupt OBs:

e 0OB40 to OB47 (hardware interrupt)
e OB8O (time error)

e 0OBB82 (diagnostic interrupt)

e OB83 (insert/remove module)

e OB85 (priority class error)

e OB86 (DP slave or rack failure)

For more information about the interrupt OBs, refer to the S7-300 and S7-400
System and Standard Functions Reference Manual or to the online help for
STEP 7.

Use the menu command Execute » Trigger Error OB to select a specific OB, and
enter the header information in the dialog box. When you click on the “OK” button,
the simulated PLC generates the appropriate event and runs the program in the
associated OB.

Note

S7-PLCSIM grays out the interrupt OB menu selection if an 1/0 configuration has
not been successfully downloaded. For S7-300 users, this means that you must
use a CPU 315-2 DP project to download the hardware configuration (even if your
CPU is actually a different model). For S7-400 users, if you use DP /O, but your
CPU does not directly support DP, you must copy your hardware configuration into
an S7-400 CPU with a DP extension and download it to S7-PLCSIM from the DP
station. See Appendix C for information about creating a project to hold your
hardware configuration for the purpose of downloading I/O information to
S7-PLCSIM.

Testing Your S7 Progams with S7-PLCSIM
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Monitoring and Modifying Data with the

View Objects

Overview

S7-PLCSIM provides view objects that allow you to display the following
information:

Variable data, such as timers, counters, inputs, and outputs

Accumulators and status word

Address registers

Block registers

Nesting stack and MCR stack

5

Any change made by a view object affects the program immediately. When you
use a STEP 7 variable table to change a value, the CPU reads that change at the
beginning of the next scan.

Section Description Page
51 Controlling the CPU 5-2
5.2 Monitoring and Modifying the Data Used by the Program 5-4
5.3 Displaying the Symbolic Addresses 5-7
5.4 Accessing the Accumulators, Status Word, and Address 5-8

Registers
5.5 Monitoring the Block Registers 5-9
5.6 Monitoring the Data in the CPU Stacks 5-10
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5.1

Displaying the Status of the CPU

5-2

Controlling the CPU

Figure 5-1 shows a sample CPU view object. From this view object, you can
perform the following functions:

¢ Change the CPU operating mode (STOP, RUN, and RUN-P)
¢ Reset the CPU memory (MRES)

The CPU view object provides the following indicators, like LEDs, that display the
CPU status:

e SF (system fault) indicates an error condition.

e DP (distributed peripherals, or remote 1/O) indicates the status of
communication with distributed (remote) I/O.

e DC (power supply) indicates that power to the CPU is on.
¢ RUN indicates that the CPU is in RUN mode.
e STOP indicates that the CPU is in STOP mode.

For more information about the S7-300 and S7-400 CPUs, refer to the System
Software for S7-300 and S7-400 Program Design Programming Manual or to the

online help for STEP 7.

CPU status
indicators

[ cru3o0/400 M= B3

% g'; [ RUN-P

B oC RUN
Bl RUN STOP
[ ]STOP L) MRES

CPU operating
mode controls

Figure 5-1

CPU View Object
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Changing the CPU Operating Mode

The check boxes on the CPU view object allow you to change the CPU operating
modes:

¢ In STOP mode, the CPU is not executing the program. To download a program
that includes SDBs, or to change the node address, you must place the CPU in
STOP mode. Unlike the case with a real CPU, placing the CPU view object in
STOP mode does not change the state of the outputs.

¢ In RUN mode, the CPU executes the program. As with a real CPU, you cannot
download any new programs or logic blocks when the CPU view object is in
RUN mode. You can use the STEP 7 tools to monitor (but not to modify) the
variables.

¢ In RUN-P mode, the CPU executes the program. When the CPU view object is
in RUN-P mode, you can download new programs or logic blocks, and you can
modify the variables with the STEP 7 tools.

To change the CPU mode, click on the box for STOP, RUN, or RUN-P. The CPU
status indicators show whether the CPU is in RUN (or RUN-P) mode or in STOP
mode.

Resetting the CPU Memory (MRES)

The CPU view object provides an MRES button for resetting the memory of the
CPU. When you reset the CPU memory, the simulated CPU performs the following
tasks:

e The memory areas are reset.
e The program blocks are deleted.

To reset the CPU memory, click on the MRES button or select the menu command
PLC » Clear/Reset.

Testing Your S7 Progams with S7-PLCSIM
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5.2 Monitoring and Modifying the Data Used by the Program

You can create view objects that access the data stored in the different memory
areas of the simulated CPU. S7-PLCSIM provides view objects that contain default
addresses for a timer, a counter, a bit memory location, an input, and an output.
You can also create a generic view object to access the data stored in other
memory areas.

Accessing the Data Stored in the CPU Memory

The view objects that you create with the Insert menu commands allow you to
monitor and modify those values and immediately see the effect on your program.
When you change a value in a data field, press ENTER for it to be accepted.

You can use these view objects to access the inputs and outputs, the timers,
counters, and the data used by the program. Table 5-1 lists the memory areas that
can be accessed.

For more information about the memory areas, refer to the System Software for
S7-300 and S7-400 Program Design Programming Manual or to the online help for
STEP 7.

Note

The peripheral input (PI) memory area overwrites the input (I) memory area at the
beginning of every CPU scan. If you use a view object to modify a value in the

| memory area, the simulator immediately copies that value to the peripheral
memory. This ensures that the desired input value is not overwritten at the
beginning of the next scan. Likewise, the output (Q) memory area writes to the
peripheral output (PQ) memory area at the end of every CPU scan; if you use a
view object to modify a value in the peripheral (PQ) memory area, the simulator
immediately writes the desired value to the output (Q) memory area so that the
value is not lost at the end of the scan.

Table 5-1 Memory Areas for the S7-300 and S7-400 CPUs

Memory Area Description

Pl peripheral (external) input The CPU writes the Pl memory to the | memory at the
beginning of each scan.

PQ peripheral (external) output | The CPU writes the Q memory to the PQ memory at
the end of every scan.

| process-image input The | memory area is overwritten by the PI memory
area at the beginning of every scan.

Q process-image output The Q memory area overwrites the PQ memory area at
the end of each scan.

M  bit memory The M memory area provides storage for interim
results calculated in the program.

Testing Your S7 Progams with S7-PLCSIM
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Table 5-1 Memory Areas for the S7-300 and S7-400 CPUs, continued

Memory Area Description
T timer The T memory area provides the timers used by the
program.
C counter The C memory area stores the counter values used by

the program.

DB data block The DB memory address references the data stored in
the data blocks for the program.

Creating View Objects for Accessing the Program Data

To create view objects for monitoring and modifying the data used by the program,
use the Insert menu commands. Figure 5-2 shows several examples of the view
objects. Use the following procedure to access a memory address with a view
object:

1. Enter the memory address to be accessed and press ENTER. For example:
“IBO” accesses byte 0 of the | (Input) memory area and “T 2" accesses timer 2.

2. Use the drop-down list box to select the appropriate representation for the data
that will be displayed or entered (such as binary, decimal, or hexadecimal).

mB o P EEE|
B 0 [Bits  |v] T 2

7 6 54 3 210

OOCC Cooic [ oims [T=0
CIDENN -] I -1

w0 | Decimal [v| w8 | Hex k1

|| 0 || 0
E DB5.DBB !Eﬂ

[MD o | Slider: Relv| |DB5.DBB 0 |Decimal |v]

J

[0.000 | value ¥} | 0

Figure 5-2  Variable View Objects
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Using the Slider Control

5-6

The slider control allows you to simulate values that change gradually or have a
specific range, such as analog values. Figure 5-3 shows a slider control.

You can use either the mouse or the arrow keys to change the position of the slider
control. Changing the position of the slider control changes the value of the
variable stored in the memory location. You can also enter a specific value in the
“Value” field.

When you select the slider control, you also select whether to represent the values
as either decimal (positive integers), integer (positive and negative integers), or
real numbers. The selection options are determined by the size of the memory
location being accessed:

e Byte (B): decimal
e Word (W): decimal and integer
e Double word (D): decimal, integer, and real

You can also configure a minimum and maximum value for the slider control.
Selecting a range of values does not affect the values that can be stored in the
variable: the minimum and maximum values affect only the values that can be
entered or displayed by the slider control. Selecting a range of values provides the
following benefits:

¢ You can simulate a specific range of values. For example, this allows you to
simulate the range of values that would be generated by a specific analog
module.

¢ By limiting the range of values between the minimum and maximum, you can
provide better resolution for entering data with the slider. You can always enter
an exact value in the “Value” field of the view object.

B MD 0 =) x| |/ Select the slider control and

representation of data.
[MD 0 | Slider: Re v |*
= Select the minimum and maximum
IO-OOO || Value M‘ values for the slider control.

Figure 5-3  Configuring the Slider Control
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Using the View Objects to Modify Data
Use the following guidelines to modify data in the view objects:

¢ When you select bit format for a variable such as an input byte, the eight check
boxes correspond to bits 0 through 7. To activate any of the bits in the view
object, click on the corresponding check box to change the state from off to on
(0 to 1). A check mark appears, indicating a state of 1 (on). Clear the check box
to turn the bit off.

e For variables that you specify as bytes, words, or double words, use the
drop-down list box to select the appropriate representation for the data that you
want to enter (such as binary, decimal, or hexadecimal). Enter the value in the
text field in the corresponding format and press ENTER.

5.3 Displaying the Symbolic Addresses

You can display the symbol names assigned to the absolute addresses in any of
the view objects of your simulated PLC. To establish a link to the symbol table
associated with the downloaded program, follow these steps:

1. Select the menu command Options » Attach Symbols...

2. Use the browser dialog box to select the symbol table associated with the
downloaded program.

3. Click on the “OK” button to confirm the selection.

The menu command Options » Show Symbols toggles the symbolic
representation on and off for all of the view objects.
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5.4

5-8

Accessing the Accumulators, Status Word, and Address

Registers

You can display the contents of the accumulators, the status word, and the
address registers in the CPU by opening the “ACCUs & Status Word” view object.
Select the menu command View » Accumulators to open this view object.

Figure 5-4 shows the “ACCUs & Status Word” view object.

For more information about the status word and the accumulators for the S7-300
and S7-400 CPUs, refer to the System Software for S7-300 and S7-400 Program
Design Programming Manual or to the online help for STEP 7.

ACCUs & Status Word =7 x] |

— Accumulators ~ Status Word
1100 8 E BR

(e Dec 7[]cC1

2 " 300 6 []CCoO
30 ~Hex 5 [ ov
4]0 4 []os
— Address Registers — 2 E Ol
2 [[] STA

1 "0 1 [ RLO
2]o 0 [ /Fc

Figure 5-4  Accumulators and Status Word View Object
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Monitoring and Modifying Data with the View Objects

5.5 Monitoring the Block Registers

Displaying the Contents of the Block Registers

You can view the contents of the data and logic block registers by opening the
“Block Regs” view object. Select the menu command View » Block Registers to
open this view object.

Figure 5-5 shows the “Block Regs” view object.

For more information about the block registers for the S7-300 and S7-400 CPUs,
refer to the System Software for S7-300 and S7-400 Program Design
Programming Manual or to the online help for STEP 7.

I Block Regs !E n |

Data Block
1 ||o

2||o

Logic Block SAC
1/0oB 1 16
2o 0

Figure 5-5  Block Registers View Object
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Monitoring and Modifying Data with the View Objects

5.6 Monitoring the Data in the CPU Stacks

Monitoring the Nesting Stack and the MCR Stack

The “Stacks” view object displays the status of both the nesting stack and the
master control relay (MCR) stack. These stacks help you to monitor the state
changes of individual instructions in your program:

e The nesting stack stores up to seven entries. For each entry, the nesting stack
stores the states of the RLO and OR bits of the status word for the And (A),
And Not (AN), Or (O), Or Not (ON), Exclusive Or (X), and Exclusive Or Not
(XN) instructions.

e The MCR stack stores up to eight levels of nesting for an MCR.

To create the view object for viewing the nesting stack and the MCR stack, use the
View » Stacks menu command.

Figure 5-6 shows the “Stacks” view object. Refer to the Statement List (STL) for
S7-300 and S7-400 Programming Manual for more information about the nesting
stack and the MCR stack.

— Nesting Stack ~ MCR
S GR [ MA bito I%_o
1 E E 1 E
2 E E 2 E
3 E E 3 E
sC O s
6 E E 6 E
7 E E 7 E

Figure 5-6  Stacks View Object

Testing Your S7 Progams with S7-PLCSIM
5-10 C79000-G7076-C201-02



Troubleshooting

Table A-1  Troubleshooting

Problem

Possible Cause

Your program does not
download to the simulated
PLC.

Verify that the CPU is in either STOP mode or RUN-P mode.

As with a real CPU, you cannot download your program if the simulated
CPU is in RUN mode. Also, you cannot download your program when the
simulated CPU is in Pause mode.

If your program contains the hardware configuration for the PLC, verify that
the CPU is in STOP mode.

As with a real CPU, you can download the hardware configuration only
when the simulated CPU is in STOP mode.

Note: If the CPU view object is in RUN-P mode, S7-PLCSIM prompts you to
change to STOP mode before downloading the hardware configuration.

Verify that the CPU and the program use the same node address.

As with a real MPI network, the node address defined for the program must
match the node address of the CPU.

When you attempt to
close the simulated PLC,
a message alerts you that
there is a connection
open.

If you attempt to close the simulated PLC while one of the STEP 7 tools
(such as a variable table) is monitoring the program, STEP 7 alerts you to
disconnect the STEP 7 tool from the simulated PLC. Always disconnect any
STEP 7 tool by turning off the monitoring of the program status or by closing
the tool before closing the simulated PLC.

The S7-PLCSIM
application does not
respond and appears to
have “locked up.”

First, check to see if Single Scan execution control or the Pause function is
on. Either one can appear as a lock-up. Turn off Pause, or select
Continuous Scan mode.

If the software does not respond to one of the actions above, press the
“Ctrl"+“Alt"+“Del” keys simultaneously, and end the S7-PLCSIM application.
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S7 Reference Information B

Overview

S7-PLCSIM provides view objects for accessing the information stored in the
simulated CPU. You can access any of the memory areas, using the standard
S7/STEP 7 notation for entering the memory addresses.

This appendix provides descriptions of the memory areas, accumulators, and
address registers. It also provides a quick reference for the different formats for
displaying or modifying the data.

Section Description Page
B.1 Memory Areas for the S7-300 and S7-400 CPUs B-2
B.2 S7-PLCSIM Notation for Entering Data B-4
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S7 Reference Information

B.1 Memory Areas for the S7-300 and S7-400 CPUs
Figure B-1 shows the memory areas, accumulators, address registers, and the
status word for the S7-300 and S7-400 CPUs. S7-PLCSIM uses the view objects
to access the values stored in the simulated CPU.
Table B-1 describes the different memory areas.
CPU Accumulators and Registers Memory Areas
Accumulators 32 bits Peripheral I/0 PI, PQ
| Accumulatorl (ACCU 1) |
Outputs Q
| Accumulator2 (ACCU 2) |
Inputs |
| Accumulator3 (ACCU 3) S7-400 only | Bit Memory M
| Accumulator4 (ACCU4)  S7-4000nly | Timers T
Counters C
Address Registers 32 bits
| Address Register 1  (AR1) | Data blocks DB
| Address Register2  (AR2) | (in the executable user program)
Data Block Registers 32 bits
| DB number for the open DB |

DB number for the open instance DB (DI) |

Status Word

| Status bits 16 bits

Figure B-1  Memory Areas for the S7-300 and S7-400 CPUs

B-2
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S7 Reference Information

Table B-1 Memory Areas for the S7-300 and S7-400 CPUs

(PQ)

external outputs

Name Memory Area Function of Memory Area
Input (1) Process-image At the beginning of the scan cycle, the operating system reads
input table the inputs from the process and records the values in this table.
The program uses these values in its normal processing.
For every CPU cycle, input memory stores the state of the
inputs in the process-image input table. The process-image
input table maps the first 512 bytes of the peripheral input
memory.

Output (Q) Process-image During the scan cycle, the program calculates output values

output table and places them in this table. At the end of the scan cycle, the
operating system reads the calculated output values from this
table and sends them to the process outputs.
The process-image output table maps the first 512 bytes of the
peripheral output memory.

Bit memory (M) Memory bits This area provides storage for interim results calculated in the
program. You designate whether the data are to be accessed
as bits, bytes, words, etc.

Peripheral input 1/0: Peripheral memory allows direct access to the field devices

(PI) external inputs (physical, or external, inputs and outputs).

Peripheral output 1/0: Peripheral memory can be accessed in byte, word, and

double-word format, but not as bits.

Timer (T) Timer This area provides storage for timer values.

Counter (C) Counter This area provides storage for counter values.

Data block (DB) Part of the DBs store the information for the program.
program

Testing Your S7 Progams with S7-PLCSIM
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S7 Reference Information

B.2

B-4

S7-PLCSIM Notation for Entering Data

The “Variables” view object provides a variety of formats for displaying or entering
the data in your program. The formats allowed are determined by the size entered
with the address: byte (B), word (W), or double word (D). Table B-2 lists the

formats that are available.

Table B-2 Data Formats for the “Variables” View Object

Data Format Size Example
Bits B [=off [V =on
BCD (binary-coded decimal) W and D 400
Binary B and W 10010011
Char (character) B, W, and D ‘a',’'s7’
Date w 1998-06-18
Decimal B, W, and D 232
Hex (hexadecimal) B, W, and D 9A
Integer W and D 623, —2370
Real D —2134.232323
S5Time w 3m25s30ms
S7 Format B, W, and D DW#16#09A2FF23
Slider: Dec (decimal) B, W, and D &
Slider: Int (integer) W and D &
Slider: Real D i
Time D 2d8h15m6s240ms
TOD (Time of Day) D 2:34:45.330
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Downloading System Data to S7-PLCSIM C

Overview

Testing Your S7 Progams with S7-PLCSIM
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If you want to simulate interrupt OBs in S7-PLCSIM, you must first correctly
download your I/O configuration. If your project matches either of the following
descriptions, certain modifications are required to download your hardware
configuration to S7-PLCSIM:

e An S7-300 project with any CPU other than the CPU 315-2 DP

e An S7-400 project that uses DP I/O with a CP instead of using a CPU model
that explicitly supports DP I/O

Note

Projects configured for a CPU 315-2 DP, or for an S7-400 CPU that explicitly
supports DP, do not require the modifications that are described in this appendix.

Section Description Page

Cci1 Modifying and Downloading Your I/0O Configuration C-2
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Downloading System Data to S7-PLCSIM

C.1 Modifying and Downloading Your 1/0O Configuration

Interrupt OBs Require a Valid I1/0O Configuration

In order to simulate interrupt OBs, you must download a hardware configuration
that contains your I/0. There are some cases where your I/O is not automatically
included in the system data that STEP 7 downloads to S7-PLCSIM:

S7-300 CPUs:

Only the CPU 315-2 DP downloads an I/O configuration; all of the other S7-300
CPUs autoconfigure the I/O to match the physical I/O installed in the rack.

To successfully download 1/0 to S7-PLCSIM, you must copy your hardware
configuration and put the data into a CPU 315-2 DP project. When you
download the I/O information from the CPU 315-2 DP project, you can simulate
interrupt OBs in S7-PLCSIM (and S7-PLCSIM is also able to detect any 1/O
referencing errors that your program may contain).

S7-400 CPUs:

If you use a CP with PROFIBUS-DP |/O, rather than using a CPU model that
explicitly supports DP, you cannot download this I/O configuration and use it to
simulate an interrupt OB in S7-PLCSIM. However, you can copy your 1/O
configuration into a second project and replace the S7-400 CP and CPU with an
S7-400 CPU model that explicitly supports DP. Once you download the
hardware configuration from this second project to S7-PLCSIM, you can
simulate interrupt OBs and detect I/O referencing errors.

Modifying Your Hardware Configuration for S7-PLCSIM

To successfully download an 1/O configuration to S7-PLCSIM, you must use either
a CPU 315-2 DP or an S7-400 CPU that directly supports DP 1/0O. Use the
following procedure to create and modify a copy of your hardware configuration.

1.

C-2

Insert a new SIMATIC station to hold the modified configuration that you are
going to create. Name it something descriptive, such as SIM_10.

. Navigate to your project.

. Open the Hardware Configuration of your project.

Testing Your S7 Progams with S7-PLCSIM
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Downloading System Data to S7-PLCSIM

4. Copy the central rack from your Hardware Configuration.

ii Caution
Be certain only to copy, not cut, from the configuration of your original project to
the configuration of the SIM_10 project. If you cut items from your original
configuration, your Hardware Configuration will not work in real field applications
any more.

5. Leaving the Hardware Configuration of your project open, navigate back to the
SIM_10 project and open its Hardware Configuration.

6. Paste the central rack from your original configuration into the SIM_IO
configuration.

7. In the SIM_IO configuration, edit the rack to replace the existing CPU.
— If the existing CPU is an S7-300, replace it with a CPU 315-2 DP.

— If the existing CPU is an S7-400, replace it with a CPU that directly supports
DP. (The extension “DP” should appear in the name of the model that you
select.)

Note

When you insert a new CPU in the central rack, the STEP 7 hardware
configuration software issues a series of messages prompting you to assign a
network. If your original project was not networked, answer “No” to these prompts.
The STEP 7 hardware configuration software displays the message “Cannot
assign a PROFIBUS network to the DP master.” Since you do not need a
PROFIBUS network, this message is not a problem.

8. If your configuration previously used a CP for DP communications, delete the
CP from the SIM_1O configuration. The CP is not necessary after you put a DP
CPU into the configuration.

9. If you have expansion racks in your original configuration, copy them into the
SIM_IO configuration.

10.1f you have PROFIBUS slaves in your original configuration, copy them into the
SIM_IO configuration.

11. Carefully check the addresses assigned by STEP 7 to the modules in the
SIM_10 configuration and make any necessary changes.

12.Save the SIM_IO configuration and download the configuration to the
S7-PLCSIM.

13.Close the original configuration.
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Index

A

Accessible nodes

location of button, 4-2

viewing the simulated PLCs, |4-2
Accessing the CPU memory areas, |5-4
Accumulators,|5-8, B-2
Address registers (AR1 and AR2), |5-8| B-2
Addresses, symbolic or absolute, 5-7
Assistance, technical, |iv
Authorization, 2-2, 2-5

original disk, 2-2

transfer,|2-3
AUTHORS.EXE, 2-3

BCD (binary-coded decimal), format,|B-4
Binary data, format, B-4

Bit memory area of memory, description,|B-2
Blocks, FBs, FCs, DBs, OBs,|1-3

C

Changing the CPU operating mode, |5-3

Changing the node address, turning the power
off, 4-3

Closing the simulated PLC, 4-7

Continuous scan, 4-3

Controlling the execution of a program,
simulator options, 4-3

Copy-protection, 2-2

Counters, accessing counter data, 5-4
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CPU
areas of memory, B-2
changing operating modes, |5-3
cycling power,|4-3
disconnect STEP 7 tools before closing, 4-4
indicators, |5-2
memory areas, 5-4
memory reset (MRES), 5-3
opening a CPU view object, 4-6
operating modes, 5-3
resetting the memory (MRES), 5-3
using a variable table,|3-7|/4-5
CPU scan
continuous scan, 4-3
single scan mode, 4-3
Creating view objects, 5-5
Cycling power,|4-3

D

Data block (DB),|5-9
description as area of memory,|B-2

Data formats, |B-4

Decimal data, format, B-4

Diagnostic information, 1-4

Differences between simulated and real PLCs,
1-4

Disconnecting STEP 7 tools before closing
CPU,|4-4

Downloading a program, 4-6
selecting the simulator,|4-2

E

Entering data, |B-4

Errors, during installation, |2-5
Execution control, selecting type of,|4-3
Exiting the application, 4-7

F

Features supported,|1-2,|1-3
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Index

H

Halting the program
effect of Pause on STEP 7 tools, 4-4
Pause, 4-3

Hexadecimal data, format, B-4

I/O memory supported, 1-3
Input area of memory, description, |B-2
Inputs
setting bits, |3-5//5-7
turning on and off,|5-4
Installation
error, 2-5
overview, 2-1
Installing, PLCSIM, 2-4
Integer, format, B-4

L

L Stack, description of temporary local
memory, B-2

Ladder logic program, monitoring status,|3-8

Layout of view objects, saving, 3-6

LEDs (status indicators), 5-2

Logic blocks supported,|1-3

M

Manuals, STEP 7 set, liv

Master control relay. See MCR stack

MCR stack, |4-4, 5-10

Memory areas,|5-4

Memory bits supported,|1-3

Memory reset (MRES), |5-3

Modes, changing CPU operation,|5-3

Monitoring and modifying data, 5-4

Monitoring and modifying the program
using a variable table, 3-7//4-5
using view objects, 3-5-3-6, 4-4

MPI address. See Node address

MRES. See Memory reset (MRES)

N

Nesting stack, 4-4,/5-10

Index-2

Node address
only one PLC at a time, 4-6
turning the power off before changing,|4-3

O

Opening a PLC, |4-6
Opening a layout, 3-6
Operating modes, changing CPU, 5-3
Options, simulation, |4-3
Error OBs supported,|1-3|/4-8
Interrupt OBs supported, 1-3,4-8
Organization blocks (OBs) supported, |1-3
Output area of memory, description, B-2
Outputs, accessing Q and PQ memory, 5-4
Overview

installation, 2-1

product features, 1-1

P

Pause function, 4-3
with STEP 7 tools, |4-4
Peripheral input and output areas of memory
accessing,|5-4
description, B-2
PLC
closing, 4-7
downloading a program, |4-6
opening, 4-6
Opening a PLC, 4-6
saving configuration,|4-6
PLCSIM
errors during installation, 2-5
Installation, 2-4
Power on/off
CPU indicator, 5-2
cycling power, 4-3
Process image, 1-3
Product overview, 1-1
Program editor, monitoring status, 3-8

R

Real number, format,|B-4
Resetting the CPU memory, |5-3
Resetting timers, 3-6
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RUN mode
changing the CPU mode to, 5-2
CPU indicator, |5-2
Running a program, 3-5-3-6
RUN-P mode, changing the CPU mode to, 5-2

S

S7 format, B-4
Sample program, running, 3-5-3-6
Saving
a layout of view objects, 3-6
the PLC configuration, 4-6
Scan modes, 4-3
Showing symbol names, 5-7
SIMATIC Manager, selecting the simulator, 4-2
Simulation session, turning on and off,|4-2
Simulator button, SIMATIC Manager, 4-2
Simulator options
continuous scan, |4-3
Pause, 4-3
single scan mode, 4-3
Single scan mode, |4-3
Stacks, 4-4//5-10
Starting the program, 3-5
Status indicators (LEDs), 5-2
Status word, 5-8
STEP 7 manuals, |iv
STEP 7 tools
disconnect before closing CPU, 4-4
monitoring logic execution, 3-8
variable table (VAT), 3-7|/4-5
STOP mode
changing the CPU mode to, 5-2
CPU indicator, 5-2
Stop mode, before resetting CPU memory
(MRES),|5-3
Symbol names for addresses, 5-7
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System fault (SF), CPU indicator, 5-2
System function blocks (SFBs) supported, 1-3
System functions (SFCs) supported, |1-3

T

Technical assistance, iv
Timer area of memory, description, B-2
Timers
accessing timer data, 5-4
creating, 3-4
execution times, 1-3
resetting, 3-6
Toolbar buttons
in PLCSIM window, 3-5//4-3,|4-4
in SIMATIC Manager, 3-2, 4-2

U

Uninstalling, PLCSIM, 2-5
Using STEP 7 tools, 3-7-3-8

\'}

Variable table, monitoring and modifying the
program, 3-7,/4-5
Variables, modifying data, 5-7
Variables view object, data formats, |B-4
VAT. See Variable table
View object
accessing data in memory, 5-4-5-7
accumulators, |4-4
block registers,|4-4
CPU, 4-6//5-2
saving the PLC,|4-6
stacks, 4-4| 5-10
variable, 4-4
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Country:
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Remarks Form

Your comments and recommendations will help us to improve the quality and usefulness
of our publications. Please take the first available opportunity to fill out this questionnaire
and return it to Siemens.

Please give each of the following questions your own personal mark within the range
from 1 (very good) to 5 (poor).

Do the contents meet your requirements?

Is the information you need easy to find?

Is the text easy to understand?

Does the level of technical detail meet your requirements?
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Please rate the quality of the graphics/tables:

Additional comments:
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