
Tecplot, Inc. Bellevue, WA 2013

           

Getting Started Manual

Release 1



COPYRIGHT NOTICE

Tecplot 360TM Getting Started Manual is for use with Tecplot 360TM Version 2013 R1.

Copyright © 1988-2013 Tecplot, Inc. All rights reserved worldwide. Except for personal use, this manual may not be reproduced, transmitted, transcribed, stored in a retrieval system, or translated in any form, in whole or in part, without the express written
permission of Tecplot, Inc., 3535 Factoria Blvd, Ste. 550; Bellevue, WA 98006 U.S.A.

The software discussed in this documentation and the documentation itself are furnished under license for utilization and duplication only according to the license terms. The copyright for the software is held by Tecplot, Inc.  Documentation is provided for
information only. It is subject to change without notice. It should  not be interpreted as a commitment by Tecplot, Inc. Tecplot, Inc. assumes no liability or responsibility for documentation errors or inaccuracies.

Tecplot, Inc.
Post Office Box 52708
Bellevue, WA 98015-2708 U.S.A.
Tel:1.800.763.7005 (within the U.S. or Canada), 00 1 (425)653-1200 (internationally)
email: sales@tecplot.com, support@tecplot.com
Questions, comments or concerns regarding this document: documentation@tecplot.com
For more information, visit http://www.tecplot.com

THIRD PARTY SOFTWARE COPYRIGHT NOTICES

LAPACK 1992-2007 LAPACK Copyright © 1992-2007 the University of Tennessee. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistribu-
tions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer listed in this cense in
the documentation and/or other materials provided with the distribution. Neither the name of the copyright holders nor the names of its contributors may be used to endorse or promote products derived from this software without pecific prior written per-
mission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.  The University
of Tennessee. All Rights Reserved. SciPy 2001-2009 Enthought. Inc. All Rights Reserved. NumPy 2005 NumPy Developers. All Rights Reserved. VisTools and VdmTools 1992-2009 Visual Kinematics, Inc. All Rights Reserved. NCSA HDF & HDF5 (Hierarchical
Data Format) Software Library and Utilities  Contributors: National Center for Supercomputing Applications  (NCSA) at the University of Illinois, Fortner Software, Unidata Program Center (netCDF), The Independent JPEG Group (JPEG), Jean-loup Gailly
and Mark Adler (gzip), and Digital Equipment Corporation (DEC). Conditions of Redistribution: 1. Redistributions of source code must retain the above copyright notice, this list of conditions, and the following disclaimer. 2. Redistributions in binary form
must reproduce the above copyright notice, this list of conditions, and the following disclaimer in the documentation and/or materials provided with the distribution. 3. In addition, redistributions of modified forms of the source or binary code must carry
prominent notices stating that the original code was changed and the date of the change. 4. All publications or advertising materials mentioning features or use of this software are asked, but not required, to acknowledge that it was developed by The HDF
Group and by the National Center for Supercomputing Applications at the University of Illinois at Urbana-Champaign and credit the contributors. 5. Neither the name of The HDF Group, the name of the University, nor the name of any Contributor may be
used to endorse or promote products derived from this software without specific prior written permission from the University, THG, or the Contributor, respectively. DISCLAIMER: THIS SOFTWARE IS PROVIDED BY THE HDF GROUP (THG) AND THE
CONTRIBUTORS "AS IS" WITH NO WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED.  In no event shall THG or the Contributors be liable for any damages suffered by the users arising out of the use of this software, even if advised of the pos-
sibility of such damage. Copyright © 1998-2006 The Board of Trustees of the University of Illinois, Copyright © 2006-2008 The HDF Group (THG). All Rights Reserved. PNG Reference Library  Copyright © 1995, 1996 Guy Eric Schalnat, Group 42, Inc., Copy-
right © 1996, 1997 Andreas Dilger, Copyright © 1998, 1999 Glenn Randers-Pehrson. All Rights Reserved. Tcl 1989-1994 The Regents of the University of California. Copyright © 1994 The Australian National University. Copyright © 1994-1998 Sun
Microsystems, Inc. Copyright © 1998-1999 Scriptics Corporation. All Rights Reserved. bmptopnm  1992 David W. Sanderson. All Rights Reserved. Netpbm 1988 Jef Poskanzer . All Rights Reserved. Mesa 1999-2003 Brian Paul. All Rights Reserved. W3C IPR
1995-1998 World Wide Web Consortium, (Massachusetts Institute of Technology, Institut National de Recherche en Informatique et en Automatique, Keio University). All Rights Reserved. Ppmtopict 1990 Ken Yap. All Rights Reserved. JPEG 1991-1998 Thomas
G. Lane. All Rights Reserved. Dirent API for Microsoft Visual Studio (dirent.h) 2006-2006 Copyright © 2006 Toni Ronkko. Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the
``Software''), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense,  and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so.
Toni Ronkko. All Rights Reserved. ICU 1995-2009 Copyright © 1995-2009 International Business Machines Corporation and others. All rights reserved. Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated
documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished
to do so, provided that the above copyright notice(s) and this permission notice appear in all copies of the Software and that both the above copyright notice(s) and this permission notice appear in supporting documentation.  International Business Machines
Corporation and others. All Rights Reserved. QsLog 2010 Copyright © 2010, Razvan Petru. All rights reserved. QsLog Copyright (c) 2010, Razvan Petru. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are
permitted provided that the following onditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this
list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. The name of the contributors may not be used to endorse or promote products derived from this software without specific prior written
permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABIL-
ITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUEN-
TIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. Razvan Petru.
All Rights Reserved. VTK 1993-2008 Copyright © 1993-2008 Ken Martin, Will Schroeder, Bill Lorenson. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions
are met:  Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer
in the documentation and/or other materials provided with the distribution. Neither name of Ken Martin, Will Schroeder, or Bill Lorensen nor the names of any contributors may be used to endorse or promote products derived from this software without spe-
cific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHORS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSE-
QUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABIL-
ITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. Ken Martin,
Will Schroeder, Bill Lorenson. All Rights Reserved. 

TRADEMARKS

Tecplot,® Tecplot 360,TM the Tecplot 360 logo, Preplot,TM Enjoy the View,TM Master the View,TM and FramerTM are registered trademarks or trademarks of Tecplot, Inc. in the United States and other countries.

3D Systems is a registered trademark or trademark of 3D Systems Corporation in the U.S. and/or other countries. Macintosh OS is a registered trademark or trademark of Apple, Incorporated in the U.S. and/or other countries. Reflection-X is a registered trade-
mark or trademark of Attachmate Corporation in the U.S. and/or other countries. EnSight is a registered trademark or trademark of Computation Engineering Internation (CEI), Incorporated in the U.S. and/or other countries. EDEM is a registered trademark
or trademark of DEM Solutions Ltd in the U.S. and/or other countries. Exceed 3D, Hummingbird, and Exceed are registered trademarks or trademarks of Hummingbird Limited in the U.S. and/or other countries. Konqueror is a registered trademark or trade-
mark of KDE e.V. in the U.S. and/or other countries. VIP and VDB are registered trademarks or trademarks of Halliburton in the U.S. and/or other countries. ECLIPSE FrontSim is a registered trademark or trademark of Schlumberger Information Solutions
(SIS) in the U.S. and/or other countries. Debian is a registered trademark or trademark of Software in the Public Interest, Incorporated in the U.S. and/or other countries. X3D is a registered trademark or trademark of Web3D Consortium in the U.S. and/or other
countries. X Window System is a registered trademark or trademark of X Consortium, Incorporated in the U.S. and/or other countries. ANSYS, Fluent and any and all ANSYS, Inc. brand, product, service and feature names, logos and slogans are registered
trademarks or trademarks of ANSYS Incorporated or its subsidiaries in the U.S. and/or other countries. PAM-CRASH is a registered trademark or trademark of ESI Group in the U.S. and/or other countries. LS-DYNA is a registered trademark or trademark of
Livermore Software Technology Coroporation in the U.S. and/or other countries. MSC/NASTRAN is a registered trademark or trademark of MSC.Software Corporation in the U.S. and/or other countries. NASTRAN is a registered trademark or trademark of
National Aeronautics Space Administration in the U.S. and/or other countries. 3DSL is a registered trademark or trademark of StreamSim Technologies, Incorporated in the U.S. and/or other countries. SDRC/IDEAS Universal is a registered trademark or trade-
mark of UGS PLM Solutions Incorporated or its subsidiaries in the U.S. and/or other countries. Star-CCM+ is a registered trademark or trademark of CD-adapco in the U.S. and/or other countries. Reprise License Manager is a registered trademark or trade-
mark of Reprise Software, Inc. in the U.S. and/or other countries. Python is a registered trademark or trademark of Python Software Foundation in the U.S. and/or other countries. Abaqus, the 3DS logo, SIMULIA and CATIA  are registered trademarks or
trademarks of Dassault Systèmes  or its subsidiaries in the U.S. and/or other countries. The Abaqus runtime libraries are a product of Dassault Systèmes Simulia Corp., Providence, RI, USA. © Dassault Systèmes, 2007 FLOW-3D is a registered trademark or
trademark of Flow Science, Incorporated in the U.S. and/or other countries. Adobe, Flash, Flash Player, Premier and PostScript are registered trademarks or trademarks of Adobe Systems, Incorporated in the U.S. and/or other countries. AutoCAD and DXF are
registered trademarks or trademarks of Autodesk, Incorporated in the U.S. and/or other countries. Ubuntu is a registered trademark or trademark of Canonical Limited in the U.S. and/or other countries. HP, LaserJet and PaintJet are registered trademarks or
trademarks of Hewlett-Packard Development Company, Limited Partnership in the U.S. and/or other countries. IBM, RS/6000 and AIX are registered trademarks or trademarks of International Business Machines Corporation in the U.S. and/or other countries.
Helvetica Font Family and Times Font Family are registered trademarks or trademarks of Linotype GmbH in the U.S. and/or other countries. Linux is a registered trademark or trademark of Linus Torvalds in the U.S. and/or other countries. ActiveX, Excel,
Microsoft, Visual C++, Visual Studio, Windows, Windows Metafile, Windows XP, Windows Vista, Windows 2000 and PowerPoint are registered trademarks or trademarks of Microsoft Corporation in the U.S. and/or other countries. Firefox is a registered trade-
mark or trademark of The Mozilla Foundation in the U.S. and/or other countries. Netscape is a registered trademark or trademark of Netscape Communications Corporation in the U.S. and/or other countries. SUSE is a registered trademark or trademark of
Novell, Incorporated in the U.S. and/or other countries. Red Hat is a registered trademark or trademark of Red Hat, Incorporated in the U.S. and/or other countries. SPARC is a registered trademark or trademark of SPARC International, Incorporated in the
U.S. and/or other countries. Products bearing SPARC trademarks are based on an architecture developed by Sun Microsystems, Inc. Solaris, Sun and SunRaster are registered trademarks or trademarks of Sun MicroSystems, Incorporated in the U.S. and/or
other countries. Courier is a registered trademark or trademark of Monotype Imaging Incorporated in the U.S. and/or other countries. UNIX and Motif are registered trademarks or trademarks of The Open Group in the U.S. and/or other countries. Qt is a reg-
istered trademark or trademark of Trolltech in the U.S. and/or other countries. Zlib is a registered trademark or trademark of Jean-loup Gailly and Mark Adler in the U.S. and/or other countries. OpenGL is a registered trademark or trademark of Silicon Graph-
ics, Incorporated in the U.S. and/or other countries. JPEG is a registered trademark or trademark of Thomas G. Lane in the U.S. and/or other countries. SENSOR is a registered trademark or trademark of Coats Engineering in the U.S. and/or other countries.
SENSOR is licensed and distributed only by Coats Engineering and by JOA Oil and Gas, a world-wide authorized reseller. MySQL is a registered trademark or trademark of Oracle in the U.S. and/or other countries. MySQL is a trademark of Oracle Corpora-
tion and/or its affiliates. All other product names mentioned herein are trademarks or registered trademarks of their respective owners.

NOTICE TO U.S. GOVERNMENT END-USERS

Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in subparagraphs (a) through (d) of the Commercial Computer-Restricted Rights clause at FAR 52.227-19 when applicable, or in subparagraph (c)(1)(ii) of the Rights in
Technical Data and Computer Software clause at DFARS 252.227-7013, and/or in similar or successor clauses in the DOD or NASA FAR Supplement. Contractor/manufacturer is Tecplot, Inc., 3535 Factoria Blvd, Ste. 550; Bellevue, WA 98006 U.S.A.

13-360-02-1

Rev 1/2013



3

Table of Contents

1 Introduction ............................................................................  7

2 Overview ....................................................................................  9

Interface........................................................................................ 10
Menubar....................................................................................... 10

Sidebar ............................................................................................... 11
Status Line......................................................................................... 23
Tecplot 360 Workspace ...................................................................... 23

Data Hierarchy............................................................................ 23
Frames ............................................................................................... 23
Datasets ............................................................................................. 24
Zones ................................................................................................. 24

Data Structure ............................................................................. 24
Ordered Data ..................................................................................... 24
Finite Element Data .......................................................................... 24

Creating Plots .............................................................................. 26
Output Formats...........................................................................26

3 External Flow Tutorial ...................................................  29

Introduction................................................................................. 29
Background Information.................................................................... 29
Tutorial Summary ............................................................................. 29

Getting Started ............................................................................ 30
Load a Plot3D File (Including a Boundary File)............................... 30
Manipulate Layers............................................................................. 31
Determine the Number of Zones and Variables ................................ 32

Displaying a Contour Map of the Pressure Coefficient ........ 33
Calculate the Pressure Coefficient ..................................................... 33

Modifying the Contour Layer................................................... 34



4

Add a Contour Legend ...................................................................... 35
Modify the Contour Legend .............................................................. 35
Add Contour Levels........................................................................... 37
Modify the Contour Coloring............................................................ 39
Isolate the Wing Using the Sidebar................................................... 40

Creating a 2D Projection Plane ................................................. 41
Extract a Slice.................................................................................... 41
Activate the Edge Layer for Zone 7 Only ......................................... 42
Create a New Frame .......................................................................... 44
Delete a Group of Mappings ............................................................. 44
Activate the Mapping........................................................................ 45
Change the Zone Associated with the Mapping ............................... 45
Adjust the View ................................................................................. 46

Manipulating Data ..................................................................... 46
Determine the Max and Min Values of the X Variable..................... 46
Create a New Variable ....................................................................... 47
Change the X-Axis Variable .............................................................. 48
Adjust the View ................................................................................. 49

Comparing Simulation Data with Measured Data................ 50
Load the Measured Data File ............................................................ 50
Change the Variable Name ................................................................ 52
Create New Mappings....................................................................... 53
Rename the Mappings ....................................................................... 54
Change Zone Assignments................................................................ 55
Activate the New Mappings.............................................................. 56
Reverse the Y-Axes............................................................................ 57
Adjust the Mapping Style ................................................................. 58
Add a Line Legend............................................................................. 60
Export the Frames to a File ............................................................... 61

Conclusion ................................................................................... 62

4 Internal Flow Tutorial ....................................................  63

Introduction................................................................................. 63
Background Information ................................................................... 63
Tutorial Summary ............................................................................. 63

Getting Started ............................................................................ 64
Load a Fluent File .............................................................................. 64
Use the Sidebar to Deactivate Plot Layers ........................................ 67

Adjusting the Plot View............................................................. 67
Slice and Clip to View a Cross Section.............................................. 67
Adjust View Inside Mixer ................................................................. 70

Using the Zone Style Dialog to Customize Settings.............. 70
Accentuate the Blade ......................................................................... 70
Adjust the Lighting Effects ............................................................... 72
Change the Frame Background Color ............................................... 72
Adjust the Lighting ........................................................................... 74
Activate Streamtraces........................................................................ 74
Position Streamtraces Using the Add Streamtraces Tool ................. 75
Position Streamtraces Using the Streamtrace Details Dialog .......... 75



5

Copy Plot to Clipboard ...................................................................... 76
Conclusion ................................................................................... 78

5 Fluid Structure Interaction Tutorial ....................  79

Introduction................................................................................. 79
Background Information.................................................................... 79
Tutorial Summary ............................................................................. 79

Getting Started ............................................................................ 79
Load an Abaqus Output Database File ............................................. 80
Load a Set of Transient Fluent Data Files......................................... 83
Modify the Plot View......................................................................... 85

Adjusting the View..................................................................... 87
Change the View Setting ................................................................... 87
Modify the Axis ................................................................................. 88

Working with Contour Groups ................................................ 89
Display Contours .............................................................................. 89
Set the Contour Variable for Contour Group 1 ................................. 90
Modify the Contour Levels for Contour Group 1.............................. 90
Modify the Color Map for Contour Group 1..................................... 92
Set the Contour Variable for Contour Group 2 ................................. 94
Modify the Color Map for Contour Group 2..................................... 95
Change the Contour Group Assigned to a Zone ............................... 96

Customizing Contour Legends ................................................ 98
Add Contour Legends........................................................................ 98
Modify the Contour Legends ........................................................... 100

Using Streamtraces...................................................................102
Display Streamtraces....................................................................... 102
Modify Streamtraces ....................................................................... 104

Animating Your Plot, Displaying Result in PowerPoint.....106
Animate on the Screen.....................................................................106
Export Your Animation to a File .................................................... 106
Insert a Tecplot 360 AVI Animation into PowerPoint ................... 109

Conclusion .................................................................................111



6



7

1

Introduction

Tecplot 360 allows you to interactively explore, visualize, and analyze your data, and then communicate 
your results through high-quality plots for reports, papers, presentations, or websites.

The user documentation for Tecplot 360 is divided into these nine books:

• Getting Started Manual (this document) - New Tecplot 360 users are encouraged to work 
through the tutorials provided in the Getting Started Manual. The tutorials highlight how to 
work with key features in Tecplot 360.

• User’s Manual - This manual provides a complete description of working with Tecplot 360 
features. 

• Scripting Guide - This guide provides Macro and Python command syntax and information on 
working with Macro and Python files and commands.

• Quick Reference Guide - This guide provides syntax for zone header files, macro variables, 
keyboard shortcuts, and more.

• Data Format Guide - This guide provides information on outputting simulator data to Tecplot 
360 file format.

• Add-on Developer’s Kit - User’s Manual - This manual provides instructions and examples for 
creating add-ons for Tecplot 360.

• Add-on Developer’s Kit - Reference Manual - This manual provides the syntax for the 
functions included in the add-on kit.

• Installation Instructions - These instructions give a detailed description of how to install 
Tecplot 360 on your machine. 

• Release Notes - These notes provide information about new and/or updated Tecplot 360 
features.

• Tecplot Talk - A user-supported forum discussing Tecplot 360, Tecplot Focus, Python scripting, 
Add-on development, TecIO and more. Visit www.tecplottalk.com for details.

This manual includes an overview of Tecplot 360, as well as three tutorials. Each tutorial takes 
approximately 20-40 minutes to complete. 

• External Flow Tutorial - This tutorial includes calculating a pressure coefficient, using a 
contour layer, extracting a slice, and plotting data from multiple files in one frame.

http://www.tecplottalk.com
http://www.tecplottalk.com
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• Internal Flow Tutorial - This tutorial includes value blanking and streamtrace animation.
• Fluid Structure Interaction Tutorial - This tutorial includes contour groups, manipulation of 

multiple data files, and transient animation.

For in-depth information on any of the topics covered in the Getting Started Manual, please refer to the 
User’s Manual.
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2

Overview

Tecplot 360 features allow you to visualize complex numerical and computational fluid dynamics and 
vital engineering plot relationships by:

• Animating XY, Polar, 2D, and 3D plots in one unified environment
• Customizing the independent axes for specialty plots (for example, Lift vs. Angle of Attack or 

Cp vs. Cord)
• Using the interactive slice, iso-surface, and streamtrace tools
• Detecting vortex cores, shock surfaces, and separation and reattachment lines
• Calculating critical flow functions and performing integrations
• Integrating particle trajectories with support for massed particles and drag effects
• Validating numerical models with test data in the same window
• Comparing multiple models simultaneously, including visualization of fluid structure 

interaction
• Supporting 30 CFD, FEA, structural analysis, and industry-standard data formats

After creating your plots, you can communicate your results clearly and effectively by:

• Using the “Copy Plot to Clipboard” command to paste a plot directly into Microsoft® 
PowerPoint®, Microsoft Word®, and other Microsoft Office® applications

• Animating to a file for use in a PowerPoint presentation, a webpage, or a Framer (AVI, Flash®, 
or Raster Metafile)

• Using the Publish command to share results directly on the Web
• Exporting presentation-quality vector and raster formats (JPEG, PNG, TIFF, BMP, WMF, 

Adobe® PostScript®, or EPS)

You may also save time and effort by automating routine analyses and plotting operations through these 
methods:

• Customizing the interface to your workflow
• Creating macros by recording or writing scripts
• Using the Quick Macro Panel dialog for one-click macro access
• Batch process plotting and printing
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• Extending Tecplot 360 functionality with the Add-on Developer's Kit

2 - 1   Interface
Five major sections make up the Tecplot 360 interface:

2 - 2   Menubar
The menubar offers rapid access to most of Tecplot 360’s features.

Tecplot 360’s features are organized into the following menus:

• File - Use the File menu to read or write data files and plot layouts, print and export plots, and 
set configuration preferences.

• Edit - Use the Edit menu to select, undo, cut, copy, paste, and clear objects, open the Quick 
Edit dialog, and change the draw order for selected items (push or pop).

• View - Use the View menu to manipulate the point of view of your data, including scale, view 
range, and 3D rotation. You can also use the View menu to copy and paste views between 
frames. 
The View menu includes the following convenient sizing options:

Cut, Copy, and Paste work only within Tecplot 360. To place a graphic image of your 
layout into another program, use Copy Plot to Clipboard. This option is available on 
Windows® and Macintosh® platforms.

 Sidebar

Menubar Tools

Tecplot 360 

Status 
Line
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Menubar

• Fit Everything (3D Only) - This options resizes plots so that all data points, text, and 
geometries are included in the frame. 

• Fit Surfaces (3D Only) - This option resizes plots so that all surfaces are included in the 
frame, excluding any volume zones. 

• Fit to Full Size - This option fits the entire plot into the frame. This option does not 
affect the axis ranges. 

• Nice Fit to Full Size - This option sets the axis range to begin and end on major axis 
increments (if axes are dependent, the vertical axis length is adjusted to accommodate a 
major tick mark). 

• Data Fit - This option fits the data points to the frame. 
• Make Current View Nice - This option modifies the range on a specified axis to fit the 

minimum and maximum of the variable assigned to that axis, and then snaps the major 
tick marks to the ends of the axis. (If axis dependency is not set as independent, this may 
affect the range on another axis.) 

• Center - This option moves the plot image so that the data points are centered within 
the frame. (Only the data is centered; text, geometries, and the 3D axes are not 
considered.) 

• Plot - Use the Plot menu to control the style of your plots. The menu items available are 
dependent upon the active plot type (chosen in the Sidebar).

• Insert - Use the Insert menu to add text, geometries (polylines, squares, rectangles, circles, and 
ellipses), or image files. If you have a 3D zone, you may also use the Insert menu to insert a 
slice. If the plot type is set to 2D or 3D Cartesian, you may insert a streamtrace.

• Animate - Use the Animate menu to animate IJK Planes, IJK Blanking, iso-surfaces, mappings, 
slices, streamtraces, time, and zones.

• Data - Use the Data menu to create, manipulate, and examine data. Types of data 
manipulation available in Tecplot 360 include zone creation, interpolation, triangulation, and 
creation or alteration of variables.

• Frame - Use the Frame menu to create, edit, and control frames.
• Options - Use the Options menu to control the attributes of your workspace, including the 

color map, paper grid, display options, and rulers.
• Scripting - Use the Scripting menu to play or record macros, and to access the Quick Macros 

Panel dialog.
• Tools - Use the Tools menu to launch the Quick Edit dialog or an add-on.
• Analyze - Use the Analyze menu to examine grid quality, perform integrations, generate 

particle paths, extract flow features, and estimate numerical errors.
• Help - Choose “Tecplot 360 Help” from the Help menu to get specific, complete help on 

features or operations within Tecplot 360. By choosing “About Tecplot 360” from this menu, 
you can obtain specific information about your license.

2 - 2.1   Sidebar
The Sidebar provides easy access for frequently used plot controls. The functions available in the Sidebar 
depend on the plot type of the active frame. For 2D or 3D Cartesian plot types, you can add or subtract 
zone layers, zone effects (3D only), and derived objects from your plot using the Sidebar. For line plots (XY 
and Polar), you can add or subtract mapping layers using the Sidebar. 

To customize your plot, simply:

• Choose the desired type of plot from the Plot Types menu.
• Use the toggle switches to add and subtract Zone Layers/Map Layers, Zone Effects, or Derived 

Objects. Use the Zone Style/Mapping Style dialogs to further customize your plot by adding 
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or subtracting zones from specific plot layers/mappings, changing the way a zone or group of 
zones is displayed, or changing various plot settings. 

Plot Types
The plot type, combined with a frame’s dataset, active layers, and each layer’s associated attributes, define 
a plot. Each plot type represents one view of the data. There are five plot types available:

• 3D Cartesian - 3D plots of surfaces and volumes
• 2D Cartesian - 2D plots of surfaces, where the vertical and horizontal axes are both dependent 

variables (i.e. x = f(A) and y = f(A), where A is another variable)
• XY Line - Line plots of independent and dependent variables on a Cartesian grid; typically 

with the horizontal axis (x) as the independent variable and the vertical axis (y = f(x)) as a 
dependent variable

• Polar Line - Line plots of independent and dependent variables on a polar grid
• Sketch - Plots without data, such as drawings, flow charts, and viewgraphs

Plot Types Menu

Zone Layers/Map Layers

Zone Effects 
(3D only)

Figure 2-1. The Tecplot 360 Sidebar for a 
field plot (left) and a line 
plot (right). The features 
available in the Sidebar are 
dependent upon the plot 
type. For 3D Cartesian plots, 
you may add and subtract 
zone layers, derived objects, 
and effects for your plot. You 
may also use the Placement 
Plane for positioning of 
some 3D objects (3D plots 
only). For 2D Cartesian plots 
(not shown), you may add 
and subtract zone layers and 
some derived objects for 
your plot. For field plots (3D 
or 2D), you may animate 
transient data directly from 
the Sidebar. For line plots, 
you may add and subtract 
map layers.                                             
NOTE: XY line plots have 

Derived 
Objects (Iso-
surfaces and 
slices are 3D 
only)

Transient 
Controls 

Placement Plane 
(3D only, 
available when 
the slice or 
streamtrace tool 
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Menubar

Zone Layers/Map Layers
A layer is a way of representing a frame’s dataset. The complete plot is the sum of all the active layers, 
axes, text, geometries, and other elements added to the data and plotted in the layers. There are six zone 
layers for 2D and 3D Cartesian, four map layers for XY Line, two map layers for Polar Line, and no layers 
for Sketch.

The following six zone layers are options for 2D and 3D Cartesian plot types:

• Mesh - Lines connecting the data points within each zone
• Contour - Lines having a constant value, the region between these lines (contour flooding), or 

both
• Vector - Arrows indicating the direction and magnitude of physical quantities
• Scatter - Symbols at the location of each data point
• Shade - The effect used to tint each zone with a specified solid color, or to add light-source 

shading to a 3D surface plot. When using this effect in conjunction with the Lighting zone 
effect, you may set Paneled or Gouraud shading. When using the shade effect in conjunction 
with the Translucency zone effect, you may create a translucent surface for your plot.

• Edge - Zone edges and creases for ordered data and creases for finite element data

The four XY Line map layers are:

• Lines - Lines that plot a pair of variables (X and Y) as a set of line segments or a fitted curve
• Symbols - A pair of variables (X and Y) that are individual data points and are represented by 

a symbol that you specify
• Bars - A pair of variables (X and Y) as a horizontal or vertical bar chart
• Error Bars - An option that allows you to add error bars to your plot

The two Polar Line map layers are:

• Lines - A pair of variables (R and Theta) that are a set of line segments or a fitted curve
• Symbols - A pair of variables (R and Theta) that are individual data points represented by a 

symbol that you specify

Zone Effects
For 3D Cartesian plot types, use the Sidebar to turn Lighting and Translucency on or off. Only shaded and 
flooded contour surface plot types are affected.

Derived Objects
For Cartesian plot types (2D and 3D), toggle-on “Iso-Surfaces”, “Slices”, or “Streamtraces” from the 
Sidebar to explore these elements. Their corresponding Details dialogs can be accessed with the Details 
button in the Sidebar. (In 2D Cartesian plots, only streamtraces are available.)

Transient Controls
When working with transient data, simply click the Play  button in the 
Sidebar to animate the data over time. The active frame will be animated 
from the Current Solution Time (left, circled in red) to the last time step. You 
may also drag the slider left or right to change the Current Solution Time of 
your plot.

The Transient Controls have the following functions:
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•  - This button jumps to the Starting Value.

•  - This button jumps toward the Starting Value by one step.

•  - This button runs animation as specified by the Operation field of the Time Details 
dialog. This Play button becomes a Pause button while the animation is playing.

•  - This button jumps toward the Ending Value by one step.

•  - This button jumps to the Ending Value.

Use the Details button in the Transient Controls region of the Sidebar to launch the Time Details dialog.

See Section 7 - 2 “Time Aware” in the User’s Manual for more information on time controls and the Time 
Details dialog.

Placement Plane
When using certain tools to add objects to your plot, toggle-on “Use 
Placement Plane” in the Sidebar to place the objects along a given plane (3D 
Plots only). Use the X, Y, and Z buttons to choose the plane to use, and use the 
slider to reposition the Placement Plane. The Placement Plane will appear as 
a gray slice in your plot. 

The Placement Plane is available for:

• Placing streamtraces (using the Add Streamtrace tool )

• Placing slices (using the Slice tool )

• Adding Contour Levels (using the Add Contour Level tool )

• Deleting Contour Levels (using the Remove Contour Level tool )

• Probing (using the Probing tool )

Snap Modes
Snap to Grid - Constrains object movement to whole steps on the axis grid. This 
can be useful for aligning text and geometries with specific plot features.

Snap to Paper - Constrains object movement to whole steps on the paper's ruler 
grid. This can be useful for positioning frames precisely for printing, or for 
absolute positioning of text, geometries, and other plot elements.
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Redraw Buttons
The redraw buttons allow you to keep your plot up to date: Redraw All-CTRL-D redraws all frames, 
SHIFT-Redraw All causes Tecplot 360 to completely regenerate the workspace, and Redraw-CTRL-R 
redraws only the current frame.

Auto Redraw
Use Auto Redraw - When toggled-on, Tecplot 360 will automatically redraw the plot whenever style or 
data changes. Some users prefer to turn this option off while setting multiple style settings and then 
manually clicking Tecplot 360's Redraw or Redraw All button on the Sidebar to see a full plot. 

Cache Graphics
Tecplot 360 uses OpenGL® to render plots. OpenGL provides the ability to cache graphic instructions for 
rendering and can re-render the cached graphics much faster than having Tecplot 360 send the 
instructions again. This is particularly true for the interactive manipulation of a plot. However, this 
performance potential comes at the cost of using more memory. If the memory need is too high, the overall 
performance could be less. Tecplot 360 has three graphics cache modes: cache all graphics, cache only 
lightweight graphics objects, and do not cache graphics.

When “Cache Graphics” is toggled-on in the Sidebar, Tecplot 360 assumes there is enough memory to 
generate the graphics cache. Assuming this is true, Tecplot 360's rendering performance will be optimal 
for the interactive manipulation of a plot.

When memory constraints are very limited, consider toggling-off “Cache Graphics”. If you intend to 
interact with the plot under limited memory constraints, also consider setting the “Plot Approximation” 
mode to “All Frames Always Approximated”.

See Section  “Graphics Cache” in the User’s Manual for more information.

Plot Approximations
If “Plot Approximation” is toggled-on and the number of data points is above the point threshold, Tecplot 
360 will render the approximate plot for style, data, and interactive view changes followed immediately 
by the full plot. This option provides for good interactive performance with the final plot always 
displayed in the full representation.

Tools
Each of the tools represented in the toolbar changes the mouse mode and allows you to edit your plot 
interactively.

An auto redraw can be interrupted at any time with a mouse click or key press.

Double-click on a tool to launch the Details dialog associated with that tool.
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Selector Tool
Use the Selector tool to select objects in your workspace. The objects can be modified using the Quick Edit 
dialog when the Quick Edit button is chosen in the Sidebar before an object is selected.

The following objects can be moved (translated) using the Selector tool itself:

• Frames
• Axis Grid Area
• Text
• Geometries
• Contour Labels
• Streamtraces
• Streamtrace Termination Line
• Legends
• 3D Frame Axis

To select an object and open that object's attributes dialog, either double-click on the desired object or drag 
the cursor to select a group of objects to call up the Group Select dialog. Click OK, and then click the 
Object Details button in the Sidebar.

Adjustor Tool
Use the Adjustor tool to perform the following specific modifications to your plot and data:

• Change the location of individual or groups of data points in the grid
• Modify the values of the dataset variables at a particular point
• Change the length or placement of individual axes (2D Cartesian and XY Line plot types only)
• Change the spacing between an axis label and its associated axis (2D Cartesian and XY line 

plot types only)
• Change the shape of a polyline

Except for the above actions, the behavior of the Adjustor tool is identical to that of the Selector tool. 

To select multiple points, you can either SHIFT-click after selecting your initial point to select additional 
points, or you can draw a group select band to select the points within the band. (In Line plots, you can 
select points from only one mapping at a time.)

Once you have selected all desired points, move the Adjustor over the selection handles of one of the 
points, then drag to the desired location of the chosen data point. Other selected points will move as a unit 
with the chosen data point, maintaining their relative positions.

The Adjustor tool can alter your data. Be sure you want to use the Adjustor tool before 
dragging points in the data region.

For XY Line plots: If several mappings are using the same data for one of the variables, 
adjusting one of the mappings will result in simultaneous adjustments to the others. You 
can avoid this by pressing the H or V keys on your keyboard while adjusting the selected 
point. The H and V keys restrict the adjustment to the horizontal and vertical directions, 
respectively.
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Group Select
The Group Select dialog is opened when you select a group of objects with the Selector or Adjustor tools. 
Drag to create a rectangle around the objects you want to select. Use the Group Select dialog to specify 
which types of objects within the specified selection region should be selected. 

The Group Select dialog allows you to specify the following object types to be selected (if the selection 
rectangle does not include a specific object, its associated check box is inactive):

• Text
• Geometries
• Frames
• Zones
• Axis Grid Area
• Contour Labels
• Streamtraces

The Group Select dialog offers the following attribute filters:

• Geoms of Type - Choose geometries of a particular type from the menu.
• Geoms with Line Pattern - Choose all geometries having a particular line pattern.
• Text with Font - Choose all text displayed in a particular font.
• Objects with Color - Choose all objects of a particular color. (Choose the appropriate color 

from the Select Color dialog.)

Zoom Tool

This tool enables zooming into or away from a plot.

With the zoom tool selected as the mouse mode, when a mouse-click occurs (without dragging), the 
zooming is centered at the location of your click.

There are two zoom modes: plot zooming and paper zooming.

For plot zooming, drag the magnifying glass cursor to draw a box about the region that you want to fit into 
the frame. The box may be larger than the frame. Drawing a box larger than the frame zooms away from 
the plot. The region within the view box will be resized to fit into the frame.

To return to the previous view, choose “Last” from the View menu (CTRL-L). To restore the original 2D 
view, choose “Fit to Full Size” (CTRL-F) from the View menu.

The results of plot zooming for the 2D plot type are dependent upon the axis mode selected in the Axis 
Details dialog (accessed via the Plot menu):

• 2D Independent Axis Mode - The independent axis mode allows the selected region to 
expand to exactly fit in the frame. The axes are rescaled independently to fit the zoom box.

• 2D Dependent Axis Mode - In dependent mode, the axes are not fit perfectly to the zoom box. 
The longest dimension from the zoom box is applied to the associated axis, and the other axis 
is resized according to the dependency relation.

If Snap to Grid is toggled-on in the Sidebar, you cannot make the zoom box larger than 
the grid area.
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For paper zooming, SHIFT-drag the magnifying glass cursor to draw a box about the region that you want 
to magnify. The plot is resized such that the longest dimension of the zoom box fits into the workspace. 
You can fit one or all frames to the workspace by using the “Fit Selected Frames to Workspace” or “Fit All 
Frames to Workspace” options from the View>Workspace menu. To return to the default paper view, 
choose “Fit Paper to Workspace” from the View>Workspace menu.

Translate Tool

Use the Translate/Magnify tool to translate or magnify data within a frame or the paper within the 
workspace.

While in Translate/Magnify mode, drag the cursor to move the data with respect to the frame, or SHIFT-
drag to move the paper with respect to the workspace.

Three-dimensional Rotation
Tecplot 360 allows you to rotate your data in a variety of ways. Choose one of the six possible 3D rotation 
mouse modes, then drag the pointer in the workspace to rotate your 3D image. The six rotation mouse 
modes can be engaged by selecting one of these six tools:

• Spherical - Drag the mouse horizontally to rotate about the Z-axis; drag the mouse 
vertically to control the tilt of the Z-axis.

• Rollerball - Drag the mouse in the direction you want to move the plot with respect to 
the current orientation on the screen. In this mode, your mouse acts much like a rollerball.

• Twist - Drag the mouse clockwise around the image to rotate the image clockwise. Drag 
the mouse counterclockwise around the image to rotate the image counterclockwise.

• X-axis - Drag the mouse to rotate the image about the X-axis.
• Y-axis - Drag the mouse to rotate the image about the Y-axis.
• Z-axis - Drag the mouse to rotate the image about the Z-axis.

Once you have selected a rotation mouse mode, you can quickly switch to any of the other rotation 
capabilities or rotation modes using the following keyboard shortcuts:

Use the center mouse button to zoom smoothly into or out of the plot.
Clicking anywhere in your plot while the zoom tool is active zooms in on the plot and 
centers that zoom around your click.

Use the right mouse button to translate objects within a frame interactively.
Rescale image: You can rescale your image by choosing the translate tool and pressing 
“+” to magnify or “-” to shrink. 
Rescale paper: To rescale the paper, first SHIFT-drag to move the paper, and then use 
the rescale buttons “+” or “-” to magnify or shrink the paper, respectively.

Drag Rotate about the defined rotation origin with 
your current Rotate tool.

ALT-drag Rotate about the viewer position using your 
current Rotate tool.

Middle-click Smooth zoom in and out of the data.
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Slice Tool

Use the Slice tool to control your slice rendering interactively.

The following keyboard/mouse options are available when the Slice tool is active:

Right-click Translate the data.

O

Move rotation origin to probed point of data. 
This shortcut can be used without first selecting 
a rotation mouse mode. Hover over your 
intended point of origin, type O, and then 
CTRL-right-click and drag to rotate the image.

R Switch to Rollerball rotation.

S Switch to Spherical rotation.

T Switch to Twist rotation.

X Switch to X-axis rotation.

Y Switch to Y-axis rotation.

Z Switch to Z-axis rotation.

+

Primary Slices, Start/End Slices active - Turn on 
intermediate slices (if not already active) and add a 
slice.
Primary Slices active [ONLY] - Turn on Start/End Slices 
and add a slice.
Start/End Slices active [ONLY] - Turn on Start/End 
Slices and add a slice.

-

Primary Slices, Start/End Slices active - Remove start 
and end slices.
Primary Slices active [ONLY] - Remove the primary 
slice.
Start/End Slices active [ONLY] - Remove the Start and 
End Slices.

Click-drag
Update the position of the primary slice (if active). If 
only start and end slices are visible, click to update the 
position of the slice closest to the click.

ALT-click/ALT-drag
Determine the XYZ-location by ignoring zones and 
looking only at derived volume objects (streamtraces, 
slices, iso-surfaces).

SHIFT-click
Place the start or end slice (whichever is closest to the 
initial click location). Show Start/End Slices as activated, 
if necessary.

SHIFT-drag
Move the start or end slice (whichever is closest to the 
initial click location). Show Start/End Slices as activated, 
if necessary.

I, J, K (ordered zones 
only) Switch to slicing constant I, J, or K planes respectively.
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Add Streamtrace
Choose the Add Streamtrace tool to add a streamtrace interactively by clicking anywhere in your plot. 
Select the number of streamtraces to include with each click (rake) using 1-9 on the keyboard. 

Streamtrace Termination Line
Select the Add Streamtrace Termination Line tool to add a streamtrace termination line interactively. 

To draw a Streamtrace Termination Line:

1. Move the cursor into the data region.
2. Click once at the desired starting point for the line.
3. Click again at each desired break point.
4. When the polyline is complete, double-click on the last point of the polyline, press the ESC 

key on your keyboard, or right-click.

The polyline will end any streamtrace(s) that pass through it.

Add Contour Level
Choose the Add Contour Level tool to add a contour level interactively by clicking anywhere in the 
current data region. A new contour level, passing through the specified location, is calculated and drawn.

You can use the following keyboard and mouse shortcuts when the Add Contour Level tool is selected:

X, Y, Z Switch to slicing constant X, Y, or Z planes respectively.

1-8 Numbers one through eight switch to the 
corresponding slice group.

Refer to the Chapter 15: “Streamtraces” in the User’s Manual for more information 
about using streamtraces.
D         Switch to streamrods
R         Switch to streamribbons
S         Switch to surface lines
V         Switch to volume lines
1-9      Change the number of streamtraces added when placing a rake of streamtraces
SHIFT  Draw a rake on concave 3D volume surfaces. These rakes are normally not 
drawn, as they occur outside of the data.

ALT-click Place a contour line by probing on a streamtrace, slice, or iso-surface.

Click Place a contour line.

CTRL-click Replace the nearest contour line with a new line.

Drag Move the new contour line.

- Switch to the Delete Contour Level tool.
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Delete Contour Level
Choose the Delete Contour Level tool to delete a contour level interactively by clicking anywhere in the 
current data region. The contour line nearest the specified location is deleted.

Add Contour Labels
Choose the Add Contour Label tool to switch to the Contour Label mode, which enables you to add a 
contour label interactively (by clicking anywhere in the current data region).

A contour label is added to the plot at the specified location; its level or value information is taken from 
the nearest contour line. This allows you to place labels slightly offset from the lines that they label.

Probe Tool
Choose the Probe tool to probe for values of the dataset's variables at a particular point.

To obtain interpolated values of the dataset variables at the specified location, choose any point in the data 
region. To obtain exact values for the data point nearest the specified location, CTRL-click at the desired 
location.

Insert Text
To add text to any frame, click the Add Text tool and draw a text box in the selected frame. The Text 
Details dialog will be launched automatically. Use it to assign and modify text.

Insert Geometries
Use the corresponding geometry buttons in the toolbar to insert geometries into your plot: 

Polylines

Squares

Rectangles

Use the “+” key to switch to the Add Contour Level tool and the “-” key to switch back 
to the Delete Contour Level tool.

The Contour Type must be “Lines” or “Both Lines & Flood” in order for this tool to be 
active. You can set the Contour Type on the Contour page of the Zone Style dialog.

For XY plots - When you move into the axis grid area, the cursor crosshair is 
augmented by a vertical or horizontal line, depending on whether you are probing along 
the X-axis or the Y-axis. You can change the axis to be probed by pressing X to probe the 
X-axis or Y to probe the Y-axis.
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Circles

Ellipses

Select a geometry shape for insertion, and then drag in the workspace to create the shape of desired size.

Create New Frame
Select the Create New Frame tool to create a new frame. 

To add a frame, drag in the workspace to create a frame of desired size and shape.

Extract Discrete Points
Choose the Extract Discrete Points tool to extract selected points to a data file or a new zone.

To select points:

1. Left-click at each location where you would like to extract a point.
2. To end extraction, either double-click on the last point, press the ESC key, or right-click.
3. The Extract Data Points dialog appears; use it to specify how many points to extract and how 

to save the data.

Extract Points along Polyline
Choose the Extract Line tool to extract points along a specified polyline to a data file or a new zone.

To select points:

1. Click your left-hand mouse button at each location where you would like to extract a point 
along a polyline.

2. To end extraction, either double-click on the last point, press the ESC key, or right-click.
3. The Extract Data Points dialog appears; use it to specify how many points to extract and how 

to save the data.

Create Rectangular Zone (2D Only)
Choose the Create Rectangular Zone tool to add new 2D rectangular zones to the current Tecplot 360 
dataset.

To create a rectangular zone:

1. Click once in the current data region to anchor one corner of the zone.
2. Drag the diagonal corner until the zone is the desired size and shape. The new zone created is 

IJ-ordered.

If you have data loaded into Tecplot 360 and you create a new frame, you can attach the 
existing dataset to the new frame by changing the plot type to match that of the existing 
dataset.
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Data Hierarchy

To specify the maximum I-index and J-index, use the Create Rectangular Zone dialog (accessed via 
Data>Create Zone>Rectangular). 

Create Circular Zone (2D Only)
Select the Create Circular Zone tool to add new 2D circular zones to the current Tecplot 360 dataset.

To create a circular zone:

1. Click once in the current data region to specify the center of the zone.
2. Drag until the zone has the desired radius. The new zone created is IJ-ordered.

To specify the maximum I-index and J-index, use the Create Circular Zone dialog (accessed via 
Data>Create Zone>Circular).

2 - 2.2   Status Line
The status line, running along the bottom of the Tecplot 360 window, gives “hover help”. When you move 
the pointer over a tool in the toolbar, a button on the Quick Edit dialog, or a menu item, a description of 
the control appears. It also provides a progress bar and information during long calculations.

2 - 2.3   Tecplot 360 Workspace
The workspace is the portion of your screen in which you create sketches and plots. Each sketch or plot is 
created within a subwindow called a frame. The current state of the workspace, including the sizing and 
positioning of frames, the location of the data files used by each frame, and all current attributes for all 
frames, makes up a layout. By default, the workspace displays a representation of the paper Tecplot 360 is 
set up to draw on, as well as a reference grid and rulers. The active frame in which you are currently 
working is on top. All modifications are made to the active frame. 

2 - 3   Data Hierarchy
Tecplot 360 structures data on two levels: datasets and zones. Datasets are contained within frames. Each 
dataset is composed of a zone or group of zones, and each zone contains a variable or group of variables. 
All zones in a dataset contain the same set of variables.

2 - 3.1   Frames
You can create multiple plots simultaneously in Tecplot 360 using subwindows called “frames”. By 
default, one frame is open when you launch Tecplot 360. You can add frames to the workspace using the 
Frame menu. Datasets can be unique to the frame or shared between frames. Linking data between frames 
allows you to generate unique plots of the same data. For more information on working with frames, 
please refer to Chapter 2: “Using the Workspace” in the User’s Manual.

The current frame must have a dataset attached to it in order for this tool to be active. 
(This option is only available in 2D Cartesian plots.)

The current frame must have a dataset attached to it in order for this tool to be active. 
(This option is only available in 2D Cartesian plots.)
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2 - 3.2   Datasets
A dataset is defined as “all of the data in a frame”. Starting with an empty frame, a dataset is created and 
assigned to the active frame when you read one or more data files into Tecplot 360, or when you create a 
zone within Tecplot 360. 

2 - 3.3   Zones
Zones are subsets of datasets. A dataset can be composed of a single zone or several zones. Zones are 
either defined in the data file or created directly in Tecplot 360. The number of zones in a concatenated 
dataset is the sum of the number of zones in each of the data files that are loaded. 

Typically, a data file is divided into zones based on its physical coordinates. For example, a dataset of an 
airplane may consist of a zone for each wing, each wheel, the nose, and so forth. Alternatively, zones may 
be defined based on material. For example, a dataset of a fluid tank may have a zone for the tank itself and 
additional zones for each fluid therein.

2 - 4   Data Structure
Tecplot 360 accommodates two different types of data: ordered and finite element. The data structure is 
defined within the data file. Each zone is composed of one data type.

2 - 4.1   Ordered Data
Ordered data is a set of points logically stored in a 1D, 2D, or 3D array, where I, J, and K are the index 
values within the array. The number of data points is the product of all of the dimensions within the array. 

• 1D array (I-ordered, J-ordered, or K-ordered) - A 1D array is a one-dimensional array of data 
points, where one dimension (I, J, or K) is greater than or equal to one, and the other 
dimensions are equal to one. In a one-dimensional array, the total number of data points is 
equal to the length of the single-ordered array. For example, an I-ordered dataset with I=5, 
J=K=1 has five data points.

• 2D array (IJ-ordered, JK-ordered, IK-ordered) - In a 2D array of data points, two of the three 
dimensions (I, J, or K) are greater than one, and the other dimension is equal to one. The 
number of data points in a 2D ordered dataset is the product of the all of the dimensions. For 
example, in an IJ-ordered dataset, the number of data points is equal to I x J (where K=1).

• 3D array (IJK-ordered) - In a 3D array of data points, all three of the dimensions (I, J, and K) 
are greater than one. The number of data points is the product of the I, J, and K dimensions.

2 - 4.2   Finite Element Data
While finite element data is usually associated with numerical analysis for modeling complex problems in 
3D structures (heat transfer, fluid dynamics, and electromagnetics), it also provides an effective approach 
for organizing data points in or around complex geometrical shapes. For example, you may not have the 
same number of data points on different lines, there may be holes in the middle of the dataset, or the data 
points may be irregularly (randomly) positioned. For such difficult cases, you may be able to organize 
your data as a patchwork of elements. Each element can be independent of the other elements, so you can 
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Data Structure

group your elements to fit complex boundaries and leave voids within sets of elements. The figure below 
shows how finite element data can be used to model a complex boundary.

Figure 2-2. This figure shows finite element data used to model a complex boundary. This plot file, 
feexchng.plt, is located in your Tecplot 360 distribution under the examples/2D subdirectory.

Finite element data defines a set of points (nodes) and the connected elements of these points. The 
variables may be defined either at the nodes or at the cell (element) center. Finite element data can be 
divided into three types:

• Line data is a set of line segments defining a 2D or 3D line. Unlike I-ordered data, a single 
finite element line zone may consist of multiple disconnected sections. The values of the 
variables at each data point (node) are entered in the data file similarly to I-ordered data, 
where the nodes are numbered with the I-index. This data is followed by another set of data 
defining connections between nodes. This second section is often referred to as the 
connectivity list. All elements are lines consisting of two nodes, specified in the connectivity 
list.

• Surface data is a set of triangular, quadrilateral, or polygonal elements defining a 2D field or a 
3D surface. When using polygonal elements, the number of sides may vary from element to 
element. In finite element surface data, you can choose (by zone) to arrange your data in three 
point (triangle), four point (quadrilateral), or variable-point (polygonal) elements. The number 
of points per node and their arrangement are determined by the element type of the zone. If a 
mixture of quadrilaterals and triangles is necessary, you may repeat a node in the quadrilateral 
element type to create a triangle, or you may use polygonal elements.

• Volume data is a set of tetrahedral, brick or polyhedral elements defining a 3D volume field. 
When using polyhedral elements, the number of sides may vary from element to element. 
Finite element volume cells may contain four points (tetrahedron), eight points (brick), or 
variable points (polyhedral). The figure below shows the arrangement of the nodes for 
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tetrahedral and brick elements. The connectivity arrangement for polyhedral data is governed 
by the method in which the polyhedral facemap data is supplied.

Figure 2-3. Connectivity arrangements for FE-volume datasets
In the brick format, points may be repeated to achieve 4, 5, 6, or 7 point elements. For example, 
a connectivity list of “n1 n1 n1 n1 n5 n6 n7 n8” (where n1 is repeated four times) results in a 
quadrilateral-based pyramid element.
 Section 4 - 5 “Finite Element Data” in the Data Format Guide provides detailed information 
about how to format your FE data in Tecplot’s data file format.

2 - 5   Creating Plots
The basic steps for creating a plot in Tecplot 360 are the following:

1. Define your dataset using one of the following methods: 
a. Using the “Load Data File(s)” command from the File menu to load any type of data 

file
b. Using the “Open Layout” command from the File menu to load linked layout or

layout package files 
c. Using any combination of the options in the Create Zone submenu of the Data menu

or the Insert menu to create your datasets directly within Tecplot 360
2. Choose the Plot Type (3D, 2D, XY line, Polar line, or Sketch) from the Sidebar.
3. Toggle-on any mapping or zone layers from the Sidebar (for example, contour zone layer or 

symbols mapping layer). Use the Details button to customize zone layers. 
4. OPTIONAL (3D only) - Toggle-on zone effects (translucency and lighting). 
5. OPTIONAL - Use the Zone Style or Mapping Style dialogs to opt zones in and out of plot 

layers or the entire plot. 
6. OPTIONAL (2D or 3D only) - Add derived objects (slices, streamtraces, or iso-surfaces). Use 

the Details button to customize any derived objects.

You are not limited to working with only one plot at a time in Tecplot 360. You can create multiple files at 
once using frames and frame linking.

Once you have loaded your data, you can use the options in the Plot menu (such as “Blanking” or “Axis 
Details”) to customize how your data is displayed. You can also use the options in the Data menu (such as 
“Specify Equations” or “Interpolation”) to alter the dataset.

2 - 6   Output Formats
Once you have completed your plot(s), you can use any of the following media to distribute or publish 
your plot(s) outside of Tecplot 360:

Tetrahedral connectivity arrangement Brick connectivity arrangement
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Output Formats

• Printing - Use the “Print” option from the File menu to print your plots.
• Exporting to an image file - Use the “Export” option from the File menu and select the desired 

image format in the Export dialog.
• Exporting to an animation file - Access this export option via any of the Animation dialogs by 

selecting “To File” in the Animate field, or by selecting a movie file format from the Export 
dialog (accessed via the File menu).

• Publishing - Use the “Publish” option from the File menu to save your plots in HTML format.
• Copying the plot to a clipboard (Windows and Macintosh operating systems only) - Use the 

“Copy Plot to Clipboard” option from the Edit menu to paste your plot into word processing 
software.
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3

External Flow Tutorial

3 - 1   Introduction
The following tutorial demonstrates how to display pressure on an airplane wing, and how to compare 
measured and simulated data on a two-dimensional projection plane. We will implement several Tecplot 
360 features to create this plot, including the PLOT3D loader, the Calculate Variables option, contour 
legends, a 2D projected plane, and a line legend. 

3 - 1.1   Background Information
In 1972, the ONERA Aerodynamics Department designed a swept, semi-span wing with no twist1. The 
wing was instrumented to be used as an experimental support for basic studies of 3D flows at high 
Reynolds numbers from low to transonic speeds (that is, local supersonic flow, shocks, and turbulent 
boundary layer separation). 

The simulated dataset is a PLOT3D file with freestream conditions M = 0.8395, Re = 11.72 x 106, Angle of 
Attack = 6 degrees, and angle of side-slip = 0.0 degrees. The measured dataset was obtained in the ONERA 
S2MA wind tunnel by Schmitt and Charpin at Mach numbers of 0.7, 0.84, 0.88, and 0.92 for angles of attack 
up to 6 degrees and a Reynolds number of approximately 12 x 106. The measured dataset is an ASCII file. 
The tutorial compares the datasets at M = 0.84 and y/b = 0.44 (where b is the wingspan).

3 - 1.2   Tutorial Summary
The tutorial should take approximately 30-40 minutes to complete. All supporting data files for this 
tutorial can be found in: $TEC_360_2013R1\tutorials\external_flow2

.

1.  Schmitt, V. and F. Charpin, "Pressure Distributions on the ONERA-M6-Wing at Transonic Mach Numbers," 
Experimental Data Base for Computer Program Assessment. Report of the Fluid Dynamics Panel Working 
Group 04, AGARD AR 138, May 1979.

2. $TEC_360_2013R1 is the installation directory for Tecplot 360. For Windows users, this is typically C:\Pro-
gram Files\Tecplot\Tec360 2013R1.
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3 - 2   Getting Started

Step 1  Load a Plot3D File (Including a Boundary File)
A. Choose “Load Data File(s)” from the File menu.

B. Choose “PLOT3D Loader” in the Select Import Format dialog.

C. In the Plot3D Loader dialog:

i.  Click the “Load Grid and Solution/Function File(s)” radio button.

ii. Select the Add Files button to the right of “Grid File(s)”.
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Getting Started

D. In the Read Grid File dialog, navigate to: $TEC_360_2013R1\tutorials\external_flow\data and 
select m6wing.xyz.

E. Click the Add to List button, then the Open Files button.

F. In the Plot3D Loader dialog, click the Browse button next to “Solution File(s)”.

G. In the Read Solution File dialog:

i.  Navigate to: $TEC_360_2013R1\tutorials\external_flow\data.

ii. Select m6wing.q.

iii. Click the Add To List button.

iv. Click the Open Files button.

H. Click OK after returning to the Plot3D Loader dialog.

You have now successfully loaded a PLOT3D data file into the Tecplot 360 workspace.

Step 2  Manipulate Layers
To quickly view a more pleasing image, remove the edge layer and display the contour layer on the plot. 

A. Toggle-off the “Edge” layer in the Sidebar. Toggle-off the “Shade” layer.

B. Toggle-on the “Contour” layer.

Tecplot 360 will automatically load the boundary file, m6wing.xyz.fvbnd, since its 
filename prefix (m6wing.xyz) matches the grid file, and the files are located in the same 
folder.

Any combination of layers can be viewed at the same time by turning them on and off in 
the Sidebar.
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The image will appear as follows: 

Step 3  Determine the Number of Zones and Variables
In Tecplot 360, the data can be subdivided into smaller regions called “zones”. The zones can be defined in 
the data file itself or manually created by going to Data>Create Zone. In this case, the zones were defined 
within the data file using the grid blocks established by the preprocessor. See also Section 2 - 3.3 “Zones”.

A. Go to Data>Data Set Info to explore the dialog.

In this dataset, there are six zones, each of which contain nine variables.
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Displaying a Contour Map of the Pressure Coefficient

B. Close the Data Set Information dialog.

3 - 3   Displaying a Contour Map of the Pressure Coefficient
In order to have a more useful visualization of the wing, we would like to use the Contour layer (which we 
toggled-on in Step 2) to view the pressure on the wing. In this case, the pressure data was not provided in 
the data file. However, Tecplot 360 can calculate the Pressure Coefficient for us using the helpful Calculate 
Variables feature!

The following steps teach the calculation of the Pressure Coefficient using Tecplot 360’s Calculate on 
Demand method. This method adds the variable to the dataset, but does not calculate the variable until it 
is needed, which can optimize operation speed when manipulating unsteady solutions. For more 
information about calculating on demand, see Section 22 - 6.2 “Calculate-on-demand Variables” in the 
User’s Manual.

Step 4  Calculate the Pressure Coefficient
A. Choose “Calculate Variables” from the Analyze menu.

B. In the Calculate dialog, click the Select button to choose the variable to calculate.

C. In the Select Function dialog, highlight “Pressure Coefficient” and click OK.
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D.  Click the Calculate button.

E. Click OK in the Information dialog.

F. Close the Calculate dialog.

G. Open the Contour Details dialog by either of the following methods.

i.  Clicking the Details button to right of “Contour” in the Sidebar

ii. Choosing “Contour/Multi-Coloring” in the Plot menu

H. In the Contour Details dialog, select the “Pressure Coefficient” as the contour variable.

3 - 4   Modifying the Contour Layer
Using the Contour and Multi-Coloring Details dialog (which we will refer to as the Contour Details 
dialog), you can customize contour levels, coloring, and more.

While calculating variables, you may use any units. However, you must be consistent 
within your variable set. For information on specifying variables’ units, see Section 22 - 6 
“Calculating Variables” in the User’s Manual.
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Modifying the Contour Layer

Step 5  Add a Contour Legend
A. Expand the Contour Details dialog by clicking the >> button.

B. Switch to the Legend page of the dialog.

C. Toggle-on “Show Contour Legend”.

Step 6  Modify the Contour Legend
A. With the Legend page of the Contour Details dialog still open, go to the Alignment region of 

the page and perform the following steps: 

i.  Toggle-off “Separate Color Bands” to remove the level lines from the legend.

ii. Change the Alignment to “Horizontal”.

iii. Reposition the legend to “10” for Y%.

B. In the Font region of the page, perform the following steps:
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i.  Click the Header Font button.

ii. In the Select Font dialog, change the header font size (Height) to “2%” and click OK to 
close the dialog.

iii. Click the Number Font button.

iv. Change the number font size to “1.5%” and click OK to close the dialog.

After completing this step, the Legend page of the Contour Details dialog will look as follows:
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Modifying the Contour Layer

The plot will look as follows:

Step 7  Add Contour Levels
Judging from the legend, the bulk of the data values are between 0.2 and -0.4. We would like to include 
more levels in that range to add definition to the plot. 

A. Switch to the Levels page of the Contour Details dialog.

B. Click the Add Levels button.

C. In the Enter Contour Level Range dialog, make the following changes:

i.  Click the “Min, Max, and Delta” radio button.

ii. Enter “-.15” in the Minimum Level field.
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iii. Enter “.15” in the Maximum Level field.

iv. Enter “.1” in the Delta field.

v. Click OK to apply the changes and close the dialog.

The Levels page will look as follows:

The plot containing a legend will look as follows:

Alternatively, you can add contour levels to your plot using the Add Contour Level  
tool, or using the Level To Add field on the Levels page and adding the following levels: 
“.15”, “-.15”, “-.5”, and “.5” (one at a time).
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Modifying the Contour Layer

Step 8  Modify the Contour Coloring
A. Switch to the Coloring page of the Contour Details dialog.

B. Click the “Continuous” radio button. 

C. Close the dialog.

The plot will look as follows:

You can adjust the color map and its control points by choosing “Color Map” from the 
Options menu.
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Step 9  Isolate the Wing Using the Sidebar
The list of zones represented by the current plot is also viewable by clicking the Zone Style button in the 
Sidebar. For the purposes of this tutorial, we wish to isolate Zones 5 and 6, the two zones that define the 
lower wing surface and the upper wing surface (“LowerWingSurface” and “UpperWingSurface”). 

A. Click the Zone Style button in the Sidebar. 

The Zone Style dialog allows you to customize display settings for each of the zones in your 
data file. In this case, we would like to limit the number of zones that are displayed. The first 
four columns of the Zone Style dialog are independent of the active page. Changes made in 
any of those columns will be applied to the entire plot.

B. In the Zone Style dialog, select Zones 1-4 by any of the following methods.

i.  Click on Zone 1, holding down the SHIFT key, and click on Zone 4.

ii. Click Zone 1 and drag to Zone 4.

iii. Select “Select Range” from the Zone Num button, and enter “1” in the Begin field and 
“4” in the End field of the Enter Range dialog.

iv. Choose “Select by Name” from the Zone Name button and enter “m6*” in the Enter 
Name dialog.

C. Click the Zone Show button and select “Deactivate”.

D. Close the dialog.

Alternatively, you can select Zones 5-6 and choose “Show Selected Only” from the Zone 
Show button.

The specific zone(s) of the data in which the wing is located is a characteristic of the 
data file. If you have a data file that is not arranged in this manner, you may find the 
following methods helpful:
- For many viscous CFD datasets, you can use Blanking to isolate regions where the 
absolute value of the velocity vector is zero.
- For preliminary visualization, you may be able to isolate the region you are looking for 
by toggling-on “Contour”.
Experiment with turning zones on and off and the options on the Surfaces page of the 
Zone Style dialog. In this particular example, if the boundary plot is not loaded, you 
could view the wing by selecting “J-Planes” from the Surfaces to Plot button on the 
Surfaces page of the Zone Style dialog.
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Creating a 2D Projection Plane

3 - 5   Creating a 2D Projection Plane
During the original ONERA wing study, the researchers compared simulation and measured data at y/b 
equal to 0.2, 0.44, 0.65, 0.8, 0.9, 0.95, and 0.99, where b is the wingspan. The following steps will recreate 
the comparison plots for y/b equal to 0.44.

Step 10  Extract a Slice
The y-axis from the data is equivalent to the z-axis in Tecplot 360. From the ONERA study, we know that b 
(wingspan) is 1.1963 m. As such, we would like to extract a slice at z=0.44*b, or z=0.526372.

A. Go to Data>Extract>Slice from Plane.

B. Make the following adjustments in the Extract Slice from Plane dialog:

i.  Choose the “Constant Z” radio button.

ii. Set “Position Z” equal to “0.526372”.

iii. Click the Extract button.

C. Click OK in the Information dialog.

D. Close the Extract Slice from Plane dialog.
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E. Go to the Zone Style dialog and verify that a new zone has been created. The new zone is 
named “SLC Z=0.526372”.

Step 11  Activate the Edge Layer for Zone 7 Only
We would like to show the slice in the Edge layer, and also have the slice as the only zone visible in the 
Edge layer. We can accomplish this by using the Zone Style dialog.

A. Toggle-on “Edge” in the Sidebar.

B. Reopen the Zone Style dialog, if you closed the dialog at the end of Step 10.

C. Switch to the Edge page of the Zone Style dialog and perform the following steps:

i.  Choose Zone 7 (the extracted slice). 
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Creating a 2D Projection Plane

ii. Select “Yes” from the Show Edges button.

iii. Select Zones 5-6 and select “No” from the Show Edges button.

iv. Close the Zone Style dialog.

The plot will look as follows:

When the wingspan is not recorded, you can approximate the wingspan using the Probe 
 tool and a distance equation.
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Step 12  Create a New Frame

A. Click the Create New Frame tool in the toolbar .

B. Drag in the workspace to create a new frame.

C. To associate the new frame with the existing dataset, go to the Sidebar and switch the Plot Type 
to “XY line”

Prior to this point, the newly created frame did not have an associated dataset. Switching the 
plot type for a new frame to a plot type that requires a dataset will automatically attach the 
dataset from another frame to the new frame. 

The plot will look as follows:

Step 13  Delete a Group of Mappings
The new plot currently displays an XY line plot of the first zone in the original dataset. Ultimately, we 
would like to plot Cp versus x/c.

A. With your new frame as the active frame, open the Mapping Style dialog by either:

i.  Clicking the Mapping Style button in the Sidebar

ii. Selecting Plot>Mapping Style

B. In the Mapping Style dialog, select Maps 1-8 by any of the following methods:

When working with multiple frames, click within a frame to make that the active frame. 
By default, the active frame displays with a thicker black border.
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Creating a 2D Projection Plane

i.  Click on Map 1, hold down the SHIFT key and click on Map 8

ii. Click on Map 1, and drag to Map 8

iii. Select “Select Range” from the Map Num button and use the Enter Range dialog to 
specify Maps 1-8

C. With Maps 1-8 highlighted, click the Delete Map button.

D. Click OK to confirm deletion of the eight zones.

Step 14  Activate the Mapping
A. With the Mapping Style dialog still open, the remaining mapping will be highlighted.

B. Select “Activate” from the Map Show button.

Step 15  Change the Zone Associated with the Mapping
A. In the Mapping Style dialog, click the Zone button.

B. Select “7: SLC Z=0.526372” from the Select Mapping Zones dialog.
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C. Click the OK button to close the Select Mapping Zone dialog. Close the Mapping Style dialog.

Step 16  Adjust the View
Still with the XY Line plot as the active frame, go to View>Fit to Full Size. The plot will look as 
follows:

3 - 6   Manipulating Data
The simulated data (Pressure Coefficient) is currently plotted against the x variable. The measured data 
that will be loaded in the next section uses x/c, where c is the chord length. In order to compare the 
datasets, we will create a new variable {x/c} that shifts the current x variable to 0 and scales the value by c.

Step 17  Determine the Max and Min Values of the X Variable
A. Go to Data>Data Set Info. 
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Manipulating Data

B.  Select “Zone 7” in the Zone(s) area of the Data Set Information dialog.

C. Make note of the Min & Max values listed in the Var Range - Selected Zone region of the 
dialog. We will use these values in the next step.

i.  Min = “0.3027”

ii. Max = “0.8212”

iii. Range = “0.5185” (not listed)

D. Close the dialog.

Step 18  Create a New Variable
A. Go to Data>Alter>Specify Equations.

B. Enter the following equation in the Equations(s) field of the Specify Equations dialog:
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{x/c} = ({x} - .3027)/.5185

C. Click the Compute button.

D. Click the OK button in the Information dialog.

E. Close the dialog.

Step 19  Change the X-Axis Variable
A. Open the Mapping Style dialog. The remaining mapping will be highlighted. 

B. Click the X-Axis Variable button on the Definitions page.

Dataset variables that are identified by name are denoted with curly braces, {}, in the 
Specify Equations dialog. New variables can be created simply by placing the new 
variable name within curly braces at the left-hand side of the equation. New variables 
must be applied to all zones.
In the above dialog, a new variable {x/c} was created using shifted and scaled values of 
the existing {x} variable.
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Manipulating Data

C. In the Select Variable dialog, select “x/c” from the menu.

D. Click OK to assign the variable and close the dialog.

E. Close the Mapping Style dialog. The plot will look as follows:

Step 20  Adjust the View
Go to View>Fit to Full Size. 
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The plot will look as follows:

3 - 7   Comparing Simulation Data with Measured Data
Step 21  Load the Measured Data File

A. Go to File>Load Data File. 

B. In the Select Import 
Format dialog, select the “Tecplot Data Loader”.

C. In the Load Data File Warning dialog, choose the “Add 
to the current data set” radio button and click the OK 
button.
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Comparing Simulation Data with Measured Data

D. In the Tecplot Data Loader dialog, navigate to: $TEC_360_2013R1\tutorials\external_flow\data 
and select “ONERA_CP_Test_Span0.44.dat”.

E. Click the Open button to load the file.

F. Click OK in the Warning dialog.

G. Go to the Vars page of the Tecplot Data Loader Options dialog.

Because the Pressure Coefficient has a different variable name in the experimental and 
measured datasets, we need to combine the two pressure variables.

i.  Choose the “Cp” variable in the left-hand column.

Variables listed on the left-hand side of the dialog are from the new data file. Variables 
listed on the right-hand side of the dialog are already in the dataset. If a variable has an 
‘*’ before its name, it is not present in all files.
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ii. Choose the “Pressure Coefficient” variable in the right-hand column.

iii. Click Combine from the center column.

iv. Click the OK button to apply your changes and close the dialog.

Step 22  Change the Variable Name
To simplify our axes labels, we will change the combined variable name.

A. Go to Data>Data Set Info.

B. Choose “Pressure Coefficient; Cp” in the Variable(s) region of the dialog.

The combined variable name will be “Pressure Coefficient;Cp”.
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Comparing Simulation Data with Measured Data

C. Enter “Cp” in the Variable Name field.

D. Close the dialog.

Step 23  Create New Mappings
We now need to add mappings of the measured dataset to our plot.

A. Open the Mapping Style dialog by either of the following options:

i.  Clicking the Mapping Style button in the Sidebar

ii. Choosing “Mapping Style” from the Plot menu

B. With the remaining mapping selected, click the Copy Map button twice.

The name change will apply to all zones.
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The Mapping Style dialog will look as follows:

Step 24  Rename the Mappings
To avoid confusion, we will rename all of the mappings in the plot.

A. Rename Map 1.

i.  Select Map 1.

ii. Choose “Edit Name” from the Map Name button.

iii. Enter “Simulated Data” in the Enter Mapping 
Name dialog.

iv. Click the OK button to apply the changes and 
close the dialog.

B. Rename Maps 2 & 3.

i.  Select Maps 2 & 3.

ii. Choose “Edit Name” from the Map Name button.
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Comparing Simulation Data with Measured Data

iii. Enter “Experimental Data” in the Enter Mapping Name dialog.

iv. Click the OK button to apply the changes and close the dialog.

Step 25  Change Zone Assignments
A. Map Num 2:

i.  In the Mapping Style dialog, choose “Map Num 2”.

ii. Click the Zone button.

iii. Choose “8: Lower Surface” in the Select Mapping Zone dialog.

iv. Click the OK button to apply the changes and close the dialog.

B. Map Num 3:

i.  In the Mapping Style dialog, choose “Map Num 3”.
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ii. Click the Zone button.

iii. Choose “9: Upper Surface” from the Select Mapping Zone dialog.

iv. Click the OK button to apply the changes and close the dialog.

Step 26  Activate the New Mappings
The new mappings have not appeared in the plot yet because they have not been activated.

A. Choose Maps 2 & 3 in the Mapping Style dialog.

B. Choose “Activate” from the Map Show button.
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Comparing Simulation Data with Measured Data

C. Go to View>Fit to Full Size. 

The plot will look as follows:

Step 27  Reverse the Y-Axes
In aerodynamics, it is customary to display the negative pressure increasing upwards, so we will reverse 
the vertical axis.

A. Go to Plot>Axis.

B. In the Axis Details dialog, click the Y1 button.
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C. On the Range page of the Axis Details dialog, toggle-on “Reverse Axis Direction”.

D. Close the Axis Details dialog. The plot will look as follows:

Step 28  Adjust the Mapping Style
The current style of the plot makes it difficult to discriminate between the simulated and measured data. 
As such, we will change the measured data to a symbol plot.

A. Toggle-on the “Symbols” layer in the Sidebar.

B. Open the Mapping Style dialog and go to the Lines page.

i.  Select Maps 2 & 3.
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Comparing Simulation Data with Measured Data

ii. Choose “No” from the Line Show button.

C. On the Symbols page of the Mapping Style dialog:

i.  Select Map 1.

ii. Choose “No” from the Symb Show button.

iii. Select Maps 2 & 3.

iv. Click the Outline Color button.

v. Select Red in the Select Color dialog. 

The Symbols page of the Mapping Style dialog will look as follows:
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The plot will look as follows:

Step 29  Add a Line Legend
A. Go to Plot>Line Legend.

B. In the Line Legend dialog, toggle-on “Show Line Legend”.

C. Accept the remaining default settings by closing the dialog. 
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Comparing Simulation Data with Measured Data

The final plot will look as follows:

Step 30  Export the Frames to a File
A. Go to File>Export.

B. In the Export dialog, choose “TIFF” from the Export Format menu.
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C. Accept the remaining default settings by clicking OK.

D. In the Select Export File dialog, navigate to the desired directory and specify a filename.

E. Click Save to export the image.

The image file is now ready to be imported into your presentation software.

3 - 8   Conclusion
This concludes the External Flow tutorial. Having completed this tutorial you should now be familiar with 
calculating and displaying contour variables such as pressure, as well as comparing measured and 
simulated data on a 2D projection plane. Refer to the User’s Manual for details regarding any of the 
features discussed in this tutorial.



63

4

Internal Flow Tutorial

4 - 1   Introduction
This tutorial demonstrates how to visualize the internal flow during the mixing process of soap or 
detergent. We will use several Tecplot 360 features to create our plot: 3D rotation, surface clipping, lighting 
effects, and streamtraces.

4 - 1.1   Background Information
There are four primary steps for manufacturing soap and detergent: mixing, heat transfer, drying, and 
separation. In both liquid and powder detergent manufacturing, dry and liquid ingredients are blended 
into a uniform mixture using static mixers called crutchers. Location of the dry and liquid inlets, internal 
temperature, and the velocity of the particles leaving the crutcher all play an important role in optimizing 
the manufacturing process.

This tutorial will model and examine some of these properties with a crutcher model.

4 - 1.2   Tutorial Summary
The tutorial takes an average of 20 minutes to complete. All supporting data files for this tutorial can be 
found in $TEC_360_2013R1\tutorials\internal_flow, where $TEC_360_2013R1 represents the default 
installation folder for Tecplot 360. For Windows users, Tecplot 360 installs by default to C:\Program 
Files\Tecplot\Tec360 2013R1.



64

4 - 2   Getting Started

Step 1  Load a Fluent File
Tecplot 360’s Fluent Data Loader allows you to load FLUENT® case .gas and/or data .dat files (as well as 
compressed case .cas.gz and/or compressed data .dat.gz files). For this tutorial, we will load one set of case 
and data files.

A. To start loading the files, choose “Load Data File(s)” in the File menu.

B. Select “Fluent Data Loader” in the Select Import Format dialog.

The  “Fluid Structure Interaction Tutorial” demonstrates loading multiple Fluent data 
files.
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C. In the Fluent Data Loader dialog, click the Add Files button.

D. In the Read Case and Data File dialog:

i.  Navigate to: $TEC_360_2013R1\tutorials\internal_flow\data.

ii.  Highlight both files (crutcher.dat and crutcher.cas) and click the Add To List button.
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iii. Click the Open Files button.

E. In the Fluent Data Loader dialog, accept the remaining default settings and click OK to close 
the dialog. 
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Adjusting the Plot View

The initial view of the plot will look as follows:

Step 2  Use the Sidebar to Deactivate Plot Layers
By default, the Edge layer is toggled-on when a data file is first loaded into Tecplot 360. In this case, the 
number of zones in the data make it difficult to discern the objects in the plot. 

4 - 3   Adjusting the Plot View
Step 3  Slice and Clip to View a Cross Section
We would like to view the mixer’s interior without eliminating any zones, which we can accomplish by 
using surface clipping.

To use surface clipping, we will insert a slice, adjust the slice position, and “clip off” the display of all 
zones in front of the slice.

While experimenting with the position of the slice, you can rotate the mixer by pressing 
the Ctrl key while dragging in the workspace with the right mouse button.

Toggle-off the Edge layer in the Sidebar.
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A. Click the Slice tool in the Sidebar to activate the Slice tool.  Click in the mixer to insert a 
slice.

B. Open the Slice Details dialog by clicking the Details button next to Slices in the Sidebar.

C. Choose Y-Planes from the Slice Location menu to orient the slice along the Y plane rather than 
the default X plane. Keep this dialog open.

D. You can adjust the position of the slice by either of two methods:
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Adjusting the Plot View

i.  Adjust Interactively To adjust the position of the slice interactively, with the 
Slice tool still selected, drag the slice. You can also drag the slider in the Slice 
Location region of the dialog, below the Show Primary Slice toggle.

ii. Edit Position To adjust the position by editing coordinates, in the Slice Details dialog 
(accessible by clicking the Details button next to Slices in the Sidebar, or by choosing 
“Slices” from the Plot menu), enter a coordinate value the first coordinate field in the 
dialog. A good value for this cut-away is 0.1.

E. To clip off the display in front of the slice, in the Slice Details dialog, select “Above Primary 
Slice” from the Clip menu. The primary slice display will automatically turn off, revealing the 
inside of the mixer.

F. Close the Slice Details dialog. Your plot will look similar to the following:

You can still change the position of the clipping slice by choosing the Slices tool and dragging 
the slice in your plot.
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Step 4  Adjust View Inside Mixer
Now we can see into the mixer. However, we would like to see complete views of internal structures, 
including the blades and the shaft. In this step we will adjust which zones obey the surface clipping.

A. First, the translucency effect is no longer needed, since the surface clipping allows an inside 
view of the mixer. Toggle-off the Translucency layer in the Sidebar.

A. Click the Zone Style button in the Sidebar to open the Zone Style dialog. Notice that each 
structural piece of the mixer is controlled by a zone.

B. On the Effects page of the Zone Style dialog, select Zones 9 and 10 (using the SHIFT key or by 
dragging with your pointer tool). Click the Clip By button, and select “None” from the menu.

C. Select Zones 21 and 22, and select “None” from the Clip By menu. This will prevent the blades 
from being clipped by the clipping slice.

Your plot will look similar to the following:

4 - 4   Using the Zone Style Dialog to Customize Settings
In the previous step of this tutorial, we had a glimpse of how to customize specific zones in the Zone Style 
dialog. Now we will begin to fine-tune the individual zone settings. Click the Zone Style button from the 
Sidebar to reopen the Zone Style dialog.

Step 5  Accentuate the Blade
A. On the Shade page of the Zone Style dialog, highlight Zones 21 & 22 (using the SHIFT key or 

by dragging with your pointer tool).
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Using the Zone Style Dialog to Customize Settings

B. Click the Shade Color button.

C. Choose Dark Red in the Select Color dialog. 

Your plot will look as follows:
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Step 6  Adjust the Lighting Effects
By default, Tecplot 360 sets the shading to be continuous (Gouraud), which provides a cleaner image. For 
better performance when working with slower processor speeds, set the shading to Paneled. The paneled 
shading option uses a single shading value for each cell.

To adjust the lighting effects:

A. Switch to the Effects page of the Zone Style dialog.

B. Click the Zone Num button and choose “Select All” from the menu.

C. Click the Lighting Effect button, and choose “Paneled” or “Gouraud” from the menu.

D. Close the Zone Style dialog.

Step 7  Change the Frame Background Color
In order to contrast the bright tones of the image, we would like to change the frame background color. 

A. Go to Frame>Edit Active Frame.

B. Toggle-on “Show Background” if it is toggled-off. 

Especially if you wish to export your plot, you will probably wish to retain the default 
Gouraud shading for better image quality.
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Using the Zone Style Dialog to Customize Settings

C. Click the Color box and choose Black from the color palette.

D. Click Yes in the confirmation box, and close the Edit Active Frame dialog.

The result will look as follows:

By clicking “yes” in the confirmation box when changing the background color of the 
frame to a dark color, you allow objects such as the 3D orientation axis to change from 
black to white. 



74

Step 8  Adjust the Lighting
We can also adjust the lighting, by using the Light Source dialog. Open this dialog by clicking the Details 
button next to Lighting in the Sidebar (or you can choose “Light Source” from the Plot menu)

Specular Highlights are toggled-on by default and can be adjusted in the Light Source dialog.

E. Close the Light Source dialog.

Step 9  Activate Streamtraces
We would like to visualize the internal flow of the mixer using streamtraces. You can access streamtrace 
controls and the Streamtrace Details dialog from the Sidebar (or by choosing “Streamtraces” in the Plot 
menu).

You can interactively move the light source position by dragging the circle within the 
Light Source Position region of the dialog.



75

Using the Zone Style Dialog to Customize Settings

A. Toggle-on “Streamtraces” in the Sidebar.

B. Accept the default vector variables in the Select Variables dialog by clicking OK.

Step 10  Position Streamtraces Using the Add Streamtraces Tool
Similarly to slices, streamtraces can be added interactively, using the Add Streamtraces  tool, or by 
using the Position page of the Streamtrace Details dialog (accessible by choosing “Streamtraces” in the 
Plot menu, or clicking the Details button in the Sidebar).

A. Click the Add Streamtraces  tool in the Sidebar.

B. Click or drag within your plot. This will add streamtraces to your plot.

Step 11  Position Streamtraces Using the Streamtrace Details Dialog
[OPTIONAL] To more closely match the internal flow layout included in your installation, place 
streamtraces precisely using the Streamtrace Details dialog.

A. Open the Streamtrace Details dialog by clicking the Details button to the right of Streamtraces 
in the Sidebar.

B. Specify the following settings:

After the vector variables have been defined, you can change them by going to Plot > 
Vector > Variables.

When the Add Streamtraces tool is selected, the cursor will change from a pointer to a 
crosshair (+).
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i.  Select the “Enter XYZ Positions” radio button.

ii. For the Streamtrace Start Position, set the following variable values:

•X = “- 0.103”
•Y = “0”
•Z = “0.23”

C. Click the Create Stream(s) button.

D. To contour the streamtraces according to the variable “Turbulent Kinetic Energy”, set the 
following:

•Switch to the Line page of the Streamtrace Details dialog, and choose “Multi 1” 
as the Line Color. 

•Also on the Line page, set the Line Thickness % to 0.3 for better visibility.
•Open the Contour...Details dialog by clicking the Details button next to the 

Contour toggle in the Sidebar, and choose “Turbulent Kinetic Energy” from the 
menu. Close this dialog.

E. Close the Streamtrace Details dialog.

Your final plot will look as follows:

Step 12  Copy Plot to Clipboard
Now that your plot is complete, you can copy it to the clipboard and paste it into other software   (such as 
into a PowerPoint project).

You can see that the clipping slice does not clip the added streamtraces. To instruct the 
streamtraces to obey the clipping slice(s), toggle-on “Obey Clipping Settings” on the 
Integration page of the Streamtrace Details dialog.
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Using the Zone Style Dialog to Customize Settings

A. Choose “Copy Plot to Clipboard” from the Edit menu.

B. In the Copy Plot to Clipboard dialog, choose “Active Frame” from the Region menu.

C. Choose the “Image (BMP)” radio button.
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D. Click OK. The plot can now be pasted into other software, such as Microsoft® Word®.

4 - 5   Conclusion
This concludes the Internal Flow tutorial. Having completed this tutorial, you should now be familiar with 
using the Tecplot 360 features of surface clipping, lighting effects, and streamtraces. Refer to the User’s 
Manual for details regarding any of the features discussed in this tutorial.
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5

Fluid Structure Interaction Tutorial

5 - 1   Introduction
This tutorial illustrates how to use Tecplot 360 to visualize a Fluid Structure Interaction (FSI). We will 
produce an animation that shows the movement of a nonlinear baffle as it is affected by fluid pressure. To 
create this plot, we will implement several Tecplot 360 features, including contours, color maps, 
streamtraces, and animation.

5 - 1.1   Background Information
The FSI used in this tutorial illustrates the transient deformation of a nonlinear baffle due to fluid flow 
within a duct. The baffle has a height of 0.1 meters and a thickness of 0.005 meters, and the duct is twice 
the height of the baffle. The fluid flow enters the duct from the left (inlet) and exits on the right (outlet) 
over time1. The baffle was modeled in Abaqus, and the fluid data was calculated using FLUENT.

5 - 1.2   Tutorial Summary 
The tutorial should take approximately 30-40 minutes to complete.

The supporting data files for this tutorial are available for download at: http://download.tecplot.com/360/
tutorials/fsi.zip. The remainder of the tutorial assumes that you have downloaded the zip file and placed 
its contents in: $TEC_360_2013R1\tutorials\fsi, where $TEC_360_2013R1 is your installation directory for 
Tecplot 360. For Windows users, this is typically C:\Program Files\Tecplot\Tec360 2013R1. 

We strongly recommend downloading the files to your computer’s local drive and not to a network drive. 
Depending on the speed of your network, accessing the files over the network could dramatically increase 
the loading time into Tecplot 360. 

5 - 2   Getting Started
This portion of the tutorial illustrates how to load an ABAQUS Output Database file and a set of FLUENT 
files. 

1. The Tecplot 360 FSI tutorial is based on a tutorial created by SIMULIA®. For more information on SIMULIA, 
visit www.simulia.com.

http://www.simulia.com/
http://download.tecplot.com/360/tutorials/fsi.zip
http://download.tecplot.com/360/tutorials/fsi.zip
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Step 1  Load an Abaqus Output Database File
The first step is to load an Abaqus file into Tecplot 360. 

For Windows Users
A. Go to File>Load Data File(s).

B. In the Select Import Format dialog, choose the “ABAQUS Output 
Database (FEA)” loader; then click OK. 

C. In the Load ABAQUS Output Database (FEA) File dialog:

i.  Click the Browse button to navigate to $TEC_360_2013R1\tutorials\fsi. 

ii. Choose the file named: abaqus.odb.

iii. Accept the default options and click OK to finish the loading process.

The Abaqus Output Database loader is available on Windows® platforms only. If you are 
on a Windows machine, follow the steps below. Otherwise, proceed to the Section  “Non-
Windows Platforms” on page 81 to load a Tecplot 360 .plt file of the same data. 
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Getting Started

D. The Select Initial Plot dialog will launch automatically. Make sure “2D Cartesian” is selected 
in the Initial Plot Type menu, and click OK.

E. The FEA Post-Processing dialog will be launched automatically1.

F. In this dialog:

i.  Choose “Von Mises Stress/Strain” in the Derive Variables region.

ii. Select “Stress” in the From: list. This will allow you to derive the Von Mises Stress from 
the Stress variable already included in the data file.

iii. Click the Add to Data Set button to add the Von Mises Stress to your data.

iv. Click Close to close the dialog.

v. Proceed to Step 2 Load a Set of Transient Fluent Data Files on page 83.

Non-Windows Platforms
For non-Windows users, we have provided a .plt file of the Abaqus data file. This file was created using 
the “Write Data File” option in the File menu2. 

1. You can access this dialog at any time via the Tools menu.
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A. Go to File>Load Data File(s).

B. In the Select Import Format dialog, select “Tecplot Data Loader” from the list, and click OK.

C. Choose “Add to current data set” in the Load Data File Warning dialog.

D. In the Tecplot Data Loader dialog, navigate to $TEC_360_2013R1\tutorials\fsi\data and choose 
the file named abaqus_data.plt. Click Open. 

E. In the Select Initial Plot dialog, be sure that “2D Cartesian” is selected and click OK.

2. The Von Mises Stress that was calculated in Step 1: For Windows Users, was calculated for this data prior to 
writing out the data file. 
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Getting Started

The initial plot will look as follows:

Step 2  Load a Set of Transient Fluent Data Files
Now that we have the Abaqus file loaded (which we will refer to as the “baffle”), we will append our 
dataset with a set of transient FLUENT data files. 

A. Go to File>Load Data File(s).

B. In the Select Import Format dialog, select “Fluent Data Loader” from the list and click OK to 
launch the Fluent Data Loader dialog. 
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C. In the Import Data File Warning dialog, choose the “Add to current data set” radio button. 
Then click OK. 

D. In the Fluent Data Loader dialog:

i.   Click the Add Files button. 

E. In the Read Case and Data File dialog:

i.  Navigate to $TEC_360_2013R1\tutorials\fsi\data\f.

ii. Select all available files (by using the SHIFT key or pressing CTRL-A). The FLUENT data 
consists of 150 time steps with one case (.cas) file and one data (.dat) file for each time step.

iii. Click the Add To List/Add button (Windows/UNIX).

On certain machines, the animation process may dramatically slow if all the data files 
are loaded. To avoid a lengthy animation series, we recommend loading a subset of the 
time steps using the Remove button.
Be sure that you remove both the .cas file and the .dat file for any time step that you 
choose to omit.
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Getting Started

iv. Click the Open Files/OK button (Windows/UNIX). 

F. In the Fluent Data Loader dialog:

i.  Select the “Load Cells Only” radio button.

ii.  Click OK in the Fluent Data Loader dialog to finish the loading process. Depending on 
the number of time steps you chose to load, it may take a few minutes to load all the data. 

Step 3  Modify the Plot View
Now we will modify the plot view to better see the “water” zone by turning on “Mesh” and changing the 
zone color.
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A. Toggle-on “Mesh” in the Sidebar, and then click the Zone Style button to launch the Zone Style 
dialog. (The Zone Style dialog can also be launched at any time by double-clicking directly on 
the plot.)

B. To better differentiate the zones, choose the baffle (Step 1 Incr 1) and choose “No” from the 
Mesh Show button.

C. Next we will change the “water” zone color by doing the following.

i.  Click on the “water” zone to select it in the Zone Style dialog.

ii. Click the Mesh Color button on the Mesh page of the Zone Style Dialog.

iii. Select Blue from the Select Color dialog.

An asterisk (*) next to a “Zone Num” or “Zone Name” indicates that the zone is a 
transient zone. The zone number is linked to the active time step. In this case, Zone 
Name describes the object. Press the Play button in the Sidebar and watch the zone 
numbers change with the time step. Refer to Section 7 - 1 “Field Plot Modification - Zone 
Style Dialog” in the User’s Manual for more information about transient zones.
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Adjusting the View

D. Click Close.

E. The plot will look as follows:

5 - 3   Adjusting the View
Notice that the FLUENT data surrounds the baffle, but that only one side is visible. Even though the baffle 
deforms to the right, we would like to see all the surrounding fluid flow. To accomplish this, we will adjust 
the view. 

Step 4  Change the View Setting
Choose View>Fit to Full Size to fit the plot to the frame.

Tecplot 360 provides several methods of adjusting your current view. Experiment with the options under 
the View menu to see how you can change the plot view.
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The plot will look as follows:

Step 5  Modify the Axis
We have modified the view of the plot to fit the screen, but to make the baffle more visible, we will zoom 
in on the X-axis. 

A. Double-click on the X-axis to launch the Axis Details dialog1. 

B. In the Axis Details dialog, click the X button to adjust the range for the X-axis.

C. On the Range page of the Axis Details dialog:

i.  Enter “-0.15” for the Min.

ii. Enter “0.15” for the Max.

iii. Click Close.

1. The Axis Details dialog can also be accessed via the Plot menu.
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Working with Contour Groups

The modified plot will look as follows: 

5 - 4   Working with Contour Groups
Now that the data is loaded, we would like to examine the effect of the pressure in the fluid body 
(FLUENT data) on the stress component of the baffle (Abaqus/Tecplot 360 data). To achieve this, we will 
create a contour plot and animate it. Displaying contours will give us a visual representation of the stress 
and pressure variables and how they interact with each other. 

Step 6  Display Contours
We will now activate the contour layer.

A. Toggle-off “Mesh” and “Edge” in the Sidebar. Turning off the Mesh and Edge layers will 
improve visibility of the Contour layer.

B. Toggle-on “Contour”.
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Your plot will look as follows:

Step 7  Set the Contour Variable for Contour Group 1
Because we would like to create a contour plot of two separate variables simultaneously, we need to work 
with contour groups. A contour group is used to link a set of contour parameters (for example, the contour 
variable and the contour levels) to one another. Contour groups allow us to apply different levels, values, 
and colors to specific groups of data. We can also link a color map to a contour group and customize the 
color map attributes to make them easy to recognize.

The first contour group we will create will be used to illustrate the pressure in the fluid body. 

Open the Contour Details dialog by clicking the Details button to the right of “Contour” in the Sidebar.

In the Contour Details dialog, click the 1 button to set the first contour group. Choose “Pressure” from the 
menu.

Step 8  Modify the Contour Levels for Contour Group 1
A. Expand the Contour Details dialog by clicking the >> button. This will fully open the Contour 

Details dialog, so we can work with the other options in the dialog.
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Working with Contour Groups

B. To modify contour levels, switch to the Levels page of the dialog.

On the Levels page of the Contour Details dialog, a list of the current contour levels is 
displayed in the Levels region. In addition, the minimum and maximum values of the Contour 
Variable are displayed on the right-hand side of the page. We will use those values to add two 
more contour levels.

There are several methods for adding and deleting contour levels. In this tutorial, we will 
demonstrate using the << Add Level button. Alternatively, you may use the Reset Levels, New 
Levels, or Add Levels buttons located at the top of the page.

C. In the “Level To Add” field:

i.   Enter: “-7775”, and click the << Add Level button. 

ii. Enter: “9200”, and click the << Add Level button.
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The new levels will be listed in the Levels region:

Step 9  Modify the Color Map for Contour Group 1
Because we are using two contour variables simultaneously, we would like to alter the coloring of each 
map to ensure the different contour groups are easily distinguishable. For this tutorial, we will use a 
GrayScale color map for Contour Group 1 and a Rainbow color map for Contour Group 2.

We will start with the pressure variable.

A. With the 1 button selected on the Contour Details dialog, switch to the Coloring page.

B. Click the Details button next to “Use Color Map Group” to open the Color Map dialog1. 

C. Tecplot 360 allows you to work with up to eight different color maps. By default, the maps are 
linked together (so that changing one color map changes the other color maps). 

In the Color Map dialog:

1. The Color Map dialog can also be launched via the Options menu.
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Working with Contour Groups

i.   Toggle-off “Link All Color Maps Together” to allow you to modify the color 
maps separately. 

Unlinking color maps also results in separate color maps being assigned to each of the contour 
groups. Color Map 1 is assigned to Contour Group 1, Color Map 2 is assigned to Contour 
Group 2, and so on. 

ii. Choose “GrayScale” from the Base Color Map menu.

D. Click Close.
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E. On the Coloring page of the Contour Details dialog, make sure that “Banded” is selected for 
the “Color Distribution Method”. This will allow you to easily identify the different contour 
levels on the plot. 

The plot will look as follows:

Step 10  Set the Contour Variable for Contour Group 2
We will now set up the second contour group (Contour Group 2) to illustrate the Von Mises Stress on the 
baffle. 

A. In the Contour Details dialog, click the 2 button to switch to Contour Group 2.
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Working with Contour Groups

B.  Choose “Von Mises Stress” from the menu.

Step 11  Modify the Color Map for Contour Group 2
A. With the 2 button selected, switch to the Coloring page of Contour Details dialog.

B. On the Coloring page of the dialog, Color Map “Large Rainbow” (Lg Rainbow) will 
automatically be set to the second color map. 

C. In the Contour Details dialog, choose the “Continuous” radio button. This will create a 
continuous color map between each contour level. 

D. In the “Contour Values at Color Map Endpoints” region:

i.  Enter “-250000” for Min.
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ii. Enter “250000” for Max.

E. Click Close.

Step 12  Change the Contour Group Assigned to a Zone 
By default, all zones are using Contour Group 1. This means we do not currently see Contour Group 2 on 
our plot. We will use the Zone Style dialog to assign Contour Group 2 to the baffle (Abaqus zone).

A. Launch the Zone Style dialog by clicking the Zone Style button in the Sidebar or by double-
clicking on your plot.

You may see Min and Max values at zero. This will occur if the Von Mises Stress is not 
defined at the current time step. The Contour Values will automatically adjust with the 
time step.
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Working with Contour Groups

B. Switch to the Contour page of the dialog.

On the Contour page, you can see a list of all of the active zones for this time step. The first 
zone, Step 1 Incr 1, is the baffle (Abaqus data). The remaining zone is the fluid body (FLUENT 
data). 

i.  Choose the baffle (Step 1 Incr 1).

ii. Select “C2: Von Mises Stress” from the Flood By button.

C. Click Close. The plot will look as follows:
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5 - 5   Customizing Contour Legends
Contour legends are used as a key to define the numerical value of the variable tied to each color in the 
plot. The attributes of the legend of each contour group can be specified within the Contour Details 
dialog. 

Step 13  Add Contour Legends
Now that we have defined our contour groups, we will add contour legends to the plot. One legend will 
be for the pressure variable and the other will be for Von Mises Stress. 

A. Launch the Contour Details dialog by clicking the Details button next to “Contour” in the 
Sidebar.

B. Click the 1 button in the Contour Details dialog to begin making changes for the first contour 
group.

C. Switch to the Legend page of the dialog.

D. On the Legend page, toggle-on “Show Contour Legend”. 
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Customizing Contour Legends

A contour legend will appear on the plot:

E. Choose the 2 contour group to add a legend for the second contour group, Von Mises Stress. 
On the Legend page, toggle-on “Show Contour Legend”. 
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The plot will look as follows:

Step 14  Modify the Contour Legends
As you can see, the contour legends overlap one another. We will modify their size, placement, and 
appearance so that they are easier to read. As you work your way through the following steps, note   how 
the legends change.

A. Choose 1 in the Contour Details dialog, and set the following:

i.  Toggle-off “Separate Color Bands” to remove the level lines from the legend.

ii. Change the Alignment to “Horizontal”.

iii. Change the Y% to “90”. This places the top left-hand corner of the contour legend up 
90% of the frame’s height (in relation to the bottom left-hand corner of the frame). 
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Customizing Contour Legends

iv. Using the arrows in the Font region, change both the Header Font and the Number Font 
to “1.5%”.

v. Toggle-on “Resize Automatically” to fit the legend to the plot.

The plot will look as follows:

B. Repeat Step i and Step ii in Step A from above for 2 (that is, toggle-off “Separate Colors Band” 
and set the Alignment to “Horizontal”). 

C. We will leave Y% at its default of “80” so that the legend for Contour Group 2 will sit below 
Contour Group 1.

D. Toggle-off “Resize Automatically” and enter “3” into Level Skip to display only every third 
contour level in the legend, compressing it. 
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E. Using the arrows in the Font region, change both the Header Font and the Number Font to 
“1.5%”.

F. Click Close. The plot will look as follows:

5 - 6   Using Streamtraces
Streamtraces allow you to better visualize how the fluid pressure and the baffle affect one another. There 
are two main types of streamtraces: surface line streamtraces and volume streamtraces. Volume 
streamtraces are created in 3D volume zones, while surface line streamtraces are used on 3D or 2D 
surfaces (such as we have for our plot). For more information about streamtraces, see Chapter 15: 
“Streamtraces” in the User’s Manual. 

Step 15  Display Streamtraces
We will now add streamtraces to our plot. 

A. Toggle-on “Streamtraces” in the Sidebar. This will allow you to include streamtraces in your 
plot.

You can turn off “Streamtraces” to hide streamtraces from your plot. Turn on the 
Streamtraces control in the sidebar to add your previously created streamtraces back 
into your plot.
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Using Streamtraces

B. The Select Variables dialog will be launched automatically. The Select Variables dialog allows 
you to specify the vector variables for your streamtraces. Accept the defaults by clicking OK. 

C. Click the Details button next to “Streamtraces” in the Sidebar.

D. On the Position page of the Streamtrace Details dialog, change Streamtrace per Rake to “5”. 
This will allow you to draw individual streamtraces on the plot by creating a rake.

E. Click Close.

F. Click the Add Streamtrace button to the right of “Streamtraces” in the 
Sidebar1.

1. Double-clicking this tool will also bring up the Streamtrace Details dialog.
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G. On the plot, draw a rake of streamtraces parallel with the X-axis by dragging the mouse 
vertically down the plot. 

Your plot will look similar to the following:

H. You may animate the plot by clicking the Play  button in the Sidebar.

Step 16  Modify Streamtraces
We will now modify the appearance of the streamtraces using the Streamtrace Details dialog.

A. Open the Streamtrace Details dialog by clicking the Details button to the right of 
“Streamtraces” in the Sidebar. 

The first pass through the animation will take a few minutes because the streamtraces 
are calculated for each time step. Subsequent passes will be faster because the 
information has already been calculated. 
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Using Streamtraces

B. Go to the Line page in the Streamtrace Details dialog.

C. Toggle-off “Show Arrowheads on Lines”. The arrows will disappear, leaving only lines on 
your plot.

D. Click the button next to Line Color.

E. In the Select Color dialog, choose Blue. 

F. In the Streamtrace Details dialog, change the Line Thickness (%) to “0.4”.

G. Click Close.
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The plot will look as follows (when reset):

5 - 7   Animating Your Plot, Displaying Result in PowerPoint
Now that we have set up our plot, we are ready to animate it. Tecplot 360 offers several forms of 
animation, including: time steps, zones, and streamtraces. In this example, we will animate the data over 
time. The animation will illustrate the deformation of the baffle due to the changes in the surrounding 
fluid pressure. 

Step 17  Animate on the Screen
You can animate the plot to run through all the time steps or one at a time by:

• Clicking the Play  button in the Time Region of the Sidebar to animate through all the time 
steps.

• Clicking the + or - buttons to move through the time steps individually. 

Step 18  Export Your Animation to a File
You can export an animation to a file for use in Microsoft PowerPoint® presentations or websites. 

A. Launch the Time Details dialog by selecting the Details button to the right of Time in the 
Sidebar.

The full animation could take up to five minutes, depending on your machine and RAM. 
To pause the animation, click the Pause button. (The Play button becomes the Pause 
button once the animation has started.)
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Animating Your Plot, Displaying Result in PowerPoint

B. On the Animate page of the Time Details dialog, choose “To File” from the Destination menu.

C. Choose AVI from the File Format menu, and click the Generate Animation File button.

D. The Export dialog will launch automatically: 

i.  Toggle-on “Antialiasing”.

Choosing “Antialiasing” will improve the appearance of text in the final output. It is also 
important to note that when using the “Use width of image on screen” option, the size of 
the frame window at the time of export will prescribe the video dimensions. 
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ii. Set “Supersample Factor” to “3”.

iii. Choose one of the following AVI Compression options:

•Color Preserving - This compression option optimizes the color quality of your 
output.

•Line Preserving - This compression option optimizes the quality of lines in your 
output. 

•Lossless Uncompressed - This compression option gives the highest picture 
quality and preserves complete 24-bit pixel information. Note that this option 
also creates the largest file size.

iv. Accept the other default settings by clicking OK.
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Animating Your Plot, Displaying Result in PowerPoint

E.  In the Select Movie File dialog, navigate to the desired directory and click Save to save the file 
as fsi.avi. 

Step 19  Insert a Tecplot 360 AVI Animation into PowerPoint
AVI movies can be inserted directly into PowerPoint. We will now go through the steps involved in 
inserting an exported Tecplot 360 AVI animation file into PowerPoint.

A. Launch PowerPoint, and choose a slide layout of your choosing.

B. PowerPoint Version 2007 - Go to Insert>Movie>Movie From File to launch the Insert Movie 
dialog.

Tecplot 360 exports the data images to the file so that it may be viewed via another 
program. This process may take a few moments.
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PowerPoint Version 2003 or Older - Go to Insert>Movies and Sounds>Movie from File to 
launch the Insert Movie dialog. 

C. Choose your AVI file in the Insert Movie dialog. 

D. Choose whether you would like your movie to start automatically in your slide show, or by a 
mouse click. 
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Conclusion

Once the slide show has played, the animation will show on the slide workspace. 

5 - 8   Conclusion
This concludes the FSI tutorial. Having completed this tutorial, you should now be familiar with contour 
groups, color maps, streamtraces, and animation. Refer to the User’s Manual for details regarding any of 
the features discussed in the tutorial.
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