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Introduction 

This Quick Start Guide is designed to get you started using Vector NTI Advance™ 11. It provides 
brief descriptions of the Vector NTI Advance™ 11 graphical user interface, including Vector NTI 
Explorer and the Molecule Viewer, and step-by-step instructions for using the most common 
features and functions of the software. The topics covered include locating the desired tools, 
displaying molecules, designing PCR primers, cloning two fragments, gene synthesis, aligning 
molecules, performing a restriction analysis, and assembling contigs. 

This guide assumes that you have a working knowledge of basic Microsoft® Windows® and Mac OS® 
features and functions (how to open and save files, how to use your mouse, and so on) and that 
Vector NTI Advance™ 11 is installed on your computer. 
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Opening Vector NTI Advance™ 11 

The QuickStart Page is a single page that consolidates most commonly used modules, tools, and 
utilities that Vector NTI Advance provides.  

To launch the QuickStart Page, select Start > All Programs > Invitrogen > Vector NTI Advance 11 
> Quick Start. 

 
Figure 1. QuickStart Page 

You can configure the software to open both the Molecule Viewer and Vector NTI Explorer when 
you select Vector NTI from the Start menu. 

1. In the Molecule Viewer window, go to the Edit menu and select Options.  
2. In the General tab of the dialog, select the Open Local Explorer At Startup checkbox.  

3. Click OK to make the change. 
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Local Database 
Vector NTI Explorer is the main tool for accessing the information in your local Vector NTI 
Advance™ database. Using the Explorer, you can import, open, export, and organize molecules and 
other database items, and launch other Vector NTI Advance™ modules (Figure 2). 

To launch Vector NTI Explorer: 

• On QuickStart Page, click on Local Database. 

• In the Molecule Viewer, click on the Local Database icon ( ). 

• From the Windows® Start menu, select Programs | Invitrogen | Vector NTI Advance 11 | 
Vector NTI Explorer. 

• The local database in Vector NTI Advance™ contains records for different types of 
molecular biology objects. Each database record includes all the information for that 
object (e.g., a DNA molecule record includes the DNA sequence, defined features of the 
molecule, and other information). Objects in the database can include molecules, 
analysis results, BLAST search results, citations, and other types of information. 

Import/create molecules       Display/analyze molecules 

Import analysis results       Export molecules 

Import BLAST results       Launch tools 

  
Figure 2. Vector NTI Explorer (Local Database) window. 

Database objects in Vector NTI Advance™ are categorized by type (DNA molecules, protein molecules, 
and so on). Some molecules are installed with the software. When you first open the software, DNA/RNA 
Molecules is the selected object type. Click on the tab in the lower left corner of the Vector NTI Explorer 
to select from the other available database objects.  

To open an object from the local database, double-click on the object name in the right-hand pane of the 
Explorer. Depending on the object type, information about that object may be displayed in a dialog box, 
or the object may be loaded into a viewer. For example, DNA, RNA, and protein molecules are displayed 
in the Molecule Viewer. 

 

When you install Vector NTI Advance™, the default local database is created in a 
folder called VNTI Database in the root directory of your computer (e.g., C:\VNTI 
Database). 

 

List of 
database 
records

Database 
object type 
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Database Backup/Restore 

It is strongly recommended that the local database be backed up routinely. You may launch the Database 
Backup manually, or use the Database Backup Reminder to trigger the task automatically as configured 
(Figure 3).  

To manually perform Database Backup:  

• From the Vector NTI Explorer menu, select Database | Backup Database Now. 

To configure the Database Backup Reminder: 

• From the Vector NTI Explorer menu, select Database | Database Backup Reminder. 

• To set a specific date or interval (e.g., backup every 15 days), click on Set Reminder. 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3. Database Backup 

To restore a database:  

• From Vector NTI Explorer menu, select Database | Database Restore. 

 

 

 

 

 

 

 

Figure 4. Database Restore 
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Molecule Viewer 

The Molecule Viewer displays information about DNA, RNA, and protein molecules. To launch the 
Molecule Viewer: 

• Click on Molecule Viewer on the QuickStart page, or 

• From the Windows® Start menu, select Programs | Invitrogen | Vector NTI Advance 11 | 
Vector NTI, or 

• Double-click on a molecule name in the Vector NTI Explorer. 

To open a molecule from within the Molecule Viewer, click on the Open button ( ) on the main 
toolbar and select the molecule name from the dialog box. 

The molecule will be loaded into the Molecule Viewer. 

 
Figure 5. Molecule Viewer window for a DNA molecule. 

The Molecule Viewer window has different panes for displaying different types of information about 
the molecule, as shown in Figure 5. Click inside a pane to make it the active pane. The available tools 
and right-click menu options will change depending on which pane is active. 

Use tools on the dropdown menus and toolbars to add information about the molecule and perform 
various analysis functions, as described in the step-by-step instructions on the following pages. 

Multiple molecules can be displayed in separate windows of the Molecule Viewer.  

Sequence 
Pane 

Graphics 
Pane 

Text Pane 
(info about 
features, 
restriction 
sites, etc.) 

Pane-specific 
tools 
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Selecting and Editing Molecule Sequences 

In the Molecule Viewer, you can select part of a molecule sequence in several different ways: 

• Hold down the mouse button and drag the cursor across the sequence in the Sequence 
Pane or Graphics Pane (Figure 6). 

• Go to the Edit menu, select Set Selection, and enter the sequence base-pair range in 
the dialog box. 

• Click on a defined feature in the Graphics Pane. 

• Click on a defined feature in the Text Pane, and click on Find ( ) on the main toolbar. 

The selected sequence will appear highlighted in both the Graphics Pane and the Sequence Pane. 

  
 

Figure 6. Selecting a DNA sequence by (1) dragging in Graphics Pane or  
(2) dragging in Sequence Pane. 

 

To copy a molecule sequence: 

1. Select it as described above. 

2. To copy it to the Windows® clipboard, use the CTRL + C keyboard command, or 

To copy the sequence as a text file, go to the Edit menu and select Copy to > File. You will be 
prompted to select a format and enter a name for the file. 

 

To delete a molecule sequence: 

1. Select it as described above. 

2. Click on the DELETE key on your keyboard. 

 

To paste a molecule sequence: 

1. With the sequence in text format on the Windows® clipboard, click on the point in the Sequence 
Pane where you want to add the insert. 

2. Click on CTRL + V on your keyboard. 

3. The Insert Sequence dialog will open, displaying the sequence to be inserted. 

4. Click on OK to complete the insertion. 

 

 

(1) (2) 
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Designing PCR Primers from a Sequence 

Vector NTI Advance™ 11 can analyze a selected sequence and design PCR primers for it, based on 
parameters such as desired melting temperature (Tm), GC content, and amplicon length. 

With a DNA or RNA molecule open in the Molecule Viewer: 

1. Select the part of the sequence for which you want to design primers, as described on the 
previous page. 

2. Go to the Primer Design menu. 

3. Select Find PCR Primers to find primers within the sequence (Figure 7), or 

 Select Amplify Selection to find primers in the regions before and after the sequence (other 
amplification selections are available; see the Vector NTI Advance™ 11 User’s Manual for 
more information). 

4. In the dialog box, select the desired primer-design parameters. Note that most of these 
parameters have default values based on typical PCR primers. 

5. Click on OK. The results will appear under PCR Analysis in the Text Pane. 

 
 

 

 

 

 

 

 

 

 

 

Figure 7. Designing PCR primers within a selected region. 

 

To save the PCR analysis results as a separate object in the database: 

1. Right-click on the PCR Analysis folder in the Text Pane. 

2. Select Save as Analysis Result. 

The saved results will be listed under the Analysis Results object type in the Vector NTI Explorer 
(Figure 8). 

 
 

Figure 8. PCR analysis results listed in Vector NTI Explorer. 

PCR analysis 
results 
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Clone Two Fragments with Clone2Seq 

Clone2Seq offers the easiest way to clone two fragments. To use Clone2Seq: 

1. In the Molecule Viewer, go to Cloning | Clone2Seq, or click on the Clone2Seq button ( ) on 
the main toolbar. 

2. To load Insert and/or Vector, click on Load Molecule. 

3. Select fragment by Restriction Site by clicking on Site #1, shift-clicking on Site #2 on each 
molecule. 

4. Make sure the left terminus of the first fragment is compatible with the right terminus of the 
second fragment, and the right terminus of the first fragment is compatible with the left terminus 
of the second fragment. 

5. Add selected fragments by clicking on Add Fragment. 

6. Click on Clone. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 9. Clone 2 fragments with Clone2Seq. 
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In-Silico Gene Synthesis with ReGENerator 
ReGENerator offers the fastest way to build your desired DNA from the ground up, optimized for 
expression, with any amino acid mutation you want, and with the flanking sequences you need for 
expression, purification, or detection. Then, right from your desktop, send your DNA sequence to our 
partner Blue Heron® Bio’s secure server for rapid synthesis. 

To design the DNA from an amino acid sequence: 

1. With the source protein molecule loaded in the Molecule Viewer, select Cloning | ReGENerator 

or click on the ( ) icon on the main toolbar.  

2. Mutate the protein molecule by inserting, deleting, or replacing single or multiple amino acids. 

3. Select the desired Codon Usage Table for the organism. 

4. Select the desired Genetic Code. 

5. You may also add attachment sequences to the terminus of the DNA: 

• Choose terminus (5’ or 3’) 

• Choose Attachment Type 

6. To view the back-translated DNA, click View Molecule. 

7. To send the DNA sequence for synthesis at Blue Heron®, click Send for Synthesis. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 10. In-Silico Gene Synthesis with ReGENerator. 
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Identifying Open Reading Frames (ORFs) 
Vector NTI Advance™ 11 can analyze a DNA/RNA molecule and identify the open reading frames 
(ORFs) in it, based on start and stop codons within the molecule. 

 With a DNA or RNA molecule open in the Molecule Viewer: 

1. Go to the Analyses menu and select ORF (Figure 11). 

2. In the dialog box, select the parameters for identifying and marking ORFs in the molecule. 

3.  When you click on OK, the sequences identified as ORFs will be marked with directional 
arrows in the Graphics Pane and Sequence Pane, and the ORFs will be listed in the Text Pane. 

4. To identify an ORF in the different panes: 

• Click on a directional ORF arrow in the Graphics Pane to highlight its sequence in the 
Sequence Pane, or 

• Open a folder under Open Reading Frames in the Text Pane, right-click on the ORF 
name, and select Find ORF to highlight it in the Graphics and Sequence Panes. 

5. To save an ORF to the feature map of the molecule, right-click on the ORF arrow in the 
Graphics Pane or the ORF folder in the Text Pane, and select Add ORF to FMap. 

 

 

 

 

 

 

 

 

 

Figure 11. Identifying ORFs 

ORF marked in Graphic pane 
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Creating a Restriction Map 

Vector NTI Advance™ 11 can analyze a DNA/RNA molecule and identify the restriction sites in it, 
using the software’s comprehensive library of restriction enzymes. 

With a DNA or RNA molecule open in the Molecule Viewer: 

1. Go to the Analyses menu and select Restriction Analyses > Restriction Sites (Figure 12). 

2. In the Restriction Map Setup dialog, review the list of restriction enzymes in the Use 
Enzymes: field. These are the enzymes that will be used to identify the restriction sites. Click on 
the < Add, > Remove, and >> Remove All buttons to add and remove enzymes from the list. 

 Note: If you click on < Add, the Choose Database Enzymes dialog will open, listing all the enzymes in 
the database. Select enzymes in the list by clicking on them or click on the Select All button, and then 
click on the OK button to add them to the Restriction Map Setup dialog. 

3. Click on OK in the Restriction Map Setup dialog. The restriction enzymes and their binding 
sites will be shown in the Graphics Pane and Sequence Pane. The specific cut site of each 
enzyme will be listed under Restriction/Methylation Map in the Text Pane. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

      

Figure 12. Creating a Restriction Map. 

Rest. site shown in Sequence Pane 

Rest. site shown in 
Graphics Pane 
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Aligning Molecules 

Vector NTI Advance™ 11 can align the sequences of two or more DNA/RNA molecules. The tool for 
doing this is called AlignX. This tool can be launched from either the Molecule Viewer or Vector NTI 
Explorer. 

To align sequences using Vector NTI Explorer: 

1. In the Explorer, select the molecules that you want to align using SHIFT + CLICK or CTRL + 
CLICK key commands (Figure 13). 

2. Go the Align menu and select AlignX—Align Selected Molecules. The AlignX Window will 
open, with the molecules you selected listed in the upper left Text Pane. 

3. In the AlignX Window, use SHIFT + CLICK or CTRL + CLICK key commands to select two or more 
molecules in the Text Pane list to align. 

4. To begin the alignment, click on the Align button ( ) on the toolbar. The alignment may 
take several minutes, depending on the length and number of the molecules selected. 

5. When the alignment is complete, the results are displayed in the AlignX Window, as shown in 
Figure 13. The AlignX Window has panes showing different similarity graphs and the points at 
which the sequences align. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 13. Aligning molecules. 

Complexity and 
similarity plots 

Sequence 
alignment 

Relatedness 
tree 



16 

Contig Assembly 

Vector NTI Advance™ 11 can be used to assemble DNA fragments—both text sequences and 
chromatograms from automated sequencers—into longer contiguous sequences or “contigs.” The 
tool for doing this is called ContigExpress. 

In Vector NTI Explorer or the Molecule Viewer: 

1. Go to the Assemble menu and select ContigExpress—Open New Assembly Project (Figure 
144). 

2. In the ContigExpress Project Explorer, go to the Project menu and select Add Fragments >. 
Select your fragment file type from the submenu list. The Import Sequence dialog will open. 

3. In the Import Sequence dialog, navigate to the directory containing your fragment sequence 
files. Select the files and click on Open. 

4. Depending on the file type, you may be prompted to list the fragments by their Windows® file 
names or by their internal fragment names. Select the desired option. The fragments will be 
loaded in the ContigExpress Project Explorer. 

5. To view a particular fragment, double-click on it in the Project Explorer list. It will be loaded 
into the Fragment Viewer. 

6. When you are ready to perform contig assembly, select the fragments in the ContigExpress 
Project Explorer. 

7. Click the Assemble Selected Fragments icon ( ) on the main toolbar.  Fragments will be 
analyzed and assembled into one or more contigs, which will be listed in the Project Viewer 
along with the fragments in each contig. 

8. Double-click on a contig in the list. It will be displayed in the Contig Viewer. The Sequence 
Pane at the bottom shows the sequence of the assembly. The Graphics Pane on the right 
shows the orientations of the fragments in the assembly.  The Text Pane on the left lists the 
fragments in the assembly. 

9. If you wish to edit the contig, enable the Enhanced Edit Mode by clicking the icon Use 
Enhanced Edit Mode (far left on the toolbar in the Contig window) before making any 
reasonable changes. 

10. There are three trimming options in ContigExpress.  Fragments can be trimmed for 
ambiguities, Phred quality scores, and vector contamination.  Refer to the Vector NTI 
Advance™ 11 User’s Manual for details. 

Continued on the following page 
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Contig Assembly, continued 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 14. Assembling a Contig 

Fragment Viewer 
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Additional Information 

Invitrogen's free technical support for Vector NTI Advance 11 is available exclusively through the web. 
For more information, check out the Software Support section of the Vector NTI website at 
http://www.invitrogen.com/VectorNTI. 

 

To obtain personalized technical support by telephone or email, you must have an annual support 
contract.  You may purchase an Advanced Support Contract by contacting Invitrogen at 
bioinfosales@invitrogen.com. 

To receive technical support, use the following contacts:  

United States 
Phone: 800-955-6288 x 67990 (Toll-free, U.S.) 
E-mail: bioinfosupport@invitrogen.com  

 

Europe, Middle East, Africa, Asian Pacific 
Phone: +44 781 696 2707 
Email: bioinfosupport@invitrogen.com  
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