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Chapter 1. GENERAL INFORMATION

Read  the  operating  instructions  carefully  before  operating  the  MultiScan
Software.

1.1. Overview

MultiScan universal program is intended for:
· receiving  the  image  in  the  surface  of  survey  for  detection  and

identification of hidden objects (scanning);
· analysis of received images;
· image processing using built-in filters;
· creation of animated  image  of  investigated  object,  allowing  to  estimate

the internal nature of the object.

MultiScan can  acquire  images  when  operates  in  co-operation  with  different
devices having corresponding interface. Depending on the type of device used,
the  you  can  get  the  image  using  different  number  of  frequencies  and
channels:  for  example,  five  frequencies  and  two  channels  –  crossed  and
parallel.  According  to  his  need  operator  can  supply  the  received  image  of
investigated surface with comments and description containing information as
follows: test  conditions,  date,  etc.  The  maximum  information  volume  is  256
symbols.

System requirements
· PC Pentium IV processor
· 256MB RAM
· CDROM
· SVGA 800x600 or high, 65536 colors or high
· Windows 2000/XP/Vista

1.2. Install MultiScan

To use  MultiScan,  you  must  have  installed  the  files  from   the   MultiScan
 CD-ROM  disk  onto  your  hard  drive.  You   cannot   run  MultiScan  from
your CD-ROM drive.

To install MultiScan:
1. Insert the MultiScan CD-ROM disk into  your CD-ROM drive. The

MultiScan Setup dialog box appears. If  the Setup does not start
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automatically,  choose  the  Run command  from  the  Start  Menu.
Type x:\setup.exe (where x:  is the CD-ROM drive indicator) and
click OK.

2. Follow the Setup instruction on the screen.
3. When the Setup is complete, the program is ready for operation.
4. Restart the computer.

1.3. Uninstall MultiScan

You can remove all  of the MultiScan  components  you  installed,  except  the
data files you have created.

To uninstall MultiScan:
1. Click the Start Menu and choose Setting->Control Panel.
2. Double-click the Add/Remove Programs Control Panel.
3. Select Rascan Suite, click Add/Remove, and click OK to confirm

removal.
4. Follow the Setup instruction on the screen.
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Chapter 2. USER'S INTERFACE

MultiScan program has the multiwindow interface allowing to process several
images simultaneously.

MultiScan program screen

There  is  command  menu  in  the  upper  part  of  the  screen,  activated  when
clicking  the  mouse  upon  the  menu  name  or  when  pressing  Alt  button  and
then underlined letter in the menu name, for example: press Alt, F  to choose
menu  File.  In  the  drop-down  window  choose  the  required  command  by
clicking  with  mouse  button  or  pressing  the  underlined  letter.  If  there  is  an
arrow near the menu command pointed to the right,  then  this  command  has
its own sub-menu. Menu commands available in this situation are bright,  non-
available  commands  are  faded.  Menu  command  chosen  in  sequence  we’ll
separate  further  with  “>“  symbol.  For  example,  File>Open  means  choose
command Open in the menu File.
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2.1. Menu

The menu commands are listed in the table.

Command Description

"File" menu

Open (Ctrl+O) This command displays the “Open” dialog window which allows  to

choose the file(s) to be loaded in the MultiScan program. User can

choose data files with  DBI or BIT (old format) extensions.

Close This command closes the file in active window.  If file was  changed

you have to confirm saving these changes.

Save  (Ctrl+S) This command saves file in the active window.

Save as This  command displays the dialog window “Save File As”  where

user can save the file with arbitrary name in any folder.

Save as AVI file This  command  is  available  when  “Animation”  window  is  active.

After creation of animation user can save the results in AVI format.

Save as bitmap This  command allows  to  save  the  current  active  image  as  bitmap

file. Following types of files are supported: BMP, GIF, JPG, PNG, TIF.

Save as table  This  command  allows  to  save  the  current  active  image  as  ASCII

table in file with TXT extension.

Import This  command allows  to choose  the bitmap file  and  transform  it  in

DBI format for  future processing in  MultiScan program.  Following

types of files are supported: BMP, GIF, JPG, PNG, TIF.

Recent files This command shows the list of last files the user worked  with.  The

maximum  list  volume  is  set  in  the  “General”  card  of

“Tool>Option” dialog window. This volume could not be more than

9 files.

Exit This command finishes program’s operation.

"Edit" menu

Copy (Ctrl+C) This  command  allows  to  copy  file  from  active  window  to  the

clipboard in DBI format. In addition,  the image from active channel  in

the form of bitmap file is copied in the clipboard. In future this   image

can be used by any Windows program.

Paste (Ctrl+V) This command creates the new file with  the image based upon  the

file contained in the clipboard in DBI format.

"View" menu

Toolbar This command makes toolbar visible/invisible.

Status bar This  command  makes  visible/invisible  the  status bar  with

supplemental information.
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Command Description

Description window This  command  makes  visible/invisible  the  file  description  window

containing the description of file placed in the active window.

Animation This command allows to make frequency animation. The command is

available from active window with images.

Graphics This  command  allows  to  draw  the  graphic  for  the  image  chosen

along horizontal or vertical direction.

Histogram This command allows to view histogram for the chosen image. 

Refresh (F5) This command redraws the contents of all program windows.

"Image" menu

Rotate This command allows to rotate the image clockwise/anticlockwise at

an angle of 90°.

Flip image This  command allows  to  mirror  the  image  relatively  the  horizontal/

vertical axis.

Merge This command allows to merge images  along horizontal/vertical  line.

When merging along vertical  line the images  should have the same

horizontal  dimensions.  When  merging  along  horizontal  line  the

images should have the same vertical dimensions. 

Inversion (Ctrl+I) This command switches on/off the color inversion when black  color

becomes white  and white  color becomes black.  Command’s  action

spreads on all windows with images.

Information This command displays a dialog box with the image parameters.  The

command is available when window with images is active.

"Filter" menu

Contrast This filter allows to change the range of displayed image brightness.

Noise This  filter  allows  to  delete  noise  of  different  nature  using  square

masks.

Custom This filter lets you design your own filter effect.

Smooth This  filter  allows  to  make  image’s  linear  and  non-linear  smoothing

along lines or columns.

Threshold This filter makes threshold image processing.

"Scan" menu

Start scan (F6 This  command  loads  device’s  driver  and  activates  driver’s  card

"Scan". The scanning features you can see in  the device’s  User’s

Manual. This command is available if driver was not loaded earlier.

Stop scan (F7) This  command cancels the  scanning  process.  The  device’s  driver

stays active.
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Command Description

"Tools" menu

Test (Ctrl+T) This  command loads the device’s  driver  and  activates  the  driver’s

card "Test".  The test  features you can see in  the device’s  User’s

Manual. This command is available if driver was not loaded earlier.

Options This command displays the dialog window with  MultiScan  program

settings.

"Window" menu

Cascade This  command forces the program  to  arrange  all  windows  so  the

user can see the name of each window.

Tile horizontaly This  command  forces  the  program  to  arrange  all  windows  top-

down.

Tile verticaly This command forces the program to arrange all  windows from left

to right.

Next This command moves you to the next window.

Previous This command moves you to the previous window.

Clos e This command closes the current active window.

Close all windows This command closes all windows.

"Help" menu

Contents This  command  activates  the  information  service  system  of

MultiScan program and displays its contents.

Index This  command  activates  the  information  service  system  of

MultiScan program and displays its "Index" section.

About This  command  displays  "About  MultiScan"  section  with  about

property and copyright, program version and user’s support  service

information.

2.2. Toolbar

The toolbar  contains  icons  for  the  most  used  menu  commands.  The  brief
descriptions of these icons are listed in the table.

Icon Corresponding menu command

File>Open 

(Open file with image)

File>Save 

(Save file with image)
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Icon Corresponding menu command

Edit>Copy 

(Copy image to Clipboard)

Edit>Paste 

(Paste image from Clipboard)

Scan>Start scan 

(Start active unit driver in Scan mode)

Scan>End scan 

(Interrupt scan process)

View>Description window 

(On/Off description window)

View>Animation 

(Call animation creation window)

View>Graphic 

(Call graphic window)

View>Histogram 

(Call histogram window)

Filters>Contrast 

(Call image contrast filter)

Image>Inversion 

(Invert image colors)

Image>Information 

(Call active image information)

Tools>Test 

(Start active unit driver in Test mode)

2.3. Status bar

The status  bar  is  in  the  lower  part  of  the  screen.  The  status  bar  fields  are
described in the table.
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Field Description

X, Y coordinates Two numbers in  the beginning of the status line point  out  the

current  coordinates  of  the  mouse  pointer  in  image  active

window when drugging the pointer. The coordinates are given

in pixels and in millimeters (within parentheses).

Amplitude Displays the signal amplitude in the point  where mouse pointer

is located.

Active channel name The  image  can  contain  information  about  the  same  object

received from several channels. When viewing the image user

should know what channel  is active since all  processing and

analysis operations are made  with  active channel  only. To do

the channel  active,  click with  mouse  left  button  at  the  image

corresponding to this channel.

Minimum and maximum

amplitude value

During image review the range of all  image points is stretched

along the whole amplitude of grey color,  from black  to  white.

It’s  made  for  better  image  perception.  This  field  shows  true

amplitude range for user to be able to estimate  the contrast of

objects in the image.

Image size Determines width and height of the active image in pixels.
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2.4. Image window

When multi-window interface is used, each image has its own window.

MultiScan program image window

Channel
In  MultiScan  program  there  are  several  displaying  modes.  You  can
choose  one  displaying  channel  or  several  channels  displaying
simultaneously.  When  you  choose  one  displayed  channel  you  should
determine  the  channel  to  be  displayed.  If  this  field  is  inactive,  several
channels would be displayed simultaneously.

Frequency
Chooses the frequency number to be displayed.

How many channels do show
Chooses the number of channels to be displayed simultaneously.



11USER'S INTERFACE

© 1995-2009 RSLab

All frequencies
The  displaying  mode  when  all  frequencies  of  the  chosen  channels  are
displayed at once switches on and off.

All frequencies display mode

In the lower part of the image window there is a line with channels’ names.
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Chapter 3. PROGRAM SETTINGS

After MultiScan program start (especially, for the first time) we recommend to
check program settings. To  select  the  settings,  choose  the  Tools>Options
menu command.

3.1. "General" card

"General" card of program options window

Units
You can set the default  measuring units.  You can  switch  between  pixels
and centimeters.

Equalize color histogram if signal amplitude more than … 
Specifies the peak-to-peak signal amplitude which starts the enlarging the
image to full color range.
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Maintain aspect ratio
In  this  state  when  images  are  viewed  the  geometric  dimensions  of
scanned zone are kept unchanged taking into consideration the step value
along axes.

Prompt to save a new acquired images
Switches  on  the  compulsory  confirmation  of  file  saving  if  this  file  is  not
saved or contains any changes.

Create new description when creating new file
When this option is enabled,  the  empty  description  is  added  to  the  new
file. If this option is disabled, the new file gets description from the previous
one.

Recent file list contains
Specifies the number of file list  used recently by the user.  Ensures quick
access to these files.

3.2. "Devices" card

"Devices" card of program options window
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The devices’ registered drivers are listed on this card. 

“Add new” button allows to register the new device. The new device would be

placed at the end of the list.

“Delete” button allows to delete the device from the list. 

“Move device up” button to move the device one position up in the list.

“Move device down” button to move the device one position down in the list.

MultiScan program can operate with different  types of devices.  Before  you’ll
be able to use the device you  should  register  it.  The  program  uses  the  first
device in the list  as default. To change the list  order you should  use  “Move
device up” and “Move device down” buttons. 

3.3. "Edit" card

"Edit" card of program options window
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You can change the intensity value of  any  point  of  the  acquired  image.  The
edit mode is available with a double click at the point you would like to edit.

Here you can set the default values used during image points edition. 

Mode
Auto

The new value of intensity is calculated automatically as simple
average of two adjoining points (left and right or top and bottom).

Manually
The new value of intensity is set by the user.

New value
When  the  new value  is  chosen  automatically  you  can  choose  as  initial
points two adjoining points from left  and  from  right,  or  from  top  and  from
bottom. If  the edited  point  is  located  at  the  boarder  of  the  image  so  the
new  intensity  value  is  equal  to  intensity  in  the  adjoining  point  (along
chosen direction) from outside inwards.

When the new value is chosen manually you can choose the new intensity
value in dialog window in “New value” section.

Apply to
Specifies the application field of point editing procedure.

Current image
Changes point on the current image only.

Current frequency
Changes  points  in  the  position  chosen  to  all  channels  in  current
frequency.

Current channel
Changes points in the position chosen to all  frequencies in the channel
chosen.

All images
Changes  points  in  the  position  chosen  to  all  frequencies  in  all
channels.
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3.4. "Colors" card

"Colors" card of program options window

You can set the colors of the image window. The color can be changed with a
double click on the color box.

Back color
Background color of window.

Image area in scan mode
Color of working field background during scan mode.

Grid color
Grid color during scan mode.
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3.5. "Filters" card

"Filters" card of program options window

Specifies filters operational field.

Current image
A filter is applied for current image only.

Current frequency
A filter is applied for images at the current frequency to all channels.

Current channel
A filter is applied for images in the current channel at all frequencies.

All images
A filter is applied for all images in all channels at all frequencies
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3.6. "Graphics" card

"Graphics" card of program options window

You can set graphics window options. 

Colors
You can set the colors of:

· background;
· grid;
· line;
· text.

The color can be changed with a double click on the color box.

Grid
You  can  set  the   the  grid  dimensions  along  the  chart  axes.  If  the  grid
dimension of the grid along the axis is equal  to  1,  there  is  no  grid  along
this axis.
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3.7. "File location" card

"File location" card of program options window

You  can  select  the  default  folder  for  data  files.  You  can  write  this  path
manually in the corresponding line, or press the button “...” located at the right
hand and choose the required folder.
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3.8. "Animation" card

"Animation" card of program options window

Frames
This  option  allows  you  to  set  the  number  of  frames  when  animation  is
created.

Delay between frames
This  option allows  you  to  set  the  delay  between  frames  when  animation
playback is in progress allowing to compensate the computer’s processing
speed.

Algorithm
This option lets you select one of the available algorithms for animation
line creation. 

Cubic spline
The interpolation is made using cubic spline.

Linear spline
The interpolation is made using linear spline.
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Chapter 4. IMAGE OPERATION

4.1. Image acquiring

To  acquire  the  image  of  scanned  surface,  choose  command
Scan>Start scan,  and, if it is necessary, choose the  operational  mode.  For
more details, see User’s Manual of the used device.

4.2. Image processing

4.2.1. Filtration

The MultiScan program uses  a  number  of  filters  for  image  processing.  The
filters’  parameters  are  set  in  the  corresponding  dialog  windows.  All  dialog
windows have common controls

 Filters’ common controls

Channel
Specities the current displaying channel in the dialog window.

Frequency
Specities the current displaying frequency in the dialog window.

Scope
Specities  the  filter’s  operational  field.  The  filter  can  be  used  when
processing:

· current image;
· current frequency;
· current channel;
· all images. 
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Filter’s operational field can be set in the “Apply” dialog window.

“Apply” dialog window

Also, each filter’s control dialog window has its control:

Button Action

Finishes filter’s  operation. The filter  processing  result  is  displayed  in  the

new window of MultiScan program.

Interrupts filter’s operation without saving of filter processing result. 

Starts creation process of the new filtered image. 

Memorizes filter processing result for the current channel and frequency. 

Interrupts new image calculating process. The button becomes active only

after pressing the button “Preview”. When calculating process  is finished,

the button becomes inactive. 

To use this filter you should mark the image (click it with mouse  left  button)
the filter should apply to and in Filters menu choose the required filter.
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4.2.1.1. Contrast

"Contrast" filter dialog window

This  command  allows  to  change  the  interval  of  displayed  image’s  intensity
values according to the following algorithm:

· Values that less than new minimum A
min

, are replaced with A
min

;

· Values that more than new maximum A
max

, are replaced with A
max

.
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4.2.1.2. Noise

“Noise” filter dialog window

Using  matrix  filters  when  processing  the  image,  one  can  reduce  noise  of
different nature.

Controls

Filter Determines used filter type. The following filters are possible:

- Average,

- Minimum,

- Median,

- Maximum.

Size Determines filter’s size. The following matrixes are possible: 3х3, 5х5, 7х7, 9х9,

11х11, 13х13, 15х15.

Intensity New value if intensity can be calculated according to the following formula: 

C(i,j) = (1-k)*A(i,j) + k*B(i,j), where 

A(i,j) – value of intensity of the initial image,

B(i,j) - value of intensity of filtered image,

k – filter’s strength in percent. 
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4.2.1.3. Custom filter

"Custom" filter dialog window

The  custom  filter (mask)  lets  you  design  your  own  filter  effect.  With  the
custom filter (mask), you can change  the  brightness  values  of  each  pixel  in
the  image  according  to  a  predefined  mathematical  operation  known  as
convolution.  Each  pixel  is  reassigned  a  value  based  on  the  values  of
surrounding  pixels.  You  can  save  the  custom  filters (mask)  you  create  and
use them with other images.
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Controls

New Use the New button to create new custom filter (mask) by size

defined in the Size box.

Load Use the Load button to load custom filter (mask).

Save Use the Save button to save custom filter (mask).

Size Defines the filter (mask) size, which will be created after click the

New button. The maximum filter size is 9x9.

Divisor A divisor value. After multiplies each matrix element will be

divided into this value.

Offset An offset value. This is the value that will be added to the final

pixel values just before the effect is applied.

Intensity The new pixel value is defined as 

C (i, j) = (1-k) *A (i, j) + k*B (i, j), 

where

A (i, j) - the pixel value of the source image, 

B (i, j) - the pixel value of the image after filtration, 

k - force of the filter in percentage.

Auto compute divisor Enable this check box to ensure that color values remain within

the range of 0 to 255. If the sum of elements of a matrix is equal

to null, the divider is equal 1. 

Symmetric Enable this check box to keep the values entered in the matrix

symmetrical. For example, if you enter a value in the top left field

with this check box enabled, that same value will appear in the

other three corner fields.

Predetermined Multiscan includes some predefinition filters. You can select any

from them and apply its to the image.
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4.2.1.4. Smooth

"Smooth" filter dialog window

The filter allows doing linear (3 and 5 point algorithm) and non-linear  (7  point
algorithm) image smoothing along chosen direction (along lines and columns).
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4.2.1.5. Threshold

"Threshold" filter dialog window

The filter allows doing the binary threshold processing:
· Values that less than threshold are replaced with 0;
· Values that more than threshold are replaced with 1. 

or usual threshold processing:
· Values that less than threshold are replaced with 0;
· Value that more than threshold remain without change.

4.2.2. Animation

MultiScan program gets image of investigated surface at several  frequencies.
It  was  made  since  when  scanning  at  single  frequency  due  to  the  phase
correlation  there  can  be  situation  when  the  object  would  not  differ  from  the
background and would be invisible. The frequencies are selected in a way that
the object would be visible at least on one of the images. The animation mode
is  intended  to  offer  operator  the  possibility  to  review  all  images
simultaneously.  The  animation  mode  configuration  is  described  in  the
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"Program settings" chapter of this Manual. To  enable  this  mode  choose  the
menu command View>Animation.

Animation creation dialog window

To  create  animation  you  should  first  choose  the  point  upon  the  image  and
click twice with mouse button (this point would be considered as background)

and then press the button Start ( ). To cancel the viewing press the button

Stop  ( ).  When  animation  is  prepared  the  intermediate  images  are  based
upon interpolation of true images.
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4.2.3. Graphics

For  more detailed image analysis  the program has the following feature.  You
can  formulate  the  relation  between  image  brightness  and  longitudinal  or
transversal  coordinate.  When  you  choose  the  menu  command
View>Graphics the following dialog window opens for graphics creation: 

Graphics creation dialog window

The window has the following controls:

Channel control
Use to select view channel.

Navigation buttons
Use the navigation buttons to move along the image.
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Cross-section buttons
Use  these  buttons  to  select  the  cross-section  direction  for  drawing  the
graphics. The cross-section direction may be either horizontal or vertical.

Draw line button
Use this button  to  turn  on/off  a  marker  of  the  current  viewed  line  on  the
source image.

4.2.4. Histogram

A histogram illustrates how pixels in an image are distributed by graphing the
number of pixels at each color intensity level. This can show you whether the
image contains  enough  detail  in  the  shadows,  mid  tones,  and  highlights  to
make  a  good  correction.  When  you  choose  the  menu  command
View>Histogram the following dialog window opens:

Histogram dialog window
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Statistical information

Minimum Represents the minimum intensity value.

Maximum Represents the maximum intensity value (brightness).

Mean Represents the average intensity value (brightness).

Std Dev

(Standard deviation)

Represents how widely intensity values (brightness) vary.

Moving the  mouse  cursor  in  the  histogram  window  you  can  see  quantity  of
points belonging given level of a signal (brightness).

Level The level of signal (brightness)

Points The total number of pixels with a given level of signal (brightness).
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