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GETTING STARTED

REQUIREMENTS

Some Microsoft Windows operating systems may require 
administrator rights to install this software.

Microsoft Operating Systems.......�Windows XP Service Pack 3, 
Windows Vista or Windows 7

Hard Drive Space.........................200 MB of free space

Processor.....................................�IBM compatible x86 Pentium class 
processor, or newer, running at a 
minimum of 733 MHz

Memory.........................................1 GB of RAM

Peripheral Devices.......................USB 2.0 port

Peripheral Software......................Microsoft .NET 2.0

Recommendations
Matrix Pro (software version 2.0 or above is required)

Internet Access

DOWNLOADING FROM TEEJET.COM

Fieldware Link is available for download at www.teejet.com.

Fieldware Link 4.0 is a free program and does not require license 
codes or registration.

Uninstallation of previous versions is not required when updating or 
reinstalling the software. It is recommended that all jobs be backed 
up before updating or reinstalling.

Please contact TeeJet Technologies with any questions or for 
assistance.

TeeJet Technologies is not responsible for damage due to improper 
download and installation.

INSTALLATION

Once the installation program has been downloaded:

1.	 Double-click the TEEJET FIELDWARE LINK icon .
2.	 Follow instructions on installation windows.
Figure 1: TeeJet Fieldware Link Icon

Figure 2: Installation Windows

NOTE:  The operation language can be change after installation.
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Starting the Program
To start Fieldware Link:

1.	 Double-click TEEJET Fieldware LINK icon  on the desktop.
OR

1.	 Select “All Programs /  TeeJet /  Fieldware Link /  
Fieldware Link” from the computer’s Start Menu.

Figure 3: Welcome Screen

Setting the Program Language
The program language can be change from the Welcome Screen or 
in the program options.

Welcome Screen
1.	 Click DOWN arrow  to show list of available languages
2.	 Select language.

Program Options
1.	 Open the View Menu.
2.	 Click  Options .
3.	 Click DOWN arrow  to show list of available languages
4.	 Select language.

Figure 4: Welcome Screen

Figure 5: Program Options
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INTERFACE OVERVIEW

The menus allow you to have access to all functions. Most of the menu functions can be accomplished with a click of the toolbar or right-
click on the catalog.

The toolbar allows you to have one-click access to many common functions. Hover over any button to view button information. All toolbar 
button functionality can be duplicated in one of the drop down menus. Most can be duplicated in the catalog tree view right-click options.

The catalog tree view allows you to observe the organization of clients, farms, fields and jobs within the catalog. Within a catalog, you 
can add new clients, farms, fields or jobs; and copy, delete and organize existing clients, farms, fields or jobs. Most catalog tree view 
functionality can be accessed in one of the drop down menus or on the toolbar.

Clients, farms, fields and jobs are each given their own tab when opened. The screen can be organized to see multiple tabs at one time.

Figure 6: Interface Overview

Catalog

Inactive Tabs

Toolbar

Menu

Tab ListActive Tab
Close Active Tab
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Menus
The menus allow you to have access to all functions.

Most of the menu functions can be accomplished with a click of the 
toolbar or right-click on the catalog.

The File Menu
The File Menu allows you to manage catalogs and print clients, 
farms, fields or jobs.

NOTE:	 Jobs are created and loaded using the new client ,  
farm , field  or job  buttons, menu options or 
catalog right-click options.

Figure 7: The File Menu

Table 1: File Menu Options

Option Description

New – creates a new empty catalog

Save/Save As – saves the current open catalog

Load – opens an existing catalog

Print Preview – provides a preview of a client, 
farm, field or job to be printed

Also gives access to the Print button
Recent – provides a list of recent catalogs. 
Number of available catalogs can be set under  
View-->Options

Close – closes the catalog

The Edit Menu
The Edit Menu allows you to cut, copy, paste or delete text or 
catalog clients, farms, fields or jobs.

►�To cut, copy, paste or delete a catalog item, highlight the 
appropriate client, farm, field or job on the Catalog side bar.

Figure 8: The Edit Menu

The View Menu
The View Menu allows you to access catalog clients, farms, fields 
or jobs’ details, export/import jobs, search for information, convert 
units of measurement and access program options.

Figure 9: The View Menu

Table 2: View Menu Options

Option Description
Properties – access catalog clients, farms, fields 
or jobs’ details
Import/Export [Port] Jobs – export/import jobs 
from/to Matrix Pro
Find – search for information based on a word or 
phrase
Converter – convert area, length, temperature, 
speed or volume from one unit of measurement to 
another
Options – access program options including 
language, units, preferences and recent catalog 
list quantities
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The Resources Menu
The Resources Menu allows you to add a new client, farm, field or 
job to a catalog.

►�New farms, fields or jobs will be placed in the currently active 
client. Farms, fields and jobs can be organized using the 
Catalogs tab.

Figure 10: The Resources Menu

Table 3: Resources Menu Options

Option Description

New Client – creates a new client

New Farm – creates a new farm under the 
selected client. If no client is selected, button will 
be greyed out.
New Field – creates a new field under the 
selected farm. If no farm is selected, button will be 
greyed out.
New Job – creates a new job under the selected 
field. If no field is selected, button will be greyed 
out.

The Window Menu
The Window Menu allows you to close and access tabs.

The active tab is highlighted in the window menu.

Figure 11: The Window Menu

Table 4: Window Menu Options

Option Description
Close Active – close only the active tab
Close All – close all tabs
Close All But Active – close all tabs except for the 
active tab 

Icon varies 
based on 
the open 
window

View and access all open tabs

The Help Menu
The Help Menu allows you to obtain help information, access www.
teejet.com or Fieldware Link software information.

Figure 12: The Help Menu
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Toolbar
The toolbar allows you to have one-click access to many common 
functions. Hover over any button to view button information.

All toolbar button functionality can also be accessed in one of the 
drop down menus. Most can be accessed in the catalog tree view 
right-click options.

Figure 13: Toolbar

Import/Export Jobs
Show Properties

New Catalog
Load Catalog

Save Catalog

Cut
Copy

Paste

Redo
Undo Add New Field

Add New Job

Add New Farm
Add New Client

Table 5: Toolbar Options

Button Description

New Catalog – creates a new empty catalog

Load Catalog – opens an existing catalog

Save Catalog – saves the current open catalog

Show Properties – access catalog clients, farms, 
fields or job’s details
Import/Export [Port] Jobs – export/import jobs 
from/to Matrix Pro

Add New Client – creates a new client

Add New Farm – creates a new farm under the 
selected client. If no client is selected, button will 
be greyed out.
Add New Field – creates a new field under the 
selected farm. If no farm is selected, button will be 
greyed out.
Add New Job – creates a new job under the 
selected field. If no field is selected, button will be 
greyed out.

Catalog Tree View
The catalog tree view allows you to observe the organization of 
clients, farms, fields and jobs within the catalog. Within a catalog 
you can add new clients, farms, fields or job; and copy, delete and 
organize existing clients, farms, fields or jobs.

Most catalog tree view functionality can be accessed in one of the 
drop down menus or on the toolbar.

Figure 14: Catalog Tree View

Right-Click 
Options

Double-Click to  
View/Edit 

Properties

Client
Farm
Field
Job

Auto Hide Catalog
Catalog Options

Table 6: Auto Hide & Catalog Options

Option Description
Auto Hide Catalog – automatically hide the 
catalog window when not in use

Catalog Options – access options for closing tabs
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Table 7: Right-Click Options

Option Description
Properties – access catalog clients, farms, fields 
or job’s details
Print Preview – provides a preview of a client, 
farm, field or job to be printed. Also gives access 
to the Print button

New Client – creates a new client

New Farm – creates a new farm under the 
selected client. If no client is selected, button will 
be greyed out.
New Field – creates a new field under the 
selected farm. If no farm is selected, button will be 
greyed out.
New Job – creates a new job under the selected 
field. If no field is selected, button will be greyed 
out.

Catalog Reorganization
Reorganize farms, fields or jobs from one client, farm or field to 
another by:

•	 Click and drag a farm, field or job on the catalog to a new 
location

–– �Holding the “Ctrl” button on the keyboard while clicking 
and dragging will duplicate the farm, field or job.

•	 On the catalog, highlight copy/cut a farm, field or job and paste 
it into a new location

NOTE:	 The client, farm, field or job will be added to the level 
highlighted on the catalog, NOT the currently viewed tab.

Screen Organization
Screen organization allows you to see multiple tabs at one time.

To divide the screen:

1.	 Click and hold on tab to be moved.
2.	 Drag the tab and release it on the portion of the  

DIVIDER icon  to where the tab is to be moved.
The space being moved to will be highlighted.

Figure 15: Divide the Screen
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Figure 16: Divide the Screen

To combine tabs into one screen section:

1.	 Click and hold on tab to be moved.
2.	 Drag the tab and release it

►On the centre of the DIVIDER icon 
►On the tab header.

The screen section being combined will be highlighted.

Figure 17: Combine Tabs Into One Screen Section

Figure 18: Combine Tabs Into One Screen Section
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Program options is used to establish language, units, preferences, 
messages and recent catalog list.

To adjust program options:

1.	 Open the View Menu.
2.	 Click  Options .
3.	 Select from:

►Language – used to define the program language. Options 
include*: Chinese, Czech, Danish, Dutch, English, French, 
German, Hungarian, Italian, Polish, Portuguese - European, 
Portuguese - Brazilian, Russian, Spanish - European, 
Spanish - Central American, Spanish - South American and 
Swedish. 

	 * The languages included in the program may be changed at any time.

►Units – used to define the program measurements. Options 
include area, length, temperature, speed and volume.

►Preferences – used to define startup options
►Messages – used to reset all suppressed messages. 

Suppressed messages are those which have been marked 
as, “Do not show again.”

►Recent Catalog List – used to establish the number of 
catalogs listed in the recent catalog list as well as clear all 
catalogs from the recent catalog list

Figure 19: Select Options

Figure 20: Options Tab

PROGRAM OPTIONS
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MANAGING CLIENTS, FARMS, FIELDS AND JOBS

ADDING, VIEWING, DELETING
Adding New Clients, Farms, Fields or Jobs
To add clients to the catalog:

1.	 Click ADD NEW CLIENT  toolbar option, menu option or 
catalog right-click option.

To add farms to the catalog:

1.	 On the catalog, highlight the client to which the farm is to be 
added.

2.	 Click ADD NEW FARM  toolbar option, menu option or 
catalog right-click option.

To add fields to the catalog:

1.	 On the catalog, highlight the farm to which the field is to be 
added.

2.	 Click ADD NEW FIELD  toolbar option, menu option or 
catalog right-click option.

To add jobs to the catalog:

1.	 On the catalog, highlight the field to which the job is to be 
added.

2.	 Click ADD NEW JOB  toolbar option, menu option or catalog 
right-click option.

NOTE:	 The new client, farm, field or job will be added to the level 
highlighted on the catalog, NOT the currently viewed tab.

Figure 21: Adding New Clients, Farms, Fields or Jobs

Right-Click 
Options

Toolbar OptionsMenu Options

Add New Client
Add New Farm
Add New Field
Add New Job

Add New Farm
Add New Client

Add New Job
Add New Field
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Viewing Client, Farm, Field or Job Properties
To view a client, farm, field or job:

1.	 On the catalog, double-click the client, farm, field or job.
OR

1.	 On the catalog, highlight the client, farm, field or job.
2.	 Click PROPERTIES  toolbar option, menu option or catalog 

right-click option.
From the properties tab you can edit the client, farm, field or job 
information. If an element of a catalog has been edited and not 
saved, a black dot will appear in the lower right-hand corner of the 
window.

Figure 22: Viewing Client, Farm, Field or Job Properties

Right-Click
Option

Toolbar OptionMenu Option

Figure 23: Edited Catalog Mark

Deleting a Client, Farm, Field or Job
To delete a client, farm, field or job:
1.	 On the catalog, highlight the client, farm, field or job.
2.	 Click DELETE  menu option or catalog right-click option.

OR
Press the Delete key on your keyboard.

NOTE:	 When deleting a client, farm or field, all sub-elements of 
these [farms, fields or jobs] will also be deleted.

Figure 24: Deleting a Client, Farm, Field or Job

Right-Click
Option

Menu Option
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Client
A client tab gives access to details about the client including:

•	 Image

•	 Name

•	 Business information

•	 Mailing address

•	 Contact numbers and addresses

–– �Click the GO TO button  to send an e-mail or access 
their website

•	 Notes

•	 Associated farm(s)

Figure 25: Client on Matrix Pro

4/4/11 06:38

Job

Client: Mr. Nelson

New Job

Field: Smith Plot #5

Farm: Cityville Station

Start Job

Headland Herbicide

Figure 26: Client

TAB OVERVIEW
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Farm
A farm tab gives access to details about the farm including:

•	 Image

•	 Description

•	 Area

–– �Each of these entries are user defined (not pulled from 
jobs on the Matrix Pro). Highlight and type over existing 
information or use the UP/DOWN arrows  to make 
changes.

•	 Notes

•	 Associated client and field(s)

Figure 27: Farm on Matrix Pro

4/4/11 06:38

Job

Client: Mr. Nelson

New Job

Field: Smith Plot #5

Farm: Cityville Station

Start Job

Headland Herbicide

Figure 28: Farm
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Field
A field tab gives access to details about the field including:

•	 Image

•	 Description

•	 Area

–– �Each of these entries are user defined (not pulled from 
jobs on the Matrix Pro). Highlight and type over existing 
information or use the UP/DOWN arrows  to make 
changes.

•	 Farm association information

–– �Each of these entries are user defined. Highlight and type 
over existing information to make it specific to the field

•	 Legal information

–– �Each of these entries are user defined. Highlight and type 
over existing information to make it specific to the field.

•	 Notes

•	 Associated farm and job(s)

NOTE:	 For consistency within the catalog, the value entered in 
a “Name” section will be the same throughout the entire 
catalog on all field tabs.

Figure 29: Field on Matrix Pro

4/4/11 06:38

Job

Client: Mr. Nelson

New Job

Field: Smith Plot #5

Farm: Cityville Station

Start Job

Headland Herbicide

Figure 30: Field
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Job
A job tab gives access to details about the job including:

•	 Image

•	 Description

•	 Notes

•	 Associated field

Figure 31: Job on Matrix Pro

4/4/11 06:38

Job

Client: Mr. Nelson

New Job

Field: Smith Plot #5

Farm: Cityville Station

Start Job

Headland Herbicide

A job tab also gives the opportunity to delete the following 
information from the specific job:

•	 Applied area

•	 Boundaries

•	 Guidelines

The edited job can then be reused by importing back into  
the Matrix Pro.

Figure 32: Job
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Duplicating a Job for Reuse
A job can be duplicated for reuse.  This assists the user to use boundary and guideline data from an existing job in a future job  
in the same field.

To duplicate a job:
1.	 On the catalog, highlight the job.
2.	 Click COPY  toolbar option, menu option or catalog right-click option.
3.	 Click PASTE  toolbar option, menu option or catalog right-click option.
4.	 Edit the newly created job’s description.
5.	 Edit the job’s image, notes, applied area, boundaries and guidelines as needed.

–– �To apply an application to an area more than once using established boundries and guidelines,  
click the Applied Data  Delete  button.

–– To only reuse an established guideline such as an azimuth degree line, click the Applied Data and Boundaries  Delete  buttons.

–– To only reuse an established boundary, click the Applied Data and Guidelines  Delete  buttons.

6.	 Click SAVE  to save the catalog.
Export the duplicated job to a USB drive for use in the Matrix Pro.

Figure 33: Duplicating a Job for Reuse
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Jobs can be imported from or exported to a USB drive for use with 
the Matrix Pro.

See Appendix A of this manual or the Matrix Pro User Manual for 
details on importing and exporting jobs on the Matrix Pro.

See Appendix B of this manual or the Matrix Pro User Manual for 
details on creating, starting and closing jobs on the Matrix Pro.

To access the Port Jobs tab:
1.	 Click PORT JOBS  toolbar option or menu option.
2.	 Select the console model.
3.	 Select the USB drive.
4.	 Click  OK .
Figure 34: Import/Export

Toolbar OptionMenu Option

Exporting Job Data to the Matrix Pro
NOTE:	 Exporting a job to a USB drive will remove it from the 

catalog.

To include a selected job to be worked with on the Matrix Pro:

1.	 On the catalog, highlight:
►The job to move a specific job.
►The field, to move all jobs associated with the selected field.
►The farm, to move all jobs associated with the selected farm.
►The client, to move all jobs associated with the selected 

client.
2.	 Click EXPORT JOB button  or click and drag to the import/

export tab.
3.	 Repeat steps 1 to 2 as needed for other jobs.
4.	 Click  DONE .
5.	 Remove USB drive.
6.	 Insert USB drive into Matrix Pro. See Appendix A for Job Data 

options.
Figure 35: Exporting Job Data to the Matrix Pro

Export Job

Import/Export Tab

IMPORTING/EXPORTING
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Importing/Merging Job Data from the Matrix Pro
If a job (or jobs) being imported/merged has not been created or edited in Fieldware Link, it will be placed in new client (named “Unknown”) 
in the catalog.  The imported/merged job(s) can be manually moved to a different client, farm or field; or the new client, farm and field can 
be edited and saved.

NOTE:	 Importing/merging a job from a USB drive will remove/delete it from the USB drive.

To import/merge a selected job back into the catalog:
1.	 On the USB drive, highlight:

►The job, to move a specific job.
►The field, to move all jobs associated with the selected field.
►The farm, to move all jobs associated with the selected farm.
►The client, to move all jobs associated with the selected client.

2.	 Click MERGE SELECTED button , right-click and select MERGE  or click and drag to the catalog*.
3.	 Repeat steps 1 to 2 as needed for other jobs.
4.	 Click  DONE .
5.	 Remove USB drive.
*Clicking and dragging into the catalog will place the job where dropped - not where it was associated on the USB drive.

To merge all jobs back into the catalog:
1.	 Click MERGE ALL button  .
2.	 Click  DONE .
3.	 Remove USB drive.
Figure 36: Importing/Merging Job Data from the Matrix Pro

Merge Selected Into 
Catalog
Merge All Into Catalog

Right-Click Option
MergeImport/Export Tab
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CONVERTER

Convert area, length, temperature, speed or volume from one unit of measurement to another

1.	 Open the View Menu.
2.	 Click  Converter .
3.	 Click DOWN arrow  to select the units to be converted.
4.	 Click DOWN arrow  to select the input value units.
5.	 Click DOWN arrow  to select the output value units
6.	 Highlight and type over existing input value or use the UP/DOWN arrows  to make changes.
Converted value will appear in the output section.

Figure 37: Converter
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PRINT PREVIEW

Print preview provides a preview of a client, farm, field or job to be printed 
and gives access to the  Print  button.

To preview a client, farm, field or job:

1.	 On the catalog, highlight the client, farm, field or job.
2.	 Click PRINT PREVIEW   menu option or catalog right-click option.
A new tab with a preview of the selected will be made. From here you can 
print, zoom in or out or access the page setup for the previewed page.

Figure 38: Print Preview
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Page Setup 
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APPENDIX A
Matrix Pro Job Data
When in advanced job mode, the job data screen on the Matrix Pro allows selected jobs to be moved to or from a USB drive as well as to 
be deleted.

Jobs saved on a USB storage device can be opened and updated using Fieldware Link. In Fieldware Link, a user can input client, farm 
and field data as well as duplicate/edit jobs for reuse of boundaries and guidelines. From Fieldware Link, jobs can be ported back to a USB 
storage device to be moved back onto the console’s internal storage for use.

NOTE:	 The job(s) stored in Job Data are not available for selection when a job is active/started (option is greyed out). Stop the current job 
to enable the Job Data function. Job Data is not available in Simple Job Mode.

1.	 Press UNIT SETUP bottom tab .
2.	 Press DATA MANAGEMENT side tab .
3.	 Press  Job Data .
4.	 Select from:

►Move Job Data to USB Storage – used to move job data from internal storage to USB storage
►Move Job Data to Internal Storage – used to move job data from USB storage to internal storage
►Delete Job Data from Internal Storage – used to delete job data from internal storage or USB storage

5.	 Press RETURN arrow  or DATA MANAGEMENT side tab  to return to the main Data Management screen.
Figure 39: Job Data
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Job Data Reports

Options

Data-> Job Data

Internal Storage USB Storage

Field 1 Fertilize

Herbicide

Headland Herbicide
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USB Storage
Move job data from internal storage to USB storage.

1.	 Insert a USB drive into the console.
2.	 Under Internal Storage, select the job name to be moved.
3.	 Press RIGHT arrow  to move the job to the USB Storage.
4.	 Repeat as needed.
5.	 Remove USB Drive from the console.
Figure 40: Copy Job Data to USB Storage
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Internal Storage USB Storage

Field 1
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Headland Herbicide

Data-> Job Data

Internal Storage USB Storage

Field 1 Fertilize
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Internal Storage
Move job data from USB storage to internal storage.

1.	 Insert a USB drive into the console.
2.	 Select the job name to be saved in the Internal Storage.
3.	 Press LEFT arrow  to move the job to Internal Storage.
4.	 Repeat as needed.
5.	 Remove USB Drive from the console.
Figure 41: Copy Job Data From USB Storage
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Matrix Pro New Job
Jobs can be started new on the Matrix Pro console, then ported into 
Fieldware Link to add client, farm and field information.

To start a New Job with an automatically generated name:

1.	 Press  New Job .
2.	 Press  Yes  to automatically generate a name.

►No – to enter a name using the on-screen keyboard
The console will jump to Vehicle View.

Figure 42: New Job with Automatic Name

4/4/11 06:38
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To start a New Job with a custom name:

1.	 Press  New Job .
2.	 Press  No  to enter a name using the on screen keyboard.

►Yes – to automatically generate a name
The console will jump to Vehicle View.

Figure 43: New Job with a Custom Name
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Matrix Pro Start Job
Jobs can be created on the Matrix Pro console or Fieldware Link.

With GPS acquired, jobs that have been started on the Matrix 
Pro will use the field finder tool to assist the user in finding the job 
closest to the vehicle’s current GPS location. The job pick list will 
be updated every ten seconds. During this update, the list of jobs is 
sorted by distance with the closest two jobs displayed on the top of 
the list. The remaining jobs are listed beneath these alphabetically. 

Without GPS or if a job has been created in Fieldware Link and 
has not been started in the Matrix Pro, the jobs will be listed 
alphabetically.

Client, farm and field information are inputted using Fieldware Link. 

To continue an existing job:

1.	 Press DOWN arrow  to access the list of jobs saved in the 
console.

2.	 Select the job name to be started/continued.
3.	 Press  Start Job .
The console will jump to Vehicle View and begin providing 
navigation information.

Figure 44: Continue an Existing Job
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Matrix Pro Close Job
Once a job is closed, the job can be mergerd back into the catalog 
in Fieldware Link. Client, farm and field information are inputted 
using Fieldware Link.

To close a job:

1.	 Press HOME bottom tab .
2.	 Press  Close Job .
Figure 45: Close a Job
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Close Job and Save Reports
When closing a job with a USB drive in the console, you have 
the option to create a report on the current job. These reports are 
different than the reports in Fieldware Link and cannot be opened in 
Fieldware Link.

To create a report of the job:

1.	 Insert a USB drive into the USB port of the console.
2.	 Press HOME bottom tab .
3.	 Press  Close Job .
4.	 Select:

►Yes – to create a report of the last job
►No – to return to the Home screen without saving

Figure 46: Close Job and Save Reports
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•	 Enhanced data organization with Fieldware Link application

–– Reuse guidelines and/or boundaries

–– Input job details such as names or images
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