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INFINITY Software v6.1.0 
What’s New 

 INFINITY Software v6.1.0 Release 

This release includes several device driver updates, as well as improvements to performance 
and some bug fixes for INFINITY ANALYZE.  
 
The following list summarizes the highlights for this 6.1.0 release: 
 

 Camera Device Drivers 
• Device driver files for the INFINITY2-3C camera have been updated to correct a 

problem with captured images that were all black in INFINITY CAPTURE.  This timing 
problem was only evident on some computers. 

• An update to the INFINITY2-1 device driver fixes an issue present on some Windows 
7 computers. 

• Improved frame rate range adjustments included in the device drivers for the 
INFINITY2-1R and INFINITY2-5 camera models.  

• An improvement to the INFINITY2-5 drivers to better manage transitions between 
clocks.  

INFINITY CAPTURE & TWAIN interface 
• No changes. 

INFINITY ANALYZE 
• The area WB (white balance) function has been revised since release 6.0.0 where 

performance was compromised on several camera models. 
• Camera frame rates have been configured to operate at their fastest speeds. 
• Closing the histogram window removes additional processing that was  impacting the 

frame rate performance for the INFINITY1-5 and INFINITY2-5 models on some 
computers. 

• Certain computers experienced lock-up with ANALYZE when capturing images from 
the INFINITY1-3C camera model.  The application has been altered to correct this 
issue. 
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 INFINITY Software v6.0.0 Release 

This release incorporates improvements to the installation package, device driver updates, 
and some nice additions to the INFINITY ANALYZE package.  The locations of some 
application-related files have been altered to better accommodate Windows 7 and VISTA 
permissions. 
 
The following list summarizes the highlights for this 6.0.0 release: 
 

 Camera Device Drivers 
• Improvements to the INFINITY1-2CB exposure controls allow this frame rate-centric 

camera to respond more like an exposure-centric camera. 

 INFINITY CAPTURE & TWAIN interface 
• Changed location of Last Settings file to overcome write protection issues as follows:  

On VISTA & Windows 7 –  C:\Program Data\Twain_32\INFINITY 
On Windows XP – C:\ \Documents and Settings\All Users\Application 
Data\TWAIN_32\INFINITY\ 

 INFINITY ANALYZE 
• Now includes dynamic window zoom for both live preview and captured images. 
• New Cell Counting menu item available on the Measure menu allows for interactive 

thresholding and quantitative results based on pixel intensities. 
• The image title bar is updated with the image file name as soon as it has been saved. 
• Micrometer bar text and length are now associated to the active calibration. 
• User Manual has been fully updated to reflect all menus and dialogs. 
• User interface is now available in 7 different languages. 
• Help menu provides direct access to video tutorials available on the Lumenera 

website. 
• New Annotation menu item creates a bitmap overlay image from displayed graphics. 
• All auxiliary windows and toolbars can be interactively enabled / disabled from the 

Help -> Settings dialog, on a new tab. 
• Photometry auxiliary window displays pixel intensity distribution for measured areas. 
• The camera presets file (containing calibrations) is now located in this folder location: 

On VISTA & Windows 7 – C:\users\[User Name]\AppData\Roaming\INFINITY 
ANALYZE\ 
On Windows XP – C:\Documents and Settings\ [User Name]\Application 
Data\INFINITY ANALYZE\ 

 

KNOWN ISSUES 
• Frame rate of the INFINITY1-2CB is limited to 10 fps, but can be extended to 15 fps in 

INFINITY CAPTURE. Note that vertical bands may be visible, impacting image quality. 
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• Frame rate of the INFINITY1-2CB is limited to 5 fps in INFINITY ANALYZE, but will be 
increased in a subsequent release. 

• INFINITY ANALYZE does not currently take advantage of the modified ‘exposure-
centric’ behavior that has been implemented for the INFINITY1-2CB camera, and 
included with INFINITY CAPTURE. This will be addressed in a subsequent release. 

 

 INFINITY Software v5.0.6 Release 

The following list summarizes the highlights for this 5.0.6 release: 

 INFINITY ANALYZE 
• Added the default previewing video mode for the INFINITY2-5 camera. 

 Camera Drivers 
• Improvement of the exposure and gain properties control. 
  

 

 INFINITY Software v5.0.5 Release 

The following list summarizes the highlights for this 5.0.5 release: 

 Camera Drivers 
• Added support for the new INFINITYLiteB cameras. 
• Improved support for the new INFINITY1-2B cameras. 

 

 INFINITY Software v5.0.4 Release 

The following list summarizes the highlights for this 5.0.4 release: 
 

 Camera Drivers 
• Added support for the new INFINITY4-11 cameras. 
• Added support for the new INFINITY2-5 cameras. 
• Added support for the new INFINITY1-2B cameras using the SOI image sensor. 
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 Upgrade to new API version 2.1.0.241 
• Improve Windows 7 support. 

INFINITY Software v5.0.3 Release 

This section describes all the additions and updates we have made to the latest 
release of the software: 

 Camera Drivers 
• Added CIM3 support for INFINITY2-1 and INFINITY2-2 cameras. 

 

INFINITY Software v5.0.2 Release 

The following list summarizes the highlights for this 5.0.2 release:   

 Installation and Camera Drivers 
• The installation process has been revised to include a screen prompting for the 

INFINITY camera to be disconnected from the PC prior to continuing.   
• New driver file updates are included to correct an issue with the INFINITY4-11 

and Lw11057-SCI models that could result in corruption of the live video 
preview.  Currently does not support external signaling of start of frame in 
Video mode (GPO4: Video SoF). 

• Corrected an issue where pixels would not fully saturate at default gain for the 
INFINITY1-5 model.  In addition, the following Still Mode properties have been 
enabled: 
 STILL_EXPOSURE 
 STILL_GAIN 
 STILL_GAIN_RED 
 STILL_GAIN_GREEN1 
 STILL_GAIN_GREEN2 
 STILL_GAIN_BLUE 
 STILL_STROBE_DURATION 

• Corrected issue for the INFINITY4 and Lu330 camera models with driver 
signing for Windows Vista.  Also improved quality of Brightness, Contrast and 
Gamma in 16-bit mode. 
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 INFINITY ANALYZE 
• ANALYZE Settings files have been relocated to the standard Windows folder 

location for Application Data, providing better compatibility with future releases 
of the O/S. This new location will be different on XP and VISTA platforms: 
 
For XP: 

 [Drive:]\Documents and Settings\All Users\Application Data\INFINITY ANALYZE\ 
 
For VISTA: 

[Drive:]\ProgramData\INFINITY ANALYZE\Settings 
 

• A problem has been rectified with saving new camera Presets. The original 
release of INFINITY 5.0 introduced a problem resulting in ANALYZE failing to 
store the camera white balance settings. When a Preset was restored, the 
appropriate color gains were not being set on the camera.   

• An incorrectly imposed restriction on number of decimal places allowed in the 
Measure Options dialog has been removed. Entry of any value less than 2 was 
not permitted in the first releases of the 5.0 version. 

• An enhancement has been added to the micrometer bar placement allowing the 
previously selected location to be used again in the current image. The option 
is presented in the pop-up dialog after using the mouse to select a location in 
the image. This allows for the micrometer bar to be easily placed in a consistent 
location on all images, if desired.  

• Italian language files have been added to the installation, and the additional 
entry may now be selected from the View -> Language menu option. 

• The ANALYZE Advanced Features USB-Key is now being distributed as a 
driver-less device, making for a simpler installation supported across more O/S 
platforms. The Release 5.0.2 of INFINITY ANALYZE is required to take 
advantage of this new style of USB key. 

INFINITY Software v5.0.1 Release 

Includes a correction to the driver for the INFINITY1-3 model. This patch release is 
identical to the 5.0.0 release in all respects for INFINITY CAPTURE and ANALYZE 
applications. 

INFINITY Software v5.0.0 Release 

 Release Highlights 
The following list summarizes the highlights for this 5.0.0 release. Details can be found 
below, with even more information available in the Release Notes and product 
documentation. 
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• 64-bit drivers are now available for all INFINITY cameras on Windows platforms 
• ANALYZE now includes a FULL SCREEN mode 
• Preview grid pattern artefacts have been eliminated from ANALYZE 
• Bitmap Overlay added to Live Preview and Captured images in ANALYZE 
• CAPTURE can now export camera settings to a named ANALYZE preset 
• ANALYZE now offers a Simple layout for demos and first time operators 

 Camera Drivers 
• Added support for 64-bit Windows XP and Windows Vista operating systems. 

• All drivers are digitally signed for Windows Vista operating systems. 

• Added support for new revision of INFINITY2-2 cameras. 

 INFINITY CAPTURE 
• New function to export current camera settings into an INFINITY ANALYZE 

preset. 

• Added additional 75% zoom mode to preview zoom control. 

• Improved AVI filenames when converting a RAW AVI file to a standard AVI file. 

 INFINITY ANALYZE 

 Changes to the Layout: 

• On initial start-up of the software, the first-time user will be presented with 
ANALYZE shown in a simple configuration.   

• New options to quickly modify the application layout are provided as Simple 
Mode and Enable All, available from the View Menu. 

• A new Full Screen display function has been added. This feature allocates the 
maximum amount of the display for either the live preview or for captured 
images. The application can switch in and out of Full Screen mode by using the 
View menu, or with a simple press on the <Esc> key. 

• The contrast of the status bar has been improved by making the background 
color black. 

• Some toolbar icons used for image positioning have been removed to reduce 
clutter. These seldom used navigation functions are now accessible only from 
the View menu, as items labelled as Center and Corner.  

• The Field Menu entry formerly labelled as Vector Arithmetic has been 
changed to Math. 

• The buttons labelled Video On/Off have been removed from the CAPTURE 
Control panel, providing more space.  
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• The sequence of Control panels (from top to bottom) has been rearranged for 
greater ease of use.   

• The Measure Menu has undergone a transformation to make the most 
commonly used options readily accessible and to improve the ease of use for 
common measurement tasks. The Calibration and Micrometer functions have 
been moved onto this menu. 

• Revisions to the Micrometer function allow the bar and the text to be re-
positioned anywhere on the image by placing them in the annotation layer.  

• The distance or length measurements tool formerly labelled as Caliper, has 
been changed to Point to Point. 

• A new option has been added to the File menu called Close All Images. This 
feature pops-up a single confirmation dialog prior to closing down all displayed 
images in the working area. 

• Warnings and information messages now alert the operator when the Field 
Group memory is consumed, or if the number of fields has been used. 

 Camera performance and controls:  

• The Camera Control panel now includes a new option to provide a 
Continuous Auto Exposure function.   

• In previous revisions of the ANALYZE package the live preview from certain 
high resolution camera models (notably the INFINITY2-3, INFINITY1-5, and 
INFINITY4-11) would often produce a grid pattern appearance that varied 
based on the display window dimensions. While this artefact was observed only 
in the live preview and not on captured images, it was an undesirable 
characteristic. Modifications have been made to the display capabilities to help 
eliminate or minimize this problem.   

 Other functional changes 

• A Bitmap Overlay function has been added to both the Live Preview display 
and to Captured images.   This function is accessed using the File Menu  
Bitmap Overlay…   

• The newly designed Grid Options function allows for the origin and size of the 
grid spacing to be easily defined.  A new tool allows for the operator to specify 
the grid parameters using the cursor position on the captured image.  

• It is now possible to change the units of measurement without re-calibrating.   

• A new auxiliary window called Photometry has been added to ANALYZE.  It 
reports pixel intensity values for any defined measurement areas.   
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