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Copyright Statement 

Copyright in this document is owned by XiFrame Technologies LLC, herein after referred to as XiFrame.  

Any person is hereby authorized to view, copy, print and distribute this document subject to the following 

conditions: 

 The document may be used for informational purposes only 

 The document may be used for non-commercial purposes only 

 Any copy of this document or portion thereof must include this copyright notice 

Kindly note that any product, process, technology or other matter described in the document may be the 

subject of other Intellectual Property rights, all of which are owned and reserved by XiFrame and which 

are not licensed hereunder. 

This document is provided "as is" without any warranty of any kind, either express or implied, statutory 

or otherwise; without limiting the foregoing, the warranties of satisfactory quality, fitness for a particular 

purpose or non-infringement are expressly excluded and under no circumstances will XiFrame be liable 

for direct or indirect loss or damage of any kind, including loss of profit, revenue, goodwill or anticipated 

savings. All such warranties are hereby excluded to the fullest extent permitted by law. 

XiFrame will not be responsible for the accuracy of the information contained in this document, which is 

used at your own risk and should not be relied upon. The information could include technical inaccuracies 

or typographical errors. 

Changes are periodically made to the information contained herein; these changes will be incorporated 

in new editions of the document. XiFrame may make improvements and/or changes to the information 

at any time. 
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Questions & Feedback 

We thank you for downloading and using our software.  We also welcome your feedback and suggestions 

for improvement to our applications. 

To send feedback to XiFrame about this, or any other product, please write to us directly at 

mailto://support@xiframe.com 

To see our other products, please visit http://www.xiframe.com.  

http://www.xiframe.com/
mailto:support@xiframe.com
http://www.xiframe.com/
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Introduction 

If you are reading this manual then you probably recently downloaded the XiFrame XMI Explorer 

application.  This document will show you how to install and use the application. 

Download and Installation 
Before starting, please make sure that you have the latest version of the XiFrame XMI Explorer application.  

To get the latest version please go to http://www.xiframe.com and download it.  Run the downloaded 

executable and follow the prompts on the installation script. 

Note that the installation file will include the latest version of this documentation in Adobe PDF format.  

Please use that document version as it will be the latest issued document. 

Application Purpose 
The XiFrame XMI Explorer is a utility program designed for use by the IBM mainframe community.  If you 

have spent any time developing applications on the IBM mainframe or you are an IBM mainframe systems 

programmer then you will already be familiar with XMI or XMIT files.  We’ll just call them XMI files for the 

remainder of this document. 

XMI files are a common mechanism for moving data from one mainframe to another or for moving files 

from the mainframe environment to the PC environment. 

The purpose of this application is to allow a mainframe developer to examine or extract data from an XMI 

file within the Windows Environment. 

Compatibility 
The XiFrame XMI Explorer application has been tested, and is known to work, on Windows XP, Windows 

7, Windows 8 & Windows 8.1.  We deliberately skipped Vista as it was seen (even by Microsoft) as a non-

production ready operating system. 

References 
The greatest collection of XMI transmission files available on the web is undoubtedly the collection stored 

at http://www.cbttape.org.  This repository is maintained by volunteers for the good of the mainframe 

community.  This document uses File #876 as a test case for the purpose of describing the application 

functionality.  For greatest ease of use, please download the same file to follow along.  The file is described 

on cbttape.org as follows (click the link to download the XMI file directly) 

File # 876 ALGOL F v2.1 source and executables 

From this point forward the documentation assumes that you have a file called FILE876.XMI in an 

accessible location within your file system. 

http://www.xiframe.com/
http://www.xiframe.com/
http://www.cbttape.org/
http://cbttape.org/ftp/cbt/CBT876.zip
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Application Operation 

Application Appearance 
The XiFrame XMI Explorer is a simple single window application.  Figure 1 shows the main components of 

the application.  When looking at an XMI file containing a PSD or PDSE the left hand pane shows the 

original name of the unloaded file followed by each of the members contained within the dataset.  When 

looking at an unloaded sequential file then, of course, only the original file name is shown. 

The right-hand pane shows the content of any active member.  The XiFrame XMI Explorer will attempt to 

identify the contents of a particular member as text or data.  For text data (such as program source code 

or JCL) the member contents are automatically translated to local representation (ASCII) and displayed in 

the right pane. 

The Toolbar and Status-bar provide convenient access to program functions and application information. 

The “Content Aware” bar appears when the content of a member is recognized as a valid external format.  

The bar provides an immediate option to save the data to a new file; or, where applicable, to launch the 

content directly inside its registered viewer.  (For security reasons the XiFrame XMI Explorer does not 

allow launching of .EXE files. 

 

Figure 1- XiFrame XMI Explorer Main Window 

http://www.xiframe.com/
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Starting the Application 
To start the XiFrame XMI Explorer application you simply click on the application icon (shown in Figure 2).  

Alternatively you can double click on any file on your computer with an XMI or XMIT extension.  This will 

automatically start the application and, if the file is in a valid format, will open that file within the explorer. 

 

Figure 2- XiFrame XMI Explorer application Icon 

  

The XiFrame XMI Explorer Toolbar 
The XiFrame XMI Explorer has a simple toolbar that allows access to many common functions.  Each of 

the buttons on the toolbar is documented below.  Note that if a particular function is not available within 

the current context then that button will be diabled. 

 

Figure 3-XiFrame XMI Explorer Toolbar 

 

Opening an XMI file 
There are several ways to open an XMI file within the XiFrame XMI Explorer: 

1. From the windows desktop or windows explorer, double click an XMI file. 

2. With the application open, press CTRL+O to start the file open dialog. 

3. Select the “Open XMI File…” option from the “File” menu.  This can also be done using keyboard 

shortcuts 

a. ALT+F 

b. O 

4. Go to the recent items menu and select one of the last 9 XMI files you were looking at 

http://www.xiframe.com/
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Closing an XMI file 
Closing an XMI file is simple.  Either close the XiFrame XMI Explorer application by clicking on the close 

icon at the top right of the screen; Or, select “Close XMI File” from the application File menu. 

Remember that XiFrame XMI Explorer is a “READ ONLY” application.  The application does not change the 

content of an XMI file and so shutting down the application is safe. 

Navigating Data 
XMI Files can contain various file formats.  XiFrame XMI Explorer supports the following XMI types 

 A sequential dataset 

o Fixed Block 

o Variable Blocked 

 A PDS or PDSE 

o Load Library 

 RECFM=U 

 RECFM=VB 

o Library 

 Variable Records 

 Fixed Records 

XiFrame XMI Explorer will automatically select the most likely view format for each file type: 

Sequential Datasets 
Sequential datasets will be shown in full text mode if the record length is less than 150 bytes and more 

than 90% of the record content is displayable; otherwise the dataset will be shown in Hex Dump mode. 

  

http://www.xiframe.com/
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PDS/PDSE Libraries 
XiFrame XMI Explorer will show an emulation of the TSO/ISPF directory listing for any PDS/PDSE. An 

example is shown below: 

 

Figure 4- XiFrame XMI Explorer PDS directory listing 

In this case the user clicked on the DSN name in the explorer; XiFrame XMI explorer shows the extracted 

PDS/PDSE statistics and displays them in an identical format to TSO/ISPF. 

PDS Load Library members will always be shown in Hex Dump mode.  Each load member will be shown as 

a full hex dump of the load module. 

PDS library members with formats of FB or VB will show dynamically depending upon the content of a 

particular member.  If the member is obviously EBCDIC or ASCII text, it will show accordingly in the view 

pane.  If the member contains a non-displayable format, it will display as a hex dump of that member.  

Examples are when a member contains embedded data such as a load-library, PDF, ZIP or EXE file. 

XiFrame XMI Explorer contains functionality to recognize the following data types being stored in a 

member: 

 An embedded XMI unload file 

 An Adobe™ PDF file 

 An embedded EXE file 

 An embedded ZIP file 

 An embedded AWSTAPE file 

http://www.xiframe.com/
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If any of these conditions are recognized the application will provide an opportunity to either launch that 

data within an installed view, or it will give the opportunity to save the data to a separate file where it can 

be further explored using other tools.  An example is shown below: 

 

Figure 5- XiFrame XMI Explorer Recognizes embedded .PDF content 

If the user clicks the “Launch” button then the PDF file will be immediately launched within the Adobe™ 

PDF reader application (Note that it is assumed that the Adobe PDF Reader application is installed – this 

is true for >90% of PCs operating today).  Upon Launch the following window will be displayed: 

http://www.xiframe.com/
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Figure 6- CBT Tape #876, Member #COMPILR launched in Adobe PDF Reader 

 

Extract Data from an XMI File 

Extracting the currently displayed member 

Display Format 

XiFrame XMI Explorer always allows the current “View Port” to be saved to a text file.  To save the 

currently viewed data perform one of the following: 

 Click the save button on the toolbar 

 Select “Save Current Data” from the “File” menu 

 Right-Click the data view and select “Save Current Data” 

When one of these options is selected the user will be presented with the save dialog which will allow the 

contents of the display area to be saved in text format. 

http://www.xiframe.com/
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Figure 7- Save Dialog for the current member display 

Native Format 

It is also possible to save the current member in a “Native Format”.  Native Format saves the data exactly 

as it was found within the source XMI/XMIT file.  To save in Native Format, select one of the following: 

 Select “Save Current Native Data” from the “File” menu 

 Right-Click the data view and select “Save Current Native Data” 

Where it is possible to determine an appropriate native file extension (i.e. PDF, ZIP, AWS, EXE or XMI) then 

that option will be provided to the user, otherwise an extension of “.DAT” will be the default.   

No Translation takes place when saving native format data. 

Extracting All Members from the XMI/XMIT 
When browsing a PDS/PDSE, it is possible to extract all members from the XMI as a “Batch Unload”.  To 

extract all members from a PDS/PDSE perform one of the following actions: 

 Click the “Extract All Members from this XMI” toolbar button 

 Right click anywhere in the left tree-view pane and select “Extract All Data from this XMI” from 

the pop-up menu. 

 Select “Extract All Data from this XMI” from the “Tools” menu. 

After selecting one of these options the user will be presented with the extract dialog: 

http://www.xiframe.com/
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Figure 8- Extract All Data Dialog 

To perform the extraction, navigate to the location where you would like to extract the information.  

An option is provided (by default) to assign a new folder name based upon the DSN found within the XMI 

File. 

Click “OK” to perform the batch extraction of Click “CANCEL” to abort the operation. 

Copying Data to the Clipboard 
To copy a portion of the displayed data to the Clipboard; Drag a selection box within the view panel to 

select the required data and hit CTRL+C to copy.  Alternatively you can: 

 Press the Copy button on the toolbar. 

 Select “Copy Selected Text” from the “Edit” menu. 

 Right-Click and select “Copy Selected Text” from the Pop-Up menu. 

To copy the entire viewed data to the Clipboard, Select “Copy All Data” from the “Edit” menu.  Or, Right-

Click and select “Copy All Data” from the Pop-Up menu. 

Printing Data 
To print the currently viewed data, Select “Print” from the “File” menu or click the Print Icon from the 

toolbar. 

http://www.xiframe.com/
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Application Settings 

The XiFrame XMI Explorer allows the user to select some options which affect the behavior of the 

application.  To see the Application settings dialog, choose “Application Preferences” from the “Tools” 

menu.  You will be presented with this dialog box: 

 

Figure 9- XiFrame XMI Explorer Preferences 

The following options are available: 

Member View 
You can set the background color, foreground color and font for display of member data. 

Re-open the Previous XMI file 
Check this box to force the XiFrame XMI Explorer to automatically open the previously viewed file upon 

application start-up. 

Show Splash Screen  
The XiFrame XMI Explorer application has a splash screen.  Un-check this setting to bypass display of the 

splash screen upon startup. 

Character Translation 
The XiFrame XMI Explorer application supports multiple code-pages when translating data from Native to 

PC format.  The application includes many popular code-pages for global support 

Note: At this time DBCS translation is not supported. 

http://www.xiframe.com/


XiFrame XMI Explorer – User Manual 
 

http://www.xiframe.com  16 | P a g e  
 

Application Support 

XiFrame XMI Explorer is a free application.  XiFrame is very interested in your suggestions for 

improvements to this documentation or to the application itself. 

To contact XiFrame, please send an email to mailto://support@xiframe.com  

Alternatively, visit http://www.xiframe.com/contact to send us a message from the website. 

We promise to respond to all messages.   

Thank you in advance for commenting on our products. 

http://www.xiframe.com/
mailto:support@xiframe.com
http://www.xiframe.com/contact

