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The information provided in this documentation contains general descriptions and/or 
technical characteristics of the performance of the products contained herein. This 
documentation is not intended as a substitute for and is not to be used for 
determining suitability or reliability of these products for specific user applications. It 
is the duty of any such user or integrator to perform the appropriate and complete 
risk analysis, evaluation and testing of the products with respect to the relevant 
specific application or use thereof. Neither Schneider Electric nor any of its affiliates 
or subsidiaries shall be responsible or liable for misuse of the information contained 
herein. If you have any suggestions for improvements or amendments or have found 
errors in this publication, please notify us. 

No part of this document may be reproduced in any form or by any means, electronic 
or mechanical, including photocopying, without express written permission of 
Schneider Electric.

All pertinent state, regional, and local safety regulations must be observed when 
installing and using this product. For reasons of safety and to help ensure 
compliance with documented system data, only the manufacturer should perform 
repairs to components.

When devices are used for applications with technical safety requirements, the 
relevant instructions must be followed. 

Failure to use Schneider Electric software or approved software with our hardware 
products may result in injury, harm, or improper operating results.

Failure to observe this information can result in injury or equipment damage.

© 2012 Schneider Electric. All rights reserved.
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Safety Information
Important Information

NOTICE
Read these instructions carefully, and look at the equipment to become familiar with 
the device before trying to install, operate, or maintain it. The following special 
messages may appear throughout this documentation or on the equipment to warn 
of potential hazards or to call attention to information that clarifies or simplifies a 
procedure.
EIO0000000819 01/2012 5



PLEASE NOTE
Electrical equipment should be installed, operated, serviced, and maintained only by 
qualified personnel. No responsibility is assumed by Schneider Electric for any 
consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction 
and operation of electrical equipment and its installation, and has received safety 
training to recognize and avoid the hazards involved.
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About the Book
At a Glance

Document Scope
This manual presents the Web Designer software for Modicon M340 RTU and 
describes its installation and operation.

NOTE: In this manual, the term "Web Designer" means "Web Designer for Modicon 
M340 RTU”.

Validity Note
This documentation is valid for Web Designer software version 2.22.

Related Documents

You can download these technical publications and other technical information from 
our website at www.schneider-electric.com.

Product Related Information
All pertinent state, regional, and local regulations must be observed when installing 
and using this product. Only the manufacturer should perform repairs to this product 
to maintain system data.

When controllers are used for applications with technical requirements, please 
follow the relevant instructions. 

Title of Documentation Reference Number

Modicon M340 RTU BMX NOR 0200 H Module User Manual EIO0000000505 (Eng)
EIO0000000507 (Fre)
EIO0000000506 (Ger)
EIO0000000508 (Spa)
EIO0000000509 (Ita)
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Anyone who has access to a configuration tool and to your embedded server can 
override your security settings and download new settings to the server.

Unauthorized or incorrect changes to data may change the behavior of your 
application in ways that may be undesirable or hazardous.

User Comments
We welcome your comments about this document. You can reach us by e-mail at 
techcomm@schneider-electric.com.

WARNING
UNINTENDED EQUIPMENT OPERATION

Use only Schneider Electric software or approved software with our hardware 
products.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

WARNING
UNINTENDED EQUIPMENT OPERATION

Keep strict access to the embedded server by configuring passwords.
Carefully select the symbols and direct addresses you authorize to be modified 
online.
Do not authorize online modifications of critical process variables.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
8 EIO0000000819 01/2012
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Scope of this Chapter
This chapter introduces Web Designer, explains how to install it and provides a 
description of the graphical interface.

What’s in this Chapter?
This chapter contains the following topics:

Topic Page

Presentation 10

Preparing for Web Designer installation 12

Interface Presentation 13
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Introduction
Presentation

Introduction 
Web Designer is a software tool that allows easy creation of custom Web-based 
Human Machine Interfaces. It can also be used for easy configuration of built-in 
advanced processing functions for various Web enabled devices and RTU 
equipment:

FactoryCast Web servers modules for Modicon M340 PAC and Premium and 
Quantum PLCs
FactoryCast HMI Web servers modules for Modicon Premium and Quantum 
PLCs
FactoryCast ETG 1000/3000 Gateways for remote access
RTU module for Modicon M340 PAC

It provides the tools needed to design a Web HMI or RTU project.

 This manual describes the Web Designer version dedicated to the RTU module 
BMX NOR 0200 H for the Modicon M340 PAC platform.

Web Designer handles the following basic features for the module application and 
Web site:

configuration of the device Web site functions (data monitoring tables, monitoring 
screens, etc.)
management and Upload/Download of the devices Web site
configuration of advanced processing services

Advanced Services
Web Designer provides a user friendly interface to easily configure the following 
advanced services:

NOTE: Web Designer only configures the advanced processing services of the 
BMX NOR 0200 H module. The basic hardware (serial port, modem 
communications) and protocol (IEC60870 / DNP3) configuration of the module is 
done through the module Web pages. Please refer to the BMX NOR 0200H module 
documentation (see Modicon M340 RTU, BMX NOR 0200 H Module, User Manual) 
for the module setup.

Name Description

Datalogging Allows archiving of application data (events, alarms, 
process data, measures, etc.) in CSV files in the 
internal memory of the BMX NOR 0200 H module.

Email Allows the BMX NOR 0200 H module to sent alarm or 
report notifications via Email or SMS.
10 EIO0000000819 01/2012



Introduction
Compatibility between Web Designer Target Version and BMX NOR 0200 H Firmware
The version of the firmware available in the BMX NOR 0200 H module is identical to 
the version of the target used in the Web Designer project.

An upgrade function is available in Web Designer via the menu:

Target → Upgrade Target version

This function upgrades only the Web Designer application to the latest version. If 
necessary, upgrade the firmware of the BMX NOR 0200 H.

Required configuration
To use this software at an optimal level, the following configuration is recommended 
for the PC running the Web Designer:

1 GHz CPU

512 Mb RAM

80 Mb minimum of free disk space available on the hard disk

800x600 screen

Windows 2000 SP2, Windows XP Professional or Windows Vista Business 32-bit

Java Virtual Machine 1.4.2 minimum

NOTE: For Windows XP or Windows Vista, you need administration privileges to 
install the Web Designer Software. You also need administration privileges to run 
the software under Windows Vista.
EIO0000000819 01/2012 11



Introduction
Preparing for Web Designer installation

Foreword
Uninstall any previous version of Web Designer before installing the new version. 
Web Designer offers to perform the uninstall for you.

NOTE: Once installed, you can access Web Designer by clicking Start → All 
programs → Schneider Electric → Vijeo Designer Suite → Web Designer.

Installation
The installation procedure is as follows: insert the CD-ROM into the CD drive. The 
CD is Auto-run, therefore if your PC is set up for this feature you should see the 
Web Designer main window. If Auto-run is disabled or does not work:

Importing Previous Projects
Previous projects are visible in the navigator once Web Designer is reinstalled.

Step Action

1 Click Start → Settings → Control panel.

2 Click Add/Remove Programs in the Control Panel.

3 Click Add New Programs in the menu on the left, then CD-ROM and follow the 
instructions.

4 The Install Tool will automatically find the WebDesigner.exe program on the CD 
and will also display the path and file name then prompt you to perform the 
installation.
12 EIO0000000819 01/2012
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Interface Presentation

Main Window Contents
The following illustration describes the elements of the Web Designer main window:
EIO0000000819 01/2012 13



Introduction
7 main zones compose this screen which are: 

Navigator
This zone displays the files and folders associated with existing projects. It provides 
an overall view of the application displayed as a file tree:

The 3 main zones that compose the navigator are: 

Number Zone Description

1 Menu (see Web Designer for 
Modicon M340, Premium and 
Quantum, User Manual)

list of options available

2 Toolbar shortcuts to frequently used functions

3 Navigator (see page 14) displays the files related to the projects

4 Editing zone Web Designer uses this zone to edit, create or configure services 
associated with the project

5 Console zone list of the last detected errors

6 Information zone displays the connection status and the available memory of the selected 
module

7 Site Explorer View displays the target files

Zone Description

1 This zone displays the name of the project as root directory. By clicking +, all the 
targets associated with the project appear.

2 This folder displays the name of the target associated with the project and its IP 
address. By clicking +, all the folders and files associated with the target appear.
14 EIO0000000819 01/2012



Introduction
Toolbar
The toolbar enables you to access the main functions of the program directly by 
clicking its icons.

The figure below shows you the toolbar:

The following table describes the elements of the toolbar:

3 4 directories are visible for each target associated with the project:
Device: it displays the devices (CPUs connected to the module) associated with 
the target.
DataTables: it contains tables created using the Data editor (see page 82).
Service: it displays the services created by the user (availability depending on the 
target).
Website: it contains the website files for the project. You can customize the 
website (see Web Designer for Modicon M340, Premium and Quantum, User 
Manual) by changing these files or by adding your own pages.

Zone Description

Icon Function

New: by clicking the down arrow, you can:
create a new project
add a target to the project
add a device to the target
create a new service
create a folder
create a file

Open: opens an existing project

Save: saves the currently edited window

Save All: saves all items modified in the project

Cut: removes the selected object and puts it on the clipboard

Copy: copies the object to the clipboard

Paste: pastes the clipboard
EIO0000000819 01/2012 15



Introduction
Undo: cancels last action

Find: opens the Search window where you can search for a text located in a file 
of the project

Lookup: opens the Lookup window in which you can search a variable

Global Transfers: downloads all the project’s modules (and all the files)

Target -> PC: transfers a project from the target to the PC

PC -> Target: transfers a project from the PC to the target

Connection to the module: connects Web Designer to the target

Connection to the local simulator: connects Web Designer to the simulator

Disconnect: disconnects from the target or the simulator

Statistics: views statistics for the selected service (incoming messages, 
outgoing messages, and so on)

Stop: shuts down the current service

Run: starts the current service

Icon Function
16 EIO0000000819 01/2012
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Getting Started
Scope of this Chapter
The purpose of this chapter is to show the procedure using Web Designer to 
configure advanced services (Data logging, EMail/SMS notifications) and 
monitoring services for a Modicon M340 RTU application.

What’s in this Chapter?
This chapter contains the following topics:

Topic Page

Presentation 18

Creating a New Project 19

Device Selection 20

Target Properties 21

Variable Selection 23

Data Editor 25

Transfer 28

Accessing the Website 31
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Getting Started
Presentation

Introduction
This Getting Started is an example to show the steps to follow to configure an 
application for the BMX NOR 0200 H module.

A project consists of a BMX NOR 0200 H module and a Modicon M340 RTU PLC 
connected on the same PLC rack. The Web server hosted by the BMX NOR 0200 H 
module, periodically scans the values of selected variables located in the PLC and 
performs internal processing on these variables such as Datalogging, Alarm or 
report notification via Email.

Architecture
The following diagram shows the architecture of the Getting Started example:

The IP address for the module is a.b.c.d.

The following table describes the elements of the example:

Reference Type Description

BMX NOR 0200 H Target RTU module

Modicon M340 Device PLC
18 EIO0000000819 01/2012



Getting Started
Creating a New Project

Introduction
This topic provides an example showing how to create a new project using a 
BMX NOR 0200 H module.

Creating a New Project
The following procedure shows how to create a new project:

Step Action

1 Click on Project → New → Project
Result: The Web Designer Project Creation Wizard dialog appears. 

2 Enter the project name (RTU Project) in the Project field.

3 In the target box, scroll over the drop down menu of the RTU and select the module 
you require (for example, BMX NOR 0200 H v1.5) and click on the > button.
Result: The chosen module appears in the Selected Target(s) box on the right.

4 Enter the Name of the target (RTU module) in the Selected Target(s) box.

5 Enter the IP Address (a.b.c.d) in the Selected Target(s) box. For more information 
about IP addressing, refer to the Modicon M340 for Ethernet Communications 
Modules and Processors User Manual.

6 Repeat steps 3 to 5 if you want to select more than one target.

7 Click on Next.
Result: The second dialog of the Web Designer Project Creation Wizard appears.
EIO0000000819 01/2012 19



Getting Started
Device Selection

Introduction
For each target you can configure the devices that are connected to it.

Device creation
The following procedure shows how to attach devices to a target:

Step Action

1 Select a device in the Device List box and click on the > button. 
Result: The device appears in Selected Target(s) Device(s).

2 In the selected Target(s)/Device(s) table, enter the device name in the Name column 
and its address in the Address column. For more information about addressing refer 
to the Modicon M340 for Ethernet Communications Modules and Processors User 
Manual.

3 If the device supports several protocols, enter the desired protocol in the Protocol 
column.

4 If you want to attach more than one target, repeat steps 1 to 4 until you have selected 
all devices required.

5 Click on End.
Result: The project example appears in the browser.

6 Save your project by clicking on:
20 EIO0000000819 01/2012



Getting Started
Target Properties

Introduction
The target properties allow you to change the name of the target and its address.

This example shows you how to manually configure the IP parameters for a 
BMX NOR 0200 H. 

Accessing the Target Properties Page
You can access the Target Properties page by either:

On the Web Designer browser, right-click on the device name and click on 
Properties.
On the Target menu, click on Properties.

Result: The Target Properties dialog appears.
EIO0000000819 01/2012 21



Getting Started
Setting the IP Parameters
Use the IP parameters area to define the IP configuration of the module.

Having two devices with the same IP address can cause unpredictable operation of 
your network.

NOTE: In this example, we manually assign the IP address to the module. For 
details about managing IP address, refer to the Modicon M340 for Ethernet 
Communications Modules and Processors User Manual.

The following procedure shows how to manually configure the BMX NOR 0200 H 
module:

WARNING
UNINTENDED OPERATION — DUPLICATE IP ADDRESS

Make sure that each device receives a unique IP address.
The system administrator needs to establish a standardized process for 
assigning IP addresses so that duplicate addresses are not assigned 
inadvertently.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

Step Action

1 Access the Target Properties page.

2 Enter the IP address for the BMX NOR 0200 H in the IP Address field.

3 Click on OK to validate.

4 Save the new configuration by clicking on:
22 EIO0000000819 01/2012



Getting Started
Variable Selection

Introduction
The Import PLC Symbol dialog menu lets you select the PLC variables that can be 
used in a BMX NOR 0200 H module application.

All PLC device variables used in a project are located in a file called Namespace. 
The Data Editor, Data logging and EMail report notification services in a project uses 
the variables in Namespace.

Types of Symbols
For Modicon M340 RTU PLCs, symbols that can be used come from the PLC 
application files (.stu, .xvm, .prj or .fef files). 

Selecting PLC Symbols
The following procedure shows how to select PLC symbols:

Step Action

1 In the browser, extend the menu tree.

2 In the Devices directory, double-click on a PLC type device (Modicon M340 in 
our example).
Result: The device dialog opens.

3 Click on Import PLC symbols.
Result: The Open dialog appears

4 Select the (.stu or .xvm) file that has the application symbols.
EIO0000000819 01/2012 23



Getting Started
Namespace
By clicking on the Namespace file of the project in the browser, a table that groups 
all symbols previously selected for targets or devices appears.

5 Click on Open.
Result: The Select Variables to Import dialog appears.

6 Select the required symbols by double click on it in the 1st column.

7 Click on Import selected variables.

8 Save the project by using the menu Project → Save all. 

Step Action
24 EIO0000000819 01/2012



Getting Started
Data Editor

Introduction
The Data Editor enables you to create animated Data tables that display the values 
of application variables in a table format. In certain cases, these values can be 
modified by the user.

Allowing write access can change system behavior.

Variables that can be written are accessible only by trained personnel (through a 
password).

Selecting Editor Symbols
The following procedure shows how to select the editor symbols:

WARNING
UNINTENDED OPERATION

Apply password protection to limit access to the Data Editor.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

Step Action

1 In the browser, extend the menu tree.

2 Right-click on the DataTables directory to open the contextual menu and choose 
New Table.

3 In the Table Name field, enter a name for the data table.

4 Click on OK.
Result: An empty data table appears.
EIO0000000819 01/2012 25



Getting Started
5 To access the configuration tab either:
Double-click on a line of the Table dialog,
Right-click on the Table dialog to open the contextual menu and choose 
New.

Result: The configuration tab appears.

Step Action
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Getting Started
6
Click on , to obtain a list of available symbols. 
Result: The search list box for symbols appears.

Note: The list corresponds to the variables coming from the devices connected 
to the target.

7 Select the symbols to monitor.

8 Click on OK.

9 Save your table by clicking on:

Step Action
EIO0000000819 01/2012 27



Getting Started
Transfer

Introduction
Once you have completed BMX NOR 0200 H application configuration, you can 
transfer it to the BMX NOR 0200 H target.

Transfer the Website to a Target

Step Action

1 Select BMX NOR 0200 H in the menu tree.

2 Click on Target → Transfer → PC ->Target. 
Result: The Target Validation dialog appears.

If errors are detected in your project, the transfer cannot be performed. Refer to 
Project Validation (see page 49) for more information.
28 EIO0000000819 01/2012



Getting Started
3 Click on OK.
Result: The Transfer Status dialog appears.

Note: if there are differences between the firmware version of the project and the 
target, the transfer cannot be performed.

Step Action
EIO0000000819 01/2012 29



Getting Started
4 Click on Transfer.
Result: If a configuration password has been set, the Configuration Password 
dialog appears. Otherwise, go to step 6.

5 Enter the configuration password and click on OK.
Result: The Progress Information dialog appears. The files are displayed one at a 
time in the Status Bar.

6 The Transfer Progress Information dialog opens. The files are displayed one by one 
in the Status Bar.

Step Action
30 EIO0000000819 01/2012



Getting Started
Accessing the Website

Introduction
At this time, you have:

created a project,
selected the devices and the variables of your choice,
created data table to monitor the installation,
transferred your application from the PC to the target.

The last step consists of connecting to the website.

Accessing the Website

Step Action

1 Open a Web browser.

2 Type the IP address of the BMX NOR 0200 H module, a.b.c.d (see page 44), in the 
address bar.

3 Click on Go.
Result: The module website appears.

4 Click on Monitoring on the horizontal menu bar of the website.
Result: The monitoring home page appears.
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Getting Started
5 Click on Data Editor on the vertical menu bar of the website to see the animation 
tables created with the Data Editor.
The following figure shows the Data Table:

Select a table on the left side of the Data Editor applet and click on  to launch 
the animation.

Step Action
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Scope of this Chapter
This chapter explains how to manage a project. It concerns: 

Modifying a project,

Opening and closing a project,

Importing a project from a file.

What’s in this Chapter?
This chapter contains the following topics:

Topic Page

Adding/Removing Targets 34

Adding/Removing a Device 36

Adding/Removing Items 38

Opening/Closing a Project 40

Import 41
33



Project Management
Adding/Removing Targets

Adding a New Target
The following procedure shows how to add a target:

Step Action

1 Select a project.

2 Click on Project → New → Target.
Result: The Web Designer Project Creation Wizard opens, initialized with 
targets that already exist in the project.

3 In the Target List, select the targets to add.

4 Click on [>].
Result: The new target appears in the Selected Target(s) list.

5 Type a name and an address for that target.

6 Click on Next.
Result: The device selection wizard appears.
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Project Management
Dialog Fields
The following table gives a description of the elements of the Web Designer Project 
Creation Wizard dialog:

The button > enables you to add one of the targets in the list.

The button < enables you to remove a target in the list.

Removing a Target
To remove a target from the project, right-click on the target in the navigator to open 
the contextual menu and select Delete.

NOTE: If you delete a target of the project, the files associated with that target 
(including devices) are also deleted.

Number of Targets
A project can contain up to 16 targets. If you select the same type of target several 
times, attribute a different name and IP address for each target.

Field Function

Project Project name

Target List List of available targets

Target Target types selected in the Module List

Name Target Name, to distinguish targets of the same type

Address IP address of the target
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Project Management
Adding/Removing a Device

Adding a Device
The following procedure shows how to add a device:

NOTE: If you have more than one target in your project, select another target in the 
Target List to attach it before performing step 3.

Step Action

1 Select the Devices directory of your project.

2 Click on Project → New → Device or
Right-click on the Devices directory and then click on New Device.
Result: Web Designer Project Creation Wizard window appears, initialized 
with devices that already exist in the project.

3 Select the devices to add in the Device List field and validate with the button >.

4 Type a name and an address for that device.

5 Click on End to validate the project targets and devices.
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Project Management
Window Fields
The following table shows the fields in the Web Designer Project Creation Wizard 
for the Device window.

Removing a Device
To remove a device from the project, right-click on the device in the navigator to 
open the contextual menu and select Delete.

NOTE: When you delete a device, all variables in the Namespace of the device are 
also deleted.

Device Selection
You can only select 1 device.

Module Device
For a target in a rack, the default address is localhost.

Protocol
You can associate one or several protocols with each device. When a device 
supports several protocols, the protocol column is active and the user can choose 
one from the list. The address in the previous column depends on the protocol 
selected.

Field Function

Target List List of targets created in the previous panel

Device List List of available devices

Selected 
Target(s)/Device(s)

Device selected (from the Device List)

Name Name given to the device to distinguish it from other devices of the 
same type

Address Address of the target

Protocol Protocol supported by the device (the Protocol List is determined by 
the type of device)
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Adding/Removing Items

Presentation
This topics shows how to add elements of the following type to the project:

Data Tables

Services

Folders

Files.

Adding a Data Table
The following procedure shows how to add a Data table:

Adding a Service
The following procedure shows how to add a service:

Adding a Folder
The following procedure shows how to add a folder:

NOTE: You cannot create new folders outside of the Website menu tree.

Step Action
1 Select the project.

2 Select the sub-directory DataTables in the target directory.

3 Click on Project → New → Data or
Right-click on the DataTables directory and click on New Table.
Result: The Data Editor opens with a blank table.

Step  
1 Select the target.

2 Click on Project → New → Service or
Right-click on the Service directory and click on New Service.
Result: A dialog opens with a list of services that can be created.

3 Select the desired service from the list.

4 Click on OK.
Result: The Service dialog opens.

Step Action
1 Select one of the Website folders or the Website itself.

2 Click on Project → New → Folder or
Right-click on the Website directory and click on New → Folder.
Result: The Create a Folder dialog opens.
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Project Management
Adding a File
The following procedure shows how to add a file:

NOTE: You cannot create new files outside the Website menu tree.

Removing Items
To remove an item from the project, right-click on the item in the navigator to open 
the contextual menu and select Delete.

Step Action

1 Select one of the Website folders or the Website itself.

2 Click on Project → New → File or
Right-click on the Website directory and click on New → File.
Result: The Create a File dialog opens.
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Project Management
Opening/Closing a Project

Presentation
This section shows how to:

open/close a project,
save a project,
close Web Designer.

Opening an Existing Project
The following table shows how to open an existing project:

Closing a Project
The following table shows how to close an existing project:

Saving Multiple Modifications
To save multiple modifications, select Save All in the project menu or click the 
Save All icon in the tool bar. This operation saves the modifications made in open 
windows. These modifications relate to any open projects.

Closing Web Designer
When you close Web Designer, it memorizes the open or close state of projects. 
Projects that are open when you close Web Designer will automatically reopen the 
next time you launch the software.

Step Action

1 Click Project → Open Project. 
Result: the Open Project window opens. This window displays the list of 
projects in the workspace.

2 Select a project.

3 Click End. 
Result: the project appears in the menu tree.

Step Action

1 Select the project.

2 Click Project → Close Project. 
Result: the project disappears from the menu tree.
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Project Management
Import

List of sources 
Web Designer can import a project from the following sources to recuperate 
previous developments:

a .zip file exported by Web Designer,
a Web Designer project outside the Workspace.

Import
To import a project, click on Project → Import.

Import dialog:

After the import, the project appears in the menu tree.

Export
To export a project as a .zip file, click on Project → Export. This function is useful 
for saving a complete project before modifying it. The project stays open after being 
exported.
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Subject of this Chapter
This chapter describes how to transfer a website. You can transfer it from the 
configuration PC to the module or vice-versa. The transfer concerns the WEB pages 
generated by Web Designer and those created by the user. The transfer can be 
more general and, it can include files describing services.

What’s in this Chapter?
This chapter contains the following topics:

Topic Page

Transfer 44

Project Validation 49

Connecting/Disconnecting to/from the Module 52
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Transfer
Transfer

Introduction
The transfer functions enable you to transfer the Data Editor tables, the services, the 
website and its associated files, either from the configuration PC to the target, or 
from the target to the configuration PC. Specify the target address. Web Designer 
carries out a validation of the structure of the project before transferring the files. 

Setting Up the IP Address
Having two devices with the same IP address can cause unpredictable operation of 
your network.

Set the IP address of the module to perform a transfer. The following procedure 
shows how to enter the physical IP address of the module:

NOTE: You can also advise the address during the creation of the project with the 
Creation Wizard.

WARNING
UNINTENDED NETWORK OPERATION

Assign each device a unique IP address.
Always obtain your IP addresses from your system administrator.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

Step Action

1 Select the target in the browser.

2 Click on Target → Set Target Address.
The following dialog appears:

3 Enter an IP Address.

4 Click on Validate.
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Transfer
Transferring from the PC to the Target
The following procedure shows how to transfer data to the module:

Step Action

1 In the browser, select the target.

2 Click on Target → Transfer → PC ->Target. 
Result: The Target Validation dialog appears.

If there are detected errors in your project, the transfer cannot be performed. 
Refer to the Project Validation part (see page 49) for more information.
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Transfer
3 Click on OK.
The Transfer Status dialog appears:

Note: If there are differences between the version of firmware for the project 
and the target, the transfer cannot be performed.

4 Select the files to transfer.

5 Click on Transfer.
Result: If a configuration password has been set, the Configuration Password 
dialog appears. Otherwise, go to Step 7.

Step Action
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Transfer
Transferring from the Target to the PC
The following procedure shows how to transfer data from the module to a PC:

6 Enter the configuration password and click on OK.
Result: the Progress Information dialog appears. The files are displayed one 
at a time in the Status Bar.

7 The Transfer Progress Information dialog opens. The files are displayed one 
by one in the Status Bar.

Step Action

Step Action

1 In the browser, select the target.

2 Click on Target → Transfer → Target ->PC. 
The Transfer Status dialog appears:

3 Select the files to transfer.
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Transfer
Total Transfer of the Project
This function transfers the entire project to all the targets associated with it. The 
transfer is done target by target. The global transfer only works in one way, you can 
transfer from the PC to the targets, but not from the targets to the PC. To transfer 
from the targets to the PC, you have to manually transfer the files target by target.

To activate the transfer, click on Project → Global transfer. The procedure is 
exactly the same as a transfer from the PC to a target (see page 45). 

Partial Transfer
If you just modified a small part of a project, to save time, you can do a partial 
transfer. In the website, rdt (data tables) and Service directories, the contextual 
menu authorizes a partial transfer limited to files located in these directories.

Documentation
To manage online documentation, the user can add Word (.doc) or Acrobat (.pdf) 
files to the website in the site directory. The Transfer function copies these files to 
the target.

Site Explorer
The button Site Explorer displays all the target files in the lower window. This is 
especially useful before or after a data transfer to analyze the contents of the target.

4 Click on Transfer.
Result: If a configuration password has been set, the Configuration Password 
dialog appears. Otherwise, go to Step 6.

5 Enter the configuration password and click on OK.
Result: the Progress Information dialog appears. The files are displayed one 
at a time in the Status Bar.

6 The Transfer Progress Information dialog opens. The files are displayed one 
by one in the Status Bar.

Step Action
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Transfer
Project Validation

Introduction
Web Designer carries out a validation on the structure of the project before 
transferring files to the target. If the verification detects anomalies, the transfer is 
cancelled. Web Designer also performs a comparison between the PC configuration 
and the target configuration.

Validating a Project
When you start a transfer, Web Designer performs a project validation. You can also 
validate a project at any time by selecting Project Validation in the Project menu.

The Project Validation dialog looks like this:

The validation process monitors the following points:
The available space on the target is bigger than the size of the website.

The use of a user page or a service with variables not in the Namespace (file 
Namespace.dat).
The number of variables is less that the maximum number authorized for the 
target (1000).
The detected errors related to services.

Click on a message line to display the details of the detected errors.
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Transfer
Transfer Status
The following figure shows the Transfer Status dialog:

Legend:

The information has not been found on the remote target. 

Inconsistent, non-blocking information between the target and the PC. 

Inconsistent, blocking information between the target and the PC. 

Consistent information between the target and the PC. 
50 EIO0000000819 01/2012



Transfer
Use the Select area to specify the files you want to transfer: 

Parameter Action

Transfer Website Select this box to transfer files located in the Website directory.

Transfer only 
Modified Files

Select this box to transfer only files of the website that have been 
modified since the last transfer.

Transfer rdt Files Select this box to transfer data tables (rdt directory).
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Transfer
Connecting/Disconnecting to/from the Module

Introduction
The information below explains the procedure for executing an application once the 
services have been created.

Transferring a project to the module permanently erases the existing project. When 
a project is transferred, the old project is overwritten.

Anyone who has access to Web Designer can modify the value of PLC variables 
that have been write enabled and also modify your security settings. Unauthorized 
or incorrect changes to data change the behavior of your application or your process 
in ways that can be undesirable or hazardous.

NOTE: if an application is in RUN mode, the new project will be taken into account 
after a module reboot.

WARNING
UNAUTHORIZED SECURITY ACCESS

Do not use default or obvious passwords.
Change your passwords monthly.
Do not use obvious user names.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

CAUTION
LOSS OF DATA

Backup sensitive information before transferring a new application.

Failure to follow these instructions can result in injury or equipment damage.
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Transfer
Connecting to the Module and Recovering a Project from the Module
The following table shows the procedure for connecting to the module with a view to 
recovering its application:

Disconnecting from the Module
The following table shows the procedure for disconnecting from the module:

Step Procedure

1 Select the target in the browser.

2 Click Target → Connect → Target.
Web Designer analyses the changes between your project and the module 
content.
If you have modified the project, the software will ask you to transfer the project. 
Otherwise the application moves automatically to online mode.
Result: the Configuration Password window appears if a configuration 
password has already been set. Otherwise Web Designer connects to the 
module.

3 Enter the configuration password and click OK.
Result: Web Designer connects to the module.

Step Function Procedure

1 Disconnecting from 
the module

Click Target → Disconnect. 
Result: Web Designer has just switched back to offline mode.
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Managing Variables
Subject of this Chapter
This chapter explains how Web Designer handles variables.

This chapter also presents the Namespace file, which contains these variables. The 
data publishers and services use these variables.

What’s in this Chapter?
This chapter contains the following topics:

Topic Page

Namespace 56

Importing from a Programmable PLC 57

Manual Edit 60

Author Rights in Namespace 61
55



Managing Variables
Namespace

Introduction
Namespace contains all variables (symbols) previously selected for targets or 
devices. Data Editors and services get symbols from Namespace.

Variables come from either connected devices or from PLC applications. If there is 
more than one instance of a device type connected to the same target, use the 
following naming convention to have a unique name for each instance: 
device.name, variable name.

If the device is a PLC, name the variables declared in the PLC like this: PLC 
device.name, PLC variable name.

Accessing the Namespace

Step Action

1 Select the project.

2 Extend the target directory.

3 Double-click on the Namespace icon. 
Result: The Namespace dialog appears.
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Managing Variables
Importing from a Programmable PLC

Introduction
It’s possible to access a Unity Pro database with the function Import Symbols.

NOTE: Depending on the devices that you connect to the target, the type of 
variables you can access through the target might be different. Refer to the Modicon 
M340 RTU User Manual (see Modicon M340 RTU, BMX NOR 0200 H Module, User 
Manual) for more information on supported variables.

Accessing the Software Database
The following procedure shows how to access the software database:

Step Action

1 Double-click on the desired device in the Devices directory. 
Result: The following dialog appears.

Tab: 
Topic: Name of the variable
Variable: Address of the variable
Type: Type of variable
Access: Access right to the variable
Persistent: Access mode to the variable. It cannot be changed
Rate: Frequency at which the variable value will be refreshed

Button: 
Remove: Deletes the variable.
Duplicate: Duplicates the variable.
Import PLC Symbols: Opens a selection dialog of variables.
Import from CSV: Imports all the variables from a CSV file.
Export to CSV: Exports the variables to a CSV file.
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Managing Variables
2 Click on Import PLC symbols. 
Result: A file explorer dialog opens.

3 Select the file (.stu, .xvm, .fef or .prj) to import.

4 Click on Open.
Result: A dialog displaying symbols opens.

Step Action
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Managing Variables
Accessing the Unity Pro Database
To access a Unity Pro database, install the Unity Pro software on your computer. 
Unity Pro database files have .stu extension. The Unity Pro export file (extension 
.xvm) can be used without installing Unity Pro.

Synchronization with the PLC Program
If you modify the Unity Pro database from which you created your Namespace, the 
Web Designer Configuration Program automatically alerts you about the differences 
between the database and your Namespace when you open a configuration 
associated with the PLC database file.

Synchronization
The following procedure shows how to synchronize a Namespace with a PLC 
database:

5 Select desired symbols.

6 Select the variables you want to import by double clicking on the variables in 
the list.

7 Click on Import selected variables.
Result: the variables appear in the Device window.

Step Action

Step Action

1 Click on Target → Synchronize with PLC database.
Result: Inconsistencies are shown in a dialog. 

2 Click on OK to start default resynchronization operations. 

3 Transfer the project to the module.
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Managing Variables
Manual Edit

Presentation
You can manually add variables by directly entering a symbol, an address, its type 
and define the access rights in the Variables dialog of each device.

NOTE: Depending on the devices that you connect to the target, the type of 
variables you can access through the target might be different. 

Automatic Input
Automatic Input is an option that makes easier the manual creation of variables by 
incrementing the value of the last record.

If you select this option, the value of the fields is automatically filled when you add a 
new variable. The values correspond to those of the previous line incremented by 1.

Activating / Desactivating Automatic Input:

Options → Automatic Input
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Managing Variables
Author Rights in Namespace

Presentation
This table enables you to specify which variables can be accessed in the read/write 
mode.

NOTE: Write access is controlled by a password whose default value is USER.

Unauthorized or incorrect changes to data may change the behavior of your 
application in ways that may be undesirable or hazardous.

WARNING
UNAUTHORIZED CHANGES TO VARIABLES OR DIRECT ADDRESSES.

Carefully select the variables (symbols) and the direct addresses you authorize to 
be modified online, and the people authorized to do so.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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Managing Variables
Managing Author Rights 
Use the following procedure to manage author rights:

Step Action

1 In the navigator either: 
double-click on the NameSpace Write Access file
right-click on the NameSpace Write Access file and select Open

Result: The dialog manager for the Namespace author rights appears.

2 Define the intervals at which variables can be written. Outside these intervals, variables with direct 
access are read-only.
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Scope of this Chapter
This chapter describes the embedded advanced services.

What’s in this Chapter?
This chapter contains the following topics:

Topic Page

Device and HMI Services 64

Datalogging Service 65

Email and SMS Services 75
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Device and HMI Services

Presentation
The BMX NOR 0200 H module can perform internal standalone processing such as 
the following services: Advanced services are executed inside the module 
independently of any other processing done at CPU or SCADA level.

The following services are available for the BMX NOR 0200 H module:
Device Services: for configuring devices data acquisition (device variables 
polling).
Datalogging: automatic archiving of application information such as measures, 
events, alarms, device status, etc., to CSV log files in the BMX NOR 0200 H 
module memory (SD card).
Email: for alarm or report notification via Email or SMS.

Services Limitations

Variables:
a maximum of 1000 variables per application.
a maximum of 100 internal variables per application.

WARNING
UNINTENDED EQUIPMENT OPERATION

Restrict access to the embedded server by configuring passwords.
Restrict the symbols and direct addresses you authorize to be modified online.
Do not authorize online modification of critical variables concerning human and 
material integrity.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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Datalogging Service

Introduction
The datalogging service allows application data archiving (events, alarms, process 
data, devices status, measures, etc.) in the internal memory of the M340 
BMX NOR 0200 H module. This service allows you to log data into CSV files in the 
ASCII format. CSV files are stored locally in the SD memory card of the M340 
BMX NOR 0200 H module.

Datalogging can be performed either periodically or when a specific event 
(configured by the user) occurs. CSV files are directly usable by an MS Excel 
spreadsheet or a database management system (DBMS). The CSV files can also 
be sent through FTP or attached to an email (using the email service) that is 
automatically sent to specified users. CSV files can also be accessed by an FTP 
client.

Any FTP client can access the RTU module’s file system. You can specify a URL to 
automatically send information to a remote FTP server.

For more information on the Datalogging service principle, refer to the M340 RTU 
BMX NOR 0200 H module User Manual (see Modicon M340 RTU, BMX NOR 0200 
H Module, User Manual).

Accessing the Datalogging Configuration and Properties Dialog
To access the datalogging configuration dialog, double click on Datalogging in the 
project navigation window.

The configuration properties dialog contains:
A Configuration tab
A Properties tab
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The configuration properties dialog for the Datalogging service is shown below:

1 Use this tab to customize the Datalogging service.
2 Use this tab to configure the general properties of the Datalogging service.

How to Create a Datalogging Service

Step Action

1 Click on the name of your project in the browser.
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NOTE: You can create only one datalogging service.

2 To add the new service you can either:
Click on Project → New → Service
Right-click on Services in the browser, then click on New Service

Result: The following dialog appears.

3 Select datalogging in the Service type list box.

4 Enter the service name or click on Finish to keep the name by default.
Result: The datalogging service is created.

Step Action
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View of the Datalogging Configuration Dialog 

Datalogging Configuration Dialog Parameters
Log Tables Parameters:

Elements Function

Log Tables list 
box

List of the current log tables stored in the module. It is possible to:
create a new log file using the Add button
remove a log file using the Remove button
duplicate a log file using the Duplicate button
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Tables Parameters:

Log Parameters:

Fields Function

Table name text 
box

Name of the log file that contains all data configured by the user.

Table status 
variable text box

Determines the status of the table.

Enable logging 
check box

By selecting this check box and defining an associated variable in the 
Enable logging variable, the table can only perform actions such as: 
log data, backup, purge or FTP when the associated variable is set to 
a value other than zero and when the trigger is activated.
NOTE: Select the type of trigger in the drop down menu.

Elements Function

Use of a trigger 
text box

If the event is associated with a variable, to trigger logging of variables, 
configure an event in the Use of a trigger variable. Provide the name 
of this variable (for example, calculation.calculation1.Pressure1) in the 
text box. 
NOTE: Select the type of trigger in the drop down menu.

Use of a timer text 
box

If the event is periodic, to trigger logging of variables, configure an 
event in the Use of a timer variable. Set a time base in the text box. 
NOTE: Select the timer units in the drop down menu.

Erase on restart 
check box

Selecting this deletes the table log files on restart of the module.

Erase Table on 
Backup check box

Selecting this removes the previous logs in the table after backup, so 
the table restarts empty.

Timestamp check 
box

Selecting this records in the log file Timestamp (hour and date) for 
each event.
Note: Timestamps are mandatory if you want to use the log file for a 
Datalogging History.

Optimized log 
format check box

Selecting this compacts the log file format of the .csv file. In this case, 
the variable name does not appear in each record.

Maximum record 
number drop-
down list

Configures the maximum of records that can be stored in a log file. If 
that number is reached, new records overwrite old records.
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Log Variables Parameters:

Backup Parameters:

Elements Function

Log variables list 
box

The variable name part lists the variables (PLC/devices or Calculation 
variables) that are stored in the log file.
It is possible to:

create a new log variable using the Add button
remove a log variable using the Remove button

Elements Function

Use of a trigger 
text box

If the event is associated with a variable, to trigger logging of variables, 
configure an event in the Use of a trigger variable. Provide the name 
of this variable (for example, calculation.calculation1.Pressure1) in the 
text box. 
The use of a trigger field is greyed-out depending whether the Global 
backup check box from the datalogging properties dialogs is checked 
or not.
NOTE: Select the type of trigger in the drop down menu.

Use of a timer text 
box

If the event is periodic, to trigger logging of variables, configure an 
event in the Use of a timer variable. Set a time base in the text box. 
The use of a timer field is greyed-out depending whether the Global 
backup check box from the datalogging properties dialogs is checked 
or not.
NOTE: Select the timer units in the drop down menu.

Media target drop-
down list

Use to define the media target to use.

Maximum file 
number text box

Defines the maximum number of CSV files to use for each table. By 
default it is set to 10. The maximum authorized value is 100. The last 
file is the .csv file, the previous is the .0 file, and the oldest is the .8 file.

Status variable 
text box

Determines the status of the Backup action. The status is set to 0 when 
the service starts, to 1 when the backup action begins, and to 2 when 
the backup action completes.

Log estimated 
time text box

Provides information on the time length of the log based on the 
maximum file number, the logging and backup period. It is only 
available when using a timer.

Log maximum size 
text box

Provides the maximum log size. This field can be changed via the 
backup parameters in the datalogging Properties Dialog.
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Purge Parameters:

FTP Settings:

FTP Access to Datalogging CSV Files
Datalogging CSV files stored in the module memory can be accessed from any FTP 
client utility using the following path: SDCARD/USERDATA.

File Format
The file format is fixed and cannot be modified by the user. The file is encoded in the 
ASCII format as a text file with a .csv extension. Microsoft Excel is able to open these 
files.

Example of log file:

2007-10-01;02:44:55;plc.plc1.height;150;plc.plc1.length;200;plc.plc1.width;50;

2007-10-01 03:48:08; plc.plc1.height;140;plc.plc1.length;150;plc.plc1.width;30;

2007-10-01 04:55:10; plc.plc1.height;220;plc.plc1.length;280;plc.plc1.width;80;

2007-10-01 06:01:05; plc.plc1.height;170;plc.plc1.length;220;plc.plc1.width;60;

Elements Function

Use of trigger text 
box

Specifies the event that triggers the purge.

Status Variable 
text box

Determines the status of the Purge action. The status is set to 0 when 
the service starts, to 1 when the purge action begins, and to 2 when the 
purge action completes.

Elements Function

FTP trigger check 
box

Specifies the event that triggers sending the selected table log files 
(CSV file) via FTP.

FTP address text 
box

The address of the remote FTP server.

Status Variable 
text box

Determines the status of the FTP action. The status is set to 0 when 
the service starts, to 1 when the FTP action begins, and to 2 when the 
FTP action completes.

Login and 
Password text 
boxes

Login parameters for the remote FTP server access.
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Example of optimized log file:

Date;plc.plc1.height;plc.plc1.length;plc.plc1.width;

2007-10-01 02:44:55;150;200;50;

2007-10-01 03:48:08;140;150;30;

2007-10-01 04:55:10;220;280;80;

2007-10-01 06:01:05;170;220;60;

View of the Datalogging Properties Dialog

Datalogging Properties Parameters
Backup Parameters:

Elements Function

Global backup check 
box

When checked, all created tables use the same event to trigger a 
backup.
When not checked, each created table has its own event to trigger 
a back up.
NOTE: When a Global backup check box is checked, the fields use 
of a trigger and use of a timer become available.
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Purge Parameters:

Service Properties Parameters:

Trigger Types
The trigger types available are:

use of a trigger text 
box

Provides the name of a variable to trigger variable logging on an 
event associated to this variable.
NOTE: Select the type of your trigger in the drop down menu on the 
left.

use of timer text box Provides a periodic time base to trigger variable logging on an 
event.

Media target list box SD card to store the information on the SD card of the module

Log maximum size 
drop-down list

Specifies the maximum size of memory allocated to the backup files. 
The maximum log file size is defined for each media via the drop 
down menu, but the value can be changed. For more information, 
refer to Datalogging Limitations (see page 74).

Path text box Provides the destination path for the media selected.

Elements Function

Use of a trigger text 
box

If checked, this event triggers a purge of the current backup files on 
all media currently in use.
NOTE: Select the type of your trigger in the drop down.

Elements Function

Service status 
variable text box

Selects the variable with the associated event that is to trigger the 
check of the status of the Datalogging service.

Elements Function

Type Meaning Function

NY Notify Triggered by a change from a bit status or word value.

RE Rising Edge Triggered by a bit rising edge or by an increasing word value.

FE Falling Edge Triggered by a bit falling edge or by a decreasing word value.

BQ Bad Quality Triggered if the trigger status has bad quality.
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Datalogging Limitations
The Datalogging service has the following limitations:

The maximum number of Datalogging services is 1.
The maximum number of tables is 10.
The maximum number of variables is 100 per table.
The maximum number of records per table is 10 000.
The number of backup copies is 100 by default (10 backup CSV files per table), 
but it may be changed for each table.

Maximum Log Size Limitation
The limitation is 128 MB for a SD card in the BMX NOR 0200 H
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Email and SMS Services

Presentation
The BMX NOR 0200 H module can automatically and dynamically send emails or 
SMSs to alert specified users to:

alarm notifications
maintenance reminders
production reports
plant status updates
other plant information

The email service enables you to create various email notifications (including 
recipient’s names, email addresses, message subject, email body and attached 
files).

The body of an email can include fixed text messages, hyperlinks, file attachments, 
and real-time application values that are dynamically integrated into the email at the 
moment the email is sent by the module. Files can be attached to the email (for 
example, a datalogging file generated by the datalogging service).

SMS messages may also be sent to mobile phones if you are using a GSM modem 
or if the client’s email server has the capability. SMSs are a dedicated configuration 
of the email service. Emails or SMSs are sent when predefined application or 
process event is triggered.

For more information on the Email and SMS service principle, refer to the M340 RTU 
BMX NOR 0200 H module User Manual (see Modicon M340 RTU, BMX NOR 0200 
H Module, User Manual).

NOTE: The module is not designed for:

integrity of data sent by the module with the email or SMS service
the exactness of the time at which the message has been sent
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Creating an Email or a SMS Service
The procedure below describes how to create an e-mail or a SMS service:

Step Action

1 Click on the name of your project in the browser.

2 To add the new service you can either:
Click on Project → New → Service
Right-click on Services in the browser, then click on New Service

Result: The following dialog appears.

3 Select email in the Service Type list box.

4 Enter a service name or click on Finish to keep the name by default.
The email service has been created.
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Configuring the Server
The properties configuration dialog for the email and the SMS service is shown 
below:

The elements in the properties configuration dialog are:

Elements Function

SMTP server

SMTP server address text box SMTP address of the server.

SMTP server port text box TCP port used by the SMTP server 
(generally port 25).

Secure Authentication check box Select this box if authentication is required to 
access the SMTP server.

Login text box Login to access the SMTP server.

Password text box Password to access the SMTP server.

Sender

Sender text box Email address of the sender of the message.
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Reply address text box Email address to which a reply will be sent if 
the user clicks on Reply.

Module

Maximum size of the send queue text box Maximum number of emails that can be 
stored in the buffer memory before being 
sent:

Default value = 100,
Minimum value = 30,
Maximum value= 200.

NOTE: When the maximum number of 
emails is reached (100), no further 
messages can be queued.

Time before retry is sent (in seconds) text 
box

Delay before emails stored in the buffer 
memory are reset after an unsuccessful 
transmission:

Default value = 15 s,
Minimum value = 5 s,
Maximum value= 3,600 s.

Service

Service status variable text box Used to determine the status of the Email 
service.

Elements Function
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Configuring the Email and the SMS Service
The email and SMS configuration dialog is shown below:

The elements in the email and SMS configuration dialog are:

Elements Function

Send SMS 
check box

Select this box to send a SMS instead of an email.

Identifier text 
box

Email address or phone number (SMS) of the sender of the message.

Trigger text 
box

Event that triggers the email.

Type drop-
down list box

NY: Notify Triggered by bit status change or word value change.

RE: Rising Edge Triggered by a bit rising edge or by an increasing word 
value.

FE: Falling Edge Triggered by a bit falling edge or by a decreasing word 
value.

BQ: Bad Quality Triggered if the trigger status is Bad quality.
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NOTE:  

You can include dynamic application data inside the message body:
double click on in the body of the message at the place where you want to 
display the value of a variable and select the variable within the list which is 
displayed.
type the variable name between brackets.

The following fields are mandatory to record and save an email: Identifier, 
Trigger and Destination.

Limitations
The number of messages (email or SMS) you can configure in the project is 
restricted to 100. 

The maximum number of email or SMS services is 2.

NOTE: The SMTP server supports PLAIN or LOGIN authentication. Other authenti-
cation protocols are not supported.

Destination 
text box

Email addresses or SMS numbers of the recipients (separator ‘,’).

Subject text 
box

Subject of the notification.

Content list 
box

Content of the notification.

Click on this button to attach a file to the email (not available for a SMS).

Source drop-
down list box

Select the media from which the attached file comes from (not available for 
a SMS).

Path text box Specify the name and the path of the file to be attached to the email. 
Typical attached files are Datalogging files.
Default path is /SDCA/WEB/USERDATA.

Elements Function
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Subject of this Chapter
This chapter presents the different ways provided by Web Designer to monitor your 
system.

What’s in this Chapter?
This chapter contains the following topics:

Topic Page

Data Editor 82

Creating a Data Template 84

Data Editor Spreadsheet 85

Inserting a Symbol (Variable) in a Data Template 88

Inserting a Direct Address in a Data Template 90

Using an Existing Data Template 91
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Monitoring
Data Editor

Overview
The Data Editor allows you to edit/create data monitoring tables or to display data 
tables. Data tables provide read/write access to application data and device 
registers. Write access is password protected.

Allowing write access can change system behavior.

Variables that can be written are accessible only by trained personnel (through a 
password).

This section shows how to use the Data Editor to display and modify the values of 
the symbol variables and direct addresses.

The Data Editor is a Java applet that enables you to create dynamic data tables that 
can be updated with run-time data from the PLC.

WARNING
UNINTENDED SYSTEM OPERATION

Apply password protection to limit access to the Data Editor.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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Monitoring
Elements of Data Editor
The following illustration shows you the Data Editor:

Number Description

1 List of the variables included in this table.

2 The configuration area makes it possible to:
select and/or modify a symbol
select and/or modify an address
select the variable type
select the variable’s display format
check the read-only option
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Monitoring
Creating a Data Template

Overview
To display symbols (variables), create a new data template.

Creating a Data Template
Follow the procedure below to create a data template: 

NOTE: Save the current spreadsheet before selecting a new spreadsheet. Selecting 
a new spreadsheet deletes the current spreadsheet.

Step Description

1 Right click on the DataTables directory in the navigator and select New Table.
Result: The New Table dialog appears.

2 Enter a name of the new Data template.

3 Click on OK.
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Monitoring
Data Editor Spreadsheet

Overview
Depending on the target, the Data Editor displays data in a spreadsheet with the 
following fields:

name,
address,
type,
read only,
format,
status.

This section describes the spreadsheet screen and gives an explanation of each 
field.

Spreadsheet
The following figure shows the Data Editor spreadsheet:

Field Name
The fields in the Data Editor screen are:

Fields Function

Name The Name column contains the names of symbolic variables from the 
Namespace.
The symbolic variables which may be used in the Data Editor are those 
that have been predefined by the configuration tool. The symbolic 
variables are grouped in a file called Namespace.
EIO0000000819 01/2012 85



Monitoring
Type Field
The Data Type field contains the data type of the symbol variable or direct address. 
The types of data of the symbolic variable appear automatically when the symbol 
variable is located. Set the direct address data types from a drop-down list.

The following data types are valid:

Format Field
The Format field contains the format type for displaying the value of the symbol 
variable or direct address. The following formats are accepted:

Address The Address column contains the addresses of the symbols. You can 
display any direct address by entering its reference in this field. This direct 
address does not need to be referenced in Namespace, but needs to be 
associated with a symbol.

Type Data type (see page 86): input or output register, input or output bit.

Format Format (see page 86) of the data value.

Read Only If this box is selected the variable cannot be output directly.

Fields Function

Abbreviation Data type

INT 16-bit signed integer

UINT 16-bit unsigned integer

DINT 32-bit signed integer

UDINT 32-bit unsigned integer

REAL 32-bit IEEE floating point

TIME 32-bit unsigned integer (in ms)

DATE Date (32-bit BCD)

TOD Date/time (32-bit BCD)

BOOL 1 internal bit (boolean)

Abbreviation Format Type

bool Boolean

dec Decimal

hex Hexadecimal

binary Binary

ASCII Bytes displayed as ASCII characters

time Day_hr_min_sec_ms

date YYYY-MM-DD or HH:MM:SS
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Monitoring
Status Field
The Status column contains messages about the status of communications with the 
symbol variable or direct address. If communications are normal, the status 
message is "OK". 

If communication with a simple variable or a direct address is not operational, the 
Status column displays a message describing the event.
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Monitoring
Inserting a Symbol (Variable) in a Data Template

Overview
If you want to view or modify the value of a symbol (variable) in the Namespace, you 
must insert that symbol (variable) in a data template.

Inserting a Symbol (Variable)
Follow the steps in the procedure below to insert a Symbol (variable):

WARNING
UNINTENDED EQUIPMENT OPERATION

Password-protect access to the embedded server.
Carefully select the symbols and direct addresses you authorize to be modified 
online.
Do not authorize online modifications of critical process variables.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

Step Action

1 Double-click on an empty row in the spreadsheet.
Result: The data editor’s configuration tab appears. 

2

In the configuration area, click on the button.
Result: The Lookup dialog appears.
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Monitoring
3 Select the symbols (variables) you want to insert in the data template by clicking 
them in the list.

4 Click on OK.
Result: New rows corresponding to the symbols (variables) you selected appear 
in the spreadsheet.

5

Save your data table by clicking on .

Step Action
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Monitoring
Inserting a Direct Address in a Data Template

Presentation
If you want to view or modify the value of a direct address, insert that direct address 
in a data template.

Allowing write access can change system behavior.

Inserting a Direct Address

WARNING
UNINTENDED EQUIPMENT OPERATION

Limit embedded server access to qualified personnel.
Password-protect access to the embedded server.
Carefully select the symbols and direct addresses you authorize to be modified 
online.
Do not authorize online modifications of critical process variables.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.

Step Action

1 Double-click on an empty row in the spreadsheet.
Result: The data editor’s configuration area appears. 

2 In the Address field of the configuration area, enter the variable’s Direct 
address.

3 In the configuration area, click on Apply.
Result: A new row that corresponds to the variable address is displayed in the 
spreadsheet.
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Monitoring
Using an Existing Data Template

Overview
Once you have created data templates, you may want to access or modify them. 

Accessing a Data Template
The following procedure shows you how to access a existing data template.

Step Action

1 Extend the DataTables directory in the navigator.
Result: The existing tables appear in the navigator.

2 Either:
Double click on the table you want to modify in the list or,
Right click on the table you to modify and select Edit.

Result: The selected table appears in the editing zone.
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Setting Up an External Tool

Overview
This function enables you to setup an external tool to be used by Web Designer. For 
example, you can setup FrontPage to edit the files of your website.

The following part shows you how setup FrontPage to open the files of the website, 
however the procedure is the same if you use another software. 
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Setting Up an External Tool
Example
The following procedure shows how to set up a HTML editor. Here, hostname is 
used as an example:

Step Action

1 Click on Options → Configuration of an external tool → External tools.
Result: The setup dialog for external tools appears.
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Setting Up an External Tool
2 Click on New.
Result: The following dialog appears.

3 Enter a name for the external software (i.e. FrontPage).

4 In the Location group, click on Browse File System.
Result: A file explorer opens.

5 Select the path of the .exe file of the external software (i.e. 
C:\windows\frontpage\frontpage.exe).

6 In the Working Directory group, click on Browse File System.
Result: A file explorer opens.

7 Specify the directory that contains the files you want to open with your external 
tool (i.e. C:\workspace\WD_project\website.

Step Action
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Setting Up an External Tool
8 In the Arguments group, click on Variables....
Result: The Select Variables dialog appears.

9 Select the ressource_loc variable that returns the absolute file system path of a 
resource.

10 Click on Apply.

11 Click on Close.

12 Select a file of the website in your Web Designer navigator.

13 Click on Options → Configuration of an external tool → FrontPage. 
Result: FrontPage opens automatically the selected file.

Step Action
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Changing the Workspace 
Directory
Presentation
The workspace is the space where projects are stored. Only those located in the 
current workspace can be opened. Projects are automatically created in the current 
workspace. It is possible to have several workspaces and to pass from one to 
another.

This function enables you to change the path to the workspace.

To do this, select Change Workspace... in the Options menu.
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Module
Restart/Format a Module

Introduction
Restarting is necessary to take into account the modifications made to the 
application.

Formatting deletes the website on the module and restores the default website 
(Website and rdt directories). Formatting allows you to delete the modifications 
made to the website of a module, to start a fresh one from a defined status. It does 
not modify the system configuration.

The following procedure shows how to restart a module:

Step Action
1 In the menu tree, select a module.

2 In the Target menu, click on Reboot target. 
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Formatting and re-starting
Format the Module
The following procedure shows how to format a module:

Step Action

1 In the menu tree, select a module.

2 In the Target menu, click on Format target. 
Result: If a configuration password has been set, the Configuration Password 
dialog appears. Otherwise the formatting starts.

3 Enter the configuration password and click on OK.
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Subject of this Chapter
This chapter explains how to manage the security for a website using a firewall, 
access rights and password protection. 

What’s in this Chapter?
This chapter contains the following topics:

Topic Page

Internal Security 102

External Security 103

Variable Access Security, Symbol, Direct Address 105

Changing Passwords 106
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Security
Internal Security

Overview
Web Designer provides 2 mechanisms to allow that only authorized users view and 
modify your data:

password entry,
write restrictions.

Anyone who has access to a configuration tool and to your embedded server can 
override your security settings and download new settings to the server. 
Unauthorized or incorrect changes to data may change the behavior of your 
application in ways that may be undesirable or hazardous.

Password Entry
Although you may add unprotected Web pages to the site, the default Web pages 
and any other pages to which you want to restrict access can only be viewed by 
users who supply the correct user name and password.

Restrictions 
Restrictions are applied overall.

When you create a website and you want to restrict access to it, place it in the folder 
called secure.

WARNING
UNINTENDED OPERATION

Restrict control of access to the embedded server:

Change passwords monthly.
Do not use simple user names and passwords.
Disable default passwords before commissioning the module.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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Security
External Security

Overview
If your network has been configured to enable users to consult your Internet site, 
your security system is the same as that of an intranet site, only you have an 
additional security measure: a firewall.

Architecture of a Firewall
A firewall forms a gateway between Internet and your embedded server. You can 
use a firewall to restrict or forbid access to your website.

A firewall can be configured to authorize network connections to a limited range of 
ports, or to authorize traffic to or from certain IP addresses. 

Types of Firewalls
There are two types of firewalls:

Network firewalls
Application firewalls

Network Firewalls
Network firewalls are installed between the Internet and a single entry point to an 
intranet or internal protected network.
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Security
Application-Level Firewalls
An application firewall works for an application, for example FTP. It intercepts traffic 
sent to this application, and decides whether or not to transmit this traffic to the 
application. Application firewalls are located on individual host computers.

Firewall Configuration
Web Designer uses HTTP, FTP and Schneider Electric Modbus application protocol 
(MBAP) to access embedded server pages and files. If you want viewers to be able 
to access your site from the Internet and your embedded server is behind a firewall, 
configure the firewall to authorize HTTP, FTP and MBAP traffic.

NOTE:  

The default FTP name and password are USER/USER.
The RTU client follows the "Firewall Friendly FTP" standard, RFC 1579. It issues 
an FTP PASV command to the RTU server before any attempt to establish an 
FTP data connection.
The online mode of the configuration tool is not operational if the module is behind 
a firewall. The ports in this mode are dynamically assigned.

Port Protocol Access to...

21 FTP Protected embedded server files

Higher than 1024

80 HTTP WEB pages

502 MBAP Operational data
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Security
Variable Access Security, Symbol, Direct Address

Presentation
Users who enter the write password can only modify variables (symbols) and direct 
addresses which are write-enabled. When you create a WEB-enabled database of 
variables and direct addresses, you can designate each element as read-only or 
write-enabled.

Unauthorized or incorrect modifications made to symbols and direct addresses may 
have undesirable or hazardous effects on the behavior of your application.

WARNING
UNINTENDED EQUIPMENT OPERATION

Keep strict access to the embedded server by configuring passwords.
Carefully select the symbols and direct addresses you authorize to be modified 
online.
Do not authorize online modification of variables of critical nature concerning 
human and material integrity.

Failure to follow these instructions can result in death, serious injury, or 
equipment damage.
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Security
Changing Passwords

Introduction
This topic explains how to modify the different user names and passwords that are 
used for identification.

Modify Passwords
This procedure describes how to change passwords:

Step Action

1 In the browser, select the target.

2 In the Target menu, click on Properties.
Result: The Target Properties dialog appears.

3 Select Security.
Result: The following dialog appears.
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Security
Passwords
This table shows the elements in the various dialogs used to modify passwords:

4 Click on Modify to change a password (see page 107).
Result: The Password dialog appears.

5 Enter a new password and confirm it by typing it in the Confirm new password 
field.
If it’s an HTTP password, the login is also requested.

6 Click on OK in the Password dialog. 
Note: if you leave any fields empty during the modification, you are asked to 
confirm the replacement of the current password by an empty password.

7 Repeat actions 4...6 for each password to modify.

8 Click on OK in the Properties dialog of the target to close the dialog.

Step Action

Dialog Function

Secure HTTP 
Password

Required for connecting to the secure pages of the module website 
via a browser.

Write Password Required to write variables in the animation mode.

Configuration 
Password

Required to access the configuration parameters of the module.

FTP Password Not available.
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Subject of this Chapter
This chapter describes the menus for Web Designer functions. 

What’s in this Chapter?
This chapter contains the following topics:

Topic Page

Menu 112

Contextual Menu 114
111



Menu
Menu

Overview
The following table shows the complete menu system when all functions are 
supported:

Menu Sub-menu Overview

Project New Create a new project:
Creating a new module/device/data table.
Creating a service.
Creating files and folders.

Open project Open an existing project.

Close project Close current project.

Save Save an item modified in the project.

Save all Save all items modified in the project.

Import Importing an existing (.zip) project or a RTU or RTU HMI project.

Export Exporting the current project to a .zip file.

Global transfer Downloading the project’s modules (and all the files).

Project Validation Verifying the project before transfer.

Refresh Updating the dialog and menu tree.

Properties View/modify the project’s properties (passwords, comments, etc.).

Quit Exit application

Edit Undo Cancel last action.

Cut Removing the selected object and putting it on the clipboard (the object can 
be a project, a module, a device, a file, a variable etc.).

Copy Copy the object to the clipboard.

Paste Paste the clipboard.

Delete Delete the selected object.

Find... Search for text in the project.
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Menu
Target Transfer Transfer all files, either from your PC to the destination, or from the 
destination to your PC.

Partial Transfer Transfer only data tables and service directories, either from your PC to the 
destination, or from the destination to your PC.

Connect Connecting to the module (if the module authorizes the connection) or to 
the simulator.

Disconnect Disconnect from the module or from the simulator

Stop all services Shutting down all the services (for targets using services).

Start all services Starting all the services (for targets using services).

Site Explorer Display a view of the website in the dialog on the bottom.

Reboot target Rebooting the connected module (for modules that authorize).

Format target Formatting the connected module (for modules that authorize).

Set target address Display/modify the IP Address, user name and password of the target.

Upgrade target 
version

Synchronize with 
PLC database

Synchronize the namespace of your project with a PLC database. Not 
available for RTU targets.

Properties View/modify the target’s properties.

Service Stop Shut down current service.

Run Start current service.

Operator screens View operator screens.

Plc Program Viewer

Print Print current service.

Statistics View statistics for the selected service (incoming messages, outgoing 
messages, etc.).

Options Configuration of an 
external tool

Set up an external tool (for example FrontPage).

Change 
workspace...

Changing a workspace directory.

Default display Restoring the three-dimensional view of the work dialog by default.

Automatic input Fill in automatically the values of a new variable by incrementing the values 
of the last record.

Help Help Access to Web Designer Help file.

About Information about the version, copyright etc. of Web Designer.

Menu Sub-menu Overview
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Menu
Contextual Menu

Table
The following table shows the contextual menu of the file tree.

File tree item Menu (right-click) Sub-menu Comment

Project name New Project
Target

Launch the wizard. 1st dialog.

Edit

Paste Paste project.

Delete Destroy project.

Rename Rename project.

Global transfer Transfer project.

Properties View the project properties.

Module name New Device
Service

Launch the wizard. 2nd dialog.

Edit

Cut Cut module.

Copy Copy module.

Paste Paste module.

Delete Delete module.

Rename Rename module.

Transfer PC->Target
Target->PC

Transfer web site.

Connect Target Connect module.

Disconnect Disconnect module.

Properties View the module’s properties.

Devices folder New device View the selection dialog of symbols.

Paste Paste device.

Device element Edit Launch the device display dialog.

Cut Cut device.

Copy Copy device.

Delete Delete device.

Rename Rename device.

Run Start the service.

Stop Stop the service.

Partial transfer Target>PC Transfer only the folder.
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Menu
DataTables folder New Table Launch the data editor.

Paste Paste the data table.

Partial transfer Target>PC
PC->Target

Transfer only the folder. See note.

DataTables item Edit Data Editor.

Open Data Viewer.

Cut Cut the data table.

Copy Copy the data table.

Delete Delete the data table.

Rename Rename the data table.

Partial transfer Target>PC
PC->Target

Transfer only the folder. See note.

 Services folder New service Create a new service.

Paste Paste a service.

Partial transfer Target>PC 
PC->Target

Transfer only the folder. See note.

A Services folder
calculation, email, 
database, data 
logging, active pages

New Launch the service wizard with the selected 
service.

Cut Cut a service.

Copy Copy a service.

Paste Paste a service.

Delete Delete a service.

Partial transfer Target>PC 
PC->Target

Transfer only the folder. See note.

Services item Cut Cut the service.

Copy Copy the service.

Delete Delete the service.

Rename Rename the service.

Run Start the service.

Stop Stop the service.

Partial transfer PC->Target Transfer only the folder. See note.

File tree item Menu (right-click) Sub-menu Comment
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Menu
Website folder New Folder
File

Create a new file or folder.

Paste Paste a new file or folder.

Import File Importing an existing website.

Partial transfer Target>PC
PC->Target

Transfer only the website. See note.

Folder in Website New Folder
File

Create a new file or folder.

Cut Cut the folder.

Copy Copy the folder.

Paste Paste a new file or folder.

Delete Delete the folder.

Rename Rename the folder.

Import File Importing an existing file.

Partial transfer Target>PC
PC->Target

Transfer only the folder. See note.

File in WebSite Open Open the file.

Open with System 
Editor

Launch another dialog with System Editor.

Edit with Notepad Launch the HTML page in Edit mode with notepad.

FrontPage Launch the HTML page in Edit mode with 
FrontPage.

Cut Cut the file.

Copy Copy the file.

Delete Delete the file.

Rename Rename the file.

Partial transfer Target>PC
PC->Target

Transfer only the file.

Namespace Open Launch the Namespace dialog.

Namespace Write 
Access

Edit Launch the author rights Namespace dialog.

File tree item Menu (right-click) Sub-menu Comment
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A

applet
Software component that runs in the context of another program, for example a Web 
browser.

ASCII
American Standard Code for Information Interchange.

Pronounced "aski". This is an American code (but now an international standard) 
which allows alphanumerical characters used in English, punctuation marks, some 
graphics characters and various commands to be defined with 7 bits.

AT commands
Also called Hayes Commands: Set of commands for various phone-line 
manipulations, dialing and hanging up for instance.

B

bit
Contraction of Binary Digit.

This is the binary unit of information content, which can represent two separate 
values (or states): 0 or 1.

A field of 8 bits constitutes 1 byte.
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BOOTP
Bootstrap Protocol: Protocol for booting diskless terminals or stations by 
centralized management of network parameters.

C

CF card
CompactFlash card: Type of data storage device, used in portable electronic 
devices.

communication interruption
Communication error detected by the module when the periodic exchanges with the 
PLC stop.

configuration
The configuration comprises the data that defines the device (invariable) and that is 
necessary to the operation of the module.

CPU
Central Processing Unit: The microprocessor. This comprises the entire control 
unit and the arithmetic unit. The purpose of the control unit is to extract the execution 
instruction from the central memory along with the data needed to execute this 
instruction, to establish electrical connections in the arithmetic and logic unit and to 
start the processing of this data in the unit. ROM or RAM memories are sometimes 
included on the same chip, and sometimes I/O interfaces or buffers.

CRC
Cyclic Redundancy Check: Type of hash function used to produce a checksum – 
a small, fixed number of bits – against a block of data, such as a packet of network 
traffic or a block of a computer file.

D

DHCP
Dynamic Host Configuration Protocol: Protocol allowing a station connected to 
the network to obtain its configuration dynamically.
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DNS
Domain Name System: It stores and associates many types of information with 
domain names and it translates domain names (computer hostnames) to IP 
addresses.

driver
Program which informs the operating system of the presence and characteristics of 
a peripheral.

F

FactoryCast HMI
Active Web server that executes HMI functions integrated in a PLC module. When 
you use the active Web server, you do not need to communicate via polling to 
update the HMI/SCADA database.

FDR
Faulty Device Replacement: Automatic configuration recovery service provided by 
the module. 

firewall
Information technology (IT) security device which is configured to permit, deny or 
proxy data connections set and configured by the organization’s security policy.

Flash memory
Form of non-volatile computer memory that can be electrically erased and 
reprogrammed. 

FTP/TFTP
File Transfer Protocol/Trivial File Transfer Protocol: Network file transfer 
protocol.

G

GPRS
General Packet Radio Service: A radio technology for GSM networks that adds 
packet-switching protocols and shorter set-up time for ISP connections.
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H

HMI
Human Machine Interface: The aggregate of means by which people (the users) 
interact with a particular machine, device, computer program or other complex tool 
(the system).

HTML
HyperText Markup Language: the predominant markup language for the creation 
of web pages. It provides a means to describe the structure of text-based 
information in a document and to supplement that text with interactive forms, 
embedded images, and other objects.

HTTP
HyperText Transfer Protocol: Network transfer protocol for documents written in 
hypertext (links).

I

IP
Internet Protocol: Data-oriented protocol used for communicating data across a 
packet-switched internetwork (i.e. the Internet).

IP Address
Unique address that devices use in order to identify and communicate with each 
other on a computer network utilizing the Internet Protocol standard (IP)—in simpler 
terms, a computer address.

ISO
International Standards Organization. Formats, symbols, transmission rules are 
covered by ISO standards. AFNOR is a member of ISO.

ISP
Internet Service Provider: Business or organization that sells to consumers access 
to the Internet and related services.
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M

MIB
Management Information Base: Database used by the SNMP protocol for network 
management and containing information on data transmission, station or router 
components, etc.

MIB II: standard MIB
Schneider Automation MIB: private MIB

N

NAT
Network Address Translation: is the translation of an Internet Protocol address (IP 
address) used within one network to a different IP address known within another 
network.

NTP
Network Time Protocol: Protocol for synchronizing the clocks of computer systems 
over packet-switched, variable-latency data networks.

O

operating mode
The rules governing the behavior of the module when it is running.

P

PAP
Password Authentication Protocol: Password identification protocol used for 
remote modem connections.

PL7
Schneider Automation PLC programming software.
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PLC
Programmable Logic Controller: It is a small computer used for automation of 
industrial processes, such as control of machinery on factory assembly lines.

PPP
Point-to-Point Protocol: Point-to-point communication protocol used for modem 
connections.

Premium
Family of Schneider Automation PLCs.

PSTN/RTC
Public Switched Telephone Network: The network of the world’s public circuit-
switched telephone networks.

Q

Quantum
Family of Schneider Automation PLCs.

R

RGB
Additive model in which red, green, and blue (often used in additive light models) are 
combined in various ways to reproduce other colors.

RS232
Serial communication standard that in particular defines the following operating 
voltage:

A signal of +3 to +25V indicates a logic 0

A signal of -3V to -25V indicates a logic 1

Between +3V and -3V the signal is regarded as invalid.

RS 232 connections are relatively sensitive to interference. The standard 
recommends not exceeding a distance of 15 meters and a speed of 20,000 baud 
(bps) maximum.
122 EIO0000000819 01/2012



Glossary
RS485
Serial connection standard operates at +/-5V differential. The connection uses 
separate wires for transmission and receipt. Their "3-status" outputs allow them to 
switch to listening mode when transmission is completed.

RTU
Remote Terminal Unit.

RUN
Function used to start execution of the application program in the PLC.

S

SCADA
Supervisory Control And Data Acquisition: Software that, interfacing with a 
programmable logic controller, gathers and analyzes information used to monitor 
and control commercial equipment.

SMTP
Simple Mail Transfer Protocol: Application protocol used to transmit messages via 
the Internet and direct them to a mailbox.

SNMP
Simple Network Management Protocol: Network management protocol for 
controlling a network remotely by polling the stations for their status and modifying 
their configuration, performing security tests and viewing information relating to data 
transmission. It can also be used to manage software and databases remotely.

SQL
Structured Query Language: Used to query (request data from) a relational 
database.

T

TCP
Transmission Control Protocol: Virtual circuit protocol that is one of the core 
protocols of the Internet protocol suite, often simply referred to as TCP/IP.
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TCP/IP
The set of communications protocols that implement the protocol stack on which the 
Internet and many commercial networks run.

Time Out
Expiry of a waiting time. Stops the application or disconnects after a lengthy period 
of non-use.

U

UDP
User Datagram Protocol: One of the core protocols of the Internet protocol suite. 
Using UDP, programs on networked computers can send short messages 
sometimes known as datagrams to one another.

URL
Uniform Resource Locator: The global address of documents and other resources 
on the World Wide Web.

V

VPN
Virtual Private Network: A private network that is configured within a public 
network. It uses encryption and other security mechanisms so that only authorized 
users can access the network and that the data cannot be intercepted.

X

XML
Extensible Markup Language: it is aimed to facilitate the sharing of data across 
different information system. It is a simplified subset of the SGML and is designed 
to be relatively human-legible.
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CBA
Index
A
automatic input, 60

D
Data Editor

spreadsheet, 85
symbol, 88
templates, 84
variable, 85, 88

data templates, 84
datalogging service, 65
direct addresses, 90

E
email service

configuration, 75
example

see (getting started), 17
export, 41
external tool

configuration, 93

F
format target, 100
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G
getting started, 17

accessing the website, 31
configuring the module, 21
creating a new project, 19
Data Editor, 25
presentation, 18
selecting devices, 20
selecting variables, 23
transferring a project, 28

H
HMI services

presentation, 64

I
import, 41

synchronization, 59
installation, 12
introduction, 10
IP address, 44

M
module

connecting/disconnecting, 52
FTP, 48
IP address, 44
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N
namespace, 56

write access, 61

O
online documentation, 48

P
password, 106

configuration, 107
HTTP, 107
write, 107

PC configuration, 11
presentation, 10
project

add devices, 36
add targets, 34
close, 40
device list, 37
global transfer, 48
open, 40
partial transfer, 48
remove devices, 37
remove items, 39
remove targets, 35
save, 40
target list, 35
transfer, 45
validation, 49

R
reboot target, 99

S
security

access, 105
Security

access, 102
firewall, 103
passwords, 102
126
service
creation, 38

site explorer, 48
SMS service

configuration, 75
symbol

 name, 56
import from PLC, 57
manual selection, 60

synchronization, 59

T
transfer status, 50

V
variable

import from PLC, 57
manual selection, 60
name, 56
Unity Pro, 59

W
Web Designer

close, 40
Workspace directory, 97
write

password, 107
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