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1. Introduction 

Zaref zLearn Teacher is an application that allows the user (the teacher) to connect with Zaref zLearn 

Student through wireless or wired Ethernet networks. You can see students registered for your class, 

create and send multiple choice questions in the form of a quiz, questionnaire or poll, receive responses 

from students and view response analysis by student and question.  
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1.1 Prerequisites 

In order for you to fully understand the user manual you are first required to read and understand the 

document ‘zLearn System Overview’ that details basic hardware, software and system requirements. 

For the zLearn system to work properly the device upon which the Teacher Application is installed must 

be connected to a network via some interface card. This may be either a LAN interface or WiFi interface. 

Once the machine is connected the Teacher Application can be started. When the Teacher Application is 

started there is no default session. For any further step to be successfully taken a session must be 

opened. If you have no pre-saved session then you should open a new session. If you have saved the 

responses of a session then this session can’t be used again to run the quiz. You have the option of 

cloning this session which will create a new session similar to the original but without the responses. The 

Teacher Application requires a license to operate fully with all features. If you have now installed the 

Teacher Application or have not licensed it as yet it will run in Demonstration mode only. 

 

Figure 1.1 A 

Demonstration mode only allows the user to open the default demonstration session with its existing 

questions. These questions cannot be deleted or modified in demonstration mode. No new questions 
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can be added to the demonstration session. You will be able to allow students to connect and 

administer this quiz to them. However their responses cannot be saved in demonstration mode.  
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1.2 Navigation 

The Teacher Application is divided into six “views” (explained in detail later in the document) which are: 

1. Session View  

2. Students View 

3. Session Questions View 

4. Manage Session Questions View 

5. Responses View 

6. Result Analysis View 

Navigation through the system will be done via the View Menu which will have links to all views except 

the one which you are currently on. 
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1.3 Installing zLearn Teacher 

1. Insert the install CD you purchased into your CD/DVD drive.  

2. Open the folder containing the installer package. 

3. Double click on the .msi icon that will launch the installation process. 

4. Follow the onscreen instructions to complete the installation process.  

The Install Wizard will guide you through the installation process. Selecting the default folder for 

installation is recommended. 

 

Figure 1.3 A  
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1.4 Starting zLearn Teacher 

Once installation is complete; click on the ‘Start’ button on the Windows desktop taskbar and go to 

‘Programs’. Click on ‘Zaref Engineering’ and this will show the ‘Zaref zLearn Teacher’ button. Clicking on 

this launches the application. 

 

Figure 1.4 A 
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A splash screen appears while the Teacher Application is loading.  

 

Figure 1.4 B 

A tray icon showing a black hummingbird will also appear. Right clicking on this icon allows you to 

manipulate the application in much the same way you would from the user interface.  

 

Figure 1.4 C 

Right-clicking on the tray icon allows you to navigate the application.  

 

Figure 1.4 D 

The view shown once the Teacher Application has launched will be the Session View. If you have not yet 

requested a license for your application you will notice that you can only open sessions and you cannot 

create new sessions. There is a ‘Demo Session’ that you can use without requesting a license.  

  

zLearn tray icon  
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1.5 Requesting a License 

 

 
Figure 1.5 A 

 

a. Go to the menu bar on the application and click on ‘Tools -> License -> Request License’. This prompts 

you to enter a valid email address. It is important that you enter the same email address you used on 

Zaref Engineering’s website when ordering Zaref zLearn Teacher. This makes it easier to verify the 

validity of your license request and track future issues.  

b. Once your request for a license is received you will receive a reply with an attachment containing a 

license file. Download and save this license file to your computer.  
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1.6 Installing a License 

 

 
Figure 1.6 A 

 

Open the teacher application and click on ‘Tools -> License -> Install License’. Navigate to the folder on 

your computer where you have the license file saved. Double click on it to install it. Once the license has 

been installed you will be able to create your own sessions and add questions to the application’s 

database. 

 

 
Figure 1.6 B 
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2. Session View 

The session view is the first screen that interfaces with the user at start up of the Teacher Application.  

In this view the user can create a new session or open an existing one. The user can navigate to the 

other views, once a session is loaded. The user can view the network address, configure the network 

ports or change the color scheme of the application. The user can also launch the session quiz from this 

view. However a session must be open for these actions to take place. The actions that are available at 

the point in time will be displayed in normal text while those that are unavailable will be grayed out or 

disabled. These options are dependent on whether a session is loaded or not. 

 

Figure 2 A 
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2.1 Opening a New Session 

A new session can be created for a given time and class. Sessions can be saved to show the results for 

that session only and is therefore unique. The session can be cloned but this will only create a replica of 

the quiz and questions and not the responses so that the session can be used for another class at 

another time and saved with different results.  

Click on ‘Session -> New Session’ 

 

 
Figure 2.1 A 

Enter Session information in fields 

 

 
Figure 2.1 B 
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The session can be saved at this point by clicking on ‘Session -> Save Session’ or you can continue to 

create questions for the session quiz. 

 

 

 
Figure 2.1 C 
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2.2 Opening an Existing Session 

You can open an existing session for use. However, if this session contains results you will not be able to 

administer the quiz. Instead you will need to clone the session and use this to collect new results.  

 

Click on ‘Session -> Open Session’ 

 

 
Figure 2.2 A 

 

Navigate to the session folder stored in ‘C:\zLearn -> Database -> Session’. Open a session of your choice 

by double clicking on the session.  

 

 
Figure 2.2 B 

 

You can now proceed to administer the quiz in this session or make further modifications to the session 

for use at a later time.   
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2.3 Cloning an Existing Session 

A session can be cloned if the existing quiz questions found within that session are suitable for reuse. 

Once the session is cloned it is now saved as a separate session and you will need to enter new session 

information.  

Click on ‘Session -> Clone Session’ 

 

Figure 2.3 A 

A new session is created with the same quiz questions and the session fields for ‘Session Information’ 

are now blank.  

 

Figure 2.3 B 
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Fill in the fields for the Session Information with new data 

 

Figure 2.3 C 
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2.4 Saving a Session 

A session can be saved by clicking on ‘Session -> Save Session’. This automatically prompts the user to 

save the session in the default program database folder.  

 

Click on ‘Session -> Save Session’ 

 

 
Figure 2.4 A 

 

A notification pops up once the session is saved.  

 

 
Figure 2.4 B 
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The saved session now shows the Session Information fields to be disabled. 

 

 
Figure 2.4 C 

 

  



21 | P a g e  

 

3. Student View 

The Student view is available for the Teacher to monitor the connection of the Student Applications. 

Once the Student Application has registered with the Teacher Application the Student will always be on 

the list for the duration of the Session.  

 

Figure 3 A 
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3.1 Viewing Connected Students 

If the Student is connected then there will be a green dot under the connected column. If the student is 

disconnected there will be a red dot under the connected column. When the student is selected by 

clicking on the row containing the student information, the information is displayed in the appropriate 

fields under the section ‘Student Information’. 

Green dots show that students are connected.  

 

 
Figure 3.1 A 

 

Selected student information is shown when a row is highlighted.   

 

 
Figure 3.1 B 
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A red dot show that one student is disconnected.  

 

 
Figure 3.1 C 
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4. Session Questions View 

The Session Question View allows the Teacher to create new questions as well as edit existing ones. This 

functionality is not allowed in Demonstration Mode. The Teacher can launch the session quiz from this 

location. A timer showing the current quiz time will be shown to the top of this interface. 

 

Figure 4 A 

The Demonstration mode quiz can be launched from here by clicking on ‘Quiz -> Make Available’.  

Timer 
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4.1 Creating a new Question 

You can create new questions that will be saved automatically as part of your current quiz and in the 

database. Click on ‘Question -> New’ and this allows you to start editing fields.  

 

Click on ‘Question -> New’ 

 

 
Figure 4.1 A 

 

Fields are now available for editing.  

 

 
Figure 4.1 B 
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Type in a title for the question, the question and select the number of options for responses. This 

creates the appropriate number of answer fields. Enter answers in each field and click on the checkbox 

next to the correct response. This allows the program to automatically correct the quiz for you.  

 

A question is created.  

 

 
Figure 4.1 C 

 

Clicking on ‘Save’ at the bottom results in the question appearing on the left in the current Quiz 

Questions. Continue creating new questions to complete your quiz.   

 

 
Figure 4.1 D 
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4.2 Editing an Existing Question 

You can edit existing questions that will be saved automatically as part of your current quiz and in the 

database. Highlight the question you wish to edit and then click on ‘Question -> Edit’ and this allows you 

to start editing fields.  

 

Click on ‘Question -> Edit’ 

 

 
Figure 4.2 A 

 

Fields are now available for editing.  

 

 
Figure 4.2 B 
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The edited question is saved and fields are now disabled.  

 

 
Figure 4.2 C 
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4.3 Deleting a Question 

You can delete existing questions from a quiz but these questions will still be contained in the database. 

Highlight the question to be deleted and click on ‘Question -> Delete’ and this result in a deleted 

question.  

 

Click on ‘Question -> Delete’ 

 

 
Figure 4.3 A 

 

The question was deleted.  

 

 
Figure 4.3 B 
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4.4 Starting the Session Quiz 

You can make the entire quiz created available to students by clicking on ‘Quiz -> Make Available’. The 

students will only receive this quiz if they are connected to the network.  

 

The quiz is broadcasted to all connected students. 

 

 
Figure 4.4 A 

 

The timer counts down the time remaining for the quiz 

 

 
Figure 4.4 B 
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4.5 Recalling Quiz 

The quiz can be recalled at any time from the students during the running of the quiz by clicking on ‘Quiz 

-> Recall Quiz’. 

 

The quiz is recalled from the students.  

 

 
Figure 4.5 A 

 

The quiz timer resets once the quiz is recalled.  

 

 
Figure 4.5 B 
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5. Manage Session Questions View 

The Manage Session Question View can be used by the Teacher to add existing questions from the 

question database to the Session Quiz or to remove questions from the Session Quiz. This view allows a 

preview of question selected from the Database to the left and a preview of questions selected from the 

Session Quiz to the right. Every time questions are created for different sessions all of the quiz questions 

are saved automatically in the Questions Database. Questions cannot be deleted from this database and 

are always there for future use.   

 

Figure 5 A 
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5.1 Adding a Question from the Database 

A question can be added to the current quiz by selecting from the stored set of questions in the 

database. Highlight a question in the database by clicking on it and click on ‘Transfer -> Question’ in the 

menu bar and the selected question will be moved to the current quiz.  

 

Click on ‘Transfer -> Question’ 

 

 
Figure 5.1 A 

 

Transferred questions become part of the current quiz. 

 

 
Figure 5.1 B 
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5.2 Removing a Question from the Quiz 

A question can be removed from the current quiz by selecting from the set of questions in the quiz. 

Highlight a question in the quiz by clicking on it and click on ‘Remove -> Quiz Question’ in the menu bar 

and the selected question will be removed from the current quiz.  

 

Click on ‘Remove -> Quiz Question’ 

 

 
Figure 5.2 A 

 

Although questions are removed from the quiz they are still part of the database.   

 

Figure 5.2 B 
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6. Responses View 

The Responses View can be used by the Teacher to view the responses submitted within the Session. 

These responses can be sorted by Question answered or by the Student submission. The responses are 

automatically corrected and are indicated by a green ‘�’ for correct or a red ‘X’ for incorrect in the 

appropriate column of the response table. This view also gives time statistics which include minimum, 

maximum, mean and standard deviation times. These statistics are based on the selection available in 

the response table. 

If nothing is selected in the ‘Questions in this Session’ and ‘Students in this Session’ fields then all results 

are shown for all questions and for all students. 

 
Figure 6 A 
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When filtering by questions all the responses to the selected question will be displayed in the responses 

table. You can filter by questions by selecting an appropriate question in the drop-down field for 

‘Questions in this Session’. 

 

Results for all students for ‘Question 1’ including time statistics for Question 1.  

 

 
Figure 6 B 

 

Results for all students for ‘Question 2’ including time statistics for Question 2.  

 

 
Figure 6 C 
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When filtered by Student all the responses submitted by the selected student will be displayed in the 

response table. You can filter by students by selecting an appropriate student name in the drop-down 

field for ‘Students in this Session’. 

 

All responses for the student ‘John Doe’ including time statistics for this student 

 

 
Figure 6 D 
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7. Result Analysis View 

The Results Analysis View offers the Teacher a graphical display of the responses via question by 

question analysis. The graphical displays to choose from are Bar and Pie charts. The bar chart lays out 

the number of responses for each option of the question. It also gives the number of responses that 

were blank. This is indicated on the x-axis in the column ‘N.A’ (No Answer). The pie chart gives the 

percentage of correct responses against the number of incorrect responses. The correct answer 

representation is given in green while the incorrect answer representation is given in red for both 

graphics. 

Bar Chart View of responses for Question 1 for all students.  

 

 
Figure 7 A 
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Bar Chart View of responses for Question 2 for all students 

 

 
Figure 7 B 

 

Bar Chart View of responses for Question 3 for all students 

 

 
Figure 7 C 
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Bar Chart View of responses for Question 8 for all students 

 

 
Figure 7 D 

 

Pie Chart View of responses for Question 8 for all students 

 

 
Figure 7 E 
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8. Getting Network Address 

Student applications will automatically connect to the running teacher application that has an active 

session open. If however, there are more than one running teacher applications within range of the 

student applications the students will be prompted to enter the network address for the correct teacher 

application. In this case the teacher will have to get their network address and notify the students so 

that they can connect to the correct teacher application.   

 

Click on ‘Tools -> Network -> Get Network Address’  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 8 A 
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A pop-up box notifies the teacher of the network address. This address is announced to the students. 

 

 
Figure 8 B 
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9. Configuring Network Ports (Optional – Advanced Users Only) 

The Teacher Application requires the use of several network ports for communication. These ports need 

to be open ports on the network that are not blocked by any firewall or used by any other application. If 

you network does not have any firewall and the defaults ports 4445, 4446, 4447 and 4448 are not used 

then there is no need to configure the ports of the Teacher Application. 

To configure the ports you go to Tool -> Network -> Configure Ports as shown below. 

 
Figure 9 A 
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The popup screen shown below will appear. Type in the relevant port numbers selecting numbers from 

the range 0-65535. However, it is advisable to try to use numbers in the upper range.  

 

 
Figure 9 B 

 

Click on configure to set these port numbers, ensuring that there are different numbers for all the ports. 
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10. Configuring Color Scheme 

There are three default color schemes that can be used to customize the look of the teacher application; 

Plain, Earth and Carri Blue.   

 

To configure the Plain color scheme select ‘Tools -> Color Scheme -> Plain’ 

 

 
Figure 10 A 

 

The Plain color scheme.  
 

 
Figure 10 B 
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To configure the Earth color scheme select ‘Tools -> Color Scheme -> Earth’ 

 

 
Figure 10 C 

 

The Earth color scheme.  
 

 
Figure 10 D 
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To configure the Carri Blue color scheme select ‘Tools -> Color Scheme -> Carri Blue’ 

 

 
Figure 10 E 

 

The Carri Blue color scheme. 

 

 
Figure 10 F 
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10. 1 Configuring Color Scheme – Custom 

A custom color scheme can be created for a particular session. However, while this color scheme can be 

applied for that session, it cannot be saved.   

 

To configure a custom color scheme select ‘Tools -> Color Scheme -> Custom’ 

 

 
Figure 10.1 A 

 

Selecting a background color changes the outermost layer of the application.  

 

 
Figure 10.1 B 
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The background color has been changed to green.  

 

 
Figure 10.1 C 

 

Selecting a panel color changes the innermost layer of the application and selecting the border color 

changes the middle layer of the application.  

 

 
Figure 10.1 D 
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The panel color has been changed to mint green and the border color has been changed to olive green.   

 

 
Figure 10.1 E 

 

Clicking on ‘Apply this Color Scheme’ changes the application’s color scheme.   

 

 
Figure 10.1 F 

 

 

 

 

 


