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1. Introduction to Siebel 

1.1 System Requirements 
•  Windows 95/98/NT 
•  Microsoft IE 4+ or Netscape Navigator/Communicator 4+, with 40bit encryption 

minimum 
•  Internet connection with bandwidth of no less than 56KB 
•  Minimum resolution of 800x600 – 1024x768 preferred 

 
1.2 Special System Functionality 

•  The application is delivered using MS TSE & Citrix Metaframe, which is a host-
based application, with the display rendered back to your local PC. 

•  The application automatically maps the server C: drive to your local C: drive, to 
allow you to save files locally. 

•  The application attempts to map a server printer your local default printer, to allow 
you to print reports to your local printer.  This is currently not thoroughly tested and 
may not function.  What is clear is that your local default printer driver must be 
available on the server.  To make certain, send an email with the attached driver 
files to HelpDesk@efi.com 

•  Cut and paste is available between your local PC and the Siebel application. 
 

1.3 How to Connect 
•  Launch web browser 
•  Go to: https://portal.efi.com/defect 
•  Follow instructions from the web page. 

.  
1.4 Login screen 

 
 

The EFI Siebel system login screen will appear.   
    

•  Enter your login 
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•  Enter your password 
•  Click [OK]. 
 

 
The EFI Siebel System application opens. 

 

  
 

 
1.5 Changing Primary Position (NOTE: Use this option ONLY if you belong to multiple 

positions) 
 

•  Select Edit -> Change Position from the Menu Bar 
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2. Basic System Navigation  
 

2.1 Menu Bar: 
Like all other GUI applications, the Siebel user interface shows a menu bar at the top. 
Use this menu bar to choose any of the application commands.  

 
 
Many of the commands in the menu bar are also available in other parts of the application. 
The two most common alternatives are: 
 
Right clicking, which brings up a shortcut menu of commands. 
 
 As with other Windows applications, the exact menu that appears depends on where you 
right-click. For example, right clicking inside a form applet brings up the commands New 
Record, Copy Record, and Delete Record. 

  
On the other hand, right-clicking inside a field on a form applet also brings up Copy, 
Paste, and Select All because these commands make sense in that context. 

 
Using the various shortcut bars. 

  
These include the toolbar, the tab bar, and the view bar. 

 
2.2 Tool Bar: 

As with other Windows applications, the toolbar gives you quick access to the most 
commonly used commands: clicking a button on the toolbar is equivalent to choosing a 
command from a menu in the menu bar. 
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a) Working with Records 0 
A group of related pieces of information is called a record. For example, all the 
information about a defect —including the defect ID, product, problem area etc…— 
make up a Defect record. 
 
When you use Siebel applications to add new information or retrieve existing 
information, you’re working with records. You can add, insert, copy and delete a 
record using tool bar icons. 

 
b) Moving from Record to Record 0 

When you’re looking at a list of records, the row pointer (>) shows which record is 
active—the one you intend to act on. For example, when you choose the Copy Record 
command, it’s the active record that will be copied. If you want to move to the next 
record in the list, you can also use the Next Record button on the toolbar or use the 
DOWN ARROW key on your keyboard. 

 
c) Searching for Information Using the FIND Command 0 

Moving from record to record is easy; however, if you have hundreds of records, 
looking at every single one can be a time-consuming way to find exactly what you’re 
looking for. A faster way to find information is through the Find command. 
NOTE: Your Find dialog box may have different items in the two columns, depending 
on which application you’re using. 

 
d) Searching for Information Using ‘Query by Example’ 

Another way to find information is through queries, or query by example. In a query 
by example (sometimes called QBE), you provide what you already know to find out 
what you don’t. Performing a query by example is a two-step process: 
 

•  Entering the query—starting the query and specifying your search criteria 

•  Executing the query—telling the application to find all records that match your search 
criteria 
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After you enter your search criteria, click the Execute Query button to see the query 
results. You can also execute your query by simply pressing ENTER.  After you’ve 
run a query, you can sort its results so they appear in order with respect to any of the 
fields. For example, you can sort alphabetically on a particular text field or in 

chronological order on a particular date field. You can also see the items sorted in 
either ascending or descending order. 
 
Once you’ve run a query, you can save it if you expect to use the same search criteria 
later.   

 
e) Saving Your Changes 0 

There is no Save command anywhere in Siebel applications because each application 
saves your changes as you go along. Each time you leave a record (by clicking 
anywhere outside of it), your work is saved. 

 
f) Correcting Mistakes 0 

If you make a mistake as you work with records or queries, you can click the Undo 
Change button. The Undo button is particularly useful if you accidentally press a key 
and don’t know what you did. If you want to undo all your changes to a record (rather 
than just the most recent), choose the Undo Record command from the Edit menu. 
This command undoes any changes you made since the last save—that is, since you 
last left a record. 

 
2.3 Tab Bar: 

  0 

A Siebel application consists of screens, views, and applets. The tab bar contains the 
names of the most commonly used screens. 

 
 

2.4 View Bar: 
 

It is on the left-hand side of the window, displays a view associated to a screen. The 
name of the active screen appears as the highlighted tab and at the top of the view bar. 
The highlighted item on the view bar is the active view. 
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2.5 Message Bar and Status Bar: 
0 

At the very bottom of the application window are two bars that display information. 
Thread Bar tracks current path through views. Use thread buttons or forward and back 
arrows to navigate through threads. 
Status Bar displays the information about the fields and records. 

 
History tracks previous view/record navigation including previous sessions. Most recent 
view/record appears at top of list. 

 
 

2.6 Customizing User Options: 
 

•  Select  View -> Option from the menu,  you can set 
- Color scheme and appearance (Appearance tab) 
- Number of threads saved (General tab) 
- Start-up screen and default query for each view (Screen tab) 
- Message Bar specifications. (Message Broadcasting tab) 
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2.7 Unavailable functions 
 

Please DO NOT USE the following functions from the File Menu: 
•  Send E-mail 
•  Send Fax 
•  Send Page 
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3. Queries 
 

Siebel uses query by example (QBE) method of forming queries by entering conditions in 
the blank fields of records displayed by the database program.  Queried records are 
displayed in the list applet. 

 
Types of Queries 
 
i. Public queries defined by an administrator. 
ii. User defined private queries where you can set the criteria. 
 
•  You can … 

- Use existing public queries. 
- Create new private queries. 
- Refine public and private queries. 
- Save new and refined Queries. 
- Delete private queries. 

 
•  Administrators can change private queries to public queries. 
 

For example, Users can use queries to find a group of product defects and their 
statuses. 

 
 

3.1 Predefined Public Query. 
 

•  Predefined Public queries appear in the Queries drop down list on upper right hand 
top corner of the screen. If there is none, that means that there is no Predefined 
Public query. 

 
 
•  The list of queries in the Queries drop down list changes when the view changed.  
•  You cannot delete a predefined public query, but you can refine and save it as a new 

private query as needed. 
 
 

3.2 User Defined Query. 
•  You can create both simple and compound queries. 
•  A simple query finds information based on one condition.  
•  Compound queries find information based on two or more conditions. 
•  You can save, refine, rename, and delete your own query. 

 



EFI Siebel System – OEM Manual 

Page 11  

Steps to create and execute a User Defined Query 
 

•  Navigate to the desired view query on 
For example OEM Defect  screen -> My Group’s Defect View 

•  Select Query -> New Query from the menu bar  OR  
            Press CTRL + Q   OR                                                 

             Click on the Left Magnifying Glass  

 
 

•  Put in your query/search criteria into the fields 
NOTE:  
- Wildcard symbols(‘*’) can be used.  

� For example, in the Short Description or Steps to Reproduce, user can 
enter ‘Print*’ as criteria. 

- Single literal values  
- For checkbox, a check mark represents TRUE. 
- Operator in the ‘Operator table’ below can be used.  

� For example, in the Status field, users can enter ‘Open’ or ‘For OEM 
Verify’ into the STATUS field to find all the Open or For OEM Verify 
defects. 
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•  Press ENTER OR select Query -> Execute Query OR click the right magnifying 

glass from the menu bar to run the query. 
 

3.3 Refining a Query 
•  You can refine predefined public Queries or user defined queries.  
•  To Refine a Query, select the Query and add additional criteria. 
•  Then save that Refined Query as another name. 

 
3.5 Saving a Query 

•  To save a Query, select Query -> Save Query As or  Ctrl + S. 
•  Enter the name of the Query in the dialog box and say OK. 
•  You can see your Query in Queries list box on right hand top corner of the screen. 

 
3.6 Deleting a Query 

•  You can delete User defined Private Queries. 
•  To delete a private Query select Query -> Delete Query. 
•  A dialog box is displayed, with all the Queries. 
•  From the list select the Query you want to delete. 
•  Just by clicking OK button, selected Query can be deleted.  
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•  Once you delete a query, it will disappear from the Queries drop-down list, and you 
cannot recover it. 

 
3.7 Sorting a Query 

•  You can sort the output of a query. 
•  For sorting  choose Query -> Sort Order 
•  It takes you to a new window where you can set sort preferences depending on your 

requirement, Click OK button to see the results.  
 

 
 

3.8 Export to Output File 
      

•  You can export the output of a query to the following format: 
- HTML 
- Tab delimited text file 
- CSV formats (MS Excel readable format) 

                         
•  To export the query result set, click on the ‘OEM Product Defect List applet’ (the 

applet at the lower bottom), then select File -> Export 
- Select data and columns to export 
- Select file type 
- Specify path and name of file 
- Open automatically on export (if desired) 
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4. Product Defects 
 

OEMs users can submit defect against a product/project using the ‘My Defects’ and ‘My 
Group’s Defects’ views.  

 
 
 
To access the Defect views, users can select the OEM Defect screen/tab or select ‘Screen’ 
from the menu bar, then select ‘OEM Defects’, then select the different views. 
 
Using the Defect views from the OEM Defect screen/tab, users do the following: 

 
•  Create, view, and manage Defect information (My Defect view and My Group’s Defects 

view) 
•  View defects that are ‘Reported By’ OR ‘Assigned to’ you (the login person) (My Defects 

view) 
•  Create and view the activities/comments associated with a defect (OEM Activities view) 
•  Attach file attachments to a defect or view attachments (OEM Attachment view) 
•  Attach ‘pre-existing’ solutions in the database to a defect (OEM Solutions view) 
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4.1 How to create a “NEW” Product Defect 
 

a) Select the OEM Defect Screen/tab or select ‘Screen’ from the menu bar, then select 
‘OEM Defects’ 

b) Select the ‘My Defects’ or ‘My Group’s Defects’ view. Click on the [New] button. The 
following view will appear. 

 
 

c) Default values (like Defect #, Reported By, Channel, Reported, Status) will be populated.  
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d) Click on the Product field, a Multi Value Group (MVG) applet appears.  
� Click the New button inside the MVG applet to launch the pick applet that will allow 

you to select/add the Product to be associated to the defect.  

 
 

 
� Users can find products by selecting the appropriate product table fields in the [Find] 

picklist and then put in the criteria in the [starting with] field (Note: Wildcards * can 
be used. For example, *oem_name* ) 

� Click [Add] 
� Click [Close] 

 
e) Add all the required fields (fields prefix with *) using the pick lists  

� *Problem area 
� *Defect Type 
� *Priority 
� *Severity 
� *Short Description 
� *Steps to Reproduce (this field should be used only for information on how to  

reproduce the defect) 
� *OEM Id (Id OEM used to their defects) 

f) Enter all other fields (as needed) into the Product Defect record. 
g) The defect will automatically be saved if you leave the defect record.  
h) To copy an existing defect, click on the [Copy] button to copy from any existing record. 
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i) If OEM users would like to add Comments and Notes to communicate with others, click 
on the ‘OEM Activities’ view. The following view will appear. 

 
 

 
OEM users can enter in their comments and notes by right-mouse clicking on the OEM 
Activity list applet (the bottom applet) will appear (like above). The following will 
appear. 
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Select ‘New Record’, the new activity record of ‘OEM Note’ activity type will appear. 

 
OEM user can enter information into the [Comments] fields. To save the activities, just 
leave the record. 
 
Different Activity types 
 
OEM will also be able to see activities with the following activity types: 
•  Comments/Notes  

- Activities of EFI public comment/notes.  
•  Contd Short Desc 

- In order to accommodate the conversion of Scopus Bug and Case information into 
the Siebel database, some changes were necessary.  The data in Scopus is much 
longer than Siebel's Short Description (100 characters limit) and Steps to 
Reproduce fields (800 characters limit).  Therefore, for all Scopus Bugs and Cases 
that exceed these limits, activity record(s) will be created to store "overflow" of 
this data.  For example, if the Scopus Bug has 1500 characters in the ‘Short 
Description’ field, then the 1st 100 characters will be populated into the Siebel 
‘Short Description’ field, the remaining characters will be stored as an activity 
with the activity Type = "Contd Short Desc". 

•  Contd Steps to Reproduce 
- See explanation above in ‘Contd Short Desc’ 

•  Email-Outbound 
- When an email is manually sent or automatically sent by the Workflow manager, 

an activity of ‘Email-Outbound’ will be automatically created. 
•  OEM Note 
- Activities where OEM users enter their comments and notes and also where EFI 

users use to communicate with OEM. 
•  Status Change  

- Audit trail information. An ‘Status Change’ activity is automatically populated 
when status changes. 
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j) If it is necessary to add attachments to the Product Defect, click on the to the ‘OEM  

Attachments’ view.  
 

 
 

If there are existing related attachments, the list of attachments will appear in the bottom 
list applet. Users can create or modify any attachment(s) for a defect. To add an 
attachment, right-click in the OEM Attachments list applet.  Select ‘New Record’ from 
the  

 
 
A popup window with all directory listings is displayed.  Browse the directories to find 
your document, select the document, then clicking the “Select” button.  The file will 
automatically be attached to the Product Defect and saved on the Siebel file server. Other 
users will be able to access that file afterwards.  
 
NOTE: Attached file size limit is 5MB per file. 
 



EFI Siebel System – OEM Manual 

Page 21  

Besides attaching the file to the Siebel file server, users can also put in the URL or ftp 
into the [URL] field to point to any Internet URLs or FTP sites. For example, URL like 
http://www.efi.com OR ftp like ftp://ftp.efi.com/sample.exe. 
 
NOTE: Please DO NOT CHECK the [Link to file] checkbox. 
 
 

 
 
 

k) Sending Email or Fax or Page from the application is NOT AVAILABLE.  
 

Please DO NOT USE File menu -> Send E-Mail or Send Fax or Send Page. 
 

 
4.2 Defect Verification by OEM QA 
 

OEM QA verifies the defects that are assigned back to them by EFI QA.  
a) From My Defect view, the OEM users can query on the defects that are ‘Open’ or ‘For 

OEM Verify’ defects that is assigned to you or use the predefined ‘My Pending Defects’ 
query. 

b) If the defect is verified, change the ‘Status’ field to ‘Closed’. 
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4.3 Defect Solutions 
 

OEM user can see Defect solutions for a defect (if available) by selecting ‘OEM Solution’ 
view. 
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5. Reporting 
A 

To run defect reports, do the following: 
a) Select any Defect views 
b) To narrow/filter your report result set, put in your report criteria, and then executes the 

query before running the report. The report displays the data in the same order as they are 
displayed in the view.  
� To resolve “no data is available for the report” error, you need to refresh and re-

query before running a report.  
c) Select the defect report from the ‘Reports’ menu.  
 

The following defect reports are available: 
- Product Defect Activity (OEM) 
- Product Defect Summary (OEM) 
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d) The report will appear in the Siebel report viewer. 

 

 
 

e) You can save a formatted report in a .ROI (report instance) file. Certain reports may also 
be saved as HTML files. 

 
 

6. Support 
 
- For problems and questions, please contact your EFI contact. 

  


