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Serendipi ty Blackmagic Quick Start  Guide 
 
This booklet contains information on the basic installation, set up and configuration of the Serendipity 
Blackmagic software. 
 
For complete instructions and comprehensive calibration information refer to the User Manual included on 
the installation DVD, or available for download from the Serendipity Software website. 
 
 
Serendipity Software Website: www.serendipity-software.com.au 
 
Serendipity Software Knowledge Base: skb.serendipity-software.com.au 
 
Serendipity Software Technical Support: support@serendipity-software.com.au 

 
 



© Serendipity Software Pty Ltd. All Rights Reserved.   Web: www.serendipity-software.com.au 4	
  

What’s on the DVD? 
 
The software is supplied on one DVD for Mac OS X, Linux and Windows versions. 
All versions come with a SuperPro USB dongle and require a dongle driver be installed.  
 
 

DVD Contents 
 
Agent - Contains the Agent software for all supported platforms. 

Docs - Contains all documentation including User Manuals and release notes. 

Dongle  - Contains the dongle drivers for Linux, Mac OS X and Windows. 

D rivers - Contains the Megarip PPDs for all supported platforms.  

Extras - Contains additional components and print drivers loaded as part of the install process. 

HTML - Contains the information required for the web browser install. This automatically launches the 
default browser for installation to begin. 

L inux - Contains the Serendipity Blackmagic and AppleTalk installation packages for Linux. 

MacOSX - Contains the Serendipity Blackmagic installation package for Mac OS X. 

Serendipity  C lient - Contains the Serendipity Client and C5 Client for all supported platforms. 

Testprn - Contains Serendipity internal test prints. 

W indows - Contains the Serendipity Blackmagic installation package for Windows. 
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Instal lat ion 
 

Windows Instal lat ion 
Administrator rights are required to install Serendipity Blackmagic and the Serendipity Agent. If upgrading 
from an existing installation, see the Upgrading section within this booklet. 
 
 

Instal l ing the Dongle Driver 
	
  

1. Remove all USB dongles from the computer.  
2. On the installation DVD, navigate to the dongle/windows directory. 
3. Double-click the Sentinel Protect ion Instal ler.exe file to launch the application. 
4. Follow the onscreen instructions to complete the installation. 
5. Restart the computer when finished. 

 
 

Instal l ing Serendipity Blackmagic 
There are two (2) Windows files available - a 32 bit or a 64 bit version. Select the appropriate file for your 
system to install. 
 

1. On the installation DVD, navigate to the Windows folder. 
2. Run the file blackmagic.msi (32 or 64 bit version). 
3. Follow the onscreen instructions to complete the installation. 

 
 

Instal lat ion of the Serendipity Agent 
If you are polling a RIP or RIP folder on a Windows machine, the most efficient method is to use the 
Serendipity Remote Agent. This runs a service on the Windows machine where the RIP is located. 
 

1. On the installation DVD, navigate to the agent/windows directory. 
2. Run the agent32.msi (32 bit) or the agent64.msi (64 bit) file. 
3. Follow the onscreen instructions to complete the installation. 

 
Once the installation has finished, proceed to the “Running the Software” section of this booklet. 

 

 



© Serendipity Software Pty Ltd. All Rights Reserved.   Web: www.serendipity-software.com.au 6	
  

Mac OS X Instal lat ion 
Administrator rights are required to install Serendipity Blackmagic and the Serendipity Agent. If upgrading 
from an existing installation, see the Upgrading section within this booklet. 
 

Instal l ing the Dongle Driver 
	
  

1. Remove all USB dongles from the computer.  
2. On the installation DVD, navigate to the dongle/macosx directory. 
3. Double-click the Sentinel System Driver.pkg file to launch the application. 
4. Follow the onscreen instructions to complete the installation. 
5. Restart the computer when finished. 

 
 

Instal l ing the Serendipity Printer Drivers 
Used when setting up a Published Pagesetup for printing from third party applications like Photoshop. 
 

1. On the installation DVD, navigate to the drivers/mac folder. 
2. Double-click the Serendipity Printer Drivers.pkg file to launch the application. 
3. Follow the onscreen instructions to complete the installation. 

 
 

Instal l ing Serendipity Blackmagic 
	
  

1. On the installation DVD, navigate to the macosx folder. 
2. Double-click the Serendipity Blackmagic.pkg file to launch the application. 
3. Follow the onscreen instructions to complete the installation. 

 
 

Instal l ing the Serendipity Agent 
	
  

1. Select and run the Serendipity Agent.pkg file located in the agent/macosx folder on the DVD. 
2. Follow the onscreen instructions to complete the installation. 

 
Once the installation has finished, proceed to the “Running the Software” section of this booklet. 
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Linux Instal lat ion 
If upgrading from an existing installation, see the Upgrading section within this booklet. 
 

Instal l ing the Dongle Driver 
	
  

1. Remove all USB dongles from the computer.  
2. On the installation DVD, navigate to the dongle/ l inux directory. 
3. Double-click the snt l-sud-7.5.1-0. i386.rpm file to launch the application. 

 
 

Instal l ing Serendipity Blackmagic 
Before installing on a Linux x64 operating system, ensure the following i686 (32 bit) libraries are installed: 
 
libstdc++.i686  GNU Standard C++ Library 
mesa-libGLU.i686 Mesa libGLU runtime library 
zlib.i686  The zlib compression and decompression library 
freetype.i686  A free and portable font rendering engine 
libXrender.i686 X.Org X11 libXrender runtime library 
fontconfig.i686  Font configuration and customisation library 
glib2.i686  A library of handy utility functions 
libpng.i686  A library of functions for manipulating PNG image format files 
libSM.i686  X.Org X11 Sm runtime library 
 
If the package installer cannot locate the libraries open a terminal window, go to the /root directory and 
install each library using the following command: 
 
yum install name of library 

 

Once the libraries are installed: 

1. On the installation DVD, navigate to the l inux folder. 
2. Double-click the instal l .sh file and select Run in Terminal. A terminal window will popup and the 

installer will display the default installation directory. 
3. Press Enter to install or type an alternative path then press Enter. 
4. When the installation is complete the terminal window will close. 

 
Note: If using an alternative path for installation ensure the folder exists and the current user has 
read/write/execute permissions for the folder. 
 
 
Once the installation has finished, proceed to the “Running the Software” section of this booklet. 
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Upgrading 
	
  

Upgrading to Version 5.4  
The following information is relevant for upgrading an existing Serendipity Blackmagic installation to 
Version 5.4. 
 
The installer will automatically upgrade the existing database to the current 5.4 format. As a precaution 
before upgrading it is recommended that the Blackmagic database and ICC profiles are backed up using the 
Archives application. 
 

Backing Up a Current Instal lat ion 
 

1. Run the existing Blackmagic Server and Serendipity Client. 
2. Go to the Serendipity Client Application menu > Archives. This application is called Archiver in 

previous versions. 
3. Select File > Perform Full Backup. 
4. Once all database items have appeared in the Archives window (may take a few minutes), select 

File > Save Archive to save the .sdb archive file to a selected location. 
5. Close the Archives application when finished. 

 
 
 

Windows - Upgrading to Version 5.4 
 

Instal l ing the Dongle Driver 
	
  

1. Make sure the Blackmagic Server and Client are not running and remove any Blackmagic or 
SuperPro USB dongles from the computer. 

2. On the installation DVD, navigate to the dongle/windows folder and run the Sentinel 
Protect ion Instal ler.exe file. 

3. Run the Sentinel Installer. 
4. Select Upgrade and Next. 
5. Follow the onscreen instructions to complete the driver upgrade. 
6. Restart the computer when finished. 

 

Instal l ing C++ Runtime Libraries 
 
To run correctly, Blackmagic 5.4 requires the installation of Microsoft Visual C++ Redistributable libraries 
that may not be present in your Windows operating system. If these were not installed for the existing 
Blackmagic version they will need to be installed now. 
 

1. Navigate to the windows folder on the Blackmagic installation DVD. 
a. For Windows 32 bit - Run the vcredist_x86.exe file. 
b. For Windows 64 bit - Run the vcredist_x64.exe file. 

2. Follow the prompts to install Windows Visual C++ 2008 Redistributable. 
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Instal l ing the Blackmagic 5.4 Upgrade 
 
Current Windows file/folder security and permissions makes it necessary to install Blackmagic 5.4 in the 
root directory of the hard drive rather than in Program Files where earlier versions of the software were 
installed. 
 

1. On the Blackmagic installation DVD navigate to the windows folder. 
2. Run the blackmagic32.msi (32 bit) or blackmagic64.msi (64 bit) file. 
3. If necessary, change the installation directory to the root directory of the hard drive and click Next. 
4. Follow the onscreen prompts to complete the upgrade. 
5. Plug the Blackmagic dongle in to an available USB port. 
6. Start the 5.4 Blackmagic Server and the Serendipity Client. 

 
If the installation directory did not require changing, the existing database should appear once the Server 
and Client have restarted, reformatted and intact in the Workbench. The Client should open with the 
previous version’s configuration. 
 
If the installation directory was (or needed to be) changed, or in the event the existing database is not 
complete, the database backup (made in earlier steps) will need to be imported using the Archives 
application. 

 

Import ing an Exist ing Database 
	
  

1. Open the Archives application from the Serendipity Client Application menu. 
2. Select File > Open Archive. 
3. Navigate to and select the saved backup .sdb file and click Open. The archive will load into the 

Archives window. This may take a few moments depending on size. 
4. Once the archive has loaded, select Edit > Add to Database > Whole Archive. This will import the 

entire archive. Alternatively, select individual items to import and select > Selected Nodes when 
importing. 

5. The database items will import and appear in the Workbench ready for use. 
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Mac OS X - Upgrading to Version 5.4 
 

Instal l ing the Dongle Driver 
 

1. Remove all SuperPro USB dongles. 
2. On the installation DVD navigate to the dongle/macosx folder. 
3. Double-click the Sentinel System Driver.pkg file to launch the installer. 
4. Follow the onscreen instructions to complete the installation. 

 

Instal l ing the Serendipity Printer Drivers 
Used when setting up a Published Pagesetup for printing from third party applications like Photoshop. 
 

1. On the installation DVD, navigate to the drivers/mac folder. 
2. Double-click the Serendipity Printer Drivers.pkg file to launch the application. 
3. Follow the onscreen instructions to complete the installation. 

 
 

Instal l ing the Blackmagic 5.4 Upgrade 
 

1. On the installation DVD, navigate to the macosx folder. 
2. Run the Serendipity Blackmagic.pkg file. 
3. Select the drive and location to install the software. The installer will choose the current installation 

location by default, usually Applications/Serendipity. 
4. Follow the onscreen instructions to complete the upgrade. 
5. Plug in the Blackmagic USB dongle in to an available port. 
6. Start the 5.4 Blackmagic Server and the Serendipity Client . 

 
If the installation directory did not require changing, the existing database should appear once the Server 
and Client have restarted, reformatted and intact in the Workbench. The Client should open with the 
previous version’s configuration. 
 
If the installation directory was (or needed to be) changed, or in the event the existing database is not 
complete, the database backup (made in earlier steps) will need to be imported using the Archives 
application. 

 

Import ing an Exist ing Database 
 

1. Open the Archives application from the Serendipity Client Application menu. 
2. Select File > Open Archive. 
3. Navigate to and select the saved backup .sdb file and click Open. The archive will load into the 

Archives window. This may take a few moments depending on size. 
4. Once the archive has loaded, select Edit > Add to Database > Whole Archive. This will import the 

entire archive. Alternatively, select individual items to import and select > Selected Nodes when 
importing. 

5. The database items will import and appear in the Workbench ready for use. 

Linux - Upgrading to Version 5.4  
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Instal l ing the Dongle Driver 
 

1. Remove all SuperPro USB dongles. 
2. On the installation DVD navigate to the dongle/ l inux folder. 
3. Double-click the snt l-sud-7.5.1-0. i386.rpm file to launch the installer. 

 

Instal l ing the Blackmagic 5.4 Upgrade 
 

1. On the installation DVD, navigate to the l inux folder. 
2. Double-click the instal l .sh file and select Run in Terminal. 
3. A terminal window will popup and the installer will display the default installation directory. 
4. Press Enter to install or type an alternative path then press Enter. The terminal window will close 

when the upgrade is complete. 
Note: If using an alternative install path ensure the folder exists and the current user has 
read/write/execute permissions for the folder. 

5. Plug in the Blackmagic USB dongle in to an available port. 
6. Start the 5.4 Blackmagic Server and the Serendipity Client . 

 
 
If the installation directory did not require changing, the existing database should appear once the Server 
and Client have restarted, reformatted and intact in the Workbench. The Client should open with the 
previous version’s configuration. 
 
If the installation directory was (or needed to be) changed, or in the event the existing database is not 
complete, the database backup (made in earlier steps) will need to be imported using the Archives 
application. 
 

Import ing an Exist ing Database 
 

1. Open the Archives application from the Serendipity Client Application menu. 
2. Select File > Open Archive. 
3. Navigate to and select the saved backup .sdb file and click Open. The archive will load into the 

Archives window. This may take a few moments depending on size. 
4. Once the archive has loaded, select Edit > Add to Database > Whole Archive. This will import the 

entire archive. Alternatively, select individual items to import and select > Selected Nodes when 
importing. 

5. The database items will import and appear in the Workbench ready for use. 
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Running the Software 
Once the software has been installed, launch the Server and Client applications to begin the configuration. 
The Blackmagic Server should be started first and allowed to complete initialisation before the Serendipity 
Client is launched. 
 
Important Note for Mac OS X Users 
The Blackmagic Server and Serendipity Client (for Mac OS X) are able to run in either 32 bit or 64 bit 
modes. Running both in 64 bit mode is optimal for normal usage however not all Spectrophotometer and 
printer manufacturers have converted their drivers to support 64 bit and will be unavailable for use in 64 bit 
mode. New installations of Blackmagic are always in 64 bit mode by default. 
 
 

Before start ing the Server and Cl ient (Mac OS X Only) 
To switch the Server and Client from 64 to 32 bit mode: 
 

1. Open a Finder window and navigate to the Applications/Serendipity/Serendipity Blackmagic folder. 
2. Highlight the Serendipity Client application and select CMD+I or right-click and select Get Info. 
3. Tick the checkbox to enable Open in 32 bit mode. 
4. Repeat the above steps for the Serendipity Blackmagic and C5 applications as necessary. 

 
If the Open in 32 bit mode checkbox does not appear in the Get Info window it will be necessary to reset the 
Mac OS X Finder. 
 

1. Open a Terminal window and type the following command into the screen and press Enter (with no 
line breaks): 

 
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framewor
k/Versions/A/Support/lsregister -domain local -domain user -domain system -kill -r 
 

2. The above command will make the Open in 32 bit mode option appear in the Get Info window. 
3. Go to the Finder window, right-click, select Get Info and enable the option as necessary. 

 

Start ing the Blackmagic Server 
 

1. Plug the Blackmagic dongle in to an available USB port.  
2. Launch the Server by double-clicking the Serendipity Blackmagic file in the installation directory, or 

the shortcut/desktop icon. 
 
The Server window will appear with information about the Server and the initialisation process will begin. 
 
 

Start ing the Serendipity Cl ient 
 

1. Launch the Serendipity Client by double-clicking the Client file in the installation directory, or the 
shortcut/desktop icon. 

 
The Client will connect to the active Server and display the default monitoring application - Jobs - onscreen. 
From this point configuration of the system or loading a pre-configured setup can be done. 
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2. Select Server menu > Server Settings (Preferences). 
3. Select the Colour Management tab. 
4. Click on Change System Specials and select Reference-Lab (or your own Specials) and click OK. 
5. Click OK to dismiss the System Settings window and apply any changes. 

 
 

Manual Cl ient Configurat ion 
 
There are four (4) sections within the Client that require configuration in order to begin processing jobs. 
These are: A RIP where the jobs are polled; a Pagesetup and Media where jobs are processed; and an 
Output where the print job will be sent. 
 
The following information will provide a BASIC configuration process for the Serendipity Client. For a full 
setup including calibration process refer to the User Manual or Serendipity Software Knowledge Base. 
 
Before a Pagesetup is created, create a Media and an Output as each Pagesetup must be linked to a valid 
one of each type. 
 
To begin configura tion:  

	
  

1. In the Serendipity Client, select the Application menu > Workbench. This will open the configuration 
application. 

 

Output Configurat ion 
	
  

1. In the Workbench window, select Output from the list of data types on the left. 
2. Create a new Output by selecting File > New. 
3. Rename the Output as required and select the item. 
4. In the Queue panel of the gray configuration area select the appropriate driver for the printer from 

the dropdown list of licensed drivers. 
5. In the Destination panel select a destination driver (connection method) for the printer and enter the 

appropriate information. 
6. Configure any Collating or Nesting requirements as needed. 
7. OPTIONAL - After a Media is created it can be assigned to the Output via the Change Media button. 

Assigning a Media to the Output will only allow jobs submitted to that particular Media to print. See 
the Media section of the User Manual for further information on this option. 

8. Save the Output configuration when completed by selecting File > Save. 

 

Media Configurat ion 
 

1. Select Media from the data types list in the Workbench. 
2. Create a new Media by selecting File > New.  
3. Rename the Media as required and select the item.  
4. In the Output panel, select the appropriate driver for the printer from the dropdown list of licensed 

drivers. This should be the same driver as was used for the Output Configuration above. 
5. Configure the print resolution to be used (if available) and the print colourspace (CMYK, RGB etc). 



© Serendipity Software Pty Ltd. All Rights Reserved.   Web: www.serendipity-software.com.au 14	
  

6. Select any custom settings for the printer. Click the Edit button to select options from the popup 
window. Click Accept to close the window.  

7. Set the Output ICC Profile via the Choose ICC Profile button. In most cases for a new install this will 
be the Standard SWOP (CMYK) profile. Optionally load your own profile via the Upload File button. 

8. Save the Media configuration when complete by selecting File > Save. 
 
Note: The Media configuration here is the minimal configuration required to get a proof/print workflow 
functioning. For proofing work the Media will need to be correctly calibrated. For a complete guide to 
configuring a calibrated Pagesetup/Media/Output refer to the Serendipity Knowledge Base on the 
Serendipity Software website, or the User Manual for Blackmagic. 
 

Pagesetup Configurat ion 
	
  

1. Select Pagesetup from the data types list in the Workbench. 
2. Create a new Pagesetup by selecting File > New.  
3. Rename the Pagesetup as required and select the item.  
4. Assign the Output created previously to the Pagesetup via the Change Output button in the Output 

panel. 
5. Assign the Media created previously via the Change Media button. Jobs will be printed using this 

Media configuration unless another is selected  when submitting a job for print.  
6. Apply any colour correction curves if required by selecting the appropriate curve button in the 

Curve Correction panel. 
7. Select the input ICC profiles for RGB and Press (CMYK/Multicolour) respectively by clicking the RGB 

ICC Profile and Choose ICC Profile buttons in the ICC Profiles panel. 

8. Use the dropdown menus below each ICC profile to select the Rendering Intent to be used for each 
assigned profile. 

9. Configure any other sheet, effects, margins, etc as required in the other panels of the Pagesetup. 
See the Workbench > Pagesetup section of the User Manual for complete details on each option. 

10. Save the Pagesetup configuration when complete by selecting File > Save. 
 

RIP Configurat ion 
If the Blackmagic installation requires proofing a RIP output, a RIP setup will need to be configured to poll 
RIP jobs for processing. 
 

1. Select RIP from the data types list in the Workbench. 
2. Create a new RIP by selecting File > New. 
3. Rename the RIP as required and select the item. 
4. In the Driver panel select the appropriate RIP driver for the CTP RIP input from the dropdown list of 

licensed drivers. 
5. Configure the RIP driver options by enabling checkbox options and/or selecting Custom Settings via 

the Edit button. 
6. Tick the Enable Polling checkbox in the Polling panel. Set a poll interval time (e.g. 2 minutes). 

 
Note: Some RIP drivers and polling methods require the use of the Job Genie in order for the Blackmagic 
RIP setup to recognise the incoming RIPped files. See the Workbench > Job Genie section of the User 
Manual for further information. 
 

7. Choose the method the RIP setup will use to connect to the RIP output folder from the dropdown 
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menu in the Polling panel and enter any connection details required. 
8. Enter the file path to the RIP folder in the Paths panel. To enter a path click the New button below 

the panel. 
9. Click Browse to navigate to the RIP folder to be polled. Click OK to save the path. If required set up 

Stripe Paths. 
10. Click the Test button at the bottom of the panel to Save and Test the RIP setup. A Polling OK result 

will confirm the RIP path is valid. Alternate messages will appear to notify of any errors or problems 
with the configuration. 

 
This completes the basic configuration of Blackmagic. The next step is to configure an application in order to 
manage jobs as they pass through the various stages of processing. 
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Monitoring Jobs 
	
  

Configurat ion 
 
Once the base configuration has been completed a monitoring application needs to be configured in order 
to manage jobs throughout the system. The following information will outline how to configure one of the 
two applications available. 
 
Jobs or Monitor 
The Jobs application is the default and will be launched when the Client is started for the first time. This is a 
tab based interface and is pre-configured with selected layouts and modules for tracking and managing 
various processes.  
The Monitor application performs the same functions available in Jobs and was the default application in 
previous versions of the software. It has a fully customisable user interface.  
 
 

Jobs Applicat ion Configurat ion 
The default layout of Jobs includes the QueueManager, Thumbnail and QueueStatus modules.  
The RIPMonitor tab will need to be added to the Jobs application in order to poll jobs. 
 

1. In the Jobs application window, select the Tabs menu > Add Tabs. 
2. A window will appear with a list of available layouts. 
3. Select the RIP Monitor tab layout from the list. A preview screen will appear to the right. Click Add. 

The RIP Monitor tab will automatically appear in the Jobs window. 
4. Available RIP queues can be polled by selecting them from the dropdown list and clicking the Poll 

button three (3) times consecutively. 
5. Jobs appearing in the RIPMonitor may now be submitted for processing. 

 
Additional pre-configured tabs may be added to the Jobs application as required. 
 

 

Monitor Appl icat ion Configurat ion 
The Monitor application allows the user to fully customise the interface to match monitoring requirements.  
 

1. Select the Application menu > Monitor to open a new Monitor window. 
2. The default view will include a Queues tab and a Logs tab. The Queues tab includes the 

QueueManager, Thumbnail and QueueStatus modules. The Logs tab contains the ClientLog and 
ServerLog modules. 

 
A RIP Monitor tab will need to be added to the Monitor application in order to poll jobs (if required). 
 

3. Select Tab menu > New Tab to create a new tab for the RIPMonitor. 
4. Rename the Tab to RIP Queues or similar to differentiate it from the other tabs. 
5. Select Layout > Add RIPMonitor. A module window will appear for the RIPMonitor. 
6. The window may be resized and positioned by selecting Layout > Edit. Select the corner of the 

window and resize it by dragging the mouse. Select Layout > Use when done. This will lock the 
modules. 

7. Click the Spanner icon to expand the Toolbar. 
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8. If no RIP jobs appear in the RIP Queue, click the Poll button three (3) times consecutively. 
9. Jobs appearing may now be submitted for processing. 

 
Additional Tabs and Modules may be added to the Monitor as required. See the Monitor section of the 
Blackmagic User Manual for complete information on the available Modules. 
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The C5 Cl ient  
The C5 Client is for use with Serendipity Megarip and Blackmagic only. C5 has its own icon and is designed 
to be run as an alternative to the Serendipity client application. While the Serendipity and C5 Clients can be 
run simultaneously, this is NOT RECOMMENDED. 
 
The C5 interface has simplified, icon-based access to functions. The interface is easy to use but the GUI is 
fixed and is not user-configurable. C5 does not have the facilities to create a calibrated Media and Paper 
Profiles are not accessible. It does not have access to RIP setups or the RIPMonitor, making it unsuitable for 
most Blackmagic RIP proofing workflows.  
 
There are two (2) ways to run the C5 application.  
 

Quick Start  -  C5 Cl ient 
	
  

1. Insert a valid dongle (Blackmagic) in to an available USB port. 
2. Launch the C5 Client by double-clicking the file in the install directory or from the shortcut/desktop 

icon. 
 

This method of starting the software will automatically start the Server application in the background. A 
valid dongle must be plugged in for this method to work otherwise a licensing error message will appear. 
 

Server & C5 Cl ient Start  
	
  

1. Insert a valid dongle (Blackmagic) in to an available USB port. 
2. Launch the Server by double-clicking the Serendipity Blackmagic file. 
3. Once the Server has completed initialisation launch the C5 Client by double-clicking the file in the 

install directory or from the shortcut/desktop icon.  
 

The C5 Client will open with the default Media Library window displayed ready for setup. 

 

Configuring the C5 Cl ient 
The C5 Client will default to the Media Library window when it is run for the first time. In order to begin 
using C5, a Media Pack must be imported and a printer setup. It is assumed for the purposes of this booklet 
that a Media Pack is available for use - either downloaded from the Serendipity Software website or 
provided by a Dealer.  
 
A Media Pack must be loaded into C5. There are two (2) ways this can be done: 
 

1. Drag and drop the C5 Media Pack file into the Media Packs list. The new Media Pack will load and 
be added to the list; or 

2. Click the + button at the bottom of the Media Pack list. This will open a file chooser window to 
navigate to the file for importing. 

 
Once the Media Pack has been imported a confirmation message will appear on screen. 
 



© Serendipity Software Pty Ltd. All Rights Reserved.   Web: www.serendipity-software.com.au 19	
  

Sett ing up a Printer 
	
  

1. Click on the Printers icon at the top of the interface. 
2. Click on the + icon at the bottom of the list panel to add a new printer. 
3. Select the printer from the list of available drivers in the dropdown menu.  
4. Select a calibrated Media to use with the printer from the dropdown menu. 
5. Optionally rename the printer. Back/forward slashes will be replaced with spaces. 
6. Click OK when done. 

 
 

Connecting the Printer 
	
  

1. Click on the newly created printer in the Printer List.  
2. Click on the Connections icon in the Options panel. 
3. Select a printer connection method from the dropdown menu and enter any relevant information. 
4. Click the Show All button to return to the main screen. All actions are automatically saved. 
5. Configure any other settings required and submit a job. Follow the progress via the Jobs window. 

 

 

Print ing Jobs with the C5 Cl ient 
There are various methods available for submitting files for printing when using the C5 Client. See the C5 
Client User Manual for further information on each area listed below. 
 
Printers 
• Select a printer from the Printers List. 
• Select Printers menu > Print Files. 
• Navigate to the file and click Open to print. 
 
Studio 
• Layout any assets (jobs) for nesting/tiling using the Studio application. 
• When ready submit the job for printing via Studio menu > Print. 
• Select a printer from the dropdown menu and click OK. 
 
Jobs 
• Select Jobs menu > Print Files. 
• Navigate to the file location and Open it. 
• Select a printer from the dropdown menu in the Choose Printers window and click OK. 
 
Assets 
Assets are generally used by the Studio application. It is possible however to drag and drop a submitted 
asset file directly onto a QuickDrop area for printing. See the Assets section of the C5 User Manual for 
further information. 
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DropArea 
Each printer in the Printers List automatically has a DropSpot created for it in the DropArea panel of C5. To 
print simply drag and drop one or more files onto the selected DropSpot. 

DropFolder 
In addition to a DropSpot each printer in the Printers List has a DropFolder auto-generated for file 
submission. The printer DropFolders are located in the product installation directory, drop subfolder. The 
names of the DropFolders are set up as per the assigned printer names in the list. 
 
Note: The DropFolders cannot be moved however a desktop shortcut may be created for them to make 
dropping files simpler still. 
 
To print using DropFolders save a copy of the job into the selected DropFolder. The file will be placed in the 
queue for printing. 
 
Important Note: Job files are deleted from the DropFolder immediately after printing. For this reason it is 
recommended that copies, not originals of the job files to be saved to DropFolders. If the C5 Server is 
shutdown all DropFolders are cleared. Any unprinted jobs in the DropFolders are lost and will need to be 
re-copied to the folders for printing. 
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Warranty Pol icy for Serendipi ty Software Products 
 
Warranty 
Warranty lasts for 1 year (12 months) from the date of purchase of the original software. Once the warranty 
period has lapsed the customer may purchase a Software Upgrade which will then cover them for a further 
year (12 months). 
 
Warranty covers: 
 i) Minor software upgrades / new features or enhancements (referred to as “X”) 
 ii) Bug fixes / maintenance releases (referred to as “Y”) 
 
These are determined by the second and third numbers of a version released. For example, V5.X.YY or 
V5.1.02. 
 
All bug fixes/maintenance releases (Y) are free for the particular version of software purchased, regardless 
of warranty period. If a customer is out of warranty and requires access to new features and/or minor 
upgrades (X) that are available in later versions of software, a Software Upgrade must be purchased. 
 
Purchasing Input Fi l ters (RIPs) or Output Drivers 
Purchase of an additional input filter or output driver does not constitute a Software Upgrade.  
If a customer is out of warranty and requires access to a filter or driver only supported by a later version of 
software, a Software Upgrade must be purchased in addition to the input filter or output driver. 
 
A customer may change their input filter and/or output driver selections once only, within three (3) months 
of the date of the original product purchase (this does not include Software Upgrades or Product Upgrades). 
Any changes made after this period will require the purchase of additional drivers and/or filters. 
 

Product Upgrades 
Upgrading a product, for example, Lite to Pro, does not constitute a Software Upgrade. 
If the customer is out of warranty and requires new features and/or drivers that are only available in later 
versions of the software, a Software Upgrade must be purchased in addition to the Product Upgrade. 
 
Major Software Upgrades 
The Warranty does not cover a major Software Upgrade, for example, Version 5 to Version 6. 
When a version number changes due to a major Software Upgrade, all customers are required to purchase 
a Software Upgrade.  
The upgrade fee will be waived for any new, original purchases (not Software Upgrades or Product 
Upgrades) made 30 days prior to the release date of the new version. 
 
Serendipity Software Pty Ltd reserves the right to alter these warranty terms and conditions at any time 
without notice. 


