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Chapter 1:

ACORN Tutorial Overview

The following topics are covered in this chapter:

Introduction…………………………………………………………………………….………… 9

Organization…………………………………………………………………………….………... 10
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Introduction

This tutorial is designed to introduce you to basic concept of atmospheric correction and the full capabilities of
the Atmospheric COrrection Now (ACORN) software.  Data sets acquired by the Airborne Visible/Infrared
Imaging Spectrometer (AVIRIS) from Cuprite, Nevada, and Jasper Ridge, California are used to explore the full
range of options in ACORN.   These example data sets are provided with the ACORN software as well as an
example data set acquired by the HYMAP sensor over Cuprite Nevada.  All the files necessary to run these
tutorial examples are provided with the ACORN software.  The tutorial uses the ENVI software for display and
extraction of spectra.  If other image processing software is used, similar display and data extraction capabilities
will be required.

The Atmospheric CORection Now (ACORN) software has been developed to offer a range of atmospheric
correction capabilities. These capabilities include:

Mode 1. Radiative transfer atmospheric correction of calibrated hyperspectral data.

Mode 1.5. Radiative transfer atmospheric correction of calibrated hyperspectral data with water vapor and liquid
water spectral fitting

Mode 2. Single spectrum enhancement of a hyperspectral atmospheric correction.

Mode 3. Atmospheric correction using the empirical line method for hyperspectral data.

Mode 4. Convolution of hyperspectral data to multispectral data.

Mode 5. Radiative transfer atmospheric correction of calibrated multispectral data.

Mode 6. Single spectrum enhancement of a multispectral atmospheric correction.

Mode 7. Atmospheric correction by the empirical line method for multispectral data.

This tutorial goes through step-by-step examples of each of the ACORN modes.  Because some of the ACORN
modes require some of the same input parameters and input files there is considerable overlap in aspects of the
descriptions of the different modes.  When working through this tutorial, it may be useful to refer to the ACORN
Users Manuel which contains complementary information.

Note: ACORN is not an image processing software package. File editing, image processing, and image
viewing capabilities are required to create ACORN support files and to view and assess ACORN results.
For this tutorial the ENVI software as well as standard text editing and spreadsheet software is used.
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Orgainization

This ACORN tutorial includes a brief introductory chapter and then a chapter presenting an overview of some of
the factors involved in atmospheric correction.  The remaining chapters give step-by-step tutorial examples of
each of the ACORN modes.

Each of the ACORN mode tutorial chapters is designed to stand alone and not require review of other chapters to
work through the example.  This leads to overlap of information and descriptions where ACORN modes require
similar files and parameters.
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Chapter 2:

Introduction to Atmospheric
Correction
The following topics are covered in this chapter:

Radiance and Reflectance…………………………….…………………………………….…… 13

Components of Measured Radiance………………...…………………………………….…… 14

Atmospheric Correction Options and Methodology…………………………………….…… 17

Multispectral and Hyperspectral Measurements…...……………………………..…….…… 18
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Radiance and Reflectance

All airborne and spaceborne remote sensing instrument measure the upwelling radiance that arrives at the sensor.
The upwelling radiance results from the exo-atmospheric solar irradiance, the two-way transmittance and
scattering of the atmosphere, and the reflectance of the surface.  Figure 2-1 shows a radiance image of the
Cuprite, Nevada data set.  Figure 2-2 shows the measured radiance spectrum extracted from Stonewall Playa at
the right central edge of the image.

Figure 2-1.  Image of Cuprite, Nevada acquired by the AVIRIS hyperspectral sensor.  Wavelengths 655.8, 1483.3,
and 2268.4 nm are displayed as blue, green, and red respectively.
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Figure 2-2.  Spectrum extracted from Stonewall playa located on the right central edge of the Cuprite, Nevada
radiance image.

This radiance spectrum is dominated by shape of the exo-atmospheric solar spectrum and the two-way
transmittance of the atmosphere.  The shape of the surface reflectance is not apparent in the radiance spectrum.
Figure 2-3 shows the surface reflectance of stonewall playa.

For the purposes of this tutorial and ACORN software, reflectance is a unitless parameter corresponding to the
ratio of the upwelling radiance from a surface to the expected upwelling radiance from a perfectly reflecting
perfectly Lambertian surface.
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Figure 2-3.  Reflectance spectrum from Stonewall Playa.  The x-axis is in units of wavelength in units of
nanometers.  The y-axis is in units of reflectance.

The shape of the surface reflectance is related to the molecular and scattering composition of the surface.  To
pursue surface related research and/or applications with remote sensing data, atmospheric correction is a critical
step.  This is true for both hyperspectral and multispectral remote sensing measurements.

Components of the Measured Radiance

The radiance measured by a remote sensing instrument begins with the energy from the sun.  Figure 2-4 shows a
spectrum of the solar irradiance arriving at the top of the atmosphere.  This spectrum has the overall form of a
Planck function at 6000 degrees K temperature.  Superimposed on this general form are the effects of the solar
atmosphere and range of temperatures in the upper zones of the sun.
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Figure 2-4 Spectrum of the exo-atmospheric solar irradiance

In the passage from the top of the atmosphere to the surface and then to the remote sensing instrument energy is
absorbed by the molecules and particles in the atmosphere.  Figure 2-5 shows a transmittance spectrum of the
atmosphere for a path from the top of the atmosphere to the surface and to a remote sensing instrument.
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Figure 2-5.  Transmittance of the atmosphere.  The attenuation is due to the absorption and scattering of energy
by the molecules and particles of the atmosphere.

The dominant absorber in the atmosphere is water vapor.  Figure 2-6 shows a series of transmittance spectra for
different amounts of water vapor in the atmosphere.  Only the transmittance due to water vapor is shown.  The
amount of water vapor is given in units of precipitable mm of water vapor.  This corresponds to the depth of the
puddle of liquid water if the water vapor in the atmosphere was condensed.
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Figure 2-6.  Transmittance of the atmosphere with different amounts of water vapor.

The transmittance effects of the other components of the atmosphere are shown in Figure 2-7.  These include
molecular absorption due to oxygen, carbon dioxide, ozone, and methane as well as scattering effects of the
molecules and aerosol particles in the atmosphere.
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Figure 2-7.  Transmittance of the atmosphere due to constituents other than water vapor.

In addition to the atmospheric transmittance effects on the upwelling radiance measured by a remote sensing
instrument, some energy is scattered directly from the atmosphere towards the sensor.  This is generally referred
to as atmospheric path radiance or path radiance.  Figure 2-8 shows an example spectrum of path radiance.  The
aerosol, molecular and total path radiance are shown.  The total path radiance is the radiance that would be
measured by a remote sensing instrument if the surface reflectance was zero.
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Figure 2-8.  Spectrum of the atmospheric path radiance scattered in the direction of a remote sensing instrument.

The total radiance measured by a remote sensing instrument includes both the path radiance and the surface
reflected radiance.  The surface reflected radiance is the solar energy that has been reflected by the surface in the
direction of the sensor.  The reflected radiance plus the path radiance is the total radiance measured by the remote
sensing instrument.  Figure 2-9 shows the total radiance, path radiance, and reflected radiance for a 0.25
reflectance surface.
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Figure 2-9.  The total, reflected, and path radiance for a 0.25 reflectance surface.

Atmospheric Correction Options and Methodology

ACORN offers a range of strategies for atmospheric correction.  These include both empirical and radiative
transfer code based methods for atmospheric correction of both hyperspectral and multispectral data sets.
ACORN also offers several artifact suppression options as well as single spectrum enhancement options to
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improve atmospheric correction results.  The conversion of hyperspectral data to multispectral data for
investigation of multispectral solutions to remote sensing problems is also part of the core capabilities of
ACORN.

The most advanced form of atmospheric correction offered in ACORN is radiative transfer based. Radiative
transfer atmospheric correction of calibrated data uses both the calibrated data and provided parameters to derive
and model the absorption and scattering characteristics of the atmosphere. These atmospheric characteristics are
then used to invert the radiance to apparent surface reflectance.
The approach for atmospheric correction is based in the following equations that can be found or derived from the
information in the text Radiative Transfer by Chandrasekhar (December 1960,
Dover, ISBN: 0486605906). In simplified terms, Equation 2-1 gives the relationship between contributions
between the solar source, atmosphere, and surface to the radiance measured by an earth-looking sensor for a
homogeneous plane parallel atmosphere.

Lt(λ) = F0(λ){ρa(λ) + Td(λ)ρ(λ)Tu(λ)/(1-s(λ)ρ(λ))}/π Equation 2-1

In this equation, Lt is the total radiance arriving at the sensor. F0 is the top of the atmospheric solar irradiance.  ρa
is the reflectance of the atmosphere. Td is the downward transmittance of the atmosphere. ρ is the spectral
reflectance of the surface. Tu is the upward transmittance of the atmosphere.  s is the downward reflectance of the
atmosphere. λ is spectral wavelength.  The solution of this equation for apparent surface reflectance is given in
Equation 2-2.

ρ(λ) = 1/[{F0(λ)Td(λ)Tu(λ)/π)/(Lt(λ)-F0(λ)ρa(λ)/π)}+s(λ)] Equation 2-2

These and other mathematical equations are used in ACORN for each of the radiative transfer based atmospheric
correction modes.

Multispectral and Hyperspectral Measurements

The two principal types of remote sensing data are multispectral and hyperspectral.  Multispectral instruments and
measurement were developed first.  Hyperspectral instruments were conceived and developed only in the 1980s.
Figure 2-10 shows the spectral response functions for the Landsat multispectral sensor.  Landsat has 6
multispectral bands in the solar reflected portion of the electromagnetic spectrum.  These response functions
describe how the upwelling radiance arriving at Landsat is partitioned into each mulispectral band.  Figure 2-11
shows an image of the Jasper Ridge, California in the southern San Francisco Bay area.  Figure 2-12 shows an
example of upwelling radiance measured through the Landsat spectral response functions for several surface
targets.  Figure 2-13 shows the corresponding reflectance for these targets after ACORN atmospheric reflectance.
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Figure 2-10.  Spectral response functions of the Landsat remote sensing instrument.

Figure 2-11.  Image of Jasper Ridge, California.
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Figure 2-12.  Multispectral radiance measurements from Jasper Ridge through the Landsat spectral response
functions.
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Figure 2-13.  Multispectral derived reflectance from Jasper Ridge after atmospheric correction with ACORN

To compare and contrast multispectral and hyperspectral measurement types the corresponding plots for the same
data set are given at the full spectral resolution of theAVIRIS hyperspectral sensor.  Figure 2-14 shows the
spectral response function for the AVIRIS sensors from 400 to 1000 nm.  The full range is not shown because the
plot becomes too compressed.  Figure 2-15 shows the upwelling radiance spectra for the targets in the Jasper
Ridge, California data set.  Figure 2-16 shows the corresponding reflectance spectra for these targets following
atmospheric correction with ACORN.  The hyperspectral spectra show the full spectral signatures across the
spectra range measured.
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Figure 2-14.  Spectral response functions for the AVIRIS hyperspectral remote sensing instrument over the range
from 400 to 1000 nm.  The full range is not shown due to plot compression.
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Figure 2-15.  Measured hyperspectral radiance spectra from the Jasper Ridge, California AVIRIS data set.
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Description

ACORN mode 1 uses radiative transfer calculations and the measured, calibrated hyperspectral data to deduce a
subset of the atmospheric effects present in the hyperspectral data set. These derived atmospheric properties are
used in conjunction with modeled atmospheric properties to correct for the atmosphere in the hyperspectral data
set. With an input of calibrated hyperspectral radiance data, ACORN produces an output of apparent surface
reflectance.

Note: The hyperspectral data must be spectrally and radiometrically calibrated to use ACORN!

The ACORN user controls the strategy for water vapor estimation, artifact suppression and visibility constraint
and estimation.

The quality of the ACORN atmospheric correction is closely tied to the quality of the calibration of the image
data. For all of the modes of ACORN, the spectral and radiometric calibration of the data must be accurate. Partial
exceptions to this rule exist and are indicated in the description of each mode in the ACORN User’s Manual.

At present, perfect calibration and perfect knowledge of the atmosphere are not achievable. Some artifacts will be
present in every atmospheric correction. The strength of the artifacts will be related to the quality of the
calibration, the knowledge of the atmosphere, and the ability to model the atmosphere. Several options and modes
are offered in ACORN to help suppress artifacts in the atmospheric correction.

Input Image Data

For this example of ACORN mode 1 the AVIRIS data set acquired over Jasper Ridge, California is used.  Begin
by examining the Jasper Ridge calibrated radiance data set provided with the ACORN software.

1. Start ENVI software on your computer

2. Open the Jasper Ridge data provide with ACORN.  The default installed location is c:\program
files\ACORN4\Data\Jasper\jsp0rdn.

3. Select bands 30, 40, 20 to display as red, green, blue.  This is done with in the Available Bands List window by
clicking the RGB Color option and then scrolling and clicking on band 30, 40 and 20 in that order.  Then click the
Load Band button.  This image is shown in Figure 3-1.  Figure 3-2 shows a set of extracted spectra from the
Jasper Ridge data.  Table 3-1 gives the site, and location of these extracted spectra.
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Figure 3-1.  Jasper Ridge radiance image bands 30, 40 and 20 as red, green and blue.

4. Extract and examine the radiance spectra with ENVI Z profiles.
a)  This is done in the ENVI image window by selecting Functions>Profiles>Z Profiles.
b)  To move the cursor to a specific location, from the ENVI image window select Functions>Interactive
Analysis>Pixel Locator
c)  In the pixel locator window, enter the X and Y location and click Apply.
d)  To extract and save spectra select Option> New Window:Blank.
e) In the Z profile window click the right mouse button to show the X, Y location of the displayed spectrum.
f) To save a spectrum to the blank window drag X,Y location label to the new window.
g) Repeat this until you have all the Z profiles in the new window that you wish.
h) These extracted spectra may be saved to an ASCII file by selecting File>Output Data>ASCII.

Table 3-1.  Locations of Extracted Spectra                      
Site                                           Sample  Line                  
Stanford Golf Course 504 226
Jasper Ridge Grassland 314 159
Plowed Field 402 242
Redwood Forest 102 250
Felt Lake                                   398                   355       
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Figure 3-2.  Extracted spectra from Jasper Ridge radiance image.

These image radiance spectra contain the effects of the solar illumination,  two-way transmittance and scattering
of the atmosphere, as well as reflectance of the surface.  These image extracted spectra are also scaled so that the
radiance values fall in a range of efficiently stored integers.  ACORN mode 1 is designed to use input and derived
parameters to assess and correct for these atmospheric effects.

Starting ACORN

In this section ACORN Mode 1 will be used to atmospherically correct the Jasper Ridge calibrated radiance data
set.

1.  Start ACORN by selecting Start>Programs>ACORN4>ACORN.

The ACORN 4 Control Panel will appear as shown in Figure 3-3.  ACORN operates based on control files that
provide the parameters for atmospheric correction.
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Figure 3-3.  ACORN  Control Panel

Reviewing and Editing the Control File

1.  Select Open

2.  Select the Jasper Ridge mode 1 control file.  The default location for this file is C:\Program
Files\ACORN4\Data\Jasper\jsp1.in.

3.  Examine the ACORN Mode 1 control file parameter entry panel shown in Figure 3-4.  These are the files and
parameters necessary to perform a Mode 1 atmospheric correction.  Each parameter and file is described for the
Jasper Ridge example.

Note: Except for the examples provided with ACORN you must obtain the appropriate calibration files and
data parameters from the data provider.

Figure 3-4.  ACORN Mode 1 control file parameter entry window.
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Input Image File Name:  This is the name of the input calibrated radiance image file.  For this example, the
default location is C:\Program Files\ACORN4\Data\Jasper\jsp0rdn.

Output Reflectance Image File Name:  This is the name of the output image to be generated by ACORN.  For
this example, the default location is C:\Program Files\ACORN4\Data\Jasper\jsp1rfl.

Input File Format:  This parameter specifies whether the input image data are band-interleaved-by-line (BIL) or
band-interleave-by-pixel (BIP).  The Jasper Ridge data set is BIP file format

Integer Format:  This parameter specifies whether the image data are stored as big endian (host, intel) or little
endian (network or IEEE).  The Jasper Ridge integer format is big endian.

Image Dimension:  These are the dimension of the input image in terms of bands, lines, samples, and offset.  The
offset parameter is the number of bytes used to skip any embedded image headers.  The dimensions of the Jasper
Ridge data set are 224 bands, 512 lines, and 614 samples with 0 byte offset.

Image Spectral Calibration file:  This is the spectral calibration file for the input image.  The format is ASCII.
The default location is C:\Program Files\ACORN4\Data\Jasper\avr97.wvl.  This is a two column
file.  The first colum is the center position of each spectral band in nanometers.  The second column is the full-
width-at-half-maximum (FWHM) of the appropriate Gaussian function for that spectral band in nanometers.
Table 3-2 shows a subset of this file.

Table 3-2.  Jasper Ridge spectral calibration file. 
369.85 9.61
379.69 9.58
389.53 9.55
… …
2486.99 10.07
2496.90 10.05
2506.81             10.03                                        

Gain File:  This is the file that converts the image file integer values to radiance in units of (W/m^2/um/sr).  The
default location for this example is
C:\Program Files\ACORN4\Data\Jasper\avr97.gain.  This is a one column file that is use by
ACORN to convert the image file integers to the correct radiance units. Table 3-3 shows a subset of this file.

Table 3-3.  Contents of the Jasper Ridge gain file.            
0.2
0.2
0.2
…
0.1
0.1
0.1                                                                                

Offset File:  This is a file that corrects for any offset in the image file integer values in the conversion to radiance
in units of (W/m^2/um/sr).  For this example, the default location is
C:\Program Files\ACORN4\Data\Jasper\avr97.gain.  This is a one column file that is added to
the radiance values. Table 3-4 shows a subset of this file.

Table 3-4.  Contents of the Jasper Ridge offest file.         
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0.0
0.0
0.0
…
0.0
0.0
0.0                                                                                

Image Latitude:  These are the degrees, minute, seconds of the image data set.  Each parameter may be integer or
decimal. If decimal degrees are used the minutes and second field should be zero.  North latitude is positive.  The
approximate latitude of the Jasper Ridge data set is 37.18.

Image Longitude:  These are the degrees, minute, seconds of the image data set.  Each parameter may be integer
or decimal.  If decimal degrees are used the minutes and second field should be zero.  The approximate longitude
of the Jasper Ridge data set is -122.3.  East longitude is positive.

Image Date:  This is the date of image acquisition in day, month, year format.  This example data set was
acquired on the 3rd of April, 1997.

Image Time:  This is the nominal time of acquisition in hours, minutes, and seconds. The time must be
Greenwich Mean Time (GMT).  Each parameter may be integer or decimal.  The example Jasper Ridge data set
was acquired at 19:57:23 GMT.

Artifact Suppression:  This option allows selection of artifact suppression options.
i) Artifact suppression type 1 attempts to address spectral calibration mismatches between the image data

set and the radiative transfer code model of the atmosphere.
ii) Artifact suppression type 2 attempts to address radiometric calibration mismatches between the image

data set and the radiative transfer code model of the atmosphere.
iii) Artifact suppression type 3 attempts to address artifacts due to low measured signal.

For this example no artifact suppression options are selected.

Image Elevation:  This is the average elevation of the surface in the input image.  The nominal elevation of the
Jasper Ridge example data set is 200 m.

Image Acquisition Altitude:  This is the altitude of the instrument that acquired the image data in kilometers.
The altitude of acquisition of this example Jasper Ridge data set is 20 km.

Atmospheric Model:  This option selects the appropriate atmospheric model to be used for atmospheric
correction.  The options are mid-latitude-summer, mid-latitude-winter, and tropical.  For this example the mid-
latitude-summer atmospheric model is selected.

Derive Water Vapor:  This option selects the type of water vapor derivation for ACORN Mode 1.  ACORN
derives water vapor from the strength of the water vapor absorption band expressed in the radiance spectrum.

i)  none
ii)  820 water vapor band
iii)  940 water vapor band

 iv)  1140 water vapor band
v)  940 and 1140 water vapor band

For this example the option to use both the 940 and 1140 nm water vapor bands is selected.

Fixed Water Vapor:  If water vapor is not derived from the data themselves then a fixed water vapor amount is
required in units of precipitable mm of water vapor.  A value of 10 precipitable mm is entered, but this parameter
will not be used because the derive water vapor option is engaged.
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Image Atmospheric Visibility:  This parameter controls the visibility of the atmospheric model used in the
atmospheric correction.  A visibility of 60 km is entered for this example.

ACORN Estimated Visibility:  If selected ACORN will attempt to estimate the visibility from the data
themselves.  This option is not selected for this example.

4.  Click OK to complete creation of ACORN mode 1 parameter file.

5. From the ACORN control panel window click Save to save the control file Jsp1.in.

Running ACORN Mode 1

To execute ACORN mode 1,  click Run on the ACORN control panel.  A processing status box will appear to
indicate the progress of the atmospheric correction.  When the atmospheric correction is complete the program
will return to the ACORN Control Panel.

ACORN Mode 1 Results

The primary result of ACORN Mode 1 is the atmospherically corrected image.

1.  With ENVI open the Jasper Ridge reflectance image.  The location specified in the tutorial control file is
c:\program files\ACORN4\Data\Jasper\jsp1rfl.  Figure 3-5 shows the reflectance image with bands
30, 40, 20 displayed as Red, Green, Blue respectively.

2.  Extract the atmospherically corrected spectra from the sites in table 3-1.  The extracted spectra are shown in
Figure 3-6.  These spectra are stored as 2 byte integers of reflectance multiplied by 10000.  This preserves the
precision of the measurement and allows the data to be stored efficiently.  Using 4 byte real numbers would
require twice the disk space.

3.  Compare the extracted reflectance spectra with the input radiance spectra.  The effects of the solar source and
atmosphere have been compensated.  Residual spectral artifacts are present at spectral regions of strong
atmospheric absorption.  Suppression strategies for these artifacts are discussed further along in this chapter.
Also, the water vapor is not completely compensated over vegetation sites.  This is addressed in the chapter on
ACORN mode 1.5.
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Figure 3-5.  Atmospherically corrected Jasper Ridge image following implementation of ACORN mode 1.

Figure 3-6.  Extracted spectra from Jasper Ridge data set after mode 1 atmospheric correction.

Additional Output Files

In addition to the output image file there are several other files created by ACORN.
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.in  This is the control file that provides the files and parameters that are used by ACORN.  The file jsp1.in was
created in the default location for this tutorial example.

.eco  In the same file location of the jsp1.in file will be a jsp1.in.eco.  This file is an echo of the input file as it is
being interpreted by the ACORN software.  If problems are detected interpreting the control file these will be
indicated in this file.

.diag1  In the same directory as the output reflectance file will be a jsp1rfl.diag1.  The diag1  file confirms the
input parameters used in the atmospheric correction and indicates  problems encountered during the run.

.diag2  In the same directory as the output reflectance the jsp1rfl.diag2 file will be created.  This file contains
selected spectral outputs that may be helpful to understand problems with the atmospheric correction.

Artifact Suppression Type 1

Artifact suppression type 1 attempts to address spectral calibration mismatches between the image data set and the
radiative transfer code model of the atmosphere.

For this example from the ACORN Control Panel select Open and open file jsp1a1.in.  The default installation
location for this file is c:\Program Files\ACORN4\Data\Jasper\jsp1a1.in.

Notice that in the control file editor artifact type 1 is selected.

Click OK

Click Run on the ACORN Control Panel.

When the run is complete open the output image file with ENVI.  The default location and name for this file is
c:\Program Files\ACORN4\Data\Jasper\jsp1a1rfl.

With ENVI extract the spectra from the five sites given in Table 3-1.  Figure 3-7 shows these extracted spectra.
In comparison to the spectra shown in Figure 3-6 many of the spectral artifacts have been suppressed.
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Figure 3-7.  Atmospherically corrected spectra from Jasper Ridge with ACORN Mode 1 and artifact suppression
type 1.

Artifact Suppression Type 1 and 2

Artifact suppression type 2 attempts to address radiometric calibration mismatches between the image data set and
the radiative transfer code model of the atmosphere.

For this example from the ACORN Control Panel select Open and open file jsp1a1.in.  The default installation
location for this file is c:\Program Files\ACORN4\Data\Jasper\jsp1a2.in.

Notice that in the control file editor artifact type 1 and 2 are selected.

Click OK

Click Run on the ACORN Control Panel.

When the run is complete open the output image file with ENVI.  The location and name for this file specifed in
the tutorial example control file is c:\Program Files\ACORN4\Data\Jasper\jsp1a2rfl.

With ENVI extract the spectra from the five sites given in Table 3-1.  Figure 3-8 shows these extracted spectra.
In comparison to the spectra shown in Figure 3-6 and Figure 3-7 additional spectral artifacts have been
suppressed.

Figure 3-8.  Atmospherically corrected spectra from Jasper Ridge with ACORN Mode 1 and artifact suppression
type 1 and 2.

Artifact Suppression Type 1, 2, and 3
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Artifact suppression type 3 attempts to address artifacts due to low measured signal.

For this example from the ACORN Control Panel select Open and open file jsp1a3.in.  The default installation
location for this file is c:\Program Files\ACORN4\Data\Jasper\jsp1a3.in.

Notice that in the control file editor artifact type 1, 2 and 3 are selected.

Click OK

Click Run on the ACORN Control Panel.

When the run is complete open the output image file with ENVI.  The location and name for this file specified in
the tutorial example control file is c:\Program Files\ACORN4\Data\Jasper\jsp1a3rfl.

With ENVI extract the spectra from the five sites given in Table 3-1.  Figure 3-9 shows these extracted spectra.
In comparison to the spectra shown in Figure 3-6, Figure 3-7, and Figure 3-8 the low signal noisy portions of the
spectrum have been suppressed.

Figure 3-9.  Atmospherically corrected spectra from Jasper Ridge with ACORN Mode 1 and artifact suppression
type 1, 2 and 3.

Visibility Estimation

ACORN will attempt to estimate the visibility from the data themselves.

For this example from the ACORN Control Panel select Open and open file jsp1a3v.in.  The default location for
this file in the tutorial is c:\Program Files\ACORN4\Data\Jasper\jsp1a3v.in.

Notice that in the control file editor artifact type 1, 2, 3 and estimate visibility are selected.
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Click OK

Click Run on the ACORN Control Panel.

When the run is complete open the output image file with ENVI.  The location and name for this file in the
tutorial is c:\Program Files\ACORN4\Data\Jasper\jsp1a3vrfl.

With ENVI extract the spectra from the five sites given in Table 3-1.

For comparison spectra are shown in Figure 3-10 where ACORN was run with a fixed visibility of 20 km.  20 km
is too hazy an atmosphere for this data set and results in negative reflectance values in the visible portion of the
spectrum.  The ACORN estimated visibility spectra in Figure 3-11 give a better result.

Figure 3-10.  Atmospheric correction with fixed 20 km visibility used.  20 km is excessively haze and causes
negative reflectance results in the visible portion of the spectrum.
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Figure 3-11.  Atmospheric correction with ACORN visibility estimation used.

Other Tutorial Examples

Additional tutorial examples are provided with ACORN for the Cuprite Nevada AVIRIS and Hymap data.  The
default location for these files is c:\Program Files\ACORN4\Data\Cuprite\cup1.in and
c:\Program Files\ACORN4\Data\Cupriteh\cuph1.in.  You may run these examples and examine
the input and output files to gain additional experience with ACORN mode 1.
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Chapter 4
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Description

ACORN mode 1.5 is a new mode introduced in ACORN version 4.1 that uses radiative transfer calculations and
the measured, calibrated hyperspectral data to deduce a subset of the atmospheric effects present in the
hyperspectral data set.  This mode includes spectral fitting to simultaneously determine the water vapor and liquid
water in vegetation (or water saturated soil) on the surface.  This gives an improved estimation of water vapor for
the atmospheric correction and provides a surface liquid water parameter data set that may be used to describe
liquid water related properties of vegetation.  The derived atmospheric properties are used in conjunction with the
other constraint parameters to correct for the effects of the atmosphere in the hyperspectral data set. With an input
of calibrated spectral radiance data, ACORN produces an output of apparent surface reflectance.

The ACORN user controls the strategy for water vapor estimation, artifact suppression and visibility constraint
and estimation.

As always, the quality of the atmospheric correction is closely tied to the quality of the calibration of the image
data.  At present, perfect calibration and perfect knowledge of the atmosphere are not achievable. Some artifacts
will be present in every atmospheric correction. The strength of the artifacts will be related to the quality of the
calibration, the knowledge of the atmosphere, and the ability to model the atmosphere. Several options are offered
in ACORN to help suppress artifacts in the atmospheric correction result.

Input Image Data

For this example the AVIRIS data set acquired over Jasper Ridge, California is used.  Begin by examining the
Jasper Ridge calibrated radiance data set provided with the ACORN software.

1. Start ENVI software

2. Open the Jasper Ridge data provide with ACORN.  The default installation location for this data set is
c:\Program Files\ACORN4\Data\Jasper\jsp0rdn.

3. Select bands 30, 40, 20 to display as red, green, blue.  This is done with in the Available Bands List window by
clicking the RGB Color option and then scrolling and clicking on band 30, 40 and 20 in that order.  Then click the
Load Band button.  The resulting displayed image is shown in Figure 4-1.  Figure 4-2 shows a set of extracted
spectra the Jasper Ridge data.  Table 4-1 gives the site, and location of these extracted spectra.
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Figure 4-1.  Jasper Ridge AVIRIS radiance image.

Figure 4-2 shows a set of extracted spectra the Jasper Ridge data.  Table 4-1 gives the site, image label, and
location of these extracted spectra.

4. Extract and examine the radiance spectra with ENVI Z profiles.
a)  This is done in the ENVI image window by selecting Functions>Profiles>Z Profiles.
b)  To move the cursor to a specific location, from the ENVI image window select Functions>Interactive
Analysis>Pixel Locator
c)  In the pixel locator window, enter the X and Y location and click Apply.
d)  To extract and save spectra select Option> New Window:Blank.
e) In the Z profile window click the right mouse button to show the X, Y location of the displayed spectrum.
f) To save a spectrum to the blank window drag X,Y location label to the new window.
g) Repeat this until you have all the Z profiles in the new window that you wish.
h) These extracted spectra may be saved to an ASCII file by selecting File>Output Data>ASCII.
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Figure 4-2.  Extracted spectra from Jasper Ridge radiance image.

Table 4-1.  Locations of Extracted Spectra                      
Site                                           Sample  Line                  
Stanford Golf Course 504 226
Jasper Ridge Grassland 314 159
Plowed Field 402 242
Redwood Forest 102 250
Felt Lake                                   398                   355       

These image radiance data contain the effects of the solar illumination, two-way transmittance and scattering of
the atmosphere, as well as reflectance of the surface.  These image extracted spectra are also scaled so that the
radiance values fall in a range of efficiently stored integers.  ACORN mode 1.5 is designed to use input and
derived parameters with spectral fitting for water vapor and surface liquid water to assess and correct for these
atmospheric effects.

Starting ACORN

In this example ACORN Mode 1.5 will be used to atmospherically correct the Jasper Ridge calibrated radiance
data set.

1.  Start ACORN by selecting Start>Programs>ACORN4>ACORN.

The ACORN Control Panel will appear as shown in Figure 4-3.  ACORN operates based on control files that
provide the parameters and files for implementation of the atmospheric correction.
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Figure 4-3.  ACORN 4 Control Panel

Reviewing and Editing the Control File

Note: Except for the examples provided with ACORN you must obtain the appropriate calibration files and
data parameters from the data provider.

1.  From the ACORN Control Panel, select Open

2.  For this example, select the Jasper Ridge mode 1.5 control file.  The default location for this file is
C:\Program Files\ACORN4\Data\Jasper\jsp1_5a3.in.

3.  Examine the ACORN control file parameter entry panel shown in Figure 4-4.  These are the files and
parameters necessary to perform the atmospheric correction.  Each parameter and file is described below for this
Jasper Ridge ACORN mode 1.5 example.
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Figure 4-4.  ACORN Mode 1.5 control file parameter entry window.

Input Image File Name:  This is the name of the input radiance image file.  The default location is
C:\Program Files\ACORN4\Data\Jasper\jsp0rdn.

Output Reflectance Image File Name:  This is the name of the output image to be generated by ACORN.  The
default location is C:\Program Files\ACORN4\Data\Jasper\jsp1_5a5rfl.

Input File Format:  This parameter specifies whether the input image data are band-interleaved-by-line (BIL) or
band-interleave-by-pixel (BIP).  The Jasper Ridge data set is BIP file format.

Integer Format:  This parameter specifies whether the image data are stored as big endian (host, intel) or little
endian (network or IEEE).  The Jasper Ridge integer format is big endian.

Image Dimension:  These are the dimension of the input image in terms of bands, lines, samples, and offset.  The
offset parameter is the number of bytes used to skip any embedded image headers.  The dimensions of the Jasper
Ridge data set are 224 bands, 512 lines, and 614 samples with 0 byte offset.

Image Spectral Calibration file:  This is the spectral calibration file for the input image.  The default location is
C:\Program Files\ACORN4\Data\Jasper\avr97.wvl.  This is a two column file.  The first column
is the center position of each spectral band in the image in nanometers.  The second column is the full-width-at-
half-maximum (FWHM) of the appropriate Gaussian function to describe the spectral response function of the
band in nanometers.  Table 4-2 shows a subset of this file.
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Table 4-2.  Jasper Ridge spectral calibration file. 
369.85 9.61
379.69 9.58
389.53 9.55
… …
2486.99 10.07
2496.90 10.05
2506.81             10.03                                        

Gain File:  This is the gain file that converts the image file integer values to radiance in units of (W/m^2/um/sr).
The default location is C:\Program Files\ACORN4\Data\Jasper\avr97.gain. This is a one
column file that is multiplied by the image integer values to convert the integers to the correct radiance units.
Table 4-3 shows a subset of this file.
                                                                                    
Table 4-3.  Contents of the Jasper Ridge gain file.            
0.2
0.2
0.2
…
0.1
0.1
0.1                                                                                

Offset File:  This is the offset file that corrects for any offset in the image file integer values in the conversion to
radiance in units of (W/m^2/um/sr).  The default location is
C:\Program Files\ACORN4\Data\Jasper\avr97.off.  This is a one column file that is added to the
radiance values. Table 4-4 shows a subset of this file.
                                                                                    
Table 4-4.  Contents of the Jasper Ridge offest file.         
0.0
0.0
0.0
…
0.0
0.0
0.0                                                                                

Image Latitude:  These are the central degrees, minute, seconds of the image data set.  Each parameter may be
integer or decimal. If decimal degrees are used the minutes and second field should be zero.  North latitude is
positive.  The central latitude of the Jasper Ridge data set is 37.18.

Image Longitude:  These are the central degrees, minute, seconds of the image data set.  Each parameter may be
integer or decimal.  If decimal degrees are used the minutes and second field should be zero.  The central
longitude of the Jasper Ridge data set is -122.3.  East longitude is positive.

Image Date:  This is the date of image acquisition in day, month, year format.  This example data set was
acquired on the 3rd of April, 1997.
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Image Time:  This is the nominal time of acquisition in hours, minutes, and seconds. The time must be
Greenwich Mean Time (GMT).  Each parameter may be integer or decimal.  The example Jasper Ridge data set
was acquired at 19:57:23 GMT.

Artifact Suppression:  This option allows selection of artifact suppression options.
i) Artifact suppression type 1 attempts to address spectral calibration mismatches between the image data

set and the radiative transfer code model of the atmosphere.
ii) Artifact suppression type 2 attempts to address radiometric calibration mismatches between the image

data set and the radiative transfer code model of the atmosphere.
iii) Artifact suppression type 3 attempts to address artifacts due to low measured signal.

For this example all artifact suppression options are selected.

Image Elevation:  This is the average elevation of the surface in the input image in meters.  The approximate
average elevation of the Jasper Ridge example data set is 200 m.

Image Acquisition Altitude:  This is the altitude of the instrument that acquired the image data in kilometers.
The altitude of acquisition of this example Jasper Ridge data set is 20 km.

Atmospheric Model:  This option selects the appropriate atmospheric model to be used for atmospheric
correction.  The options are mid-latitude-summer, mid-latitude-winter, and tropical.  For this example the mid-
latitude-summer atmospheric model is selected.

Derive Water Vapor:  This option selects the type of water vapor derivation for ACORN Mode 1.5.
i)  940 water vapor band

 ii)  1140 water vapor band
iii) 940 and 1140 water vapor band

For this example the option to use both the 940 and 1140 nm water vapor bands is selected.

Path Radiance:  This option includes fine tuning of the path radiance parameter in the spectral fitting of water
vapor and liquid water.  This may improve the quality of the water vapor and liquid water result.  For this
example this option is selected.

Image Atmospheric Visibility:  This parameter controls the visibility of the atmospheric model used in the
atmospheric correction.  A visibility of 60 km is entered for this example.

ACORN Estimated Visibility:  If selected ACORN will attempt to estimate the visibility from the data
themselves.  This option is not selected for this example.

4.  Click OK to complete creation of ACORN control file.

5. From the ACORN control panel window click Save to save the control file Jsp1_5a3.in.

Running ACORN Mode 1.5

To execute ACORN mode 1.5, click Run on the ACORN control panel.  A processing status box will appear to
indicate the progress of the atmospheric correction.  When the atmospheric correction is complete the program
will return to the ACORN Control Panel.
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Reflectance Results

The primary result of ACORN Mode 1.5 is the atmospherically corrected apparent reflectance image.

1.  With ENVI open the Jasper Ridge reflectance image.  The default location is
c:\program files\ACORN4\Data\Jasper\jsp1_5a3rfl.  Figure 4-5 shows the reflectance image with
bands 30, 40, 20 displayed as Red, Green, Blue respectively.

2.  Extract the atmospherically corrected spectra from the sites in table 4-1.  The extracted spectra are shown in
Figure 4-6.  These spectra are stored as integer of reflectance multiplied by 10000.  This preserves the precision of
the measurement and allows the data to be stored efficiently.

3.  Compare the extracted reflectance spectra with the input radiance spectra.  The effects of the solar source and
atmosphere have been compensated.   The reflectance spectra are smooth over vegetation in the 980 and 1200 nm
region where liquid water absorption in vegetation occurs.

Figure 4-5.  Atmospherically corrected Jasper Ridge image following use of ACORN mode 1.5.
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Figure 4-6.  Extracted spectra from Jasper Ridge data set after mode 1.5 atmospheric correction.

Water Vapor Image

In addition to the atmospherically corrected reflectance image at water vapor image is generated from the spectral
fitting algorithm.  Figure 4-7 shows the water vapor image for this tutorial example.  Water vapor is reported in
units of  precipitable microns (um).

1.  With ENVI open the Jasper Ridge water image.  The default location is
c:\program files\ACORN4\Data\Jasper\jsp1_5a3rfl.wtrv.

2.  Use the ENVI cursor value location capability to examine the water vapor values. From the ENVI image
window select Function>Interactive Analysis> Cusor Location/Value.  Move the cursor to various parts of the
image to see the change in water vapor.  Water vapor varies from 5000 um to 7000 precipitable um (5 to 7
precipitable mm) across the image.  This is a dry atmosphere data set.  The image is largely devoid of surface
structure as expected for water vapor.  Some surface leakage occurs over dark targets such as the open water areas
of lakes.
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Figure 4-7.  Water vapor image from ACORN atmospheric correction mode 1.5.

Liquid Water Image

A second result of the water vapor and liquid water spectral fitting algorithm used in ACORN is a surface liquid
water image.  Figure 4-8 shows the liquid water image for this tutorial example.  Liquid water is reported in units
of expressed path absorption in microns (um).  This parameter may be used to derive vegetation water, species-
type, and phonological state properties.

1.  With ENVI open the Jasper Ridge water image.  The default location is
c:\program files\ACORN4\Data\Jasper\jsp1_5a3rfl.wtrl.

2.  Use the ENVI cursor value location capability to examine the water vapor values. From the ENVI image
window select Function>Interactive Analysis> Cusor Location/Value.  Move the cursor to various parts of the
image to see the change in expressed liquid water.  Liquid water varies from 0 to 4000 um expressed path
absorption in um (0 to 4 mm) over the image.  Paved surfaces, soils, and dry grass give low to zero values.
Healthy vegetation gives a range of values depending on species, water status, and phonological state.  Some of
the highest liquid water values are found in the redwood forest in the upper left corner of the data set.
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Figure 4-8.  Suface liquid water image from ACORN atmospheric correction mode 1.5.

Additional Output Files

In addition to the output image file there are several other files created by ACORN.

.in  This is the control file that provides the files and parameters that are used by ACORN.  The file jsp1_5a3.in
was created in the default location for this tutorial example.

.eco  In the same file location of the jsp1_5a3.in file will be a jsp1_5a3.in.eco.  This file is an echo of the input
file as it is being interpreted by the ACORN software.  If problems are detected interpreting the control file these
will be indicated in this file.

.diag1  In the same directory as the output reflectance file will be a jsp1_5a3rfl.diag1.  The diag1  file confirms
the input parameters used in the atmospheric correction and indicates  problems encountered during the run.

.diag2  In the same directory as the output reflectance the jsp1_5a3rfl.diag2 file will be created.  This file contains
selected spectral outputs that may be helpful to understand problems with the atmospheric correction.

Other Tutorial Examples

Additional tutorial examples are provided with ACORN for the Cuprite Nevada AVIRIS and Hymap data.  The
default location for these files is c:\Program Files\ACORN4\Data\Cuprite\cup1_5.in. an d
c:\Program Files\ACORN4\Data\Cupriteh\cuph1_5.in.  You may run these examples and
examine the input and output files to gain additional experience with ACORN mode 1.5.
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Description

For single spectrum enhancement of a hyperspectral atmospheric correction, ACORN uses a spectrum extracted
from an atmospherically corrected hyperspectral data set and an accurately known spectrum for the same target.
With these two spectra, the full atmospherically corrected hyperspectral data set is corrected to the accuracy of the
known spectrum. ACORN accurately and automatically convolves the known spectrum to the spectral
characteristics of the hyperspectral data set for this atmospheric correction enhancement.  This is a powerful
method to compensate for residual errors in the hyperspectral atmospheric correction due to data calibration as
well as atmospheric modeling.

Input Image Data

For this example the AVIRIS data set acquired over Cuprite, Nevada is used.  Begin by using ACORN Mode 1 to
atmospherically correct the Cuprite data set.  Do this by following the ACORN Mode 1 tutorial, but use the input
control file for Cuprite.  The default installation location for the Cuprite control file is c:\Program
Files\ACORN4\Data\Cuprite\cup1.in.

Once the Mode 1 atmospheric correction is complete examine the Cuprite reflectance image

1. Start ENVI software

2. Open the Cuprite, Nevada data provide with ACORN.  The default location for this data set is c:\Program
Files\ACORN4\Data\Cuprite\cup1rfl.

3. Select bands 200, 130, 30 to display as red, green, blue.  This is done with in the Available Bands List window
by clicking the RGB Color option and then scrolling and clicking on band 200, 130 and 30 in that order.  Then
click the Load Band button.  The resulting displayed image is shown in Figure 5-1.  Figure 5-2 shows a set of
extracted spectra the Cuprite atmospherically corrected data set.  Table 5-1 gives the site, image label, and
location of these extracted spectra.
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Figure 5-1.  Cuprite, Nevada AVIRIS radiance image.

4. Extract and examine the radiance spectra with ENVI Z profiles.
a)  This is done in the ENVI image window by selecting Functions>Profiles>Z Profiles.
b)  To move the cursor to a specific location, from the ENVI image window select Functions>Interactive
Analysis>Pixel Locator
c)  In the pixel locator window, enter the X and Y location and click Apply.
d)  To extract and save spectra select Option> New Window:Blank.
e) In the Z profile window click the right mouse button to show the X, Y location of the displayed spectrum.
f) To save a spectrum to the blank window drag X,Y location label to the new window.
g) Repeat this until you have all the Z profiles in the new window that you wish.
h) These extracted spectra may be saved to an ASCII file by selecting File>Output Data>ASCII.
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Figure 4-2.  Extracted spectra from Cuprite ACORN Mode 1 atmospherically corrected image.

Table 4-1.  Locations of Extracted Spectra                                  
Site                                                       Sample  Line                  
Stonewall Playa 606 293
Opalite Zone w/Alunite 554 272
Strongly Argillized Zone w/Kaolinite 526 319
Buddingtonite Zone 472 235
Calcite                                                  295                   348       

These extracted spectra from the Cuprite ACORN Mode 1 atmospherically corrected image have some spectra
roughness to them across the spectral range.  This is due to imperfections in the data calibration as well as the
atmospheric modeling used by ACORN.  ACORN Mode 2 is designed to suppress this systematic spectral
roughness.

Starting ACORN

In this example ACORN Mode 2 will be used to enhance the atmospheric correction for the Cuprite ACORN
Mode 1 reflectance data set.

1.  Start ACORN by selecting Start>Programs>ACORN4>ACORN.

The ACORN 4 Control Panel will appear as shown in Figure 5-3.  ACORN operates based on control files that
provide the parameters and files for the ACORN algorithm.
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Figure 5-3.  ACORN Control Panel

Reviewing and Editing the Control File

Note: Except for the examples provided with ACORN you must obtain the appropriate calibration files and
data parameters from the data provider.

1.  From the ACORN Control Panel, select Open

2.  For this example, choose the Cuprite Mode 2 tutorial control file.  The default installation location for this
control file is C:\Program Files\ACORN4\Data\Cuprite\cup2.in

3.  Examine the ACORN control file parameter entry panel shown in Figure 5-4.  These are the files and
parameters necessary to perform the single spectrum enhancement tutorial example.  Each parameter and file is
described below for this tutorial example.
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Figure 5-4.  ACORN Mode 2 control file parameter entry window.

Input Image File Name:  This is the name of the input radiance image file.  The default location is
C:\Program Files\ACORN4\Data\Cuprite\cup1rfl.

Note: You must have created cup1rfl by running ACORN Mode 1 on the Cuprite radiance data set.

Output Reflectance Image File Name:  This is the name of the output image to be generated by ACORN. For
this tutorial, the default location is C:\Program Files\ACORN4\Data\Cuprite\cup2rfl.

Input File Format:  This parameter specifies whether the input image data are band-interleaved-by-line (BIL) or
band-interleave-by-pixel (BIP).  The Cuprite data set is BIP file format.

Integer Format:  This parameter specifies whether the image data are stored as big endian (host, intel) or little
endian (network or IEEE).  The Cuprite integer format is big endian.

Image Dimension:  These are the dimension of the input image in terms of bands, lines, samples, and offset.  The
offset parameter is the number of bytes used to skip any embedded image headers.  The dimensions of the Cuprite
data set are 224 bands, 512 lines, and 614 samples with 0 byte offset.

Image Target Reflectance Spectrum File:   This is a single column file with the extracted spectrum from
cup1rfl that corresponds to the location where an accurate surface reflectance spectrum has been acquired.  Table
5-3 shows a portion of this file.  Negative and noisy values have been set to 0.000.
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Table 5-3.  Cuprite Image Target Reflectance Spectrum File.       
0.000
0.000
516.721
1399.558
1863.000
…
3529.698
5338.349
5243.674                                                                                   

Image Spectral Calibration file:  This is the spectral calibration file for the input image.  The default location is
C:\Program Files\ACORN4\Data\Cuprite\avr97.wvl.  This is a two column file.  The first column
is the center position of each spectral band in the image in nanometers.  The second column is the full-width-at-
half-maximum (FWHM) of the appropriate Gaussian function to describe the spectral response function of the
band in nanometers.  Table 5-2 shows a subset of this file.

Table 5-3.  Cuprite image spectral calibration file.           
369.85 9.61 . . .
379.69 9.58
389.53 9.55
… …
2486.99 10.07
2496.90 10.05
2506.81             10.03                                                    

Measured Target Reflectance Spectrum File :  This is the measured reflectance for the same target as the
Image Target Reflectance Spectrum File.  The default location of the file for this tutorial is C:\Program
Files\ACORN4\Data\Cuprite\Cup2.meas. This is a two column file.  The first column is wavelength
in nm and the second column is reflectance.  The reflectance is multiplied by 10000 to have the same scaling as
the Image Target Reflectance Spectrum File.  Table 5-4 shows a portion of this file.

Table 5-4.  Contents of the Measured Target Reflectance Spectrum File.   
350 1636.862
351 1638.537
352 1642.535
… …
2503 4079.836
2504 4081.076
2505     4082.106                                                                                   

Running ACORN Mode 2

To execute ACORN mode 2, click Run on the ACORN control panel.  A processing status box will appear to
indicate the progress of the atmospheric correction.  When the atmospheric correction is complete the program
will return to the ACORN Control Panel.
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ACORN Mode 2 Results

The principal result of ACORN Mode 2 is the single spectrum enhanced reflectance image.

1.  With ENVI open the Cuprite single spectrum enhanced image.  The default location for the tutorial is
c:\program files\ACORN4\Data\Cuprite\cup2rfl.  Figure 5-5 shows the reflectance image with bands
200, 130, 30 displayed as Red, Green, Blue respectively.

2.  Extract the single spectrum enhanced spectra from the sites in table 5-1.  The extracted spectra are shown in
Figure 5-6.

3.  Compare the extracted single spectrum enhanced spectra with the input reflectance spectra in Table 5-1.   The
spectral roughness has been removed.  Spectral artifacts remain only in the 1400 and 1900 nm region where the
signal is extremely low due to the absorption of atmospheric water vapor.

Figure 5-5.  Single Spectrum Enhance image following use of ACORN Mode 2.
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Figure 5-6.  Extracted spectra from Cuprite data set after Mode 2 Single Spectrum Enhancement.

Additional Output Files

In addition to the output image file there are several other files created by ACORN.

.in  This is the control file that provides the files and parameters that are used by ACORN.  The file cup2.in was
created in the default location for this tutorial example.

.eco  In the same file location of the cup2.in file will be a cup2.in.eco.  This file is an echo of the input file as it is
being interpreted by the ACORN software.  If problems are detected interpreting the control file these will be
indicated in this file.

.diag1  In the same directory as the output reflectance file will be a cup2rfl.diag1.  The diag1  file confirms the
input parameters used in the atmospheric correction and indicates  problems encountered during the run.

.diag2  In the same directory as the output reflectance the cup2rfl.diag2 file will be created.  This file contains
selected spectral outputs that may be helpful to understand problems with the atmospheric correction.

Other Tutorial Examples

Additional tutorial examples are provided with ACORN for the Jasper Ridge AVIRIS and Cuprite Hymap data.
The default location for these files is c:\Program Files\ACORN4\Data\Jasper\jsp2.in. an d
c:\Program Files\ACORN4\Data\Cupriteh\cuph2.in.  You may run these examples and examine
the input and output files to gain additional experience with ACORN mode 2.
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Chapter 6
Mode 3. Atmospheric correction using the empirical
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Description
ACORN uses a dark and bright extracted target spectrum from a hyperspectral data set and corresponding
measured ground spectra for these same targets. These four input spectra are used to implement an empirical line
atmospheric correction. ACORN accurately and automatically convolves the known spectra to the spectral
characteristics of the hyperspectral data set for this mode of atmospheric correction. This mode is less dependent
on the accuracy of the radiometric calibration of the hyperspectral data and can even be run on the raw image data
from the image provider.

To implement ACORN empirical line correction a measured dark and bright target reflectance spectrum is
required from within the region of the hyperspectral data set. Typically there must be at least 0.10 reflectance
between the dark and bright spectra. Figure 6-1 shows the measured dark and bright target reflectance spectra.
The spectra must have equal or better spectral resolution and sampling than the hyperspectral data set. The
spectral range must be equal or greater as well. Spectra from the corresponding areas of the hyperspectral data set
must be extracted using an image processing software capability. Figure 6-1 also shows the extracted dark and
bright target image radiance spectra. With these spectra and the spectral calibration parameters of the
hyperspectral data set ACORN performs an empirical line atmospheric correction.
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Figure 6-1: Left: dark and bright target measured spectra from the Cuprite area. Right: spectra for the
dark and bright targets extracted from the Cuprite hyperspectral radiance data

Input Image Data

For this example the AVIRIS data set acquired over Cuprite, Nevada is used.  Begin by examining the scaled
radiance spectra of the cuprite data set.

1. Start ENVI software.

2. Open the Cuprite, Nevada data provide with ACORN.  The default installation location for this data set is
c:\Program Files\ACORN4\Data\Cuprite\cup0rdn.

3. Select bands 200, 130, 30 to display as red, green, blue.  This is done with in the Available Bands List window
by clicking the RGB Color option and then scrolling and clicking on band 200, 130 and 30 in that order.  Then
click the Load Band button.  The resulting displayed image is shown in Figure 6-2.  Figure 6-3 shows a set of
extracted radiance spectra the Cuprite.  Table 6-1 gives the site and location of these extracted spectra.  Extract
these spectra for later comparison with empirical line result.
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Figure 6-2.  Cuprite AVIRIS radiance image.

4. Extract and examine the radiance spectra with ENVI Z profiles.
a)  This is done in the ENVI image window by selecting Functions>Profiles>Z Profiles.
b)  To move the cursor to a specific location, from the ENVI image window select Functions>Interactive
Analysis>Pixel Locator
c)  In the pixel locator window, enter the X and Y location and click Apply.
d)  To extract and save spectra select Option> New Window:Blank.
e) In the Z profile window click the right mouse button to show the X, Y location of the displayed spectrum.
f) To save a spectrum to the blank window drag X,Y location label to the new window.
g) Repeat this until you have all the Z profiles in the new window that you wish.
h) These extracted spectra may be saved to an ASCII file by selecting File>Output Data>ASCII.
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Figure 6-3.  Extracted spectra from Cuprite radiance image.

Table 6-1.  Locations of Extracted Spectra                                              
Site                                                                   Sample              Line      
Stonewall Playa 606 293
Opalite Zone w/Alunite 554 272
Strongly Argillized Zone w/Kaolinite 526 319
Buddingtonite Zone 472 235
Calcite                                                              295                   348       

These image radiance data contain the effects of the solar illumination,  two-way transmittance and scattering of
the atmosphere, as well as reflectance of the surface.  These image extracted spectra are also scaled so that the
radiance values fall in a range of efficiently stored integers.  ACORN mode 3 is designed to use the empirical line
method to correct these radiance spectra to reflectance.

Starting ACORN

In this example ACORN Mode 3 will be used to perform an empirical line atmospheric correction on the Cuprite
radiance data set.

1.  Start ACORN by selecting Start>Programs>ACORN4>ACORN.

The ACORN 4 Control Panel will appear as shown in Figure 6-4.  ACORN operates based on control files that
provide the parameters and files for the ACORN algorithm.
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Figure 6-4.  ACORN Control Panel

Reviewing and Editing the Control File

Note: Except for the examples provided with ACORN you must obtain the appropriate calibration files and
data parameters from the data provider.

1.  From the ACORN Control Panel, select Open

2.  For this example, choose the Cuprite Mode 3 tutorial control file.  The default installation location for this
control file is C:\Program Files\ACORN4\Data\Cuprite\cup3.in

3.  Examine the ACORN control file parameter entry panel shown in Figure 6-5.  These are the files and
parameters necessary to perform the empirical line atmospheric correction.  Each parameter and file is described
below for this tutorial example.
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Figure 6-5.  ACORN Mode 3 control file parameter entry window.

Input Image File Name:  This is the name of the input radiance image file.  The default location is
C:\Program Files\ACORN4\Data\Cuprite\cup0rdn.

Output Reflectance Image File Name:  This is the name of the output image to be generated by ACORN. For
this tutorial, the default location is C:\Program Files\ACORN4\Data\Cuprite\cup3rfl.

Input File Format:  This parameter specifies whether the input image data are band-interleaved-by-line (BIL) or
band-interleave-by-pixel (BIP).  The Cuprite data set is BIP file format.

Integer Format:  This parameter specifies whether the image data are stored as big endian (host, intel) or little
endian (network or IEEE).  The Cuprite integer format is big endian.

Image Dimension:  These are the dimension of the input image in terms of bands, lines, samples, and offset.  The
offset parameter is the number of bytes used to skip any embedded image headers.  The dimensions of the Cuprite
data set are 224 bands, 512 lines, and 614 samples with 0 byte offset.

Image Spectral Calibration file:  This is the spectral calibration file for the input image.  The default location is
C:\Program Files\ACORN4\Data\Cuprite\avr97.wvl.  This is a two column file.  The first column
is the center position of each spectral band in the image in nanometers.  The second column is the full-width-at-
half-maximum (FWHM) of the appropriate Gaussian function to describe the spectral response function of the
band in nanometers.  Table 6-2 shows a subset of this file.
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Table 6-2.  Cuprite image spectral calibration file.           
369.85 9.61 . . .
379.69 9.58
389.53 9.55
… …
2486.99 10.07
2496.90 10.05
2506.81             10.03                                                    

Dark Target Image Spectrum File:   This is a single column file with the extracted dark target spectrum from
the input image.  This spectrum corresponds to the location where an accurate surface reflectance spectrum has
been acquired.  The default location of the file for this tutorial is C:\Program
Files\ACORN4\Data\Cuprite\Cup3d.ext. Table 6-3 shows a portion of this file.

Table 6-3.  Dark Target Image Spectrum File.                 
864.64
1147.03
1587.77
…
10.35
15.77
11.48                                                                            

Dark Target Reflectance File :  This is the measured reflectance for the dark target.  The default location of the
file for this tutorial is C:\Program Files\ACORN4\Data\Cuprite\Cup3d.meas. This is a two
column file.  The first column is wavelength in nm and the second column is reflectance.  The reflectance is
multiplied by 10000 to product a scaling between 0 and 10000 in the output file.  Table 6-4 shows a portion of
this file.

                                                                        
Table 6-4.  Dark Target Reflectance File.            
350 1636.86
351 1638.53
352 1642.53
… …
2503 4079.83
2504 4081.07
2505     4082.10                                                 

Bright Target Image Spectrum File:   This is a single column file with the extracted dark target spectrum from
the input image.  This spectrum corresponds to the location where an accurate surface reflectance spectrum has
been acquired.  The default location of the file for this tutorial is C:\Program
Files\ACORN4\Data\Cuprite\Cup3b.ext. Table 6-5 shows a portion of this file.
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Table 6-5.  Bright Target Image Spectrum File.   
1524.44
2022.41
2694.53
…
31.85
45.26
31.55                                                                

Bright Target Reflectance File :  This is the measured reflectance for the bright target.  The default location of
the file for this tutorial is C:\Program Files\ACORN4\Data\Cuprite\Cup3b.meas. This is a two
column file.  The first column is wavelength in nm and the second column is reflectance.  The reflectance is
multiplied by 10000 to product a scaling between 0 and 10000 in the output file.  Table 6-6 shows a portion of
this file.

                                                                        
Table 6-6.  Bright Target Reflectance File.          
351 462.23
351 469.62
352 473.59
… …
2503 1174.56
2504 1173.76
2505     1173.2                                                  

Running ACORN Mode 3

To execute ACORN mode 3, click Run on the ACORN control panel.  A processing status box will appear to
indicate the progress of the atmospheric correction.  When the empirical atmospheric correction is complete the
program will return to the ACORN Control Panel.

ACORN Mode 3 Results

The principal result of ACORN Mode 3 is the empirical line reflectance image.

1.  With ENVI open the Cuprite empirical line reflectance image.  The default location for the tutorial is
c:\program files\ACORN4\Data\Cuprite\cup3rfl.  Figure 6-6 shows the reflectance image with bands
200, 130, 30 displayed as Red, Green, Blue respectively.

2.  Extract the empirical line corrected spectra from the sites in table 6-1.  The extracted spectra are shown in
Figure 6-7.

3.  Compare the extracted empirical line corrected spectra with the input image radiance spectra in Figure 6-3.
The radiance data have been corrected to apparent surface reflectance.  Some residual artifacts remain near the
water vapor bands because the empirical line correction assumes a homogenous atmosphere over the entire data
set.
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Figure 6-6.  Empirical line atmospheric correction image following use of ACORN Mode 3.

Figure 6-7.  Extracted spectra from Cuprite data set after Mode 3 empirical line atmospheric correction.

Additional Output Files

In addition to the output image file there are several other files created by ACORN.

.in  This is the control file that provides the files and parameters that are used by ACORN.  The file cup3.in was
created in the default location for this tutorial example.
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.eco  In the same file location of the cup3.in file will be a cup3.in.eco.  This file is an echo of the input file as it is
being interpreted by the ACORN software.  If problems are detected interpreting the control file these will be
indicated in this file.

.diag1  In the same directory as the output reflectance file will be a cup3rfl.diag1.  The diag1  file confirms the
input parameters used in the atmospheric correction and indicates  problems encountered during the run.

.diag2  In the same directory as the output reflectance the cup3rfl.diag2 file will be created.  This file contains
selected spectral outputs that may be helpful to understand problems with the atmospheric correction.

Other Tutorial Examples

Additional tutorial examples are provided with ACORN for the Jasper Ridge AVIRIS and Cuprite Hymap data.
The default location for these files is c:\Program Files\ACORN4\Data\Jasper\jsp3.in. an d
c:\Program Files\ACORN4\Data\Cupriteh\cuph3.in.  You may run these examples and examine
the input and output files to gain additional experience with ACORN mode 3.
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Description

ACORN uses the designated multispectral spectral response functions to convolve a spectrally and
radiometrically calibrated hyperspectral data set to the corresponding multispectral data set. This convolution
handles the case of overlapping or irregularly spaced sampling in the hyperspectral data set. ACORN mode 4
requires input of a calibrated hyperspectral data set.   For the convolution, the spectral response functions of the
multispectral data set to be generated are required. Figure 7-1 shows the spectral response functions for a six band
multispectral sensor in the solar reflected spectrum.
Any multispectral data set may be generated that is within the spectral range of the hyperspectral data set.
Multispectral band response functions for existing, planned, or imagined multispectral sensors may be used.
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Figure 7-1: Multispectral spectral response functions for six bands in the solar reflected spectrum from 400 to
2500 nm.

Input Image Data

For this example of ACORN mode 1 the AVIRIS data set acquired over Jasper Ridge, California is used.  Begin
by examining the Jasper Ridge calibrated radiance data set provided with the ACORN software.

1. Start ENVI software on your computer

2. Open the Jasper Ridge data provide with ACORN.  The default installed location is c:\program
files\ACORN4\Data\Jasper\jsp0rdn.

3. Select bands 30, 40, 20 to display as red, green, blue.  This is done with in the Available Bands List window by
clicking the RGB Color option and then scrolling and clicking on band 30, 40 and 20 in that order.  Then click the
Load Band button.  This image is shown in Figure 7-2.  Figure 7-3 shows a set of extracted spectra from the
Jasper Ridge data.  Table 7-1 gives the site, and location of these extracted spectra.
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Figure 7-2.  Jasper Ridge radiance image.

4. Extract and examine the radiance spectra with ENVI Z profiles.
a)  This is done in the ENVI image window by selecting Functions>Profiles>Z Profiles.
b)  To move the cursor to a specific location, from the ENVI image window select Functions>Interactive
Analysis>Pixel Locator
c)  In the pixel locator window, enter the X and Y location and click Apply.
d)  To extract and save spectra select Option> New Window:Blank.
e) In the Z profile window click the right mouse button to show the X, Y location of the displayed spectrum.
f) To save a spectrum to the blank window drag X,Y location label to the new window.
g) Repeat this until you have all the Z profiles in the new window that you wish.
h) These extracted spectra may be saved to an ASCII file by selecting File>Output Data>ASCII.
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Figure 7-3.  Extracted spectra from Jasper Ridge radiance image.

Table 7-1.  Locations of Extracted Spectra                      
Site                                           Sample  Line                  
Stanford Golf Course 504 226
Jasper Ridge Grassland 314 159
Plowed Field 402 242
Redwood Forest 102 250
Felt Lake                                   398                   355       

Starting ACORN

In this example ACORN Mode 4 will be used to perform spectral convolution on the Jasper radiance data set.

1.  Start ACORN by selecting Start>Programs>ACORN4>ACORN.

The ACORN Control Panel will appear as shown in Figure 7-4.  ACORN operates based on control files that
provide the parameters and files for the ACORN algorithm.
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Figure 7-4.  ACORN Control Panel

Reviewing and Editing the Control File

Note: Except for the examples provided with ACORN you must obtain the appropriate calibration files and
data parameters from the data provider.

1.  From the ACORN Control Panel, select Open

2.  For this example, choose the Jasper Ridge Mode 4 tutorial control file.  The default installation location for
this control file is C:\Program Files\ACORN4\Data\Jasper\jsp4.in

3.  Examine the ACORN control file parameter entry panel shown in Figure 7-5.  These are the files and
parameters necessary to perform the hyperspectral to multispectral convolution.  Each parameter and file is
described below for this tutorial example.

Figure 7-5.  ACORN Mode 4 control file parameter entry window.

Input Image File Name:  This is the name of the input radiance image file.  The default location is
C:\Program Files\ACORN4\Data\Jasper\jsp0rdn.

Output Reflectance Image File Name:  This is the name of the output image to be generated by ACORN. For
this tutorial, the default location is C:\Program Files\ACORN4\Data\Jasper\jps4tm.
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Input File Format:  This parameter specifies whether the input image data are band-interleaved-by-line (BIL) or
band-interleave-by-pixel (BIP).  The Jasper Ridge data set is BIP file format.

Integer Format:  This parameter specifies whether the image data are stored as big endian (host, intel) or little
endian (network or IEEE).  The Jasper Ridge integer format is big endian.

Image Dimension:  These are the dimension of the input image in terms of bands, lines, samples, and offset.  The
offset parameter is the number of bytes used to skip any embedded image headers.  The dimensions of the Jasper
Ridge data set are 224 bands, 512 lines, and 614 samples with 0 byte offset.

Image Spectral Calibration file:  This is the spectral calibration file for the input image.  The default location is
C:\Program Files\ACORN4\Data\Jasper\avr97.wvl.  This is a two column file.  The first column
is the center position of each spectral band in the image in nanometers.  The second column is the full-width-at-
half-maximum (FWHM) of the appropriate Gaussian function to describe the spectral response function of the
band in nanometers.  Table 7-2 shows a subset of this file.

Table 7-2.  Cuprite image spectral calibration file.           
369.85 9.61 . . .
379.69 9.58
389.53 9.55
… …
2486.99 10.07
2496.90 10.05
2506.81             10.03                                                    

Hyperspectral Gain File:  This is the gain file that converts the image file integer values to radiance in units of
(W/m^2/um/sr).  For this tutorial example, the default installation location is C:\Program
Files\ACORN4\Data\Jasper\avr97.gain.   This is a one column file that is multiplied by the image
integer values to convert the integers to the correct radiance units. Table 7-3 shows a subset of this file.  This gain
factor is required to account changing gains across the spectrum before the convolution is applied.

Table 7-3.  Contents of the Jasper Ridge gain file.            
0.2
0.2
0.2
…
0.1
0.1
0.1                                                                                

Mulispectral Spectral Response File:  This is a two column ASCII file containing the multispectral spectral
response functions. The first column is the wavelength in nanometers and the second column is the response value
for the multispectral band. The spectral responses for each band are contained in this one file with the end of each
band indicated by a negative value in the second column. The default location of the file for this tutorial is
C:\Program Files\ACORN4\Data\Jasper\tm.rsp. Table 7-4 shows a portion of the spectral
response file.
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Table 7-4.  Mulispectral Spectral Response File.  
428 0.0000
430 0.0021
432 0.0087
… …
504 1.0000
506 0.9609
508 0.914
… …
552 0.0003
554 0.0001
556 -0.0001
502 0.0000
504 0.0006
506       0.0057                                                  

Multispectral Gain File:  This is the gain file that converts the convolved image radiance values to integer
values for the output file  For this tutorial example, the default installation location is C:\Program
Files\ACORN4\Data\Jasper\Jsp4tm.gain.   Table 7-5 shows a subset of this file.  This gain factor is
required to preserve the precision of the convolution in the output integer data.

Table 7-5.  Multispectral Gain File.        
100
100
100
100
100
100                                                       

Running ACORN Mode 4

To execute ACORN Mode 4, click Run on the ACORN control panel.  A processing status box will appear to
indicate the progress of the atmospheric correction.  When the convolution is complete the program will return to
the ACORN Control Panel.

ACORN Mode 4 Results

The principal result of ACORN Mode 4 is the convolved image.

1.  With ENVI open the Jasper Ridge convolved image.  The default location for the tutorial is c:\program
files\ACORN4\Data\Jasper\jsp4tm.  Figure 7-6 shows the convolved image with bands 3, 4, 2 displayed
as Red, Green, Blue respectively.

2.  Extract the convolved image spectra from the sites in table 7-1.  These spectra are shown in Figure 7-7.

3.  Compare the extracted convolved spectra with the input spectra in Figure 7-3.   The Hyperspectral data set has
been converted to multispectral.



79

Figure 7-6.  Convolved  image following use of ACORN Mode 4.

Figure 7-7.  Extracted spectra from Jasper Ridge data set after Mode 4 convolution

Additional Output Files

In addition to the output image file there are several other files created by ACORN.

.in  This is the control file that provides the files and parameters that are used by ACORN.  The file jsp4.in was
created in the default location for this tutorial example.
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.eco  In the same file location of the jsp4.in file will be a jsp4.in.eco.  This file is an echo of the input file as it is
being interpreted by the ACORN software.  If problems are detected interpreting the control file these will be
indicated in this file.

.diag1  In the same directory as the output file will be a jsp4tm.diag1.  The diag1  file confirms the input
parameters used in the atmospheric correction and indicates  problems encountered during the run.

.diag2  In the same directory as the output the jsp4tm.diag2 file will be created.  This file contains selected
spectral outputs that may be helpful to understand problems with the convolution.

Other Tutorial Examples

Additional tutorial examples are provided with ACORN for the Jasper Ridge AVIRIS and Cuprite Hymap data.
The default location for these files is c:\Program Files\ACORN4\Data\Cuprite\cup4.in. and
c:\Program Files\ACORN4\Data\Cupriteh\cuph4.in.  You may run these examples and examine
the input and output files to gain additional experience with ACORN mode 4.
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Chapter 8
Mode 5. Radiative transfer atmospheric correction of
calibrated multispectral data.
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Description

ACORN uses radiative transfer calculations to atmospherically correct multispectral data. With an input of
calibrated multispectral radiance data and baseline atmospheric parameters, ACORN produces an output of
apparent surface reflectance. An accurate spectral response functions file is required for this mode. The
multispectral data must be spectrally and radiometrically calibrated.

Figure 8-1 shows four radiance spectra from the example Jasper Ridge multispectral data set and the
atmospherically corrected spectra after ACORN mode 5.
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Figure 8-1: Left: radiance spectra for targets in the example Jasper Ridge multispectral data set. Right
ACORN Mode 5 results showing the apparent reflectance spectra for the same targets

Input Image Data

For this example of ACORN Mode 5 the AVIRIS data set acquired over Jasper Ridge, California convolved to the
Landsat Thematic Mapper multispectral bands is used.    This data set must be generate by following the Mode 4
example in the tutorial.  Begin by examining the Jasper Ridge convolved multispectral calibrated radiance data.

1. Start ENVI software on your computer

2. Open the Jasper Ridge data provide with ACORN.  The default location is c:\program
files\ACORN\Data\Jasper\jsp5tm.

3. Select bands 3, 4, 2 to display as red, green, blue.  This is done with in the Available Bands List window by
clicking the RGB Color option and then scrolling and clicking on band 3, 4 and 2 in that order.  Then click the
Load Band button.  This image is shown in Figure 8-2.  Figure 8-3 shows a set of extracted spectra from the
Jasper Ridge data.  Table 8-1 gives the site, and location of these extracted spectra.
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Figure 8-2.  Jasper Ridge Multispectral convolved radiance image.

4. Extract and examine the radiance spectra with ENVI Z profiles.
a)  This is done in the ENVI image window by selecting Functions>Profiles>Z Profiles.
b)  To move the cursor to a specific location, from the ENVI image window select Functions>Interactive
Analysis>Pixel Locator
c)  In the pixel locator window, enter the X and Y location and click Apply.
d)  To extract and save spectra select Option> New Window:Blank.
e) In the Z profile window click the right mouse button to show the X, Y location of the displayed spectrum.
f) To save a spectrum to the blank window drag X,Y location label to the new window.
g) Repeat this until you have all the Z profiles in the new window that you wish.
h) These extracted spectra may be saved to an ASCII file by selecting File>Output Data>ASCII.
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Figure 8-3.  Extracted spectra from Jasper Ridge convolved mulitpsectral radiance image.

Table 8-1.  Locations of Extracted Spectra                      
Site                                           Sample  Line                  
Stanford Golf Course 504 226
Jasper Ridge Grassland 314 159
Plowed Field 402 242
Redwood Forest 102 250
Felt Lake                                   398                   355       

These image radiance data contain the effects of the solar illumination,  two-way transmittance and scattering of
the atmosphere, as well as reflectance of the surface.  These image extracted spectra are also scaled so that the
radiance values fall in a range of efficiently stored integers.  ACORN Mode 5 is designed to correct for these
illumination and atmospheric effects in Multispectral data.

Starting ACORN

In this section ACORN Mode 5 will be used to atmospherically correct the Jasper Ridge calibrated multispectral
radiance data set.

1.  Start ACORN by selecting Start>Programs>ACORN4>ACORN.

The ACORN Control Panel will appear as shown in Figure 8-4.  ACORN operates based on control files that
provide the parameters for atmospheric correction.

Figure 8-4.  ACORN Control Panel

Reviewing and Editing the Control File

Note: Except for the examples provided with ACORN you must obtain the appropriate calibration files and
data parameters from the data provider.

1.  Select Open

2.  Select the Jasper Ridge mode 5 control file.  The default location for this file is C:\Program
Files\ACORN4\Data\Jasper\jsp5.in.
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3.  Examine the ACORN Mode 5 control file parameter entry panel shown in Figure 8-5.  These are the files and
parameters necessary to perform a Mode 5 atmospheric correction.  Each parameter and file is described for the
Jasper Ridge example.

Figure 8-5.  ACORN 4 Mode 5 control file parameter entry window.

Input Image File Name:  This is the name of the input radiance image file.  For this example, the default location
is C:\Program Files\ACORN4\Data\Jasper\jsp4tm.

Output Reflectance Image File Name:  This is the name of the output image to be generated by ACORN Mode
5.   For this example, the default location is C:\Program Files\ACORN4\Data\Jasper\jsp5tmrfl.

Input File Format:  This parameter specifies whether the input image data are band-interleaved-by-line (BIL) or
band-interleave-by-pixel (BIP).  The Jasper Ridge data set is BIP file format

Integer Format:  This parameter specifies whether the image data are stored as big endian (host, intel) or little
endian (network or IEEE).  The Jasper Ridge integer format is big endian.

Image Dimension:  These are the dimension of the input image in terms of bands, lines, samples, and offset.  The
offset parameter is the number of bytes used to skip any embedded image headers.  The dimensions of the Jasper
Ridge data set are 6 bands, 512 lines, and 614 sample with 0 byte offset.
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Image Spectral Response File:  This is a two column ASCII file containing the multispectral spectral response
functions. The first column is the wavelength in nanometers and the second column is the response value for the
multispectral band. The spectral responses for each band are contained in this one file with the end of each band
indicated by a negative value in the second column. The default location of the file for this tutorial is
C:\Program Files\ACORN4\Data\Jasper\tm.rsp. Table 8-2 shows a portion of the spectral
response file.

Table 8-2.  Mulispectral Spectral Response File.  
428 0.0000
430 0.0021
432 0.0087
434 0.0154
436 0.0221
… …
500 0.9791
502 0.9883
504 1.0000
506 0.9609
508 0.914
… …
552 0.0003
554 0.0001
556 -0.0001
502 0.0000
504 0.0006
506       0.0057                                                  

Gain File:  This is the gain file that converts the image integer values to radiance (W/m^2/um/sr).  For this
tutorial example, the default installation location is C:\Program
Files\ACORN4\Data\Jasper\Jsp5tm.gain.   Table 8-3 shows a subset of this file.

Table 8-3.  Multispectral Gain File.        
0.01
0.01
0.01
0.01
0.01
0.01                                                      

Offset File:  This is the offset file that corrects for any offset in the image file integer values in the conversion to
radiance in units of (W/m^2/um/sr).  For this example, the default location is
C:\Program Files\ACORN4\Data\Jasper\jsp5tm.off.  This is a one column file that is added to
the radiance values. Table 8-4 shows a subset of this file.

Table 8-4.  Contents of the Jasper Ridge multispectral offest file. 
0.0
0.0
0.0
0.0
0.0
0.0                                                                                            
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Image Latitude:  These are the degrees, minute, seconds of the image data set.  Each parameter may be integer or
decimal. If decimal degrees are used the minutes and second field should be zero.  North latitude is positive.  The
approximate latitude of the Jasper Ridge data set is 37.18.

Image Longitude:  These are the degrees, minute, seconds of the image data set.  Each parameter may be integer
or decimal.  If decimal degrees are used the minutes and second field should be zero.  The approximate longitude
of the Jasper Ridge data set is -122.3.  East longitude is positive.

Image Date:  This is the date of image acquisition in day, month, and year format.  This example data set was
acquired on the 3rd of April, 1997.

Image Time:  This is the average time of acquisition in hours, minutes, and seconds. The time must be
Greenwich Mean Time (GMT).  Each parameter may be integer or decimal.  The example Jasper Ridge data set
was acquired at 19:57:23 GMT.

Image Elevation:  This is the average elevation of the surface in the input image in meters.  The approximate
elevation of the Jasper Ridge example data set is 200 m.

Image Acquisition Altitude:  This is the altitude of the instrument that acquired the image data.  The altitude of
acquisition of this example Jasper Ridge data set is 20 km.

Atmospheric Model:  This option selects the appropriate atmospheric model to be used for atmospheric
correction.  The options are mid-latitude-summer, mid-latitude-winter, and tropical.  For this example the mid-
latitude-summer atmospheric model is selected.

Fixed Water Vapor:  A water vapor amount must be specified in units of precipitable mm of water vapor.  For
this example a value of 15 mm is used.

Image Atmospheric Visibility:  This parameter controls the visibility of the atmospheric model used in the
atmospheric correction.  A visibility of 60 km is entered for this example.

4.  Click OK to complete creation of ACORN mode 5 control file.

5. From the ACORN control panel window click Save to save the control file Jsp5.in.  

Running ACORN Mode 5

To execute ACORN mode 5,  click Run on the ACORN control panel.  A processing status box will appear to
indicate the progress of the atmospheric correction.  When the atmospheric correction is complete the program
will return to the ACORN Control Panel.

ACORN Mode 5 Results

The primary result of ACORN Mode 5 is the atmospherically corrected image.

1.  With ENVI open the Jasper Ridge reflectance image.  The location specified in the tutorial control file is
c:\program files\ACORN4\Data\Jasper\jsp5tmrfl.  Figure 8-6 shows the reflectance image with bands
3, 4, 2 displayed as Red, Green, Blue respectively.
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2.  Extract the atmospherically corrected spectra from the sites in table 8-1.  The extracted spectra are shown in
Figure 8-7.  These spectra are stored as 2 byte integers of reflectance multiplied by 10000.  This preserves the
precision of the measurement and allows the data to be stored efficiently.

3.  Compare the extracted reflectance spectra with the input radiance spectra.  The effects of the solar source and
atmosphere have been compensated.

Figure 8-6.  Atmospherically corrected Jasper Ridge image following implementation of ACORN mode 5.

Figure 8-7.  Extracted spectra from Jasper Ridge data set after mode 1 atmospheric correction.
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Additional Output Files

In addition to the output image file there are several other files created by ACORN.

.in  This is the control file that provides the files and parameters that are used by ACORN.  The file jsp5.in was
created in the default location for this tutorial example.

.eco  In the same file location of the jsp5.in file will be a jsp5.in.eco.  This file is an echo of the input file as it is
being interpreted by the ACORN software.  If problems are detected interpreting the control file these will be
indicated in this file.

.diag1  In the same directory as the output file will be a jsp5tmrfl.diag1.  The diag1  file confirms the input
parameters used in the atmospheric correction and indicates  problems encountered during the run.

.diag2  In the same directory as the output the jsp5tmrfl.diag2 file will be created.  This file contains selected
spectral outputs that may be helpful to understand problems with the convolution.

Other Tutorial Examples

Additional tutorial examples are provided with ACORN for the Cuprite AVIRIS and Cuprite Hymap data.  The
default location for these files is c:\Program Files\ACORN4\Data\Cuprite\cup5.in. an d
c:\Program Files\ACORN4\Data\Cupriteh\cuph5.in.  You may run these examples and examine
the input and output files to gain additional experience with ACORN mode 5.
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Description

ACORN Mode 6 uses a set of bands extracted from an atmospherically corrected multispectral data set and an
accurately known spectrum for the same target. With the band values and spectrum, the full atmospherically
corrected multispectral data set is then corrected to the accuracy of the known spectrum. ACORN accurately and
automatically convolves the known spectrum to the spectral characteristics of the multispectral data set for this
atmospheric correction enhancement.

Input Image Data

For this example the AVIRIS data set acquired over Jasper Ridge that has been convolved to Landsat Thematic
Mapper bands and atmospherically corrected is used.  The convolved and atmospherically corrected data set are
created by using ACORN modes 4 and 5 as described in proceeding chapters of this tutorial.

Begin by examining the Jasper Ridge convolved multispectral atmospherically corrected data.

1. Start ENVI software on your computer

2. Open the Jasper Ridge data.  The default location is c:\program
files\ACORN\Data\Jasper\jsp5tmrfl.

3. Select bands 3, 4, 2 to display as red, green, blue.  This is done with in the Available Bands List window by
clicking the RGB Color option and then scrolling and clicking on band 3, 4 and 2 in that order.  Then click the
Load Band button.  This image is shown in Figure 9-1.  Figure 9-2 shows a set of extracted spectra from the
Jasper Ridge data.  Table 9-1 gives the site, and location of these extracted spectra.

Figure 9-1.  Atmospherically corrected Jasper Ridge image following implementation of ACORN mode 4 and
Mode 5.

4. Extract and examine the radiance spectra with ENVI Z profiles.
a)  This is done in the ENVI image window by selecting Functions>Profiles>Z Profiles.

L
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b)  To move the cursor to a specific location, from the ENVI image window select Functions>Interactive
Analysis>Pixel Locator
c)  In the pixel locator window, enter the X and Y location and click Apply.
d)  To extract and save spectra select Option> New Window:Blank.
e) In the Z profile window click the right mouse button to show the X, Y location of the displayed spectrum.
f) To save a spectrum to the blank window drag X,Y location label to the new window.
g) Repeat this until you have all the Z profiles in the new window that you wish.
h) These extracted spectra may be saved to an ASCII file by selecting File>Output Data>ASCII.

Figure 9-2.  Extracted spectra from Jasper Ridge data set after Mode 4 convolution to multispectral data and
Mode 5 atmospheric correction.

Table 9-1.  Locations of Extracted Spectra                      
Site                                           Sample  Line                  
Stanford Golf Course 504 226
Jasper Ridge Grassland 314 159
Plowed Field 402 242
Redwood Forest 102 250
Felt Lake                                   398                   355       

Starting ACORN

In this example ACORN Mode 6 will be used to enhance the atmospheric correction for the Jasper Ridge Mode 4
and Mode 5  generated reflectance data set.

1.  Start ACORN by selecting Start>Programs>ACORN4>ACORN.

The ACORN Control Panel will appear as shown in Figure 9-3.  ACORN operates based on control files that
provide the parameters and files for the ACORN algorithm.
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Figure 9-3.  ACORN Control Panel

Reviewing and Editing the Control File

Note: Except for the examples provided with ACORN you must obtain the appropriate calibration files and
data parameters from the data provider.

1.  From the ACORN Control Panel, select Open

2.  For this example, choose the Japser Ridge Mode 6 example control file.  The default installation location for
this control file is C:\Program Files\ACORN4\Data\Jasper\jsp6.in

3.  Examine the ACORN control file parameter entry panel shown in Figure 9-4.  These are the files and
parameters necessary to perform the single spectrum enhancement to the atmospheric correction.  Each parameter
and file is described below for this tutorial example.
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Figure 9-4.  ACORN Mode 6 control file parameter entry window.

Input Image File Name:  This is the name of the input radiance image file.  The default location is
C:\Program Files\ACORN4\Data\jasper\jsp5tmrfl.

Output Reflectance Image File Name:  This is the name of the output image to be generated by ACORN. For
this tutorial, the default location is C:\Program Files\ACORN4\Data\Jasper\jps6tmrfl.

Input File Format:  This parameter specifies whether the input image data are band-interleaved-by-line (BIL) or
band-interleave-by-pixel (BIP).  The Jasper Ridge data set is BIP file format.

Integer Format:  This parameter specifies whether the image data are stored as big endian (host, intel) or little
endian (network or IEEE).  The Jasper Ridge integer format is big endian.

Image Dimension:  These are the dimension of the input image in terms of bands, lines, samples, and offset.  The
offset parameter is the number of bytes used to skip any embedded image headers.  The dimensions of the Jasper
Ridge data set are 224 bands, 512 lines, and 614 samples with 0 byte offset.

Image Spectral Response File:  This is a two column ASCII file containing the multispectral spectral response
functions. The first column is the wavelength in nanometers and the second column is the response value for the
multispectral band. The spectral responses for each band are contained in this one file with the end of each band
indicated by a negative value in the second column. The default location of the file for this tutorial is
C:\Program Files\ACORN4\Data\Jasper\tm.rsp. Table 9-2 shows a portion of the spectral
response file.
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Table 9-2.  Mulispectral Spectral Response File.  
428 0.0000
430 0.0021
432 0.0087
434 0.0154
436 0.0221
… …
500 0.9791
502 0.9883
504 1.0000
506 0.9609
508 0.914
… …
552 0.0003
554 0.0001
556 -0.0001
502 0.0000
504 0.0006
506       0.0057                                                  

Image Target Spectrum File:   This is a single column file with the extracted spectrum from jsp5tmrfl that
corresponds to the location where a accurate surface reflectance spectrum has been acquired.  The default location
of the file for this tutorial is C:\Program Files\ACORN4\Data\Jasperr\jsp6tm.ext. Table 9-3
shows a portion of this file.   The units of this file are reflectance * 10000

Table 9-3.  Jasper Image Target Reflectance  File.
777.59
1171.09
1498.30
2196.30
3567.10
3194.80                                                             

Measured Target Reflectance Spectrum File :  This is the measured reflectance for the same target as the
Image Target Reflectance Spectrum File.  The default location of the file for this tutorial is C:\Program
Files\ACORN4\Data\Jasper\jps6tm.meas. This is a two column file.  The first column is wavelength
in nm and the second column is reflectance.  The reflectance is multiplied by 10000 to have the same scaling as
the Image Target Reflectance Spectrum File.  Table 9-4 shows a portion of this file.

Table 9-4.  Contents of the Measured Target Reflectance Spectrum File.   
350 250.02
351 251.14
352 253.81
… …
2498 2573.75
2499 2574.65
2500     2575.773                                                                       
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Running ACORN Mode 6

To execute ACORN mode 6, click Run on the ACORN control panel.  A processing status box will appear to
indicate the progress of the single spectrum enhancement.  When the processing is complete the program will
return to the ACORN Control Panel.

ACORN Mode 6 Results

The principal result of ACORN Mode 6 is the single spectrum enhanced reflectance image.

1.  With ENVI open the Jasper Ridge single spectrum enhanced image.  The default location for the tutorial is
c:\program files\ACORN4\Data\Jasper\jsp6tmrfl.  Figure 9-5 shows the reflectance image with
bands 3, 4, 2 displayed as Red, Green, Blue respectively.

2.  Extract the single spectrum enhanced spectra from the sites in table 9-1.  The extracted spectra are shown in
Figure 9-6.

3.  Compare the extracted single spectrum enhanced spectra with the input reflectance spectra in Figure 6-2.  The
radiative transfer code based reflectance has been enhanced to the accuracy of the surface reflectance spectrum of
the target area.

Figure 9-5.  Multispectral Single Spectrum Enhanced image following use of ACORN Mode 6.
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Figure 9-6.  Extracted spectra from Jasper Ridge data set after Mode 6 Single Spectrum Enhancement.

Additional Output Files

In addition to the output image file there are several other files created by ACORN.

.in  This is the control file that provides the files and parameters that are used by ACORN.  The file jsp6.in was
created in the default location for this tutorial example.

.eco  In the same file location of the jsp6.in file will be a jsp6.in.eco.  This file is an echo of the input file as it is
being interpreted by the ACORN software.  If problems are detected interpreting the control file these will be
indicated in this file.

.diag1  In the same directory as the output file will be a jsp6tmrfl.diag1.  The diag1  file confirms the input
parameters used in the atmospheric correction and indicates  problems encountered during the run.

.diag2  In the same directory as the output the jsp6tmrfl.diag2 file will be created.  This file contains selected
spectral outputs that may be helpful to understand problems with the convolution.

Other Tutorial Examples

Additional tutorial examples are provided with ACORN for the Cuprite AVIRIS and Cuprite Hymap data.  The
default location for these files is c:\Program Files\ACORN4\Data\Cuprite\cup6.in. an d
c:\Program Files\ACORN4\Data\Cupriteh\cuph6.in.  You may run these examples and examine
the input and output files to gain additional experience with ACORN mode 6.



100



101
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Description

ACORN uses a dark and bright extracted target spectrum from a multispectral data set and corresponding
measured ground spectra for these targets. These input pair of band values and pair of known spectra are used to
implement an empirical line atmospheric correction. ACORN accurately and automatically convolves the known
spectra to the spectral characteristics of the multispectral data set for this mode of atmospheric correction. This
mode is less dependent on the accuracy of the radiometric calibration of the multispectral data. In some cases raw
integer values can be used.

Input Image Data

For this example the AVIRIS data set acquired over Jasper Ridge that has been convolved to Landsat thematic
mapper bands is used.  This convolution is achieved by using ACORN mode 4 as described in an earlier chapter
of this tutorial.

Begin by examining the Jasper Ridge convolved multispectral data.

1. Start ENVI software on your computer

2. Open the Jasper Ridge data.  The default location is c:\program
files\ACORN4\Data\Jasper\jsp4tm.

3. Select bands 3, 4, 2 to display as red, green, blue.  This is done with in the Available Bands List window by
clicking the RGB Color option and then scrolling and clicking on band 3, 4 and 2 in that order.  Then click the
Load Band button.  This image is shown in Figure 10-1.  Figure 10-2 shows a set of extracted spectra from the
Jasper Ridge data.  Table 10-1 gives the site, and location of these extracted spectra.

Figure 10-1.  Jasper Ridge Multispectral convolved radiance image.

4. Extract and examine the radiance spectra with ENVI Z profiles.
a)  This is done in the ENVI image window by selecting Functions>Profiles>Z Profiles.

L
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b)  To move the cursor to a specific location, from the ENVI image window select Functions>Interactive
Analysis>Pixel Locator
c)  In the pixel locator window, enter the X and Y location and click Apply.
d)  To extract and save spectra select Option> New Window:Blank.
e) In the Z profile window click the right mouse button to show the X, Y location of the displayed spectrum.
f) To save a spectrum to the blank window drag X,Y location label to the new window.
g) Repeat this until you have all the Z profiles in the new window that you wish.
h) These extracted spectra may be saved to an ASCII file by selecting File>Output Data>ASCII.

Figure 10-2.  Extracted spectra from Jasper Ridge convolved multipsectral radiance image.

Table 10-1.  Locations of Extracted Spectra                     
Site                                           Sample  Line                  
Stanford Golf Course 504 226
Jasper Ridge Grassland 314 159
Plowed Field 402 242
Redwood Forest 102 250
Felt Lake                                   398                   355       

These image radiance data contain the effects of the solar illumination, two-way transmittance and scattering of
the atmosphere, as well as reflectance of the surface.  These image extracted spectra are also scaled so that the
radiance values fall in a range of efficiently stored integers.  ACORN mode 7 is designed implement an empirical
line atmospheric correction.

Starting ACORN

In this example ACORN Mode 7 will be used to implement an empirical line correction on the Jasper Ridge data
set that has been convolved to the Landsat Thematic Mapper multispectral bands.



104
1.  Start ACORN by selecting Start>Programs>ACORN4>ACORN.

The ACORN Control Panel will appear as shown in Figure 10-2.  ACORN operates based on control files that
provide the parameters and files for the ACORN algorithm.

Figure 10-2.  ACORN Control Panel

Reviewing and Editing the Control File

1.  From the ACORN Control Panel, select Open

2.  For this example, choose the Japser Ridge Mode 7 example control file.  The default installation location for
this control file is C:\Program Files\ACORN4\Data\Jasper\jsp7.in

3.  Examine the ACORN control file parameter entry panel shown in Figure 10-3.  These are the files and
parameters necessary to perform the atmospheric correction.  Each parameter and file is described below for this
tutorial example.
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Figure 10-3.  ACORN Mode 7 control file parameter entry window.

Input Image File Name:  This is the name of the input radiance image file.  The default location is
C:\Program Files\ACORN4\Data\jasper\jsp4tm.

Output Reflectance Image File Name:  This is the name of the output image to be generated by ACORN. For
this tutorial, the default location is C:\Program Files\ACORN4\Data\Jasper\jps7tmrfl.

Input File Format:  This parameter specifies whether the input image data are band-interleaved-by-line (BIL) or
band-interleave-by-pixel (BIP).  The Jasper Ridge data set is BIP file format.

Integer Format:  This parameter specifies whether the image data are stored as big endian (host, intel) or little
endian (network or IEEE).  The Jasper Ridge integer format is big endian.

Image Dimension:  These are the dimension of the input image in terms of bands, lines, samples, and offset.  The
offset parameter is the number of bytes used to skip any embedded image headers.  The dimensions of the Jasper
Ridge data set are 6 bands, 512 lines, and 614 samples with 0 byte offset.

Image Spectral Response File:  This is a two column ASCII file containing the multispectral spectral response
functions. The first column is the wavelength in nanometers and the second column is the response value for the
multispectral band. The spectral responses for each band are contained in this one file with the end of each band
indicated by a negative value in the second column. The default location of the file for this tutorial is



106
C:\Program Files\ACORN4\Data\Jasper\tm.rsp. Table 10-2 shows a portion of the spectral
response file.

Table 10-2.  Mulispectral Spectral Response File.
428 0.0000
430 0.0021
432 0.0087
434 0.0154
436 0.0221
… …
500 0.9791
502 0.9883
504 1.0000
506 0.9609
508 0.914
… …
552 0.0003
554 0.0001
556 -0.0001
502 0.0000
504 0.0006
506       0.0057                                                  

Dark Target Image Value File:   This is a single column file with the extracted  values from the image jsp4tm
that corresponds to the location where a accurate surface reflectance spectrum of a dark target has been acquired.
The default location of the file for this tutorial is C:\Program
Files\ACORN4\Data\Jasperr\jsp7tmd.ext. Table 10-3 shows a portion of this file.   The units are
the image value units.

Table 10-3.  Jasper Image Dark Target  File.      
6782.2
5066.2
3874.5
3076.0
507.2
154.9                                                                

Dark Target Reflectance Spectrum File :  This is the measure reflectance for the dark target.  The default
location of the file for this tutorial is C:\Program Files\ACORN4\Data\Jasper/jps7tmd.meas.
This is a two column file.  The first column is wavelength in nm and the second column is reflectance.  The
reflectance is multiplied by 10000 so that the output file will have this scale.

Table 10-4.  Contents of the Dark Target Reflectance Spectrum File.        
350 400.03
351 402.22
352 407.38
… …
2498 686.61
2499 685.99
2500     685.38                                                                                      
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Bright Target Image Value File:   This is a single column file with the extracted values from the image jsp4tm
that corresponds to the location where a accurate surface reflectance spectrum of a bright target has been acquired.
The default location of the file for this tutorial is C:\Program
Files\ACORN4\Data\Jasperr\jsp7tmd.ext. Table 10-5 shows a portion of this file.   The units are
the image value units.

Table 10-5.  Jasper Image Bright Target  File.    
23062.2
22706.1
20291.2
14731.5
2494.4
757.9                                                                

Bright Target Reflectance Spectrum File :  This is the measure reflectance for the bright target.  The default
location of the file for this tutorial is C:\Program Files\ACORN4\Data\Jasper/jps7tmb.meas.
This is a two column file.  The first column is wavelength in nm and the second column is reflectance.  The
reflectance is multiplied by 10000 so that the output file will have this scale. Table 10-6 shows a portion of this
file

Table 10-6.  Contents of the Bright Target Reflectance Spectrum File.      
350 1920.492
351 1928.312
352 1946.853
… …
2498 3249.936
2499 3246.004
2500     3242.096                                                                                   

Running ACORN Mode 7

To execute ACORN mode 7, click Run on the ACORN control panel.  A processing status box will appear to
indicate the progress of the atmospheric correction.  When the atmospheric correction is complete the program
will return to the ACORN Control Panel.

ACORN Mode 7 Results

The principal result of ACORN Mode 7 is the empirical line reflectance image.

1.  With ENVI open the Jasper Ridge empirical line reflectance image.  The default location for the tutorial is
c:\program files\ACORN4\Data\Jasper\jsp7tmrfl.  Figure 10-4 shows the reflectance image with
bands 3, 4,2 displayed as Red, Green, Blue respectively.

2.  Extract the single spectrum enhanced spectra from the sites in table 10-1.  The extracted spectra are shown in
Figure 10-5.
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3.  Compare the extracted single spectrum enhanced spectra with the input radiance spectra in Figure 10-2.  The
effects of the illumination and the atmosphere have been suppressed.

Figure 10-4.  Multispectral empirical line image following use of ACORN Mode 7.

Figure 10-5..  Extracted spectra from Jasper Ridge data set after Mode 7 empirical line.

Additional Output Files

In addition to the output image file there are several other files created by ACORN.

.in  This is the control file that provides the files and parameters that are used by ACORN.  The file jsp7.in was
created in the default location for this tutorial example.
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.eco  In the same file location of the jsp7.in file will be a jsp7.in.eco.  This file is an echo of the input file as it is
being interpreted by the ACORN software.  If problems are detected interpreting the control file these will be
indicated in this file.

.diag1  In the same directory as the output file will be a jsp7tmrfl.diag1.  The diag1  file confirms the input
parameters used in the atmospheric correction and indicates  problems encountered during the run.

.diag2  In the same directory as the output the jsp7tmrfl.diag2 file will be created.  This file contains selected
spectral outputs that may be helpful to understand problems with the convolution.

Other Tutorial Examples

Additional tutorial examples are provided with ACORN for the Cuprite AVIRIS and Cuprite Hymap data.  The
default location for these files is c:\Program Files\ACORN4\Data\Cuprite\cup7.in. an d
c:\Program Files\ACORN4\Data\Cupriteh\cuph7.in.  You may run these examples and examine
the input and output files to gain additional experience with ACORN mode 7.


