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Chapter 1

System Overview

The SIMA system consists of components that allow the user to monitor seismometers, display and store the data locally,
and transmit that data to clients over the Internet.

1.1 Components

There are three main components to the software: the client, server, embedded microsystem (TINI). The client can be run
by anyone with an Internet connection and is used to monitor and display seismic data being transmitted from different
servers on the Internet. The server and TINI software work in conjunction with each other. The TINI software runs on the
TINI and actually monitors the amplified signals from the seismometers, converting the analog signal to digital data and
transmitting it to the server over a network connection. The server displays the data locally and transmits the data to the
client software over the internet.

1.2 System Requirements

The client and server software require a PC running at least Windows 95 (2000 or XP recommended)
The TINI software requires a TINI board from Dallas Semiconductor.
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Chapter 2

Client Software

2.1 Installation

2.1.1 From the web

Download the appropriate client setup file from

http://www.physics.moravian.edu/seismic/download.html

After downloading the file, locate it on your computer and double-click on it to execute it. This will begin the setup
program that will walk you through each step of installing the Seismic Internet Monitoring Application Client.

2.1.2 From CD-ROM

For this section we will assume that D: is the drive letter of your CD-ROM.
In order to install the client, run the setup program located at

D:\Client\setup.exe

This program will step you through the installation of the client software.

2.2 Getting Started

When you first start the program you will be presented with a blank trace window that will connect you to the Moravian
seismic station by default. If you wish to see data right away, select:

Seismometer -> Connect

This will connect you to the server running at Moravian College in Bethlehem, PA, USA.

2.3 Station Management

2.3.1 Setting Station Address

To set the address of the station for the active trace window select:

Setup -> Set Station Address

This will bring up a window where you can enter the name, address, and port number of the server to which you wish to
make a connection. The name is a name for the station that is selected by the user. The name is used for creating a folder
in which the seismic data may be saved. The address is the network address of the server to which a connection is made,
either in the form of an IP address (e.g. 204.186.196.43) or a name address (e.g. quake.cs.moravian.edu). The port will be
5999. Do not change this number; this has been made a variable for possible future development of the software.
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2.3.2 Changing the Station Name

If at any time you wish to change the name of a station select:

Setup -> Station Name

Then enter a name for the station in the text box.

2.3.3 Adding a Station

To add a station select:

File -> Add Seismometer

This will bring up a blank trace window. You must set the station address as described above and then you are set to go.
Current valid station addresses are available at

http://www.physics.moravian.edu/seismic/stations.html

2.3.4 Viewing All Stations

To view all stations that you are connected to select:

File -> View All Connections

This will bring up a window displaying a list of all the servers to which you are currently connected. From this window
you can remove a connection by selecting it from the list and clicking the Remove Connection button. If a connection is
listed but no trace window is displayed for the connection, one can be displayed by selecting the connection and clicking
the Show Trace Form button.

2.4 Data Storage

2.4.1 Saving Data

By default the seismic data is not stored locally on the client. If you wish to store the seismic data locally select:

Seismometer -> Save Trace Data

The data will then be stored in the folder

./data/<station name>/

where station name is the name you entered when setting up the station. Files will be stored in that folder by the date
and time in the format year-month-day-hour-minute-second with the extension .trc. If the triggering option is invoked, see
section 2.6, and the incoming data exceeded the trigger limits, the extension of the file will be .qke.

2.4.2 Opening Saved Data

To open a file containing saved seismic data select:

File -> Open Trace File

This will bring up a window similar to the trace window displaying all the trace data in that file. Currently the display
options for saved trace data can not be changed. If you use the mouse pointer to click on the displayed trace,the voltage
(from 0 to +5.0 volts) and the timestamp will be displayed.

2.5 Display

2.5.1 Types

The program allows the user to select the method of display for the trace data. There are currently two different display
modes, split-screen mode and full screen mode.
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Split-Screen Mode

This mode breaks up the window into individual sections, one for each trace. For example, if the server you are connected
to has 3 traces, the window will be broken up into 3 equally sized strips and each trace will only draw in it’s strip. This is
the default display mode for the program.

Full Screen Mode

This mode draws all the traces overlapping using the full height of the window. An offset can be specified for each trace to
control their separation on the display, but each trace will draw over the other.

2.5.2 Display Attributes

All display modes and attributes can be selected and changed by selecting:

Trace -> Change Display Attributes

Mode

By selecting the mode tab you can change the display mode to split-screen or full screen. If the mode you select is
fullscreen, four text boxes will appear on the bottom where you can enter the offset for each trace. The maximum number
of traces that can be displayed in one trace window is four.

Colors

By selecting the Colors tab you can change the color of the display. In split-screen mode you can assign a color for the
trace, background, triggers, and center lines. In full screen mode you can assign a separate color for each trace. The
background color will remain the current background color.

Line Widths

By selecting the Line Widths tab you can change the width of the various lines drawn on the trace. Enter a number in the
text box and a line will appear in the picture box next to it as an example of that width. You can independently change the
width of the trace, trigger, and center line.

2.6 Triggering

The program allows the user to set triggers for each of the channels. When a trigger limit is exceeded a window will pop
up displaying the channel that exceeded its limit, the time it occurred, and in which file the data is located.

2.6.1 Setting Triggers

To set the triggers after you have connected to a server select:

Triggers -> Set Triggers

This will bring up a window where you can select the channel, set the upper and lower limits. You can also select the
option to monitor any channel. Also, an audible alert tone can be selected to be played when the channel exceeds the
trigger limits. If the saved data option is invoked and the incoming data exceeds the trigger limits, the extension of the
saved file will be changed from .trc to .qke to identify to the user files that may contain seismic events.

2.6.2 Viewing Triggers

To see a visual representation of the triggers on the trace select:

Triggers -> View Triggers

This will draw lines across the trace representing the trigger values.
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Chapter 3

Server Software

The server software is used only if you have a seismometer and a TINI. See section 4.1.

3.1 Installation

3.1.1 From the web

Download the appropriate server setup file from

http://www.cs.moravian.edu/seismic/download.html

After downloading the file, locate it on your computer and execute it. This will begin the setup program that will walk you
through each step of installing the Seismic Internet Monitoring Application Server.

3.1.2 From CDROM

For this section we will assume that D: is the drive letter of your CD-ROM.
In order to install the server run the setup program located at

D:\Server\setup.exe

This program will step you through the installation of the server software.

3.2 Getting Started

Upon starting up the server software you will be presented with a blank trace screen. Select:

Seismometer -> Set Seismometer Address

You must then fill in the address and port of the TINI. After filling in this information select:

Seismometer -> Connect

To connect to the TINI and begin receiving data from it.

3.3 TINI Management

3.3.1 Setting TINI Address

To set the address of a TINI select:

Seismometer -> Set Seismometer Address

Then enter the IP address and port on which the TINI is listening for connections.
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3.3.2 Adding a TINI

To add a TINI to the server select:

File -> Add Seismometer

This will bring up a blank trace window where you can then set the address and port of the TINI and begin receiving data
from it.

3.3.3 Viewing All TINIs

To view a list of all TINIs you are connected to select:

File -> View All Connections

This will bring up a window displaying a list of all the servers to which you are currently connected. From this window
you can remove a connection by selecting it from the list and clicking the Remove Connection button. If a connection is
listed but no trace window is displayed for the connection, one can be displayed by selecting the connection and clicking
the Show Trace Form button.

3.4 Data Storage

3.4.1 Saving Data

Data is stored on the server by default. The data is stored in the folder

./data/<station name>/

, where station name is the name you entered when setting up the station. Files will be stored in that folder by the date
and time in the format year-month-day-hour-minute-second with the extension .trc. If the triggering option is invoked, see
section 3.6, and the incoming data exceeded the trigger limits, the extension of the file will be .qke.

3.4.2 Opening Saved Data

To open a file containing saved seismic data select:

File -> Open Trace File

This will bring up a window similar to the trace window displaying all the trace data in that file. Currently the display
options for saved trace data can not be changed. If you use the mouse pointer to click on the displayed trace,the voltage
(from 0 to +5.0 volts) and the timestamp will be displayed.

3.5 Display

3.5.1 Types

The program allows the user to select the method of display for the trace data. There are currently two different display
modes, split-screen mode and full screen mode.

Split-Screen Mode

This mode breaks up the window into individual sections, one for each trace. For example, if the server you are connected
to has 3 traces, the window will be broken up into 3 equally sized strips and each trace will only draw in it’s strip. This is
the default display mode for the program.

Full Screen Mode

This mode draws all the traces overlapping using the full height of the window. An offset can be specified for each channel
but each trace will draw over the other.
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3.5.2 Display Attributes

All display modes and attributes can be selected and changed by selecting:

Trace -> Change Display Attributes

Mode

By selecting the mode tab you can change the display mode to split-screen or full screen. If the mode you select is
fullscreen, four text boxes will appear on the bottom where you can enter the offset for each channel.

Colors

By selecting the Colors tab you can change the color of the display. In split-screen mode you can assign a color for the
trace, background, triggers, and center lines. In full screen mode you can assign a color for each channel. The background
color will remain the current background color.

Line Widths

By selecting the Line Widths tab you can change the width of the various lines drawn on the trace. Enter a number in the
text box and a line will appear in the picture box next to it as an example of that width. You can change the width of the
trace, trigger, and center line.

3.6 Triggering

The program allows the user to set triggers for each of the channels. When a trigger limit is exceeded a window will pop
up displaying the channel that exceeded it’s limit, the time it occurred, and which file the data is located in.

3.6.1 Setting Triggers

To set the triggers after you have connected to a server select:

Triggers -> Set Triggers

This will bring up a window where you can select the channel, set the upper and lower limits. You can also select if you
wish to monitor the channel and if you want an audible warning when the channel exceeds the trigger limits.

3.6.2 Viewing Triggers

To see a visual representation of the triggers on the trace select:

Triggers -> View Triggers

This will draw lines across the trace representing the trigger values.

3.7 Server Maintenance

To perform maintenance on the seismometer select:

Seismometer -> Peform Server Maintenance

This will allow you to adjust the seismometers and still see the traces as they are being drawn across the screen, but the
center value for the system will be sent out to all clients to prevent false triggering.
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Chapter 4

TINI Software

4.1 Hardware

For this project we are using a 1MB TINI and the Step+ board from Systronix.

http://www.systronix.com

4.2 Setting up the TINI

Instructions for setting up the firmware and operating system for the TINI can be found at

http://www.systronix.com/tutor/tini_quick/tini_quick_top.htm

You do not need to install JBuilder to use this program.

4.3 Connecting Seismometers to the TINI

Located on the Step+ board is a row of 8 pins broken up into 4 pairs, numbered 1 through 4. Each pin has a + or - under it
indicating the polarity which should be connected to it in order for the A-D converter to function properly. If you have more
than one seismometer, begin connecting the seismometers at pair 4 and with each one you add work down towards pair
1. Make sure that you connect the wires properly to maintain the indicated polarity. The voltage range of your amplifier
output should be between 0 and 5 volts, centered at 2.5v. The connectors we use to connect to the pins on the TINI are
from Digi-Key

http://www.digikey.com

. Parts number A3007 and A3017. A3007 are the metal terminals. A3017 is the plug.

4.4 Installing the TINI Software

Download the appropriate TINI files from

http://www.physics.moravian.edu/download.html

Unzip the contents to your computer. After the operating system and slush (the shell program) have been installed on the
TINI, FTP into the system. Make sure the mode is set to binary. Send the unzipped .tini files to the TINI.

4.5 Configuring the TINI Software

To configure the software, telnet into the TINI. From wherever you installed the software above run ”java config.tini”
This will run a program that asks you a few questions about the configuration of the software. The suggested values are 10
data points to integrate and to listen on port 5050.
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4.6 Running the TINI Software

After the software has been configured run ”java SeismometerMonitor.tini” from the telnet command line.

4.7 Troubleshooting

TINI Commands:
ps - list all processes
kill - kill a process
reboot - reboot the TINI
java - start a .tini application
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Appendix A

Protocol Specification

A.1 TINI Communication

A.2 Connection Initiation

When the server makes a connection to the TINI a message is sent from the TINI to the server. This message contains a
single byte with the value 1-4 indicating the number of seismometers connected to the TINI. It then enters its run loop.

A.3 TINI Message

This is the message that is sent from the TINI to the Server.
Hour - 1 byte, value between 0 and 23
Minute - 1 byte, value between 0 and 59
Second - 1 byte, value between 0 and 59
Hundreth - 1 byte, value between 0 and 99
Month - 1 byte, value between 1 and 12
Day - 1 byte, value between 1 and 31
Year - 2 bytes, values begin at 0, epoch begins at 2000.
Channel(1-4) - 4 bytes, integer, represents voltage times 100000000 (e.g. 2.73V = 273000000)

A.4 Server Communication

A.5 Server Message

This is the message that is sent from the Server to the Client.
Hour - 1 byte, value between 0 and 23
Minute - 1 byte, value between 0 and 59
Second - 1 byte, value between 0 and 59
Hundreth - 1 byte, value between 0 and 99
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Month - 1 byte, value between 1 and 12
Day - 1 byte, value between 1 and 31
Year - 2 bytes, represents current year.
Channel(1-4) - 8 bytes, double, represents voltage for the given channel.
Additional Data - 32 bytes, reserved for future development
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