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Introduction 

1. Introduction to 4SPack 

Presentation 

4SPack is a software package designed to support your GPS surveys. 
4SPack offers the same functions and benefits from the same assets as its 
predecessor 3SPack, with even higher levels of performance, compactness 
and user-friendliness. For example, 4SPack can support both real-time and 
post-processing surveys in the same project. 
4SPack is organized around a powerful database containing all the data 
created or collected at different stages during your projects. 
Any data collection in the project database can be viewed in different forms 
through a simple drag & drop operation. The documents created in this way 
consist of tables, maps or graphs and are all attached to the project. Modi-
fying an object in a collection through one of these documents auto-
matically impacts all the other documents present in the project. 
4SPack also includes the following functions: import/export, background 
map projects, network adjustment, report generation, coordinate system 
management, coordinate transformations tool complying with the OpenGIS 
Implementation Specification document, etc.  
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�� Utility Programs Provided 
Different tools are provided in 4SPack. They are used to: 

- Edit /manage coordinate systems used by 4SPack 
- Transform coordinates from a known system to another known 

system 
- Set leap seconds involved in the GPS-to-UTC time conversion at 

any given date 
- Transform GPS week & time into local date & time 

In addition, 4SPack is delivered with 4 separate utility programs: 
- Pred is used to depict the GPS constellation seen from any given 

point located on the Earth surface, at any given time in the past 
or future. Pred provides both qualitative and quantitative figures 
about the constellation then visible. 

 You can then use Pred to choose the best moment when to per-
form a survey. In addition, the Curtain function allows you to 
simulate the impact of close obstructions on the number of us-
able satellites, on the GDOP, etc. 

 Pred can also be used when post-processing files as a monitoring 
tool, for example for better understanding of what happened 
when logging the raw data files. 

- WinComm is used to communicate with a GPS/GNSS Thales 
Navigation receiver, directly from the PC to which it is attached, 
via the set of proprietary commands available (“$PDAS” NMEA 
0183 compatible). From WinComm, you can check / modify the 
receiver settings (configuration) or run raw data recording se-
quences in manual or automatic mode. 

- Geoids allows you to exploit all geoid models existing to date. In 
practice, you can use Geoids to extract part of the data from a ge-
oid model, according to the geographical region you choose, and 
load this data direct to the Thales Navigation receiver for further 
use in the field. In this way, any position fix performed in refer-
ence to the ellipsoid will be corrected through this model to give 
elevation. 
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- DTR is used to convert raw data files logged by a Thales Naviga-
tion receiver into RINEX-compatible files for further use in any 
other system compatible with the RINEX format. 

 

Installation 

�� Minimum System Requirements 
- Personal Computer, PC type 
- Operating system: Windows 9x / Me / NT / 2000 / XP 
- Processor: Pentium 100 MHz or faster 
- RAM: minimum 32 MB, 64 MB recommended 
- Space occupied on hard disk (without user data): 16 MB approx. 
- CD-ROM drive 
- PC Card drive recommended for post-processing 
-  One or more RS232 serial ports 
 

�� Installing 4SPack 
- Close all the applications running in Windows 
- Insert the 4SPack CD-ROM in the drive 
- If the Autorun program does not start automatically from the 

CD-ROM, in the Windows task bar, click on Start and select 
Run... 

- Type x:\setup  (where x is the name of the CD-ROM drive) and 
then press Enter. After you specify where to install 4SPack pro-
grams and projects, and you agree to the terms of the software 
license, your computer will complete the installation process.   
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Overview 

�� Starting / quitting 4SPack 
- Starting 4SPack: In the Windows task bar, click on Start and se-

lect Programs>Ashtech>4SPack. The main window opens from 
which you can start working with 4SPack. See description of this 
window on the next page. 

- Quitting 4SPack: On the 4SPack menu bar, select File>Exit. This 
closes the application. If projects are still open in the main win-
dow when running the Exit command, then all these projects will 
be first saved and closed before 4SPack itself is closed. 

 
�� Unlocking a Software Option 

You may need to unlock one of the software options you purchased to be 
able to use 4SPack according to your needs. To do this: 

- On the 4SPack menu bar, select Help>About 4SPack 
- In the About 4SPack dialog box that opens, click on the ...button 

(on the right). A new dialog box opens, which looks like this: 

  
 To get the password needed to run the desired option, click on 

sales-administration@thalesnavigation.com. This automatically 
opens a new, predefined e-mail that you just have to complete 
and send. From your personal code (shown on top of the above 
dialog box) and the VT number provided by your distributor, we 
will generate a password for you. Once you get this password, 
type it in the lower edit box (see dialog box above) and then 
click OK. The software option is now unlocked, ready for use. 
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�� Description of the Main Window 
 
 
 
 
 
 

 
 
 
 
 
 
 

Map Tool bar 

Workspace pane: 
shows the structure of 
each of the projects in 
the open workspace 

 

View pane: shows open 
maps, attribute tables 
and reports pertaining 
to the projects in the 

workspace 

Output pane: reports in 
real time all internal 
operations. Errors 

messages, if any, will 
appear in red 
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�� Viewing surveys on maps 
When creating a new land survey project, 4SPack automatically creates de-
fault documents among which is a document showing a map of the working 
area (Survey View document). This document is displayed in the View 
pane: 

 
Map example showing two points and a baseline 

 
 

Two viewing options exist for the map itself: 
- With/without grid. The grid is defined as a network of horizon-

tal and vertical lines drawn at regular intervals of distance along 
the X & Y axes. 

- With/without ruler. The ruler is defined as the set of coordinate 
values associated with the grid  

There may be as many map documents as necessary in a project. The de-
faults (Design View and Survey View) are created when creating the 
project. To create other maps, use the File>New command and then ask for a 
new map document to be created with a name that you specify. 
The default coordinate system used in a map document is always the one 
defined for the project. You can however use another coordinate system, 
specifically for this map document using the Map>View command. 
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�� Default Documents Created in a Project 
These are listed in the Workspace pane on the Documents tab. 

 
Workspace pane showing a project with its default documents: 

 
 

The default documents include 2 map documents, as explained in the pre-
vious page, and 15 table documents. The Design View document only 
shows the points in the survey whereas the Survey View also shows base-
lines, vectors and processes. 
Each of the default table documents gives a partial representation of the 
land survey in progress (points, lines, vectors, processes, etc.). 
� A very important thing to know about table documents is that they can 
easily be filled from any collection in the project database through a simple 
drag & drop operation. 
Two more types of documents can be created in a project: 

- Graphs. Blank graphs are created using File>New (Graph). Graph 
documents can also be filled through drag & drop, but this time 
from any data column selected in a table document. 

- Reports. Blank reports are created using File>New (Report). In 
addition, project reports can be created using the Project>Generate 
Report command. Project reports are created based on specific 
templates, depending on the type of generated report. 

Results files downloaded 
from your real-time survey-

ing equipment will also 
appear as text files in the 

Documents tab 
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�� Introducing project databases 
The following architecture is implemented by 4SPack every time you cre-
ate a new project: 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Workspace 

Project database

Project #1 

Collections 

Collection #1 

Documents 
Maps 
Attribute tables 
Reports 
Graphs 

Object #1 Attributes 
(text, numeric, geometric) 

Object #n Attributes 
(text, numeric, geometric) 

Collection #n 

Object #1 Attributes 
(text, numeric, geometric) 

Object #n Attributes 
(text, numeric, geometric) 

Project #2 

etc. 
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Workspace: Contains one or more projects of the same type, or of differ-
ent types. Any project created previously from another workspace can be 
inserted into the open workspace, for the sole purpose of being seen from 
within this workspace. 
Project: Two types: Land Survey and Background Map. Two tabs are used 
in the workspace pane to show the content of a project: Collections and 
Documents. 
Collections:  Each collection contains a number of objects. Each object is 
defined by a list of attributes, plus a geometric attribute defining the loca-
tion of the object on the surface of the Earth. 
Documents: Four possible types: map, attribute table, report and graph. 
Documents are created to show the content of the project database from a 
given angle. 
 
The open workspace and the projects it contains are shown in the left-hand 
pane of 4SPack. 
Example of workspace: 

 

 
 
Typical project database architecture: 
 

 

 
 

Projects present in 
the open work-

space 

Workspace name 

Set of collections 
present in the 
land survey 

project 

Present in the project only after 
importing GPS raw data files 

Project name 
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To know more about the different collections you can find in a project, 
please refer to the Appendices section at the end of the manual. 
 

�� Editing the content of a collection 
In the Collections tab of the active project, select any collection by clicking 
on its name (for example click on Points). Two different actions are then 
possible: 

1. Listing the attributes characterizing any of the objects present in 
the collection: after a right click on the selected collection, select 
Properties on the popup menu, or double-click directly on the col-
lection. 

 
The two tabs showing the attributes of a point object (general case): 

   
 

 The first tab lists all the classic attributes (“one-dimensional” 
text, numeric or Boolean type) whereas the second one shows 
the geometric attribute (“multi-dimensional”). There are three 
possible types of geometric attributes: 

- Point, defined by a set of 2 or 3 coordinates expressed on 
a specific coordinate system 

- Line, defined by two or more sets of 2 or 3 coordinates 
expressed on a specific coordinate system 

- Area, defined by a close line 
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2. Editing the objects of a collection: As explained earlier, after 
creating a table document from File>New and opening it in the 
View pane, drag & drop the collection icon on the table: 

  
 Each row in the table depicts an object from the collection. Use 

the horizontal scroll bar to browse through the full set of attrib-
utes (one attribute per column). For points only, the last 
columns, i.e. those in the right-hand part of the table, provide the 
parameters relevant to the geometric attribute of the object. 

 From this table, you can view the attributes of an object in a dif-
ferent manner: using the mouse cursor, point at the cell in the 
first column corresponding to the desired object. Once the cursor 
looks like an arrow (�), right-click and then select Properties. 
The object attributes are then shown as follows. 

 
Example of the two tabs showing the attributes of a selected point object: 

   
- Other actions are possible from within the “attribute table” 

document (see section 3) 
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�� Representing database objects on a map 
Almost any collection in a project database can be represented on a map. 
4SPack refers to styles to visualize objects from collections. Styles can be 
user-modified. A style is defined by the following parameters: 

- Name of the attribute chosen to identify the objects in the collec-
tion. For example, you can use the point name or one of its 
geocodes to identify all points on the map. 

- Text color (name) 
- Background color (behind name) 
- Line or fill style for collections of lines or areas 
- Icon assigned to objects (defined as a file stored in 

.../4SPack/Symbols). The user can create new icons if required 
and store them with the existing ones (see also page 91). 

- Icon size 
- Name position with respect to the icon. 
 
 

Example of Style dialog box: 

 
For more details, see section 4. 
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In a collection, you can decide on which objects you would like to show on 
the map, thus making the other ones invisible. This choice is made by set-
ting a display filter: 

 
Example of a display filter: 

 
In this example, only points for which geocode1=streetlights will appear on the 
map. For more details see page 97. 

 
We will conclude this section about map documents with the introduction 
of the following two terms: 

- Layer: visual result on the map of a style and a filter applied to a 
collection of objects 

- Legend: the set of layers defined in a map document. 
Knowing these definitions helps you understand what a map document 
really is. In fact, when you save a map, you just save its legend. 
It is easy to imagine how interesting map documents are. What appears 
when you open the map document depends on the contents of the project 
database that time. The same map can show very different things at differ-
ent times (for example at the beginning and then at the end of a survey). 
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�� Creating survey reports 
4SPack allows you create almost instantly any kind of survey report for 
your clients or for your archives. These reports being part of the project, 
they are listed in the Documents tab of the Workspace pane (as are all the 
other types of created documents). 
The process of creating survey reports is based on the use of VB Script 
macros stored in the ...\Studio\Macro folder. 
 

�� Coordinate systems used in a project 
When you create a new project, you are asked to specify a coordinate sys-
tem. This coordinate system (defined as the “Spatial Reference System”) 
will be used by default in any new map or table document that you will 
create in the project. 
 You can however define a different coordinate system for any of these 
documents that you create WITHOUT affecting the choice of the coordi-
nate system used at project level. 
As explained elsewhere in the manual, the process of defining a coordinate 
system in 4SPack is a bit different from that used in its predecessor 
3SPack. � 
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2. Tutorials 

Post-Processing a Baseline between two Un-
known Points 

Incidentally in this example, we will introduce the vector export function 
using a custom format (Step 6). 
 

�� First Step: Creating a New Project 
- On the 4SPack menu bar, select File>New 
- In the New dialog box that appears, select the Projects tab (unless 

already done) 
- In this tab, select Land Survey Project on the left 
- In the Project name edit box, type a name for the new project. 

For example, type Tuto_process 

  
- Click OK. In the Welcome dialog box that appears, check the By 

entering all settings check box 
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- Click Next. In the new dialog box that appears, select WGS84 as 
the spatial reference system to be used in the new project. Keep 
the default selection in the Time zone field. 

- Skip the next three dialog boxes by clicking three times on the 
Next button and then on the Finish button. As a result, the new 
project is created and the following is displayed in the 4SPack 
main window: 

 
 
 The Workspace pane (1) lists the default collections and docu-

ments created in the new project. Click on the Documents tab in 
the lower part of this pane to see the default documents. Come 
back to the project collections by clicking on the Collections tab. 

 The View pane (2) shows an empty map with coordinates corre-
sponding to your choice of spatial reference system. 

 The Output pane (3) shows three lines of messages attesting to 
the creation of the new project. 

(1) 

(2) 

(3) 
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�� Second Step: Importing Raw Data into the Project 
� In this step, you will have to insert the 4SPack installation CD-ROM in 
the computer’s CD drive. 

- On the 4SPack menu bar, select Project>Import Data from Files...  
- In the dialog box that appears, make the following two choices:  

  
 

- Click OK. This causes the Open dialog box to appear: 

  
 

- Insert the 4SPack CD-ROM in the computer’s CD drive 
- Using the Look in combo box, select the following folder on the 

4SPack CD-ROM: ..\Samples\RawData\Baseline. 
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 This folder contains 2 binary files: From.bin and To.bin. One 
contains the raw data recorded in the field at one unknown point 
(static observation), and the other file contains the raw data for 
the other unknown point (also a static observation). 

- Select these two files (using the Shift key to select the 2nd one) 

  
 

- Click Open. The following window then appears: 

  
 

 This window is maximized so that none of the parameters shown 
in the right-hand columns of the table can escape your attention. 

 Click on  to give this window a normal size. 
- Accept all the default choices displayed in this box by clicking 

directly on the OK button. 4SPack then starts importing the data 
files. The following message boxes appear on the screen during 
the import sequence: 

 

  then:  
 

- Let 4SPack complete the import sequence. 
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�� Third step: Analyzing the Content of the Project after 
Importing the Data Files 

- At the end of the import sequence, the following can be ob-
served in the 4SPack main window: 

 
 
 
 
 

  
  

 
3. All operations performed 

while importing data are listed 
on the Output pane 

2. The created sites and still unprocessed 
baseline are represented on the View pane 

(Survey View map document). The grid 
coordinates are updated to match the 

locations of the sites 

1. A new folder (GPS-
Measurement) is added to 
the database, as shown on 

the Workspace pane 
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- On the Workspace pane, come back to the default documents list 
by clicking on the Documents tab. 

- When creating a new project, the Survey Map document (2nd 
position in the list) shows on the View pane. Close this docu-
ment by selecting File>Close map on the menu bar or by clicking 
the following button under the 4SPack title bar: 

 

  
 

- On the Workspace pane, double-click on the Points (All Coordi-
nates) document. This document, which opens on the View pane, 
provides the approximate coordinates of the two points now in 
the project. These two points were created following the import 
operation: 

  
 

- Close this document by clicking on  
-  On the Workspace pane, double-click on the Processes docu-

ment. This document, which opens on the View pane, provides 
the definition of a baseline that can be processed by 4SPack in 
view of the data now available in the database: 

  
 

- Close this document by clicking on  
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�� Fourth Step: Refining the Location of the “From” Point 
- On the 4SPack menu bar, select Project>Process Single Site... 
- In the Single Site Processing dialog box that appears, make the 

following choices: 

  
 

- Click OK. 4SPack starts computing the coordinates of the 
“From” point. The following message box is then displayed: 

   
 

 At the end of this processing, the following lines can be read on 
the Output pane: 

  
 

- If you now open the Points (All Coordinates) document from the 
Documents tab on the Workspace pane, you will notice that the 
“From” point is now declared as “Averaged” and its coordinates 
have changed: 
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�� Fifth Step: Processing the Baseline 
- On the 4SPack menu bar, select Project>Process Baselines... The 

following window appears: 

  
 

 This window is maximized so that none of the parameters shown 
in the right-hand columns of the table can escape your attention. 
You can click on  to give this window a normal size. 

- Click on the Process button. This starts the baseline processing. 
A message box is displayed providing information on the com-
putation in progress (baseline numbers, computation steps, etc.). 

 At the end of this processing, the following lines can be read on 
the Output pane: 

   
 

- To read the characteristics of the vector resulting from the base-
line processing, select the Documents tab on the Workspace pane 
and open the Vectors (Process Results) document by double-
clicking on this document name. 
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- In addition, if you open the Survey View document on the View 
pane, the value of baseline length will appear on the map: 

  
 

�� Sixth Step: Exporting the Processed Vector to a File 
(This step includes creating a custom format for data export.) 

- Unless already done, open the Vectors (Process Results) document 
and select (highlight) row #1 containing the vector results  

- On the 4SPack menu bar, select Project>Export Data to File... 
- In the dialog box that appears, select Vectors: 

  

- To create a custom format, in the Format list box, click on . 
This opens the Custom Format window. 

- Follow the instructions provided in this window to create a new 
format. 
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- To become familiar with all the buttons and functions present in 
this window, try to re-create the format defined in the Format 
Header and Format Body boxes below: 

 

  
  

 For more information on this dialog box, refer to page 105 
- Once the custom format has been created, click OK. The Export 

Data to Files dialog box appears again, this time with “Patsformat” 
selected to be the custom format used for data export 
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- Click OK. In the Save As dialog box that appears, type a name for 
the export file (for example: “tutovect”) and then click on the 
Save button. 4SPack then creates the export file and saves it to 
the project folder as a text file (txt). 

 If you edit this file using Notepad for example, you would get 
the following: 

   
 
- To complete the first example, close the project. To do this, on 

the 4SPack menu bar, select File>Close Workspace. This closes the 
project contained in the workspace, and the workspace as well. 
Note that all the changes made in the project and all the envi-
ronmental parameters pertaining to the workspace are directly 
and automatically saved before effectively closing them.   
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Post-Processing a Point Network including two 
Known Points 

This is a new example in which redundancy exists in the observations made 
in the field. This means that most surveyed points will be involved in the 
processing of several vectors. 
To produce a single, accurate solution for each of the surveyed points, we 
will therefore perform a “network adjustment” step in which the two 
known points involved will be held fixed so that the surveyed points be ac-
curately determined in relation to these known points.  
Incidentally, in this example, we will introduce the “As Workbook” view-
ing option in the 4th step. This option allows you to know at any moment 
which documents are currently open on the View pane while allowing you 
to optimize the use of this pane for displaying a single document. This op-
tion can also be combined with the commands available on the Window 
menu (Tile Horizontally, Tile vertically, Cascade). 
 
 

�� First Step: Creating a New Project 
- Create a new project (“Tuto2_process” for example). Follow the 

same instructions as in the previous example (see page 15). 
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�� Second Step: Importing Raw Data into the Project 
� In this step, you will have to insert the 4SPack installation CD-ROM in 
the computer’s CD drive. 

- Follow the same instructions as in the previous example (see 
page 17) to import the following raw data files stored in 
\Samples\RawData\Network on the CD-ROM: 

  
 

- Click Open. The following window appears: 

   
 This window is maximized so that none of the parameters shown 

in the right-hand columns of the table can escape your attention. 
 Click on  to give this window a normal size. 
- Click OK in this window to allow 4SPack to import these files. 
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- After data import, the View pane shows the following: 
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�� Third Step: Editing the Control Points 
In this project, two known points are used whose coordinates are accurately 
known (reference coordinates): 

 Point “Ser_0320”:  
 Long: 1°29’30.6944”W 
 Lat: 47°16’08.4190”N 
 Height: 92.590 m 

 Point “LCPC_0320”:  
 Long: 1°38’53.54844”W 
 Lat: 47°09’17.3384”N 
 Height: 91.757 m 

 
In this step, we will edit the control points so that the reference coordinates 
listed above be assigned to them. In addition, we will hold them fixed so 
that the coordinates of these control points cannot be changed during the 
baseline processing run in the next step. 

 
- On the map toolbar, click  (toolbar in the lower part of the 

4SPack window)  
- On the View pane, click repeatedly on the point “Ser_0320” un-

til it is clearly visible (zoom-in operation) 

- On the map toolbar, click  
- On the View pane, select (highlight) the point “Ser_0320” by 

clicking on the point name: 

   
- Right-click on this point and select Properties 
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- Change the coordinates and attributes as indicated below: 
 Location tab: 

 Long: 1°29’30.6944”W instead of 1°29’30.6524”W 
 Lat: 47°16’08.4190”N instead of 47°16’08.4868”N 
 Height: 92.590 instead of 104.743 

 Attributes tab: 
 Fixed field: in the combo box opposite this field, select Hori-

zontal and vertical fixed to protect the known coordinates from 
change 
 

- Click OK to accept changes 

- On the Map toolbar, click  to adjust the map scale so that all 
the points on the map can be viewed on the View pane. 

  is then automatically selected on the map toolbar 
- Select “LCPC_0320” by clicking on the point name 
- Right-click on this point and select Properties 
- Change the coordinates and attributes as indicated below: 
 Location tab: 

 Long: 1°38’53.5484”W instead of 1°38’53.4138”W 
 Lat: 47°09’17.3384”N instead of 47°09’17.5473”N 
 Height: 91.757 instead of 115.275 

 Attributes tab: 
 Fixed field: in the combo box opposite this field, select Hori-

zontal and vertical fixed to protect the known coordinates from 
change 
 

- Click OK to close the Properties dialog box 
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�� Fourth Step: Processing all the Baselines 
- On the 4SPack menu bar, select Project>Process Baselines... The 

following window appears: 

  
 

 This window gathers all the baseline processes that can possibly 
be run. These processes were identified by 4SPack during the 
second step (data import) (See principles on page 111 and next 
one, particularly points 6. and 7.).  

 This window is maximized so that none of the parameters shown 
in the right-hand columns of the table can escape your attention. 
You can click on  to give this window a normal size. 

- Accept the content of this window by clicking directly on the 
Process button. This starts the baseline processing (Notice: de-
pending on the performance level of your computer, this 
processing may take between 10 and 30 minutes). 
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 On completion of this processing phase, the following is dis-
played on the View pane: 

 

  
 
- On the 4SPack menu, select View>As Workbook to check this op-

tion. The View pane now appears as a workbook, i.e. with a tab 
in the lower part of the pane indicating the name of the open 
document (which here is “Survey View”) 

- To read the characteristics of the vectors resulting from the base-
line processing, select the Documents tab on the Workspace pane 
and open the Vectors (Process Results) document by double-
clicking on this document name. 
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 As a result, this document now appears as a second tab in the 
View pane. Navigate in the document using the horizontal scroll 
bar associated to the tab. 

  
- To come back to the survey map, simply click on the Survey 

View... tab. 
  

�� Fifth Step: Performing Network Adjustment 
In this step, as there is some redundancy in the measurements performed in 
the field (each surveyed point is involved in two or three vectors computed 
in the 4th step), 4SPack will optimize the solution of each computed vector 
through least-square processing. 

- On the 4SPack menu bar, select Project>Adjust Baselines... This 
starts the network adjustment procedure immediately as indi-
cated by the message box that appears on the screen: 

  
 

 During this phase, 4SPack adjusts all the vectors computed pre-
viously in the third step. 
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- To know the impact of the network adjustment on the vectors, 
open the Vectors (Adjustment Results) document. Read the residuals 
of the network adjustment after dragging the horizontal scroll 
bar fully to the right. 

  
 A good network adjustment is characterized by low residuals of 

approximately the same magnitude as well as successful Tau test 
for each adjusted vector (all buttons checked in the Tau test col-
umn). Note that these two criteria are met in this example. 

 
�� Sixth Step: Viewing the Results in a Specific Spatial 

Reference System 
- Select Project>Edit Settings and, unless already done, select the 

Region tab 
- Select “Lambert II” as the new spatial reference system and 

click OK. 4SPack then automatically transforms the coordinates 
of the all points surveyed into the new system. When this opera-
tion is complete, you can read the new coordinates in the Points 
(All coordinates) document. The Survey View document (default 
map) is also updated to reflect the change of spatial reference 
system. 

 Note that selecting a new spatial reference system does not im-
pact on the vector components (see Vectors... documents) as these 
are all expressed in ECEF. 

- To complete this example, on the 4SPack menu bar, select 
File>Close Workspace. This saves and closes the project contained 
in the workspace, and the workspace as well.   



Tutorials 
“Stop & Go” Project 

 35 

T
utorials 

 “Stop & Go” Project 

�� First Step: Creating a New Project 
- Create a new project (“Tuto3_process” for example). Follow the 

same instructions as in the previous examples (see page 15). 
 

�� Second Step: Importing Raw Data into the Project 
� In this step, you will have to insert the 4SPack installation CD-ROM in 
the computer’s CD drive. 

- Follow the same instructions as in the previous examples (see 
page 17) to import the following raw data files stored in 
\Samples\RawData\Stop&Go on the CD-ROM: 

  
 

- Click Open. The Importing GPS data window appears 
- Check the “Dynamic” check box for the “Cercle” site: 
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- Click OK in this window to allow 4SPack to import these files. 
- After data import, the View pane shows the following: 

  
 

�� Third Step: Analyzing the Content of the Project after 
Importing the Data Files 

- On the Workspace pane, click on the Documents tab and double-
click on the Stops document: 

  
 

 This document shows the list of static occupation times found by 
4SPack in the “Cercle” file when importing this file to the pro-
ject database. 
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- On the Workspace pane, double-click on Processes to open this 
document on the View pane. As you can see, 4SPack under-
stands that a Stop & Go processing can be run between the two 
considered points. 

  
 

- On the Workspace pane, double-click on Points (All coordinates) to 
open this document on the View pane. As you can see, 4SPack 
only lists two points for which it gives approximate coordinates 
(determined from the first measurements found in the corre-
sponding data files) 

  
 
 

�� Fourth Step: Editing the Station Coordinates 
In this project, the point used (“Thales”) has precisely the following coor-
dinates: 

 Long: 1°30’32.4817”W 
 Lat: 47°17’56.5190”N 
 Height: 91.051 m 

 
- In the Survey View map document, select (highlight) the point 

“Thales” by clicking on the point name 
- Right-click on this point and select Properties 
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- Change the coordinates as indicated below: 
 Location tab: 

 Long: 1°30’32.4817”W instead of 1°30’32.5416”W 
 Lat: 47°17’56.5190”N instead of 47°17’56.4095”N 
 Height: 91.051 instead of 92.375 m 

 Note that you do not need to fix the station position, as it is not 
involved in any baseline 

- Click OK to close the Properties dialog box. 
 

�� Fifth Step: Running the Stop & Go Processing 
- On the 4SPack menu bar, select Project>Process Baselines... The 

following window appears: 

  
 

- Click on the Process button to start the Stop & Go processing 
 On completion of this processing phase, the following is dis-

played on the View pane: 
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�� Sixth Step: Analyzing the Results of the Stop & Go 
Processing 

- On the map toolbar, click  (toolbar in the lower part of the 
4SPack window)  

- On the View pane, click repeatedly on the lower point “204” un-
til the set of points created by the Stop & Go processing can be 
properly seen: 
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- On the Workspace pane, double-click on Vectors (Process Results) 
to open this document on the View pane. This document lists 7 
computed vectors corresponding to the 7 static occupations ini-
tially detected in the “Cercle” data file: 

  
 

- And the Points (All coordinates) document now contains 9 points 
(station “Thales”, approximate initial point “Cercle” and the 7 
points corresponding to the 7 static occupations initially detected 
in the “Cercle” data file): 

   
 

- Select File>Close Workspace. This saves and closes the project 
contained in the workspace, and the workspace as well. 
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Real-Time Project: Staking Out Target Points 

In this example, the target points to be surveyed are not created in the pro-
ject, although this would be possible using the map toolbar. Target points 
are made available in the form of a text file that we have especially pre-
pared for this example. We will also bypass the field survey step, which 
does not fall within the scope of 4SPack. We will however provide you 
with a results file as if you had performed the field survey, so that the post-
survey steps can be run with 4SPack. 
 

�� First Step: Creating a New Project 
- On the 4SPack menu bar, select File>New. 
- In the New dialog box that appears, select the Projects tab (unless 

already done). 
- In this tab, select Land Survey Project on the left. 
- In the Project name edit box, type a name for the new project. 

For example, type Tuto4_process. 
- Click OK. In the Welcome dialog box that appears, check the By 

entering all settings check box. 
- Click Next. In the new dialog box that appears, select Lambert II as 

the spatial reference system to be used in the new project. 
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 Keep the default selection in the Time zone field (GMT+01:00) 

   
- Click Next three times 
- In the Transfer tab, check the 6000 receiver option allowing data 

exchange with a PC card (PCMCIA) or the hard disk on your 
PC. In the PC card drive field, type “C:\Temp\” to define this 
folder as if it were the PC Card drive: 

  
 

 Leave all the other settings unchanged. 
- Click Finish to allow 4SPack to create the new project. 
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�� Second Step: Importing the Target Points from a File 
� In this step, you will have to insert the 4SPack installation CD-ROM in 
the computer’s CD drive. 
Assuming the characteristics of the target points to be surveyed have earlier 
been stored in a file, do the following: 

- On the 4SPack menu bar, select Project>Import Data from Files... 
- In the dialog box that appears, make the following two choices:  

  
 

- Click OK. This causes the Open dialog box to appear: 

  
 

- Insert the 4SPack CD-ROM in the computer’s CD drive 
- Using the Look in combo box, select the following folder on the 

4SPack CD-ROM: ..\Samples\Pcmcia. 
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- Select the POINTS.txt file. This file contains all the target points 
for the project: 

  
 

- Click Open to import the file to the project. As a result, all the 
target points contained in the imported file now appear on the 
View pane: 
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- The coordinates of these points can be viewed by opening the 
Points (All coordinates) document from the Documents tab in the 
Workspace pane: 

  
 

�� Third Step: Uploading the Survey Job to the PC Card 
(C:\Tmp folder emulates PC Card) 

- On the 4SPack menu bar, select Edit> Select All or, on the map, 
drag a rectangle surrounding all the points 

- Select Project>Upload real-time Job. This displays the PCMCIA Trans-
fer dialog box. This box reminds you of the path to the PCMCIA 
emulation (C:\Temp) 

- Click OK. The following dialog box then appears: 

  
 

- In this box, a default name is prompted for the job (TUTO4_00) 
derived from the project name (accept this name) 

- Click OK to create the job (TUTO4_00.job) in the Temp folder. 
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�� Fourth Step: Field Survey 
(Skipped) 
 

�� Fifth Step: Downloading the Field Results 
(\samples\pcmcia folder on 4SPack CD-ROM will emulate PC Card. This 
will allow you to retrieve the desired file, as if it were downloaded from a 
PCMCIA) 
 

- Select Project>Download real-time Results. This displays the PCMCIA 
Transfer dialog box. 

- In the Insert PC card into drive field, type the following: 
   <CD drive unit>\samples\pcmcia\ 
 In the example below, <CD drive unit> = E: 

  
 

- Click OK. In the dialog box that appears, select TUTO. This file 
contains the results of the field survey (In fact we have made the 
survey for you): 

  
 

- Click OK. This starts the download operation. 
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 On completion of this operating phase, the map in the Survey 
View... document looks like this: 

  
 

- Note that a new document called “TUTO” has been added to the 
document list on the Documents tab of the Workspace pane. This 
document is the results file in editable text format. It is stored in 
the project folder. Double-click on TUTO to open this document 
in the View pane: 
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�� Sixth Step: Comparing the Field Results with the Initial 
Target Points in the Job 

- Open the Design View document. This document only shows 
points, not baselines 

- Zoom in on the area where all the points are located.  

  
 

 This map shows the location of each surveyed target point (ver-
tical flag+ leaning flag). The leaning flag is just to remind you 
that each of these points was initially planned in the project for 
staking out purposes (planned point).  
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- To have a closer look into the results, you can open the follow-
ing documents on the View pane: 
- Points (All Coordinates) listing the type and coordinates of all 

the points of the survey. Additional points are shown that are 
not targets: 
 Logged points (3200, 4300, 3002, 4010): additional 

points logged in the field that were not initially planned 
in the job 

 Station location (S2) 
 Intermediate points (4300_P1, 4300_P2, 4010_P1, 

4010_P2): pivot points used to stake out an inaccessible 
point through one of the possible offset procedures (lin-
ear, lateral or intersection) 

- Points (Target Coordinates) listing only the coordinates of the 
target points as logged in the field while staking out these 
points 

- Points (Station Coordinates) providing the coordinates of the 
base station used in the field 

- Points (Target Errors) providing the deviations between planned 
and surveyed target points: 

  
 

- Select File>Close Workspace. This saves and closes the project 
contained in the workspace, and the workspace as well. 



Tutorials 
Real-Time Project: Determining a Local Grid 

50  

2 

Real-Time Project: Determining a Local Grid 

In this example, we will determine a new coordinate system (local grid) 
starting from a number of surveyed target points used as references. 
The target points are provided in the form of a real-time results file that we 
will download into an empty project using an “unknown” coordinate sys-
tem. 
In the fourth step, we will examine the characteristics of the local grid de-
termined by 4SPack, which incidentally will allow us to introduce the way 
4SPack manages its library of coordinate systems. It is worth noting that 
4SPack strictly complies with the OpenGIS Implementation Specification 
document concerning coordinate transformations. 
Finally, in the last two steps, we will introduce the Report Generation func-
tion offering an easy way of producing ready-to-use survey reports. 
 

�� First Step: Creating a New Project 
- On the 4SPack menu bar, select File>New 
- In the New dialog box that appears, select the Projects tab (unless 

already done) 
- In this tab, select Land Survey Project on the left 
- In the Project name edit box, type a name for the new project. 

For example, type Tuto5_process 
- Click OK. In the Welcome dialog box that appears, check the By 

entering all settings check box 
- Click Next. In the new dialog box that appears, select Unknown as 

the spatial reference system to be used in the new project. 
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 Keep the default selection in the Time zone field (GMT+01:00): 

  
 

- Click Next three times. 
- In the Transfer tab, check the 6000 receiver option allowing data 

exchange with a PC card (PCMCIA). 
 Leave all the other settings unchanged. 
- Click Finish to allow 4SPack to create the new project. After 

4SPack has created the new project, note the following warnings 
reported on the Output pane: 

  
 As reported in the Output pane, all objects from collections can-

not be viewed on the default map document, as the latter uses the 
same coordinate system as the project, namely an “Unknown” 
system. 
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�� Second Step: Downloading the Real-Time Results con-
taining the Surveyed Points 

(\samples\pcmcia folder on 4SPack CD-ROM will emulate PC Card. This 
will allow us to retrieve the desired file, as if it were downloaded from a 
PCMCIA) 
 

- Select Project>Download real-time Results. This displays the PCMCIA 
Transfer dialog box. 

- In the Insert PC card into drive field, type the following: 
   <CD drive unit>\samples\pcmcia\ 
 In the example below, <CD drive unit> = E: 

  
 

- Click OK. In the dialog box that appears, select FLEURI01. This 
file contains the results of the field survey (In fact we have made 
the survey for you): 

  
 

- Click OK. This starts the download operation. 
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 4SPack then asks which coordinate system to use in the project 
as 4SPack has detected that the selected results file refers to an-
other coordinate system. Choose “Current System”: 

   
 

- Then, click Go to download the FLEURI01 file. On completion 
of the download operation, note that the project map remains 
blank as 4SPack is still unable to reliably locate any points on 
the map (“Unknown” displayed in the right-upper corner of the 
map). 

 The following message lines appear on the Output pane: 

  
 

 These warnings refer to the Transfer options in the Project Set-
tings dialog box (access: Project>Edit Settings..., Transfer tab). 

 To display option 2 on this tab, in the When reading results... area, 
click  once to display the setting of this option. 
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�� Third Step: Computing the Horizontal Grid 
- On the 4SPack menu bar, select Project>Compute Horizontal Grid... 

This opens the Compute Local Grid dialog box 
-  Click the Add button 
- In the Browse dialog box that opens, select all the targets (using 

the Shift key): 

   
- Click OK 
- Click OK in the Compute Local Grid dialog box. This starts the 

horizontal grid computation. On completion of this processing 
phase, the following Warning dialog box is displayed: 
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- Click Yes to confirm that you wish to use the horizontal grid that 
4SPack has just determined. 

- After this, the Survey View document is as follows: 

  
  

 Note that “WGS84˜1” is displayed in the right-upper corner of 
the view. This name has automatically been assigned to the 
newly determined spatial reference system. 
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�� Fourth Step: Displaying the Characteristics of the New 
Spatial Reference System 

- On the 4SPack menu bar, select Project> Edit Settings... This opens 
the Project Settings dialog box 

- Unless already done, select the Region tab. As expected, the spa-
tial reference system now used in the project is “WGS84˜1” 

- Click  opposite the Spatial Reference System field. A new dialog 
box opens showing the definition of the new system (see below). 
Basically this is a compound system consisting of a horizontal 
system and a vertical system: 

  
 

 In this dialog box, you can change the default name (WGS84˜1) 
for a name of your choice (if desirable). 

- Using the  buttons attached to each field, you can scroll up 
and down in the definitions of the horizontal and vertical sys-
tems. 
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 The two diagrams below summarize the architecture of each of 
these systems (general cases). 

 
 
 
 
 
 
 
 
 
 
  
 
 
 
 
 
 
 

 
�� Fifth Step: Generating a Report 

- On the 4SPack menu bar, select Project>Generate Report... 
- In the dialog box that opens, select Logged Reference Points in the 

list of possible reports 

  
- Click OK to let 4SPack generate the report (based on an internal 

template). 

Fitted horizontal system 

Projected system Projection plane 
shifts 

Geographic 
system 

Projection type and 
definition, distance 
units and labels 

Datum Prime Meridian, 
angle units and 
labels 

Ellipsoid Datum shifts 

Semi-major axis 
Inverse flattening 

+

+

+

+

Fitted vertical system 

Vertical shifts 

Vertical datum 
(Ellipsoid or 
geoid model)

Distance unit 
and label 

Vertical system +

+
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 The report then appears on the View pane, as if it were one of 
the documents opened from the Documents tab. 

- Use the vertical scroll bar on the right to scroll up and down in 
the report. The beginning of the report looks like this: 

  
 

�� Sixth Step: Editing and Saving the Report 
- If necessary, make changes to the report content or layout using 

the toolbar now displayed under the 4SPack menu bar. You can 
also edit text directly in the report, as you would do with any 
text editor or office software. 

- When you are satisfied with the content and aspect of the report, 
on the 4SPack menu bar, select File>Save report... or File >Save re-
port As... to save the report. 

 If you select File>Save report... the report will be saved in the cur-
rent project folder under the default name “Logged References 
Report.rtf”. If you select File >Save report As... a Save As dialog 
box will open and you will then be allowed to choose the folder 
where to save the file and the name under which you wish to 
save the file. In both cases however, the file produced will nec-
essarily be an “rtf” (rich text format) file. 

- Select File>Close Workspace. This saves and closes the project 
contained in the workspace, and the workspace as well. 
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Introducing Background Map Projects 

Background map projects can accompany your land survey projects enrich-
ing them with diverse categories of information. Associating a background 
map project with a land survey project is simply made by creating the two 
projects in the same workspace. Obviously, the two projects must cover the 
same geographic area. 
With this example, you will become familiar with the architecture of a 
background map project. Incidentally, you will also learn that you can drag 
and drop any collection from the workspace pane to any document open on 
the View pane. This technique for inserting data into a document is really 
simple and in addition can be used in both types of projects. 
 

�� First Step: Creating a New Project 
� In this step, you will have to insert the 4SPack installation CD-ROM in 
the computer’s CD drive. 

- Insert the 4SPack CD-ROM in the computer’s CD drive 
- On the 4SPack menu bar, select File>New 
- In the New dialog box that appears, unless already done, select 

the Projects tab 
- In this tab, select Background Maps Project on the left 
- In the Project name edit box, type a name for the new project. 

For example, type Tuto6_process 

  
 

- Click OK. This causes an Open dialog box to open 
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- Using the Look in combo box in the Open dialog box, select the 
following folder on the 4SPack CD-ROM: ..\Samples\OpenGIS 
and select the file “World1.mdb”: 

  
 

- Click Open. This enables 4SPack to create the new project. 
 

�� Second Step: Analyzing the Content of the Project 
- Once the project is created, select the Collections tab in the Work-

space pane and select the single collection present in the project, 
named “WORLDMIF” 

- On the 4SPack menu bar, select View>Properties. The dialog box 
that opens displays the properties of the WORLDMIF collection, 
which are two types: 

- Attributes 
- Location 

- Select the Attributes tab 
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- Select any of these items in the list and then click  located on 
the right to display the properties of this item in another secon-
dary window (no changes allowed in this box): 

  
 

 Each of the listed items has its own properties that you can dis-
play as explained in the previous point. 

- Click OK to close the window last open and then select the Loca-
tion tab on the “WORLDMIF” Properties dialog box. This tab 
indicates the geometric properties of the collection which fall 
into three categories: 

- Geometry type (area) 
- Coordinates dimension (2D) 
- Spatial Reference System used 
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- Click  opposite the Spatial Reference System field to access the 
definition of the spatial reference system on which the collection 
relies: 

  
 

 As you can see the spatial reference system is defined using the 
same architecture as the one presented in the previous example 
(see page 56). 

- Click OK to close the window last open and then OK again to 
close the “WORLDMIF” Properties dialog box. 
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�� Third Step: Creating a Map document in the Project 
- On the 4SPack menu bar, select File>New. In the New dialog box, 

select the Documents tab. Then select Map in the list on the left 
and type a name in the File name edit box (for example: 
Tuto6_Map): 

  
- Click OK. A new, empty, map document then opens on the View 

pane. 
- From the Collections tab of the Workspace pane, drag and drop 

the WORLDMIF collection on the map document. As a result, 
the following appears in the map document:  
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�� Fourth Step: Working on the Map 
- For example zoom-in on Australia using the usual tools on the 

Map toolbar 
- Using the Select tool on the same toolbar, select this country on 

the map 
- Right-click on the mouse (keeping the cursor over Australia) and 

then select Properties on the pop-up menu.  

  
 

 As you can see, the project provides a lot of details about this 
object shown on the map. This is true for any other country that 
you can select on the map. 

 On the Location tab, the project also provides the coordinates of 
all the points used to draw the country borders on the map as 
well as the identification of the spatial reference system used to 
express these coordinates. 

- Click OK to close this Properties dialog box 
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- Right-click on the map document and select Legend in the pop-up 
menu 

- Click  in the right-upper part of the window that displays to 
edit the legend. A new Properties dialog box opens. 

 On the Style tab, you can define the color and borderline for each 
object on the map. This choice applies to ALL objects on the 
map. 

 On the Data tab, after clicking , you can set a filter on the 
map. For example, after setting the following filter: 

  
 

 And after you click OK three times to close all the legend-related 
dialog boxes, you will get the following in the map document: 
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�� Fifth Step: Creating a Table Document in the Project 
- On the 4SPack menu bar, select File>New. In the New dialog box 

that opens, select the Documents tab. Then select Table in the list 
on the left and type a name in the File name edit box (for exam-
ple: Tuto6_Table) 

- Click OK. A new, empty, table document then opens on the View 
pane. 

- From the Collections tab of the Workspace pane, drag and drop 
the WORLDMIF collection on the table document. As a result, 
the following appears in the table document:  
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�� Sixth Step: Sorting / Filtering Data 
- On the 4SPack menu bar, select Table>Sort 
- In the Table Properties dialog box that opens, select “Country” in 

the first Order by combo box 
- Click OK. As a result, the table content is re-arranged to show the 

data rows in ascending order of country names (sort criterion: 
country name in Country column): 

  
 

- On the 4SPack menu bar, select Table>Data 
- In the Table Properties dialog box that opens, select 

“Pop_Grw_Rt” in the attribute list: 
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- Click  to open the Attribute and Filter dialog box 
- Make the following choices in this box. 

  
- Click OK 
- Click OK to close the Table Properties dialog box. As a result, the 

table document only lists those countries for which the popula-
tion growth rate is greater than 5%, as requested by the above 
filter. 

  
 

 End of the example. Select File>Close Workspace... to save and 
close the project and the workspace.  
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Creating a New Coordinate System 

In this section, you will learn how to create a new coordinate system. You 
do not need to open a project to do this. On the 4SPack menu bar, select 
Tools>Coordinate Systems... . This opens the Coordinate Systems dialog box 
listing all the coordinate systems stored in 4SPack, and from which you can 
create a new system. Example of dialog box then displayed: 

  
 

Assuming you want to create the following system: 
Name: United Kingdom 
Central Meridian: 2°W 
Scale Factor: 0.99960127 
Latitude at origin: 49.00°N 
Eo: 400 000.000, No: -100 000.000 
Projection Type: Transverse Mercator 
Datum: Name: OSGB36 
  Dx: 375.000 
  Dy: -111.000 
  Dz: 431.000 
  �x=�y=�z=0.0°  
  Scale Factor: 1.000 
Ellipsoid: Name: AIRY 
  Semi-major axis: 6377563.396 
  Inverse flattening: 299.324964578 

 
The creation process will go through two different steps: first you will have 
to create a geographic system in which you will define the required ellip-
soid and datum. Then you will have to create a projected system in which 
you will introduce the required projection placed over the previous geo-
graphic system. 
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�� First Step: Creating the Geographic System 

- Click  and select 2D System>Geographic... 
- In the Datum combo box, select <New Horizontal Datum>: 

  
 

- In the new dialog box that opens, click on the Ellipsoid combo 
box and choose <New ellipsoid>: 
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- In the new dialog box that opens, enter the definition of the new 
ellipsoid, as indicated below: 

  
 

- Click OK. This closes the above dialog box. The name of the new 
ellipsoid now appears in the active dialog box. In this box, type 
the characteristics of the OSGB36 datum (name and shifts), as 
shown below: 

  
 

- Click OK. This closes the above dialog box. The name of the new 
datum now appears in the active dialog box. 

 In this box, you create a new “layer” –just one step above the da-
tum level and called “geographic system”– in which you 
associate labels for coordinates and an angle unit to the datum 
you have just defined. It is therefore important to define a 
slightly different name for the geographic system to avoid 
confusion between these two definition levels. 
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- For example, name the geographic system based on OSGB36 as 
follows and define the following labels and angle unit: 

  
- Click OK. This closes the active window and takes you back to 

the Coordinate Systems dialog box. The list now includes the new 
geographic system you have just created. 
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�� Second Step: Creating a Projected System 

- Click  and select 2D System>Projected... 
- In the dialog box that opens, enter the following: 

  
- Click OK. This closes the active window and takes you back to 

the Coordinate Systems dialog box.  
 The list now includes the new projected system you have just 

created: 

   � 
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3. 4SPack Functions 
This section provides detailed information on all the functions available in 
4SPack. To try to be as exhaustive as possible, we will first provide a brief 
description of all the commands available from the 4SPack menu bar. Sec-
ond, we will present in more detail some of the 4SPack features not 
described elsewhere in the manual. 
 

File Menu 

 New: Opens the New dialog box to create a document, 
workspace or project 

 Close xxx: Closes the active document (xxx: table, graph, re-
port or map) 

 Save xxx As...: Saves the active document (xxx: table, graph, report 
or map) 

 Open Workspace...: Opens the workspace that you choose in the list of 
workspaces. If a workspace is already open in 
4SPack, this workspace will be closed before open-
ing the selected one 

 Close Workspace: Closes the currently open workspace. Saves the 
workspace and its project(s) before closing them all  

 Print xxx...: Prints the active document (xxx: table, graph, report 
or map) 

 Print Preview: Previews the active document to see what it will 
look like when printed 

 Print Setup...: Opens the Print Setup dialog box to choose printer 
settings 

 Recent Workspaces: Lists the 4 workspaces last open. Selecting one in 
the list closes the currently open workspace and 
opens the selected one 

 Exit: Exits 4SPack 



4SPack Functions 
Edit Menu 

76  

3 

Edit Menu 

 Undo: Undoes the last action performed (unless it is a de-
lete or add action) 

 Redo: Cancels the last Undo action performed 
 Cut: Cuts the current selection to the clipboard 
 Copy: Copies the current selection to the clipboard 
 Paste: Pastes the data from the clipboard at the insertion 

point 
 Delete: Deletes the document currently selected in the 

Documents tab, or the object currently selected in the 
active map document 

 Rename: Renames the document currently selected in Docu-
ments tab 

 Select All: (Insertion point must be in an open report 
document) Selects the entire document 

 Insert New Object: Prompts you to enter a new object into the active 
report, at the insertion point 

 Links...: For an object selected in the active report, shows the 
definition of the link through which this object is 
present in the report (in the case of an object in-
serted into the report by reference) 

 Objects: Edits the selected object in the active report docu-
ment. 

 

View Menu 

 As Workbook: Configures the View pane as a workbook, i.e. with 
tabs in the lower part providing easy access to any 
open document 

 Workspace: Shows/hides the workspace pane 
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 Output: Shows/hides the output pane 
 Ruler: Shows/hides the ruler on top of the active report 

document 
 Refresh: Refreshes the content of the open map document 
 Properties: Shows the properties of the selected collection 

 
 

Table Menu 

(Available only if a table document is active in the View pane.) 
 Data: Provides access to the Data tab in the Table Properties 

dialog box. Used to remove, re-arrange, restore and 
filter the attributes present in a table document. The 
types of attributes shown in a table document come 
from a given collection. 

 Sort: Provides access to the Sort tab in the Table Properties 
dialog box. Allows you to list the rows of attributes 
according to your criteria. 

 View: Provides access to the View tab in the Table Properties 
dialog box. Shows the spatial reference system and 
the time zone attached to the table document. 

 
 

Report Menu 

(Available only if a report document is active in the View pane.) 
 Font: Lets you choose a font for the current selection 
 Bullet Style: Adds/removes a bullet at the beginning of the cur-

rent paragraph 
 Paragraph...: Lets you define the characteristics of the current 

paragraph 
 Tabs: Lets you set tabs for the current paragraph. 
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Graph Menu 

(Available only if a graph document is active in the View pane.) 
 Legend: Provides access to the Legend tab in the Graph Proper-

ties dialog box. 
 View: Provides access to the View tab in the Graph Properties 

dialog box. Shows the spatial reference system and 
the time zone attached to the graph document. Also 
lets you define a title for the graph. The title will 
then appear above the graph in the document. 

 Zoom out: Restores the normal (non-magnified) graph in the 
active graph document. 

 
 

Map Menu 

(Available only if a map document is active in the View pane.) 
 Select: Selects one or more objects shown on the map. Mul-

tiple selection is accomplished either by dragging 
the mouse cursor around the desired objects or by 
selecting the objects one after the other. You have to 
hold down the Shift key to add new objects to the 
first selected object 

 Zoom In: Zooms in on the area where you click or drag 
 Zoom Out: Zooms out from where you click or drag 
 Zoom To Fit: Adjusts the map scale so that all the visible objects 

present on the map can be seen 
 Grabber:  Shifts the map as instructed. The map shift directly 

proceeds from the length and orientation of the 
segment you drag on the map 
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 Distance:  Measures the distance between two points that you 
draw with the mouse. To use this tool, hold down 
the mouse button on the first point and then drag the 
mouse to the second point. The tool then continually 
indicates the distance between the start point and the 
current position of the mouse cursor  

 Set Active Collection: Allows you to choose the type of object you want to 
place on the map, equivalent to using the combo box 
on the Map toolbar  

 Draw Points:  Allows you to add a point on the map 
 Draw Lines:  Allows you to add a line on the map 
 Draw Areas:  Allows you to add an area on the map 
 Ruler:  Shows/hides the coordinates on the map 
 Grid:  Shows/hides the grid on the map 
 Legend:  Provides access to the Map Properties dialog box, 

Legend tab. This tab allows you to choose the objects 
you want to show or hide on the map. You can also 
define the visual aspect that 4SPack must give to 
each type of object (color, icon, shape, label, etc.) 

 View:  Provides access to the Map Properties dialog box, View 
tab. This tab indicates the coordinates of the map’s 
current central point, the scale currently used, the 
name of the coordinate system (Spatial Reference 
System) used and the current settings for the map 
viewing options (grid and ruler) 
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Project Menu 

 Set Active Project: Allows you to choose which project must be active 
(you have to make this choice if there is more than 
one project in the workspace)  

 Import Data From Files...: Allows you to import different types of data to the 
project database. Each type may be in various for-
mats: 

 - Points (NMEA or custom) 
 - Vectors (custom) 
 - Raw data (SBIN, SVAR, SFIX, proprietary 

formats) 
 
 Export Data to Files...: Allows you to export different types of data to a file. 

Each type may be in various formats: 
 - Points (NMEA or custom) 
 - Vectors (custom) 
 
 Group Points...: Transforms the selected points in the active map 

document as a line or an area. The points involved 
in this operation may be deleted or kept unchanged. 

 Ungroup Points...: Creates separate, independent points from the points 
forming the selected line or area. The selected line 
or area can be kept unchanged or deleted. 

 Change Into...: Used to change the type of the point currently se-
lected in the active map document 

 Upload real-time Job...: Used to transfer a job to the field equipment in order 
to assist the operator in his/her real-time survey 
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Download real-time Results: Used to transfer the results files of a real-time sur-
vey, once complete, to 4SPack for further analysis 

 Process Single Site...: Used to compute an averaged position solution for 
the selected site using the field observations avail-
able for this site 

 Build Process Scenario...: Examines or re-examines all the observation files 
available in the project to deduce all the possible 
baselines that can be processed, making assump-
tions on which points are reference points and which 
ones are not. This command is automatically run 
following data import so that you can directly run 
the Process Baselines... command 

 Process Baselines...: Processes all or some of the baselines reported in 
the scenario (see previous command). The result of 
each processed baseline is a vector   

 Adjust Baselines...: Runs network adjustment processing on the vectors 
resulting from the previous command. The purpose 
is to issue a single solution for every surveyed point 

 Compute Datum Shifts...: Computes the datum shifts based on the reference 
points that you specify 

 Compute Horizontal Grid...: Computes the characteristics of a horizontal grid 
based on the reference points that you specify 

Compute Vertical Correction...: Computes the characteristics of a vertical correction 
based on the reference points that you specify 

 Generate Report....: Automatically generates a pre-formatted report in 
RTF format after you choose the type of data for 
which you want a report to be created 
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 Edit Settings...: Opens the Project Settings dialog box containing four 
different tabs.  The project’s coordinate system and 
time zone are defined on the Region tab. The opera-
tors’ list for the active project is defined on the 
Operators tab. The geocodes, and corresponding 
meanings, that can be associated with the points of 
the active project are defined on the Geocodes tab. 
The Transfer tab is used to define the type of survey 
equipment used in conjunction with 4SPack and the 
associated data exchange means (PCMCIA or serial 
port). It is also used to set a number of processing 
choices that 4SPack will need when you download 
field data. 

Insert Project Into Worksp...: Allows you to add a project from another workspace 
to the currently open workspace. In fact, it is still the 
same single project, but seen from another work-
space. If for example you make changes to this 
project, these changes will also appear when you 
open this project in the original workspace. 4SPack 
can only open a single workspace at a time. 
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Tools Menu 

 Geoids: Launches the Geoids utility in a separate window 
(see Section 9) 

 Coordinate Systems...: Provides access to the library of coordinate systems 
created in 4SPack. Window fitted with powerful 
import, export, add, edit and delete functions. 

 Test Transfo...: Launches a utility used to test coordinate transfor-
mations in a separate window. You must specify the 
source and target coordinate systems. Transforma-
tions can be run in one direction or the other, which 
means the functions of “target” and "source" sys-
tems can be swapped between the two systems 
involved, depending on the direction you choose for 
the transformation. 

 Leap Seconds...: Lets you edit/add/delete leap seconds for any given 
date 

 Test Time...: Opens the Test Time dialog box in which you can 
convert any GPS-formatted time (i.e. week, sec-
onds) into local time (day, hours, minutes, seconds), 
taking into account the specified local time zone 

 Customize...: Opens the Customize dialog box containing three 
tabs. The Toolbars tab lets you choose which default 
toolbars to display in the 4SPack window. Other 
viewing options can be set on this tab. The Command 
tab lets you move the available 4SPack command 
buttons to any toolbar. The Tools tab is used to 
add/remove new programs to the 4SPack Tools 
menu.  

 Options...: Opens the Options dialog box in which you can set a 
number of editing options concerning report docu-
ments 
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Window Menu 

 Cascade: Arranges the open documents in cascade configura-
tion 

 Tile Horizontally: Arranges the open documents in horizontal tile con-
figuration 

 Tile Vertically: Arranges the open documents in vertical tile 
configuration 

 Close All: Closes all the documents open in the View pane 
 {Open Documents List}: Lists all the documents open in the View pane. 

Checking one of them makes it the active document. 
 

  

? Menu 

 User’s Guide: Opens the electronic User’s guide in Acrobat 
Reader  

 Explain: Not implemented 
 About 4SPack...: Displays the software version, licensee name and 

list of installed software applications. Provides ac-
cess to another dialog box allowing you to unlock 
software options after getting a password from 
Thales Navigation. The password is tied to a per-
sonal code deduced from the computer hardware. 
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Working in a Map Document 

The following tools are available to work in a map document: 
- Toolbar: 

 
 
 
 

 
 
 
 
 
 

- Popup menu on map: 

  
- Map menu from menu bar: 
  

Scale factor: choose a 
preset value from the combo 
box. Clicking on the zoom-
to-fit button will also cause 
the scale factor to be up-

dated to reflect the changes 
then produced  

Zoom-to-fit button: 
adjusts the map scale 
so that all the objects 
present on the map 

can be seen 
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n Point, Line, Area 
buttons: once one 
of these has been 
clicked, the corre-

sponding object can 
be created in the 
project database. 

This object will then 
appear on the map 

Grab button : slides the map in 
the direction in which you drag 
the mouse cursor, by a value tied 
to the distance traveled by the 
cursor while being dragged  

Select
button: once 
clicked, any 

object on 
the map can 
be selected

Layer combo box.
Combined with one of 
the three buttons on 

the right, allows you to 
create new objects in 
the project database. 

These objects will then 
appear on the map  
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�� Adding an object to a collection from the map 
For example, open the Tuto2_Process project created in the Tutorials sec-
tion. Follow the instructions below to create a new reference point in this 
project. The point will be named “LandMark#10”. 

- On the Map toolbar, in the combo box located on the right, se-
lect  <Project_Name> \ Points: 

  
- On the Map toolbar, click  
- Move the mouse cursor over the map and left-click where you 

want to create a new point. A new dialog box opens showing the 
coordinates of the new point resulting from where you clicked 
on the map. This dialog box shows the coordinates of the point 
in the project’s spatial reference system. Example: 

  
 

- If this point is accurately known, you may need to enter its 
coordinates to be exactly those known for the point 
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- Select the Attributes tab. In the first field, type a name for the new 
point. In the second field (a combo box), choose the type of 
point you are creating. Example: 

  
 
- Click OK. The new point now appears on the map. Its representa-

tion on the map relies on the definition of a layer that is 
associated with the type this point belongs to. We will come 
back to this particular point in the next two paragraphs. Example 
of point representation:  

  
 You can quickly create as many points as required having the 

same type as this one by holding down the Shift key and clicking 
repeatedly on the map where you want these points to be cre-
ated. In this case, 4SPack skips the display of the New Points 
Feature Properties dialog box and directly creates the points. 
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Lines & areas can be created using the same technique. On the map toolbar: 

- Select <Project_Name> \ Lines in the combo box, click , then 
start drawing the line on the map. Click on the start point, then at 
the end of each new segment forming the line. To end the line, 
make a double click. In the dialog box that opens, the Location 
tab shows the coordinates of the points where segments end or 
start. The line attributes shown on the Attributes tab only consist 
of 4 possible geocodes plus a comment field. 

-  Select <Project_Name> \ Areas in the combo box, click , then 
start drawing the limits of the area. Click on the start point, then 
at the end of each new segment forming the area. Make a double 
click on the map to close the area. If you double-click on a point 
other than the area’s start point, 4SPack will automatically create 
the missing segment allowing it to close the geometric figure. In 
the dialog box that opens, the Location tab shows the coordinates 
of the points where segments end or start. The area attributes 
shown on the Attributes tab only consist of 4 possible geocodes 
plus a comment field. 

 
�� Showing/hiding a collection on the map 

- On the map pop-up menu, select Legend. This dialog box pro-
vides the list of existing layers. If the button opposite is checked, 
then all the objects from a collection meeting the criteria of this 
layer (see below) will be visible on the map. On the contrary, if 
this button is cleared, none of these objects will appear on the 
map.  
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�� Adding a new layer on the map 
As explained earlier, representing any object from a collection in the pro-
ject database resorts to the use of a layer. In any project that you create, 
there is a number of default layers created by 4SPack itself. However you 
can create as many layers as necessary for a given collection. For example, 
with points, you can create as many types of layers as there are different 
types of points. 
To add a new layer, you have to: 

1. Choose the collection on which the layer will apply to 
2. Name the layer 
3. Define a filter on the attributes of the source collection. In fact, 

the definition of the layer will result from the choices you make 
in this step 

4. Define a style (icon and associated text) specific to the layer. 
4Spack will refer to this style to represent each of the objects 
meeting the layer criteria. 

In the example below we will create a new layer called “Reference Points” 
corresponding to any object from the Points collection for which Type= 
Reference Points. This will be done using the Tuto2_Process project that 
we created in the Tutorial section. 

- On the menu bar, select Map>Legend 

- On the Legend tab, click  
- In the new dialog box that opens, select “Points”: 
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- Click OK. In the Layer Wizard: Data dialog box that opens, type a 
name for the new layer in the Alias field. For example, type 
“Logged References” 

- Then click  on the right 
- In the new dialog box that opens, set the attribute filter as shown 

in the screen capture below: 

  
 

- Click OK. A new dialog box shows the filter settings you have 
just made: 
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- Click Next. The Style dialog box now displays. You can do the 
following to customize the appearance of an object on the map: 

 
 
 
 
 
 

  
 
 
 
 
 
 
 

 

Use these 
buttons to 
adjust the 
size of the 

object on the 
map 

Check this button to see 
what the object looks like 

when selected 

This area is constantly 
updated to show the aspect
of the object as you define 

the style

Label definition area. If you clear the Text button, there is nothing
else to be defined in this area. If on the contrary this button is 
checked, you have to define: 
 - The attribute used as label 
 - The color used for characters 
 - Background color (if Back button checked) 
 - Location of the label with respect to the icon (9 preset locations) 

Icon definition area. If you clear the 
Symbol button, there is nothing else 
to be defined in this area. If on the 
contrary this button is checked, you 
have to choose the representation of 
the object in the combo box opposite 
the button. 
Then, depending on the symbol 
chosen, you have to define additional 
parameters, such as: 
 -Line color and width 
 - Fill color and effect   
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- When you have finished with the definition of the style, click the 
Finish button. The new layer now appears in the Map Properties 
dialog box. As a default setting, the check button opposite has 
been checked so that all the objects meeting the layer criteria be 
seen on the map: 

  
 

 Incidentally, this dialog box includes a number of buttons that can be used for 
the following: 

-  to modify an existing layer 

-  to delete the selected layer from the legend 

-  to move the selected layer upward in the list 

-  to move the selected layer downward in the list 
 

- Click OK to close the dialog box. The map is updated to take ac-
count of the change in the legend, which now includes a new 
layer. 
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�� Deleting an object in a collection from a map document 
- On the map, select the object you want to delete 
- Press the Del key or on the menu bar, select Edit>Delete. A warn-

ing message appears asking you to confirm your choice 
- Click Yes to allow 4SPack to delete the object. 
 

��  “Change Into” Function 
This function is used to transform the type of a point. For example, you can 
change a logged point into a logged reference point. To use this function: 

- On the map, select the point you want to change  
- On the Project menu, select Change Into... The following dialog 

box appears: 

  
- In the INTO combo box, choose the new type desired for the point 

and then click OK. As a result, the map is updated to show the 
type change. 
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Working in a Table Document 

�� Creating a Table Document 
- On the menu bar, select File>New 
- Select “Table” on the Documents tab. Name the new document by 

typing a name in the File Name field (for example type “Table1” 
- Click OK. A new blank table document opens on the View pane. 

 
4SPack builds a default table not necessarily containing all the object at-
tributes pertaining to the collection for which you are creating a table 
document. 4SPack lets you change the organization of the table document 
to suit your particular needs. For instance you can add/delete data columns, 
place a filter to list only those objects meeting the filter criteria or list the 
objects in a given order. 

- Open a table document. For example, use the tutorial project 
called “Tuto2_Process” that you created in Section 4 and open 
the Points (All coordinates) document 

- On the menu bar, select Table>Data. The Table Properties dialog 
box opens listing all the attributes (columns) currently viewed in 
the table document for each object (rows) in the collection. 
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�� Adding an Attribute to a Table Document 

- In the Table Properties dialog box, click . The new dialog box 
that opens allows you to choose the attributes that you wish to 
see in the table document. The default list shown in this table 
provides all the attributes that are not currently present in the ta-
ble document. (You could also list all the possible attributes by 
checking the Show all attributes radio button.) 

- To add a new attribute in the table document, simply select it 
and click Add: 

  
 

 The newly added attribute now appears at the end of the attrib-
utes list in the Table Properties dialog box. 

 You can change the rank of this attribute in the list. 

 To do this, select the attribute and click  until the attribute is 
at the desired position in the list. The first attribute in this list 
will appear in the first column in the table and so on 

- Click OK. A new column now appears in the table document. 
This column contains the attribute you have just added. 
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�� Removing an Attribute from a Table Document 
Temporary removal: 

- On the menu bar, select Table>Data. This opens the Table Properties 
dialog box. 

- In the list of attributes, clear the check button opposite the name 
of the attribute to temporarily remove it from the table. 

- Click OK. This removes the concerned column from the table. 
 To re-enable this attribute in the table document, re-check this 

button. 
 

Normal removal: 
- On the menu bar, select Table>Data. This opens the Table Properties 

dialog box. 
- In the list of attributes, select the attribute you want to remove 

from the table document. 

- Click . This deletes the attribute from the list. 
- Click OK. This removes the corresponding column from the ta-

ble. 
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�� Setting a Filter on an Attribute 
Setting filters on attributes allows you to list only these objects in a table 
document that you are interested in viewing. The result of this operation is 
that the table document will contain fewer objects (fewer rows). 

- On the menu bar, select Table>Data. This opens the Table Properties 
dialog box. 

- In the list of attributes, select the attribute for which you want to 
set a filter. For example, select “Horizontal_Precision”. 

- Click . In the dialog box that opens, make the following 
choices: 

  
 

- Click OK (twice). The table document now only consists of a 
single row showing the only object meeting the filter criterion. 
This criterion is recalled just under the column header. 
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Working in a graph document 

�� Creating a graph document 
- On the menu bar, select File>New 
- Select “Graph” on the Documents tab. Name the new document 

by typing a name in the File Name field, for example, type 
“Graph1”. 

- Click OK. A new blank graph document opens on the View pane. 
 

�� Defining the X and Y Axes 
You need to have a table document open on the View pane to create a 
graph in the graph document. Choose one or two columns to be involved in 
the definition of the graph. If you select a single column, then its content 
will necessarily be used to define the Y axis and a dimensionless, linear 
scale will be used as default setting on the X axis.  

- Open a table document containing some interesting data that you 
would like to plot on a graph. For example, use the tutorial pro-
ject called “Tuto2_Process” that you created in Section 4 and 
open the Points (All coordinates) document in this project 

- On the Window menu, select any of the options allowing 4SPack 
to show the two documents side by side on the View pane (Tile 
Horizontally for example) 

- In the Points (All coordinates) document, use the horizontal scroll 
bar to display the Vertical _Precision column 

- Select this column by clicking in the column header 
- Drag and drop the column header within the empty Graph docu-

ment. 
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 A graph now appears in the graph document, as shown below: 

  
 

�� Adding a new curve on the same graph 
- Right-click anywhere within the graph document and select Leg-

end in the pop-up menu. The Graph Properties dialog box opens 

- On the Legend tab, click  
- Select “Horizontal Precision” in the PLOT field (located in the 

Data area at the bottom of the dialog box). 
- Click OK. The Graph Properties dialog box now shows two items 

on the Legend tab: 

  
 

- Click OK. Two curves are now plotted on the graph with differ-
ent colors: one for the vertical precision, the other one for the 
horizontal precision. 
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 Both use the same X axis. 

  
 
 

�� Zooming in on a Graph 
- Drag horizontally (along the X axis) on the graph. The selection 

resulting from the drag operation appears in black: 

  
 

- When you release the mouse button, 4SPack zooms in on the se-
lected region in order to show this region using the total width of 
the graph document: 

  
 

- To come back to normal size, right-click anywhere on the graph 
document and select Zoom Out on the pop-up menu. 
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Coordinate Systems 

The following two types of coordinates systems are supported by 4SPack: 
 

System Category Definition Icon used 
Fitted Projected system + Local correction  

Projected Geographic system + Projection type + dis-
tance unit and labels used  2D 

(horizontal) 
Geographic Datum definition + angular unit and labels 

used  

Compound Horizontal system (one of the three catego-
ries above) + Vertical system  3D 

(horizontal 
& vertical) Geocentric Datum definition + distance unit and labels 

used  
 Datum Ellipsoid + shift values + scale factor  
 Ellipsoid Semi-major axis + inverse of flattening None 

 
Local correction: Based on the equation of a straight line (with specific value at 
the origin and specific gradient) 
Projection type: Conic stereographic, transverse or oblique Mercator, etc. 
Datum: Ellipsoid + shift values 

 
NOTE: 4SPack strictly complies with OpenGIS concerning coordinate 
transformations. 
Use the command Tools>Coordinate Systems... on the menu bar to work on 
the coordinate systems available in 4SPack. The set of available buttons in 
the upper-right corner of the window allows you to import/export (in text 
format), add, edit and delete your coordinate systems. 
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Geocodes & Operators 

In the Project Settings dialog box that you can access from the Project menu, 
4SPack lets you define a list of operators and a list of geocodes for the pro-
ject. Any list of operators or list of geocodes can be saved as a text file for 
further use. To work with a list previously saved as a text file, use the Load 
button to load this file into 4SPack. 
The list of operators may be useful for real-time surveys. When you upload 
a job to field equipment, you can specify the name of the operator in charge 
of the field survey. Later on, this name will be downloaded to 4SPack to-
gether with the associated field results. This allows you to know the names 
of the different operators that worked on the survey. 
The list of geocodes is just a memo to remind you of the meaning of each 
of the geocodes used in your surveys. 
To access these two lists, on the menu bar, select Project>Edit Settings... The 
list of geocodes is shown on the Geocodes tab. The list of operators is 
shown on the Operators tab. 
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Editing an Object in a Collection 

As you progress in your survey, and before you undertake such operations 
as baseline processing or network adjustment, the objects you are working 
on may require edits to some properties. Note however, not all the attrib-
utes can be changed. 
Typically, you may need to edit a point to change the following attributes: 
. Classic attributes: 

- Name 
- Type 
- Geocodes 
- Comment 
And also: 
- Control type: this attribute is used to define the spatial dimen-

sion of a point (1D, 2D or 3D). For example, selecting 1D for a 
point means that only its Z or Altitude coordinate will be used in 
the computations involving this point. 

- Fixed (Constraint): this attribute defines the degree of freedom 
assigned to a point (floating, fixed horizontally or/and verti-
cally). This parameter is of the utmost importance in the baseline 
processing and network adjustment procedures. It is the user’s 
responsibility to know how each point should be set regarding 
this attribute.  

- Target coordinates (if appropriate): only relevant to planned 
points for which theoretical coordinates (“target” coordinates) 
are defined in a real-time project. The field equipment in fact 
uses these coordinates (stored in the job in progress) when guid-
ing the field operator to these points (staking-out operations) 

. Geometric attributes: 
- Location (approximate, computed, preset or adjusted depending 

on how far you are in your survey) 
- Spatial reference system in which the point’s coordinates are ex-

pressed. 
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Editing an object stored in the project database can only be achieved from 
within a map or table document created in the project. Whatever the docu-
ment you use to do this, the changes will then appear in both documents, 
and also in any other document in the project mentioning this object. 

 
Accessing the Properties dialog box from a map document: 

- Select a point on the map 
- Right-click on this point and select Properties in the pop-up menu 
- In the dialog box that opens, make the changes required. 

 
 Accessing the Properties dialog box from a table document: 

- Select the row in the table providing the attributes of the point 
- Right-click anywhere on this row and select Properties in the 

pop-up menu 
- In the dialog box that opens, make the changes required. 
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Creating Custom Formats 

With 4SPack, you can easily create a data import or export format suited to 
your needs. All the creation process takes place within a single dialog box 
that you can access by following the procedure below, after opening a pro-
ject in 4SPack:  

- On the 4S Pack menu bar, select Project>Import Data From Files... or 
Project>Export Data to Files... 

- In the left-hand area of the dialog box that opens, select Points or 
Vectors, depending on the type of object for which you want to 
create a custom format 

- Click on  to create a new format, or  to make changes to an 
existing custom format after selecting its name in the right-hand 
list. The dialog box that opens allows you to define a new format 
or to modify the existing custom format. 

This dialog box is divided into 5 main areas as shown in the figure on the 
next page: 

- Area allowing you to name the file that will contain the created 
custom format (1) 

- Area allowing you to choose the parameters that can be inserted 
into the custom format + insert buttons + Header/Body selection 
buttons (2) 

- Area for editing the header of the custom format (3) 
- Area for editing the body of the custom format (4) 
- Area providing instructions on how to use this dialog box (5). 
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Dialog box allowing you to create a custom format: 

  
 

To create a new custom format, follow the instructions below: 
1. In the Name field, enter a name for the new format. In the Exten-

sion field just below this field, enter the file extension (3 
characters max.; default: txt) for the created file 

2. Start with the definition of the header by checking the Format 
Header radio-button. All the fields that can be inserted into the 
header are listed in the Field Selection list box 

3. Choose one of these fields from the list and click on the Insert... 
button. A new dialog box opens asking you to specify formatting 
instructions for this field 

 Depending on the type of the field, you will have to define its 
length (width), the number of decimal places if it’s a numeric 
field, its format spec if it’s a date or time, and possibly the asso-
ciated text (use \t to insert a tab within the text box). 

(1) 

(2) 

(3) 

(4) 

(5) 
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 For example, you can enter the following formatting instructions 

in this box after you have selected $Project in the list: 

  
 

4. Click on OK. The Format Header edit box now contains the fol-
lowing information: 

  
 You can change the formatting parameters by selecting them di-

rectly from within this edit box. 
Note that the “Width” parameter you have just defined is located just after the 
field name, within the square brackets, and is separated from the name by the “:” 
symbol. 
If you could have defined a number of decimal places for this field, this number 
would have been inserted just after the “Width” parameter, also separated from 
this parameter by a “:”. 
Example: SdZ:8:2 means that the “SdZ” numeric field will occupy a total of 8 
characters, 2 of which will be dedicated to the fractional part. If the field value 
fits in less than 8 characters, then leading spaces will be inserted to fill the field. 
The decimal point occupies one character. 
 

5. If you now select another field from the Field Selection list box 
and you click on the Insert (instead of the Insert...) button, then the 
field will be directly inserted into the Format Header edit box, 
keeping the same formatting instructions, if applicable, as the 
ones you have defined previously for the $Project field. 
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6. In the Format Header edit box, you can also create a new line, by 

inserting a carriage return, to type text directly in this box (see 
example on page 106 in which the inserted words are in fact the 
column headers corresponding to the fields entered in the Format 
Body edit box) 

7. Check the Format Body radio-button. All the fields that can be in-
serted into the format body are now listed in the Field Selection 
list box 

8. Follow the instructions from points3. to 5. above to create the 
format body. The instructions mentioned in the dialog box (see 
area (5) on page 106) are an alternative to the procedure de-
scribed above 

9. Click OK to save the newly created format. The name of the new 
format is now listed on the right in the initially selected dialog 
box (Import... or Export...). � 
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4. Post-Processing Survey Principles 

Field Survey Objectives 

Post-processing surveys are performed in the field using Thales Navigation 
receivers for logging GPS raw data on the sites to be surveyed. 
Potentially, from each data block in a log file, a straight GPS position can 
be determined for the receiver location when the data block was logged. 
The longer the logging time, the larger the number of data blocks available 
for the post-processing phase. 
In order to reach centimeter-level accu-
racies for each of the points being 
surveyed, raw data files must be logged 
simultaneously in two distinct receivers. 
One must be operated as a stationary 
unit at a known fixed point (it is then 
called the station), the other one is oper-
ated successively on each of the 
surveyed sites (and is called the rover). 
Several algorithms are used in the post-
processing phase with gradually increas-
ing precision (Floating, Wide Lane, 
Fixed), which ultimately lead to centi-
meter precision. 
The surveyed site is either a single point, or a trajectory that may include 
specific site occupation (Stop & Go). In the first case, logging takes place 
at a fixed point and so is said to be “static”. In the other case, it is per-
formed while the receiver is moved along the trajectory and so is known as 
“dynamic” or “kinematic”. 

� If the files logged on the surveyed point do not correspond in time to any other file 
logged at fixed point, the best position solution that you can expect for the surveyed 
site will only be an average of all the straight GPS solutions determined from the data 
blocks in these files. 
� Static log files does not differ in essence from dynamic log files. For this reason, it 
is essential for the user to remember in which conditions files are logged when he/she 
imports them into 4SPack. 

Reference 

P1 
P2 

Trajectory 
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Recommended Occupation Times 

With recording rate= 1 second and minimum 5 satellites properly received: 
- 10 minutes + 1 minute/km with single-frequency (L1) receivers  
- 5 minutes + 0.5 minute/km with dual-frequency (L1/L2) receiv-

ers  
 

Operating Ranges 

- Up to 15 km (9 miles) with single-frequency (L1) receivers  
- Up to 50 km (31 miles) with dual-frequency (L1/L2) receivers 
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4SPack Internal Processing Steps Tied to Raw 
Data Import 

(Project>Import Data from Files command; choose to import Raw-data Files) 
When importing a raw data file (observation file) into the active project, af-
ter the user has provided a File name, a Point name and has specified 
whether the file results from static or dynamic logging, the following takes 
place in 4SPack: 

1. The data blocks from the imported file are stored in the project 
database, more precisely in the GPS_Measurement folder as a 
new collection named: “<File_name>" 

2. Broadcast_Ephemeris and Broadcast_Iono collections are pos-
sibly updated. The updating will take place only if the ephemeris 
& ionospheric data present in the imported file are different from 
those already present in the project database. 

3. An approximate position (let’s call it “P0”) is determined in 
straight GPS mode using the first data blocks from the 
<File_name> collection. This computation is made regardless of 
the type of imported file (i.e. static or dynamic)1 

4. A new object is added to the project database in the Files collec-
tion. This object provides a full description of the imported file 
and also includes the name of the associated point (name pro-
vided by the user at the beginning of the import operation) + the 
approximate P0 position computed in the previous step2. A file 
object is said to be static or dynamic if it proceeds from, respec-
tively static or dynamic logging. 

                                                           
1 For a static log file, computing this coarse solution will allow 4SPack to locate the surveyed 
point on any map document created in the project. For a dynamic or “Stop & Go” log file, 4SPack 
will be able to “anchor” the surveyed trajectory on the map from its start point. 
2 Assigning P0 to the file also allows 4SPack to locate the file on a map. P0 is definitively tied to 
the file whereas the same P0, assigned to the point, will be updated as new computations are run to 
refine this position. 
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5. Finally, a new object is created in the Points collection3 and P0 
is assigned to this point. If however a point already exists in the 
database with the name specified at the beginning of the import 
operation, no new object will be created in the Points collection 
and, in this case, P0 will not be assigned to this point. 

 In the case of a “Stop & Go” survey, 4SPack will update the 
Stops collection to report all the marks (or events) detected in the 
log file. 

6. In the project database, 4SPack searches for files that coincide in 
time, partially or completely, with the file that has just been cre-
ated. 

7. If concomitant files are found, new objects are created in the 
Processes collection. Each of these objects describes a baseline4. 
The baseline is oriented in such a way that the first point men-
tioned is more likely than the other to be a reference point. The 
probability is all the more important as the point is: 

- Held fixed by the user 
- Involved in a large number of baselines 
- Associated with a long observation. 

                                                           
3 Surprisingly, this step also applies to a dynamic log file. In fact, as long as a trajectory remains 
unprocessed in 4SPack, it is assumed to be a point, which means a point whose position is that of 
the trajectory’s start point, as explained in footnote 2. 
4 A baseline is defined as the straight line between the two points associated with a pair of simulta-
neous observation files. 
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Baseline Processing 

(Project>Process Baselines...command) 
To process a baseline, 4SPack needs: 

- The point providing the reference position 
- A file the reference point is associated with 
- The surveyed site (a point or the start point of a trajectory) 
- A file the surveyed site is associated with 
- An indication on the processing mode to use: “static” if the file 

associated with the surveyed site is static, “dynamic” if it is dy-
namic or “Stop & Go” if it’s a dynamic survey during which the 
survey receiver was informed of the moments when it was kept 
stationary (marks, or “events” logged in the observation file) 

- To know the processing options. 
 

�� Static 
(Static mode selected) 
The following processing steps are run in 4SPack: 

1. An optimized L1 or L1/L2 float solution is determined for the 
surveyed site. 

2. An optimized Wide Lane solution is determined (only if L1/L2 
data is available) 

3. An optimized L1 or L1/L2 fixed solution is determined. 
4. An ultimate solution is computed, with the best possible accuracy 
5. The ultimate result is stored in the Points collection, in the ob-

ject corresponding to the surveyed site (unless this site is held 
fixed) 

6. The vector resulting from the above processing is built. It is ori-
ented from the reference to the computed point. 

7. A new object is created in the Vectors collection showing how 
the vector is built. The vector is identified by the two points 
from which it proceeds and therefore has no proper name. 
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 NOTE:  At the beginning of the procedure, you can specify a 
point name different from that of the surveyed site and associate 
the file available for this site with the new name. As a result, the 
ultimate solution will automatically be saved as a new object in 
the Points collection. This way of working allows you to save 
several solutions for the same surveyed site. In this case how-
ever, it is the user’s responsibility to use appropriate naming so 
that he/she does not get lost amid all the solutions available. 

 
�� Dynamic 

(Dynamic mode selected) 
The following processing steps are run in 4SPack: 

1. All objects in the Points and Vectors collections pertaining to the 
trajectory being processed are deleted if this trajectory already 
exists in the Lines collection. 

2. A certain number (n) of optimized floating or fixed solutions are 
computed for all epochs for which GPS measurements are avail-
able. 

3. The n solutions are saved as n objects in the Points collection 
4. The n points are linked to form the trajectory 
5. An object is created in the Lines collection. It is named like the 

site from which it proceeds. The set of n points making up the 
trajectory is then defined as the geometric attribute of the new 
object. If however the trajectory already exists in the collection, 
its geometric attribute is updated with the set of n points com-
puted. The object from the Points collection involved in this 
processing is updated as the first point of the trajectory. 
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�� Stop & Go 
(Stop & Go mode selected) 
The following processing steps are run in 4SPack: 

1. An optimized L1 or L1/L2 float solution is determined corre-
sponding to each mark present in the Stops collection 

2. An optimized Wide Lane solution is determined (only if L1/L2 
data is available) for each of these marks 

3. An optimized L1 or L1/L2 fixed solution is determined for each 
of these marks 

4. An ultimate solution is computed, with the best possible accuracy, 
for each of these marks 

5. The ultimate results are stored in the Points collection 
6. The vectors resulting from the above processing are built. They 

are oriented from the reference to the computed points 
7. New objects are created in the Vectors collection showing how 

the vectors are built. The vectors are identified by the two points 
from which they proceed and therefore have no proper names. 

 
� Unlike the processing of a trajectory, no object is created in the Lines collection and 
no intermediate points are stored in the Points collection.. 
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Sites computed individually 

(Project>Process Single Site... command) 
To determine a solution for a site taken separately, 4SPack needs: 

- The name of the surveyed site (a point or a trajectory) 
- An observation the surveyed site is associated with 
- An indication on the processing mode to use: “static” if the ob-

servation associated with the surveyed site is static, or 
“dynamic” if it is dynamic or of the Stop & Go type. 

 
Static Processing (Static mode selected) 
The following processing steps are run in 4SPack: 

1. From all the pure GPS solutions deduced from the observation, 
an average position solution is computed for the site 

2. The result is stored in the corresponding object in the Points col-
lection. If the object does not exist, it is then created. 

 
Dynamic Processing (Dynamic mode selected) 
The following processing steps are run in 4SPack: 

1. All objects in the Points and Vectors collections pertaining to the 
trajectory being processed are deleted if this trajectory already 
exists in the Lines collection. 

2. n pure GPS solutions are computed for all epochs for which GPS 
measurements are available 

3. The n solutions are saved as n objects in the Points collection 
4. The n points are linked to form the trajectory 
5.  An object is created in the Lines collection. It is named as the 

site from which it proceeds. The set of n points making up the 
trajectory is then defined as the geometric attribute of the new 
object. If however the trajectory already exists in the collection, 
its geometric attribute is updated with the set of n points com-
puted. The object from the Points collection involved in this 
processing is updated as the first point of the trajectory. 
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Survey Schemes 

�� Static 
1st step: Field Survey 
Assuming the following survey example: 1 reference point on which a 
Thales Navigation 6502 SP receiver logs raw data for about 30 minutes. 
Another receiver, for example a Thales Navigation 6502 MP, is moved 
successively on points P1, P2 and P3. The receiver is kept at standstill on 
each point for about 10 minutes during which raw data is logged by this re-
ceiver. These logging sequences coincide in time with that performed at the 
reference point. 

 
 
 
 
 
 
 
 

 
2nd step: Creating a new land survey project with 4SPack 
Use the File>New command to create a land survey project (and a work-
space). 
 
3rd step: Importing raw data files into the project database 
Use the Project>Import Data from Files command to import the files logged in 
the field (P1log.bin, P2log.bin, P3log.bin, Reflog.bin). The following is 
then performed in the project database: 

- In GPS_Measurement folder, a new collection is created for 
each imported file 

Reference

P1 
P2 

P3 Baselines 

Raw data logging:

At P1
 
At P2
 
At P3

At  Ref

P1log.bin P2log.bin P3log.bin Reflog.bin Created files:
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- In the GPS_Data folder, ephemeris & iono data collections are 
updated if different from those already present in the database 

- In the Files collection, a new object is created for each imported 
file 

- In the Points collection, a new object is created for each im-
ported file (unless already existing) 

- In the Processes collection, as simultaneous observations are 
found, 3 objects are created to describe the following 3 baselines 
in our example: RefP1, RefP2, RefP3. 

Before proceeding to the next step, the operator has to enter the coordinates 
and attributes of the reference point.  

 
4th step: Processing baselines 
Use the Project>Process Baselines... command. Choose the adequate proces-
sor to perform this operation. Two different processors are available: Static 
or Dynamic. For the present example, the Static processor is the one to be 
used to determine the three baselines. 
After the validation step, the ultimate results are stored as objects in the fol-
lowing collections: 

- Vectors 
- Points 

Vectors may be adjusted using Project>Adjust Baselines... if there is sufficient 
redundancy in the measurements, which is highly desirable.  
 
5th step: Analyzing results & creating a report 
Use the Project>Generate Report... command to generate a project report. 
There are several types of reports available. Each type results from the exe-
cution of a specific VB Script macro saved in ...\Studio\Macro. Each of 
these macros drives 4SPack to format the data read from the database. 
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Post Processing 

�� Dynamic 
1st step: Field Survey 
Assuming the following survey example: 1 reference point on which a 
6502 SP type receiver logs raw data for about 30 minutes. 
Another receiver, for example a 6502 MP, is moved along a trajectory wile 
logging raw data. The two logging sequences coincide in time. 

 
 
 
 
 
 
 
 

 
2nd step: Creating a new land survey project with 4SPack 
Use the File>New command to create a land survey project (and a work-
space). 
 
3rd step: Importing raw data file into the project database 
Use the Project>Import Data... command to import the files logged in the field 
(trajlog.bin, Reflog.bin). Don’t forget to select the Dynamic check box be-
fore importing trajlog.bin (this will automatically set the processing of the 
resulting baseline to Dynamic or Stop & Go if files contain events). The fol-
lowing is then performed in the project database: 

- In GPS_Measurement folder, a new collection is created for 
each imported file 

- In the GPS_Data folder, ephemeris & iono data collections are 
updated if different from those already present in the database 

- In the Files collection, a new object is created for each imported 
file 

Raw data logging: 

Along trajectory

At  Ref 

trajlog.bin Reflog.bin Created files:

Reference

Start

EndTrajectory 
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- In the Points collection, a new object is created for each im-
ported file or is updated if the object already exists. See Footnote 
3 on page 112 for the description of the site created for the rover. 

- In the Processes collection, as simultaneous observations are 
found, an object is created to describe the following pseudo-
baseline in our example: RefStart. 

Before proceeding to the next step, the operator has to enter the coordinates 
and attributes of the reference point.  
 
4th step: Processing baselines 
Use the Project>Process Baselines... command. Choose the adequate proces-
sor to perform this operation. Two different processors are available: Static 
or Dynamic. For the present example, the Dynamic processor is the one to 
be used to determine the trajectory. 
After the validation step, the ultimate results are stored as objects in the fol-
lowing collections: 

- Points 
- Lines 

As there cannot be any redundancy in the data recorded when surveying a 
trajectory, there is no point in using the network adjustment command.  
 
5th step: Analyzing results & creating a report 
Use the Project>Generate Report... command to generate a project report. 
There are several types of reports available. Each type results from the exe-
cution of a specific VB Script macro saved in ...\Studio\Macro. Each of 
these macros drives 4SPack to format the data read from the database. 
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�� Stop & Go 
Follow the same steps as in Dynamic section except for the following: 

- 3rd step: 4SPack also feeds the Stops collection after analyzing 
the marks found in the imported file. In the Processes collection, 
new objects are created only for the detected marks 

- 4th step: no new object is created in the Lines collection. � 
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5. Real-Time Survey Principles 

Survey Scheme 

1st step: Creating a new land survey project with 4SPack 
Use the File>New command to create a real-time project (and a workspace). 
 
2nd step: Preparing a job with 4SPack 
In the open real-time project, create a map document to create/import all 
the points needed for your survey (reference, target points, etc.). An exam-
ple of a job is shown on the map document below: 

 
 

3rd step: Uploading the job to the field system 
Use the Project>Upload real-time job... command to upload the job to the sur-
vey terminal. 
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4th step: Field Survey 
Assuming the following survey example: a Thales Navigation 6502 SK sta-
tion is operated at an accurately known point throughout the duration of the 
survey. 
Another receiver, for example a Thales Navigation 6502 MK rover, is used 
to take the field operator to the different points and trajectory described in 
the job. 
 
 
 
 
 
 
 
 
Once the field operator has accurately placed the rover antenna on each of 
the targets, he/she can place stakes on these points and save the position 
then computed by the receiver for further cross-checking. He/she can also 
be guided along a preset trajectory, for example to stake it out. 
In addition to the job itself, the field operator can also compute and save 
the position of any interesting point located in the working area (including 
control points, also for the sake of cross-checking) or log points along a tra-
jectory at regular intervals of time or distance. 
 
5th step: Downloading survey results 
Use the Project>Download real-time results... command to download the survey 
results into the original real-time project. The results will appear immedi-
ately on the project map according to the current settings of style and 
display filter for the concerned collection types. 

Pt1 

Pt2 Pt3 

Ref 

P 

Pt4 

Sta1 

Traj1 
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6th step: Analyzing results & creating a report 
Use the Project>Generate Report... command to generate a project report. 
There are several types of reports available. The generation of each type re-
sults from the execution of a specific VB Script macro saved in 
...\Studio\Macro. Each of these macros drives 4SPack to format the data 
read from the database. � 
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6. Post-Processing Algorithms 
When you run the Project>Process Baselines function, the pair of data files 
associated with each baseline is processed several times, each time in a dif-
ferent mode starting from the less precise, up to the most precise. 
In the case of single-frequency raw data files, the processing modes used 
are: 

- First “L1 Float” 
- Then “L1 Fixed” 

 
In the case of dual-frequency raw data files, the processing modes used are: 

- First “L1/L2 Float” 
- Then “Wide Lane” 
- Then “L1/L2 Fixed” 

 
Each step produces a position solution specific to the processing mode 
used. This fully qualified solution is used as the “approximate position” in 
the next processing mode run by 4SPack. 

 
If at the end of the processing, the fixed solution does not pass the valida-
tion test, 4SPack will reject this solution and will only keep the float 
solution. 
The post-processing algorithms implemented in 4SPack provide the follow-
ing precision figures (fixed solutions): 

- 3 mm + 0.5 ppm (static) 
- 10 mm + 1 ppm (kinematic) 
 1� RMS figures, on a clear site, in normal conditions of GPS reception (nor-

mally active ionosphere, 5 satellites used and HDOP<4). � 
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7. Network Adjustment 

Introduction 

A least-squares adjustment of survey observations is one of the most im-
portant steps in a GPS survey. Properly used, a least-squares adjustment 
helps isolate blunders in the observations being adjusted and improves the 
accuracy and reliability of the point positions being determined. The 
mathematics and statistics involved in performing and analyzing a least-
squares adjustment is somewhat complex but the basic concepts of the task 
accomplished by an adjustment are straightforward.  
The primary components of a least-squares adjustment are the survey ob-
servations (angles, distances, elevation differences, and, in this case, GPS 
vectors) and the uncertainties (confidence) associated with these observa-
tions. Due to measurement limitations of the surveying instruments and the 
influence of the instrument operators, these observations include some 
level of error. These errors cause loops not to close perfectly and result in 
the ability to compute different positions for the same point in the network 
based on which observations were used to compute the position.  
The ultimate goal of a least-squares adjustment is to produce a set of ob-
servations where all loops close perfectly and only one position can be 
computed for any point in the network. In order to accomplish this task, the 
observations going into the adjustment must be changed slightly, i.e. ad-
justed. Of course, you do not want the observations to be changed much 
since this it what was physically observed in the field, but the observations 
do contain some level of error. 
Any error associated with an observation is predictable because of the 
measurement accuracy of the survey instruments used. So, do not be con-
cerned that the observations are adjusted as long as the amount of 
adjustment to any given observation is not significantly greater than the 
expected error in the observation. 
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These are the fundamental guidelines to a least-squares adjustment. A suc-
cessful adjustment is one where observations are changed as little as 
possible, and the amount of change (adjustment) to any observation is 
within expected levels, i.e. about the same magnitude as the uncertainty in 
the observation. 
Unfortunately, there are a number of obstacles that can stand in the way of 
producing a successful adjustment. Primary on this list are blunders, errors 
in the observations due to equipment malfunction or operator error. Exam-
ples are an incorrectly measured instrument height, an instrument not 
properly centered over the survey mark, insufficient data to produce a high 
quality GPS vector, assigning the wrong Site ID to a point, etc. The list is 
long. Fortunately, tools exist to assist in overcoming these obstacles. These 
adjustment analysis tools have been incorporated into the adjustment mod-
ule of 4SPack.  
Adjustment analysis tools cannot function properly without redun-
dancy in the adjusted observations. It is impossible to detect a blunder in 
an observation establishing the position of a point if there is only one ob-
servation at this point. When designing a survey network, be sure to 
include sufficient redundancy in the observations. The best case would 
be to include more than one observation of each point being established. 
Unfortunately, this is not practical and really not necessary. Select a cer-
tain percentage of points to receive multiple observations. Thirty to 
fifty percent is recommended. This redundancy will significantly increase 
the likelihood that observation blunders will be detected by the adjustment. 
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Running a Network Adjustment 

When 4SPack performs a network adjustment, detailed information is re-
ported in the Output pane concerning the adjustment in progress. Below is 
an example of what can be read on the output pane. 

 

 
 

Each adjustment step reported in this pane is detailed hereafter. 
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�� Network Connectivity Test 
In order to properly adjust an entire data set of observations, there must be 
connectivity between all sections of the data set. For example, look at a 
survey of a pipeline that will require multiple days of work to complete. 
Two survey crews begin work on the project, one on the north end and one 
on the south end. At the end of day 1, each crew will have surveyed a num-
ber of points at each end of the project. The two data sets have no 
observations between them yet. These two data sets cannot be adjusted to-
gether because they are not connected.  
The network connectivity test examines the data set prior to adjustment to 
determine if there are subsets of the data set that are not connected by ob-
servations. 
 

�� Variance of Unit Weight/Standard Error of Unit Weight 
The Variance of Unit Weight and the Standard Error of Unit Weight (the 
square-root of the Variance of Unit Weight) monitor the relationship be-
tween the uncertainties assigned with the observations and the magnitude 
of the change required to each observation (residuals) in the adjustment. 
Changes to the observations should be small and should not be signifi-
cantly greater than the uncertainties associated with the observations.  
The Variance of Unit Weight and Standard Error of Unit Weight gauge the 
magnitude of the observation changes (residuals) compared to the observa-
tion uncertainties for the entire network. 



Network Adjustment 
Running a Network Adjustment 

 133 

N
etw

ork 
A

djustm
ent 

Analysis of the magnitude of the computed Variance of Unit Weight and 
Standard Error of Unit Weight reveals one of the following three condi-
tions regarding the quality of the adjustment: 

1. A computed value close to 1 is an indication that the changes to 
the observations (residuals) are within expected levels, i.e. 
within the uncertainties associated with the observations. Since 
this is the desired outcome, a value close to 1 is normally an in-
dication of a good adjustment.  

2. A computed value significantly smaller than 1 indicates an im-
balance between the observation residuals (changes) and 
observation uncertainties. Specifically, the observation uncer-
tainties are too pessimistic (too large).  

3. A computed value significantly larger than 1 is also an indica-
tion of an imbalance between the observation residuals 
(changes) and observation uncertainties. Specifically, one or two 
problems exist with the adjustment. Either one or more blunders 
exist in the observations causing the observation residuals to be 
much larger than the observation uncertainties, or the observa-
tion uncertainties are too optimistic (too small).  
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�� Chi-Square Test 
The Chi-Square test is a statistical test evaluating the computed value for 
the Variance of Unit Weight. Its purpose is to determine if the computed 
value for the Variance of Unit Weight is statistically equivalent to 1. As 
stated earlier, a Variance of Unit Weight equal to 1 indicates a balance be-
tween observation residuals and observation uncertainties. It is very seldom 
that the computed value for the Variance of Unit Weight will exactly equal 
1. But an exact value of 1 is not required. The Chi-Square test examines the 
computed value to determine if it is statistically equivalent to 1. If the test 
passes, the computed value is considered equivalent to 1.  
Due to the difficulties in computing observation uncertainties due to the 
many variables involved, in many cases the Variance of Unit Weight will 
be larger or smaller than 1. This causes the Chi-Square test to fail. 4SPack 
automatically compensates for observation uncertainties being too large or 
too small, therefore the passing or failure of the Chi-Square test has no true 
bearing on the quality of the adjustment. 
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�� Observation Residuals 
In a least-squares adjustment, small corrections are applied to the observa-
tions to obtain the best fit of all observations producing one solution for all 
points. The best fit is the solution that produces the least amount of correc-
tions to the observations. These small corrections are termed residuals. 
Each observation will have one or more residuals. GPS observations have 
three residuals, one for each component of the GPS vector (X,Y,Z or 
N,E,U).  
The reason why observations have to be corrected at all in order to produce 
a good fit is due to errors in the observations. If observations contained no 
errors, then an adjustment would not be needed. All observations would fit 
together perfectly. Two types of errors can be found in survey observa-
tions, random errors and blunders. Random errors will cause small 
corrections to be needed in observations in order to make them fit together 
properly. If only random errors exist in the data set, all residuals will likely 
be small. On the other hand, if large blunders exist in the data set, large re-
siduals will likely be produced. 
Examining the size of observation residuals can help in identifying blun-
ders in the observations used in the adjustment. 4SPack will display and 
output the residuals for all observations. These residuals should be exam-
ined in an attempt to identify blunders. If blunders are identified, they must 
be removed from the data set, and the adjustment rerun. If the observation 
containing the blunder is a critical observation of the data set, it should be 
examined to determine the cause of the blunder. Once repaired, the obser-
vation can be returned to the adjustment. If the observation is critical to the 
strength of the network and cannot be repaired, the data will need to be re-
observed. 
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�� Tau Test 
Examining residuals is a good indicator of the quality of individual obser-
vations. As stated earlier, the expected value of residuals/normalized 
residuals are predictable since they are expected to follow a normal distri-
bution.  
The Tau test utilizes this predictability to automatically test the residuals of 
an observation to determine if the residuals could represent an observation 
containing a blunder. The Tau test utilizes the normalized residuals for an 
observation to determine if statistically the residual is within expected lim-
its. A threshold value is computed to test each normalized residual against. 
Each normalized residual is tested with two possible outcomes: 

- The Tau test passes indicating that the magnitude of the normal-
ized residual is not greater than the expected limit for the 
residual. This is usually a good indication that the observation is 
free of blunders. 

- The Tau test fails indicating that the magnitude of the 
normalized residual is greater than expected. The observation 
failing the test should be checked for blunders. 

The tau test is automatically performed by the adjustment module of 
4SPack. Each residual is tested and the outcome of the test is presented in a 
check button along with the residuals for each observation. If the button is 
checked, this means that the residual has passed the Tau test.  
It is important to understand, that if a residual does not pass a statistical 
test, it does not mean that there is a blunder in that observation. The obser-
vation is merely flagged so that it can be examined and a decision about its 
retention or rejection can be made. Blind rejection is never recommended. 
A blunder in one observation usually affects the residuals in other observa-
tions. Therefore, the tests will often flag other observations in addition to 
the ones containing blunders. If one or more observations are flagged, the 
search begins to determine if there is a blunder. 
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In summary, the Tau test examines observation residuals in an attempt to 
locate observations that may contain blunders. Each residual is tested to de-
termine if it passes or fails the test. 

- If a residual passes the Tau test, this is a good indicator that the 
observation does not contain blunders. 

- If the residual fails the Tau test, the observation should be 
closely examined to determine if it contains a blunder. 

- Remember that if a residual fails the Tau test, this is not a certain 
indicator that a blunder exists. Simply removing observations 
that have failed the Tau test is not recommended. These observa-
tions must be examined carefully to determine if a blunder 
exists. � 
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8. Pred Utility 

Introduction 

Pred allows you to know which GPS satellites should be visible from a 
given observation point on the surface 
of the Earth, and for a given period of 
time (max. 24 hours). The World Map 
editor (see opposite) allows you to 
quickly define an observation point. 
Pred uses almanac data sent by GPS 
satellites to perform a prediction. Each 
set of almanac data provides the 
orbital parameters for the whole GPS 
constellation. Almanacs are assumed 
to be valid for a period of time 
centered around a reference time 
called TOA (Time Of Almanac). The closer to the time of prediction the 
TOA of the chosen almanacs, the more reliable the prediction. 
Pred allows you to import new sets of almanac data saved in Thales 
Navigation formats (SFIX, SVAR or SBIN), or of the following type: 
 SEM<Week No.>.TXT (almanac files downloaded from the US coast-
guards site: www.navcen.uscg.gov). 
 
Pred can also display the set of alma-
nacs used (see opposite). 
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Pred produces the following views to help you analyze the results of the 
prediction: 

At Time Schedule Range 

   
Doppler Elevation Azimuth 

   
Polar GDOP 

  
 
Pred also allows you to edit curtains and to apply them to the observation 
point (see Curtain Editor below). A curtain is a pattern representative of the 
obstructions around the 
observation point and 
liable to disturb the re-
ception of GPS signals 
at this point.  
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Almanacs used in the prediction 

�� Opening a set of almanacs  
When launching Pred, the set of almanacs last loaded is used. To open a 
new set of almanacs: 

- Click on , or in the menu bar, select File>Open. A dialog box 
opens showing the list of some of the almanac files stored in the 
Raw directory 

- In the lower part of this box, specify the format of the almanac 
file you would like to open. The possible choices are: 

� ASCII (*.raw) 
� Binary (*.bin or *. dXX) 
� SEM almanacs from the US coast gards (Sem*.txt) 

- Choose the desired set of almanacs from the files list, then click 
Open to load it. 

 
�� Importing a new set of SEM-type almanacs 

Using this function supposes that your PC can be connected to the Internet. 
- In the menu bar, select Help>Get Almanacs. A new dialog box 

opens asking you to con-
firm the address of the US 
coast guards site (currently 
www.navcen.uscg.gov) 
with direct access to the 
almanac page 
/ftp/GPS/almanacs/ 
sem/  

- Click OK to launch your 
Internet browser, which then automatically connects to the re-
quested site 
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- Choose the desired set of almanacs from the list and then display 
it on the screen 

- Save this set of almanacs as a TXT file in your local Raw direc-
tory then leave the site. 

To use this new set of almanacs, open it in Pred as explained previously. 
 
 

�� Viewing the set of almanacs used 
- On the menu bar, select View>Almanac. The main window then 

shows the set of almanacs currently used in the form of numeri-
cal data. 

- Click on Page Up or Page Down, or on the corresponding keys on 
the keyboard, to view the almanac for the next or previous satel-
lite (each screen provides the orbital parameters for a single 
satellite). 

 
 

Example of almanac for satellite No.1 at the specified date and time: 

   

  



Pred Utility 
Defining the observation point 

 143 

Pred 

Defining the observation point 

When launching Pred, a prediction for the last selected observation point is 
run. 
The parameters defining an observation point are its name, its WGS84 co-
ordinates (Lat/Lon/Alt), and the curtain placed on this point. 
The definition of an observation point can be saved to be used at a later 
date. 
To define the observation point: 

- Click on , or on the menu bar, select Edit>Site and complete 
the following fields: 

 Site Give a name to the observation point (xx characters max.) 
 Lat, Long Enter its latitude and longitude: 
  ▪ by completing manually the Lat and Long fields  
  ▪ or by using the World Map Editor located on the right. 

This tool allows you to complete automatically the pre-
vious two fields by selecting the point graphically on 
the surface of the globe (see page 158) 

 Alt Define the point’s altitude by completing manually this 
field 

 Local Obstructions... 
 button This button provides access to the Curtain Editor, which 

you can use if you wish to define a curtain around the ob-
servation point. A default curtain exists which consists of 
all the space between 0° elevation and the minimum ele-
vation angle above which satellites are used. See 
page 161 and next ones. 

 Load... button Allows you to select an observation point saved earlier as 
a Pos file in order to use it as the current observation 
point 

 Save... button  Allows you to save the current observation point as a 
*.Pos file (stored in Pos directory) for further use. 
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Dialog box allowing you to define an observation point: 
 

 

Use of World Map Editor described in 
detail from page 158 

Use of Curtain Editor described in detail 
from page 161 
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Defining the date & time of prediction 

When launching Pred, a prediction for the current date & time is automati-
cally computed. 
The parameters defining a time of prediction are the date (month, year, 
day) and the start & end times (max. observation time span: 24 hours) 
To define a new date & time of prediction: 

- Click on , or on the menu bar, select Edit>Epoch and select the 
following in the dialog box that opens: 

 Date Select month, year and date of prediction 
 From Enter start time of prediction 
 To Enter end time 

- Click OK to complete the definition. 

 
Dialog box allowing you to define the date & time of prediction: 
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Defining a moment within the prediction 

You can define a particular moment within the prediction time span: 

- Click on  or on the menu bar, select Edit>Cur. Time 

- In the lower-right corner, specify the interesting moment (in 
hours, minutes, seconds) 

- Click OK to complete the definition. 

 
 

Dialog box allowing you to define a particular moment within the prediction: 
 

 
 
 

NOTE : This particular moment in the prediction can be shifted graphi-
cally on any prediction view. See page 155. 



Pred Utility 
Defining the local/ UTC time deviation 

 147 

Pred 

Defining the local/ UTC time deviation 

This deviation identifies the time zone in which the observation point is lo-
cated. 
To change this deviation: 

- On the menu bar, select Edit>Time Zone  
- Select the working area in the Zone field 

You can also enter a deviation expressed in hours, minutes and 
seconds by selecting the “UTC+HH:MM:SS” option in the Zone 
field, and then by entering the value of time deviation in the 
HH:MM:SS field shown just below 

- Click OK to complete the definition. 
 
 

Dialog box allowing you to define the local/UTC time deviation: 
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Prediction results 

Prediction results are provided in the form of graphs called “views”. Apart 
from the At Time and Polar views, all the views use an axis system with the 
prediction time span represented along the X axis (a linear scale is used and 
each graduation represents 1/10th of the total prediction time span). Along 
the Y axis are represented the possible values of the displayed parameter 
which may be one of the following: 

- On Schedule View: SV No. (1 to 32) AND No. of visible satel-
lites  

- On Range View: distance from 20 000 to 26 000 km 
- On Doppler View: Doppler from -1000 to +1000 m/s 
- On Elevation View: Elevation angle from 0 to 90° 
- On Azimuth View: azimuth angle from 0 to 360° 
- On DOP View: DOP from 0.1 to 100  

 
The Polar view uses polar coordinates as suggested by its name. The At Time 
view provides numerical data for one given moment chosen in the predic-
tion. 
To select a view: 

- Select View>[View Name] or, after placing the mouse cursor any-
where within the display zone, choose it from the menu 
displayed after a right click on the mouse. 

 
The following information is provided in each view subtitle: 

- Label & XYZ coordinates of the observation point (1st line)  
- Prediction start & end times (2nd line)  
- Validity date of the almanac data used in the prediction, mini-

mum elevation angle and presence or absence of a curtain (3rd 
line).  
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�� “At Time” view 
The “At Time” view lists the positions of the visible satellites from the ob-
servation point, for the moment chosen in the prediction. 

Example of “At Time” view : 

 
 
�� “Schedule” view 

This view shows the times when each satellite is visible, as well as the total 
number of visible satellites at any given time within the prediction. 
The period of time during which a satellite is visible is represented as a 
bold horizontal line. The red multi-line is representative of the total number 
of visible satellites at any time during the prediction. Grey lines, if any, in-
dicate unhealthy satellites. 

Example of “Schedule” view: 
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�� “Range” view 
This view shows the variations of distance between each of the visible sat-
ellites and the observation point. 

Example of “Range” view: 

 
 
�� “Doppler” view 

This view shows the variations of speed for each of the visible satellites 
with respect to the observation point. 

Example of “Doppler” view: 
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�� “ Elevation” view 
This view shows the variations of elevation for each of the visible satellites 
during the prediction. 

Example of “Elevation” view : 

 
 
�� “Azimuth” view 

This view shows the variations of azimuth for each of the visible satellites 
during the prediction. 

Example of “Azimuth” view : 
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�� “Polar” view 
This view shows the orbit of each of the visible satellites above the obser-
vation point, for the whole prediction time, as well as the planned position 
of each of these satellites for the chosen moment. The view uses polar co-
ordinates: 

- Center of concentric circles: location of observation point 
- From center to larger circle: elevation angle, from 90° to 0° re-

spectively (each new circle represents 10° in elevation) 
- The angular space between any two adjacent lines represents 30° 

in azimuth; graduated clockwise from 0 to 360°. 
 

Example of “Polar” view ( azimuth=f(elevation)) : 
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�� “GDOP” view 
This view shows the variations of the selected DOP as a function of the fix 
computation envisaged on the observation point: 
To select which DOP parameter to plot: 

- Select Options>DOP... >[Parameter Name] The possible choices are:  
- GDOP: Geometric Dilution Of Precision 
- PDOP: Position Dilution Of Precision 
- HDOP: Horizontal Dilution Of Precision 
- VDOP: Vertical Dilution Of Precision 
- TDOP: Time Dilution Of Precision 

Define the type of fix computation envisaged at the observation point so 
that Pred can determine the corresponding DOP values: 

- Select Options>3D+T or Options>2D+T. 
2D+T should be chosen if the altitude is known and constant 
throughout the working area around the observation point, oth-
erwise choose 3D+T. In 2D+T only 2 position unknowns, 
instead of 3, are involved in the GDOP computation. This natu-
rally results in better (lower) GDOP figures. 

 
Example of “GDOP” view: 
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�� Displaying 4 or 2 different views at the same time  
- Select View>Split and then click in the middle of the window with 

the left-mouse button. The window is split into 4 areas each of 
them showing a different view of the prediction 

 
Example of a screen showing 4 different views at the same time: 

  
  

- To choose a different view in an area, position the mouse cursor 
anywhere within the area and then select the desired view from 
the menu displayed after a right click 

- Switching to two views and then back to a single view are 
simply obtained by dragging the concerned border out of the 
window or by double-clicking on it. 

 
�� Copying or printing the active view 

- Click on  or select Edit>Copy to copy the active view to the 
clipboard so you can paste it in a document created with another 
program. In the case of several views displayed concurrently, the 
active view is merely the one in which you have last clicked. 

- Click on  or select File>Print Preview to preview the active 
view. 

- Click on  or select File>Print to print the active view. 
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�� Redefining a specific moment in the prediction 
For all views on which the X axis represents the total duration of predic-
tion, the specific moment (defined in page 146) is denoted by a marker (a 
down-arrow): 
 

 
 
This marker may be shifted towards the beginning or the end of the predic-
tion using one of the following methods. Whatever the method you use, the 
Current Time dialog bow will always be updated following this operation. 

1. By directly clicking inside the graph where you would like the marker 
to be located 

2. Using the following buttons on the toolbar: 

- Click on  to move the marker. 
 or 
- Click on  to move the marker one step backward.  

 
3. Using the following buttons on the keyboard: 

- A short press on the "+" key (numeric keypad) will move the 
marker one step forward. A long press will cause the marker to 
move forward until you release the key. 

- A short press on the "-" key (numeric keypad) will move the 
marker one step backward. A long press will cause the marker to 
move backward until you release the key. 

 
The specific moment in the prediction can also be changed on the At Time or 
Polar views using the 2nd or 3rd method described above.  
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Changing the prediction options 

�� Deselecting satellites 

- Click on  or, on the menu bar, select Options>Svs... A dialog 
box opens allowing you to modify the set of satellites involved 
in the prediction. 

 The first time you display this box for any given prediction, all 
visible satellites have been selected to be used in the prediction. 
Satellite numbers (PRN) shown in black letters stand for the 
visible satellites whereas those in white stand for the non-visible 
ones. All buttons are in the “OFF” position (i.e. released). The 
changes you can make are the following: 

- Deselecting a satellite : depress the corresponding button 
- Deselecting all satellites : click on the All button 
- Re-selecting a satellite (that you have previously dese-

lected) : click on the corresponding button (which then 
comes back to the “OFF” position) 

- Re-selecting the complete set of visible satellites : click on 
the None button. 

 
Example of settings on the SVs Deselection box: 

 
In this example, satellites No. 12, 16 and 32 are not visible, satellite No. 22 is visi-
ble but deselected, satellite No. 32 is not visible and furthermore is deselected. All 
other satellites are visible and used. 
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�� Changing the minimum elevation 

- Click on  or, on the menu bar, select Options>Elev Min... A dia-
log box opens allowing you to change the value of the minimum 
elevation angle under which any satellite should be seen from 
the observation point for it to be used in the prediction. 

 

Minimum Elevation dialog box: 

 
 

�� Applying / removing the curtain  

- Click on  or, on the menu bar, select Options>Use curtain. A 
dialog box opens in which you can apply (button depressed) or 
remove (button released) the curtain defined on the observation 
point. 

 The curtain, which is part of the observation point definition (see 
page 143), describes an angular area seen from the point. All 
GPS signals received from that area will NOT be used. 
The presence of the curtain (size and shape shown on the Polar 
view, impacts most of the other views in the prediction. 
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World Map editor 

The World Map editor shows the planet Earth. From this view, you can se-
lect any point on the surface of the Earth where you would like to run a 
prediction. The World Map editor is equipped with a number of functions 
allowing you to access this point. 

 
Example of a view obtained with the World Map editor: 

 
 

 

�� Rotating the Earth  
If the visible part of the World Map editor does not show the desired ob-
servation point, do the following: 

- Position the mouse cursor anywhere on the globe 
- Right-click on the mouse and select Grabber. The mouse 

pointer now looks like this: 
- Hold down the mouse left button and drag in the direction that 

would bring the desired point on the visible part of the globe. 
When you release the mouse button, this will cause the globe to 
rotate around its axis by an angle proportional to the distance tra-
veled by the mouse pointer while dragging. 
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�� Zooming in 
- Position the mouse pointer anywhere on the globe 
- Right-click on the mouse and choose Zoom in. The 

mouse pointer now looks like this:  
- Position the mouse pointer on the globe where you would like to 

zoom in, and then click on the left button. This causes the region 
to be magnified. The center point of the magnified view is in fact 
the point where you have just clicked 

 You can repeat this operation several times (as long as the 
mouse pointer is a “+” magnifying glass). From the initial view 
showing all the globe, up to 6 successive zoom-in operations can 
be performed. 

 
�� Zooming out 

- Position the mouse pointer anywhere on the globe 
- Right-click on the mouse and choose Zoom out. The mouse 

pointer now looks like this:  
- Position the mouse pointer on the globe where you would like to 

zoom out, and then click on the left button. This causes the re-
gion to be reduced in size. The center point of the reduced view 
is in fact the point where you have just clicked 

 You can repeat this operation several times until the entire globe 
can be seen on the screen. 

 
�� Selecting a point 

Once the globe is large enough making possible a good visual estimate of 
the desired observation point on the globe’s surface, do the following: 

- Position the mouse pointer anywhere on the globe 
- Right-click on the mouse and choose Draw. The mouse 

pointer now looks like this: 
- Position the mouse pointer very accurately on the desired point, 

then click on the left mouse button to define this point. 
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 The Lat & Long fields in the dialog box are then updated to 
reflect the exact coordinates of the point you have just se-
lected. Note that the Alt field is left unchanged. This 
parameter should be defined manually by typing its value 
directly in the field.  

 On the globe, the selected point is shown as a red dot 
whose size is independent of the zoom setting. 

 
�� Globe Viewing Options 

- Position the mouse pointer anywhere on the globe 
- Right-click on the mouse and choose Options. A dialog box 

opens in which you can change the globe viewing options. The 
defaults for these options are the following: 

  
The available 4 resolutions are: 

- low 
- medium 
- high 
- very high 

The higher the resolution, the more accurate the details on the globe sur-
face. 
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Curtain editor  

�� What is a curtain? 
Seen from the observation point, some directions in space may exist in 
which GPS reception for some reason is bad. The concept of curtain is in-
troduced specifically to describe these particular directions so that the 
signals received from this region of space can be curtained if necessary. 
For a given observation point, the curtain consists of one or more obstruc-
tion zones seen from this point. Each obstruction zone is defined in relation 
to Azimuth (Az) and Elevation (Ev). 
A curtain may be drawn on a polar view centered on the observation point, 
or on linear view showing elevation vs. azimuth. Once the curtain is drawn 
on a view, it is also visible on the other. 
A curtain may also be defined by specifying each of the points making it 
up. As a result, the curtain also appears on the two views as if it had been 
drawn. 
On the chart, the area located between Elevation Angle 0° and the user-set 
Min Ev angle (see bottom of the tab) is considered as part of the curtain 
(also shown in blue). 
When you enable the curtain in a prediction computation, you allow the 
application to behave as if there were no GPS signals received in the cur-
tain's direction. 
 

�� Accessing the curtain editor for a given observation 
point 

- Click on , or in the menu bar, select Edit>Site 

- Define the observation point, or load it if it has already been de-
fined and saved 

- Click on the Local Obstructions... button. 
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�� Changing the curtain view  
- Position the mouse pointer anywhere on the curtain editor 
- Right-click on the mouse and select the linear or polar view. 
 

�� Drawing a curtain 
- Position the mouse pointer anywhere on the chart and click with 

the right mouse button. 
- In the shortcut menu that pops up, select the Draw command. 

The mouse pointer then changes to   
- Position the mouse pointer on the desired location, referring to 

the Az and Ev indications, and click with the mouse to begin 
drawing the curtain. 

- Move the mouse pointer to reach the next point. Note the curve 
that results from the pointer displacement (a straight line on the 
Linear view, an arc on the Polar view). Once you have reached the 
next point, click with the mouse again, etc. 

- If you need to go through the 0/360° or 360/0° limits while you 
draw an obstruction zone, move the pointer outside the chart. 
This causes the horizontal scale to move accordingly so long as 
you keep the pointer outside the chart. 

- To complete the curtain definition, double-click on the last point. 
As a result, the curtain appears in blue as a close shape, even if 
the last point is not superimposed on the first one. On the Linear 
view, the curtain is always a polygon, on the Polar view it is a 
close shape composed of several arcs. 

- After completing the definition of the obstruction zone and if 
you want to restore a 0/360° normal non-shifted scale (if appro-
priate), choose the Select command from the pop-up menu and 
then simply double-click inside the chart area with the left-hand 
mouse button. 
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�� Editing a curtain manually 
After accessing the curtain editor chart: 

- Position the mouse pointer anywhere on the graph and click with 
the right mouse button. 

- In the shortcut menu that pops up, select the Edit Curtain com-
mand. 

- In the dialog box that appears, specify the points delimiting the 
obstruction zone(s). 

 

  
 

Curtain pane 
 List box : Shows the number of obstruction zones defined to form the 

curtain for the concerned site. Obstruction zones are num-
bered from 1 to n. The definition of the selected obstruction 
is shown in the right-hand part of the box 

 Add button : Press this button to add a new obstruction zone in the 
above list box  

 Delete button : Press this button to delete the obstruction zone selected in 
the above list box 
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Point �x/x� pane 
 Azimuth : Azimuth angle for the displayed point 
 Elevation : Elevation angle for the displayed point 
 Right from previous point : Check this button if you want the position you are 

defining to be somewhere on the right of the previous 
point (this choice will force the extension of the ob-
struction zone to the right of the previous point even if 
the azimuth angle of the new point is less than that of 
the previous one; this allows you to go through the 
360/0° singular value). 

 Align with previous point : Check this button if you want the position you are 
defining to be aligned with the previous point (i.e. same 
azimuth) 

 Left from previous point : Check this button if you want the position you are 
defining to be somewhere on the left of the previous 
point (this choice will force the extension of the ob-
struction zone to the left of the previous point even if 
the azimuth angle of the new point is greater than that 
of the previous one; this allows you to go through the 
0/360° singular value) 

 Add button : Click this button to add a point to the definition of the 
obstruction zone. As a result, the total number of 
points (see top of dialog box) is incremented by one  

 Insert button : Click this button to add a point to the definition of the 
obstruction zone. The new point is inserted into the 
list of points just before the displayed point. As a re-
sult, the total number of points (see top of dialog box) 
is incremented by one 

 Delete button : Click this button to delete the point displayed above 
 OK button : Click this button to validate the entire box content 
 Cancel button : Click this button to cancel all the changes you have 

made to the box since you opened it. 
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�� Moving, re-shaping or deleting a curtain 
- Position the mouse pointer anywhere on the graph and click with 

the right mouse button.  
- In the shortcut menu that pops up, choose the Select command. 
- Select the curtain by clicking the mouse pointer inside the draw-

ing object (a selected curtain displays handles) then: 
. drag this object to move the curtain 
. or drag each of its handles successively to re-shape it 
. or press the Del key to delete it. � 
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9. WinComm Utility 

Introduction 

WinComm allows you to communicate with GPS receivers by offering the 
following functions: 

- Automatic search for baud rate to be used (on operator's request, 
only with Thales Navigation receivers) 

- Identification of the connected GPS receiver (on operator's re-
quest, only with Thales Navigation receivers) 

- Viewing the data stream on the serial port 
- Sending commands to the GPS receiver 
- Manual request for recording data from the GPS receiver 
- Programmable requests for recording data from the GPS re-

ceiver. 
 

WinComm main window: 

 



WinComm Utility 
Enabling communications with a GPS receiver 

168  

9 

Enabling communications with a GPS receiver  

After you start WinComm or click the Settings button in the WinComm main 
window, the Communication Settings dialog box shows up that allows you to 
view and change the serial port parameters of your computer and enable 
communications with the GPS receiver connected to it. 

 
Communication Settings Dialog Box: 

  
You can save your customary communications settings to a configuration 
file (using the Save Settings button) and specify the configuration file name 
in the command line of any shortcut created to start WinComm. As a result 
the configuration file will automatically be loaded and enabled when you 
double-click the WinComm icon to start WinComm (in that case the Communi-
cation Settings dialog box will not be prompted). 
Use the combo boxes to set the communication parameters. The parameters 
are preset to default values. Select the desired port (Comm parameter), that 
is the computer port connected to the desired GPS receiver and the appro-
priate serial communication parameters (baud rate, etc.) to match those of 
the receiver. 
With Thales Navigation receivers, the baud rate will be adjusted automati-
cally if you use the Auto Configure button. 

 
�� OK button 

Clicking the OK button activates the current serial port parameter settings 
and closes the Communication Settings dialog box. This enables communica-
tions between the computer and the GPS receiver, unless the serial port 
parameter settings do not match those of the receiver connected. 
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�� Cancel button 
Clicking the Cancel button closes the Communication Settings dialog box. Any 
changes you made in this dialog box are ignored. 
 

�� Auto Configure button 
Auto Configure initiates an automatic search for the baud rate and receiver 
type. Use this button if you are not sure about the baud rate or if you wish 
to view the type of the receiver connected. 
An automatic search for the baud rate and receiver type is only allowed 
with Thales Navigation receivers as this requires that the receiver be capa-
ble of returning a consistent reply to a "TEST 1" or "IDENT" command. 
After choosing Auto Configure you are allowed to: 

- disable the communication by clicking Cancel 
- or, if the identification is successful, close the Communication Set-

ting dialog box, by clicking OK. This enables communications 
between the computer and the GPS receiver and allows you to 
use any of the WinComm functions. 

 
�� Receiver Type  

After communication is successfully established (e. g. using the Auto Con-
figure button), the identification of the connected receiver appears in this 
box. 
The example below results from a communication established with a 
Thales Navigation receiver. 
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After the Communication Settings dialog box is closed, you can ask for the re-
ceiver type by sending the TEST 1 or IDENT command to the connected 
receiver, using the Command pane. 

�� Load settings button 
Load settings opens a dialog box that allows you to select any serial port 
configuration file saved earlier using the Save Settings button. 
Click the desired file name in the list box, to select it (typically in the 'set' 
directory), and click Open. As a result the serial port parameters in the 
Communication Settings dialog box are automatically set as specified in the 
file you selected. 
(Clicking Cancel would take you back to the Communication Settings dialog 
box). 
 

�� Save settings button 
Save settings opens a dialog box that allows you to save the serial port con-
figuration currently enabled so that you can quickly retrieve it at a later 
date using the Load Settings button. It can be loaded automatically if you 
specify its name in the command line of any shortcut icon created to start 
Wincomm. 
In the File Name text box, enter a name (e.g. the type of the receiver con-
nected) for the file to which the serial port configuration should be saved 
(typically with '.set' as extension). Typically, serial port configuration pa-
rameters are saved to the 'set' directory. 
Clicking the Save button saves the following communication parameters:  

- serial port No. 
- baud rate 
- number of bits per character 
- parity check option 
- number of stop bits 

(Clicking Cancel would take you back to the Communication Settings dialog 
box without saving any settings). 
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System Menu  

- In the left corner of the WinComm window's title bar, click on the 
connector icon. The system menu appears from which you can 
define the options below. 

  
 

 All Commands Uppercase : Unless you are satisfied with the current setting, 
select this command to toggle the setting. 

   Checked: lower-case characters in the command are 
changed to upper-case characters before being sent 
to the receiver 

   Cleared: characters, whether lower-case or upper-
case, are sent unchanged. 

 

 No Internal Memory : Command not used with the new range of receivers. 
Unless you are satisfied with the current setting, se-
lect this command to toggle the setting. 

   Checked: there is no internal memory in the at-
tached receiver (Internal Memory Reader option 
disappears from the Win Comm window). Always 
make this choice with the current range of receivers. 

   Cleared: there is an internal memory in the attached 
receiver (Internal Memory Reader option available in 
the Win Comm window). 
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Display area 

After communication is enabled between the computer and a GPS receiver 
the Display pane allows you to view the data stream on the receiver port, in-
cluding data output in response to any command generated by Wincomm. 
If you wish to enlarge the Display pane, click  in this pane (top right). 
This causes the pane to be transformed into a separate window which you 
can move/re-size using the usual commands assigned to windows in the 
Windows environment. 
To restore the Display pane at the initial location, click  or  (top right). 

 
Display area defined as a separate window: 

 
 
As the data may be refreshed every 0.1 seconds, it is not possible to log all 
that flows through the port so that it can be displayed at a later date, or this 
would require a huge memory size. For that reason, only the latest 100 data 
lines are stored and can be viewed using the vertical scroll bar available. 
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Each data line ends with <CR><LF> characters and/or when it reaches the 
maximum length (80 characters). 

 
 Clear View : Clicking this button deletes any data displayed in the Dis-

play pane / window. 

 Print View : Clicking this button opens a Print dialog box that allows 
you to print any data displayed in the Display pane/window. 

 Pause : Freezes the Display pane/window and changes the label of 
the button to Resume. 

   Pressing the Pause button does not suspend the data flow on 
the receiver port or the recording in progress. 

   Pressing this button again (now changed to a Resume but-
ton) will re-activate the Display pane/window. 

 

Sending a Command to the GPS receiver  

After communication is established between the computer and the GPS re-
ceiver, the Command pane can be used to send commands to the receiver 
(label of selected command group recalled in the command pane, see ex-
ample below). 
 

 
To send a command, do the following: 

- Type the command in the Command combo box or select it from 
the Command or Label combo box. 

- Click the Send button. 
The list of commands prompted in the Label combo box can be changed us-
ing the Advanced... button. 

Command box 

 Label box 
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�� Commands editor dialog box 
This dialog box (appearing after you click the Advanced button) allows you 
to set up a group of commands interpretable by the connected receiver. The 
commands you select in this dialog box will be prompted in the main win-
dow. As a result, you will only need to choose the desired command from 
the list in the main window and click to send the command to the receiver. 
After you install WinComm, a number of default command groups are avail-
able on your computer. Each command group is contained in a file whose 
name is the Group Label (see this parameter in the next page), with .cmd as 
extension. 
The buttons in the Commands Editor dialog box allow you to load any com-
mand-group file available, make any change to the group and save your 
own command groups. 
The selected command group will be available in the main window after 
you close the Commands Editor dialog box (by clicking in the upper-right 
corner). 

 
 Group Label : Used to enter and/or view the name given to a com-

mand group. For example, this name can suggest the 
type of receiver connected when this command group 
should be used 

 Command : Used to enter and/or view each command script. Use 
the associated scrollbar to browse through the list of 
available commands 

Click here to close the Com-
mands Editor dialog box. This 
loads the selected command 
group to the main window. 
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 Label : Used to enter and/or view a plain label for each com-
mand script. Use the associated scrollbar to browse 
through the list of available commands 

 Add command : Adds the command viewed in the text box to the list of 
available commands. 

 Delete command : Removes the command viewed in the text box from the 
list of available commands. 

 Load commands : Opens a dialog box that allows you to choose the ap-
propriate command group file for the connected 
receiver so that the command group becomes available 
in the main window after you close the Commands Editor 
dialog box. 

 Save commands : Opens a dialog box that allows you to save your own 
command group (as viewed in the Commands Editor dia-
log box). 
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Simple GPS recorder 

All data output from the receiver's port is viewed in the main window's Dis-
play pane/window. The data can be recorded to the file specified in the File 
Name and Directory text boxes. 
When the Simple GPS Recorder option is activated, you start and stop the re-
cording manually, by simply clicking the Start/Stop Recording button. 

  
 
 File Name : Used to specify the name of the file to which you wish to 

record the data from the receiver. 
   Unless a maximum size is selected for the file, you are 

also allowed to enter an extension into the associated box. 
 File Max Size : Used to specify whether a single file should be created on 

the disk (No Limits option) or the file should be split into 
0.7 MB or 1.4 MB segments (with a view to storing it on 
floppy disks for example). 

   If you elect to split the file into segments, then the system 
will automatically add “001” as extension to the name of 
the first segment. This will automatically be incremented 
for each file segment generated, if the file exceeds the se-
lected File Max Size. 
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 Start Recording : Clicking this button opens a new dialog box in which you 
can specify which type of raw data you would like to re-
cord, if any, before you effectively enable data recording. 

 

 

 

 

    
 

 

 

   Then click on the OK button to start the data recording. 

   The data recording will take place until you click on the 
Stop Recording button (this button is in fact the Start Re-
cording button which is renamed once data recording is in 
progress). 

Choose the type of raw data that you would like to insert into the record file(s). Choose also 
the format for the selected data as well as the port on which the data will be available. 

 
The resulting command ($PDAS or other) 

is automatically formatted in this area according to your choices 

If necessary, edit other commands that you would like the recorder to run after the above one. This requires 
good knowledge of the different commands possible as well as their syntax. You can save your lists of com-

mands as a BAT file (using the Save button) and load them quickly later on, using the Load button. 
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Programmable GPS recorder 

The Programmable GPS Recorder option allows you to prepare one or more 
requests for recording the data output on the connected receiver port, by 
specifying a start date, time and duration for each planned recording ses-
sion, and also a disk file name, directory and maximum size. 
You can save the recording session requests you prepare (using the Save 
button) so that you can load them back at a later date (using the Load but-
ton). 
 

 
 

 Directory : Used to specify the directory to which you wish to re-
cord the data from the receiver. Clicking the button to 
the right opens a dialog box that allows you to navigate 
through the directory tree on your hard disk or a floppy 
disk, and select the desired destination directory. 
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 File Name : Used to specify the name of the file to which you wish 
to record the data from the receiver. 

  - If you choose the Automatic File Name option (i. e. if 
the option box is checked), then the File Name text 
box is dimmed and the name is automatically as-
signed by the system, based on the date (month, day 
number) and time (hour, minute) of the recording 
session. Example: 12240929 for a file recorded on 
December 24 at 9:29 a.m 

  - If you do not select the Automatic File Name option, 
then you can enter a name of your own. Unless a 
maximum size is selected for the file, you are also 
allowed to enter an extension into the associated 
box. 

 File Max Size : Used to specify whether a single file should be created 
on the disk (No Limits option) or the file should be split 
into 0.7 MB or 1.4 MB segments (with a view to storing 
it on floppy disks) 

   If you elect to split the file into segments, then the sys-
tem will automatically add “001” as extension to the 
name of the first segment. This will automatically be 
incremented for each file segment generated, if the file 
exceeds the File Max Size selected 

 Start Date : Used to specify the day on which the recording session 
should begin. The current date is prompted by default  

 Start Time : Used to specify the time when the recording session 
should begin. The current time is prompted by default 

 Duration : Used to specify the planned duration of the recording 
session 
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 Automatic File Name : If you choose the Automatic File Name option (i. e. if the 
option box is checked), then the File Name text box is 
dimmed and the name is automatically assigned by the 
system, based on the date (month, day number) and 
time (hour, minute) of the recording session. Example: 
12240929 for a file recorded on December 24 at 9:29 
a.m 

   If you do not select the Automatic File Name option, then 
you can enter a name of your own. Unless a maximum 
size is selected for the file, you are also allowed to enter 
an extension. 

 Add Request : This button saves the recording session description cur-
rently displayed and increments the number of 
programmed sessions that appears at the bottom of the 
scrollbar. (This automatically selects the Automatic File 
Name option and prompts the next possible session, con-
sidering the specified duration). 

 Delete Request : This button deletes the recording session description 
currently displayed and decrements the number of pro-
grammed sessions that appears at the bottom of the 
scrollbar. 
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 Run Program : This button activates the Programmable GPS Recorder 
mode. First, a new dialog box appears in which you can 
specify which type of raw data you would like to re-
cord, if any, before you effectively enable data 
recording. 

 
 

 

 

    
 

 

Choose the type of raw data that you would like to insert into the record file(s). Choose also 
the format for the selected data as well as the port on which the data will be available. 

 
The resulting command ($PDAS or other) 

is automatically formatted in this area according to your choices 

If necessary, edit other commands that you would like the recorder to run after the above one. This requires 
good knowledge of the different commands possible as well as their syntax. You can save your lists of com-

mands as a BAT file (using the Save button) and load them quickly later on, using the Load button. 
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   Then click on the OK button. This causes WinComm to 
wait for the next scheduled recording session and per-
form recording as planned. The label of the button 
changes from Run Program to Stop Program. Until the 
planned recording is complete or you click Stop Program, 
all other buttons in the Programmable GPS Recorder pane 
are inhibited and you cannot change to another Mode. 

 Load Program : This button opens a dialog box that allows you to select 
a file (typically a .pgm file) containing descriptions of 
planned recording sessions (saved earlier using the Save 
Program button). Select the desired file name and click 
Open. 

 Save Program : This button opens a dialog box that allows you to save 
descriptions of planned recording sessions so that they 
can be used at a later date (using the Load Program but-
ton). Enter a name into the File Name text box and click 
Save. 

 Print Program : This button opens a Print dialog box that allows you to 
print the descriptions of planned recording sessions cur-
rently loaded. 
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WinComm shortcut 

You can save your customary communications settings to a configuration 
file and specify the configuration file name in the command line of any 
shortcut created to start WinComm. As a result the configuration file will au-
tomatically be loaded and enabled when you double-click the WinComm 
icon to start WinComm (in that case the Communication Settings dialog box 
will not be prompted). 
To create a WinComm shortcut icon that will automatically load one of your 
customary communications configuration files, do the following: 

- With the mouse right button, click outside any window in the 
workspace. From the menu that pops up, select New then Shortcut. 
This opens the Create Shortcut dialog box. 

- Click the Browse button. This opens a dialog box that prompts all 
the directories existing on your disk. Open (by double-clicking) 
the directory containing WinComm. 

- Click WinComm.exe and click the Open button (or simply double-
click WinComm.exe). This closes the Browse dialog box and auto-
matically enters WinComm.exe (with its path) into the Command 
line text box in the Create Shortcut dialog box. 

- In the Command line text box, enter the name of your configura-
tion file after WinComm.exe, with a space in between. 

- Click the Next button. Enter a name for your shortcut icon. Click 
the Finish button. This closes the Create Shortcut dialog box. 

 
As a result, a new WinComm icon appears in the workspace, with the name 
you specified. � 
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10. Geoids Utility 

Introduction 

Geoids allows the following: 
- Importing new geoid models 
- Extracting data from a geoid model in order to create a smaller 

file just describing the specified region 
- Loading a geoid model, either partially or completely, into a 

Thales Navigation receiver 
- Reading the geoid model currently used in a receiver. 

The following formats exist in Geoids: 
- EGM96 (worldwide model) 
- RAF98 (for France only) 
- GSD95 (Region of the Saint Laurent in Canada) 
- NAP (Normaal Amsterdams Peil) 
- North Sea (Land Sea) 

 
Opening a geoid model 

- Select File>Open. A dialog box opens in which you can choose a 
geoid model among those available 

- Choose a model and then click OK. A new window appears sho-
wing the main characteristics of the chosen geoid (name, date of 
creation, file size, comment, geographical limits, grid step and 
number of points). 
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Example of geoid model open in Geoids (EGM96) : 

 
 

Extract a region from the geoid model 

1. Select File>Open and choose the geoid model from the displayed 
list. Geoids will extract the data for your region from this model. 
Then click OK. The selected model appears in Geoids 

2. Select File>Extract As…. A new dialog box is displayed in which 
you can define the geographical area you are interested in. 

  
Definition box for data extraction from a geoid model: 

  
3. Define the following parameters: 
� File name (8 characters max.) 
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� Comment (25 characters max.). It will appear in the 3rd line 
when you open the geoid model 

� Geographical limits of the considered region, necessarily a rec-
tangular area defined by a North-West point (NW) and a South-
East point (SE). 

 

  
 Define the NW & SE points manually, by entering their latitudes 

& longitudes in the corresponding fields, or graphically using 
the World Map editor. 

 To use the World Map editor, click on the World Map button and 
follow the instructions provided on page 158, except for the Draw 
function which in the present case must be used to surround the 
desired region. 

4. Click on the Extract button to extract the data from the geoid 
model for the concerned region. The resulting file is automati-
cally opened in the Geoids window once it has been created. 

 
Example of data extraction using the World Map editor: 

� �  
  
 Fields automatically 

filled after making a 
selection on the World 

Map editor 

Geographical 
area covered 

by initial 
model 

Resulting geoid model 
for the selected region

Selected 
region 
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Uploading a geoid model into a receiver 

- Connect an adequate RS232 cable between one of the serial 
ports on the PC running Geoids and one of the ports on the 
Thales Navigation receiver 

- Open the desired geoid model in Geoids 
- Select Transfer>Write. A dialog box appears asking you to specify 

and configure the serial port used on the PC. 
 

  
 
- After setting a port, click OK to upload the geoid file. 
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Importing a new geoid model 

This function allows you to update any geoid model whose data format is 
known. Geoids will convert any type of file you import into a binary file 
with GEO extension. 

- Select File>Import. A dialog bow opens allowing you to specify 
the location of the original file containing the new geoid, its 
format, the name of the GEO file that will result from the import 
operation, and a comment associated with the imported geoid 
model  

- Click on the Import button to import the selected geoid model. 
 

Example of Import dialog box: 
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Displaying the versions of the available geoid 
formats 

- Select Help>About Geoids... A dialog box opens listing the versions 
of the DLL files corresponding to the available geoid models. 

 
 

Dialog box showing the available geoid models: 

  
 
 

Deleting a geoid model 

- Select File>Open. A dialog box opens allowing you to specify 
which geoid model should be deleted (a complete or partial one) 

- Click Delete. The geoid file is deleted after user confirmation. 
 � 
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11. DTR Utility 

Introduction 

DTR is used to convert Thales-formatted raw data files into Observation + 
Navigation files in RINEX format. 

�� Input files 
Input files should be Thales raw data files containing binary or ASCII data. 

�� Time labeling  
Format conversion involves changing the time-labeling of the raw data. 
This operation is required as the Thales format is based on satellite time 
whereas the RINEX format uses receiver time. 
Time-labeling is changed through extrapolation. 

�� Naming the output files  
The output files can be named freely, or using the conventions defined in 
the RINEX format, namely:  

<site_name><log_day><file_index>.<log_year><type_code> 
where: 

 <site_name> the first 4 characters from the name of the site where 
raw data was logged 

 <log_day> log day in 3 figures (1 to 365) 

 <file_index> a figure from 0 to 9 allowing you to create up to 10 
different files for the same log date and the same 
site 

 <log_year> log year in 2 figures (example: 2001� 01 ; 1998� 
98) 

 <type_code> letter « 0 » for Observation file, or « N » for Navi-
gation file. 
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Using DTR 

�� Description of the main window 
 
 
 

 
 
 
 

 

 These 3 fields are preset 
automatically upon selection 

of the file to be converted 

Enter the path & name of the file to 
be converted in this field. 
Use the button to the right 

of this field to find the file on the 
computer disk 

Optional parameters 
which are normally 

present in the header 
of a RINEX file. As 

they are not present 
in the THALES 

format, if you define 
them now in these 
fields, they will be 
inserted into the 
RINEX file when 

converting the file. 
When you are ready, 

click on the Run... 
button to convert the 

input file 

 For data time-labeling (see next page)

 Check this button to name output files according to RINEX conventions. Then 
choose manually the file index (from 0 to 9) in the combo box which then appears 

on the right 
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�� Advanced options 

This window is displayed after clicking on the Advanced button in the main 
window. It is used to define precisely in which way time-labeling is chan-
ged from satellite to receiver time. 
 

 
 
For a standard conversion, use instantaneous dopplers and Tx=0. 
To optimize further processing of files in RINEX format originating exclu-
sively from THALES log files, use Tx=75 ms preferably. In addition, to 
optimize static processing, choose filtered dopplers preferably. 
NOTE : 75 ms stands for the average propagation time of GPS signals be-
tween any satellite and any receiver on Earth. It is therefore the best value a 
priori to use in the conversion. � 
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12. Appendices 

Database in a Land Survey Project 

�� Areas collection 
Each object in the collection has the following attributes: 

 
+ a geometric attribute comprising: 

- Geometry type: area 
- Dimension: 3-dimensional 
- Spatial Reference System in which the coordinates are expressed 
 

�� Lines collection 
Each object in the collection has the following attributes: 

 
+ a geometric attribute comprising: 

- Geometry type: line 
- Dimension: 3-dimensional 
- Spatial Reference System in which the coordinates are expressed 



Appendices 
Database in a Land Survey Project 

196  

12
�� Points collection 

Each object in the collection has the following attributes: 

 
+ a geometric attribute comprising: 

- Geometry type: point 
- Dimension: 3-dimensional 
- Spatial Reference System in which the coordinates are expressed 
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�� Files collection 
Each object in the collection has the following attributes: 

 
+ a geometric attribute comprising: 

- Geometry type: point 
- Dimension: 3-dimensional 
- Spatial Reference System 
 

�� Processes collection 
Each object in the collection has the following attributes: 

 
+ a geometric attribute comprising: 

- Geometry type: line 
- Dimension: 3-dimensional 
- Spatial Reference System 
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�� Stops collection 

Each object in the collection has the following attributes: 
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�� Vectors collection 
Each object in the collection has the following attributes: 
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+ a geometric attribute comprising: 

- Geometry type: line 
- Dimension: 3-dimensional 
- Spatial Reference System in which all coordinates are expressed. 
 

 
�� Broadcast_Ephemeris collection 

Each object in the collection has the following attributes: 
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�� Broadcast_Iono collection 
Each object in the collection has the following attributes: 

 
 

�� GPS_Measurements collection 
Each object in the collection has the following attributes: 
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Created Files & Directories 

�� Creating a New Project in a New Workspace 
The project and the workspace then have the same name. 
A new folder, named <project_name>, as well as two files are created in 
the MyProjects folder. A number of files are created in the new folder. 
These files are in fact the default documents listed on the Documents tab of 
the Workspace pane. Below is a project structure example, as seen from 
Windows Explorer: 

 
Where: 

- *.map: map documents 
- *.tbl: table documents 
- *.gph: graph documents 
- *.TPP: Project database 
- *>.rtf: RTF file containing the text displayed in the Output pane 

for the project (messages, processing reports, etc.) 
- *.wsp: file containing the current settings of 4SPack main win-

dow for this workspace. � 
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 Glossary 

 
 Blunder: Error made by the field operator during the 

survey causing glaring errors in survey results. 
Not to be confused with uncertainties in sys-
tem measurements  

 Connectivity: A test performed during a network adjustment 
to see if all the points in the active project are 
linked together by measurements. If that is the 
case, the project passes the connectivity test. 
Otherwise the test fails, which means that the 
project contains two or more independent point 
networks instead of a single one  

 Datum: An ellipsoid that is offset with respect to a ref-
erence ellipsoid (usually the WGS84). A 
datum is therefore fully defined by providing 
the following parameters: an ellipsoid defini-
tion, datum shifts (i.e. angular & linear 
components of the spatial deviation between 
the center of the ellipsoid and that of the refer-
ence ellipsoid) and a scale factor 

 Ellipsoid: A mathematical representation of the Earth as 
an ellipse that is rotated about its minor axis. 
An ellipsoid is fully defined by providing the 
following two parameters: semi-major axis and 
inverse of flattening  

 Geographic System: A coordinate system based on the definition of 
a datum 

 Intermediate Point: Any point in a trajectory 
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 Logged Reference: A reference (or control) point, other than the 
planned ones, surveyed by a field operator 

 Logged Point: A point, other than the planned ones, surveyed 
by the field operator  

 Planned Reference: A reference (or control) point with already 
surveyed coordinates. Creating such a point in 
a project means that you wish the field opera-
tor to re-survey that point for cross-checking 
purposes 

 Planned Target: A point whose coordinates are provided by the 
project. This point is not materialized in the 
field. Creating such a point in a project means 
that you wish the field operator to get to this 
point, guided by her/his equipment, to place a 
stake on that point. In the same time, the field 
operator will be prompted to log the position 
solution computed by the equipment on that 
point. 

 Staked-Out Target: A target point, which the operator visited, 
guided by his/her equipment, to place a stake 
and to record the position computed in real-
time by this equipment. 

 Station: The position of a point from which corrections 
data is transmitted to be used by operators 
working in the field. 


	Introduction to 4SPack
	Presentation
	Utility Programs Provided

	Installation
	Minimum System Requirements
	Installing 4SPack

	Overview
	Starting / quitting 4SPack
	Unlocking a Software Option
	Description of the Main Window
	Viewing surveys on maps
	Default Documents Created in a Project
	Introducing project databases
	Editing the content of a collection
	Representing database objects on a map
	Creating survey reports
	Coordinate systems used in a project


	Tutorials
	Post-Processing a Baseline between two Unknown Points
	First Step: Creating a New Project
	Second Step: Importing Raw Data into the Project
	Third step: Analyzing the Content of the Project after Importing the Data Files
	Fourth Step: Refining the Location of the “From” 
	Fifth Step: Processing the Baseline
	Sixth Step: Exporting the Processed Vector to a File

	Post-Processing a Point Network including two Known Points
	First Step: Creating a New Project
	Second Step: Importing Raw Data into the Project
	Third Step: Editing the Control Points
	Fourth Step: Processing all the Baselines
	Fifth Step: Performing Network Adjustment
	Sixth Step: Viewing the Results in a Specific Spatial Reference System

	“Stop & Go” Project
	First Step: Creating a New Project
	Second Step: Importing Raw Data into the Project
	Third Step: Analyzing the Content of the Project after Importing the Data Files
	Fourth Step: Editing the Station Coordinates
	Fifth Step: Running the Stop & Go Processing
	Sixth Step: Analyzing the Results of the Stop & Go Processing

	Real-Time Project: Staking Out Target Points
	First Step: Creating a New Project
	Second Step: Importing the Target Points from a File
	Third Step: Uploading the Survey Job to the PC Card
	Fourth Step: Field Survey
	Fifth Step: Downloading the Field Results
	Sixth Step: Comparing the Field Results with the Initial Target Points in the Job

	Real-Time Project: Determining a Local Grid
	First Step: Creating a New Project
	Second Step: Downloading the Real-Time Results containing the Surveyed Points
	Third Step: Computing the Horizontal Grid
	Fourth Step: Displaying the Characteristics of the New Spatial Reference System
	Fifth Step: Generating a Report
	Sixth Step: Editing and Saving the Report

	Introducing Background Map Projects
	First Step: Creating a New Project
	Second Step: Analyzing the Content of the Project
	Third Step: Creating a Map document in the Project
	Fourth Step: Working on the Map
	Fifth Step: Creating a Table Document in the Project
	Sixth Step: Sorting / Filtering Data

	Creating a New Coordinate System
	First Step: Creating the Geographic System
	Second Step: Creating a Projected System


	4SPack Functions
	File Menu
	Edit Menu
	View Menu
	Table Menu
	Report Menu
	Graph Menu
	Map Menu
	Project Menu
	Tools Menu
	Window Menu
	? Menu
	Working in a Map Document
	Adding an object to a collection from the map
	Showing/hiding a collection on the map
	Adding a new layer on the map
	Deleting an object in a collection from a map document
	“Change Into” Function

	Working in a Table Document
	Creating a Table Document
	Adding an Attribute to a Table Document
	Removing an Attribute from a Table Document
	Setting a Filter on an Attribute

	Working in a graph document
	Creating a graph document
	Defining the X and Y Axes
	Adding a new curve on the same graph
	Zooming in on a Graph

	Coordinate Systems
	Geocodes & Operators
	Editing an Object in a Collection
	Creating Custom Formats

	Post-Processing Survey Principles
	Field Survey Objectives
	Recommended Occupation Times
	Operating Ranges
	4SPack Internal Processing Steps Tied to Raw Data Import
	Baseline Processing
	Static
	Dynamic
	Stop & Go

	Sites computed individually
	Survey Schemes
	Static
	Dynamic
	Stop & Go


	Real-Time Survey Principles
	Survey Scheme

	Post-Processing Algorithms
	Network Adjustment
	Introduction
	Running a Network Adjustment
	Network Connectivity Test
	Variance of Unit Weight/Standard Error of Unit Weight
	Chi-Square Test
	Observation Residuals
	Tau Test


	Pred Utility
	Introduction
	Almanacs used in the prediction
	Opening a set of almanacs
	Importing a new set of SEM-type almanacs
	Viewing the set of almanacs used

	Defining the observation point
	Defining the date & time of prediction
	Defining a moment within the prediction
	Defining the local/ UTC time deviation
	Prediction results
	“At Time” view
	“Schedule” view
	“Range” view
	“Doppler” view
	“ Elevation” view
	“Azimuth” view
	“Polar” view
	“GDOP” view
	Displaying 4 or 2 different views at the same time
	Copying or printing the active view
	Redefining a specific moment in the prediction

	Changing the prediction options
	Deselecting satellites
	Changing the minimum elevation
	Applying / removing the curtain

	World Map editor
	Rotating the Earth
	Zooming in
	Zooming out
	Selecting a point
	Globe Viewing Options

	Curtain editor
	What is a curtain?
	Accessing the curtain editor for a given observation point
	Changing the curtain view
	Drawing a curtain
	Editing a curtain manually
	Moving, re-shaping or deleting a curtain


	WinComm Utility
	Introduction
	Enabling communications with a GPS receiver
	OK button
	Cancel button
	Auto Configure button
	Receiver Type
	Load settings button
	Save settings button

	System Menu
	Display area
	Sending a Command to the GPS receiver
	Commands editor dialog box

	Simple GPS recorder
	Programmable GPS recorder
	WinComm shortcut

	Geoids Utility
	Introduction
	Opening a geoid model
	Extract a region from the geoid model
	Uploading a geoid model into a receiver
	Importing a new geoid model
	Displaying the versions of the available geoid formats
	Deleting a geoid model

	DTR Utility
	Introduction
	Input files
	Time labeling
	Naming the output files

	Using DTR
	Description of the main window
	Advanced options


	Appendices
	Database in a Land Survey Project
	Areas collection
	Lines collection
	Points collection
	Files collection
	Processes collection
	Stops collection
	Vectors collection
	Broadcast_Ephemeris collection
	Broadcast_Iono collection
	GPS_Measurements collection

	Created Files & Directories
	Creating a New Project in a New Workspace





