
 

 

 

 

4.5 Studio 

User’s Manual 
www.badgepass.com 

  

http://www.badgepass.com/


2 | P a g e  

 

Table of Contents 
 

1. Installation 
a. Connected 
b. Disconnected 

2. File Tab 
3. Home Tab 

a. Text Field 
i. Value Modifiers 

1. Insert 
2. Length 
3. Remove 
4. Remove 
5. Replace 
6. Substring 
7. Substring 
8. ToLower 
9. ToUpper 
10. Trim 

ii. Date / Time Format 
iii. Number Format 

b. Image 
c. Variable Image 
d. Line 
e. Rectangle 
f. Barcode 

i. Epic Barcode 
g. Magstripe 

4. Format Tab 
5. Opening and Saving a Design 

a. Connected Mode 
b. Disconnected Mode 

6. Appendices 
a. Appendix A: Exporting Database Fields in Management Console for use in 

BadgePass Studio 

  



3 | P a g e  

 

Installation 
 
BadgePass Studio is where all badge designs are done for the BadgePass Identity 
Manager and Visitor Manager badges.  
 

Run the installer and follow the prompts. BadgePass Studio can be loaded in either 
Connected or Disconnected mode. You will be prompted during the install process to 
choose which way you want to install it. 

 

 
 

Connected 
 
This option installs the BadgePass Studio whereby it is linked to the BadgePass 
database. All the badge designs are automatically saved to the BadgePass suite. 
 

Disconnected 
 
This option installs the BadgePass Studio whereby it will operate independent from the 
BadgePass database. You can design badges and then import them into the 
BadgePass suite via the BadgePass Management Console.  
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File Tab 
 
After you install the BadgePass Studio and run the program you will get the following 
screen: 

 

 
 

Click on the File tab and you will see the following screen: 
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This is where you begin designing your new badge. 
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First you will need to name the badge design, to do so simply type the name you wish to 
use in the Name field. Set your badge Size, Orientation and select the Entity Type. The 
entity type is the entity within BadgePass (ex: Employee, Visitor, Person1, 2, 3). 
 

 
 

Then click the Create button.  
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Home Tab 
 
The Home tab is where you add fields to the badge design. The available fields are: 
Text Field, Image, Variable Image, Line, Rectangle, Barcode and Magstripe. It should 
be noted that the Magstripe field will only be highlighted if you are working on the back 
of a card design. To see the back of the card click on Front in the design area tab. The 
value will change to Back showing that you are working with the backside of the card. 
 

When you create fields on the card you will see a rotation handle on top of the field. 
This is used to rotate the field box. On each corner of the field box there are resize 
handles that can be used to change the size of the box. Also, there is a red number 
below the box - this is the Z order of the box on the template. 
 

 

Text Field 
 
To add a text field to the card design just single click on the Text Field icon. The 
following window will appear: 
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You can use variable text (data from a database field), static data or a combination of 
both types here. To add variable data just double click on the database field in the left 
column.  When you add the field to the Output box the buttons in-between the two 
columns become highlighted. The arrows will add or takeaway fields from the output 
box. The Format button allows you to add formatting elements to the field in the output 
box and the Date button adds the system date to the field when the badge is being 
printed. 
 
To add static values to the field simply type the value in the Output box. 
 



10 | P a g e  

 

 
 

You can also combine static and variable information in the Output box. 
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This would output a value similar to: 
 

This Badge belongs to George Smith. 

 
To add a name field, with the first and last name together, just double click the First 
Name field in the Database Fields column, press the space bar then double click the 
Last Name in the Database Fields column. 
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It will show up on the card template like the image below: 
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To add static text, single click on the text icon and type the text in the Text Field box and 
click the OK button. 
 
Variable Information can be formatted. For example, the employee’s last name might be 
Smith, but can be formatted such that it is printed in all caps and appears on the badge 
like SMITH. To format variable information, select it in the Output box. This will cause 
the Format button to become enabled. 
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Click the Format button and the following window appears. 
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The first thing you see is the variable information the formats will be applied to. 
The area below that (which is empty right now), shows the list of formats that have been 
added. 
The last tabbed area shows the different types of formats that can be added. 
 
Note that more than one format can be applied to any given variable information. This is 
why there is a list of formats that have been added. The formats will be applied in the 
order they are listed using the result of the previously applied format as the input for the 
next format. 
 
Use the Plus and Minus buttons to move the formats up and down. 
 
The various types of formats that can be applied are Value Modifiers, Date / Time 
Formats, and Number Formats. 
 

NOTE: All index values are 0 based meaning they start at 0 not 1. 
 

Value Modifiers 
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Insert 
This modifier will insert a specific value starting at a specific column within a substring. 

Ex: The value of “George” with the following Insert format 

 
Will produce “GeoArga”. 

 

Length 
This modifier will count the number of characters in the string and return the literal 
numeric value. 

Ex: The value of “George” will output the number “6”. 

 
Remove 
This modifier will remove all characters to the right starting at the index (column). 

Ex: With an index value of 3 the output of “George” would be “Geor” 

 
Remove 
This modifier will remove all characters to the right starting at the <Start index> (column) 
up to the number of characters specified in the <count> field. 

Ex: With an index value of 1 and a length of 2 the value “George” would be “Gege”. 

 
 
Replace 
This modifier will replace all occurrences of the <old value> with the <new value>. 

Ex: An <old value> of ‘e’ and a <new value> of ‘A’ and the field value of “George” would 
output “GAorgA” 

 
Substring 
This modifier will left truncate the field starting at the index value. 

Ex: A <Start Index> of 3 and a field value of “George” would output “ge” 

. 
Substring 
This modifier will left truncate the field starting at the index value up to the number of 
characters specified in the <length> field. 

Ex: A <Start Index> of 1 and a <length> of 2 with a field value of “George” would output 
“Grge” 

 
ToLower 
This modifier will convert the entire field to lower case. 
  Ex: A string with a value of “George” would change to “george” 

 
ToUpper 
This modifier will convert the entire field to upper case. 
  Ex: A string with a value of “George” would change to “GEORGE” 

 
Trim 
This modifier will remove all the spaces before the field as well as all trailing spaces. 
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  Ex: A string with a value of  “  George  “ would change to “George” 
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Date / Time Formats 
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The Date / Time Formats convert your date value to the specified format. See the 
examples next to each format for an explanation. 
 

Number Formats 
 

 
 

The Number Formats convert your numeric values to the specified format. 
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Image Field 
 
To add an image field to the badge click on the Image Field icon. The following window 
will appear: 
 
 

 
 
 

The left lists the image types that can be printed on the badge. 
Static Image is an image that does not change no matter who the badge is being printed 
for. 
The other items (such as Photo) are images that are images associated with the entity 
being printed. For images other than static images, what shows up in Studio is the 
woman’s placeholder image. This image will be replace by the entities image of that 
type during print. 
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By selecting Static Image, a Browse button becomes enabled. Click the Browse button 
and navigate to the static image to add to the badge. 
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Variable Image Field 
 
Variable Image allows for a group of images to be included, each with an associated 

value, only one of which will be printed during print depending on which image’s value is 

correct for the given entity being printed.  

On the Home tab, click Variable Image. This will open the Variable Image window. 
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Click on the button to the right of the Trigger Field’s textbox (  ). This will open the 

Trigger Field window showing all the fields available to be used as a Trigger Field. 
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Double click on the field to be used as the Trigger Field. This will close the Trigger Field 

window and return to the Variable Image window with the Trigger Field set and 

indicated in the Trigger Field’s textbox. 

Bellow the Trigger Field is an Add button. This button adds an Image / Trigger Value 

pair. 

There is also a delete button which will delete all the selected Image / Trigger Value 

pairs. 

NOTE: To select an Image / Trigger Value pair, check the corresponding checkbox 

located at the beginning of the respective Image / Trigger Value pair row. 

Add an Image / Trigger Value pair for each Trigger Field supported. 

Each Image / Trigger Value pair has a browse button and a Trigger Value textbox. 

Browse for the image for the Image / Trigger Value pair’s Image. 

Type in the value for the Image / Trigger Value pair’s Trigger Value. 
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Click OK button when done. 

 

Line 
 
To add a line to the badge, click on the Line icon. The line will show up on the card 
template. To change the attributes of the line click on the Format (see an explanation of 
the Format tab) tab with the line highlighted. 
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You can set the Location, Size, Rotation and Z order in the Common area of the ribbon. 
You can set the color in the Line area of the ribbon. Click on the color icon. 
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Click on the Advanced button to manually change the color settings. You can also set 
the transparency of the fill color of the line by changing the Alpha settings.  

 

HSL is where you can change the Hue, Saturation and Lightness. 
CYMK is where you will change the CYMK color settings. 
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Both Image and Variable have a border overlay. You can adjust the thickness of the 
border from the Format ribbon tab. You must only have one item selected and it must 
be an image or variable image for this option to be available. 
 

 
 

Rectangle 
 
To add a rectangle to the card design, click on the Rectangle icon. The rectangle will 
show up on the card template. To change the attributes of the rectangle click on the 
Format tab with the rectangle highlighted. On this tab you can set the Location, Size, 
Rotation and Z Order in the Common area of the ribbon. In the Rectangle area of the 
ribbon, the Weight, Outline color and Fill color can be set as well. 
 

Barcode 
 
There are 9 barcode formats available: Epic Barcode, Visitor Barcode, Code 128 
Barcode, Code 39 Barcode, MaxiCode Barcode, PDF 417 Barcode, QR Barcode, 
Interleave 2 Of 5 Barcode, and Data Matrix Barcode. 
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Visitor Barcode is only enabled if the entity type is a Visitor. The Visitor Barcode is used 
by the auto check out feature found in the Visitor Manager module.  
 
Click on the Barcode icon and select the barcode type you want to add to the badge. 
The Barcode Data window will appear. This window is just like the Text Field Data 
window. Add static and variable information to the Output box. Add sample data to the 
sample data area. Format variable information as desired. 
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You can set the Location, Size, Rotation and Z Order in the Common area of the ribbon. 
Additionally, (depending on the barcode type), whether the barcode’s data shows up in 
a human readable format, the background color, the aspect ratio of the barcode and the 
density of the barcode can be set in the Barcode area of the ribbon. 
 
Density is only available if the aspect ratio is set to none. Otherwise density is set 
internally by the barcode builder. 
Note that if you set the aspect ratio to none to manually set density, the barcode will 
NOT appear on the canvas as it will when it is printed. When the barcode is placed on 
the canvas (as with any design item) it is put inside of container that allows you to move 
/ resize / and rotate the design item. After much effort, we were told by the third party 
vendor we use to generate the barcodes that since they could get it to work outside the 
container, that they were closing the support ticket. Below is how a Code 128 looks on 
the canvas with the aspect ratio set to none and the density set to .3. 
 



33 | P a g e  

 

 
 
To see how the barcode will be printed, select File > Print and the preview of the badge 
will be displayed. Since the preview is generated outside the container, the barcode 
vendor is able to render the barcode correctly. 
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Epic Barcode 
 

With the release of BadgePass 3.1, the BadgePass Studio has been updated to include 
a new barcode format: the Epic Barcode. The Epic Barcode can be added to all entity 
type designs, except for Visitor. Additionally, it is added to a design just like any other 
barcode type. 
 
To add an Epic Barcode, begin by clicking on the Barcode icon in the ribbon menu and 
selecting Epic Barcode: 
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Next, you will be presented with an Epic Registration Code window. Here you will be 
required to enter your Epic Registration Code you obtained in order for the barcode to 
be added to the design. Below is an image of this window: 
 

 
 

Also on this window is a checkbox labeled Send to EPIC Data Server. It is 
recommended that is option is always selected. By selecting this option, whenever an 
entity is saved in Identity Manager and the badge associated with said entity has an 
Epic Barcode, then the barcode’s data is transmitted to the EPIC Data Server. 
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Below is an example of an Epic Barcode that has been added to a design: 
 

 
 

Just like all of the other barcode formats, by clicking on the Format tab (after selecting 
the Epic Barcode) you can adjust Common properties such as Location, Size, Rotation, 
Z Order. Depending on the barcode type, you can adjust Barcode properties such as 
Background Color, Show Text, Aspect Ratio, and Density. 
 

Magstripe 
 
When designing a card, a Magstripe can only be added to the back of a card design. As 
such this icon will only be enabled while you are working on the back of a card design. 
To work with the backside of the card, click on the word Front in the design area tab. 
When clicked, the value will change to Back showing that you are working with the 
backside of the card. 
 



37 | P a g e  

 

 
 

To add a Magstripe field to the card, click on the Magstripe icon. The following window 
will appear: 
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You can add variable or static data to each track. Keep in mind that Track 1 follows 
IATA Magstripe rules, track 2 follows ABA Magstripe rules and track 3 follows TTS 
Magstripe rules. Click in the desired mag track box and enter the data that you want to 
encode. When finished, click the OK button. 
 

 
 
. 

Format Tab 
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To change attributes on a Text Field, Image, Variable Image, Line, Rectangle or 
Barcode, highlight the particular item and click on the Format tab at the top. 
 

 
 
 

The Format tab allows you to set the Location, Size, Rotation and Z Order. These are 
found in the Common area of the ribbon. In the example above we see what would be 
present on the Format tab when having selected a Text Field. Additionally, depending 
on the type of item you have selected on the badge design, there will be another section 
on the ribbon bar that allows you adjust other item-type-specific properties. Our 
example above shows a Text Field section where you can set various font properties 
and overflow properties. 
 

 

Opening and Saving a Design 
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When you are done with your design click on the File tab and click Save. To open an 
existing design, click on the File tab, click on Open, choose the design from the Designs 
drop down list and click the Open button. 
 

 

 
Connected Mode 
 

When you save a design and are in Connected Mode, the designs are automatically 
saved to the BadgePass Suite. You can find them in the BadgePass Management 
Console under Badge Management -> Badges. 
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You can have multiple design screens open. They will each have a tab that you can 
click on.  
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Disconnected Mode 
 
When BadgePass Studio is installed in Disconnected Mode, there will be different 
choices in the File tab menu. 
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The Disconnected Mode gives you the ability to Import existing badge designs. Also, 
you can Import Database Fields. By importing the database fields you are able to add 
database fields to the badge design, even while in Disconnected Mode. 
 
To import a badge design click on Import in the menu and navigate to the location of the 
.xps file and click Open. 
 

 
 

After editing the design, click on Save to save the changes to the file. Because this 
action will overwrite the file it is suggested that you make a backup of the original file, 
just in case you make an error or need to revert back in the future. 
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To import the database fields, click on Import Db Fields in the menu. Navigate to the 
location of the BadgePass.bpe file that was exported from the BadgePass Management 
Console and click Open. 
 
Now when you create a badge design you will see the database fields: 
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Appendices 
 

Appendix A: Exporting Database Fields in Management 
Console for use in BadgePass Studio 
 
To export the database fields from the Management Console for use with BadgePass 
Studio do the following: 

- Open the Management Console and navigate to BadgePass System -> 
Database. 

- Next, click on Browse button under Export Settings region and select a location 
to save the BadgePass.bpe file to. 

 

 
 

- Once you have chosen all settings that you would like to export, click the Export 
Settings button 

 


