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Introduction

Topics

The following topics are covered in this chapter:

Assumptions  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     T-6

Where to find our documentation      .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     T-7

Technical support and updates    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     T-8

Be
fore you begin .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     T-9
Example designs .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     T-9
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Assumptions

We assume that you are familiar with the use of your operating system. If you are not familiar with Microsoft Windows, we 
recommend that you work through the tutorials provided with MS Windows before using ModelSim. 

We also assume that you have a working knowledge of VHDL and/or Verilog. Although ModelSim is an excellent tool to use 
while learning HDL concepts and practices, this document is not written to support that goal. 
delSim Tutorial
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Where to find our documentation

ModelSim documentation is available from our website at www.model.com/support or in the following formats and locations:

Document Format How to get it

ModelSim Installation & 
Licensing Guide

paper shipped with ModelSim

PDF select Help > Documentation; also available from the Support 
page of our web site: www.model.com

ModelSim Quick Guide 
(command and feature 
q

paper shipped with ModelSim
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T

uick-reference) PDF select Help > Documentation, also available from the Support 
page of our web site: www.model.com

odelSim Tutorial PDF, HTML select Help > Documentation; also available from the Support 
page of our web site: www.model.com

odelSim User’s Manual PDF, HTML select Help > Documentation

odelSim Command 
eference

PDF, HTML select Help > Documentation

odelSim GUI Reference PDF, HTML select Help > Documentation

ommand Help ASCII type help [command name] at the prompt in the Transcript pane

rror message help ASCII type verror <msgNum> at the Transcript or shell prompt

cl Man Pages (Tcl 
anual)

HTML select Help > Tcl Man Pages, or find contents.htm in 
\modeltech\docs\tcl_help_html

echnotes HTML select Technotes dropdown on www.model.com/support

http://www.model.com/support
http://www.model.com/products/release.asp
http://www.model.com/products/release.asp
http://www.model.com/products/release.asp
http://www.model.com/support/documentation/BOOK/sdk_um.pdf
http://www.model.com/support
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Technical support and updates

Support

Model Technology online and email technical support options, maintenance renewal, and links to international support 
contacts:
www.model.com/support/default.asp

Mentor Graphics support:
www.mentor.com/supportnet

Updates

La
delSim Tutorial

Access to the most current version of ModelSim:
www.model.com/downloads/default.asp

test version email

Place your name on our list for email notification of news and updates:
www.model.com/products/informant.asp

http://www.model.com/support/default.asp
http://www.mentor.com/supportnet/
http://www.model.com/downloads/default.asp
http://www.model.com/products/informant.asp
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Before you begin

Preparation for some of the lessons leaves certain details up to you. You will decide the best way to create directories, copy files, 
and execute programs within your operating system. (When you are operating the simulator within ModelSim’s GUI, the interface 
is consistent for all platforms.)

Example designs

ModelSim comes with Verilog and VHDL versions of the designs used in these lessons. This allows you to do the tutorial 
regardless of which license type you have. Though we have tried to minimize the differences between the Verilog and VHDL 
versions, we could not do so in all cases. In cases where the designs differ (e.g., line numbers or syntax), you will find language-
specific instructions. Follow the instructions that are appropriate for the language that you are using.
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Lesson 1 - ModelSim conceptual overview

Topics

The following topics are covered in this chapter:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-12

Basic simulation flow      .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-13
Creating the working library      .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-13
Compiling your design   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-13

Pr

M

De
Running the simulation  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-13
Debugging your results  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-14

oject flow   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-15

ultiple library flow .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-16

bugging tools  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-17
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Introduction

ModelSim is a simulation and debugging tool for VHDL, Verilog, SystemC, and mixed-language designs. 

This lesson provides a brief conceptual overview of the ModelSim simulation environment. It is divided into four topics, which 
you will learn more about in subsequent lessons:

Topic Additional information and 
practice

Basic simulation flow Lesson 2 - Basic simulation

Project flow Lesson 3 - ModelSim projects

M

D

delSim Tutorial

ultiple library flow Lesson 4 - Working with multiple 
libraries

ebugging tools Remaining lessons
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Basic simulation flow

The following diagram shows the basic steps for simulating a design in ModelSim.
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Create a working library

Compile design files
reating the working library

ModelSim, all designs, be they VHDL, Verilog, or some combination thereof, are compiled into a library. You typically sta
ew simulation in ModelSim by creating a working library called "work". "Work" is the library name used by the compiler a
 default destination for compiled design units.

ompiling your design

ter creating the working library, you compile your design units into it. The ModelSim library format is compatible across al
pported platforms. You can simulate your design on any platform without having to recompile your design.

unning the simulation

ith the design compiled, you invoke the simulator on a top-level module (Verilog) or a configuration or entity/architecture pa
HDL). Assuming the design loads successfully, the simulation time is set to zero, and you enter a run command to begin 
ulation.

Run simulation

Debug results
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Debugging your results

If you don’t get the results you expect, you can use ModelSim’s robust debugging environment to track down the cause of the 
problem.
delSim Tutorial
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Project flow

A project is a collection mechanism for an HDL design under specification or test. Even though you don’t have to use projects in 
ModelSim, they may ease interaction with the tool and are useful for organizing files and specifying simulation settings.

The following diagram shows the basic steps for simulating a design within a ModelSim project.

As

•  Y

•  P

Create a project
 you can see, the flow is similar to the basic simulation flow. However, there are two important differences:

ou do not have to create a working library in the project flow; it is done for you automatically.

rojects are persistent. In other words, they will open every time you invoke ModelSim unless you specifically close them.

Add files to the project

Run simulation

Debug results

Compile design files
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Multiple library flow

ModelSim uses libraries in two ways: 1) as a local working library that contains the compiled version of your design; 2) as a 
resource library. The contents of your working library will change as you update your design and recompile. A resource library 
is typically static and serves as a parts source for your design. You can create your own resource libraries, or they may be supplied 
by another design team or a third party (e.g., a silicon vendor).

You specify which resource libraries will be used when the design is compiled, and there are rules to specify in which order they 
are searched. A common example of using both a working library and a resource library is one where your gate-level design and 
testbench are compiled into the working library, and the design references gate-level models in a separate resource library.

The diagram below shows the basic steps for simulating with multiple libraries.

Yo h 
the
delSim Tutorial

u can also link to resource libraries from within a project. If you are using a project, you would replace the first step above wit
se two steps: create the project and add the testbench to the project.

Create a working library

Compile design files

Run simulation

Debug results

Link to resource libraries
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Debugging tools

ModelSim offers numerous tools for debugging and analyzing your design. Several of these tools are covered in subsequent 
lessons, including:

•  Setting breakpoints and stepping through the source code

•  Viewing waveforms and measuring time

•  Exploring the "physical" connectivity of your design

•  Viewing and initializing memories

•  Testing code coverage

•  C
omparing waveforms
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Lesson 2 - Basic simulation

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-20
Design files for this lesson   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-20
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-20

Creating the working design library  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-21

Compiling the design.     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-23

Lo

Ru

Se

Le
ading the design into the simulator     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-24

nning the simulation   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-25

tting breakpoints and stepping in the Source window.     .     .     .     .     .     .     .     .     .     .     .     .     .   T-27

sson wrap-up   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-29
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DL – <install_dir>/modeltech/examples/counter.vhd and tcounter.vhd

is lesson uses the Verilog files counter.v and tcounter.v in the examples. If you 
ve a VHDL license, use counter.vhd and tcounter.vhd instead. Or, if you have 

ixed license, feel free to use the Verilog testbench with the VHDL counter or 
e versa.

elated reading

odelSim User’s Manual – Chapter 3 - Design libraries  (UM-51), Chapter 5 - 
rilog simulation  (UM-97), Chapter 4 - VHDL simulation  (UM-65)

odelSim Command Reference (vlib (CR-281), vmap (CR-293), vlog (CR-282), 
om (CR-237), and view (CR-257) commands)
20 Lesson 2 - Basic simulation 

troduction

 this lesson you will go step-by-step through the basic simulation flow:

esign files for this lesson

e sample design for this lesson is a simple 8-bit, binary up-counter with an 
sociated testbench. The pathnames are as follows:

rilog – <install_dir>/modeltech/examples/counter.v and tcounter.v

Compile design units

Run simulation

Debug results

Create a working library
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This opens a dialog where you specify physical and logical names for the 

lSim dialog

rary dialog

3b
library (Figure 2). You can create a new library or map to an existing 
library. We’ll be doing the former.

b Type work in the Library Name field if it isn’t entered automatically.
reating the working design library

fore you can simulate a design, you must first create a library and compile the 
urce code into that library.

Create a new directory and copy the tutorial files into it.

Start by creating a new directory for this exercise (in case other users will be 
working with these lessons). 

Verilog: Copy counter.v and tcounter.v files from /<install_dir>/examples 
to the new directory.

VHDL: Copy counter.vhd and tcounter.vhd files from /<install_dir>/
examples to the new directory. 

Start ModelSim if necessary.

a Type vsim at a UNIX shell prompt or use the ModelSim icon in 
Windows.

Upon opening ModelSim for the first time, you will see the Welcome to 
ModelSim dialog (Figure 1). Click Close.

b Select File > Change Directory and change to the directory you created 
in step 1. 

Create the working library.

a Select File > New > Library.

Figure 1: The Welcome to Mode

Figure 2: The Create a New Lib
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c Click OK.

ModelSim creates a directory called work and writes a specially-
formatted file named _info into that directory. The _info file must remain 
in the directory to distinguish it as a ModelSim library. Do not edit the 
folder contents from your operating system; all changes should be made 
from within ModelSim.

ModelSim also adds the library to the list in the Workspace (Figure 3) 
and records the library mapping for future reference in the ModelSim 
initialization file (modelsim.ini).

hen you pressed OK in step c above, three lines were printed to the Main 
ndow Transcript pane:

vlib work
vmap work work
# Modifying modelsim.ini

e first two lines are the command-line equivalent of the menu commands you 
oked. Most menu driven functions will echo their command-line equivalents in 
s fashion. The third line notifies you that the mapping has been recorded in the 
odelSim initialization file.

Figure 3: The newly created wo
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iled into the work library
a On the Library tab, click the ’+’ icon next to the work library and you will 
see two design units (Figure 5). You can also see their types (Modules, 
Entities, etc.) and the path to the underlying source files if you scroll to 
the right. 
ompiling the design

ith the working library created, you are ready to compile your source files.

u can compile by using the menus and dialogs of the graphic interface, as in the 
rilog example below, or by entering a command at the ModelSim> prompt as 
the VHDL example below.

Verilog: Compile counter.v and tcounter.v.

a Select Compile > Compile.

This opens the Compile Source Files dialog (Figure 4).

If the Compile menu option is not available, you probably have a project 
open. If so, close the project by selecting File > Close when the 
Workspace pane is selected.

b Select counter.v, hold the <Ctrl> key down, and then select tcounter.v. 

c With the two files selected, click Compile.

The files are compiled into the work library.

d Click Done.

VHDL: Compile counter.vhd and tcounter.vhd.

a Type vcom counter.vhd tcounter.vhd at the ModelSim> prompt and 
press <Enter> on your keyboard.

View the compiled design units.

Figure 4: The Compile HDL Sou

Figure 5: Verilog modules comp
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oading the design into the simulator

Load the test_counter module into the simulator.

a Double-click test_counter in the Main window Workspace to load the 
design.

You can also load the design by selecting Simulate > Start Simulation 
in the menu bar. This opens the Start Simulation dialog. With the Design 
tab selected, click the ’+’ sign next to the work library to see the counter 
and test_counter modules. Select the test_counter module and click OK 
(Figure 6).

When the design is loaded, you will see a new tab named sim that 
displays the hierarchical structure of the design (Figure 7). You can 
navigate within the hierarchy by clicking on any line with a ’+’ (expand) 
or ’-’ (contract) icon. You will also see a tab named Files that displays 
all files included in the design.

Figure 6: Loading the design wi

Figure 7: Workspace tab showi
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b Type run 500 at the VSIM> prompt in the Main window.

ave window

 the Wave window

2c
The simulation advances another 500 ns for a total of 600 ns (Figure 9).
unning the simulation

w you will run the simulation. 

Set the graphic user interface to view all debugging windows.

a Select View > Debug Windows > All Windows.

This opens all ModelSim windows, giving you different views of your 
design data and a variety of debugging tools. Most windows will open as 
panes within the Main window. The Dataflow, List, and Wave windows 
will open as separate windows. You may need to move or resize the 
windows to your liking. Panes within the Main window can be undocked 
to stand alone.

Add signals to the Wave window.

a In the Workspace pane, select the sim tab.

b Right-click test_counter to open a popup context menu.

c Select Add > Add to Wave (Figure 8).

Three signals are added to the Wave window.

Run the simulation.

a Click the Run icon in the Main or Wave window toolbar.

The simulation runs for 100 ns (the default simulation length) 
and waves are drawn in the Wave window.

Figure 8: Adding signals to the W

Figure 9: Waves being drawn in
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c Click the Run -All icon on the Main or Wave window toolbar.

The simulation continues running until you execute a break 
command or it hits a statement in your code (e.g., a Verilog 
$stop statement) that halts the simulation.

d Click the Break icon.

The simulation stops running.



 and stepping in the Source window  T-27

ModelSim Tutorial

S
S

Ne
M
sim
on

1

2

3

Breakpoint 31.

4

ource window
d Click on line number 31 again to re-create the breakpoint.

Restart the simulation.

a Click the Restart icon to reload the design elements and reset 
the simulation time to zero. 

The Restart dialog that appears gives you options on what to 
retain during the restart (Figure 11).

b Click Restart in the Restart dialog.
Setting breakpoints

etting breakpoints and stepping in the
ource window

xt you will take a brief look at one interactive debugging feature of the 
odelSim environment. You will set a breakpoint in the Source window, run the 

ulation, and then step through the design under test. Breakpoints can be set 
ly on lines with red line numbers.

Open counter.v in the Source window.

a Select the Files tab in the Main window Workspace.

b Double-click counter.v to add it to the Source window.

Set a breakpoint on line 31 of counter.v (if you are simulating the VHDL files, 
use line 30 instead).

a Scroll to line 31 and click on the line number.

A red ball appears next to the line (Figure 10) indicating that a breakpoint 
has been set.

Disable, enable, and delete the breakpoint.

a Click the red ball to disable the breakpoint. It will become a black circle.

b Click the black circle to re-enable the breakpoint. It will become a red 
ball.

c Click the red ball with your right mouse button and select Remove 

Figure 10: A breakpoint in the S

Figure 11: The Restart dialog



T-

Mo

5

inter on a variable in the Source view

Objects window
delSim Tutorial
28 Lesson 2 - Basic simulation 

c Click the Run -All icon.

The simulation runs until the breakpoint is hit. When the 
simulation hits the breakpoint, it stops running, highlights the 
line with a blue arrow in the Source view (Figure 12), and issues a Break 
message in the Transcript pane.

When a breakpoint is reached, typically you want to know one or more 
signal values. You have several options for checking values:

• look at the values shown in the Objects window (Figure 13).

• set your mouse pointer over the count variable in the Source 
window, and a "balloon" will pop up with the value (Figure 12)

• highlight the count variable in the Source window, right-click it, and 
select Examine from the pop-up menu 

• use the examine command to output the value to the Main window 
Transcript (i.e., examine count)

Try out the step commands.

a Click the Step icon on the Main window toolbar.

This single-steps the debugger.

Experiment on your own. Set and clear breakpoints and use the 
Step, Step Over, and Continue Run commands until you feel comfortable 
with their operation.

Figure 12: Resting the mouse po

Figure 13: Values shown in the 
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is concludes this lesson. Before continuing we need to end the current 
ulation.

Select Simulate > End Simulation. 

Click Yes when prompted to confirm that you wish to quit simulating.
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Lesson 3 - ModelSim projects

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-32
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-32

Creating a new project    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-33
Adding objects to the project     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-34
Changing compile order (VHDL)    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-35

Compiling and loading a design  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-36

Or

Si

Le
ganizing projects with folders .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-37
Adding folders   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-37
Moving files to folders   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-38
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troduction

 this lesson you will practice creating a project. At a minimum, projects have a 
rk library and a session state that is stored in a .mpf file. A project may also 

nsist of:

• HDL source files or references to source files

• other files such as READMEs or other project documentation

• local libraries

• references to global libraries

is lesson uses the Verilog files tcounter.v and counter.v in the examples. If you 
ve a VHDL license, use tcounter.vhd and counter.vhd instead.

elated reading

odelSim User’s Manual, Chapter 2 - Projects  (UM-31)
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reating a new project

If you just finished the previous lesson, ModelSim should already be running. 
If not, start ModelSim.

a Type vsim at a UNIX shell prompt or use the ModelSim icon in 
Windows.

Create a new project.

a Select Create a Project from the Welcome dialog or File > New > 
Project (Main window) from the menu bar.

This opens a dialog where you enter a Project Name, Project Location 
(i.e., directory), and Default Library Name (Figure 14). The default 
library is where compiled design units will reside. 

b Type test in the Project Name field.

c Click Browse to select a directory where the project file will be stored. 

d Leave the Default Library Name set to work.

e Click OK.

If you see the Select Initial Ini dialog, asking which modelsim.ini file you 
would like the project to be created from, select the Use Default Ini 
button.

Figure 14: The Create Project d
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dding objects to the project

ce you click OK to accept the new project settings, you will see a blank Project 
 in the workspace area of the Main window and the Add items to the Project 
log will appear (Figure 15). From this dialog you can create a new design file, 

d an existing file, add a folder for organization purposes, or create a simulation 
nfiguration (discussed below). 

Add two existing files.

a Click Add Existing File.

This opens the Add file to Project dialog (Figure 16). This dialog lets you 
browse to find files, specify the file type, specify which folder to add the 
file to, and identify whether to leave the file in its current location or to 
copy it to the project directory.

b Click Browse.

c Open the examples directory in your ModelSim installation tree.

d Verilog: Select counter.v, hold the <Ctrl> key down, and then select 
tcounter.v.
VHDL: Select counter.vhd, hold the <Ctrl> key down, and then select 
tcounter.vhd.

e Click Open and then OK.

f Click Close to dismiss the Add items to the Project dialog.

Figure 15: Adding new items to

Figure 16: The Add file to Proje
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c Click OK to close the Compile Order dialog.

 files display a ’?’ for status

ialog box

move up / down buttons
1b
You should now see two files listed in the Project tab of the Workspace 
pane (Figure 17).

Question mark icons (?) in the Status column mean the file hasn’t been 
compiled or the source file has changed since the last successful compile. 
The other columns identify file type (e.g., Verilog or VHDL), 
compilation order, and modified date.

hanging compile order (VHDL)

mpilation order is important in VHDL designs. Follow these steps to change 
mpilation order within a project.

Change the compile order.

a Select Compile > Compile Order.

This opens the Compile Order dialog box (Figure 18).

b Click the Auto Generate button. 

ModelSim "determines" the compile order by making multiple passes 
over the files. It starts compiling from the top; if a file fails to compile 
due to dependencies, it moves that file to the bottom and then recompiles 
it after compiling the rest of the files. It continues in this manner until all 
files compile successfully or until a file(s) can’t be compiled for reasons 
other than dependency. 

Alternatively, you can select a file and use the Move Up and Move Down 
buttons to put the files in the correct order. 

Figure 17: Newly added project

Figure 18: The Compile Order d
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 an expanded library

 the counter design unit
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simulation that started when you loaded test_counter.

End the simulation.

a Select Simulate > End Simulation.

b Click Yes.

4a
36 Lesson 3 - ModelSim projects 

ompiling and loading a design

Compile the files.

a Right-click anywhere in the Project tab and select Compile > Compile 
All from the pop-up menu.

ModelSim compiles both files and changes the symbol in the Status 
column to a check mark. A check mark means the compile succeeded. If 
the compile had failed, the symbol would be a red ’X’, and you would 
see an error message in the Transcript pane.

View the design units.

a Click the Library tab in the workspace.

b Click the "+" icon next to the work library.

You should see two compiled design units, their types (modules in this 
case), and the path to the underlying source files (Figure 19).

Load the test_counter design unit. 

a Double-click the test_counter design unit.

You should see a new tab named sim that displays the structure of the 
test_counter design unit (Figure 20). A fourth tab named Files contains 
information about the underlying source files.

At this point you would generally run the simulation and analyze or 
debug your design like you did in the previous lesson. For now, you’ll 

Figure 19: The Library tab with

Figure 20: The structure tab for

2a 2b 3a
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c Click the Folder Location drop-down arrow and select Design Files.

to the project

1b

2c

2b
d Click OK.
Figure 23: Creating a subfolder
rganizing projects with folders

you have a lot of files to add to a project, you may want to organize them in 
lders. You can create folders either before or after adding your files. If you 
ate a folder before adding files, you can specify in which folder you want a file 
ced at the time you add the file (see Folder field in Figure 16). If you create a 

lder after adding files, you edit the file properties to move it to that folder. 

dding folders

 shown previously in Figure 15, the Add items to the Project dialog has an 
tion for adding folders. If you have already closed that dialog, you can use a 
nu command to add a folder.

Add a new folder.

a Select File > Add to Project > Folder.

b Type Design Files in the Folder Name field (Figure 21).

c Click OK.

You’ll now see a folder in the Project tab (Figure 22). 

Add a sub-folder.

a Right-click anywhere in the Project tab and select Add to Project > 
Folder.

b Type HDL in the Folder Name field (Figure 23).

Figure 21: Adding a new folder 

Figure 22: A folder in a project
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You’ll now see a ’+’ icon next to the Design Files folder in the Project 
tab (Figure 24).

e Click the ’+’ icon to see the HDL sub-folder.

oving files to folders

w that you have folders, you can move the files into them. If you are running 
 a Windows platform, you can simply drag-and-drop the files into the folder. On 
ix platforms, you either have to place the files in a folder when you add the files 
the project, or you have to move them using the properties dialog.

Move tcounter.v and counter.v to the HDL folder.

a Select counter.v, hold the <Ctrl> key down, and then select tcounter.v. 

b Right-click either file and select Properties.

This opens the Project Compiler Settings dialog (Figure 25), which lets 
you set a variety of options on your design files.

c Click the Place In Folder drop-down arrow and select HDL.

d Click OK.

The two files are moved into the HDL folder. Click the ’+’ icons on the 
folders to see the files.

The files are now marked with a ’?’ icon. Because you moved the files, 
the project no longer knows if the previous compilation is still valid.

Figure 24: A folder with a sub-f

Figure 25: Changing file locatio

2e
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uration in the Project tab
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1d
(Figure 27).

Load the Simulation Configuration.

a Double-click the counter Simulation Configuration in the Project tab.

In the Transcript pane of the Main window, the vsim (the ModelSim 
simulator) invocation shows the -hazards and -t ps switches (Figure 28). 
These are the command-line equivalents of the options you specified in 
the Simulate dialog. 
imulation Configurations

Simulation Configuration associates a design unit(s) and its simulation options. 
r example, say every time you load tcounter.v you want to set the simulator 
olution to picoseconds (ps) and enable event order hazard checking. Ordinarily 
u would have to specify those options each time you load the design. With a 
mulation Configuration, you specify options for a design and then save a 
onfiguration" that associates the design and its options. The configuration is 
n listed in the Project tab and you can double-click it to load counter.v along 
th its options.

Create a new Simulation Configuration.

a Select File > Add to Project > Simulation Configuration.

This opens the Simulate dialog (Figure 26). The tabs in this dialog 
present a myriad of simulation options. You may want to explore the tabs 
to see what’s available. You can consult the ModelSim User’s Manual to 
get a description of each option. 

b Type counter in the Simulation Configuration Name field.

c Select HDL from the Place in Folder drop-down.

d Click the ’+’ icon next to the work library and select test_counter.

e Click the Resolution drop-down and select ps.

f For Verilog, click the Verilog tab and check Enable Hazard Checking.

g Click OK.

Figure 26: The Simulation Conf

Figure 27: A Simulation Config
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esson wrap-up

is concludes this lesson. Before continuing you need to end the current 
ulation and close the current project.

Select Simulate > End Simulation. Click Yes.

Select the Project tab in the Main window Workspace.

Right-click the test project to open a context popup menu and select Close 
Project.

If you do not close the project, it will open automatically the next time you 
start ModelSim.

Figure 28: Transcript shows op

command-line switches
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Lesson 4 - Working with multiple libraries

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-42
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-42

Creating the resource library .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-43

Creating the project   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-45

Linking to the resource library    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-46

Pe

Le
rmanently mapping resource libraries .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-49

sson wrap-up   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-50
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troduction

 this lesson you will practice working with multiple libraries. As discussed in 
sson 1 - ModelSim conceptual overview, you might have multiple libraries to 
ganize your design, to access IP from a third-party source, or to share common 
rts between simulations. 

u will start the lesson by creating a resource library that contains the counter 
sign unit. Next, you will create a project and compile the testbench into it. 
nally, you will link to the library containing the counter and then run the 

ulation.

esign files for this lesson

e sample design for this lesson is a simple 8-bit, binary up-counter with an 
sociated testbench. The pathnames are as follows:

rilog – <install_dir>/modeltech/examples/counter.v and tcounter.v

DL – <install_dir>/modeltech/examples/counter.vhd and tcounter.vhd

is lesson uses the Verilog files tcounter.v and counter.v in the examples. If you 
ve a VHDL license, use tcounter.vhd and counter.vhd instead.

elated reading

odelSim User’s Manual, 3 - Design libraries  (UM-51)
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4b
a Select File > New > Library.

b Type parts_lib in the Library Name field (Figure 29).

The Library Physical Name field is filled out automatically. 

Once you click OK, ModelSim creates a directory for the library, lists it 
in the Library tab of the Workspace, and modifies the modelsim.ini file 
to record this new library for the future. 
reating the resource library

Create a directory for the resource library.

Create a new directory called resource_library. Copy counter.v from 
<install_dir>/modeltech/examples to the new directory.

Create a directory for the testbench.

Create a new directory called testbench that will hold the testbench and 
project files. Copy tcounter.v from <install_dir>/modeltech/examples to the 
new directory.

You are creating two directories in this lesson to mimic the situation where 
you receive a resource library from a third-party. As noted earlier, we will 
link to the resource library in the first directory later in the lesson.

Start ModelSim and change to the exercise directory.

If you just finished the previous lesson, ModelSim should already be running. 
If not, start ModelSim.

a Type vsim at a UNIX shell prompt or use the ModelSim icon in 
Windows.

If the Welcome to ModelSim dialog appears, click Close.

b Select File > Change Directory and change to the resource_library 
directory you created in step 1. 

Figure 29: Creating the new res



T-

Mo

5

6

esource library

5b

5c
delSim Tutorial
44 Lesson 4 - Working with multiple libraries 

Compile the counter into the resource library.

a Click the Compile icon on the Main window toolbar.

b Select the parts_lib library from the Library list (Figure 30).

c Double-click counter.v to compile it.

d Click Done.

You now have a resource library containing a compiled version of the counter 
design unit.

Change to the testbench directory.

a Select File > Change Directory and change to the testbench directory 
you created in step 2. 

Figure 30: Compiling into the r
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reating the project

w you will create a project that contains tcounter.v, the counter’s testbench.

Create the project.

a Select File > New > Project. 

b Type counter in the Project Name field.

c Click OK.

d If a dialog appears asking about which modelsim.ini file to use, click Use 
Default Ini.

Add the testbench to the project.

a Click Add Existing File in the Add items to the Project dialog.

b Click the Browse button and select tcounter.v.

c Click Open and then OK.

d Click Close to dismiss the Add items to the Project dialog.

The tcounter.v file is listed in the Project tab of the Main window.

Compile the testbench.

a Right-click tcounter.v and select Compile > Compile Selected.
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a In the Library tab, click the ’+’ icon next to the work library and double-
click test_counter.

The Main window Transcript reports a warning(Figure 32). When you 
see a message that contains text like "Warning: (vsim-3473)", you can 
view more detail by using the verror command.

b Type verror 3473 at the ModelSim> prompt.

The expanded error message tells you that a component (’dut’ in this 
case) has not been explicitly bound and no default binding can be found.

c Type quit -sim to quit the simulation.
46 Lesson 4 - Working with multiple libraries 

inking to the resource library

 wrap up this part of the lesson, you will link to the parts_lib library you created 
rlier. But first, try simulating the testbench without the link and see what 
ppens. 

odelSim responds differently for Verilog and VHDL in this situation. 

rilog

Simulate a Verilog design with a missing resource library.

a In the Library tab, click the ’+’ icon next to the work library and double-
click test_counter.

The Main window Transcript reports an error (Figure 31). When you see 
a message that contains text like "Error: (vsim-3033)", you can view 
more detail by using the verror command.

b Type verror 3033 at the ModelSim> prompt.

The expanded error message tells you that a design unit could not be 
found for instantiation. It also tells you that the original error message 
should list which libraries ModelSim searched. In this case, the original 
message says ModelSim searched only work.

DL

Simulate a VHDL design with a missing resource library.

Figure 31: Verilog simulation er

Figure 32: VHDL simulation wa
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e process for linking to a resource library differs between Verilog and VHDL. 
you are using Verilog, follow the steps in "Linking in Verilog" (T-47). If you are 
ing VHDL, follow the steps in "Linking in VHDL" (T-48) one page later.

nking in Verilog

nking in Verilog requires that you specify a "search library" when you invoke 
 simulator.

Specify a search library during simulation.

a Click the Simulate icon on the Main window toolbar.

b Click the ’+’ icon next to the work library and select 
test_counter.

c Click the Libraries tab.

d Click the Add button next to the Search Libraries field and browse to 
parts_lib in the first directory you created earlier in the lesson.

e Click OK.

The dialog should have parts_lib listed in the Search Libraries field 
(Figure 33).

f Click OK.

The design loads without errors.

Figure 33: Specifying a search li
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The testbench source code should now look similar to that shown in 
Figure 33.

d Select File > Save.

Recompile and simulate.

a In the Project tab of the Main window, right-click tcounter. vhd and 
select Compile > Compile Selected.

b In the Library tab, double-click test_counter to load the design.

The design loads without errors.
48 Lesson 4 - Working with multiple libraries 

nking in VHDL

 link to a resource library in VHDL, you have to create a logical mapping to the 
ysical library and then add LIBRARY and USE statements to the source file.

Create a logical mapping to parts_lib.

a Select File > New > Library.

b In the Create a New Library dialog, select a map to an existing library.

c Type parts_lib in the Library Name field.

d Click Browse to open the Select Library dialog and browse to parts_lib 
in the resource_library directory you created earlier in the lesson. 
Click OK to select the library and close the Select Library dialog.

e The Create a New Library dialog should look similar to the one shown in 
Figure 34. Click OK to close the dialog.

Add LIBRARY and USE statements to tcounter.vhd.

a In the Library tab of the Main window, click the ’+’ icon next to the work 
library.

b Right-click test_counter in the work library and select Edit.

This opens the file in the Source window.

c Add these two lines to the top of the file:

LIBRARY parts_lib;
USE parts_lib.ALL;

Figure 34: Mapping to the parts

Figure 35: Adding LIBRARY a
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ermanently mapping resource libraries

you reference particular resource libraries in every project or simulation, you 
y want to permanently map the libraries. Doing this requires that you edit the 
ster modelsim.ini file in the installation directory. Though you won’t actually 

actice it in this tutorial, here are the steps for editing the file:

Locate the modelsim.ini file in the ModelSim installation directory 
(<install_dir>/modeltech/modelsim.ini).

IMPORTANT - Make a backup copy of the file.

Change the file attributes of modelsim.ini so it is no longer "read-only."

Open the file and enter your library mappings in the [Library] section. For 
example:

parts_lib = C:/libraries/parts_lib

Save the file.

Change the file attributes so the file is "read-only" again. 
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esson wrap-up

is concludes this lesson. Before continuing we need to end the current 
ulation and close the project.

Select Simulate > End Simulation. Click Yes.

Select the Project tab of the Main window Workspace.

Select File > Close. Click OK.
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Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-52
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-52

Loading a design .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-53

Adding objects to the Wave window.     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-54

Using cursors in the Wave window  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-56

Sa

Le
Working with a single cursor     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-56
Working with multiple cursors  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-57

ving the window format    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-59

sson wrap-up   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-60
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troduction

e Wave window allows you to view the results of your simulation as HDL 
veforms and their values.

e Wave window is divided into a number of window panes (Figure 36). All 
ndow panes in the Wave window can be resized by clicking and dragging the 
r between any two panes.

elated reading

odelSim GUI Reference – "Wave window" (GR-182) 

odelSim User’s Manual – Chapter 8 - WLF files (datasets) and virtuals  (UM-

5)

Figure 36: The Wave window a

pathname value

cursor name cursor valu
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r the examples in this lesson, we have used the design simulated in Lesson 2 - 
sic simulation.

If you just finished the previous lesson, ModelSim should already be running. 
If not, start ModelSim.

a Type vsim at a UNIX shell prompt or use the ModelSim icon in 
Windows.

If the Welcome to ModelSim dialog appears, click Close.

Load the design.

a Select File > Change Directory and open the directory you created in 
Lesson 2.

The work library should already exist.

b Click the ’+’ icon next to the work library and double-click test_counter.

ModelSim loads the design and adds sim and Files tabs to the 
Workspace.
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ModelSim adds the objects for that instance to the Wave window.

c Drag a signal from the Objects pane to the Wave window.

d In the Wave window, select Edit > Select All and then Edit > Delete.

Add objects using a command.

a Type add wave * at the VSIM> prompt.

ModelSim adds all objects from the current region.

b Run the simulation for awhile so you can see waveforms.
54 Lesson 5 - Viewing simulations in the Wave window 

dding objects to the Wave window

odelSim offers several methods for adding objects to the Wave window. In this 
ercise, you will try different methods.

Add objects from the Objects pane.

a Select an item in the Objects pane of the Main window, right-click, and 
then select Add to Wave > Signals in Region.

ModelSim adds several signals to the Wave window.

Undock the Wave window.

By default ModelSim opens Wave windows as a tab in the MDI frame of the 
Main window. You can change the default via the Preferences dialog (Tools 
> Edit Preferences). See "ModelSim GUI preferences" (GR-236) in the 
ModelSim GUI & Interface Reference for more information.

a Click the undock icon on the Wave pane (Figure 37).

The Wave pane becomes a standalone, un-docked window.

Add objects using drag-and-drop.

You can drag an object to the Wave window from many other windows and 
panes (e.g., Workspace, Objects, and Locals).

a In the Wave window, select Edit > Select All and then Edit > Delete.

b Drag an instance from the sim tab of the Main window to the Wave 

Figure 37: A Wave window doc
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ooming the waveform display

oming lets you change the display range in the waveform pane. There are 
merous methods for zooming the display.

Zoom the display using various techniques.

a Click the Zoom Mode icon on the Wave window toolbar.

b In the waveform pane, click and drag down and to the right. 

You should see blue vertical lines and numbers defining an area to zoom 
in (Figure 38).

c Select View > Zoom > Zoom Last.

The waveform pane returns to the previous display range.

d Click the Zoom In 2x icon a few times.

e In the waveform pane, click and drag up and to the right. 

You should see a blue line and numbers defining an area to zoom out 
(Figure 39).

Figure 38: Zooming in with the 

Figure 39: Zooming out with the
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le cursor in the Wave window

1e
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if you click or drag a cursor to within ten pixels of a waveform edge. You 
can set the snap distance in the Window Preferences dialog (select Tools 
> Window Preferences). 

e In the cursor pane, drag the cursor to the right of a transition (Figure 40).

The cursor doesn’t snap to a transition if you drag in the cursor pane. 
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sing cursors in the Wave window

rsors mark simulation time in the Wave window. When ModelSim first draws 
 Wave window, it places one cursor at time zero. Clicking anywhere in the 
veform pane brings that cursor to the mouse location.

u can also add additional cursors; name, lock, and delete cursors; use cursors 
measure time intervals; and use cursors to find transitions.

orking with a single cursor

Position the cursor by clicking and dragging.

a Click the Select Mode icon on the Wave window toolbar.

b Click anywhere in the waveform pane.

A cursor is inserted at the time where you clicked (Figure 40).

c Drag the cursor and observe the value pane.

The signal values change as you move the cursor. This is perhaps the 
easiest way to examine the value of a signal at a particular time.

d In the waveform pane, drag the cursor to the right of a transition with the 
mouse positioned over a waveform. 

Figure 40: Working with a sing
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1 Add a second cursor.

t between two cursors

1d
a Click the Add Cursor icon on the Wave window toolbar.

b Right-click the name of the new cursor and delete the text.

c Type B and press Enter.

d Drag cursor B and watch the interval measurement change dynamically 
(Figure 42).
Rename the cursor.

a Right-click "Cursor 1" in the cursor name pane, and select and delete the 
text (Figure 41).

b Type A and press Enter.

The cursor name changes to "A".

Jump the cursor to the next or previous transition.

a Click signal count in the pathname pane.

a Click the Find Next Transition icon on the Wave window toolbar.

The cursor jumps to the next transition on the currently selected signal.

b Click the Find Previous Transition icon on the Wave window toolbar.

The cursor jumps to the previous transition on the currently selected 
signal.

orking with multiple cursors

Figure 41: Renaming a cursor

Figure 42: Interval measuremen

2a
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Lock cursor B.

a Right-click cursor B in the cursor pane and select Lock B.

The cursor color changes to red and you can no longer drag the cursor 
(Figure 43).

Delete cursor B.

a Right-click cursor B and select Delete B.

Figure 43: A locked cursor in th



Saving the window format  T-59

ModelSim Tutorial

S

If 
sig
Fo
pr
as

Fo
sim

1

2

aving the window format

you close the Wave window, any configurations you made to the window (e.g., 
nals added, cursors set, etc.) are discarded. However, you can use the Save 
rmat command to capture the current Wave window display and signal 
eferences to a DO file. You open the DO file later to recreate the Wave window 
 it appeared when the file was created. 

rmat files are design-specific; use them only with the design you were 
ulating when they were created.

Save a format file.

a Select File > Save > Format.

b Leave the file name set to wave.do and click Save.

c Close the Wave window.

Load a format file.

a In the Main window, select View > Debug Windows > Wave.

All signals and cursor(s) that you had set are gone.

b In the Wave window, select File > Open > Format.

c Select wave.do and click Open.

ModelSim restores the window to its previous state.

d Close the Wave window when you are finished by selecting File > Close.
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esson wrap-up

is concludes this lesson. Before continuing we need to end the current 
ulation.

Select Simulate > End Simulation. Click Yes.
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Lesson 6 - Debugging with the Dataflow window

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-62
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-62

Compiling and loading the design    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-63

Exploring connectivity    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-64

Tracing events     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-65

Tr

Di

Le
acing an ’X’ (unknown)    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-67

splaying hierarchy in the Dataflow window   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-68

sson Wrap-up  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-69

Note: The functionality described in this tutorial requires a dataflow license feature in 
your ModelSim license file. Please contact your Mentor Graphics sales representative if 
you currently do not have such a feature.
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troduction

e Dataflow window allows you to explore the "physical" connectivity of your 
sign; to trace events that propagate through the design; and to identify the cause 
 unexpected outputs. The window displays processes; signals, nets, and 
isters; and interconnect.

esign files for this lesson

e sample design for this lesson is a testbench that verifies a cache module and 
w it works with primary memory. A processor design unit provides read and 
ite requests.

e pathnames to the files are as follows:

rilog – <install_dir>/modeltech/examples/dataflow/verilog

DL – <install_dir>/modeltech/examples/dataflow/vhdl

is lesson uses the Verilog version in the examples. If you have a VHDL license, 
e the VHDL version instead. When necessary, we distinguish between the 
rilog and VHDL versions of the design.

elated reading

odelSim User’s Manual –"Tracing signals with the Dataflow window" (UM-255)

odelSim GUI Reference – "Dataflow window" (GR-111)
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• Creates the working library
• Compiles the design files

• Opens the Dataflow and Wave windows

• Adds signals to the Wave window

• Logs all signals in the design

• Runs the simulation

Feel free to open the DO file and look at its contents.
ompiling and loading the design

 this exercise you will use a DO file to compile and load the design. 

Create a new directory and copy the tutorial files into it.

Start by creating a new directory for this exercise (in case other users will be 
working with these lessons). Create the directory and copy all files from 
<install_dir>/examples/dataflow/verilog to the new directory.

If you have a VHDL license, copy the files in <install_dir>/examples/
dataflow/vhdl instead.

Start ModelSim and change to the exercise directory.

If you just finished the previous lesson, ModelSim should already be running. 
If not, start ModelSim.

a Type vsim at a UNIX shell prompt or use the ModelSim icon in 
Windows.

If the Welcome to ModelSim dialog appears, click Close.

b Select File > Change Directory and change to the directory you created 
in step 1. 

Execute the lesson DO file.

a Type do run.do at the ModelSim> prompt.

The DO file does the following:
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xploring connectivity

primary use of the Dataflow window is exploring the "physical" connectivity of 
ur design. You do this by expanding the view from process to process. This 
ows you to see the drivers/receivers of a particular signal, net, or register.

Add a signal to the Dataflow window.

a Make sure instance p is selected in the sim tab of the Workspace pane.

b Drag signal strb from the Objects pane to the Dataflow window (Figure 
44).

Explore the design.

a Double-click the net highlighted in red.

The view expands to display the processes that are connected to strb 
(Figure 45).

b Select signal test on process #NAND#44 (labeled line_62 in the 
VHDL version) and click the Expand net to all drivers icon.

Notice that after the display expands, the signal line for strb is 
highlighted in green. This highlighting indicates the path you have 
traversed in the design.

c Select signal oen on process #ALWAYS#149(labeled line_75 in 
the VHDL version), and click the Expand net to all readers 
icon.

Figure 44: A signal in the Dataf

Figure 45: Expanding the view 
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racing events

other useful debugging feature is tracing events that contribute to an 
expected output value. Using the Dataflow window’s embedded wave viewer, 
u can trace backward from a transition to see which process or signal caused the 
expected output.

Add an object to the Dataflow window.

a Make sure instance p is selected in the sim tab of the Main window. 

b Drag signal t_out from the Objects pane into the Dataflow window.

c Select View > Show Wave in the Dataflow window to open the wave 
viewer (Figure 46). You may need to increase the size of the Dataflow 
window and scroll the panes to see everything. 

Trace the inputs of the nand gate.

a Select process #NAND#44 (labeled line_62 in the VHDL version) in the 
dataflow pane. 

All input and output signals of the process are displayed automatically in 
the wave viewer. 

b In the wave view, scroll to time 2785 ns (the last transition of signal 
t_out) .

c Click on the last transition of signal t_out to set a cursor (Figure 47).

Figure 46: The embedded wave 

Figure 47: Signals added to the 
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d Select Trace > Trace next event to trace the first contributing event.

ModelSim adds a cursor marking the last event, the transition of the 
strobe to 0 at 2745 ns, which caused the output of 1 on t_out (Figure 48).

e Select Trace > Trace next event two more times.

f Select Trace > Trace event set.

The dataflow pane sprouts to the preceding process and shows the input 
driver of signal strb (Figure 49). Notice too that the wave viewer now 
shows the input and output signals of the newly selected process.

You can continue tracing events through the design in this manner: select 
Trace next event until you get to a transition of interest in the wave 
viewer, and then select Trace event set to update the dataflow pane.

Select File > Close to close the Dataflow window.

Figure 48: Cursor in wave view

Figure 49: Tracing the event set



Tracing an ’X’ (unknown)  T-67

ModelSim Tutorial

T

Th
thr
wi
wi
Da
wi

1

2

3

n values

 cause of the unknown on t_out
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Trace the unknown.

a In the Dataflow window, make sure t_out is selected and then select 
Trace > ChaseX.

The design expands to show the source of the unknown (Figure 51). In 
this case there is a HiZ (U in the VHDL version) on input signal test_in 
and a 0 on input signal_rw (bar_rw in the VHDL version), so output 
signal test2 resolves to an unknown.

Scroll to the bottom of the Wave window, and you will see that all of the 
signals contributing to the unknown value have been added.

Clear the Dataflow window before continuing.
racing an ’X’ (unknown)

e Dataflow window lets you easily track an unknown value (X) as it propagates 
ough the design. The Dataflow window is linked to the stand-alone Wave 
ndow, so you can view signals in the Wave window and then use the Dataflow 
ndow to track the source of a problem. As you traverse your design in the 
taflow window, appropriate signals are added automatically to the Wave 
ndow.

View t_out in the Wave and Dataflow windows.

a Scroll in the Wave window until you can see /top/p/t_out.

t_out goes to an unknown state at 2065 ns and continues transitioning 
between 1 and unknown for the rest of the run (Figure 50). The red color 
of the waveform indicates an unknown value.

b Double-click the last transition of signal t_out at 2785 ns.

This automatically opens the Dataflow window and displays t_out, its 
associated process, and its waveform. You may need to increase the size 
of the Dataflow window and scroll the panes to see everything.

c Move the cursor in the Wave window.

As previously mentioned the Wave and Dataflow windows are designed 
to work together. As you move the cursor in the Wave, the value of t_out 
changes in the Dataflow window.

d Move the cursor to a time when t_out is unknown (e.g., 2724 ns).

Figure 50: A signal with unknow

Figure 51: ChaseX identifies the
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isplaying hierarchy in the Dataflow win-
ow

u can display connectivity in the Dataflow window using hierarchical 
tances. You enable this by modifying the options prior to adding objects to the 
ndow.

Change options to display hierarchy.

a Select Tools > Options from the Dataflow window menu bar.

b Check Show Hierarchy and then click OK (Figure 52).

Add signal t_out to the Dataflow window.

a Type add dataflow /top/p/t_out at the VSIM> prompt. 

The Dataflow window will display t_out and all hierarchical instances 
(Figure 53).

Figure 52: The Dataflow option

Figure 53: Dataflow window dis
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is concludes this lesson. Before continuing we need to end the current 
ulation.

Type quit -sim at the VSIM> prompt.



T-

Mo
delSim Tutorial
70 Lesson 6 - Debugging with the Dataflow window 



ModelSim Tutorial

 T-71

Lesson 7 - Viewing and initializing memories

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-72
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-72

Compiling and loading the design    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-73

Viewing a memory    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-74
Navigating within the memory  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-76

Sa

In

In

Le
ving memory contents to a file      .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-78

itializing a memory      .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-79

teractive debugging commands     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-81

sson Wrap-up  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-83
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troduction

 this lesson you will learn how to view and initialize memories in ModelSim. 
odelSim defines and lists as memories any of the following:

• reg, wire, and std_logic arrays

• Integer arrays

• Single dimensional arrays of VHDL enumerated types other than 
std_logic

esign files for this lesson

e ModelSim installation comes with Verilog and VHDL versions of the 
ample design. The files are located in the following directories:

rilog – <install_dir>/modeltech/examples/memory/verilog

DL – <install_dir>/modeltech/examples/memory/vhdl

is lesson uses the Verilog version for the exercises. If you have a VHDL 
ense, use the VHDL version instead.

elated reading

odelSim GUI Reference – "Memory windows" (GR-140)

odelSim Command Reference – mem display (CR-145), mem load (CR-148), 
em save (CR-151), radix (CR-182) commands
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VHDL:
Type vcom -93 sp_syn_ram.vhd dp_syn_ram.vhd ram_tb.vhd at the 
ModelSim> prompt. 

Load the design.

a On the Library tab of the Main window Workspace, click the "+" icon 
next to the work library.

b Double-click the ram_tb design unit to load the design. 
ompiling and loading the design

Create a new directory and copy the tutorial files into it.

Start by creating a new directory for this exercise (in case other users will be 
working with these lessons). Create the directory and copy all files from 
<install_dir>/examples/memory/verilog to the new directory.

If you have a VHDL license, copy the files in <install_dir>/examples/
memory/vhdl instead.

Start ModelSim and change to the exercise directory.

If you just finished the previous lesson, ModelSim should already be running. 
If not, start ModelSim.

a Type vsim at a UNIX shell prompt or use the ModelSim icon in 
Windows.

If the Welcome to ModelSim dialog appears, click Close.

b Select File > Change Directory and change to the directory you created 
in step 1. 

Create the working library and compile the design.

a Type vlib work at the ModelSim> prompt.

b Verilog: 
Type vlog sp_syn_ram.v dp_syn_ram.v ram_tb.v at the ModelSim> 
prompt.
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iewing a memory

emories can be viewed via the ModelSim GUI.

Open a Memory instance.

a Select View > Debug Windows > Memory.

The Memories tab opens in the Workspace pane (Figure 54) and lists the 
memories in the current design context (ram_tb) with the range, depth, 
and width of each memory.

b VHDL: The radix for enumerated types is Symbolic. To change the radix 
to binary for the purposes of this lesson, type the following command at 
the vsim prompt:
VSIM> radix bin

c Double-click the /ram_tb/spram1/mem instance in the memories list to 
view its contents. 

A mem tab is created in the MDI frame to display the memory contents. 
The data are all X (0 in VHDL) since you have not yet simulated the 
design. The first column (blue hex characters) lists the addresses (Figure 
55), and the remaining columns show the data values.

d Double-click instance /ram_tb/spram2/mem in the Memories tab of the 
Workspace,

This creates a new tab in the MDI frame called mem(1) that contains the 
addresses and data for the spram2 instance. Each time you double-click 
a new memory instance in the Workspace, a new tab is created for that 

Figure 54: Viewing the memori

Figure 55: The mem tab in the M
/ram_tb/spram1/mem
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Simulate the design.

a Click the run -all icon in the Main window.

b Click the mem tab of the MDI frame to bring the 
/ram_tb/spram1/mem instance to the foreground (Figure 56).

VHDL: 
In the Transcript pane, you will see NUMERIC_STD warnings that can be 
ignored and an assertion failure that is functioning to stop the simulation. The 
simulation itself has not failed.

Let’s change the address radix and the number of words per line for instance 
/ram_tb/spram1/mem.

a Right-click anywhere in the Memory Contents pane and select 
Properties. 

The Properties dialog box opens (Figure 57). 

b For the Address Radix, select Decimal. This changes the radix for the 
addresses only.

c Select Words per line and type 1 in the field.

d Click OK.

You can see the results of the settings in Figure 58. If the figure doesn’t match 
what you have in your ModelSim session, check to make sure you set the 
Address Radix rather than the Data Radix. Data Radix should still be set to 
Symbolic, the default.

Figure 56: Memory display upd

Figure 57: Changing the addres
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avigating within the memory

u can navigate to specific memory address locations, or to locations containing 
rticular data patterns. First, you will go to a specific address.

Use Goto to find a specific address.

a Right-click anywhere in address column and select Goto (Figure 59).

The Goto dialog box opens in the data pane.

b Type 30 in the dialog box.

c Click OK.

The requested address appears in the top line of the window. 

Figure 58: Memory window: ne

Figure 59: The Goto dialog box
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Edit the address location directly.

To quickly move to a particular address, do the following:

a Double click any address in the address column.

b Enter any desired address. (Figure 60)

c Press <Enter> on your keyboard.

The pane scrolls to that address.

Now, let’s find a particular data entry.

a Right-click anywhere in the data column and select Find.

The Find in dialog box opens (Figure 61).

b Type 11111010 in the Find data: field and click Find Next.

The data scrolls to the first occurrence of that address. Click Find Next 
a few more times to search through the list.

c Click Close to close the dialog box.

Figure 60: Edit the address dire

Figure 61: Find in: searching fo
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c In the Properties dialog, set the Address Radix to Decimal and the Data 
Radix to Binary. Click OK to accept the changes and close the dialog.

d Select File > Save to bring up the Save Memory dialog box. 

e Specify a Start address of 0 and End address of 250.

f For Address Radix select Decimal, and for Data Radix select Binary.

g Click No addresses to create a memory pattern that you can use to 
relocate somewhere else in the memory, or in another memory.

h Enter the file name as reloc.mem, then click OK to save the memory 
contents and close the dialog.

1e
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aving memory contents to a file

u can save memory contents to a file that can be loaded at some later point in 
ulation. 

Save a memory pattern from the /ram_tb/spram1/mem instance to a file.

a Make sure /ram_tb/spram1/mem is open and selected in the MDI frame.

b Select File > Save to bring up the Save Memory dialog box (Figure 62).

c For the Address Radix, select Decimal.

d For the Data Radix, select Binary.

e Type data_mem.mem into the Filename field.

f Click OK.

You can view the saved file in any editor.

emory pattern files can be saved as relocatable files, simply by leaving out the 
dress information. Relocatable memory files can be loaded anywhere in a 
mory because no addresses are specified.

Save a relocatable memory pattern file from the /ram_tb/spram2/mem 
instance.

a Select the mem(1) tab in the MDI pane to see the data for the /ram_tb/
spram2/mem instance.

b Right-click on the memory contents to open a popup menu and select 

Figure 62: Save Memory dialog

1c 1d
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c Click OK.

The addresses in instance /ram_tb/spram3/mem are updated with the data 
from data_mem.mem (Figure 64).
You will use this file for initialization in the next section.

itializing a memory

 ModelSim, it is possible to initialize a memory using one of three methods: 
m a saved memory file, from a fill pattern, or from both.

rst, let’s initialize a memory from a file only. You will use one you saved 
eviously, data_mem.mem. 

View instance /ram_tb/spram3/mem.

a Double-click the /ram_tb/spram3/mem instance in the Memories tab.

This will open a new tab – mem(2) – in the MDI frame to display the 
contents of /ram_tb/spram3/mem. Scan these contents so you can 
identify changes once the initialization is complete.

b Right-click and select Properties to bring up the Properties dialog. 

c Change the Address Radix to Decimal and Data Radix to Binary and 
click OK.

Initialize spram3 from a file.

a Right-click anywhere in the data column and select Load to bring up the 
Load Memory dialog box (Figure 63).

The default Load Type is File Only.

b Type data_mem.mem in the Filename field.

Figure 63: Load Memory dialog

Figure 64: Initialized memory fr



T-

Mo

In
pa
pr
ad

3

Yo
yo

No
vie

4

e memory file

n memory instance

3c

3f

3d

3e
delSim Tutorial

w, before you leave this section, go ahead and clear the instances already being 
wed. 

Right-click somewhere in the mem(2) pane and select Close All.
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 this next step, you will experiment with loading from both a file and a fill 
ttern. You will initialize spram3 with the 250 addresses of data you saved 
eviously into the relocatable file reloc.mem. You will also initialize 50 
ditional address entries with a fill pattern.

Load the /ram_tb/spram3/mem instance with a relocatable memory pattern 
(reloc.mem) and a fill pattern.

a Right-click in the data column of the mem(2) tab and select Load to 
bring up the Load Memory dialog box (Figure 65).

b For Load Type, select Both File and Data.

c For Address Range, select Addresses and enter 0 as the Start address and 
300 as the End address. 

This means that you will be loading the file from 0 to 300. However, the 
reloc.mem file contains only 251 addresses of data. Addresses 251 to 300 
will be loaded with the fill data you specify next.

d For File Load, enter reloc.mem in the Filename field.

e For Data Load, select a Fill Type of Increment.

f In the Fill Data field, set the seed value of 0 for the incrementing data.

g Click OK.

h View the data near address 250 by double-clicking on any address in the 
Address column and entering 250. 

u can see the specified range of addresses overwritten with the new data. Also, 
u can see the incrementing data beginning at address 251 (Figure 66).

Figure 65: Loading a relocatabl

Figure 66: Overwritten values i

3b
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Figure 69: Random contents of 
teractive debugging commands

e memory panes can also be used interactively for a variety of debugging 
rposes. The features described in this section are useful for this purpose. 

Open a memory instance and change its display characteristics.

a Double-click instance /ram_tb/dpram1/mem in the Memories tab.

b Right-click in the memory contents pane and select Properties. 

c Change the Data Radix to Hexadecimal.

d Select Words per line and enter 2.

e Click OK.

Initialize a range of memory addresses from a fill pattern.

a Right-click in the data column of /ram_tb/dpram1/mem contents pane 
and select Change to open the Change Memory dialog (Figure 68).

b Click the Addresses radio button and enter the start address as 
0x00000006 and the end address as 0x00000009. The "0x" hex notation 
is optional.

c Select Random as the Fill Type.

d Enter 0 as the Fill Data, setting the seed for the Random pattern.

e Click OK.

The data in the specified range are replaced with a generated random fill 

Figure 67: Original memory con

Figure 68: Changing memory co
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Change contents by highlighting.

You can also change data by highlighting them in the Address Data pane.

a Highlight the data for the addresses 0x0000000c:0x0000000e, as shown 
in Figure 70.

b Right-click the highlighted data and select Change.

This brings up the Change dialog box (Figure 71). Note that the 
Addresses field is already populated with the range you highlighted.

c Select Value as the Fill Type.

d Enter the data values into the Fill Data field as follow: 34 35 36

e Click OK.

The data in the address locations change to the values you entered (Figure 
72).

Edit data in place.

To edit only one value at a time, do the following:

a Double click any value in the Data column.

b Enter the desired value and press <Enter>. 

c When you are finished editing all values, press the <Enter> key on your 
keyboard to exit the editing mode.

If you needed to cancel the edit function, press the <Esc> key on your 
keyboard.

Figure 70: Changing contents b

Figure 71: Entering data to cha
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is concludes this lesson. Before continuing we need to end the current 
ulation.

Select Simulate > End Simulation. Click Yes.
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Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-86
Design files for this lesson   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-86
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-86

Compiling the design.     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-87

Loading and running the design  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-88
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ewing statistics in the Main window   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-89

ewing statistics in the Source window.     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-91

ewing toggle statistics in the Objects pane     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-93

cluding lines and files from coverage statistics    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-94

eating Code Coverage reports .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-94

sson wrap-up   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-96

Note: The functionality described in this tutorial requires a coverage license feature in 
your ModelSim license file. Please contact your Mentor Graphics sales representative if 
you currently do not have such a feature.
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troduction

odelSim Code Coverage gives you graphical and report file feedback on which 
ecutable statements, branches, conditions, and expressions in your source code 
ve been executed. It also measures bits of logic that have been toggled during 
ecution. 

esign files for this lesson

e sample design for this lesson consists of a finite state machine which controls 
ehavioral memory. The testbench test_sm provides stimulus. 

e ModelSim installation comes with Verilog and VHDL versions of this design. 
e files are located in the following directories:

rilog – <install_dir>/modeltech/examples/coverage/verilog

DL – <install_dir>/modeltech/examples/coverage/vhdl

is lesson uses the Verilog version in the examples. If you have a VHDL license, 
e the VHDL version instead. When necessary, we distinguish between the 
rilog and VHDL versions of the design.

elated reading

odelSim User’s Manual – Chapter 12 - Measuring code coverage  (UM-289)
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 Compile the design files.

a For Verilog – Type vlog -cover bct sm.v sm_seq.v beh_sram.v 
test_sm.v at the ModelSim> prompt. 

For VHDL – Type vcom -cover bct sm.vhd sm_seq.vhd sm_sram.vhd 
test_sm.vhd at the ModelSim> prompt.

The -cover bct argument instructs ModelSim that you want branch, 
condition, and toggle coverage statistics (statement coverage is included 
by default). See "Enabling code coverage" (UM-293) for more information 
on the available coverage types.
ompiling the design

abling Code Coverage is a two step process–first, you compile the files and 
ntify which coverage statistics you want; second, you load the design and tell 

odelSim to produce those statistics.

Create a new directory and copy the tutorial files into it.

Start by creating a new directory for this exercise (in case other users will be 
working with these lessons). Create the directory and copy all files from 
<install_dir>/modeltech/examples/coverage/verilog to the new directory.

If you have a VHDL license, copy the files in <install_dir>/modeltech/
examples/coverage/vhdl instead.

Start ModelSim and change to the exercise directory.

If you just finished the previous lesson, ModelSim should already be running. 
If not, start ModelSim.

a Type vsim at a UNIX shell prompt or use the ModelSim icon in 
Windows.

If the Welcome to ModelSim dialog appears, click Close.

b Select File > Change Directory and change to the directory you created 
in step 1. 

Create the working library.

a Type vlib work at the ModelSim> prompt.
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"Excluding lines and files from coverage statistics" (T-94) for more 
information).

ese panes can be re-sized, rearranged, and "undocked" to make the data more 
sily viewable. To resize a pane, click-and-drag on the top or bottom border. To 
ve a pane, click-and-drag on the double-line to the right of the pane name. To 

dock a pane you can select it then drag it out of the Main window, or you can 
ck the Dock/Undock Pane button in the header bar (top right). To redock the 
ne, click the Dock/Undock Pane button again.

e will look at these panes more closely in the next exercise. For complete details 
 each pane, see "Code coverage panes" (GR-99).
88 Lesson 8 - Simulating with Code Coverage 

oading and running the design

Load the design.

a Type vsim -coverage test_sm at the ModelSim> prompt.

Run the simulation

b Type run 1 ms at the VSIM> prompt.

hen you load a design with Code Coverage enabled, ModelSim adds several 
lumns to the Files and sim tabs in the Workspace (Figure 73). ModelSim also 
plays three Code Coverage panes in the Main window (Figure 74):

Missed Coverage

Displays the selected file’s un-executed statements, branches, conditions, and 
expressions and signals that have not toggled.

Instance Coverage

Displays statement, branch, condition, expression and toggle coverage 
statistics for each instance in a flat, non-hierarchical view.

Details

Shows details of missed coverage such as truth tables or toggle details.

other coverage-related pane is the Current Exclusions pane. Select View > 
de Coverage > Current Exclusions to display that pane.

Current Exclusions

Figure 73: Coverage columns in

Figure 74: Coverage panes
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t’s take a look at the data in these various panes.

View statistics in the Workspace pane.

a Select the sim tab in the Workspace and scroll to the right.

Coverage statistics are shown for each object in the design. 

b Select the Files tab in the Workspace and scroll to the right. 

Each file in the design shows summary statistics for statements, 
branches, conditions, and expressions. 

c Click the right-mouse button on any column name and select an object 
from the list (Figure 75).

Whichever column you selected is hidden. To redisplay the column, 
right-click again and select that column name. The status of which 
columns are displayed or hidden is persistent between invocations of 
ModelSim.

View statistics in the Missed Coverage pane.

a Select different files from the Files tab of the Workspace.

The Missed Coverage pane updates to show statistics for the selected file 
(Figure 76).

b Select any entry in the Statement tab to display that line in the Source 
window.

Figure 75: Right click a column

Figure 76: Statement statistics i
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View statistics in the Details pane.

a Select the Toggle tab in the Missed Coverage pane. 

If the Toggle tab isn’t visible, you can do one of two things: 1) widen the 
pane by clicking-and-dragging on the pane border; 2) if your mouse has 
a middle button, click-and-drag the tabs with the middle mouse button.

b Select any object in the Toggle tab to see details in the Details pane 
(Figure 77).

View instance coverage statistics.

The Instance Coverage pane displays coverage statistics for each instance in 
a flat, non-hierarchical view (Figure 78). Select any instance in the Instance 
Coverage pane to see its source code displayed in the Source window.

Figure 77: Details pane showing

Figure 78: The Instance Covera
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 the previous section you saw that the Source window and the Main window 
verage panes are linked. You can select objects in the Main window panes to 
w the underlying source code in the Source window. Furthermore, the Source 
ndow contains statistics of its own.

View coverage statistics for test_sm in the Source window.

a Make sure test_sm is selected in the sim tab of the Workspace.

b In the Statement tab of the Missed Coverage pane, expand test_sm.v if 
necessary and select any line (Figure 79).

The Source window opens in the MDI frame with the line you selected 
highlighted (Figure 80).

c Switch to the Source window.

The table below describes the various icons.

Icon Description

green checkmark indicates a statement that has been executed

red X indicates that a statement in that line has not been 
executed (zero hits)

green E indicates a line that has been excluded from code 
coverage statistics

Figure 79: Selecting a line in the

Figure 80: Coverage statistics in
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d Hover your mouse pointer over a line of code with a green checkmark.

The icons change to numbers that indicate how many times the 
statements and branches in that line were executed (Figure 81). In this 
case line 24 was executed 1562 times. 

e Select Tools > Code Coverage > Show coverage numbers.

The icons are replaced by execution counts on every line. An ellipsis (...) 
is displayed whenever there are multiple statements on the line. Hover 
the mouse pointer over a statement to see the count for that statement.

f Select Tools > Code Coverage > Hide coverage numbers to return to 
icon display.

Figure 81: Coverage numbers s



 toggle statistics in the Objects pane  T-93

ModelSim Tutorial

V
p

To
an
> 
co
inf

1

mns in the Source window
Viewing

iewing toggle statistics in the Objects
ane

ggle coverage counts each time a logic node transitions from one state to 
other. Earlier in the lesson you enabled two-state toggle coverage (0 -> 1 and 1-
0) with the -cover t argument. Alternatively, you can enable six-state toggle 
verage using the -cover x argument. See "Toggle coverage" (UM-299) for more 
ormation.

View toggle data in the Objects pane of the Main window.

a Select test_sm in the sim tab of the Main window.

b If the Objects pane isn’t open already, select View > Debug Windows > 
Objects.

c Scroll to the right and you will see the various toggle coverage columns 
(Figure 82).

The blank columns show data when you have extended toggle coverage 
enabled.

Figure 82: Toggle coverage colu
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xcluding lines and files from coverage 
tatistics

odelSim allows you to exclude lines and files from code coverage statistics. You 
n set exclusions with the GUI, with a text file called an "exclusion filter file", or 
th "pragmas" in your source code. Pragmas are statements that instruct 
odelSim to not collect statistics for the bracketed code. See "Excluding objects 
m coverage" (UM-303) for more details on exclusion filter files and pragmas.

Exclude a line via the Missed Coverage pane.

a Right click a line in the Missed Coverage pane and select Exclude 
Selection. (You can also exclude the selection for the current instance 
only by selecting Exclude Selection For Instance <inst_name>.)

Exclude an entire file.

a In the Files tab of the Workspace, locate sm.v (or sm.vhd if you are using 
the VHDL example).

b Right-click the file name and select Coverage > Exclude Selected File 
(Figure 83).

The file is added to the Current Exclusions pane. 

Cancel the exclusion of sm.v.

a Right-click sm.v in the Current Exclusions pane and select Cancel 
Selected Exclusions.

Figure 83: Excluding an entire f
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a Type coverage report -file cover.txt at the VSIM> prompt.

t dialog
b Type notepad cover.txt at the VSIM> prompt to view the report.

c Close Notepad when you are done reviewing the report.
reating Code Coverage reports

u can create reports on the coverage statistics using either the menus or by 
tering commands in the Transcript pane. The reports are output to a text file 
ardless of which method you use.

 create coverage reports via the menus, do one of the following: 

select Tools > Code Coverage > Reports from the Main window menu

right-click any object in the sim or Files tab of the Workspace and select Code 
Coverage > Coverage Reports

right-click any object in the Instance Coverage pane and select Code coverage 
reports from the context menu

Create a report on all instances.

a Select Tools > Coverage > Reports from the Main window toolbar.

This opens the Coverage Report dialog (Figure 84). 

b Make sure Report on all instances and No Filtering are selected and 
then click OK.

ModelSim creates a file report.txt in the current directory and displays 
the report in Notepad.

c Close Notepad when you are done looking at the report.

Create a summary report on all design files from the Transcript pane.

Figure 84: The Coverage Repor
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esson wrap-up

is concludes this lesson. Before continuing we need to end the current 
ulation.

Type quit -sim at the VSIM> prompt.
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Lesson 9 - Waveform Compare

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-98
Design files for this lesson   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-98
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .   T-98

Creating the test dataset  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-100
Verilog   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-100
VHDL    .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-101

Co
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Sa

Le
mparing the simulation runs   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-102

ewing comparison data      .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-103
Viewing comparison data in the Main window .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-103
Viewing comparison data in the Wave window.     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-103
Viewing comparison data in the List window   .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-104

ving and reloading comparison data   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-105

sson wrap-up   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-107

Note: The functionality described in this tutorial requires a compare license feature in 
your ModelSim license file. Please contact your Mentor Graphics sales representative if 
you currently do not have such a feature.
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e the VHDL version instead. When necessary, we distinguish between the 
rilog and VHDL versions of the design.

elated reading

aveform Compare" (UM-240), Chapter 8 - WLF files (datasets) and virtuals  
M-195)
98 Lesson 9 - Waveform Compare 

troduction

aveform Compare computes timing differences between test signals and 
erence signals. The general procedure for comparing waveforms has four main 
ps:

Selecting the simulations or datasets to compare

Specifying the signals or regions to compare

Running the comparison

Viewing the comparison results

 this exercise you will run and save a simulation, edit one of the source files, run 
 simulation again, and finally compare the two runs.

esign files for this lesson

e sample design for this lesson consists of a finite state machine which controls 
ehavioral memory. The testbench test_sm provides stimulus. 

e ModelSim installation comes with Verilog and VHDL versions of this design. 
e files are located in the following directories:

rilog – <install_dir>/modeltech/examples/compare/verilog

DL – <install_dir>/modeltech/examples/compare/vhdl

is lesson uses the Verilog version in the examples. If you have a VHDL license, 



Creating the reference dataset  T-99

ModelSim Tutorial

C

Th
It 
sim

In

1

2

3

a Type do gold_sim.do at the ModelSim> prompt.

The DO file does the following:

• Creates and maps the work library

• Compiles the Verilog and VHDL files

• Runs the simulation and saves the results to a dataset named gold.wlf

• Quits the simulation

Feel free to open the DO file and look at its contents.
reating the reference dataset

e reference dataset is the .wlf file that the test dataset will be compared against. 
can be a saved dataset, the current simulation dataset, or any part of the current 

ulation dataset.

 this exercise you will use a DO file to create the reference dataset. 

Create a new directory and copy the tutorial files into it.

Start by creating a new directory for this exercise (in case other users will be 
working with these lessons). Create the directory and copy all files from 
<install_dir>/modeltech/examples/compare/verilog to the new directory.

If you have a VHDL license, copy the files in <install_dir>/modeltech/
examples/compare/vhdl instead.

Start ModelSim and change to the exercise directory.

If you just finished the previous lesson, ModelSim should already be running. 
If not, start ModelSim.

a Type vsim at a UNIX shell prompt or use the ModelSim icon in 
Windows.

If the Welcome to ModelSim dialog appears, click Close.

b Select File > Change Directory and change to the directory you created 
in step 1. 

Execute the lesson DO file.
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• Re-compiles the testbench

• Adds waves to the Wave window

• Runs the simulation
100 Lesson 9 - Waveform Compare 

reating the test dataset

e test dataset is the .wlf file that will be compared against the reference dataset. 
ke the reference dataset, the test dataset can be a saved dataset, the current 

ulation dataset, or any part of the current simulation dataset.

 simplify matters, you will create the test dataset from the simulation you just 
. However, you will edit the testbench to create differences between the two 

ns. 

rilog

Edit the testbench.

a Select File > Open and open test_sm.v.

b Scroll to line 122, which looks like this:

@ (posedge clk) wt_wd('h10,'haa);

c Change the data pattern ’aa’ to ’ab’:

@ (posedge clk) wt_wd('h10,'hab);

d Select File > Save to save the file.

Compile the revised file and rerun the simulation.

a Type do sec_sim.do at the ModelSim> prompt.

The DO file does the following:
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Edit the testbench.

a Select File > Open and open test_sm.vhd.

b Scroll to line 151, which looks like this:

wt_wd ( 16#10#, 16#aa#, clk, into );

c Change the data pattern ’aa’ to ’ab’:

wt_wd ( 16#10#, 16#ab#, clk, into );

d Select File > Save to save the file.

Compile the revised file and rerun the simulation.

a Type do sec_sim.do at the ModelSim> prompt.

The DO file does the following:

• Re-compiles the testbench

• Adds waves to the Wave window

• Runs the simulation
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omparing the simulation runs

odelSim includes a Comparison Wizard that walks you through the process. 
u can also configure the comparison manually with menu or command line 

mmands.

Create a comparison using the Comparison Wizard.

a Select Tools > Waveform Compare > Comparison Wizard.

b Click the Browse button and select gold.wlf as the reference dataset 
(Figure 85). 

Recall that gold.wlf is from the first simulation run.

c Leaving the test dataset set to Use Current Simulation, click Next.

d Select Compare All Signals in the second dialog and click Next (Figure 
86).

e In the next three dialogs, click Next, Compute Differences Now, and 
Finish, respectively.

ModelSim performs the comparison and displays the compared signals 
in the Wave window.

Figure 85: First dialog of the Co

Figure 86: Second dialog of the 
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Figure 89: The compare icons
iewing comparison data

mparison data displays in three places within the ModelSim GUI: the 
orkspace pane of the Main window, the Wave window, and the List window.

ewing comparison data in the Main window

mparison information displays in three places in the Main window: the 
mpare tab in the Workspace pane shows the region that was compared; the 
anscript shows the number of differences found between the reference and test 
tasets; and the Objects pane shows comparison differences if you select the 
ject on the Compare tab (Figure 87).

ewing comparison data in the Wave window

 the pathnames pane of the Wave window, a timing difference is denoted by a 
 X (Figure 88). Red areas in the waveform pane show the location of the timing 
ferences, as do the red lines in the scrollbars. Annotated differences are 
hlighted in blue.

e Wave window includes six compare icons that let you quickly jump between 
ferences (Figure 89). From left to right, the icons do the following: find first 
ference, find previous annotated difference, find previous difference, find next 
ference, find next annotated difference, find last difference. Use these icons to 
ve the selected cursor.

e compare icons cycle through differences on all signals. To view differences 
r just the selected signal, use <tab> and <shift> - <tab>.

Figure 87: Comparison informa

Figure 88: Comparison objects 
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ewing comparison data in the List window

u can also view the results of your waveform comparison in the List window.

Add comparison data to the List window.

a Select View > Debug Windows > List from the Main window menu bar.

b Drag the test_sm comparison object from the compare tab of the Main 
window to the List window.

c Scroll down the window.

Differences are noted with yellow highlighting (Figure 90). Differences 
that have been annotated have red highlighting.

Figure 90: Compare differences
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 to a text file
This saved compare.rul to the current directory.

e Select Tools > Waveform Compare > End Comparison.
Sa

aving and reloading comparison data

u can save comparison data for later viewing, either in a text file or in files that 
n be reloaded into ModelSim. 

 save comparison data so it can be reloaded into ModelSim, you must save two 
es. First, you save the computed differences to one file; next, you save the 
mparison configuration rules to a separate file. When you reload the data, you 
st have the reference dataset open.

Save the comparison data to a text file.

a Select Tools > Waveform Compare > Differences > Write Report.

b Click Save.

This saved compare.txt to the current directory (Figure 91).

c Type notepad compare.txt at the VSIM> prompt.

d Close Notepad when you are done reviewing the report.

Save the comparison data in files that can be reloaded into ModelSim.

a Select Tools > Waveform Compare > Differences > Save.

b Click Save.

This saved compare.dif to the current directory.

c Select Tools > Waveform Compare > Rules > Save.

d Click Save.

Figure 91: Coverage data saved
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Reload the comparison data.

a Select File > Open and open.

b Change the Files of Type to Log Files (*.wlf).

c Double-click gold.wlf to open the dataset.

d Select Tools > Waveform Compare > Reload.

Since you saved the data using default file names, the dialog should 
already have the correct files specified (Figure 93).

e Click OK.

The comparison reloads.

Figure 92: Displaying log files in

Figure 93: Reloading saved com
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is concludes this lesson. Before continuing we need to end the current 
ulation and close the gold.wlf dataset.

Type quit -sim at the VSIM> prompt.

Type dataset close gold at the ModelSim> prompt.
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Lesson 10 - Automating ModelSim

Topics

The following topics are covered in this lesson:

Introduction   .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-110
Related reading  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-110

Creating a simple DO file     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-111

Running ModelSim in command-line mode .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-113

Using Tcl with ModelSim     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-116

Le
sson Wrap-up  .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     .     . T-118



T-

Mo

In

As
fo
aft
wh
wi

DO
ca
or
so
the

R

M

Pr
delSim Tutorial
110 Lesson 10 - Automating ModelSim 

troduction

ide from executing a couple of pre-existing DO files, the previous lessons 
cused on using ModelSim in interactive mode: executing single commands, one 
er another, via the GUI menus or Main window command line. In situations 
ere you have repetitive tasks to complete, you can increase your productivity 
th DO files. 

 files are scripts that allow you to execute many commands at once. The scripts 
n be as simple as a series of ModelSim commands with associated arguments, 
 they can be full-blown Tcl programs with variables, conditional execution, and 
 forth. You can execute DO files from within the GUI or you can run them from 
 system command prompt without ever invoking the GUI.

elated reading

odelSim User’s Manual – 17 - Tcl and macros (DO files)  (UM-195)

actical Programming in Tcl and Tk, Brent B. Welch, Copyright 1997

Important: This lesson assumes that you have added the 
<install_dir>/modeltech/<platform> directory to your PATH. If you did not, 
you will need to specify full paths to the tools (i.e., vlib, vmap, vlog, vcom, and 
vsim) that are used in the lesson.
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run 400
force reset 0
run 200

Save the file.

a Select File > Save As.

b Type sim.do in the File name: field and save it to the current directory.
reating a simple DO file

eating DO files is as simple as typing the commands in a text file. Alternatively, 
u can save the Main window transcript as a DO file. In this exercise, you will 
e the transcript to create a DO file that adds signals to the Wave window, 
ovides stimulus to those signals, and then advances the simulation.

Load the test_counter design unit.

a If necessary, start ModelSim.

b Change to the directory you created in Lesson 2 - Basic simulation.

c In the Library tab of the Workspace pane, double-click the test_counter 
design unit to load it.

Enter commands to add signals to the Wave window, force signals, and run 
the simulation.

a Select File > New > Source > Do to create a new DO file.

a Enter the following commands into the source window:

add wave count
add wave clk
add wave reset
force -freeze clk 0 0, 1 {50 ns} -r 100
force reset 1
run 100
force reset 0
run 300
force reset 1
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Load the simulation again and use the DO file.

a Type quit -sim at the VSIM> prompt.

b Type vsim test_counter at the ModelSim> prompt.

c Type do sim.do at the VSIM> prompt.

ModelSim executes the saved commands and draws the waves in the 
Wave window.

When you are done with this exercise, select File > Quit to quit ModelSim.
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unning ModelSim in command-line mode

e use the term "command-line mode" to refer to simulations that are run from a 
S/ UNIX prompt without invoking the GUI. Several ModelSim commands 

g., vsim, vlib, vlog, etc.) are actually stand-alone executables that can be 
oked at the system command prompt. Additionally, you can create a DO file 
t contains other ModelSim commands and specify that file when you invoke 
 simulator.

Create a new directory and copy the tutorial files into it.

Start by creating a new directory for this exercise. Create the directory and 
copy these files into it:

• \<install_dir>\modeltech\examples\counter.v

• \<install_dir>\modeltech\examples\stim.do

We have used the Verilog file counter.v in this example. If you have a VHDL 
license, use counter.vhd instead.

Create a new design library and compile the source file.

Again, enter these commands at a DOS/ UNIX prompt in the new directory 
you created in step 1.

a Type vlib work at the DOS/ UNIX prompt.

b For Verilog, type vlog counter.v at the DOS/ UNIX prompt. For VHDL, 
type vcom counter.vhd.
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          delta       /counter/clk
                      /counter/reset
          0  +0                x z *
          1  +0                0 z *
         50  +0                0 * *
        100  +0                0 0 *
        100  +1                0 0 0
        150  +0                0 * 0
        151  +0                1 * 0
        200  +0                1 0 0
        250  +0                1 * 0

.

.

.
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Create a DO file.

a Open a text editor.

b Type the following lines into a new file:

# list all signals in decimal format
add list -decimal * 

# read in stimulus
do stim.do

# output results
write list counter.lst

# quit the simulation
quit -f

c Save the file with the name sim.do and place it in the current directory.

Run the batch-mode simulation.

a Type vsim -c -do sim.do counter -wlf counter.wlf at the DOS/ UNIX 
prompt.

The -c argument instructs ModelSim not to invoke the GUI. The -wlf 
argument saves the simulation results in a WLF file. This allows you to 
view the simulation results in the GUI for debugging purposes.

View the list output.

a Open counter.lst and view the simulation results.
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This is the output produced by the Verilog version of the design. It may 
appear slightly different if you used the VHDL version.

View the results in the GUI.

Since you saved the simulation results in counter.wlf, you can view them in 
the GUI by invoking VSIM with the -view argument.

a Type vsim -view counter.wlf at the DOS/ UNIX prompt.

The GUI opens and a dataset tab named "counter" is displayed in the 
Workspace (Figure 94).

b Right-click the counter instance and select Add > Add to Wave.

The waveforms display in the Wave window.

When you finish viewing the results, select File > Quit to close ModelSim.

Figure 94: A dataset in the Main
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b Now add these lines to the bottom of the script:
delSim Tutorial

add wave -r /*
when {clk'event and clk="1"} {
   echo "Count is [exa count]"
   if {[exa count]== "00100111"} {
      add_wave_zoom $now 1
   } elseif {[exa count]== "01000111"} {
      add_wave_zoom $now 2
   }
}

116 Lesson 10 - Automating ModelSim 

sing Tcl with ModelSim

e DO files used in previous exercises contained only ModelSim commands. 
wever, DO files are really just Tcl scripts. This means you can include a whole 

riety of Tcl constructs such as procedures, conditional operators, math and trig 
nctions, regular expressions, and so forth.

 this exercise you’ll create a simple Tcl script that tests for certain values on a 
nal and then adds bookmarks that zoom the Wave window when that value 
ists. Bookmarks allow you to save a particular zoom range and scroll position 
the Wave window.

Create the script.

a In a text editor, open a new file and enter the following lines:

proc add_wave_zoom {stime num} {
echo "Bookmarking wave $num"
bookmark add wave "bk$num"  "[expr $stime - 50] [expr $stime + 

100]" 0
}

These commands do the following:

• Create a new procedure called "add_wave_zoom" that has two 
arguments, stime and num.

• Create a bookmark with a zoom range from the current simulation 
time minus 50 time units to the current simulation time plus 100 time 
units.
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These commands do the following:

• Add all signals to the Wave window.

• Use a when statement to identify when clk transitions to 1.

• Examine the value of count at those transitions and add a bookmark 
if it is a certain value.

c Save the script with the name "add_bkmrk.do." 

Save it into the directory you created in Lesson 2 - Basic simulation.

Load the test_counter design unit.

a Start ModelSim.

b Select File > Change Directory and change to the directory you saved 
the DO file to in step 1c above.

c In the Library tab of the Main window, expand the work library and 
double-click the test_counter design unit.

Execute the DO file and run the design.

a Type do add_bkmrk.do at the VSIM> prompt.

b Type run 1500 ns at the VSIM> prompt.

c The simulation runs and the DO file creates two bookmarks.Select View 
> Bookmarks > bm1. 

Watch the Wave window zoom on and scroll to the time when count is 
00100111. Try the bm2 bookmark as well.
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esson Wrap-up

is concludes this lesson.

Select File > Quit to close ModelSim.
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End-User License Agreement

IMPORTANT - USE OF THIS SOFTWARE IS SUBJECT TO LICENSE RESTRICTIONS.
CAREFULLY READ THIS LICENSE AGREEMENT BEFORE USING THE SOFTWARE.

This license is a legal “Agreement” concerning the use of Software between you, the end user, either individually or
as an authorized representative of the company acquiring the license, and Mentor Graphics Corporation and Mentor
Graphics (Ireland) Limited acting directly or through their subsidiaries or authorized distributors (collectively
“Mentor Graphics”). USE OF SOFTWARE INDICATES YOUR COMPLETE AND UNCONDITIONAL
ACCEPTANCE OF THE TERMS AND CONDITIONS SET FORTH IN THIS AGREEMENT. If you do not agree
to these terms and conditions, promptly return, or, if received electronically, certify destruction of Software and all
accompanying items within five days after receipt of Software and receive a full refund of any license fee paid.

END-USER LICENSE AGREEMENT

1.

2.

3.
GRANT OF LICENSE. The software programs you are installing, downloading, or have acquired with this Agreement,
including any updates, modifications, revisions, copies, documentation and design data (“Software”) are copyrighted,
trade secret and confidential information of Mentor Graphics or its licensors who maintain exclusive title to all Software
and retain all rights not expressly granted by this Agreement. Mentor Graphics grants to you, subject to payment of
appropriate license fees, a nontransferable, nonexclusive license to use Software solely: (a) in machine-readable, object-
code form; (b) for your internal business purposes; and (c) on the computer hardware or at the site for which an applicable
license fee is paid, or as authorized by Mentor Graphics. A site is restricted to a one-half mile (800 meter) radius. Mentor
Graphics’ standard policies and programs, which vary depending on Software, license fees paid or service plan purchased,
apply to the following and are subject to change: (a) relocation of Software; (b) use of Software, which may be limited, for
example, to execution of a single session by a single user on the authorized hardware or for a restricted period of time
(such limitations may be communicated and technically implemented through the use of authorization codes or similar
devices); (c)  support services provided, including eligibility to receive telephone support, updates, modifications, and
revisions. Current standard policies and programs are available upon request.

ESD SOFTWARE. If you purchased a license to use embedded software development (“ESD”) Software, Mentor
Graphics grants to you a nontransferable, nonexclusive license to reproduce and distribute executable files created using
ESD compilers, including the ESD run-time libraries distributed with ESD C and C++ compiler Software that are linked
into a composite program as an integral part of your compiled computer program, provided that you distribute these files
only in conjunction with your compiled computer program. Mentor Graphics does NOT grant you any right to duplicate or
incorporate copies of Mentor Graphics' real-time operating systems or other ESD Software, except those explicitly
granted in this section, into your products without first signing a separate agreement with Mentor Graphics for such
purpose.

BETA CODE. Portions or all of certain Software may contain code for experimental testing and evaluation (“Beta
Code”), which may not be used without Mentor Graphics’ explicit authorization. Upon Mentor Graphics’ authorization,
Mentor Graphics grants to you a temporary, nontransferable, nonexclusive license for experimental use to test and
evaluate the Beta Code without charge for a limited period of time specified by Mentor Graphics. This grant and your use



T-120 License Agreement  

Mo

of the Beta Code shall not be construed as marketing or offering to sell a license to the Beta Code, which Mentor Graphics may
choose not to release commercially in any form. If Mentor Graphics authorizes you to use the Beta Code, you agree to evaluate
and test the Beta Code under normal conditions as directed by Mentor Graphics. You will contact Mentor Graphics periodically
during your use of the Beta Code to discuss any malfunctions or suggested improvements. Upon completion of your evaluation
and testing, you will send to Mentor Graphics a written evaluation of the Beta Code, including its strengths, weaknesses and
recommended improvements. You agree that any written evaluations and all inventions, product improvements, modifications or
developments that Mentor Graphics conceived or made during or subsequent to this Agreement, including those based partly or
wholly on your feedback, will be the exclusive property of Mentor Graphics. Mentor Graphics will have exclusive rights, title
and interest in all such property. The provisions of this subsection shall survive termination or expiration of this Agreement.

4. RESTRICTIONS ON USE. You may copy Software only as reasonably necessary to support the authorized use. Each copy
must include all notices and legends embedded in Software and affixed to its medium and container as received from Mentor
Graphics. All copies shall remain the property of Mentor Graphics or its licensors. You shall maintain a record of the number
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and primary location of all copies of Software, including copies merged with other software, and shall make those r
available to Mentor Graphics upon request. You shall not make Software available in any form to any person othe
employees and contractors, excluding Mentor Graphics' competitors, whose job performance requires access. You sha
appropriate action to protect the confidentiality of Software and ensure that any person permitted access to Software do
disclose it or use it except as permitted by this Agreement. Except as otherwise permitted for purposes of interoperabi
specified by applicable and mandatory local law, you shall not reverse-assemble, reverse-compile, reverse-engineer or 
way derive from Software any source code. You may not sublicense, assign or otherwise transfer Software, this Agreem
the rights under it, whether by operation of law or otherwise (“attempted transfer”), without Mentor Graphics’ prior w
consent and payment of Mentor Graphics’ then-current applicable transfer charges. Any attempted transfer without M
Graphics' prior written consent shall be a material breach of this Agreement and may, at Mentor Graphics' option, result
immediate termination of the Agreement and licenses granted under this Agreement. 

The terms of this Agreement, including without limitation, the licensing and assignment provisions shall be binding upo
heirs, successors in interest and assigns. The provisions of this section 4 shall survive the termination or expiration 
Agreement.

LIMITED WARRANTY.

5.1. Mentor Graphics warrants that during the warranty period Software, when properly installed, will substantially conf
the functional specifications set forth in the applicable user manual. Mentor Graphics does not warrant that Softwa
meet your requirements or that operation of Software will be uninterrupted or error free. The warranty period is 9
starting on the 15th day after delivery or upon installation, whichever first occurs. You must notify Mentor Grap
writing of any nonconformity within the warranty period. This warranty shall not be valid if Software has been sub
misuse, unauthorized modification or installation. MENTOR GRAPHICS' ENTIRE LIABILITY AND Y
EXCLUSIVE REMEDY SHALL BE, AT MENTOR GRAPHICS' OPTION, EITHER (A) REFUND OF THE P
PAID UPON RETURN OF SOFTWARE TO MENTOR GRAPHICS OR (B) MODIFICATION OR REPLACEMEN
SOFTWARE THAT DOES NOT MEET THIS LIMITED WARRANTY, PROVIDED YOU HAVE OTHER
COMPLIED WITH THIS AGREEMENT. MENTOR GRAPHICS MAKES NO WARRANTIES WITH RESPEC
(A) SERVICES; (B) SOFTWARE WHICH IS LICENSED TO YOU FOR A LIMITED TERM OR LICENSED A
COST; OR (C) EXPERIMENTAL BETA CODE; ALL OF WHICH ARE PROVIDED “AS IS.”
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5.2. THE WARRANTIES SET FORTH IN THIS SECTION 5 ARE EXCLUSIVE. NEITHER MENTOR GRAPHICS
NOR ITS LICENSORS MAKE ANY OTHER WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, WITH
RESPECT TO SOFTWARE OR OTHER MATERIAL PROVIDED UNDER THIS AGREEMENT. MENTOR
GRAPHICS AND ITS LICENSORS SPECIFICALLY DISCLAIM ALL IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT OF
INTELLECTUAL PROPERTY.

6. LIMITATION OF LIABILITY. EXCEPT WHERE THIS EXCLUSION OR RESTRICTION OF LIABILITY
WOULD BE VOID OR INEFFECTIVE UNDER APPLICABLE LAW, IN NO EVENT SHALL MENTOR GRAPHICS
OR ITS LICENSORS BE LIABLE FOR INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES
(INCLUDING LOST PROFITS OR SAVINGS) WHETHER BASED ON CONTRACT, TORT OR ANY OTHER
LEGAL THEORY, EVEN IF MENTOR GRAPHICS OR ITS LICENSORS HAVE BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES. IN NO EVENT SHALL MENTOR GRAPHICS' OR ITS LICENSORS'
LIABILITY UNDER THIS AGREEMENT EXCEED THE AMOUNT PAID BY YOU FOR THE SOFTWARE OR
SERVICE GIVING RISE TO THE CLAIM. IN THE CASE WHERE NO AMOUNT WAS PAID, MENTOR

7.

8.

9.
GRAPHICS AND ITS LICENSORS SHALL HAVE NO LIABILITY FOR ANY DAMAGES WHATSOEVER.

LIFE ENDANGERING ACTIVITIES. NEITHER MENTOR GRAPHICS NOR ITS LICENSORS SHALL BE
LIABLE FOR ANY DAMAGES RESULTING FROM OR IN CONNECTION WITH THE USE OF SOFTWARE IN
ANY APPLICATION WHERE THE FAILURE OR INACCURACY OF THE SOFTWARE MIGHT RESULT IN
DEATH OR PERSONAL INJURY. 

INDEMNIFICATION.  YOU AGREE TO INDEMNIFY AND HOLD HARMLESS MENTOR GRAPHICS AND ITS
LICENSORS FROM ANY CLAIMS, LOSS, COST, DAMAGE, EXPENSE, OR LIABILITY, INCLUDING
ATTORNEYS' FEES, ARISING OUT OF OR IN CONNECTION WITH YOUR USE OF SOFTWARE AS
DESCRIBED IN SECTION 7.

INFRINGEMENT.

9.1. Mentor Graphics will defend or settle, at its option and expense, any action brought against you alleging that
Software infringes a patent or copyright or misappropriates a trade secret in the United States, Canada, Japan, or
member state of the European Patent Office. Mentor Graphics will pay any costs and damages finally awarded
against you that are attributable to the infringement action. You understand and agree that as conditions to Mentor
Graphics' obligations under this section you must: (a) notify Mentor Graphics promptly in writing of the action;
(b) provide Mentor Graphics all reasonable information and assistance to defend or settle the action; and (c) grant
Mentor Graphics sole authority and control of the defense or settlement of the action.

9.2. If an infringement claim is made, Mentor Graphics may, at its option and expense: (a) replace or modify Software so
that it becomes noninfringing; (b) procure for you the right to continue using Software; or (c) require the return of
Software and refund to you any license fee paid, less a reasonable allowance for use.

9.3. Mentor Graphics has no liability to you if infringement is based upon:  (a) the combination of Software with any
product not furnished by Mentor Graphics; (b) the modification of Software other than by Mentor Graphics; (c) the
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use of other than a current unaltered release of Software; (d) the use of Software as part of an infringing process; (e) a
product that you make, use or sell; (f) any Beta Code contained in Software; (g) any Software provided by Mentor Graphics’
licensors who do not provide such indemnification to Mentor Graphics’ customers; or (h) infringement by you that is
deemed willful.  In the case of (h) you shall reimburse Mentor Graphics for its attorney fees and other costs related to the
action upon a final judgment.

9.4. THIS SECTION 9 STATES THE ENTIRE LIABILITY OF MENTOR GRAPHICS AND ITS LICENSORS AND YOUR
SOLE AND EXCLUSIVE REMEDY WITH RESPECT TO ANY ALLEGED PATENT OR COPYRIGHT
INFRINGEMENT OR TRADE SECRET MISAPPROPRIATION BY ANY SOFTWARE LICENSED UNDER THIS
AGREEMENT.

10. TERM. This Agreement remains effective until expiration or termination. This Agreement will immediately terminate upon
notice if you exceed the scope of license granted or otherwise fail to comply with the provisions of Sections 1, 2, or 4.  For any
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other material breach under this Agreement, Mentor Graphics may terminate this Agreement upon 30 days written notice
are in material breach and fail to cure such breach within the 30-day notice period.  If Software was provided for limite
use, this Agreement will automatically expire at the end of the authorized term. Upon any termination or expiration, you a
cease all use of Software and return it to Mentor Graphics or certify deletion and destruction of Software, including all cop
Mentor Graphics’ reasonable satisfaction.

. EXPORT. Software is subject to regulation by local laws and United States government agencies, which prohibit exp
diversion of certain products, information about the products, and direct products of the products to certain countries and 
persons. You agree that you will not export any Software or direct product of Software in any manner without first obtain
necessary approval from appropriate local and United States government agencies.

. RESTRICTED RIGHTS NOTICE. Software was developed entirely at private expense and is commercial computer so
provided with RESTRICTED RIGHTS. Use, duplication or disclosure by the U.S. Government or a U.S. Gover
subcontractor is subject to the restrictions set forth in the license agreement under which Software was obtained pursu
DFARS 227.7202-3(a) or as set forth in subparagraphs (c)(1) and (2) of the Commercial Computer Software - Restricted 
clause at FAR 52.227-19, as applicable. Contractor/manufacturer is Mentor Graphics Corporation, 8005 SW Boeckman
Wilsonville, Oregon 97070-7777 USA.

. THIRD PARTY BENEFICIARY. For any Software under this Agreement licensed by Mentor Graphics from Micro
other licensors, Microsoft or the applicable licensor is a third party beneficiary of this Agreement with the right to enfo
obligations set forth herein.

. AUDIT RIGHTS.  With reasonable prior notice, Mentor Graphics shall have the right to audit during your normal bu
hours all records and accounts as may contain information regarding your compliance with the terms of this Agreement. M
Graphics shall keep in confidence all information gained as a result of any audit.  Mentor Graphics shall only use or d
such information as necessary to enforce its rights under this Agreement.

. CONTROLLING LAW AND JURISDICTION. THIS AGREEMENT SHALL BE GOVERNED BY AND CONST
UNDER THE LAWS OF THE STATE OF OREGON, USA, IF YOU ARE LOCATED IN NORTH OR SOUTH AME
AND THE LAWS OF IRELAND IF YOU ARE LOCATED OUTSIDE OF NORTH AND SOUTH AMERICA. All di
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arising out of or in relation to this Agreement shall be submitted to the exclusive jurisdiction of Dublin, Ireland when the
laws of Ireland apply, or Wilsonville, Oregon when the laws of Oregon apply. This section shall not restrict Mentor
Graphics’ right to bring an action against you in the jurisdiction where your place of business is located.  The United
Nations Convention on Contracts for the International Sale of Goods does not apply to this Agreement.

16. SEVERABILITY. If any provision of this Agreement is held by a court of competent jurisdiction to be void, invalid,
unenforceable or illegal, such provision shall be severed from this Agreement and the remaining provisions will remain in
full force and effect.

17. PAYMENT TERMS AND MISCELLANEOUS.  You will pay amounts invoiced, in the currency specified on the
applicable invoice, within 30 days from the date of such invoice. This Agreement contains the parties' entire
understanding relating to its subject matter and supersedes all prior or contemporaneous agreements, including but not
limited to any purchase order terms and conditions, except valid license agreements related to the subject matter of this
Agreement (which are physically signed by you and an authorized agent of Mentor Graphics) either referenced in the
purchase order or otherwise governing this subject matter. This Agreement may only be modified in writing by authorized

representatives of the parties. Waiver of terms or excuse of breach must be in writing and shall not constitute subsequent
consent, waiver or excuse. The prevailing party in any legal action regarding the subject matter of this Agreement shall be
entitled to recover, in addition to other relief, reasonable attorneys' fees and expenses.

Rev. 040401, Part Number 221417
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linking to external libraries T-46
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macros T-109
manuals T-7
mapping libraries permanently T-49
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changing values T-81
initializing T-79
viewing T-71

memory contents, saving to a file T-78
Memory window T-71

N
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quit 

R

radix command T-74
reference dataset, Waveform Compare T-99
reference signals T-98
run -all T-26
run command T-25

S

saving simulation options T-39
simulation

basic flow overview T-13
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ad command T-105

ns, simulation T-39

ical connectivity T-64
cts T-31
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creating T-33
flow overview T-15
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simulation configurations T-39

command T-46

comparing runs T-97
restarting T-27
running T-25

simulation configurations T-39
stepping after a breakpoint T-28
Support T-8
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Tcl, using in ModelSim T-116
Technical support and updates T-8
test dataset, Waveform Compare T-100
test signals T-98
time, measuring in Wave window T-56
toggle statistics, Signals window T-93
tracing events T-65
tracing unknowns T-67

U

unknowns, tracing T-67
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vcom command T-73
verror command T-46
vlib command T-73
vlog command T-73
vsim command T-21

W

Wave window T-51
adding items to T-54
cursors T-56
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work

X
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zoom
measuring time with cursors T-56
saving format T-59
zooming T-55
eform Compare T-97
reference signals T-98
saving and reloading T-105
test signals T-98
ing library, creating T-13, T-21

lues, tracing T-67

ing, Wave window T-55
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